Problema

Durante la migrazione del contenuto da AEM 6.0, 6.1 o 6.2 a AEM 6.3 con l'utilità CRX2Oak, osservi il seguente errore:

22.08.2017 11:25:16.256 ERROR c.a.g.c.c.MigrationSpecGenerator: I/O error during processing migration specification: org.apache.jackrabbit.oak.segment.file.InvalidFileStoreVersionException: Usando oak-segment-tar, ma si dovrebbe usare oak-segment

Ambiente

CRX2Oak-1.6.x è usato per migrare da AEM6.0-6.2 a 6.3 o versione futura.

Causa

Parametro mancante nel comando CRX2Oak.

Risoluzione

Aggiungi "segment-old:" prima del percorso della sorgente nel comando CRX2Oak in questo modo (vedi il testo evidenziato sotto):

java -Xmx1g -jar crx2oak-1.6.8-all-in-one.jar --include-paths=/content/geometrixx segment-old:/opt/old-aem/repository /opt/aem63/crx-quickstart/repository

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online