Errore durante AsyncIndexUpdate

Causa

Ci possono essere molte cause per cui gli indici asincroni non vengono aggiornati in AEM.

Alcune possibili cause sono:

  • Un file di indice Lucene corrotto
  • Corruzione dell'archivio Oak che causa errori durante l'indicizzazione

Risoluzione

Il primo passo per risolvere un problema di questo tipo è eseguire il debug della causa principale.  Una volta che si conosce la causa principale, si può decidere se è necessaria o meno la reindicizzazione.

Nelle versioni AEM precedenti alla 6.2, tutti gli indici utilizzavano una corsia “async”.  Lo stato di tale corsia dell'indice può essere visualizzato nel MBean IndexStats:

http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dasync%2Ctype%3DIndexStats

In AEM 6.2, ci sono due corsie di indice:

  • “fulltext-async” usato dall'indice /oak:index/lucene - http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dfulltext-async%2Ctype%3DIndexStats
  • “async” usato da tutti gli altri indici Lucene - http://aem-host:port/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dasync%2Ctype%3DIndexStats

Puoi visualizzare gli MBeans IndexStats per vedere lo stato dell'indicizzazione e identificare se l'indicizzazione non è riuscita o se richiede molto tempo.

I campi chiave a cui fare riferimento sono:

  • LatestError - l'errore che determina la mancata riuscita dell'indicizzazione in caso di errore.
  • LatestErrorTime - l'ora in cui si è verificato l'errore.
  • LastIndexedTime - l'ultima volta in cui un ciclo di indicizzazione è riuscito.


Se vedi un errore elencato in LatestError, allora devi correggere quell'errore per far funzionare di nuovo l'indicizzazione.  Contattare il Servizio Clienti AEM per assistenza se non sei sicuro dei passi successivi per risolvere il problema.

Logo Adobe

Accedi al tuo account