Ultimo aggiornamento il
3 mag 2021
Causa
Le cause di questo problema potrebbero essere molteplici. In questo articolo, ci concentriamo su una causa nota, dove le ACL dell'utente del servizio sling-i18n vengono eliminate. Questo di solito accade quando un pacchetto ACL è installato da un altro ambiente.
Risoluzione
Controlla se l'utente del servizio sling-i18n ha accesso in lettura sul nodo root /
- Vai a http://host:port/crx/explorer/index.jsp
- Accedi come amministratore
- Apri Content Explorer
- Fai clic sul nodo root - /
- Nella navigazione in alto, seleziona Sicurezza => Accedi a Control Editor (il pulsante Sicurezza è l'immagine di una cassaforte)
- Controlla se all'utente sling-i18n è permesso l'accesso in lettura. In caso contrario, segui la procedura sottostante.
Ripara gli ACL dell'utente del servizio:
- Installa ACS Commons se non è già installato. Sarà necessario utilizzare ACS Commons ACL Packager.
- Utilizza l'ACL Packager per creare un pacchetto di backup di tutte le ACL dall'ambiente danneggiato. Prima di costruire il pacchetto, modifica la sua configurazione, vai alla scheda Avanzate e imposta Gestione AC in modalità Fusione.
- Installa una nuova istanza AEM con tutte le stesse patch (service pack, hotfix, ecc.).
- Crea un pacchetto con modalità fusione delle ACL dalla nuova istanza.
- Costruisci anche il pacchetto con la modalità di fusione.
- Scarica il pacchetto.
- Installalo nell'ambiente guasto. Reinstalla il pacchetto ACL dal passaggio 1.
- La reinstallazione del pacchetto riordina gli ACL personalizzati fino alla fine dell'elenco, assicurando che non siano sovrascritti da quelli preconfigurati.
Una volta che l'ACL è stato risolto, è necessario un ultimo passaggio.
- Vai a /system/console/bundles, e riavvia il bundle "Suppoto Internazionalizzzione Apache Sling"