L'aggiornamento della sessione di login non funziona | AEM 6.x

Problema

In AEM quando Token Refresh è abilitato sulla configurazione OSGi di Apache Jackrabbit Oak Token Configuration OSGi[1], il token di login non viene aggiornato. Questo problema si applica sia a LDAP, sia a SAML 2, l'autenticazione predefinita del Token.

[1]

http://aem-host:port/system/console/configMgr/org.apache.jackrabbit.oak.security.authentication.token.TokenConfigurationImpl

Causa

Il token di login non riesce ad aggiornare sia a causa di un'idea sbagliata di come funziona il token refresh o se il token incapsulato è abilitato.

Risoluzione

Controlla se il supporto per il token incapsulato è abilitato. Al momento della stesura di questo articolo (AEM v6.0-6.3), il token di login incapsulato non supportava il token refresh.

  1. Vai al seguente URL e accedi come amministratore : http://aem-host:port/system/console/configMgr/com.day.crx.security.token.impl.impl.TokenAuthenticationHandler

  2. Vedi se Abilita assistenza token incapsulati è abilitato.

Se il supporto per i token incapsulati non è abilitato, è probabile che il token refresh funzioni, ma non funziona come previsto. Quando gli utenti accedono al sistema, il token non viene aggiornato a meno che gli utenti non accedano al sistema dopo che la metà del tempo di scadenza del token configurato nella configurazione del token Oak Token Configuration [1] è trascorsa.

Ad esempio, se la scadenza è impostata su due ore, l'utente può utilizzare il sistema per tutta la prima ora. Ma, se non accedono al sistema dopo un'ora, il token non si aggiorna. Poi devono effettuare nuovamente il login dopo due ore dal loro login iniziale.  Tuttavia, se si collegano, aspettano un'ora e accedono nuovamente al sistema, il token si aggiorna e la sessione viene prolungata. 

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