Questo documento descrive come installare e utilizzare il plug-in OpenEXR Alpha aggiuntivo.

Il plug-in OpenEXR Alpha aggiuntivo fornisce un metodo alternativo per la gestione dei dati di canale "A" durante l'apertura di un file OpenEXR. Anziché convertire direttamente i dati di canale "A" in trasparenza (come accade per il vecchio plug-in OpenEXR), OpenEXR Alpha apre i dati di canale "A" come un canale alpha.

Informazioni generali

In genere, Photoshop CS2 non supportava la trasparenza in modalità a 32 bit. In tale versione, era stata implementata una soluzione alternativa per consentire la lettura di dati in trasparenza su un canale alpha. In Photoshop CS3, il supporto per la trasparenza è stato implementato in modalità a 32 bit, garantendo conformità alle specifiche OpenEXR. La trasparenza non veniva pertanto più letta in un canale alfa durante la composizione del canale.

Prima di iniziare

L'installazione del plug-in OpenEXR Alpha richiede diritti di amministratore locale. Se utilizzate Mac OS, Windows Vista o Windows 7, il sistema operativo richiede di immettere il nome e la password di un account utente amministratore. Se utilizzate Windows XP, accedete al computer tramite un account amministratore locale prima di iniziare.

Utenti Windows: alcuni dei passaggi in questa nota tecnica elencano i file per nome completo, comprese le estensioni (ad esempio, OpenEXR Alpha.8bi). In Windows, le estensioni dei nomi di file per tipi di file conosciuti non sono visibili per impostazione predefinita. Per rendere le estensioni dei nomi file visibili, eseguite quanto segue:

  1. In Esplora risorse, scegliete Strumenti > Opzioni cartella (Windows XP) o Organizza > Opzioni cartella e ricerca (Windows 7 e Vista).
  2. Selezionate la scheda Visualizzazione accanto alla parte superiore della finestra Opzioni cartella.
  3. Nell'area Impostazioni avanzate della scheda Visualizzazione, deselezionate Nascondi le estensioni per i tipi di file conosciuti.
  4. Fate clic su OK.

Utenti di Windows: alcuni dei passaggi in questo documento richiedono di determinare se è in uso un'edizione a 32 bit o 64 bit di Windows. Per determinare quale tipo di sistema è in uso, consultate Come determinare se l'edizione di Windows in esecuzione nel computer è a 32 o a 64 bit.

Compatibilità

In Windows, il plug-in OpenEXR Alpha non è compatibile con le versioni di Photoshop precedenti a Photoshop CS5. Non viene caricato in Photoshop CS3 o CS4.

In Mac OS, il plug-in OpenEXR Alpha non viene caricato sui computer PPC.

Installate il plug-in OpenEXR Alpha per Photoshop CS5 su Mac o Windows (scaricate l'aggiornamento dal sito Web di Adobe)

Per installare il plug-in OpenEXR Alpha scaricando un aggiornamento dal sito Web di Adobe:

  1. Scaricate il plug-in compresso:

  2. Uscite da Photoshop CS5.
  3. Decomprimete il file scaricato.
  4. Trascinate il plug-in nella cartelle dei plug-in di Photoshop.
    • Windows a 32 bit: trascinate OpenEXR Alpha.8bi dalla cartella Win32 in /Programmi/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows a 64 bit/Photoshop a 64 bit: trascinate OpenEXR Alpha.8bi dalla cartella Win64 in /Programmi/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows a 64 bit/Photoshop a 32 bit: trascinate OpenEXR Alpha.8bi dalla cartella Win32 in /Programmi (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: trascinate OpenEXR.plugin in /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Avviate Photoshop CS5.

Utilizzo del plug-in OpenEXR Alpha

Per aprire un file EXR:

  1. Avviate Photoshop CS5.
  2. Scegliete File > Apri.
  3. Individuate il file EXR che desiderate aprire. Nell'elenco dei formati file, scegliete OpenEXR Alpha. Photoshop gestisce i dati canale "A" come un canale alpha invece che in trasparenza.

Per esportare un file EXR:

  1. Scegliete File > Salva con nome.
  2. Nell'elenco dei formati file, scegliete OpenEXR Alpha.

  3. Selezionate l'opzione di salvataggio dei canali Alpha. Questa impostazione conserva i dati canale alpha.

Nota: la trasparenza aggiunta dopo l'apertura del file è convertita.

Nota: anche dopo l'installazione del plug-in OpenEXR Alpha, è comunque possibile scegliere l'elenco di formati file OpenEXR più vecchio. Questo plug-in gestisce comunque i dati nel canale "A" come trasparenza. Questo comportamento era quello predefinito in Photoshop da Photoshop CS3 (versione 10.0).

Note aggiuntive

Altri comportamenti degni di nota durante l'utilizzo del plug-in aggiuntivo:

  • La composizione premoltiplicata non è supportata.
  • Se fate doppio clic su un file per aprirlo, Photoshop CS5 utilizza sempre OpenEXR Alpha invece di OpenEXR.
  • Se aprite un file con due o più canali alpha, OpenEXR Alpha non conserva alcuno dei canali alpha. Vengono totalmente ignorati.
  • (Mac OS): nella finestra di dialogo Salva, OpenEXR Alpha è l'elemento primario. Non viene visualizzato accanto a Open EXR in ordine alfabetico.
  • (Windows): per fare in modo che OpenEXR adotti il comportamento precedente, scegliete File > Apri come, quindi selezionate OpenEXR.
     

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online