当您分发表单时,Acrobat 会自动创建一个用于收集用户提交的数据的 PDF 包。默认情况下,保存此文件的文件夹与原始表单相同,且命名为:文件名_responses。您可以使用此文件来编译返回的表单。

Adobe recommends

Adobe recommends
<a href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">视频教程:管理表单数据</a>
Timothy Plumer, Jr.

收集用户数据

  1. 在用户提交表单后,打开返回的表单。
  2. 在“添加完成的表单到响应文件”对话框中,选择下列任一项:

    添加到现有的响应文件

    编译您使用“分发表单”向导发送表单时所创建的响应文件中的数据。(如果需要,请单击“浏览”并找到该响应文件。)

    创建新的响应文件

    使用您指定的名称和位置创建新的响应文件。

响应文件在您单击“确定”后打开。添加到响应文件中的每个返回的表单都以 PDF 包的组件文件形式显示。

编译表单数据

  1. 在 Acrobat 中,选择“工具”>“表单”>“更多表单选项”>“编译返回的表单”。
  2. 在“编译数据”对话框中,执行下列任一操作来选择 PDF 响应文件:
    • 单击“浏览”,然后定位并选择响应文件。

    • 输入到响应文件的路径。

  3. 单击“添加文件”,并导览到返回的表单。
  4. 按需要重复上一步多次来添加更多返回的表单。

当您单击“确定”后,选中表单中的数据会添加到响应文件。每个返回的表单都以 PDF 包的组件文件的形式显示。

向现有的响应文件中添加用户数据

  1. 在 Acrobat 中,打开响应文件。
  2. 在左侧导览面板中,单击“添加”。
  3. 在“添加返回的表单”对话框中,单击“添加文件”。然后定位并选择返回的表单,并单击“打开”。
  4. 重复上一步骤来在其它文件夹中添加任何返回的表单。完成后,请单击“确定”。

完成后,每个已添加的 PDF 表单都会以 PDF 包的组件文件的形式显示。

从响应文件中导出用户数据

使用此过程将 PDF 包响应文件中的所有条目保存到电子表格或 XML 文件中。

  1. 在 Acrobat 中,打开响应文件并选择要导出的数据。
  2. 在左侧导览面板中,单击“导出”。
  3. 在“选择文件夹来保存文件”对话框中,指定表单数据的名称、位置和文件格式(CSV 或 XML),并单击“保存”。

管理表单数据文件

您可以在 PDF 表单移动回答到/从其它保存数据比 PDF 节约空间的文件格式。

导入表单数据

在某些工作流程情况下,某些个人以仅数据文件而不是完整的 PDF 文件提交已填写的表单。这些文件不是 PDF,但可以使用其它格式,例如 FDF 或 XML。您可以通过打开原始文件并导入数据文件中的信息来查看单独接收人在 PDF 上下文中提交的数据。

  1. 在 Acrobat 中,打开要导入数据的 PDF 表单。
  2. 选择“工具”>“表单”>“清除表单”。

    注意:

    当您从其它文件导入数据到 PDF 表单时,导入的数据将替换任何出现在先前单独表单域中的数据。但是,如果导入的数据文件包含一个或多个空白表单域,导入将不清除原始数据。

  3. 选择“工具”>“表单”>“更多表单选项”>“管理表单数据”>“导入数据”。
  4. 在“选择包含表单数据的文件”对话框中,选择与您要导入的数据文件对应的文件类型格式。然后查找并选择此文件,并单击“打开”。

    注意:

    某些格式仅对特定类型的 PDF 表单可用,具体取决于创建表单时所用的应用程序,例如 Acrobat 或 Designer ES2。您从文本文件(.txt)导入的数据必须按每行制表符分割表单列。

导出文件数据

当数据文件在其它文件格式时您可以按完整的 PDF 表单保存信息。以后,您可以重新使用数据来重新填写表单或其它具有相同域和域名称的表单。

  1. 在 Acrobat 中,打开已完成的表单文件。
  2. 选择“工具”>“表单”>“更多表单选项”>“管理表单数据”>“导出数据”。
  3. 在“导出表单数据为”对话框中,选择您要保存表单数据的格式(FDF、XFDF、XML 或 TXT)。然后选择位置和文件名并单击“保存”。

    注意:

    某些格式仅对特定 PDF 表单类型可用,取决于表单是如何创建的。

合并导出的数据文件到工作表

如果您想要编译的数据来自没有数据组的表单,请使用下列步骤。

  1. 选择“工具”>“表单”>“更多表单选项”>“管理表单数据”>“合并数据文件到电子表格”。
  2. 在“从多个表单导出数据”对话框中,单击“添加文件”。
  3. 在“选择包含表单数据的文件”对话框中,在“文件类型”选项中选择一个文件格式选项(“Acrobat 表单数据文件”或“所有文件”)。然后查找您要合并到工作表中的表单文件,选择这些文件,然后单击“打开”。
  4. 如果需要,重复先前步骤来添加其它位置的表单数据文件。
  5. 单击“导出”。然后选择工作表的文件夹和文件名并单击“保存”。
  6. 在“导出进度”对话框中,单击“立即显示文件”来打开工作表文件或“关闭对话框”来返回 Acrobat。

注意:

当返回的表单在响应文件中时,将信息导出到电子表格的最有效的方法是使用 PDF 包响应文件左侧导览面板中的“导出数据”按钮。

关于表单追踪器

使用“追踪器”管理已分发或接收的表单。使用追踪器可以查看和编辑响应文件的位置,追踪哪些收件人已进行响应,添加更多的收件人,通过电子邮件发所有收件人,以及查看表单的响应。

追踪表单

  1. 在 Acrobat 中,选择“编辑”>“表单选项”>“追踪”“视图”>“追踪器”

  2. 在左侧导览面板中,展开“表单”。

  3. 选择表单并执行以下任一操作:

    • 要查看表单的所有响应,请单击“查看响应”。

    • 要修改响应文件的位置,请在“响应文件位置”中单击“编辑文件位置”。

    • 要查看原始表单,请单击“打开原始表单”。

    • 要将表单发送给更多收件人,请单击“添加收件人”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略