使用 PDF 优化器进行保存 (Acrobat Pro)

PDF 优化器提供了大量用于减小 PDF 文件大小的设置。某些 PDF 优化器设置与使用 Distiller 创建 Adobe PDF 文件时可用的设置相同。是否使用所有设置取决于您使用文件的目的和文件自身的本质要求。通常情况下,默认设置通过删除某些嵌入字体,压缩图像,以及从文件删除不再需要的项目来最大程度的优化存储空间。

在优化文件前,您最好统计文件空间使用情况。空间统计结果可以告诉您减小文件大小的最佳方面。通过使用“减小文件大小”命令,也可以减小 PDF 的大小。

注意:

某些压缩方法可能会导致图像在印刷制作工作流程中不能使用。您应该在进行不可撤消的更改前使用不同设置进行试验。

打开 PDF 优化器

  1. 要打开“PDF 优化器”对话框,请执行以下任一操作:
    • 在一个 PDF 中,选择“文件”>“另存为其它”>“优化的 PDF”。

    • 在编辑“动作向导”时,单击“保存至”选项。然后在“输出选项”对话框中,选择“PDF 优化器”,然后单击“设置”。

注意:

如果“视图”菜单中的“重排”为选中状态,则“PDF 优化器”将不可用。

统计 PDF 空间的使用情况 (Acrobat Pro)

提供了一个反映特定文档元素的空间使用情况(所使用的字节数)和文件大小的统计报告,这些元素包括字体、图像、书签、表单、已命名的目标和注释。统计的结果包括元素占用空间的大小,以及在整个文件中所占的百分比。

  1. 选择“文件”>“另存为其它”>“优化的 PDF”。将打开“PDF 优化器”对话框。
  2. 单击对话框顶部的“统计空间使用情况”按妞。

注意:

您也可以在“内容”窗格中统计 PDF 的空间使用情况。选择“视图”>“显示/隐藏”>“导览窗格”>“内容”。从“内容”窗格的“选项”菜单 中,选择“统计空间使用情况”。

优化 PDF (Acrobat Pro)

  1. 打开“PDF 优化器”对话框(“文件”>“另存为其它”>“优化的 PDF”)。
  2. 要使用默认设置,请从“设置”菜单中选择“标准”,然后跳至步骤 6。如果您在“PDF 优化器”对话框中更改了任何设置,“设置”菜单将自动切换到“自定义”。
  3. 从“兼容于”菜单中选择“保留当前压缩”来保留当前的 PDF 版本,或选择一个 Acrobat 版本。(面板中的可用选项会根据选择而改变。)
  4. 选择面板旁的复选框(例如,图像、字体、透明度),然后选择在面板中的选项。要防止在优化期间执行面板中所有的选项,请取消选中那个面板的复选框。
  5. (可选)要保留您优化的设置,单击“保存”按钮然后命名设置。(要删除保存的设置,请在“设置”菜单中选择它并单击 Delete 键。)
  6. 当您完成选项设置后,请单击“确定”。
  7. 请在“另存优化文件为”对话框中,单击“保存”来用优化文件覆盖原始文件,或者以新名称保存或保存到新位置。

    注意:

    要同时优化多个文档,请使用“动作向导”的“输出”选项。

PDF 优化器选项 (Acrobat Pro)

使用“PDF 优化器”对话框中的面板上的选项来减少 PDF 的大小。

“图像”面板

通过“PDF 优化器”的“图像”面板,您可以设置彩色、灰度和单色图像压缩,以及图像缩减像素采样。

PDF 优化器
在 <span class="uicontrol">Acrobat Pro</span> 中,在“PDF 优化器”对话框的“图像”面板中更改 PDF 兼容性。

根据需要,指定下列选项:

缩减像素采样

通过合并原始像素的颜色为较大的像素从而降低图像分辨率,减小文件大小。

注意:蒙版图像和大小小于 16 X 16 像素的图像不会被缩减像素采样。

压缩

通过去除不必要的像素数据来减小文件大小。通常,JPEG 和 JPEG2000 压缩对于类似于照片的具有渐变颜色的图像压缩效果较好。ZIP 更适用于包含大面积实色、单色的插图或由单色构成的图案。对于单色图像,JBIG2 压缩(在“PDF 优化器”中可用,但在 Distiller 中不可用)优于 CCITT。

质量

仅对 JPEG 和 JPEG2000 格式可用。JPEG 和 JPEG2000 压缩方法是典型的“有损压缩”,处理时将永久删除某些像素数据。您可以使用不同的级别(最低、低、中、高或最高)来对彩色图像进行 JPEG 或 JPEG 2000 压缩。对于 JPEG 2000 压缩,您还可以指定为“无损压缩”,这样将不会删除像素数据。除了提供了有损和无损两种压缩模式的 JBIG2 压缩,其它单色图像压缩方式都是无损的。

块尺寸

仅对 JPEG2000 格式可用。将正在压缩的图像分解为给定尺寸的块。(如果图像高度或宽度并非块尺寸的偶数倍,不完整的块将用于边缘。)每个块的图像数据是单独压缩的,并且可以单独解压缩。推荐的是 256 默认值。

仅在大小减小时优化图像

当选定时,如果图像设置将导致文件大小的增加,则跳过对该图像的优化。

字体面板

要确保与原始文档完全一致,最好嵌入文档中使用的所有字体。如果您不需要完全一致但较小的文件,您可以选择不嵌入用于罗马文字和东亚文字(繁体中文、简体中文、韩文和日文)的字体。在未安装原始字体的系统上查看时,会用替代字体替代这些语言的文本。“PDF 优化器”的“字体”面板包含两个字体列表:可用于取消嵌入的字体和要取消嵌入的字体。某些字体不能被取消嵌入,不会显示在“字体”面板中。要在某个文档中取消嵌入字体,请在“嵌入的字体”列表中选择一个或多个字体,然后单击“取消嵌入”按钮。如果您不要嵌入已嵌入字体的子集,请取消选择“子集化所有嵌入字体”。要防止文档中取消嵌入所有字体,请选择“不取消嵌入任何字体”。

透明度面板

如果 PDF 文档包含透明度的设计,您可以使用“PDF 优化器”的透明度面板中的预置参数来拼合透明以减少文件大小。(通过矢量平衡和光栅平衡区域的设置,拼合将透明度混合到相应作品。)“PDF 优化器”先将透明度选项应用到文档中的所有页面,然后再应用其它的优化选项。

如果您选择了“Acrobat 4.0 和更高版本”兼容性设置,则会启用“透明度”面板且优化过程中将合并文件中的所有透明度。它可以和 Acrobat 4.0 和更低的版本相兼容,这些版本不支持透明度。

当您创建拼合预设,它们在“透明度”面板中是默认预设设置。

注意:

透明度拼合在文件保存后无法撤消。

放弃的对象面板

通过“放弃的对象”面板,您可以指定要从 PDF 删除的对象以及在 CAD 绘图中优化曲线。您可以放弃在 Acrobat 和其它应用程序中创建的对象。选择对象将删除该对象在 PDF 文档中的所有对象。

在“放弃的对象”区域,您可以选择以下选项或其他选项:

放弃所有的表单提交,导入和重置动作

停用全部涉及到提交或导入表单数据以及重置表单域的操作。本选项保留操作链接到的表单对象。

拼合表单域

使表单域不可用且不改变其外观。表单数据和页面合并成为页面内容。

放弃所有 JavaScript 动作

在使用 JavaScript 的 PDF 中删除任何动作。

放弃所有替代图像

删除图像的所有版本,只保留用于屏幕查看的版本。某些 PDF 文档包含同一图像的不同版本用于不同目的,例如,包含低分辨率的版本用于屏幕查看,而高分辨率的版本用于印刷。

放弃嵌入的页面缩略图

删除嵌入的页面缩略图。对于单击“页面缩略图”按钮后需要很长时间来显示页面缩略图的大文档,此选项十分有效有用。

放弃文档标签

从文档删除标签,同时文本的辅助工具和重排功能也被删除。

转换平滑线条为曲线

减少用于在 CAD 绘图中构建曲线的控制点的数量,来减小 PDF 文件大小并加快屏幕渲染速度。

检测并合并图像碎片

寻找被分割为小的碎片的图像或蒙板,并尝试将碎片合并为单一图像或蒙板。

放弃嵌入的打印设置

从文档中删除嵌入的打印设置,例如页面缩放和双面模式。

放弃嵌入的搜索索引

删除嵌入的搜索索引,这将减小文件大小。

放弃书签

从文档中删除所有书签。

放弃用户数据面板

使用“放弃用户数据”面板来删除您不希望分发或与其他人共享的个人信息。如果您找不到个人信息,可能是该信息已隐藏。您可以通过使用“检查文档”命令(“工具”>“保护”>“删除隐藏的信息”),查找隐藏的文本和用户相关信息。

放弃所有注释、表单和多媒体

删除 PDF 中的所有注释、表单、表单域和多媒体。

放弃文档信息和元数据

删除文档信息字典和元数据流中的信息。(使用“另存为”命令将元数据流恢复到 PDF 副本中。)

放弃所有对象数据

从 PDF 中删除所有对象。

放弃文件附件

删除所有文件附件,包括作为注释添加到 PDF 中的附件。(PDF 优化器不优化附加的文件。)

放弃外部交叉引用

删除链接到其它文档的链接。在 PDF 文档中链接到其它位置的链接不被删除。

放弃其它应用程序的专用数据

PDF 文档中的脚本信息仅对创建文档的应用程序有用。本选项不影响 PDF 文档的功能性,同时减少了文件大小。

放弃隐藏的图层内容并拼合可见的图层

减小文件大小。优化文档看起来与原始 PDF 文档一样,但是其中不包含图层信息。

整理面板

“PDF 优化器”的“整理”面板中的选项用来从文档中删除无用的项目。这些项目包括文档中对于您的用途来说已过时或不再需要的元素。删除某些元素会严重影响 PDF 的功能。默认情况下,仅不影响功能的元素被选中。如果您无法确定删除其它选项会出现什么结果,请使用默认选择。

对象压缩选项

指定在文件中如何应用 Flate 压缩。

使用 Flate 编码未经编码的流

应用 Flate 压缩所有未编码的流。

在使用 LZW 编码的流中,使用 Flate 编码替代

将 Flate 压缩应用到所有使用 LZW 编码的内容流和图像。

放弃无效书签

删除文档中指向被删除的页面的书签。

放弃无效链接

删除跳至无效目标的链接。

放弃未引用的已命名目标

删除在本 PDF 文档未引用的已命名目标。由于本选项不检查来自其它 PDF 文件或网站的链接,因此其不适用于某些工作流程。

优化页面内容

将所有行尾字符转换为空格字符,这将提高 Flate 压缩。

优化 PDF 快速 Web 查看

重新结构化 PDF 文档以便允许从网络服务器分页下载(字节服务)。

启用 PDF 中的快速 Web 查看

“快速 Web 查看”为从网络服务器一次下载一页(字节级服务)重新结构化 PDF 文档。使用“快速 Web 查看”时,网络服务器将仅发送请求的页面,而不是整个 PDF。对于那些要花费很长时间从服务器下载的大文档,此选项特别重要。

请向您的网络管理员咨询,确保您使用的网络服务器软件支持“一次一页”(page-at-a-time) 下载。要确保您网站上的 PDF 文档在较旧的浏览器中显示,也可以创建到 PDF 文档的 HTML 链接(相对于 ASP 脚本或 POST 方法),并使用相对较短的路径名称(256 个字符或更少)。

请验证现有的 PDF 启用了快速 Web 查看

  1. 执行以下任一操作:

    • 在 Acrobat 中打开 PDF,然后选择“文件”>“属性”。在该对话框的“说明”面板的右下方查看“快速 Web 查看”设置(“是”或“否”)。
    • (仅 Windows)右键单击 PDF 文件图标,然后选择“属性”。单击“PDF”标签并在该面板的下方查看“快速 Web 查看”设置(“是”或“否”)。

确认“快速 Web 查看首选项”设置

按照以下过程来确认您在创建 PDF 过程中启用了 Acrobat“快速 Web 查看”。

  1. 在“首选项”对话框的“类别”下,选择“文档”。

  2. 在该对话框右侧的“保存设置”下,确保选中了“另存为优化快速 Web 查看”,然后单击“确定”。

为现有的 PDF 启用“快速 Web 查看”

当您确认了“快速 Web 查看首选项”设置,并检查了 PDF 属性确认文件没有启用“快速文件查看”之后,请使用以下过程。

  1. 打开 PDF。

  2. 选择“文件”>“另存为”。选择相同的文件名和位置。

  3. 当提示您是否覆盖已存在的文件消息出现时,单击“确定”。

注意:

Acrobat Pro 中,您还可以使用“准备网络发布”动作在 Adobe PDF 文件的整个文件夹中快速启用“快速 Web 查看”。请参阅运行动作

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略