创建表单域

在 Acrobat 中,可以选择其中一个表单工具来创建表单域。通过“表单域属性”对话框,您可以为每个域类型设置多种选项。

打开表单编辑模式

表单编辑模式下将显示“表单”任务窗格。使用“表单”任务窗格中的选项,您可以添加新域、编辑现有域以及执行与表单相关的其它任务。

  • 如果创建了新的表单,默认情况下,将在表单编辑模式下打开。
  • 对于现有表单,请选择“工具”>“表单”>“编辑”。

表单现在以表单编辑模式显示,且“表单”任务面板已打开。

创建表单域

  1. 将文档转换为 PDF 表单后,如果“表单”任务窗格尚未打开,请将其打开(“工具”>“表单”>“编辑”)。
  2. 执行以下任一操作:
    • 单击“添加新域”,然后选择要添加的表单域的类型。

    • 从“快速访问”工具栏中选择表单域。

    • 右键单击页面并选择工具。

    光标将变成十字线,并显示域的预览。

  3. 在页面上,单击要添加域以创建默认大小的域的位置。要使用自定义大小创建域,请拖动矩形来定义域的大小。
  4. 在“域名称”框中,键入域的名称,并指定您是否希望该域成为必填域。选择相关的描述性名称以便于组织和收集数据。
  5. 要显示“属性”对话框并修改任何其它域属性,请单击“所有属性”。

    注意:

    如果您已经在表单工具栏(在表单编辑模式时可见)中选择“保持选择工具”,在添加域后“域名称”框不显示。每次单击页面时,会向表单中添加新域。要退出此模式,请按 Esc 键或单击“选择对象”工具按钮 。要修改域的属性,请双击该域。

  6. 要测试表单,请单击工具栏上的“预览”按钮。使用预览表单功能可以采用与表单收件人相同的表单查看方式来查看表单,并有机会验证表单。如果要预览表单,则可以单击“编辑”按钮返回编辑模式。
  7. 表单完成时,单击“关闭表单编辑”。

在网格中布局表单域

您可以使用网格帮助您在页面上精确的定位表单域。您可以定义网格间距、颜色和位置。您可以选择是否在编辑表单域时使表单域的边界与网格线对齐。网格线不打印。

  1. 选择“视图”>“显示/隐藏”>“标尺及网格”>“网格”。
  2. 要在创建或移动表单域时使其与最近的网格线对齐,请选择“视图”>“显示/隐藏”>“标尺及网格”>“对齐网格”。

复制表单域

您可以在 PDF 表单的一个页面上创建表单域的副本。您还可以复制表单域并将其粘贴到其它页面上。创建重复表单域时,会将原始域的复本添加到一个或多个其它页面中。重复域在每个页面上的位置总是与原始域所在的位置相同。副本和重复都可以拖动到页面的其它位置,但不能在页面之间拖动。例如,您可以使用

创建的副本和重复与原始表单域的基本名称相同。使用“跨页复制”命令粘贴的副本和重复还附加了一个数字。所有有相同基本名称的表单域共享相同用户数据和动作属性。因此,当用户添加或编辑副本或重复域的响应时,该响应会显示在具有相同基本名称的所有域中。

如果您更改具有相同基本名称的多个版本表单域的其中任一版本的属性,则这些更改只会影响表单域的副本。例外情况是如果触发器不是鼠标动作您更改了“动作”列表。

注意:

要防止某个重复或复制的表单域与原始域的行为相同,请更改新表单域的名称。

创建表单域的副本

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 请选择表单域并执行以下任一操作:
    • 要将表单域复制到当前视图的中心,请选择“编辑”>“复制”,然后选择“编辑”>“粘贴”。

    • 要复制表单域并将其移动到页面上的其它位置,请按住 Ctrl 键拖动。

      提示:要在拖动时限制垂直或水平移动,请按住 Shift 键。

  3. 如果要使用用户在原始域中键入的数据自动填充域,请不要修改其名称。如果复制的域用于填写唯一的用户信息,请重命名。

在页面上创建表单域的多个副本

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 执行以下任一操作:
    • 右键单击表单域并选择“创建多个副本”。

    • 选择表单域,然后选择“任务”>“编辑域”>“创建多个副本”。

  3. 在创建域的多个副本”对话框中,选择“预览”,根据需要移动对话框以便显示表单页面上的原始域和副本。
  4. 选择要应用的选项:
    • 要更改创建的副本数,请在“纵向复制选定的域”和“横向复制选定的域”选项中输入其它值。

    • 要更改原始域和所有副本的尺寸,请在“更改宽度”和“更改高度”选项中输入其它值。

    • 要移动原始域和所有副本,请单击“”、“”、“”和“”按钮。

  5. 如果要使用用户在原始域中键入的数据自动填充域,请不要修改其名称。如果复制的域用于填写唯一的用户信息,请重命名。

在多个页面间复制表单域

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 执行以下任一操作:
    • 右键单击表单域并选择“跨页复制”。

    • 选择表单域并选择“表单”>“任务”>“编辑域”>“跨页复制”。

      注意:“复制”命令对于仅包含一个页面的表单不可用。

  3. 执行以下任一操作:
    • 要在表单中的每一页复制表单域,选择“所有”,然后单击“确定”。

    • 要在有限的页面范围内复制表单域,请单击“从”按钮,输入要显示表单域的起始和结束页码。然后单击“确定”。

      注意:是否包含最初显示表单域的页面不影响复制过程。包含该页面不会在原始页面上再创建一个副本,不包含该页面也不会删除原始的表单域。

  4. 如果要使用用户在原始域中键入的数据自动填充域,请不要修改其名称。如果复制的域用于填写唯一的用户信息,请重命名。

选择多个表单域

选择多个表单域是若干个任务(如创建副本、对齐表单域和调整表单域之前的间距)的第一步。

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 执行以下任一操作:
    • 要选择所有表单域的所有类型,请选择“编辑”>“全部选定”。

    • 要选择一个范围的表单域,请单击范围中的第一个表单域,然后按 Shift 键并单击最后一个表单域。这两个表单域之间的所有表单域都将被选择。

    • 要在 PDF 页面的不同部分选择各个表单域,请按住 Ctrl 键并单击每个表单域。

    • 要选择某个页面区域内的所有表单域,请使用“选择对象”工具 在该区域周围拖画选取框。

    • 要取消选择单个表单域,请按 Ctrl 键并单击该域。

    用深蓝色高亮显示并显示外框把手的域是。当您单击选择多个表单域时,选择的最后的域是锚。当您使用选取框时,第一个创建的表单域是锚。如果您按 Ctrl 键并单击取消选择锚,位于选择项目左上方的表单域将变成新的锚表单域。

调整表单域大小并进行排列

创建表单域后,您可以重排、调整大小或移动表单域来使页面更整洁、更专业。

在表单编辑模式下调整表单域的布局(选择“工具”>“表单”>“编辑”)。

重新调整表单域的大小

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 选择您要重新调整大小的表单域。
  3. 执行以下任一操作:
    • 要手动调整域的大小,请拖动外框手柄。按住 Shift 键同时拖动角控点,以保持表单域当前的长宽比。

    • 要以一个像素为单位调整域的大小,请按 Ctrl+方向键;要以十个像素为单位调整域的大小,请按 Ctrl+Shift+方向键。

    • 要调整到特定尺寸,请右键单击域并选择“属性”。然后单击“位置”标签,并调整“宽度”和“高度”值。

重新调整多个单域大小来域选定的表单域匹配

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 请选择您要重新调整大小的所有表单域。
  3. 右键单击您要其它选定的表单域匹配的表单域。选择“设置域为相同大小”,然后选择下列任一项:

    高度

    调整高度而不更改宽度。

    宽度

    调整宽度而不更改高度。

    两者兼有

    调整所有的宽度和高度来匹配。

移动单个表单域

您可以简单的拖动表单域来移动它们。要在较少的时间达到较大的准确度,您可以使用将它们对齐的特殊功能来调整它们之间的间距并将它们放在页面的中心。

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 选择要移动的一个或多个表单域。
  3. 执行以下任一操作:
    • 要移动到接近的位置,请拖动选定的表单域到新的位置。

      提示:要限制水平或垂直方向的移动,请开始拖拽,然后按住 Shift 持续拖拽选区。

    • 要移到特定位置,请右键单击域并且选择“属性”。然后单击“位置”标签,并设置“位置”值。

    • 要以小幅增量水平或垂直移动,请按方向键来将选定的表单域推到相关位置。

    • 要将表单域移动到页面中心,请选择“编辑”>“剪切”,导航至目标页面,然后选择“编辑”>“粘贴”。

      注意:仅在第一次粘贴时,域会位于页面中心。其它时候粘贴的域会与之前粘贴的域发生偏离。

对齐并使多个表单域居中

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 请选择您要对齐的两个或多个表单域。
  3. 右键单击要其它域对齐的域。选择“对齐、均分或居中”,然后按如下所示选择命令:
    • 要对齐域的列,请选择“左对齐”、“右对齐”或“纵向对齐”。它们分别与锚表单域的左边缘、右边缘或纵轴(中心)对齐。

    • 要对齐一行域,请选择“上对齐”、“下对齐”或“水平对齐”。将分别与锚表单域的上边缘、下边缘或横轴(中心)对齐。

    • 要将域居中,请选择“垂直居中”、“水平居中”或两者皆选。

    注意:

    当您右键单击其中一个选定的域时,它显示外框把手,指示这是表单域。“对齐”菜单命令将移动其它选定表单域来与锚表单域的边缘对齐。

调整表单域之间的间距

在布局页面上的表单域的上下文中,“分发”是指给一组表单域统一的间距,从相邻的域的中心度量。“分发”命令优先级高于“对齐网格”命令。

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 请选择您要调整的表单域。
  3. 请右键单击任何选定的表单域,并执行以下任一操作:
    • 要使域在最顶部的域和最底部的域之间均匀分布,请选择“对齐、均分或居中”>“垂直均分”。

    • 要使域在最左侧的域和最右侧的域之间均匀分布,请选择“对齐、均分或居中”>“水平均分”。

      注意:“工具”>“表单”中的“分布”命令具有不同的功能。使用此命令可以将表单发送给其他用户,然后这些用户可以填写信息并将数据返回给您。

删除表单域

  1. 如果未打开表单编辑模式,请选择“工具”>“表单”>“编辑”。
  2. 在“域”面板或页面视图中选择您要删除的表单域。
  3. 请按“删除”,或选择“编辑”>“删除”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略