关于 Flash 文件

在 Flash Professional 中,您可以处理各种文件类型,每种文件类型的用途各不相同:

  • FLA 文件是在 Flash Professional 中使用的主要文件,其中包含 Flash Professional 文档的基本媒体、时间轴和脚本信息。媒体对象是组成 Flash Professional 文档内容的图形、文本、声音和视频对象。时间轴用于告诉 Flash Professional 应何时将特定媒体对象显示在舞台上。您可以将 ActionScript® 代码添加到 Flash Professional 文档中,以便更好地控制文档的行为并使文档对用户交互做出响应。

  • 未压缩的 XFL 文件与 FLA 文件类似。XFL 文件和同一文件夹中的其他关联文件只是 FLA 文件的等效格式。通过此格式,多组用户可以更方便地同时处理一个 Flash 项目的不同元件。有关详细信息,请参阅使用未压缩的 XFL 文件

  • SWF 文件(FLA 文件的编译版本)是在网页上显示的文件。当您发布 FLA 文件时,Flash Professional 将创建一个 SWF 文件。

    Flash Professional SWF 文件格式是其他应用程序所支持的一种开放标准。有关 Flash Professional 文件格式的更多信息,请参阅 www.adobe.com/go/flashplayer_cn

  • AS 文件是 ActionScript 文件,您可以使用这些文件将部分或全部 ActionScript 代码放置在 FLA 文件之外,这对于代码组织和有多人参与开发 Flash Professional 内容的不同部分的项目很有帮助。

  • SWC 文件包含可重用的 Flash Professional 组件。每个 SWC 文件都包含一个已编译的影片剪辑、ActionScript 代码以及组件所要求的任何其他资源。

    注意(仅限 Flash Professional CC)不能将 SWC 文件导入 Flash Pro 中。

  • ASC 文件是用于存储 ActionScript 的文件,将在运行 Flash Media Server 的计算机上执行。 这些文件提供了实现与 SWF 文件中的 ActionScript 结合使用的服务器端逻辑的功能。

    注意:Flash Professional CC 不支持 ASC 文件。

  • JSFL 文件是 JavaScript 文件,可用来向 Flash Professional 创作工具添加新功能。

Adobe 推荐的资源

Adobe 推荐的资源
<ahref=”>“http://goo.gl/1iL8LIntroducingFlashProfessional</a>
Todd Perkins

下面更多的视频和教程演示了如何使用 Flash Professional。某些视频可能显示 Flash Professional CS3 或 CS4 界面,但仍适用于 Flash Professional CS5。

使用其他 Adobe 应用程序

Flash 可以使用其他 Adobe® 应用程序来实现广泛的创造性工作流程。您可以将 Illustrator® 和 Photoshop® 文件直接导入到 Flash 中。您还可以在 Flash 中创建视频,然后在 Adobe® Premiere® Pro 或 After Effects® 中进行编辑,或者从这些应用程序中将视频导入到 Flash 中。发布 SWF 文件时,可以使用 Dreamweaver® 将内容嵌入网页,然后在 Dreamweaver 中直接启动 Flash 来编辑这些内容。

打开 XFL 文件

从 Flash Professional CS5 开始,XFL 是创建的 FLA 文件的内部格式。在 Flash 中保存文件时,默认格式是 FLA,但文件的内部格式是 XFL。

其他 Adobe® 应用程序(例如 After Effects®)可以导出 XFL 格式的文件。这些文件的文件扩展名是 XFL,而不是 FLA。InDesign® 可直接以 FLA 格式导出在内部为 XFL 格式的文件。这样,就可以首先在 After Effects 或 InDesign 中处理项目,然后在 Flash 中继续进行处理。

可以按与打开 FLA 文件相同的方式,在 Flash 中打开和处理 XFL 文件。在 Flash Professional 中打开 XFL 文件后,可以将该文件另存为 FLA 文件或另存为未压缩的 XFL 文件。

下列视频教程演示了通过 XFL 和 FLA 从 InDesign 和 AfterEffects 导出到 Flash:

在 Flash 中打开 XFL 文件:

  1. 在其他 Adobe® 应用程序(如 InDesign 或 After Effects)中,将您完成的工作导出为 XFL 文件。

    该应用程序在 XFL 文件中保存原始文件的所有图层和对象。

  2. 在 Flash Professional 中,选择“文件”>“打开”,然后导航到该 XFL 文件。单击“打开”。

    XFL 文件按与 FLA 文件相同的方式在 Flash 中打开。原始文件的所有图层都显示在时间轴中,且原始对象显示在“库”面板中。

    现在可以正常处理文件了。

  3. 若要保存文件,请选择“文件”>“保存”。

    Flash Professional 会提示您在“另存为”对话框中为新 FLA 文件指定名称。

  4. 键入名称,然后保存 FLA 文件。

使用未压缩的 XFL 文件

从 Flash Professional CS5 开始,您可以选择使用未压缩的 XFL 格式的 Flash 文件。这种格式允许您查看构成 Flash 文件的每个单独的部分或子文件。这些部分包括:

  • 全面描述 Flash 文件的 XML 文件。

  • 描述每个库元件的各个 XML 文件。

  • 包含发布设置、移动设置及其他设置的其他 XML 文件。

  • 包含 Flash 文件使用的外部资源(如位图文件)的文件夹。

借助未压缩的 XFL 格式,不同的人员可以单独使用 Flash 文件的各个部分。您还可以使用源控制系统管理对未压缩的 XFL 文件中的每个子文件所做的更改。将这些功能协作,可以使多个设计人员和开发人员在大型项目上更加轻松地合作。

使用 XFL 文件的实时更新

借助未压缩的 XFL 文档的可编辑资源的实时更新,在 Flash 中打开未压缩的 XFL 文档后,您可以编辑其中的任何库资源。当在其他应用程序中完成资源编辑时,Flash 将反映您对该资源的更改。

要在其他应用程序中编辑未压缩的 XFL 文档中的资源,请执行下列操作:

  1. 以未压缩的 XFL 格式保存 Flash 文档。

  2. 在适当的编辑器中(例如 Photoshop),从“未压缩的 XFL 文档”的 LIBRARY 文件夹中打开要编辑的资源。

  3. 编辑资源并保存更改。

  4. 返回到 Flash Pro。

    该资源的更新立即在 Flash 中反映出来。

在 Flash 中用 Dreamweaver 编辑 SWF 文件

如果已安装 Flash 和 Dreamweaver,则可以在 Dreamweaver 文档中选择一个 SWF 文件,然后使用 Flash 编辑该文件。Flash 并不直接编辑 SWF 文件,而是编辑源文档(FLA 文件)并重新导出 SWF 文件。

  1. 在 Dreamweaver 中,打开"属性"检查器("窗口">"属性")。
  2. 在 Dreamweaver 文档中,执行下列操作之一:
    • 单击 SWF 文件占位符以选中它,然后在"属性"检查器中单击"编辑"。

    • 右键单击 (Windows) 或者按住 Control 单击 (Macintosh) SWF 文件的占位符,然后从上下文菜单中选择"使用 Flash 编辑"。

      Dreamweaver 将焦点切换到 Flash,Flash 将尝试定位到所选的 SWF 文件的 Flash 创作文件 (FLA)。如果 Flash 无法找到相应的 Flash 创作文件,则会提示您定位到该文件。

      注意:如果 FLA 文件或 SWF 文件已被锁定,请在 Dreamweaver 中取出该文件。

  3. 在 Flash 中,编辑该 FLA 文件。"Flash 文档"窗口指示您正在 Dreamweaver 内修改文件。
  4. 在完成编辑后,单击"完成"。

    Flash 将更新 FLA 文件并将其重新导出为 SWF 文件,接着关闭该文件,然后将焦点返回到 Dreamweaver 文档。

    注意:

    若要更新 SWF 文件并保持 Flash 打开,请在 Flash 中选择"文件">"更新用于 Dreamweaver"。

  5. 若要在文档中查看更新后的文件,请在 Dreamweaver 的"属性"检查器中单击"播放",或者按 F12 在浏览器窗口中预览页面。
  1. 启动 Flash。
  2. 在 Flash 主屏幕上,选择“新建”>“Flash 文件(移动)”。
  3. 在 Device Central 中,选择 Player 版本和 ActionScript 版本。
  4. 选择一种内容类型。
  5. 在“可用的设备”列表中,选择一个目标设备或多个设备(或者在“设备组”列表中选择一组设备或单个设备)。
  6. 单击“创建”。
  7. 在新的 Flash 文档中添加内容。
  8. 要测试文档,请选择“控制”>“测试”。

创建新文档

您可以在 Flash Professional 中创建新的文档或打开以前保存的文档,也可以在工作时打开新的窗口。您可以设置新建文档或现有文档的属性。

创建新文档

  1. 选择“文件”>“新建”。
  2. 在“常规”选项卡上,选择要创建的 Flash 文档类型。
  3. 请执行下列操作之一:

从模板创建新文档

  1. 选择“文件”>“新建”。
  2. 单击“模板”选项卡。
  3. 从“类别”列表中选择一个类别,并从“类别项目”列表中选择一个文档,然后单击“确定”。 可以选择 Flash Professional 自带的标准模板,也可以选择您曾经保存的模板。

打开现有文档

  1. 选择“文件”>“打开”。
  2. 在“打开”对话框中,定位到文件或在“转到”框中输入文件的路径。
  3. 单击“打开”。

在打开多个文档时查看文档

打开多个文档时,“文档”窗口顶部的选项卡会标识所打开的各个文档,允许您在它们之间轻松导航。 只有在“文档”窗口中最大化各文档后,才会显示选项卡。

  1. 单击要查看的文档的选项卡。

    默认情况下,选项卡按文档创建顺序排列。 可以通过拖动文档选项卡来更改它们的顺序。

为当前文档打开一个新的窗口

  1. 选择“窗口”>“重制窗口”。

设置新建文档或现有文档的属性

  1. 在文档打开的情况下,选择“修改”>“文档”。

    此时将显示“文档设置”对话框。

  2. 若要设置“舞台尺寸”,请执行下列操作之一:
    • 若要指定舞台大小(以像素为单位),请在“宽”和“高”框中输入值。最小为 1 x 1 像素;最大为 2880 x 2880 像素。

    • 若要将“舞台尺寸”与舞台内容使用的间距量精确对应,请选择“匹配: 内容”选项。

    • 若要将舞台大小设置为最大的可用打印区域,请选择“匹配: 打印机”。此区域的大小是纸张大小减去“页面设置”对话框 (Windows) 或“打印边距”对话框 (Macintosh) 的“页边界”区域中当前选定边距之后的剩余区域。

    • 若要将舞台大小设置为默认大小(550 x 400 像素),请选择“匹配: 默认值”。

  3. 若要调整舞台上 3D 对象的位置和方向,以保持其相对于舞台边缘的外观,请选择“调整 3D 透视角度以保留当前舞台投影”。

    仅当更改舞台大小时此选项才可用。

  4. (仅限 CS5.5)若要相对于舞台大小的更改自动缩放舞台内容,请选择“用舞台缩放内容”。

    仅当更改舞台大小时此选项才可用。您可以在“首选参数”中选择是否缩放锁定和隐藏图层中的内容。有关详细信息,请参阅设置常规首选参数

  5. 若要指定显示在工作区的标尺的度量单位,请从“标尺单位”菜单中选择一个选项。(此设置还确定了在“信息”面板中使用的单位。)
  6. 要设置文档的背景色,请单击“背景色”样本,然后从调色板中选择颜色。
  7. 要指定“帧频”,请输入每秒显示的动画帧的数量。

    对于大多数计算机显示的动画,特别是网站中播放的动画,8 fps 到 15 fps 就足够了。更改帧速率时,新的帧速率将变成新文档的默认值。

  8. (仅限 CS5.5)要以指定的时间间隔自动保存文档,请选择“自动保存”选项并指定保存的时间间隔(分钟数)。
  9. 请执行下列操作之一:
    • 若要将新设置仅应用于当前文档,请单击“确定”。

    • 要将这些新设置用作所有新文档的默认属性,请单击“设为默认值”。

使用属性检查器更改文档属性

  1. 单击舞台外部的工作区,以取消选择舞台上的所有对象。属性检查器中将显示文档属性。要打开属性检查器,请选择(“窗口”>“属性”)。
  2. (仅限 CS5.5)在“发布”部分,选择文档的 Flash Player 版本和 ActionScript 版本。要访问其他“发布”设置,请单击“发布设置”按钮。有关更多信息,请参阅发布设置

  3. 在“属性”部分中,对于 FPS(每秒帧数),请输入每秒播放的动画帧的数量。
  4. 要更改舞台大小,请输入舞台的宽度和高度值。
  5. 要选择舞台的背景色,请单击“舞台”属性旁边的颜色样本,然后从调色板中选择颜色。
  6. 要编辑其他文档属性,请单击“大小”属性旁边的“编辑”按钮。有关所有文档属性的更多信息,请参阅为新文档或现有文档设置属性

向文档中添加 XMP 元数据

可以在 FLA 文件中包含可扩展元数据平台 (XMP) 数据,例如标题、作者、描述、版权等。XMP 是一种某些其他 Adobe® 应用程序能够理解的元数据格式。可以在 Flash Professional 和 Adobe® Bridge 中查看元数据。有关 XMP 元数据的详细信息,请参阅 Bridge 帮助中的“元数据和关键字”

注意:Adobe Flash Professional CC 不支持 32 位 Bridge。

嵌入元数据可改善基于 Web 的搜索引擎的功能,以便在搜索 Flash Professional 内容时返回有意义的结果。搜索元数据基于 XMP(可扩展元数据平台)规范,并以 W3C 兼容的格式存储在 FLA 文件中。

文件的元数据包含有关文件的内容、版权状态、出处及历史记录的信息。在“文件信息”对话框中,可以查看和编辑当前文件的元数据。

根据所选文件的不同,可能会显示以下类型的元数据:

描述

包含作者、标题、版权和其他信息。

IPTC

显示可编辑的元数据。您可以在文件中添加字幕以及版权信息。IPTC Core 是 IPTC(国际出版电信协会)于 2004 年 10 月批准的规范。它与早期 IPTC(前身是 IIM)的不同之处在于,新增了一些属性,更改了一些属性名称并删除了一些属性。

摄像头数据 (Exif)

显示由数字摄像头分配的信息,包括在获取图像时所用的摄像头设置。

视频数据

显示视频文件的元数据,包括像素高宽比、场景和快照。

音频数据

显示音频文件的元数据,包括艺术家、专辑、曲目编号和流派。

Mobile SWF

列出有关 SWF 文件的信息,包括标题、作者、描述和版权。

历史记录

使用 Photoshop 记录对图像所做的更改。

注意:必须在 Photoshop 中启用历史记录日志首选参数,才能将该日志与文件的元数据一起保存。

Version Cue

列出任意 Version Cue 文件版本信息。

DICOM

显示有关用医学数字图像通讯 (DICOM) 格式保存的图像的信息。

若要添加元数据,请执行下列操作:

  1. 选择“文件”>“文件信息”。
  2. 在显示的“文件信息”对话框中,输入要包含的元数据。可以随时在 FLA 文件中添加或删除元数据。

保存 Flash 文档

可以用当前的名称和位置或其他名称或位置保存 Flash Professional FLA 文档。

如果文档包含未保存的更改,则文档标题栏、应用程序标题栏和文档选项卡中的文档名称后会出现一个星号 (*)。 保存文档时星号即会消失。

以默认的 FLA 格式保存 Flash 文档

  1. 请执行下列操作之一:
    • 要覆盖磁盘上的当前版本,请选择“文件”>“保存”。

    • 要将文档保存到不同的位置和/或用不同的名称保存文档,或者要压缩文档,请选择“文件”>“另存为”。

  2. 如果选择“另存为”,或者以前从未保存过该文档,请输入文件名和位置。
  3. 单击“保存”。

以未压缩的 XFL 格式保存文档

  1. 选择“文件”>“另存为”。
  2. 从“另存为类型”菜单中,选择“Flash CS5 或 CS5.5 未压缩文档(* xfl)”。
  3. 为文件选择名称和位置,然后单击“保存”。

还原到上次保存的文档版本

  1. 选择“文件”>“还原”。

将文档另存为模板

  1. 选择“文件”>“另存为模板”。
  2. 在“另存为模板”对话框的“名称”框中输入模板的名称。
  3. 从“类别”弹出菜单中选择一种类别或输入一个名称,以便创建新类别。
  4. 在“描述”框中输入模板说明(最多 255 个字符),然后单击“确定”。

    在“新建文档”对话框中选择该模板时,会显示此说明。

    要删除保存的模板,请定位到以下文件夹之一,并从包含模板 FLA 文件的类别文件夹中删除该文件。

    • 在 Windows XP 中 - C:\Documents and Settings\<用户名>\Local Settings\Application Data\Adobe\Flash CS5\zh_CN\Configuration\Templates\

    • 在 Windows Vista 和 7 中 - C:\Users\<用户名>\AppData\Local\Adobe\Flash CS5\<语言>\Configuration\Templates\

    • 在 Mac OS 中 - <硬盘>/Users/<用户名>/Library/Application Support/Adobe/Flash CS5/<语言>/Configuration/Templates/

将文档另存为 Flash CS4 文档

  1. 选择“文件”>“另存为”。
  2. 输入文件名和位置。
  3. 从“格式”弹出菜单中选择“Flash CS4 文档”,再单击“保存”。

    注意:

    如果出现一条警告消息,指示如果保存为 Flash CS4 格式则将删除内容,请单击“另存为 Flash CS4”以继续。如果文档包含的功能仅在 Flash CS5 中适用,则可能发生此情况。如果以 Flash CS4 格式保存文档,Flash Professional 不会保留这些功能。

在退出 Flash 时保存文档

  1. 选择“文件”>“退出”(Windows) 或“Flash”>“退出 Flash”(Macintosh)。
  2. 如果打开的文档包含未保存的更改,Flash Professional 会提示您保存或放弃每个文档的更改。
    • 单击“是”保存更改并关闭文档。

    • 单击“否”关闭文档,不保存更改。

打印 Flash 文档

若要预览和编辑文档,可打印 Adobe Flash Professional 文档中的帧,也可以通过查看器指定可以从 Flash Player 中打印的帧。

打印 Flash Professional 文档中的帧时,可以使用“打印”对话框,指定要打印的场景或帧的范围和打印份数。在 Windows 中,“页面设置”对话框可以指定纸张大小、方向和各种打印选项,包括边距设置以及是否每一页都要打印所有的帧。 在 Macintosh 中,这些选项分布在“页面设置”和“打印边距”对话框中。

两个操作系统上的“打印”和“页面设置”对话框都是标准的,而且它们的外观取决于选择的打印机驱动程序。

  1. 选择“文件”>“页面设置”(Windows) 或“文件”>“打印边距”(Macintosh)。
  2. 设置页面边距。 对两个操作系统均选择“居中”选项,以便在页面的中间打印帧。
  3. 在“帧”菜单中,选择是打印文档中的所有帧,还是只打印每个场景的第一帧。
  4. 在“布局”菜单中,选择以下某个选项:

    实际大小

    按照帧的完全大小打印。 在“缩放”中输入一个用来缩小或放大所打印帧的值。

    缩放到页面大小

    缩小或放大每个帧,使其填充页面的整个打印区域。

    记事本

    在一个页面上打印几个缩略图。 可以选择“方框”、“网格”、“空白”。 在“帧”框中输入每一页中缩略图的数量。 在“帧边距”框中设置缩略图之间的间隔,然后选择“标签帧”以将帧标签打印为缩略图。

  5. 若要打印帧,请选择“文件”>“打印”。

使用帧标签禁用打印

若不想打印主时间轴中的任何帧,则可以将其中一个帧标记为 !#p 以使整个 SWF 文件都不可打印。将某个帧标记为 !#p 会禁用(变暗)Flash Player 上下文菜单中的“打印”命令。您也可删除 Flash Player 上下文菜单。

即使禁用从 Flash Player 中打印的功能,用户仍可以用浏览器的打印命令打印帧。 因为该命令是浏览器的功能,所以不能用 Flash Professional 控制或禁用它。

禁用 Flash Player 上下文菜单中的打印

  1. 打开或激活要发布的 Flash Professional 文档(FLA 文件)。
  2. 选择主时间轴中的第一个关键帧。
  3. 选择“窗口”>“属性”以查看“属性”检查器。
  4. 在属性检查器中,对“帧标签”输入 !#p 以指定该帧不可打印。

    只需指定一个 !#p 标签即可禁用(变暗)上下文菜单中的“打印”命令。

    注意:

    也可以选择一个空白帧(而非关键帧),并将其标记为 #p.

通过删除 Flash Player 的上下文菜单禁用打印

  1. 打开或激活要发布的 Flash Professional 文档(FLA 文件)。
  2. 选择“文件”>“发布设置”。
  3. 选择“HTML”选项卡,取消选择“显示菜单”,然后单击“确定”。

打印帧时指定打印区域

  1. 打开包含要打印帧的 Flash Professional 文档(FLA 文件)。
  2. 选择未指定为使用 #p 帧标签进行打印的帧,该帧应位于与标记为 #p 的帧相同的层上。

    为方便起见,可选择标记为 #p 的帧后面的一帧。

  3. 在舞台中,创建所需打印区域大小的形状。 若要使用某个帧的边框,可选择这样的帧,它具有适合打印区域大小的对象。
  4. 选择时间轴中的帧,其中包含要用于边框的形状。
  5. 在属性检查器中(“窗口”>“属性”),为“帧标签”输入 #b 以将所选的形状指定为打印区域的边框。

    每个时间轴只允许使用一个 #b 帧标签。这个选项与用打印动作选择影片边框选项一样。

更改打印的背景色

可以打印在“文档属性”对话框中设置的背景色。 在要打印的时间轴的最低层上放置一个有颜色的对象,可以只更改要打印的帧的背景色。

  1. 在要打印的时间轴的最低层上放置一个覆盖舞台的填充形状。
  2. 选择该形状,然后选择“修改”>“文档”。 为打印背景选择一种颜色。

    该动作将改变整个文档的背景色,包括影片剪辑和所加载 SWF 文件的背景色。

  3. 请执行下列操作之一:
    • 要用这种颜色作为文档的打印背景色,请指定要打印放置了形状的帧。

    • 若要对非打印帧保持不同的背景色,请重复步骤 2 和步骤 3。然后在所有未指定为要打印的帧中,将形状放在时间轴的最低层。

使用 Flash Player 上下文菜单中的“打印”命令可以打印任何 Flash Professional SWF 文件中的帧。

上下文菜单的“打印”命令无法打印透明或色彩效果,也无法打印其他影片剪辑中的帧;要获得更多高级打印功能,请使用 PrintJob 对象或 print() 函数。

  1. 打开文档。

    该命令使用舞台作为打印区域或使用指定的边框来打印标记为 #p 的帧。

    如果没有具体指定要打印哪些帧,则将打印文档主时间轴中的所有帧。

  2. 选择“文件”>“发布预览”>“默认”,或者按下 F12 在浏览器中查看 Flash Professional 内容。
  3. 在浏览器窗口中的 Flash Professional 内容中右键单击 (Windows) 或按住 Control 再单击 (Macintosh),以显示 Flash Player 的上下文菜单。
  4. 从 Flash Player 的上下文菜单中选择“打印”,以显示“打印”对话框。
  5. 在 Windows 中,选择打印范围以选定要打印哪些帧。
  6. 在 Macintosh 中,在“打印”对话框中选择要打印的页面。
  7. 根据打印机属性选择其他打印选项。
  8. 单击“确定”(Windows) 或“打印”(Macintosh)。

注意:

从上下文菜单中进行打印不会影响对 PrintJob 对象的调用。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略