问题

在 Adobe Photoshop 或 Photoshop Elements 的“打开”对话框中,Camera Raw 图像的文件名不可用。或者,在尝试打开该图像时,应用程序返回以下错误之一:

  • “无法完成您的请求,因为该文件不是正确类型的文档。”
  • “无法完成您的请求,因为 Photoshop 无法识别这种类型的文件。”
  • “无法打开 [文件名],因为该文件是错误类型的文件。”
  • “文件已损坏或者是无法包含的格式。”

涵盖的主题

说明

请按照下面的说明顺序进行操作。在说明告诉您转到特定的解决方案时,请打开链接以执行该解决方案。

1. 确定随 Photoshop 或 Photoshop Elements 安装的 Camera Raw 增效工具版本。

通过使用 Photoshop Camera Raw 增效工具,您可以打开原始图像并以非破坏性的方式进行编辑。在安装 Photoshop 或 Photoshop Elements 时,将自动安装一个 Camera Raw 增效工具版本。

Adobe 定期发布新的 Camera Raw 增效工具版本,以增加对新数码相机型号的支持。最新的 Camera Raw 增效工具版本为 8.1。

先确定您的计算机上随 Photoshop 或 Photoshop Elements 安装的 Camera Raw 增效工具版本。打开 Photoshop 或 Photoshop Elements,然后执行以下操作之一:

  • Mac OS 上的 Photoshop:选择“Photoshop”>“关于增效工具”。
  • Windows 上的 Photoshop:选择“帮助”>“关于增效工具”。
  • Mac OS 上的 Photoshop Elements:选择“Photoshop Elements”>“关于增效工具”。
  • Windows 上的 Photoshop Elements:打开 Photoshop Elements 编辑器,然后选择“帮助”>“关于增效工具”。

在“关于增效工具”子菜单中查找 Camera Raw。(增效工具是按字母顺序列出的。)然后,执行以下操作之一:

  • 如果 Camera Raw 未在“关于增效工具”子菜单中列出,请转到解决方案 1
  • 如果 Camera Raw 列出了多次,请转到解决方案 2
  • 如果 Camera Raw 列出了一次,请选择该增效工具。版本号位于打开的信息窗口中。单击信息窗口上的任意位置以将其关闭,然后执行步骤 2。

2. 确定为您的相机启用支持所需的最低 Camera Raw 增效工具版本。

Camera Raw 增效工具 | 支持的相机中查找您的相机。

  • 如果您的相机未在支持的相机列表中列出,请转到解决方案 5
  • 如果您的相机支持的相机列表中列出,请注意该相机所需要的 Camera Raw 增效工具的最低版本。然后,执行以下操作之一:
    • 如果您当前安装的 Camera Raw 增效工具版本等于或高于所需要的最低版本,则转到解决方案 2
    • 如果您当前安装的 Camera Raw 增效工具版本低于所需要的最低版本,请继续执行步骤 3。

3. 确定 Adobe 应用程序是否与所需的 Camera Raw 增效工具版本兼容。

确保 Adobe 应用程序与所需的 Camera Raw 增效工具版本兼容。有关更多信息,请参阅与 Camera Raw 兼容的 Adobe 应用程序

  • 如果您的 Adobe 应用程序与 Camera Raw 增效工具版本兼容,请转到解决方案 1
  • 如果您的 Adobe 应用程序与 Camera Raw 增效工具版本不兼容,请转到解决方案 3

解决方案

解决方案:安装与 Adobe 应用程序兼容的最新 Camera Raw 增效工具版本。

安装与 Photoshop 或 Photoshop Elements 版本兼容的最新 Camera Raw 增效工具版本。(必要时,请参阅与 Camera Raw 兼容的 Adobe 应用程序。)例如,如果 Photoshop 版本与 Camera Raw 4.6 和更早版本兼容,请安装 4.6 版。即使您只需要使用 4.3 版即可为您的相机启用支持,也要安装最新版本。

注意通常,每个新的 Camera Raw 增效工具版本以早期版本支持的相机为基础。例如,Camera Raw 4.4 版支持 4.3 版所支持的所有相机以及其他相机。4.3 版支持 4.2 版所支持的所有相机以及其他相机,依此类推。

安装说明包含在 Camera Raw 下载页面中,您可在 http://www.adobe.com/cn/downloads/updates/ 上找到它。

对于当前版本的产品,您可以通过 Adobe Updater 或 Adobe Application Manager(CS5 及更高版本)自动更新到最新版本的 Camera Raw。在 Photoshop 或 Photoshop Elements 中,选择“帮助”>“更新”。

也可以在以下技术说明中找到相应的说明和支持的相机信息:

如果您仍无法打开相机中的照片,请继续执行解决方案 2

解决方案 2:删除并重新安装 Photoshop 或 Photoshop Elements。

如果 Photoshop 或 Photoshop Elements 加载多个 Camera Raw 增效工具实例,这些增效工具彼此之间将发生冲突。要解决该问题,请删除并重新安装 Photoshop 或 Photoshop Elements。

重要:在卸载软件之前,请确保您具有安装介质以重新安装该软件。替换介质不适用于以前版本的 Adobe 软件。

要删除 Mac OS 上的 Photoshop 或 Photoshop Elements,请执行以下操作:

  1. 退出所有 Adobe 应用程序。
  2. 在 Applications/Adobe Photoshop [版本] 或 Applications/Adobe Photoshop Elements [版本] 文件夹中备份要保存的任何个人文件,包括第三方增效工具。
  3. 执行以下操作之一:

    • 如果您具有 Photoshop CS3 或更高版本或者 Photoshop Elements 6,请在 /Applications/Utilities/Adobe Installers 中双击您的应用程序或 Adobe Creative Suite 版本的卸载程序。然后,按照屏幕上的说明删除 Photoshop 或Photoshop Elements。
    • 如果您具有早期版本的 Photoshop 或 Photoshop Elements,请将 Adobe Photoshop [版本] 或 Adobe Photoshop Elements [版本] 文件夹拖到废纸篓中。(这些文件夹位于 Applications 文件夹中。)
  4. 在 Finder 中,浏览到 /Library/Application Support/Adobe。

    注意该文件路径指向启动磁盘卷的根目录级别中的 Library 文件夹,而不是指向用户 Home 文件夹中的 Library 文件夹。

  5. 如果在 Adobe 文件夹中看到名为 Plug-Ins 的文件夹,请将其拖到废纸篓中。
  6. 重新启动计算机。
  7. 选择“Finder”>“清倒废纸篓”。如果由于包含锁定的文件而未完全清倒废纸篓,请按 Option 键,然后选择“Finder”>“清倒废纸篓”。

删除 Windows 上的 Photoshop 或 Photoshop Elements:

  1. 关闭所有 Adobe 应用程序。
  2. 在 Program Files/Adobe Photoshop [版本] 或 Program Files/Photoshop Elements [版本] 文件夹中备份要保存的任何个人文件,包括第三方增效工具。
  3. 选择“开始”>“控制面板”(或“开始”>“设置”>“控制面板”),然后执行以下操作之一:

    • Windows XP:打开“添加或删除程序”。
    • Windows Vista、Windows 7:从控制面板主页的“程序”部分中选择“卸载程序”。或者,如果位于经典视图中,请打开“程序和功能”。
  4. 从安装的程序列表中选择您的 Photoshop 或 Photoshop Elements 版本,然后单击“更改/删除”(Windows XP) 或“卸载”(Windows Vista、Windows 7)。

    注意如果将 Photoshop 作为套件的一部分进行安装,请从安装的程序列表中选择您的 Adobe Creative Suite 版本。

  5. 按照屏幕上的说明删除 Photoshop 或 Photoshop Elements。

  6. 在 Windows 资源管理器中,浏览到 Program Files\Common Files\Adobe。
  7. 如果在 Adobe 文件夹中看到名为 Plug-Ins 的文件夹,请将其删除。

在删除 Photoshop 或 Photoshop Elements 后,请使用原始安装介质重新安装该应用程序。然后,尝试打开原始图像。如果您无法打开原始图像,请重复执行以上说明

解决方案 3:升级到最新版本的 Photoshop 或 Photoshop Elements。

如果您的 Photoshop 或 Photoshop Elements 版本与所需的 Camera Raw 增效工具版本不兼容,请考虑升级到最新的版本。这些应用程序的最新版本始终支持最新版本的 Camera Raw 增效工具以及各种不同的相机。

如果您不想升级,请参阅解决方案 4,以了解如何针对 Photoshop 或 Photoshop Elements 使用 Adobe DNG Converter 的信息。

您可以从 Adobe 授权的经销商购买升级,也可以直接从 Adobe 购买。有关更多信息,请参阅如何购买 Adobe 产品

解决方案 4:使用 Adobe DNG Converter 将相机的原始文件转换为 DNG 文件。

如果您的 Photoshop 或 Photoshop Elements 版本与您的相机所要求的 Camera Raw 增效工具版本不兼容,请使用 Adobe DNG Converter。Adobe DNG Converter 是一个免费实用程序,它可在不损失任何图像数据的前提下,将相机原始文件转换为数字负片 (DNG) 文件。Adobe 开发的 DNG 是数码相机原始图像文件的通用格式。

Adobe DNG Converter 可转换受相同版本 Camera Raw 增效工具支持的相同相机中的原始图像文件。要在 Photoshop 或 Photoshop Elements 的 Camera Raw 中打开转换的 DNG 文件,您需要使用 Camera Raw 2.3 或更高版本。

要在 Mac OS 上安装 Adobe DNG Converter,请双击下载的 DMG 文件。然后,双击 Adobe DNG converter.pkg 文件,并按照屏幕上的说明完成安装。

要在 Windows 上安装 Adobe DNG Converter,请双击您下载的 DNGConverter_[版本].exe 文件,然后按照屏幕上的说明完成安装。

将相机原始图像转换为 DNG:

  1. 在硬盘驱动器上创建一个文件夹,然后将要转换的相机原始文件移动或复制到该文件夹中。如果要在现有文件夹中转换所有相机原始文件,则不需要先创建文件夹。
  2. 执行以下操作之一:

    • 在 Mac OS 中,从“应用程序”文件夹中打开 Adobe DNG Converter。
    • 在 32 位版本的 Windows 中,从 C:\Program Files\Adobe\ 文件夹中打开 Adobe DNG Converter 应用程序。
    • 在 64 位版本的 Windows 中,从 C:\Program Files\Adobe\ 文件夹中打开 Adobe DNG Converter 应用程序。如果要在 32 位版本的 Windows 中使用 Adobe DNG Converter,请从 C:\Program Files (x86)\Adobe\ 文件夹中打开 Adobe DNG Converter 应用程序。
  3. 选择要转换的图像的文件夹。
  4. (可选)要转换在上一步中选择的文件夹的子文件夹中包含的文件,请选中“包括子文件夹中包含的图像”。
  5. 选择“在新位置存储”,然后选择一个文件夹位置以保存转换的图像。或者,选择“在相同位置存储”。
  6. (可选)如果在步骤 4 中选择了“包括子文件夹中包含的图像”,并且要将转换的文件放在具有原始文件夹结构的文件夹中,请选择“保留子文件夹”。
  7. (可选)为转换的图像选择一个命名方案。如果未更改命名方案,则转换的文件具有与原始文件相同的名称,但具有 DNG 文件扩展名。
  8. (可选)要更改转换设置,请选择“更改首选项”,从“首选选”对话框中选择所需的任何选项,然后单击“确定”。
  9. 单击“转换”。“转换状态”窗口将指示转换进度。在转换完成后,单击“确定”以返回到 Adobe DNG Converter 以处理其他图像,或者单击“退出”以关闭该应用程序。

解决方案 5:检查支持您的相机的 Camera Raw 更新。

如果您的相机未在 Camera Raw 增效工具 | 支持的相机中列出,则 Camera Raw 增效工具不支持您的相机。定期检查页面(或数码相机原始数据支持页面)。您可以了解是否发布了新的 Camera Raw 增效工具版本以及该版本是否支持您的相机。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略