您可以创建超链接,以便在 InDesign 中导出为 Adobe PDF 或 SWF 时,查看者单击某个链接即可跳转到同一文档的其他位置、其他文档或网站。在 InCopy 中导出为 PDF 或 SWF 的超链接处于不活动状态。

“源”可以是超链接文本、超链接文本框架或超链接图形框架。“目标”可以是超链接跳转到达的 URL、文件、电子邮件地址、页面文本锚点或共享目标。一个源只能跳转到达一个目标,但可有任意数目的源跳转到达同一个目标。

“源”可以是超链接文本或超链接图形。“目标”可以是超链接跳转到达的 URL、文件、电子邮件地址、页面、文本锚点或共享目标。一个源只能跳转到达一个目标,但可有任意数目的源跳转到达同一个目标。

注意:

若要从目标文本生成源文本,请插入交叉引用,而不要添加超链接。请参阅交叉引用

dy_00
Hyperlinks

A. Hyperlink source B. List of hyperlinks in the current document C. Hyperlink status icons 
  • 选择“窗口”>“交互”>“超链接”。
  • 选择“窗口”>“超链接”。
  • 选择“窗口”>文字和表>“交叉引用”。
  1. 从“超链接”面板菜单中选择“排序”,然后选择下列任意一项:

    手动

    按照超链接添加到文档中的顺序显示超链接。

    按名称

    按照字母顺序显示超链接。

    按类型

    按照类型分组显示超链接。

  1. 从“超链接”面板菜单中选择“小面板行”。

您可以创建指向页面、URL、文本锚点、电子邮件地址和文件的超链接。若要创建指向其他文档中某个页面或文本锚点的超链接,请确保导出文件出现在同一文件夹中。

注意:

要显示或隐藏超链接,请选择“视图”>“其他”>“显示超链接”或“隐藏超链接”。

注意:

在 InDesign 的“导出 Adobe PDF”对话框中如果选择“超链接”,在 Adobe PDF 导出文件中则会有超链接。如果在“导出 SWF”对话框中选择“包含超链接”,在 SWF 导出文件中则会有超链接。

您可以使用多种不同的方法来创建指向 URL 的超链接。指定 URL 时,可以使用任何有效的 Internet 资源协议:http://、file://、ftp:// 或 mailto://。

注意:

您可能希望为超链接创建字符样式。超链接的格式通常是带有下划线的蓝色文本。

  1. 选择要作为超链接源的文本、框架或图形。例如,可以选择文本“See the Adobe website”。
  2. 在“超链接”面板中,使用下列任一方法创建指向 URL 的超链接:
    • 在“URL”文本框中,键入或粘贴该 URL 的名称(如 http://www.adobe.com),然后从“超链接”面板中选择“新建超链接”。从“链接到”菜单中选择“URL”,指定外观选项,然后单击“确定”。

    • 如果在文档中选择了 URL,请在“超链接”面板菜单中选择“通过 URL 新建超链接”。双击“超链接”面板中的超链接,然后从“链接到”菜单中选择 URL,指定外观选项,然后单击“确定”。

    • 从“URL”菜单中选择以前添加的某个 URL。此时超链接的外观与以前添加的 URL 中使用的外观相同。

    • 在“超链接”面板菜单中选择“新建超链接”。从“链接到”菜单中选择“URL”,指定外观选项,然后单击“确定”。

注意:

如果导出的 PDF 中的某个 URL 超链接不起作用,则问题可能是由于该超链接是一个“共享目标”。双击“超链接”面板中的超链接,从“链接到”菜单中选择 URL,取消选中“共享的超链接目标”,然后单击“确定”。

创建指向文件的超链接时,单击 PDF 或 SWF 导出文件中的超链接将会在其本机应用程序中打开文件,例如在 Microsoft Word 中打开 .doc 文件。

请确保打开 PDF 或 SWF 导出文件的任何人都可使用您指定的文件。例如,如果要将 PDF 导出文件发送给同事,请指定共享服务器中的文件,不要指定硬盘中的文件。

  1. 选择要作为超链接源的文本、框架或图形。
  2. 在“超链接”面板菜单中选择“新建超链接”,或单击位于“超链接”面板底部的“创建新的超链接”按钮。
  3. 在“新建超链接”对话框中,从“链接到”菜单中选择“文件”。
  4. 对于“路径”,请键入路径名或单击文件夹按钮,以找到并双击文件名。
  5. 如果您希望将文件存储在“超链接”面板中以便于重复使用,请选中“共享的超链接目标”。
  6. 指定超链接源的外观,然后单击“确定”。
  1. 选择要作为超链接源的文本、框架或图形。
  2. 在“超链接”面板菜单中选择“新建超链接”,或单击位于“超链接”面板底部的“创建新的超链接”按钮。
  3. 在“新建超链接”对话框中,从“链接到”菜单中选择“电子邮件”。
  4. 对于“地址”,请键入电子邮件地址,例如“username@company.com”
  5. 对于“主题行”,请键入显示在电子邮件主题行中的文本。
  6. 如果您希望将电子邮件存储在“超链接”面板中以便于重复使用,请选择“共享的超链接目标”。
  7. 指定超链接源的外观,然后单击“确定”。

可以创建指向页面的超链接,而不需首先创建目标。但是,通过创建页面目标,可以指定页码和视图设置。

  1. 选择要作为超链接源的文本、框架或图形。
  2. 在“超链接”面板菜单中选择“新建超链接”,或单击位于“超链接”面板底部的“创建新的超链接”按钮。
  3. 在“新建超链接”对话框中,从“链接到”菜单中选择“页面”。
  4. 对于“文档”,选择包含要跳转到的目标的文档。弹出式菜单中将列出已存储的所有打开的文档。如果要查找的文档未打开,则在弹出式菜单中选择“浏览”,找到该文件,然后单击“打开”。
  5. 对于“页面”,请指定要跳转到达的页码。
  6. 对于“缩放设置”,请执行下列操作之一以选择跳转到达页面的视图状态:
    • 选择“固定”以显示在创建链接时使用的放大级别和页面位置。

    • 选择“适合视图”将当前页面的可见部分显示为目标。

    • 选择“适合窗口大小”以在目标窗口中显示当前页面。

    • 选择“适合宽度”或“适合高度”以在目标窗口中显示当前页面的宽度或高度。

    • 选择“适合可见”以显示页面,从而使它的文本和图形适合窗口宽度,这通常意味着不显示边距。

    • 选择“承前缩放”,从而按照单击超链接时读者所使用的缩放比例显示目标窗口。

  7. 指定外观选项,然后单击“确定”。

只有创建指向“文本锚点”的超链接或交叉引用时,才有必要创建超链接目标。文本锚点可指向选定文本或插入点位置。然后,创建指向超链接目标的超链接或交叉引用。也可以为页面和 URL 创建超链接目标,但没有必要为这些链接创建目标。

您创建的超链接目标不会显示在“超链接”面板中;它们显示在创建或编辑超链接时所显示的对话框中。

  1. 若要创建文本锚点,请使用“文字”工具放置插入点,或选择要作为锚点的文本范围。

    不能为主页上的文本设置锚点目标。

  2. 在“超链接”面板菜单中选择“新建超链接目标”。
  3. 在“类型”菜单中选择“文本锚点”。指定文本锚点的名称,然后单击“确定”。
  4. 执行下列任何一项,然后单击“确定”:
    • 在“类型”菜单中选择“文本锚点”。为文本锚点指定名称。

    • 在“类型”菜单中选择“页面”。指定要跳转到达的页码以及缩放设置。键入页面的名称,或选择“以页码命名”,从而根据您指定的页码和缩放设置为目标自动命名。

    • 在“类型”菜单中选择“URL”。键入或粘贴 URL,例如“http://www.adobe.com”。可以使用任何有效的 Internet 资源协议:http://、file://、ftp:// 或 mailto://。

  1. 选择要作为超链接源的文本、框架或图形。
  2. 在“超链接”面板菜单中选择“新建超链接”,或单击位于“超链接”面板底部的“创建新的超链接”按钮。
  3. 从“链接到”菜单中选择“文本锚点”。
  4. 对于“文档”,选择包含要跳转到的目标的文档。弹出式菜单中将列出已存储的所有打开的文档。如果要查找的文档未打开,则在弹出式菜单中选择“浏览”,找到该文件,然后单击“打开”。
  5. 从“文本锚点”菜单中,选择您创建的文本锚点目标。
  6. 指定超链接外观选项,然后单击“确定”。

创建超链接时,如果从“链接到”菜单中选择了“共享目标”,则可以指定任何已命名的目标。在创建指向 URL、文件或电子邮件地址期间,使用“URL”文本框添加 URL 或选择“共享的超链接目标”时将会为目标命名。

  1. 选择要作为超链接源的文本、框架或图形。
  2. 在“超链接”面板菜单中选择“新建超链接”,或单击位于“超链接”面板底部的“创建新的超链接”按钮。
  3. 在“新建超链接”对话框中,从“链接到”菜单中选择“共享目标”。
  4. 对于“文档”,选择包含要跳转到的目标的文档。弹出式菜单中将列出已存储的所有打开的文档。如果要查找的文档未打开,则在弹出式菜单中选择“浏览”,找到该文件,然后单击“打开”。
  5. 从“名称”菜单中选择一个目标。
  6. 指定超链接外观选项,然后单击“确定”。

这些选项可以确定 PDF 或 SWF 导出文件中超链接源或交叉引用源的外观。如果您选择“视图”>“其他”>“显示超链接”,则 InDesign 文档中还会显示以下外观选项。

字符样式

选择要应用于超链接源的一种字符样式。仅当超链接源是所选文本(而非所选框架或图形)才可使用“字符样式”选项。

若要插入交叉引用,则可以在编辑交叉引用格式时应用字符样式。另外还可以将字符样式应用于某种格式中的构建单元。请参阅使用交叉引用格式

文字

选择“可见矩形”或“不可见矩形”。

突出显示

选择“反转”、“轮廓”、“内陷”或“无”。这些选项可以确定在 PDF 或 SWF 文件中单击超链接时超链接的外观。

颜色

为可见超链接矩形选择颜色。

宽度

选择“细”、“中”或“粗”以确定超链接矩形的粗细。

样式

选择“实底”或“虚线”以确定超链接矩形的外观。

您可以查找文档中的 URL(如“www.adobe.com”),然后将其转换为超链接。

  1. 从“超链接”面板菜单中选择“将 URL 转换为超链接”。
  2. 对于范围,请指示您要转换整个文档、当前文章还是当前选定范围中的 URL。
  3. 要为超链接应用字符样式,请从“字符样式”菜单中选择一个字符样式。
  4. 执行以下任意操作,然后单击“完成”。
    • 单击“查找”可找到下一个 URL。

    • 单击“转换”可将当前 URL 转换为超链接。

    • 单击“全部转换”可将所有 URL 转换为超链接。

使用“超链接”面板可以编辑、删除、重置或定位超链接。在 InCopy 中,仅当注销文章以便进行编辑时才能管理超链接。

  1. 在“超链接”面板中,双击要编辑的项目。
  2. 在“编辑超链接”对话框中,根据需要更改超链接,然后单击“确定”。

注意:

若要编辑某个指向 URL 的超链接,请选择该超链接,在“URL”文本框中编辑 URL,然后按 Tab 或 Enter。

移去超链接时,源文本或图形仍然保留。

  1. 在“超链接”面板中选择要移去的一个或多个项目,然后单击此面板底部的“删除”按钮。

为超链接源重新命名将会更改超链接源在“超链接”面板中的显示方式。

  1. 在“超链接”面板中,选择超链接。
  2. 从“超链接”面板菜单中选择“重命名超链接”,然后指定一个新名称。
  1. 打开其中显示目标的文档。
  2. 在“超链接”面板菜单中选择“超链接目标选项”。
  3. 对于“目标”,选择要编辑的目标名称。
  4. 执行以下操作之一:
    • 单击“编辑”,然后对目标做必要的更改。

    • 单击“删除”移去目标。

  5. 完成目标的编辑或删除处理之后,请单击“确定”。
  1. 选择将用作新超链接源的文本范围、文本框架或图形框架。例如,您可能需要在源中另外增加一些文本。
  2. 在“超链接”面板中选择超链接。
  3. 执行以下操作之一:
    • 在“超链接”面板菜单中选择“重置超链接”。

    • 要将超链接更新到外部文档,请在“超链接”面板菜单中选择“更新超链接”。

  • 若要定位超链接源或交叉引用源,请在“超链接”面板中选择要定位的项目。在“超链接”面板菜单中选择“转到源”。该文本或框架将被选定。
  • 若要定位超链接目标或交叉引用目标,请在“超链接”面板中选择要定位的项目。在“超链接”面板菜单中选择“转到目标”。

如果项目是 URL 目标,则 InDesign 将启动或切换到 Web 浏览器以显示此目标。如果项目是文本锚点或页面目标,则 InDesign 将跳转到该位置。

当带有超链接的 Microsoft Word 文档导入 InDesign 文档时,您可能会注意到超链接的 URL(如 www.adobe.com)周围会有一个边框。InDesign 文档继承了一种名为 Word_R0_G0_B255 的蓝色色板。该文档还继承了一种名为“超链接”的字符样式,这种样式会对文本添加下划线并应用蓝色。

要删除此边框,请在“超链接”面板中双击该超链接。在“外观”下,从“类型”菜单中选择“不可见矩形”,然后单击“确定”。

您可能还希望删除导入的色板。执行此操作时,您可以将其替换为不同的色板。请参阅删除单个色板

注意:

在将 Word 文档置入 InDesign 之前,您可能需要删除 Word 文档中的 URL 超链接以避免继承此格式。查看您的 Word 文档。另一个选项是:导入之前,在 InDesign 文档中创建一个名为“超链接”的字符样式。当导入 Word 文档时,默认情况下将使用具有相同名称的 InDesign 样式。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略