将文档内容导出为 XML

在将内容从 InDesign 文档导出为 XML 之前,必须首先执行以下操作:

  • 创建或载入元素标签。

  • 将标签应用于文档页面上的项目。

  • 如果需要,在“结构”窗格中调整带标签元素的层次结构。

可以导出文档中的全部或部分 XML 内容。只能导出带有标签的内容。

注意:

如果要导出的文档包含表,必须为这些表添加标签,否则 InDesign 不会将它们导出到 XML 中。

  1. 如果只想导出文档的一部分,请在“结构”窗格中选择作为导出操作预期开始位置的元素。
  2. 选择“文件”>“导出”。
  3. “存储类型”(Windows) 或“存储格式”(Mac OS) 中,选择“XML”。
  4. 为 XML 文件指定名称和位置,然后单击“保存”。
  5. 在“导出 XML”对话框的“常规”选项卡中,执行以下操作之一:

    包含 DTD 声明

    将对 DTD 的引用与 XML 文件一起导出。只有在“结构”窗格中存在 DOCTYPE 元素的情况下,该选项才可用。

    XML 查看工具

    在浏览器、XML 编辑应用程序或文本编辑器中打开导出的文件。从列表中选择浏览器或应用程序。

    从选定元素导出

    从在“结构”窗格中选定的元素开始导出。仅当在选择“文件”>“导出”之前选定了某元素时,此选项才可用。

    将未标记的表作为 CASL XML 导出

    将未添加标签的表以 CALS XML 格式导出。只有当表位于带有标签的框架中并且表不具有标签时,才能将表导出。

    重新映射换行符、空格和特殊字符

    将换行符、空格和特殊字符作为十进制字符实体而非直接字符导出。

    应用 XSLT

    应用样式表以定义从导出的 XML 向其他格式(例如,经过修改的 XML 树或 HTML)的变换。选择“浏览”(Windows) 或“选择”(Mac OS),以便从文件系统中选择一个 XSLT 文件。默认设置“使用 XML 中的样式表”使用 XSLT 变换指令(如果在导出时应用的 XML 中引用了该指令)。

  6. 从“编码”菜单中选择编码类型。
  7. 若要为图像指定导出选项,请单击“图像”选项卡,然后选择下列一个或多个选项:

    原始图像

    将原始图像文件的副本置入 Images 子文件夹中。

    优化的原始图像

    优化并压缩原始图像文件,然后将文件副本置于 Images 子文件夹中。

    优化的已设置格式的图像

    优化包含所应用变换(如旋转或缩放)的原始图像文件,然后将文件置于 Images 子文件夹中。例如,如果文档包含两幅图像,一幅已裁切、一幅未裁切,那么只有已裁切图像会被优化并复制到 Images 子文件夹中。

  8. 如果在上一步中选择了“优化的原始图像”或“优化的已设置格式的图像”,请选择用于优化图像的选项。
  9. 单击“导出”。

注意:

XML 不支持某些特殊字符(如“自动页码”字符)。如果无法在导出的 XML 文件中包含某个字符,InDesign 会提出警告。如果没有为某个表添加标签,也会出现此警告。

优化的图像导出选项

在“导出 XML”对话框的“图像”选项卡中选择“优化的原始图像”或“优化的已设置格式的图像”时,可使用下列选项:

图像转换

为转换的图像指定应使用的文件格式。如果选择“自动”,InDesign 会根据图像选择最佳文件类型。因此,可能需要同时指定“GIF 选项”和“JPEG 选项”。

GIF 选项

为在导出至 XML 时转换为 GIF 格式的图像指定格式。可设置下列选项:

调板

指定转换时图像应遵照的颜色调板。选择用于 XML 内容最终显示格式的调板。“随样性”(无仿色)对主体为纯色的图像效果极佳,当最终输出具有多种格式时也可使用“随样性”(无仿色)。

交错

每一趟只下载图像的奇数行或偶数行,而不是一趟就下载完整幅图像。利用交错方式可以对图像进行预览,以便实现快速下载;后续每一次都会将分辨率提高一些,直至满足最终品质要求。

JPEG 选项

为导出至 XML 时转换为 JPEG 格式的图像指定格式。可设置下列选项:

图像品质

指定转换的图像的品质。品质设置越高,文件大小就越大,下载时间也越长。

格式方法

指示应如何针对下载需求对 JPEG 图像设置格式。“基线”格式一趟就可以下载完最终品质的图像,因此文件在打开时就显示的是其最终品质;下载时,这种格式的图像比“连续”格式的图像需要花费更长时间。“连续”格式则需要经过若干趟方能完成图像下载,第一趟下载的是图像的低分辨率版本,后续每一趟都会使图像分辨率有一定程度的提高,直至满足最终品质要求。

仅将标签存储为 XML

仅存储标签,以便能够将标签载入到 InDesign 文档中并在文档中利用这些标签。

  1. 从“标签”面板菜单中选择“存储标签”。
  2. 键入名称并指定位置,然后单击“保存”。

    文档中的标签及为其指定的颜色存储在 XML 文件中。

编辑导出的 XML 文件

在使用 InDesign 创建并导出 XML 文件之后,可以使用以下两种方法之一更改 XML:

  • 若要直接在 XML 文件中进行更改,请在文件编辑器或 XML 编辑器中打开该文件。
  • 若要使所做的更改保留在源文档中,请打开从其中导出 XML 的 InDesign 文件。在 InDesign 中更改了内容之后,可以再次将其导出为 XML(如果希望替换原始 XML 文件,可以使用原始 XML 文件名)。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略