想要提高 Photoshop Lightroom 的性能?请尝试本文提供的一些建议。

要获得最佳效果,需采取一种全面综合的方法。请阅读下面提供的所有建议。请考虑在您的计算机设置环境中应实施哪些解决方案。此外,还请考虑您所使用的文件类型以及具体工作流程。每种情况都是独一无二的,需要使用不同的技术组合才能获得最佳的 Lightroom 性能。

优化您的硬件和操作系统

更新到 Lightroom 的最新版本

在 Lightroom 中,选择“帮助”>“检查更新”。

超出最低系统要求

运行 Lightroom 的最低系统要求是指使用 Lightroom 需满足的最低要求。尤其是配置容量更大的 RAM 和速度更快的处理器,可以显著地提升性能。这些要求根据以下各项而有所不同:

  • 您处理的文件类型
  • 文件的大小
  • 目录中的图像总数
  • 应用于图像的污点修复或局部(画笔)调整的程度

有助于提升性能的选项包括:

  • 64 位多核处理(为了获得最佳性能,需要多达六核的处理器;如果要使用需要更大功率的多个显示器或高分辨率显示器,则额外功率尤为重要)
  • 12 GB RAM(推荐);至少 4 GB RAM,如果要同时使用 Photoshop,则需要更大容量
  • 快速硬盘,目录和预览尤其需要这种硬盘

了解您的 Lightroom 版本的系统要求

若要查看特定系统配置的详细信息,请在 Lightroom 中,选择“帮助”>“系统信息”。

在具有 12 GB RAM 或更大容量的计算机上运行 Lightroom

为了获得最佳性能,建议在具有 12 GB RAM 或更大容量的计算机上运行 Lightroom。使用推荐的 RAM 容量可以带来显著的性能优势,这些优势在导入和导出照片、在放大视图下切换照片,或创建 HDR 图像和全景图时表现得尤为明显。

使用快速硬盘驱动器

对于最简单的工作流程,内置快速 (7200 rpm) 串行 ATA 驱动器就足够了。对于有更高要求的工作流程,请考虑使用 RAID 阵列。

如果在多台计算机上使用同一个目录,则方便的做法是将目录、图像文件和预览存储到外部驱动器中。但是,这样做可能会对 Lightroom 性能产生不良影响。如果必须将文件存储到外部,请确保采用快速连接。例如,使用 Thunderbolt 连接、USB 3.0(而不是 USB 1.0 或 2.0)或 eSATA 连接。为了获得最佳性能,连接外部驱动器的端口应该是所有可用端口中具有最高带宽限制的兼容端口。各种端口的带宽限制如下所示:

Thunderbolt = 10GB/秒
eSATA = 600 MB/秒
PCIe = 500 MB/秒
USB3 = 400 MB/秒
USB2 = 35 MB/秒

注意:

目录文件无法存储在网络驱动器上,但是您可以在网络驱动器上存储您的照片。不过,网络驱动器(通过网络访问的硬盘)的数据传输率较慢。为此,在 Lightroom 中切换模块或从一个文件切换到另一个文件时,会需要更多的时间。

确保使用容量足够大的硬盘驱动器,并拥有足够的可用空间

使用太少的可用硬盘空间可能会导致性能降低。请确保存储 Lightroom 目录、预览和图像文件的硬盘驱动器至少有 20% 的空间可用。

请参阅 Lightroom 系统要求,以了解您的 Lightroom 版本所需的最低可用硬盘空间。

更新图形驱动程序

使用兼容的图形处理器(也称为图形卡、显卡或 GPU)。请务必保持图形驱动程序软件为最新。

如果您计算机的图形处理器与 Lightroom 不兼容,请取消选中 Lightroom (macOS)/编辑(Win) > 首选项 > 性能中的使用图形处理器复选框。

详细信息,请参阅 Lightroom 图形处理器 (GPU) 疑难解答和常见问题解答

以 64 位模式运行 Lightroom(Lightroom 4 和 3)

如果以 64 位模式运行 Lightroom,则 Lightroom 可以访问超过 2 GB 的 RAM,2 GB RAM 是 32 位操作系统的上限。允许 Lightroom 访问超过 4 GB 的 RAM 可以显著提高性能。

如果 Lightroom 安装在支持 64 位且运行 64 位操作系统的计算机上,则它会自动以 64 位模式运行。您可以通过执行下列操作来验证 Lightroom 是否在以 64 位模式运行:

验证 Windows 上的 Lightroom 是否在以 64 位模式运行

  1. 启动 Lightroom 并查看应用程序的标题栏。

  2. 查看标题中是否显示“x64”。

验证 Mac OS 上的 Lightroom 是否在以 64 位模式运行

  1. 在 Finder 中,导航到“应用程序”文件夹,然后单击“Adobe Lightroom 3”。

  2. 按 Command + I。

  3. 在“常规”选项中,确保取消选择以 32 位模式打开

如果您结合使用 Photoshop 和 Lightroom,请检查 Photoshop 的 RAM 设置

请参阅此技术说明中的“最大限度地利用 RAM 和内存”部分,以确定计算机的最佳 RAM 设置。要更改 Photoshop 中的内存设置,请选取 Apple > 首选项 > 性能 (Mac OS)编辑 > 首选项 > 性能 (Windows)

高分辨率显示

当 Lightroom 在整个屏幕使用高分辨率显示时,绘制到屏幕上的速度可能会变慢。高分辨率显示具有将近 2560 x 1600 的原生分辨率,并且可在 30 寸显示器和 Retina MacBook 上显示。要提高此类显示的性能,请减小 Lightroom 窗口的大小,或在“导航器”面板中使用 1:2 或 1:3 视图比例。

使用 Lightroom 中的优化设置

在 Lightroom Classic 中进行编辑时暂停“与 Lightroom CC 同步”

同步图像时,系统会使用 CPU 和系统资源来创建预览,并从 Creative Cloud 中上载/下载图像。在台式计算机上导入和编辑图像时,暂停与 Lightroom CC 同步。然后,恢复与 Lightroom CC 同步,并让应用程序一整晚保持打开状态,以让同步过程继续进行直至结束。

有意渲染 1:1 预览

Lightroom 在“网格”视图、“放大”视图及“修改照片”、“幻灯片放映”、“打印”和“Web”模块中使用预览显示照片缩览图。

导入照片时,可以选择三种类型的预览(其品质逐渐升高):

最小:这些预览是照片中嵌入的小尺寸、低分辨率的 JPEG 预览,这些预览由相机生成。它们是创建速度最快的预览类型。在 Lightroom 渲染这些缩览图的标准大小预览之前,“图库”模块的“胶片显示窗格”和“网格”视图会暂时使用最小预览。

嵌入与附属文件:这些预览较大,而且也是由相机生成的,创建此类预览所用的时间比创建最小预览略微长些。

标准:Lightroom 可创建标准预览。此类预览使用 Camera Raw 引擎进行处理。因此,有时显示效果会与最小或嵌入式预览不同,特别是在“修改照片”模块中应用了调整之后。您可以根据使用的显示器,指定所需的标准预览大小。标准预览用在“胶片显示窗格”和“网格”视图缩览图,以及“幻灯片放映”、“打印”和“Web”模块的预览和内容区域中。

1:1:这些预览是 100% 的实际像素视图,与标准预览一样,也是使用 Camera Raw 引擎进行处理。当 Lightroom 生成 1:1 预览时,也会生成最小预览和标准预览,因此程序可以根据需要使用这三类预览。由于要处理这么多的数据,因此 1:1 预览可能需要大量时间才能创建。无论您何时在“图库”模块中缩放到 1:1 或更高比例,Lightroom 都将使用 1:1 预览。

若要显示和处理照片,Lightroom 需要使用标准预览或 1:1 预览,具体依任务而定。如果导入时只让 Lightroom 生成最小预览或嵌入预览,则在使用 Lightroom 时,该应用程序会自动创建标准预览和 1:1 预览。此过程会影响性能。若要提高工作效率并减少这种干扰,应管理渲染 1:1 预览的时间和方式。可在导入时渲染,或留出时间进行手动渲染。

若要在导入时渲染 1:1 预览,请使用导入窗口的“文件处理”面板。选择“渲染预览”>“1:1”。尽管导入时生成高品质的 1:1 预览会减慢导入过程,但当您开始在“图库”模块中工作时,这可以提高 Lightroom 的响应速度。

如果要加快导入过程,另一种可选用的方法是,在导入时渲染最小预览或标准预览。然后,可以随时在“图库”模块的“网格”视图中选择多张照片,并选择“图库”>“预览”>“渲染 1:1 预览”。在开始使用图像之前,可以先让 Lightroom 处理图像。

尽可能保持较小的标准预览

由于渲染标准预览本身需要花费一些时间,因此切勿再加重 Lightroom 的运行负荷。保持较小的标准预览还有助于减小预览文件缓存的大小,从而可以提高性能和节省硬盘空间。

若要减小标准预览的大小,请在“目录设置”对话框中指定相应的大小和品质:

  1. 选择“编辑”>“目录设置”(Windows) 或“Lightroom”>“目录设置”(Mac OS),然后选择“文件处理”。

  2. 对于“标准预览大小”,选择与屏幕分辨率的最长边缘最接近,但不短于该边缘的选项。例如,如果您的屏幕分辨率为 1920 x 1200 像素,则选择“标准预览大小”>“2048 像素”。

  3. 对于“预览品质”,选择“低”或“中”,这相当于低等或中等品质标准的 JPEG 文件。

注意:

如果使用的显示器较大(且分辨率较高),则在进行调整时,Lightroom 需要完成更多的工作来计算预览和更新像素。如果在使用大显示器时出现性能降低问题,请尝试使用“显示控制面板”(Windows) 或“显示器系统偏好设置”(Mac OS) 降低显示器的分辨率。 

尽可能长时间保留 1:1 预览

由于 1:1 预览可能会快速耗尽磁盘空间,因此 Lightroom 提供了定期(每天、每周或每月)放弃预览的选项。每次放弃预览后,下次需要时,Lightroom 必须重新创建预览,即便只是放大到“放大”视图,也需要重新创建预览。

只要磁盘空间允许,应尽可能长时间保留 1:1 预览以优化性能。在“目录设置”对话框的“文件处理”区域中,选择“自动放弃 1:1 预览”>“30 天后”或“从不”。

但请注意,如果将删除预览的选项设置为“从不”或“30 天后”,则包含预览的文件 [目录名称] Previews.lrdata 可能会变得很大。该文件与目录文件位于同一位置。如果将此选项设置为“从不”,并且出现硬盘空间不足问题,可检查该文件的大小。如果太大,请将其删除。

保持目录和预览缓存位于同一个文件夹中

默认情况下,Lightroom 会将预览缓存文件 [目录名称] Previews.lrdata 存放在目录文件 [目录名称].lrcat 所在的文件夹中。如果移动目录文件或将其与缓存分开存储,则 Lightroom 必须重新生成预览。因此,请将它们存放在一起。

有关目录、预览和其他 Lightroom 文件的默认位置,请参阅首选项文件和其他文件的位置

保持自动写入 XMP 处于关闭状态

默认情况下,您在 Lightroom 对文件所作的更改(例如添加关键字或修复红眼)随照片一起存储在 Lightroom 目录中。但是,为了使其他应用程序(例如 Adobe Bridge 和 Camera Raw)可以识别这些编辑,应将它们作为 XMP(可扩展元数据平台)数据进行保存。此数据是图像文件的附属内容。

在 Lightroom 中,可以自动或手动将编辑保存到 XMP。如果您经常在 Lightroom、Adobe Bridge 和 Camera Raw 之间切换,则最便捷的做法是自动将更改保存到 XMP。这样,您就不必考虑它了。应用程序始终保持同步,始终反映最新的 Lightroom 编辑,并且您不会在 Bridge 或 Lightroom 中看到元数据不匹配图标或徽章。

然而,自动保存更改可能会显著降低 Lightroom 的性能。如果您未使用多个应用程序,请考虑关闭自动写入首选项。更改仍保存在目录中,并且当您从 Lightroom 打印或导出照片时,更改将在输出中显示。

要关闭自动写入 XMP,请执行以下操作:

  1. 选择“编辑”>“目录设置”(Windows) 或“Lightroom”>“目录设置”(Mac OS)。

  2. 单击“元数据”选项卡,取消选择“将更改自动写入 XMP 中”。

即使关闭了自动写入 XMP,您仍可以随时手动将元数据更改保存到各个文件。有关更多信息,请参阅元数据基础知识和操作

优化目录

Lightroom 会不断将更改写入目录文件 (.lrcat) 中。性能降低时,可以选择“文件”>“优化目录”来优化 Lightroom 目录。优化目录将指示 Lightroom 检查目录的数据结构,并确保该结构简洁。

若要进一步优化性能并提高目录稳定性,请在退出 Lightroom 并备份目录时,选择“在备份之前测试完整性”和“备份后优化目录”选项。虽然这两个过程需要花费一些时间,但可以确保目录顺利运行。 

增加 Camera Raw 缓存大小

每次在“修改照片”模块中查看或编辑 Raw 图像时,Lightroom 都会生成最新的高品质预览。它使用原始图像数据作为基础,然后针对应用的任何处理或调整更新预览。如果原始图像数据位于 Camera Raw 缓存中,则此过程会稍微快些。Lightroom 会检查原始图像数据的缓存,如果图像数据已缓存,则会跳过初期处理。

默认情况下,Lightroom 将 Camera Raw 缓存设置为 1 GB。如果增加缓存大小,则可以存储更多图像数据,转而加速这些图像的预览生成。一些 Lightroom 用户发现,将 Camera Raw 缓存增加至 20 GB 或更大,可以大幅提高“修改照片”模块的性能。若要增加 Camera Raw 缓存大小,请执行以下操作:

  1. 选择“Lightroom”>“首选项”(Mac OS),或“编辑”>“首选项”(Windows)。

  2. 单击“文件处理”选项卡。

  3. 在“Camera Raw 缓存设置”区域中,尝试将“最大大小”设置为 10.0 GB 或更大。

若要进一步加快缓存速度,请将其置于快速硬盘上。若要指定 Camera Raw 缓存的位置,请执行以下操作:

  1. 选择“Lightroom”>“首选项”(Mac OS),或“编辑”>“首选项”(Windows)。

  2. 单击“文件处理”选项卡。

  3. 在“Camera Raw 缓存设置”区域中,单击“选择”,然后导航到要存储缓存的位置。

污点去除工具、局部校正和历史记录面板

“污点去除工具”和“局部校正画笔”本身并不适合用来执行成百上千的校正。如果您的图像包含许多(数百个)局部调整,请考虑使用基于像素的编辑应用程序(如 Photoshop)来进行此级别的校正。

如果您要进行的校正太多,请检查您的“历史记录”面板。“历史记录”面板没有任何限制,并且它不会被删除,除非另有指示。如果您创建了许多局部或污点校正,则您的历史记录可能会很长,以至于从整体上减慢了 Lightroom 的性能。

通过单击“历史记录”面板标题右侧的 X,清除“历史记录”面板。

修改照片操作的顺序

可提升性能的修改照片操作的最佳顺序如下所示:

  1. 污点修复。
  2. 类似于镜头校正配置文件和手动校正之类的几何校正,包括使用垂直滑块的梯形校正。
  3. 全局非细节校正,如曝光度和白平衡。必要时,也可首先完成这些校正。
  4. 局部校正,如渐变滤镜和调整画笔描边。
  5. 细节校正,如减少杂色和锐化。

注意:执行污点修复首先会提高污点修复的准确度,并且可以确保已修复区域的边界与污点位置匹配。

避免不需要的校正

此建议尤其适用于局部校正。您在应用局部矫正时更改的每个滑块或渐变滤镜适用于整个校正。而且每个选项均占用一定资源并会影响性能。

在应用局部校正和渐变时,请确保您需要已选择的所有校正。

如果不需要画笔描边或渐变来执行特定类型的校正,请将其滑块设置为零。

还要避免使用非必要的全局校正,特别是占用资源的选项,例如减少杂色、锐化和镜头校正。

某些滑块具有默认值且在默认情况下处于打开状态。对于更耗费资源的选项,值为零可禁用该滑块。

缩放选项

如果“调整和填充”缩放选项速度较慢,请尝试在“导航器”面板中使用 1:2、1:3 或 1:4 选项。

要使用哪个进程版本

进程版本 2012 要占用比进程版本 2010 更多的资源,因此在某些情况下,它的速度更慢。但是,有必要通过进程版本 2012 所具备的编辑和图像质量对性能增益进行平衡。

删除 Lightroom 预览缓存

虽然仅在极少数情况下会发生以下一个或多个问题,但如果它们发生,您可能需要删除预览缓存文件:

  • 您的硬盘被意外占满。
  • Lightroom 中出现了一个与您的缓存有关的错误。
  • 您的图像中存在伪影(如线条、点或意外的颜色区域)。

包含缩略图和预览数据的文件被命名为 [目录名称] Previews.lrdata,并和您的目录位于同一个文件夹中。

缩略图、小型预览和 1:1(完全大小)预览全都保存在此 Previews.lrdata 文件中。通过 Lightroom 的首选项可以选择在何时删除最大的预览(即 1:1 预览)。在删除 1:1 预览后,Previews.lrdata 文件的大小会减小。如果没有删除 1:1 预览,则预览文件可能会变得非常大。 

确定何时删除大型 1:1 预览的默认设置为一周。当这些大的预览被删除时,预览文件的大小会减小,但并未删除整个文件,除非您手动删除它。文件没有变得很大,除非您极少或从不删除 1:1 预览,但它是否会影响您的硬盘则取决于您可用的硬盘空间大小。通过选择编辑 > 目录设置 > 文件处理 (Windows),或 Lightroom > 目录设置 > 文件处理 (Mac OS),可更改 1:1 预览被删除的频率。

注意:请不要将此技术说明中讨论的 Previews.lrdata 文件与 [目录名称] Smart Previews.lrdata 文件相混淆,后者包含您所有的智能预览。在硬盘空间极为有限的情况下,您可能需要删除此文件,但是如果您的硬盘空间太小以至于您收到了硬盘空间不足的错误,那么就应当清空您的废纸篓,将某些文件存档,并且/或者重新整理您的数据,以便腾出更多的可用硬盘空间。

如果删除 Previews.lrdata 文件,会为您在 Lightroom 中打开的每个文件夹或收藏夹重新创建预览,因此,当您首次在文件夹中工作时,将在重新创建预览的时候遇到一些延迟。

如果“自动弃用 1:1 预览”的选项设置为“从未”或“30 天后”,则您的预览文件可能会变得非常巨大。它可能占用许多 GB 的空间。如果您的硬盘突然被占满,请检查此文件的大小。您随后可以删除该文件。 

您可能会在 Lightroom 中遇到一个错误指示缓存存在问题;此时您也会希望删除 previews.lrdata 文件。

如果图像显示存在伪像,例如有颜色的线条、有颜色的点或有意外颜色的区域,则您的预览文件可能已损坏,修复此问题的唯一方法是删除 previews.lrdata 文件。 

请注意,如果在您存档的图像目录中包含图像预览,那么这些预览也会丢失。 

如果删除 Previews.lrdata 文件并未解决您的问题,请尝试清除 Camera Raw 缓存文件。 

  1. 在 Lightroom 中,选择编辑 > 首选项 > 文件处理 (Windows),或 Lightroom > 首选项 > 文件处理 (Mac OS)。
  2. 单击“Camera Raw 缓存设置”下方的清除缓存

通过单击选择,也可更改此缓存的位置。请注意,此缓存仅可由“修改照片”模块使用。 

减小预设量

将预设添加到 Lightroom(无论是由您还是第三方创建)可降低性能,因为“修改照片”模块会在“导航器”面板中为每个预设生成缩略图。当您拥有 2000 个或更多个预设时,这会非常壮观。将载入 Lightroom 的预设数量减少到您最常使用的那些预设,以避免此类速度减慢。

执行常规系统维护

保持 Lightroom 为最新

更新不仅会修复错误,还可提高性能。请确保您运行的是最新更新的 Lightroom 版本。可选择“帮助”>“检查更新”。

关闭不必要的应用程序和启动项

其他打开的应用程序和启动项会减少 Lightroom 可用的内存量。请退出不必要的应用程序、启动项和扩展,以便为 Lightroom 提供更多可用内存。

在使用 Lightroom 时,还请暂时禁用执行实时扫描或自动备份的防病毒或安全软件。有关停用防病毒或安全软件功能的说明,请参阅防病毒或安全软件的文档。

运行磁盘清理 (Windows)

在使用某个应用程序时,Windows 会在硬盘驱动器上存储数据文件的临时副本。许多应用程序会创建 .tmp 文件,然后在退出应用程序时将其删除。但是,崩溃或系统错误可能会阻止应用程序删除这些文件,从而使这些文件占用磁盘空间并产生问题。时常运行“磁盘清理”可删除临时文件和其他未使用的文件。

  1. Windows:选取“开始”,在“搜索”文本框中键入“磁盘清理”,然后从“程序”列表中选择“磁盘清理”。

  2. 选择要清理的相应驱动器。

  3. 选择临时文件和其他要删除的文件。

  4. 单击“确定”。

对硬盘进行碎片整理

随着您在硬盘上添加、删除和移动文件,硬盘的可用空间将不再是单一的连续数据块。如果系统没有足够的连续空间,则会将文件片段存储到硬盘驱动器上的不同位置。与读写那些存储在连续位置中的文件相比,Lightroom 需要花费更多的时间来读写存储在碎片位置中的文件。

在对硬盘进行碎片整理时,请务必选择用于修复驱动器错误和恢复坏扇区的选项。有关在 Windows 中对硬盘进行碎片整理的说明,请参阅下面的 Microsoft 帮助主题:

一般来说,Mac OS 硬盘不需要进行碎片整理。Mac OS X 会自动对小文件进行碎片整理。若要执行更加可靠的碎片整理或解决 Mac OS 中的硬盘问题,请使用 Apple 磁盘工具。或者,使用第三方实用程序,如 Micromat Tech Tool Pro。请参阅 Apple 支持网站上的关于 Mac OS X 的磁盘优化

安装最新操作系统更新

利用 Windows 或 macOS 操作系统中的各种更新,可以改善其性能以及与应用程序的兼容性。

请从 Microsoft 网站获取 Windows Service Pack 和其他更新。要获取有关安装 Service Pack 和其他更新的帮助,请联系 Microsoft 技术支持。

若要获取 Mac OS X 更新,请从 Apple 菜单选择“软件更新”。有关安装更新的帮助,请与 Apple 技术支持部门联系。

注意:

在安装系统更新之前,请查看 Adobe 软件的系统要求以确保兼容性。(还请检查与 Adobe 软件一起使用的所有第三方软件或硬件。)如果未列出更新,请与 Adobe 或者第三方软件或硬件的制造商联系。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略