学习在复杂背景中删除头发的高级技巧。

您需要什么

此样本文件包含 Adobe Stock 资产,可用于练习本教程所学内容。若要将此样本文件用于本教程练习以外的其他用途,请至 Adobe Stock 购买许可。请仔细阅读文件夹中的说明文件 (ReadMe),了解此样本文件的使用条款。

所学内容:对头发使用蒙版,以及使用其他图片中的头发绘制头发

选择要编辑的人

  • 打开一个人的图片,选择包含这个人的图层,即肖像图层。
  • 在“Properties”(属性)面板中找到“Quick Actions”(快速操作),点击“Remove Background”(移除背景)。将自动创建一个图层蒙版,隐藏这个人周围的背景。
  • 或者,可以通过“Select”(选择)>“Subject”(对象)或“Quick Selection”(快速选择)工具来选择这个人,然后点击“Layers”(图层)面板底部的“Add Layer Mask”(添加图层蒙版)按钮,为所选对象制作一个蒙版。

精细调整图层蒙版

  1. 选中肖像图层上的图层蒙版缩略图,然后点击“Select”(选择)>“Select and Mask”(选择并使用蒙版)。
  2. 在“Select and Mask”(选择并使用蒙版)工作区中,使用滑块微调图层蒙版的边缘。选择“View Mode”(视图模式)>“On Black”(黑色)。然后向右滑动“Smooth”(平滑度)滑块,最大程度降低蒙版边缘的粗糙度。
  3. 向右拖动“Feather”(羽化度)滑块,柔化蒙版边缘。
  4. 选择“Output To”(输出至)>“Layer Mask”(图层蒙版),然后点击“OK”(确定)。
  5. 返回“Select and Mask”(选择并使用蒙版)工作区,对头发使用蒙版。再次点击“Select and Mask”(选择并使用蒙版)按钮。
  6. 选择“Refine Edge”(优化边缘)笔刷工具,涂刷头发边缘。
  7. 向右拖动“Shift Edge”(边缘漂移)滑块,使蒙版边缘向内移动并隐藏瑕疵。  
  8. 点击“OK”(确定)关闭“Select and Mask”(选择并使用蒙版)工作区。如果蒙版并不完美也不必担心。可以通过绘制数字头发让头发看起来更加真实。

创建自定义头发笔刷

有时候可以使用来自其他图片的头发创建自定义头发笔刷,获得更好的效果。找一张纯色背景,且头发与背景对比度较高的图片。然后始终这张图片中的头发创建一个自定义笔刷。

  1. 使用裁剪工具,对图片中的头发进行裁剪,只留下你希望制成笔刷的区域。
  2. 选择“Image”(图像)>“Adjustments”(调整)>“Desaturate”(降低饱和度)去除颜色。
  3. 选择“Image”(图像)>“Adjustments”(调整)>“Levels”(水平),拖动“Input Levels”(输入水平)滑块,使背景变为白色,头发变为黑色。
  4. 选择减淡工具,将“Range”(范围)设置为“Highlights”(高光),涂刷背景中的所有灰色区域,使其变为白色。
  5. 选择加深工具,将“Range”(范围)设置为“Shadows”(阴影),涂刷头发,使其颜色更深。
  6. 选择“Edit”(编辑)>“Define Brush Preset”(定义笔刷预设),将黑白色的头发图片制成笔刷。

使用新的自定义笔刷绘制数字头发

  1. 返回原始的肖像图片,点击“Create New Layer”(创建新图层)按钮创建一个新图层。
  2. 将新图层拖动到肖像图层下方。
  3. 当笔刷工具处于活动状态时,按下 Alt(Windows)或 Option(MacOS)临时切换到滴管工具。点击头发对头发的颜色进行取样。
  4. 使用键盘上的左右括号键 ([ ]) 改变头发笔刷的大小,使其与肖像图片匹配。
  5. 单击鼠标将头发绘制到新的图层上。
  6. 按下 Control+T(Windows)或 Command+T(MacOS)改变头发形状,使其与图片更相配。
  7. 重复此过程,直到你满意为止。

小技巧:对于你绘制的头发不要只使用一种颜色。应尽可能多地使用与对象的头发颜色类似的颜色,以创造更加真实的效果。

07/13/2020

Adobe Stock 教程作者:alonesdjblackday

演示者:Jesus Ramirez

此页面是否有帮助?