本文档介绍如何安装并使用辅助 OpenEXR Alpha 增效工具。

辅助 OpenEXR Alpha 增效工具提供了另一种在打开 OpenEXR 文件时处理“A”通道数据的备用方法。OpenEXR Alpha 并不像旧版 OpenEXR 增效工具那样直接将“A”通道数据转换为透明度,而是打开“A”通道数据将其作为一个 alpha 通道。

背景

Photoshop CS2 在 32 位模式下通常不支持透明度。在此版本中,实施了一个解决方法,允许您将透明度数据读入 alpha 通道。在 Photoshop CS3 中,实施了对 32 位模式的透明度支持,以确保与 OpenEXR 规格兼容。因此在直通道合成过程中,透明度不再被读入 alpha 通道。

准备事项

安装 OpenEXR Alpha 增效工具要求具有本地管理员权限。如果您使用 Mac OS、Windows Vista 或 Windows 7,操作系统会提示您输入管理员用户帐户的名称和密码。如果使用 Windows XP,请在开始之前使用本地管理员帐户登录到您的计算机。

Windows 用户:此技术说明中的某些步骤按完整的文件名列出文件,其中包括文件扩展名(例如 OpenEXR Alpha.8bi)。在 Windows 中,已知文件类型的文件扩展名在默认情况下不可见。要使文件扩展名可见,请执行以下操作:

  1. 在 Windows 资源管理器中,选择“工具”>“文件夹选项”(Windows XP),或“组织”>“文件夹和搜索选项”(Windows 7 和 Vista)。
  2. 选择“文件夹选项”窗口顶部附近的“查看”选项卡。
  3. 在“查看”选项卡的“高级设置”区域中,取消选中“隐藏已知文件类型的扩展名”。
  4. 单击“确定”。

Windows 用户:此文档中的某些步骤需要您确定您使用的是 32 位还是 64 位版本的 Windows。要确定您拥有哪种系统类型,请参阅确定您的计算机运行的是 32 位还是 64 位版本的 Windows

兼容性

在 Windows 中,OpenEXR Alpha 增效工具与早于 Photoshop CS5 的 Photoshop 版本不兼容。它不会在 Photoshop CS3 或 CS4 中加载。

在 Mac OS 中,OpenEXR Alpha 增效工具不会在 PPC 计算机上加载。

在 Mac 或 Windows 中,安装适用于 Photoshop CS5 的 OpenEXR Alpha 增效工具(从 Adobe 网站下载更新)

要通过从 Adobe 网站下载更新来安装 OpenEXR Alpha 增效工具,请执行以下步骤:

  1. 下载压缩打包的增效工具:

  2. 退出 Photoshop CS5。
  3. 解压缩下载的文件。
  4. 将增效工具拖到 Photoshop 增效工具文件夹中。
    • Windows 32 位:将 OpenEXR Alpha.8bi 从 Win32 文件夹拖到 /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 文件夹。
    • Windows 64 位/Photoshop 64 位:将 OpenEXR Alpha.8bi 从 Win64 文件夹拖到 /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 文件夹。
    • Windows 64 位/Photoshop 32 位:将 OpenEXR Alpha.8bi 从 Win32 文件夹拖到 /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats 文件夹。
    • Mac OS:将 OpenEXR.plugin 拖到 /Applications/Adobe Photoshop CS5/Plug-ins/File Formats 文件夹。
  5. 启动 Photoshop CS5。

使用 OpenEXR Alpha 增效工具

要打开 EXR 文件,请执行以下操作:

  1. 启动 Photoshop CS5。
  2. 选择“文件”>“打开”。
  3. 浏览到要打开的 EXR 文件。在文件格式列表中,选择 OpenEXR Alpha。Photoshop 将“A”通道数据视为一个 alpha 通道,而不是透明度。

要导出 EXR 文件,请执行以下操作:

  1. 选择“文件”>“另存为”。
  2. 在文件格式列表中,选择 OpenEXR Alpha。

  3. 选择“存储: Alpha 通道”选项。此设置可保留 alpha 通道数据。

注意:在打开文件后添加的透明度将被拼合。

注意:即使在安装了 OpenEXR Alpha 增效工具之后,您仍然可以在文件格式列表中选择原有的 OpenEXR。此增效工具仍将“A”通道中的数据作为透明度处理。此行为自 Photoshop CS3(版本 10.0)起便是 Photoshop 中的默认行为。

附加备注

使用辅助增效工具时其他值得一提的行为还包括:

  • 不支持预先进行正片叠底合成。
  • 如果您双击某文件将其打开,Photoshop CS5 将始终使用 OpenEXR Alpha 而不是 OpenEXR。
  • 如果您打开具有两个或更多 alpha 通道的文件,OpenEXR Alpha 不会保留任何 alpha 通道。它们将被完全丢弃。
  • (Mac OS):在“存储”对话框中,OpenEXR Alpha 是第一个项。而不是按照字母顺序挨着 Open EXR 显示。
  • (Windows):要获取旧的 OpenEXR 行为,请选择“文件”>“打开为”,然后选择 OpenEXR。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略