注意:

在 Photoshop CS6 中,与 MATLAB 相关的功能是 Photoshop Extended 的一部分。以前提供的 Photoshop Extended 中的所有功能现在是 Photoshop CC 的一部分。Photoshop CC 不提供单独的 Extended 版本。

关于 Photoshop 和 MATLAB

MATLAB 是一种用于算法开发、数据可视化、数据分析和数字计算的高级技术计算语言和交互环境。通过使用 Photoshop,您可以在 Photoshop 中查看 MATLAB 图像处理结果,并将 MATLAB 命令与 Photoshop 的图像编辑功能组合在一起。

从 MATLAB 连接到 Photoshop 之后,在 MATLAB 命令提示符处键入命令就可以在 Photoshop 中执行各种操作。可以运行 MATLAB 算法并在 Photoshop 中查看图像的结果。

注意:

Photoshop 和 MATLAB 之间的通信使用 Photoshop JavaScript 接口和 MATLAB 库接口。

设置 MATLAB 和 Photoshop

在计算机上安装 Photoshop 和 MATLAB。在安装 Photoshop 和 MATLAB 之后,应验证 MATLAB 集成。

对于 64 位系统,安装相应的编译器

要在 64 位系统上使用 Photoshop 界面,必须安装 C 编译器:

  • 在 Windows 中,安装 Microsoft Developer Studio。

  • 在 Mac OS 中,安装 Xcode。

有关更多信息,请参阅 Photoshop 应用程序文件夹中的 MATLAB Photoshop 自述文件。

注意:

在 Windows 中,将 64 位 Photoshop 与 64 位 MATLAB 一起使用,将 32 位 Photoshop 与 32 位 MATLAB 一起使用。

验证 MATLAB 集成

  1. 依次启动 Photoshop 和 MATLAB。

  2. 从 MATLAB 中添加路径 Photoshop/MATLAB(包括子文件夹)。
  3. 在 MATLAB 提示符下,打开 MATLAB 文件夹,定位到并打开 Tests 文件夹,然后键入 testall
  4. Photoshop 和 MATLAB 会运行一系列测试以确保在两个程序之间的集成,并显示摘要报告。

(可选)从 MATLAB 设置对 Photoshop 的访问

可以设置 Photoshop 的路径以允许从 MATLAB 直接访问 Photoshop 命令。

  1. 从 MATLAB 中选择“File”>“Set Path”。
  2. 单击“Add Folder”,然后选择安装 Photoshop 的 MATLAB 文件夹。

  3. 单击“存储”,然后单击“关闭”。
  4. 从 MATLAB 菜单中选取“File”>“Preferences”。
  5. 在“首选项”对话框中,单击“常规”树(左上方)。
  6. 单击“Update Toolbox Path Cache”按钮。
  7. 单击“Apply”,然后单击“OK”。

从 MATLAB 连接到 Photoshop 或取消与 Photoshop 的连接

  1. 在 MATLAB 中,执行下列操作之一:
    • 要启动 Photoshop 或连接到 Photoshop,请键入 pslaunch,然后按 Enter 键 (Windows) 或 Return 键 (Mac OS)。

    • 要取消与 Photoshop 的连接并退出,请键入 psquit 并按 Enter 键 (Windows) 或 Return 键 (Mac OS)。

使用 MATLAB 帮助

MATLAB 的帮助系统包含一些 MATLAB/Photoshop 工作流程的示例。

  1. 选取“Help”>“Full Product Family Help”。

    您会看到带有子菜单项的 Photoshop 工具箱,其中包括可帮助您快速入门的示例。如果无法看到 Photoshop 工具箱,请尝试下列步骤。

  2. 单击“Start”按钮。
  3. 选取“Desktop Tools”>“View Source Files”。
  4. 单击“Refresh Start”按钮,单击“Close”,然后重试“Help”菜单。

MATLAB 命令

通过在 MATLAB 命令行中键入命令,可以连接到 Photoshop 或取消与 Photoshop 的连接,以及生成可在 Photoshop 文档中查看的像素。

有关所有 MATLAB Photoshop 命令的列表,请浏览安装 Photoshop 的目录下的 MATLAB 文件夹中的 psfunctionscat.html 文件。在 MATLAB 命令提示符下输入 help(命令名称)可获得有关每条命令的更全面的描述,包括语法、参数和示例。

注意:

所有 MATLAB 命令都支持日文字符。用于 Windows 的 MATLAB 在日文 Windows XP 系统上支持日文用户界面。用于 Mac OS 的 MATLAB 在日文 Mac OS 系统上仅支持美国英语。有关更多信息,请与 The MathWorks, Inc. 联系。

在 MATLAB 中创建文档

  1. 在 MATLAB 中,输入 psnewdoc
  2. 要指定新文档的属性,请输入下列内容之一:
    • 要使用默认值创建文档,请输入 psnewdoc()。有关默认值的信息,请参阅以下内容。

    • 要创建具有特定宽度和高度的文档,请输入 psnewdoc(W,H)。W 值和 H 值使用 Photoshop 中的“首选项”对话框的“单位与标尺”选项中设置的当前单位。其它文档属性将设置为其默认值。

    注意:

    输入字符串“undefined”可跳过输入参数。新文档的默认大小是 504 x 360 像素。  

    • 要创建文档并指定属性,请输入 psnewdoc(W,H,R,N,M,F,A,B,P)。有关新文档属性的信息,请参阅以下内容。

    以下代码是用于在 MATLAB 中创建文档并指定所有属性的示例代码:

    psnewdoc(10, 10, 72, 'hi', 'cmyk', 'transparent', 2.5, 16, 'U.S. Web Coated (SWOP) v2')

新文档属性和默认值

输入 psnewdoc(W,H,R,N,M,F,A,B,P) 将使用下列属性的值创建文档:

W

使用 Photoshop 中的“首选项”对话框的“单位与标尺”选项中的当前单位指定文档的宽度。默认宽度为 504 像素。

H

使用 Photoshop 中的“首选项”对话框的“单位与标尺”面板中的当前单位指定文档的高度。默认高度为 360。

R

指定分辨率。默认值为 72 ppi。

N

指定文档名称。默认值为“未标题-X”,其中 X 是新文档的索引。

M

指定颜色模式:RGB、CMYK、Lab、位图或灰度。默认值为 RGB。

F

指定新文档的背景内容:白色、背景色或透明。默认值为白色。

A

指定像素长宽比。默认值为 1.0(方形)。

B

指定位深度:1、8、16 或 32。默认值为 8。

P

指定颜色配置文件。默认值为指定颜色模式的工作颜色空间。工作空间在 Photoshop 的“颜色设置”对话框中指定。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略