可用于 Adobe Photoshop CC 的安全更新

发布日期:2017 年 4 月 11 日

漏洞标识符:APSB17-12

优先级:3

CVE 编号:CVE-2017-3004、CVE-2017-3005

平台:Windows 和 Macintosh

摘要

Adobe 已发布适用于 Windows 和 Macintosh 的 Photoshop CC 更新。这些更新解决了在解析恶意 PCX 文件时可能导致代码
执行的关键内存损坏漏洞 (CVE-2017-3004)。这些更新还解决了 Windows 版 Photoshop
中的不带引号的搜索路径漏洞 (CVE-2017-3005)。

受影响的软件版本

产品 受影响的版本 平台
Adobe Photoshop CC 2017 18.0.1 及更早版本 Windows 和 Macintosh
Adobe Photoshop CC 2015.5 17.0.1 (2015.5.1) 及更早版本 Windows 和 Macintosh

解决方案

Adobe 建议用户通过每个应用程序的更新机制更新其软件安装,具体方法为:启动每个应用程序,导航至“帮助”菜单,然后单击“更新”。有关详细信息,请参阅此帮助页面

产品 更新后的版本 平台 优先级
Adobe Photoshop CC 2017 18.1 Windows 和 Macintosh 3
Adobe Photoshop CC 2015.5 17.0.2 (2015.5.2) Windows 和 Macintosh 3

对于托管环境,IT 管理员可以使用 Creative Cloud Packager 创建部署包。有关 Creative Cloud Packager 的详细信息,请参阅此帮助页面

漏洞详情

  • 这些更新解决了在解析恶意 PCX 文件时可能导致代码执行的内存损坏漏洞 (CVE-2017-3004)。
  • 这些更新解决了 Windows 版 Photoshop 中的不带引号的搜索路径漏洞 (CVE-2017-3005)。

鸣谢

Adobe 衷心感谢以下个人和组织,感谢他们报告相关问题并与 Adobe 一起帮助保护我们的客户:

  • 来自 Fortinet FortiGuard 实验室的 Kushal Arvind Shah (CVE-2017-3004)
  • Cyril Vallicari / HTTPCS – Ziwit (CVE-2017-3005)