问题

在打开任何 Adobe 应用程序时,出现“您需要安装旧版 Java SE 6 运行时”错误。

Legacy Java error

解决方案

在 Mac OS 10.7 (Lion) 及更高版本中,Java 运行时不再作为操作系统安装的一部分自动进行安装。请按照以下任意方法安装 Java 运行时。

方法 1

您可以从 Java 网站下载并安装最新的 Java 运行时 - 下载免费的 Java 软件

注意:

在 Mac OS 10.10 (Yosemite) 上,当安装任意 Adobe 产品时,您可能会收到以下警告:“应用程序已移动,并且其路径已更改...”。

单击立即修复更新按钮可更新位置并解决问题。当提示输入密码时,请输入您的系统密码以完成操作。

“应用程序已移动”警告消息

方法 2

如果未安装 Java 运行时,当您首次启动任何 Adobe 产品时,系统会提示您进行安装。请按照“需要 Java”通知对话框中的屏幕说明进行安装。

方法 3(Mac OS 10.7 和 10.8)

使用以下方法启动 Java 运行时安装或确认其是否已安装。

  1. 转到“应用程序”>“实用工具”>“Java 偏好设置”。
  2. 打开“Java 偏好设置”。
  3. 如果未安装 Java,您会收到以下消息:“要打开‘Java 偏好设置’,您需要 Java 运行时。是否要立即安装?”

    “未安装 Java”消息
  4. 单击“安装”并接受许可协议。此时会下载并安装 Java 运行时。
    Java 下载进度
    “Java 偏好设置”显示已安装 Java 运行时

其他信息

许多 Adobe 应用程序依赖于 Oracle Java 运行时环境 (JRE),才能使用某些功能。Apple 最近更改了在 Mac OS 中包含 Java 的方式;在 Lion 中,不再预安装 Java。它现在而是一个必须选择的可选安装选项。 

由于当前的 Adobe 安装程序和应用程序都是在 Apple 做出这些更改之前构建的,因此 Adobe 软件期望安装 Java。Adobe 和 Apple 已开始协同工作来确保您可以在安装操作系统时安装 Java。或者,可以稍后在安装 Adobe 应用程序之前进行安装。在运行时,当您启动 Adobe 应用程序时,如果尚未安装 Java,系统会提示您进行安装。如果在运行 Adobe 应用程序之前未安装 Java,某些功能可能会缺失或其行为方式可能不正确。如果遇到任何问题,请安装 Java 来更正这些问题。Adobe 建议企业 IT 组织预先安装 Java(或确保可通过其防火墙/安全软件安装 Java),以避免与 Adobe 应用程序发生冲突。

如果未安装 Java 运行时,已知可能会出现下面一些问题:

  • 无法启动。
  • 尝试使用应用程序时提示安装 Java 运行时。
  • 应用程序挂起或退出。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略