Legal notices
# Contents

**Chapter 1: Introduction to Dreamweaver**
- Responsive web design basics ................................................................. 1
- What's new in Dreamweaver ................................................................. 1
- Web development using Dreamweaver - An Overview ............................. 2
- Dreamweaver / Common Questions ....................................................... 5
- Dreamweaver manual (PDF) ................................................................. 7
- Dreamweaver system requirements ...................................................... 7
- Feature summary .................................................................................. 9
- Dreamweaver system requirements | 2020 releases ................................ 23

**Chapter 2: Dreamweaver and Creative Cloud**
- Creative Cloud Libraries in Dreamweaver .......................................... 26
- Using Photoshop files in Dreamweaver ................................................. 33
- Work with Adobe Animate and Dreamweaver ....................................... 39
- Extract web-optimized SVG files from Libraries .................................. 40

**Chapter 3: Dreamweaver workspaces and views**
- The Dreamweaver workspace ............................................................. 43
- Optimize Dreamweaver workspace for visual development .................. 63
- Search files based on filename or content | Mac OS ............................... 65

**Chapter 4: Set up sites**
- About Dreamweaver sites .................................................................. 67
- Set up a local version of your site ....................................................... 69
- Set up a testing server ......................................................................... 72
- Import and export Dreamweaver site settings .................................... 76
- Bring existing websites from a remote server to your local site root ....... 78
- Accessibility features in Dreamweaver ............................................... 79
- Advanced settings ............................................................................. 82
- Set site preferences for transferring files .............................................. 84
- Specify proxy server settings in Dreamweaver .................................... 86
- Using Git in Dreamweaver ................................................................. 87

**Chapter 5: Manage files**
- Create and open files .......................................................................... 110
- Manage files and folders ...................................................................... 124
- Getting and putting files to and from your server ................................ 137
- Check in and check out files ............................................................... 141
- Synchronize files ................................................................................ 149
- Compare files for differences ............................................................. 151
- Cloak files and folders in your Dreamweaver site ................................. 154
- Enable Design Notes for Dreamweaver sites ...................................... 156
- Preventing potential Gatekeeper exploit ............................................ 159

Last updated 11/7/2019
Chapter 6: Layout and design

Use visual aids for layout .......................................................... 161
About using CSS to lay out your page ..................................... 164
Design responsive websites using Bootstrap ............................ 170
Creating and using media queries in Dreamweaver .................... 181
Present content with tables ....................................................... 185
Colors ....................................................................................... 200
Responsive design using fluid grid layouts ............................... 201
Extract in Dreamweaver .......................................................... 203

Chapter 7: CSS

Understand Cascading Style Sheets .......................................... 222
Laying out pages using CSS Designer ........................................ 226
Using CSS preprocessors in Dreamweaver ................................. 236
How to set CSS style preferences in Dreamweaver .................... 248
Move CSS rules in Dreamweaver .............................................. 249
Convert inline CSS to a CSS rule in Dreamweaver .................... 250
Work with div tags .................................................................. 250
Apply gradients to background ................................................ 252
Create and edit CSS3 transition effects in Dreamweaver .......... 254
Format code ............................................................................ 256

Chapter 8: Page content and assets

Set page properties ................................................................ 261
Set CSS heading properties and CSS link properties ................ 263
Work with text ........................................................................ 264
Find and replace text, tags, and attributes ................................. 268
DOM panel ............................................................................ 276
Edit in Live View .................................................................... 283
Encoding documents in Dreamweaver ...................................... 295
Select and view elements in the Document window .................. 295
Set text properties in the Property inspector ............................. 298
Spell check a web page ............................................................ 302
Using horizontal rules in Dreamweaver ..................................... 303
Add and modify font combinations in Dreamweaver ................. 304
Work with assets .................................................................... 307
Insert and update dates in Dreamweaver ................................. 313
Create and manage favorite assets in Dreamweaver ................. 314
Insert and edit images in Dreamweaver .................................... 316
Add media objects .................................................................. 328
Adding videos in Dreamweaver ............................................... 333
Insert HTML5 video ............................................................... 340
Insert SWF files ...................................................................... 342
Add audio effects .................................................................... 344
Insert HTML5 audio in Dreamweaver ...................................... 346
Work with library items ........................................................... 347
Using Arabic and Hebrew text in Dreamweaver ....................... 351
### Chapter 9: Linking and navigation

- About linking and navigation ....................................................... 352
- Linking ....................................................................................... 354
- Image maps ............................................................................... 361
- Troubleshoot links .................................................................... 363

### Chapter 10: jQuery widgets and effects

### Chapter 11: Coding websites

- About coding in Dreamweaver .................................................... 366
- Coding environment in Dreamweaver ......................................... 370
- Set coding preferences ............................................................... 375
- Customize code coloring .......................................................... 381
- Write and edit code ................................................................... 388
- Code hinting and code completion ............................................. 410
- Collapse and expand code ......................................................... 423
- Reuse code with snippets .......................................................... 426
- Optimize code .......................................................................... 432
- Edit code in Design view ........................................................... 436
- Work with head content for pages ............................................. 441
- Insert server-side includes in Dreamweaver ............................... 445
- Using tag libraries in Dreamweaver ........................................... 447
- Importing custom tags into Dreamweaver ................................. 449
- Use JavaScript behaviors (general instructions) ......................... 451
- Apply built-in JavaScript behaviors .......................................... 454
- About XML and XSLT ................................................................. 463
- Perform server-side XSL transformations in Dreamweaver ......... 470
- Performing client-side XSL transformations in Dreamweaver .... 487
- Add character entities for XSLT in Dreamweaver ....................... 489

### Chapter 12: Cross-product workflows

- Installing and using extensions to Dreamweaver ....................... 491
- In-App updates in Dreamweaver ................................................. 497
- Insert Microsoft Office documents in Dreamweaver (Windows only) .................................................. 500
- Working with Fireworks and Dreamweaver ............................... 501
- Edit content in Dreamweaver sites using Contribute .................. 506
- Dreamweaver-Business Catalyst integration .............................. 512
- Create personalized email campaigns ...................................... 514

### Chapter 13: Templates

- About Dreamweaver templates .................................................. 524
- Recognizing templates and template-based documents ............. 527
- Create a Dreamweaver template ................................................. 529
- Create editable regions in templates ........................................ 532
- Create repeating regions and tables in Dreamweaver ............... 534
- Use optional regions in templates ............................................. 536
- Define editable tag attributes in Dreamweaver ......................... 539
- How to create nested templates in Dreamweaver ....................... 540

---

Last updated 11/7/2019
Edit, update, and delete templates ................................................................. 543
Export and import xml content in Dreamweaver ........................................... 546
Apply or remove a template from an existing document ............................. 547
Edit content in Dreamweaver templates ....................................................... 549
Syntax rules for template tags in Dreamweaver .......................................... 551
Set highlighting preferences for template regions ....................................... 552
Benefits of using templates in Dreamweaver .............................................. 554

Chapter 14: Mobile and multiscreen
Create media queries .................................................................................. 555
Changing page orientation for mobile devices ............................................. 557
Create web apps for mobile devices using Dreamweaver ......................... 557

Chapter 15: Dynamic sites, pages and web forms
Understand web applications ...................................................................... 560
Set up your computer for application development .................................... 567
Troubleshoot database connections .......................................................... 572
Removing connection scripts in Dreamweaver .......................................... 577
Design dynamic pages ................................................................................ 578
Dynamic content sources overview ........................................................... 579
Define sources of dynamic content .......................................................... 584
Add dynamic content to pages .................................................................. 598
Changing dynamic content in Dreamweaver ............................................. 601
Display database records .......................................................................... 602
Provide and troubleshoot live data in Dreamweaver ................................. 611
Add custom server behaviors in Dreamweaver ......................................... 612
Building forms using Dreamweaver ............................................................ 622
Use forms to collect information from users .............................................. 623
Create and enable ColdFusion forms in Dreamweaver ........................... 626
Create web forms ...................................................................................... 637
Enhanced HTML5 support for form elements ........................................... 650
Develop a form using Dreamweaver .......................................................... 653

Chapter 16: Building applications visually
Build master and detail pages in Dreamweaver ........................................ 654
Build search and results pages .................................................................. 661
Build a record insert page .......................................................................... 666
Build an update record page in Dreamweaver ......................................... 669
Building record delete pages in Dreamweaver ......................................... 674
Use ASP commands to modify database in Dreamweaver ....................... 682
Build a registration page ........................................................................... 686
Build a login page ..................................................................................... 688
Build a page that only authorized users can access ................................... 690
Securing folders in Coldfusion using Dreamweaver ............................... 693
Using ColdFusion components in Dreamweaver .................................... 693
## Chapter 17: Test, preview, and publish websites

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preview pages</td>
<td>700</td>
</tr>
<tr>
<td>Preview Dreamweaver web pages on multiple devices</td>
<td>706</td>
</tr>
<tr>
<td>Test your Dreamweaver site</td>
<td>710</td>
</tr>
</tbody>
</table>
Chapter 1: Introduction to Dreamweaver

Responsive web design basics

Learn basic design techniques for displaying content on various devices – mobile, tablet and desktop – before writing the code in Dreamweaver.

1. Create mock-up designs in Adobe Photoshop CC before using Dreamweaver.
2. Use a design that easily adapts to different screen sizes.
3. Pay attention to the Menu and how images stack in different window sizes.

What's new in Dreamweaver

Seamless live view editing
Live view editing has been simplified
Japanese default font

Introducing a new default font in Japanese

Code hinting improvements

Code hints are now improved for better availability and accurate filtering logic

See detailed new feature summary

Previous releases of Dreamweaver

- Feature Summary | Dreamweaver | 2019 releases
- Feature Summary | Dreamweaver | October 2018 release
- Feature Summary | Dreamweaver | 2018 releases

Web development using Dreamweaver - An Overview

This article helps you understand how you can complete various stages or phases of web development using Dreamweaver.

Note:

This article assumes that you have a beginner to intermediate level of understanding of the web domain, and HTML, CSS, and JavaScript.

1 The first stage in web development is the planning phase in which you analyze the audience needs, technical, and marketing requirements. You also gather necessary information required for designing and publishing your website and have answers for questions like some of these:
   - Which service provider do I choose for hosting the website? Do I have access to upload files to the publishing server?
   - What domain name is to be used for the website?
• In case you are migrating existing websites into Dreamweaver, where are the files and assets stored currently? Do I have access to the server where this information is stored?
• If you want a dynamic website, which server can I use to test if data is being displayed dynamically? Do I have the details of the web application server that I want to use for loading dynamic data?
• What kind of assets are required for the website?
• Will these be assets designed from scratch? If the assets are already available, do I have access to them?
• What apps do I want to use for designing assets?
• Do I plan to create a responsive website?

Assuming that you have a clear understanding of the website you want to develop and how and where you want to host it, and have chosen Dreamweaver and Creative Cloud for the web development process, proceed to the next step.

2 Check if you have all the assets required for your website. Gather and organize them together in your local folders or in Adobe's Creative Cloud Libraries.

3 Create a new document in Dreamweaver using:
• A new blank document,
• Starter templates packaged with Dreamweaver, or
• Template files (*.dwt) created by someone else

Note:

If you are not familiar with Dreamweaver or just learning web development, starter templates are a great help in getting you up and running with designing web pages.

Even if you are planning to start from scratch, it is a good idea to peek a little into these pages to understand the elements of a good web page design.

4 Take a few minutes to familiarize yourself with the Dreamweaver workspace. Find a workspace you are comfortable with, and set a color theme. Reorganize the different panels in a way that suits you.

5 Set up your site in Dreamweaver. Set about creating a folder structure with files and assets. After you’ve organized your information and determined a structure, you can begin creating your site. (See About Dreamweaver sites.)

At this stage, it is a good idea to also set up connections to remote servers, and set up testing servers (if you have dynamic content).

6 Start coding your web pages in Code view, or designing them in Design / Live view.

If you plan to use Photoshop comps, you can extract them into Dreamweaver and work on them too. For more information on working with Photoshop comps, see Extract in Dreamweaver.

Add design elements such as text, images, rollover images, image maps, colors, movies, sound, HTML links, tables, and more.

7 Style the appearance of your web page using CSS. Using CSS preprocessors in Dreamweaver Coding environment in Dreamweaver

You can work with CSS in different ways in Dreamweaver:
• You can hand code the CSS. For information on Dreamweaver's coding features that help you hand code your CSS, see Coding environment in Dreamweaver.
• If you are not very familiar with creating CSS pages, you can use the CSS Designer panel to help build your CSS. For more information, see Laying out pages using CSS Designer.
• If you prefer to work with Sass and Less files, Dreamweaver supports that option as well, allowing you to bring in Sass and Less files into your Dreamweaver site, and work with them. Dreamweaver then autocompiles them (or you can choose to manually compile them) and see the results of your CSS changes in real time. For information on using Sass and Less files with Dreamweaver, see Using CSS preprocessors in Dreamweaver.

8 Set up a web application for creating dynamic content.
Many websites contain dynamic pages that allow visitors to view information stored in databases, and usually allow some visitors to add new information and edit information in the databases. To create such pages, you must first set up a web server and application server, create or modify a Dreamweaver site, and connect to a database. For more information, see Dynamic sites, pages and web forms.

9 Create dynamic pages.
In Dreamweaver, you can define a variety of sources of dynamic content, including recordsets extracted from databases, form parameters, and JavaBeans components. To add the dynamic content to a page, simply drag it on to the page.

You can set your page to display one record or many records at a time, display more than one page of records, add special links to move from one page of records to the next (and back), and create record counters to help users keep track of the records. For more information, see Dynamic sites, pages and web forms.

10 Test, preview, and publish your website.
As you create pages, you need to preview them to see that your website is progressing according to the design. You can code in Split view keeping your Code and Live views side-by-side.

You can also preview web pages in real time on a device (if you are creating responsive web pages), or on a browser. If you don’t need a live preview experience, you can use the regular preview in browser experience.

If you have already defined connections to remote servers, then to publish your website, you need to put your files in the remote server to make them live.
Dreamweaver / Common Questions

Basics

- **What is Dreamweaver and who is it for?**
  Adobe Dreamweaver is the world's most complete tool for web designers and front-end developers. It combines a powerful design surface and best-in-class code editor with robust site management tools, for you to easily design, code, and manage websites.

Dreamweaver 2017 has been redesigned with a modern interface and fast, flexible coding engine to give web designers and front-end developers easier ways to create, code and manage websites that look amazing on any size screen. This release of Adobe Dreamweaver 2017 includes an all-new code engine, completely refreshed user interface with selectable dark and light themes, support for modern web workflows such as CSS Preprocessors, and lots more.

First-class integration with Bootstrap lets you build responsive websites that adapt and scale to any browser, regardless of the size, screen resolution, or orientation. Deep integration with Adobe CreativeSync makes it easy to work with design assets from tools like Photoshop and Illustrator, along with the ability to browse and access stock photos from Adobe Stock.

As Dreamweaver is a part of Adobe's Creative Cloud, you get access to all the latest updates as soon as they're available. Learn more about [Creative Cloud](https://www.adobe.com/creativecloud).

- **What makes Dreamweaver different from other web tools?**
  Dreamweaver is a unique web development tool that lets you visualize your site in real-time as you are coding.

  - Code faster and with greater flexibility with Dreamweaver's new coding engine. Code hints help new users learn HTML, CSS, and other web standards, and visual aids like auto-indentation, code coloring, and resizable fonts help reduce errors and make your code easier to read.
  - Dreamweaver supports common CSS pre-processors like SASS, Less, and SCSS, with full code coloring, and compilation, so you can save time and produce cleaner code.
  - Write more than one line of code at a time to quickly do things like create a bulleted list, update a series of strings, and make multiple edits simultaneously.
  - Quick Edit offers an inline editor for the relevant CSS within an HTML file, so you can make changes fast.
  - Quick Docs saves you time by displaying relevant Web Platform Docs reference information for CSS properties directly within Code View.
  - Load and open files quickly and get through projects faster with a new performance-boosted and clutter-free workspace designed for developers.
  - Preview your page edits in real time as you code without having to manually refresh your browser.
  - Use Dreamweaver's FTP features to push your files on to a web server.

- **Where can I learn more about new features?**
  See the [What's New](https://www.adobe.com/support/dreamweaver/whatsnew.html) page for details.

- **How does Dreamweaver compare with earlier versions?**
  Check out the Dreamweaver [version comparison](https://www.adobe.com/support/dreamweaver/versioncomparison.html).

- **How does Dreamweaver integrate with other Adobe creative applications?**
Dreamweaver can be used with other Creative Cloud tools such as Adobe Photoshop, Illustrator, Animate, and more to build beautiful, modern websites. You can also share assets and collaborate with others with the Creative Cloud Libraries integration.

Technical questions

- **What are the minimum system requirements to run Dreamweaver?**
  See the [Dreamweaver system requirements](#) for information.

- **Is Dreamweaver compatible with Windows 10?**
  Yes. [Dreamweaver system requirements](#)

- **Is Dreamweaver compatible with macOS v10.12 or OS X v10.11?**
  Yes. [Dreamweaver system requirements](#)

- **What types of documents can I open with Dreamweaver?**
  Dreamweaver 2017 can open and edit multiple document types. Some of the document file types that Dreamweaver can open and edit are:
  - HTML documents
  - Server-side Includes
  - JavaScript documents
  - PHP files
  - XML files
  - SQL files
  - SVG files
  - Json files
  - Library files (*.lbi)
  - Template files (*.dwt)
  - Style sheets (*.css, *.less, *.sass, *.scss)
  - Active Server Pages and Active Server Plus Pages
  - ColdFusion templates
  - Manifest (*.appcache)
  - Directory Configuration files (*.htaccess)
  - Text files (*.txt)

- **What type of code does Dreamweaver produce?**
  All the features in Dreamweaver produce HTML5 code to align with the latest standards in web development. With use of the code editor, you have the ability to write and edit code to suit your own development needs.

- **Can I create responsive web and mobile content in Dreamweaver?**
  Yes. Dreamweaver supports Bootstrap framework for mobile-first, responsive websites. Dreamweaver also includes responsive features such as Visual Media Queries and Fluid Grid Layouts.

- **Can I continue to use earlier versions of Dreamweaver?**
Yes. If you already have a prior installation of Dreamweaver CS6, you can continue to use it as is. With a Creative Cloud membership, you can download previous versions of Dreamweaver at any time to use alongside your current Dreamweaver installation.

**Free trials**

- **Where can I get a trial version of Dreamweaver?**
  
  With a free Creative Cloud membership, you can download a 7-day trial version of Dreamweaver — and other applications in Creative Cloud. When you upgrade to an All Apps plan, you'll be able to download the full version of every Creative Cloud application.

- **Can I convert my trial version to a paid membership?**
  
  Yes. You can convert your trial to a Creative Cloud All Apps or Single App membership by purchasing on the Creative Cloud website. After you purchase your membership, your desktop product trial will automatically be licensed upon relaunch.

**Purchasing options**

- **How can I purchase Dreamweaver?**
  
  Learn more about purchasing options on the Creative Cloud plans page.

**Using Dreamweaver**

- **How can I get started with Dreamweaver?**
  
  Check out Dreamweaver Learn & Support for all you need to get started, with video and step-by-step-tutorials as well as comprehensive product support from Adobe and our knowledgeable community.

- **Where can I find the manual?**
  
  You can find web and PDF versions of the Dreamweaver manual on the Dreamweaver Help page.

- **How can I give comments or leave feedback on Dreamweaver?**
  
  Visit the Dreamweaver forums to provide feedback or have your support questions answered.

- **Where can I report a bug or submit a feature request?**
  
  You can use this form to request new features or suggest changes to existing features. You can also get to this link from the Help menu in Dreamweaver (Help > Submit Bug/Feature Request).

**Dreamweaver manual (PDF)**

Find a PDF of articles to learn how to use Dreamweaver.

**Dreamweaver system requirements**

*Applicable for:* November 2019 (20.0) release.

*System requirements for earlier releases:* Dreamweaver system requirements | earlier releases

Last updated 11/7/2019
Minimum system requirements for Dreamweaver

**Windows**

<table>
<thead>
<tr>
<th>Minimum requirement</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Intel® Core 2 or AMD Athlon® 64 processor; 2 GHz or faster processor.</td>
</tr>
<tr>
<td>Operating system</td>
<td>Microsoft Windows 7 with Service Pack 1 (64-bit), or Windows 10 v1607, 1803 or later (64-bit).</td>
</tr>
<tr>
<td>RAM</td>
<td>2 GB of RAM (4 GB recommended).</td>
</tr>
<tr>
<td>Hard disk space</td>
<td>2 GB of available hard-disk space for installation; additional free space (approximately 2 GB) required during installation. Dreamweaver cannot be installed on removable flash storage devices.</td>
</tr>
<tr>
<td>Monitor resolution</td>
<td>1280x1024 display with 16-bit video card.</td>
</tr>
<tr>
<td>Internet</td>
<td>Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.</td>
</tr>
</tbody>
</table>

**macOS**

<table>
<thead>
<tr>
<th>Minimum requirement</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Multicore Intel processor with 64-bit support</td>
</tr>
<tr>
<td>Operating system</td>
<td>macOS v10.15, macOS v10.14, macOS v10.13</td>
</tr>
<tr>
<td>RAM</td>
<td>2 GB of RAM (4 GB recommended)</td>
</tr>
<tr>
<td>Hard disk space</td>
<td>2 GB of available hard-disk space for installation; additional free space (approximately 2 GB) required during installation. Dreamweaver cannot be installed on removable flash storage devices.</td>
</tr>
<tr>
<td>Monitor resolution</td>
<td>1280x1024 display with 16-bit video card</td>
</tr>
<tr>
<td>Internet</td>
<td>Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.</td>
</tr>
</tbody>
</table>

Language versions available for Dreamweaver

- Deutsch
- English
- Español
- Français
- Français*
- Hebrew*
- Italiano
- Nederlands
- Polish
Feature summary

Note:

The Dreamweaver October 2017 (18.0) release is now available! See the What’s new in Dreamweaver.

The 2017 releases of Dreamweaver brings in several new features and enhancements including support for Git, an all-new code editor, more intuitive user interface with a selectable dark theme, and several enhancements including an improved onboarding experience.

Read on for a quick introduction to these new features and enhancements.

For a summary of features introduced in earlier releases of Dreamweaver, see Feature summary | Dreamweaver 2015 releases.Link

Adobe Dreamweaver 2017.5 release

Dreamweaver 2017.5 supports the following new features and enhancements:

- Git support to manage files in Dreamweaver
- New code themes
- Improved onboarding experience for new users
Read on to know more about these features and enhancements.

**Git support in Dreamweaver**

Dreamweaver 2017.5 release supports Git, which is an open source version control system. With the new Git support, you can now easily manage your files, including source code, from within Dreamweaver.

You can now perform common Git operations from within Dreamweaver, without the need for third-party tools. The new Git panel (Windows > Git) allows you to perform various Git operations including Commit, Push, Pull, and Fetch.

You can also use Git as a collaboration tool by creating and merging branches and remote repositories. You can also view the differences between two versions of a file, and view file and repository histories.

Further, the Files panel in Dreamweaver now supports a new Git view. Using this view, you can manage the untracked, modified, staged, and committed files associated with your site.

To learn more about using Git for version control and collaboration, see Using Git in Dreamweaver.

**New code themes**

Dreamweaver 2017.5 now supports two new code themes: Monaki and Classic. You can select and use these code themes that provide code colors similar to Dreamweaver 2015.

Select Dreamweaver > Preferences (macOS) or Edit > Preferences > Interface (Windows), to try the new code themes for improved readability and visual appeal.
New code themes in Dreamweaver 2017.5 - Monaki and Classic

**Improved onboarding experience**

When you launch Dreamweaver 2017.5 for the first time, the Welcome screen displays an improved on-boarding experience. The new onboarding experience showcases one of the following two video tutorials, based on the workspace you choose:

- A quick tutorial on Developer workspace
- A quick tutorial on Standard workspace
Introduction to Dreamweaver

Improved onboarding experience in Dreamweaver 2017.5

You can also access the two video tutorials from the Help menu. Click Help > Quick Tutorial to view the tutorials.

Other enhancements

Dreamweaver 2017.5 is now integrated with a new version of CEF. With the new CEF version, the Live View in Dreamweaver displays custom HTML elements, custom properties for CSS, and more.

Adobe Dreamweaver 2017.1 release

Dreamweaver 2017.1 provides additional coding support by including the following features:

- Support for PHP 7.1
- Improved find and replace

Read on for a quick introduction to these enhancements.
Support for PHP 7.1
In earlier versions of Dreamweaver, you could access code hints and parser checks for PHP 5.6. Dreamweaver 17.1 is set up for PHP versions 5.6 and 7.1.

You can choose to compile your site's PHP files with 5.6 or 7.1 through the Site Setup dialog box, or Edit > Preferences.

For more information on PHP 7.1 support, see the following articles:

- Set PHP preferences
- PHP code hints

Improved find and replace
This release includes important enhancements to the find and replace features.

You can now search for attributes and tags using the Find and Replace dialog box (Find > Find and Replace in Files). You can use this dialog even if no files are open in Dreamweaver (searching within a folder, for instance).

In addition, the Find and Replace Quick Find bar (Find > Find and Replace) is now moved to the bottom of the Dreamweaver workspace. Use this panel to quickly find and replace text and attributes within the current document.

For more information on find and replace, see Find and replace text, tags, and attributes. For known issues with find and replace in Dreamweaver 17.1, see Known issues and defects fixed in Dreamweaver 2017 releases.

New keyboard shortcuts for find and replace:
- Find in Current Document: Ctrl + F (on Windows), and Cmd + F (on Mac)
- Find and Replace in Files: Ctrl + Shift + F (on Windows), and Cmd + Shift + F (on Mac)
- Replace in Current Document: Ctrl + H (on Windows), and Cmd + Alt + F (on Mac)

For a complete list of find and replace keyboard shortcuts, see Find and replace keyboard shortcuts.

Update to Dreamweaver 2017 release (17.0.2)

Create email campaigns using Dreamweaver with Campaign
You can now use the Campaign extension for Dreamweaver to create personalized email campaigns.

Creating personalized content is very important to make an immediate connection with the reader, and hopefully increase your success rates with email marketing.

If you use Dreamweaver to create email campaigns, you can now go a step further and add personalized content (such as the reader's name, or a personalized call to action) using data from Adobe Campaign.

To get started, download the Campaign extension by clicking Window > Extensions > Browse Extensions, create a new email newsletter, or edit an existing one. After you finish designing, personalize content using Campaign's personalization fields and content blocks, and you are ready to go.

Dreamweaver automatically syncs up with Campaign so that your content changes in Dreamweaver are available for you in Campaign. All you then have to do is enter an email address, and send a personalized campaign to your email recipient.

For more information, see Create personalized email campaigns.
Update to Dreamweaver 2017 release (17.0.1)

In-built code coloring support
You can now create and customize code themes, based on the default Light and Dark themes. You can then customize the code colors by modifying the right selectors in the theme file.

Select the light or dark default code theme in Edit > Preferences > Interface, and if you want to change the code colors, save the theme with a new name, and start editing the theme file.

For more information on customizing your code colors, see Customize code coloring.

Note:
This release also includes fixes for a number of defects. For more information on defects fixed, see Known issues and defects fixed in Dreamweaver 2017 releases.

Dreamweaver 2017 release (17.0)
The Dreamweaver 2017 release brings to you an all-new code editor, a more intuitive user interface with selectable dark and light themes, and several enhancements including support for new workflows such as CSS preprocessors.

Read on for a complete list of what's new and changed in Dreamweaver 2017:

• Redesigned Code Editor
• CSS preprocessor support
• Real-time Preview in browser
• Quick editing of related code files (Quick Edit)
• In-context CSS documentation (Quick Docs)
• Multiple cursors to write and edit code
• Modern user interface
• Changes in menus, workspaces, and toolbars
• Snippets panel changes
• Files panel changes
• Changes in the Welcome screen and on-boarding experience
• Live Highlighting in Find and Replace
• Enhancements to Creative Cloud Libraries
• Auto-recovery of files after a crash

Redesigned Code Editor
Several productivity enhancements have been made to the Code Editor in Dreamweaver to enable you to get on with the task of coding quickly and efficiently.

Code hints help new users learn HTML, CSS, and other web standards, and visual aids like auto-indentation, code coloring, and resizeable fonts help reduce errors and make your code easier to read.
Code hints
The code hinting functionality in Dreamweaver is enhanced to provide more useful information for the selected code.

In earlier versions of Dreamweaver, when you type a right-angle bracket, you get a drop-down list of relevant code.

In this release, you not only get the relevant code, you also get additional information that helps you to quickly ramp up on HTML, CSS, and other web technologies within Dreamweaver itself.

For more information, see Code hinting and code completion.

Code display enhancements
The overall appearance of the code is now enhanced for better readability. You can see improvements in code formatting, and code coloring.

Code formatting
When you write code, Dreamweaver auto-indents the code to circumvent erroneous manual indentation and improve readability.

Code coloring
Dreamweaver now supports code coloring for additional number of file types.

Code coloring support is now available for HTML, JS, CSS, PHP, XML, LESS, Sass, SCSS, SVG, Bash, C, C#, C++, clojure, CoffeeScript, Dart, Diff, EJS, Embedded Ruby, Groovy, Handlebars, Haskell, Haxe, Java, JSON, Lua, Markdown, Markdown (GitHub), Perl, Properties, Python, RDF Turtle, Ruby, Scala, SQL, Stylus, Text, VB, VBScript, XML, and YAML.

You can change syntax highlighting for different file types directly from the status bar in code view.

For more information on all these changes, see Coding environment in Dreamweaver.
**CSS preprocessor support**

Dreamweaver now supports common CSS preprocessors like Sass, Less, and SCSS, with full code coloring, and compilation, so you can save time and produce cleaner code.

For more information on Dreamweaver support for CSS preprocessors, see Using CSS preprocessors in Dreamweaver.

**Real-time Preview in browser**

Quickly preview your code changes in browser in real time without manually refreshing your browser. Dreamweaver now connects with your browser so changes appear in your browser instantly without page reloads.

![Preview changes in real-time in your browser](image)

For more information, see Real-time Preview in browser.

**Quick editing of related code files (Quick Edit)**

To make quick changes to your code, place the cursor on specific code snippets and use the context menu, or press Ctrl-E (on Windows) or Cmd-E (on Mac) to access Quick Edit.

Dreamweaver offers context-specific code options and inline tools.

For more information, see Quick Edit.
In-context CSS documentation (Quick Docs)

Dreamweaver provides in-context documentation for CSS properties, right within the code view.

Now you don’t have to navigate outside Dreamweaver to a web page to learn or refer to CSS properties. To bring up help for CSS, press Ctrl+K (on Windows) or Cmd+K (on Mac).

For more information, see Get help with CSS within Dreamweaver using Quick Docs.

Multiple cursors to write and edit code

To write multiple lines of code simultaneously, use multi-cursors.

This feature is a huge productivity booster, as you don’t have to write the same line of code multiple times.

To invoke multiple cursors, you can:

- To add cursors to multiple continuous lines - Hold down the Alt key, then click drag vertically.
• To add cursors in multiple discontinuous lines - Press the Ctrl key, and click the different lines where you want to place the cursor.
• To select text in multiple continuous lines - Press the Alt key and drag diagonally
• To select text in multiple discontinuous lines - Select some text, then press the Ctrl key (Windows), or Cmd key (Mac), and continue to make further selections.

For more information, see Use multiple cursors to add or change text in multiple places.

Modern user interface

Dreamweaver is redesigned with a more intuitive and customizable interface, more accessible menus and panels, and a contextual and configurable toolbar that shows you only the tools you need.

The new interface also offers four levels of contrast from light to dark, so it's easier to read and edit lines of code.

Here are before and after snapshots of the new user interface.
Introduction to Dreamweaver

User interface - Dreamweaver 2015 releases
Changes in menus, workspaces, and toolbars

Dreamweaver's menus, toolbars, and workspaces are also redesigned in this release. Read on to learn more about these changes.

Workspace changes

The Dreamweaver interface is optimized to include the following default workspaces:

- **Developer workspace**
  This workspace is minimal, and by default, includes only those panels that are most essential for developers who code websites - for instance, the Files, and Snippets panels.

- **Standard workspace**
  This workspace includes everything you need when you work with both code and design - such as Files, CC Libraries, CSS Designer, Insert, DOM, Assets, and Snippets panels.

  **Note:**

  After you select a workspace, you can customize it by adding or removing panels. For more information on customizing workspaces, see Create custom workspaces.

Here is a summary of the differences in the workspaces provided in Dreamweaver 2015 and Dreamweaver 2017.

**Dreamweaver 2015**

- Beginner
- Code
Introduction to Dreamweaver

- Default
- Design
- Extract

Dreamweaver 2017
- Developer
- Standard

For more information on workspace changes, see The Dreamweaver workspace.

Menu changes
The application menu is revamped to remove sparingly used menu items, and move others to more intuitive menu locations.

For a detailed description of the changes in Dreamweaver’s application menu, see Redesigned Menus.

Toolbar changes
The toolbar is now common across all views. The toolbar displays only the tools that are required for the view in which you are working. Toolbar overview

However, you can customize the toolbar to display the required set of tools you need.

For more information, see Toolbar overview.

Status bar changes
The status bar now displays useful information when you work in Code view. Status bar overview

You can now:
- Toggle between INS (Insert) and OVR (Overwrite) modes
- See the line and column number at the bottom of the screen. These numbers indicate the line and column where the mouse is placed.
- Select a desired code coloring for different types of code files.

For more information, see Status bar overview.

Snippets panel changes
The snippets panel now wears a new cleaner look, and is also redesigned to make the process of inserting snippets easier.

The following image highlights the major changes in the Snippets panel:
Introduction to Dreamweaver

UI changes in the Snippets panel

In the previous releases of Dreamweaver, you had to insert snippets using keyboard shortcuts.

Inserting snippets using keyboard shortcuts was not an efficient process due to the following reasons:

- The need to remember non-intuitive shortcuts
- Possible clashes with product keyword shortcuts

In this version of Dreamweaver, you can use trigger keys to insert code snippets.

Trigger keys are user-friendly text strings assigned to code snippets. For example, for a code snippet that creates a mailto link, you can type "mailto" and make that the trigger key.

After you assign a trigger key, place the cursor in your document, type "mailto", and press Tab. Dreamweaver then inserts the related code snippet in your document.

For more information on the Snippets panel, see Reuse code with snippets.

Files panel changes

The Files panel is redesigned to make it simpler and more intuitive to use.

At its simplest, the Files panel displays a list of only the local files in your computer. As you work more with the Files panel - setting up a site, setting up connections to remote servers, enabling check in and check out, more options appear in the Files panel.

For more information on the changes to the Files panel, see Redesigned Files panel.
Changes in the Welcome screen and on-boarding experience

When you launch Dreamweaver or when you close all Dreamweaver documents, a new Start workspace is displayed. You have convenient access to your recently used files, Libraries, and starter templates with the Start workspace.

If you prefer the older dialogs, you can still type Ctrl/Cmd + O to launch the Open dialog, or Ctrl/Cmd + N to launch the New Document dialog.

To help you ramp up quickly on the changes in the Dreamweaver 2017 workspace, an onboarding experience is available to you. Quickly go through the customization experience, and you will be presented with a workspace and theme options that are right for you.

For more information, see The Dreamweaver workspace.

Live Highlighting in Find and Replace

The new, non-obtrusive, Find and Replace toolbar sits at the top of your window without blocking any portion of your screen.

Find and replace, in general, is faster and more efficient, as compared to previous versions of Dreamweaver. Dreamweaver now looks for search strings as you type in the Find panel and highlights all instances of the string in the current document.

For more information, see Find and replace text, tags, and attributes.

Enhancements to Creative Cloud Libraries

Archive, restore, add comments, and see version history for all your assets stored in Creative Cloud, including files in your Creative Cloud Libraries, assets created with Creative Cloud desktop products, and mobile projects.

Auto-recovery of files after a crash

If Dreamweaver shuts down unexpectedly because of system errors, power outages, or other problems, then you can recover any unsaved changes in the files that you were editing. Manage files and folders

For more information, see Auto-recovery of files.

Dreamweaver system requirements | 2020 releases

Applicable for: November 2019 (20.0) release.

System requirements for earlier releases: Dreamweaver system requirements | earlier releases

Minimum system requirements for Dreamweaver

Last updated 11/7/2019
Windows

<table>
<thead>
<tr>
<th>Minimum requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
</tr>
<tr>
<td>Intel® Core 2 or AMD Athlon® 64 processor; 2 GHz or faster processor.</td>
</tr>
<tr>
<td>Operating system</td>
</tr>
<tr>
<td>Microsoft Windows 7 with Service Pack 1(64-bit), or Windows 10 v1607, 1803 or later (64-bit).</td>
</tr>
<tr>
<td>RAM</td>
</tr>
<tr>
<td>2 GB of RAM (4 GB recommended).</td>
</tr>
<tr>
<td>Hard disk space</td>
</tr>
<tr>
<td>2 GB of available hard-disk space for installation; additional free space (approximately 2 GB) required during installation. Dreamweaver cannot be installed on removable flash storage devices.</td>
</tr>
<tr>
<td>Monitor resolution</td>
</tr>
<tr>
<td>1280x1024 display with 16-bit video card.</td>
</tr>
<tr>
<td>Internet</td>
</tr>
<tr>
<td>Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.</td>
</tr>
</tbody>
</table>

macOS

<table>
<thead>
<tr>
<th>Minimum requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
</tr>
<tr>
<td>Multicore Intel processor with 64-bit support</td>
</tr>
<tr>
<td>Operating system</td>
</tr>
<tr>
<td>macOS v10.15, macOS v10.14, macOS v10.13</td>
</tr>
<tr>
<td>RAM</td>
</tr>
<tr>
<td>2 GB of RAM (4 GB recommended)</td>
</tr>
<tr>
<td>Hard disk space</td>
</tr>
<tr>
<td>2 GB of available hard-disk space for installation; additional free space (approximately 2 GB) required during installation. Dreamweaver cannot be installed on removable flash storage devices.</td>
</tr>
<tr>
<td>Monitor resolution</td>
</tr>
<tr>
<td>1280x1024 display with 16-bit video card</td>
</tr>
<tr>
<td>Internet</td>
</tr>
<tr>
<td>Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.</td>
</tr>
</tbody>
</table>

Language versions available for Dreamweaver

Deutsch
English
Español
Français
Français*
Hebrew*
Italiano
Nederlands
Polish
Português (Brasil)
Svenska
Turkish
čeština
Русский
* Chinese Simplified, Chinese Traditional, and Korean are available for Windows only. Arabic and Hebrew versions have localized support and features with an English interface. North African French (Français*) version has localized support and features with a French interface.
Chapter 2: Dreamweaver and Creative Cloud

Creative Cloud Libraries in Dreamweaver

Creative Cloud Libraries make your favorite assets available to you anywhere. You can create or capture images, colors, text styles, and more in several Creative Cloud desktop and mobile apps, and then easily access them across other desktop and mobile apps for a seamless creative workflow.

You can access CC Libraries right from within Dreamweaver to reuse colors and graphics in your web pages. You can also keep the inserted graphics up-to-date with those on the cloud by inserting them as 'linked' assets.

Read on for more information on using CC Libraries in Dreamweaver.

The CC Libraries panel

The CC Libraries panel (Window > CC Libraries) is the main access point to your assets saved on Creative Cloud. The panel also lets you search for assets in Adobe Stock.
Using this panel, you can:

- Browse a specific library for the assets stored in the library
- Create a library
Dreamweaver and Creative Cloud

- Preview assets in the selected library
- Drag or copy assets to be inserted onto your web page
- Enter a key word, such as, full name or part of a name of an image to search on Adobe Stock

Getting started

Define a site in Dreamweaver
A site in Dreamweaver is a folder where all the images, videos, scripts, stylesheets, and other files related to your web pages are stored. Defining a site upfront helps you easily save the assets that you import from CC Libraries to the site. Ensure that the web page into which you want to import assets from CC Libraries is also saved in the site folder.

For information on creating sites, see Set up a local version of your site.

Add assets to CC Libraries
Ensuring that all the required assets are available on Creative Cloud helps you import the assets into your web page in Dreamweaver quickly.

If you are looking for stock images, then Adobe Stock is a good place to start with. For detailed information, see Get assets from Adobe Stock.

Graphics and colors that you capture or create from various Adobe mobile and desktop apps can be stored on Creative Cloud and imported into your web pages. For example, a vector graphic created using Adobe Shape CC or an image processed using Photoshop. Creative Cloud also lets you and your team collaborate and share assets, so you can reuse assets created by others too.

For more information on Creative Cloud Libraries, see Creative Cloud Libraries.

Get assets from Adobe Stock
Adobe Stock is deeply integrated with Creative Cloud Libraries. You can search for images and add them to any of your CC Libraries in one of the following ways:

- Directly from the Adobe Stock website.
- Using the CC Libraries panel in Dreamweaver.
- Using the CC Libraries panels in other Adobe applications, such as Photoshop and Illustrator.

Once you add the images to a CC Library, you can follow the instructions in the Reuse graphics in CC Libraries topic to use these images in your web pages.

If you are unsure about purchasing Stock images right away, you can add only watermarked Stock images (previews) to your libraries and use these images as placeholders. When you are ready to purchase these images, you can do so in the CC Libraries panel in Dreamweaver and other apps, or directly from the Adobe Stock website.
Searching for images on Adobe Stock using CC Libraries panel

When you license an image, all instances of the watermarked asset in your open documents are updated to the high-resolution version of the licensed image.
Reuse colors and color themes saved in CC Libraries

- Reuse colors in Live view
- Reuse colors in Code view

Reuse colors and color themes in Live view
You can save colors and color themes in your Creative Cloud Libraries from apps such as Illustrator, Photoshop, or Adobe Color CC. You can import these colors and color themes in your web pages using the CC Libraries panel in Dreamweaver using the following steps:

1. In the CC Libraries panel, perform one of the following actions:
   - Click the required color or color theme. The HEX value of the color or color theme is copied to the clipboard.
   - Right-click the required color or color theme, and then click Copy RGB or Copy HEX.
2. Paste the color value in Code view or CSS Designer.

Reuse colors in Code view
Colors saved on Creative Cloud are available as code hints in Code view. You can select the required colors from the code hints as you code in Code view. The Creative Cloud icon adjacent to the color in code hints indicates that these colors are stored on Creative Cloud.

Colors in Creative Cloud Library displayed in code hints

The code hints pick colors from the library that is currently opened in the CC Libraries panel. In the image above, colors in the library 'My Library' are made available as code hints. To get colors in another Creative Cloud Library as code hints, open the required library in the CC Libraries panel and then resume your work in Code view.

Reuse graphics saved in CC Libraries
You can save graphics created using Adobe desktop and mobile apps, such as, Photoshop, Illustrator, Adobe Shape CC, or Adobe Sketch CC, in your Creative Cloud Libraries. The CC Libraries panel helps you insert graphics into Live view and the code hints help you insert graphics directly into your code.

Link You can insert graphics from CC Libraries as:

- **Linked assets**: When graphics are inserted as linked assets, a small cloud icon appears at the lower right corner of the asset in Live view. This icon indicates that the asset is linked to the original asset on the cloud. The cloud icon is also displayed adjacent to the asset in the Assets panel.
Dreamweaver and Creative Cloud

- **Unlinked assets:** You can insert an asset as a local copy in your web pages. In Live view, right-click the required asset in the CC Libraries panel, and select 'Insert Unlinked'. When you insert a copy of a graphic, the asset is copied to your local machine and is not linked to the original asset on the cloud. This means, any changes or updates to the asset on the cloud is not reflected in Dreamweaver.

You can also batch download assets and save on your computer for later use.

- Reuse graphics in Live view
- Reuse graphics in Code view
- Specify sampling options for graphics
- Resample or rename linked graphics
- Download graphics

**Reuse graphics in Live view**

1. Perform one of the following actions:
   - a. Drag the graphic from the CC Libraries panel onto your page in Live view.
     
     **Note:** When you drag graphics from the CC Libraries panel onto Live view, the graphic is inserted as a 'Linked' graphic (if you have defined a site).

     Illustrator files are inserted as web-optimized, SVG files by default. If you want to customize the properties of SVG files, you can edit the preferences in `options.json` file. For more information, see [Extract web-optimized SVG files from CC Libraries](#).

   - b. Right-click the required asset in the CC Libraries panel, and select:
     - 'Insert Linked' to insert the graphic as a linked asset. This means that the asset will maintain its reference to the corresponding asset on the cloud. Any change to the asset on the cloud will be reflected in the linked asset in Dreamweaver.
     - 'Insert Unlinked' to insert the graphic as an unlinked asset.

2. In the Sampling dialog box that appears, specify the file name and the dimensions of the image. For detailed information, see [Specify sampling options for graphics](#).

**Reuse graphics in Code view**

Graphics saved in your Creative Cloud Libraries are available as code hints in Code view. First, open the required library by selecting it in the CC Libraries panel. Then, switch to Code view and select the required graphic from the code hints as you code. The Creative Cloud icon adjacent to the graphic in code hints indicates that the graphic is stored on Creative Cloud.
Note: When you insert graphics using code hints, the graphics are inserted as ‘unlinked’ graphics.

To get colors in another Creative Cloud Library as code hints, open the required library in the CC Libraries panel and then resume your work in Code view.

Specify sampling options for graphics

The Height and Width boxes resample the asset using the Dreamweaver image optimization engine. You can also select the format type in which you want the asset to be placed. The enabled cloud icon indicates that the asset will be placed as a linked asset. After specifying the file name and sampling options, press Enter to insert the asset.

Note:
- The SVG option is available for Illustrator (.ai) files only and is set as default for such files. You can change the format of such files to JPEG using the drop-down list in the resampling dialog box.
A JPEG file can be inserted only as a JPEG file, and so no other format option is available for such files.

**Edit graphics**

Using the CC Libraries panel, you can quickly open and edit InDesign and Illustrator assets in their native applications. To do so, right-click the asset in the CC Libraries panel, and then click Edit.

Ensure that the native applications - InDesign or Illustrator - are installed on the same computer as the Dreamweaver instance you are using. Also, ensure that you have installed the latest updates to these applications from Creative Cloud.

**Unlink, resample, and rename linked graphics**

You can change the name, size, or resample images imported into your web page from CC Libraries using one of the following options:

- Click the asset in Live view and then click the cloud icon.
- Right-click the asset and click Linked asset options.
- Double-click the cloud icon adjacent to the asset name in the Assets panel.

The resampling dialog box appears to let you change the required properties. To unlink the asset from its source in CC Libraries, click the cloud icon in the resampling dialog box.

When you unlink an asset, any changes to the source file on Creative Cloud will not be reflected in the image in your web page.

**Download graphics**

You can download the required graphics as linked assets from CC Libraries in bulk and insert them in your project at a later point in time. When you use these assets in your projects, they will still maintain the link to the corresponding library item.

- **Linked**: To download graphics as linked assets, right-click the asset in CC Libraries panel and select Download Linked. The popup with filename and resampling options is displayed. Save the asset in your site folder by specifying the filename and sampling options, and pressing Enter.
- **Unlinked**: To download graphics as unlinked assets, right-click the required asset in the CC Libraries panel and select Download Copy. The popup with filename and resampling options is displayed. Save the asset in your site folder by specifying the filename and sampling options, and pressing Enter.

**Using Photoshop files in Dreamweaver**

**About Photoshop integration**

You can insert Photoshop image files (PSD format) into web pages in Dreamweaver and let Dreamweaver optimize them as web-ready images (GIF, JPEG, and PNG formats). When you do this, Dreamweaver inserts the image as a Smart Object and maintains a live connection to the original PSD file.

You can also paste all or part of a multi-layered or multi-sliced Photoshop image into a web page in Dreamweaver. When you copy and paste from Photoshop, however, no live connection to the original file is maintained. To update the image, make your changes in Photoshop, and copy and paste again.

**Note:**
If you use this integration feature often, you may want to store your Photoshop files in your Dreamweaver site for easier access. If you do, be sure to cloak them to avoid exposure of the original assets, as well as unnecessary transfers between the local site and the remote server.

For a tutorial on Photoshop integration with Dreamweaver, see Integrating Dreamweaver with Photoshop.

About Smart Objects and Photoshop-Dreamweaver workflows

There are two main workflows for working with Photoshop files in Dreamweaver: the copy/paste workflow, and the Smart Objects workflow.

Copy/paste workflow

The copy/paste workflow lets you select slices or layers in a Photoshop file, and then use Dreamweaver to insert them as web-ready images. If you want to update the content later on, however, you must open the original Photoshop file, make your changes, copy your slice or layer to the clipboard again, and then paste the updated slice or layer into Dreamweaver. This workflow is only recommended when you want to insert part of a Photoshop file (for example, a section of a design comp) as an image on a web page.

Smart Objects workflow

When working with complete Photoshop files, Adobe recommends the Smart Objects workflow. A Smart Object in Dreamweaver is an image asset placed on a web page that has a live connection to an original Photoshop (PSD) file. In Dreamweaver Design view, a Smart Object is denoted by an icon in the upper left corner of the image.

When the web image (that is, the image on the Dreamweaver page) is out of sync with the original Photoshop file, Dreamweaver detects that the original file has been updated, and displays one of the Smart Object icon's arrows in red. When you select the web image in Design view and click the Update from Original button in the Property inspector, the image updates automatically, reflecting any changes that you made to the original Photoshop file.
When you use the Smart Objects workflow, you do not need to open Photoshop to update a web image. Additionally, any updates you make to a Smart Object in Dreamweaver are non-destructive. That is, you can change the web version of the image on your page while keeping the original Photoshop image intact.

You can also update a Smart Object without selecting the web image in Design view. The Assets panel lets you update all Smart Objects, including images that might not be selectable in the Document window (for example, CSS background images).

**Image optimization settings**

For both the copy/paste and the Smart Object workflows, you can specify optimization settings in the Image Optimization dialog box. This dialog box lets you specify the file format and image quality. If you are copying a slice or a layer, or inserting a Photoshop file as a Smart Object for the first time, Dreamweaver displays this dialog so that you can easily create the web image.

If you copy and paste an update to a particular slice or layer, Dreamweaver remembers the original settings and re-creates the web image with those settings. Likewise, when you update a Smart Object using the Property inspector, Dreamweaver uses the same settings you used when you first inserted the image. You can change an image's settings at any time by selecting the web image in Design view, and then clicking the Edit Image Settings button in the Property inspector.

**Storing Photoshop files**

If you’ve inserted a web image, and have not stored the original Photoshop file in your Dreamweaver site, Dreamweaver recognizes the path to the original file as an absolute local file path. (This is true for both the copy/paste and Smart Object workflows.) For example, if the path to your Dreamweaver site is C:\Sites\mySite, and your Photoshop file is stored in C:\Images\Photoshop, Dreamweaver will not recognize the original asset as part of the site called mySite. This will cause problems if you ever want to share the Photoshop file with other team members because Dreamweaver will only recognize the file as being available on a particular local hard drive.

If you store the Photoshop file inside your site, however, Dreamweaver establishes a site-relative path to the file. Any user with access to the site will also be able to establish the correct path to the file, assuming that you have also provided the original file for them to download.

For a video tutorial on roundtrip editing with Photoshop, see [Roundtrip editing with Photoshop](#).

**Create a Smart Object**

When you insert a Photoshop image (PSD file) into your page, Dreamweaver creates a Smart Object. A Smart Object is a web-ready image that maintains a live connection to the original Photoshop image. Whenever you update the original image in Photoshop, Dreamweaver gives you the option of updating the image in Dreamweaver with the click of a button.

1. In Dreamweaver (Design or Code view), place the insertion point on your page where you want the image inserted.
2. Select Insert > Image.

   ![Tip icon](image)

   *You can also drag the PSD file to the page from the Files panel if you're storing your Photoshop files in your website. If you do so, you'll skip the next step.*

3. Locate your Photoshop PSD image file in the Select Image Source dialog box by clicking the Browse button and navigating to it.
4. In the Image Optimization dialog box that appears, adjust optimization settings as needed and click OK.
5 Save the web-ready image file to a location within your website's root folder.

Dreamweaver creates the Smart Object based on the selected optimization settings and places a web-ready version of the image on your page. The Smart Object maintains a live connection to the original image and lets you know when the two are out of synch.

Note:

If you decide later that you want to change the optimization settings for an image placed in your pages, you can select the image, click the Edit Image Settings button in the Property inspector, and make changes in the Image Optimization dialog box. Changes made in the Image Optimization dialog box are applied non-destructively. Dreamweaver never modifies the original Photoshop file, and always re-creates the web image based on the original data.

For a video tutorial on roundtrip editing with Photoshop, see Roundtrip editing with Photoshop.

Update a Smart Object

If you change the Photoshop file to which your Smart Object is linked, Dreamweaver notifies you that the web-ready image is out of sync with the original. In Dreamweaver, Smart Objects are denoted by an icon at the upper left corner of the image. When the web-ready image in Dreamweaver is in sync with the original Photoshop file, both of the arrows in the icon are green. When the web-ready image is out of sync with the original Photoshop file, one of the icon's arrows turns red.

To update a Smart Object with the current contents of the original Photoshop file, select the Smart Object in the Document window, and then click the Update from Original button in the Property inspector.

Note:

You do not need Photoshop installed to make the update from Dreamweaver.

Update multiple Smart Objects

You can update multiple Smart Objects at once using the Assets panel. The Assets panel also lets you see Smart Objects that might not be selectable in the Document window (for example, CSS background images).

1 In the Files panel, click the Assets tab to view site assets.

2 Make sure that Images view is selected. If it isn’t, click the Images button.

3 Select each image asset in the Assets panel. When you select a Smart Object, you’ll see the Smart Object icon in the upper left corner of the image. Regular images do not have this icon.

4 For each Smart Object that you want to update, right-click the filename and select Update from Original. You can also Control-click to select multiple filenames and update them all at once.

Note:

You do not need Photoshop installed to make the update from Dreamweaver.

Resize a Smart Object

You can resize a Smart Object in the Document window just as you would any other image.

1 Select the Smart Object in the Document window and drag the resize handles to resize the image. You can maintain the width and height proportions by holding down the Shift key as you drag.

2 Click the Update from Original button in the Property inspector.
When you update the Smart Object, the web image non-destructively re-renders at the new size, based on the current contents of the original file, and the original optimization settings.

**Edit a Smart Object’s original Photoshop file**

After you create a Smart Object on your Dreamweaver page, you can edit the original PSD file in Photoshop. After you make your changes in Photoshop, you can then easily update the web image in Dreamweaver.

*Note:*

*Make sure that you have Photoshop set as your primary external image editor.*

1. Select the Smart Object in the Document window.
2. Click the **Edit** button in the Property inspector.
3. Make your changes in Photoshop and save the new PSD file.
4. In Dreamweaver, select the Smart Object again and click the **Update from Original** button.

*Note:*

*If you changed the size of your image in Photoshop, you need to reset the size of the web image in Dreamweaver.*

Dreamweaver updates a Smart Object based only on the contents of the original Photoshop file, and not its size. To sync the size of a web image with the size of the original Photoshop file, right-click the image and select **Reset Size To Original**.

**Smart Object states**

The following table lists the various states for Smart Objects.

<table>
<thead>
<tr>
<th>Smart Object state</th>
<th>Description</th>
<th>Recommended action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Images synched</td>
<td>The web image is in sync with the current contents of the original Photoshop file. Width and height attributes in the HTML code match the dimensions of the web image.</td>
<td>None</td>
</tr>
<tr>
<td>Original asset modified</td>
<td>The original Photoshop file has been modified after the creation of the web image in Dreamweaver.</td>
<td>Use the <strong>Update From Original</strong> button in the Property inspector to sync the two images.</td>
</tr>
<tr>
<td>Dimensions of web image are different from selected HTML width and height</td>
<td>The width and height attributes in the HTML code are different from the width and height dimensions of the web image that Dreamweaver created upon insertion. If the web image's dimensions are smaller than the selected HTML width and height values, the web image can appear pixelated.</td>
<td>Use the Update From Original button in the Property inspector to re-create the web image from the original Photoshop file. Dreamweaver uses the currently specified HTML width and height dimensions when it re-creates the image.</td>
</tr>
<tr>
<td>Dimensions of original asset are too small for selected HTML width and height</td>
<td>The width and height attributes in the HTML code are larger than the width and height dimensions of the original Photoshop file. The web image can appear pixelated.</td>
<td>Don't create web images with dimensions larger than the dimensions of the original Photoshop file.</td>
</tr>
<tr>
<td>Original asset not found</td>
<td>Dreamweaver cannot find the original Photoshop file specified in the Original text box of the Property inspector.</td>
<td>Correct the file path in the Original text box of the Property inspector, or move the Photoshop file to the location that’s currently specified.</td>
</tr>
</tbody>
</table>
Copy and paste a selection from Photoshop

You can copy all or some of a Photoshop image and paste the selection into your Dreamweaver page as a web-ready image. You can copy a single layer or a set of layers for a selected area of the image or you can copy a slice of the image. When you do this, however, Dreamweaver does not create a Smart Object.

Note:

While the Update from Original functionality is not available for pasted images, you can still open and edit the original Photoshop file by selecting the pasted image and clicking the Edit button in the Property inspector.

1 In Photoshop, do one of the following:

   - Copy all or part of a single layer by using the Marquee tool to select the portion you want to copy, and then choose Edit > Copy. This copies only the active layer for the selected area into the clipboard. If you have layer-based effects, they are not copied.
   - Copy and merge multiple layers by using the Marquee tool to select the portion you want to copy, and then choose Edit > Copy Merged. This flattens and copies all the selected areas' active and lower layers into the clipboard. If you have layer-based effects associated with any of these layers, they are copied.
   - Copy a slice by using the Slice Select tool to select the slice, and then choose Edit > Copy. This flattens and copies all the slice's active and lower layers into the clipboard.

You can choose Select > All to quickly select all of an image for copying.

2 In Dreamweaver (Design or Code view), place the insertion point on your page where you want the image inserted.

3 Select Edit > Paste.

4 In the Image Optimization dialog box, adjust optimization settings as needed and click OK.

5 Save the web-ready image file to a location within your website's root folder.

Dreamweaver defines the image according to your optimization settings and places a web-ready version of your image in your page. Information about the image, such as the location of the original PSD source file, is saved in a Design Note, regardless of whether you have enabled Design Notes for your site. The Design Note allows you to return to edit the original Photoshop file from Dreamweaver.

Edit pasted images

After you paste Photoshop images in your Dreamweaver pages, you can edit the original PSD file in Photoshop. When using the copy/paste workflow, Adobe recommends that you always make your edits to the original PSD file (rather than the web-ready image itself), and then repaste to maintain single sourcing.

Note:

Make sure that you have Photoshop set as your primary external image editor for the file type you want to edit.

1 In Dreamweaver, select a web-ready image that was originally created in Photoshop and do one of the following:

   - Click the Edit button in the image's Property inspector.
   - Press Control (Windows) or Command (Macintosh) as you double-click the file.
   - Right-click (Windows) or Control-click (Macintosh) an image, choose Edit Original With from the context menu, and then choose Photoshop.

Note:
This assumes that Photoshop is set as the primary external image editor for PSD image files. You may also want to set Photoshop as the default editor for JPEG, GIF, and PNG file types.

2 Edit the file in Photoshop.

3 Return to Dreamweaver and paste the updated image or selection into your page.

If you want to reoptimize the image at any time, you can select the image and click the Edit Image Settings button in the Property inspector.

Setting Image Optimization dialog box options

When you create a Smart Object or paste a selection from Photoshop, Dreamweaver displays the Image Optimization dialog box. (Dreamweaver also displays this dialog box for any other kind of image if you select the image and click the Edit Image Settings button in the Property inspector.) This dialog box lets you define and preview settings for web-ready images using the right mix of color, compression, and quality.

A web-ready image is one that can be displayed by all modern web browsers and looks the same no matter what system or browser the viewer is using. In general, the settings result in a trade-off between quality and file size.

Note:
Whatever settings you select only affect the imported version of the image file. The original Photoshop PSD or Fireworks PNG file always remains untouched.

Preset Choose a Preset that best suits your requirements. The file size of the image changes based on your chosen preset. An instant preview of the image with the applied setting is displayed in the background.

For example, for images that have to be displayed with a high degree of clarity, choose PNG24 for Photos (Sharp Details). Select GIF For Background Images (Patterns) if you are inserting a pattern that will act as the background of the page.

When you select a preset, the configurable options for the preset are displayed. If you want to further customize optimization settings, modify the values for these options.

Work with Adobe Animate and Dreamweaver

Edit a SWF file from Dreamweaver in Animate

If you have both Animate and Dreamweaver installed, you can select a SWF file in a Dreamweaver document and use Animate to edit it. Animate does not edit the SWF file directly; it edits the source document (FLA file) and re-exports the SWF file.

1 In Dreamweaver, open the Property inspector (Window > Properties).

2 In the Dreamweaver document, do one of the following:

- Click the SWF file placeholder to select it; then in the Property inspector click Edit.
- Right-click (Windows) or Control-click (Macintosh) the placeholder for the SWF file, and select Edit With Flash from the context menu.

Dreamweaver switches the focus to Animate, and Animate attempts to locate the Flash authoring file (FLA) for the selected SWF file. If Animate cannot locate the Flash authoring file, you are prompted to locate it.
Note:

*If the FLA file or SWF file is locked, check out the file in Dreamweaver.*

3 In Animate, edit the FLA file. The Animate Document window indicates that you are modifying the file from within Dreamweaver.

4 When you finish making edits, click Done.

Animate updates the FLA file, re-exports it as a SWF file, closes, and then returns the focus to the Dreamweaver document.

Note:

*To update the SWF file and keep Animate open, in Animate select File > Update for Dreamweaver.*

5 To view the updated file in the document, click Play in the Dreamweaver Property inspector or press F12 to preview your page in a browser window.

**Extract web-optimized SVG files from Libraries**

If you have saved Illustrator or licensed, Adobe Stock images in your Creative Cloud Libraries, you can extract them as web-optimized SVG files in your Dreamweaver web pages. When you drag the images from the Libraries panel into your web pages, they are inserted as SVG files by default. For more information, see *Reuse graphics stored in Libraries*.

If you want to customize the properties of SVG files, you can edit the preferences in *options.json* file that is present in the following location:

- **Windows**: `%appdata%\Adobe\Dreamweaver CC 2015\<locale>\Configuration\SVGOptions\`
- **Mac**: `~/Library/Application Support/Adobe/Dreamweaver CC 2015\<locale>\Configuration/SVGOptions/`

The JSON object for converting .ai files to SVG files can contain the following properties:

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>trimToArtBounds</td>
<td>boolean</td>
<td>The SVG covers the art bounds independent of the dimension of the OMG document.</td>
</tr>
<tr>
<td>useViewBox</td>
<td>boolean</td>
<td>If trimToArtBounds and useViewBox are set to true, the content of the document will not be shifted. Instead, the viewBox value of the root SVG element is modified to slice and zoom the content to fit the needs.</td>
</tr>
<tr>
<td>constrainToDocBounds</td>
<td>boolean</td>
<td>Clips the visible content to the document bounds.</td>
</tr>
<tr>
<td>preserveAspectRatio</td>
<td>string</td>
<td>Aspect ratio as defined by the SVG specification. Setting preserveAspectRatio overrides the computed value of svgWriter. Therefore, it is recommended to not set this value.</td>
</tr>
</tbody>
</table>

*Note*: For *meet* or *xMidYMid* meet use the equivalent string, *xMidYMid*, for reduced file size.
| styling | string | This property is optional and defaults to `class`:
  - `class`: Use the global element and reference the style block with the class attribute.
  - `style`: Use the style attribute to apply styling properties to elements.
  - `attribute`: Use presentation attributes to apply styling properties to elements.
| prefix | string | A prefix that will be added to every ID and class name. This allows unique naming schemes for every SVG document. Multiple SVG documents can be inlined to a single HTML document without an ID or class name clashes as long as the provided prefixes are unique.
| cropRect | object | A rectangle with the properties `x, y, width, height`. `x` and `y` are optional. Defines a rectangle to which the SVG document gets cropped. Padding is created if the dimension is smaller than the crop rectangle.
| minify | | Avoids indentations, newlines and whitespaces in the SVG output. Uses minimal IDs.
| idType | string | • `regular`: The default way to create IDs. Preferable based on layer/object names in the application.
  
  • `minimal`: Creates shortest possible IDs independent of user defined layer/object names in the application.
  
  • `unique`: Create UUIDs based on rfc4122 in the format `xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx`.
| precision | number | The number of digits after the floating point. The number must be in the range of 0 to 10, and if specified otherwise, the number is trimmed. Default is 3.
| isResponsive | boolean | If set to `true`, the SVG document fills the viewport/image area (no width and height attributes set on SVG root.)
| carriageReturn | boolean | By default, `svgWriter` uses the line ending LF. With `carriageReturn` set to `true`, line endings use CRLF.
<table>
<thead>
<tr>
<th><strong>indentation</strong></th>
<th><strong>string</strong></th>
<th>Use a custom string as indentation. For example, use tab indentation. The default value in this case is 2 spaces.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>fillFilter</strong></td>
<td><strong>boolean</strong></td>
<td>Filters apply only to the fill of an element. The stroke is unaffected and gets drawn on top of the filtered content.</td>
</tr>
<tr>
<td><strong>documentUnits</strong></td>
<td><strong>string</strong></td>
<td>mm</td>
</tr>
</tbody>
</table>
Chapter 3: Dreamweaver workspaces and views

The Dreamweaver workspace

Onboarding Dreamweaver
After installing Dreamweaver, when you first launch the application, a QuickStart menu appears on the screen asking you three questions that help you personalize your Dreamweaver workspace according to your needs.

Based on your responses to these questions, Dreamweaver opens in a Developer workspace (a minimal code-focused layout), or a Standard workspace (a split layout with visual tools and an in-app preview as you code).

After you choose a workspace, you choose a color theme that you are comfortable with. You can then get started.

Note:
You can change these workspace preferences any time later using the Edit > Preferences dialog.

Improved Home screen
The Home screen in Dreamweaver gives you quick access to your recently used files, file types, and starter templates.

Depending on your subscription status, the Start workspace may also display content tailored for your requirements.

Dreamweaver displays the Home screen at launch or when no documents are open.

The start workspace in Dreamweaver
Options in the Dreamweaver Start experience

Learn  Click Learn to instantly access the Dreamweaver tutorials from this screen.

Quick Start  Get started creating documents in Dreamweaver by clicking any of the file types displayed.

Starter Templates  Open one of the starter templates packaged with Dreamweaver.

Home  Click Home to go back to the start screen.

You can view the recent files that you have worked on in the start screen. If you do not have any recent files, this tab is blank.

You can also use the search functionality by using the Search icon on the upper-right corner of this screen. When you type a search query, the application displays your recent files, Creative Cloud assets, help links, and stock images that match the search query.

Note:
This Start screen is enabled, and is opened by default.

If you don’t need this Start screen, uncheck Show Start Screen in the Preferences > General dialog box.

You can click Create New to start creating new Dreamweaver files. If you already have files in your system, click Open.

For information on creating and opening documents in Dreamweaver, see Create and open files.

Workspace overview

The Dreamweaver workspace lets you view documents and object properties. The workspace also places many of the most common operations in toolbars so that you can quickly make changes to your documents.
Workspace elements overview

The workspace includes the following elements:

- **The Application bar** is across the top of the application window and contains a workspace switcher, menus (Windows only), and other application controls.
- **The Document toolbar** contains buttons that provide options for different views of the Document window (such as Design view, Live view, and Code view).
- **The Standard toolbar** contains buttons for common operations from the File and Edit menus: New, Open, Save, Save All, Print Code, Cut, Copy, Paste, Undo, and Redo.
- **The toolbar** is on the left side of the application window and contains view-specific buttons.
- **The Document window** displays the current document as you create and edit it.
- **The Property inspector** lets you view and change a variety of properties for the selected object or text. Each object has different properties.
- **The Tag selector** located in the Status bar at the bottom of the Document window. Shows the hierarchy of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all its contents.
- **Panels** help you monitor and modify your work. Examples include the Insert panel, the CSS Designer panel, and the Files panel. To expand a panel, double-click its tab.
- **The Extract panel** lets you upload and view your PSD files on Creative Cloud. Using this panel, you can extract CSS, text, images, fonts, colors, gradients, and measurements from your PSD comps into your document.
- **The Insert panel** contains buttons for inserting various types of objects, such as images, tables, and media elements, into a document. Each object is a piece of HTML code that lets you set various attributes as you insert it. For example, you can insert a table by clicking the Table button in the Insert panel. If you prefer, you can insert objects using the Insert menu instead of the Insert panel.
- **The Files panel** lets you manage your files and folders, whether they are part of a Dreamweaver site or on a remote server. The Files panel also lets you access all the files on your local disk. For more information, see Manage files and folders.
- **The Snippets panel** lets you save and reuse your code snippets across different web pages, different sites, and different installations of Dreamweaver (using sync settings). For more information, see Reuse code with snippets.
- **The CSS Designer panel** is a CSS Property Inspector that lets you "visually" create CSS styles, files, and set properties, along with media queries.

*Note:*

Dreamweaver provides many other panels, inspectors, and windows. To open the panels, inspectors, and windows, use the Window menu.

Document window overview

The Document window shows the current document. To switch views of the document, use the view options on the Document toolbar.

You can also switch views, using the View options in the View menu.

**Live view** displays a realistic representation of what your document will look like in a browser, and lets you interact with the document exactly as you would in a browser. You can edit HTML elements directly in Live View and instantly
preview your changes in the same view as well. For more information on editing in Live View, see Live View Property Inspector.

**Design view** is a design environment for visual page layout, visual editing, and rapid application development. In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what you would see when viewing the page in a browser.

**Code view** is a hand-coding environment for writing and editing HTML, JavaScript, and any other kind of code.

**Code - Code** is a split version of Code view that lets you scroll to work on different sections of the document at the same time.

**Code - Live** lets you see both Code view and Live view for the same document in a single window.

**Code - Design** lets you see both Code view and Design view for the same document in a single window.

**Live Code** displays the actual code that a browser uses to execute the page, and can dynamically change as you interact with the page in Live view.

When a Document window is maximized (the default), tabs appear at the top of the Document window showing the filenames of all open documents. Dreamweaver displays an asterisk after the filename if you have made changes that you haven’t saved yet.

Dreamweaver also displays the Related Files toolbar below the document’s tab (or below the document’s title bar if you are viewing documents in separate windows). Related documents are documents associated with the current file, such as CSS files or JavaScript files. To open one of these related files in the Document window, click its filename in the Related Files toolbar.

**Switch between views**

Use the Document toolbar to toggle between different views quickly. For more information, see Document toolbar overview.

You can also switch between views using the following options in the View menu:

- Code view only: Select Code
- Split view: Select Split and select any of the split options
- View mode: Toggle between Live and Design views
- Switch Views: To switch views from one view to another.
Cascade, tile, or rearrange document windows
If you have many documents open at once, you can cascade or tile them.
To cascade document windows: select Window > Arrange > Cascade.
To tile document windows:
- (Windows) Select Window > Arrange > Tile Horizontally or Tile Vertically.
- (Macintosh) Select Window > Arrange > Tile.
When you open more than one file, the Document windows are tabbed. To rearrange the order of tabbed Document windows, drag a window’s tab to a new location in the group.

Resize document window
The Status bar displays the Document window’s current dimensions (in pixels). To design a page that looks its best at a specific size, you can adjust the Document window to any of the predetermined sizes, edit those predetermined sizes, or create sizes.
When you change the view size of a page in design or live view only the dimensions of the view size change. The document size is unaltered.
In addition to predetermined and custom sizes, Dreamweaver also lists sizes specified in a media query. When you select a size corresponding to a media query, Dreamweaver uses the media query to display the page. You can also change the page orientation to preview the page for mobile devices where the page layout changes based on how the device is held.
To resize the document window, select one of the sizes from the Window Size pop-up menu at the bottom of the Document window.

The window size shown reflects the inside dimensions of the browser window, without borders; the monitor size or mobile device is listed to the right.

Note:
For less precise resizing, use your operating system's standard methods of resizing windows, such as dragging the lower-right corner of a window.

**Note:**

(Windows only) Documents within the Document window are maximized by default, and you can’t resize a document when it’s maximized. To de-maximize the document, click the de-maximize button in the upper right corner of the document.

### Change the values listed in the Window Size pop-up menu

1. Select Edit Sizes from the Window Size pop-up menu.
2. Click any of the width or height values in the Window Sizes list, and type a new value. To make the Document window adjust only to a specific width (leaving the height unchanged), select a height value and delete it.
3. Click the Description box to enter descriptive text about a specific size.

### Add a new size to the Window Size pop-up menu

1. Select Edit Sizes from the Window Size pop-up menu.
2. Click the blank space below the last value in the Width column.
3. Enter values for Width and Height.
   
   To set the Width or Height only, simply leave one field empty.
4. Click the Description field to enter descriptive text about the size you added.
49

Dreamweaver workspaces and views

For example, you might type SVGA or average PC next to the entry for an 800 x 600 pixel monitor, and 17-in. Mac next to the entry for an 832 x 624 pixel monitor. Most monitors can be adjusted to a variety of pixel dimensions.

5 Click Apply and close the dialog box.

Your new window size is now available to use in the Window Size pop-up menu.

Document toolbar overview

The Document toolbar contains buttons that let you toggle between different views of your document quickly. The toolbar also contains some common commands and options related to viewing the document and transferring it between the local and remote sites.

![Document toolbar]

The following options appear in the Document toolbar:

- **Code View** Displays only the Code view in the Document window.
- **Split View** Splits the Document window between the Code and the Live/Design views. Design view option is not available for fluid grid documents.
- **Live View** Is an interactive preview that accurately renders HTML5 projects and updates in real time to show your changes as you make them. You can also edit HTML elements in Live View. The drop-down list adjacent to the Live options lets you switch between Live and Design views. This drop-down list is not available in fluid grid documents.
- **Design View** Displays a representation of the document showing how the user views it in a web browser.

Standard toolbar overview

The Standard toolbar To display the Standard toolbar, select Window > Toolbars > Standard. The toolbar contains buttons for common operations from the File and Edit menus: New, Open, Save, Save All, Print Code, Cut, Copy, Paste, Undo, and Redo.

Browser Navigation toolbar overview

The Browser Navigation toolbar becomes active in Live view (only if you have enabled it by selecting Window > Toolbars -> Standard), and shows you the address of the page you’re looking at in the Document window. Live view acts like a regular browser, so even if you browse to a site outside of your local site (for example, http://www.adobe.com), Dreamweaver will load the page in the Document window.
By default, links are not active in **Live** view. Having links non-active lets you select or click link text in the **Document** window without being taken to another page. To test links in **Live** view, you can enable one-time clicking or continuous clicking by selecting **View > Live View Options > Follow Links (Ctrl+Click Link)** or **Follow Links Continuously**.

**Toolbar overview**

The toolbar appears vertically on the left side of the **Document** window, and is visible in all views - **Code**, **Live**, and **Design**. The buttons on the toolbar are view-specific and appear only if they are applicable to the view you are working in. For example, if you are working in **Live** view, then **Code** view-specific options such as Format Source Code are not visible.

**Customize toolbar**

You can choose to customize this toolbar according to your needs by adding menu options, or removing unwanted menu options from the toolbar.

To customize the toolbar, do the following:

1. Click ![Toolbar](image) in the Toolbar, to open the Customize Toolbar dialog box.
2. Select or deselect the menu options that you want available in the toolbar and click Done to save your toolbar. To restore the default toolbar buttons, click Restore Default in the Customize Toolbar dialog box.

Status bar overview
The Status bar at the bottom of the Document window provides additional information about the document you are creating.

Tag selector
Shows the hierarchy of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all its contents. Click <body> to select the entire body of the document. To set the class or ID attributes for a tag in the tag selector, right-click (Windows) or Control-click (Macintosh) the tag and select a class or ID from the context menu.

Output panel
Click this icon to display the Output panel that shows coding errors in your document.
Code coloring

(Only available in Code view)
Select any of the coding languages from this pop-up menu to change the coloring of the code to display according to the programming language.

Insert and Overwrite toggle

(Only available in Code view)
Allows you to toggle between Insert and Overwrite modes while working in Code view.

Line and column number

(Only available in Code view)
Displays the line number and column number where the cursor is located.

Property inspector overview

The Property Inspector (Window > Properties) lets you examine and edit the most common properties for the currently selected page element, such as text or an inserted object.

The contents of the Property Inspector vary depending on the element selected. For example, if you select an image on your page, the Property Inspector changes to show properties for the image (such as the file path to the image, the width and height of the image, the border around the image, if any, and so on).

![Property Inspector](image)

The Property Inspector is at the lower edge of the workspace by default, but you can undock it and make it a floating panel in the workspace.

*Note:*

Use the Tag inspector to view and edit every attribute associated with a given tag’s properties.

To access help for a particular Property inspector, click the help button in the upper right corner of the Property inspector, or select Help from a Property inspector’s Options menu.

View and change properties of a page element

1. Select the page element in the Document window.
   
   You may have to expand the Property inspector to view all the properties of the selected element.

2. Change any of the properties in the Property inspector.
   
   *Note:*
   
   *For information on specific properties, select an element in the Document window, and then click the Help icon in the upper-right corner of the Property inspector.*

3. If your changes are not immediately applied in the Document window, apply the changes in one of these ways:
   
   • Click outside the property-editing text fields.
Dreamweaver workspaces and views

- Press Enter (Windows) or Return (Macintosh).
- Press Tab to switch to another property.

Context menus

Context menus provide convenient access to the most useful commands and properties related to the object or window you're working with. Context menus list only those commands that are applicable to the current selection.

To open a context menu, right-click (Windows) or Ctrl+Click (Mac) a section of code in Code view, or an object in Live or Design Views.

Rearranging panels in Dreamweaver

You can customize the placement and appearance of all the Dreamweaver panels according to your requirements.

Dock and undock panels

- To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.
- To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.
- To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock or make it free-floating.

Move panels

As you move panels, you see blue highlighted drop zones, areas where you can move the panel. For example, you can move a panel up or down in a dock by dragging it to the narrow blue drop zone above or below another panel. If you drag to an area that is not a drop zone, the panel floats freely in the workspace.

- To move a panel, drag it by its tab.
- To move a panel group, drag the title bar.

Note:

Press Ctrl (Windows) or Command (Mac OS) while moving a panel to prevent it from docking. Press Esc while moving the panel to cancel the operation.

Add and remove panels

If you remove all panels from a dock, the dock disappears. You can create a dock by moving panels to the right edge of the workspace until a drop zone appears.

- To remove a panel, right-click (Windows) or Control-click (Mac) its tab and then select Close, or deselect it from the Window menu.
- To add a panel, select it from the Window menu and dock it wherever you want.

Manipulate panel groups

- To move a panel into a group, drag the panel's tab to the highlighted drop zone in the group.
- To rearrange panels in a group, drag a panel's tab to a new location in the group.
- To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.
- To move a group, drag the title bar (the area above the tabs).

Stack floating panels
When you drag a panel out of its dock but not into a drop zone, the panel floats freely. The floating panel allows you to position it anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when you drag the topmost title bar.

- To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.
- To change the stacking order, drag a panel up or down by its tab.
- To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

**Resize panels**

- To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also double-click the tab area (the empty space next to the tabs).
- To resize a panel, drag any side of the panel.

**Collapse and expand panel icons**

You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the default workspace.

- To collapse or expand all panel icons in a column, click the double arrow at the top of the dock.
- To expand a single panel icon, click it.
- To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text disappears. To display the icon text again, make the dock wider.
- To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel's title bar.

**Create custom workspaces**

You can customize your workspace by adding or removing panels according to your requirements. You can then save these changes to your workspace by saving it to access later from the Workspace Switcher in the Document toolbar.

By saving the current size and position of panels as a named workspace, you can restore that workspace even if you move or close a panel.

**To save a custom workspace:**

2. Type a name for the workspace.

The workspace is saved and is visible in the Workspace switcher in the Document toolbar.

**To delete a custom workspace:**

Select Manage Workspaces from the workspace switcher in the Application bar to open the Manage Workspaces dialog box. Select the workspace, and then click Delete.

**Display or switch workspaces**

Select a workspace from the workspace switcher in the Document toolbar.

**Customizing Dreamweaver in multi-user systems**

You can customize Dreamweaver to suit your needs even in a multiuser operating system such as Windows XP or Mac OS X.
Dreamweaver prevents any user’s customized configuration from affecting any other user’s customized configuration. To accomplish this goal, the first time you run Dreamweaver in one of the multiuser operating systems that it recognizes, the application creates copies of a variety of configuration files. These user configuration files are stored in a folder that belongs to you.

If you reinstall or upgrade Dreamweaver, Dreamweaver automatically makes backup copies of existing user configuration files, so if you customized those files by hand, you still have access to the changes you made.

**Display tabbed documents (On Mac only)**

You can view multiple documents in a single Document window by using tabs to identify each document. You can also display them as part of a floating workspace, in which each document appears in its own window.

**Open a tabbed document in a separate window**

Control-click the tab and select Move To New Window from the context menu.

**Change the default tabbed document setting**

1. Select Dreamweaver > Preferences, and then select the General category.
2. Select or deselect Open Documents in Tabs, and click OK.

Dreamweaver does not alter the display of documents that are currently open when you change preferences. Documents opened after you select a new preference, however, display according to the preference you selected.

The Welcome screen appears when you start Dreamweaver and anytime that you do not have any documents open. You can choose to hide the Welcome screen, and then later display it again. When the Welcome screen is hidden and no documents are open, the Document window is blank.

**Common Dreamweaver panels**

You work with a number of panels in Dreamweaver. Some of the commonly used panels are described here.

**Insert panel overview**

The Insert panel (Window > Insert) contains buttons for creating and inserting objects such as tables, images, and links. The buttons are organized into several categories, which you can switch by selecting the desired category from the drop-down list at the top.
Some categories have buttons with pop-up menus. When you select an option from a pop-up menu, it becomes the default action for the button. For example, if you select Line Break from the Character button’s pop-up menu, the next time you click the Character button, Dreamweaver inserts a line break. Anytime you select a new option from the pop-up menu, the default action for the button changes.
The **Insert** panel is organized in the following categories:

**HTML**  Lets you create and insert the most commonly used HTML elements such as div tags and objects, such as images, and tables.

**Form**  Contains buttons for creating forms and inserting form elements, such as search, month, and password.

**Templates**  Lets you save the document as a template and mark specific regions as editable, optional, repeating, or editable optional regions.

**Bootstrap components**  Contains Bootstrap components to provide navigation, containers, dropdowns, and more that you can use in responsive projects.

**jQuery Mobile**  Contains buttons for building sites that use jQuery Mobile.

**jQuery UI**  Lets you insert jQuery UI elements such as accordion, sliders, and buttons.

**Favorites**  Lets you group and organize the Insert panel buttons you use the most in one common place.

**Note:**

*If you are working with certain types of files, such as XML, JavaScript, Java, and CSS, the Insert panel and the Design view option are dimmed because you cannot insert items into these code files.*

### Insert object

To insert an object using the Insert panel:

1. Select the appropriate category from the Category pop-up menu of the Insert panel.
2. Do one of the following:
   - Click an object button or drag the button’s icon into the Document window (into Design, Live, or Code View).
   - Click the arrow on a button, then select an option from the menu.

   Depending on the object, a corresponding object-insertion dialog box may appear, prompting you to browse to a file or specify parameters for an object. Or, Dreamweaver may insert code into the document, or open a tag editor or a panel for you to specify information before the code is inserted.

   For some objects, no dialog box appears if you insert the object in Design view, but a tag editor appears if you insert the object in Code view. For a few objects, inserting the object in Design view causes Dreamweaver to switch to Code view before inserting the object.

### Edit Insert panel preferences

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. In the General category of the Preferences dialog box, deselect Show Dialog When Inserting Objects to suppress dialog boxes when you insert objects such as images, tables, scripts, and head elements or by holding down the Control key (Windows) or the Option key (Macintosh) while creating the object.

**Note:**

*When you insert an object with this option off, the object is given default attribute values. Use the Property inspector to change object properties after inserting the object.*

### Add, delete, or manage items in the Favorites category of the Insert panel

1. Select any category in the Insert panel.
2. Right-click (Windows) or Control-click (Macintosh) in the area where the buttons appear, and then select Customize Favorites.
3 In the Customize Favorite Objects dialog box, make changes as necessary, and click OK.

To add an object, select an object in the Available Objects pane on the left, and then click the arrow between the two panes or double-click the object in the Available Objects pane.

![Customize favorites in the Insert panel](image)

**Note:**

You can add one object at a time. You cannot select a category name, such as Common, to add an entire category to your favorites list.

- To delete an object or separator, select an object in the Favorite Objects pane on the right, and then click the Remove Selected Object in Favorite Objects List button above the pane.
- To move an object, select an object in the Favorite Objects pane on the right, and then click the Up or Down arrow button above the pane.
- To add a separator below an object, select an object in the Favorite Objects pane on the right, and then click the Add Separator button below the pane.

4 If you’re not in the Favorites category of the Insert panel, select that category to see your changes.

**Files panel overview**

Use the Files panel to view and manage the files on your Dreamweaver site.

You can use the Files panel to view files and folders, check whether they are associated with a Dreamweaver site or not, and perform standard file maintenance operations, such as opening and moving files.

The Files panel also helps you manage and transfer files to and from a remote server.
Dreamweaver workspaces and views

For more information on all you can do with the Files panel, see Manage files and folders.

CSS Designer

CSS Designer panel (Windows > CSS Designer) is a CSS Property Inspector that lets you 'visually' create CSS styles, files, and set properties, along with media queries.

You can use Ctrl/Cmd + Z to undo or Ctrl/Cmd + Y to redo all actions you perform in CSS Designer. The changes are automatically reflected in Live View and the relevant CSS file is also refreshed. To let you know that the related file has changed, the affected file's tab is highlighted for a while (around 8 seconds).
The CSS Designer panel consists of the following panes and options:

**All** Lists all the CSS, media queries, and selectors associated with the current document. You can filter for the required CSS rules and modify the properties. You can also use this mode to begin creating selectors or media queries.

This mode is not sensitive to the selection. This means, when you select an element on the page, the associated selector, media query, or CSS are not highlighted in CSS Designer.

**Current** Lists all the computed styles for any selected element in Design or Live view of the current document. When you use this mode for a CSS file in Code view, all the properties for the selector in focus are displayed.

This mode is context-sensitive. Use this option to edit the properties of selectors associated with selected elements in the document.

**Sources** Lists all the CSS style sheets associated with the document. Using this pane, you can create and attach a CSS to the document, or define styles within the document.
@Media  Lists all the media queries in the source selected in the Sources pane. If you do not select a specific CSS, this pane displays all the media queries associated with the document.

Selectors  Lists all the selectors in the source selected in the Sources pane. If you also select a media query, this pane narrows down the list of selectors for that media query. If no CSS or media queries are selected, this pane displays all the selectors in the document.

When you select Global in the @Media pane, all the selectors that are not included in a media query of the selected source are displayed.

Properties  Displays properties that you can set for the specified selector. For more information, see Set CSS properties.

If you collapse or expand the panes in CSS Designer, the sizes of the panes are remembered within a session. Sources and Media panes stick to the customized sizes until you change their sizes again.

Note: When you select a page element, the most specific Selector is selected in the Selectors pane. To view the properties of a specific Selector, click the name of that Selector in the pane.

To view all the selectors, you can choose All Sources in the Sources pane. To view selectors that do not belong to any media query in the selected source, click Global in the @Media pane.

Visual guides overview
Dreamweaver provides several kinds of visual guides to help you design documents and predict approximately how they appear in browsers. You can do any of the following:

• Instantly snap the Document window to a desired window size to see how the elements fit on the page.
• Use a tracing image as the page background to help you duplicate a design created in an illustration or image-editing application such as Adobe® Photoshop® or Adobe® Fireworks®.
• Use rulers and guides to provide a visual cue for precise positioning and resizing of page elements.
• Use the grid for precise positioning and resizing of absolutely positioned elements (AP elements).

Grid marks on the page help you align AP elements, and when snapping is enabled, AP elements automatically snap to the closest grid point when moved or resized. (Other objects, such as images and paragraphs, do not snap to the grid.) Snapping works regardless of whether the grid is visible.

Zoom in and out of a page
Dreamweaver lets you increase the magnification (zoom in) in the Document window so that you can check the pixel accuracy of graphics, select small items more easily, design pages with small text, design large pages, and so on.

To zoom in or out of a page, select View > Design View Options > Magnification, and choose any of the magnification options available.

You can choose from a variety of magnification options. You can also choose to:

• Fit Selection - Select an object or text, and choose this option to fill the Document window with the selection.
• Fit All - Fill the Document window with an entire page
• Fit Width - Fill the Document window with the entire width of a page

Note:
You can also zoom in without using the Zoom tool by pressing Control+= (Windows) or Command+= (Macintosh). You can also zoom out without using the Zoom tool by pressing Control+- (Windows) or Command+- (Macintosh).
Set General preferences for Dreamweaver

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Set any of the following options:

**Open Documents In Tabs**

- **Update links automatically**: Opens all documents in a single window with tabs that let you switch between documents (Mac only).

**Show Start Screen**

- Displays the Dreamweaver Welcome screen when you start Dreamweaver or when you don’t have any documents open.

**Reopen Documents on Startup**

- Opens any documents that were open when you closed Dreamweaver. If this option is not selected, Dreamweaver displays the Welcome screen or a blank screen when you start (depending on your Show Welcome Screen setting).

**Warn When Opening Read-Only Files**

- Alerts you when you open a read-only (locked) file. Choose to unlock/check out the file, view the file, or cancel.

**Enable Related Files**

- Lets you see which files are connected to the current document (for example, CSS or JavaScript files). Dreamweaver displays a button for each related file at the top of the document, and opens the file if you click the button.

**Discover Dynamically-Related Files**

- Lets you select whether Dynamically-Related Files appear in the Related Files toolbar automatically, or after manual interaction. You can also choose to disable the discovery of Dynamically-Related Files.

**Update Links When Moving Files**

- Determines what happens when you move, rename, or delete a document within your site. Set this preference to always update links automatically, never update links, or prompt you to perform an update. (See Update links automatically.)

**Show Dialog When Inserting Objects**

- Determines whether Dreamweaver prompts you to enter additional information when inserting images, tables, Shockwave movies, and certain other objects by using the Insert panel or the Insert menu. If this option is off, the dialog box does not appear and you must use the Property inspector to specify the source file for images, the number of rows in a table, and so on. For rollover images and Fireworks HTML, a dialog box always appears when you insert the object, regardless of this option setting. (To temporarily override this setting, Control-click (Windows) or Command-click (Macintosh) when creating and inserting objects.)

**Enable Double-Byte Inline Input**

- Lets you enter double-byte text directly into the Document window if you are using a development environment or language kit that facilitates double-byte text (such as Japanese characters). When this option is deselected, a text input window appears for entering and converting double-byte text; the text appears in the Document window after it is accepted.

**Switch To Plain Paragraph After Heading**

- Specifies that pressing Enter (Windows) or Return (Macintosh) at the end of a heading paragraph in Design or Live view creates a new paragraph tagged with a p tag. (A heading paragraph is one that’s tagged with a heading tag such as h1 or h2.) When the option is disabled, pressing Enter or Return at the end of a heading paragraph creates a new paragraph tagged with the same heading tag (allowing you to type multiple headings in a row and then go back and fill in details).

**Allow Multiple Consecutive Spaces**

- Specifies that typing two or more spaces in Design or Live view creates nonbreaking spaces that appear in a browser as multiple spaces. (For example, you can type two spaces between sentences, as you would on a typewriter.) This option is designed mostly for people who are used to typing in word processors. When the option is disabled, multiple spaces are treated as a single space (because browsers treat multiple spaces as single spaces).
Use **strong** and *em* in Place of **b** and *i* Specifies that Dreamweaver applies the strong tag whenever you perform an action that would normally apply the b tag, and applies the em tag whenever you perform an action that would normally apply the i tag. Such actions include clicking the Bold or Italic buttons in the text Property inspector in HTML mode and choosing Format > Style > Bold or Format > Style > Italic. To use the b and i tags in your documents, deselect this option.

Note: The World Wide Web Consortium discourages use of the b and i tags; the strong and em tags provide more semantic information than the b and i tags do.

Warn when placing editable regions within `<p>` or `<h1>` - `<h6>` tags Specifies whether a warning message is displayed whenever you save a Dreamweaver template that has an editable region within a paragraph or heading tag. The message tells you that users will not be able to create more paragraphs in the region. It is enabled by default.

Limit undo actions to the active document Limits the undo actions to the current file being edited. For example, if you are editing a CSS file, you can undo changes made only to the CSS file.

However if this checkbox is disabled, HTML source and all related CSS files make use of a single undo history and you can undo your actions irrespective of whether you are working with HTML code or in a related CSS file.

Maximum Number of History Steps Determines the number of steps that is remembered by Dreamweaver. (The default value should be sufficient for most users.) If you exceed the given number of steps, the oldest steps are discarded.

Spelling Dictionary Lists the available spelling dictionaries. If a dictionary contains multiple dialects or spelling conventions (such as American English and British English), the dialects are listed separately in the Dictionary pop-up menu.

Set Fonts preferences for documents in Dreamweaver A document's encoding determines how the document appears in a browser. Dreamweaver font preferences let you view a given encoding in the font and size you prefer. The fonts you select in the Fonts Preferences dialog, however, only affect the way fonts appear in Dreamweaver; they do not affect the way the document appears in a visitor's browser. To change the way fonts appear in a browser, you need to change the text by using the Property inspector or by applying a CSS rule.

For information on setting a default encoding for new documents, see Creating and opening documents.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac).
2 Select Fonts from the Category list on the left.
3 Select an encoding type (such as Western European or Japanese) from the Font Settings list.
   
   **Note:**
   
   To display an Asian language, you must be using an operating system that supports double-byte fonts.
4 Select a font and size to use for each category of the selected encoding.
   
   **Note:**
   
   To appear in the font pop-up menus, a font must be installed on your computer. For example, to see Japanese text you must have a Japanese font installed.

Proportional Font The font that Dreamweaver uses to display normal text (for example, text in paragraphs, headings, and tables). The default depends on your system’s installed fonts. For most U.S. systems, the default is Times New Roman 12 pt. (Medium) on Windows and Times 12 pt. on Mac OS.
Fixed Font  The font Dreamweaver uses to display text within pre, code, and tt tags. The default depends on your
system's installed fonts. For most U.S. systems, the default is Courier New 10 pt. (Small) on Windows and Monaco
12 pt. on Mac OS.

Code View  The font used for all text that appears in the Code view and Code inspector. The default depends on your
system's installed fonts.

Customize Dreamweaver highlighting colors
Use the Highlighting preferences to customize the colors that identify template regions, library items, third-party tags,
layout elements, and code in Dreamweaver.

1 Select Edit > Preferences and select the Highlighting category.

2 Beside the object you want to change the highlighting color for, click the color box, and then use the color picker to
select a new color, or enter a hexadecimal value.

3 To activate or deactivate highlighting for a particular option, select or deselect the Show option.

Optimize Dreamweaver workspace for visual
development

Display web-application development panels
Select the Data category from the Category pop-up menu of the Insert panel to display a set of buttons that let you add
dynamic content and server behaviors to your page.

The number and type of buttons that appear vary depending upon the document type opened in the Document
window. Move your mouse over an icon to display a tooltip that describes what that button does.

The Insert panel includes buttons to add the following items to the page:

- Recordsets
- Dynamic text or tables
- Record navigation bars

If you switch to Code view (View > Code), additional panels might appear in their own Insert panel category,
allowing you to insert code in the page. For example, if you view a ColdFusion page in Code view, a CFML panel
becomes available in the CFML category of the Insert panel.

Several panels provide ways for you to create dynamic pages:

- Select the Bindings panel (Window > Bindings) to define sources of dynamic content for your page and add the
  content to the page.
- Select the Server Behaviors panel (Window > Server Behaviors) to add server-side logic to your dynamic pages.
- Select the Databases panel (Window > Databases) to explore databases or create database connections.
- Select the Components panel (Window > Components) to inspect, add, or modify code for ColdFusion
  components.
Dreamweaver workspaces and views

Note:
The Components panel is enabled only if you open a ColdFusion page.

A server behavior is the set of instructions inserted in a dynamic page at design time and executed on the server at run time.

For a tutorial on setting up the development workspace, see www.adobe.com/go/vid0144.

View your database within Dreamweaver
After connecting to your database, you can view its structure and data within Dreamweaver.

1 Open the Databases panel (Window > Databases).

   The Databases panel displays all the databases for which you created connections. If you're developing a ColdFusion site, the panel displays all the databases that have data sources defined in the ColdFusion Administrator.

   Note:
   
   Dreamweaver looks at the ColdFusion server you defined for the current site.

   If no database appears in the panel, you must create a database connection.

2 To display the tables, stored procedures, and views in the database, click the Plus (+) sign beside a connection in the list.

3 To display the columns in the table, click a table name.

   The column icons reflect the data type and indicate the primary key of the table.

4 To view the data in a table, right-click (Windows) or Control-click (Macintosh) the table name in the list, and select View Data from the pop-up menu.

Preview dynamic pages in a browser
Web application developers often debug their pages by checking them often in a web browser. You can quickly view dynamic pages in a browser without first manually uploading them to a server (press F12).

To preview dynamic pages, you must complete the Testing Server category of the Site Definition dialog box.

You can specify that Dreamweaver use temporary files instead of the original files. With this option, Dreamweaver runs a temporary copy of the page on a web server before displaying it in your browser. (Dreamweaver then deletes the temporary file from the server.) To set this option, select Edit > Preferences > Preview In Browser.

The Preview In Browser option does not upload related pages such as a results or a detail page, dependent files such as image files, or server-side includes. To upload a missing file, select Window > Site to open the Site panel, select the file under Local Folder, and click the blue up arrow in the toolbar to copy the file to the web server folder.

Restrict database information displayed in Dreamweaver
Advanced users of large database systems like Oracle should restrict the number of database items retrieved and displayed by Dreamweaver at design time. An Oracle database may contain items that Dreamweaver cannot process at design time. You can create a schema in Oracle and use it in Dreamweaver to filter out unnecessary items at design time.

   Note:
   
   You cannot create a schema or catalog in Microsoft Access.
Other users may benefit from restricting the amount of information Dreamweaver retrieves at design time. Some databases contain dozens or even hundreds of tables, and you might prefer not to list them all while you work. A schema or catalog can restrict the number of database items that are retrieved at design time.

You must create a schema or catalog in your database system before you can apply it in Dreamweaver. Consult your database system documentation or your system administrator.

**Note:**

You cannot apply a schema or catalog in Dreamweaver if you’re developing a ColdFusion application, or using Microsoft Access.

1. Open a dynamic page in Dreamweaver; then open the Databases panel (Window > Databases).
   - If the database connection exists, right-click (Windows) or Control-click (Macintosh) the connection in the list, and select Edit Connection from the pop-up menu.
   - If the connection does not exist, click the Plus (+) button at the top of the panel and create it.
2. In the dialog box for the connection, click Advanced.
3. Specify your schema or catalog, and click OK.

**Set the Property inspector for ColdFusion stored procedures and ASP commands**

Modify the selected stored procedure. The available options vary depending on the server technology.

? Edit any of the options. When you select a new option in the inspector, Dreamweaver updates the page.

**Input Name options**

This Property inspector appears when Dreamweaver encounters an unrecognized input type. Typically this occurs because of a typing or other data entry error.

If you change the field type in the Property inspector to a value that Dreamweaver recognizes—for example, if you correct the spelling error—the Property inspector updates to show the properties for the recognized type. Set any of the following options in the Property inspector:

- **Input Name** Assigns a name to the field. This box is required, and the name must be unique.
- **Type** Sets the input type of the field. The contents of this box reflect the input type value that currently appears in your HTML source code.
- **Value** Sets the value of the field.
- **Parameters** Opens the Parameters dialog box so you can view the current attributes of the field, as well as add or remove attributes.

**Search files based on filename or content | Mac OS**

This feature is available only for Mac OS.

Use Live Search to locate files based on filename or text present in files. The site selected in the Files panel is used for search. If there is no site selected in the panel, the search option does not appear.
Live Search uses the Spotlight API in Mac OS. Any customization that you apply to Spotlight preferences is also used for Live Search. Spotlight displays all files on your computer that match your search query. Live Search searches files in the local root folder of the site currently selected in the Files panel.

1 Select Edit > Live Search. Alternatively, use CMD+SHIFT+F. The focus is set to the Live Search text box in Files Panel.

2 Enter the word or phrase in the text box. The results are displayed as you enter text in the text box.

   Matching files Displays a maximum of 10 filenames that match your search criteria. The message More Than 10 Results Found is displayed if there are more than 10 matching files. Refine your search criteria if you do not find your desired file in the options displayed.

   Matching Text In Displays a maximum of 10 files that contain text matching the word or phrase you entered. For more options, click Find All. The results are displayed in the Search panel.

3 When you move the mouse cursor over a search result, a tool tip with the root-relative path of the file is displayed. Press Enter, or click the item to open the file.

   For files containing matching text, the first instance of the text is highlighted. Use Cmd+G to navigate to other instances.

   Note:

   To close the Live Search results panel, click outside the panel, or press Escape / Esc
Chapter 4: Set up sites

About Dreamweaver sites

In Dreamweaver the term “site” refers to a local or remote storage location for the documents that belong to a website. A Dreamweaver site provides a way to organize and manage all of your web documents, upload your site to a web server, track and maintain your links, and manage and share files. You should define a site to take full advantage of Dreamweaver features.

Adobe Dreamweaver site is a collection of all of the files and assets in your website. You can create web pages on your computer, upload them to a web server, and maintain the site by transferring updated files whenever you save them. You can also edit and maintain websites that were created without Dreamweaver.

Why define a Dreamweaver site?

You can work in Dreamweaver without setting up (or defining) a site. However, defining a site has many benefits:

- It helps prevent broken links, automatically updating files site-wide if you move or rename a file.
- It helps you perform site-wise find and replace operations, which greatly boosts productivity.
- It helps you publish your site easily, as well as synchronize files between your local hard drive and remote files on the web or a staging server.

To get the best out of Dreamweaver functionalities, start by defining a site. For more information on defining a site, see Set up a local version of your site.

Components of a Dreamweaver site

In Dreamweaver, a site organizes all the documents on your local computer associated with your website and lets you track and maintain links, manage files, and transfer your site files to a web server.

A Dreamweaver site consists of as many as three parts, or folders, depending on your development environment and the type of website you are developing:

- **Local Folder**: This is your working directory—usually a folder on your hard drive. Dreamweaver refers to this folder as your local site root. This folder can also be on a network server. For more information, see Set up a local version of your site.

- **Remote Folder**: This is where you store your files on the computer that's running your web server. The web server is often (but not always) the computer that makes your site publicly available on the web.

Once you finish creating or updating your site, you can then publish your site to a remote server on the internet retaining a local copy to update files when necessary.

For more information, see Connect to a publishing server.

- **Testing folder**: This is the folder where Dreamweaver processes dynamic pages. If you have dynamic forms, PHP content, you can set up the testing folder for your site.
For more information, see Set up a testing server.

Note:
To define a Dreamweaver site, you only need to set up a local folder. To transfer files to a web server or to develop web applications, you must also add information for a remote site and testing server.

Understanding local and remote folder structure

When you want to use Dreamweaver to connect to a remote folder, you specify the remote folder in the Servers category of the Site Setup dialog box. The remote folder that you specify (also referred to as the “host directory”) should correspond to the local root folder of your Dreamweaver site. (The local root folder is the top-level folder of your Dreamweaver site.) Remote folders, like local folders, can have any title, but commonly, Internet Service Providers (ISPs) name the top-level remote folders for individual user accounts public_html, pub_html, or something similar. If you are in charge of your own remote server, and can name the remote folder anything you want, it is a good idea for your local root folder and remote folder to have the same name.

The following example shows a sample local root folder on the left and a sample remote folder on the right. The local root folder on the local machine maps directly to the remote folder on the web server, rather than to any of the remote folder’s sub folders, or folders that exist above the remote folder in the directory structure.

![Diagram of local and remote folder structure]

Note:
The above example illustrates one local root folder on the local machine, and one top-level remote folder on the remote web server. If, however, you are maintaining a number of Dreamweaver sites on your local machine, you would need an equal number of remote folders on the remote server. In such a case the above example would not apply, and you would instead create different remote folders within the public_html folder, and then map them to their corresponding local root folders on your local machine.

When you first establish a remote connection, the remote folder on the web server is usually empty. Then, when you use Dreamweaver to upload all of the files in your local root folder, the remote folder populates with all of your web files. The directory structure of the remote folder and the local root folder should always be the same. (That is, there should always be a one-to-one correspondence between the files and folders in your local root folder, and the files and folders in your remote folder.) If the structure of the remote folder doesn't match the structure of the local root folder, Dreamweaver uploads files to the wrong place, where they might not be visible to site visitors. Additionally, image and link paths can easily break when folder and file structures are not in synch.

The remote folder must exist before Dreamweaver can connect to it. If you don't have a designated folder that acts as your remote folder on the web server, create one or ask your ISP's server administrator to create one for you.
Set up sites

Set up a local version of your site

Although you can work in Dreamweaver without creating a local site root folder, it is a good idea to define a Dreamweaver local site folder for each new website you create.

Creating a local site folder enables Dreamweaver to know where your site files are to create all the internal links correctly, and to update them when you move files to a different location within your site.

For more information on why it is beneficial to create local sites, see Benefits of a Dreamweaver site.

To set up a local version of your site, you must specify the local folder where you plan to store all of your site files.

The local folder can be on your local computer or on a network server. You can use the Site > New Site or Site > Manage Sites dialog boxes in Dreamweaver to set up multiple sites and manage them.

Before you start

Identify or create the folder on your computer where you want to store the local version of your site files. The folder can be anywhere on your computer. You then specify this folder as your local site in Dreamweaver.

For a video tutorial on setting up a new Dreamweaver site, Define a site in Dreamweaver.

Best practices for naming files and folders

Follow these general guidelines for naming files and folders:

• File and folder names in websites should never contain spaces or any of the following characters: /?%*:\"<>.

• Although other special characters are permitted, it is better to confine yourself to alphanumeric characters, hyphens, and underscores.

• Most file and folder names end up as part of a web page’s URL, so keep them short, but meaningful. Long URLs are difficult for users to remember and type into browsers on a mobile device.

• Stick to lowercase letters for file and folder names to avoid file not found issues. Most web servers are Linux –based, which are case-sensitive.

The Site Setup dialog

The Manage Sites dialog box is your gateway into various Dreamweaver site functions. From this dialog box, you can initiate the process for creating a new site, editing an existing site, duplicating a site, removing a site, or importing or exporting a site’s settings.

To set up and manage a site, use the Site > New Site, or Site > Manage Sites dialogs.
Set up sites

The Site setup dialog

**New Site** Click the New Site button to create a new Dreamweaver site. Then specify the name and location for your new site in the Site Setup dialog box.

**Import Site** Click the Import Site button to import a site. For more information, see Import and export Dreamweaver site settings.

**Note:**

*The import site feature only imports site settings that have previously been exported from Dreamweaver. It does not import site files to create a new Dreamweaver site.*

For existing sites, the following options are also available:

**Delete** Deletes the selected site and all of its setup information from your list of Dreamweaver sites; it does not delete the actual site files. (If you want to remove the site files from your computer, you need to do that manually.) To delete a site from Dreamweaver, select the site in the site list and then click the Delete button. You cannot undo this action.

**Edit** Enables you to edit information such as username, password, and server information for an existing Dreamweaver site. Select the existing site in the site list and click the Edit button to edit the existing site. (The Site Setup dialog box opens once you click the Edit button for a selected site.) For more information on editing existing site options, click the Help button in the various screens of the Site Setup dialog box.

**Duplicate** Creates a copy of an existing site. To duplicate a site, select the site in the site list and click the Duplicate button. The duplicated site appears in the site list with the word “copy” appended to the name of the site. To change the name of the duplicated site, leave the site selected and click the Edit button.

**Export** Enables you to export the selected site's settings as an XML file (*.ste). For more information, see Import and export site settings.
Setting up a local version of your site

1. In Dreamweaver, choose Site > New Site.
2. In the Site Setup dialog box, make sure the Site category is selected.
3. In the Site Name text box, enter a name for your site. This name appears in the Files panel and in the Manage Sites dialog box; it does not appear in the browser.
4. In the Local Site Folder text box, specify the folder you identified earlier—the folder on your computer where you want to store the local version of your site files. Click the folder icon to the right of the text box to browse to the folder.

5. If you want to use Git to manage your files for your site, select the Associate a Git Repository With This Site check box.
   - If you are a first time Git user, and you want to associate the site that you are creating with Git, select Initialize As a Git Repository.
   - If you already have a Git login, and want to associate the site that you are creating with an existing repository, select Clone Existing Git Repository Using URL.
6. Click Save to close the Site Setup dialog box. You can now begin working on your local site files in Dreamweaver. This folder location is where you keep the working copies of web pages on your local computer.
Later, if you want to publish your pages and make them publicly available, you have to define a remote folder (or a publishing server)—a place on a remote computer, running a web server that will hold published copies of your local files.

For information on defining and connecting to a remote server (or a publishing server), see Connect to a publishing server.

Set up a testing server

If you plan to develop dynamic pages using server-side languages such as PHP, set up a testing server to generate and display dynamic content while you work.

The testing server can be your local computer, a development server, a staging server, or a production server.

For a detailed overview about the purposes of a testing server, see David Powers's article, Setting up a local testing server in Dreamweaver CS5.

Benefits of setting up a testing server

Setting up a testing server allows you to test all your dynamic code safely without causing any damage to your live website.

You can also work virtually uninterrupted from network failures and Internet outages that might keep you from uploading everything onto a remote server.

In addition by having a local test server, you do not have to waste any time uploading, testing, fixing, reuploading, and retesting your pages.

So if you are testing layouts, shopping carts, or any other script – set up a testing server.

Another benefit of a testing server is that Dreamweaver automatically syncs dynamic documents to your testing server when you open, create, or save changes made to dynamic documents. For more information, see Automatic pushing of dynamic files.

Note:

Analytics and load times will not be accurate unless you are accessing the site from a remote location.

This is especially true of load times—since loading a web site from your local computer is always faster than loading the same web site through a network.

Before you start

Before you set up a testing server from within Dreamweaver, you must set up and install the following:

• A web-server such as Apache
• A database server such as MySQL
• Server-side language such as PHP

Set up a testing server

1 Select Site > Manage Sites.
2 Click New to set up a new site, or select an existing Dreamweaver site and click the edit icon.
3 In the Site Setup dialog box, select the Servers category and do one of the following:
   • Click the Add New Server button to add a new server
   • Select an existing server and click the Edit Existing Server button

4 Specify Basic options just like you would for a remote server connection, and then click the Advanced button. While setting up the basic options, make sure you specify a Web URL in the Basic screen.
   For information on setting up a remote server connection, see Connect to a publishing server.
   For more information on the web URL for the testing server, see About the Web URL for the testing server.

5 Under Testing Server, select the server model you want to use for your web application.

6 Click Save to close the Advanced screen. Then in the Servers category, specify the server you just added or edited as a testing server.

About the Web URL for the testing server

You must specify a Web URL so Dreamweaver can use the services of a testing server to display data and to connect to databases while you work. Dreamweaver uses the design-time connection to provide you with useful information about the database, such as the names of the tables in your database and the names of the columns in your tables.

A Web URL for a testing server consists of the domain name and any of your website's home directory's subdirectories or virtual directories.

Note:
The terminology used in Microsoft IIS may vary from server to server, but the same concepts apply to most web servers.

The home directory The folder on the server mapped to your site's domain name. Suppose the folder you want to use to process dynamic pages is c:\sites\company\, and this folder is your home directory (that is, this folder is mapped to your site's domain name—for example, www.mystartup.com). In that case, the URL prefix is http://www.mystartup.com/.

If the folder you want to use to process dynamic pages is a subfolder of your home directory, simply add the subfolder to the URL. If your home directory is c:\sites\company\, your site's domain name is www.mystartup.com, and the folder you want to use to process dynamic pages is c:\sites\company\inventory. Enter the following Web URL:

http://www.mystartup.com/inventory/

If the folder you want to use to process dynamic pages is not your home directory or any of its subdirectories, you must create a virtual directory.

A virtual directory A folder that is not physically contained in the home directory of the server even though it appears to be in the URL. To create a virtual directory, specify an alias for the folder's path in the URL. Suppose your home directory is c:\sites\company, your processing folder is d:\apps\inventory, and you define an alias for this folder called warehouse. Enter the following Web URL:

http://www.mystartup.com/warehouse/

Localhost Refers to the home directory in your URLs when the client (usually a browser, but in this case Dreamweaver) runs on the same system as your web server. Suppose Dreamweaver is running on the same Windows system as the web server, your home directory is c:\sites\company, and you defined a virtual directory called warehouse to refer to the folder you want to use to process dynamic pages. The following are the Web URLs you would enter for selected web servers:
Note:

By default the ColdFusion MX 7 web server runs on port 8500, the Apache web server runs on port 80, and the Jakarta Tomcat web server runs on port 8080.

For Macintosh users running the Apache web server, your personal home directory is Users/MyUserName/Sites, where MyUserName is your Macintosh user name. An alias called ~MyUserName is automatically defined for this folder when you install Mac OS 10.1 or higher. Therefore, your default Web URL in Dreamweaver is as follows:

http://localhost/~MyUserName/

If the folder you want to use to process dynamic pages is Users:MyUserName:Sites:inventory, then the Web URL is as follows:

http://localhost/~MyUserName/inventory/Choose an application server

For more information, see Choose an application server.

Automatic pushing of dynamic files

A dynamic document is automatically pushed to the testing server when you edit and save it in Live view or Code view. If you want to disable auto push of dynamic files, you can do so in the server settings. For more information, see Disable auto push of dynamic files.

When the files are auto-pushed, Dreamweaver also pushes the dependent files if they are not present on the testing server. If the dependent files are already present on the server, then only the server-side document is pushed to the testing server.

Consider the following scenarios:

Scenario 1: You make changes to the source code and dependent files. The focus is in the source code when you click Save.

In this case, the following dialog box that lists all the affected, dependent files appears:

I was not able to get this screen displayed. Would you be able to give me a screencap?
You can then choose the files that you want to push to the testing server.

**Note:** You can select Always Auto Save the Dependent Files to not see the prompt for subsequent operations. To revert this preference at any point in time, go to the settings of the testing server (Site Setup), and in the Advanced tab, uncheck Always Auto Save Dependent Files.
Set up sites

Scenario 2: You make changes to the source code and dependent files. The focus is on one of the dependent files when you click Save.

In this case, only the dependent file is saved and pushed to the testing server.

**Disable auto push of dynamic files**

You can disable auto-push of dynamic files in the server settings.

1. Go to Site > Manage Sites.
2. Choose your Site and click the edit button. The Site Setup dialog box appears.
3. Go to Servers category.
4. Choose the testing server and click the edit icon.
5. In the popup that appears, click Advanced.

![Disabling auto-push of dynamic files](image)

**Import and export Dreamweaver site settings**

When you define a site, Dreamweaver stores that site’s information in its files.

You can export your site settings as an XML file that you can later import into Dreamweaver. Migrating site settings in this way transfers valuable site information to other machines and product versions. You can also share site settings with other users, and back up site settings.

💡 The import/export feature does not import or export site files. It only imports/exports site settings to save you the time of recreating sites in Dreamweaver. For information on creating a new site in Dreamweaver, see Set up a local version of your site.

**Scenarios where you want to import or export site settings**

- Export your site settings regularly so that you have a backup copy if anything happens to the site.
- If you have set up a site, and then are working with several other people, then you can export and then import site settings on the different computers.
Export your site settings

1. Select Site > Manage sites.

2. Select one or more sites whose settings you want to export and click the Export icon.
   • To select more than one site, Control-click (Windows) or Command-click (Macintosh) each site.
   • To select a range of sites, Shift-click the first and last site in the range.

3. If you have created remote server connections with user name and password information, then Dreamweaver prompts you asking if you want to back up site settings for yourself, or if you want to share settings with others.
   If you want to back up your site settings for yourself, select Back up my settings and click OK.
   Dreamweaver saves remote server login information, such as the user name and password, as well as local path information.
   If you want to share your settings with other users, select Share settings with other users and click OK. Dreamweaver does not save information that would not work for other users, such as your remote server login information and local paths.

   ![Options to export site settings](image.png)

4. For each site whose settings you want to export, browse to a location where you want to save the site file and click Save. (Dreamweaver saves each site's settings as an XML file, with an .ste file extension.)

5. Click Done.
   Note:
   Save the *.ste file to your site root folder or to your desktop to make it easy to find. If you cannot remember where you put it, do a file search on your computer for files with the *.ste extension to locate it.

Import site settings

1. Select Site > Manage sites.

2. Click Import Site.

3. Browse to and select one or more sites—defined in files with an .ste file extension—whose settings you want to import.
   To select more than one site, Control-click (Windows) or Command-click (Macintosh) each .ste file. To select a range of sites, Shift-click the first and last file in the range.

4. Click Open and then click Done.
   After Dreamweaver imports the site settings, the site names appear in the Manage Sites dialog box.
Bring existing websites from a remote server to your local site root

You can use Dreamweaver to copy an existing remote site (or any branch of a remote site) to your local disk and edit it there, even if you didn't use Dreamweaver to create the original site. You must have the correct connection information, and connect to the site's remote server, before you can edit the site.

Scenario when you want to bring websites from a remote server and edit them

Sometimes you have to work on websites that are already published on the web, and for which you no longer have the files.

In such a scenario, you can bring in the files to your local system and edit them in Dreamweaver.

High-level workflow

To get files from a remote server to edit them in Dreamweaver, do the following tasks:

1. Create a local folder to contain the existing site and set up the folder as the local folder for the site.
   
   For more information, see Set up a local version of your site.

   Note:

   You must locally duplicate the entire structure of the relevant branch of the existing remote site.

2. Set up a remote folder, using the remote access information about the existing site. You must connect to the remote site to download the files to your computer before you can edit them.

   For more information, see Connect to a publishing server.

   Make sure to choose the correct root folder for the remote site.

3. In the Files panel (Window > Files), click the Connects To Remote Server button (for FTP access) or the Refresh button (for network access) in the toolbar to view the remote site.

4. Edit the site:

   • If you want to work with the entire site, select the root folder of the remote site in the Files panel, and click Get File(s) from Remote Server in the toolbar to download the entire site to your local disk.

   • If you want to work with just one of the files or folders of the site, locate the file or folder in the Remote view of the Files panel, and click Get File(s) from Remote Server in the toolbar to download that file to your local disk.

   Note:

   When editing only one part of a site, make sure you include dependent files, such as image files.

Dreamweaver automatically duplicates as much of the remote site's structure as is necessary to place the downloaded file in the correct part of the site hierarchy.

Once the files are downloaded, you can see the files appear in the Files panel.

After you are done with your edits, you can then repost the new versions of the files back to the server, or you can set up another remote site in relation to this same local directory, and post the edited files to a different server entirely.
Accessibility features in Dreamweaver

About accessible content
Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other disabilities. Examples of accessibility features for software products and websites include screen reader support, text equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver provides tools that make it accessible to use and tools that help you author accessible content.

For Dreamweaver developers who need to use accessibility features, the application offers screen reader support, keyboard navigation, and operating system accessibility support.

For web designers who need to create accessible content, Dreamweaver assists you in creating accessible pages that contain useful content for screen readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on a page for a user with visual disabilities, the screen reader reads the description.

Note:
For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act (www.section508.gov).

Note:
For more information about Japan Industry Standard accessibility guidelines, see JIS X 8341-3 (www.jisc.go.jp).

No authoring tool can automate the development process. Designing accessible websites requires you to understand accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.

Use screen readers with Dreamweaver
A screen reader recites text that appears on the computer screen. It also reads non-textual information, such as button labels or image descriptions in the application, provided in accessibility tags or attributes during authoring.

As a Dreamweaver designer, you can use a screen reader to assist you in creating your web pages. The screen reader starts reading from the upper-left corner of the Document window.

Dreamweaver supports JAWS for Windows, from Freedom Scientific (www.freedomscientific.com), and Window-Eyes screen readers, from GW Micro (www.gwmicro.com).

Support for operating system accessibility features
Dreamweaver supports accessibility features in both the Windows and Macintosh operating systems. For example, on the Macintosh you set the visual preferences in the Universal Access Preferences dialog box (Apple > System Preferences). Your settings are reflected in the Dreamweaver work space.

The Windows operating system's high contrast setting is also supported. You activate this option through the Windows Control Panel and it affects Dreamweaver as follows:

• Dialog boxes and panels use system color settings. For example, if you set the color to White on Black, all Dreamweaver dialog boxes and panels appear with a white foreground color and black background.
• Code view uses the system and window text color. For example, if you set the system color to White on Black, and then change text colors in Edit > Preferences > Code Coloring, Dreamweaver ignores those color settings and displays the code text with a white foreground color and black background.

• Design view uses the background and text colors you set in Modify > Page Properties so that pages you design render colors as a browser will.

**Optimize the work space for accessible page design**

When you create accessible pages, you need to associate information, such as labels and descriptions, with your page objects to make your content accessible to all users.

To do this, activate the Accessibility dialog box for each object, so that Dreamweaver prompts you for accessibility information when you insert objects. You can activate a dialog box for any of the objects in the Accessibility category in Preferences.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Accessibility from the Category list on the left, select an object, set any of the following options, and click OK.
   - **Show Attributes When Inserting** Select the objects for which you want to activate accessibility dialog boxes. For example, form objects, frames, media, and images.
   - **Keep Focus In The Panel** Maintains focus on the panel, which makes it accessible to the screen reader. (If you don't select this option, the focus remains in Design or Code view when a user opens a panel.)
   - **Offscreen Rendering** Select this option when using a screen reader.

*Note:*

*Accessibility attributes appear in the Insert Table dialog box when you insert a new table.*

**Navigate Dreamweaver using the keyboard**

You can use the keyboard to navigate panels, inspectors, dialog boxes, frames, and tables without a mouse.

*Note:*

*Tabbing and the use of arrow keys are supported for Windows only.*

**Navigate panels**

1. In the Document window, press Control+F6 to shift focus to a panel.
   - A dotted line around the panel title indicates that focus is on that panel. The screen reader reads the panel title bar that has focus.
2. Press Control+F6 again to shift focus until you have focus on the panel you want to work in. (Press Control+Shift+F6 to shift focus to the previous panel.)
3. If the panel you want to work in is not open, use the keyboard shortcuts in the Windows menu to display the appropriate panel; then press Control+F6.
   - If the panel you want to work in is open, but not expanded, place focus on the panel title bar, and then press the Spacebar. Press the Spacebar again to collapse the panel.
4. Press the Tab key to move through the options in the panel.
5 Use the arrow keys as appropriate:
   • If an option has choices, use the arrow keys to scroll through the choices, and then press the Spacebar to make a selection.
   • If there are tabs in the panel group to open other panels, place focus on the open tab, and then use the left or right arrow key to open another tabs. Once you open a new tab, press the Tab key to move through the options in that panel.

**Navigate the Property inspector**
1 Press Control+F3 to display the Property inspector, if it is not visible.
2 Press Control+F6 (Windows only) until you shift focus to the Property inspector.
3 Press the Tab key to move through the Property inspector options.
4 Use the arrow keys as appropriate to move through option choices.
5 Press Control+Down arrow/Up arrow (Windows) or Command Down arrow/Up arrow (Macintosh) to open and close the expanded section of the Property inspector, as necessary, or, with focus on the expander arrow in the lower-right corner, press the Spacebar.
   
   **Note:**
   
   *Keyboard focus must be inside the Property inspector (and not on the panel title) for expanding and collapsing to work.*

**Navigate a dialog box**
1 Press the Tab key to move through the options in a dialog box.
2 Use the arrow keys to move through choices for an option.
3 If the dialog box has a Category list, press Control+Tab (Windows) to shift focus to the category list, and then use the arrow keys to move up or down the list.
4 Press Control+Tab again to shift to the options for a category.
5 Press Enter to exit the dialog box.

**Navigate frames**
? If your document contains frames, you can use the arrow keys to shift focus to a frame.

**Select a frame**
1 Press Alt+Down Arrow to place the insertion point in the Document window.
2 Press Alt+Up Arrow to select the frame that currently has focus.
3 Continue pressing Alt+Up Arrow to shift focus to the frameset, and then to the parent framesets, if there are nested framesets.
4 Press Alt+Down Arrow to shift focus to a child frameset or a single frame within the frameset.
5 With focus on a single frame, press Alt+Left or Right Arrow to move between frames.

**Navigate a table**
1 Use the arrow keys or press Tab to move to other cells in a table as necessary.
Pressing Tab in a right-most cell adds another row to the table.

2 To select a cell, press Control+A (Windows only) while the insertion point is in the cell.

3 To select the entire table, press Control+A twice if the insertion point is in a cell, or once if a cell is selected.

4 To exit the table, press Control+A three times if the insertion point is in a cell, twice if the cell is selected, or once if the table is selected, and then press the Up, Left, or Right Arrow key.

Advanced settings

Access the Advanced settings in the Site Setup dialog box by choosing Site > Manage Sites, selecting the site you want to edit, and clicking Edit.

CSS Preprocessors

If you are working with CSS preprocessors such as Sass, Less, or SCSS, then you can set up site-specific CSS preprocessor preferences.

For information about CSS preprocessor support in Dreamweaver, see Using CSS preprocessors in Dreamweaver.
Advanced Settings

Local Info

Default Images Folder  The folder in which you want to store images for your site. Enter the path to the folder, or click the folder icon to browse to the folder. Dreamweaver uses the path to the folder when you add images to documents.

Links Relative To  Specifies the kind of links Dreamweaver creates when you create links to other assets or pages in your site. Dreamweaver can create two kinds of links: document-relative and site root-relative. For more information on the differences between the two, see Absolute, document-relative, and site root-relative paths.

By default, Dreamweaver creates document-relative links. If you change the default setting and select the Site Root option, make sure the correct Web URL for the site is entered in the Web URL text box (see below). Changing this setting does not convert the path of existing links; the setting will only apply to new links you create visually with Dreamweaver.

Note:

Content linked by site-root relative links does not appear when you preview documents in a local browser unless you specify a testing server, or select the Preview Using Temporary File option in Edit > Preferences > Preview In Browser. This is because browsers don't recognize site roots—servers do.

Web URL  The URL of your website. Dreamweaver uses the Web URL to create site root-relative links, and to verify links when you use the link checker.

Site root-relative links are useful if you are uncertain about the final location in the directory structure of the page you’re working on, or if you think you might later relocate or reorganize files that contain links. Site root-relative links are links whose paths to other site assets are relative to the site root, not the document, so if you move the document at some point, the path to the assets remains correct.

For example, let’s say that you’ve specified http://www.mysite.com/mycoolsite (the remote server’s site root directory) as the Web URL, and that you also have an images folder in the mycoolsite directory on the remote server (http://www.mysite.com/mycoolsite/images). Let’s also say that your index.html file is in the mycoolsite directory. When you create a site root-relative link from the index.html file to an image in the images directory, the link looks as follows:

<img src="/mycoolsite/images/image1.jpg" />

This is different from a document-relative link, which would simply be:

<img src="images/image1.jpg" />

The appendage of /mycoolsite/ to the image source links the image relative to the site root, not the document. Assuming the image stays in the image directory, the file path to the image (/mycoolsite/images/image1.jpg), will always be correct, even if you move the index.html file to another directory.

For more information, see Absolute, document-relative, and site root-relative paths.

With regard to link verification, the Web URL is necessary for determining whether a link is internal or external to the site. For example, if your web URL is http://www.mysite.com/mycoolsite, and the link checker finds a link with a URL of http://www.yoursite.com on your page, the checker determines that the latter link is an external link and reports it as such. Similarly, the link checker uses the Web URL to determine if links are internal to the site, and then checks to see if those internal links are broken.

Case-sensitive Links Checking  Checks that the case of the links matches the case of the filenames when Dreamweaver checks links. This option is useful on UNIX systems wherefilenames are case-sensitive.
Enable Cache  Indicates whether to create a local cache to improve the speed of link and site management tasks. If you do not select this option, Dreamweaver asks you if you want to create a cache again before it creates the site. It is a good idea to select this option because the Assets panel (in the Files panel group) only works if a cache is created.

Cloaking and other categories
For more information on the Cloaking, Design Notes, File View Columns, Contribute, Templates, JQuery, Web Fonts, and Animation Assets categories, click the corresponding topic in the following table.

<table>
<thead>
<tr>
<th>Category</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cloaking</td>
<td>Cloak files and folders in your Dreamweaver site</td>
</tr>
<tr>
<td>Design Notes</td>
<td>Enable Design Notes for Dreamweaver sites</td>
</tr>
<tr>
<td>File View Columns</td>
<td>Manage files and folders</td>
</tr>
<tr>
<td>Contribute</td>
<td>Edit content in Dreamweaver sites using Contribute</td>
</tr>
<tr>
<td>PHP</td>
<td>Set PHP preferences</td>
</tr>
<tr>
<td>Bootstrap</td>
<td>Design responsive websites using Bootstrap</td>
</tr>
<tr>
<td>Templates</td>
<td>About Dreamweaver templates</td>
</tr>
<tr>
<td>JQuery</td>
<td>Use jQuery UI widgets in Dreamweaver</td>
</tr>
<tr>
<td>Web Fonts</td>
<td>Add and modify font combinations in Dreamweaver</td>
</tr>
<tr>
<td>Animation Assets</td>
<td>Import animated compositions into Dreamweaver</td>
</tr>
<tr>
<td>JS Lint</td>
<td>ECMAScript 6 Linting</td>
</tr>
</tbody>
</table>

Set site preferences for transferring files
You can set preferences to control how files are transferred between local and remote sites in the Files panel.

1  Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2  In the Preferences dialog box, select Site from the category list on the left.
3 Set the options and click OK.

**Always Show** Specifies which site (remote or local) is always shown, and in which Files panel pane (left or right) the local and remote files appear.

By default, the local site always appears on the right. Whichever pane is not chosen (the left one by default) is the changeable pane: this pane can display the files in the other site (the remote site by default).

**Dependent Files** Displays a prompt for transferring dependent files (such as images, external style sheets, and other files referenced in the HTML file) that the browser loads when it loads the HTML file. By default, both Prompt on Get/Check Out and Prompt on Put/Check In are selected.

It's usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there's no need to download them again. This is also true for uploading and checking in files: no need if up-to-date copies are already at the destination.

If you deselect these options, your dependent files are not transferred. Therefore, to force the Dependent Files dialog box to appear even when these options are deselected, hold down Alt (Windows) or Option (Macintosh) while choosing the Get, Put, Check In, or Check Out commands.

**FTP Connection** Determines whether the connection to the remote site is terminated after the specified number of minutes have passed with no activity.
FTP Time Out  Specifies the number of seconds in which Dreamweaver attempts to make a connection with the remote server.

If there is no response after the specified amount of time, Dreamweaver displays a warning dialog box alerting you to this fact.

FTP Transfer options  Determines whether Dreamweaver selects the default option, after a specified number of seconds, when a dialog box appears during a file transfer and there is no user response.

Proxy Host  Specifies the address of the proxy server through which you connect to outside servers if you are behind a firewall.

If you are not behind a firewall, leave this space blank. If you are behind a firewall, select the Use Proxy option in the Site Definition dialog box (Servers > Edit Existing Server (pencil icon) > More Options).

Proxy Port  Specifies the port in your proxy or firewall through which you pass to connect to the remote server. If you connect through a port other than 21 (the default for FTP), enter the number here.

Put Options: Save Files Before Putting  Indicates that unsaved files are saved automatically before being put onto the remote site.

Move Options: Prompt Before Moving Files on Server  Alerts you when you attempt to move files on the remote site.

Manage Sites  Opens the Manage Sites dialog box, where you can edit an existing site or create a new one.

You can define whether the types of files that you transfer are transferred as ASCII (text) or binary, by customizing the FTPExtensionMap txt file in the Dreamweaver/Configuration folder (on the Macintosh, FTPExtensionMapMac.txt). For more information see, Extending Dreamweaver.

Specify proxy server settings in Dreamweaver

Several Dreamweaver features require Internet connectivity. If you or your organization is routing Internet connections through a proxy server, you must provide the server credentials for Dreamweaver to connect to the Internet successfully.

You can specify the proxy server credentials in the Adobe Creative Cloud for desktop app. When the Creative Cloud desktop app is first launched, it determines whether or not the Internet connections are routed through a proxy server. If a proxy server is set up, it prompts you to provide the credentials. If the Creative Cloud desktop app is already installed and the proxy server is set up at a later point in time, then too, the app detects the proxy server automatically and prompts for credentials.

When Dreamweaver queries for a connection to the Internet, it will recognize that the credentials have already been set and stored in the Creative Cloud desktop app and leverages them.

If you are an enterprise customer and the installation does not include the Creative Cloud desktop app, you will be prompted by Dreamweaver to provide proxy server credentials.
Proxy server settings prompted by Dreamweaver

To learn more, see Proxy support in Creative Cloud products.

Note:

Contact your system administrator if you need assistance with the proxy server credentials.

Using Git in Dreamweaver

Dreamweaver supports Git, an open source distributed version control system, to manage source code. With the integration of Git in Dreamweaver, you can independently work on your code from anywhere, and later merge your changes to a central Git repository. Git helps you track all the modifications in a file, and lets you revert to the previous versions as well.

Git repositories are also helpful when you work as a team, as Git allows you to easily create and maintain branches. For example, if you are a designer who wants to work on a design change for your site. At the same time, if another team member accommodates change requests for the same site, you both can work independently using Git. In this case, you both can independently create a branch and make your changes in your respective local repository. The local repository contains the full history of all the changes that you made to the source. You can pause and merge your changes with the central repository at any point in time. Merge ensures that the central repository always has the latest code with both your changes.

Read on to know how to get started with using Git in Dreamweaver.

Getting started with Git in Dreamweaver

If you are a new Git user, you must first download a Git client and create a Git account. A Git client is essential before you use Git from within Dreamweaver.

If you are a user who already has a Git account, sign in to your account. Ensure that you have downloaded the Git client to your system.

Perform the following steps to get started with Git in Dreamweaver:

1. Download the Git client for your Operating System.
2. Create an account for your Git client.
   - If you already have a Git account, provide your login credentials to sign in to your Git client.
The Git Panel

It is recommended that you install the Git client with the default configuration settings. Dreamweaver then automatically picks the path to the executable.

You can now launch Dreamweaver and associate your site with a Git repository.

Dreamweaver supports Git operations through the Git panel (Windows > Git). As a Dreamweaver user, you can use this panel to perform common Git operations such as commit, push, pull, fetch.

Note:

You can view this panel in Dreamweaver only after you download the Git client in your computer.

Git panel in Dreamweaver

A Commit  B Fetch all remotes and refresh counters  C Git Pull  D Git Push  E Show repository history  F Show file history  G Create tag  H Open bash/terminal console  I More actions  J Search  K Diff  L Revert file

Associate your site with Git

To start using Git in Dreamweaver, you must first associate your Dreamweaver site with a Git repository. A Git repository is like a folder that you create to help you track file changes. You can have any number of Git repositories on your computer. Each repository on your system is independent. That is, the changes saved in one Git repository do not affect the contents of another.

You can associate your website with a repository either by creating a repository or by cloning an existing repository. When you initialize or create a repository, an empty Git repository is created in your current working directory, with a .gitignore file in the folder.

However, when you clone an existing Git repository, all the files from your parent repository are cloned to your local system.

Read on to know how to initialize a Git repository or Clone an existing repository.

Initialize a Git repository

When you begin working with Git in Dreamweaver, the first step is to create a repository. When you initialize a Git repository for your site, you create a Git repository where you can add the files associated with your Dreamweaver site.

1 As a Dreamweaver user, you can start with a new site. Or, you can have an existing site that you want to associate with a Git repository. Either ways, follow this procedure to initialize a Git repository.

   • To associate a new Dreamweaver site, click Site > New Site.
To associate an existing Dreamweaver site, click Site > Manage Sites. From the Manage Sites dialog box, double-click the site that you want to associate with a Git repository.

2. If you're creating a new site, specify a name for the site.

If you have a folder containing files related to your site, then point to the folder from the Local Site Folder field.

3. Select the Associate a Git Repository with this Site check box. Then, select the Initialize as a Git Repository option.

Specify the name and folder location for your new Dreamweaver site.

If you want to associate your new site with an existing Git repository, ensure that the Local Site Folder points to the appropriate Git repository.
4 Click Save.

Notice that the files from your local folder are now visible in the Files panel (Git View). The files are in an untracked state. That is, these files are not yet committed to your Git repository.

You can continue to work on your files and commit your files later. Else, you can open the Git panel (Windows > Git) and commit your files to your repository. To know how to commit files in Git, see Track and Commit changes.

Clone an existing repository

If you’re already working with an existing Git repository hosted on Github or Bitbucket or other popular hosting services, you can perform the following procedure to clone the repository from within Dreamweaver. When you clone an existing repository, you create a copy of the target repository in your local system.

1 Click Site > New Site.

2 From the Site Setup dialog box, select the Associate a Git Repository With This Site check box. Then, select Clone Existing Git Repository using URL.

3 Enter the URL of the repository that you want to clone.

Ensure that the https URL of the target repository you enter, is valid. To test whether the URL is valid, click the Test button in this dialog box. Invalid URL results in errors while cloning and while performing actions such as Git Fetch or Pull.

4 To save the credentials that you have entered, select the Save Credentials check box. This action saves you from entering your credentials every time you perform remote actions such as Git Push or Pull.

5 Click Save.

After you clone a repository, a local copy of the origin repository is created. You can view and edit the local files from within Dreamweaver.

The snapshot of the original repository that is cloned is shown in the Git panel > Origin at the upper-right corner.
Notice the origin repository from the Git panel

**Using Git for version control**

Now that you have associated your Dreamweaver site with a Git repository, you can view the files in Git from the Files panel (Git view). Git categorizes the files in your local repository as:

- **Untracked files**: Files that you have not committed to the Git repository even once. After you initialize a Git repository, the files are untracked until you commit them.
- **Unmodified files**: Files that are not modified.
- **Modified files**: Files that are edited.
- **Staged files**: Files that are modified and ready to be committed.

Using Git, you can track the modifications for the files. When you modify the files in your local system, the modified files appear in a different color in the Files panel. When you double-click and open the file in Code View, you can also see the gutter mark against the lines that have been modified. You can go ahead and commit your modified files in Git to synchronize the changes.

When you commit your files, Git allows you to enter log messages for each commit and review the changes using the diff feature. You can also view the version history for each file and for the entire repository.

Read on to learn how to track your edits within Dreamweaver, and commit your changes in Git.

**Track edits in Git**

In the Files panel in Dreamweaver, notice the Git icon that allows you to toggle between the FTP view and Git view. Click the Git icon to toggle Git view.

If you had initialized a Git repository, and did not commit your files, the files remain untracked. However, if you had committed your files after initializing your repository, Git recognizes those files.
View the untracked files in the Files panel
If you had cloned all your files from another repository, the files are again recognized by Git.

When you modify a file and click Save, the Files panel displays the modified files in a different color. To view the exact changes in the Code View, double-click the modified file.
Set up sites

Notice the gutter mark in Code View

A guttermark indicates those lines where changes have been made. Guttermarks in green indicate new code that has been added. Guttermark in yellow indicates modified code, while guttermark in red indicates a code line that has been deleted.
When you click the yellow guttermark, the application displays the change in the code. The deleted line of code appears in red while the newly added code appears in green.

Notice an R symbol at the left corner of the deleted lines of code. To add the deleted code back to your file, click the R symbol.

Use the guttermarks to view the diff and review your changes before committing the changes to the Git repository.

**View the diff for modified files**

When you open the Git panel, you can see a list of the modified files. You can click a file in this list and view the changes made to the file after the previous commit (diff). To view the diff for a file, do one of the following from the Git panel:

- To view the edits at a file level, click each file. The red highlights indicate the previous version, while the green highlights indicate the change that you have made now.
- Select the file for which you want to view the diff. Click (Diff icon). The Git Diff dialog box appears, which has the changes highlighted in red and green.
Commit changes
To record all the changes in your local repository, you must commit the changes made in your files. To commit your changes in Git:

1. In the Git panel, select the file or files that you want to Commit.

   ![Commit changes to your local Git repository](image1)

2. Click (Commit icon).

   When you click Commit, the system displays the Git Commit dialog box. This dialog box displays the files that have modifications.

   You can click each file to view the changes, before you proceed to Commit the files.

3. To commit the files, enter a commit message in the message box, and click OK.

   After the files are committed, the files are also cleared from the Git panel.

   ![Commit your changes in Git](image2)

Revert changes
If you have already committed your changes and you want to revert to the previous version of a file, do the following:

1. In the Git panel, select the file or files that you want to revert.

2. Click the sandwich icon in the Git panel, and select Revert Changes Since Last Commit.
The previous version of the files is restored in your local repository. You can view the restored files from the Files panel.

Revert changes after you commit files

**Note:**

*If you want to revert a file after commit, you must have committed the file at least twice.*

3 To revert changes before Commit, perform the following steps:

If you want to retain the last committed version of your file before committing the file:

a In the Git panel, click the file that you want to retain, and click the Refresh icon.

b From the confirmation dialog box, click OK.

The file that you selected is cleared from the modified files list, and the previous version of the file is restored.

Revert file before committing the changes

Create tags

You can create tags whenever you commit your changes in Git. You can use tags to mark important commits. For example, a check-in for a major change requested by your client. The tags act as a pointer to a specific commit.

1 To create a tag, click (Create Tag icon) in the Git panel.

2 From the Create Tag dialog box, specify a name for your tag. Click OK.
Create Tag

Enter tag name

OK  Cancel

Create a tag for your commit

The tag that you created is associated with your commit.

If you create a tag after you perform a commit, the tag is automatically associated with your latest commit.

View file history

Every time you commit a file in Git, you can view the history of the file along with the details of the commit. This capability helps in identifying important commits, and tags associated with commits.

? In the Git panel, do one of the following:
• Select the required file, and click (Show File History icon).
• Right-click the file from the Files panel and select File History.

The system displays the Git File History of the selected file. You can also view the details of the commit for this file from the same dialog box.

View the file history in Git
View repository history
Apart from viewing the history of a file in Git, you can also view the changes made at the repository level. You can view all the changes and commits made at the repository level. To view the repository history, perform the following steps:

1. From the Git panel, click the Show Repository History icon. The system displays the Git Repository History with the details of all the commits.

2. You can view the commit message, date, and time when the files were committed. You can also view the tags associated with a commit, and the details of the user who committed the files.

3. The repository history typically specifies the list of files that were committed at the repository level. You can click each file to view the change history at the file-level.

Using Git for collaboration
One of the most distinct features of Git is branches. Unlike most version control systems, a Git branch can be equated to an independent line of all your associated files or code. By default, your repository has one branch named “master”. The master branch is the main or definitive branch. You can create branches from master, and make edits in each of the branches.

You can also create a branch off another branch, where you are making a copy of the parent branch. You can independently work on both the branches in the same Git repository. For example, you can work on a new feature for your site on one branch while addressing some change requests in another branch.

Git also allows you to merge branches if you want to incorporate the changes from your current branch to a target branch. When you merge two branches, both the branches continue to exist independently. You can continue to work with the parent and the target branches.

In Dreamweaver, when developers and designers work together for a site, each user can create a branch off the master and make changes independently. Whenever required, they can easily merge their changes with another branch, and continue to work with both the branches.

To know more about creating and managing branches in Git, read the following sections:

Create branches in Git
1. From the Files panel, select the drop-down list that lists all the branches.

2. Click Manage Branches.
Create a branch in Git

3 From the Manage Branches dialog box, click the + sign at the lower left corner.
4 In the Create New Branch dialog box, select the origin branch from which you want to make a copy. If it is the first branch that you are creating, the origin branch is your master branch.

![Create New Branch dialog box]

Select the origin branch

5 In the Branch Name field, specify a name for the new branch.

6 Click OK.

**Merge branches**

1 From the Files panel, select the drop-down list that lists all your branches.

2 Click Manage Branches. From the Manage Branches dialog box, select the branch that you want to merge.

3 Click ![Merge Branch icon] at the bottom of the dialog box.

4 From the Merge Branch dialog box, select the Target branch. This branch is the target repository with which you want to merge your branch.

   Optionally, specify a message associated with this merge.

5 Click OK to merge your branch with your target.

![Merge branch dialog box]

Merge branches in Git

If file changes from one commit conflict with the changes from another branch, the merge process is paused. The system displays a conflict message along with the files that are causing the conflict.
The Git panel also displays the files that have a conflict. Notice the icon that indicates that there is a conflict.

To go ahead with the merge, you must first resolve the conflict. You can either use the Rebase option or proceed with the merge by using the no fast forward option.

6 If you encounter a merge conflict, choose one of the following options:

• **Use Rebase**: When you select the rebase option, your current changes are applied over the conflicts in your target branch. After you choose rebase and click OK, open the Git panel to view the files that are yet to be committed. You can then either cancel the rebase or restart rebase. When you cancel rebase, the rebase action is stopped and no changes are applied to the target branch. When you restart rebase, your changes are skipped over the conflicts seen in the target branch.

• **Create a merge commit even when the merge resolves as a fast forward**: You can also merge your commit despite the conflicts seen between your branch and the target branch. In this case, the merge is forced with your changes overriding the changes in the target branch.

To know more about rebase in Git, see [Git Rebasing](#).

### Working with remote repositories

Remote repositories in Git are versions of a project that are hosted in another network. You can access remote repositories by creating a connection with the repository. Depending on the access rights specified in the remote repository, you can either have a read-only access or write access to that repository.

When you work in a team, remote repositories help you push and pull data to and from other repositories. From the Dreamweaver Git panel, you can create a remote connection, perform several Git operations such as Fetch, Git Push, Git Pull, and Remote Refresh.

Read the following procedures to know how to create and manage remote repositories.

#### Add a remote repository

You can add a remote repository to share files, your work progress, and to access your project files hosted in another network. By adding a remote repository, you establish a remote connection with the target repository. Dreamweaver allows you to create remote repositories from the Git panel.

Before you add a remote repository, ensure that the other repository has public settings enabled.

1. From the Git panel, click Create Remote.
2. Specify a name for the remote repository.
3. Enter the URL and the credentials for the remote repository.

   To ensure that you have entered a valid URL while adding a remote repository, click Test after entering the URL. When you click Test, the validity of the URL is tested.
This test is not applicable for validating the credentials.

Add a remote repository

**Note:**

*If you do not enter a valid URL or credentials, you experience errors when you perform Git Pull, Git Push, Fetch and so on.*

4 Click OK.

When you add a remote repository, you see the repository in the drop-down list at the top of the Git panel. You can also view more icons for performing Git Push, Git Pull, Fetch remote, and refresh counters.

Manage remote repositories

After you add a remote repository and establish a connection, you can fetch and pull the files from the remote repository to your local repository. You can also push your files to the remote repository. However, you must first fetch files from the remote repository before you perform a Git Push action for the first time.

Remember to commit all your files in the local repository before you attempt to push your files. If your local repository has staged files, Git Push remains unsuccessful.

You can perform the following Git operations from within Dreamweaver:
**Fetch all**
Click ![arrow](image) to fetch all the files from all your remote connections. It is recommended that you perform a Git Fetch before you perform Git Push or Git Pull. This action only fetches the files from remote, and does not modify your local repository.

**Pull files from remote repository**
You can pull changes from a single repository or from a group of repositories. When you click the Git Pull icon, the system displays the Git Pull dialog box with various options.

1. From the Git panel, click ![arrow](image) (Git Pull icon) to pull the modified files from the remote repository and merge the changes with your local repository.

2. From the Git Pull dialog box, select the tracking branch. Specify whether you want to pull changes from the current branch or another branch, and then set the pull settings.

Perform a Git Pull from remote repositories

3. By default, the Default merge is selected. In this case, the files from remote are pulled into your local repository and the changes are merged to your local.

4. You can also choose one of the following options:
   - **Avoid manual merging**: Select this option to disable manual merging of files.
   - **Merge without commit**: Select this option to proceed with the merge to the remote repository even without committing your staged files.
Set up sites

- **Use rebase**: Select this option to perform a rebase. When you use rebase, the changes from your current branch are taken and applied on the history of the branch that you are pulling files from. The last committed history of your branch is rewritten. The files now match the versions in the target branch from where you are pulling the files. Although Rebasing produces a clean Git history for your branch, you must exercise caution while choosing the Use rebase option.

- **Use soft reset**: Select this option to perform a reset or soft rebase. You can choose the Use soft reset option when you pull the files from a remote repository for the first time. In this case, the remote repository acts as a parent repository from which the local repository receives all the changes. However, the changes in your local repository are retained. Git does not recognize the files that are present in your local repository, but not in the remote repository. These files are displayed as deleted files after you perform a soft reset. If you choose to retain these files in your local repository, the remote changes are lost.

  **Note:**

  *If you go ahead with the soft reset, your unrecognized files are deleted.*

**Push files to the remote repository**

After you connect with remote repositories, when you modify and commit the modified files, Git records these changes. The Git Push icon in the Git panel immediately displays the number of files that have been modified. These files can now be pushed to the remote repository.

When you perform a Git Push, the commits that you made to the local repository are pushed to the remote repository.

To push your files from within Dreamweaver:

1. From the Git panel, click the Git Push icon.

   The system displays the Git Push dialog box. You can either push your commits to the current tracking branch or to another branch that you specify.
Set up sites

Push the local commits to a remote Git repository

2 You can also set the push settings from this dialog box. By default, the Default Push option is selected.

3 You can also select the following options:
   - Forced Push: Select this option to forcefully push your changes to the remote repository, despite potential conflicts.
   - Delete remote branch: Select this option to delete the existing remote branch and push your local files to the remote repository.

4 Optionally select the Send Tags check box to push your tags to the remote repository.

5 Click OK.

If there are conflicts between your local commits and the commits made to the remote repository, it is recommended that you first resolve the conflicts. You can then push your changes.

To do so, you must first Pull the changes from the remote repository, resolve the conflicts, and then push the files without any conflicts.

Searching files in the Git panel

The Search bar in the Git panel allows you to search for files using the filename. This capability is especially useful when you have large number of files associated with your site.
To search for a file, simply type the filename in the Search bar. The file or files containing your search query is displayed immediately.

**Add files to the ignore list**

When you do not want Git to act on a file, you can add the file to `.gitignore`. Git then ignores the files in this folder whenever you perform any action including commit, push, and pull. You must commit the `.gitignore` file to your repository so that any other user cloning your repository is also aware of the files in the `.gitignore` folder.

To add files to `.gitignore`, go to the Files panel in Dreamweaver. Select and right-click the file that you want Git to ignore, and select Git > Add to `.gitignore`.

At any point in time, if you want to remove a file from `.gitignore`, select the file from the Files panel. Right-click and select Git > Remove from `.gitignore`.

Ensure that you commit the `.gitignore` file to the local and remote repositories after modifying this file.
Accessing Git through command line

In the previous sections in this article, you learnt how to use the Git panel (UI) to perform tasks like associating a Git repository to your site, creating and managing remote connections, pushing files to a repository, or pulling files from a repository. You can also perform these actions and more using git commands.

To perform any Git operation using the terminal, do one of the following:

- Click Window > Git, and click the Open Bash/Terminal Console icon.
- From the Files panel, toggle the Git View. Click the Open Git Terminal icon next to the repositories drop-down list.

To view the common git commands, see the Git Cheat Sheet.

Note:

Some actions like git stash and combining commits after push are currently possible only from the command line.

When you perform certain actions such as initializing a Git repository from the command line, these actions are also reflected in the Dreamweaver interface.

However, you can also modify files using command line when the Dreamweaver application is closed. In this case, you see the following message when you launch Dreamweaver the next time:

![Message when files are modified using CLI]

Set Git preferences in Dreamweaver

Git preferences in Dreamweaver allow you to define some settings for using Git in Dreamweaver. You can use the Preferences dialog box to set Git preferences like path to the terminal, timeout settings, and so on.

1. Select Edit > Preferences.
2. From the Preferences dialog box, select Git.
3. From the Git Preferences dialog box, set the following:
   - Path to Git executable: The .exe file of your Git client. If your executable is saved in another location, browse to the location where you have saved the Git .exe file.
   - Default Git operation Timeout: Specify the timeout in seconds, for any remote Git operation.
   - Path to Terminal: The complete path to the executable file to open and use the Git terminal.
   - Command Arguments: Provide command arguments, if any, for your Git commands.
Set up sites

Set preferences for Git in Dreamweaver

4 Click Apply to save your settings.

Note:

Restart Dreamweaver for your updated preferences to take effect.
Chapter 5: Manage files

Create and open files

Dreamweaver offers a flexible environment for working with a variety of web documents. In addition to HTML documents, you can create and open a variety of text-based documents—such as JavaScript, PHP, and Cascading Style Sheets (CSS).

Dreamweaver provides several options for creating a new document. You can create any of the following:

- A new blank document or template
- A document based on one of the predesigned page layouts that comes with Dreamweaver, including over 30 CSS-based page layouts
- A document based on one of your existing templates

You can also set document preferences. For example, if you typically work with one type of document, you can set it as the default document type for new pages you create.

You can easily define document properties, such as meta tags, document title, and background colors, and several other page properties in either Design view or Code view.

Dreamweaver file types

You can work with a variety of file types in Dreamweaver. The primary kind of file you will work with is the HTML file. HTML files—or Hypertext Markup Language files—contain the tag-based language responsible for displaying a web page in a browser. You can save HTML files with either the .html or .htm extension. Dreamweaver saves files using the .html extension by default.

Dreamweaver lets you create and edit HTML5-based web pages. Starter layouts are also available for building HTML5 pages from scratch.

Following are some of the other common file types you might use when working in Dreamweaver:

CSS Cascading Style Sheet files have a .css extension. They are used to format HTML content and control the positioning of various page elements.

GIF Graphics Interchange Format files have a .gif extension. GIF format is a popular web graphic format for cartoons, logos, graphics with transparent areas, and animations. GIFs contain a maximum of 256 colors.

JPEG Joint Photographic Experts Group files (named after the organization that created the format) have a .jpg extension, and are usually photographs or high-color images. The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.

XML Extensible Markup Language files have a .xml extension. They contain data in a raw form that can be formatted using XSL (Extensible Stylesheet Language).
The New Document dialog
The New Document dialog displays all the supported document file types, including PHP, XML, and SVG.
You can also access predefined layouts, templates, and frameworks from this dialog.

Note:
All the featured starter layouts are built to support responsive websites and are HTML-5 compliant.

Create an HTML layout using a blank page
You can create a page that contains a predesigned CSS layout, or create a completely blank page and then create a layout of your own.

1 Select File > New.
2 In the New Document category, select the kind of page you want to create from the Document Type column. For example, select HTML to create a plain HTML page.
3 Select a document type from the DocType pop-up menu. In most cases, you can use the default selection, HTML5.
4 Select additional options depending on the type of page you want to create.
   • None: Select this option if you want to create a simple web page without using any framework.
   • Bootstrap: Bootstrap templates are predefined layouts using the Bootstrap framework. Select this option if you want to create responsive web pages using the Bootstrap framework. By default, a Bootstrap 4.0.0 document is created.

Note:
If you are planning to create responsive web pages, then select the Bootstrap framework.

5 If you are not using a framework, then:
   • Document Title: Enter your Document Title in this field, and Dreamweaver adds it automatically to the document’s <head> section.
   • Doc Type: Select a doc type from the DocType pop-up menu. In most cases, you can use the default selection, HTML5.

Selecting one of the XHTML document type definitions from the Doc Type menu makes your page XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu. XHTML (Extensible Hypertext Markup Language) is a reformulation of HTML as an XML application. Generally, using XHTML gives you the benefits of XML, while ensuring the backward and future compatibility of your web documents.

Note:
For more information about XHTML, see the World Wide Web Consortium (W3C) website, which contains the specification for XHTML 1.1 - Module-Based XHTML (www.w3.org/TR/xhtml11/) and XHTML 1.0 (www.w3c.org/TR/xhtml1/), as well as XHTML validator sites for web-based files (http://validator.w3.org/) and local files (http://validator.w3.org/file-upload.html).

   • Attach CSS: Attach an existing CSS layout to the page. To do this, click the Attach Style Sheet icon next to the Attach CSS File pane and select a CSS style sheet.
If you want to create a new page based on your Photoshop comp, then select Use Extract to build your page from Photoshop comps.

Selecting this option opens the Extract panel where you can upload a PSD file and get started creating your HTML page.

6  If you want to create a responsive web page using the Bootstrap framework, then:

- Bootstrap CSS: Opt to create a new Bootstrap CSS, or use an existing CSS file. If you are using an existing CSS file, provide the path to the file. Make sure that the CSS file is within your site root folder.
- Attach CSS: Attach an existing CSS layout to the page. To do this, click the Attach Style Sheet icon next to the Attach CSS File pane and select a CSS style sheet.
- Include a pre-built layout: Select this option if you have a layout already. Click Customize to edit the grid and breakpoint values.
If you want to create a new page based on your Photoshop comp, then select Use Extract to build your page from Photoshop comps.

Selecting this option opens the Extract panel where you can upload a PSD file and get started creating your HTML page.

7 Click Preferences if you want to set default document preferences, such as a document type, encoding, and a file extension.

8 Click the Create button.

9 Save the new document (File > Save).

10 In the dialog box that appears, navigate to the folder where you want to save the file.

11 In the File Name box, type a name for the file.

Avoid using spaces and special characters in file and folder names, and do not begin a filename with a numeral. In particular, do not use special characters (such as é, ç, or ¥) or punctuation marks (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break.
Manage files

Create a blank template
You can use the New Document dialog box to create Dreamweaver templates. By default, templates are saved in the Templates folder of your site.

Note:
You cannot create a template without creating a site first. For information on sites, and how to create a site, see About Dreamweaver sites.

1. Select File > New.
2. In the New Document dialog box, select the Site Templates category.
3. Select a document type from the DocType pop-up menu. In most cases, you will want to leave this selected to the default selection, XHTML 1.0 Transitional.

Selecting one of the XHTML document type definitions from the DocType (DTD) menu makes your page XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu. XHTML (Extensible Hypertext Markup Language) is a reformulation of HTML as an XML application. Generally, using XHTML gives you the benefits of XML, while ensuring the backward and future compatibility of your web documents.

Note:
For more information about XHTML, see the World Wide Web Consortium (W3C) website, which contains the specification for XHTML 1.1 - Module-Based XHTML (www.w3.org/TR/xhtml11/) and XHTML 1.0 (www.w3c.org/TR/xhtml1/), as well as XHTML validator sites for web-based files (http://validator.w3.org/) and local files (http://validator.w3.org/file-upload.html).
4. Select Update page when template changes if you want to want the page to update automatically when you edit the template.
5. Click the Create button.
6. Save the new document (File > Save). If you haven't added editable regions to the template yet, a dialog box appears telling you that there are no editable regions in the document. Click OK to close the dialog box.
7. In the Save As dialog box, select a site in which to save the template.
8. In the File Name box, type a name for the new template. You do not need to append a file extension to the name of the template. When you click Save, the .dwt extension is appended to the new template, which is saved in the Templates folder of your site.

Avoid using spaces and special characters in file and folder names and do not begin a filename with a numeral. In particular, do not use special characters (such as é, ç, or ¥) or punctuation (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break.

Create a page based on a template
You can select, preview, and create a new document using one of your existing templates, or Dreamweaver’s starter templates. You can either use the New Document dialog box to select a template from any of your Dreamweaver-defined sites or use the Assets panel to create a new document from an existing template.

Create a document based on a template
1. Select File > New.
2. In the New Document dialog box, select the Page From Template category.
3 In the Site column, select the Dreamweaver site that contains the template you want use, and then select a template from the list on the right.

4 Deselect Update Page When Template Changes if you don't want to update this page each time you make changes to the template on which this page is based.

5 Click Preferences if you want to set default document preferences, such as a document type, encoding, and a file extension.

6 Click Get More Content if you want to open Dreamweaver Exchange where you can download more page design content.

7 Click Create and save the document (File > Save).

**Create a document from a template in the Assets panel**

1 Open the Assets panel (Window > Assets), if it is not already open.

2 In the Assets panel, click the Templates icon on the left to view the list of templates in your current site.

3 Right-click (Windows) or Control-click (Macintosh) the template you want to apply, then select New From Template.

   The document opens in the Document window.

4 Save the document.

**Create a page based on a Dreamweaver starter template**

Dreamweaver comes with several professionally developed starter files for mobile applications. You can use these sample files as starting points for designing pages in your sites.

When you create a document based on a starter template, Dreamweaver creates a copy of the file, so you don't overwrite the starter files.

You can preview a sample file and read a brief description of a document's design elements in the New Document dialog box.

1 Select File > New.

2 In the New Document dialog box, select the Starter Templates category.
You can see the sample page details and the and the visualisation on the right side of the panel as you select the different options.

3 Click the Create button.
   The new document and all its relates files open in the Document window.

4 Save the document (File > Save).

**Create new code files for different coding languages**
You can create code files for a number of coding languages in Dreamweaver.

For more information on coding support in Dreamweaver, see *About coding in Dreamweaver*.

To create a new code file in Dreamweaver, use the following instructions:

1 Select File > New Document.

2 From the Document Type, select the code file you want to create.

3 Select the kind of document you want to create from the Document Type column (such as a PHP file).
4 Based on the file type you select, additional options are available while creating a document. For example, if you are creating a PHP file, you can select DocType options, and some CSS options.

5 Click the Create button. Then save the document (File > Save).

Save and revert documents

You can save a document using its current name and location, or save a copy of a document using a different name and location.

Note:

When naming files, avoid using spaces and special characters in file and folder names. In particular, do not use special characters (such as é, ç, or ¥) or punctuation (such as colons, slashes, or periods) in the names of files you intend to put on a remote server; many servers change these characters during upload, which will cause any links to the files to break. Also, do not begin a filename with a numeral.

Save a document

1 Do one of the following:
   • To overwrite the current version on the disk, and save any changes you have made, select File > Save.
   • To save the file in a different folder or using a different name, select File > Save As.

2 In the Save As dialog box that appears, navigate to the folder where you want to save the file.

3 In the File Name text box, type a name for the file.

4 Click Save to save the file.
Manage files

Save all open documents
1 Select File > Save All.

2 If there are any unsaved documents open, the Save As dialog box is displayed for each unsaved document. In the dialog box that appears, navigate to the folder where you want to save the file.

3 In the File Name box, type a name for the file and click Save.

Revert to the last saved version of a document
1 Select File > Revert. A dialog box asks if you want to discard your changes, and revert to the previously saved version.

2 Click Yes to revert to the previous version; click No to keep your changes.

Note: If you save a document, and then exit Dreamweaver, you cannot revert to the previous version of the document when you restart Dreamweaver.

Set default document type and encoding preferences
If most of the pages in your site are of a specific file type (such as HTML, PHP, or JavaScript), you can set document preferences that automatically create new documents of the specified file type.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

You can also click the Preferences button in the New Document dialog box to set new document preferences when you create a new document.

2 Click New Document from the category list on the left.

3 Set or change preferences as necessary, and click OK to save them.

Default Document Select a document type that will be used for pages that you create.

Default Extension Specify the file extension you prefer (.htm or .html) for new HTML pages you create.

Note: This option is disabled for other file types.

Default Document Type (DDT) Select one of the XHTML document type definitions (DTD) to make new pages XHTML-compliant. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the menu.

Default Encoding Specify the encoding to be used when a new page is created, as well as when a document is opened that does not specify any encoding.

If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see www.w3.org/TR/REC-html40/sgml/entities.html.

If you select Unicode (UTF-8) as a default encoding, you can include a Byte Order Mark (BOM) in the document by selecting the Include Unicode Signature (BOM) option.
A BOM is 2-4 bytes at the beginning of a text file that identifies a file as Unicode, as well as the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required.

**Unicode Normalization Form** Select one of these options if you select Unicode (UTF-8) as a default encoding.

There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common one used in the Character Model for the World Wide Web. Adobe provides the other three Unicode Normalization Forms for completeness.

**Show New Document Dialog Box on Control+N** Deselect this option ("on Command+N" for Macintosh) to automatically create a document of the default document type when you use the key command.

In Unicode, there are characters that are visually similar but can be stored within the document in different ways. For example, "ë" (e-umlaut) can be represented as a single character, “e-umlaut,” or as two characters, “regular Latin e” + “combining umlaut.” A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the “Latin e.” Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same form. That is, all “ë” characters in a document are saved as single “e-umlaut” or as “e” + “combining umlaut,” and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at [www.unicode.org/reports/tr15](http://www.unicode.org/reports/tr15).

---

**Open and edit existing documents**

You can open an existing web page or text-based document, whether or not it was created in Dreamweaver, and edit it in either Design view or Code view.

If the document you open is a Microsoft Word file that was saved as an HTML document, you can use Tools > Clean up Word HTML to remove the extraneous markup tags that Word inserts into HTML files.

To clean up HTML or XHTML that is not generated by Microsoft Word, use Tools > Clean up HTML. For more information, see [Clean up Microsoft Word HTML files](#).

You can also open non-HTML text files, such as JavaScript files, XML files, CSS style sheets, or text files saved by word processors or text editors.

1 Select File > Open.

*You can also use the Files panel to open files.*

2 Navigate to and select the file you want to open.

*Note:*

*If you haven’t already done so, it is a good idea to organize files you plan to open and edit in a Dreamweaver site, instead of opening them from another location. For more information on Dreamweaver sites, see About Dreamweaver sites.

3 Click Open.

The document opens in the Document window. JavaScript, text, and CSS Style Sheets open in Code view by default. You can update the document while working in Dreamweaver, and save the changes in the file.
Open Related Files

Dreamweaver lets you view files related to your main document, without losing the main document’s focus. For example, if you have CSS and JavaScript files attached to a main document, Dreamweaver lets you view and edit these related files in the Document window while keeping the main document visible.

For information on dynamic related files, see Open Dynamically Related Files.

Note:

When working with HTML files, if you want to make quick changes to related CSS, JavaScript, or PHP files without having to navigate to that file, you can use Quick Edit. For more information, see Quick Edit.

By default, Dreamweaver displays the names of all files related to a main document in a Related Files toolbar below the main document’s title. The order of the buttons in the toolbar follows the order of related files links that exist within the main document.

Note:

If a related file is missing, Dreamweaver still displays the corresponding button in the Related Files toolbar. If you click the button, however, Dreamweaver does not display anything.

Dreamweaver supports the following kinds of related files:

- Client-side script files
- Server Side Includes
- External CSS style sheets (including nested style sheets)

Open a related file from the Related Files toolbar

Do one of the following:

- In the Related Files toolbar at the top of the document, click the filename of the related file you want to open.
- In the Related Files toolbar, right-click the filename of the related file you want to open and select Open as Separate File from the context menu. When you open a related file by this method, the main document does not remain simultaneously visible.

Open a related file from the Code navigator

1 Place the insertion point on a line or in an area that you know is affected by a related file.

2 Wait for the Code Navigator indicator to appear, and then click it to open the Code Navigator.

3 Hover over the items in the Code Navigator to see more information about them. For example, if you want to change a particular CSS color property, but don't know which rule it resides in, you can find the property by hovering over the available rules in the Code Navigator.

4 Click the item you’re interested in to open the corresponding related file.

Return to the source code of the main document

? Click the Source Code button in the Related Files toolbar.

Change the display of related files

When you open a related file from Design view or Code and Design views (Split view), the related file displays in Split view. You can select View > Split and choose from the different Split view options if you want to customize the Split view. If you want to view the related files in Code view only, select Code at the top of the toolbar.
Note:

*Standard Code view does not let you display related Documents at the same time as the main document’s source code.*

Note:

*The Code View in the display option refers to the source code of the main document. For example, if you select View > Code View on Top, Dreamweaver displays the source code of the main document in the top half of the Document window. If you select View > Code View on Left, Dreamweaver displays the source code of the main document on the left side of the Document window.*

**Disable related files**

By default, when you open an HTML file, Dreamweaver displays the related files in separate tabs. If you want to disable this functionality, you can disable it using the Preferences panel.

1. Select **Edit > Preferences** (Windows) or **Dreamweaver > Preferences** (Macintosh).
2. In the **General** category, deselect **Enable Related Files**.

**Open Dynamically Related Files**

The Dynamically-Related Files feature extends the functionality of the Related Files feature by allowing you to see the related files of dynamic pages in the **Related Files toolbar**. Specifically, the Dynamically-Related Files feature lets you see the numerous dynamic includes that are required to generate the runtime code for popular open-source PHP Content Management System (CMS) frameworks such as WordPress, Drupal and Joomla!

To use the Dynamically-Related Files feature, you must have access to a local or remote PHP application server running WordPress, Drupal, or Joomla! One common approach for testing pages is to set up a localhost PHP application server, and test the pages locally.

Before you test pages, you’ll need to perform the following steps:

- Set up a Dreamweaver site and make sure that you have filled out the Web URL text box the Site Setup dialog box.
- Set up a PHP application server.
  
  *Note:* The server must be running before you attempt to work with Dynamically-Related Files in Dreamweaver.
- Install WordPress, Drupal, or Joomla! on the application server. For more information, see:
  - WordPress Installation
  - Drupal Installation
  - Joomla Installation
- In Dreamweaver, define a local folder where you’ll download and edit your CMS files.
- Define the location of the installed WordPress, Drupal, or Joomla files as your remote and testing folder.
- Download (Get) your CMS files from the remote folder.

**Set Dynamically-Related Files preferences**

When you open a page that is associated with Dynamically-Related Files, Dreamweaver can discover the files automatically, or let you discover the files manually (which you do by clicking a link in the Info bar above the page). The default setting is manual discovery.

1. Choose **Edit > Preferences** (Windows) or **Dreamweaver > Preferences** (Macintosh OS).
2. In the **General** category, make sure the **Enable Related Files** option is selected.
3 Select **Manually** or **Automatically** from the **Dynamically-Related Files** pop-up menu. You can also disable the discovery entirely by selecting Disabled.

**Discover Dynamically-Related Files**

1 Open a page that has Dynamically-Related Files associated with it—for example, the site root index.php page of a WordPress, Drupal, or Joomla! site.

2 If the discovery of Dynamically-Related Files is set to manual (the default), click the **Discover** link in the Info bar that appears above the page in the Document window.
   
   If the discovery of Dynamically-Related Files is automatically enabled, then a list of Dynamically-Related Files appears in the Related Files toolbar.

The order of Related and Dynamically-Related Files in the **Related Files** toolbar is as follows:

- Static related files (related files that do not require any sort of dynamic processing)
- External related files (.css and .js files) that are attached to dynamic path server include files
- Dynamic path server include files (.php, .inc, and .module files)

**Filter Related Files**

Because Related Files and Dynamically-Related Files can often be numerous, Dreamweaver lets you filter Related Files so that you can precisely locate the files you want to work with.

1 Open a page that has Related Files associated with it.

2 Discover Dynamically-Related Files if necessary.

3 Click the **Filter Related Files** icon at the right side of the Related Files toolbar.

4 Select the types of files you want to see in the **Related Files** toolbar. By default, Dreamweaver selects all Related Files.

5 To create a custom filter, click the **Filter Related Files** icon and choose **Custom Filter**.
   
   The **Custom Filter** dialog only allows for the filtering of exact file names (style.css), file extensions (.php), and wildcard expressions using asterisks (*menu*). You can filter on multiple wildcard expressions by separating each expression with a semi-colon (for example, style.css;*.js;*tpl.php).

*Note:*

*Filter settings do not persist once you close the file.*

**Clean up Microsoft Word HTML files**

You can open documents saved by Microsoft Word (Microsoft Word 97 or later) as HTML files, and then use **Tools > Clean Up Word HTML** to remove the extraneous HTML code generated by Word.

The code that Dreamweaver removes is primarily used by Word to format and display documents in Word and is not actually needed to display the HTML file.

Retain a copy of your original Word (.doc) file as a backup, because you may not be able to reopen the HTML document in Word once have cleaned up the HTML file.

*Note:*

*To clean up HTML or XHTML that is not generated by Microsoft Word, use **Tools > Clean up HTML command.***

1 Save your Microsoft Word document as an HTML file.

*Note:*

---

Last updated 11/7/2019
In Windows, close the file in Word to avoid a sharing violation.

2 Open the HTML file in Dreamweaver.
   To view the HTML code generated by Word, switch to Code view (View > Code).

3 Select Tools > Clean Up Word HTML.
   
   **Note:**
   
   If Dreamweaver is unable to determine which version of Word was used to save the file, select the correct version from the pop-up menu.

4 Select (or deselect) options for the cleanup. The preferences you enter are saved as default cleanup settings.
   Dreamweaver applies the cleanup settings to the HTML document and a log of the changes appears (unless you deselected that option in the dialog box).

![Microsoft Word HTML clean up options](image)

**Remove All Word Specific Markup** Removes all Microsoft Word-specific HTML, including XML from HTMLelements, Word custom metadata and link tags in the head of the document, Word XML markup, conditional tags and their contents, and empty paragraphs and margins from styles. You can select each of these options individually using the Detailed tab.

**Clean Up CSS** Removes all Word-specific CSS, including inline CSS styles when possible (where the parent style has the same style properties), style attributes beginning with "mso," non-CSS style declarations, CSS style attributes from tables, and all unused style definitions from the head. You can further customize this option using the Detailed tab.

**Clean Up <font> Tags** Removes HTML tags, converting the default body text to size 2 HTML text.

**Fix Invalidly Nested Tags** Removes the font markup tags inserted by Word outside the paragraph and heading (block-level) tags.

**Apply Source Formatting** Applies the source formatting options you specify in HTML Format preferences and SourceFormat.txt to the document.
Show Log On Completion  Displays an alert box with details about the changes made to the document as soon as the cleanup is finished.

5 Click OK, or click the Detailed tab if you want to further customize the Remove All Word Specific Markup and Clean Up CSS options, and then click OK.

Manage files and folders

The Files panel in Dreamweaver allows you to access and manage files associated with your site. You can toggle between the FTP View and the Git View in Files panel, to manage the files using an FTP server or Git repositories.

To open the Files panel, click Window > Files, or press F8 (on Windows) or Shift-?-F (on Mac).

Note:

If you don’t set up a site, the Files panel works simply lists all the drives or folders in your system. You can only use it to view files. You cannot transfer files back and forth from a remote system to your local system.

To learn more about the benefits of setting up a site, and for instructions on how to create a site, see About Dreamweaver sites.

Read on to know how to use the Files panel in each of these views.

Working with the Files panel in the FTP View

You can use the FTP view to view files and folders, check whether they are associated with a Dreamweaver site or not, and perform standard file maintenance operations, such as opening and moving files. The Files panel also helps you manage and transfer files to and from a remote server.

After you set up a site in Dreamweaver, you can use the Files panel in the following ways:

• Access sites, a server, and local drives
• View files and folders
• Manage files and folders in the Files panel
• Synchronize files and folders between local and remote servers

Read on to learn how to use the Files panel in the FTP View.

Options in the Files panel

At its simplest, the Files panel displays a list of only the local files in your computer. As you work more with the Files panel - setting up a site, setting up connections to remote servers, enabling check in and check out, more options appear in the Files panel.

Here’s what the Files panel looks like:

• When no site is defined in Dreamweaver
• When a site is defined but a server is not defined
• When a site is defined, server connections are defined, and check-in and check-out of files is enabled

For information on defining a site and server, see About Dreamweaver sites.
When no site is defined in Dreamweaver

What the Files panel looks like when no site is defined in Dreamweaver

When a site is defined but a server is not defined

When you define a Dreamweaver site, the files within your site are displayed. The Files panel also includes a button - Define servers, which is a prompt to start defining connections to remote and testing servers.
When a site is defined and servers are defined and check-in and check-out is enabled

All options on the Files panel are available for you to use after you define a site, and server. If you enable check-in and check-out, these options are also available to use.

Read on to find out more about what you can do with the Files panel.

For information on enabling check-in and check-out, see [Check in and check out files](#).

You can move the Files panel as necessary and set preferences for the panel.

**Note:**

The Site Files view, Testing Server view, and Synchronize buttons appear only in the expanded Files panel.

**Site pop-up menu** Lets you select a Dreamweaver site and display that site's files. You can also use the Site menu to access all the files on your local disk, much like [Windows Explorer](#) (Windows) or the Finder (Mac).
Manage files

**File view**  Lets you view files present in your local site root, remote server, or testing server. Select an option from the pop-up menu to see files in the respective view.

**Connect to remote server** (FTP, RDS, and WebDAV protocol) Connects to or disconnects from the remote site. By default, Dreamweaver disconnects from the remote site if it has been idle for more than 30 minutes (FTP only). To change the time limit, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), then select Site from the category list on the left.

**Get files from remote server** Copies the selected files from the remote site to your local site (overwriting the existing local copy of the file, if any). If Enable File Check In And Check Out is enabled, the local copies are read-only; the files remain available on the remote site for other team members to check out. If Enable File Check In and Check Out is disabled, the file copies have both read and write privileges.

**Put files to remote server** Copies the selected files from the local site to the remote site.

**Check out files** Transfers a copy of the file from the remote server to your local site (overwriting the existing local copy of the file, if any) and marks the file as checked out on the server. This option is not available if Enable File Check In and Check Out is disabled for the current site.

**Check in files** Transfers a copy of the local file to the remote server and makes the file available for editing by others. The local file becomes read-only. This option is not available if Enable File Check In and Check Out is disabled for the current site.

**Synchronize with remote server** Synchronizes the files between the local and remote folders.

**Expand/Collapse** Expands or collapses the Files panel to display one or two panes. In the Expanded view, an additional option - View site FTP log is also available. When the Files panel is collapsed it displays the contents of the local site, the remote site, or the testing server as a list of files. When expanded, it displays the local site and either the remote site or testing server.

**Refresh** Refreshes the local and remote directory lists. Use this button to manually refresh the directory lists if you deselected either Refresh Local File List Automatically or Refresh Remote File List Automatically in the Site Definition dialog box.

**File Activity**  Displays the background file activity.

The View Site FTP log is available if you expand the Files panel by clicking the Expand/collapse icon.

**View Site FTP log** Displays the file structure of the remote and local sites in the panes of the Files panel. (A preference setting determines which site appears in the left pane and which appears in the right pane.) Site Files view is the default view for the Files panel.

**Note:**

*The files Dreamweaver copies are the files you select in the active pane of the Files panel. If the Remote pane is active, the selected remote or testing server files are copied to the local site; if the Local pane is active, Dreamweaver copies the remote or testing server version of the selected local files to the local site.*

**Note:**

*The files Dreamweaver copies are the files you select in the active pane of the Files panel. If the Local pane is active, the selected local files are copied to the remote site or testing server; if the Remote pane is active, Dreamweaver copies the local versions of the selected remote server files to the remote site.*

If you are putting a file that doesn't already exist on the remote site, and Enable File Check In and Out is enabled, the file is added to the remote site as “checked out.” Click the Check In Files button if you want to add a file without the checked out status.
**View files and folders**
You can view files and folders in the Files panel, whether they are associated with a Dreamweaver site or not. When you view sites, files, or folders in the Files panel, you can change the size of the viewing area, and, for Dreamweaver sites, you can expand or collapse the Files panel.

For Dreamweaver sites, you can also customize the Files panel by changing the view—either your local or remote site—that appears by default in the collapsed panel. Or, you can switch the content views in the expanded Files panel using the Always Show option.

**Search files in the files panel (Mac OS, Creative Cloud users only)**
Use Live Search to locate files based on filename or text present in files. The site selected in the Files panel is used for search. If there is no site selected in the panel, the search option does not appear. For more information, see Search files based on filenames or content.

**Change the size of the view area in the expanded Files panel**
In the Files panel (Window > Files), with the panel expanded, drag the bar that separates the two views to increase or decrease the view area of the right or left pane.

**Change the site view in Files panel (Dreamweaver sites only)**
You can use the Files panel to view files present in your local site root, remote server, or testing server.

In the collapsed Files panel (Window > Files), select Local View, Remote Server, or Testing Server from the Site View pop-up menu.

By default, Local View appears in the Site View menu.

*Viewing files on local site root, remote, and testing servers*

**View files outside of a Dreamweaver site**
Navigate your computer using the Site pop-up menu, much as you would if you were using Windows Explorer(Windows) or the Finder (Macintosh).

**Work with files in the FTP View**
You can open or rename files; add, move, or delete files; or refresh the Files panel after you make changes.

For Dreamweaver sites, you can also determine which files (on either the local or remote site) have been updated since the last time they were transferred.

**Open a file**
1. In the Files panel (Window > Files), select a site, server, or drive from the pop-up menu (where the current site, server, or drive appears).
2. Navigate to the file you want to open.
3. Do one of the following:
   - Double-click the file's icon.
   - Right-click (Windows) or Control-click (Macintosh) the file's icon, then select Open.
   
Dreamweaver opens the file in the Document window.
Create a file or folder
1 In the Files panel (Window > Files), select a file or folder.
   Dreamweaver creates the new file or folder inside the currently selected folder, or in the same folder as the currently selected file.
2 Right-click (Windows) or Control-click (Macintosh), then select New File or New Folder.
3 Enter a name for the new file or folder.
4 Press Enter (Windows) or Return (Macintosh).

Delete a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to delete.
2 Right-click (Windows) or Control-click (Macintosh), then select Edit > Delete.

Rename a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to rename.
2 Do one of the following to activate the name of the file or folder:
   • Click in the filename, pause, then click again.
   • Right-click (Windows) or Control-click (Macintosh) the file's icon, then select Edit > Rename.
3 Type the new name over the existing name.
4 Press Enter (Windows) or Return (Macintosh).

Move a file or folder
1 In the Files panel (Window > Files), select the file or folder you want to move.
2 Do one of the following:
   • Copy the file or folder, then paste it in a new location.
   • Drag the file or folder to a new location.
3 Refresh the Files panel to see the file or folder in its new location.

Refresh the Files panel
To refresh the view in the Files panel, do one of the following:
• Right-click (Windows) or Control-click (Macintosh) any file or folder, then select Refresh.
• (Dreamweaver sites only) Click the Refresh button in the Files panel toolbar (this option refreshes both panes).

Note:
Dreamweaver refreshes the Files panel when you make changes in another application, then return to Dreamweaver.

Find files in your Dreamweaver site
Dreamweaver makes it easy to find selected, open, checked out, or recently modified files in your site. You can also find files that are newer in your local or remote site.

Find an open file in your site
1 Open the file in the Document window.
2 Select Site > Locate in Site.
   Dreamweaver selects the file in the Files panel.

   **Note:**
   *If the open file in the Document window is not part of the current site in the Files panel, Dreamweaver attempts to determine which of your Dreamweaver sites the file belongs to; if the current file belongs to only one local site, Dreamweaver opens that site in the Files panel, then highlights the file.*

**Locate and select checked out files in a Dreamweaver site**
In the **collapsible** Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select **Edit > Select Checked Out Files**.

Dreamweaver selects the files in the Files panel.

**Find a selected file in your local or remote site**
1 Select the file in the Local or Remote view of the Files panel (Window > Files).
2 Right-click (Windows) or Control-click (Macintosh), then select Locate in Local Site or Locate in Remote Server (depending on where you selected the file).
   Dreamweaver selects the file in the Files panel.

**Locate and select files that are newer in the local site than in the remote site**
In the **collapsible** Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select **Edit > Select Newer Local**.

Dreamweaver selects the files in the Files panel.

**Locate and select files that are newer in the remote site than in the local site**
In the **collapsible** Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, then select **Edit > Select Newer Remote**.

Dreamweaver selects the files in the Files panel.

**Find recently modified files in your site**
1 In the **collapsible** Files panel (Window > Files), click the Options menu in the upper-right corner of the Files panel, and then select **Edit > Select Recently Modified**.
2 Do one of the following to indicate search dates for the report:
   • To report on all files modified in the last several days, select Files Created or Modified in the Last and enter a number in the box.
   • To report on all files modified within a specific time frame, click the Files Created or Modified Between radio button, then specify a date range.

   ![Finding recently modified files](image)

3 (Optional) Enter a user name in the Modified By box to limit your search to files modified by a specific user between the dates you indicated.
Note:
This option is only available for reports on Contribute sites.

4 Select a radio button to indicate where you want to view files listed in the report, if necessary:
- **Local Machine** if the site contains static pages.
- **Testing Server** if the site contains dynamic pages.
- **Other Location** if you want to enter a path in the text box.

Note:
This option assumes you defined a Testing Server in the Site Definition dialog box. If you have not defined a Testing Server and entered a URL prefix for that server, or if you are running the report for more than one site, this option is not available.

5 Click OK to save your settings.
Dreamweaver highlights the files that were modified within the selected time frame in the Files panel.

### Identify and delete unused files
You can identify and delete files that are no longer used by other files in your site.

1 Select Site > Site Options > Check Links Sitewide.
Dreamweaver checks all the links in your site and displays the broken ones in the Results panel.

2 Select Orphaned Files from the menu on the Link Checker panel.

![Viewing orphaned files - files with no incoming links](image)

Dreamweaver displays all the files with no incoming links. This means that no files in your site link to these files.

3 Select the files you want to delete and press Delete.

Note:
Although no other file in the site links to these files, some of the listed files may link to other files. Use caution when deleting the files.

### Access sites, a server, and local drives
You can access, modify, and save files and folders in your Dreamweaver sites, as well as files and folders that are not part of a Dreamweaver site. In addition to Dreamweaver sites, you can access a server, a local drive, or your desktop.

Before you can access a remote server, you must set up Dreamweaver to work with that server.

Note:
The best way to manage your files is to create a Dreamweaver site. For information on the benefits of creating a site, and information on how to create a site see About Dreamweaver sites.

### Open an existing Dreamweaver site
In the Files panel (Window > Files), select a site from the menu (where the current site, server, or drive appears).
Open an existing Dreamweaver site

Open a folder on a remote FTP or RDS server
1 In the Files panel (Window > Files), select a server name from the menu (where the current site, server, or drive appears).

Note:
Server names appear for servers you’ve configured Dreamweaver to work with.

2 Navigate to and edit files as you normally do.

Access a local drive or your desktop
1 In the Files panel (Window > Files), select Desktop, Local Disk, or CD Drive from the menu (where the current site, server, or drive appears).

2 Navigate to a file, then do any of the following:
• Open files in Dreamweaver or another application
• Rename files
• Copy files
• Delete files
• Drag files
  • If you drag a file from one Dreamweaver site to another or to a folder that is not part of a Dreamweaver site, Dreamweaver copies the file to the location where you drop it.
Manage files

• If you drag a file within the same Dreamweaver site, Dreamweaver moves the file to the location where you drop it.

• If you drag a file that is not part of a Dreamweaver site to a folder that is not part of a Dreamweaver site, Dreamweaver moves the file to the location where you drop it.

Note:

To move a file that Dreamweaver copies by default, hold down the Shift key (Windows) or the Command key (Macintosh) while you drag. To copy a file that Dreamweaver moves by default, hold the Control key (Windows) or the Option key (Macintosh) while you drag.

Customize the file and folder details displayed in the Files panel

When you view a Dreamweaver site in the Files panel, by default only the files and folder structure is displayed. However, you can customize the appearance of the Files panel to show the following details:

• Notes
• Size
• Type
• Date a file was last modified
• Check out details

To include these columns in your Files panel view, right-click the toolbar and select the options you want to see.

Showing and hiding file and folder details in the Files panel

You can do some additional column customization using the Manage Sites > Advanced Settings > File View Columns dialog:

• Change the order of columns
• Add, delete, or change column details

Customizing file view columns using the Manage Sites > Advanced Settings > File View Columns dialog

Change the order of columns

In the Manage Sites > Advanced Settings > File View Columns panel, select a column name, and then click the up or down arrow button to change the position of the selected column.

Note:

You can change the order of any column except Name, which is always the first column.

Add, delete, or change column details

1 Select Site > Manage Sites.

2 Select a site, then click Edit.

3 Expand Advanced Settings and select the File View Columns category.
4 Select a column and click the Plus (+) button to add a column.
5 In the Column Name box, enter a name for your column.

Adding custom columns

6 Select a value from the Associate with Design Notes menu, or type in your own.

Note:
You must associate a new column with a Design Note, so that there is data to display in the Files panel.

7 Select an alignment to determine how text is aligned within the column.

8 Select or deselect Show to reveal or hide the column.

9 Select Share with All Users of This Site to share the column with all users connected to the remote site.

To delete a column, select it and click the Minus (-) button.

Note:
The column is deleted immediately and without confirmation, so make certain that you want to delete the column before clicking the Minus (–) button.

Sort columns in the Files panel
In the Files panel, click the heading for the column you want to sort.

Note:
Click the heading again to reverse the order (ascending or descending) by which Dreamweaver sorts the column.

Auto-recovery of files
If Dreamweaver shuts down unexpectedly because of system errors, power outages, or other problems, then you can recover any unsaved changes made to files you were working on.

The auto-recovery feature automatically backs up any unsaved files in Dreamweaver. If a crash occurs, the following dialog box is displayed during subsequent launches of Dreamweaver.

Note:
You must have saved your file at least once for Dreamweaver to be able to recover it.
When you open a crashed Dreamweaver, you recover or discard last changes to a file:

- Recover - Select this option to open the auto-saved version of your file
- Discard - Select this option to open the last saved version of your file

**Note:**
In Dreamweaver, auto-save happens approximately every five seconds (depending on the operating system).

**Working with the Files panel in Git View**

The Git view in Files panel allows you to connect with Git repositories, and manage files using Git. The Files panel works as an interface for you to perform various operations like commit, stage, unstage, add to gitignore and so on.

You can use the Git View to perform the following actions:

- View the files associated with a site, in Git repositories
- Synchronize files and folders between your local repository and Git
- View the untracked, staged, and committed files
- Access the Git terminal

You can also initialize a Git repository from this panel, if it has already not been done. When you create a site in Dreamweaver, you can associate a Git repository with your site. If you have not done this during site creation, you can Initialize a Git repository using the Files panel.

To initialize a repository, click **Initialize Git** from the Files panel. The files associated with your site are immediately visible in the Git view, along with their status.
View the status of files
You can view the status of the files associated with a Git repository, from the Files panel. When you initialize a Git repository, the files are displayed in green. This means that the files are untracked and do not exist in Git yet.

When you commit a file, the file appears in white in the Files panel. This means that the file has been committed in the Git repository that you have chosen.

Now, when you edit and save a file after commit, the color of the file changes to yellow in the Files panel. This indicates that the files in your local repository and in the Git repository are not in sync.

To learn about the version control workflow in Git, see Using Git for version control.

Create and manage branches
You can create and manage branches locally, using the Files panel. To create a branch, select the drop-down list at the top of the panel. Click Manage Branches, and click the + sign from the Manage Branches dialog box.

You can choose your origin branch and create a new branch. You can also remove a branch and merge one branch with another.

To know more about managing local branches using the Files panel, see Create and manage branches.

Perform basic Git actions
Apart from initializing and managing branches, you can also perform various Git actions from the Files panel. From the files panel, select a file, right-click, and do one of the following:

- Click Add to .gitignore to add the selected file or files to the gitignore folder. These files will not be touched by Git, and no actions can be performed on these files.
- Click Remove from .gitignore to remove a file from the gitignore folder.
- Click Stage to stage the selected file. Staging is one step behind committing a file in Git.
- Click Unstage to remove a file from staging.
- Click Stage All to stage all the files in the repository.
- Click Unstage All to remove all the files in the repository from staging.
- Click Diff to view the changes in the file between the previous commit and the current version.
- Click File History to view the change and commit history of the selected file.
- Click Revert File to discard all the changes done to the file, and restore the previous committed version.
- Click Commit All Staged to commit the files that you have staged, from this repository.

Perform Git actions from the Files panel

To know more about each of these actions, and about Git in Dreamweaver, read Using Git in Dreamweaver.
Getting and putting files to and from your server

If you’re working in a collaborative environment, use the Check In/Check Out system to transfer files between local and remote sites. If you’re the only person working on the remote site, however, you can use the Get and Put commands to transfer files without checking them in or out.

For more information on checking in and checking out files, see Check in and check out files.

When you transfer a document between a local and remote folder using the Files panel, you have the option of transferring the document’s dependent files. Dependent files are images, external style sheets, and other files referenced in your document that a browser loads when it loads the document.

Note:

*It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there’s no need to download them again. This is also true for uploading and checking in files: no need if up-to-date copies are already at the remote site.*

Library items are treated as dependent files.

Some servers report errors when putting library items. However, you can cloak these files to prevent them from being transferred.

About background file transfers

You can perform other, non-server-related, activities while you’re getting or putting files. Background file transfer works for all of the transfer protocols supported by Dreamweaver: FTP, SFTP, LAN, WebDAV, and RDS.

Non-server-related activities include common operations like typing, editing external style sheets, generating site-wide reports, and creating new sites.

Server-related activities that Dreamweaver cannot perform during file transfers include the following:

- Put/Get/Check in/Check out files
- Undo check-out
- Create a database connection
- Bind dynamic data
- Preview data in Live view
- Insert a web service
- Delete remote files or folders
- Preview in a browser on a testing server
- Save a file to a remote server
- Insert an image from a remote server
- Open a file from a remote server
- Auto put files upon saving
- Drag files to the remote site
- Cut, copy, or paste files on the remote site
- Refresh Remote view

Last updated 11/7/2019
By default, the Background File Activity dialog box is open during file transfers. You can minimize the dialog box by clicking the Minimize button in the upper right corner. Closing the dialog box during file transfers results in a cancelation of the operation.

**Get files from a remote server**

You can copy files from the remote site to your local site in one of the following ways:

- Get files from a remote server using the Files panel
- Get files from a remote server using the Document window

Dreamweaver creates a log of file activity during the transfer that you can view and save.

*Note:*

You cannot turn background file transfer off. If you have the detail log open in the Background File Activity dialog box, you can close that to improve performance.

Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem.

**Get files from a remote server using the Files panel**

1. In the Files panel (Window > Files), select the files you want to download.

   Usually you select these files in the Remote view, but you can select the corresponding files in the Local view if you prefer. If the Remote view is active, then Dreamweaver copies the selected files to the local site; if the Local view is active, then Dreamweaver copies the remote versions of the selected local files to the local site.

   *Note:*

   To get only those files for which the remote version is more recent than the local version, use the Synchronize option.

2. Do one of the following to get the file:
   - Click the Get button in the Files panel toolbar.
   - Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Get from the context menu.

3. Click Yes in the Dependent Files dialog box to download dependent files; if you already have local copies of the dependent files, click No. The default is to not download dependent files. You can set this option at Edit > Preferences > Site.

Dreamweaver downloads the selected files, as follows:

- If you're using the Check In/Check Out system, getting a file results in a read-only local copy of the file; the file remains available on the remote site or testing server for other team members to check out.
- If you're not using the Check In/Check Out system, getting a file results in a copy that has both read and write privileges.

*Note:*

If you're working in a collaborative environment—that is, if others are working on the same files—you should not disable Enable File Check In and Check Out. If other people are using the Check In/Check Out system with the site, you should use that system as well.

To stop the file transfer at any time, click the Cancel button in the Background File Activity dialog box.
**Get files from a remote server using the Document window**

1. Make sure the document is active in the Document window.

2. Do one of the following to get the file:
   - Select Site > Get.
   - Click the File Management icon in the Document window toolbar, then select Get from the menu.

   *Note:*
   
   If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Get operation.

**Display the FTP log**

1. Click the Options menu in the upper right corner of the Files panel.

2. Select View > Site FTP Log.

   *Note:*
   
   In the Expanded Files Panel, you can click the FTP Log button to display the log.

**Put files on a remote server**

You can put files from the local site to the remote site, generally without changing the file’s checked out status.

There are two common situations where you use the Put command instead of Check In:
   - You’re not in a collaborative environment and you are not using the Check In/Check Out system.
   - You want to put the current version of the file on the server but you are going to keep editing it.

   *Note:*
   
   If you put a file that didn’t previously exist on the remote site and you’re using the Check In/Check Out system, the file is copied to the remote site and is then checked out to you so that you can continue editing.

You can use the Files panel or the Document window to put files. Dreamweaver creates a log of file activity during the transfer that you can view and save.

   *Note:*
   
   You cannot turn background file transfer off. If you have the detail log open in the Background File Activity dialog box, you can close that to improve performance.

Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem. For a tutorial on putting files on a remote server, see [www.adobe.com/go/vid0163](http://www.adobe.com/go/vid0163). For a tutorial on troubleshooting publishing problems, see [www.adobe.com/go/vid0164](http://www.adobe.com/go/vid0164).

**Put files on a remote or testing server using the Files panel**

1. In the Files panel (Window > Files), select the files to upload.

   Usually you select these in the Local view, but you may select the corresponding files in the Remote view if you prefer.

   *Note:*
   
   You can put only those files for which the local version is more recent than the remote version.
2 Do one of the following to put the file on the remote server:
   • Click the Put button in the Files panel toolbar.
   • Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Put from the context menu.

3 If the file hasn’t been saved, a dialog box appears (if you set this preference in the Site category of the Preferences dialog box) allowing you to save the file before putting it on the remote server. Click Yes to save the file or No to put the previously saved version on the remote server.

   Note:
   If you do not save the file, any changes you've made since the last time you saved will not be put onto the remote server. However, the file remains open, so you can still save the changes after putting the file on the server if you want.

4 Click Yes to upload dependent files along with the selected files, or click No to refrain from uploading dependent files. The default is to not upload dependent files. You can set this option at Edit > Preferences > Site.

   Note:
   It's usually a good idea to upload dependent files when checking in a new file, but if the latest versions of the dependent files are already on the remote server, there's no need to upload them again.

   To stop the file transfer at any time, click the Cancel button in the Background File Activity dialog box.

Put files on a remote server using the Document window
1 Make sure the document is active in the Document window.

2 Do one of the following to put the file:
   • Select Site > Put.
   • Click the File Management icon in the Document window toolbar, then select Put from the menu.

   Note:
   If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Put operation.

Display the FTP log
1 Click the Options menu in the upper right corner of the Files panel.

2 Select View > Site FTP Log.

   Note:
   In the Expanded Files Panel, you can click the FTP Log button to display the log.

Manage file transfers
You can view the status of file transfer operations, as well as a list of transferred files and their outcomes (transfer successful, skipped, or failed). You can also save a log of the file activity.

   Note:
   Dreamweaver lets you perform other non-server-related activities while you're transferring files to or from a server.
**Cancel a file transfer**

? Click the Cancel button in the Background File Activity dialog box. If the dialog box isn't showing, click the File Activity button at the bottom of the Files panel.

**Show the Background File Activity dialog box during transfers**

Click the File Activity or Log button at the bottom of the Files panel.

**View details of the last file transfer**

1. Click the Log button at the bottom of the Files panel to open the Background File Activity dialog box.
2. Click the Details expander arrow.

**Save a log of the last file transfer**

1. Click the Log button at the bottom of the Files panel to open the Background File Activity dialog box.
2. Click the Save Log button and save the information as a text file.

You can review the file activity by opening the log file in Dreamweaver or in any text editor.

---

**Check in and check out files**

If you're working in a collaborative environment, you can check files in and out from local and remote servers. If you're the only person working on the remote server, you can use the Put and Get commands without checking files in or out.

*Note:*

*You can use Get and Put functionality with a testing server, but you cannot use the Check In/ Check Out system with a testing server.*

Checking out a file is the equivalent of declaring “I’m working on this file now—don’t touch it!” When a file is checked out, the name of the person who checked out the file is displayed in the Files panel, along with a red check mark (if a team member checked out the file) or green check mark (if you checked out the file) next to the file's icon.

Checking in a file makes the file available for other team members to check out and edit. When you check in a file after editing it, your local version becomes read-only and a lock symbol appears beside the file in the Files panel to prevent you from making changes to the file.

Dreamweaver does not make checked-out files read-only on the remote server. If you transfer files with an application other than Dreamweaver, you can overwrite checked-out files. However, in applications other than Dreamweaver, the LCK file is visible next to the checked-out file in the file hierarchy to help prevent such accidents.

**Set up the Check In/Check Out system**

Before you can use the Check In/Check Out system, you must associate your local site with a remote server.

1. Select Site > Manage Sites.
2. Select a site and click Edit.
3. In the Site Setup dialog box, select the Servers category and do one of the following:
   - Click the Add New Server button to add a new server
   - Select an existing server and click the Edit Existing Server button
4 Specify Basic options as necessary, and then click the Advanced button.

5 Select Enable File Check Out if you are working in a team environment (or working alone but from several different machines). Deselect this option if you want to disable file check in and check out for your website.
   
   This option is useful to let others know that you checked out a file for editing, or to alert yourself that you may have left a more recent version of a file on another machine.
   
   If you do not see Check In/Out options, it means that you have not set up a remote server.

6 Select the Check Out Files when Opening option if you want to automatically check out files when you double-click to open them from the Files panel.
   
   Using File > Open to open a file doesn't check the file out even when this option is selected.

7 Set the remaining options:

   - **Check Out Name**  The check-out name appears in the Files panel alongside any files that are checked out; this enables team members to communicate with the right person if a file they need is checked out.
   
   - **Email Address**  If you enter an e-mail address, when you check out a file, your name appears in the Files panel as a link (blue and underlined) next to that file. If a team member clicks on the link, their default e-mail program opens a new message with the user's e-mail address and a subject that corresponds to the file and site name.

---

**Check files into and out of a remote folder**

After you set up the Check In/Check Out system, you can check in and check out files on a remote server using the Files panel or from the Document window.

**Check out files using the Files panel**

1 In the Files panel (Window > Files), select files to check out from the remote server.

   - **Note:**  
   
   *You can select files in the Local or Remote view, not the Testing Server view.*
   
   A red check mark indicates that another team member has the file checked out and a lock symbol indicates that the file is read-only (Windows) or locked (Macintosh).

2 Do one of the following to check out the file(s):
   
   - Click the Check Out button in the Files panel toolbar.
   - Right-click (Windows) or Control-click (Macintosh), then select Check Out from the context menu.

3 In the Dependent Files dialog box, click Yes to download dependent files along with the selected files, or click No to refrain from downloading dependent files. The default is to not download dependent files. You can set this option at Edit > Preferences > Site.

   - **Note:**  
   
   *It's usually a good idea to download dependent files when checking out a new file, but if the latest versions of the dependent files are already on the local disk, there's no need to download them again.*
   
   A green check mark appears beside the local file's icon indicating that you have checked it out.

   - **Note:**
If you check out the currently active file, the currently open version of the file is overwritten by the new checked-out version.

**Check in files using the Files panel**

1. In the Files panel (Window > Files), select checked-out or new file(s).
   
   *Note:*
   
   You can select files in the Local or Remote view, but not the Testing Server view.

2. Do one of the following to check in the file(s):
   
   • Click the Check In button in the Files panel toolbar.
   
   • Right-click (Windows) or Control-click (Macintosh), then select Check In from the context menu.

3. Click Yes to upload dependent files along with the selected files, or click No to refrain from uploading dependent files. The default is to not upload dependent files. You can set this option at Edit > Preferences > Site.
   
   *Note:*
   
   It’s usually a good idea to upload dependent files when checking in a new file, but if the latest versions of the dependent files are already on the remote server, there’s no need to upload them again.

   A lock symbol appears beside the local file’s icon indicating that the file is now read-only.

   *Note:*
   
   If you check in the currently active file, the file may be automatically saved before it’s checked in, depending on the preference options you’ve set.

**Check in an open file from the Document window**

1. Make sure the file you want to check in is open in the Document window.
   
   *Note:*
   
   You can check in only one open file at a time.

2. Do one of the following:
   
   • Select Site > Check In.
   
   • Click the File Management icon in the Document window toolbar, then select Check In from the menu.

   If the current file is not part of the active site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to a site other than the one that’s active in the Files panel, Dreamweaver opens that site, then performs the check in operation.

   *Note:*
   
   If you check in the currently active file, the file may be automatically saved before it’s checked in, depending on the preference options you’ve set.

**Undo a file check-out**

If you check out a file, then decide not to edit it (or decide to discard the changes you made), you can undo the check-out operation and the file returns to its original state.

To undo a file check-out, do one of the following:

• Open the file in the Document window, then select Site > Undo Check Out.
• In the Files panel (Window > Files), right-click (Windows) or Control-click (Macintosh), then select Undo Check Out.

The local copy of the file becomes read-only, and any changes you've made to it are lost.

**Use WebDAV to check in and check out files**

Dreamweaver can connect to a server that uses WebDAV (Web-based Distributed Authoring and Versioning), which is a set of extensions to the HTTP protocol that allow users to collaboratively edit and manage files on remote web servers. For more information, see [www.webdav.org](http://www.webdav.org).

1 If you have not already done so, define a Dreamweaver site that specifies the local folder you use to store your project files.

2 Select Site > Manage Sites, and then double-click your site in the list.

3 In the Site Setup dialog box, select the Servers category and do one of the following:
   • Click the Add New Server button to add a new server
   • Select an existing server and click the Edit Existing Server button

4 In the Basic screen, select WebDAV from the Connect Using pop-up menu, and complete the rest of the Basic screen options, as necessary.

5 Click the Advanced button.

6 Select the Enable File Check Out option and enter the following information:
   • In the Check Out Name box, enter a name identifying you to other team members.
   • In the Email Address box, enter your e-mail address.

   The name and e-mail addresses are used to identify ownership on the WebDAV server and appear in the Files panel for contact purposes.

7 Click Save.

Dreamweaver configures the site for WebDAV access. When you use the Check In or Check Out command on any site file, the file is transferred using WebDAV.

**Note:**

WebDAV may be unable to properly check out any files with dynamic content like PHP tags or SSIs because the HTTP GET renders these as they are checked out.

**Use Subversion (SVN) to get and check in files**

**Note:**

Subversion (SVN) support is removed in Dreamweaver 2017 versions and later.

Dreamweaver can connect to a server that uses Subversion (SVN), a versioning control system that lets users collaboratively edit and manage files on remote web servers. Dreamweaver is not a full SVN client, but does let users get the latest versions of files, make changes, and commit the files.

**Note:**
Dreamweaver CS5 uses the Subversion 1.6.6 client library, and Dreamweaver CS5.5 uses the 1.6.9 client library. Later versions of the Subversion client library are not backward-compatible. Be aware, if you update a third-party client application (for example, TortoiseSVN) to work with a later version of Subversion, the updated Subversion application will update local Subversion meta data, and Dreamweaver will no longer be able to communicate with Subversion. This issue is not affected by updates to the Subversion server as those updates are backward-compatible. If you do upgrade to a third-party client application that works with Subversion 1.7 or later, you’ll need to check with Adobe for updates before you can use Subversion with Dreamweaver again. For more information on this issue, see www.adobe.com/go/dw_svn_en.

Adobe recommends that you use a third-party file comparison tool as you work with SVN version-controlled files. When you compare files for differences, you can learn exactly what kinds of changes other users made to the files. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.

For a video overview of working with SVN and Dreamweaver, see www.adobe.com/go/lrvid4049_dw.

Set up an SVN connection

Before you use Subversion (SVN) as a version control system with Dreamweaver, you must set up a connection to an SVN server. You set up a connection to an SVN server in the Version Control category of the Site Definition dialog box.

The SVN server is a repository of files from which you and other users can get and commit files. It is different from the remote server you typically use with Dreamweaver. When using SVN, the remote server remains the “live” server for your web pages, and the SVN server exists to hold the repository of files over which you want to maintain version control. The typical workflow is to get and commit files back and forth between the SVN server, and then publish them to your remote server from Dreamweaver. The remote server setup is completely separate from the SVN set up.

You must have access to an SVN server and an SVN repository before you begin this set up. For more information about SVN, see the Subversion website at http://subversion.apache.org/.

To set up the SVN connection, follow these steps:

1 Choose Sites > Manage Sites, select the site you want to set up version control for, and click the Edit button.

   Note:

   If you haven't already set up local and remote folders for a Dreamweaver site, you'll at least need to set up a local site before proceeding. (The remote site is not required at this stage, but you will eventually need to set it up before publishing your files to the Web.) For more information, see Working with Dreamweaver sites.

2 In the Site Setup dialog box, select the Version Control category.

3 Select Subversion from the Access pop-up menu.

4 Set access options as follows:

   • Select a protocol from the Protocol pop-up menu. The available protocols are HTTP, HTTPS, SVN, and SVN+SSH.

   Note:

   Using the SVN+SSH protocol requires special configuration. For more information, see www.adobe.com/go/learn_dw_svn_ssh_en.

   • Enter the address for the SVN server in the Server address text box (typically in the form of servername.domain.com).

   • Enter the path to your repository on the SVN server in the Repository path text box (typically something like /svn/your_root_directory. It is up to the server administrator to name the root folder for the SVN repository.)
- (Optional) If you want to use a server port other than the default server port, select Non Default and enter the port number in the text box.
- Enter your SVN server user name and password.

5 Click Test to test your connection, or click OK to close the dialog box. Then click Done to close the Manage Sites dialog box.

Once the connection with the server established, your SVN repository is available for viewing in the Files panel. To view it, you can select Repository View from the View pop-up menu, or click the Repository Files button in the expanded Files panel.

**Get the latest versions of files**

When you get the latest version of a file from the SVN repository, Dreamweaver merges the contents of that file with the contents of its corresponding local copy. (In other words, if someone else has updated the file since you last committed it, those updates are merged into the local version of the file on your computer.) If the file does not yet exist on the local hard drive, Dreamweaver simply gets the file.

**Note:**

When getting files for the first time from the repository, you should work with a local directory that is empty, or a local directory that does not contain files with the same names as files in the repository. Dreamweaver will not mount repository files to the local drive upon first try if the local drive contains files whose names match files in the remote repository.

1 Make sure that you’ve successfully set up an SVN connection.

2 Do one of the following:
   - Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file or folder you’re interested in and select Version Control > Get Latest Versions.
   - Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file or folder you’re interested in and select Get Latest Versions.

**Note:**

You can also either right-click a file and choose Check Out from the context menu, or select the file and click the Check Out button to get the latest version. Because SVN does not support a check-out workflow, however, this action does not actually check out the file in the traditional sense.

**Commit files**

1 Make sure that you’ve successfully set up an SVN connection.

2 Do one of the following:
   - Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then select the file you want to commit and click the Check In button.
   - Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you want to commit and select Check In.

3 Review the actions in the Commit dialog box, make changes if necessary, and click OK.
Manage files

You can change actions by selecting the file whose action you want to change, and clicking the buttons at the bottom of the Commit dialog box. Two choices are available: commit and ignore.

**Note:**
*A green check mark on a file in the Files panel denotes a changed file that has not yet been committed to the repository.*

**Update status of files or folders in the repository**
You can update the SVN status of a single file or folder. The update does not refresh the entire display.

1. Make sure that you've successfully set up an SVN connection.
2. Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel.
3. Right-click (Windows) or Control-click (Macintosh) any folder or file in the repository and select Update Status.

**Update status of local file or folders**
You can update the SVN status of a single file or folder. The update does not refresh the entire display.

1. Make sure that you've successfully set up an SVN connection.
2. Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu.
   (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3. Right-click (Windows) or Control-click (Macintosh) any folder or file in the Files panel and select Update Status.

**View revisions for a file**

1. Make sure that you've successfully set up an SVN connection.
2. Do one of the following:
   - Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu.
     (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file you want to see revisions for and select Version Control > Show Revisions.
   - Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you want to see revisions for and select Show Revisions.
3. In the Revision History dialog box, select the revision or revisions you're interested in and do one of the following:
   - Click Compare to Local to compare the selected revision with the local version of the file.
   - Click Compare to compare two selected revisions. Control-click to select two revisions simultaneously.
   - Click View to view the selected revision. This action does not overwrite the current local copy of the same file. You can save the selected revision to your hard drive just as you would save any other file.
   - Click Promote to make the selected revision the most current revision in the repository.

**Note:**
*You must install a third-party file comparison tool before you can compare files. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.*

- Click Compare to compare two selected revisions. Control-click to select two revisions simultaneously.
- Click View to view the selected revision. This action does not overwrite the current local copy of the same file. You can save the selected revision to your hard drive just as you would save any other file.
- Click Promote to make the selected revision the most current revision in the repository.
Lock and unlock files
Locking a file in the SVN repository lets other users know that you are working on a file. Other users can still edit the file locally, but will not be able to commit the file until you’ve unlocked it. When you lock a file in the repository, you’ll see an open-lock icon on the file. Other users see a completely locked icon.

1. Make sure that you’ve successfully set up an SVN connection.
2. Do one of the following:
   • Display the SVN repository files by selecting Repository View from the View pop-up menu in the Files panel, or by clicking the Repository Files button in the expanded Files panel. Then right-click (Windows) or Control-click (Macintosh) the file you’re interested in and select Lock or Unlock.
   • Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.) Then right-click (Windows) or Control-click (Macintosh) the file you’re interested in and select Lock or Unlock.

Add a new file to the repository
A blue plus sign on a file in the Files panel denotes a file that does not yet exist in the SVN repository.

1. Make sure that you’ve successfully set up an SVN connection.
2. In the Files panel, select the file you want to add to the repository and click the Check In button.
3. Make sure that the file is selected for Commit in the Commit dialog box and click OK.

Move, copy, delete, or revert files
• To move a file, drag the file to the destination folder in your local site.
  When you move a file, Dreamweaver marks the file in the new location with an Add With History sign, and marks the file in the old location with a Delete sign. When you Commit these files, the file in the old location disappears.
• To copy a file, select the file, copy it (Edit > Copy), and paste (Edit > Paste) the file in the new location.
  When you copy and paste a file, Dreamweaver marks the file in the new location with an Add With History sign.
• To delete a file, select the file and press delete.
  Dreamweaver gives you the option of whether you want to delete the local version of the file only, or both the local version and the version on the SVN server. If you select to delete the local version only, the file on the SVN server is not affected. If you select to delete the version on the SVN server as well, the local version is marked with a Delete sign, and you must commit the file for the deletion to take place.
• To revert a copied or moved file to its original location, right-click the file and select Version Control > Revert.

Resolve conflicting files
If your file conflicts with another file on the server, you can edit it and then mark it as resolved. For example, if you try to check in a file that conflicts with another user's changes, SVN will not let you commit the file. You can get the latest version of the file from the repository, manually make changes to your working copy, and then mark your file as resolved so that you can commit it.

1. Make sure that you’ve successfully set up an SVN connection.
2. Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3. Right-click (Windows) or Control-click (Macintosh) the file you want to resolve and select Version Control > Mark as Resolved.
Go offline
You might find it useful to avoid repository access during other file-transfer activities by going off-line. Dreamweaver will reconnect to the SVN repository as soon as you invoke an activity that requires a connection (Get Latest Versions, Commit, and so on).

1. Make sure that you’ve successfully set up an SVN connection.
2. Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3. Right-click (Windows) or Control-click (Macintosh) any file or folder in the Files panel and select Version Control > Go Offline.

Clean up a local SVN site
This command lets you remove locks on files so that you can resume unfinished operations. You should use this command to remove old locks if you receive “working copy locked” errors.

1. Make sure that you’ve successfully set up an SVN connection.
2. Display the local version of your SVN files in the Files panel by selecting Local view from the View pop-up menu. (If you are working in the expanded Files panel, the Local view is automatically displayed.)
3. Right-click (Windows) or Control-click (Macintosh) the file you want to clean up and select Version Control > Clean Up.

About moving files and folders in Subversion-controlled sites
When you move the local versions of files or folders in a Subversion-controlled site, you run the risk of creating problems for other users who might be synching to the SVN repository. For example, if you move a file locally, and don’t commit that file to the repository for a few hours, another user might try to get the latest version of the file from the file’s old location. For this reason, you should always commit files back to the SVN server immediately after you’ve moved them locally.

Files and folders remain on the SVN server until you’ve manually deleted them. So even if you move a file to a different local folder and commit it, the old version of the file remains in the previous location on the server. To avoid confusion, delete the old copies of files and folders that you’ve moved.

When you move a file locally and commit it back to the SVN server, the file’s version history is lost.

Synchronize files

Synchronize the files on your local and remote sites
After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.

Note:
If your remote site is an FTP server (rather than a networked server), then synchronizing your files uses FTP.

Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver also confirms which files have been updated after you complete the synchronization.
Check which files are newer on the local or remote site, without synchronizing

In the Files panel, do one of the following:

- Click the Options menu in the upper-right corner, and then select Edit > Select Newer Local or Edit > Select Newer Remote.
- In the Files panel, right-click (Windows) or Control-click (Macintosh), and then select Select > Newer Local or Select > Newer Remote.

Display detailed synchronization information for a particular file

In the Files panel, right-click (Windows) or Control-click (Macintosh) the file you want information about, and then select Display Synchronize information.

Note:
You must have the Maintain Synchronization Information option selected in the Remote category of the Site Definition dialog box for this feature to be available.

Synchronize your files

1 In the Files panel (Window > Files), select a site from the menu where the current site, server, or drive appears.
2 (Optional) Select specific files or folders or go to the next step to synchronize the entire site.
3 Click the Options menu in the upper-right corner of the Files panel and select Site > Synchronize.
   You can also click the Synchronize button at the top of the Files panel to synchronize files.
4 In the Synchronize menu, do one of the following:
   - To synchronize the entire site, select Entire Site Name Site.
   - To synchronize selected files only, select Selected Local Files Only (or Selected Remote Files Only if the Remote view of the Files panel was where you made the most recent selection).
5 Select the direction in which you want to copy the files:
   - Put Newer Files To Remote Uploads all the local files that don't exist on the remote server or have changed since the last upload.
   - Get Newer Files From Remote Downloads all the remote files that don't exist locally or have changed since the last download.
   - Get And Put Newer Files Places the most recent versions of all the files on both the local and the remote sites.
6 Select whether to delete the files on the destination site that don't have counterparts on the origin site. (This is not available if you select Get and Put from the Direction menu.)
   If you select Put Newer Files to Remote and you select the Delete option, then any files in your remote site for which there are no corresponding local files are deleted. If you select Get Newer Files from Remote, then any files in your local site for which there are no corresponding remote files are deleted.
7 Click Preview.
   Note:
   Before you can synchronize the files, you must preview the actions Dreamweaver performs to accomplish this task.
   If the newest version of each chosen file is already in both locations and nothing needs to be deleted, an alert appears informing you that no synchronization is necessary. Otherwise, the Synchronize dialog box appears to let you change the actions (put, get, delete, and ignore) for those files before executing the synchronization.
8 Verify the action that will be performed for each file.
9 To change the action for a particular file, select the file, and then click one of the action icons at the bottom of the preview window.

- **Compare** The Compare action works only if you installed and specified a file comparison tool in Dreamweaver. If the action icon is grayed out, the action cannot be performed.

- **Mark Selected Files As Already Synched** This option lets you specify that the selected file or files are already synchronized.

10 Click OK to synchronize the files. You can view or save the details of the synchronization to a local file.

### Compare files for differences

#### Compare local and remote files for differences

Dreamweaver can work with file comparison tools (also known as “diff tools”) to compare the code of local and remote versions of the same file, two different remote files, or two different local files. Comparing local and remote versions is useful if you're working on a file locally and you suspect the copy of the file on the server has been modified by someone else. Without leaving Dreamweaver, you can view and merge the remote changes into your local version before putting the file to the server.

Comparing two local files or two remote files is also useful if you keep previous, renamed versions of your files. If you've forgotten the changes made to a file from a previous version, a quick comparison will remind you.

Before you start, you must install a third-party file comparison tool on your system. For more information on file comparison tools, use a web search engine such as Google Search to search for “file comparison” or “diff” tools. Dreamweaver works with most third-party tools.

#### Specify a comparison tool in Dreamweaver

1 Install the file comparison tool on the same system as Dreamweaver.

2 In Dreamweaver, open the Preferences dialog box by selecting Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and then select the File Compare category.

3 Do one of the following:
   - In Windows, click the Browse button and select the application that compares files.
   - On the Macintosh, click the Browse button and select the tool or script that launches the file comparison tool from the command line, not the actual comparison tool itself.

Launch tools or scripts are typically located in the `/usr/bin` folder on your Macintosh. For example, if you want to use FileMerge, browse to `/usr/bin` and select `opendiff`, which is the tool that launches FileMerge.

The following table lists common file comparison tools for the Macintosh and the location of their launch tools or scripts on your hard disk:
If you use | Select the following file
---|---
FileMerge | /usr/bin/opendiff (or /Developer/usr/bin/opendiff)
BBEdit | /usr/bin/bbdiff
TextWrangler | /usr/bin/twdiff

**Note:**
The *usr* folder is normally hidden in Finder. However, you can access it with the Browse button in Dreamweaver.

**Note:**
The actual results displayed depends on the diff tool you are using. Check the user manual for your tool to understand how to interpret the results.

**Compare two local files**
You can compare two files located anywhere on your computer.

1. In the Files panel, Control-click (Windows) or Command-click (Macintosh) the two files to select them.

   To select files outside your defined site, select your local disk from the left pop-up menu in the Files panel and then select the files.

2. Right-click one of the selected files and select Compare Local Files from the context menu.

   **Note:**
   *If you have a one-button mouse, Control-click one of the selected files instead.*

   The file comparison tool starts and compares the two files.

**Compare two remote files**
You can compare two files located on your remote server. You must define a Dreamweaver site with remote settings before you can accomplish this task.

1. In the Files panel, display the files on the remote server by selecting Remote View from the right pop-up menu.

2. Control-click (Windows) or Command-click (Macintosh) the two files to select them

3. Right-click one of the selected files and select Compare Remote Files from the context menu.

   **Note:**
   *If you have a one-button mouse, Control-click one of the selected files instead.*

   The file comparison tool starts and compares the two files.

**Compare a local file to a remote file**
You can compare a local file to a file located on your remote server. To do this, you must first define a Dreamweaver site with remote settings.

1. In the Files panel, right-click a local file and select Compare With Remote from the context menu.

   **Note:**
If you have a one-button mouse, Control-click the local file instead.

The file comparison tool starts and compares the two files.

**Compare a remote file to a local file**

You can compare a remote file to a local file. You must define a Dreamweaver site with remote settings before accomplishing this task.

1. In the Files panel, display the files on the remote server by selecting Remote View from the right pop-up menu.
2. Right-click a file in the panel and select Compare with Local from the context menu.

   **Note:**

   If you have a one-button mouse, Control-click the file instead.

**Compare an open file to a remote file**

You can compare a file open in Dreamweaver to its counterpart on the remote server.

? In the Document window, select File > Compare with Remote.

   The file comparison tool starts and compares the two files.

   *You can also right-click the document tab along the top of the Document window and select Compare with Remote from the context menu.*

**Compare before putting files**

If you edit a file locally and then try to upload it to your remote server, Dreamweaver will notify you if the remote version of the file has changed. You have the option of comparing the two files before you upload the file and overwrite the remote version.

Before you start, you must install a file comparison tool on your system and specify it in Dreamweaver.

1. After editing a file in a Dreamweaver site, put the file (Site > Put) to your remote site.
   
   If the remote version of the file has been modified, you’ll receive a notification with the option of seeing the differences.

2. To view the differences, click the Compare button.
   
   The file comparison tool starts and compares the two files.

   If you haven’t specified a file comparison tool, you are prompted to specify one.

3. After you’ve reviewed or merged the changes in the tool, you can proceed with the Put operation or cancel it.

**Compare files when synchronizing**

You can compare the local versions of your files with the remote versions when you synchronize your site files with Dreamweaver.

Before you start, you must install a file comparison tool on your system and specify it in Dreamweaver.

1. Right-click anywhere in the Files panel and select Synchronize from the context menu.
2. Complete the Synchronize Files dialog box and click Preview.
After you click Preview, the selected files and the actions that will be taken during synchronization are listed.

3 In the list, select each file you want to compare and click the Compare button (the icon with two small pages).

*Note:*

*The file must be text-based, such as HTML or ColdFusion files.*

Dreamweaver starts the comparison tool, which compares the local and remote versions of each file you selected.

---

**Cloak files and folders in your Dreamweaver site**

**About site cloaking**

Site cloaking enables you to exclude files and folders from operations such as Get or Put. You can also cloak all files of a particular type (JPEG, FLV, XML, and so on) from site operations. Dreamweaver remembers your settings for each site so that you don't have to make selections each time you work on that site.

For example, if you're working on a large site and you don't want to upload your multimedia files each day, you can use site cloaking to cloak your multimedia folder. Dreamweaver will then exclude files in that folder from site operations you perform.

You can cloak files and folders on the remote or local site. Cloaking excludes cloaked files and folders from the following operations:

- Performing Put, Get, Check In, and Check Out operations
- Generating reports
- Finding newer local and newer remote files
- Performing sitewide operations, such as checking and changing links
- Synchronizing
- Working with Asset panel contents
- Updating templates and libraries

*Note:*

*You can still perform an operation on a specific cloaked folder or file by selecting the item in the Files panel and performing an operation on it. Performing an operation directly on a file or folder overrides cloaking.*

*Note:*

*Dreamweaver excludes cloaked templates and library items from Get and Put operations only. Dreamweaver does not exclude these items from batch operations, because it might cause them to become out of sync with their instances.*

**Enable and disable site cloaking**

Site cloaking enables you to exclude folders, files, and file types in a site from sitewide operations such as Get or Put, and is enabled by default. You can disable cloaking permanently or just temporarily to perform an operation on all files, including cloaked files. When you disable site cloaking, all cloaked files are uncloaked. When you enable site cloaking again, any previously cloaked files become cloaked again.

*Note:*
You can also use the Uncloak All option to uncloak all files, but this does not disable cloaking; also there is no way to re-cloak all files and folders that were previously cloaked, except to set cloaking again for each folder, file, and file type.

1. In the Files panel (Window > Files) select a file or folder.
2. Right-click (Windows) or Control-click (Macintosh), and do one of the following:
   - Select Cloaking > (deselect to disable).
   - Select Cloaking > Settings to open the Cloaking category of the Site Setup dialog box. Select or deselect , and select or deselect Cloak Files Ending With to enable or disable cloaking for specific file types. You can enter or delete file suffixes in the text box that you want to cloak or uncloak.

Cloak and uncloak site files and folders
You can cloak specific files and folders, but you cannot cloak all files and folders or cloak an entire site. When you cloak specific files and folders, you can cloak multiple files and folders at the same time.

1. In the Files panel (Window > Files), select a site that has site cloaking enabled.
2. Select the folder(s) or file(s) you want to cloak or uncloak.
3. Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Cloak or Cloaking > Uncloak from the context menu.

   A red line through the file or folder icon appears or disappears, indicating that the folder is cloaked or uncloaked.

   Note:
   You can still perform an operation on a specific cloaked file or folder by selecting the item in the Files panel and performing an operation on it. Performing an operation directly on a file or folder overrides cloaking.

Cloak and uncloak specific file types
You can indicate specific file types to cloak, so that Dreamweaver cloaks all files ending with a specified pattern. For example, you can cloak all files ending with the .txt extension. The file types that you enter do not have to be file extensions; they can be any pattern at the end of a filename.

Cloak specific file types within a site
1. In the Files panel (Window > Files), select a site that has site cloaking enabled.
2. Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Settings.
3. Select the Cloak Files Ending With option, enter the file types to cloak in the box, and click OK.

   For example, you might enter .jpg to cloak all files with names ending in .jpg in your site.

   Separate multiple file types with one space; do not use a comma or semicolon.

   In the Files panel, a red line appears through the affected files, indicating that they are cloaked.

   ![Tip](image)

   Some software creates backup files ending in a particular suffix, such as .bak. You can cloak such files.

   Note:
   You can still perform an operation on a specific cloaked file or folder by selecting the item in the Files panel and performing an operation on it. Performing an operation directly on a file or folder overrides cloaking.
Manage files

Uncloak specific file types within a site
1 In the Files panel (Window > Files), select a site that has site cloaking enabled.
2 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Settings.
3 In the Advanced Site Definition dialog box, do one of the following:
   - Deselect the Cloak Files Ending With option to uncloak all the file types listed in the box.
   - Delete specific file types from the box to uncloak those file types.
4 Click OK.
   The red lines disappear from the affected files, indicating that they are uncloaked.

Uncloak all files and folders
You can uncloak all files and folders in a site at the same time. This action cannot be undone; there is no way to re-cloak all items that were previously cloaked. You have to re-cloak items individually.

If you want to temporarily uncloak all folders and files, then re-cloak those items, disable site cloaking.
1 In the Files panel (Window > Files), select a site that has site cloaking enabled.
2 Select any file or folder in that site.
3 Right-click (Windows) or Control-click (Macintosh), then select Cloaking > Uncloak All.
   Note:
   This step also deselects the Cloak Files Ending With option in the Cloaking category of the Site Definition dialog box.
   The red lines through folder and file icons disappear, indicating that all files and folders in the site are uncloaked.

Enable Design Notes for Dreamweaver sites

About Design Notes
Design Notes are notes that you create for a file. Design Notes are associated with the file they describe, but stored in a separate file. You can see which files have Design Notes attached in the expanded Files panel: A Design Notes icon appears in the Notes column.

You can use Design Notes to keep track of extra file information associated with your documents, such as image sourcefilenames and comments on file status. For example, if you copy a document from one site to another, you can add Design Notes for that document, with the comment that the original document is in the other site folder.

You can also use Design Notes to keep track of sensitive information that you can’t put inside a document for security reasons, such as notes on how a particular price or configuration was chosen, or what marketing factors influenced a design decision.
If you open a file in Adobe® Fireworks® or Flash, and export it to another format, Fireworks and Flash automatically save the name of the original source file in a Design Notes file. For example, if you open myhouse.png in Fireworks and export it to myhouse.gif, Fireworks creates a Design Notes file called myhouse.gif.mno. This Design Notes file contains the name of the original file, as an absolute file: URL. So, the Design Notes for myhouse.gif might contain the following line:

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

A similar Flash Design Note might contain the following line:

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

Note:
To share Design Notes, users should define the same site-root path (for example, sites/assets/orig).

When you import the graphic into Dreamweaver, the Design Notes file is automatically copied into your site along with the graphic. When you select the image in Dreamweaver and choose to edit it using Fireworks, Fireworks opens the original file for editing.

Enable and disable Design Notes for a site
Design Notes are notes associated with a file, but stored in a separate file. Use Design Notes to keep track of extra file information associated with your documents, such as image source-filenames and comments on file status.

You enable and disable Design Notes for a site in the Design Notes category of the Site Definition dialog box. When you enable Design Notes, you can also choose to share them with others, if you want.

1 Select Site > Manage Sites.
2 In the Manage Sites dialog box, select a site, then click Edit.
3 In the Site Setup dialog box, expand Advanced Settings and select the Design Notes category.
4 Select Maintain Design Notes to enable Design Notes (deselect to disable them).
5 If you want to delete all local Design Notes files for your site, click Clean Up, and then click Yes. (If you want to delete remote Design Notes files, you’ll need to delete them manually).

Note:
The Clean Up Design Notes command only deletes MNO (Design Notes) files. It does not delete the _notes folder or the dwsync.xml file inside the _notes folder. Dreamweaver uses the dwsync.xml file to maintain information about site synchronization.

6 Select Enable Upload Design Notes For Sharing to upload Design Notes associated with your site with the rest of your documents and click OK.

- If you select this option, you can share Design Notes with the rest of your team. When you put or get a file, Dreamweaver automatically puts or gets the associated Design Notes file.
- If you do not select this option, Dreamweaver maintains Design Notes locally but does not upload them with your files. If you work alone on your site, deselecting this option improves performance. Design Notes will not be transferred to the remote site when you check in or put your files and you can still add and modify the Design Notes for your site locally.

Associate Design Notes with files
You can create a Design Notes file for each document or template in your site. You can also create Design Notes for applets, ActiveX controls, images, Flash content, Shockwave objects, and image fields in your documents.
Manage files

Note:

If you add Design Notes to a template file, documents you create with the template do not inherit the Design Notes.

1 Do one of the following:
   • Open the file in the Document window and select File > Design Notes.
   • In the Files panel, right-click (Windows) or Control-click (Macintosh) the file, and select Design Notes.

Note:

If the file resides in a remote site, you must first check out or get the file, and then select it in the local folder.

2 In the Basic Info tab, select a status for the document from the Status menu.

3 Click the date icon (above the Notes box) to insert the current local date in your notes.

4 Type comments in the Notes box.

5 Select Show When File Is Opened to make the Design Notes file appear every time the file is opened.

6 In the All Info tab, click the Plus (+) button to add a new key-value pair; select a pair and click the Minus (–) button to remove it.

   For example, you might name a key Author (in the Name box) and define the value as Heidi (in the Value box).

7 Click OK to save the notes.

    Dreamweaver saves your notes to a folder called _notes, in the same location as the current file. The filename is the
document's filename, plus the extension .mno. For example, if the filename is index.html, the associated Design
Notes file is named index.html.mno.

Work with Design Notes

After you associate a Design Note with a file, you can open the Design Note, change its status, or delete it.

Open Design Notes associated with a file

Do one of the following to open the Design Notes:
   • Open the file in the Document window, then select File > Design Notes.
   • In the Files panel, right-click (Windows) or Control-click (Macintosh) the file, and select Design Notes.
   • In the Notes column of the Files panel, double-click the yellow Design Notes icon.

Note:

To show the yellow Design Notes icons, select Site > Manage Sites > [your site name] > Edit > Advanced Settings > File
View Columns. Select Notes in the list panel and choose the Show option. When you click the Expand button on the Files
toolbar to show both the local and remote site, you have a Notes column in your local site that shows a yellow note icon
for any file with a Design Note.

Assign a custom Design Notes status

1 Open Design Notes for a file or object (see the previous procedure).

2 Click the All Info tab.

3 Click the Plus (+) button.

4 In the Name field, enter the word status.

5 In the Value field, enter the status.
If a status value already existed, it's replaced with the new one.

6 Click the Basic Info tab and note that the new status value appears in the Status pop-up menu.

Note:

You can have only one custom value in the status menu at a time. If you follow this procedure again, Dreamweaver replaces the status value you entered the first time with the new status value you enter.

Delete unassociated Design Notes from your site

1 Select Site > Manage Sites.
2 Select the site and click Edit.
3 In the Site Definition dialog box, select Design Notes from the category list on the left.
4 Click the Clean Up button.

Dreamweaver prompts you to verify that it should delete any Design Notes that are no longer associated with a file in your site.

If you use Dreamweaver to delete a file that has an associated Design Notes file, Dreamweaver deletes the Design Notes file too; so usually orphan Design Notes files occur only if you delete or rename a file outside of Dreamweaver.

Note:

If you deselect the Maintain Design Notes option before you click Clean Up, Dreamweaver deletes all Design Notes files for your site.

Preventing potential Gatekeeper exploit

Gatekeeper is a built-in malware detection feature in Mac OS X 10.7 and later. Apps that are installed from Mac App Store are considered to be safe since Apple reviews each app before they are accepted by the store. Apps that are downloaded from places other than the App Store must be digitally signed with the Developer ID issued by Apple. Gatekeeper checks for the signature in the apps during launch and blocks the apps that are tampered with or are not signed by a Developer ID. It also prompts users to confirm if they want to run the app.

While Gatekeeper checks for valid signatures when an app is being installed, it does not check the apps or plug-ins that get dynamically loaded after the app is installed. This shortcoming can be exploited to load malicious plug-ins through Dreamweaver, especially if the Dreamweaver install package is downloaded from non-Adobe sources and installed in a location other than /Applications.

Adobe Dreamweaver that is downloaded from Creative Cloud is signed with a valid Developer ID and can be successfully installed in the default location on Mac: /Applications. All third-party libraries within the /Applications folder are also automatically loaded.

When Dreamweaver is installed in a custom location, it does not automatically load third-party libraries to prevent a potential Gatekeeper exploit. Dreamweaver displays a dialog box that lists all the third-party libraries that can be loaded:
Confirmation for loading third-party libraries

If you are sure that these libraries have been obtained from credible sources, you can go ahead and choose to load them. The dialog box is not displayed again and Dreamweaver continues to load these libraries and extensions in all subsequent launches.

If you do not want to load these libraries or extensions, click No. Note that Dreamweaver will not display this dialog box again and none of the extensions that you install in future will be loaded.

If you want the dialog box to be displayed again so that you can change your option, delete the Preferences file. However, exercise caution while deleting this file and follow the instructions described in this article.
Chapter 6: Layout and design

Use visual aids for layout

Set rulers
Rulers help you measure, organize, and plan your layout. They can appear on the left and top borders of the page, marked in pixels, inches, or centimeters.

- To toggle rulers on and off, select View > Design View Options > Rules > Show/Hide.
- To change the origin, drag the ruler-origin icon (at the upper-left corner of the Design view of the Document window) anywhere on the page.
- To reset the origin to its default position, select View > Design View Options > Rulers > Reset Origin.
- To change the unit of measure, select View > Rulers, and then select Pixels, Inches, or Centimeters.

Set layout guides
Guides are lines that you drag onto the document from the rulers. They help you place and align objects more precisely. You can also use guides to measure the size of page elements, or emulate the folds (visible areas) of web browsers.

To help you align elements, you can snap elements to guides, and snap guides to elements. (Elements must be absolutely positioned in order for the snap feature to work.) You can also lock guides to prevent them from being accidentally moved by another user.

Create a horizontal or vertical guide
1 Drag from the corresponding ruler.
2 Position the guide in the Document window and release the mouse button (reposition the guide by dragging it again).

Note:
By default, guides are recorded as absolute pixel measurements from the top or left side of the document, and are shown relative to the origin of the ruler. To record the guide as a percentage, press the Shift key while you create or move the guide.

Show or hide guides
? Select View > Guides > Show Guides.

Snap elements to guides
- To snap elements to guides, select View > Design View Options > Guides > Snap to Guides.
- To snap guides to elements, select View > Design View Options > Guides > Guides Snap to Elements.
Note:

When you resize elements, such as absolutely-positioned elements (AP elements), tables, and images, the resized elements snap to guides.

**Lock or unlock all guides**
Select View > Design View Options > Guides > Lock Guides.

**View and move a guide to a specific position**
1. Hold the mouse pointer over the guide to view its position.
2. Double-click the guide.
3. Enter the new position in the Move Guide dialog box and click OK.

**View the distance between guides**
Press Control (Windows) or Command (Macintosh) and hold the mouse pointer anywhere between the two guides.

*Note:*

The unit of measure is the same as the unit of measure used for the rulers.

**Emulate the fold (visible area) of a web browser**
Select View > Design View Options > Guides, and then select a preset browser size from the menu.

**Remove a guide**
Drag the guide off the document.

**Change guide settings**
? Select View > Design View Options > Guides > Edit Guides, set the following options, and click OK.

- **Guide color** Specifies the color of the guide lines. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.
- **Distance Color** Specifies the color of the lines that appear as distance indicators when you hold the mouse pointer between guides. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.
- **Show Guides** Makes guides visible in Design view.
- **Snap to Guides** Makes page elements snap to guides as you move elements around the page.
- **Lock Guides** Locks guides in place.
- **Guides Snap to Elements** Snaps guides to elements on the page as you drag guides.
- **Clear All** Clears all guides from the page.

**Use guides with templates**
When guides are added to a Dreamweaver template, all instances of the template inherit the guides. Guides in template instances, however, are treated as editable regions, so users can modify them. Modified guides in template instances are restored to their original location whenever the instance is updated with the master template.
You can also add your own guides to instances of a template. Guides added in this manner are not overwritten when the template instance is updated with the master template.

**Use the layout grid**

The grid displays a system of horizontal and vertical lines in the Document window. It is useful for placing objects precisely. You can make absolutely-positioned page elements automatically snap to the grid as you move them, and change the grid or control the snapping behavior by specifying grid settings. Snapping works whether or not the grid is visible.

**Show or hide the grid**

Select View > Design View Options > Grid > Show Grid.

**Enable or disable snapping**

Select View > Design View Options > Grid > Snap to Grid.

**Change grid settings**

1. Select View > Design View Options > Grid > Grid Settings.
2. Set the options and click OK to apply the changes.
   - **Color** Specifies the color of the grid lines. Click the color swatch and select a color from the color picker, or type a hexadecimal number in the text box.
   - **Show Grid** Makes the grid visible in Design view.
   - **Snap to Grid** Makes page elements snap to the lines of the grid.
   - **Spacing** Controls how far apart the grid lines are. Enter a number and select Pixels, Inches, or Centimeters from the menu.
   - **Display** Specifies whether the grid lines appear as lines or dots.

   **Note:**
   
   *If Show Grid is not selected, the grid does not appear in the document and no changes are visible.*

**Use a tracing image**

You can use a tracing image as a guide to re-create a page design that was created in a graphics application such as Adobe Freehand or Fireworks.

A tracing image is a JPEG, GIF, or PNG image that is placed in the background of the Document window. You can hide the image, set its opacity, and change its position.

The tracing image is visible only in Dreamweaver; it is not visible when you view the page in a browser. When the tracing image is visible, the page's real background image and color are not visible in the Document window; however, the background image and color will be visible when the page is viewed in a browser.

**Place a tracing image in the Document window**

1. Do one of the following:
   - Select View > Design View Options > Tracing Image > Load.
   - Select File > Page Properties, then in the Tracing Image category, click Browse (next to the Tracing Image text box).
2 Navigate to your image file and click OK.
3 In the Page Properties dialog box, specify the transparency for the image by dragging the Image Transparency slider, then click OK.

To switch to another tracing image or change the transparency of the current tracing image at any time, select File > Page Properties.

**Show or hide the tracing image**
Select View > Design View Options > Tracing Image > Show.

**Change the position of a tracing image**
? Select View > Design View Options > Tracing Image > Adjust Position.

- To precisely specify the position of the tracing image, enter coordinate values in the X and Y text boxes.
- To move the image 1 pixel at a time, use the arrow keys.
- To move the image 5 pixels at a time, press Shift and an arrow key.

**Reset the position of the tracing image**

The tracing image returns to the upper-left corner of the Document window (0,0).

**Align the tracing image to a selected element**
1 Select an element in the Document window.
2 Select View > Design View Options > Tracing Image > Align with Selection.

The upper-left corner of the tracing image is aligned with the upper-left corner of the selected element.

**Set tracing image properties**
Set properties for a tracing image (which is an image file to use as a guide in designing your page).

1 Do one of the following:
   - Click File > Page Properties
   - Click Window > Properties, and click Page Properties in the text Property inspector.
2 From the Page Properties dialog box, select Tracing Image. You can configure the following options from this panel:
   - **Tracing Image**: Specifies an image to use as a guide for copying a design. This image is for reference only, and does not appear when the document is displayed in a browser.
   - **Transparency**: Determines the opacity of the tracing image, from completely transparent to completely opaque.

**About using CSS to lay out your page**
About CSS page layout
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying its location with respect to its current location). You can also position div tags by specifying floats, paddings, and margins—the preferred method by today's web standards.

About CSS page layout structure
Before proceeding with this section, you should be familiar with basic CSS concepts.

The basic building block of the CSS layout is the div tag—an HTML tag that in most cases acts as a container for text, images, and other page elements. The following example shows an HTML page that contains three separate div tags: one large “container” tag, and two other tags—a sidebar tag, and a main content tag—within the container tag.

Following is the code for all three div tags in the HTML:
In the above example, there is no “styling” attached to any of the div tags. Without CSS rules defined, each div tag and its contents fall into a default location on the page. However, if each div tag has a unique id (as in the above example), you can use the ids to create CSS rules that, when applied, change the style and positioning of the div tags.

The following CSS rule, which can reside in the head of the document or in an external CSS file, creates styling rules for the first, or “container” div tag on the page:

```css
#container {
  width: 780px;
  background: #FFFFFF;
  margin: 0 auto;
  border: 1px solid #000000;
  text-align: left;
}
```

The #container rule styles the container div tag to have a width of 780 pixels, a white background, no margin (from the left side of the page), a solid, black, 1-pixel border, and text that is aligned left. The results of applying the rule to the container div tag are as follows:

A Text aligned left  B White background  C 1-pixel solid black border
The next CSS rule creates styling rules for the sidebar div tag:

```css
#sidebar {
    float: left;
    width: 200px;
    background: #EBEBEB;
    padding: 15px 10px 15px 20px;
}
```

The #sidebar rule styles the sidebar div tag to have a width of 200 pixels, a gray background, a top and bottom padding of 15 pixels, a right padding of 10 pixels, and a left padding of 20 pixels. (The default order for padding is top-right-bottom-left.) Additionally, the rule positions the sidebar div tag with `float: left`—a property that pushes the sidebar div tag to the left side of the container div tag. The results of applying the rule to the sidebar div tag are as follows:

![Sidebar div, float left](image1)

- **A** Width 200 pixels
- **B** Top and bottom padding, 15 pixels

Lastly, the CSS rule for the main container div tag finishes the layout:

```css
#mainContent {
    margin: 0 0 0 250px;
    padding: 0 20px 20px 20px;
}
```

The #mainContent rule styles the main content div with a left margin of 250 pixels, which means that it places 250 pixels of space between the left side of the container div, and the left side of the main content div. Additionally, the rule provides for 20 pixels of spacing on the right, bottom, and left sides of the main content div. The results of applying the rule to the mainContent div are as follows:

The complete code looks as follows:

```css
Main Content div, left margin of 250 pixels
- **A** 20 pixels left padding
- **B** 20 pixels right padding
- **C** 20 pixels bottom padding
```
Note:

The above example code is a simplified version of the code that creates the two-column fixed left sidebar layout when you create a new document using the predesigned layouts that come with Dreamweaver.

Create a page with a CSS layout

When creating a new page in Dreamweaver, you can create one that already contains a CSS layout. Dreamweaver comes with 16 different CSS layouts that you can choose from. Additionally, you can create your own CSS layouts and add them to the configuration folder so that they appear as layout choices in the New Document dialog box.
Create a page with a CSS layout

1. Select File > New.

2. In the New Document dialog box, select the Blank Page category. (It's the default selection.)

3. For Page Type, select the kind of page you want to create.

   **Note:**
   
   You must select an HTML page type for the layout. For example, you can select HTML, ColdFusion®, PHP, and so on. You cannot create an ActionScript™, CSS, Library Item, JavaScript, XML, XSLT, or ColdFusion Component page with a CSS layout. Page types in the Other category of the New Document dialog box are also restricted from including CSS page layouts.

4. For Layout, select the CSS layout you want to use. You can choose from 16 different layouts. The Preview window shows the layout and gives a brief description of the selected layout.

   The predesigned CSS layouts provide the following types of columns:

   **Fixed** Column width is specified in pixels. The column does not resize based on the size of the browser or the site visitor’s text settings.

   **Liquid** Column width is specified as a percentage of the site visitor’s browser width. The design adapts if the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text settings.

5. Select a document type from the DocType pop-up menu.

6. Select a location for the layout’s CSS from the Layout CSS in pop-up menu.

   **Add To Head** Adds CSS for the layout to the head of the page you’re creating.

   **Create New File** Adds CSS for the layout to a new external CSS stylesheet and attaches the new stylesheet to the page you’re creating.

   **Link To Existing File** Lets you specify an existing CSS file that already contains the CSS rules needed for the layout. This option is particularly useful when you want to use the same CSS layout (the CSS rules for which are contained in a single file) across multiple documents.

7. Do one of the following:

   - If you selected Add to Head from the Layout CSS in pop-up menu (the default option), click Create.
   - If you selected Create New File from the Layout CSS pop-up menu, click Create, and then specify a name for the new external file in the Save Style Sheet File As dialog box.
   - If you selected Link to Existing File from the Layout CSS in pop-up menu, add the external file to the Attach CSS file text box by clicking the Add Style Sheet icon, completing the Attach External Style Sheet dialog box, and clicking OK. When you’re finished, click Create in the New Document dialog box.

   **Note:**

   When you select the Link to Existing File option, the file you specify must already have the rules for the CSS file contained within it.

   When you put the layout CSS in a new file or link to an existing file, Dreamweaver automatically links the file to the HTML page you’re creating.

   **Note:**

   Internet Explorer conditional comments (CCs), which help work around IE rendering issues, remain embedded in the head of the new CSS layout document, even if you select New External File or Existing External File as the location for your layout CSS.
8 (Optional) You can also attach CSS style sheets to your new page (unrelated to the CSS layout) when you create the page. To do this, click the Attach Style Sheet icon above the Attach CSS file pane and select a CSS style sheet. For a detailed walk-through of this process, see David Powers's article, Automatically attaching a style sheet to new documents.

Add custom CSS layouts to the list of choices
1 Create an HTML page that contains the CSS layout you'd like to add to the list of choices in the New Document dialog box. The CSS for the layout must reside in the head of the HTML page.

To make your custom CSS layout consistent with the other layouts that come with Dreamweaver, you should save your HTML file with the .htm extension.

2 Add the HTML page to the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts folder.

3 (Optional) Add a preview image of your layout (for example a .gif or .png file) to the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts folder. The default images that come with Dreamweaver are 227 pixels wide x 193 pixels high PNG files.

Give your preview image the same file name as your HTML file so that you can easily keep track of it. For example, if your HTML file is called myCustomLayout.htm, call your preview image myCustomLayout.png.

4 (Optional) Create a notes file for your custom layout by opening the Adobe Dreamweaver CS5\Configuration\BuiltIn\Layouts\_notes folder, copying and pasting any of the existing notes files in the same folder, and renaming the copy for your custom layout. For example, you could copy the oneColElsCtr.htm.mno file, and rename it myCustomLayout.htm.mno.

5 (Optional) After you've created a notes file for your custom layout, you can open the file and specify the layout name, description, and preview image.

Design responsive websites using Bootstrap

Bootstrap is a popular, free, HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites. The framework includes responsive CSS and HTML templates for buttons, tables, navigation, image carousels, and other elements that you can use on your web page. A few optional JavaScript plug-ins are available, which enable developers with even basic coding knowledge to develop great responsive websites.

Dreamweaver lets you create Bootstrap documents and also edit existing web pages created with Bootstrap. Whether they are fully designed Bootstrap files or works-in-progress, you can edit them in Dreamweaver to not only edit code, but also use visual editing features such as Live View editing, visual CSS designer, Visual Media Queries, and Extract to make design changes.

Note:

Bootstrap versions that are currently supported include v4.3.1 and v3.4.1.

Common questions
I've been using fluid grids in Dreamweaver. How do I get started with Bootstrap?

When you created fluid grid documents, Dreamweaver made your web pages responsive by applying appropriate classes automatically. All you had to do was to focus on your content and decide how they reflow in the different form factors.

Similarly, in Bootstrap documents, you only have to focus on content and design and the responsiveness of your web page is taken care of by Dreamweaver, which is tightly integrated with the Bootstrap framework.

Dreamweaver currently supports Bootstrap 3.4.1 and 4.3.1 versions:

"Bootstrap 3.4.1 includes a responsive, mobile first fluid grid system that appropriately scales up to 12 columns as the device or viewport size increases. It includes predefined classes for easy layout options, as well as powerful mixins for generating more semantic layouts." - Bootstrap documentation.

"Bootstrap 4.3.1, with major changes, includes powerful mobile-first flexbox grid to build layouts of all shapes and scales thanks to a twelve column system, five default responsive tiers, Sass variables and mixins, and dozens of predefined classes." - Bootstrap documentation.

To get started with Bootstrap documents in Dreamweaver, consider using Bootstrap starter templates. Dreamweaver includes a bunch of templates aimed at different types of websites you may want to create, for example, ecommerce or portfolio.

If you want to create a Bootstrap document from scratch, you could always do so as described in the Creating HTML documents based on Bootstrap framework section.

Can I migrate existing fluid grid documents to Bootstrap documents in Dreamweaver?

No, there isn't a direct method of converting your existing fluid grid documents to Bootstrap documents. However, the user experience in Dreamweaver while creating and designing Bootstrap documents is similar to that of fluid grid documents. For example, you can get started by creating a Bootstrap document right from the New Document dialog box. While you create fluid grid documents for three basic form factors – Mobile, Tablet, and Desktop, for Bootstrap, you start by creating a document for basic screen sizes – small, medium, large, and extra large. The layout editing options that are displayed when you click elements in Bootstrap documents also look similar to that of fluid grid documents.

Can I import old sites in the latest version of Dreamweaver?

Yes, you can import old sites in the latest version of Dreamweaver. When you do so, Dreamweaver looks for the Bootstrap CSS file in the site root/css/ folder.

- if the site has a Bootstrap v3 CSS file, the Bootstrap Version in Manage Site > Advanced Settings > Bootstrap is set to 3.4.1.
- if the site has a Bootstrap v4 CSS file, the Bootstrap Version in Manage Site > Advanced Settings > Bootstrap is set to 4.3.1.
- if the site has no Bootstrap CSS file in the site root/css path, the Bootstrap Version in Manage Site > Advanced Settings > Bootstrap is set to 4.3.1.

Create Bootstrap documents

You can begin designing your Bootstrap website using one of the following options in the New Document dialog box:

- Bootstrap starter templates (Starter Templates > Bootstrap Templates) - Use this option if you want to get started quickly without the hassle of laying out your pages from scratch. Simply edit the text and replace the assets, if necessary, and your responsive website is ready. See Using Bootstrap starter templates for more information.
Create an HTML document based on Bootstrap framework (New Document > HTML > Bootstrap) - Use this option if you want to build your website brick-by-brick using CSS and Bootstrap components within Dreamweaver. For more information, see Creating HTML documents based on Bootstrap framework.

Using Bootstrap starter templates
Bootstrap starter templates let you create web pages for popular themes in a jiffy. All the dependent files in the framework are saved automatically.

1. Click File > New.
2. In the New Document dialog box that appears, click Starter Templates, and then select the required template from the list of Bootstrap Templates.
3. Click Create.

An HTML page that is based on the template you chose is created. You can now modify the page by adding or deleting components, editing text, or assets, as required.

Creating HTML documents based on Bootstrap framework
You can start building your responsive website by creating an HTML document based on Bootstrap framework. You can choose to create a set of Bootstrap framework files or use the existing files. Once the document is created, you can add Bootstrap components such as accordions and carousels using the Insert panel in Dreamweaver. Or, if you have Photoshop comps, you can use Extract to bring in images, fonts, styles, text, and more into your Bootstrap document.

1. Click File > New.
2. In the New Document dialog box, click New Document > HTML, and then click the Bootstrap tab.
3. To create a new bootstrap.css file (and the other bootstrap files), perform the following actions:
   Specify whether you want to create a new Bootstrap CSS or use an existing CSS.
   If you choose to create a new CSS, a "css" folder is created in the site root, and the bootstrap.css file is copied into the new folder. If you choose to use an existing CSS, specify the path or browse to the location of the CSS.
   a. Click Create New.
Create a new Bootstrap document

b (Optional) if you want to attach any other CSS to your document, click Attach CSS in the Attach CSS section. The Attach External Style Sheet dialog box appears. Specify the settings and click OK.

c Include A Pre-built Layout option provides a basic Bootstrap document structure.

If you do not want the basic structure and want to start off with a blank document, deselect the Include A Pre-built Layout option.

d (Optional) The default layout contains 12 columns with 30 px gutter. The default screen sizes are 576px, 768px, 992px, and 1200px.

If you want to modify these settings, click Customize. The bootstrap.css file is modified accordingly.

Note:

For Bootstrap v3.4.0, the default screen sizes are 768 px, 992 px, and 1200 px.

e Select Use Extract to Build Your Page from Photoshop Comps if you want the Extract panel to be opened (in case it is closed). By doing so, you can start extracting assets from Photoshop comps right away.

By default, a new site is created using Bootstrap version 4.3.1. After you create the document, you find the css, and js folders in the site root folder. However, if you want to create the site using Bootstrap version 3.4.1, select Site > Manage Sites. Select the site root folder. Click Advance Settings > Bootstrap. In the Bootstrap Version drop-down field, select 3.4.1. For Bootstrap version 3.4.1, you can see the css, js, and fonts folder in the site root folder.
Select the Bootstrap version 4.3.1

When you create a Bootstrap 4.3.1 page, the jQuery version 3.3.1 is supported. The Bootstrap Starter templates are updated to Bootstrap version 4.3.1.

When you add Bootstrap components to a Bootstrap page, you can upgrade the Bootstrap 4.0.0 pages to Bootstrap 4.3.1 and jQuery version to 3.3.1. Click Yes on the dialog that appears when you insert Bootstrap components to page.

Version compatibility confirmation dialog
When you import a Bootstrap 4.0.0 site or when you migrate a site from previous versions to the next version of Dreamweaver release, the Bootstrap version is set to 4.3.1 in Site Setup > Advanced setting > Bootstrap.

**Note:**

With Bootstrap 4.3.1, the height of a Grid row column is changed from 1 px to 0 px. So, to make it visible in Live view you need to add some content in the Grid row column.

4 To use existing Bootstrap framework files, perform the following actions:

- Click **Use Existing**, and specify the path of the bootstrap.css file. You can also browse to the location where the CSS is saved.
Creating Bootstrap documents using existing framework files

b  (Optional) if you want to attach any other CSS to your document, click in the Attach CSS section. In the Attach External Style Sheet dialog box, specify the settings and click OK.

c  Include A Pre-built Layout option provides a basic Bootstrap document structure. If you do not want the basic structure and want to start off with a blank document, deselect the Include A Pre-built Layout option.

5  Click Create.

Note:
The bootstrap.css file that is created is read-only. So, you cannot edit these styles using the CSS Designer; the Properties pane in CSS Designer is disabled in Bootstrap files.

If you want to modify the styling of your Bootstrap document, create another CSS file to override the existing styles, and then attach it to the document.

Open Bootstrap files

Note:
It is recommended that you open and edit documents that are created only in Bootstrap version 3 and later in Dreamweaver.

You can open Bootstrap files using one of the following ways:

•  Click File > Open and browse to the Bootstrap HTML file.

•  (Recommended) Create a Dreamweaver site and point the site folder to the folder that contains all your Bootstrap files.
When you open a Bootstrap HTML file in Dreamweaver:

- The rows are highlighted in gray dashed lines with rounded corners
- The columns are highlighted in blue dashed lines

Dreamweaver recognizes the CSS files associated with any Bootstrap HTML file if the CSS filename contains 'bootstrap'. The CSS file reference can be any or all of the following:

- **Local path:**
  The minified or unminified CSS file is present locally. For example:
  
  `<link href="css/bootstrap.css" rel="stylesheet">` or `<link href="css/bootstrap.min.css" rel="stylesheet">`

- **Remote path:**
  A remote minified or unminified CSS file. For example:
  
  `<link href="http://somewebsite.com/css/bootstrap.css" rel="stylesheet"> ` `link href="http://somewebsite.com/css/bootstrap.min.css" rel="stylesheet">`

- **CDN**
  `<link href="http://maxcdn.bootstrapcdn.com/bootstrap/<bootstrap_version_number>/css/bootstrap.min.css" rel="stylesheet">`

*Note:*

Bootstrap style sheets in both link and import tags are supported in Dreamweaver. However, nested import - link to a style sheet that in turn imports another style sheet - is not supported.

**Hide, unhide, and manage hidden Bootstrap elements**

Sometimes, you may require an element to be displayed in one viewport while in another viewport, you may want to hide the element for design purposes.

To hide a Bootstrap element, right-click and select Hide Element. The element is temporarily hidden from the view.
To view and unhide hidden elements, right-click and select Manage Hidden Elements. The hidden elements appear with a gray, hashed background. Click the eye icon to unhide the element.

Add Bootstrap components

The Bootstrap Components option in the Insert panel lists all the Bootstrap components that you can add to your web page in Dreamweaver. According to the Bootstrap version in the bootstrap.css file linked to the HTML page, the respective components are listed in the Insert panel. For example, in Bootstrap v4.0.0, you see additional components such as Cards, Badges. Similarly, Glyphicons, Panel, Wells, and Thumbnails components are available only in Bootstrap v3.3.7. Depending on the Bootstrap version, you see the respective components in the Insert panel.

The components in the Insert panel are populated based on the following criteria:

- The document in focus: The components in the Insert panel are populated based on the Bootstrap version in the Bootstrap file that is linked to the document.
- Version in Site Preferences: For a non-bootstrap document, Dreamweaver looks for the version in Site Preferences > Advanced > Bootstrap. Depending on the version in this option, the appropriate components are populated. By default, for new sites, the version is 4.3.1.
- Where the files are saved: For a non-bootstrap document that is not a part of any site, the Insert panel reflects the 4.3.1 components.
Components supported in Bootstrap 4.0.0

To add a component, drag it from the panel onto the web page. Before you drop the component, take note of the visual aids such as Live Guides, Precision Insert (using DOM), and Position Assist. Use these aids to place the components quickly, and accurately on your page. For more information on inserting elements in your web page, see Insert panel overview.
Add rows
Click the required row after which you want to add the new row. Then, click the Add new row icon. A Bootstrap row along with two child column elements with six columns each is added.

The code for the added row is as follows:

```html
<div class="row">
  <div class="col-*-6"></div>
  <div class="col-*-6"></div>
</div>
```

where * represents the current screen size in Dreamweaver.

Add columns
Select the required column and then click the Add new column icon. The selected column is duplicated without its children.

All empty columns are assigned a minimum height of 20px. However, this height is not actually added to the page; it is shown only in Live view for easier insertion of elements within the columns.

Duplicate rows and columns
Click the row or column that you want to duplicate and then click the duplicate icon at the lower right corner. The entire row or column is duplicated along with its contents.

Note:
The Add Row or Add Column option duplicates the row or column with classes, but without the content.

Resize and offset columns
Resizing and offsetting columns become imperative especially when you are creating responsive designs for various viewports.

Resize columns
Click the required column and drag the handle on the right to resize. For a Bootstrap v4.0.0 document, when you resize a column, the col-*-n class is added, where * represents the current media query (sm, md, ld, xl) and n represents the number of columns that it occupies. For the Extra small screen size, the class col-n is added.

For a Bootstrap v3.3.7 document, when you resize a column, the col-*-n class is added, where * represents the current media query (xs, sm, md, or lg) and n represents the number of columns that it occupies.

Dreamweaver detects the current screen size and adds the appropriate class. To resize columns to suit specific viewports, change the viewport size using the options in the lower-right corner or the scrubber. Then resize the columns as appropriate.

Offset columns
Click the required column and drag the handle on the left to offset the column. The offset is shown as a hashed area. For a Bootstrap v4.0.0 document, when you offset the column, the offset-*-n class is added, where * represents the current media query (sm, md, lg or xl) and n represents the number of columns that it occupies.

For a Bootstrap v3.3.7 document, when you offset the column, the col-*-offset-n class is added, where * represents the current media query (xs, sm, md, or lg) and n represents the number of columns by which it shifts.
Dreamweaver detects the current screen size and adds the right class. To offset columns to suit specific viewports, change the viewport size using the options in the lower-right corner or the scrubber. Then, offset the columns as appropriate.

Creating and using media queries in Dreamweaver

Media Queries is a CSS3 module that helps you design responsive websites by defining different style rules for different devices or media types. Based on these rules, content is rendered to adapt to various conditions, such as, screen sizes, browser window sizes, device sizes and orientation, and resolution.

You can add media queries using the @media rule to your CSS. Or, you can create separate style sheets for different media types and then call them using the following syntax:

```html
<link rel='stylesheet' media='all' href='normal.css' />
<link rel='stylesheet' media='print' href='print.css' />
<link rel='stylesheet' media='screen and (min-width: 701px)' href='medium.css' />
```

The browser on a device checks the media query and uses the corresponding CSS file to display the web page.

For more information, see this article.

You can add the media queries by adding the relevant code to your HTML or CSS files. In addition, Dreamweaver lets you create and manage media queries easily using:

- Visual Media Query bar
- CSS Designer

The basic difference between these two methods is the visual aspect. If you prefer to code and then view the changes in Live view, use the CSS Designer. If you prefer to visualize your page at different breakpoints and simultaneously make design changes, Visual Media Query is a better bet.

Visual Media Query bars

Visual Media Query bars are a visual representation of the media queries present in a page. These bars help you visualize your web page at different breakpoints and how different components of your web page reflow in different viewports. While you view your page in different viewports, you can make design changes that are specific to a viewport without affecting the page design in other viewports.

Visual Media Query consists of three bars as horizontal rows, each representing a category of media query:

- **Green**: Media queries with max-width conditions
- **Blue**: Media queries with both min-width and max-width conditions
- **Purple**: Media queries with min-width conditions

Note:

*The media queries listed in the CSS designer panel are also prefixed with these colors.*

Each category can consist of one or more media queries. If a media query condition is not defined in the document, then the corresponding visual media query bar, too, will not be displayed. For example, if the document does not contain min-width conditions, then the purple bar is not displayed.

The breakpoint values are indicated on the bars - min-width at the left and max-width at the right of the bar.
Hide or show Visual Media Queries

The Visual Media Query bar is visible in Live View by default. To hide the bar, use the Toggle Visual Media Queries bar in the toolbar.

Switch between breakpoints

To view your page in a specific size (breakpoint), click the corresponding media query bar. The document will snap to the breakpoint.

Alternatively, you can drag the scrubber to the required breakpoint.

To resize the view to the size of the Dreamweaver document window, do one of the following actions:

- Double-click anywhere in the grey area at the right of the document where you see the text ‘Double Click To Fit Width’. If you don’t see the grey area, drag the scrubber to the left.
- Select the Full Width option in the drop-down list at the bottom of the document window.
If you do not see this option, drag the scrubber to decrease the size of the web page.

**Edit media queries visually**

1. Click the Visual Media Query bar that corresponds to the media query that you want to edit.

   Resize handles appear. For media queries that have both *min* and *max-width* values, resize handles appear on both the sides of the bar.
2 Drag the handles to the required size.

The media queries are automatically updated with the new min-width and/or max-width values. A notification is displayed to indicate that the media query was successfully edited. If there are multiple media queries that correspond to the visual media query bar, all the media queries are updated. The number of media queries that were updated is displayed along with the success message.

💡

To undo, press Ctrl+Z (Win) or Cmd+Z (Mac).

Alternatively, you can double-click the breakpoint values to type in the values using your keyboard.

**Add new media queries**

1 Drag the scrubber along the ruler to the required size.

2 Click 🔄.
In the pop-up that appears, the max-width option is selected by default. To specify min-width or min-max, select the appropriate option in the drop-down list and select the required units. Then, select a CSS source in which the media query must be added.

If you choose to create a new CSS file, another pop-up appears. Specify the name and the path of the new CSS file and click OK.

To undo, press Ctrl+Z (Win) or Cmd+Z (Mac).

**Delete media queries**

1. Right-click the corresponding Visual Media Query bar.
2. Click Delete and then click the media query that you want to delete.
3. Click OK to confirm that you want to delete all the media queries and the associated selectors.

To undo, press Ctrl+Z (Win) or Cmd+Z (Mac).

**View the code for media queries**

1. Right-click the required Visual Media Query bar and hover your mouse on Go To Code.
   - A list of all media queries in that particular breakpoint range along with the files in which they are declared appears.
2. Click the required media query to navigate to the corresponding code in Code View.
   - If the Code View is not visible, the document is switched to Split view to display the code.

**Present content with tables**

Tables are a powerful tool for presenting tabular data on an HTML page. A table consists of one or more rows; each row consists of one or more cells. Although columns aren't usually explicitly specified in HTML code, Dreamweaver enables you to manipulate columns as well as rows and cells.

*Note:*

*It is recommended that you do not use tables for laying out your web page. Try the starter templates (File > New > Starter Templates) to get started with predesigned layouts. You can insert your own text and images in these layouts, and style them using CSS.*

**Table formatting precedence in HTML**

When formatting tables in Design view, you can set properties for the entire table or for selected rows, columns, or cells in the table. When a property, such as background color or alignment, is set to one value for the whole table and another value for individual cells, cell formatting takes precedence over row formatting, which in turn takes precedence over table formatting.
The order of precedence for table formatting is as follows:

1. Cells
2. Rows
3. Table

For example, if you set the background color for a single cell to blue, then set the background color of the entire table to yellow, the blue cell does not change to yellow, since cell formatting takes precedence over table formatting.

*Note:*

When you set properties on a column, Dreamweaver changes the attributes of the td tag corresponding to each cell in the column.

**About splitting and merging table cells**

You can merge any number of adjacent cells—as long as the entire selection is a line or a rectangle of cells—to produce a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of whether it was previously merged. Dreamweaver automatically restructures the table (adding any necessary colspan or rowspan attributes) to create the specified arrangement.

In the following example, the cells in the middle of the first two rows have been merged into a single cell that spans two rows.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Merged cells*

**Insert a table and add content**

Use the Insert panel or the Insert menu to create a new table. Then, add text and images to table cells the same way that you add text and images outside of a table.

1. Place the insertion point where you want the table to appear.

   *Note:*

   *If your document is blank, you can place the insertion point only at the beginning of the document.*

   - Select Insert > Table.
   - In the HTML category of the Insert panel, click Table.

2. Set the attributes of the Table dialog box and click OK to create the table.
Creating a table

**Rows**  Determines the number of table rows.

**Columns**  Determines the number of table columns.

**Table Width**  Specifies the width of the table in pixels, or as a percentage of the browser window's width.

**Border Thickness**  Specifies the width, in pixels, of the table's borders.

**Cell Spacing**  Determines the number of pixels between adjacent table cells.

---

**Layout and design**
When you don't explicitly assign values for border thickness or cell spacing and cell padding, most browsers display the table border thickness and cell padding set to 1 and cell spacing were set to 2. To ensure that browsers display the table with no border, padding or spacing, set Cell Padding and Cell Spacing to 0.

**Cell Padding** Determines the number of pixels between a cell's border and its contents.

- **None** Does not enable column or row headings for the table.
- **Left** Makes the first column of the table a column for headings, so that you can enter a heading for each row of the table.
- **Top** Makes the first row of the table a row for headings, so that you can enter a heading for each column of the table.
- **Both** Enables you to enter column and row headings in the table.

*It's a good idea to use headers in case any of your website visitors use screen readers. Screen readers read table headings and help screen-reader users keep track of table information.*

**Caption** Provides a table title which displays outside of the table.

**Summary** Provides a table description. Screen readers read the summary text, but the text does not appear in the user's browser.

### Import and export tables

You can import tabular data that has been created in another application (such as Microsoft Excel) and saved in a delimited text format (with items separated by tabs, commas, colons, or semicolons) into Dreamweaver and format it as a table.

You can also export table data from Dreamweaver into a text file, with the contents of adjacent cells separated by a delimiter. You can use commas, colons, semicolons, or spaces as delimiters. When you export a table, the entire table is exported; you cannot select portions of a table to export.

*If you want only some of the data from a table—for example, the first six rows or the first six columns—then copy the cells containing that data, paste those cells outside of the table (to create a new table), and export the new table.*

### Import table data

1. Select File > Import > Import Tabular Data.
2. Specify the options for the tabular data and click OK.
   - **Data File** The name of the file to import. Click the Browse button to select a file.
   - **Delimiter** The delimiter used in the file you’re importing.

   If you select Other, a text box appears to the right of the pop-up menu. Enter the delimiter used in your file.

   **Note:**

   *Specify the delimiter that was used when the data file was saved. If you don't do this, the file will not be imported properly, and your data will not be correctly formatted in a table.*

   - **Table Width** The width of the table.
     - Select Fit to Data to make each column wide enough to fit the longest text string in the column.
• Select Set to specify a fixed table width in pixels or as a percentage of the browser window's width.

**Border** Specifies the width, in pixels, of the table's borders.

**Cell Padding** The number of pixels between a cell's content and the cell boundaries.

**Cell Spacing** The number of pixels between adjacent table cells.

If you don't explicitly assign values for borders, cell spacing, and cell padding, most browsers display the table with borders and cell padding set to 1, and cell spacing set to 2. To ensure that browsers display the table with no padding or spacing, set Cell Padding and Cell Spacing to 0. To view cell and table boundaries when the border is set to 0, select View > Visual Aids > Table Borders.

**Format Top Row** Determines what formatting, if any, is applied to the top row of the table. Select from four formatting options: no formatting, bold, italic, or bold italic.

### Export a table

1. Place the insertion point in any cell of the table.
2. Select File > Export > Table.
3. Specify the following options:
   - **Delimiter** Specifies which delimiter character should be used to separate items in the exported file.
   - **Line Breaks** Specifies which operating system you'll be opening the exported file in: Windows, Macintosh, or UNIX. (Different operating systems have different ways of indicating the end of a line of text.)
4. Click Export.
5. Enter a name for the file and click Save.

### Select table elements

You can select an entire table, row, or column at once. You can also select one or more individual cells.

When you move your pointer over a table, row, column, or cell, Dreamweaver highlights all the cells in that selection so that you know which cells will be selected. This is useful when you have tables without borders, cells that span multiple columns or rows, or nested tables. You can change the highlight color in preferences.

If you position the pointer over a table's border, then hold the Control key (Windows) or Command key (Macintosh), the entire structure of the table—that is, all cells in the table—is highlighted. This is useful when you have nested tables and want to see the structure of one of the tables.

### Select an entire table

Do one of the following to select a table:

- Click the upper-left corner of the table to select the table.
- Click in a table cell, then select the tag in the tag selector at the lower-left corner of the Document window.
- Click in a table cell, click the table header menu, then select Select Table. Selection handles appear on the selected table's lower and right edges.
Select individual or multiple rows or columns
1 Position the pointer to point to the left edge of a row or the top edge of a column.
2 When the pointer changes to a selection arrow, click to select a row or column, or drag to select multiple rows or columns.

Select a single column
1 Click in the column.
2 Click the column header menu and choose Select Column.

Select a single cell
? Do one of the following:
  - Click in the cell, then select the &lt;td&gt; tag in the tag selector at the lower-left corner of the Document window.
  - Control-click (Windows) or Command-click (Macintosh) in the cell.

Select a line or a rectangular block of cells
Do one of the following:
  - Drag from a cell to another cell.
  - Click in one cell, Control-click (Windows) or Command-click (Macintosh) in the same cell to select it, then Shift-click another cell.

Select nonadjacent cells
Control-click (Windows) or Command-click (Macintosh) the cells, rows, or columns you want to select.

If each cell, row, or column you Control-click or Command-click isn't already selected, it's added to the selection. If it is already selected, it's removed from the selection.

Change the highlight color for table elements
1 Select Edit &gt; Preferences (Windows) or Dreamweaver &gt; Preferences (Macintosh).
2 Select Highlighting from the category list on the left, make either of the following changes, and click OK.

- To change the highlighting color for table elements, click the Mouse-Over color box, then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the text box).
- To enable or disable highlighting for table elements, select or deselect the Show option for Mouse-Over.

Note:
These options affect all objects that Dreamweaver highlights when you move the pointer over them.

Set table properties
You can use the Property inspector to edit tables.

1 Select a table.
2 In the Property inspector (Window > Properties), change properties as necessary.

Table properties

Table Id  An ID for the table.

Rows and Cols  The number of rows and columns in the table.

W  The width of the table in pixels, or as a percentage of the browser window's width.

Note:
You usually don't need to set the height of a table.

CellPad  The number of pixels between a cell's content and the cell boundaries.

CellSpace  The number of pixels between adjacent table cells.

Align  Determines where the table appears, relative to other elements in the same paragraph, such as text or images.
Left aligns the table to the left of other elements (so that text in the same paragraph wraps around the table to the right); Right aligns the table to the right of other elements (with text wrapping around it to the left); and Center centers the table (with text appearing above and/or below the table). Default indicates that the browser should use its default alignment.

When alignment is set to Default, other content is not displayed next to the table. To display a table next to other content, use Left or Right alignment.

Border  Specifies the width, in pixels, of the table's borders.
If you don't explicitly assign values for the border, cell spacing, and cell padding, most browsers display the table with the border and cell padding set to 1 and cell spacing set to 2. To ensure that browsers display the table with no padding or spacing, set Border to 0, Cell Padding and Cell Spacing to 0. To view cell and table boundaries when the border is set to 0, select View > Visual Aids > Table Borders.

**Class** sets a CSS class on the table.

**Note:**

You might need to expand the Table Property inspector to see the following options. To expand the Table Property inspector, click the expander arrow in the lower-right corner.

**Clear Column Widths and Clear Row Heights** and Clear Row Heights delete all explicitly specified row height or column width values from the table.

**Convert Table Widths To Pixels** and Convert Table Heights To Pixels set the width or height of each column in the table to its current width in pixels (also sets the width of the whole table to its current width in pixels).

**Convert Table Widths To Percent** and Convert Table Heights To Percent set the width or height of each column in the table to its current width expressed as a percentage of the Document window's width (also sets the width of the whole table to its current width as a percentage of the Document window's width).

If you entered a value in a text box, press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

### Set cell, row, or column properties

You can use the Property inspector to edit cells and rows in a table.

1. Select the column or row.
2. In the Property inspector (Window > Properties), set the following options:
   - **Horz** Specifies the horizontal alignment of the contents of a cell, row, or column. You can align the contents to the left, right, or center of the cells, or you can indicate that the browser should use its default alignment (usually left for regular cells and center for header cells).
   - **Vert** Specifies the vertical alignment of the contents of a cell, row, or column. You can align the contents to the top, middle, bottom, or baseline of the cells, or indicate that the browser should use its default alignment (usually middle).
   - **W and H** The width and height of selected cells in pixels, or as a percentage of the entire table's width or height. To specify a percentage, follow the value with a percent symbol (%). To let the browser determine the proper width or height based on the contents of the cell and the widths and heights of the other columns and rows, leave the field blank (the default).

   By default, a browser chooses a row height and column width to accommodate and the widest image or the longest line in a column. This is why a column sometimes becomes much wider than the other columns in the table when you add content to it.

   **Note:**

   *You can specify a height as a percentage of the total table height, but the row may not display at the specified percentage height in browsers.*

   - **Bg** The background color for a cell, column, or row, chosen with the color picker.

   - **Merge Cells** Combines selected cells, rows, or columns into one cell. You can merge cells only if they form a rectangular or linear block.
Split Cell  Divides a cell, creating two or more cells. You can split only one cell at a time; this button is disabled if more than one cell is selected.

No Wrap  Prevents line wrapping, keeping all the text in a given cell on a single line. If No Wrap is enabled, cells widen to accommodate all data as you type it or paste it into a cell. (Normally, cells expand horizontally to accommodate the longest word or widest image in the cell, then expand vertically as necessary to accommodate other contents.)

Header  Formats the selected cells as table header cells. The contents of table header cells are bold and centered by default.

You can specify widths and heights as either pixels or percentages, and you can convert from pixels to percentages and back.

Note: When you set properties on a column, Dreamweaver changes the attributes of the td tag corresponding to each cell in the column. When you set certain properties for a row, however, Dreamweaver changes the attributes of the tr tag rather than changing the attributes of each td tag in the row. When you’re applying the same format to all the cells in a row, applying the format to the tr tag produces cleaner, more concise HTML code.

3 Press Tab or Enter (Windows) or Return (Macintosh) to apply the value.

Format tables and cells

You can change the appearance of tables by setting properties for the table and its cells or by applying a preset design to the table. Before you set table and cell properties, be aware that the order of precedence for formatting is cells, rows, and tables.

To format the text inside a table cell, use the same procedures you would use to format text outside of a table.

Change the format of a table, row, cell, or column

1 Select a table, cell, row, or column.

2 In the Property inspector (Window > Properties), click the expander arrow in the lower-right corner and change properties as necessary.

3 Change the properties as necessary.

For more information on the options, click the Help icon on the Property inspector.

Note: When you set properties on a column, Dreamweaver changes the attributes of the td tag corresponding to each cell in the column. When you set certain properties for a row, however, Dreamweaver changes the attributes of the tr tag rather than changing the attributes of each td tag in the row. When you’re applying the same format to all the cells in a row, applying the format to the tr tag produces cleaner, more concise HTML code.

Add or edit accessibility values for a table in Code view

Edit the appropriate attributes in the code.
Note:
To quickly locate the tags in the code, click in the table, then select the &lt;table&gt; tag in the tag selector at the bottom of the Document window.

Add or edit accessibility values for a table in Design view
- To edit the table caption, highlight the caption and type a new caption.
  - To edit the caption alignment, place the insertion point in the table caption, right-click (Windows) or Control-click (Macintosh), then select Edit Tag Code.
  - To edit the table summary, select the table, right-click (Windows) or Control-click (Macintosh), then select Edit Tag Code.

Resize tables, columns, and rows
Resizing tables
You can resize an entire table or individual rows and columns. When you resize an entire table, all of the cells in the table change size proportionately. If a table’s cells have explicit widths or heights specified, resizing the table changes the visual size of the cells in the Document window but does not change the specified widths and heights of the cells.

You can resize a table by dragging one of its selection handles. Dreamweaver displays the table width, along with a table header menu, at the top or bottom of the table when the table is selected or the insertion point is in the table.

Sometimes the column widths set in the HTML code do not match their apparent widths on the screen. When this happens, you can make the widths consistent. Table and column widths and header menus appear in Dreamweaver to help you lay out your tables; you can enable or disable the widths and menus as necessary.

Resizing columns and rows
You can change the width of a column or the height of a row in the Property inspector or by dragging the borders of the column or row. If you have trouble resizing, you can clear the column widths or row heights and start over.

Note:
You can also change cell widths and heights directly in the HTML code using Code view.

Dreamweaver displays column widths, along with column header menus, at the tops or bottoms of columns when the table is selected or the insertion point is in the table; you can enable or disable the column header menus as necessary.

Resize a table
Select the table. If you are in Live view, Element Display is shown when you select the table. Click the sandwich icon to enter the table formatting mode.
- To resize the table horizontally, drag the selection handle on the right.
- To resize the table vertically, drag the selection handle on the bottom.
- To resize the table in both dimensions, drag the selection handle at the lower-right corner.

To exit the table formatting mode in Live view, press Esc or click outside the table. You can use Edit > Table menu options to modify the table further.

Note: The options in Edit > Table menu vary based on whether you have selected the entire table or a single cell. In Live view, Element Display shows ‘table’ when the entire table is selected and ‘td’ when a specific cell is selected. To switch from a cell formatting to table formatting mode, click the table border.
Change a column's width and keep the overall table width

? In Design view, drag the right border of the column you want to change.

The width of the adjacent column also changes, so you actually resize two columns. Visual feedback shows you how the columns will adjust; the overall table width does not change.

![Diagram](image1)

*Change column width while maintaining table width*

**Note:**

*In tables with percentage-based widths (not pixels), if you drag the right border of the rightmost column, the entire table's width changes, and all of the columns grow wider or narrow proportionately.*

Change a column's width and maintain the size of the other columns

? In Design view, hold the Shift key and drag the column's border.

The width of one column changes. Visual feedback shows you how the columns will adjust; the overall table width changes to accommodate the column you are resizing.

![Diagram](image2)

*Change column width while other columns maintain their width*

Change a row's height visually

Drag the lower border of the row.

Make column widths in code consistent with visual widths

1 Click in a cell.
2 Click the table header menu, then select Make All Widths Consistent.

Dreamweaver resets the width specified in the code to match the visual width.

Clear all set widths or heights in a table

1 Select the table.
2 Do one of the following:
   • Select Edit > Table > Clear Cell Widths, or Edit > Table > Clear Cell Heights.
   • In the Property inspector, (Window > Properties), click the Clear Row Heights button or the Clear Column Widths button.
   • Click the table header menu, then select Clear All Heights or Clear All Widths.
Clear a column’s set width
Click in the column, click the column header menu, and select Clear Column Width.

Enable or disable table and column widths and menus in Design View
Select View > Design View Options > Visual Aids > Table Widths.

Add and remove rows and columns
To add and remove rows and columns, use the Modify > Table or column header menu.

Pressing Tab in the last cell of a table automatically adds another row to the table.

Add a single row or column
Click in a cell and do one of the following:
- Select Edit > Table > Insert Row or Edit > Table > Insert Column.
  A row appears above the insertion point or a column appears to the left of the insertion point.
- Click the column header menu, and then select Insert Column Left or Insert Column Right.

Add multiple rows or columns
1. Click in a cell.
2. Select Edit > Table > Insert Rows Or Columns, complete the dialog box, and click OK.
   - **Insert** Indicates whether to insert rows or columns.
   - **Number of Rows or Number of Columns** The number of rows or columns to insert.
   - **Where** Specifies whether the new rows or columns should appear before or after the row or column of the selected cell.

Delete a row or column
Do one of the following:
- Click in a cell within the row or column you want to delete, then select Edit > Table > Delete Row, or Edit > Table > Delete Column.
- Select a complete row or column, then press Delete.
- In the Property inspector (Windows > Properties), do one of the following:
  - To add or delete rows, increase or decrease the Rows value.
  - To add or delete columns, increase or decrease the Cols value.

Note:
Dreamweaver does not warn you if you are deleting rows and columns that contain data.

Split and merge cells
Use the Property inspector or the options in the Edit > Table submenu to split or merge cells.
Merge two or more cells in a table
1 Select the cells in a contiguous line and in the shape of a rectangle.

In the following illustration, the selection is a rectangle of cells, so the cells can be merged.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

Cells can be merged in a rectangle of cells

In the following illustration, the selection is not a rectangle, so the cells can't be merged.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

Cells cannot be merged if the selection is not a rectangle

2 Do one of the following:
   • Select Edit > Table > Merge Cells.
   • In the expanded HTML Property inspector (Window > Properties), click Merge Cells.

Note:
If you don't see the button, click the expander arrow in the lower-right corner of the Property inspector so that you see all the options.

The contents of the individual cells are placed in the resulting merged cell. The properties of the first cell selected are applied to the merged cell.

Split a cell
1 Click in the cell and do one of the following:
   • Select Edit > Table > Split Cell.
   • In the expanded HTML Property inspector (Window > Properties), click Split Cell.

Note:
If you don't see the button, click the expander arrow in the lower-right corner of the Property inspector so that you see all the options.

2 In the Split Cell dialog box, specify how to split the cell:
   **Split Cell Into** Specifies whether to split the cell into rows or columns.
   **Number Of Rows/Number Of Columns** Specifies how many rows or columns to split the cell into.
Increase or decrease the number of rows or columns spanned by a cell

Do one of the following:

- Select Edit > Table > Increase Row Span, or Edit > Table > Increase Column Span.
- Select Edit > Table > Decrease Row Span, or Edit > Table > Decrease Column Span.

Copy, paste, and delete cells

You can copy, paste, or delete a single table cell or multiple cells at once, preserving the cells’ formatting.

You can paste cells at the insertion point or in place of a selection in an existing table. To paste multiple table cells, the contents of the Clipboard must be compatible with the structure of the table or the selection in the table in which the cells will be pasted.

Cut or copy table cells

1. Select one or more cells in a contiguous line and in the shape of a rectangle.

   In the following illustration, the selection is a rectangle of cells, so the cells can be cut or copied.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

   Cells can be cut or copied in a rectangle of cells

In the following illustration, the selection is not a rectangle, so the cells can’t be cut or copied.

<table>
<thead>
<tr>
<th>Location Name</th>
<th>City</th>
<th>State or Country</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baltimore-Washington International</td>
<td>Baltimore</td>
<td>MD</td>
</tr>
<tr>
<td>Cairo International</td>
<td>Cairo</td>
<td>Egypt</td>
</tr>
<tr>
<td>Canberra</td>
<td>Canberra</td>
<td>Australia</td>
</tr>
<tr>
<td>Cairns</td>
<td>Cairns</td>
<td>Queensland</td>
</tr>
<tr>
<td>Cape Town Airport</td>
<td>Cape Town</td>
<td>South Africa</td>
</tr>
</tbody>
</table>

   Cells cannot be cut or copied if the selection is not a rectangle

2. Select Edit > Cut or Edit > Copy.

   Note:

   If you selected an entire row or column and you select Edit > Cut, the entire row or column is removed from the table (not just the contents of the cells).

Paste table cells

1. Select where you want to paste the cells:

   - To replace existing cells with the cells you are pasting, select a set of existing cells with the same layout as the cells on the clipboard. (For example, if you’ve copied or cut a 3 x 2 block of cells, you can select another 3 x 2 block of cells to replace by pasting.)
• To paste a full row of cells above a particular cell, click in that cell.
• To paste a full column of cells to the left of a particular cell, click in that cell.

Note:
If you have less than a full row or column of cells in the clipboard, and you click in a cell and paste the cells from the clipboard, the cell you clicked in and its neighbors may (depending on its location in the table) be replaced with the cells you are pasting.

• To create a new table with the pasted cells, place the insertion point outside of the table.

2 Select Edit > Paste.

If you are pasting entire rows or columns into an existing table, the rows or columns are added to the table. If you are pasting an individual cell, the contents of the selected cell are replaced. If you are pasting outside a table, the rows, columns, or cells are used to define a new table.

Remove cell content but leave the cells intact
1 Select one or more cells.

Note:
Make sure the selection does not consist entirely of complete rows or columns.

2 Press Delete.

Note:
If only complete rows or columns are selected when you select Edit > Clear or press Delete, the entire rows or columns—not just their contents—are removed from the table.

Delete rows or columns that contain merged cells
1 Select the row or column.
2 Select Edit > Table > Delete Row, or Edit > Table > Delete Column.

Nest tables
A nested table is a table inside a cell of another table. You can format a nested table as you would any other table; however, its width is limited by the width of the cell in which it appears.

1 Click in a cell of the existing table.
2 Select Insert > Table, set the Insert Table options, and click OK.

Sort tables
You can sort the rows of a table based on the contents of a single column. You can also perform a more complicated table sort based on the contents of two columns.

You cannot sort tables that contain colspan or rowspan attributes—that is, tables that contain merged cells.

1 Select the table or click in any cell.
2 Select Edit > Table > Sort Table, set the options in the dialog box, and click OK.

Sort By Determines which column's values will be used to sort the table's rows.
Order  Determines whether to sort the column alphabetically or numerically, and whether to sort it in ascending order (A to Z, lower numbers to higher numbers) or descending order.

When the contents of a column are numbers, select Numerically. An alphabetic sort applied to a list of one- and two-digit numbers results in the numbers being sorted as if they were words (resulting in ordering such as 1, 10, 2, 20, 3, 30) rather than being sorted as numbers (resulting in ordering such as 1, 2, 3, 10, 20, 30).

Then By/Order  Determines the sorting order for a secondary sort on a different column. Specify the secondary-sort column in the Then By pop-up menu, and the secondary sort order in the Order pop-up menus.

Sort Includes The First Row  Specifies that the first row of the table should be included in the sort. If the first row is a heading that should not be moved, do not select this option.

Sort Header Rows  Specifies to sort all the rows in the table's thead section (if any) using the same criteria as the body rows. (Note that thead rows remain in the thead section and still appear at the top of the table even after sorting.) For information about the thead tag, see the Reference panel (select Help > Reference).

Sort Footer Rows  Specifies to sort all the rows in the table's tfoot section (if any) using the same criteria as the body rows. (Note that tfoot rows remain in the tfoot section and still appear at the bottom of the table even after sorting.) For information about the tfoot tag, see the Reference panel (select Help > Reference).

Keep All Row Colors The Same After The Sort Has Been Completed  Specifies that table row attributes (such as color) should remain associated with the same content after the sort. If your table rows are formatted with two alternating colors, do not select this option to ensure that the sorted table still has alternating-colored rows. If the row attributes are specific to the content of each row, then select this option to ensure that those attributes remain associated with the correct rows in the sorted table.

Colors

Web-safe colors

In HTML, colors are expressed either as hexadecimal values (for example, #FF0000) or as color names (red). A web-safe color is one that appears the same in Safari and Microsoft Internet Explorer on both Windows and Macintosh systems when running in 256-color mode. The conventional wisdom is that there are 216 common colors, and that any hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF (RGB values 0, 51, 102, 153, 204, and 255, respectively) represents a web-safe color.

Testing, however, reveals that there are only 212 web-safe colors rather than a full 216, because Internet Explorer on Windows does not correctly render the colors #0033FF (0,51,255), #3300FF (51,0,255), #00FF33 (0,255,51), and #33FF00 (51,255,0).

When web browsers first made their appearance, most computers displayed only 265 colors (8 bits per channel (bpc). Today, the majority of computers display thousands or millions of colors (16- and 32-bpc), so the justification for using the browser-safe palette is greatly diminished if you are developing your site for users with current computer systems.

One reason to use the web-safe color palette is if you are developing for alternative web devices such as PDA and cell phone displays. Many of these devices offer only black and white (1-bpc) or 256 color (8-bpc) displays.

The Color Cubes (default) and the Continuous Tone palettes in Dreamweaver use the 216-color web-safe palette; selecting a color from these palettes displays the color's hexadecimal value.
To select a color outside the web-safe range, open the system color picker by clicking the Color Wheel button in the upper-right corner of the Dreamweaver color picker. The system color picker is not limited to web-safe colors.

UNIX versions of browsers use a different color palette than the Windows and Macintosh versions. If you are developing exclusively for UNIX browsers (or your target audience is Windows or Macintosh users with 24-bpc monitors and UNIX users with 8-bpc monitors), consider using hexadecimal values that combine the pairs 00, 40, 80, BF, or FF, which produce web-safe colors for SunOS.

**Use the color picker**

In Dreamweaver, many of the dialog boxes, as well as the Property inspector for many page elements, contain a color box, which opens a color picker. Use the color picker to select a color for a page element. You can also set the default text color for your page elements.

1. Click a color box in any dialog box or in the Property inspector.

   The color picker appears.

2. Do one of the following:
   - Use the eyedropper to select a color swatch from the palette. All colors in the Color Cubes (default) and Continuous Tone palettes are web-safe; other palettes are not.
   - Use the eyedropper to pick up a color from anywhere on your screen—even outside the Dreamweaver windows. To pick up a color from the desktop or another application, press and hold the mouse button; this allows the eyedropper to retain focus, and select a color outside of Dreamweaver. If you click the desktop or another application, Dreamweaver picks up the color where you clicked. However, if you switch to another application, you may need to click a Dreamweaver window to continue working in Dreamweaver.
   - To select one of the different color models, click Hex or RGBa or HSLa at the bottom of the color picker dialog box.
   - To clear the current color without choosing a different color, click the Default Color button.

**Responsive design using fluid grid layouts**

The layout of a website has to respond and adapt to the dimensions of the device on which it is displayed (responsive design). A fluid grid layout provides a visual way to create different layouts corresponding to devices on which the website is displayed.

For example, your website is going to be viewed on desktops, tablets, and mobile phones. You can use fluid grid layouts to specify layouts for each of these devices. Depending on whether the website is displayed on a desktop, tablet, or mobile phone, the corresponding layout is used to display the website.

More info: [Adaptive Layout versus Responsive Layout](#)

**Note:**

*Inspect mode is not available for Fluid Grid Layout documents.*

**Create a fluid grid layout**

**Note:**

*You can edit existing fluid grid layouts in Dreamweaver 2017. However, you cannot create fluid grid layouts.*
Instead, use bootstrap to create responsive layouts in Dreamweaver 2017. For more information on Bootstrap, see Design responsive websites using Bootstrap.

1 Select File > Fluid Grid (legacy).

2 The default value for the number of columns in the grid is displayed in the center of the media type. To customize the number of columns for a device, edit the value as required.

3 To set the width of a page as compared to the screen size, set the value in percentage.

4 You can additionally change the gutter width. The gutter is the space between two columns.

5 Specify the CSS options for the page.
   When you click Create, you are asked to specify a CSS file. You can do one of the following:
   • Create a new CSS file.
   • Open an existing CSS file.
   • Specify the CSS file being opened as a Fluid Grid CSS file.

   The Fluid Grid for mobile phones is displayed by default. Also, the Insert panel for Fluid Grid is displayed. Use the options in the Insert panel to create your layout.

   To switch to designing the layout for other devices, click the corresponding icon in the options below the Design view.

6 Save the file. When you save the HTML file, you are prompted to save the dependent files such as boilerplate.css and respond.min.js to a location on your computer. Specify a location, and click Copy.

   The boilerplate.css is based on the HTML5 boilerplate. It is a set of CSS styles that ensures consistency in the way your web page is rendered across multiple devices. respond.min.js is a JavaScript library that helps provide support for media queries in older versions of browser.

Edit fluid grid documents
You can edit fluid grid documents directly in Live View to:
   • Associate HTML classes and IDs to elements. For more information, see Element Display.
   • Edit image attributes and text. For more information, see Quick Property Inspector and Edit text in Live View.
   • Insert new elements. For more information, see Insert fluid grid elements.

You can also visualize the HTML DOM structure of a fluid grid document using Element Quick View.

Insert fluid grid elements
The Insert panel (Window > Insert) lists the elements that you can use in a fluid grid layout. While inserting the elements, you can choose to insert them as fluid elements.

1 In the Insert panel, click the element that you want to insert.

2 In the dialog box that appears, click Before, After, or Nest to position the element with respect to the reference element highlighted in the document.

3 Select a class, or enter a value for the ID. The Class menu displays classes from the CSS file that you specified when creating the page.

4 Select the Insert As Fluid Element check box.
5 When you select an inserted element, the options to hide, duplicate, or delete the Div are displayed. For Divs layered on top of each other, the option to swap Divs is displayed.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swap Div</td>
<td>Swaps the currently selected element with the element above or below.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides the element. To unhide an element, do one of the following: To unhide ID selectors, change the display property in the CSS file to block. (display:block) To unhide class selectors, remove the applied class (hide_&lt;MediaType&gt;) in the source code.</td>
</tr>
<tr>
<td>Move up a row</td>
<td>Moves the element up by a row</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Duplicates the currently selected element. CSS linked to element is also duplicated.</td>
</tr>
<tr>
<td>Delete</td>
<td>For ID selectors, deletes both the HTML as well as CSS. For delete HTML only, press Delete. For class selectors, only HTML is deleted.</td>
</tr>
<tr>
<td>Align</td>
<td>For class selectors, the Align option acts as a zero margin button. For ID selectors, the align button aligns the element to the grid.</td>
</tr>
</tbody>
</table>

Elements on a page can be traversed cyclically using the up and down arrow keys. Select the element boundary and then press the arrow key.

Nesting elements
To nest fluid elements within other fluid elements, ensure that the focus is inside the parent element. Then, insert the required child element.

Nested Duplication is also supported. Nested Duplication duplicates the HTML (of the selected element) and generates the relevant Fluid CSS. Absolute elements contained within the selected element are positioned appropriately. Nested elements can also be duplicated using the duplicate button.

When you delete a parent element, the CSS corresponding to the element, its children, and associated HTML are deleted. Nested elements can also be deleted together using the Delete button (Keyboard Shortcut: Ctrl+Delete).

Extract in Dreamweaver
Extract integration with Dreamweaver lets web designers and developers apply design information and extract web-optimized assets directly within the coding environment. Extract provides a complete, self-contained solution for extracting style information and assets from PSD comps, reducing the need to go back and forth between Photoshop and Dreamweaver.

With the Extract panel in Dreamweaver, you can extract CSS, images, fonts, colors, gradients, and measurements, right into your web page. In addition to these primary Extract features, Dreamweaver also provides the following unique features:
• Direct access to your PSD files on Creative Cloud and to those PSD files that are shared with you in a collaborative folder
• Contextual code hinting to easily define fonts, colors, and gradients in your CSS
• Drag-and-drop support to create image tags from PSD layers
• Paste styles directly into Live View (for example, CSS Designer and Element Display)

Getting started with Extract

Extract CSS

Set Extract preferences

Copy text

Extract images

Extract fonts, colors, and gradients

Extract measurements

Last updated 11/7/2019
Getting started with Extract

Extract in Dreamweaver lets you access your PSD files directly from within the Extract panel in Dreamweaver. Read the following topics to know more about the Extract panel and workspace, and about loading your PSD files in the Extract panel:

- Extract panel and workspace
- Upload PSD files to Creative Cloud
- Open PSD files in Extract panel

Extract panel and workspace

The Extract workspace is designed to help you use Extract with Dreamweaver effectively. In this workspace, the Extract panel appears on the left and your web page appears on the right in split view (Live and Code Views). You can customize the workspace by dragging, docking, collapsing, or expanding panels to suit your needs. You can also save the customized workspace for future use.

Note:

If you happen to close the Extract panel, use the keyboard shortcut - Ctrl + K (Win); Cmd + K (Mac), or select Window > Extract to open the panel again.

Upon the first launch of Dreamweaver, the Extract panel displays an interactive tutorial to get you started with the workflows. You can use the drop-down list at the top of the panel to switch between different tutorials.

After you have used the tutorial, you can click Get Started to begin using Extract in Dreamweaver. The Extract panel displays a thumbnail view of folders and PSD files in your Creative Cloud account. These files are those that are either uploaded or synced from your desktop, or those that are shared with you through a collaborative folder on Creative Cloud.
To relaunch the tutorial, click the pop-up menu on the upper right corner of the panel and select Launch Tutorial.

**Upload PSD files to Creative Cloud**
You can upload a PSD file to your Creative Cloud by clicking the Upload PSD icon in the Extract panel. If the PSD comps are developed by another person or team, you can have them shared on Creative Cloud. You can then download the files, and upload them to your account either directly by logging in to Creative Cloud or through the Extract panel in Dreamweaver.

**Open PSD files in Extract panel**
Click the thumbnail image of the required PSD file in the Extract panel. If an updated version of the PSD file becomes available on Creative Cloud after you open it, reload the PSD file in the Extract panel. To do so, click the name of the PSD file or click Reload PSD in pop-up menu on upper right. To go back to the thumbnail view and select a different file, click the Creative Cloud icon on the upper left of the panel.

To magnify the view and take a closer look at the design, change the zoom level at the top of the Extract panel or use Alt +/- . Use the Layers tab or the Layer Comp drop-down list to show or hide elements in the PSD file.

You are now all set to translate the PSD comp to a website.
Set Extract preferences

Using Extract preferences, you can specify the default file format in which the images must be extracted and also, the default unit for fonts that is to be displayed in the Extract panel.

1. Select Edit > Preferences (Win) or Dreamweaver > Preferences (Mac).
2. Select Extract in the Category list.
3. (Optional) Change the default format in which the images must be extracted.

![Extracted image format](image)

4. (Optional) In the Extract For Devices section, select the required resolutions. These settings will be used when you choose to save an image in multiple resolution versions.
   - To save the versions with suffixes, click the corresponding row under the Suffix column, and type the text.
   - To save the multiple resolution versions in separate output folders, click the corresponding row under the Folder column, and specify the relative path.
5 (Optional) Click Clear Cache to delete the cached data related to Extract usage.

6 Click Apply, and then close the Preferences dialog box.

7 To see the changes in the Extract panel, reload the PSD (pop-up menu > Reload PSD).
Extract CSS from PSD files

You can copy all or specific CSS properties of elements in a PSD comp and directly paste the styles into CSS Designer, Element Display in Live View, or into your code (CSS source or HTML document).

Also, code hints are automatically populated with the CSS properties of the element you select in the PSD comp. If you prefer coding, you can use these code hints to extract the CSS properties into the code.

1 In the Extract panel (Window > Extract), click the required PSD file. The thumbnail view of the PSD expands, allowing you to view the comp clearly.

2 In the PSD file, click the required element or asset. A popup with a list of CSS properties of the element appears and provides you the option to select and copy them. You can view the width and height of the selected element in pixels or percentage.

**Note:** If you choose percentage here, the measurements too will be displayed in percentage units.
Copy CSS option in the Extract panel

To copy CSS, select the properties you want to copy, and then click Copy CSS.

3 Paste the CSS in your document using one of the following methods:
   • To paste the CSS in CSS Designer, right-click the required selector, and click Paste Styles.
   • To paste the CSS using Element Display, right-click a selector, and click Paste Styles.
   • To paste the CSS in the code, place the insertion point at the required location, right-click, and click Paste.

To use code hints for extracting CSS, perform the following steps:
1 Open a CSS source attached to your document or switch to the Code View of an HTML document.
2 In the Extract panel, click the required PSD file, and then the required element in the comp.
3 In your document, place the insertion point at the required location in the code.
4 Start typing the name of a CSS property to see the code hints containing the CSS properties of the selected element in the PSD comp. Click the required CSS property to insert into the code.

5 To extract multiple CSS properties, select the required properties in the Extract panel popup. Then, in code hints, click Insert Selected.
Batch insert CSS properties

Copy text from PSD files

Text or content in your PSD comps can be inserted into your web page with a single click. To copy text from your PSD comp in the Extract panel, select a text element and click Copy Text. The text is copied to your clipboard. You can then paste the text wherever required.
Copy Text option in the Extract panel

After you have extracted the text, you can extract properties, such as, font and colors that are associated with the text. For more information, see Extract fonts, colors, and gradients from PSD files.

Extract images from PSD files

You can simply drag any layer in your PSD comps from the Extract panel to a precise location in the Live view of your web page. Visual aids in Live View such as Live Guides and DOM icon help drag and place an element. When you pause for a while before dropping the element, the DOM icon (<> ) appears. The DOM structure is displayed when you hover your mouse over the <> icon and you can drop the element inside the structure. If you prefer coding, you can use the contextual code hinting and extract images. Code hints allow you to extract colors and gradients as images.

Note:

If your PSD file contains multiple artboards, each artboard is displayed as a folder in the layers pane. You can expand or collapse the folder to see or hide its contents. To zoom in to a specific artboard, simply click the artboard name. To zoom out, click anywhere outside the artboard and click FIT.

Before inserting the extracted image, Dreamweaver displays the image name, which you can edit. By default, the image is saved in the site root folder. If you want to save the image in a custom location, you can include the complete directory path along with the filename.

Note: If you are extracting an image into a document that does not belong to a defined site, the image is extracted into the directory in which the document exists. For unsaved documents, you are prompted to first save the document.

You can also save the image on your local disk and call it into your web page at a later point in time. Also, if you are designing a responsive website, you can save multiple resolution versions of an image for devices with a single click.

1 In the Extract panel, click the PSD file from which you want to download the images.

2 Click the required image in the PSD file.

Note:

Use the Layers tab and the Layer Comps drop-down list in the Extract panel to show or hide images in the PSD comp. If an image consists of multiple layers, you can select individual layer of the image to extract.

Notice that the code hints popup in the Code View on the right side of the workspace.

3 To import multiple images, hold down the Shift or the Command key, and click the required images. The selected images are extracted as a single image.

4 Perform one of the following actions:
   - In the popup that appears when you click the image, click 1. Specify the path, filename, file format, and scaling factor (if required). Then, perform one of the following actions:
     - Click Save to save the image at 1x resolution. To scale the image, select Scale At, and specify the scaling factor.
     - Click Save Multiple to save multiple resolution versions of the image. The PSD file need not necessarily contain these versions; Dreamweaver can save the image in multiple resolutions during extraction.

You can specify the required resolution versions and the corresponding output folder in Preferences.
Drag the image into the Live View of your document. Live Guides appear in the Live View to help you position the image.

When you drop the image, Dreamweaver displays the name of the image. You can not only edit the name of the image, but also the extension, and press Enter to save the image. The image is saved in the site root folder by default. To save the image in a custom location, enter the path along with the filename.
Filename and extension editing option when you drag an image from Extract panel

- When you click the image, contextual code hints in Dreamweaver are populated. In the Code View of your
HTML document or in your CSS document, place the cursor at the insertion point. After you type the background-image property name or the `<img>` tag, the name of the selected image appears in the code hints. Select the image, modify the name and extension if required, and press Enter.

By default, the image is saved in the site root folder. To save the image in a custom location, enter the custom file path along with the filename.

![Extracting images using code hints](image.png)

**Extract measurements from PSD files**

Using the Extract panel, you can easily view and extract the measurement value between any two elements in the PSD comp.

1. In the PSD file in the Extract panel, click the required elements by holding down the Shift or the Command key. The Extract panel displays the horizontal and vertical distance between the two elements.
We can never have enough of **Nature**

—Henry David Thoreau

**Featured Location: Dominica**

Known as “Nature Isle of the Caribbean” because of its untouched natural beauty, Dominica offers a wealth of exploring by land and sea. The island, situated in the Lesser Antilles region of the Caribbean, is home to Champagne Reef – a premier dive site. The water starts shallow off the coast and extends to deeper reefs, offering exceptional snorkeling and scuba diving, depending on experience level and weather.
Measurements in the Extract panel

**Note:**

To view the measurements in percentage units, click any element and then click percentage.

2 Click the required value to copy it to the clipboard.

3 Paste the value wherever required, for example, in the CSS properties of CSS Designer or in your code.

**Extract fonts, colors, and gradients from PSD files**

Using the Extract panel, you can extract the CSS properties of fonts, colors, or gradients used in your PSD comp.

1 In the Extract panel, click Styles.

2 To extract fonts, perform the following actions in the Fonts section.
   a Expand the required font type.
      To know more about the font, click the Adobe Fonts icon.
   b Click the format and size that you want to copy, and in the popup that appears, click Copy CSS. Extract tags the text elements that use the font, format, and size that you clicked.

**Note:**

You can change the unit of the font to ‘em’ or ‘rem’ in Extract preferences (Preferences > Extract). Click Reload PSD in the pop-up menu on the upper right corner of the Extract panel to see the changes.
To extract colors, perform the following actions in the Colors section:

d  Click the required color swatch. Extract tags the elements that use the selected color.

Note: You can also pick any other color from the PSD comp using the color picker.

e  In the popup that appears when you click the color swatch, select the required color model (RGB, Hex, or HSL), and then copy (Ctrl+c; Cmd+c) the color value.

f  Paste the color value wherever required, for example, in the code or CSS Designer.

3  To extract gradients, click a gradient swatch in the Gradients section. In the popup that appears, click Copy CSS. Paste the CSS wherever required, for example, in the code or in CSS Designer.

Vendor prefixes that are selected in the preferences (Preferences > CSS Styles) are also pasted along with the gradients. If you extract a radial gradient, the corresponding CSS is inserted without a vendor prefix since radial gradients are not supported.
Extracting gradient
Chapter 7: CSS

Understand Cascading Style Sheets

About Cascading Style Sheets

*Cascading Style Sheets (CSS)* is a collection of formatting rules that control the appearance of content in a web page. Using CSS styles to format a page separates content from presentation. The content of your page—the HTML code—resides in the HTML file, and the CSS rules defining the presentation of the code reside in another file (an external style sheet) or in another part of the HTML document (usually the head section). Separating content from presentation makes it much easier to maintain the appearance of your site from a central location because you don’t need to update every property on every page whenever you want to make a change. Separating content from presentation also results in simpler and cleaner HTML code, which provides shorter browser loading times, and simplifies navigation for people with accessibility issues (for example, those using screen readers).

CSS gives you great flexibility and control over the exact appearance of your page. With CSS you can control many text properties including specific fonts and font sizes; bold, italics, underlining, and text shadows; text color and background color; link color and link underlining; and much more. By using CSS to control your fonts, you can also ensure a more consistent treatment of your page layout and appearance in multiple browsers.

In addition to text formatting, you can use CSS to control the format and positioning of block-level elements in a web page. A block-level element is a standalone piece of content, usually separated by a new line in the HTML, and visually formatted as a block. For example, *h1* tags, *p* tags, and *div* tags all produce block-level elements on a web page. You can set margins and borders for block-level elements, position them in a specific location, add background color to them, float text around them, and so on. Manipulating block-level elements is in essence the way you lay out pages with CSS.

About CSS rules

A CSS formatting rule consists of two parts—the selector and the declaration (or in most cases, a block of declarations). The selector is a term (such as *p*, *h1*, a class name, or an id) that identifies the formatted element, and the declaration block defines what the style properties are. In the following example, *h1* is the selector, and everything that falls between the braces ({} ) is the declaration block:

```
   h1 {
      font-size: 16 pixels;
      font-family: Helvetica;
      font-weight: bold;
   }
```

An individual declaration consists of two parts, the property (such as *font-family*) and value (such as *Helvetica*). In the previous CSS rule, a particular style has been created for *h1* tags: the text for all *h1* tags linked to this style will be 16 pixels in size, Helvetica font, and bold.
The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it's formatting—usually in an external style sheet, or in the head portion of an HTML document. Thus, one rule for h1 tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on many different pages). In this way, CSS provides extremely easy update capability. When you update a CSS rule in one place, the formatting of all the elements that use the defined style are automatically updated to the new style.

You can define the following types of styles in Dreamweaver:

- **Class styles** let you apply style properties to any element or elements on the page.
- **HTML tag styles** redefine the formatting for a particular tag, such as h1. When you create or change a CSS style for the h1 tag, all text formatted with the h1 tag is immediately updated.
- **Advanced styles** redefine the formatting for a particular combination of elements, or for other selector forms as allowed by CSS (for example, the selector td h2 applies whenever an h2 header appears inside a table cell.) Advanced styles can also redefine the formatting for tags that contain a specific id attribute (for example, the styles defined by #myStyle apply to all tags that contain the attribute-value pair id="myStyle").

CSS rules can reside in the following locations:

**External CSS style sheets** Collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML file). This file is linked to one or more pages in a website using a link or an @import rule in the head section of a document.

**Internal (or embedded) CSS style sheets** Collections of CSS rules included in a style tag in the head portion of an HTML document.

**Inline styles** Defined within specific instances of tags throughout an HTML document. (Using Inline styles is not recommended.)

Dreamweaver recognizes styles defined in existing documents as long as they conform to CSS style guidelines. Dreamweaver also renders most applied styles directly in Design view. (Previewing the document in a browser window, however, gives you the most accurate “live” rendering of the page.) Some CSS styles are rendered differently in Microsoft Internet Explorer, Netscape, Opera, Apple Safari, or other browsers, and some are not currently supported by any browser.
About cascading styles

The term *cascading* refers to the way a browser ultimately displays styles for specific elements on a web page. Three different sources are responsible for the styles you see on a web page: the style sheet created by the author of the page, the user's customized style selections (if any), and the default styles of the browser itself. The previous topics describe creating styles for a web page as the author of both the web page and the style sheet attached to that page. But browsers also have their own default style sheets that dictate the rendering of web pages, and in addition to that, users can customize their browsers by making selections that adjust the display of web pages. The final appearance of a web page is the result of the rules of all three of these sources coming together (or "cascading") to render the web page in an optimal way.

A common tag—the paragraph tag, or `<p>` tag—illustrates the concept. By default, browsers come with style sheets that define the font and font size for paragraph text (that is, text that falls between `<p>` tags in the HTML code). In Internet Explorer, for example, all body text, including paragraph text, displays in Times New Roman, Medium font by default.

As the author of a web page, however, you can create a style sheet that overrides the browser's default style for paragraph font and font size. For example, you can create the following rule in your style sheet:

```css
p {
  font-family: Arial;
  font-size: small;
}
```

When a user loads the page, the paragraph font and font size settings set by you as the author override the default paragraph text settings of the browser.

Users can make selections to customize the browser display in an optimal way for their own use. In Internet Explorer, for example, the user can select View > Text Size > Largest to expand the page font to a more readable size if they think the font is too small. Ultimately (at least in this case), the user's selection overrides both the default browser styles for paragraph font size and the paragraph styles created by the author of the web page.

Inheritance is another important part of the cascade. Properties for most elements on a web page are inherited—for example, paragraph tags inherit certain properties from body tags, span tags inherit certain properties from paragraph tags, and so on. Thus, if you create the following rule in your style sheet:

```css
body {
  font-family: Arial;
  font-style: italic;
}
```

All paragraph text on your web page (as well as text that inherits properties from the paragraph tag) will be Arial and italic because the paragraph tag inherits these properties from the body tag. You can, however, become more specific with your rules, and create styles that override the standard formula for inheritance. For example, if you create the following rules in your style sheet:

```css
body {
  font-family: Arial;
  font-style: italic;
}
p {
  font-family: Courier;
  font-style: normal;
}
```
All body text will be Arial and italic except paragraph (and its inherited) text, which will display as Courier normal (non-italic). Technically, the paragraph tag first inherits the properties that are set for the body tag, but then ignores those properties because it has properties of its own defined. In other words, while page elements generally inherit properties from above, the direct application of a property to a tag always causes an override of the standard formula for inheritance.

The combination of all of the factors discussed above, plus other factors like CSS specificity (a system that gives different weight to particular kinds of CSS rules), and the order of CSS rules, ultimately create a complex cascade where items with higher priorities override properties that have lower priorities. For more information on the rules governing the cascade, inheritance, and specificity, visit www.w3.org/TR/CSS2/cascade.html.

**About text formatting and CSS**

By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text. The styles that you apply to text using the Property inspector or menu commands create CSS rules that are embedded in the head of the current document. **Laying out pages using CSS Designer**

You can also use the CSS Designer to create and edit CSS rules and properties. The CSS Designer is a much more robust editor than the Property inspector, and displays all CSS rules defined for the current document, whether those rules are embedded in the head of the document or in an external style sheet. Adobe recommends that you use the CSS Designer (rather than the Property inspector) as the primary tool for creating and editing your CSS. As a result, your code will be cleaner and easier to maintain.

For more information on CSS Designer, see [Laying out pages using CSS Designer](#).

In addition to styles and style sheets you create, you can use style sheets that come with Dreamweaver to apply styles to your documents.

For a tutorial about formatting text with CSS, see [www.adobe.com/go/vid0153](http://www.adobe.com/go/vid0153).

**About Shorthand CSS properties**

The CSS specification allows for the creation of styles using an abbreviated syntax known as **shorthand CSS**. Shorthand CSS lets you specify the values of several properties using a single declaration. For example, the `font` property lets you set `font-style`, `font-variant`, `font-weight`, `font-size`, `line-height`, and `font-family` properties on a single line.

A key issue to note when using shorthand CSS, is that values omitted from a shorthand CSS property are assigned their default value. This may cause pages to be incorrectly displayed when two or more CSS rules are assigned to the same tag.

For example, the `h1` rule shown below uses longhand CSS syntax. Note that the `font-variant`, `font-stretch`, `font-size-adjust`, and `font-style` properties have been assigned their default values.

```css
h1 {
  font-weight: bold;
  font-size: 16pt;
  line-height: 18pt;
  font-family: Arial;
  font-variant: normal;
  font-style: normal;
  font-stretch: normal;
  font-size-adjust: none
}
```

Rewritten as a single, shorthand property, the same rule might appear as follows:
When written using shorthand notation, omitted values are automatically assigned their default values. Thus, the previous shorthand example omits the `font-variant`, `font-style`, `font-stretch`, and `font-size-adjust` tags.

If you have styles defined in more than one location (for example, both embedded in an HTML page and imported from an external style sheet) using both the short and long forms of CSS syntax, be aware that omitted properties in a shorthand rule may override (or cascade) properties that are explicitly set in another rule.

For this reason, Dreamweaver uses the long form of CSS notation by default. This prevents possible problems caused by a shorthand rule overriding a longhand rule. If you open a web page that was coded with shorthand CSS notation in Dreamweaver, be aware that Dreamweaver will create any new CSS rules using the longhand form. You can specify how Dreamweaver creates and edits CSS rules by changing the CSS editing preferences in the CSS Styles category of the Preferences dialog box (Edit > Preferences in Windows; Dreamweaver > Preferences on the Macintosh).

### Dreamweaver and CSS

In Dreamweaver, you can work with CSS in multiple ways:

- You can use the CSS Designer to build your CSS with minimal coding. For more information, see [Laying out pages using CSS Designer](#).
- You can also code your CSS by hand. For more information on coding features offered by Dreamweaver, see [Coding environment in Dreamweaver](#).
- If you prefer to work with Sass, Scss, or Less files, you can code your files using your preferred syntax and use it in Dreamweaver. For more information, see [Using CSS preprocessors in Dreamweaver](#).

### Laying out pages using CSS Designer

CSS Designer panel (Window > CSS Designer) is a CSS Property Inspector that lets you "visually" create CSS styles, files, and set properties, along with media queries.

The following sections are available in the CSS Designer interface:

- **Sources**: A collection of CSS files associated with the project
- **@Media**: Media queries to control the screen size
- **Selectors**: Selectors associated with the selected media query in the @Media panel
- **Properties**: Properties associated with the selected selector, with an option to show only the set properties

Using the CSS Designer, you can edit an individual rule in a CSS style sheet (use the Current tab in the CSS Designer), or if you prefer, you can work directly in the CSS style sheet (use the All tab in the CSS Designer).
Create and attach style sheets

1. In the Sources pane of the CSS Designer panel, click 📁, and then click one of the following options:
   - Create a New CSS File: To create and attach a new CSS file to the document
   - Attach Existing CSS File: To attach an existing CSS file to the document
   - Define in Page: To define a CSS within the document
Based on the option you choose, **Create A New CSS File** or **Attach Existing CSS File** dialog boxes appear.

2 Click **Browse** to specify the name of the CSS file and, if you are creating a CSS, the location to save the new file.

3 Do one of the following:
   - Click **Link** to link the Dreamweaver document with the CSS file
   - Click **Import** to import the CSS file into the document.

4 (Optional) Click **Conditional Usage** and specify the media query that you want to associate with the CSS file.
Define media queries

1. In the CSS Designer panel, click a CSS Source in the Sources pane.

2. Click in the @Media pane to add a new media query.

   The Define Media Query dialog box appears and lists all the media query conditions supported by Dreamweaver.

3. Select the Conditions as per your requirements.

   Ensure that you specify valid values for all the conditions you select. Else, corresponding media queries do not get created successfully.

   **Note:**

   *Only 'And' operation is supported for multiple conditions.*

   If you add media query conditions through code, only the supported conditions are populated in the Define Media Query dialog box. The Code text box in the dialog box, however, displays the code completely (including unsupported conditions).
If you click on a media query in the Design/Live view, the viewport switches to match the selected media query. To view the full size viewport, click Global in the @Media pane.

**Define CSS Selectors**

1. In the CSS Designer panel, select a CSS source in the Sources pane or a media query in the @Media pane.
2. In the Selectors pane, click . Based on the element selected in the document, CSS Designer smartly identifies and prompts you with the relevant selector (upto three rules).

You can do one or more of the following:

- Use the up or down arrow keys to make the suggested selector more specific or less specific.
- Delete the suggested rule and type the required selector. Ensure that you type the name of the selector along with the denotation for the Selector Type. For example, if you are specifying an ID, prefix the name of the selector with a '#'.
- To search for a specific selector, use the search box at the top of the pane.
- To rename a selector, click the selector, and type the required name.
- To reorganize the selectors, drag the selectors to the required position.
- To move a selector from one source to another, drag the selector to the required source in the Source pane.
- To duplicate a selector in the selected source, right-click the selector, and click Duplicate.
- To duplicate a selector and add it into a media query, right-click the selector, hover the mouse over Duplicate Into Media Query, and then choose the media query.

**Note:** The Duplicate Into Media Query option is available only when the source of the selected Selector contains media queries. You cannot duplicate a Selector from one source into a media query of another source.

**Copy-paste styles**

You can now copy styles from one selector and paste into another. You can copy all styles or copy only specific category of styles such as Layout, Text, and Border.

Right-click a selector and choose from the available options:

- If a selector has no styles, Copy and Copy All Styles are disabled.
- Paste Styles is disabled for remote sites that cannot be edited. But Copy and Copy All styles is available.
- Pasting Styles that already exist partially on a selector (Overlapping) works. Union of all the selectors is pasted.
- Copy-paste Styles also works for different linkages of CSS files – Import, Link, Inline Styles.
Rearrange selectors
Click the required selector and drag it to the new position with the Selectors pane.

Set CSS properties
The properties are grouped into the following categories and are represented by different icons at the top of the Properties pane:

• Layout
• Text
• Border
• Background
• More (list of 'text only' properties and not properties with visual controls)

Note:
Before editing the properties of a CSS Selector, identify the elements associated with the CSS Selector using Reverse Inspect. By doing so, you can evaluate if all the elements highlighted during Reverse Inspect actually require the changes.

Select the Show Set check box to view only the set properties. To view all the properties that you can specify for a selector, deselect the Show Set check box.

To set a property, such as, width or border-collapse, click the required options displayed adjacent to the property in the Properties pane.

Overridden properties are indicated using a strikethrough format.

Set margins, padding, and position
Using the box controls in CSS Designer's Properties pane, you can quickly set the margins, padding, and position properties. If you prefer code, you can specify shorthand code for margin and padding in the quick edit boxes, as shown in this example.
Click the values and type the required value. If you want all the four values to be the same and changed simultaneously, click the link icon at the center.

At any point in time, you can disable or delete specific values, for example, left margin value while retaining the right, top, and bottom values.

**Set border properties**

Border Control properties are organized into logical tabs to help you quickly view or modify the properties.

If you prefer code, you can specify shorthand code for borders and border radius in the quick edit text box.

To specify the Border Control properties, first set the properties in the 'All Sides' tab. The other tabs are then enabled and the properties set in the 'All Sides' tab are reflected for individual borders.

When you change a property in the individual border tabs, the value of the corresponding property in the 'All Sides' tab changes to 'undefined' (default value).

In the example below, the border color was set to black and then changed to red for the Top border.
The code that is inserted is based on the preference setting for shorthand or longhand.

During Inspect, the tabs are focused based on the priority of the "set" tabs. The highest priority is for "All sides" tab followed by "Top", "Right", "Bottom" and "Left". For example, if only the top value for a border is set, the computed mode takes the focus to the "Top" tab ignoring the "All sides" tab because "All sides" tab is not set.
Disable or delete properties
The Disable/Enable CSS Property feature lets you comment out portions of CSS from the CSS Designer panel, without having to make changes directly in the code. When you comment out portions of the CSS, you can see what kinds of effects particular properties and values have on your page.

When you disable a CSS property, Dreamweaver adds CSS comment tags and a [disabled] label to the CSS property you've disabled. You can then easily re-enable or delete the disabled CSS property according to your preference.

You can disable or delete each property using the CSS Designer.

The following screenshot shows the disable and delete icons for the height property. These icons are visible when you hover your mouse on the property.

![Disable/delete property](image_url)

You can also use the delete and disable controls at the Border Control group level to apply these actions to all the properties.

Keyboard shortcuts
You can add or delete CSS selectors and properties using keyboard shortcuts. You can also navigate between the property groups in the Properties pane.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Workflow</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + Alt + [Shift =]</td>
<td>Adds Selector (If control is in the selector section)</td>
</tr>
<tr>
<td>CTRL + Alt + S</td>
<td>Add Selector (If control is anywhere in the application)</td>
</tr>
<tr>
<td>CTRL + Alt + [Shift =]</td>
<td>Adds Property (If control is in the property section)</td>
</tr>
<tr>
<td>CTRL + Alt + P</td>
<td>Adds Property (If control is anywhere in the application)</td>
</tr>
<tr>
<td>Select + Delete</td>
<td>Deletes selector, if selector is selected</td>
</tr>
<tr>
<td>CTRL + Alt + (PgUp/PgDn)</td>
<td>Jump between sections while in the properties subpanel</td>
</tr>
</tbody>
</table>

Identify page elements associated with a CSS Selector
Most often, a single CSS Selector is associated with multiple page elements. For example, text in the main content of a page, header, and footer text can all be associated with the same CSS Selector. When you edit the properties of the CSS Selector, all the elements associated with the Selector are affected, including the ones that you do not intend to change.

Live Highlight helps you identify all the elements associated with a CSS Selector. If you want to change only one element or some of the elements, you can create a new CSS Selector for those elements, and then edit the properties.
To identify the page elements associated with a CSS Selector, hover your mouse over the Selector in Live View (with Live Code ‘off’). Dreamweaver highlights the associated elements with dotted lines.

To lock-in the highlight for the elements, click the Selector. The elements now are highlighted with a blue border.

To remove the blue highlight around the elements, the Selector again.

Live Highlight is enabled by default. To disable Live Highlight, click Live View options in Document Toolbar and click Disable Live Highlight.

**Link to an external CSS style sheet**

When you edit an external CSS style sheet, all documents linked to that CSS style sheet are updated to reflect those edits.

You can export the CSS styles found in a document to create a new CSS style sheet, and attach or link to an external style sheet to apply the styles found there.

You can attach to your pages any style sheet that you create or copy into your site.

1. Open the CSS Designer by doing one of the following:
   - Select Window > CSS Designer.
   - Press Shift + F11.

2. In the CSS Designer, click the + icon next to Sources, and select Attach Existing CSS File.

3. Do one of the following:
   - Click Browse to browse to an external CSS style sheet.
   - Type the path to the style sheet in the File/URL box.

4. Click the Preview button to verify that the style sheet applies the styles you want to the current page.
If the styles applied are not what you expect them to be, click Cancel to remove the style sheet. The page will revert to its previous appearance.

Click OK.

**Using CSS preprocessors in Dreamweaver**

CSS is a language that describes the style of an HTML document. CSS preprocessors compile code written in a preprocessed language to the most familiar CSS. Preprocessed language raises CSS to a level closer to a programming language.

Specifically, preprocessors allow you to use variables, mix-ins, functions, and many other techniques that are not possible in CSS. Using CSS preprocessors, you can define everything once and reuse them repeatedly that results in maintainable and extendable CSS.

Using a CSS preprocessor, you can also produce cleaner and easy-to-maintain CSS. If you are creating websites that reference a number of CSS files, using CSS preprocessors like Sass, or Compass can reduce manual coding and copy/paste actions.

Dreamweaver uses a built-in Ruby-Saas compiler to compile the SCSS, LESS files. Dreamweaver also supports Compass, and Bourbon frameworks for compiling Sass files.

LESS is JavaScript-based while Sass is Ruby-based. However, you do not have to know anything about either of these languages. Nor do you have to use the command line to compile the files into CSS. Dreamweaver auto compiles these files into CSS using the less.js JavaScript library, when you load, edit, or save these files.

**Supported versions:**

- Sass: 3.4.25
- LESS: 2.7.2
- Compass: 1.0.3
- Bourbon: 4.2.6
- Bourbon Neat: 1.7.3
- Bourbon Bitters: 1.2.0

**How Dreamweaver handles CSS preprocessors**

How Dreamweaver handles CSS preprocessors varies depending on whether you have defined a site. If you define a site, you can set up CSS preprocessor preferences, and also use the Compass and Bourbon frameworks from within Dreamweaver.

When you define a site, you can customize the way CSS preprocessors work within Dreamweaver by setting site-specific CSS preprocessor preferences. Setting site-specific CSS preprocessor preferences allows you to specify compilation options on a site basis. You can also customize the location of Sass and CSS files, and preprocessor options specific to each site.

Read on to know how to use Dreamweaver with CSS preprocessors:
Dreamweaver 2017 and CSS preprocessors

In Dreamweaver 2017, CSS preprocessor support is built in Dreamweaver. That is, you can work with Sass/LESS/SCSS files within Dreamweaver. A simple Ctrl+S or Cmd+S enables you to auto-compile CSS in Dreamweaver. You can also manually compile individual CSS files using Tools > Compile (or F9). The changes are also reflected in all the open HTML files where this compiled CSS is linked or attached.

Here is a high-level workflow of the tasks involved when using CSS preprocessors:

- Install the appropriate compiler if you want to use Compass or Bourbon from within Dreamweaver. This installation is a one-click process. Set up your CSS preprocessor settings.

Install the compiler only if you want a copy of the framework files (Bourbon), or if you want to generate default scss files and Ruby-based configuration files (Compass). Keeping a copy of the framework files is recommended. If certain mixins or functions from the authoring framework are removed in later revisions, you can still access the preprocessor files within your site.

- Ensure that auto-compile is enabled. Then press Save to update the CSS files.

- (Optional) View the changes getting reflected in Live view or Real-time Preview in all HTML pages where the generated css is used.

Dreamweaver 2015 and CSS preprocessors

In Dreamweaver 2015 and earlier CC versions, you could use Sass, LESS, and SCSS files with Dreamweaver. However, you had to compile these files yourself outside the Dreamweaver application. Your workflow would resemble the following steps:

1. Download and install a compiler.
2. Set up a grunt (Gruntfile.js) job for the compiler to read your Sass/LESS/SCSS file.
3. Set up another grunt job to compile the file into CSS, which you would then bring into Dreamweaver.

You must perform these steps every time you make a change in your Sass/LESS/SCSS file.

Note:

See this video tutorial to learn how you can enhance your CSS using preprocessors.

If you do not have a site defined, then you can choose to manually compile your Sass and LESS files. However support for Compass and Bourbon frameworks is not supported.

How to use CSS preprocessors in Dreamweaver?

Here is a high-level workflow of the tasks involved when using CSS preprocessors:

1. Define a site in Dreamweaver. Ensure that the Sass or LESS file that you are trying to compile is included in the site root folder. If you have already defined a site and the Sass/LESS file is included in the site root, proceed to the next step. For more information on setting up a Dreamweaver site, see About Dreamweaver sites.
2. Set preferences for CSS preprocessors (such as defining the location of generated CSS files). These preferences are site-specific. For more information, see Setting preferences for CSS preprocessors.
3. If you want to use specific frameworks, such as Compass or Bourbon, you can specify the settings for these frameworks. For more information, see: Using the Compass framework or Using the Bourbon framework.
4. Set up auto compilation or manually compile your Sass and LESS files. For more information, see Compile CSS preprocessor files.

Last updated 11/7/2019
Setting preferences for CSS preprocessors

You can set site-specific preferences for CSS preprocessors using the Sites > Manage Sites dialog box.

Keeping CSS preprocessor site-specific preferences allows you to manage your CSS preprocessors on a site basis. This action also gives you control over the CSS preprocessor for each site, without having to update preferences every time you switch sites.

Note:

The settings in General, and Source & Output subsections are applicable for Ruby-Saas framework by default.

To set the preferences for Compass, you must select the Use Compass check box in the Compass section.

Set general CSS preprocessor settings

You can set the following general CSS preprocessor settings in the Sites > Manage Sites > CSS Preprocessors dialog box. By default, these settings are applicable for the Saas framework.

![General CSS preprocessor settings]

**Enable Auto Compilation on File Save** Select this check box to enable auto compilation of CSS preprocessors. If you select this option, Dreamweaver automatically generates a CSS file when you save your Sass, LESS, or SCSS file. If this option is left deselected, you have to manually compile the files every time you make a change.
LESS options

Enable Strict Math  Processes only those math that is in parentheses. For example, \((100\text{px}/25\text{px})\) is successfully processed while \(20\% + 10\%\) (without parentheses) is not processed. When this option is disabled, all math in the file is processed.

Enable Strict Units  Without this option, LESS attempts to guess at the output unit when it does maths. For example:

```css
.class {
  property: 1px * 2px;
}
```

In this case, the length multiplied by length gives an area, but css does not support specifying areas. Dreamweaver assumes that the user meant for one of the values to be a value and not a unit of length.

With strict units on, Dreamweaver assumes it is a calculation error, and throws an error.

Rewrite URLs as Relative URLs  This option enables you to rewrite URLs in the CSS file that is generated so that the URLs are always relative to the generated file.

Generate Source map  Creates a source map. Source map is a file that bridges the gap between high-level languages like Sass and LESS, and the low-level language they compile to, such as CSS.

Sass/SCSS options

Output File Style  Specifies the style of the CSS output file:

- **Nested** - Formats the compiled CSS in the well-known, modular structure.
- **Compact** - Formats the compiled CSS in a compact structure that takes up less space than Nested or Expanded.
- **Compressed** - Outputs the CSS in a flat structure.
- **Expanded** - Outputs the CSS in an expanded manner with each property and rule taking up one line. Properties are indented within the rules, but the rules are not indented in any way.

Create Source Comments  Creates comments in the output CSS file that maps the CSS code to the line from which it was generated.

Generate Source map  Creates a source map (file that bridges the gap between high-level languages like Sass and LESS, and the low-level language, they compile to, such as CSS).

Set CSS source and output preferences

You can define where the generated CSS files should be placed, and the path Dreamweaver should watch and trigger auto compilation, when a Sass/LESS file in the path is modified using an external editor.

Note:

*By default, the options in the Source & Output section is applicable for Saas. To enable these options for Compass, you must select the Use Compass check box in the Compass section.*

*After you modify these settings and install Compass, all the settings are migrated to config.rb. Later, if you want to modify any settings, directly edit the settings in the config.rb file. Also, changes made in the Site Settings dialog box do not affect the compilation.*
You can set the following source and output CSS preprocessor settings in the Sites > Manage Sites dialog.

**CSS Output**

Specify the location of the CSS output file that is generated.

**In the same folder as source** Select this option if you want the generated CSS files to be saved in the same folder as the source Sass and LESS files.
**Define output folder**  Select this option and specify a folder where you want to save the generated CSS files.

**Replace segment of input path**  This option allows you to replace a portion of the path using the From and To strings. For example, on setting From: scss and To: css, the output file is placed inside the same tree structure after replacing SCSS in the path css.

**Source Folder**  Specify the sub folder within the site root that has to be watched. Usually, this sub folder contains all your SCSS or LESS files.

If you have enabled Compilation in the Set general CSS preprocessor settings, Dreamweaver automatically triggers the CSS Preprocessor. Dreamweaver triggers autocompilation when any file within the folder is modified externally, or from within Dreamweaver.

**Using the Compass framework**

Compass is an open-source CSS Authoring Framework that allows you to create CSS3 style sheets using Sass.

Dreamweaver offers support to Compass. If you create style sheets using Compass, you can compile these style sheets and generate CSS files from within Dreamweaver.

1. **Use Compass files.**

   If you do not have Compass already installed, you can install it from within Dreamweaver.

   In the Site Setup dialog box, select **CSS Preprocessors > Compass**. Select **Use Compass** and then click **Install Files**.

   ![Installing Compass files](image)

   All the Compass files and the *.rb config file is installed within your site folder, and you can see them in the **Files** panel.
2 Specify an existing Ruby-based configuration file

If you already have Compass installed in your computer, and have the Compass *.rb file setup, in the Dreamweaver Site Setup dialog, specify the path to the Compass *.rb file within the current site root.

a In the Site Setup dialog box, select CSS Preprocessors > Compass.

b Select the Use Compass check box.

c Click Specifying Ruby-based configuration file, and browse to the file location.

d Click Save when done.
Specifying an existing Ruby-based configuration file

Note:
This file must be located in your site root folder.

Specify configuration options manually

If you do not have an existing configuration option, you can specify the configurations manually.

a In the Site Setup dialog box, select CSS Preprocessors > Compass.
b Select the Use Compass check box.
c Click Specifying Configuration Options manually. Specify the following configuration options, and click Save.

The following fields get populated automatically, but you can change them according to your requirements:

Note:
All the paths selected in these options must be within the site root.

HTTP Path The path to the project when running within the web server. Defaults to "/".
Images Directory The directory where the images are kept. The directory is relative to the project_path.
Generated Images Directory The directory where generated images are kept. This directory is relative to the project_path, and defaults to the value of images_dir.
Fonts Directory The directory where the font files are kept.
Relative Assets Indicates whether the compass helper functions should generate relative URLs from the generated CSS to assets, or absolute URLs using the http path for that asset type.

4 If you have selected Enable Auto Compilation on File Save, in the Sites > Manage Sites > CSS Preprocessors dialog box, Dreamweaver generates a CSS file every time you save changes to your Sass files.
You can also preview these changes in real time in your browser window. For more information on previewing your changes in real time in browser, see Real-time Preview in browser.

If you do not want auto-compilation, you can manually compile a CSS file by doing one of the following:

- Right-click the Sass, LESS, or SCSS file in the Files panel and click Compile.
- Click Tools > Compile to compile the current file.

You can then attach your compiled CSS file to the HTML files in your site. For more information, see Link to an external CSS style sheet.

### Using the Bourbon framework

Dreamweaver supports the Bourbon family of products. If you create style sheets using Bourbon, you can compile these style sheets and generate CSS files from within Dreamweaver.

The following Bourbon flavors are supported:

- Bourbon - A simple and lightweight mixing library for Sass
- Bourbon Neat - A lightweight semantic grid framework for Sass and Bourbon
- Bourbon Bitters - Scaffold styles, variables, and structure for Bourbon projects

You can import the Bourbon framework by adding one of the following in your code:

- `@import "bourbon"` - to import Bourbon
- `@import "neat"` – to import Bourbon Neat
- `@import "base"` – to import Bourbon Bitter

Dreamweaver then uses the prepackaged version of Bourbon while compiling the preprocessor files.

Alternatively, you can install Bourbon framework files to your site so that further updates to Dreamweaver do not affect your compilation workflows. The Bourbon framework files are copied to your site. Bourbon is the framework that is used when compilation is triggered for any of the files that import the framework.

### Install Bourbon, Bourbon Neat, or Bourbon Bitters files

To install Bourbon or any of its flavors:

1. In the Site Setup dialog box, select CSS Preprocessors > Bourbon, Bourbon Neat, or Bourbon Bitters.
2. Click Install Files to install the files in the specified site root folder location within your site.
Installing Bourbon files

All the Bourbon files are installed within your site folder, and you can see them in the Files panel.

If there is a failure, the errors are displayed in the Output panel (Window > Results > Output), and the status bar icon changes to red.
Compile CSS preprocessor files
You can compile CSS preprocessor files in one of the following ways:

- Set up auto compilation of CSS preprocessor files
- Manually compile a CSS Preprocessor file

Set up auto compilation of CSS preprocessor files
You can set up options within Dreamweaver to automatically compile changes done in a Sass or LESS file into its equivalent CSS. You can also specify the locations (within the site root) where you want to save the generated CSS.

1 In the Site Setup dialog box, select CSS Preprocessors > General > Enable Auto Compilation on File Save.

![Enabling auto compilation](image)

2 Click CSS Preprocessors > Source & Output.

3 Specify the locations where you want to save your generated CSS files. You can choose one of the following options:

   - **In the same folder as source** Select this option if you want the generated CSS files to be saved in the same folder as the source Sass and LESS files.

   - **Define output folder** Select this option and specify the folder where you want to save the generated CSS files.

   - **Replace segment of input path** This option allows you to replace a portion of the path using the From and To strings.

4 Specify the folder containing the Sass or LESS files that Dreamweaver tracks.
If you make changes to any of the files within the folder that is tracked, Dreamweaver automatically compiles the files after you save them.

![Source and output CSS preprocessor settings](image)

**Note:**

*Dreamweaver watches and compiles these files even if you make changes outside Dreamweaver (using a text editor, for example).*

After a successful compilation, a message is displayed in the **Output** panel (Window > Results > Output). The status icon in the status bar is displayed in green. To open the compiled CSS, double-click the success message in the panel.

If any errors are found, it implies that the CSS is not compiled successfully. The status icon is shown in red, and the **Output** panel lists all the errors and warnings. You can double-click an error message in the panel to quickly jump to the erroneous line in the code. The CSS file is not compiled successfully until all the errors are resolved.

**Note:**

*The **Output** panel is docked at the bottom of the workspace. If the panel is closed, click **Window > Output** panel.*

You can also toggle the **Output** panel (show/hide) using the status icon, when the status is red.

After obtaining the compiled CSS file, you can link your web page to the style sheet. When you make any changes to CSS preprocessors, the corresponding compiled CSS files are automatically updated. The web page too is autorefreshed in Live View. [Link](#)

For more information on linking your web page to the style sheet, see [Link to an external CSS style sheet](#).

**Manually compile a CSS Preprocessor file**

In some situations (such as if you have not defined a Dreamweaver site), you might want to manually compile a CSS preprocessor file.
In such scenarios, disable **Enable Auto Compilation on File Save** in the **CSS Preprocessors > General** panel of the **Site Setup** dialog.

To manually compile a CSS preprocessor, right-click the file in the **Files** panel, and click **Compile**.

![Manually compiling CSS preprocessor files through the Files panel](image)

You can also click **Tools > Compile** to compile the current file.

## How to set CSS Style preferences in Dreamweaver

CSS style preferences control how Dreamweaver writes the code that defines CSS styles. CSS styles can be written in a shorthand form that some people find easier to work with. Some older versions of browsers, however, do not correctly interpret the shorthand.

1. Select **Edit > Preferences (Windows)** or **Dreamweaver > Preferences (Macintosh)** and from the Category list select **CSS Styles**.

2. Set the CSS style options you want to apply:

   **When Creating CSS Rules Use Shorthand For**  
   Lets you select which CSS style properties Dreamweaver writes in shorthand.

   **When Editing CSS Rules Use Shorthand**  
   Controls whether Dreamweaver rewrites existing styles in shorthand.

   Select If Original Used Shorthand to leave all styles as they are.
Select According to Settings Above to rewrite styles in shorthand for the properties selected in Use Shorthand For.

**CSS prefixes**  Prefixes are added for gradients for the selected browsers.

3  Click OK.

## Move CSS rules in Dreamweaver

The CSS management features in Dreamweaver make it easy for you to move or export CSS rules to different locations. You can move rules from document to document, from the head of a document to an external style sheet, between external CSS files, and more.

**Note:**

If the rule you're trying to move conflicts with a rule in the destination style sheet, Dreamweaver displays the Rule With Same Name Exists dialog box. If you elect to move the conflicting rule, Dreamweaver places the moved rule immediately adjacent to the conflicting rule in the destination style sheet.

### Move or export CSS rules to a new style sheet

1  In Code view, select the rule or rules you want to move. Then right-click the selection and select Selection > Move CSS Rules from the context menu.

   **Note:**
   
   Partial selection of a rule will result in the relocation of the entire rule.

2  In the Move To External Style Sheet dialog box, select the new style sheet option and click OK.

3  In the Save Style Sheet File As dialog box, enter a name for the new style sheet and click Save.

   When you click Save, Dreamweaver saves a new style sheet with the rules you selected and attaches it to the current document.

### Move or export CSS rules to an existing style sheet

1  In Code view, select the rule or rules you want to move. Then right-click the selection and select Selection > Move CSS Rules from the context menu.

   **Note:**
   
   Partial selection of a rule will result in the relocation of the entire rule.

2  In the Move To External Style Sheet dialog box, select an existing style sheet from the pop-up menu or browse to an existing style sheet and click OK.

   **Note:**
   
   The pop-up menu displays all style sheets that are linked to the current document.

### Rearrange or move CSS rules by dragging

In the CSS Designer panel (All mode), select a rule and drag it rule to the desired location. You can select and drag to re-order rules within a style sheet, or move a rule to another style sheet or the document head.

**Note:**
You can move more than one rule at a time by Control-clicking (Windows) or Command-clicking (Macintosh) multiple rules to select them.

Convert inline CSS to a CSS rule in Dreamweaver

In-line styles are not recommended best practices. To make your CSS cleaner and more organized, you can convert inline styles to CSS rules that reside in the head of the document or in an external style sheet.

1. In Code view (View > Code), select the entire style attribute that contains the inline CSS you want to convert.
2. Right-click and select Selection > Convert Inline CSS to Rule.
3. In the Convert Inline CSS dialog box, enter a class name for the new rule, and then do one of the following:
   • Specify a style sheet where you want the new CSS rule to appear and click OK.
   • Select the head of the document as the location where you want the new CSS rule to appear and click OK.

Work with div tags

You can create page layouts by manually inserting div tags and applying CSS positioning styles to them. A div tag is a tag that defines logical divisions within the content of a web page. You can use div tags to center blocks of content, create column effects, create different areas of color, and much more.

If you're unfamiliar using div tags and Cascading Style Sheets (CSS) to create web pages, you can create a CSS layout based on one of the pre-designed layouts that come with Dreamweaver. If you're uncomfortable working with CSS, but are familiar with using tables, you can also try using tables.

Insert div tags

You can use div tags to create CSS layout blocks and position them in your document. This is useful if you have an existing CSS style sheet with positioning styles attached to your document. Dreamweaver enables you to quickly insert a div tag and apply existing styles to it.

1. In the Document window, place the insertion point where you want the div tag to appear.
2. Do one of the following:
   • Select Insert > HTML > Div.
   • In the HTML category of the Insert panel, click Div.
3. Set any of the following options:
   Insert Lets you select the location of the div tag and the tag name if it is not a new tag.
   Class Displays the class style currently applied to the tag. If you attached a style sheet, classes defined in that style sheet appear in the list. Use this pop-up menu to select the style you want to apply to the tag.
   ID Lets you change the name used to identify the div tag. If you attached a style sheet, IDs defined in that style sheet appear in the list. IDs for blocks that are already in your document are not listed.

Note:

Dreamweaver alerts you if you enter the same ID as another tag in your document.

New CSS Rule Opens the New CSS Rule dialog box.
4 Click OK.

The div tag appears as a box in your document with placeholder text. When you move the pointer over the edge of the box, Dreamweaver highlights it.

If the div tag is absolutely positioned, it becomes an AP element. (You can edit div tags that aren’t absolutely positioned.)

**Edit div tags**

After you insert a div tag, you can manipulate it or add content to it.

*Note:*

*Div tags that are absolutely positioned become AP elements.*

When you assign borders to div tags, or when you have CSS Layout Outlines selected, they have visible borders. (CSS Layout Outlines is selected by default in the View > Visual Aids menu.) When you move the pointer over a div tag, Dreamweaver highlights the tag. You can change the highlight color or disable highlighting.

When you select a div tag, you can view and edit rules for it using the CSS Designer. You can also add content to the div tag by simply placing your insertion point inside the div tag, and then adding content just as you would add content to a page.

1 Do one of the following to select the div tag:
   - Click the border of the div tag.
   - Click inside the div tag, and press Control+A (Windows) or Command+A (Macintosh) twice.
   - Click inside the div tag, then select the div tag from the tag selector at the bottom of the Document window.

2 Select Window > CSS Designer to open the CSS Designer panel if it is not already open.

   Rules applied to the div tag appear in the panel.

3 Make edits as necessary.

**Change the highlight color of div tags**

When you move the pointer over the edge of a div tag in Design view, Dreamweaver highlights the borders of the tag. You can enable or disable highlighting as necessary, or change the highlight color in the Preferences dialog box.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

2 Select Highlighting from the category list on the left.

3 Make either of the following changes and click OK:
   - To change the highlighting color for div tags, click the Mouse-Over color box, and then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the text box).
   - To enable or disable highlighting for div tags, select or deselect the Show checkbox for Mouse-Over.

   *Note:*

   *These options affect all objects, such as tables, that Dreamweaver highlights when you move the pointer over them.*
CSS layout blocks

You can visualize CSS layout blocks while you work in Design view. A CSS layout block is an HTML page element that you can position anywhere on your page. More specifically, a CSS layout block is either a div tag without display:inline, or any other page element that includes the display:block, position:absolute, or position:relative CSS declarations.

Following are a few examples of elements that are considered CSS layout blocks in Dreamweaver:

- A div tag
- An image with an absolute or relative position assigned to it
- An a tag with the display:block style assigned to it
- A paragraph with an absolute or relative position assigned to it

Note:

For purposes of visual rendering, CSS layout blocks do not include inline elements (that is, elements whose code falls within a line of text), or simple block elements like paragraphs.

Dreamweaver provides a number of visual aids for viewing CSS layout blocks. For example, you can enable outlines, backgrounds, and the box model for CSS layout blocks while you design. You can also view tooltips that display properties for a selected CSS layout block when you float the mouse pointer over the layout block.

The following list of CSS layout block visual aids describes what Dreamweaver renders as visible for each:

- **CSS Layout Outlines** Displays the outlines of all CSS layout blocks on the page.
- **CSS Layout Backgrounds** Displays temporarily assigned background colors for individual CSS layout blocks, and hides any other background colors or images that normally appear on the page.

Whenever you enable the visual aid to view CSS layout block backgrounds, Dreamweaver automatically assigns each CSS layout block a distinct background color. (Dreamweaver selects the colors using an algorithmic process—there is no way for you to assign the colors yourself.) The assigned colors are visually distinctive, and are designed to help you differentiate between CSS layout blocks.

- **CSS Layout Box Model** Displays the box model (that is, padding and margins) of the selected CSS layout block.

View CSS layout blocks

You can enable or disable CSS layout block visual aids as necessary. To view all CSS layout blocks, select View > Design View Options > Visual Aids.

You can enable or disable CSS Layout Backgrounds, CSS Layout Box Model, and CSS Layout Outlines.

Apply gradients to background

Using the CSS Designer panel, you can apply gradients to the background of your websites. The gradient property is available in the background category.
Click ✗ adjacent to the gradient property to open the **gradients** panel. Using this panel, you can:

- Choose colors from different color models (**RGBA**, **Hexadecimal**, or **HSLa**). Then, save different color combinations as color swatches.
  - To reset the new color to the original color, click the original color (K).
  - To change the order of the swatches, drag the swatches to the required position.
  - To delete a color swatch, drag the swatch out of the panel.
- Use color stops to create complex gradients. Click anywhere between the default color stops to create a color stop. To delete a color stop, drag the color stop out of the panel.
- Specify the angle for linear gradient.
- To repeat the pattern, edit background-repeat property.
- Save custom gradients as swatches.

Let's understand the following code:

```css
background-image: linear-gradient(57deg, rgba(255,255,255,1.00) 0%, rgba(21,8,8,1.00) 46.63%, rgba(255,0,0,1.00) 100%)
```

- **57deg**: Indicates the angle of the linear gradient
- **rgba** (255, 255, 255, 1.00): Color for the first color stop
- **0%**: Indicates color stop

**Note:**
Only '%' values for color stops are supported in Dreamweaver. If you use other values such as, px or em, Dreamweaver reads them as ‘nil’. Also, Dreamweaver does not support CSS colors and if you specify these colors in the code, such colors are read as ‘nil’.

**Rendering gradients in web browsers**

When you use gradients as background, you can configure Dreamweaver to render the gradients appropriately on different web browsers. Dreamweaver adds appropriate vendor prefixes to the code that enables web browsers to display gradients suitably.

Dreamweaver can write the following vendor prefixes along with w3c format:

- Webkit
- Firefox
- Opera

By default, Dreamweaver writes vendor prefixes for Webkit and Dreamweaver Live View. You can choose the other required vendors from the Preferences dialog box (Preferences > CSS Styles).

*Note:*

*For Box shadow, Webkit and w3c prefixes are always generated irrespective of whether you have selected them in the Preferences or not.*

Any changes to the gradients are reflected in the vendor-specific syntaxes too. If you open an existing file containing vendor-specific syntaxes in Dreamweaver, ensure that you choose the required vendor prefixes in Preferences. Because, by default, Dreamweaver updates only Webkit, and Dreamweaver Live View-related code when you use or change gradients. So, the other vendor-specific syntaxes in your code do not get updated.

**Swap background images and gradients**

You can change the order (in which they appear in the code) of the background images and gradients with a single click. Click the arrow next to the adjacent to the `url` or the `gradient` property in CSS Designer.

*Note:*

*Dreamweaver contains a basic implementation of the swap background feature. When you have multiple values or images, swap may not work as expected. Also, suppose that you have an image, second image, and then a gradient applied to the background. Swapping the gradient results in the following order: gradient, second image, first image.*

**Create and edit CSS3 transition effects in Dreamweaver**

You can create, modify, and delete CSS3 transitions using the CSS Transitions panel.

To create a CSS3 transition, create a transition class by specifying values for the transition properties of the element. If you select an element before creating a transition class, the transition class is automatically applied to the selected element.

You can choose to add the generated CSS code to the current document or specify an external CSS file.
Create and apply CSS3 transition effect

1. (Optional) Select an element (paragraph, heading, and so on) to which you want to apply the transition. Alternatively, you can create a transition and apply it later to an element.

2. Select Window > CSS Transitions.

3. Click ‣.

4. Create a transition class using the options in the New Transition dialog box.

   **Target Rule**  Enter a name for the selector. The selector can be any CSS selector such as a tag, a rule, an ID, or a compound selector. For example, if you want to add transition effects to all `<hr>` tags, enter `<hr>`

   **Transition On**  Select a state to which you want to apply the transition. For example, if you want to apply the transition when the mouse moves over the element, use the `hover` option.

   **Use the Same Transition for All Properties**  Select this option if you want to specify the same **Duration**, **Delay**, and **Timing Function** for all CSS properties that you want to transition.

   **Use a Different Transition for Each Property**  Select this option if you want to specify a different **Duration**, **Delay**, and **Timing Function** for each of CSS properties that you want to transition.

   **Property**  Click ‣ to add a CSS property to transition.

   **Duration**  Enter a duration in seconds (s) or milliseconds (ms) for the transition effect.

   **Delay**  The time, in seconds or milliseconds, before the transition effect starts.

   **Timing function**  Select a transition style from the available options.

   **End Value**  The end value for the transition effect. For example, if you want the font-size to increase to 40px at the end of the transition effect, specify 40px for the font-size property.

   **Choose Where To Create The Transition**  To embed the style in the current document, select This Document Only. If you want to create an external style sheet for the CSS3 code, select New Style Sheet File. When you click Create Transition, you are prompted for a location to save the new CSS file. After the style sheet is created, it is added to the Choose Where To Create Transition menu.

Edit CSS3 transition effects

1. In the CSS Transitions panel, select the transition effect that you want to edit.

2. Click ‣.

3. Use the Edit Transition dialog to change previously entered values for the transition.

Disable CSS shorthand for Transitions

See What is a CSS Shorthand Property? for information on CSS Shorthand, and its benefits.

1. Select Edit > Preferences.

2. Select CSS Styles.
3 In Use Shorthand For, deselect Transition.

Format code

Format code manually
1 Open a supported file.
2 Select Edit > Code > Apply Source Formatting.
   Or, select Apply Source Formatting from Common Toolbar > Format Source Code.

Format selected code in a file manually
1 Open the code.
2 Select any part of the code.
3 Select Edit > Code > Apply Source Formatting To Selection.
   Or, select Apply Source Formatting to selection from Common toolbar > Format Source Code.

Note:
If you select a code in between of any tag and apply source formatting to the selection, then formatting is applied till the parent tag.

Edit default rules for code formatting
You can customize the CSS, JS, and PHP code formatting by adding formatting rules in .jsbeautifyrc file in your site root folder.

To add the .jsbeautifyrc file, follow the steps:

Note:
• The following instructions are applicable only for CSS, JS, and PHP documents.
• HTML tags in a PHP document are formatted as per preferences in tag libraries. You can format the code within PHP blocks with below instructions.
1 Create a new file in the site root with filename as .jsbeautifyrc
2 Copy paste below default formatting rules for CSS, JS, and PHP in .jsbeautifyrc and save the file.
Edit the default rules to change the default code formatting rules as per below table and save the changes.

Relaunch Dreamweaver and apply code formatting for a CSS, JS, and PHP file.

Code is formatted as per the updated formatting rules.

Note:

If you want to customize the code formatting for PHP, CSS, and JS files in other Dreamweaver sites then you need to place the customized file .jsbeautifyrc in the site root folder.

Rules for CSS, JS, and PHP formatting:
### CSS

<table>
<thead>
<tr>
<th>Rules</th>
<th>Default values in Dreamweaver</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>preserve_newlines</td>
<td>false</td>
<td>Whether to preserve empty lines.</td>
</tr>
<tr>
<td>selector_separator_newline</td>
<td>false</td>
<td>Whether to put a newline between comma-separated selectors.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Example: &quot;div, P&quot;</td>
</tr>
<tr>
<td>end_with_newline</td>
<td>false</td>
<td>Whether to end the file with an empty line.</td>
</tr>
<tr>
<td>newline_between_rules</td>
<td>false</td>
<td>Whether to add a new line after every CSS rule.</td>
</tr>
<tr>
<td>space_around_selector_separator</td>
<td>true</td>
<td>To ensure space around selector separators: &quot;&gt;&quot;,&quot;+&quot;,&quot;~&quot;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Example: &quot;a &gt; b&quot; would become &quot;a &gt; b&quot; on applying source formatting.</td>
</tr>
</tbody>
</table>

### JS

<table>
<thead>
<tr>
<th>Rules</th>
<th>Default values in Dreamweaver</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;eol&quot;</td>
<td>&quot;\n&quot;</td>
<td>Character used to represent end of line.</td>
</tr>
<tr>
<td>preserve_newlines</td>
<td>true</td>
<td>Whether to preserve empty lines.</td>
</tr>
<tr>
<td>max_preserve_newlines</td>
<td>3</td>
<td>For &quot;max_preserve_newlines&quot;: N, N-1 empty lines are preserved on applying formatting, when more than N-1 empty lines are present in the JS file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: max_preserve_newlines is only applicable if preserve_newlines is set to true.</td>
</tr>
<tr>
<td>space_after_anon_function</td>
<td>true</td>
<td>Whether to add space before an anonymous function's parenthesis.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Example: &quot;function()&quot; would become &quot;function ()&quot; on applying source formatting.</td>
</tr>
<tr>
<td>keep_array_indentation</td>
<td>false</td>
<td>Allow or preserve newline inside array body.</td>
</tr>
<tr>
<td>space_before_conditional</td>
<td>true</td>
<td>Whether to add a space before a conditional statement</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Example: &quot;if(true)&quot; would become &quot;if (true)&quot; on applying formatting.</td>
</tr>
<tr>
<td>break_chained_methods</td>
<td>false</td>
<td>Allow or preserve newline between chained functions.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Example: 'foobar().baz()'</td>
</tr>
</tbody>
</table>
Note:

The rules for PHP formatting are same as for JS formatting (described in above table) with two additional rules given below:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>unescape_strings</td>
<td>false</td>
<td>Should printable characters in strings encoded in \xNN notation be unescaped. For Example: &quot;\x65\x78\x61\x6d\x70\x6c\x65&quot; would become &quot;example&quot; on applying source formatting.</td>
</tr>
<tr>
<td>wrap_line_length</td>
<td>0</td>
<td>Lines should wrap at next opportunity after these number of characters.</td>
</tr>
<tr>
<td>end_with_newline</td>
<td>true</td>
<td>To ensure a newline is added at the end of file.</td>
</tr>
<tr>
<td>comma_first</td>
<td>false</td>
<td>While breaking a line at comma, this flag is used to ensure comma is the first char of line.</td>
</tr>
<tr>
<td>operator_position</td>
<td>after-newline</td>
<td>If a long conditional expression is broken into multiple lines then this flag is used to define the position of operators in the lines. You can edit the flag with below values: • before-newline • after-newline • preserve-newline</td>
</tr>
<tr>
<td>PHP</td>
<td>Rules</td>
<td>Default values in Dreamweaver</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td></td>
<td>brace_style</td>
<td>collapse</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>space_in_paren</td>
<td>true</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 8: Page content and assets

Set page properties

For each page you create in Dreamweaver, you can specify layout and formatting properties using the Page Properties dialog box (File > Page Properties). The Page Properties dialog box lets you specify the default font family and font size, background color, margins, link styles, and many other aspects of page design. You can assign new page properties for each new page you create, and modify those for existing pages. Changes you make in the Page Properties dialog box apply to the entire page.

Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using CSS to set backgrounds and modify page properties.

Note:

The page properties you choose apply only to the active document. If a page uses an external CSS style sheet, Dreamweaver does not overwrite the tags set in the style sheet, as this affects all other pages using that style sheet.

Set CSS page font, background color, and background image properties

Use the Page Properties dialog box to specify several basic page layout options for your web pages, including the font, background color, and background image.

1 Select File > Page Properties, or click the Page Properties button in the text Property inspector.

2 Select the Appearance (CSS) category and set the options.

   - **Page Font** Specifies the default font family to use in your web pages. Dreamweaver uses the font family you specify unless another font is specifically set for a text element.

   - **Size** Specifies the default font size to use in your web pages. Dreamweaver uses the font size you specify unless another font size is specifically set for a text element.

   - **Text Color** Specifies the default color to render fonts with.

   - **Background Color** Sets a background color for your page. Click the Background color box and select a color from the Color Picker.

   - **Background Image** Sets a background image. Click the Browse button, then browse to and select the image. Alternatively, enter the path to the background image in the Background Image box.

Dreamweaver tiles (repeats) the background image if it does not fill the entire window, just as browsers do. (To prevent the background image from tiling, use Cascading Style Sheets to disable image tiling.)

   - **Repeat** Specifies how the background image will be displayed on the page:

      - Select the No-repeat option to display the background image only once.
      - Select the Repeat option to repeat, or tile, the image both horizontally and vertically.
      - Select the Repeat-x option to tile the image horizontally.
      - Select the Repeat-y option to tile the image vertically.
Left Margin and Right Margin Specify the size of the left and right page margins.
Top Margin and Bottom Margin Specify the size of the top and bottom page margins.

Set HTML page properties
Setting properties in this category of the Page Properties dialog box results in HTML rather than CSS formatting of your page.

1 Select File > Page Properties, or click the Page Properties button in the text Property inspector.
2 Select the Appearance (HTML) category and set the options.

Background Image Sets a background image. Click the Browse button, then browse to and select the image. Alternatively, enter the path to the background image in the Background Image box.
Dreamweaver tiles (repeats) the background image if it does not fill the entire window, just as browsers do. (To prevent the background image from tiling, use Cascading Style Sheets to disable image tiling.)

Background Sets a background color for your page. Click the Background color box and select a color from the Color Picker.

Text Specifies the default color to render fonts with.

Link Specifies the color to apply to link text.

Visited Links Specifies the color to apply to visited links.

Active Links Specifies the color to apply when a mouse (or pointer) clicks on a link

Left Margin and Right Margin Specify the size of the left and right page margins.

Top Margin and Bottom Margin Specify the size of the top and bottom page margins.

Set title and encoding properties for a page
The Title/Encoding options in Page Properties let you specify the document encoding type that is specific to the language used to author your web pages. The Title/Encoding options also let you specify which Unicode Normalization Form to use with that encoding type.

1 Do one of the following:
   • Click File > Page Properties
   • Click Window > Properties, and click Page Properties in the text Property Inspector.

2 From the Page Properties panel, select Title/Encoding. You can configure the following options:
   • Title: Specifies the page title that appears in the title bar of the Document window and most browser windows.
   • Document Type (DTD): Specifies a document type definition. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.
   • Encoding: Specifies the encoding used for characters in the document. If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see www.w3.org/TR/REC-html40/sgml/entities.html.
   • Reload: Converts the existing document, or reopens it using the new encoding.
• Unicode Normalization Form: Enabled only if you select UTF-8 as a document encoding. There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common form used in the Character Model for the World Wide Web. Adobe provides the other three Unicode Normalization Forms for completeness. In Unicode, some characters are visually similar but can be stored within the document in different ways. For example, “ë” (e-umlaut) can be represented as a single character, “e-umlaut,” or as two characters, “regular Latin e” + “combining umlaut.” A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the “Latin e.” Both forms result in the same visual typography, but what is saved in the file is different for each form. Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same form. That is, all “ë” characters in a document are saved as single “e-umlaut” or as “e” + “combining umlaut,” and not as both forms in one document. For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

• Include Unicode Signature (BOM): Includes a Byte Order Mark (BOM) in the document. A BOM is 2 to 4 bytes at the beginning of a text file that identifies a file as Unicode, and if so, the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required.

Set CSS heading properties and CSS link properties

You can specify fonts, font sizes, and colors for your page headings. By default, Dreamweaver creates CSS rules for your headings and applies them to all headings that you use on the page. The rules are embedded in the head section of the page.

To apply the CSS heading properties:

1. Do one of the following
   • Click File > Page Properties
   • Click Window > Page Properties, and click Page Properties in the text Property Inspector.

2. From the Page Properties panel, select Headings (CSS). You can configure the following options:
   • **Heading Font**: Specifies the default font family to use for headings. Dreamweaver will use the font family you specify unless another font is specifically set for a text element.
   • **Heading 1 through Heading 6**: Specify the font size and color to use for up to six levels of heading tags.

Set CSS link properties for an entire page

You can specify fonts, font sizes, colors, and other items for your links. By default, Dreamweaver creates CSS rules for your links and applies them to all links you use on the page. (The rules are embedded in the head section of the page.)

**Note:**

*If you want to customize individual links on a page, you need to create individual CSS rules, and then apply them to the links separately.*

1. Do one of the following
   • Click File > Page Properties
   • Click Window > Page Properties, and click Page Properties in the text Property Inspector.
2 From the Category option, select Links (CSS).

- **Link Fonts**: Specifies the default font family to use for link text. By default, Dreamweaver uses the font family specified for the entire page unless you specify another font.

- **Size**: Specifies the default font size to use for link text.

- **Link Color**: Specifies the color to apply to link text.

- **Visited Links**: Specifies the color to apply to visited links.

- **Rollover Links**: Specifies the color to apply when a mouse (or pointer) hovers over a link.

- **Active Links**: Specifies the color to apply when a mouse (or pointer) clicks on a link.

- **Underline Style**: Specifies the underline style to apply to links. If your page already has an underline link style defined (through an external CSS style sheet for example), the Underline Style menu defaults to a “don’t change” option. This option alerts you to a link style that has been defined. If you modify the underline link style using the Page Properties dialog box, Dreamweaver will change the previous link definition.

3

**Work with text**

**Add text to a document**

To add text to a Dreamweaver document, you can type text directly in the Document window, or you can cut and paste text. You can also import text from other documents.

When you paste text into a Dreamweaver document, you can use either the Paste or the Paste Special command. The Paste Special command lets you specify the format of pasted text in different ways. For example, if you wanted to paste text from a formatted Microsoft Word document into your Dreamweaver document, but wanted to strip out all of the formatting so that you could apply your own CSS style sheet to the pasted text, you could select the text in Word, copy it to your Clipboard, and use the Paste Special command to select the option that lets you paste text only.

When using the Paste command to paste text from other applications, you can set paste preferences as default options.

*Note:*

`Control+V (Windows) and Command+V (Macintosh) always paste text only (no formatting) in Code view.`

7 Add text to your document by doing one of the following:

- Extract text from your PSD compositions using the Extract panel. For detailed information, see Copy text from PSD files.

- Type text directly into the Document window.

- Copy text from another application, switch to Dreamweaver, position the insertion point in the Design view of the Document window, and select Edit > Paste or Edit > Paste Special.

When you select Edit > Paste Special, you can select several paste formatting options.

You can also paste text using the following keyboard shortcuts:
Insert special characters

Certain special characters are represented in HTML by a name or a number, referred to as an entity. HTML includes entity names for characters such as the copyright symbol (©), the ampersand (&), and the registered-trademark symbol (®). Each entity has both a name (such as &mdash;) and a numeric equivalent (such as &amp;#151;).

HTML uses the angle brackets <> in its code, but you may need to express the special characters for greater than or less than without Dreamweaver interpreting them as code. In this case, use &gt; for greater than (>) and &lt; for less than (<).

Unfortunately, many older browsers don’t properly display many of the named entities.

1 In the Document window, place the insertion point where you want to insert a special character.

2 Do one of the following:
   • Select the name of the character from the Insert > HTML > Character.
   • In the HTML category of the Insert panel, click the Characters option and select the character from the pop-up menu.

Note:
There are many other special characters available; to select one of them, select Insert > HTML > Character > Other..., or click the Characters button in the HTML category of the Insert panel and select the Other Characters option. Select a character from the Insert Other Character dialog box, and click OK.

Add space between characters

HTML only allows for one space between characters; to add additional space in a document you must insert a non-breaking space. You can set a preference to automatically add non-breaking spaces in a document.

Insert a non-breaking space

? Do one of the following:
   • Select Insert > HTML > Special Characters > Non-Breaking Space.
   • Press Control+Shift+Spacebar (Windows) or Option+Spacebar (Macintosh).
   • From Insert panel, select HTML, click the Characters button and select the Non-Breaking Space option.

Set a preference to add non-breaking spaces

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

2 In the General category make sure Allow Multiple Consecutive Spaces is checked.
Add paragraph spacing
Dreamweaver works similarly to many word processing applications: you press Enter (Windows) or Return (Macintosh) to create a new paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single line of space between paragraphs by inserting a line break.

Add a paragraph return
? Press Enter (Windows) or Return (Macintosh).

Add a line break
? Do one of the following:
  • Press Shift+Enter (Windows) or Shift+Return (Macintosh).
  • Select Insert > HTML > Special Characters > Line Break.
  • From the Insert panel, select HTML, click the Characters button and select Line Break.

Create bulleted and numbered lists
You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or from new text as you type in the Document window.

Definition lists do not use leading characters like bullet points or numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists that contain other lists. For example, you might want an ordered or bulleted list nested within another numbered or ordered list.

You use the List Properties dialog box to set the appearance of an entire list or for an individual list item. You can set number style, reset numbering, or set bullet style options for individual list items or for the entire list.

Create a new list
1 In the Dreamweaver document, place the insertion point where you want to add a list, then do one of the following:
   • In the HTML Property inspector, click either Ordered List or List Item.
   • Select Insert > HTML > and select the type of list desired - Unordered List (bulleted list), Ordered List (numbered list).
   The leading character for the specified list item appears in the Document window.
2 Type the list item text, then press Enter (Windows) or Return (Macintosh) to create another list item.
3 To complete the list, press Enter twice (Windows) or press Return twice (Macintosh).

Create a list using existing text
1 Select a series of paragraphs to make into a list.
2 Select Insert > HTML > Unordered List or Ordered List or List Item.

Create a nested list
1 Select the list items that you want to nest.
2 Right-click and select List > Indent.
   Dreamweaver indents the text and creates a separate list with the original list's HTML attributes.
3 Apply a new list type or style to the indented text by following the same procedure used above.
Set list properties for an entire list
1 In the Document window, create at least one list item. The new style will automatically apply to additional items you add to the list.
2 With the insertion point in the list item's text, right-click and select List > Properties. The system displays the List Properties dialog box.
3 Set the options you want to define the list:
   List Type  Specifies list properties while List Item specifies an individual item in a list. Use the pop-up menu to select a bulleted, numbered, directory, or menu list. Depending on the List Type you select different options appear in the dialog box.
   Style  Determines the style of numbers or bullets used for a numbered or bulleted list. All items in the list will have this style unless you specify a new style for items within the list.
   Start Count  Sets the value for the first item in a numbered list.
4 Click OK to set the choices.

Set list properties for a list item
1 In the Document window, place the insertion point in the text of a list item you want to affect
2 Right-click and select List > Properties.
3 Under List Item, set the options you want to define:
   New Style  Specifies a style for the selected list item. Styles in the New Style menu are related to the type of list displayed in the List Type menu. For example, if the List Item menu displays Bulleted List, only bullet options are available in the New Style menu.
   Reset Count To  Sets a specific number from which to number list item entries.
4 Click OK to set the options.

Search for and replace text
For information on finding and replacing text, see Find and replace text, tags, and attributes.

Define abbreviations and acronyms
HTML provides tags that let you define the abbreviations and acronyms you use in your page for search engines, spell checkers, language translation programs, or speech synthesizers. For example, you might want to specify that the abbreviation ME in your page stands for mechanical engineer, or the acronym WHO stands for World Health Organization.
1 Select the abbreviation or acronym in the text of your page.
2 Select Insert > HTML > Text Objects > Abbreviation, or Insert > HTML > Text Objects > Acronym.
3 Enter the full text of the acronym or abbreviation.
4 Enter the language, such as en for English, de for German, or it for Italian.

Set copy and paste preferences
You can set special paste preferences as default options when using Edit > Paste to paste text from other applications. For example, if you always want to paste text as text only, or text with basic formatting, you can set the default option in the Copy/Paste Preferences dialog box.
When you paste text into a Dreamweaver document, you can use either the Paste or the Paste Special command. The Paste Special command lets you specify the format of pasted text in different ways. For example, if you wanted to paste text from a formatted Microsoft Word document into your Dreamweaver document, but wanted to strip out all of the formatting so that you could apply your own CSS style sheet to the pasted text, you could select the text in Word, copy it to your Clipboard, and use the Paste Special command to select the option that lets you paste text only.

Preferences set in the Copy/Paste Preferences dialog box apply only to material pasted into Design view.

1 Select Edit > Preferences (Windows) or Dreamweaver Preferences (Macintosh).
2 Click the Copy/Paste category.
3 Set the following options and click OK.

- **Text Only**  Lets you paste unformatted text. If the original text is formatted, all formatting, including line breaks and paragraphs, will be removed.

- **Text With Structure**  Lets you paste text that retains structure, but does not retain basic formatting. For example, you can paste text and retain the structure of paragraphs, lists, and tables, without retaining bold, italics, and other formatting.

- **Text With Structure Plus Basic Formatting**  Lets you paste both structured and simple HTML-formatted text (e.g., paragraphs and tables, as well as text formatted with the \texttt{b}, \texttt{i}, \texttt{u}, \texttt{strong}, \texttt{em}, \texttt{hr}, \texttt{abbr}, or \texttt{acronym} tag).

- **Text With Structure Plus Full Formatting**  Lets you paste text that retains all structure, HTML formatting, and CSS styles.

**Note:**

The Full Formatting option cannot retain CSS styles that come from an external style sheet, nor can it retain styles if the application from which you are pasting does not retain styles upon pasting to the Clipboard.

- **Retain Line Breaks**  Lets you keep line breaks in pasted text. This option is disabled if you have selected Text Only.

- **Clean Up Word Paragraph Spacing**  Select this option if you selected Text With Structure or Text With Structure Plus Basic Formatting, and want to eliminate extra space between paragraphs when you paste your text.

- **Convert smart quotes to straight quotes** Converts smart quotes to straight quotes.

### Find and replace text, tags, and attributes

Use Dreamweaver’s powerful find and replace features to find and replace code, text, or tags (with or without attributes) within a current document, folder, site, or across all open documents.

You can also use powerful pattern-matching algorithms (regular expressions) for sophisticated find-and-replace operations.

Here are some of the things you can find and replace:

- Tags, attributes, and text within code
- Text within a selection, or multiple selections
- Text across multiple documents, open documents, a folder, a site, or restrict the search to the currently open document
• Use regular expressions in your search strings

You can search for text, tags, and attributes even if there is no open document in Dreamweaver.

**Find and replace text in the current document**

1. In an open document, click **Find > Find in Current Document**, or press Ctrl + F (on Windows), or Cmd+F (on Mac) to open the Quick Find bar docked at the bottom of your current document.

   If you want to also replace text, click **Find > Replace in Current Document**, or press Ctrl + H (on Windows), or Cmd + Alt + F (on Mac) to open the Quick Find and Replace bar.

2. In the Find field, type in the text you are looking to find in the current document.

   As you type, Dreamweaver automatically highlights all instances of the search string in the current document.

   ![](Finding text in current document.png)

   *Note:*

   Dreamweaver displays the number of instances of the found text in the Quick Find and Replace bar, and you can navigate through the results by using the **Previous** and **Next** arrows.
3 Use the following filters to expand or limit your search:

- **Match Case**: Limits the search to code/tag/text that exactly matches the case of the text you want to find. For example, if you search for the brown derby, you will not find The Brown Derby.

- **Use Regular Expressions**: Causes certain characters and short strings (such as ?, *, \w, and \b) in your search string to be interpreted as regular expression operators. For example, a search for the b\w\*b dog will match both the black dog and the barking dog.

- **Match Whole Word**: Limits the search to text that matches one or more complete words

- **Ignore White Spaces**: Treats all whitespace as a single space for the purposes of matching. For example, with this option selected, "this text" would match "this text" but not "thistext". This option is not available when the Use Regular Expressions option is selected; you must explicitly write your regular expression to ignore whitespace. Tags do not count as whitespace.

- **Find in Selected Text**: Confines the search to the text that’s currently selected in the active document. The selected text can be a single block of text, or multiple selections of text in different places in the currently opened document. When you are searching within selected text, the found search terms are not highlighted in the document. Click **Find All** to display the search results in the Search panel.

4 To replace found text or tags, type in the Replace field, then click **Replace** or **Replace All**.

To walk through the found instances of the page, and replace them individually, click **Replace**, and use the next and previous arrows to navigate to other instances of the search term within the document.

To replace all instances of the search term instantly, click **Replace All**. Dreamweaver replaces all the found instances, and provides a report of all the terms found and replaced.
Find and replace across multiple documents

You can find all search terms across multiple documents, within the folder, or within your site.

1 Select Find > Find and Replace in Files or press Ctrl + Shift + F (on Windows), or Cmd + Shift + F (on Mac) to open the Find and Replace dialog box.

   Note:

   When Find and Replace in Files is opened for the first time, the Search in Entire Current Local Site is the default option. If you make a different selection, Dreamweaver remembers your selection and makes your selected option the default option.

2 Type in the text in the Find text field and select any of the following options in the drop-down list:
   - Current Document - Dreamweaver searches for the specified phrase in the document that is currently in focus.
   - Open Documents - Dreamweaver searches for the specified phrase in all open documents.
   - Folder - Dreamweaver searches for the specified phrase in all the files located within the specified folder.
   - Selected Files in Site - Dreamweaver searches for the specified phrase in files that are selected from a site in the Files panel.
   - Entire Current Local Site - Dreamweaver searches for the specified phrase in the current site that you are working on.

3 Use the following filters to expand or limit your search:
   - Match Case: Limits the search to text that exactly matches the case of the text you want to find. For example, if you search for the brown derby, you will not find The Brown Derby.
• **Use Regular Expressions:** Causes certain characters and short strings (such as ?, *, \w, and \b) in your search string to be interpreted as regular expression operators. For example, a search for the b\w*\b dog will match both the black dog and the barking dog.

• **Match Whole Word:** Limits the search to text that matches one or more complete words

• **Ignore White Spaces:** Treats all whitespace as a single space for the purposes of matching. For example, with this option selected, "this text" would match "this text" but not "thistext". This option is not available when the Use Regular Expressions option is selected; you must explicitly write your regular expression to ignore whitespace. Tags do not count as whitespace.

• **Search Text Only:** Searches for specific text strings in the text of the document. A text search ignores any HTML that interrupts the string. For example, a search for "head" would match instances of head in the text only. The search ignores all instances of <head> and </head>.

**Note:**

*The Search Text Only filter is disabled in the Advanced tab in the Find and Replace dialog.*

4 Do one of the following:

• To find all instances of the specified text, select **Find All**. Dreamweaver opens the Search Results panel. If you are searching a single document, **Find All** displays all occurrences of the search text or tags, with some surrounding context. If you are searching a directory or site, **Find All** displays a list of documents that contain the tag.

• To replace found text or tags, type in text in the Replace field, and click **Replace** or **Replace All**.

• To walk through the found instances of the page, and replace them individually, click **Replace**, and use the next and previous arrows to navigate to other instances of the search term.

• To replace all instances of the search term instantly, click **Replace All**. Dreamweaver replaces all the found instances, and provides a report of all the terms found and replaced in the **Search Results** panel.

• To first see the Find results before replacing them, select **Replace All** and **Exceptions**. When this option is specified, the Find results are displayed in the Search Results panel. You can then deselect the instances you do not want to be replaced.

Double-click a search result in the Search Results panel and Dreamweaver navigates to its location and places the cursor at the location of the text.
Find and replace tags, attributes, and text in code

You can search for specific tags, attributes, and attribute values. For example, you can search for all img tags that have no Alt attribute.

You can also search for specific text strings that are within or not within a set of container tags. For example, you can search for the word Untitled contained in a title tag to find all the untyped pages on your site.

Find and replace tags, attributes, and text in code within the currently open document

1. Open the document to search in. Then select Find > Find in Current Document.

2. To search for specific text within a tag, type the text string in the Find field, and select a tag from the drop-down field next to it.

Dreamweaver highlights all instances of the specified text within the specified tags on the page being searched.

Find and replace tags, attributes, and text in code across several documents:

1. Select Find > Find and Replace in Files or press Ctrl + Shift + F (on Windows), or Cmd + Shift + F (on Mac) to open the Find and Replace dialog box.

2. In the Advanced tab, select one of the following Find in options:
   - **Current Document** - Dreamweaver searches for the specified phrase in the document that is currently open
   - **Open Documents** - Dreamweaver searches for the specified phrase in all open documents
   - **Folder** - Dreamweaver searches for the specified phrase in all the files located within the specified folder
   - **Selected Files in Site** - Dreamweaver searches for the specified phrase in files that are selected in the Files panel.
   - **Entire Current Local Site** - Dreamweaver searches for the specified phrase in the current site that you are working on.
3 Type in the search parameters, and the required action.

4 Do one of the following:
   
   - To find all instances of the specified text, select **Find All**. Dreamweaver opens the Search Results panel. If you are searching a single document, **Find All** displays all occurrences of the search text or tags, with some surrounding context. If you are searching a directory or site, **Find All** displays a list of documents that contain the tag.
   
   - To replace found text or tags, type in text in the **Replace** field, and click **Replace** or **Replace All**.
   
   - To walk through the found instances of the page, and replace them individually, click **Replace**, and use the next and previous arrows to navigate to other instances of the search term.
   
   - To replace all instances of the search term instantly, click **Replace All**. Dreamweaver replaces all the found instances, and provides a report of all the terms found and replaced in the Search Results panel.
   
   - To first see the Find results before replacing them, select **Replace All** and **Exceptions**. When this option is specified, the Find results are displayed in the Search Results panel. You can then deselect the instances you do not want to be replaced.

Double-click a search result in the Search Results panel and Dreamweaver navigates to its location and places the cursor at the location of the text.

**View search results**

To view search results:

1 Select **Window > Results > Search** to display the search results within the Search panel.

2 Double-click a search result in the Search panel to view that instance within your document.

3 Right-click the icon at the top of the Search panel to open the pop-up menu that provides more options for checking in and checking out files (if you are using a version control system), do more find and replace operations, clear search results, or close the Search panel.
Additional options within the Search results panel

Save and load search queries

Select **Find > Find and Replace**.

To save queries, click the Save icon as shown in the **Find and Replace** dialog and choose the destination to save the file as .dwr file.

To load queries, click the Load icon and choose the .dwr query file from your computer.

For Dreamweaver 2017 and 2018 versions

By default, saving and loading search queries is not enabled in Dreamweaver 2017 and 2018 versions. However, if you really need to be able to save and load search queries, then complete the following steps to enable this feature.

1. Make sure you have Dreamweaver 2017.1 installed. Open Dreamweaver and use the Advanced Find and Replace dialog at least once, and then close Dreamweaver.
2 On Windows:
   a  Open the Registry Editor - In the Start Menu, either in the Run Box or the Search box, type regedit and press Enter.
   b  Navigate to the following location: HKEY_CURRENT_USER\SOFTWARE\Adobe\Dreamweaver CC 2017\Advanced Find And Replace
   c  Right click and create a new string value with ShowHiddenOptions=TRUE.
   d  Close the Registry Editor.

   Note:
   If you cannot find Advanced Find and Replace in your Windows Registry Editor, clear your Dreamweaver preferences, and open Dreamweaver again.

On Mac:
   e  Use Finder to navigate to ~/Library/Preferences.
   f  Open Adobe Dreamweaver CC 2017 Prefs using a text editor.
   g  Find the [Advanced Find and Replace] section and add showhiddenoptions=TRUE.
   h  Save and close the file.

3 Right-click and create a string value with ShowHiddenOptions.
4 Add the value data as TRUE.
5 Close the Registry Editor.

DOM panel

The DOM panel renders an interactive HTML tree for static and dynamic content. This view helps you visually map elements in Live View with their HTML markup and the applied selectors in CSS Designer. You can also make edits to the HTML structure in the DOM panel and see the changes take effect instantly in Live View.

To open the DOM panel, select Window > DOM. You can also use the keyboard keys - Ctrl + / (Win); Cmd + / (Mac) - to open the DOM panel.

When you drag elements to directly insert them in Live View, the </> icon appears before you drop the element. You can click this icon to open the DOM panel and insert the element at the appropriate position in the document structure. For more information, see Insert elements directly in Live View.

The DOM panel displays only static elements in Code or Design view, and both static and dynamic elements in Live view.

In fluid grid documents, the DOM panel only lets you visualize the HTML DOM structure and does not let you edit the HTML structure.

   Note:
   You can edit only the static content in the DOM panel. Read-only or dynamic elements are shown in a darker shade of grey.
You can move around the DOM panel and place it at any convenient location on the user interface. You can also dock the panel along with other panels.

**How to use the DOM panel**

1. Open the required document and then open the DOM panel by selecting Window > DOM.
2 Switch to Live view and click the element that you want to inspect or edit.
   • The HTML markup of the selected element is highlighted in the DOM panel.
   • The applied selector is highlighted in CSS Designer.
   • The relevant code is highlighted in the Code view.
   • The relevant tag is highlighted (in blue) in Tag Selector.
Alternatively, you can select an HTML element in the DOM panel. When you click any element in the DOM panel:
   • Live View scrolls to the corresponding element.
   • If Code View is open, the Code View scrolls to the code corresponding to the element.
   • CSS Designer (Selectors pane) scrolls to the closest corresponding selector (similar to you clicking the element in Live View).
   • The tag is highlighted in the Tag Selector.
This syncing between different views and CSS Designer lets you visualize the HTML markup and styling associated with the selected element at a glance.

3 Proceed to edit the element as required (HTML or CSS editing). For information on using the DOM panel to edit the HTML markup, see Edit HTML structure using the DOM panel. For information on CSS Designer, see Laying out pages using CSS Designer.

Edit HTML structure using the DOM panel
The current selected element on the page is highlighted in the DOM panel. You can navigate to any node or element using the arrow keys.
   • To select an element or a node, click the element or node. To expand or collapse an element or a node, click the HTML tag or double-click the selector adjacent to the tag.
   • To duplicate an element or a node, right-click the element or the node, and click Duplicate. When you duplicate an element with an ID associated with it, the ID is incremented for the new (duplicate) element.
   • To copy an element or a node, right-click the element or the node, and click Copy. If you have copied an element with children, the child elements are also copied.
   • To paste an element or a node, click the element or the node under which you want to nest the copied elements. Then, right-click the element or the node and click Paste.
   • To paste the copied element as a child of a specific element or node, right-click the element or node (parent), and then click Paste As Child.
   • To move or rearrange elements, drag the element to the required location within the DOM panel.
A green line appears to indicate where the dragged element will be positioned. If you drop the element over the element highlighted in gray (reference element), then the dropped element is positioned as the first child of the reference element.
   • To delete an element or a node, right-click the element or the node, and click Delete.
You can undo (Ctrl/Cmd + Z) or redo (Ctrl/Cmd + Y) the operations that you perform in the DOM panel.

Keyboard shortcuts:
   • Duplicate - Ctrl + D (Win)/Cmd + D (Mac)
   • Delete - Del or Backspace
• **Copy** - Ctrl + C (Win)/Cmd + C (Mac)
• **Paste** - Ctrl + V (Win)/Cmd + V (Mac)
• **Undo** - Ctrl + Z (Win)/Cmd + Z (Mac)
• **Redo** - Ctrl + Y (Win)/Cmd + Y (Mac)

To perform the above mentioned editing operations on multiple elements, select multiple elements in the DOM panel:

- Shift + click the required elements for contiguous selection
- Ctrl + click the required elements for non-contiguous selection

**Note:**

Typically, when a page is edited, the Refresh button in the Document toolbar changes to Stop button indicating that the page is reloading. After the page is reloaded, the Refresh button appears again to indicate that the page has completely loaded.
Important: If your page contains JavaScript, the right-click menu in the DOM panel gets displayed for a while and then becomes unavailable. To use the right-click menu, hide the Live View displays (Live View options > Hide Live View Displays), and then disable JavaScript (Live View options > Disable JavaScript).

Edit tags, classes, and IDs in DOM panel
You can edit tags, classes, and IDs by double-clicking them in the DOM panel. You can also add additional classes or IDs by separating them with a space. For tags that are not associated with a class or ID, you can type the name of the class or ID after double-clicking the tag.
Code hints appear as you begin typing the tag, class, or ID name. To narrow down the hints to classes, begin typing with a dot. To see only the IDs in the hints, begin typing with a hash (#).

**Insert elements in DOM panel**

You can now insert new elements into your web page using the DOM panel in one of the following ways:

- Press the Spacebar or click the insert icon adjacent to the required element in the DOM panel. In the pop-up that appears, click one of the options. To wrap multiple elements with a tag, select the required elements and then choose Wrap Tag from the insert options.
A placeholder div tag is inserted and displayed in the editing mode. You can type the required tag name in place of the div tag.

- Click the required element in the Insert panel and drag it to the DOM panel. Live Guides appear to indicate where the element will be inserted. Drop the element at the required location.
When you insert tags using the DOM panel, default (placeholder) text and required attributes for the tags are also inserted:

- When you insert any of the following tags and commit changes, default text is inserted in Code, Live, and Design view: `div`, `header`, `nav`, `aside`, `article`, `section`, `footer`, `h1-h6`, and `hgroup`
- When you insert a `table` tag and commit the changes, a 3X3 table is inserted.
- When you insert an `embed` or `img` tag and commit the changes, the Select File dialog box appears and prompts you to select an appropriate file.
- When you insert a meta tag and commit the changes, the following code is added in Code view: `<meta name="" content="">`
- When you insert a `figure` tag and commit the changes, a `figure` tag with nested `figcaption` is inserted.
- When you insert an `ul` or an `ol` tag and commit the changes, an `ol/ul` tag with nested `li` tag is inserted.

**Edit in Live View**

Live View uses a chromium-based rendering engine so that your content looks the same in Dreamweaver as it looks in your favourite web browsers. During development, you can switch to Live View to quickly preview your page. And, to save time switching between different views (code and design view), you can edit HTML elements directly within Live View.

Live View refreshes instantly to show the changes on the page.

You can use the following components to edit your page in Live View:

- **DOM panel**: (Window > DOM) Shows the HTML structure of your document and lets you copy-paste, duplicate, delete, and rearrange the elements within the view. See DOM panel for more information.
- **Element Display**: Appears above the selected HTML element in Live View. Element Display lets you associate HTML elements with classes and IDs. See Associate HTML elements with classes and IDs for more information.
- **Quick Property Inspector**: Appears when you click the Sandwich icon in Element Display or select text. Quick Property Inspector lets you edit image attributes and format text in Live View. See Quick Property Inspector for more information.
- **Live View Property Inspector**: Appears below the Document window and lets you edit various HTML and CSS properties in Live View. See Live View Property Inspector for more information.
- **Insert panel**: (Window > Insert) Lets you drag elements from the panel directly into Live View. See Insert elements directly in Live View for more information.

**Note:**

*If your page changes dynamically (because of scripts) or has metarefresh enabled, then the edits that you do in Live View may be lost.*

**Tips:**

- If Live View goes blank when you are editing the page, switch off Live View and switch it on again.
- If you do not see the edits reflected on the page, click the refresh button in Live View.

Content that is rendered dynamically through databases or JavaScript, and non-editable regions in templates cannot be edited in Live View. When you click such elements in Live View, a grey border appears around them to indicate that the elements cannot be edited.
An element with a gray border in Live View cannot be edited

Note:

In Live View, only those options that are applicable for the selected element are made available in the main menu. Options that are not applicable are greyed out when the element is selected.

Element Display

Using Element Display, you can associate HTML elements with classes and IDs directly in Live View. The Element Display hints you with the available classes and IDs to help you quickly view and choose the required option.

You can also format tables using Element Display. For more information, see link.

Associate HTML elements with classes and IDs

Click the required element in Live View. The Element Display appears and displays the currently associated class and ID.

While in Live View, you can also click the HTML element in the DOM panel to see the Element Display for the element.

The Element Display for the element

- To dissociate the HTML element from a class or ID, click ‘x’ adjacent to the class or ID.
- To change the class or ID associated with the HTML element, click in the box. A list of available classes and IDs appears. Click the required option.
- To add a class or an ID and apply it to the element, click ‘+’, and type in the name. To save the changes, click ‘+’ or press Enter.

You can then use the CSS Designer to define a selector that includes this class or ID. For more information, see Laying out pages using CSS Designer.

Note:
Element Display of transitional elements does not move along with the elements when the transition is triggered. However, the changes that you make using the Element Display take effect even though it is not at the same location as the transitional element.

Quick Property Inspector

Quick Property Inspector for images
Quick Property Inspector appears right above the selected elements in Live View. Using this Property Inspector, you can edit attributes, or format text in Live View.

Quick Property Inspector that appears right above the page elements in Live view

To show or hide Quick Property Inspector, press Ctrl+Alt+H (Win)/CMD+Ctrl+H (Mac).

Note:
Code navigator icon is not displayed in Live View when you use Quick Property Inspector.

In Bootstrap documents, the Quick Property Inspector also includes options to customize images.
Quick Property Inspector for images in Bootstrap documents

- **Clip to Shape**: Click to clip the corners of images to circular or rounded corners, or as a thumbnail image.
- **Make image responsive**: Click to make images responsive and adapt to various screen sizes.

**Quick Property Inspector for text**
Quick Property Inspector for text in Live view lets you quickly format, indent, and hyperlink text. The Quick Property Inspector for text appears when you click the sandwich icon for text elements: h1-h6, pre, and p.

- The format option allows you to quickly change the element tag to one of these tags: h1-h6, p, and pre.
- The link option helps you hyperlink the text element.
- The icons for Bold and Italic help you add `<strong>` and `<em>` tags to the text element.
- The indentation icons help you add or remove text indentation. `<blockquote>` tag is added or removed from the code accordingly.

In Bootstrap documents, the Quick Property Inspector for text also lets you align and transform the text elements.
- **Align**: Aligns Bootstrap text elements to left, center, right, or justify by applying the corresponding classes.
• **Transform**: Changes the text casing of an element by applying classes for lowercase, uppercase, or sentence case.

**Live View Property Inspector**

Live View Property Inspector is the traditional Property Inspector that is available below the Document window.

The Live View Property Inspector lets you examine and edit the most common properties for the currently selected page element, such as text or an inserted object. The contents of the Live View Property Inspector vary depending on the element selected.

**Note:**

*Live View Property Inspector is not available in Fluid Grid pages.*

To access Help for a particular Property Inspector, click the Help button in the upper right corner of the Property Inspector. Or, select Help from a Property Inspector’s Options menu.
The following are the elements that you can edit using Live View Property Inspector:

- HTML
- CSS
- Image
- Table
- Media - only HTML5 Audio and HTML5 Video
- Anchor
- Form
- FormButton
- FormTextArea
- FormSubmitButton
- FormRange
- FormRadioButton
- FormList
- FormImage
- FormFile
- FormCheckBox
- FormColor
- FormDate
- FormDateTime
- FormDateTimeLocal
- FormMonth
- FormTime
- FormWeek
- FormNumber
- FormLabel
- FormHidden
- FormGeneric

**Note:**

jQuery UI and template-related properties are not available for editing in the Live View Property Inspector.

**Edit HTML attributes**

You can quickly add, edit, or remove HTML attributes of images directly in Live View using the Quick Property Inspector.

The Quick Property Inspector for images appears when you click the sandwich icon ⬇️. Depending on the space available, the Property Inspector appears on the right, left, top, bottom, or above the image. You can move around the Property Inspector and place it at any convenient position.
To edit the attributes, click the sandwich icon in the Quick Property Inspector. You can change the source of the image along with other attributes such as “title” and “alt”, and the changes are reflected instantaneously. Similarly you can also adjust the Width and Height of the image in Live View.

The changes that you make are saved when you do any of the following:

- Click anywhere outside the Property Inspector
- Press Enter
- Press Tab to edit another attribute in the Property Inspector
- Save the file

When images are loaded dynamically, you can use the Quick Property Inspector of the image to quickly inspect the attributes that are set for the image.

**Edit text directly in Live View**

You can now edit text elements directly in Live View. You can simply click the text element to edit it. If you are in Element Display mode press Enter to edit the text.

**Note:**

When you press Enter after entering into the edit mode, the results vary depending on where the insertion point was before you pressed Enter. The changes are similar to what happens when you press Enter while editing text in Design View.

The orange border around the text element indicates that the mode is changed to edit mode.
Feature Description

An orange border indicates edit mode

The insertion point is placed where you click. To select all the text in the text element, triple-click the text element. Cut, copy-paste, and undo-redo are supported while you edit text in Live View. When you paste text, it is pasted as plain text.

Auto-sync feature allows any edits made in live view automatically synchronize with code view.

The following table lists the supported and unsupported scenarios during text editing in Live View:

<table>
<thead>
<tr>
<th>Supported</th>
<th>Not supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>All HTML elements that can contain text and semantic tags</td>
<td>Editing of invalid or broken tags. If the HTML contains broken or invalid</td>
</tr>
<tr>
<td></td>
<td>tags, then editing of such tags is governed by the way browsers perceive these tags:</td>
</tr>
<tr>
<td></td>
<td>• If browsers fix your HTML for you such that it closes the broken tag, then you may be allowed to edit the tags in Live View.</td>
</tr>
<tr>
<td></td>
<td>• If browsers add a new tag while rendering, then you cannot edit the broken or invalid tags.</td>
</tr>
<tr>
<td>HTML files derived from templates in Live View</td>
<td>Editing of jQuery Pages</td>
</tr>
<tr>
<td>Structural tags containing inline elements. They are presented together in a single box for editing.</td>
<td>Editing of tags that have both static and dynamic content. While you can edit the selectors for such tags, you cannot edit text directly in Live View. If you double-click such elements in Live View, a grey border appears around them, indicating that text editing is not supported.</td>
</tr>
<tr>
<td>Static text in dynamic pages</td>
<td></td>
</tr>
<tr>
<td>Text containing entities</td>
<td></td>
</tr>
</tbody>
</table>

Format text

You can now change the formatting of text and hyperlink text directly in Live View. To see the text formatting options, select a word or a phrase. The Quick Property Inspector with formatting options appears just above the selected text.
Quick Property Inspector for formatting text

**Insert elements directly in Live View**

Using the **Insert** panel, you can directly drag elements into the required position in the document in **Live View**. Visual aids in Live View such as Live Guides and DOM icons help you position the dragged elements with respect to a hovered element.

Live Guides (in green) appear as you hover the mouse over different elements on the page before dropping the element. These guides indicate the positions where the element can be inserted. They can appear above, below, left, or to the right of the element that is hovered over.

- **Above and Below** - Appears while hovering over all types of elements/tags, except inline tags. When you hover the mouse in the first (top) 50% of the element, guides appear above the hovered element. When you hover the mouse in the last (bottom) 50% of the element, guides appear below the hovered element.

- **Left and Right** - Appears while hovering over inline tags, for example, `<a>`, `<span>`, or over tags that have the ’float property’ set.
When you pause for a while before dropping the element, the DOM icon (</>) appears. When you hover your mouse over this icon, the DOM panel opens and you can drop the element inside the DOM structure of the document.

To insert elements directly in Live View, perform the following steps:

1. **Switch to Live View.**
2. **From the Insert panel, click the required element and drag it into the document.** Alternatively, you can just click the required element in the Insert panel.
   
   **Tip:** If you are unable to drag an element from the Insert panel on to the page, restart your computer and try again.
3. **Drop the element at the top, bottom, right or left of an element based on Live Guides.** Or, drop the element at a precise place in the document structure by clicking </> and using the DOM panel.

   The element gets inserted into the page and is highlighted.

**Marquee selection**

Marquee selection allows you to easily select a block of text by clicking and dragging inside the tag in Live View. When you click and drag a block of text in Dreamweaver releases prior to 2014.1, the element used to move as a whole.

**Note:**

Marquee selection in live view is restricted to browser-supported operations.

**Selection and dragging-and-dropping of elements**

In Live View, you can move an element by clicking on the tag name and then dragging to the desired location. When you click on a tag name, a hand cursor icon appears indicating that you can drag the tag from the point. When you start dragging the tag, guides help you place it in the precise location.

By clicking on the tag name in Live View, you can select the full contents of that tag in Code View.

**Inspect code in Live view**

Inspect mode works together with Live View to help you quickly identify HTML elements and their associated CSS styles. With Inspect mode turned on, you can hover over elements on your page to see the CSS box model attributes for any block-level element.

In addition to seeing a visual representation of the box model in Inspect mode, you can also use the CSS Designer as you hover over elements in Live View. When you have the CSS Designer open in Current mode and hover over an element on the page, the rules and properties in the CSS Designer automatically update to show you the rules and properties for that element.
Additionally, any view or panel related to the element you’re hovering over updates as well (for example, Code view, the Tag selector, the Property inspector, and so on).

1 With your document open in the document window, click View > Inspect.

   **Note:**

   *If you’re not already in Live view, Inspect mode automatically enables it.*

2 Hover over elements on the page to see the CSS box model. Inspect mode highlights different colors for the border, margin, padding, and content.

3 (Optional) Press the left arrow on your computer keyboard to highlight the parent of the currently highlighted element. Press the right arrow to return to highlighting for the child element.

4 (Optional) Click an element to lock a highlight selection.

   **Note:**

   *Clicking an element to lock a highlight selection turns off Inspect mode.*

**Keyboard navigation in Live View**

You can traverse page elements or selectors in Element Display using your keyboard to quicken the editing process.

**Traverse page elements**

Up and Down arrow keys help you traverse page elements in Live View. The traversal is based on the DOM structure of the document.

Keyboard navigation in Live View facilitates easy access to nested and wrapped elements.

When you access an element using the up or down arrow key, the Element Display for that element appears. You can then navigate to the selectors in the Element Display or press Enter to edit the text directly in Live View.

Here the image is in focus first. When the down arrow key is pressed, the paragraph below the image is selected as shown in the next image.
The text in bold format is selected.

The paragraph is selected here. When you press the down arrow key again, the next element in the DOM structure, the text in bold format, is selected as shown in the next image.

**Traverse selectors**

Press the Tab key to traverse through the selectors in Element Display. The selector in focus is displayed with an amber border as shown below:

The selector in focus is highlighted with an amber border.

If you press the Tab key after the last applied selector, the add selector text box appears.

💡

You can use Ctrl+[ or Cmd+[ to select the parent element and Ctrl+] or Cmd+] to select the child element.

**Disable editing in Live View**

If you prefer not to use Element Display and Quick Property Inspector in Live View, you can disable these editing features.
Keyboard shortcuts:
- (Win) Ctrl+Alt+H
- (Mac) Cmd+Ctrl+H
1. Switch to Live View and click View > Live View Options.
2. Select Hide Live View Displays.

Unsupported scenarios
- Dreaweaver template files cannot be edited in Live View.
- Tags that have both static and dynamic content. While you can edit the selectors for such tags, you cannot edit text in Live View. If you double-click such elements in Live View, a grey border appears around them, indicating that text editing is not supported.
- Tags that have pseudo selectors applied to them. You may encounter unexpected results when you try to edit such elements in Live View.
- CSS Grids are supported in Live View only in Dreamweaver 2019 and later versions.

Encoding documents in Dreamweaver

Document encoding specifies the encoding used for characters in a document. Document encoding is specified in a meta tag in the head of the document. Document encoding tells the browser and Dreamweaver how the document should be decoded and what fonts should be used to display the decoded text.

For example, if you specify Western European (Latin1), the following meta tag is inserted:

```
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
```

Dreamweaver displays the document using the fonts that you specify in Fonts Preferences for the Western European (Latin1) encoding. A browser displays the document using the fonts the browser user specifies for the Western European (Latin1) encoding.

If you specify Japanese (Shift JIS), the following meta tag is inserted:

```
<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">
```

Dreamweaver displays the document using the fonts that you specify for the Japanese encoding. Browsers display the document using the fonts that the browser user specifies for the Japanese encodings.

You can change document encoding for a page and change the default encoding that Dreamweaver uses to create new documents, including the fonts used to display each encoding.

Select and view elements in the Document window

To select an element in the Design view of the Document window, click the element. If an element is invisible, you must make it visible before you can select it.

Some HTML code do not have a visible representation in a browser. For example, comment tags don’t appear in browsers. However, it can be useful while you're creating a page to be able to select, edit, move, and delete invisible elements.
Dreamweaver enables you to specify whether to display icons marking the location of invisible elements in the Design view of the Document window. To indicate which element markers appear, you can set options in Invisible Elements preferences. For example, you can specify that named anchors be visible, but not line breaks.

You can create certain invisible elements (such as comments and named anchors) and modify these elements using Preferences > Invisible Elements dialog box.

**Select elements**

- To select a visible element in the Document window, click the element or drag across the element.
- To select an invisible element, from the Design View, select View > Design View Options > Visual Aids > Invisible Elements (if that menu item isn’t already selected) and then click the element’s marker in the Document window.

Some objects appear on the page in a place other than where their code is inserted. For example, in Design view an absolutely-positioned element (AP element) can be anywhere on the page, but in Code view the code defining the AP element is in a fixed location. When invisible elements are showing, Dreamweaver displays markers in the Document window to show the location of the code for such elements. Selecting a marker selects the entire element; for example, selecting the marker for an AP element selects the entire AP element.

- To select a complete tag (including its contents, if any), click a tag in the tag selector at the lower left of the Document window. (The tag selector appears in both Design view and Code view.) The tag selector always shows the tags that contain the current selection or insertion point. The leftmost tag is the outermost tag containing the current selection or insertion point, The leftmost tag is the outermost tag containing the current selection or insertion point, The next tag is contained in that outermost tag, and so on; the rightmost tag is the innermost one that contains the current selection or insertion point.

**View HTML Code**

To view the HTML code associated with the selected text or object, do one of the following:

- In the Document toolbar, click Code.
- Select View > Code.
- Select Window > Code Inspector.

When you select something in either code editor (Code view or the Code inspector), it's generally also selected in the Document window. You may need to synchronize the two views before the selection appears.

**Show or hide marker icons for invisible elements**

Select View > Design View Options > Visual Aids > Invisible Elements.

*Note:*

*Showing invisible elements may slightly change the layout of a page, moving other elements by a few pixels, so for precision layout, hide the invisible elements.*

**Set invisible elements preferences**

Use Invisible Elements preferences to specify which kinds of elements will be visible when you select View > Visual Aids > Invisible Elements.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), then click Invisible Elements.
2. Select which elements should be made visible and click OK.
**Note:**

A check mark next to the name of the element in the dialog box means the element is visible when View > Visual Aids > Invisible Elements is selected.

**Named Anchors** Displays an icon that marks the location of each named anchor (a name = "") in the document.

**Scripts** Displays an icon that marks the location of JavaScript or VBScript code in the body of the document. Select the icon to edit the script in the Property inspector or to link to an external script file.

**Comments** Displays an icon that marks the location of HTML comments. Select the icon to see the comment in the Property inspector.

**Line Breaks** Displays an icon that marks the location of each line break (BR). This option is deselected by default.

**Client-Side Image Maps** Displays an icon marking the location of each client-side image map in the document.

**Embedded Styles** Displays an icon showing the location of CSS styles embedded in the body section of the document. If CSS styles are placed in the head section of a document, they do not appear in the Document window.

**Hidden Form Fields** Displays an icon that marks the location of form fields that have the type attribute set to "hidden".

**Form Delimiter** Displays a border around a form so you can see where to insert form elements. The border shows the extent of the form tag, so any form elements inside that border are properly enclosed in form tags.

**Anchor Points For AP elements** Displays an icon that marks the location of code defining an AP element. The AP element itself can be anywhere on the page. (AP elements are not invisible elements; only the code defining the AP element is invisible.) Select the icon to select the AP element; you can then see the contents of the AP element even if the AP element is marked as hidden.

**Anchor Points For Aligned Elements** Displays an icon showing the location of HTML code for elements that accept the align attribute. These include images, tables, ActiveX objects, plug-ins, and applets. In some cases, the code for the element may be separated from the visible object.

**Visual Server Markup Tags** Displays the location of server markup tags (such as Active Server Pages tags and ColdFusion tags) whose content cannot be displayed in the Document window. These tags typically generate HTML tags when processed by a server. For example, a <CFGRAPH> tag generates an HTML table when processed by a ColdFusion server. Dreamweaver represents the tag with a ColdFusion invisible element since Dreamweaver cannot determine the final, dynamic output of the page.

**Nonvisual Server Markup Tags** Displays the location of server markup tags (such as Active Server Pages tags and ColdFusion tags) whose content cannot be displayed in the Document window. These tags are typically set-up, processing, or logic tags (for example, <CFSET>, <CFWDDX>, and <CFXML>) that do not generate HTML tags.

**CSS Display: None** Displays an icon showing the location of content that's hidden by the display:none property in the linked or embedded stylesheet.

**Show Dynamic Text As** Displays any dynamic text on your page in the format of {Recordset:Field} by default. If the length of these values is long enough to distort your page's formatting, you can change the display to {} instead.

**Server-Side Includes** Displays the actual contents of each server-side include file.
Set text properties in the Property inspector

You can use the text Property inspector to apply HTML formatting or Cascading Style Sheet (CSS) formatting. When you apply HTML formatting, Dreamweaver adds properties to the HTML code in the body of your page. When you apply CSS formatting, Dreamweaver writes properties to the head of the document or to a separate style sheet.

Note:

When you create CSS inline styles, Dreamweaver adds style attribute code directly to the body of the page.

About formatting text (CSS versus HTML)

Formatting text in Dreamweaver is similar to using a standard word processor. You can set default formatting styles (Paragraph, Heading 1, Heading 2, and so on) for a block of text, change the font, size, color, and alignment of selected text, or apply text styles such as bold, italic, code (monospace), and underline.

Dreamweaver has two Property inspectors, integrated into one: the CSS Property inspector and the HTML Property inspector. When you use the CSS Property inspector, Dreamweaver formats text using Cascading Style Sheets (CSS). CSS gives web designers and developers greater control over web page design, while providing improved features for accessibility and reduced file size. The CSS Property inspector lets you access existing styles, as well as create new ones.

Using CSS is a way to control the style of a web page without compromising its structure. By separating visual design elements (fonts, colors, margins, and so on) from the structural logic of a web page, CSS gives web designers visual and typographic control without sacrificing the integrity of the content. In addition, defining typographic design and page layout from within a single, distinct block of code—without having to resort to image maps, font tags, tables, and spacer GIFs—allows for faster downloads, streamlined site maintenance, and a central point from which to control design attributes across multiple web pages.

You can store styles created with CSS directly in the document, or for more power and flexibility, you can store styles in an external style sheet. If you attach an external style sheet to several web pages, all the pages automatically reflect any changes you make to the style sheet. To access all CSS rules for a page, use the CSS Styles panel (Window > CSS Styles). To access rules that apply to a current selection, use the CSS Styles panel (Current mode) or the Targeted Rule pop-up menu in the CSS Property inspector.

If you prefer, you can use HTML markup tags to format text in your web pages. To use HTML tags instead of CSS, format your text using the HTML Property inspector.

Note:

You can combine CSS and HTML 3.2 formatting within the same page. Formatting is applied in a hierarchical manner: HTML 3.2 formatting overrides formatting applied by external CSS style sheets, and CSS embedded in a document overrides external CSS.

Edit CSS rules in the Property inspector

1. Open the Property inspector (Window > Properties), if it isn't already open and select the CSS option in the left corner of the panel.
2. Do one of the following:
   - Place the insertion point inside a block of text that's been formatted by a rule you want to edit. The rule appears in the Targeted Rule pop-up menu.
   - Select a rule from the Targeted Rule pop-up menu.
   - Click Edit Rule.
Select a rule from the Targeted Rule pop-up menu.

3 Make changes to the rule by using the various options in the CSS Property inspector.

**Targeted Rule** Is the rule you are editing in the CSS Property inspector. When you have an existing style applied to text, the rule affecting the text's format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to create new CSS rules, new in-line styles, or apply existing classes to selected text. If you're creating a new rule, you'll need to complete the New CSS Rule dialog box. For more information, see the links at the end of this topic.

**Edit Rule** Opens the CSS Rule Definition dialog box for the targeted rule. If you select New CSS Rule from the Targeted Rule pop-up menu and click the Edit Rule button, Dreamweaver opens the New CSS Rule definition dialog box instead.

**CSS Designer** Opens the CSS Designer panel and displays properties for the targeted rule in Current view.

**Font** Changes the font of the targeted rule.

**Size** Sets the font size for the targeted rule.

**Text Color** Sets the selected color as the font color in the targeted rule. Select a web-safe color by clicking the color box, or enter a hexadecimal value (for example, #BB5153) in the adjacent text field.
Edit CSS rules using the Edit Rule option.

**Bold** Adds the bold property to the targeted rule.

**Italic** Adds the italics property to the targeted rule.

**Left, Center, and Right Align** Aligns the targeted rule to the left, center, or right.

**Note:**

The Font, Size, Text Color, Bold, Italic, and Alignment properties always display the properties for the rule that applies to the current selection in the Document window. When you change any of these properties, you affect the targeted rule.

**Edit text color using Property inspector**

If you have not applied any specific rule for your text, you can edit the color of your text directly from the Property Inspector. In the following example, note the color of the text before editing. The field adjacent to the color picker displays white, indicating the color of the text where you have placed your cursor.

*Edit text color in Dreamweaver*
To edit the color of the text, select the text that you want to edit. Click the color picker and select any color of your choice. See the following image where the property inspector displays the new color.

Use the color picker to modify the color of text

**Set HTML formatting in the Property inspector**

1. Open the Property inspector (Window > Properties), if it isn't already open, and click the HTML button.
2. Select the text that you want to format.
3. Set the options you want to apply to the selected text:

   ![Set HTML formatting text properties](image)

   **Format** Sets the paragraph style of the selected text. Paragraph applies the default format for a `<p>` tag, Heading 1 adds an `H1` tag, and so on.

   **ID** Assigns an ID to your selection. The ID pop-up menu (if applicable) lists all of the document's unused, declared IDs.

   **Class** Displays the class style that is currently applied to the selected text. If no styles have been applied to the selection, the pop-up menu shows No CSS Style. If multiple styles have been applied to the selection, the menu is blank.

   Use the Style menu to do any of the following:
   - Select the style you want to apply to the selection.
   - Select None to remove the currently selected style.
   - Select Rename to rename the style.
   - Select Attach Style Sheet to open a dialog box that lets you attach an external style sheet to the page.

   **Bold** Applies either `<b>` or `<strong>` to the selected text according to the style preference set in the General category of the Preferences dialog box.
Italic Applies either &lt;i&gt; or &lt;em&gt; to the selected text according to the style preference set in the General category of the Preferences dialog box.

Unordered List Creates a bulleted list of the selected text. If no text is selected, a new bulleted list is started.

Ordered List Creates a numbered list of the selected text. If no text is selected, a new numbered list is started.

Blockquote and Remove Blockquote Indent or remove indentation from the selected text by applying or removing the blockquote tag. In a list, indenting creates a nested list and removing the indentation unnests the list.

Link Creates a hypertext link of the selected text. Click the folder icon to browse to a file in your site; type the URL; drag the Point-To-File icon to a file in the Files panel; or drag a file from the Files panel into the box.

Title Specifies the textual tooltip for a hypertext link.

Target Specifies the frame or window in which the linked document will load:

- _blank loads the linked file in a new, unnamed browser window.
- _parent loads the linked file in the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- _self loads the linked file in the same frame or window as the link. This target is implied, so you generally don't need to specify it.
- _top loads the linked file in the full browser window, thereby removing all frames.

Rename a class from the HTML Property inspector

Dreamweaver displays all of the classes available to your page in the Class menu of the HTML Property inspector. You can rename styles in this list by selecting the Rename option at the end of the list of class styles.

1 From the Property inspector panel, select the Class drop-down list.
2 From the list that pops up, select Rename at the end of the list.
3 Select the style that you want to rename from the Rename Style pop-up menu.

![Rename Style](image)

Rename an HTML class

4 Enter a new name in the New Name text field and click OK.

Spell check a web page

Use Spell Check to check the spelling in the current document.

The document must be a web page (for example, an HTML, ColdFusion, or PHP page).
Spell check does not work on text files or XML files.
Additionally, when you use Spell check, it ignores HTML tags and attribute values.

*Note:*

*Dreamweaver can only spell check the file that is currently open in the Document window. It cannot spell check all of the files in a site simultaneously.*

By default, the spelling checker uses the U.S. English spelling dictionary. To change the dictionary, select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > General (Macintosh), then in the Spelling Dictionary pop-up menu select the dictionary you want to use.

1. Select Tools > Spell Check or press Shift+F7.
   When Dreamweaver encounters an unrecognized word, the Spell Check dialog box appears.
2. Select the appropriate option based on how you want the discrepancy handled.
   - **Add To Personal** Adds the unrecognized word to your personal dictionary.
   - **Ignore** Ignores this instance of the unrecognized word.
   - **Change** Replaces this instance of the unrecognized word with text that you type in the Change To text box or with the selection in the Suggestions list.
   - **Ignore All** Ignores all instances of the unrecognized word.
   - **Change All** Replaces all instances of the unrecognized word in the same manner.

*Note:*

*Dreamweaver does not provide a way of deleting entries that have been added to personal dictionaries.*

**Using horizontal rules in Dreamweaver**

Horizontal rules (lines) are useful for organizing information. On a page, you can visually separate text and objects with one or more rules.

**Create a horizontal rule**

1. In the Document window, place the insertion point where you want to insert a horizontal rule.
2. Select Insert > HTML > Horizontal Rule.
   You can also insert a horizontal rule from the HTML section of the Insert panel.

**Modify a horizontal rule**

1. In the Document window, select the horizontal rule.
2. Select Window > Properties to open the Property inspector, and modify the properties as desired:
Modifying the properties of a horizontal rule

**The ID text box**  Lets you specify an ID for the horizontal rule.

**W and H**  Specify the width and height of the rule in pixels or as a percentage of the page size.

**Align**  Specifies the alignment of the rule (Default, Left, Center, or Right). This setting applies only if the width of the rule is less than the width of the browser window.

**Shading**  Specifies whether the rule is drawn with shading. Deselect this option to draw the rule in a solid color.

**Class**  Lets you attach a style sheet, or apply a class from an already attached style sheet.

Add and modify font combinations in Dreamweaver

Font combinations determine how a browser displays text in your web page. A browser uses the first font in the combination that is installed on the user’s system; if none of the fonts in the combination is installed, the browser displays the text as specified by the user’s browser preferences.

**Add Adobe Edge Web Fonts to the Font list**

You can use Adobe Edge Web Fonts in your web pages. When an Edge font is used in a page, an additional script tag is added to reference a JavaScript file. This file downloads the font from the Creative Cloud server directly to the browser’s cache.

When displaying the page, fonts are downloaded from the Creative Cloud server even if the font is available on the user’s computer.

For example, a Script tag that uses only the font "Abel" has the format:

```
<!--The following script tag downloads a font from the Adobe Edge Web Fonts server for use within the web page. We recommend that you do not modify it.-->
<script>var adobewebfontsappname = "dreamweaver"</script>
<script src="http://use.edgefonts.net/abel:n4:default.js" type="text/javascript"></script>
```

1  Select Tools > Manage Fonts.

   The Adobe Edge Fonts tab displays all the Adobe Edge Web Fonts that you can add to the Font list.

2  To find and add fonts from this list to the Font list, do the following:

   •  Click the font that you would like to add to the font list.
   •  To deselect a font, click the font again.
   •  Use filters to shortlist preferred fonts. For example, to shortlist fonts of the Serif type, click .
   •  You can use multiple filters. For example, to shortlist filters of Serif type that can be used for paragraphs, click and .
   •  To search a font by its name, enter its name in the search box.
3 Click to filter the fonts that you have selected.

4 Click Done.

Open the Font list from any location. For example, you could use the Font list in the CSS section of the Properties panel.

In the Font list, the Dreamweaver font stacks are listed ahead of the web fonts. Scroll down the list to locate your selected fonts.

**Add local web fonts to the Font list**

You can add web fonts from your computer to the Font list in Dreamweaver. The added fonts are reflected in all Font menus in Dreamweaver. Fonts of the type EOT, WOFF, TTF, and SVG are supported.

1 Select Tools > Manage Fonts.

2 In the Manage Fonts dialog, select Local Web Fonts.

3 Click the Browse button corresponding to the font type that you wish to add. For example, if your font is in the EOT format, click the Browse button corresponding to EOT Font.

4 Navigate to the location on your computer containing the font. Select the file and open it. If other formats for the font exist in that location, they are automatically added to the dialog. The Font Name is also automatically picked from the name of the font.

5 Select the option that asks you to confirm that you have licensed the font for website use.

6 Click Done.

The list of fonts is displayed in Current List of Local Web Fonts.

To remove a web font from the font list, select the font in Current List of Local Fonts, and click Remove.

**Create custom font stacks**

A font stack is a list of fonts in a CSS font-family declaration.

1 Select Tools > Manage Fonts, and select Custom Font Stacks.
2 Select the font combination from the list at the top of the dialog box.

   The fonts in the selected combination are listed in the Chosen Fonts list in the left of the dialog box. To the right is a list of all available fonts installed on your system.

3 Do one of the following:
   • To add or remove fonts from a font combination, click the arrows button (<< or >>) between the Chosen Fonts list and the Available Fonts list.
• To add or remove a font combination, click the Plus (+) and Minus (–) buttons at the top of the dialog box.

• To add a font that is not installed on your system, type the font name in the text field below the Available Fonts list and click the << button to add it to the combination. Adding a font not installed on your system is useful, for example, for specifying a Windows-only font when you are developing pages on a Macintosh.

• To move the font combination up or down in the list, click the arrow buttons at the top of the dialog box.

Add a new combination to the fontlist
1 Select Tools > Manage Fonts.
2 Select a font from the Available Fonts list and click the << button to move the font to the Chosen Fonts list.
3 Repeat step 2 for each subsequent font in the combination.

To add a font that is not installed on your system, type the font name in the text field below the Available Fonts list and click the << button to add the font to the combination. Adding a font not installed on your system is useful, for example, for specifying a Windows-only font when you are developing pages on a Macintosh.

4 When you have finished selecting specific fonts, select a generic font family from the Available Fonts menu and click the << button to move the generic font family to the Chosen Fonts list.

Generic font families include cursive, fantasy, monospace, sans-serif, and serif. If none of the fonts in the Chosen Fonts list are available on the user's system, the text appears in the default font associated with the generic font family. For example, the default monospace font on most systems is Courier.

Preview inserted fonts
You cannot preview Edge and Web fonts in the Design view. Switch to Live view or preview the page in a browser to preview them.

Update web font script tag across files
When you update the font in a CSS file that is linked to multiple HTML files, you are prompted to update the script tag in the related HTML files. When you click Update, the script tags in all the affected HTML files is updated.

Update web font script tag on a page
Select Tools > Clean Up Web Fonts Script Tag (Current Page) to update any web fonts on the web page that are not reflected in the script tag.

Work with assets
You can use Adobe Dreamweaver to keep track of and preview assets stored in your site, such as images, movies, colors, scripts, and links. You can also drag an asset directly to insert it in a page of the current document.

You obtain assets from various sources. For example, you might create assets in an application such as Adobe Photoshop, or Adobe Animate, or receive them from a co-worker, or copy them from a clip-art CD or graphics website.

Dreamweaver also provides access to two special types of assets—libraries and templates. Both are linked assets: when you edit a library item or template, Dreamweaver updates all documents that use those assets. Library items generally represent small design assets, such as a site logo or copyright. To control a larger design area, use a template instead.
Use the Assets panel (Window > Assets) to manage assets in the current site. The Assets panel displays assets for the site associated with the active document in the Document window.

**Note:**

*You must define a local site before you can view assets in the Assets panel.*
The Assets panel provides different ways to view assets:

**Site list**  Shows all of the assets in your site, including colors and URLs that are used in any document in your site.

**Favorites list**  Shows only the assets you've explicitly chosen.

To switch between these two views, select either the Site or Favorites radio button above the preview area. (These two views are not available for the Templates and Library categories.)

**Note:**

*Most of the Assets panel operations work the same in both lists. There are a few tasks, however, that you can perform only in the Favorites list.*

In both lists, assets fall into one of the following categories:

**Images**  Image files in GIF, JPEG, or PNG formats.

**Colors**  Colors used in documents and style sheets, including colors of text, backgrounds, and links.

**URLs**  External links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, e-mail (*mailto*), and local file (*file://*) links.

**Media**  Media files such as Adobe Flash (only SWF) files, Adobe Shockwave files, QuickTime, or MPEG files.

**Scripts**  JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or VBScript files) do not appear in the Assets panel. This category is available only in Code and Design View.

**Templates**  Master page layouts used on multiple pages. Modifying a template automatically modifies all pages attached to it. This category is available only in Code and Design View.

**Library items**  Design elements that you use in multiple pages; when you modify a library item, all pages containing that item are updated. This category is available only in Code and Design View.

**Note:**

*To appear in the Assets panel, a file must fall into one of these categories. Some other types of files are sometimes called assets, but they aren't shown in the panel.*

By default, assets in a category are listed alphabetically by name, but you can sort them by type and several other criteria. You can also preview assets and resize the columns and the preview area.

The Creative Cloud icon in the Type column indicates that the corresponding assets are imported from Creative Cloud Libraries. You can double-click the Creative Cloud icon for resampling the corresponding assets. For more information on reusing assets in Creative Cloud Libraries, see [Creative Cloud Libraries in Dreamweaver](#).

**View an asset in the preview area**

- Select the asset in the Assets panel.

**Display assets in a category**

- Click a category icon on the left side of the Assets panel.

**Sort assets**

- Click a column heading.
  
  For example, to sort the list of images by type (so that all the GIF images are together, all the JPEG images are together, and so on), click the Type column heading.

**Resize a column**

- Drag the line separating two column headings.
Resize the preview area

? Drag the splitter bar (between the preview area and the list of assets) up or down.

Refresh the Assets panel

It can take a few seconds to create the Site list because Dreamweaver must first read the site cache.

Certain changes don't appear immediately in the Assets panel. For instance, when you add or remove an asset from your site, the changes don't appear in the Assets panel until you refresh the Site list by clicking the Refresh Site List button. If you add or remove an asset outside Dreamweaver—using Windows Explorer or the Finder, for example—you must rebuild the site cache to update the Assets panel.

When you remove the only instance of a particular color or URL in your site, or when you save a new file that contains a color or URL that isn't already used in the site, the changes don't appear in the Assets panel until you refresh the Site list.

- To refresh the Site list manually, click the Refresh Site List button. Dreamweaver creates the site cache or updates it as necessary.
- To refresh the Site list and manually rebuild the site cache, right-click (Windows) or Command-click (Macintosh) in the Assets list, then select Refresh Site List.

Add an asset to a document

You can insert most assets into a document by dragging them into Live View, Code View, and Design View in the Document window, or by using the Insert button in the panel. You can drag the assets from both the list view and the preview pane of the Assets panel.

Note: Dragging from the preview pane is supported only on Mac.

You can insert colors and URLs in Design or Live View. In Design View, you can apply colors and URLs to selected elements.

1 In the document, place the insertion point where you want the asset to appear.
2 In the Assets panel, select from the asset category buttons at the left.
   
   Note:
   
   Select any category except Templates. A template is applied to an entire document; it can't be inserted into a document.
3 Select either Site or Favorites at the top of the panel, then select the asset.
   
   There are no Site or Favorites lists for library items; skip this step if you're inserting a library item.
4 Do one of the following:
   
   - Drag the asset from the panel to the document. You can drag from the list view as well as from the preview pane.
     
     Note: On Windows, you cannot drag assets from the preview pane.
     
     You can drag scripts into the head content area of the Document window; if that area isn't visible, select View > Head Content.
   
   - Select the asset in the panel and click Insert.
     
     If the inserted asset is a color, it applies to text appearing after the insertion point.
Apply color to text using the Assets panel
The Assets panel shows the colors you’ve already applied to various elements, such as text, table borders, backgrounds, and so on.

1 In Design View, perform the following steps:
   a Select the text in the document.
   b In the Assets panel, select the Colors category.
   c Select the desired color, and click Apply.

2 In Live View, perform the following steps:
   a In the Assets panel, select the Colors category.
   b Do one of the following:
      • Right-click the color in Assets panel, and click Copy Color Value. The color value is copied to your clipboard. You can now paste the color value (Ctrl+v, Cmd+v) in CSS Designer.
      • Drag the color from preview and hover the mouse on elements in Live View. When you drop the color, the New CSS Rule dialog appears and when you click OK, the color is applied to the selected element.
      • Click Apply in the Assets panel. The New CSS Rule dialog appears and when you click OK, the color is applied to the selected element.

Assign URLs to images or text
1 In Design View, perform the following steps:
   a Select the text or image.
   b In the Assets panel, select the URLs category in either the Sites or Favorites view, depending on where the URL is stored.
      Note: URLs for your site’s files are stored in the Sites view by default. The Favorites view holds URLs that you have added yourself.
   c Select the URL.
   d Do one of the following:
      • Drag the URL from the panel to the selection in Design View.
      • Select the URL, then click Insert.

2 In Live View, perform the following steps:
   a In the Assets panel, select the URLs category in either the Sites or Favorites view, depending on where the URL is stored.
   b Do one of the following:
      • Drag the URL from the preview or the list view. Hover the mouse on elements in Live View. When you drop the URL, <a> wraps the element highlighted in Live View.
      • Click the required element in Live View. Choose the URL in the Assets panel and click Apply. The selected element is wrapped with the <a> tag.
Select and edit assets
The Assets panel allows you to select multiple assets at once. It also provides a quick way to begin editing assets.

Select multiple assets
1 In the Assets panel, select an asset.
2 Select the other assets in one of the following ways:
   • Shift-click to select a consecutive series of assets.
   • Control-click (Windows) or Command-click (Macintosh) to add an individual asset to the selection (whether or not it's adjacent to the existing selection). Control-click or Command-click a selected asset to deselect it.

Edit an asset
When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, such as images, you use an external editor, which opens automatically if you have defined an editor for that asset type. You can edit colors and URLs in the Favorites list only. When you edit templates and library items, you make the changes within Dreamweaver.
1 In the Assets panel, do one of the following:
   • Double-click the asset.
   • Select the asset, then click the Edit button.
   
   Note:  
   If the asset must be edited in an external editor and one doesn't open automatically, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), select the File Types/Editors category, and make sure you have defined an external editor for that asset type.
2 Make your changes.
3 When you finish, do one of the following:
   • If the asset is file-based (anything other than a color or URL), save it (in the editor you used), and close it.
   • If the asset is a URL, click OK in the Edit URL dialog box.
   
   Note:  
   If the asset is a color, the color picker closes automatically after you pick a color. To dismiss the color picker without picking a color, press Esc.

Reuse assets in another site
The Assets panel shows all the assets (of recognized types) in your current site. To use an asset from the current site in another site, you must copy it to the other site. You can copy an individual asset, a set of individual assets, or an entire Favorites folder at once.

You may need to locate the file in the Files panel that corresponds to an asset in the Assets panel before you transfer the asset to or from your remote site.

Note:
The Files panel might show a different site from the one that the Assets panel shows. This is because the Assets panel is associated with the active document.
Locate an asset file in the Files panel
1 In the Assets panel, select the category of the asset you want to find.
2 Right-click (Windows) or Control-click (Macintosh) the asset's name or icon in the Assets panel, then select Locate In Site from the context menu.

Note:
Locate In Site is unavailable for colors and URLs, which do not correspond to files in the site.

The Files panel opens, with the asset file selected. The Locate In Site command locates the file corresponding to the asset itself; it does not locate files that use that asset.

Copy assets from the Asset panel to another site
1 In the Assets panel, select the category of the asset you want to copy.
2 Right-click (Windows) or Control-click (Macintosh) one or more assets in either the Site list or Favorites list, select Copy To Site, and select the target site name from the submenu listing all the sites you've defined.

Note:
In the Favorites list, you can copy a Favorites folder as well as individual assets.

The assets are copied to their corresponding locations in the target site. Dreamweaver creates new folders in the target site's hierarchy as needed. The assets are also added to the target site's Favorites list.

Note:
If the asset you copied is a color or a URL, it appears only in the target site's Favorites list. Because colors and URLs don't correspond to files, there's no file to copy into the other site.

Insert and update dates in Dreamweaver

Dreamweaver provides a convenient Date object, which inserts the current date in whatever format you prefer (with or without the time) and provides the option of updating that date whenever you save the file.

Note:
The dates and times shown in the Insert Date dialog box are not the current date, nor do they reflect the dates/times that a visitor sees when they display your site. They are examples only of the way you want to display this information.

1 In the Document window, place the insertion point where you want the date to be inserted.
2 Do one of the following:
   • Select Insert > HTML > Date.
   • In the HTML category of the Insert panel, click the Date button.
3 In the resulting dialog box, select a format for the name of the day of the week, a format for the date, and a format for the time.
If you want the inserted date to be updated every time you save the document, select Update Automatically On Save. If you want the date to become plain text when it's inserted, and never update automatically, deselect that option.

Click OK to insert the date.

If you have selected Update Automatically On Save, you can edit the date format after it has been inserted into the document by clicking on the formatted text and selecting Edit Date Format in the Property inspector.

Create and manage favorite assets in Dreamweaver

The complete list of all recognized assets list can become cumbersome for some large sites. You can add frequently used assets to a Favorites list, group related assets together, give them nicknames to remind yourself what they’re for, and find them easily in the Assets panel.

Note:

Favorite assets are not stored as separate files on your disk; they're references to the assets in the Site list. Dreamweaver keeps track of which assets from the Site list to display in the Favorites list.

Most of the operations of the Assets panel are the same in the Favorites list as in the Site list. However, there are several tasks that you can perform only in the Favorites list.
Add or remove favorite assets

There are several ways to add assets to your site’s Favorites list in the Assets panel.

Adding a color or URL to the Favorites list requires an extra step. You can’t add new colors or URLs to the Site list; the Site list contains only assets that are already in use in your site.

Note:

There are no Favorites lists for templates and library items.

Add assets to the Favorites list

Do one of the following:

• Select one or more assets in the Site list of the Assets panel, right-click (Windows) or Control-click (Macintosh), then select Add To Favorites.

• Select one or more files in the Files panel, right-click (Windows) or Control-click (Macintosh), then select Add To Favorites. Dreamweaver ignores files that don’t correspond to a category in the Assets panel.

• Right-click (Windows) or Control-click (Macintosh) an element in the Document window’s Design view, then select the context menu command to add the element to a Favorites category.

   The context menu for text contains either Add To Color Favorites or Add To URL Favorites, depending on whether the text has a link attached. You can add only those elements that match one of the categories in the Assets panel.

Add a new color or URL to the Favorites list

1 In the Assets panel, select the Colors or URLs category.
2 Select the Favorites option at the top of the panel.
3 Click the New Color or New URL button.
4 Do one of the following:
   • Select a color using the color picker, then give the color a nickname if desired.
     To close the color picker without selecting a color, press Esc or click the gray bar at the top of the color picker.
   • Enter a URL and a nickname in the Add New URL dialog box, then click OK.

Remove assets from the Favorites list

1 In the Assets panel, select the Favorites option at the top of the panel.
2 Select one or more assets (or a folder) in the Favorites list.
3 Click the Remove From Favorites button.

   The assets are removed from the Favorites list, but not from the Site list. If you remove a Favorites folder, the folder and all its contents are removed.

Create a nickname for a favorite asset

You can give nicknames (for instance, PageBackgroundColor rather than #999900) to assets only in the Favorites list. The Site list retains their real filenames (or values, in the case of colors and URLs).

1 In the Assets panel (Window > Assets), select the category that contains your asset.
2 Select the Favorites option at the top of the panel.
3 Do one of the following:
   • Right-click (Windows) or Control-click (Macintosh) the asset's name or icon in the Assets panel, then select Edit Nickname.
   • Click the asset's name once, pause, then click it again. (Do not double-click; double-clicking opens the item for editing.)
4 Type a nickname for the asset, then press Enter (Windows) or Return (Macintosh).

**Group assets in a Favorites folder**

Placing an asset in Favorites folder does not change the location of the asset's file on your disk.

1 In the Assets panel, select the Favorites option at the top of the panel. Right-click within the panel, and select New Favorites Folder.
2 Type a name for the folder, then press Enter (Windows) or Return (Macintosh).
3 Drag assets into the folder.

**Insert and edit images in Dreamweaver**

Images form an integral part of a website by providing additional context for the site visitors. Although a wide variety of graphic file formats exist, GIF, JPEG, and PNG file formats are commonly used in web pages. GIF and JPEG file formats are compatible with web pages, and can be viewed in most browsers. The following text gives more information about these file formats:

**GIF (Graphic Interchange Format)** - GIF files use a maximum of 256 colors, and are best for displaying noncontinuous-tone images. GIF files are ideal for displaying large areas of flat colors, such as navigation bars, buttons, icons, logos, or other images with uniform colors and tones.

**JPEG (Joint Photographic Experts Group)** - The JPEG file format is the superior format for photographic or continuous-tone images, because JPEG files can contain millions of colors. As the quality of a JPEG file increases, so does the file size and the file download time. You can strike a good balance between the quality of the image and the file size by compressing a JPEG file.

**PNG (Portable Network Group)** - The PNG file format is a patent-free replacement for GIFs that includes support for indexed-color, grayscale, true-color images, and alpha channel support for transparency. PNG files retain the original layer, vector, color, and effects information such as drop shadows. Further, all the elements are fully editable always. Files must have the .png filename extension to be recognized as PNG files by Dreamweaver.

**Note:**

*Dreamweaver is not a WYSIWYG (What you see is what you get) editor. That is, you can add or insert images using Dreamweaver, but you cannot move or position the images from the interface.*

*To move your images in your layout, you must use CSS that displays your HTML content the way you want. You can refer to the basic tutorials on HTML and CSS to learn how to work with images using code. You can also view the tutorial on working with images in Dreamweaver.*

To know how to insert and use images using the Dreamweaver application, see the following sections.
Insert an image

When you insert an image into a Dreamweaver document, a reference to the image file is generated in the HTML source code. To ensure that this reference is correct, the image file must be in the current site. If the image is not in the current site, Dreamweaver asks whether you want to copy the file into the site.

Dreamweaver also allows you to insert images dynamically. Dynamic images are those images that change often. For example, advertising banner rotation systems that randomly select a single banner from a list of potential banners. The system dynamically displays the selected banner’s image when a page is requested.

You can also drag-and-drop any layer from the Extract panel to any place in Dreamweaver Live View using Live Guides and Element Quick View. The Extract Panel allows you to upload PSD files and then drag-and-drop any layer in the PSD file directly into your Dreamweaver document.

After you insert an image, you can set the image tag and accessibility attributes that screen readers pick up for visually impaired users. You can edit these attributes in HTML code.

For information on extracting images from your PSD compositions, see Extract images from PSD files.

1 Place the insertion point where you want the image to appear in the Document window and do one of the following:
   • In the Insert panel, select HTML from the drop-down list. Click Image. Double-click or drag the icon to the document window (or to the Code view window if you are working using code).
   • Select Insert > Image.
   • Drag an image from the Assets panel (Window > Assets) to the desired location in the Document window; then skip to step 3.
   • Drag an image from the Files panel to the desired location in the Document window; then skip to step 3.
   • Drag an image from the desktop to the desired location in the Document window; then skip to step 3.
   • In Live View, drag an image from the Extract panel or the Layers tab. Drop the element at the top, bottom, right or left of an element, based on Live Guides. Alternatively, you can drop the element at a precise place in the document structure by clicking </> and using Element Quick View.

2 Browse to select the image or content source that you want to insert.

   If you are working in an unsaved document, Dreamweaver generates a file:// reference to the image file. When you save the document anywhere in the site, Dreamweaver converts the reference to a document-relative path.

   Note:
   When you insert images, you can use an absolute path to an image that resides on a remote server. That is, an image that is not available on the local hard drive. However, if you experience performance issues while working, you can disable viewing the image in Design view by deselecting Commands > Display External Files.

3 Click OK.

Set image properties

The Images Property inspector allows you to set properties for an image. If you do not see all of the image properties, click the expander arrow in the lower-right corner.
To view the Property Inspector for a selected image, click the image and select **Window > Properties**.

In the text box below the thumbnail image, enter a name. You can use this name to refer to the image when using a Dreamweaver behavior such as Swap Image, or when using a scripting language such as JavaScript or VBScript.

Set any of the image options.

**W and H** The width and height of the image, in pixels. Dreamweaver automatically updates these text boxes with the image’s original dimensions when you insert an image in a page.

If you set W and H values that do not correspond to the actual width and height of the image, the image is not displayed properly in a browser. To restore the original values, click the W and H text box labels, or the Reset image size button that appears to the right of the W and H text boxes.

**Note:**

You can change these values to scale the display size of this image instance. However, the change does not reduce download time, because the browser downloads all the image data before scaling the image. To reduce the download time, and to ensure that all the instances of an image appear at the same size, use an image-editing application to scale images.

**Src** Specifies the source file for the image. Click the folder icon to browse to the source file, or type the path.

**Link** Specifies a hyperlink for the image. Drag the Point-To-File icon to a file in the Files panel. Click the folder icon to browse to a document on your site, or manually type the URL.

**Alt** Specifies alternative text that appears in place of the image for text-only browsers or for browsers that have been set to download images manually. For visually impaired users who use speech synthesizers with text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the image.

**Map Name and Hotspot tools** Allow you to label and create a client-side image map.

**Target** Specifies the frame or window in which the linked page loads. This option is not available when the image is not linked to another file. The names of all the frames in the current frameset appear in the Target list. You can also choose from the following reserved target names:

- **_blank** loads the linked file into a new, unnamed browser window.
- **_new** loads the linked file into a new browser window.
- **_parent** loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- **_self** loads the linked file into the same frame or window as the link. This target is the default target. You do not need to specify this value explicitly.
- **_top** loads the linked file into the full browser window, thereby removing all frames.

**Edit** Starts the image editor you specified in External Editors preferences and opens the selected image.

**Edit image settings** Opens the **Image Optimization** dialog box and lets you optimize the image.

**Update from original** When the image on the Dreamweaver page is out of sync with the original Photoshop file, Dreamweaver detects that the original file has been updated. The application displays one of the Smart Object icon’s arrows in red. When you select the web image in Design view and click the **Update from Original** button in the
Property Inspector, the image updates automatically. The updated image reflects the changes that you made to the original Photoshop file.

**Crop**  Trims the size of an image, removing unwanted areas from the selected image.

**Resample**  Resamples a resized image, improving its picture quality at its new size and shape.

**Brightness and Contrast**  Adjusts the brightness and contrast settings of an image.

**Sharpen**  Adjusts the sharpness of an image.

*Note:*

You can also edit image attributes in Live View using the Quick Property Inspector.

Edit image accessibility attributes in code

If you inserted accessibility attributes for an image, you can edit those values in the HTML code.

1. In the Document window, click the image or select the image tag in code.
2. Do one of the following to enter a name or a brief description for the image in less than 50 characters in the Alternate Text box. The screen reader reads the information you enter here.
   - Edit the appropriate image attributes in Code view.
   - Edit image attributes in Live View using the Quick Property Inspector.
   - Edit the **Alt** value in the Property inspector.

Resize an image

You can visually resize elements such as images, plug-ins, Shockwave or SWF files, applets, and ActiveX controls in Dreamweaver.

Visually resizing an image helps you see how the image affects the layout at different dimensions but it does not scale the image file to the proportions that you specify. If you visually resize an image in Dreamweaver without using an image-editing application, the user's browser scales the image when the page is loaded. It might cause a delay in page download time and the image is not displayed properly in the user's browser.

To reduce download time and to ensure that all instances of an image appear at the same size, use an image-editing application to scale images. Read the following procedure to know how to visually resize an element.

**Visually resize an element**

1. Select the element (for example, an image or SWF file) in the Document window.

   Resize handles appear at the bottom and right sides of the element and in the lower-right corner. If resize handles do not appear, click outside the element and then reselect it. Alternatively, you can click the appropriate tag in the tag selector to select the element.
2 Resize the element by doing one of the following:
   • To adjust the width of the element, drag the selection handle on the right side.
   • To adjust the height of the element, drag the bottom selection handle.
   • To adjust the width and the height of the element at the same time, drag the corner selection handle.
   • To preserve the element's proportions (its width-to-height ratio) as you adjust its dimensions, Shift-drag the corner selection handle.
   • To adjust the width and height of an element to a specific size (for example, 1 x 1 pixel), use the Property Inspector. Enter a numeric value in the W and H fields. You can visually resize elements to a minimum of 8 x 8 pixels.

3 To return a resized element to its original dimensions, in the Property Inspector, delete the values in the W and H fields. You can also click the Reset Size button in the image Property Inspector.

Revert an image to its original size
Click the Reset size button in the image Property Inspector.

Resample a resized image
When you resize an image in Dreamweaver, you can also resample the image to accommodate new dimensions. Resampling adds or subtracts pixels from a resized JPEG and GIF image files to match the appearance of the original image as closely as possible. Resampling an image reduces its file size and improves download performance.

1 Resize the image as described in the section Resize an image.
2 Click the Resample button in the image Property inspector.
Note:

You cannot resample image placeholders or elements other than bitmap images.

**Edit images in Dreamweaver**

Dreamweaver provides basic image-editing features that let you modify images without having to use an external image-editing application such as Photoshop. The Dreamweaver image-editing tools are designed to let you easily work with content designers responsible for creating image files for use on your website.

You can resample, crop, optimize, and sharpen images in Dreamweaver. You can also adjust the brightness and contrast of images.

Note:

You do not need to have Photoshop or other image-editing applications installed on your computer to use the Dreamweaver image-editing features.

Select Edit > Image. You can set the following Dreamweaver image-editing features:

- **Optimize** Select a preset, specify a file format, and specify the level of quality. As you move the slider across the quality levels, you can see the file size of the image in the dialog box. Click OK once done.

- **Resample** Adds or subtracts pixels from a resized JPEG and GIF image files to match the appearance of the original image as closely as possible. Resampling an image reduces its file size and improves download performance.

When you resize an image in Dreamweaver, you can resample it to accommodate its new dimensions. When a bitmap object is resampled, pixels are added to or removed from the image to make it larger or smaller. Resampling an image to a higher resolution typically causes little loss of quality. Resampling to a lower resolution, however, always causes data loss and usually a drop in quality.

- **Crop** Edit images by reducing the area of the image. You can use crop to place more emphasis on the subject of the image, and remove unwanted aspects surrounding the center of interest.

- **Brightness and Contrast** Modifies the contrast or brightness of pixels in an image. Brightness and Contrast affects the highlights, shadows, and midtones of an image. You typically use Brightness/Contrast when correcting images that are too dark or too light.

- **Sharpen** Adjusts the focus of an image by increasing the contrast of edges found within the image. When you scan an image, or take a digital photo, the default action of most image capturing software is to soften the edges of the objects in the image. The scanning prevents extremely fine details from becoming lost in the pixels from which digital images are composed. However, to bring out the details in digital image files, it is often necessary to sharpen the image. Using the Sharpen option increases the edge contrast, making the image appear sharper.

Note:

Dreamweaver image-editing features apply only to JPEG, GIF, and PNG image file formats. Other bitmap image file formats cannot be edited using these image-editing features.

**Crop an image**

Dreamweaver lets you crop or trim bitmap file images.

Note:
When you crop an image, the source image file is changed on disk. It is recommended that you keep a backup copy of the image file if you have to revert to the original image.

1. Open the page containing the image you want to crop, select the image, and do one of the following:
   - Click the Crop Tool icon in the image Property inspector.
   - Select Edit > Image > Crop.
   - Crop handles appear around the selected image.

2. Adjust the crop handles until the bounding box surrounds the area of the image that you want to keep.

3. Double-click inside the bounding box or press Enter to crop the selection.

4. A dialog box informs you that the image file you are cropping will be changed on disk. Click OK.

   Every pixel in the selected bitmap outside the bounding box is removed, but other objects in the image remain.

5. Preview the image and ensure that it meets your expectations. If not, select Edit > Undo Crop to revert to the original image.

   **Note:**

   You can undo the effect of the Crop command and revert to the original image file until you quit Dreamweaver, or edit the file using an external image-editing application.
Optimize an image
You can optimize images in your web pages from within Dreamweaver.

1. Open the page containing the image that you want to optimize. Select the image, and do one of the following:
   - Click the Edit Image Settings button in the image Property Inspector.
   - Select Edit > Image > Optimize.

2. Make your edits in the Image Optimization dialog box and click OK.

Sharpen an image
Sharpening increases the contrast of pixels around the edges of objects to increase the image's definition or sharpness.

1. Open the page containing the image you want to sharpen, select the image, and do either of the following:
   - Click the Sharpen button in the image Property inspector.
   - Select Edit > Image > Sharpen.

2. To specify the degree of sharpening Dreamweaver applies to the image, drag the slider control. You can also enter a value between from 0 through 10 in the text box. As you adjust the sharpness of the image using the Sharpen dialog box, you can preview the change to the image.
3 Click OK when you are satisfied with the image.

4 Save your changes by selecting File > Save, or revert to the original image by selecting Edit > Undo Sharpen.

Note:
You can only undo the effect of the Sharpen command and revert to the original image file before you save the page containing the image. After you save the page, the changes made to the image are permanent.

Adjust the brightness and contrast of an image
Brightness and Contrast option modifies the contrast or brightness of pixels in an image. This option affects the highlights, shadows, and midtones of an image. You typically use Brightness and Contrast when correcting images that are too dark or too light.

1 Open the page containing the image you want to adjust, select the image, and do either of the following:
   • Click the Brightness and Contrast button in the image Property Inspector.
   • Select Edit > Image > Brightness/Contrast.

2 Drag the Brightness and Contrast sliders to adjust the settings. Values range from -100 to 100.

3 Click OK.

Create a rollover image
A rollover is an image that, when viewed in a browser, changes when the pointer moves across it. You must have two images to create the rollover. A primary image or the image displayed when the page first loads, and a secondary image or the image that appears when the pointer moves over the primary image. Both the images in a rollover must be of the same size. If the images are not the same size, Dreamweaver resizes the second image to match the properties of the first image.
Rollover images are automatically set to respond to the `onMouseOver` event. You can set an image to respond to a different event. For example, a mouse click or change a rollover image.

1. In the Document window, place the insertion point where you want the rollover to appear.

2. Insert the rollover using one of these methods:
   - In the Insert panel, select HTML from the drop-down list. Select Rollover Image, from the list of options.
   - Select Insert > HTML > Rollover Image.

3. In the Insert Rollover Image dialog box, select the images and set the properties for the rollover. You can set the following properties:

   ![Setting properties of a rollover image](image)

   - **Image Name** The name of the rollover image.
   - **Original image** The image you want to display when the page loads. Enter the path in the text box, or click Browse and select the image.
   - **Rollover Image** The image you want to display when the pointer rolls over the original image. Enter the path or click Browse to select the image.
   - **Preload Rollover Image** Preloads the images in the browser's cache so no delay occurs when the user rolls the pointer over the image.
   - **Alternate Text** (Optional) Text to describe the image for viewers using a text-only browser.
   - **When clicked, Go to URL** The file that you want to open when a user clicks the rollover image. Enter the path or click Browse and select the file.

   **Note:**

   If you do not set a link for the image, Dreamweaver inserts a null link (`#`) in the HTML source code to which the rollover behavior is attached. If you remove the null link, the rollover image does not work.

4. To preview the rollover image, select File > Real-time Preview, or press F12.

5. In the browser, move the pointer over the original image to see the rollover image.

   **Note:**

   You cannot see the effect of a rollover image in Design view.
**Use an external image editor**

While in Dreamweaver, you can open a selected image in an external image editor. When you return to Dreamweaver after saving the edited image file, any changes you made to the image are visible in the Document window.

You can set up a primary external editor and also set which file types an editor opens. You can select multiple image editors. For example, you can set preferences to start Photoshop when you want to edit a JPEG file and start a different image editor when you want to edit an animated GIF.

**Start the external image editor**

To open an external editor, do one of the following:

- Double-click the image that you want to edit.
- Right-click (Windows) or Control-click (Macintosh) the image that you want to edit. Then, click **Edit With > Browse** and select an editor.
- Select the image that you want to edit, and click **Edit** in the Property Inspector.
- Double-click the image file in the **Files** panel to start the primary image editor. If you haven't specified an image editor, Dreamweaver starts the default editor for the file type.

If you don’t see an updated image after returning to the Dreamweaver window, select the image and then click the **Refresh** button in the Property Inspector.

**Set an external image editor for an existing file type**

You can select an image editor for opening and editing graphic files. To select an external image editor, perform the following steps:

1. Select **Edit > Preferences** (Windows) or **Dreamweaver > Preferences** (macOS), and select **File Types/Editors** from the Category list on the left pane.
2. In the Extensions list, select the extension for which you want to set an external editor.
3  Click the Add (+) button above the Editors list.
4  In the Select External Editor dialog box, browse to the application that you want to start as an editor for this file type.
5  In the Preferences dialog box, click Make Primary if you want this editor to be the primary editor for this file type.
6  If you want to set up an additional editor for this file type, repeat steps 3 and 4.

Dreamweaver automatically uses the primary editor when you edit this image type. You can select the other listed editors from the context menu for the image in the Document window.

**Add a new file type to the Extensions list**
1  Select Edit > Preferences (Windows) or Dreamweaver > Preferences (macOS), and select File Types/Editors from the Category list on the left pane.
2  In the File Types/Editors Preferences dialog box, click the Add (+) button above the Extensions list.
   A text box appears in the Extensions list.
3  Select the extension of the file type for which you want to set an editor.
4  To select an external editor for the file type, click the Add (+) button above the Editors list.
In the dialog box that appears, select the application that you want to use to edit this image type.

Click **Make Primary** if you want this editor to be the primary editor for the image type.

**Change an existing editor preference**

1. Select **Edit > Preferences** (Windows) or **Dreamweaver > Preferences** (macOS), and select **File Types/Editors** from the Category list on the left pane.

2. In the **File Types/Editors** preferences dialog box, in the Extensions list select the file type you are changing to view the existing editors.

3. In the Editors list, select the editor you want to affect, then do one of the following:
   - To add or remove an editor, click the **Add (+)** or **Delete (–)** buttons above the Editors list.
   - To change which editor starts by default for editing, click the **Make Primary** button.

**Apply behaviors to images**

You can apply any available behavior to an image or an image hotspot. When you apply a behavior to a hotspot, Dreamweaver inserts the HTML source code into the `area` tag. Three behaviors apply specifically to images: **Preload Images**, **Swap Image**, and **Swap Image Restore**.

**Preload Images** Loads images that do not appear on the page right away such as images that are swapped in with behaviors, AP elements, or JavaScript, into the browser cache. Preloading images prevents delays caused by downloading when it is time for the images to appear.

**Swap Image** Swaps one image for another by changing the `src` attribute of the `img` tag. Use this action to create button rollovers and other image effects (including swapping more than one image at a time).

**Swap Image Restore** Restores the last set of swapped images to their previous source files. This action is automatically added whenever you attach the Swap Image action to an object by default. In this case, you need not select the Swap option manually.

You can also use behaviors to create more sophisticated navigation systems, such as jump menus.

**Add media objects**

In addition to SWF and FLV files, you can insert other audio or video objects in a Dreamweaver document. If you inserted accessibility attributes with a media object, you can set the accessibility attributes and edit those values in the HTML code.

1. Place the insertion point in the Document window where you want to insert the object.

2. Insert the object by doing one of the following:
   - In the HTML category of the Insert panel, and select the icon for the type of object you want to insert.
   - Select the appropriate object from the Insert > HTML submenu.
   - A dialog box appears letting you select a source file and specify certain parameters for the media object.
To prevent such dialog boxes from appearing, select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > General (Macintosh) and deselect the Show Dialog When Inserting Objects option. To override whatever preference is set for showing dialog boxes, hold down the Control (Windows) or Option (Macintosh) key while inserting the object.

3 Complete the Select File dialog box, and click OK.

Note:
The Accessibility Attributes dialog box appears if you have chosen to show attributes when inserting media in the Edit > Preferences dialog box.

4 Set the accessibility attributes.

Note:
You can also edit media object attributes by selecting the object and editing the HTML code in Code view, or right-clicking (Windows) or Control-clicking (Macintosh), and selecting Edit Tag Code.

Title Enter a title for the media object.

Access Key Enter a keyboard equivalent (one letter) in the text box to select the form object in the browser. This lets a visitor to the site use the Control key (Windows) with the Access Key to access the object. For example, if you enter B as the Access Key, use Control+B to select the object in the browser.

Tab Index Enter a number for the tab order of the form object. Setting a tab order is useful when you have other links and form objects on the page and need the user to tab through them in a specific order. If you set tab order for one object, be sure to set the tab order for all of them.

5 Click OK to insert the media object.

Note:
If you click Cancel, a media object placeholder appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.

To specify a source file, or to set dimensions and other parameters and attributes, use the Property inspector for each object. You can edit accessibility attributes for an object.

Start an external editor for media files
You can start an external editor from Dreamweaver to edit most media files. You can also specify the editor you want Dreamweaver to start to edit the file.

1 Make sure the media file type is associated to an editor on your system.

To find out what editor is associated with the file type, select Edit > Preferences in Dreamweaver and select File Types/Editors from the Category list. Click the file's extension in the Extensions column to view the associated editor or editors in the Editors column. You can change the editor associated to a file type.

2 Double-click the media file in the Files panel to open it in the external editor.

The editor that starts when you double-click the file in the Files panel is called the primary editor. If you double-click an image file, for example, Dreamweaver opens the file in the primary external image editor such as Adobe Fireworks.

3 If you don't want to use the primary external editor to edit the file, you can use another editor on your system to edit the file by doing one of the following:

- In the Files panel, right-click (Windows) or Control-click (Macintosh) the filename and select Open With from the context menu.
• In Design view, right-click (Windows) or Control-click (Macintosh) the media element within the current page, and select Edit With from the context menu.

Specify the editor to start from Dreamweaver
You can specify the editor you want Dreamweaver to use for editing a file type, and add or delete file types that Dreamweaver recognizes.

Explicitly specify which external editors should be started for a given file type
1 Select Edit > Preferences and select File Types/Editors from the Category list.
Filename extensions, such as .gif, .wav, and .mpg, are listed on the left under Extensions. Associated editors for a selected extension are listed on the right under Editors.
2 Select the file type extension in the Extensions list and do one of the following:
  • To associate a new editor with the file type, click the Plus (+) button above the Editors list and complete the dialog box that appears.
    For example, select the application icon for Acrobat to associate it with the file type.
  • To make an editor the primary editor for a file type (that is, the editor that opens when you double-click the file type in the Files panel), select the editor in the Editors list and click Make Primary.
  • To dissociate an editor from a file type, select the editor in the Editors list and click the Minus (-) button above the Editors list.

Add a new file type and associated editor
1 Click the Plus (+) button above the Extensions list and enter a file type extension (including the period at the beginning of the extension) or several related extensions separated by spaces.
  For example, you might enter .xml .xsl if you wanted to associate them with an XML editor installed on your system.
2 Select an editor for the file type by clicking the Plus (+) button above the Editors list and completing the dialog box that appears.

Remove a file type
? Select the file type in the Extensions list and click the Minus (-) button above the Extensions list.

Note:
You can't undo after removing a file type, so be sure that you want to remove it.

Use Design Notes with media objects
As with other objects in Dreamweaver, you can add Design Notes to a media object. Design Notes are notes associated with a particular file, that are stored in a separate file. You can use Design Notes to keep track of extra file information associated with your documents, such as image source filenames and comments on file status.

1 Right-click (Windows) or Control-click (Macintosh) the object in the Document window.

Note:
You must define your site before adding Design Notes to any object.
2 Select Design Notes for Page from the context menu.
3 Enter the information you want in the Design Note.
You can also add a Design Note to a media object from the Files panel by selecting the file, revealing the context menu, and choosing Design Notes from the context menu.

Add video (non-FLV)
You can add video to your web page in different ways and using different formats. Video can be downloaded to the user or it can be streamed so that it plays while it is downloading.

1 Place the clip in your site folder.
These clips are often in the AVI or MPEG file format.

2 Link to the clip or embed it in your page.
To link to the clip, enter text for the link such as “Download Clip”, select the text, and click the folder icon in the Property inspector. Browse to the video file and select it.

Note:
The user must download a helper application (a plug-in) to view common streaming formats like Real Media, QuickTime, and Windows Media.

Insert plug-in content
You can create content such as a QuickTime movie for a browser plug-in, and then use Dreamweaver to insert that content into an HTML document. Typical plug-ins include RealPlayer and QuickTime, while some content files include mp3s and QuickTime movies.

You can preview movies and animations that rely on browser plug-ins directly in the Design view of the Document window. You can play all plug-in elements at one time to see how the page will look to the user, or you can play each one individually to ensure that you have embedded the correct media element.

Note:
You cannot preview movies or animations that rely on ActiveX controls.

After inserting content for a plug-in, use the Property inspector to set parameters for that content. To view the following properties in the Property inspector, select a plug-in object.

The Property inspector initially displays the most commonly used properties. Click the expander arrow in the lower-right corner to see all properties.

Insert plug-in content and set its properties
1 In the Design view of the Document window, place the insertion point where you want to insert the content, then do one of the following:
   • In the Common category of the Insert panel, click the Media button and select the Plugin icon from the menu.
   • Select Insert > Media > Plugin.

2 In the dialog box that appears, select a content file for a plug-in and click OK.
3  Set the plug-in options in the Property inspector.
   
   **Name**  Specifies a name to identify the plug-in for scripting. Enter a name in the unlabeled text box on the far left side of the Property inspector.

   **W and H**  Specify, in pixels, the width and height allocated to the object on the page.

   **Src**  Specifies the source data file. Click the folder icon to browse to a file, or enter a filename.

   **Plg Url**  Specifies the URL of the *pluginspace* attribute. Enter the complete URL of the site where users can download the plug-in. If the user viewing your page does not have the plug-in, the browser tries to download it from this URL.

   **Align**  Determines how the object is aligned on the page.

   **V Space and H Space**  Specify the amount of white space in pixels above, below, and on both sides of the plug-in.

   **Border**  Specifies the width of the border around the plug-in.

   **Parameters**  Opens a dialog box for entering additional parameters to pass to the plug-in. Many plug-ins respond to special parameters.

   You can also view the attributes assigned to the selected plug-in by clicking the Attribute button. You can edit, add, and delete attributes such as width and height in this dialog box.

**Play plug-in content in the Document window**

1  Insert one or more media elements using one of the methods described in the previous section.

2  Do one of the following:

   •  Select one of the media elements you have inserted, and select View > Plugins > Play or click the Play button in the Property inspector.

   •  Select View > Plugins > Play All to play all of the media elements on the selected page that rely on plug-ins.

   **Note:**

   *Play All only applies to the current document; it does not apply to other documents in a frameset, for example.*

**Stop playing plug-in content**

7  Select a media element and select View > Plugins > Stop, or click the Stop button in the Property inspector.

   You can also select View > Plugins > Stop All to stop all plug-in content from playing.

**Troubleshoot plug-ins**

If you have followed the steps to play plug-in content in the Document window, but some of the plug-in content does not play, try the following:

•  Make sure the associated plug-in is installed on your computer, and that the content is compatible with the version of the plug-in you have.

•  Open the file Configuration/Plugins/UnsupportedPlugins.txt in a text editor and look to see if the problematic plug-in is listed. This file keeps track of plug-ins that cause problems in Dreamweaver and are therefore unsupported. (If you experience problems with a particular plug-in, consider adding it to this file.)

•  Check that you have enough memory. Some plug-ins require an additional 2 to 5 MB of memory to run.
**Use behaviors to control media**

You can add behaviors to your page to start and stop various media objects.

- **Control Shockwave Or Flash**  Play, stop, rewind, or go to a frame in a Shockwave movie or SWF file.
- **Play Sound**  Lets you play a sound; for example, you can play a sound effect whenever the user moves the mouse pointer over a link.
- **Check Plugin**  Lets you check to see if visitors to your site have the required plug-in installed, then route them to different URLs, depending on whether they have the right plug-in. This only applies to plug-ins, as the Check Plugin behavior does not check for ActiveX controls.

**Use parameters to control media objects**

Define special parameters to control SWF files and plug-ins. Parameters are used with the *object, embed,* and *applet* tags. Parameters set attributes specific to different types of objects. For example, a SWF file can use a quality parameter `<param name='quality' value='best'>` for the object tag. The Parameter dialog box is available from the Property inspector. See the documentation for the object you're using for information on the parameters it requires.

**Note:**

*There is no widely accepted standard for identifying data files for ActiveX controls. Consult the documentation for the ActiveX control you're using to find out which parameters to use.*

**Enter a name and value for a parameter**

1. Select an object that can have parameters in the Document window.
2. Open the Property inspector if it isn't already open, and click the Parameters button found in the lower half of the Property inspector. (Make sure the Property inspector is expanded.)
3. Click the Plus (+) button and enter the parameter name and value in the appropriate columns.

**Remove a parameter**

Select a parameter and press the minus (–) button.

**Reorder parameters**

Select a parameter, and use the up and down arrow buttons.

---

**Adding videos in Dreamweaver**

**Embed videos in web pages (HTML5)**

HTML5 supports video and audio tags that allow users to play video and audio files in a browser, without an external plug-in or player. Dreamweaver supports code hints for adding video and audio tags.

Live View renders the video, providing a preview of the video that you are embedding in the web page.

**Note:**
Although you can embed any video in your web page, Live View does not always render all videos. The audio and video tags are supported in Dreamweaver using the Apple QuickTime plug-in. In Windows, if the Apple QuickTime plug-in is not installed, the web page does not render the media content.

To know how to insert HTML5 video, see Insert HTML5 video.

Inserting FLV files

Insert FLV files
You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an encoded FLV file before you begin.

Dreamweaver inserts a SWF component that displays the FLV file; when viewed in a browser, this component displays the selected FLV file, as well as a set of playback controls.

Dreamweaver gives you the following options for delivering FLV video to your site visitors:

**Progressive Download Video** Downloads the FLV file to the site visitor’s hard disk and then plays it. Unlike traditional “download and play” methods of video delivery, however, progressive download allows the video file to start playing before the download is complete.

**Streaming Video** Streams the video content and plays it on a web page after a short buffer period that ensures smooth playback. To enable streaming video on your web pages, you must have access to Adobe® Flash® Media Server.

You must have an encoded FLV file before you can use it in Dreamweaver. You can insert video files created with two kinds of codecs (compression/decompression technologies): Sorenson Squeeze and On2.

As with regular SWF files, when you insert an FLV file, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player to view the video. If the user does not have the correct version, the page displays alternative content that prompts the user to download the latest version of Flash Player.

**Note:**
To view FLV files, users must have Flash Player 8 or later installed on their computers. If a user does not have the required version of Flash Player installed, but does have Flash Player 6.0 r65 or later installed, the browser displays a Flash Player express installer instead of the alternative content. If the user declines the express install, the page then displays the alternative content.

For more information about working with video, visit the Video Technology Center at www.adobe.com/go/flv_devcenter.

Insert an FLV file
1 Select Insert > HTML > Flash Video.

2 In the Insert FLV dialog box, select Progressive Download Video or Streaming Video from the Video Type pop-up menu.

3 Complete the rest of the dialog box options and click OK.

Note:
Microsoft Internet Information Server (IIS) does not process nested object tags. For ASP pages, Dreamweaver uses nested object/embed code instead of nested object code when inserting SWF or FLV files.

Set options for progressive download video
The Insert FLV dialog box lets you set options for progressive download delivery of an FLV file inserted in a web page.

1 Select Insert > HTML > Flash Video (or click the Flash Video icon in the HTML category of the Insert panel).

2 In the Insert FLV dialog box, select Progressive Download Video from the Video Type menu.
3 Specify the following options:

**URL** Specifies a relative or absolute path to the FLV file. To specify a relative path (for example, mypath/myvideo.flv), click the Browse button, navigate to the FLV file, and select it. To specify an absolute path, type the URL (for example, http://www.example.com/myvideo.flv) of the FLV file.

**Skin** Specifies the appearance of the video component. A preview of the selected skin appears beneath the Skin pop-up menu.

**Width** The width of the FLV file, in pixels. Dreamweaver determines the width of the FLV file and you can see the width automatically appearing in this field.

**Height** The height of the FLV file, in pixels. Dreamweaver automatically optimizes the height of the FLV file and you can see the height automatically appear in this field.

**Note:**

Total With Skin is the width and height of the FLV file plus the width and height of the selected skin.

**Constrain** Maintains the same aspect ratio between the width and height of the video component. This option is selected by default.

**Auto Play** Specifies whether to play the video when the web page is opened.

**Auto Rewind** Specifies whether the playback control returns to starting position after the video finishes playing.

4 Click OK to close the dialog box and add the FLV file to your web page.

The Insert FLV command generates a video player SWF file and a skin SWF file that are used to display your video content on a web page. (To see the new files, you may need to click the Refresh button in the Files panel.) These files are stored in the same directory as the HTML file to which you’re adding video content. When you upload the HTML page containing the FLV file, Dreamweaver uploads these files as dependent files (as long as you click Yes in the Put Dependent Files dialog box).
Set options for streaming video

The Insert FLV dialog box lets you set options for streaming video download of an FLV file inserted in a web page.

1. Select Insert > HTML > Flash Video (or click the Flash Video icon in the HTML category of the Insert panel).
2. Select Streaming Video from the Video Type pop-up menu.

![Setting options for streaming video]

Server URI  Specifies the server name, application name, and instance name in the form rtmp://www.example.com/app_name/instance_name.

Stream Name  Specifies the name of the FLV file that you want to play (for example, myvideo.flv). The .flv extension is optional.

Skin  Specifies the appearance of the video component. A preview of the selected skin appears beneath the Skin pop-up menu.

Width  The width of the FLV file, in pixels. Dreamweaver determines the width of the FLV file, and autopopulates the width in this field.

Height  The height of the FLV file, in pixels. Dreamweaver determines the height of the FLV file, and autopopulates the height in pixels, in this field.

Note:

Total With Skin is the width and height of the FLV file plus the width and height of the selected skin.

Constrain  Maintains the same aspect ratio between the width and height of the video component. This option is selected by default.

Live Video Feed  Specifies whether the video content is live. If Live Video Feed is selected, Flash Player plays a live video feed streamed from Flash Media Server. The name of the live video feed is the name specified in the Stream Name text box.
Note:

To enable Live Video Feed, you must select the one of the Halo skin options from the Skin field. When you select Live Video Feed, only the volume control appears on the component’s skin, because you cannot manipulate live video. Additionally, the Auto Play and Auto Rewind options have no effect.

Auto Play  Specifies whether to play the video when the web page is opened.

Auto Rewind  Specifies whether the playback control returns to starting position after the video finishes playing.

Buffer Time  Specifies the time, in seconds, required for buffering before the video starts playing. The default buffer time is set to 0 so that the video starts playing instantly after the Play button is clicked. (If Auto Play is selected, the video starts playing as soon as a connection is made with the server.) You might want to set a buffer time if you are delivering video that has a higher bit rate than the site visitor’s connection speed, or when Internet traffic might cause bandwidth or connectivity problems. For example, if you want to send 15 seconds of video to the web page before the web page starts to play the video, set the buffer time to 15.

3 Click OK to close the dialog box and add the FLV file to your web page.

The Insert FLV command generates a video player SWF file and a skin SWF file that are used to display your video on a web page. The command also generates a main.asc file that you must upload to your Flash Media Server. (To see the new files, you may need to click the Refresh button in the Files panel.) These files are stored in the same directory as the HTML file to which you’re adding video content. When you upload the HTML page containing the FLV file, don’t forget to upload the SWF files to your web server, and the main.asc file to your Flash Media Server.

Note:

If you already have a main.asc file on your server, check with your server administrator before uploading the main.asc file generated by the Insert FLV command.

You can easily upload all of the required media files by selecting the video component placeholder in the Dreamweaver Document window, and clicking the Upload Media button in the Property inspector (Window > Properties). To see a list of required files, click Show required files.

Note:

The Upload Media button does not upload the HTML file that contains the video content.

Edit Flash Player download information

When you insert an FLV file in a page, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player. If not, the page displays default alternative content that prompts the user to download the latest version. You can change this alternative content at any time.

This procedure also applies to SWF files.

Note:

If a user does not have the required version but does have Flash Player 6.0 r65 or later, the browser displays a Flash Player express installer. If the user declines the express install, the page then displays the alternative content.

1 In the Design view of the Document window, select the SWF file or FLV file.

2 Click the eye icon in the SWF file or FLV file.

You can also press Control + [ to switch to alternative content view. To return to SWF/FLV view, press Control + ] until all of the alternative content is selected. Then press Control + [ again.
3  Edit the content just as you would edit any other content in Dreamweaver.

   Note:

   You cannot add SWF files or FLV files as alternative content.

4  Click the eye icon again to return to the SWF or FLV file view.

**Troubleshoot FLV files**

This section details some of the most common causes of problems with FLV files.

**Viewing problems caused by absence of related files**

The code generated by Dreamweaver CS4 and later relies on four dependent files, different from the FLV file itself:

- swfobject_modified.js
- expressInstall.swf
- FLVPlayer_Progressive.swf
- The skin file (for example Clear_Skin_1.swf)

Note that there are two more dependent files for Dreamweaver CS4 and later, compared to Dreamweaver CS3.

The first two of these files (swfobject_modified.js and expressInstall.swf) are installed in a folder called Scripts, which Dreamweaver creates in the root of your site if it doesn’t already exist.

The second two files (FLVPlayer_Progressive.swf and the skin file) are installed in the same folder as the page in which the FLV is embedded. The skin file contains the controls for the FLV, and its name depends on the skin chosen in the options described in Dreamweaver Help. For example, if you choose Clear Skin, the file is named Clear_Skin_1.swf.

All four dependent files MUST be uploaded to your remote server for the FLV to display correctly.

Forgetting to upload these files is the most common cause of FLV files failing to run correctly in a web page. If one of the files is missing, you might see a “white box” on the page.

To ensure that you’ve uploaded all of the dependent files, use the Dreamweaver Files panel to upload the page in which the FLV appears. When you upload the page, Dreamweaver asks you if you want to upload dependent files (unless you’ve turned off this option). Click yes to upload dependent files.

**Viewing problems when previewing pages locally**

Because of security updates in Dreamweaver CS4, you cannot use the Preview in Browser command to test a page with an embedded FLV unless you define a local testing server in your Dreamweaver site definition and use the testing server to preview the page.

Normally, you require a testing server only if you are developing pages with ASP, ColdFusion, or PHP (see *Set up your computer for application development*). If you are building websites that use only HTML, and haven’t defined a testing server, pressing F12 (Windows) Opt+F12 (Macintosh) produces a jumble of skin controls onscreen. The workaround is either to define the testing server and use the testing server to preview your page, or upload your files to a remote server and view them there.

   Note:

   It’s possible that security settings may also be responsible for an inability to preview local FLV content, but Adobe has not been able to confirm this. You can try changing your security settings to see if it helps. For more information on changing your security settings, see Tech Note 117502.
Other possible causes for problems with FLV files

- If you are having trouble previewing locally, make sure the Preview using temporary file option is deselected under Edit > Preferences > Real-time Preview.
- Make sure you have the latest FlashPlayer plug-in.
- Be wary of moving files and folders around outside of Dreamweaver. When you move files and folders outside of Dreamweaver, Dreamweaver cannot guarantee the correct paths to FLV-related files.
- You can temporarily replace the FLV file that’s giving you trouble with a known working FLV file. If the replacement FLV file works, then the problem is with the original FLV file, and not with your browser or computer.

Edit or delete an FLV component

Change the settings for the video on your web page, by selecting the video component placeholder in the Dreamweaver Document window and using the Property inspector. Another way is to delete the video component and reinsert it by selecting Insert > HTML > Flash Video.

Edit the FLV component

1. Select the video component placeholder in the Dreamweaver Document window by clicking the FLV icon at the center of the placeholder.
2. Open the Property inspector (Window > Properties) and make your changes.

Note:
You cannot change video types (from progressive download to streaming, for example) by using the Property inspector. To change the video type, delete the FLV component, and reinsert it by selecting Insert > Media > FLV.

Delete the FLV component

? Select the FLV component placeholder in the Dreamweaver Document window and press Delete.

Add video (other formats)

To know how to add videos that are not .flv files, see Add video (non-FLV).

You may also want to know Insert plug-in content to play .mp3 files or Quicktime videos in your Dreamweaver site.

Insert HTML5 video

Dreamweaver allows you to insert HTML5 video into web pages.

The HTML5 video element provides a standard way to embed movies or videos in web pages.

For more information on HTML5 video element, see the article on HTML5 Video at W3schools.com.

Insert HTML5 video

1. Ensure that your cursor is at the location where you want to insert the video.
2. Select Insert > HTML > HTML5 Video. The HTML5 video element is inserted at the specified location.
3. In the Properties panel, specify values for the various options.
Source / Alt Source 1 / Alt Source 2: In Source, enter the location of the video file. Alternatively, click the folder icon to select a video file from the local file system. Support for a video format varies on different browsers. If the video format in Source is not supported on a browser, the video format specified in Alt Source 1 or Alt Source 2 is used. The browser selects the first recognized format to display the video.

![Specifying properties for HTML5 video]

To quickly add videos to the three fields, use multiple selection. When you choose three video formats for the same video from a folder, the first format in the list is used for the Source. The following formats in the list are used to auto-fill Alt Source 1 and Alt Source 2.

See the table below for more information on browser and supported video format. For the latest info, see HTML5 - Browser Support.

<table>
<thead>
<tr>
<th>Browser</th>
<th>MP4</th>
<th>WebM</th>
<th>Ogg</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer 9</td>
<td>YES</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Firefox 4.0</td>
<td>NO</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Google Chrome 6</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Apple Safari 5</td>
<td>YES</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Opera 10.6</td>
<td>NO</td>
<td>YES</td>
<td>YES</td>
</tr>
</tbody>
</table>

- **Title**: Specify a title for the video.
- **Width (W)**: Enter the width in pixel of the video.
- **Height (H)**: Enter the height in pixel of the video.
- **Controls**: Select if you want to display the video controls such as Play, Pause, and Mute in the HTML page.
- **Autoplay**: Select if you want the video to start playing as soon as it loads on the web page.
- **Poster**: Enter the location of the image you want displayed until the video completes downloading, or until the user clicks Play. The Width and Height values are auto-filled when you insert the image.
- **Loop**: Select this option if you want the video to continuously play until the user stops playing the movie.
- **Muted**: Select this option if you want to mute the audio portion of the video.
- **Flash Video**: Select a SWF file for browsers that do not support HTML5 video.
- **Fallback text**: Provide the text to display if the browser doesn’t support HTML5.
- **Preload**: Specifies the author preferences on how the video should be loaded when the page loads. Selecting Auto loads the entire video on page download. Selecting Metadata downloads only the metadata after the page download is complete.
Preview the video in browser

1. Save the web page.
2. Select File > Real-time Preview. Select the browser in which you want to preview the video.

Insert SWF files

Before you use Dreamweaver to insert content created with Adobe Animate, you should be familiar with the following different file types:

**FLA file (.fla)** The source file for any project and created in the Flash authoring tool. This type of file can only be opened in Flash (not in Dreamweaver or in browsers). You can open the FLA file in Flash, then publish it as a SWF or SWT file to use in browsers.

**SWF file (.swf)** A compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash.

**FLV file (.flv)** A video file that contains encoded audio and video data for delivery through Flash Player. For example, if you had a QuickTime or Windows Media video file, you would use an encoder (such as Flash Video Encoder, or Sorenson Squeeze) to convert the video file to an FLV file. For more information, visit the Video Technology Center at [www.adobe.com/go/flv_devcenter](http://www.adobe.com/go/flv_devcenter).

Insert and preview SWF files

Use Dreamweaver to add SWF files to your pages, and then preview them in a document or a browser. You can also set properties for SWF files in the Property inspector.

Insert a SWF file

1. In the Design view of the Document window, place the insertion point where you want to insert the content, then do one of the following:
   - In the Insert panel, select Select Flash SWF.
   - Select Insert > HTML > Flash SWF.

2. In the dialog box that appears, select a SWF file (.swf).
   A SWF file placeholder appears in the Document window.

3. Save the file.

Dreamweaver informs you that two dependent files, expressInstall.swf and swfobject_modified.js, are being saved to a Scripts folder in your site. Don't forget to upload these files when you upload the SWF file to your web server. Browsers can't display the SWF file properly unless you have also uploaded these dependent files.

**Note:**

*Microsoft Internet Information Server (IIS) does not process nested object tags. For ASP pages, Dreamweaver uses nested object/embed code instead of nested object code when inserting SWF or FLV files.*
Edit Flash Player download information

When you insert a SWF file in a page, Dreamweaver inserts code that detects whether the user has the correct version of Flash Player. If not, the page displays default alternative content that prompts the user to download the latest version. You can change this alternative content at any time.

This procedure also applies to FLV files.

*Note:* If a user does not have the required version but does have Flash Player 6.0 r65 or later, the browser displays a Flash Player express installer. If the user declines the express install, the page then displays the alternative content.

1. In the Design view of the Document window, select the SWF file or FLV file.
2. Click the eye icon in the tab of the SWF file or FLV file.
3. Edit the content just as you would edit any other content in Dreamweaver.
   
   *Note:* You cannot add SWF files or FLV files as alternative content.
4. Click the eye icon again to return to the SWF (or FLV) file view.

Preview SWF files in the Document window

1. In the Document window, click the SWF file placeholder to select the content.
2. In the Property inspector (Window > Properties), click the Play button. Click Stop to end the preview. You can also preview the SWF file in a browser by pressing F12.

   To preview all SWF files in a page, press Control+Alt+Shift+P (Windows) or Command+Option+Shift+P (Macintosh). All SWF files are set to Play.

Set SWF file properties

You can set properties for SWF files using the Property inspector. The properties are also applicable to Shockwave movies.

1. Select a SWF file or a Shockwave movie and set the options in the Property inspector (Window > Properties). To see all properties, click the expander arrow in the lower-right corner of the Property inspector.
   
   **ID** Specifies a unique ID for the SWF file. Enter an ID in the unlabeled text box on the far left side of the Property inspector. As of Dreamweaver CS4, a unique ID is required.

   **W and H** Specify the width and height of the movie, in pixels.

   **File** Specifies the path to the SWF file or Shockwave file. Click the folder icon to browse to a file, or type a path.

   **Src** Specifies the path to the source document (the FLA file), when Dreamweaver and Flash are both installed on your computer. To edit a SWF file, update the movie's source document.
**Bg** Specifies a background color for the movie area. This color also appears while the movie is not playing (while loading and after playing).

**Edit** Starts Flash to update a FLA file (a file created in the Flash authoring tool). This option is disabled if you do not have Flash installed on your computer.

**Class** Lets you apply a CSS class to the movie.

**Loop** Makes the movie play continuously. When Loop is not selected, the movie plays once and stops.

**Autoplay** Automatically plays the movie when the page loads.

**V Space and H Space** Specifies the number of pixels of white space above, below, and on both sides of the movie.

**Quality** Controls anti-aliasing during playback of the movie. High settings improve the appearance of movies. However, at high settings movies require a faster processor to render correctly on the screen. Low favors speed over appearance, whereas High favors appearance over speed. Auto Low favors speed at first but improves appearance when possible. Auto High favors both qualities equally at first but later sacrifices appearance for speed if necessary.

**Scale** Determines how the movie fits into the dimensions set in the width and height text boxes. The Default setting displays the entire movie.

**Align** Determines how the movie is aligned on the page.

**Wmode** Sets the Wmode parameter for the SWF file to avoid conflicts with DHTML elements, such as Spry widgets. The default value is Opaque, which allows DHTML elements to appear on top of SWF files in a browser. If the SWF file includes transparencies and you want DHTML elements to appear behind them, select the Transparent option. Select the Window option to remove the Wmode parameter from the code and allow the SWF file to appear on top of other DHTML elements.

**Play** Plays the movie in the Document window.

**Parameters** Opens a dialog box for entering additional parameters to pass to the movie. The movie must be designed to receive these additional parameters.

### Add audio effects

You can add sound to a web page. There are several different types of sound files and formats, including .wav, .midi, and .mp3. Some factors to consider before deciding on a format and method for adding sound are its purpose, your audience, file size, sound quality, and differences in browsers.

**Note:**

*Sound files are handled very differently and inconsistently by different browsers. You may want to add a sound file to a SWF file and then embed the SWF file to improve consistency.*

The following list describes the more common audio file formats along with some of the advantages and disadvantages of each for web design.

- **.midi or .mid (Musical Instrument Digital Interface)** This format is for instrumental music. MIDI files are supported by many browsers and don’t require a plug-in. Although their sound quality is very good, it can vary depending on a visitor’s sound card. A small MIDI file can provide a long sound clip. MIDI files cannot be recorded and must be synthesized on a computer with special hardware and software.

- **.wav (Waveform Extension)** These files have good sound quality, are supported by many browsers, and don’t require a plug-in. You can record your own WAV files from a CD, tape, microphone, and so on. However, the large file size severely limits the length of sound clips that you can use on your web pages.
.aif (Audio Interchange File Format, or AIFF) The AIFF format, like WAV format, has good sound quality, can be played by most browsers, and doesn’t require a plug-in; you can also record AIFF files from a CD, tape, microphone, and so on. However, the large file size severely limits the length of sound clips that you can use on your web pages.

.mp3 (Motion Picture Experts Group Audio, or MPEG-Audio Layer-3) A compressed format that makes sound files substantially smaller. The sound quality is very good: if an mp3 file is recorded and compressed properly, its quality can rival that of a CD. mp3 technology lets you “stream” the file so that a visitor doesn’t have to wait for the entire file to download before hearing it. However, the file size is larger than a Real Audio file, so an entire song could still take quite a while to download over a typical dial-up (telephone line) modem connection. To play mp3 files, visitors must download and install a helper application or plug-in, such as QuickTime, Windows Media Player or RealPlayer.

.ra, .ram, .rpm, or Real Audio This format has a high degree of compression, with smaller file sizes than mp3. Entire song files can be downloaded in a reasonable amount of time. Because the files can be “streamed” from a normal web server, visitors can begin listening to the sound before the file has completely downloaded. Visitors must download and install the RealPlayer helper application or plug-in to play these files.

.qt, .qtm, .mov or QuickTime This format is both an audio and video format developed by Apple Computer. QuickTime is included with Apple Macintosh operating systems, and is used by most Macintosh applications that use audio, video, or animation. PCs can also play files in QuickTime format, but require a special QuickTime driver. QuickTime supports most encoding formats, including Cinepak, JPEG, and MPEG.

Note:
In addition to the more common formats listed above, there are many different audio and video file formats available for use on the web. If you encounter a media file format that you are unfamiliar with, locate the creator of the format for information on how best to use and deploy it.

Link to an audio file
Linking to an audio file is a simple and effective way to add sound to a web page. This method of incorporating sound files lets visitors choose whether they want to listen to the file, and makes the file available to the widest audience.

1. Select the text or image you want to use as the link to the audio file.

2. In the Property inspector, click the folder icon next to the Link text box to browse for the audio file, or type the file’s path and name in the Link text box.

Embed a sound file
Embedding audio incorporates the sound directly into the page, but the sound only plays if visitors to your site have the appropriate plug-in for the chosen sound file. Embed files if you want to use the sound as background music, or if you want to control the volume, the way the player looks on the page, or the beginning and ending points of the sound file.

When incorporating sound files in your web pages, carefully consider their appropriate use in your web site, and how visitors to your site use these media resources. Always provide a control to either enable or disable the playing of the sound, in the event that visitors don’t want to listen to the audio content.

1. In Design view, place the insertion point where you want to embed the file and do one of the following:
   - In the HTML category of the Insert panel, select the Plugin icon 🎧 from the pop-up menu.
   - Select Insert > HTML > Plugin.
2 Browse for the audio file and click OK.
3 Enter the width and height by entering the values in the appropriate text boxes in the Property inspector or by resizing the plug-in placeholder in the Document window.

These values determine the size at which the audio controls are displayed in the browser.

**Insert HTML5 audio in Dreamweaver**

Dreamweaver allows you to insert and preview HTML5 audio in web pages. The HTML5 audio element provides a standard way to embed audio content into web pages.

For more information on HTML5 audio element, see the article on HTML5 audio at [W3schools.com](http://W3schools.com).

**Insert HTML5 audio**

1 Ensure that your cursor is at the location where you want to insert the audio.
2 Select Insert > HTML > HTML5 Audio. The audio file is inserted at the specified location.
3 In the Properties Inspector, enter the following information:
   - **Source / Alt Source 1 / Alt Source 2**: In Source, enter the location of the audio file. Alternatively, click the folder icon to select an audio file from your computer. Support for audio formats varies on different browsers. If the audio format in Source is not supported, the format specified in Alt Source 1 or Alt Source 2 is used. The browser selects the first recognized format to display the audio.

   *To quickly add videos to the three fields, use multiple selection. When you choose three video formats for the same video from a folder, the first format in the list is used for the Source. The following formats in the list are used to auto-fill Alt Source 1 and Alt Source 2.*

<table>
<thead>
<tr>
<th>Browser</th>
<th>MP3</th>
<th>Wav</th>
<th>Ogg</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Explorer 9</td>
<td>YES</td>
<td>NO</td>
<td>NO</td>
</tr>
<tr>
<td>Firefox 4.0</td>
<td>NO</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Google Chrome 6</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Apple Safari 5</td>
<td>YES</td>
<td>YES</td>
<td>NO</td>
</tr>
<tr>
<td>Opera 10.6</td>
<td>NO</td>
<td>YES</td>
<td>YES</td>
</tr>
</tbody>
</table>

   - **Title**: Enter a title for the audio file.
   - **Fallback text**: Enter the text to be displayed in browsers that do not support HTML5.
   - **Controls**: Select if you want to display audio controls such as Play, Pause, and Mute in the HTML page.
   - **Autoplay**: Select if you want the audio to start playing as soon as it loads on the web page.
   - **Loop Audio**: Select this option if you want the audio to continuously play until the user stops playing it.
   - **Mute**: Select this option if you want to mute the audio after download.
   - **Preload**: Selecting Auto loads the entire audio file on page download. Selecting Metadata downloads only the metadata after the page download is complete.
Preview the audio in browser

1. Save the web page.
2. Select File > Real-time Preview. Select the browser in which you want to preview the audio.

Work with library items

A library is a special Dreamweaver file containing a collection of individual assets or copies of assets that you can place in your web pages. The assets in a library are called library items. Items that you can store in a library include images, tables, sounds, and files created with Adobe Flash. You can automatically update all the pages that use a library item whenever you edit the item.

For example, suppose you’re building a large site for a company that wants a slogan to appear on every page. You can create a library item to contain the slogan and use that library item on every page. If the slogan changes, you can change the library item and automatically update every page that uses it.

Dreamweaver stores library items in a Library folder within the local root folder for each site. Each site has its own library.

You can create a library item from any element in the body section of a document, including text, tables, forms, Java applets, plug-ins, ActiveX elements, navigation bars, and images.

For linked items such as images, the library stores only a reference to the item. The original file must remain at the specified location for the library item to work correctly.

It can still be useful to store an image in a library item, though. For example, you could store a complete img tag in a library item, which would allow you to easily change the image’s alt text, or even its src attribute, throughout the site. (Don’t use this technique to change an image’s width and height attributes, though, unless you also use an image editor to change the actual size of the image.)

Note:

If the library item contains links, the links may not work in the new site. Also, images in a library item aren’t copied to the new site.

When you use a library item, Dreamweaver inserts a link to it, rather than the item itself, in the web page. That is, Dreamweaver inserts a copy of the HTML source code for that item into the document and adds an HTML comment containing a reference to the original, external item. It is this external reference that makes automatic updating possible.

When you create a library item that includes an element with a Dreamweaver behavior attached to it, Dreamweaver copies the element and its event handler (the attribute that specifies which event triggers the action, such as onClick, onLoad, or onMouseOver, and which action to call when the event occurs) to the library item file. Dreamweaver does not copy the associated JavaScript functions into the library item. Instead, when you insert the library item into a document, Dreamweaver automatically inserts the appropriate JavaScript functions into the head section of that document (if they aren’t already there).

Note:

If you hand-code JavaScript (that is, if you create it without using Dreamweaver behaviors), you can make it part of a library item if you use the Call JavaScript behavior to execute the code. If you don’t use a Dreamweaver behavior to execute the code, the code isn’t retained as part of the library item.

There are special requirements for editing the behaviors in library items. Library items cannot contain style sheets, because the code for those elements is part of the head section.
Create a library item based on a selection
1. In the Document window, switch to Design view and select a portion of a document to save as a library item.
2. Select Tools > Library > Add Object to Library.
3. Type a name for the new library item, then press Enter (Windows) or Return (Macintosh).
   Dreamweaver saves each library item as a separate file (with the file extension .lbi) in the Library folder of the site's local root folder.

Create an empty library item
1. Make sure nothing is selected in the Document window.
   If something is selected, it will be placed in the new library item.
2. In the Assets panel, select the Library category.
3. Click the New Library Item button at the bottom of the panel.
4. While the item is still selected, enter a name for it, then press Enter (Windows) or Return (Macintosh).

Insert a library item into a document
When you add a library item to a page, the actual content is inserted in the document along with a reference to the library item.
1. Place the insertion point in the Document window.
2. In the Assets panel, select the Library category.
3. Do one of the following:
   • Drag a library item from the Assets panel to the Document window.

   *To insert the contents of a library item without including a reference to the item in the document, press Control (Windows) or Option (Macintosh) while dragging an item out of the Assets panel. If you insert an item this way, you can edit the item in the document, but the document won't be updated when you update pages that use that library item.*
   • Select a library item, and click Insert.

Edit library items and update documents
When you edit a library item, you can update all documents that use that item. If you choose not to update, the documents remain associated with the library item; you can update them later.
You can rename items to break their connection with documents or templates, delete items from the site’s library, and recreate a missing library item.

Edit a library item
1. In the Assets panel, select the Library category.
2. Select a library item.
3. Either Click the Edit button or double-click the library item.
Dreamweaver opens a new window, similar to the Document window, for editing the library item. The gray background indicates that you’re editing a library item instead of a document.

4 Make and then save your changes.

5 Specify whether to update the documents on the local site that use the library item. Select Update to update immediately. If you select Don’t Update, documents won’t be updated until you choose Tools > Library > Update Current Page or Update Pages.

**Update the current document to use the current version of all library items**

7 Select Tools > Library > Update Current Page.

**Update the entire site or all documents that use a particular library item**

1 Select Tools > Library > Update Pages.

2 In the Look In pop-up menu, specify what to update:
   - To update all pages in the selected site to use the current version of all library items, select Entire Site, then select the site name from the adjacent pop-up menu.
   - To update all pages in the current site that use the library item, select Files That Use, then select a library item name from the adjacent pop-up menu.

3 Make sure that Library Items is selected in the Update option.

   *To update templates at the same time, select Templates as well.*

4 Click Start.

Dreamweaver updates the files as indicated. If you selected the Show Log option, Dreamweaver generates a report showing whether files were updated successfully, along with other information.

**Rename a library item**

1 In the Assets panel, select the Library category.

2 Select the library item, pause, and then click again. (Do not double-click; double-clicking opens the item for editing.)

3 Enter a new name.

4 Click elsewhere, or press Enter (Windows) or Return (Macintosh).

5 Specify whether to update documents that use the item by choosing either Update or Don’t Update.

**Delete a library item from a library**

When you delete a library item, Dreamweaver removes it from the library but doesn’t change the contents of any documents that use the item.

1 In the Assets panel, select the Library category.

2 Select the library item.

3 Either click the Delete button or press the Delete key, then confirm that you want to delete the item.

*Note:*

*If you delete a library item, you can’t use Undo to retrieve it. You may be able to recreate it, however.*
Recreate a missing or deleted library item
1. Select an instance of the item in one of your documents.
2. Click the Recreate button in the Property inspector (Window > Properties).

Customize highlighting of library items
You can customize the highlight color of library items and show or hide highlighting by setting Highlighting preferences.

Change the highlight color of library items
1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select the Highlighting category from the list on the left of the Preferences dialog box.
3. Click the Library Items color box, then select a highlight color using the color picker (or enter the hexadecimal color value in the text box).
4. Select Show to display the highlight color in the Document window.
5. Click OK.

To show or hide highlighting in the Document window

Edit the properties of a library item
You can use the Property inspector to open a library item for editing, detach a selected library item from its source file, or overwrite an item with the currently selected library item.

1. Select a library item in a document.
2. Select one of these options in the Property inspector (Window > Properties):
   - **Src** Displays the filename and location of the source file for the library item. You can't edit this information.
   - **Open** Opens the library item's source file for editing. This is equivalent to selecting the item in the Assets panel and clicking the Edit button.
   - **Detach From Original** Breaks the link between the selected library item and its source file. You can edit the detached item in the document, but it's no longer a library item and isn't updated when you change the original.
   - **Recreate** Overwrites the original library item with the current selection. Use this option to re-create library items if the original library item is missing or has been accidentally deleted.

Make library items editable in a document
If you've added a library item to your document and you want to edit the item specifically for that page, you must break the link between the item in the document and the library. Once you've made an instance of a library item editable, that instance isn't updated when the library item changes.

1. Select a library item in the current document.
2. Click Detach From Original in the Property inspector (Window > Properties).
Edit a behavior in a library item
To edit a behavior in a library item, you must first insert the item in a document, then make the item editable in that document. After you've made the changes, you can re-create the library item, replacing the item in the library with the edited item from your document.

1. Open a document that contains the library item.
   Note the name of the library item, as well as the exact tags it contains. You’ll need this information later.
2. Select the library item, and then click Detach From Original in the Property inspector (Window > Properties).
3. Select the element that has the behavior attached to it.
4. In the Behaviors panel (Window > Behaviors), double-click the action you want to change.
5. In the dialog box that appears, make your changes, then click OK.
6. In the Assets panel, select the Library category.
7. Record the exact name and capitalization of the original library item; select it, then click the Delete button.
8. In the Document window, select all the elements that make up the library item.
   Be careful to select exactly the same elements that were in the original library item.
9. In the Assets panel, click the New Library Item button, then give the new item the same name as the item you deleted, using the same spelling and capitalization.
10. To update the library item in your site's other documents, select Tools > Library > Update Pages.
11. In the Look In pop-up menu, select Files That Use.
12. In the adjacent pop-up menu, select the name of the library item you just created.
13. In the Update option, make sure Library Items is selected, then click Start.
14. When the updates are complete, click Close.

Using Arabic and Hebrew text in Dreamweaver
Chapter 9: Linking and navigation

About linking and navigation

After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll want to create connections from your documents to other documents.

Dreamweaver provides several ways to create links to documents, images, multimedia files, or downloadable software. You can establish links to any text or image anywhere within a document, including text or images in a heading, list, table, absolutely-positioned element (AP element), or frame.

There are several different ways of creating and managing links. Some web designers prefer to create links to nonexistent pages or files as they work, while others prefer to create all the files and pages first and then add the links. Another way to manage links is to create placeholder pages, in which you add and test links before completing all your site pages.

Absolute, document-relative, and site root-relative paths

Understanding the file path between the document you’re linking from and the document or asset you’re linking to is essential to creating links.

Each web page has a unique address, called a Uniform Resource Locator (URL). However, when you create a local link (a link from one document to another on the same site), you generally don’t specify the entire URL of the document you’re linking to; instead, you specify a relative path from the current document or from the site’s root folder.

There are three types of link paths:

- Absolute paths (such as http://www.adobe.com/support/dreamweaver/contents.html).
- Document-relative paths (such as dreamweaver/contents.html).
- Site root–relative paths (such as /support/dreamweaver/contents.html).

Using Dreamweaver, you can easily select the type of document path to create for your links.

Note:

It is best to use the type of linking you prefer and are most comfortable with—either site root- or document-relative. Browsing to links, as opposed to typing in the paths, ensures that you always enter the right path.

Absolute paths

Absolute paths provide the complete URL of the linked document, including the protocol to use (usually http:// for web pages), for example, http://www.adobe.com/support/dreamweaver/contents.html. For an image asset, the complete URL might be something like http://www.adobe.com/support/dreamweaver/images/image1.jpg.

You must use an absolute path to link to a document or asset on another server. You can also use absolute paths for local links (to documents in the same site), but that approach is discouraged—if you move the site to another domain, all of your local absolute-path links will break. Using relative paths for local links also provides greater flexibility if you need to move files within your site.
Note:

When inserting images (not links), you can use an absolute path to an image on a remote server (that is, an image that is not available on the local hard drive).

**Document-relative paths**

*Document-relative paths* are usually best for local links in most websites. They're particularly useful when the current document and the linked document or asset are in the same folder and are likely to remain together. You can also use a document-relative path to link to a document or asset in another folder by specifying the path through the folder hierarchy from the current document to the linked document.

The basic idea of document-relative paths is to omit the part of the absolute path that is the same for both the current document and the linked document or asset, providing only the portion of the path that differs.

For example, suppose you have a site with the following structure:

- To link from contents.html to hours.html (both in the same folder), use the relative path hours.html.
- To link from contents.html to tips.html (in the resources subfolder), use the relative path resources/tips.html. At each slash (/), you move down one level in the folder hierarchy.
- To link from contents.html to index.html (in the parent folder, one level above contents.html), use the relative path ../index.html. Two dots and a slash (../) moves you up one level in the folder hierarchy.
- To link from contents.html to catalog.html (in a different subfolder of the parent folder), use the relative path ../products/catalog.html. Here, ../ moves you up to the parent folder, and products/ moves you down to the products subfolder.

When you move files as a group—for example, when you move an entire folder, so that all the files inside that folder retain the same relative paths to each other—you don’t need to update document-relative links between those files. However, when you move an individual file that contains document-relative links, or an individual file targeted by a document-relative link, you do need to update those links. (If you move or rename files using the Files panel, Dreamweaver updates all relevant links automatically.)

**Site root–relative paths**

*Site root–relative paths* describe the path from the site's root folder to a document. You may want to use these paths if you are working on a large website that uses several servers, or one server that hosts several sites. However, if you are not familiar with this type of path, you may want to stick to document-relative paths.

A site root–relative path begins with a leading forward slash, which stands for the root folder of the site. For example, /support/tips.html is a site root–relative path to a file (tips.html) in the support subfolder of the site's root folder.
A site root–relative path is often the best way to specify links if you frequently move HTML files from one folder to another in your website. When you move a document that contains site root–relative links, you don’t need to change the links since the links are relative to the site root, and not to the document itself; for example, if your HTML files use site root–relative links for dependent files (such as images), then if you move an HTML file, its dependent-file links are still valid.

However, when you move or rename the documents targeted by site root–relative links, you must update those links, even if the documents’ paths relative to each other haven’t changed. For example, if you move a folder, you must update all site root–relative links to files in that folder. (If you move or rename files using the Files panel, Dreamweaver updates all relevant links automatically.)

### Linking

Before creating a link, make sure you understand how absolute, document-relative, and site root–relative paths work. You can create several types of links in a document:

- A link to another document or to a file, such as a graphic, movie, PDF, or sound file.
- A named anchor link, which jumps to a specific location in a document.
- An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in.
- Null and script links, which you use to attach behaviors to an object or to create a link that executes JavaScript code.

You can use the Property inspector and the Point-To-File icon to create links from an image, an object, or text to another document or file.

Dreamweaver creates the links to other pages in your site using document-relative paths. You can also tell Dreamweaver to create new links using site root–relative paths.

**Note:**

Always save a new file before creating a document-relative path; a document-relative path is not valid without a definite starting point. If you create a document-relative path before saving the file, Dreamweaver temporarily uses an absolute path beginning with file:// until the file is saved; when you save the file, Dreamweaver converts the file:// path to a relative path.

### Attach JavaScript behaviors to links

You can attach a behavior to any link in a document. Consider using the following behaviors when you insert linked elements into documents:

- **Set Text Of Status Bar**  Determines the text of a message and displays it in the status bar at the lower left of the browser window. For example, you can use this behavior to describe the destination of a link in the status bar instead of showing the URL associated with it.

- **Open Browser Window**  Opens a URL in a new window. You can specify the properties of the new window, including its name, size, and attributes (whether it is resizable, has a menu bar, and so on).

- **Jump Menu**  Edits a jump menu. You can change the menu list, specify a different linked file, or change the browser location in which the linked document opens.

---

Last updated 11/7/2019
Link to documents using the Property inspector
You can use the Property inspector's folder icon or Link box to create links from an image, an object, or text to another document or file.

1 Select text or an image in the Document window’s Design view.
2 Open the Property inspector (Window > Properties) and do one of the following:
   • Click the folder icon to the right of the Link box to browse to and select a file.
     The path to the linked document appears in the URL box. Use the Relative To pop-up menu in the Select File dialog box to make the path document-relative or root-relative, and then click OK. The type of path you select applies only to the current link. (You can change the default setting of the Relative To box for the site.)
   • Type the path and filename of the document in the Link box.
     To link to a document in your site, enter a document-relative or site root–relative path. To link to a document outside your site, enter an absolute path including the protocol (such as http://). You can use this approach to enter a link for a file that hasn't been created yet.
3 From the Target drop-down list, select a location in which to open the document:
   • _blank loads the linked document in a new, unnamed browser window.
   • _parent loads the linked document in the parent frame or parent window of the frame that contains the link. If the frame containing the link is not nested, then the linked document loads in the full browser window.
   • _self loads the linked document in the same frame or window as the link. This target is the default, so you usually don’t have to specify it.
   • _top loads the linked document in the full browser window, thereby removing all frames.
   • _new loads the linked document in a new window.

Link to documents using the Point-To-File icon
1 Select text or an image in the Document window’s Design view.
2 Create a link in one of two ways:
   • Drag the Point-To-File icon (target icon) at the right of the Link box in the Property inspector and point to a visible anchor in the current document, a visible anchor in another open document, an element that has a unique ID assigned to it, or a document in the Files panel.
   • Shift-drag from the selection and point to a visible anchor in the current document, a visible anchor in another open document, an element that has a unique ID assigned to it, or a document in the Files panel.

Note:
You can link to another open document only if your documents are not maximized in the Document window. To tile documents, select Window > Arrange > Cascade or Window > Arrange > Tile. When you point to an open document, that document moves to the foreground of your screen while you are making your selection.

Add a link using the Hyperlink command
The Hyperlink command lets you create a text link to an image, an object, or to another document or file.

1 Place the insertion point in the document where you want the link to appear.
2 Do one of the following to display the Hyperlink dialog box:
   • Select Insert > Hyperlink.
• In the Common category of the Insert panel, click the Hyperlink button.

3. In the Text field, enter the text of the link. From the Link drop-down menu, select the name of the file to link to. You can also click the folder icon to browse to the file you want to link to.

4. In the Target pop-up menu, select the window in which the file should open or type its name.

   The names of all the frames you’ve named in the current document appear in the pop-up list. If you specify a frame that doesn’t exist, the linked page opens in a new window that has the name you specified. You can also select from the following reserved target names:
   • _blank loads the linked file into a new, unnamed browser window.
   • _parent loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
   • _self loads the linked file into the same frame or window as the link. This target is the default, so you usually don’t need to specify it.
   • _top loads the linked file into the full browser window, thereby removing all frames.
   • _new loads the linked document in a new window.

5. In the Tab Index box, enter a number for the tab order.

6. In the Title box, enter a title for the link.

7. In the Access Key box, enter a keyboard equivalent (one letter) to select the link in the browser.

8. Click OK.

Create link to a Word or Excel document

You can insert a link to a Microsoft Word or Excel document in an existing page.

1. In Design view, open the page where you want the link to appear.

2. Drag the file from its current location to your Dreamweaver page, positioning the link wherever you want.

   The Insert document dialog box appears.

3. Select Create A Link, and then click OK.
If the document you are linking to is located outside of your site's root folder, Dreamweaver prompts you to copy the document to the site root.

By copying the document to the site's root folder, you ensure that the document will be available when you publish the website.

When you upload your page to your web server, make sure to upload the Word or Excel file, too. Your page now contains a link to the Word or Excel document. The link text is the name of the linked file; you can change the link text in the Document window if you wish.

Set the relative path of new links

By default, Dreamweaver creates links to other pages in your site using document-relative paths. To use site root-relative path instead, you must first define a local folder in Dreamweaver by choosing a local root folder to serve as the equivalent of the document root on a server. Dreamweaver uses this folder to determine the site root-relative paths to files.

1. Select Site > Manage Sites.
2. In the Manage Sites dialog box, double-click your site in the list.
3. In the Site Setup dialog box, expand Advanced Settings and select the Local Info category.
4. Set the relative path of new links by selecting the Document or Site Root option.
   Changing this setting will not convert the path of existing links after you click OK. The setting applies only to new links you create with Dreamweaver.
5. Click Save.
   The new path setting applies only to the current site.

Link to a specific place in a document

You can use the Property inspector to link to a particular section of a document by first creating named anchors. Named anchors let you set markers in a document, which are often placed at a specific topic or at the top of a document. You can then create links to these named anchors, which quickly take your visitor to the specified position.

Creating a link to a named anchor is a two-step process. First, you create a named anchor; then you create a link to the named anchor.

Create an anchor

1. In the Document window select and highlight the item that you want to set as an anchor.
2. Open the Property Inspector and check if the selected item has an ID. If the ID field is blank, add an ID. For example, Anchor.
After you add the ID, notice the change in the code. `id="<ID name>"` is inserted in the code at your selection.

Add anchors for linking

**Link back to an anchor**

1. In the Document window’s Design view, select text or an image to create a link from.

2. In the Link box of the Property inspector, type a number sign (#) and the name of the anchor. For example, to link to an anchor named “top” in the current document, type `#top`. To link to an anchor named “top” in a different document in the same folder, type `filename.html#top`.

   **Note:**
   
   Anchor names are case-sensitive.

**Link to a named anchor using the Point-To-File method**

1. Open the document containing the named anchor.

   **Note:**
   
   If you don’t see the anchor, from the Design view select View > Design View Options > Visual Aids > Invisible Elements, to make anchors visible.

2. In the Document window’s Design view, select text or an image you want to link from. (If this is another open document, you must switch to it.)

3. Do one of the following:
   
   - Click the Point-To-File icon (target icon) to the right of the Link box in the Property inspector and drag it to the anchor you want to link to: either an anchor within the same document or an anchor in another open document.
   
   - Shift-drag in the Document window from the selected text or image to the anchor you want to link to: either an anchor within the same document or an anchor in another open document.

**Create an e-mail link**

An e-mail link opens a new blank message window (using the mail program associated with the user’s browser) when clicked. In the e-mail message window, the To box is automatically updated with the address specified in the e-mail link.

**Create an e-mail link using the Insert Email Link command**

1. In the Document window’s Design view, position the insertion point where you want the e-mail link to appear, or select the text or image you want to appear as the e-mail link.

2. Do one of the following to insert the link:
   
   - Select Insert > Email Link.
   
   - In the Common category of the Insert panel, click the Email Link button.

3. In the Text box, type or edit the body of the e-mail.

4. In the Email box, type the e-mail address, then click OK.
Create an e-mail link using the Property inspector
1 Select text or an image in the Document window's Design view.
2 In the Link box of the Property inspector, type mailto: followed by an e-mail address.
   Do not type any spaces between the colon and the e-mail address.

Auto-populate the subject line of an e-mail
1 Create an e-mail link using the Property inspector as outlined above.
2 In the Link box of the Property inspector, add ?subject= after the email, and type a subject after the equals sign. Do not type any spaces between the question mark and the end of the e-mail address.
   The complete entry would look as follows:
   mailto:someone@yoursite.com?subject=Mail from Our Site

Create null and script links
A null link is an undesignated link. Use null links to attach behaviors to objects or text on a page. For instance, you can attach a behavior to a null link so that it swaps an image or displays an absolutely-positioned element (AP element) when the pointer moves over the link.

Script links execute JavaScript code or call a JavaScript function and are useful for giving visitors additional information about an item without leaving the current web page. Script links can also be used to perform calculations, validate forms, or do other processing tasks when a visitor clicks a specific item.

Create a null link
1 Select text, an image, or an object in the Document window's Design view.
2 In the Property inspector, type javascript:; (the word javascript, followed by a colon, followed by a semicolon) in the Link box.

Create a script link
1 Select text, an image, or an object in the Document window's Design view.
2 In the Link box of the Property inspector, type javascript: followed by some JavaScript code or a function call. (Do not type a space between the colon and the code or call.)

Update links automatically
Dreamweaver can update links to and from a document whenever you move or rename the document within a local site. This feature works best when you store your entire site (or an entire self-contained section of it) on your local disk. Dreamweaver does not change files in the remote folder until you put the local files on or check them in to the remote server.

To make the updating process faster, Dreamweaver can create a cache file in which to store information about all the links in your local folder. The cache file is updated invisibly as you add, change, or delete links on your local site.

Enable automatic link updates
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 In the Preferences dialog box, select General from the category list on the left.
In the Document Options section of the General preferences, select an option from the Update Links When Moving Files pop-up menu.

- **Always**  Automatically updates all links to and from a selected document whenever you move or rename it.
- **Never**  Does not automatically update all links to and from a selected document when you move or rename it.
- **Prompt** Displays a dialog box that lists all the files affected by the change. Click Update to update the links in these files, or click Don’t Update to leave the files unchanged.

Click OK.

**Create a cache file for your site**

1. Select Site > Manage Sites.
2. Select a site, and then click Edit.
3. In the Site Setup dialog box, expand Advanced Settings and select the Local Info category.
4. In the Local Info category, select Enable Cache.

   The first time you change or delete links to files in your local folder after starting Dreamweaver, Dreamweaver prompts you to load the cache. If you click Yes, Dreamweaver loads the cache and updates all the links to the file you just changed. If you click No, the change is noted in the cache, but Dreamweaver does not load the cache or update links.

   It may take a few minutes to load the cache on larger sites because Dreamweaver must determine whether the cache is up to date by comparing the timestamps of the files on the local site against the timestamps recorded in the cache. If you have not changed any files outside Dreamweaver, you can safely click the Stop button when it appears.

**Re-create the cache**

1. In the Files panel, select Site > Advanced > Recreate Site Cache.

**Change a link sitewide**

In addition to having Dreamweaver update links automatically whenever you move or rename a file, you can manually change all links (including e-mail, FTP, null, and script links) so that they point somewhere else.

This option is most useful when you want to delete a file that other files link to, but you can use it for other purposes. For example, suppose you link the words “this month’s movies” to /movies/july.html throughout your site. On August 1 you would change those links so that they point to /movies/august.html.

1. Select a file in the Local view of the Files panel.
   
   *Note:*
   
   *If you are changing an e-mail, FTP, null, or script link, you do not need to select a file.*

2. Select Site > Site Options > Change Link Sitewide.
3. Complete these options in Change Link Sitewide dialog box:
   
   - **Change All Links To**  Click the folder icon to browse to and select the target file from which to unlink. If you are changing an e-mail, FTP, null, or script link, type the full text of the link you are changing.
   
   - **Into Links to**  Click the folder icon to browse to and select the new file to link to. If you are changing an e-mail, FTP, null, or script link, type the full text of the replacement link.

4. Click OK.
Dreamweaver updates any documents that link to the selected file, making them point to the new file, using the path format already used in the document (for example, if the old path was document-relative, the new path is also document-relative).

After you change a link sitewide, the selected file becomes an orphan (that is, no files on your local disk point to it). You can safely delete it without breaking any links in your local Dreamweaver site.

**Note:**

Because these changes occur locally, you must manually delete the corresponding orphan file in the remote folder and put or check in any files in which links were changed; otherwise, visitors to your site won’t see the changes.

### Test links in Dreamweaver

Links are not active within Dreamweaver; that is, you cannot open a linked document by clicking the link in the Document window.

? Do one of the following:

- Right-click on the link and select Open Linked Page.
- Press Control (Windows) or Command (Macintosh) and double-click the link.

**Note:**

The linked document must reside on your local disk.

### Image maps

An image map is an image that has been divided into regions called hotspots; when a user clicks a hotspot, an action occurs (for example, a new file opens).

Client-side image maps store the hypertext link information in the HTML document—not in a separate map file as server-side image maps do. When a site visitor clicks a hotspot in the image, the associated URL is sent directly to the server. This makes client-side image maps faster than server-side image maps, because the server does not need to interpret where the visitor clicked.

Dreamweaver does not alter references to server-side image maps in existing documents; you can use both client-side image maps and server-side image maps in the same document. However, browsers that support both types of image maps give priority to client-side image maps. To include a server-side image map in a document, you must write the appropriate HTML code.

**Note:**

To use hotspots in Dreamweaver, you have to be in design view.

### Insert client-side image maps

When you insert a client-side image map, you create a hotspot area and then define a link that opens when a user clicks the hotspot area.

**Note:**

You can create multiple hotspot areas, but they are part of the same image map.

1 In the Document window, select the image.
In the Property inspector, click the expander arrow in the lower-right corner to see all properties.

In the Map field, enter a unique name for the image map. If you are using multiple image maps in the same document, make sure each map has a unique name.

To define the image map areas, do one of the following:

- Select the circle tool and drag the pointer over the image to create a circular hotspot.
- Select the rectangle tool and drag the pointer over the image to create a rectangular hotspot.
- Select the polygon tool and define an irregularly shaped hotspot by clicking once for each corner point. Click the arrow tool to close the shape.

After you create the hotspot, the hotspot Property inspector appears.

In the Link field, click the folder icon to browse to and select the file you want to open when the user clicks the hotspot, or type the path.

In the Target drop-down list, select the window in which the file should open or type its name.

The names of all the frames you've named in the current document appear in the pop-up list. If you specify a frame that doesn't exist, the linked page loads into a new window that has the name you specified. You can also select from the following reserved target names:

- _blank loads the linked file into a new, unnamed browser window.
- _parent loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.
- _self loads the linked file into the same frame or window as the link. This target is the default, so you usually don't need to specify it.
- _top loads the linked file into the full browser window, thereby removing all frames.
- _new loads the linked file in a new browser window.

Note:
The target option isn't available until the selected hotspot contains a link.

In the Alt box, type alternative text for display in text-only browsers or browsers that download images manually. Some browsers display this text as a tooltip when the user moves the pointer over the hotspot.

Repeat steps 4 through 7 to define additional hotspots in the image map.

When you finish mapping the image, click a blank area in the document to change the Property inspector.

Modify image map hotspots
You can easily edit the hotspots you create in an image map. You can move a hotspot area, resize hotspots, or move a hotspot forward or back in an absolutely-positioned element (AP element).

You can also copy an image with hotspots from one document to another, or copy one or more hotspots from an image and paste them on another image; hotspots associated with the image are also copied to the new document.

Select multiple hotspots in an image map
1 Use the pointer hotspot tool to select a hotspot.
2 Do one of the following:
   • Shift-click the other hotspots you want to select.
   • Press Control+A (Windows) or Command+A (Macintosh) to select all of the hotspots.
Move a hotspot
1 Use the pointer hotspot tool to select the hotspot.
2 Do one of the following:
   • Drag the hotspot to a new area.
   • Use the Control + arrow keys to move a hotspot by 10 pixels in the selected direction.
   • Use the arrow keys to move a hotspot by 1 pixel in the selected direction.

Resize a hotspot
1 Use the pointer hotspot tool to select the hotspot.
2 Drag a hotspot selector handle to change the size or shape of the hotspot.

Troubleshoot links

Find broken, external, and orphaned links
Use the Check Links feature to search for broken links and orphaned files (files that still exist in the site but that aren't linked to by any other files in the site). You can search an open file, a portion of a local site, or an entire local site.

Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the selected document or documents but does not verify them.

You can also identify and delete files that are no longer used by other files in your site.

Check links in the document
1 Save the file to a location within your local Dreamweaver site.
2 From the Files panel, open the file.
3 Select Site > Site Options > Check Links Sitewide.
4 From the Show drop-down list, select one of the following:
   • Broken Links: Select to view the broken link report.
   • External Links: Select to view the external links in the file.
   • Orphaned Files: Select to view files that do not have incoming links.
5 From the flyout menu, choose one of the following:
   • Check Links: Checks the link for the entire file.
   • Check Links for Entire Current Local Site: Checks the link that are part of a local site.
   • Check Links for Selected Files in Site: Checks links for the selected files.
   The Link Checker displays the results.
6 To save the report, from the Link Checker flyout menu, select Save Results...
The report is a temporary file. You will lose the report if you do not save it.
Fix broken links
After you run a links reports, you can fix broken links and image references directly in the Link Checker panel, or you can open files from the list and fix links in the Property inspector.

Fix links in the Link Checker panel
1 Run a link check report.
2 In the Broken Links column (not the Files column) of the Link Checker panel (Window > Results > Link Checker), select the broken link.
   A folder icon appears next to the broken link.
3 Click the folder icon next to the broken link and browse to the correct file, or type the correct path and filename.
4 Press Tab or Enter (Windows) or Return (Macintosh).
   If there are other broken references to this same file, you are prompted to fix the references in the other files as well. Click Yes to have Dreamweaver update all the documents on the list that reference this file. Click No to have Dreamweaver update the current reference only.

Note:
If Enable File Check In And Check Out is enabled for the site, Dreamweaver attempts to check out files that require changes. If it cannot check out a file, Dreamweaver displays a warning dialog box and leaves broken references unchanged.

Fix links in the Property inspector
1 Run a link check report.
2 In the Link Checker panel (in the Results panel group), double-click an entry in the File column.
   Dreamweaver opens the document, selects the broken image or link, and highlights the path and filename in the Property inspector. (If the Property inspector is not visible, select Window > Properties to open it.)
3 To set a new path and filename in the Property inspector, click the folder icon to browse to the correct file, or type over the highlighted text.
   If you are updating an image reference and the new image appears at the incorrect size, click the W and H labels in the Property inspector or click the Refresh button to reset the height and width values.
4 Save the file.
   As links are fixed, their entries disappear from the Link Checker list. If an entry still appears in the list after you enter a new path or filename in the Link Checker (or after you save changes in the Property inspector), Dreamweaver cannot find the new file and still considers the link broken.
Chapter 10: jQuery widgets and effects

Use jQuery UI and mobile widgets in Dreamweaver
Learn how to add app-like functionality to your Dreamweaver web projects using jQuery UI and mobile widgets. Insert accordions, tabs, sliders, and autocomplete boxes without writing any code.

Use jQuery effects in Dreamweaver
Design engaging websites by using cool jQuery effects. Dreamweaver's integration with jQuery lets you include effects such as sliders without having to write any code.
Chapter 11: Coding websites

About coding in Dreamweaver

The most popular programming languages to design and develop fully functional websites are HTML, HTML5, and CSS for the front-end, and PHP, JavaScript, Java, and jQuery for the back-end.

You can design the appearance of a website (such as fonts, and colors for example) across a website using CSS. You can then use HTML to insert images, text, videos, forms, and other pieces of content together into a cohesive web page.

Using CSS and HTML together, you can build a static site. However, most websites require some form of interaction (such as requiring a customer to fill out a form, or make a payment) and a database to store all the website data.

To create these back-end channels of communication, you need a server-side programming language (such as PHP) that communicates with the database.

Programming languages supported by Dreamweaver

In addition to text-editing capabilities, Adobe Dreamweaver provides various features, such as code hints, to help you code in the following languages:

- HTML
- PHP
- CSS
- JavaScript

Other languages, such as Perl, are not supported by the language-specific coding features in Dreamweaver; for example, you can create and edit Perl files, but code hints don't apply to that language.

Automatic code modification

You can set options that instruct Dreamweaver to automatically clean up your hand-written code according to criteria that you specify. However, your code is never rewritten unless the code rewriting options are enabled or you perform an action that changes the code. For example, Dreamweaver does not alter your white space or change the case of attributes unless you use the Apply Source Formatting command.

A few of these code rewriting options are enabled by default.

The Roundtrip HTML capabilities in Dreamweaver let you move your documents back and forth between a text-based HTML editor and Dreamweaver with little or no effect on the content and structure of the document's original HTML source code. These capabilities include the following:

- Use a third-party text editor to edit the current document.
- By default, Dreamweaver does not make changes in code created or edited in other HTML editors, even if the code is invalid, unless you enable code-rewriting options.
367
Coding websites

• Dreamweaver does not change tags it doesn’t recognize—including XML tags—because it has no criteria by which
to judge them. If an unrecognized tag overlaps another tag (for example,
<MyNewTag><em>text</MyNewTag></em>), Dreamweaver marks it as an error but doesn’t rewrite the code.
• Optionally, you can set Dreamweaver to highlight invalid code in Code view (in yellow). When you select a
highlighted section, the Property inspector displays information on how to correct the error.

XHTML code
Dreamweaver generates new XHTML code and cleans up existing XHTML code in a way that meets most of the
XHTML requirements. The tools that you need to meet the few XHTML requirements that remain are also provided.
Note:
Some of the requirements also are required in various versions of HTML.
The following table describes the XHTML requirements that Dreamweaver meets automatically:
XHTML requirement

Actions Dreamweaver performs

There must be a DOCTYPE declaration in the document prior to the
Adds an XHTML DOCTYPE to an XHTML document:
root element, and the declaration must reference one of the three
Document Type Definition (DTD) files for XHTML (strict, transitional, or <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
frameset).
Or, if the XHTML document has a frameset:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
The root element of the document must be html, and the html
element must designate the XHTML namespace.

Adds the namespace attribute to the html element, as follows:

A standard document must have the head, title, and body structural
elements. A frameset document must have the head, title, and
frameset structural elements.

In a standard document, includes the head, title, and body elements. In
a frameset document, includes the head, title, and frameset elements.

All elements in the document must nest properly:

Generates correctly nested code and, when cleaning up XHTML,
corrects nesting in code that was not generated by Dreamweaver.

<p>This is a <i>bad example.</p></i> <p>This is a <i>good
example.</i></p>
All element and attribute names must be lowercase.

<html xmlns="http://www.w3.org/1999/xhtml">

Forces HTML element and attribute names to be lowercase in the
XHTML code that it generates and when cleaning up XHTML,
regardless of your tag and attribute case preferences.

Every element must have a closing tag, unless it is declared in the DTD Inserts closing tags in the code that it generates, and when cleaning
as EMPTY.
up XHTML.
Empty elements must have a closing tag, or the opening tag must end Inserts empty elements with a space before the closing slash in empty
with />. For example, <br> is not valid; the correct form is <br></br> tags in the code that it generates, and when cleaning up XHTML.
or <br/>. Following are the empty elements: area, base, basefont, br,
col, frame, hr, img, input, isindex, link, meta, and param.
And for backwards-compatibility with browsers that are not XMLenabled, there must be a space before the /> (for example, <br />, not
<br/>).
Attributes can’t be minimized; for example, <td nowrap> is not valid;
the correct form is <td nowrap="nowrap">.

Inserts full attribute-value pairs in the code that it generates, and
when cleaning up XHTML.

This affects the following attributes: checked, compact, declare, defer,
disabled, ismap, multiple, noresize, noshade, nowrap, readonly, and
selected.

Note: If an HTML browser does not support HTML 4, it might fail to
interpret these Boolean attributes when they appear in their full form.

Last updated 11/7/2019


Regular expressions

Regular expressions are patterns that describe character combinations in text. Use them in your code searches to help describe concepts such as lines that begin with “var” and attribute values that contain a number.

The following table lists the special characters in regular expressions, their meanings, and usage examples. To search for text containing one of the special characters in the table, escape the special character by preceding it with a backslash. For example, to search for the actual asterisk in the phrase some conditions apply*, your search pattern might look like this: apply\*\. If you don't escape the asterisk, you’ll find all the occurrences of “apply” (as well as any of “appl”, “applly”, and “applyyyy”), not just the ones followed by an asterisk.

<table>
<thead>
<tr>
<th>Character</th>
<th>Matches</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>^</td>
<td>Beginning of input or line.</td>
<td>^T matches “T” in “This good earth” but not in “Uncle Tom’s Cabin”</td>
</tr>
<tr>
<td>$</td>
<td>End of input or line.</td>
<td>h$ matches “h” in “teach” but not in “teacher”</td>
</tr>
<tr>
<td>*</td>
<td>The preceding character 0 or more times.</td>
<td>um* matches “um” in “rum”, “um” in “yummy”, and “u” in “huge”</td>
</tr>
<tr>
<td>+</td>
<td>The preceding character 1 or more times.</td>
<td>um+ matches “um” in “rum” and “um” in “yummy” but nothing in “huge”</td>
</tr>
<tr>
<td>?</td>
<td>The preceding character at most once (that is, indicates that the preceding character is optional).</td>
<td>st/on matches “son” in “Johnson” and “ston” in “Johnson” but nothing in “Appleton” or “tension”</td>
</tr>
<tr>
<td>.</td>
<td>Any single character except newline.</td>
<td>.an matches “ran” and “can” in the phrase “bran muffins can be tasty”</td>
</tr>
<tr>
<td>x</td>
<td>y</td>
<td>Either x or y.</td>
</tr>
<tr>
<td>(n)</td>
<td>Exactly n occurrences of the preceding character.</td>
<td>o(2) matches “oo” in “loom” and the first two o’s in “mooooo” but nothing in “money”</td>
</tr>
<tr>
<td>Character</td>
<td>Matches</td>
<td>Example</td>
</tr>
<tr>
<td>-----------</td>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>(n,m)</td>
<td>At least n, and at most m, occurrences of the preceding character.</td>
<td>F(2,4) matches “FF” in “FFFF0000” and the first four Fs in #FFFFFF</td>
</tr>
<tr>
<td>[abc]</td>
<td>Any one of the characters enclosed in the brackets. Specify a range of characters with a hyphen (for example, [a-f] is equivalent to [abdef]).</td>
<td>[e-g] matches “e” in “bed”, “f” in “folly”, and “g” in “guard”</td>
</tr>
<tr>
<td>{^abc}</td>
<td>Any character not enclosed in the brackets. Specify a range of characters with a hyphen (for example, {^a-f} is equivalent to {^abdef}).</td>
<td>{^aeiou} initially matches “r” in “orange”, “b” in “book”, and “k” in “eek!”</td>
</tr>
<tr>
<td>\b</td>
<td>A word boundary (such as a space or carriage return).</td>
<td>\bb matches “b” in “book” but nothing in “goober” or “snob”</td>
</tr>
<tr>
<td>\B</td>
<td>Anything other than a word boundary.</td>
<td>\Bb matches “b” in “goober” but nothing in “book”</td>
</tr>
<tr>
<td>\d</td>
<td>Any digit character. Equivalent to [0-9].</td>
<td>\d matches “3” in “C3PO” and “2” in “apartment 2G”</td>
</tr>
<tr>
<td>\D</td>
<td>Any nondigit character. Equivalent to [^0-9].</td>
<td>\D matches “3” in “9005S” and “Q” in “Q45”</td>
</tr>
<tr>
<td>\f</td>
<td>Form feed.</td>
<td></td>
</tr>
<tr>
<td>\n</td>
<td>Line feed.</td>
<td></td>
</tr>
<tr>
<td>\r</td>
<td>Carriage return.</td>
<td></td>
</tr>
<tr>
<td>\s</td>
<td>Any single white-space character, including space, tab, form feed, or line feed.</td>
<td>\sbook matches “book” in “blue book” but nothing in “notebook”</td>
</tr>
<tr>
<td>\S</td>
<td>Any single non-white-space character.</td>
<td>\Sbook matches “book” in “notebook” but nothing in “blue book”</td>
</tr>
<tr>
<td>\t</td>
<td>A tab.</td>
<td></td>
</tr>
<tr>
<td>\w</td>
<td>Any alphanumeric character, including underscore. Equivalent to [A-Za-z0-9_].</td>
<td>b\w matches “barking” in “the barking dog” and both “big” and “black” in “the big black dog”</td>
</tr>
<tr>
<td>\W</td>
<td>Any non-alphanumeric character. Equivalent to [^A-Za-z0-9_].</td>
<td>\W matches “&amp;” in “Jake&amp;Mattie” and “%” in “100%”</td>
</tr>
<tr>
<td>Control+Enter or Shift+Enter (Windows), or Control+ Return or Shift+Return or Command+ Return (Macintosh)</td>
<td>Return character. Make sure that you deselect the Ignore Whitespace Differences option when searching for this, if not using regular expressions. Note that this matches a particular character, not the general notion of a line break; for instance, it doesn’t match a &lt;br&gt; tag or a &lt;p&gt; tag. Return characters appear as spaces in Design view, not as line breaks.</td>
<td></td>
</tr>
</tbody>
</table>

Use parentheses to set off groupings within the regular expression to be referred to later. Then use $1$, $2$, $3$, and so on in the Replace With field to refer to the first, second, third, and later parenthetical groupings.

**Note:**

_In the Search For box, to refer to a parenthetical grouping earlier in the regular expression, use \1, \2, \3, and so on instead of $1$, $2$, $3$._
For example, searching for \((\d+)\)/(\d+)\)/(\d+) and replacing it with $2/$1/$3 swaps the day and month in a date separated by slashes, thereby converting between American-style dates and European-style dates.

**Server behavior code**

When you develop a dynamic page and select a server behavior from the Server Behaviors panel, Dreamweaver inserts one or more code blocks into your page to make the server behavior work.

If you manually change the code within a code block, you can no longer use panels such as the Bindings and Server Behaviors panels to edit the server behavior. Dreamweaver looks for specific patterns in the page code to detect server behaviors and display them in the Server Behaviors panel. If you change a code block's code in any way, Dreamweaver can no longer detect the server behavior and display it in the Server Behaviors panel. However, the server behavior still exists on the page, and you can edit it in the coding environment in Dreamweaver.

**Coding environment in Dreamweaver**

If you want to work with code in Dreamweaver, you can choose to use the Developer workspace. This workspace shows the Code view by default, and has only the Files and Snippets panels docked to the left of the screen.

If you need more functionality, click Window, and then choose the appropriate panel that you need.

*Note:*

If the pre-designed workspaces do not offer exactly what you need, you can customize your own workspace layout. Open and dock panels where you want them, and then save the workspace as a custom workspace. For more information, see [Create custom workspaces](#).

**Working with code in Dreamweaver**

You can work with code in Dreamweaver in multiple ways. You can use:

- **Code view:** Clean, minimalist layout that allows you to work purely with code, without extra panels or windows. For more information, see [View code in the Document window - Code view](#).
- **Split view:** In this view you have both code and live or design views visible, so you can see the changes you make as you code. For more information, see [Code and edit a page simultaneously in the Document window - Split view](#).

You can move between different views by clicking the Code, Split, and Design/Live toggle buttons on top of your workspace.

You can also use the Code Inspector to display your HTML in a floating window. The Code Inspector allows you to see your website design and code simultaneously without having to split your view in half. For more information, see [View code in a separate window with the Code Inspector](#).

**View code in the Document window - Code view**

Select View > Code.

**Code and edit a page simultaneously in the Document window - Split view**

1. Select View > Code and Design.
   
   The code appears in the top pane and the page appears in the bottom pane.

2. To display the page on top, select Design View On Top from the View Options menu on the Document toolbar.
To adjust the size of the panes in the Document window, drag the splitter bar to the desired position. The splitter bar is located between the two panes.

Code view is updated automatically when you make changes in Design view. After making changes in Code view, manually update the document in Design view by clicking in Design view or pressing F5.

**View code in a separate window with the Code Inspector**

The Code inspector lets you work in a separate coding window, just like working in Code view.

1. Select Window > Code Inspector. The toolbar includes the following options:
   - **File Management** Puts or gets the file.
   - **Preview/Debug In Browser** Previews or debugs your document in a browser.
   - **Refresh Design View** Updates the document in Design view so that it reflects any changes you made in the code. Changes you make in the code don't automatically appear in Design view until you perform certain actions, such as saving the file or clicking this button.
   - **Code Navigation** Lets you move quickly in the code. See [Go to a JavaScript or VBScript function](#).
   - **View Options** Lets you determine how the code is displayed. See [Set the code appearance](#).

**Coding faster in Dreamweaver**

Code view in Dreamweaver offers coding-friendly features that help designers transition into developing in code view, and experienced coders can benefit from visual aids such as auto indentation, code coloring, and resizable fonts to reduce errors and improve readability.

Here are some features Dreamweaver offers.

**Code hinting and code completion**

The code hinting (or code completion) feature in Dreamweaver allows you to select tags, attributes, CSS styles from a pop-up menu as you type. This automatic code completion allows you to code faster and with fewer errors.

Here's an example showing how it works in HTML.

When you start typing "<" Dreamweaver opens a pop-up menu listing all the available HTML tags. As you continue typing your tag, Dreamweaver auto-updates the available HTML options and allows you to select an applicable tag. When you press Enter, Dreamweaver automatically inserts the tag for you. Then it displays a second pop-up menu listing all the available properties of that tag.

Code hint support is also available for CSS, JavaScript, and PHP (PHP versions 5.6 and 7.1).

For more information, see [Code hinting and code completion](#).

**Support for PHP 5.6 and 7.1 versions**

Dreamweaver supports PHP versions 5.6 and 7.1.

You can choose to compile your site's PHP files with PHP version 5.6 or 7.1 using the Site Setup dialog box (on a per-site basis), or application preferences (for all PHP files saved outside Dreamweaver sites). Dreamweaver then sets up the code hints, and linting checks for the selected PHP language version.

For new sites in Dreamweaver, the default PHP compiler is set to the version specified in Edit > Preferences > PHP.

For more information on PHP support in Dreamweaver, see [PHP code hints](#).

- Set PHP preferences
Coding websites

- **PHP code hints**

For general information on PHP versions 5.6 and 7.1, refer to the following resources:

- To learn more about PHP 7.1: [http://php.net/releases/7_1_0.php](http://php.net/releases/7_1_0.php)

**JavaScript object code hinting**

Dreamweaver supports object code hinting in JavaScript. Dreamweaver provides code hints for basic JavaScript objects like arrays, dates, numbers, and strings.

In addition, Dreamweaver tracks the JavaScript functions you create, and provides code hints using your own function names.

For more information, see [Code hinting and code completion](#).

**Refactoring JavaScript code**

Dreamweaver supports refactoring of code. Code refactoring is the process of restructuring existing computer code without changing its external behavior. The code becomes more readable and easier to understand. Debugging code saves time because of small functions and proper replacement. With JavaScript refactoring, you can rename functions and variables with scope awareness.

For more information, see [JavaScript object code hinting](#).

**Code coloring for different types of files**

Dreamweaver supports code coloring for HTML, JS, CSS, PHP, XML, LESS, Sass, SCSS, SVG, Bash, C, C#, C++, clojure, CoffeeScript, Dart, Diff, EJS, Embedded Ruby, Groovy, Handlebars, Haskell, Haxe, Java, JSON, Lua, Markdown, Markdown (GitHub), Perl, Properties, Python, RDF Turtle, Ruby, Scala, SQL, Stylus, Text, VB, VBScript, XML, and YAML.

**Multiple cursors for repetitive tasks**

Write more than one line of code at a time to quickly do things like create a bulleted list, update a series of strings, and make multiple edits simultaneously.

This feature is a huge productivity booster, because you don’t have to write the same line of code multiple times. Multiple cursors do it for you at once.

While editing code, you can:

- Add multiple cursors to add new content in multiple places
- Select text in multiple place to apply the same edit to different parts of your document

For more information, see [Add multiple cursors or multiple selections](#).

**Quick editing of related code files**

To make quick changes to your code, place the cursor on specific code snippets, and use the context menu, or press Ctrl-E (on Windows) or Cmd-E (on Mac) to access Quick Edit.

Dreamweaver presents you with context-specific code options and tools inline.

**Scenario use case**
Consider the following example:

You are editing an HTML file, and you notice something looking incorrect in live view. You then switch to code view, and realize that you have to edit another related file (say a CSS file) to fix the issue.

Instead of switching tabs, right-click the relevant code and click Quick Edit, or use a keyboard shortcut, and Dreamweaver opens the relevant section of the code in the related CSS file within the HTML file itself.

You can then edit the CSS code without having to navigate away or switch tabs. The changes get updated in the CSS file automatically.

For more information, see Quick Edit.

**In-context CSS documentation**

Quick Docs provide documentation for CSS properties, right within the code view.

You don’t have to navigate outside Dreamweaver to a web page to learn about CSS properties. To bring up Quick Docs, press Ctrl+K (on Windows) or Cmd+K (on Mac).

For more information, see Get help with CSS within Dreamweaver using Quick Docs.

**Out-of-the-box support for Emmet**

Emmet is a plug-in that allows high-speed coding and generation of HTML and CSS code.

The Emmet plug-in is included with Dreamweaver allowing you to use Emmet abbreviations without having to take the extra step of installing the plug-in.

Use Emmet abbreviations in Code View or Code Inspector in Dreamweaver and press the Tab key to expand these abbreviations into HTML markups or CSS.

HTML abbreviations expand in HTML and PHP pages.

CSS abbreviations expand in CSS, LESS, Sass, SCSS pages or within the style tag in an HTML page.

For more information on using Emmet, see Use the Emmet toolkit with Dreamweaver.

**Code collapsing**

Dreamweaver lets you collapse sections of code so that you can more easily focus on the sections you’re actively editing.

You can collapse code based on tags or brackets, or you can collapse code based on selection.

For more information, see Collapse and expand code.

**Code validation**

Dreamweaver offers strong linting functionality to help you debug errors in your code.

It analyzes code to flag potential errors or suspicious usage of code. HTML syntax errors, parsing errors in CSS, or warnings in JavaScript files are some of the things flagged by linting in Dreamweaver.

For more information about code linting in Dreamweaver, see Lint code.

If you are working with PHP and your document contains invalid code, Dreamweaver displays that code in Design view (if it is open) and highlights it in Code view (depending on the preferences you set).

If you select the code in either view, the Property inspector displays information about why the code is invalid and how to fix it.

*Note:*
The option to highlight invalid code in Code view is turned off by default. To turn it on, switch to Code View (View > Code) and then select View > Code View Options > Highlight Invalid Code.

You can also specify preferences for automatically rewriting various kinds of invalid code when you open a document.

For more information on setting coding preferences, see Set coding preferences.

Support for CSS preprocessors
Dreamweaver now supports common CSS pre-processors such as SASS, Less and SCSS, with full code coloring, code hinting, and compilation.

With CSS pre-processor support, you can save time when working with large sites that have complicated style sheets.

For more information on CSS preprocessor support in Dreamweaver, see Using CSS preprocessors in Dreamweaver.

Save and reuse code snippets
Save commonly used code blocks as code snippets within the Snippets panel. You can then insert these blocks of code in multiple pages.

Snippets saved in the Snippets panel are not site-specific, and so they can be reused across sites.

You can also use snippets across different devices, and also across different versions of Dreamweaver using sync settings.

For more information, see Reuse code with snippets.

Real-time Preview in browser
Quickly preview your code changes in browser in real-time without manually refreshing your browser. Dreamweaver now connects with your browser so changes appear in your browser instantly without page reloads.

For more information, see Real-time Preview in browser.

Customize keyboard shortcuts
You can use your favorite keyboard shortcuts in Dreamweaver. If you are used to specific keyboard shortcuts—for example, Shift+Enter to add a line break, or Control+G to go to a specific position in the code—you can add them to Dreamweaver using the Keyboard Shortcut Editor.

For instructions, see Customize keyboard shortcuts.

Open files in Code view by default
When you open a file type that normally doesn't contain any HTML (for example, a JavaScript file), the file opens in Code view (or Code inspector) instead of Design view. You can specify which file types open in Code view.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select File Types/Editors from the Category list on the left.
3 In the Open In Code View box, add the filename extension of the file type you want to open automatically in Code view.
   Type a space between filename extensions. You can add as many extensions as you like.
Set coding preferences

You can set coding preferences such as code formatting and coloring, among others, to meet your specific needs.

Note:

- To set advanced preferences, use the Tag Library editor (see Managing tag libraries).
- Dreamweaver supports formatting for CSS, JS, and PHP file types. For information on how to customize PHP, CSS, JS code formatting, see Format code

Set the code appearance

You can set word wrapping, display line numbers for the code, set syntax coloring for code elements, set indenting, and show hidden characters from the View > Code View Options menu.

1 View a document in Code view or the Code inspector.
2 Select View > Code View Options.
3 Select or deselect any of the following options:
   - **Word Wrap**  Wraps the code so that you can view it without scrolling horizontally. This option doesn't insert line breaks; it just makes the code easier to view.
   - **Line Numbers** Displays line numbers along the side of the code.
   - **Hidden Characters** Displays special characters in place of white space. For example, a dot replaces each space, a double chevron replaces each tab, and a paragraph marker replaces each line break.

   **Note:** 
   Soft line breaks that Dreamweaver uses for word wrapping are not displayed with a paragraph marker.

   - **Syntax Coloring** Enables or disables code coloring. For information on changing the coloring scheme, see Set color themes and code themes.
   - **Auto Indent** Makes your code indent automatically when you press Enter while writing code. The new line of code indents to the same level as the previous line. For information on changing the indent spacing, see the Tab Size option in Change the code format.

Change the code format

You can change the look of your code by specifying formatting preferences such as indentation, line length, and the case of tag and attribute names.

All the Code Format options, except the Override Case Of option, are automatically applied only to new documents or additions to documents that you subsequently create.

To reformat existing HTML documents, open the document, and select Edit > Code > Apply Source Formatting.

1 Select Edit > Preferences.
2 Select Code Format from the Category list on the left.
3 Set any of the following options:
   - **Indent** Indicates whether code generated by Dreamweaver should be indented (according to the indentation rules specified in these preferences) or not.

   **Note:**
Most of the indentation options in this dialog box apply only to code generated by Dreamweaver, not to code that you type. To make each new line of code that you type indent to the same level as the previous line, select View > Code View Options Auto-Indent option. For more information, see Set the code appearance.

**With** (Text box and pop-up menu) Specifies how many spaces or tabs Dreamweaver should use to indent code that it generates. For example, if you type 3 in the box and select Tabs in the pop-up menu, then code generated by Dreamweaver is indented using three tab characters for every level of indentation.

**Tab Size** Determines how many characters wide each tab character appears in Code view. For example, if Tab Size is set to 4, then each tab is displayed in Code view as a four-character-wide blank space. If, additionally, Indent With is set to 3 Tabs, then code generated by Dreamweaver is indented using three tab characters for every level of indentation, which appears in Code view as a twelve-character-wide blank space.

**Note:**

Dreamweaver indents using either spaces or tabs; it doesn’t convert a run of spaces to a tab when inserting code.

**Emmet** Select this option if you plan to use Emmet abbreviations as you code. Selecting this option ensures that when you press Tab, Dreamweaver converts the Emmet abbreviation into full HTML or CSS code. For more information on using Emmet, see Use the Emmet toolkit with Dreamweaver.

**Line Break Type** Specifies the type of remote server (Windows, Macintosh, or UNIX) that hosts your remote site. Choosing the correct type of line break characters ensures that your HTML source code appears correctly when viewed on the remote server. This setting is also useful when you are working with an external text editor that recognizes only certain kinds of line breaks. For example, use CR LF (Windows) if Notepad is your external editor, and use CR (Macintosh) if SimpleText is your external editor.

**Note:**

For servers that you connect to using FTP, this option applies only to binary transfer mode; the ASCII transfer mode in Dreamweaver ignores this option. If you download files using ASCII mode, Dreamweaver sets line breaks based on the operating system of your computer; if you upload files using ASCII mode, the line breaks are all set to CR LF.

**TD Tag: Do Not Include A Break Inside The TD Tag** Addresses a rendering problem that occurs in some older browsers when white space or line breaks exist immediately after a <td> tag, or immediately before a </td> tag. When you select this option, Dreamweaver does not write line breaks after a <td> or before a </td> tag, even if the formatting in the Tag Library indicates that the line break should be there.

**Advanced Formatting** Lets you set formatting options for individual tags and attributes in the Tag Library Editor.

**White Space Character** (Japanese version only) Lets you select either &nbsp; or Zenkaku space for HTML code. The white space selected in this option will be used for empty tags when creating a table and when the “Allow Multiple Consecutive Spaces” option is enabled in Japanese Encoding pages.

**Minimum code folding size** The default code folding size is two lines. With this default setting, all code fragments that have at least two lines of code are collapsible. Code fragments that are lesser than two lines can be collapsed only by selecting the code. For more information on code folding, see Collapse and expand code.

**Set the code rewriting preferences**

Use the code rewriting preferences to specify how and whether Dreamweaver modifies your code while opening documents, when copying and pasting form elements, and when entering attribute values and URLs using tools such as the Property inspector. These preferences have no effect when you edit HTML or scripts in Code view.
If you disable the rewriting options, invalid-markup items are displayed in the Document window for HTML that it would have rewritten.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).

2. Select Code Rewriting from the Category list on the left.

3. Set any of the following options:
   - **Fix Invalidly Nested and Unclosed Tags**  Rewrites overlapping tags. For example, `<b><i>text</b></i>` is rewritten as `<b><i>text</i></b>`. This option also inserts closing quotation marks and closing brackets if they are missing.
   - **Rename Form Items When Pasting**  Ensures you don't have duplicate names for form objects. This option is enabled by default.

   **Note:**
   Unlike the other options in this preferences dialog box, this option does not apply when you open a document, only when you copy and paste a form element.
   - **Remove Extra Closing Tags**  Deletes closing tags that have no corresponding opening tag.
   - **Warn When Fixing Or Removing Tags**  Displays a summary of technically invalid HTML that Dreamweaver attempted to correct. The summary notes the location of the problem (using line and column numbers) so that you can find the correction and ensure that it's rendering as intended.
   - **Never Rewrite Code: In Files With Extensions**  Allows you to prevent Dreamweaver from rewriting code in files with the specified filename extensions. This option is particularly useful for files that contain third-party tags.
   - **Encode <, >, &, And " In Attribute Values Using &**  Ensures that attribute values that you enter or edit using Dreamweaver tools such as the Property inspector contain only legal characters. This option is enabled by default.

   **Note:**
   This option and the following options do not apply to URLs that you type in Code view. Also, they do not cause existing code already in a file to change.
   - **Do Not Encode Special Characters**  Prevents Dreamweaver from changing URLs to use only legal characters. This option is enabled by default.
   - **Encode Special Characters In URL Using &**  Ensures that when you enter or edit URLs using Dreamweaver tools such as the Property inspector, those URLs contain only legal characters. This encoding method (using the percent sign) may be more compatible with older browsers, but doesn't work as well with characters from some languages.

   **Set code hints preferences**

   Use the code hint preferences to configure how you want code hints to work for you.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select Code Hints from the category on the left.

3 Set any of the following options:

**Close tags** Specify how you want Dreamweaver to close tags.

- After typing "<" -
- After typing the open tag's ">" - Set this option if you want Dreamweaver to automatically add a closing tag after you close the opening tag.
- Never - Set this option if you don’t want Dreamweaver to automatically add closing tags.

**Enable code hints** Select this option to enable or disable code hinting and code completion in Dreamweaver. For more information on Dreamweaver’s code hinting and code completion features, see Code hinting and code completion.

**Enable description tooltips** Select this option to enable descriptions to appear with your code hints. These descriptions provide additional information about the code you are writing.

**Auto-insert braces** When checked, closing brace is automatically inserted whenever user types an opening brace. When unchecked, closing brace is not inserted when user types opening brace. Applies to all types of braces and all file types (html, php, css, js).

**Auto-insert quotes** When checked, closing quote is automatically inserted whenever user types an opening quote. When unchecked, closing quote is not inserted when user types opening quote. Applies to both single and double quotes and all file types (html, php, css, js).

**Set preference for auto completion of codes**

You can enable and disable the auto closing of brackets and quotes by performing the following steps:

1 Open the brackets.json file from the following location:

   - **Win**: %appdata%\Adobe\Dreamweaver CC 2018\en_US\Configuration\Brackets\%
   - **Mac**: ~/Library/Application Support/Adobe/Dreamweaver CC 2018/en_US/Configuration/Brackets/

2 To disable auto closing of brackets and parantheses, set `autoCloseBraces` to False.
To disable auto insertion of matching quotes, set `autoCloseQuotes` to False.

If you want to enable auto closing of brackets, and matching quotes, set the above mentioned values to true.

Set preference for auto completion of code in Dreamweaver

```json
"smartIndent": true,
"useTabChar": true,
"spaceUnits": 4,
"tabSize": 1,
"code-folding.minFoldSize": 2,
"autoCloseQuotes": true,
"autoCloseBraces": true,
"showCodeHintsDescription": true,
"emmet.enabled": true,
"brackets-git.appTheme": "dark-theme",
"wordwrap": true,
```

Save the .json file, and launch Dreamweaver.

**Set PHP preferences**

You can set the PHP coding development environment you want to work in. You can do this on a site-specific basis for individual sites you work on, or on a general basis for all PHP files saved outside Dreamweaver sites.

Dreamweaver sets up the code hints, and linting checks for the selected PHP language version.

To set PHP code version preferences for non site-specific files, complete the following steps:

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Set PHP from the category list on the left.
3. Choose a PHP version from the PHP Version drop-down list and click Apply.

To set the PHP version for a specific site, complete the following steps:

1. In the Site Setup dialog box, under Advanced Settings, select PHP.
2. Choose a PHP version from the PHP Version drop-down list and click Save.
Set color themes and code themes

You can choose a color theme according to your preferences when you start Dreamweaver. You can also change this preference any time.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Interface from the Category list on the left.
3. Choose a theme from the Color Themes list.
4. After setting the interface theme, set the code theme.
   You can choose between a light or dark code theme.
5. Click Apply to save the changes.
   You can choose to further customize the code coloring according to your requirements. For more information, see Customize code coloring.

Use an external editor

You can specify an external editor to use for editing files with specific filename extensions. For example, you can start a text editor such as BBEdit, Notepad, or TextEdit from Dreamweaver to edit JavaScript (JS) files.

You can assign different external editors for different filename extensions.

Set an external editor for a file type

1. Select Edit > Preferences.
2 Select File Types/Editors from the Category list on the left, set the options, and click OK.

- **Open In Code View** Specifies the filename extensions that automatically open in Code view in Dreamweaver.
- **Reload Modified Files** Specifies the behavior when Dreamweaver detects that changes were made externally to a document that is open in Dreamweaver.
- **Save On Launch** Specifies whether Dreamweaver should always save the current document before starting the editor, never save the document, or prompt you to ask whether to save or not each time you start the external editor.
- **Fireworks** You can connect Fireworks with Dreamweaver by providing the path to the application here.

### Customize code coloring

In Dreamweaver, you can change your interface color preferences using Edit > Preferences > Interface. You can choose between four different color themes, and select a light or dark code theme.

After you set your color and code theme, you can further personalize your code colors in Dreamweaver by editing the selectors in the in-built main.less file.

### Set color themes and code themes

You can choose a color theme according to your preferences when you start Dreamweaver. You can also change this preference any time.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Interface from the Category list on the left.
3. Choose a theme from the Color Themes list.
4. After setting the interface theme, set the code theme.

   You can choose between a light or dark code theme. You can then save this theme with a new name and customize it further.

5. Click Apply to save the changes.
Customize code themes

After selecting a code theme, customize the code colors by saving the code theme with a new name and editing it.

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select a light or dark code theme, then click the plus icon, and save the theme with a new name.

   **Note:**
   
   The default light and dark code themes are not editable, so you have to make changes to a copy of this theme. New themes that you create can be edited always.

3. Save the default code theme with a new name.

4. Select the newly created code theme, and click the Edit icon.

   The main.less file opens in Dreamweaver, and you can now edit the selectors in the theme to customize your code colors.

   The Code view refreshes with the new colors when you save the main.less file.
**Edit selectors in the main.less file**

Before you jump into editing the selectors in the main.less file, take a few minutes to read through the comments and instructions within the theme file. If you are still not sure which selector to edit, refer the following resources:

- **Understanding selectors** - Reference tables providing information on the code elements that are impacted by a particular selector
- **Use the Token Inspector** - Use the Token Inspector to "inspect" a particular file and highlight the code elements impacted by a particular selector.
- **If you want to edit the code colors for comments, or adjust the highlighting color of paired tags, see the example code snippets listed in Code customization examples.**

Now that you know the selectors that you need to edit, make the changes to the `main.less` file.

1. Go to the end of the file until you see the following comment:
   ```
   /* Custom code colors or overrides should start after this line */
   ```

2. Type in the selectors for the code elements whose colors you want to edit. Use syntax similar to the following example:
   ```
   .cm-tag {color: #00D0D0; }
   ```
   **Note:**
   
   *If you have multiple code languages within a single file, and you want to be able to distinguish each language with its own code colors, see Customize code colors for mixed code files.*

3. Group multiple selectors if you want to assign the same color for multiple elements. In the following example, multiple selectors separated by commas, are assigned a single color.
   ```
   .cm-atom, .cm-string, .cm-string-2, .cm-hr {color: #cf681d;}
   ```

4. To make code coloring customization specific to a file type, enclose the code element selectors within the file type selector as shown in the following example:
   ```
   .HTML{
   .cm-tag { color: #00D0D0; }
   }
   ```

5. After making your changes, save the file.
   Dreamweaver refreshes the Code view in all open documents with the new colors.
   **Note:**
   
   *If there are any syntax errors or undefined variables in your changes, Dreamweaver does not load the custom code changes you have made, and instead reverts to the default Dark code theme.*

**Customize code colors for mixed code files**

If you are working with mixed mode files (one file containing different coding languages) such as HTML/CSS, or HTML/PHP, or HTML/JavaScript, then you can customize code colors in the following way:

1. Create a custom code theme following the instructions in Customize code themes. Select the new theme and apply it.
2. Quit Dreamweaver.
3. Open package.json in a text editor.
On Windows: %appdata%\Adobe\Dreamweaver CC 2017\en_US\Configuration\Brackets\extensions\user\\


Add the following line in theme{}:

```
"addModeClass": true
```

Editing the package.json file

4 Open Dreamweaver, select Edit > Preferences > Interface, select the new theme, and click the Edit icon.

5 Add mode specific styles at the end of the main.less file.

Use the selectors listed in the following table to edit code colors for the corresponding file type.

<table>
<thead>
<tr>
<th>Selector</th>
<th>Code type</th>
</tr>
</thead>
<tbody>
<tr>
<td>.cm-m-clike</td>
<td>PHP</td>
</tr>
<tr>
<td>.cm-m-css</td>
<td>CSS, Less</td>
</tr>
<tr>
<td>.cm-m-javascript</td>
<td>JavaScript</td>
</tr>
<tr>
<td>.cm-m-xml</td>
<td>HTML, XML</td>
</tr>
</tbody>
</table>

For example, to customize the code colors for tag names in CSS and style tags within HTML or PHP, use the following syntax:

```
.cm-tag {color: #BD46BD;}
.cm-m-css.cm-tag {color: #38D08B;}
```

6 Save the main.less file.

The code color changes are now reflected in your code files.

**Code customization examples**

Review the following examples to understand how you can customize code colors for different scenarios.

**Adjust the color of the highlighting of paired tags**

In the main.less file, search for the following code snippet and adjust the color.

```
    /* Ensure visibility against gray inline editor background */
    background-color: #B53A3A;
    color: #fff!important;
}
```

**Note:**

This code snippet is theme dependent. It may not be present in all themes.
Adjust the color of code comments
In the main.less file, search for the following code snippet and adjust the color.

```
.cm-comment {color: #717171; font-style: italic;}
```

Understanding selectors
To change the colors of your code elements, edit the properties of the selectors in the main.less file.

However, before you jump into modifying the selectors in main.less file, it is important to know what the different selectors mean, and the code elements they impact. Review the following table to understand the code elements in HTML, CSS, JavaScript, and PHP files that are impacted by these selectors.

You can also use the Use the Token Inspector to understand the code elements that are impacted by a particular selector.

<table>
<thead>
<tr>
<th>Selectors</th>
<th>HTML</th>
<th>CSS</th>
<th>JavaScript</th>
<th>PHP</th>
</tr>
</thead>
<tbody>
<tr>
<td>.cm-atom</td>
<td>Entity names such as  </td>
<td>Color in hexadecimal, RGB, or HSL format,</td>
<td>true, false, null, undefined,</td>
<td>True, False, Null and magic constants</td>
</tr>
<tr>
<td></td>
<td></td>
<td>predefined attribute values such as</td>
<td>NaN, Infinity</td>
<td>such as <strong>LINE</strong>, <strong>DIR</strong>, and so on</td>
</tr>
<tr>
<td>.cm-attribute</td>
<td>Attribute Name</td>
<td>Media types such as all, braille, print,</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>screen, and so on</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cm-bracket</td>
<td>Tag brackets such as &lt;, &gt;, /&gt; and &lt;/</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cm-builtin</td>
<td></td>
<td>ID selector</td>
<td>Built-in functions such as</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>htmlspecialchars, trim,</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>substr, and so on</td>
<td></td>
</tr>
<tr>
<td>.cm-comment</td>
<td>Comment</td>
<td>Comment</td>
<td>Comment</td>
<td>Comments</td>
</tr>
<tr>
<td>.cm-def</td>
<td>&quot;@ rule&quot;</td>
<td>variable, function definition and function</td>
<td>The function name in function</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>parameter</td>
<td>definition</td>
<td>definition</td>
</tr>
<tr>
<td>.cm-error</td>
<td>Closing tags without a starting tag</td>
<td>Error because of missing { or } brackets</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Missing a quotation for a attribute value</td>
<td>or missing quotes for a property value</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>or unrecognized property</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cm-keyword</td>
<td></td>
<td>Color names, !important, keywords in @media</td>
<td>Control structure keywords</td>
<td>Keywords like function, if, else, new,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>like and, only, and so on</td>
<td>(if, else, ...), in, of, from,</td>
<td>echo, isset, and so on</td>
</tr>
<tr>
<td>.cm-meta</td>
<td>&lt;DOCTYPE&gt; Declaration</td>
<td>Browser specific prefixes such as</td>
<td>Ellipsis in spread syntax.</td>
<td>&lt;DOCTYPE&gt; Declaration and PHP start and</td>
</tr>
<tr>
<td></td>
<td></td>
<td>-webkit-, -o-, and so on</td>
<td>Example: myFunction(...iterableObj)</td>
<td>end tags: &lt;?php, ?&gt;</td>
</tr>
<tr>
<td>.cm-number</td>
<td></td>
<td>Any number with or without a unit</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.cm-operator</td>
<td></td>
<td>Operators: +, -, *, +=, !==,</td>
<td>Operators like ===, &amp;&amp;, !,</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>&amp;&amp;, &gt;&gt;&gt;, and so on</td>
<td>=&gt;, +, -, and so on</td>
<td></td>
</tr>
</tbody>
</table>
The following table indicates the Dreamweaver templates and libraries that are affected by the selectors in the main.less file.

<table>
<thead>
<tr>
<th>Selector</th>
<th>Templates (DWT)</th>
<th>Library (LBI)</th>
</tr>
</thead>
<tbody>
<tr>
<td>.cm-templateComment</td>
<td>Template comments</td>
<td></td>
</tr>
<tr>
<td>.cm-templateAttrVal</td>
<td>Attribute values in template comments</td>
<td></td>
</tr>
<tr>
<td>.cm-instanceParam</td>
<td>InstanceParam comment and attribute</td>
<td></td>
</tr>
<tr>
<td>.cm-instanceParamAttrVal</td>
<td>InstanceParam attribute values</td>
<td></td>
</tr>
<tr>
<td>.cm-libraryItem</td>
<td>Inserted Libraries in a document. Example: .cm-libraryItem { color: #3A3A3A; background-color: #A4A4A4; }</td>
<td></td>
</tr>
</tbody>
</table>

The following table indicates the selectors to be used when customizing code colors for scenarios where multiple languages exist in a single file.

<table>
<thead>
<tr>
<th>Selector</th>
<th>Code file type</th>
</tr>
</thead>
<tbody>
<tr>
<td>.cm-m-clike</td>
<td>PHP</td>
</tr>
<tr>
<td>.cm-m-css</td>
<td>CSS, Less</td>
</tr>
<tr>
<td>.cm-m-javascript</td>
<td>JavaScript</td>
</tr>
<tr>
<td>.cm-m-xml</td>
<td>HTML, XML</td>
</tr>
</tbody>
</table>
Use the Token Inspector

To learn how the selectors in the main.less theme file affect code elements in code files (other than HTML, CSS, JavaScript, and PHP), use the Token Inspector.

1. Open the **Token Inspector** using Google Chrome.

   The **Token Inspector** utility consists of these sections:
   - Code editor,
   - An option to change modes, and
   - A list of selectors on the right.

2. Copy and paste the contents of a file into the Code Editor.

3. Change the mode of the file by typing in the filename extension and clicking **Change mode**.

   For example, if it is an HTML file, then change the filename extension to html. The page updates to reflect the change in mode and states the current mode at the top of the page.
Mode indication in the Token Inspector

4 Select the code element whose appearance you want to modify.

The **Token Inspector** then highlights the selector.

5 (Optional) You can also select an individual selector to see what code elements in your code file are affected by that selector.

6 Note down the selectors that you want to edit and update and close the **Token Inspector**.

**Write and edit code**

There are multiple ways you can work with code in Dreamweaver.

You can open a new code file using the New Document dialog and start typing in your code.

![Creating a new code file in Dreamweaver](image-url)
As you type, Code hinting and code completion appear to help you select code and avoid typos. Get help with CSS when you need it using Dreamweaver’s helpful Get help with CSS within Dreamweaver using Quick Docs.

You can also insert code using the Insert code using the Insert panel or use coding shortcuts such as Use the Emmet toolkit with Dreamweaver.

If you find yourself copying and pasting the same piece of code multiple times, then try these time-saving features:

- The Reuse code with snippets is invaluable for quickly creating and inserting pre-formatted code snippets into your code.
- Use multiple cursors to add or change text in multiple places allow you to create and edit multiple lines of code all at once.

Dreamweaver also provides a strong set of editing tools that make navigating through and making changes to your code a smooth process.

- Use Dreamweaver’s Find and replace text feature to search for tags, attributes, or text in code.
- Use the Navigate to related code to navigate to related code both within and outside the current file. Even better, use the Quick Edit feature to edit code in related files without even opening up the file in a new tab.
- Right-click the code to bring up a simple, relevant Edit code with the Coding context menu that allows you to edit the code directly.
- Use the Wrap text in code using the Wrap Tag to wrap text in tags.

Read on to get more information on all these code features.

**Insert code using the Insert panel**

1. Position the insertion point in the code.
2. Select an appropriate category in the Insert panel.
3. Click a button in the Insert panel or select an item from a pop-up menu in the Insert panel.

When you click an icon, the code appears in your page immediately, or a dialog box appears requesting for more information to complete the code.

The number and type of buttons available in the Insert panel varies depending on the current document type. It also depends on whether you’re using Code view or Design view.

**Use the Emmet toolkit with Dreamweaver**

Emmet is a plug-in that allows high-speed coding and generation of HTML and CSS code.

Use Emmet abbreviations in Code View or Code Inspector in Dreamweaver and press the Tab key to expand these abbreviations into HTML markups or CSS.

HTML abbreviations expand in HTML and PHP pages. CSS abbreviations expand in CSS, LESS, SASS, SCSS pages, or within the style tag in an HTML page.

Here are a few examples that demonstrate how you can use Emmet abbreviations in Code View. For detailed information and reference, see the Emmet documentation.

**Note:**

*Dreamweaver currently supports Emmet 1.2.2 abbreviations.*

**Example 1: Inserting HTML code using Emmet**
To quickly add HTML code for an unordered list with three elements, open the HTML file and type the following Emmet abbreviation in Code view within `<body></body>`:

div>{ul>li*3>{Lorem Ipsum}}+p*4>lorem

Now, ensure that the cursor is placed right after the Emmet abbreviation and press Tab to expand the abbreviation. Alternatively, select the entire abbreviation and then press Enter.

The abbreviation expands to the following code:

```html
<div>
  <ul>
    <li>Lorem Ipsum</li>
    <li>Lorem Ipsum</li>
    <li>Lorem Ipsum</li>
  </ul>
  <p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Saepe, voluptatum, perferendis ad impedit iste assumenda et laborum doloribus optio molestiae perspiciatis modi quaeat corrupti velit cupiditate eligendi tempora temporibus vel.</p>
  <p>Ipsa, distinctio, eveniet ad numquam libero quam doloremque culpa illo ex possimus eligendi amet nesciunt provident inventore rerum facere ea veritatis itaque? Suscipit rem asperiores excepturi sapien in architecto esse.</p>
  <p>Harum, ad porro molestiae corporis natus aut non fugit. Recusandae, reprehenderit, voluptate voluptas recidendi voluptatem tempora vero vel libero facere fuga maiores ratione eaque ad illum porro dignissimos sit eos.</p>
  <p>Dignissimos, molestiae, quis ducimus ratione temporibus sed accusamus libero consequuntur ex velit maiores illum repudiandae cum! Dolorum, dolore, pariatur, incidunt in saepe laudantium consequatur provident totam vero velit nobis accusantium!</p>
</div>
```

**Example 2: Inserting CSS code using Emmet**

To insert CSS code for creating border radius with vendor prefixes, open your CSS file and type the following Emmet abbreviation inside a class:

```
-bdrs
```

When you press Tab, the abbreviation expands to the following code:

```
-webkit-border-radius: ;
-moz-border-radius: ;
border-radius: ;
```

**Work with code comments**

A comment is descriptive text that you insert in HTML code to explain the code or provide other information. The text of the comment appears only in Code view and is not displayed in a browser.

**Add comments to your code**

To add comments, first type in the comment text. You can then place your cursor at the insertion point and click the Insert icon from the toolbar to open the Apply Comment submenu.

You can also select the text and make it a comment. The selected text is wrapped in a comment block.
You can add comments using various syntax options. Select the appropriate syntax and Dreamweaver inserts the tags for you. All you need to do is enter your comment text.

You can also use the Ctrl+/ (on Windows), or Cmd+/ (on Mac) keyboard shortcuts to add comments.

If you use the keyboard shortcut without selecting any text, the comment is applied for the current line. If you select text and use the keyboard shortcut, the comment is applied for the selected text.

**Remove comments from your code**

To remove code comments, select the code, and click the Remove comment icon in the toolbar. You can also use the Ctrl-/ (on Windows), or Cmd-/ (on Mac) keyboard shortcuts to remove comments.

**Toggle code comments**

To toggle between showing and hiding comments in code view, simply press Ctrl+/ on Windows, or Cmd+/ on Mac for the selected comment or line.

**Use multiple cursors to add or change text in multiple places**

Add cursors in multiple places, or select multiple sections of code and edit them simultaneously using Dreamweaver's multiple cursor feature.

*Note:*

*Copy and paste, and find and replace operations do not work with multiple cursors or multiple selections.*

**Add multiple cursors or multiple selections**

You can add multiple cursors in different ways depending on your requirements.

If you want to add the same text in multiple places without replacing any existing text, add multiple cursors.

If you want to replace existing text, you can do multiple selections. You can select continuous lines of text, or discontinuous lines of text, or both, and add cursors to them.

**To add multiple cursors or multiple selections on the same column across continuous lines:**

Hold down the Alt key, then click drag vertically. When you drag vertically, cursors are added to each line you drag across.
To select continuous lines of text, press the Alt key and drag diagonally. When you drag diagonally, Dreamweaver selects a rectangular block of text within that selection.

**Note:**

*To quickly add cursors or include multiple lines in a selection, use the Shift-Alt-Up or Down keyboard shortcut.*

Once you have added the cursors (or selected text) in multiple places, go ahead and start typing.

If you have multiple cursors, then new text is added.

If you have selected content in multiple lines of text, then the selected text is replaced with the new text you enter.

**To add multiple cursors on different columns across lines:**

To add cursors to discontinuous lines of text, simply press the Ctrl key, and click the different lines where you want to place the cursor.
Adding cursors to multiple discontinuous lines of text

To select discontinuous lines of text, select some text, then press the Ctrl key (Windows), or Cmd key (Mac), and continue to make further selections.

To add cursors at the beginning/end of each line:
Select multiple lines of text and press the Left or Right arrow keys.

To add cursors in preceding or following lines for a selection:
Press Shift+Alt+Up/Down keys and then press the right arrow key.

To select continuous and discontinuous lines of text:
You can combine these techniques to select both continuous and separate lines of text within a single selection.
First select the discontinuous lines of text, then press Ctrl-Alt (on Windows) or Cmd-Alt (on Mac) and drag to add a set of lines to the existing multiple selections.
Get help with CSS within Dreamweaver using Quick Docs

While working with CSS, LESS, or SCSS files in Dreamweaver, you can quickly get more information about CSS properties or values.

Place your cursor within a property or value and press Ctrl + K, Dreamweaver opens documentation from the Web Platform Docs project.

You can simultaneously open multiple inline editors and doc viewers.

To close a single inline editor or doc viewer, click the "X" in the upper-left or press Escape while Quick Docs is in focus.

To close all inline editors and docs, place your cursor back in the main enclosing code editor and press Escape.

Analyze code

Dreamweaver supports linting (analyzing code for potential errors) for HTML, CSS, and JavaScript.

The Output panel lists the errors and warnings detected through linting. For more information, see Lint code.
In addition, Dreamweaver also shows a quick error preview in the line number column of the erroneous line. The line number is displayed in red to indicate that it contains errors, and when you hover over it, a brief description of the error is displayed.

**Note:** Only the first error in the line is displayed. If the line contains only a warning, the description of the warning is displayed. If the line contains a warning and an error, only the error description is displayed.

### Wrap text in code using the Wrap Tag

Use the Wrap Tag in Code view to wrap specific lines of text with a tag. In Design or Live view, you can use this feature to wrap objects with a tag.

1. Select text in Code view or an object in Design view, and press Ctrl+T on your keyboard.
   - A pop-up appears allowing you to select from a number of HTML tags.
2. Select a tag from the menu.
   - If you are working in code view, then the selected text gets wrapped with the tag. If you are working in Design or Live view, the selected object gets wrapped with the tag.

### Edit code with the Coding context menu

Use Dreamweaver’s context menu to make quick edits to your code.

To access the context menu, right-click (on Windows) or Command-click (on Mac). The following options are available for you to use:

- **Quick Edit** Click this option to enter Quick Edit mode. In this mode, Dreamweaver provides context-specific code and tools inline allowing you to quickly get to the code section you need. For more information, see Quick Edit.

- **Cut, copy, paste** Click these options to quickly cut, copy, and paste text without having to access the Edit menu.

- **Find and replace, Find next, Find previous** Click these options to find, and replace text quickly without having to access the Find menu.

- **Create new snippet** Use this option to create code snippets that you can save for later reuse. Select the code, and click Create new snippet to make the selected code a snippet. For more information, see Work with code snippets.

- **Open related file** Right click over a link/script tag and click on open related file to open the file.

- **Attach Style Sheet** Attach an existing CSS style sheet to your page.

- **Selection** The Selection submenu includes various code editing options that you can use on a selected piece of code, such as toggle line and block comments, expand and collapse selection, convert inline CSS to rules, move CSS rules, and print code.

- **Code Navigator** Click this option to navigate to related code sources, such as internal and external CSS rules, server-side includes, external JavaScript files, parent template files, library files, and iframe source files. For more information, see Navigate to related code.

- **Code Hint Tools** The Code Hint Tools submenu brings the color picker, URL browser, and Font list tools at your fingertips.

### Indent code blocks

As you write and edit code in Code view or the Code inspector, you can change the indentation level of a selected block or line of code, shifting it right or left by one tab.
Indent the selected block of code
- Press Tab, or
- Press Ctrl+], or
- Select Edit > Indent Code.

Unindent the selected block of code
- Press Shift+Tab, or
- Press Ctrl+[, or
- Select Edit > Outdent Code.

Navigate to related code
The Code Navigator displays a list of code sources related to a particular selection on your page. Use it to navigate to related code sources, such as internal and external CSS rules, server-side includes, external JavaScript files, parent template files, library files, and iframe source files. When you click a link in the Code Navigator, Dreamweaver opens the file containing the relevant piece of code. The file appears in the related files area, if it is enabled. If you don't have related files enabled, Dreamweaver opens the selected file as a separate document in the Document window.

If you click a CSS rule in the Code Navigator, Dreamweaver takes you directly to that rule. If the rule is internal to the file, Dreamweaver displays the rule in Split view. If the rule is in an external CSS file, Dreamweaver opens the file and displays the rule in the related files area above the main document.

You can access the Code Navigator from Design, Code, and Split views, and also from the Code inspector.

For a video overview from the Dreamweaver engineering team about working with the Code Navigator, see www.adobe.com/go/dw10codenav.

For a video tutorial on working with Live View, related files, and the Code Navigator, see www.adobe.com/go/lrvid4044_dw.

Open the Code Navigator

? Alt+click (Windows) or Command+Option+Click (Macintosh) anywhere on the page. The Code Navigator displays links to the code affecting the area you clicked.

Click outside the Code Navigator to close it.

Note:
You can also open the Code Navigator by clicking the Code Navigator indicator 🌟. This indicator appears near the insertion point on your page when the mouse has been idle for 2 seconds.

Navigate to code with the Code Navigator

1 Open the Code Navigator from the area of the page that you're interested in.

2 Click the piece of code you want to go to.

The Code Navigator groups related code sources by file and lists the files alphabetically. For example, suppose that CSS rules in three external files affect the selection in your document. In this case, the Code Navigator lists those three files and the CSS rules relevant to the selection. For CSS related to a given selection, the Code Navigator functions like the CSS Styles panel in Current Mode.
When you hover over links to CSS rules, the Code Navigator displays tool tips of the properties in the rule. These tool tips are useful when you want to distinguish between many rules that share a name.

**Disable the Code Navigator indicator**

1. Open the Code Navigator.
2. Select Disable Indicator in the lower-right corner.
3. Click outside the Code Navigator to close it.

To re-enable the Code Navigator indicator, Alt+Click (Windows) or Command+Option+Click (Macintosh) to open the Code Navigator and deselect the Disable Indicator option.

**Go to a JavaScript or VBScript function**

In Code view and the Code inspector, you can view a list of all the JavaScript or VBScript functions in your code and jump to any one of them.

1. View the document in Code view (View > Code) or the Code inspector (Window > Code Inspector).
2. Do one of the following:
   - In Code view, right-click (Windows) or Control-click (Macintosh) anywhere in Code view, and select the Functions submenu from the context menu.

   *The Functions submenu does not appear in Design view.*

   Any JavaScript or VBScript functions in your code appear in the submenu.

   To see the functions listed in alphabetical order, Control-right-click (Windows) or Option-Control-click (Macintosh) in Code view, and then select the Functions submenu.

   - In the Code inspector, click the Code Navigation button (`` `)` in the toolbar.
3. Select a function name to jump to the function in your code.

**Extract JavaScript**

The JavaScript Extractor (JSE) removes all or most of the JavaScript from your Dreamweaver document, exports it to an external file, and links the external file to your document. The JSE can also remove event handlers such as `onclick` and `onmouseover` from your code and then unobtrusively attach the JavaScript associated with those handlers to your document.

Note the following limitations of the JavaScript Extractor before using it:

- The JSE does not extract script tags in the body of the document (except in the case of Spry widgets). There is a chance that externalizing these scripts could cause unexpected results. By default, Dreamweaver lists these scripts in the Externalize JavaScript dialog box, but does not select them for extraction. (You can manually select them if you want.)
- The JSE does not extract JavaScript from editable regions of .dwt (Dreamweaver template) files, non-editable regions of template instances, or Dreamweaver Library items.
After you extract JavaScript using the Externalize JavaScript and Attach Unobtrusively option, you can no longer edit Dreamweaver behaviors in the Behaviors panel. Dreamweaver cannot inspect and populate the Behaviors panel with behaviors that it has attached unobtrusively.

You cannot undo your changes once you close the page. You can, however, undo changes as long as you remain in the same editing session. Select Edit > Undo Externalize JavaScript to undo.

Some complex pages might not work as expected. Use care when extracting JavaScript from pages with `document.write()` in the body and global variables.

For a video overview from the Dreamweaver engineering team about JavaScript support in Dreamweaver, see www.adobe.com/go/dw10javascript.

To use the JavaScript Extractor:

1. Open a page that contains JavaScript.
2. Click Tools > Externalize JavaScript.
3. In the Externalize JavaScript dialog box, edit the default selections if necessary.
   - Select Only Externalize JavaScript if you want Dreamweaver to move any JavaScript to an external file, and to reference that file in the current document. This option leaves event handlers such as `onclick` and `onload` in the document, and leaves Behaviors visible in the Behaviors panel.
   - Select Externalize JavaScript and Attach Unobtrusively if you want Dreamweaver to 1) move JavaScript to an external file and reference it in the current document, and 2) remove event handlers from the HTML and insert them at runtime using JavaScript. When you select this option, you can no longer edit Behaviors in the Behaviors panel.
   - In the Edit column, deselect any edits you do not want to make, or select edits that Dreamweaver did not select by default.

   By default, Dreamweaver lists but does not select the following edits:
   - Script blocks in the head of the document that contain `document.write()` or `document.writeln()` calls.
   - Script blocks in the head of the document that contain function signatures related to EOLAS handling code, which is known to use `document.write()`.
   - Script blocks in the body of the document, unless the blocks contain only Spry widget or Spry data set constructors.
   - Dreamweaver automatically assigns IDs to elements that don't already have IDs. If you don't like these IDs, you can change them by editing the ID text boxes.

4. Click OK.
   The summary dialog provides a summary of extractions. Review the extractions and click OK.

5. Save the page.

Dreamweaver creates a `SpryDOMUtils.js` file, and another file that contains the extracted JavaScript. Dreamweaver saves the `SpryDOMUtils.js` file in a SpryAssets folder in your site, and saves the other file at the same level as the page from which you extracted the JavaScript. Don't forget to upload both of these dependent files to your web server when you upload the original page.

**Quick Edit**

Instead of cluttering up your coding environment with lots of panels and icons, the Quick Edit mode in Dreamweaver puts context-specific code and tools inline allowing you to quickly get to the code section you need.
You can enter Quick Edit mode by:

- Right-clicking a code snippet and select Quick Edit from the context menu that appears
- Press Ctrl + E (on Windows) or Cmd+E (on Mac)

**Using Quick Edit mode with HTML files**

In an HTML file, place your cursor inside a class or id attribute (name or value) or in the tag name. Quick Edit shows you all the CSS, SCSS, and LESS rules in your project that match. You can edit these rules directly inline, without ever leaving the context of the HTML file.

When multiple rules match, navigate among them using the list on the right side (or use Alt-Up/Down).

To create a CSS rule directly from the inline editor, click New Rule or press Ctrl-Alt-N (on Windows) or Cmd-Opt-N (on Mac).

**Using Quick Edit mode with JavaScript files**

In a JavaScript file, place the cursor on a function name. Quick Edit shows you the function’s body (even if it is present in other files referenced by a require() statement).

**Using Quick Edit mode with CSS, SCSS, or LESS files**

When you bring up Quick Edit with your cursor within a color value, you can access the color picker and quickly modify the colors used in your CSS code.
In a CSS, LESS, or SCSS file, place the cursor on a cubic-bezier() or steps() transition timing function and Quick Edit displays a graphical transition curve editor.

Pre-defined timing functions ease, ease-in, ease-out, ease-in-out, step-start, and step-end are also valid starting points.

**Refactoring code**

Code refactoring is the process of restructuring existing computer code without changing its external behavior so that the code becomes more readable, maintainable, and easier to understand and debug. It is used when you have duplicate code, long methods, or large classes in the code. Debugging code saves time because of small functions and proper replacement.

With JavaScript refactoring, you can rename functions and set the scope of a variable so that you can call it from within a block of code in which it is defined.
Note:

Refactoring code is now available only in .js files.

Refactoring JavaScript
You can refactor code in html, php, and javascript document types. When you right-click on the code area in Dreamweaver, Refactor option appears on the drop-down menu. Refactor consists of the following options:

- Rename
- Extract to Variable
- Extract to Function
- Wrap in Try Catch
- Wrap in Condition
- Convert to Arrow Function
- Create Getters/Setters

To understand the functionality of each refactoring option, refer to the following sections:

Rename
Rename is used to change all the occurrences of a variable name or function name in a JavaScript code. Selection of a variable by click and drag is not necessary to refactor.
Perform the following steps to rename in JavaScript:

1. Highlight or place the text cursor in the code that requires a change.
2. Right-click the selected text and then select **Refactor > Rename**. You can also use the **Ctrl + Alt + R** on Windows OS, or **Command + option + R** on macOS keyboard shortcuts to Rename.
3. A multi-cursor view appears on the screen, allowing you to change all the occurrences of the variable. Multicursor improvements selects the next occurrence of the current selection. Retype a unique variable or function name to replace the current name.

```
// Create variables for the welcome message
var greeting = 'Howdy!';
var name = 'Molly';
var message = ', please check your order:';
// Concatenate the three variables above to
var welcome = greeting + name + message;
```

*Before: Rename*

```
// Create variables for the welcome message
var renamed = 'Howdy!';
var name = 'Molly';
var message = ', please check your order:';
// Concatenate the three variables above to
var welcome = renamed + name + message;
```

*After: Rename*

**Extract to variable**

Use **Extract to Variable** to replace an expression with a variable, local variable, or constants in JavaScript by selecting an expression and right-clicking it. Then, select **Refactor > Extract to Variable**. You can also use **Ctrl + Alt + V** on Windows OS and **Cmd + Alt + V** on macOS.

```
// Yield expression example
function* countAppleSales() {
  var saleList = [3, 7, 5];
  for (var i = 0; i < saleList.length; i++) {
    yield saleList[i]; // the expression
  }
}
```

*Before: Extract to Variable*
**Extract to function**

Use Extract to Function to replace an expression in the calls of a function within a parameter. The default value of the new parameter can be initialized inside the function body or passed through function calls.

Perform the following steps to refactor using Extract to Function:

1. Select any expression or a set of expressions in JavaScript.

2. Right-click, and select Refactor > Extract to Function. You can also use Ctrl + Alt + M on Windows OS or Cmd + Alt + M on Mac OS.

3. Select the destination scope to extract the function from the pop-up menu that is displayed on screen.

The output varies depending on the destination scope that was selected. For example, the destination scope can be a constructor, the selected class, or a global function.

The characteristics of Extract to function are:

- It identifies the parameters to pass based on identifiers available in the selection or in the extracted scope.
• It identifies the return parameters to return from the function based on identifiers whose values are changed in the selection.

• It also creates a function with a unique name.

The following screenshots display the output based on the respective destination scope selected.

```javascript
class Polygon {
  constructor(height, width) {
    function extracted1() {
      this.name = 'Polygon';
    }
    extracted1.call(this);
    this.height = height;
    this.width = width;
  }
  sayName() {
    console.log('Hi, I am a ', this.name + '.');
  }
}
```

**Constructor**

```javascript
class Polygon {
  extracted1() {
    this.name = 'Polygon';
  }

  constructor(height, width) {
    this.extracted1();
    this.height = height;
    this.width = width;
  }
  sayName() {
    console.log('Hi, I am a ', this.name + '.');
  }
}
```

**Class**
Wrap in try catch

Use **Wrap in Try Catch** to an exception in a block of code that appears as an error after compiling the program. This function wraps the block of code in a try catch block. This block of code is marked as an exception while executing the program.

Select or place cursor at the code, right-click, and select **Refactor > Wrap in Try Catch**. If you place the cursor at a position, then it finds the surrounding statements, else it checks whether the code consists of statements or not. If there are statements, then it wraps the code in a Try Catch block.
Wrap in condition

Use **Wrap in Condition** to an expression in a code to compile only for a specific condition.

Select an expression in the code, right-click, and select **Refactor > Wrap in Condition**.

Before: Wrap in Condition

```javascript
// Sequence expression
x = 1, 2, 3;
```

After: Wrap in Condition

```javascript
// Sequence expression
if (Condition) {
  x = 1, 2, 3;
}
```

Convert to arrow function

An arrow function is an expression that does not have its own function expressions such as `this, arguments, super, or new.target`. These function expressions are for non-method expressions, and they cannot be used as a constructor.

Place cursor in a function, right-click, and select **Refactor > Convert to Arrow Function**.

Before: Convert to Arrow Function

```javascript
x = function (a,b) {
  this.a;
  this.b;
};
```

After: Convert to Arrow Function

```javascript
x = () => {
  this.a;
  this.b;
};
```

Note:

- If the statement selected has one parameter, then the parameter structure appears as `param => {statements}`.
- If the selected statement has zero or more than one parameter such as `param (param1, param2)` then the parameter structure appears as `param (param1, param2) => {statements}`.

Create getters/setters

In JavaScript, a setter can be used to execute a function where a specified property requires a change. Setters are most often used along with getters to create a type of pseudo property. You cannot create a setter to a property that has an actual value.

Place the cursor at a member of an object expression, right-click, and select **Refactor > Create Getters/Setters**.
Troubleshooting tips
The following table provides troubleshooting tips for corresponding error messages that are displayed on screen, due to incorrect selection of code:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Error message</th>
<th>Troubleshooting tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rename</td>
<td>No expression at the given position</td>
<td>Place the cursor on or before a variable or function name.</td>
</tr>
<tr>
<td>Extract to Variable</td>
<td>Selection does not form an expression</td>
<td>Select an expression in the code before refactoring the code.</td>
</tr>
<tr>
<td>Extract to Function</td>
<td>Selected block should represent set of statements or an expression</td>
<td>Ensure that you select block with a set of statements or expression.</td>
</tr>
<tr>
<td>Wrap in Try Catch</td>
<td>Select valid code to wrap in a Try-catch block</td>
<td>Ensure that you select any code before applying try catch refactoring option.</td>
</tr>
<tr>
<td>Wrap in Condition</td>
<td>Select valid code to wrap in a Condition block</td>
<td>Ensure that you select an expression before applying Wrap in Condition refactoring option.</td>
</tr>
<tr>
<td>Convert to Arrow Function</td>
<td>Place the cursor inside a function expression</td>
<td>Ensure that you place the cursor inside a function expression before applying the refactoring option.</td>
</tr>
<tr>
<td>Create Getters/Setters</td>
<td>Place the cursor at a member of an object expression</td>
<td>Ensure that you place the cursor at a member of an object expression before applying create getters/setters refactoring option.</td>
</tr>
</tbody>
</table>
Find and replace text
You can use Dreamweaver’s find and replace features to search for any kind of text, code, or whitespace in your site, or folder.
You can search the entire markup, or you can limit the search to just the rendered text in Design view or to just the code.
You can also use powerful pattern-matching algorithms (regular expressions) for sophisticated find-and-replace operations.
Once you find the text, you can then choose to replace it with your specified text, code, or whitespace.
For more information, see Find and replace text, tags, and attributes.

Previewing images and colors in Code view
After you insert relevant code for images and colors, you can preview them right within Code view.

Image preview
Hover your mouse over any image URL to see a preview of the image in Code view. You can preview images that are referenced as any of the following:
• url();
• data-uri()
• Src attribute value of img tag
Dreamweaver also shows image previews of remotely hosted images.
If Dreamweaver is unable to display the preview for remote paths, it displays an "Unable to load image" message.
You can preview the following image types:
• JPEG
• JPG
• PNG
• GIF
• SVG
Color preview
Hover your mouse over color values to preview colors in Code View. Supported formats are:

- 3 and 6 digits Hexadecimal color values: #ff0000;
- RGB: rgb(0, 0, 0);
- RGBA: rgba(0, 255, 228, 0.5);
- HSL: hsl(120, 100%, 50%);
- HSLA: hsla(120, 60%, 70%, 0.3);
- Pre-defined color names, such as, Olive, Teal, red.

Color preview is available in all document types for the above color formats.

Right-click a value and select Quick Edit to open the color picker and select a different color.

Note:
To disable previews for images and colors, uncheck the option View > Code View Options > Asset Preview.
Print code
You can print your code to edit it offline, archive it, or distribute it.

1. Open a page in Code view.
2. Select File > Print Code.
3. Specify printing options, and then click OK (Windows) or Print (Macintosh).

Code hinting and code completion
Dreamweaver's intelligent code completion or code hinting features allow you to insert and edit code quickly by reducing typos and other common mistakes.

You can also use this feature to see:

- Available attributes for a tag,
- Available parameters for a function, or
- Available methods for an object.

Supported languages and technologies
Dreamweaver supports code hinting for the following languages and technologies:

- HTML code hints
- CSS code hints
- JavaScript code hints
- PHP code hints

Read on to learn how code hints and code completion work for these languages.

Enable code hints
To enable code hints, click Edit > Preferences > Code Hints, and select Enable Code Hints. To disable code hinting, deselect Enable Code Hints.
To enable auto insertion of Braces and Quotes, select **Auto-insert Braces** and **Auto-insert Quotes** respectively.

To enable descriptions in code hints, select **Enable description tooltips**. You can then see the descriptions with your code hints.

**HTML code hints**

The following types of code hints are available for HTML:

- Tag hints
- Attribute name hints
- Attribute value hints

**Tag hints**

Press the `<` key on the keyboard to start typing your code. As you type, Dreamweaver displays valid HTML tags. If the string you are typing appears in the menu, scroll to it and press Enter or Return to complete your entry.
For example, when you type <, a pop-up menu shows a list of tag names. Instead of typing the rest of the tag name, you can select the tag from the menu to include it in your text.

These HTML hints also include a short description of the tag where applicable.

**Attribute name hints**

Dreamweaver displays appropriate attributes for tags while coding in Dreamweaver. Type in a tag name and press the spacebar to display the valid attribute names you can use.

**Attribute value hints**

Attribute value hint text can be static or dynamic (as in the code hints display values based on what is present in related files).

Most attribute value hints are static. Take for example the target attribute value, which in itself is static in nature, and so the hints are static as well.
Dreamweaver displays dynamic code hints for those attribute values that require it - such as id, target, src, href, and class.

Here are a few examples of dynamically displayed code hints.

**Dynamic code hints for src**

In this example, when you type src, you are presented with valid attribute values, and when you select images, Dreamweaver displays actual valid images that are present in your images folder. You can then scroll down and choose the one you want.

If you have assets in CC Libraries, then these assets also show up when you type src. These CC library assets are indicated using a cloud icon.

When you choose a CC library asset, a pop-up menu appears allowing you to resample the image size, and change the image format.
Including a CC library asset in your code

Note:

Only 50 CC library assets can be displayed within the code hints. These hints appear in alphabetical order.

Note:

Inclusion of remote CC library assets in Dreamweaver code is not supported.

Dynamic code hints for href

When you type href, Dreamweaver displays a list of files in your folder, while also giving you the option to browse and select the file you want to link to.

Dynamic code hints for id and style

If you have defined ids in your CSS files, then when you type id in your HTML files, Dreamweaver displays all available ids.
Dynamic code hints for id

Similarly, if you have defined CSS styles, then when you type style in your HTML files, Dreamweaver displays all available styles.

Dynamic code hints for style

**CSS code hints**

Code hints are available for the following different types of CSS:

- @rules
- Properties
- Pseudo-selectors and pseudo-elements
- Shorthand

Apart from code hints, tips are also available for CSS properties.

**Code hints for CSS @rules**

Dreamweaver displays code hints for all @rules along with a description of the CSS rule as shown here.
CSS properties hints

When you type in CSS properties, when you type the colon, code hints appear to help you choose a valid value.

In the following example code, when `font-family:` is typed, valid font-sets appear.

You can choose one of the font sets, or you can open the Manage Fonts dialog from within these hints, and set your preferred fonts.

Another example of helpful code hints is when you work with color in CSS. When you type in any color-related property (such as border color or background color), when you press the colon, code hints displays a list of colors. You can pick a color from the list, or you can open the Color Picker from within the code hints itself, and set a preferred color.
If you have color swatches in CC libraries, code hints displays these swatches as well.

**Note:**

*Only 50 CC library assets can be displayed within the code hints. These hints appear in alphabetical order.*

**Pseudo-selector and pseudo-element hints**

You can add a CSS pseudo-selector to a selector to define a particular state of the element. For example, when you use `:hover`, the style is applied when the user hovers over the element specified by the selector.

When you type `:`, Dreamweaver shows a list of valid pseudo-selectors if the cursor is in the right context.
When you type "::", Dreamweaver shows a list of valid pseudo-elements (used to style specified parts of an element) if the cursor is in the right context.

**CSS shorthand hints**

Shorthand properties are CSS properties that let you set the values of several other CSS properties simultaneously. Some examples of CSS shorthand properties are background and font properties.

As seen in the below example, if you type a CSS shorthand property (such as background, for instance), after you type a space, Dreamweaver displays:

- Appropriate property values in order of relevancy
- Mandatory values that have to be used (for example, if you use font, then font-size, and font-family are mandatory)
- Browser expansion for that property

When the CSS shorthand properties are filled out, the code hints also display the property values you have typed.

**CSS code tips**

For some CSS properties (such as box-shadow or text-shadow), Dreamweaver displays tips that indicate what values should follow it, and also indicates which values are the mandatory values using an asterisk.
You can also see how the browser interprets the CSS.

```html
92 } /* About Section */
93 /*:text-column { */
94 width: 29%;
95 text-align: justify;
96 font-weight: lighter;
97 line-height: 25px;
98 float: left;
99 padding-left: 20px;
100 padding-right: 20px;
101 color: #A3A3A3;
102 box-shadow: 15px 15px 0 0px;
103 }
104 */
105 /*:about { */
106 padding-left: 25px;
107 padding-right: 25px;
108 padding-top: 35px;
109 display: inline-block;
110 background-color: #FFFFFF;
111 margin-top: 8px;
112 */
113 /*:Stats Gallery */
114 /*:stats { */
115 color: #717F7B;
116 margin-bottom: 5px;
117 }
```

**Tips that appear for CSS properties**

### JavaScript code hints

In JavaScript files, Dreamweaver provides code hints for variables and function parameters.

In the below example, the code snippet indicates the type.

```javascript
// My sample var
var sample = m
```

**JavaScript code hints**

Dreamweaver automatically refreshes the list of available code hints as you work in JavaScript files. For example, if you are working in a primary HTML file and switch to a JavaScript file to make a change. The change you make in the JavaScript file is reflected in the list of code hints when you return to the primary HTML file.

**Note:**

*This automatic update works only if you edit your JavaScript files in Dreamweaver.*
Live Object Inspection
Dreamweaver also automatically refreshes JavaScript type code hints.

For example, if you have defined a variable as a numeral, Dreamweaver retains that information. When you reference that variable later in your code, it indicates its type.

If you change the variable type (say to a string), then Dreamweaver’s code hints automatically indicate that the variable is a string.

![Code hint indicating variable type](image)

Dynamic documentation inclusion
If you have added comments for a particular function, then when that function is hinted, Dreamweaver also displays the documentation for that function.

PHP code hints
Dreamweaver supports code hinting for PHP 5.6 and 7.1 versions. These PHP code hints are site-specific and cover all core functions, classes, and constants.

For more information on PHP 5.6, and 7.1 see PHP Manual.

For more information on site-specific code hints, see Site-specific code hints.

A helpful PHP code hints feature is the auto completion of variables.

When you type a dollar sign ($), a list of all variables in your current script appears. Select the one you want, and press Enter/Return. Variables from related files are also listed, eliminating the danger of reusing the same variable for a different purpose.

When PHP 7.1 is set as the default, Dreamweaver displays PHP 7.1 specific code hints.

![PHP 7 code hints](image)
Edit the delay settings for PHP code hints

To improve the code typing performance in .php files, Dreamweaver 2017.5 and later has an added delay for PHP code hints. When you type PHP code, Dreamweaver displays the hints after a 400ms delay. If you want to modify the delay settings for PHP code, follow this procedure:

1. Quit Dreamweaver.
2. Open brackets.json from the following location, using a text editor:
   - Win: %appdata%\Adobe\Dreamweaver CC 2017\<locale>\Configuration\Brackets\n   - macOS: ~/Library/Application Support/Adobe/Dreamweaver CC 2017/<locale>/Configuration/Brackets/
3. Click the Save Structure button in the upper right corner of the dialog box.
   In the JSON file, add a comma after the last name/value pair.
   Add the following line with your preferred delay time in milliseconds: "delayInPHPHint": <time in milliseconds>. For example, "delayInPHPHint": 200.
4. Save the file, and launch Dreamweaver.

Site-specific code hints

Dreamweaver lets developers working with Joomla, Drupal, Wordpress or other frameworks, to view PHP code hints as they write in Code view. To display these code hints, you first need to create a configuration file using the Site-Specific Code Hints dialog box. The configuration tells Dreamweaver where to look for code hints that are specific to your site.

For a video tutorial on working with Site-specific code hints, see www.adobe.com/go/learn_dw_comm13_en.

Create the configuration file

Use the Site-Specific Code Hints dialog box to create the configuration file needed to display code hints in Dreamweaver.

By default, Dreamweaver stores the configuration file in the Adobe Dreamweaver CS5\configuration\Shared\Dinamico\Presets directory.

Note:

The code hints you create are specifically for the site selected in the Dreamweaver Files panel. For the code hints to display, the page you are working on must reside in the currently selected site.

1. Select Site > Site Options > Site-Specific Code Hints.
   
   By default, the Site-Specific Code Hints feature scans your site to determine which Content Management System (CMS) framework you’re using. Dreamweaver supports three frameworks by default: Drupal, Joomla, and Wordpress. The four buttons to the right of the Structure pop-up menu let you import, save, rename, or delete framework structures.
Coding websites

Note:
You cannot delete or rename the existing default framework structures.

2 In the subroot text box, specify the subroot folder where you store your framework's files. You can click the folder icon next to the text box to browse to the framework files' location.

Dreamweaver displays a file tree structure of folders that contain your framework files. If the folders and files you want to scan are all displayed, click OK to run the scan. If you want to customize the scan, go on to the next steps.

3 Click the plus (+) button above the Files window to select a file or folder that you want to add to the scan. In the Add Files/Folders dialog box, you can specify particular filename extensions that you want to include.

Note:
Specify a particular filename extension to speed up the scanning process.

4 To remove files from the scan, select the files you don’t want scanned, and then click the minus (-) button above the Files window.

Note:
If your selected framework is Drupal or Joomla, the Site-Specific Code Hints dialog box displays an additional path to a file within your Dreamweaver configuration folder.

Don’t delete this—it’s required when using these frameworks.

5 To customize how the Site-Specific Code Hints feature treats a particular file or folder, select it from the list and do one of the following:
   - Select Scan This Folder to include the selected folder in the scan.
   - Select Recursive to include all files and folders within a selected directory.
   - Click the Extensions button to open the Find Extensions dialog box, where you can specify the filename extensions you want included in your scan for a particular file or folder.

Save site structure
You can save the customized site structure you’ve created in the Site-Specific Code Hints dialog box.

1 Quit Dreamweaver.

2 Step text

3 Create the structure of files and folders as you want it, adding and deleting files and folders as necessary.

4 Specify a name for your site structure and click Save.

Note:
If the specified name is already in use, Dreamweaver prompts you to enter a different name, or to confirm that you want to overwrite the structure with the same name. You cannot overwrite any of the default framework structures.

Rename site structures
When renaming your site structure, keep in mind that you cannot use the names of any of the three default site framework structures, or the word “custom”.

1 Display the structure that you want to rename.

2 Click the Rename Structure icon button in the upper right corner of the dialog box.

3 Specify a new name for the structure and click Rename.
Note:
If the name you specify is already in use, Dreamweaver prompts you to enter a different name, or to confirm that you want to overwrite the structure with the same name. You cannot overwrite any of the default framework structures.

Add files or folders to a site structure
You can add any files or folders that are associated with your framework. After you add files or folders, you can then specify the filename extensions of the files you want to scan.

1. Click the plus (+) button above the Files window to open the Add File/Folder dialog box.
2. In the Add File/Folder text box, enter the path to the file or folder you want to add. You can also click the folder icon next to the text box to browse to a file or folder.
3. Click the plus (+) button above the Extensions window to specify the filename extensions of files you want to scan.
   Note:
   Specify a particular filename extension to speed up the scanning process.
4. Click Add.

Scan a site for filename extensions
Use the Find Extensions dialog box to view and edit filename extensions that are included in the site structure.

1. In the Site-Specific Code Hints dialog box, click the Extensions button.
   The Find Extensions dialog box lists the current scannable extensions.
2. To add another extension to the list, click the plus (+) button above the Extensions window.
3. To delete an extension from the list, click the minus (-) button.

Collapse and expand code
You can collapse (also called as fold) and expand code fragments to view different sections of your document without scrolling.

For example, to see all the CSS rules in the head tag that apply to a div tag farther down the page, fold the code between the head tag and the div tag to see both sections of code at once.

You can select a portion of code to collapse it. You can also collapse code in HTML, PHP, XML, and SVG files based on tag blocks. In CSS, Less, Sass, SCSS, and JS files, you can collapse code based on curly brackets.

- **HTML files**: Dreamweaver collapses the code between an opening and closing HTML tag, and the initial attributes (if applicable), are displayed in the collapsed code. Dreamweaver auto-expand when the code within the block receives focus through Tag Selector, Find and Replace, Go To Line, Element Quick View, Live View, or Undo/Redo. If the selection changes, the code is automatically collapsed back again.

- **CSS, Less, Sass, SCSS, and JS files**: Code within curly brackets is collapsed and the preview is displayed as [...].

- **PHP files**: HTML elements, CSS, and JS code blocks are collapsed in addition to PHP code blocks.

Note:
Files created from Dreamweaver templates display all code as fully expanded, even if the template file (.dwt) contains collapsed code fragments.
Set code folding size preferences

The default code folding size is two lines. With this default setting, all code fragments that have at least two lines of code are collapsible. Code fragments that are lesser than two lines can be collapsed by selecting the code.

To change the minimum number of lines for code folding:

1. Click Edit > Preferences (on Windows) or Dreamweaver > Preferences (on Mac).
2. Click Code Format in the Category list and specify the minimum code folding size.

Collapse and expand code fragments

By default, all the code in Code view is in expanded mode.

However, you can collapse code by selecting several lines, and collapsing them. You can also collapse code based on the syntax - tag blocks or curly brackets.

- Collapse code based on tag blocks or curly brackets
- Collapse code based on selection

Note:

The collapsed or expanded states of code blocks are retained across Dreamweaver sessions.

Collapse code based on tag blocks or curly brackets

To collapse code based on tag blocks or curly brackets:

1. In Code view, a small triangle appears next to the line numbers corresponding to code blocks that are greater than the number of code folding lines specified in the Set code folding size preferences.
2. Click the triangle to collapse or expand the code.

To expand all the collapsed code in the document, you can use the keyboard shortcut Control+Alt+E (Win); Command+Alt+E (Mac).
Collapse code based on selection

To collapse code based on selection:

1. In Code view, select the code fragment that you want to collapse.
2. Click the triangle icon that appears to collapse and expand the selection.

Use keyboard shortcuts to collapse and expand code

<table>
<thead>
<tr>
<th>Command</th>
<th>Windows</th>
<th>Macintosh</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collapse Selection</td>
<td>Control+Shift+C</td>
<td>Command+Shift+C</td>
</tr>
<tr>
<td>Collapse Outside Selection</td>
<td>Control+Alt+C</td>
<td>Command+Alt+C</td>
</tr>
<tr>
<td>Expand Selection</td>
<td>Control+Shift+E</td>
<td>Command+Shift+E</td>
</tr>
<tr>
<td>Collapse Full Tag</td>
<td>Control+Shift+J</td>
<td>Command+Shift+J</td>
</tr>
<tr>
<td>Collapse Outside Full Tag</td>
<td>Control+Alt+J</td>
<td>Command+Alt+J</td>
</tr>
<tr>
<td>Expand All</td>
<td>Control+Alt+E</td>
<td>Command+Alt+E</td>
</tr>
</tbody>
</table>

Copy and paste a collapsed code fragment

1. Click the collapsed code fragment to select it.
2. Select Edit > Copy.
3. Place the cursor at the point where you want to paste the code.
4. Select Edit > Paste.
Reuse code with snippets

If you find yourself repeating code blocks multiple times, then you can use code snippets to speed up the process of writing code. Write the code once, save it as a snippet, and then double-click it in the Snippets panel to insert it in multiple places.

Snippets created using the Snippets panel are not site-specific, and so they can be reused across sites. You can also use snippets across different devices, and also across different versions of Dreamweaver using sync settings.

Dreamweaver comes packaged with multiple code snippets. However, you can also create your own code snippets and save them.

How to make the best use of a snippet?
Browse through the following use cases to understand where you can use snippets in your workflow:

- If you are working in an organization that follows certain design standards, or if you are a free-lancer working on multiple projects – in either scenario you can use code snippets to achieve design uniformity, by storing these common pieces of code as snippets, and then inserting them into your code.
- If you are required to define, maintain, and enforce some coding standards then code snippets come in useful.
- Hand-coding responsive elements in a web page can be time-consuming. Use some of the snippets from the Bootstrap or Responsive_Design_Snippets section of the Snippets panel (for example, a responsive table code snippet). With one click you have inserted almost 20 lines of code for that responsive table. Edit the table as required. You can merge columns or rows, add columns or rows, style it any way you want, and then select the code and save it as a new snippet that you can reuse in all other pages you create. For more information on creating code snippets, see Create snippets.
- JavaScript behaviors, CSS effects, and CSS styles are also excellent candidates for code reuse.

The Snippets panel
In Dreamweaver, you can manage code snippets using the Snippets panel (Window > Snippets). A snippets panel is like a collection of pieces of code.
What you can do with the Snippets panel

You can do the following tasks using the Snippets panel.

**Insert snippets** Expand the folders to navigate to a code snippet, and then double-click it, or click the Insert icon to insert the snippet at the cursor location. To wrap existing text in a code snippet, select the text, then insert the snippet, the text is wrapped within the code snippet. For more information, see Insert snippets.

**Create Snippet Folders** Manage your snippets by housing them in folders with an intuitive naming convention. To create a snippet folder, click the New Folder icon. A new snippet folder is created within a selected node. To change the location of the snippet folder, drag it to the desired location. For more information, see Create snippet folders.

**Create snippets** Use the pre-packaged snippets and edit them to create your own code snippets. Or, create your own snippets from scratch, and then save them in the Snippets panel for later reuse. For more information, see Create snippets.

**Edit snippets** To edit an existing snippet, select the snippet, and click the Edit icon. For more information, see Edit snippets.

**Delete snippets** Delete snippets you no longer need. To delete a snippet, select it and click the Delete icon.

**Rename snippets** To rename a snippet, right-click the snippet to open the context menu. Choose Rename snippet, and then type in the new snippet name.
Add/edit trigger keys  Trigger keys allow you to create intuitive short codes that you can type in, instead of navigating to a particular snippet in the Snippets panel and then inserting it. If you have defined trigger keys, place your cursor at the required spot in the code. Then type in the trigger key text and press tab. The code snippet is inserted into your code. For more information, see Add trigger keys and insert snippets using trigger keys.

Insert snippets
You can insert code snippets into your code at the point where your cursor is placed.

1. Place the cursor at the insertion point where you want to insert the code snippet.
2. In the Snippets panel (Window > Snippets), double-click the snippet, or click the Insert icon at the bottom of the Snippets panel.

You can also right-click (Windows) or Control-click (Macintosh) the snippet, and then select Insert from the pop-up menu.

Note:
If you have defined trigger keys, place your cursor at the required spot in the code. Then type in the trigger key text and press tab. The code snippet is inserted into your code. For more information, see Add trigger keys and insert snippets using trigger keys.

Note:
To see what a code snippet looks like, insert a snippet in design view.

Create snippets
1. In the Snippets panel, click the New Snippet icon at the bottom of the panel.
2. Enter a name for the snippet.

Note:
Snippet names cannot contain characters that are invalid in filenames, such as slashes (/ or \), special characters, or double quotes (").

3. (Optional) Enter a text description for the snippet.

A text description makes it easier for other team members to identify and use the snippet.
Creating a code snippet with enough description makes it easy to identify for later reuse.

Note:

You can also create trigger keys to add snippets into your code. For more information, see Add trigger keys and insert snippets using trigger keys.

4 Click OK.

Edit snippets

To make changes to an existing snippet, you can:

• Right-click the snippet to open the Edit Snippet dialog
• Select the snippet and click the Edit Snippet icon at the bottom of the panel

When you edit a snippet, existing instances of the snippet in the document do not get updated.

You can edit all the fields in the Snippet dialog, such as the Name, Description, trigger key, and the code.

Create snippet folders

1 In the Snippets panel, click the New Snippet Folder button at the bottom of the panel.

2 Drag snippets to the new folder or other folders, as desired.
Add trigger keys and insert snippets using trigger keys

Use trigger keys to quickly add code snippets.

First assign trigger keys to all your frequently used snippets. Then in Code view, type in the Trigger key text and press tab, Dreamweaver adds the snippet at the cursor location.

1. In the Snippets panel, right-click (Windows) or Control-click (Macintosh) and select Add Trigger Key.

![Select Add Trigger Key in the Snippets panel](image)

2. Enter the required text in the trigger key field.

   In the following image, a code snippet for creating a mailto link is assigned a trigger key of mailto, making it easy to remember later. Be sure to give simple, short, and intuitive trigger keys.
To add snippets into your code using trigger keys, type in the trigger text (in Code view) and press tab to insert the snippet into your code.

**How to distribute snippets across multiple devices**

Dreamweaver’s cloud sync feature helps you keep snippets synchronized between two machines.

Use Dreamweaver’s sync settings feature to port snippets created using one instance of Dreamweaver into another machine running Dreamweaver (for example, office and home installations of Dreamweaver).

To sync settings:

1. Click Edit > Preferences.
2. In the Sync Settings section, click Sync Settings Now.

The settings are saved on the cloud. When you next launch Dreamweaver, these settings are imported. Local settings are overridden by the settings imported from the cloud.

Your snippets, and all other preference settings get synced.

**Note:**

Trigger keys cannot contain any special characters (apart from an underscore). In addition, the same trigger key cannot be used for two different snippets.
For more information on sync settings, see Synchronize Dreamweaver settings with Creative Cloud.

**Note:**

*If synchronizing settings is something you do often, enable auto-synchronization by clicking Enable Automatic Sync in the Sync Settings section in the Preference panel. Every change in the settings is automatically saved to the cloud.*

## Optimize code

### Clean up code

You can automatically remove empty tags, combine nested *font* tags, and otherwise improve messy or unreadable HTML or XHTML code.

For information on how to clean up HTML generated from a Microsoft Word document, see Open and edit existing documents.

1. In an open document, select Tools > Clean Up HTML.
2. In the dialog box that appears, select any of the options, and click OK.

**Note:**

Depending on the size of your document and the number of options selected, it may take several seconds to complete the cleanup.

#### Remove Empty Container Tags

Removes any tags that have no content between them. For example, `<b></b>` and `<font color="FF0000"></font>` are empty tags, but the `<b>` tag in `<b>some text</b>` is not.

#### Remove Redundant Nested Tags

Removes all redundant instances of a tag. For example, in the code `<b>This is what I really wanted to say</b>`, the `b` tags surrounding the word *really* are redundant and would be removed.

#### Remove Non-Dreamweaver HTML Comments

Removes all comments that were not inserted by Dreamweaver. For example, `<!--begin body text-->` would be removed, but `<!--TemplateBeginEditable name="doctitle"-->` wouldn't, because it's a Dreamweaver comment that marks the beginning of an editable region in a template.

#### Remove Dreamweaver Special Markup

Removes comments that Dreamweaver adds to code to allow documents to be automatically updated when templates and library items are updated. If you select this option when cleaning up code in a template-based document, the document is detached from the template. For more information, see Detach a document from a template.

#### Remove Specific Tag(s)

Removes the tags specified in the adjacent text box. Use this option to remove custom tags inserted by other visual editors and other tags that you don't want to appear on your site (for example, *blink*). Separate multiple tags with commas (for example, *font,blink*).

#### Combine Nested `<font>` Tags When Possible

Consolidates two or more *font* tags when they control the same range of text. For example, `<font size="7">big red</font>` would be changed to `<font size="7" color="#FF0000">big red</font>`.

#### Show Log On Completion

Displays an alert box with details about the changes made to the document as soon as the cleanup is finished.
Verify tags and braces are balanced
You can check to make sure the tags, parentheses (()), braces ({}), and square brackets ([]) in your page are balanced. Balanced means that every opening tag, parenthesis, brace, or bracket has a corresponding closing one, and vice versa.

Check for balanced tags
1. Open the document in Code view.
2. Place the insertion point in the nested code you want to check.
   The enclosing matching tags (and their contents) are selected in your code. If you keep selecting Edit > Select Parent Tag, and your tags are balanced, eventually Dreamweaver will select the outermost html and /html tags.

Check for balanced parentheses, braces, or square brackets
1. Open the document in Code view.
2. Place the insertion point in the code you want to check.
   All of the code between the enclosing parentheses, braces, or square brackets is selected. Choosing Edit > Code > Balance Braces again selects all of the code inside the parentheses, braces, or square brackets that enclose the new selection.

Check for browser compatibility
The Browser Compatibility Check (BCC) feature helps you locate combinations of HTML and CSS that can trigger browser rendering bugs. This feature also tests the code in your documents for any CSS properties or values that are unsupported by your target browsers.

Validate XML documents
You can set preferences for the Validator, the specific problems that the Validator should check for, and the types of errors that the Validator should report.
1. Do one of the following:
   • For an XML or XHTML file, select File > Validate > As XML.
   • The Validation tab of the Results panel displays a “No errors or warnings” message or lists the syntax errors it found.
2. Double-click an error message to highlight the error in the document.
3. To save the report as an XML file, click the Save Report button.
4. To view the report in your primary browser (which lets you print the report), click the Browse Report button.

Validate documents using W3C validator
Dreamweaver helps you create standards-compliant web pages with its in-built support for the W3C validator. The W3C validator validates your HTML and XML documents for conformance to HTML, XHTML, or XML standards. You can validate both open documents, and files posted on a live server.

Use the report that is generated after validation to fix errors in your file.

Note:
In Dreamweaver preferences, you can specify the parser against which your documents must be validated. This preference is used as a fallback setting in cases where the DOCTYPE cannot be detected automatically.

**Validate an open document**
1. Select Window > Results > Validation to open the Validation panel. This panel displays the results of the validation.
2. Select File > Validate > Current Document (W3C).

**Validate a live document**
For live documents, Dreamweaver validates code received by the browser. This code is displayed when you right-click in your browser, and choose the option to view the source code. Validating live documents is especially useful when validating dynamic pages using PHP, JSP, and so on.

The Validate Live Document option is enabled only when the URL of the page being validated begins with *http*.

1. Select Window > Results > Validation to open the Validation panel. This panel displays the results of the validation.
2. Click Live View.

For live documents, when you double-click an error in the W3C validation panel, a separate window opens. The window displays the browser-generated code, and the line with the error is highlighted.

**Customize validation settings**
1. Select Window > Results > Validation to open the Validation panel.
2. In the W3C Validation panel, click the W3C Validation (Play) icon. Select Settings.
3. Select a DOCTYPE for validation if a DOCTYPE has not been explicitly specified for the document.
4. If you do not want errors and warnings displayed, clear the options.
5. Click Manage if you want to delete any warnings or errors that you have hidden using the W3C Validation panel. When you remove warnings and errors, they are not displayed when you select Show All in the W3C validation panel.
6. Select Don't Show W3C Validator Notification Dialog if you do not want the W3C Validator Notification dialog displayed when you begin validation.

**Work with validation reports**
After validation is complete, the validation reports are displayed in the W3C Validation panel.

- For more information on the error or warning, select the error/warning in the W3C Validation panel. Click More Info.
- To save the report as an XML file, click Save Report.
- To view the entire report in HTML, click Browse Report. The HTML report provides the complete list of errors and warnings along with a summary.
- To jump to the location in the code containing the error, select the error in the W3C Validation panel. Click the Options button, and select Go to Line.
- To hide errors/warnings, select the error/warning. Click the Options button, and select Hide Error.
- To view all the errors and warnings, including the hidden errors, click the Options button. Select Show All. Any hidden errors and warnings you deleted in the Preferences dialog are not listed.
- To clear all the results in the W3C validation panel, click the Options button. Select Clear Results.
Set Validator preferences
In addition to the standard W3C Validator, Dreamweaver supports external code validators that you install as extensions. When you install an external validator extension, Dreamweaver lists its preferences in the W3C Validator category of the Preferences dialog box.

1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2 Select W3C Validator from the Category list on the left.
3 Select tag libraries to validate against.
   You can't select multiple versions of the same tag library or language; for example, if you select HTML 4.01, you can't also select HTML 5. Select the earliest version you want to validate against. For example, if a document contains valid HTML 4.01 code, it will also be valid HTML 5 code.
4 Select Display options for the types of errors and warnings that you want the Validator report to include.
5 Click Apply to apply the changes, and click Close to close the Preferences dialog box.

Make pages XHTML-compliant
When you create a page, you can make it XHTML-compliant. You can also make an existing HTML document XHTML-compliant.

Create XHTML-compliant documents
1 Select File > New.
2 Select a category and type of page to create.
3 Select one of the XHTML document type definitions (DTD) from the DocType pop-up menu on the far right of the dialog box, and click Create.
   For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.

   Note:
   Not all document types can be made XHTML-compliant.

Create XHTML-compliant documents by default
1 Select Edit > Preferences or Dreamweaver > Preferences (Mac OS X), and select the New Document category.
2 Select a default document and select one of the XHTML document type definitions from the Default Document Type (DTD) pop-up menu, and click OK.
   For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.

Make an existing HTML document XHTML-compliant
1 Open a document, and do one of the following:
   • For a document without frames, select File > Convert, and then select one of the XHTML document type definitions.
      For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu.
• For a document with frames, select a frame and select File > Convert, and then select one of the XHTML document type definitions.

2 To convert the whole document, repeat this step for every frame and the frameset document.

Note:

You can’t convert an instance of a template, because it must be in the same language as the template on which it’s based. For example, a document based on an XHTML template will always be in XHTML, and a document based on a non-XHTML-compliant HTML template will always be HTML and can’t be converted to XHTML or any other language.

### Edit code in Design view

Dreamweaver lets you visually create and edit web pages without worrying about the underlying source code, but there are times when you might need to edit the code for greater control or to troubleshoot your web page. Dreamweaver lets you edit some code while working in Design view.

This section is designed for people who prefer to work in Design view, but who also want quick access to the code.

### Select child tags in Design view

If you select an object in Design view that contains child tags—for example, an HTML table—you can quickly select the first child tag of that object by selecting Edit > Select Child.

Note:

This command is only enabled in Design view.

For example, the `<table>` tag normally has `<tr>` child tags. If you select a `<table>` tag in the tag selector, you can select the first row in the table by selecting Edit > Select Child. Dreamweaver selects the first `<tr>` tag in the tag selector. Since the `<tr>` tag itself has child tags, namely `<td>` tags, selecting Edit > Select Child again selects the first cell in the table.

### Edit code with the Property inspector

You can use the Property inspector to inspect and edit the attributes of text or of objects on your page. The properties shown in the Property inspector generally correspond to attributes of tags; changing a property in the Property inspector generally has the same effect as changing the corresponding attribute in Code view.

Note:

The Tag inspector and the Property inspector both let you view and edit a tag’s attributes. The Tag inspector lets you to view and edit every attribute associated with a given tag. The Property inspector shows only the most common attributes, but provides a richer set of controls for changing those attributes’ values, and lets you edit certain objects (such as table columns) that don’t correspond to specific tags.

1 Click in the text or select an object on the page.

   The Property inspector for the text or object appears below the Document window. If the Property inspector is not visible, select Window > Properties.

2 Make changes to the attributes in the Property inspector.
Edit CFML with the Property inspector

Use the Property inspector to inspect and modify ColdFusion markup in Design view.

1. In the Property inspector, click the Attributes button to edit the tag's attributes or to add new ones.
2. If the tag holds content between its opening and closing tags, click the Content button to edit the content.
   The Content button appears only if the selected tag is not an empty tag (that is, if it has both an opening and a closing tag).
3. If the tag contains a conditional expression, make changes to it in the Expression box.

Quick Tag Editor overview

You use the Quick Tag Editor to quickly inspect, insert, and edit HTML tags without leaving Design view.

If you type invalid HTML in the Quick Tag Editor, Dreamweaver attempts to correct it for you by inserting closing quotation marks and closing angle brackets where needed.

To set the Quick Tag Editor options, open the Quick Tag Editor by pressing Control-T (Windows) or Command-T (Macintosh).

The Quick Tag Editor has three modes:

- Insert HTML mode is used to insert new HTML code.
- Edit Tag mode is used to edit an existing tag.
- Wrap Tag mode is to wrap a new tag around the current selection.

Note:

The mode in which the Quick Tag Editor opens depends on the current selection in Design view.

In all three modes, the basic procedure for using the Quick Tag Editor is the same: open the editor, enter or edit tags and attributes, and then close the editor.

You can cycle through the modes by pressing Control+T (Windows) or Command+T (Macintosh) while the Quick Tag Editor is active.

Edit code with the Quick Tag Editor

Use the Quick Tag Editor (Edit > Quick Tag Editor) to quickly insert and edit HTML tags without leaving Design view.

Insert an HTML tag

1. In Design view, click in the page to place the insertion point where you want to insert code.
2. Press Control+T (Windows) or Command+T (Macintosh).
   The Quick Tag Editor opens in Insert HTML mode.
Quick Tag Editor in Insert HTML mode

3. Enter the HTML tag and press Enter.
   The tag is inserted into your code, along with a matching closing tag if applicable.

4. Press Escape to exit without making any changes.

Edit an HTML tag

1. Select an object in Design view.
   You can also select the tag you want to edit from the tag selector at the bottom of the Document window. For more information, see Edit code with the tag selector.

2. Press Control+T (Windows) or Command+T (Macintosh).
   The Quick Tag Editor opens in Edit Tag mode.

3. Enter new attributes, edit existing attributes, or edit the tag's name.

4. Press Tab to move forward from one attribute to the next; press Shift+Tab to move back.
   Note:
   By default, changes are applied to the document when you press Tab or Shift+Tab.

5. To close the Quick Tag Editor and apply all the changes, press Enter.

6. To exit without making any further changes, press Escape.

Wrap the current selection with HTML tags

1. Select unformatted text or an object in Design view.
   Note:
   If you select text or an object that includes an opening or closing HTML tag, the Quick Tag Editor opens in Edit Tag mode instead of Wrap Tag mode.

2. Press Control+T (Windows) or Command+T (Macintosh), or click the Quick Tag Editor button in the Property inspector.
The Quick Tag Editor opens in Wrap Tag mode.

3 Enter a single opening tag, such as strong, and press Enter (Windows) or Return (Macintosh).
   The tag is inserted at the beginning of the current selection, and a matching closing tag is inserted at the end.

4 To exit without making any changes, press Escape.

**Use the hints menu in the Quick Tag Editor**
The Quick Tag Editor includes an attributes hint menu that lists all the valid attributes of the tag you are editing or inserting.

You can also disable the hints menu or adjust the delay before the menu pops up in the Quick Tag Editor.

To see a hints menu that lists valid attributes for a tag, pause briefly while editing an attribute name in the Quick Tag Editor. A hints menu appears, listing all the valid attributes for the tag you’re editing.

Similarly, to see a hints menu listing valid tag names, pause briefly while entering or editing a tag name in the Quick Tag Editor.

*Note:*
*The Quick Tag Editor code hints preferences are controlled by the normal code hints preferences. For more information, see Set code hints preferences.*

1 Do one of the following:
   - Begin to type a tag or attribute name. The selection in the Code Hints menu jumps to the first item that starts with the letters you typed.
   - Use the Up and Down Arrow keys to select an item.
   - Use the scroll bar to find an item.

2 Press Enter to insert the selected item, or double-click an item to insert it.

3 To close the hints menu without inserting an item, press Escape or continue typing.

**Disable the hints menu or change the delay before it appears**
1 Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh) and select Code Hints.
   The Code Hints Preferences dialog box appears.

2 To disable the hints menu, deselect the Enable Code Hints option.

**Edit code with the tag selector**
You can use the tag selector to select, edit, or remove tags without leaving Design view. The tag selector is located in the status bar at the bottom of the Document window and shows a series of tags.

**Edit or delete a tag**
1 Click in the document.
   The tags that apply at the insertion point appear in the tag selector.

2 Right-click (Windows) or Control-click (Macintosh) a tag in the tag selector.

3 To edit a tag, select Edit Tag from the menu. Make your changes in the Quick Tag Editor. For more information, see *Edit code with the Quick Tag Editor.*
4 To delete a tag, select Remove Tag from the menu.

Select an object corresponding to a tag
1 Click in the document.
   The tags that apply at the insertion point appear in the tag selector.
2 Click a tag in the tag selector.
   The object represented by the tag is selected on the page.

   Use this technique to select individual table rows (tr tags) or cells (td tags).

Write and edit scripts in Design view
You can work with client-side JavaScripts and VBScripts in both Code and Design views, in the following ways:
- Write a JavaScript or VBScript script for your page without leaving Design view.
- Create a link in your document to an external script file without leaving Design view.
- Edit a script without leaving Design view.
   Before starting, select View > Visual Aids > Invisible Elements to ensure that script markers appear on the page.

Write a client-side script
1 Place the insertion point where you want the script.
2 Select Insert > HTML > Script.
3 Select the script in the file selection window.
   Note:
   You don’t have to include the opening and closing script tags.
The script tag for the selected file is inserted in the document.

Edit a script
1 Select the script marker.
2 In the Property inspector, click the Edit button.
   The script appears in the Script Properties dialog box.
   If you linked to an external script file, the file opens in Code view, where you can make your edits.
   Note:
   If there is code between the script tags, the Script Properties dialog box opens even if there is also a link to an external script file.
3 In the Language box, specify either JavaScript or VBScript as the language of the script.
4 In the Type pop-up menu, specify the type of script, either client-side or server-side.
5 (Optional) In the Source box, specify an externally linked script file.
   Click the folder icon or the Browse button to select a file, or type the path.
6 Edit the script, and click OK.

**Edit ASP server-side scripts in Design view**

Use the ASP script Property inspector to inspect and modify ASP server-side scripts in Design view.

1 In Design view, select the server-language tag visual icon.
2 In the ASP script Property inspector, click the Edit button.
3 Edit the ASP server-side script, and click OK.

**Edit scripts on the page by using the Property inspector**

1 In the Property inspector, select the scripting language from the Language pop-up menu, or type a language name in the Language box.

   **Note:**
   
   *If you are using JavaScript and are unsure of the version, select JavaScript rather than JavaScript1.1 or JavaScript1.2.*

2 In the Type pop-up menu, specify the type of script, either client-side or server-side.
3 (Optional) In the Source box, specify an externally linked script file. Click the folder icon to select the file, or type the path.
4 Click Edit to modify the script.

**Use JavaScript behaviors**

You can easily attach JavaScript (client-side) behaviors to page elements by using the Behaviors tab of the Tag inspector. For more information, see [Apply built-in JavaScript behaviors](#).

**Work with head content for pages**

Pages contain elements that describe the information on the page, which is used by search browsers. You can set the properties of `head` elements to control how your pages are identified.

**View and edit head content**

You can view the elements in the `head` section of a document in Code view, or by using the Code inspector.

**Insert an element into the head section of a document**

1 Select a head tag from Insert > HTML.
2 Enter options for the element in the dialog box that appears, or in the Property inspector.

**Edit an element in the head section of a document**

You can edit Head elements by directly typing in the code in Code view, or in the Property inspector.

To edit elements in the head section using the Property Inspector:

1 Select the head element in the DOM panel (Window > DOM panel).
   
   The Property Inspector displays the properties for the selected element.
Set or modify the properties of the element in the Property inspector.

Set the meta properties for the page
A meta tag is a head element that records information about the current page, such as the character encoding, author, copyright, or keywords. These tags can also be used to give information to the server, such as the expiration date, refresh interval, and POWDER rating for the page. (POWDER, the Protocol for Web Description Resources, provides a method for assigning ratings, such as movie ratings, to web pages.)

Add a meta tag
1. Select Insert > HTML > Meta.
2. Specify the properties in the dialog box that appears.

Edit an existing meta tag
You can edit meta elements by directly typing in the code in Code view, or in the Property Inspector.
To edit elements in the meta section using the Property Inspector:
1. Select the head element in the DOM panel (Window > DOM panel).
   The Property Inspector displays the properties for the selected element.
2. Select a meta tag from the DOM panel.
3. Specify the properties in the Property inspector.
   - Attribute: Specifies whether the meta tag contains descriptive information about the page (name) or HTTP header information (http-equiv).
   - Value: Specifies the type of information you're supplying in this tag. Some values, such as description, keywords, and refresh, are already well defined (and have their own individual Property inspectors in Dreamweaver), but you can specify practically any value (for example, creationdate, documentID, or level).
   - Content: Specifies the actual information. For example, if you specified level for Value, you might specify beginner, intermediate, or advanced for Content.

Set the page title
There is only one title property: the title of the page. You can edit the page title using one of the following methods:
- Edit the title in the code directly (in Code view)
- Select the title tag in the DOM panel, and edit the title in the Property Inspector

Specify keywords for the page
Many search-engine robots (programs that automatically browse the web gathering information for search engines to index) read the contents of the Keywords meta tag and use the information to index your pages in their databases. Because some search engines limit the number of keywords or characters they index, or ignore all keywords if you go beyond the limit, it's a good idea to use just a few well-chosen keywords.

Add a Keywords meta tag
1. Select Insert > HTML > Keywords.
2. Specify the keywords, separated by commas, in the dialog box that appears.
Edit a Keywords meta tag
You can edit the keywords meta descriptions using one of the following methods:

• Edit the keyword in the code directly (in Code view)
• Select the meta tag for the keyword in the DOM panel, and view, modify, or delete the keywords in the Property Inspector.

Note:
Keywords must be separated by commas.

Specify descriptions for the page
Many search-engine robots (programs that automatically browse the web gathering information for search engines to index) read the contents of the Description meta tag. Some use the information to index your pages in their databases, and some also display the information on the search results page (instead of displaying the first few lines of your document). Some search engines limit the number of characters they index, so it’s a good idea to limit your description to a few words (for example, Pork barbecue catering in Albany, Georgia, or Web design at reasonable rates for clients worldwide).

Add a Description meta tag
1 Select Insert > HTML > Description.
2 Enter descriptive text in the dialog box that appears.

Edit a Description meta tag
You can edit the meta descriptions using one of the following methods:

• Edit the description in the code directly (in Code view)
• Select the meta tag for the description in the DOM panel, and edit the description in the Property Inspector.

Set the refresh properties of the page
Use the Refresh element to specify that the browser should automatically refresh your page—by reloading the current page or going to a different one—after a certain amount of time. This element is often used to redirect users from one URL to another, often after displaying a text message that the URL has changed.

Add a Refresh meta tag
1 Select Insert > HTML > Meta.
2 Specify the properties as follows in the dialog that is displayed:
   • Attribute  Specifies that the meta tag contains HTTP header information (http-equivalent).
   • Value      Specifies the type of information you’re supplying in this tag is refresh.
   • Content    Specify the time in seconds to wait before the browser refreshes the page. To make the browser refresh the page immediately after it finishes loading, enter 0 in this box.

Edit a Refresh meta tag
You can edit the refresh meta tag using one of the following methods:

• Edit the properties in the code directly (in Code view)
• Select the meta tag for refresh in the DOM panel or in the code, and edit the properties in the Property Inspector.

**Edit a Base meta tag**
You can edit the Base element that is used to set the base URL that all document-relative paths in the page are considered relative to.

1 Select the Base element in the DOM panel.
2 In the Property inspector, specify the Base meta tag properties.
   - **Href** The base URL. Click the Browse button to browse to and select a file, or type a path in the box.
   - **Target** Specifies the frame or window in which all linked documents should open. Select one of the frames in the current frameset, or one of the following reserved names:
     - `_blank` loads the linked document in a new, unnamed browser window.
     - `_parent` loads the linked document into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, then this is equivalent to `_top`; the linked document loads into the full browser window.
     - `_self` loads the linked document in the same frame or window as the link. This target is the default, so you usually don't have to specify it.
     - `_top` loads the linked document in the full browser window, thereby removing all frames.

**Edit a Link meta tag**
You can edit a link tag that defines a relationship between the current document and another file.

*Note:*
*The link tag in the head section is not the same thing as an HTML link between documents in the body section.*

1 Select the Link element in DOM panel or Code view.
2 In the Property inspector, specify the Link meta tag properties.
   - **Href** The URL of the file that you are defining a relationship to. Click the Browse button to browse to and select a file, or type a path in the box. Note that this attribute does not indicate a file that you're linking to in the usual HTML sense; the relationships specified in a Link element are more complex.
   - **ID** Specifies a unique identifier for the link.
   - **Title** Describes the relationship. This attribute has special relevance for linked style sheets; for more information, see the External Style Sheets section of the HTML 4.0 specification on the World Wide Web Consortium website at www.w3.org/TR/REC-html40/present/styles.html#style-external.
   - **Rel** Specifies the relationship between the current document and the document in the Href box. Possible values include Alternate, Stylesheet, Start, Next, Prev, Contents, Index, Glossary, Copyright, Chapter, Section, Subsection, Appendix, Help, and Bookmark. To specify more than one relationship, separate values with a space.
   - **Rev** Specifies a reverse relationship (the opposite of Rel) between the current document and the document in the Href box. Possible values are the same as those for Rel.
Insert server-side includes in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About server-side includes
You can use Dreamweaver to insert server-side includes in your pages, edit the includes, or preview pages containing includes.

A server-side include is a file that the server incorporates into your document when a browser requests your document from the server.

When a visitor's browser requests the document that contains the include instruction, your server processes the include instruction and creates a new document in which the include instruction is replaced by the contents of the included file. The server then sends this new document to the visitor's browser. When you open a local document directly in a browser, however, there's no server to process the include instructions in that document, so the browser opens the document without processing those instructions, and the file that's supposed to be included doesn't appear in the browser. Thus, it can be difficult, without using Dreamweaver, to look at local files and see them as they'll appear to visitors after you've put them on the server.

With Dreamweaver you can preview documents just as they’ll appear after they’re on the server, both in the Design view and when you use the Preview in Browser feature. To do so, however, you must make sure you are previewing the file that contains the include as a temporary file. (Select Edit > Preferences, select the Preview in Browser category, and make sure the Preview using temporary file option is selected.)

Note:
If you are using a testing server, such as Apache or Microsoft IIS, to preview your files on your local drive, you do not need to preview the file as a temporary file because the server does the processing for you.

Placing a server-side include in a document inserts a reference to an external file; it doesn't insert the contents of the specified file in the current document. The contents of the specified file should only contain the content that you want to include. That is, the include file should not contain any head tags, body tags, or html tags (meaning the <html> tag—formatting HTML tags, such as p tags, div tags, and so on, are fine). If it does, these tags will conflict with the tags in the original document, and Dreamweaver won't display the page properly.

You cannot edit the included file directly in a document. To edit the contents of a server-side include, you must directly edit the file that you're including. Any changes to the external file are automatically reflected in every document that includes it.

There are two types of server-side includes: Virtual and File. Dreamweaver inserts File type includes by default, but you can use the Property inspector to select the one that is appropriate for the type of web server you use:

- If your server is an Apache web server, select Virtual. In Apache, Virtual works in all cases, while File works only in some cases.
- If your server is a Microsoft Internet Information Server (IIS), select File. (Virtual works with IIS only in certain circumstances.)

Note:
Unfortunately, IIS won't let you include a file in a folder above the current folder in the folder hierarchy, unless special software has been installed on the server. If you must include a file from a folder higher in the folder hierarchy on an IIS server, ask your system administrator if the necessary software is installed.

- For other kinds of servers, or if you don't know what kind of server you're using, ask your system administrator which option to use.

Some servers are configured to examine all files to see if they contain server-side includes; other servers are configured to examine only files with a particular file extension, such as .shtml, .shtm, or .inc. If a server-side include isn't working for you, ask your system administrator if you need to use a special extension in the name of the file that uses the include. (For example, if the file is named canoe.html, you may have to rename it to canoe.shtml.) If you want your files to retain .html or .htm extensions, ask your system administrator to configure the server to examine all files (not just files with a certain extension) for server-side includes. Parsing a file for server-side includes takes a little extra time, so pages that the server parses are served a little more slowly than other pages; therefore, some system administrators won't provide the option of parsing all files.

**Insert server-side includes**

You can use Dreamweaver to insert server-side includes in your page.

**Insert a server-side include**

1. Select Insert > Server-Side Include.
2. In the dialog box that appears, browse to and select a file.
   
   By default, a File type of include is inserted.
3. To change the type of the include, select the server-side include in the Document window and change the type in the Property inspector (Window > Properties), as follows:
   
   - If your server is an Apache web server, select Virtual. In Apache, Virtual works in all cases, while File works only in some cases.
   - If your server is a Microsoft Internet Information Server (IIS), select File. (Virtual works with IIS only in certain specific circumstances.)

**Note:**

Unfortunately, IIS won't allow you to include a file in a folder above the current folder in the folder hierarchy, unless special software has been installed on the server. If you need to include a file from a folder higher in the folder hierarchy on an IIS server, ask your system administrator if the necessary software is installed.

- For other kinds of servers, or if you don't know what kind of server you're using, ask your system administrator which option to use.

**Change which file is included**

1. Select the server-side include in the Document window.
2. Open the Property inspector (Window > Properties).
3. Do one of the following:
   
   - Click the folder icon and browse to and select a new file to include.
   - In the box, type the path and filename of the new file to include.
Edit the contents of server-side includes
You can use Dreamweaver to edit server-side includes. To edit the content associated with the included file, you must open the file.

1 Select the server-side include in either Design view or Code view, and click Edit in the Property inspector.
   The included file opens in a new Document window.

2 Edit the file, and then save it.
   The changes are immediately reflected in the current document and in any subsequent document you open that includes the file.

3 Upload the include file to the remote site if necessary.

Using tag libraries in Dreamweaver
A tag library, in Dreamweaver, is a collection of tags of a particular type, along with information about how Dreamweaver should format the tags. Tag libraries provide the information about tags that Dreamweaver uses for code hints, target browser checks, the Tag Chooser, and other coding capabilities. Using the Tag Library editor, you can add and delete tag libraries, tags, attributes, and attribute values; set properties for a tag library, including format (for easy identification in the code); and edit tags and attributes.

Open and close the Tag Library editor
1 Select Tools > Tag Libraries to open the Tag library editor.
   The Tag Library Editor dialog box appears. (The options of this dialog box change depending on the selected tag.)

2 Close the Tag Library editor in one of the following ways:
   • To save changes, click OK.
   • To close the editor without saving changes, click Cancel.

Note:
When you click Cancel, all changes you've made in the Tag Library editor are discarded. If you deleted a tag or tag library, it's restored.

Add libraries, tags, and attributes
You can use the Tag Library editor to add tag libraries, tags, and attributes to the tag libraries in Dreamweaver.

Add a tag library
1 In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button, and select New Tag Library.

2 In the Library Name box, type a name (for example, Miscellaneous Tags), and click OK.

Add tags to a tag library
1 In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button and select New Tags.

2 Select Tag Library pop-up menu, and select a tag library.

3 Type the name of the new tag. To add more than one tag, separate the tags’ names with a comma and a space (for example: cfgraph, cfgraphdata).
4 If the new tags have corresponding end tags (</...>), select Have Matching End Tags.
5 Click OK.

Add attributes to a tag
1 In the Tag Library editor (Tools > Tag Libraries), click the Plus (+) button and select New Attributes.
2 In the Tag Library pop-up menu, select a tag library.
3 In the Tag pop-up menu, select a tag.
4 Type the name of the new attribute. To add more than one attribute, separate attributes’ names with a comma and a space (for example: width, height).
5 Click OK.

Edit libraries, tags, and attributes
Use the Tag Library editor to set properties for a tag library and edit tags and attributes in a library.

Set properties for a tag library
1 In the Tag Library editor (Tools > Tag Libraries), select a tag library (not a tag) in the Tags list.
   Note: The properties for tag libraries appear only when a tag library is selected. Tag libraries are represented by the top-level folders in the Tags list; for example, the HTML Tags folder represents a tag library, while the abbr folder within the HTML Tags folder represents a tag.
2 In the Used In list, select every document type that should use the tag library.
   The document types you select here determine which document types provide code hints for the given tag library. For example, if the HTML option is not selected for a given tag library, code hints for that tag library don’t appear in HTML files.
3 (Optional) Enter the prefix for the tags in the Tag Prefix box.
   Note: A prefix is used to identify a tag in the code as part of a particular tag library. Some tag libraries don’t use prefixes.
4 Click OK.

Edit a tag in a tag library
1 In the Tag Library editor (Tools > Tag Libraries), expand a tag library in the Tags list and select a tag.
2 Set any of the following Tag Format options:
   Line Breaks Specifies where Dreamweaver inserts line breaks for a tag.
   Contents Specifies how Dreamweaver inserts the contents of a tag; that is, if it applies line break, formatting, and indentation rules to the content.
   Case Specifies the case for a specific tag. Select from Default, Lowercase, Uppercase, or Mixed Case. If you select Mixed Case, the Tag Name Mixed Case dialog box appears. Type the tag with the case Dreamweaver should use when inserting it (for example, getProperty) and click OK.
   Set Default Sets the default case for all tags. In the Default Tag Case dialog box that appears, select <UPPERCASE> or <lowercase>, and click OK.
You might want to set your default case to be lowercase to comply with XML and XHTML standards.

Edit an attribute for a tag
1. In the Tag Library editor (Tools > Tag Libraries), expand a tag library in the Tags box, expand a tag, and select a tag attribute.
2. In the Attribute Case pop-up menu, select the Default, Lowercase, Uppercase, or Mixed Case option.
   - If you select Mixed Case, the Attribute Name Mixed Case dialog box appears. Type the attribute with the case Dreamweaver should use when inserting it (for example, onClick), and click OK.
   - Click the Set Default link to set the default case for all attribute names.
3. In the Attribute Type pop-up menu, select the type of the attribute.
   - If you select Enumerated, type every allowed value for the attribute in the Values box. Separate the values with commas, but no spaces. For example, the enumerated values of the showborder attribute of the cfchart tag are listed as yes,no.

Delete libraries, tags, and attributes
1. In the Tag Library editor (Tools > Tag Libraries), select a tag library, tag, or attribute in the Tags box.
2. Click the Minus (−) button.
3. Click OK to permanently delete the item.
   - The item is removed from the Tags box.
4. Click OK to close the Tag Library editor and complete the deletion.

Importing custom tags into Dreamweaver
You can import custom tags into Dreamweaver so that they become an integral part of the authoring environment. For example, when you start typing an imported custom tag in Code view, a code hints menu appears, listing the tag’s attributes and letting you select one.

Import tags from XML files
You can import tags from an XML Document Type Definition (DTD) file or a schema.
1. Open the Tag Library editor (Tools > Tag Libraries).
2. Click the Plus (+) button and select DTD Schema > Import XML DTD or Schema File.
3. Enter the filename or URL of the DTD or schema file.
4. Enter the prefix to be used with the tags.
   - Note:
     A prefix is used to identify a tag in the code as part of a particular tag library. Some tag libraries don't use prefixes.
5. Click OK.
**Import custom ASP.NET tags**

You can import custom ASP.NET tags into Dreamweaver.

Before you begin, make sure that the custom tag is installed on the testing server defined in the Site Definition dialog box (see [Set up a testing server](#)). Compiled tags (DLL files) must be placed in the site root’s /bin folder. Noncompiled tags (ASCX files) can reside in any virtual directory or subdirectory on the server. For more information, see the Microsoft ASP.NET documentation.

1. Open an ASP.NET page in Dreamweaver.
2. Open the Tag Library editor (Tools > Tag Libraries).
3. Click the Plus (+) button, select one of the following options, and click OK:
   - To import all the ASP.NET custom tags from the application server, select ASP.NET > Import All ASP.NET Custom Tags.
   - To import only certain custom tags from the application server, select ASP.NET > Import Selected ASP.NET Custom Tags. Control-click (Windows) or Command-click (Macintosh) tags from the list.

**Import JSP tags from a file or server (web.xml)**

Import a JSP tag library into Dreamweaver from a variety of file types or a JSP server.

1. Open a JSP page in Dreamweaver.
2. Open the Tag Library editor (Tools > Tag Libraries).
3. Click the Plus (+) button, and select JSP > Import From File (*.tld, *.jar, *.zip), or JSP > Import from Server (web.xml).
4. Click the Browse button or enter a filename for the file that contains the tag library.
5. Enter a URI to identify the tag library. The URI (Uniform Resource Identifier) often consists of the URL of the organization maintaining the tag library. The URL is not used to view the organization's website; it is used to uniquely identify the tag library.
6. (Optional) Enter the prefix to be used with the tags. Some tag libraries use a prefix to identify a tag in the code as part of a particular tag library.
7. Click OK.

**Import JRun tags**

If you use Adobe® JRun™, you can import your JRun tags into Dreamweaver.

1. Open a JSP page in Dreamweaver.
2. Open the Tag Library editor (Tools > Tag Libraries).
3. Click the Plus (+) button and select JSP > Import JRun Server Tags From Folder.
4. Enter a folder name for the folder that contains the JRun tags.
5. Enter a URI to identify the tag library. The URI (Uniform Resource Identifier) often consists of the URL of the organization maintaining the tag library. The URL is not used to view the organization's website; it is used to uniquely identify the tag library.
6. (Optional) Enter the prefix to be used with the tags. Some tag libraries use a prefix to identify a tag in the code as part of a particular tag library.
Use JavaScript behaviors (general instructions)

Adobe Dreamweaver behaviors place JavaScript code in documents so that visitors can change a web page in various ways or initiate certain tasks. A behavior is a combination of an event and an action triggered by that event. In the Behaviors panel, you add a behavior to a page by specifying an action and then specifying the event that triggers that action.

Note:
Behavior code is client-side JavaScript code; that is, it runs in browsers, not on servers.

Events are, effectively, messages generated by browsers indicating that a visitor to your page has done something. For example, when a visitor moves the pointer over a link, the browser generates an `onMouseOver` event for that link; the browser then checks whether it should call some JavaScript code (specified in the page being viewed) in response. Different events are defined for different page elements; for example, in most browsers `onMouseOver` and `onClick` are events associated with links, whereas `onLoad` is an event associated with images and with the body section of the document.

An action is pre-written JavaScript code for performing a task, such as opening a browser window, showing or hiding an AP element, playing a sound, or stopping an Adobe Shockwave movie. The actions provided with Dreamweaver provide maximum cross-browser compatibility.

After you attach a behavior to a page element, the behavior calls the action (JavaScript code) associated with an event whenever that event occurs for that element. (The events that you can use to trigger a given action vary from browser to browser.) For example, if you attach the Popup Message action to a link and specify that it will be triggered by the `onMouseOver` event, then your message pops up whenever someone places the pointer over that link.

A single event can trigger several different actions, and you can specify the order in which those actions occur.

Dreamweaver provides about two dozen actions; additional actions can be found on the Exchange website at www.adobe.com/go/dreamweaver_exchange as well as on third-party developer sites. You can write your own actions if you are proficient in JavaScript.

Note:
The terms behavior and action are Dreamweaver terms, not HTML terms. From the browser's point of view, an action is just like any other piece of JavaScript code.

Behaviors panel overview

You use the Behaviors panel (Window > Behaviors) to attach behaviors to page elements (more specifically to tags) and to modify parameters of previously attached behaviors.

Behaviors that have already been attached to the currently selected page element appear in the behavior list (the main area of the panel), listed alphabetically by event. If several actions are listed for the same event, they will be executed in the order in which they appear on the list. If no behaviors appear in the behavior list, no behaviors have been attached to the currently selected element.

The Behaviors panel has the following options:

Show Set Events Displays only those events that have been attached to the current document. Events are organized into client-side and server-side categories. Each category’s events are in a collapsible list. Show Set Events is the default view.
Show All Events  Displays an alphabetical list of all events for a given category.

Add Behavior (+)  Displays a menu of actions that can be attached to the currently selected element. When you select an action from this list, a dialog box appears in which you can specify parameters for the action. If all the actions are dimmed, no events can be generated by the selected element.

Remove Event (–)  Removes the selected event and action from the behavior list.

Up and down arrow buttons  Move the selected action up or down in the behavior list for a particular event. You can change the order of actions only for a particular event—for example, you can change the order in which several actions occur for the onLoad event, but all the onLoad actions stay together in the behavior list. The arrow buttons are disabled for actions that can't be moved up or down in the list.

Events  Displays a pop-up menu, visible only when an event is selected, of all the events that can trigger the action (this menu appears when you click the arrow button next to the selected event name). Different events appear depending on the object selected. If the events you expect don't appear, make sure that the correct page element or tag is selected. (To select a specific tag, use the tag selector at the lower-left corner of the Document window.)

Note:  
Event names in parentheses are available only for links; selecting one of these event names automatically adds a null link to the selected page element, and attaches the behavior to that link instead of to the element itself. The null link is specified as href="javascript:;" in the HTML code.

About events

Each browser provides a set of events that you can associate with the actions listed in the Behavior panel’s Actions (+) menu. When a visitor to your web page interacts with the page—for example, by clicking an image—the browser generates events; those events can be used to call JavaScript functions that perform an action. Dreamweaver supplies many common actions that you can trigger with these events.

For names and descriptions of the events provided by each browser, see the Dreamweaver Support Center at www.adobe.com/go/dreamweaver_support.

Different events appear in the Events menu depending on the selected object. To find out what events a given browser supports for a given page element, insert the page element in your document and attach a behavior to it, then look at the Events menu in the Behaviors panel. (By default, events are drawn from the HTML 4.01 events list, and are supported by most modern browsers.) Events may be disabled (dimmed) if the relevant objects do not yet exist on the page or if the selected object cannot receive events. If the expected events don’t appear, make sure the correct object is selected.

If you’re attaching a behavior to an image, some events (such as onMouseOver) appear in parentheses. These events are available only for links. When you select one of them, Dreamweaver wraps an <a> tag around the image to define a null link. The null link is represented by javascript:; in the Property inspector’s Link box. You can change the link value if you want to turn it into a real link to another page, but if you delete the JavaScript link without replacing it with another link, you will remove the behavior.

To see which tags you can use with a given event in a given browser, search for the event in one of the files in the Dreamweaver/Configuration/Behaviors/Events folder.

Apply a behavior

You can attach behaviors to the entire document (that is, to the <body> tag) or to links, images, form elements, and several other HTML elements.

The target browser you select determines which events are supported for a given element.
You can specify more than one action for each event. Actions occur in the order in which they’re listed in the Actions column of the Behaviors panel, but you can change that order.

1. Select an element on the page, such as an image or a link.
   To attach a behavior to the entire page, click the `<body>` tag in the tag selector at the lower-left corner of the Document window.

2. Choose Window > Behaviors.

3. Click the Plus (+) button and select an action from the Add Behavior menu.
   Actions that are dimmed in the menu can’t be chosen. They may be dimmed because a required object doesn’t exist in the current document. For example, the Control Shockwave or SWF action is dimmed if the document contains no Shockwave or SWF files.
   When you select an action, a dialog box appears, displaying parameters and instructions for the action.

4. Enter parameters for the action, and click OK.
   All actions provided in Dreamweaver work in modern browsers. Some actions do not work in older browsers, but they will not cause errors.

   **Note:**
   Targeted elements require a unique ID. For example, if you want to apply the Swap Image behavior to an image, the image requires an ID. If you don’t have an ID specified for the element, Dreamweaver automatically specifies one for you.

5. The default event to trigger the action appears in the Events column. If this is not the trigger event you want, select another event from the Events pop-up menu. (To open the Events menu, select an event or action in the Behaviors panel, and click the downward-pointing black arrow that appears between the event name and the action name.)

### Change or delete a behavior

After attaching a behavior, you can change the event that triggers the action, add or remove actions, and change parameters for actions.

1. Select an object with a behavior attached.

2. Choose Window > Behaviors.

3. Make your changes:
   - To edit an action’s parameters, double-click its name, or select it and press Enter (Windows) or Return (Macintosh); then change parameters in the dialog box and click OK.
   - To change the order of actions for a given event, select an action and click the Up or Down arrow. Alternatively, you can select the action and cut and paste it into the desired location among the other actions.
   - To delete a behavior, select it and click the Minus (–) button or press Delete.

### Update a behavior

1. Select an element that has the behavior attached to it.

2. Choose Window > Behaviors and double-click the behavior.

3. Make your changes and click OK in the behavior’s dialog box.
   All occurrences of that behavior in that page are updated. If other pages on your site have that behavior, you must update them page by page.
Download and install third-party behaviors

Many extensions are available on the Exchange for Dreamweaver website (www.adobe.com/go/dreamweaver_exchange).

1. Choose Window > Behaviors and select Get More Behaviors from the Add Behavior menu.
   Your primary browser opens, and the Exchange site appears.

2. Browse or search for packages.

3. Download and install the extension package you want.

For more information, see Add and manage extensions in Dreamweaver.

Apply built-in JavaScript behaviors

Use built-in behaviors

The behaviors included with Dreamweaver have been written to work in modern browsers. The behaviors fail silently in older browsers.

*Note:*

The Dreamweaver actions have been carefully written to work in as many browsers as possible. If you remove code from a Dreamweaver action by hand, or replace it with your own code, you may lose cross-browser compatibility.

Although the Dreamweaver actions were written to maximize cross-browser compatibility, some browsers do not support JavaScript at all, and many people who browse the web keep JavaScript turned off in their browsers. For best cross-platform results, provide alternative interfaces enclosed in `<noscript>` tags so that people without JavaScript can use your site.

Apply the Call JavaScript behavior

The Call JavaScript behavior executes a custom function or line of JavaScript code when an event occurs. (You can write the script yourself, or you can use code provided by various freely available JavaScript libraries on the web.)

1. Select an object and choose Call JavaScript from the Add Behavior menu of the Behaviors panel.

2. Type the exact JavaScript to be executed, or type the name of a function.
   For example, to create a Back button, you might type `if (history.length > 0) {history.back()}.` If you have encapsulated your code in a function, type only the function name (for example, `hGoBack()`).

3. Click OK and verify that the default event is correct.

Apply the Change Property behavior

Use the Change Property behavior to change the value of one of an object’s properties (for example, the background color of a div or the action of a form).

*Note:*
Use this behavior only if you are very familiar with HTML and JavaScript.

1. Select an object and choose Change Property from the Add Behavior menu of the Behaviors panel.
2. From the Type Of Element menu, select an element type to display all the identified elements of that type.
3. Select an element from the Element ID menu.
4. Select a property from the Property menu, or enter the name of the property in the box.
5. Enter the new value for the new property in the New Value field.
6. Click OK and verify that the default event is correct.

**Apply the Check Plugin behavior**

Use the Check Plugin behavior to send visitors to different pages depending on whether they have the specified plug-in installed. For example, you might want visitors to go to one page if they have Shockwave and another page if they do not.

*Note:*

You cannot detect specific plug-ins in Internet Explorer using JavaScript. However, selecting Flash or Director will add the appropriate VBScript code to your page to detect those plug-ins in Internet Explorer on Windows. Plug-in detection is impossible in Internet Explorer on Mac OS.

1. Select an object and choose Check Plugin from the Add Behavior menu of the Behaviors panel.
2. Select a plug-in from the Plugin menu, or click Enter and type the exact name of the plug-in in the adjacent box.

   You must use the exact name of the plug-in as specified in bold on the About Plug-ins page in Netscape Navigator. (In Windows, select Navigator's Help > About Plug-ins command; on Mac OS, select About Plug-ins from the Apple menu.)

3. In the If Found, Go To URL box, specify a URL for visitors who have the plug-in.

   If you specify a remote URL, you must include the http:// prefix in the address. If you leave the field blank, visitors will stay on the same page.

4. In the Otherwise, Go To URL box, specify an alternative URL for visitors who don’t have the plug-in. If you leave the field blank, visitors will stay on the same page.

5. Specify what to do if plug-in detection is not possible. By default, when detection is impossible, the visitor is sent to the URL listed in the Otherwise box. To instead send the visitor to the first (If Found) URL, select the option Always Go To First URL If Detection Is Not Possible. When selected, this option effectively means “assume that the visitor has the plug-in, unless the browser explicitly indicates that the plug-in is not present.” In general, select this option if the plug-in content is integral to your page; if not leave it deselected.

   *Note:*

   This option applies only to Internet Explorer; Netscape Navigator can always detect plug-ins.

6. Click OK and verify that the default event is correct.

**Apply the Drag AP Element behavior**

The Drag AP Element behavior lets the visitor drag an absolutely positioned (AP) element. Use this behavior to create puzzles, slider controls, and other movable interface elements.
You can specify in which direction the visitor can drag the AP element (horizontally, vertically, or in any direction), a target to which the visitor should drag the AP element, whether to snap the AP element to the target if the AP element is within a certain number of pixels of the target, what to do when the AP element hits the target, and more.

Because the Drag AP Element behavior must be called before the visitor can drag the AP element, you should attach Drag AP Element to the body object (with the onLoad event).

2. Click <body> in the tag selector at the lower-left corner of the Document window.
3. Select Drag AP Element from the Add Behavior menu of the Behaviors panel.
   If Drag AP Element is unavailable, you probably have an AP element selected.
4. In the AP Element pop-up menu, select the AP element.
5. Select either Constrained or Unconstrained from the Movement pop-up menu.
   Unconstrained movement is appropriate for puzzles and other drag-and-drop games. For slider controls and movable scenery such as file drawers, curtains, and mini-blinds, select constrained movement.
6. For constrained movement, enter values (in pixels) in the Up, Down, Left, and Right boxes.
   Values are relative to the starting position of the AP element. To constrain movement within a rectangular region, enter positive values in all four boxes. To allow only vertical movement, enter positive values for Up and Down and 0 for Left and Right. To allow only horizontal movement, enter positive values for Left and Right and 0 for Up and Down.
7. Enter values (in pixels) for the drop target in the Left and Top boxes.
   The drop target is the spot to which you want the visitor to drag the AP element. An AP element is considered to have reached the drop target when its left and top coordinates match the values you enter in the Left and Top boxes. Values are relative to the top left corner of the browser window. Click Get Current Position to automatically fill the text boxes with the current position of the AP element.
8. Enter a value (in pixels) in the Snap If Within box to determine how close the visitor must get to the drop target before the AP element snaps to the target.
   Larger values make it easier for the visitor to find the drop target.
9. For simple puzzles and scenery manipulation, you can stop here. To define the drag handle for the AP element, track the movement of the AP element while it is being dragged, and trigger an action when the AP element is dropped, click the Advanced tab.
10. To specify that the visitor must click a particular area of the AP element to drag the AP element, select Area within element from the Drag Handle menu; then enter the left and top coordinates and the width and height of the drag handle.
    This option is useful when the image inside the AP element contains an element that suggests dragging, such as a title bar or drawer handle. Do not set this option if you want the visitor to be able to click anywhere in the AP element to drag it.
11. Select any While Dragging options that you want to use:
    • Select Bring Element To Front if the AP element should move to the front of the stacking order while it is being dragged. If you select this option, use the pop-up menu to select whether to leave the AP element in front or restore it to its original position in the stacking order.
• Enter JavaScript code or a function name (for example, `monitorAPelement()`) in the Call JavaScript box to repeatedly execute the code or function while the AP element is being dragged. For example, you could write a function that monitors the coordinates of the AP element and displays hints such as “you’re getting warmer” or “you’re nowhere near the drop target” in a text box.

12 Enter JavaScript code or a function name (for example, `evaluateAPelementPos()`) in the second Call JavaScript box to execute the code or function when the AP element is dropped. Select Only If Snapped if the JavaScript should be executed only if the AP element has reached the drop target.

13 Click OK and verify that the default event is correct.

Gather information about the draggable AP element

When you attach the Drag AP element behavior to an object, Dreamweaver inserts the `MM_dragLayer()` function into the `head` section of your document. (The function retains the old naming convention for AP elements [that is, “Layer”] so that layers created in previous versions of Dreamweaver will remain editable.) In addition to registering the AP element as draggable, this function defines three properties for each draggable AP element—`MM_LEFTRIGHT`, `MM_UPDOWN`, and `MM_SNAPPED`—that you can use in your own JavaScript functions to determine the relative horizontal position of the AP element, the relative vertical position of the AP element, and whether the AP element has reached the drop target.

**Note:**

The information provided here is intended for experienced JavaScript programmers only.

For example, the following function displays the value of the `MM_UPDOWN` property (the current vertical position of the AP element) in a form field called `curPosField`. (Form fields are useful for displaying continuously updated information because they are dynamic—that is, you can change their contents after the page has finished loading.)

```javascript
function getPos(layerId){
    var layerRef = document.getElementById(layerId);
    var curVertPos = layerRef.MM_UPDOWN;
    document.tracking.curPosField.value = curVertPos;
}
```

Instead of displaying the values of `MM_UPDOWN` or `MM_LEFTRIGHT` in a form field, you could use those values in a variety of other ways. For example, you could write a function that displays a message in the form field depending on how close the value is to the drop zone, or you could call another function to show or hide an AP element depending on the value.

It is especially useful to read the `MM_SNAPPED` property when you have several AP elements on the page, all of which must reach their targets before the visitor can advance to the next page or task. For example, you could write a function to count how many AP elements have an `MM_SNAPPED` value of `true` and call it whenever an AP element is dropped. When the snapped count reaches the desired number, you could send the visitor to the next page or display a message of congratulations.

Apply the Go To URL behavior

The Go To URL behavior opens a new page in the current window or in the specified frame. This behavior is useful for changing the contents of two or more frames with one click.

1 Select an object and choose Go To URL from the Add Behavior menu of the Behaviors panel.

2 Select a destination for the URL from the Open In list.

The Open In list automatically lists the names of all frames in the current frameset as well as the main window. If there are no frames, the main window is the only option.
Note:

This behavior may produce unexpected results if any frame is named top, blank, self, or parent. Browsers sometimes mistake these names for reserved target names.

3 Click Browse to select a document to open, or enter the path and filename of the document in the URL box.
4 Repeat steps 2 and 3 to open additional documents in other frames.
5 Click OK and verify that the default event is correct.

Apply the Jump Menu behavior

When you create a jump menu by using Insert > Form > Jump Menu, Dreamweaver creates a menu object and attaches the Jump Menu (or Jump Menu Go) behavior to it. There is usually no need to attach the Jump Menu behavior to an object by hand.

You can edit an existing jump menu in either of two ways:

• You can edit and rearrange menu items, change the files to jump to, and change the window in which those files open, by double-clicking an existing Jump Menu behavior in the Behaviors panel.
• You can edit the items in the menu just as you would edit items in any menu, by selecting the menu and using the List Values button in the Property inspector.

1 Create a jump menu object if there isn't one already in your document.
2 Select the object and choose Jump Menu from the Add Behavior menu of the Behaviors panel.
3 Make changes as desired in the Jump Menu dialog box and then click OK.

Apply the Jump Menu Go behavior

The Jump Menu Go behavior is closely associated with the Jump Menu behavior; Jump Menu Go lets you associate a Go button with a jump menu. (Before you use this behavior, a jump menu must already exist in the document.) Clicking the Go button opens the link that's selected in the jump menu. A jump menu doesn't normally need a Go button; selecting an item from a jump menu generally causes a URL to load without any need for further user action. But if the visitor selects the same item that's already chosen in the jump menu, the jump doesn't occur. In general, that doesn't matter, but if the jump menu appears in a frame, and the jump menu items link to pages in other frames, a Go button is often useful, to allow visitors to re-select an item that's already selected in the jump menu.

Note:

When you use a Go button with a jump menu, the Go button becomes the only mechanism that “jumps” the user to the URL associated with the selection in the menu. Selecting a menu item in the jump menu no longer re-directs the user automatically to another page or frame.

1 Select an object to use as the Go button (generally a button image), and choose Jump Menu Go from the Add Behavior menu of the Behaviors panel.
2 In the Choose Jump Menu menu, select a menu for the Go button to activate and click OK.

Apply the Open Browser Window behavior

Use the Open Browser Window behavior to open a page in a new window. You can specify the properties of the new window, including its size, attributes (whether it is resizable, has a menu bar, and so on), and name. For example, you can use this behavior to open a larger image in a separate window when the visitor clicks a thumbnail image; with this behavior, you can make the new window the exact size of the image.
If you specify no attributes for the window, it opens at the size and with the attributes of the window from which it was opened. Specifying any attribute for the window automatically turns off all other attributes that are not explicitly turned on. For example, if you set no attributes for the window, it might open at 1024 x 768 pixels and have a navigation bar (showing the Back, Forward, Home and Reload buttons), location toolbar (showing the URL), status bar (showing status messages, at the bottom), and menu bar (showing File, Edit, View and other menus). If you explicitly set the width to 640 and the height to 480 and set no other attributes, the window opens at 640 x 480 pixels, without toolbars.

1 Select an object and choose Open Browser Window from the Add Behavior menu of the Behaviors panel.
2 Click Browse to select a file, or enter the URL you want to display.
3 Set the options for window width and height (in pixels) and for the incorporation of various toolbars, scroll bars, resize handles, and the like. Give the window a name (use no spaces or special characters) if you want it to be the target of links or want to control it with JavaScript.
4 Click OK and verify that the default event is correct.

Apply the Popup Message behavior

The Popup Message behavior displays a JavaScript alert with the message you specify. Because JavaScript alerts have only one button (OK), use this behavior to give the user information rather than to present a choice.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}.

Example:
The URL for this page is {window.location}, and today is {new Date()}. 

Note:
The browser controls the appearance of the alert. If you want more control over the appearance, consider using the Open Browser Window behavior.

1 Select an object and choose Popup Message from the Add Behavior menu of the Behaviors panel.
2 Enter your message in the Message box.
3 Click OK and verify that the default event is correct.

Apply the Preload Images behavior

The Preload Images behavior shortens display time by caching images that are not shown when the page first appears (for instance, images that will be swapped in with behaviors or scripts).

Note:
The Swap Image behavior automatically preloads all highlight images when you select the Preload Images option in the Swap Image dialog box, so you do not need to manually add Preload Images when using Swap Image.

1 Select an object and choose Preload Images from the Add Behavior menu of the Behaviors panel.
2 Click Browse to select an image file, or enter the path and filename of an image in the Image Source File box.
3 Click the Plus (+) button at the top of the dialog box to add the image to the Preload Images list.
4 Repeat steps 2 and 3 for all remaining images that you want to preload on the current page.
5 To remove an image from the Preload Images list, select it and click the Minus (–) button.
6 Click OK and verify that the default event is correct.
Apply the Set Text Of Frame behavior
The Set Text Of Frame behavior allows you to dynamically set the text of a frame, replacing the content and formatting of a frame with the content you specify. The content can include any valid HTML code. Use this behavior to display information dynamically.

Although the Set Text Of Frame behavior replaces the formatting of a frame, you can select Preserve Background Color to preserve the page background and text color attributes.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces (\{\}). To display a brace, precede it with a backslash (\\{}\\}).

Example:
The URL for this page is {window.location}, and today is {new Date()}.  
1 Select an object and choose Set Text > Set Text Of Frame from the Add Behavior menu of the Behaviors panel. 
2 In the Set Text Of Frame dialog box, select the target frame from the Frame menu. 
3 Click the Get Current HTML button to copy the current contents of the target frame's body section. 
4 Enter a message in the New HTML box. 
5 Click OK and verify that the default event is correct.

Apply the Set Text Of Container behavior
The Set Text Of Container behavior replaces the content and formatting of an existing container (that is, any element that can contain text or other elements) on a page with the content you specify. The content can include any valid HTML source code.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces (\{\}). To display a brace, precede it with a backslash (\\{}\\}).

Example:
The URL for this page is {window.location}, and today is {new Date()}.  
1 Select an object and select Set Text > Set Text Of Container from the Add Behavior menu of the Behaviors panel. 
2 In the Set Text Of Container dialog box, use the Container menu to select the target element. 
3 Enter the new text or HTML in the New HTML box. 
4 Click OK and verify that the default event is correct.

Apply the Set Text Of Status Bar behavior
The Set Text Of Status Bar behavior shows a message in the status bar at the lower-left corner of the browser window. For example, you can use this behavior to describe the destination of a link in the status bar instead of showing the URL associated with it. Visitors often ignore or overlook messages in the status bar (and not all browsers provide full support for setting the text of the status bar); if your message is important, consider displaying it as a pop-up message or as the text of an AP element.

Note:
If you use the Set Text Of Status Bar behavior in Dreamweaver, the text of the status bar in the browser is not guaranteed to change because some browsers require special adjustments when changing status bar text. Firefox, for example, requires that you change an Advanced option that lets JavaScript change status bar text. For more information, see your browser's documentation.
You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}).

Example:
The URL for this page is {window.location}, and today is {new Date()}.

1 Select an object and choose Set Text > Set Text Of Status Bar from the Add Behavior menu of the Behaviors panel.
2 In the Set Text Of Status Bar dialog box, type your message in the Message box.
   Keep the message concise. The browser truncates the message if it doesn't fit in the status bar.
3 Click OK and verify that the default event is correct.

Apply the Set Text Of Text Field behavior
The Set Text Of Text Field behavior replaces the content of a form's text field with the content you specify.

You can embed any valid JavaScript function call, property, global variable, or other expression in the text. To embed a JavaScript expression, place it inside braces ({}). To display a brace, precede it with a backslash (\{}).

Example:
The URL for this page is {window.location}, and today is {new Date()}.

Create a named text field
1 Select Insert > Form > Text Field.
   If Dreamweaver prompts you to add a form tag, click Yes.
2 In the Property inspector, type a name for the text field. Make sure the name is unique on the page (don't use the same name for multiple elements on the same page, even if they're in different forms).

Apply Set Text Of Text Field
1 Select a text field and choose Set Text > Set Text Of Field from the Add Behavior menu of the Behaviors panel.
2 Select the target text field from the Text Field menu and enter your new text.
3 Click OK and verify that the default event is correct.

Apply the Show-Hide Elements behavior
The Show-Hide Elements behavior shows, hides, or restores the default visibility of one or more page elements. This behavior is useful for displaying information as the user interacts with the page. For example, as the user moves the pointer over an image of a plant, you could show a page element giving details about the plant's growing season and region, how much sun it needs, how large it can grow, and so on. The behavior only shows or hides the pertinent element—it does not actually remove the element from the flow of the page when it is hidden.

1 Select an object and select Show-Hide Elements from the Add Behavior menu of the Behaviors panel.
   If Show-Hide Elements is unavailable, you probably have an AP element selected. Because AP elements do not accept events in both 4.0 browsers, you must select a different object—such as the <body> tag or a link (<a>) tag.
2 From the Elements list, select the element you want to show or hide and click Show, Hide, or Restore (which restores the default visibility).
3 Repeat step 2 for all remaining elements whose visibility you want to change. (You can change the visibility of multiple elements with a single behavior.)
4 Click OK and verify that the default event is correct. This behavior has been deprecated as of Dreamweaver CS5.

**Apply the Swap Image behavior**

The Swap Image behavior swaps one image for another by changing the `src` attribute of the `<img>` tag. Use this behavior to create button rollovers and other image effects (including swapping more than one image at a time). Inserting a rollover image automatically adds a Swap Image behavior to your page.

*Note:*

> Because only the src attribute is affected by this behavior, you should swap in an image that has the same dimensions (height and width) as the original. Otherwise, the image you swap in shrinks or expands to fit the dimensions of the original image.

There is also a Swap Image Restore behavior, which restores the last set of swapped images to their previous source files. This behavior is automatically added whenever you attach the Swap Image behavior to an object; if you leave the Restore option selected while attaching Swap Image, you should never need to select the Swap Image Restore behavior manually.

1 Select Insert > Image or click the Image button on the Insert panel to insert an image.

2 In the Property inspector, enter a name for the image in the leftmost text box.

   It isn't mandatory to name images; they're named automatically when you attach the behavior to an object. However, it is easier to distinguish images in the Swap Image dialog box if you name all the images beforehand.

3 Repeat steps 1 and 2 to insert additional images.

4 Select an object (generally the image you're going to swap) and choose Swap Image from the Add Behavior menu of the Behaviors panel.

5 From the Images list, select the image whose source you want to change.

6 Click Browse to select the new image file, or enter the path and filename of the new image in the Set Source To box.

7 Repeat steps 5 and 6 for any additional images you want to change. Use the same Swap Image action for all the images you want to change at once; otherwise, the corresponding Swap Image Restore action won't restore all of them.

8 Select the Preload Images option to cache the new images when the page is loaded.

   This prevents downloading delays when it is time for the images to appear.

9 Click OK and verify that the default event is correct.

**Apply the Validate Form behavior**

The Validate Form behavior checks the contents of specified text fields to ensure that the user has entered the correct type of data. Attach this behavior to individual text fields with the `onBlur` event to validate the fields as the user is filling out the form, or attach it to the form with the `onSubmit` event to evaluate several text fields at once when the user clicks the Submit button. Attaching this behavior to a form prevents the submission of forms with invalid data.

1 Select Insert > Form or click the Form button in the Insert panel to insert a form.

2 Select Insert > Form > Text Field or click the Text Field button in the Insert panel to insert a text field.

   Repeat this step to insert additional text fields.
3. Choose a validation method:
   - To validate individual fields as the user fills out the form, select a text field and select Window > Behaviors.
   - To validate multiple fields when the user submits the form, click the <form> tag in the tag selector at the lower-left corner of the Document window and choose Window > Behaviors.

4. Select Validate Form from the Add Behavior menu.

5. Do one of the following:
   - If you are validating individual fields, select the same field that you selected in the Document window from the Fields list.
   - If you are validating multiple fields, select a text field from the Fields list.

6. Select the Required option if the field must contain some data.

7. Select one of the following Accept options:
   - **Use Anything** Checks that a required field contains data; the data can be of any type.
   - **Use E-mail address** Checks that the field contains an @ symbol.
   - **Use Number** Checks that the field contains only numerals.
   - **Use Number From** Checks that the field contains a number in a specific range.

8. If you have chosen to validate multiple fields, repeat steps 6 and 7 for any additional fields that you want to validate.

9. Click OK.
   - If you are validating multiple fields when the user submits the form, the onSubmit event automatically appears in the Events menu.

10. If you are validating individual fields, check that the default event is onBlur or onChange. If not, select one of those events.
    - Both events trigger the Validate Form behavior when the user moves away from the field. The difference is that onBlur occurs whether or not the user has typed in the field, and onChange occurs only if the user changed the contents of the field. The onBlur event is preferred if the field is required.

---

**About XML and XSLT**

*Note:*

_The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article._

**Use XML and XSL with web pages**

Extensible Markup Language (XML) is a language that lets you structure information. Like HTML, XML lets you structure your information using tags, but XML tags are not predefined as HTML tags are. Instead, XML lets you create tags that best define your data structure (schema). Tags are nested within others to create a schema of parent and child tags. Like most HTML tags, all tags in an XML schema have an opening and closing tag.

The following example shows the basic structure of an XML file:
<?xml version="1.0">
<mybooks>
  <book bookid="1">
    <pubdate>03/01/2004</pubdate>
    <title>Displaying XML Data with Adobe Dreamweaver</title>
    <author>Charles Brown</author>
  </book>
  <book bookid="2">
    <pubdate>04/08/2004</pubdate>
    <title>Understanding XML</title>
    <author>John Thompson</author>
  </book>
</mybooks>

In this example, each parent <book> tag contains three child tags: <pubdate>, <title>, and <author>. But each <book> tag is also a child tag of the <mybooks> tag, which is one level higher in the schema. You can name and structure XML tags in any way, provided that you nest tags accordingly within others, and assign each opening tag a corresponding closing tag.

XML documents do not contain any formatting—they are simply containers of structured information. Once you have an XML schema, you can use the Extensible Stylesheet Language (XSL) to display the information. In the way that Cascading Style Sheets (CSS) let you format HTML, XSL lets you format XML data. You can define styles, page elements, layout, and so forth in an XSL file and attach it to an XML file so that when a user views the XML data in a browser, the data is formatted according to whatever you've defined in the XSL file. The content (the XML data) and presentation (defined by the XSL file) are entirely separate, providing you with greater control over how your information appears on a web page. In essence, XSL is a presentation technology for XML, where the primary output is an HTML page.

Extensible Stylesheet Language Transformations (XSLT) is a subset language of XSL that actually lets you display XML data on a web page, and “transform” it, along with XSL styles, into readable, styled information in the form of HTML. You can use Dreamweaver to create XSLT pages that let you perform XSL transformations using an application server or a browser. In a server-side XSL transformation, the server does the work of transforming the XML and XSL and displaying it on the page. In a client-side transformation, a browser (such as Internet Explorer) does the work.

The approach you ultimately take (server-side transformations versus client-side transformations) depends on what you are trying to achieve as an end result, the technologies available to you, the level of access you have to XML source files, and other factors. Both approaches have their own benefits and limitations. For example, server-side transformations work in all browsers while client-side transformations are restricted to modern browsers only (Internet Explorer 6, Netscape 8, Mozilla 1.8, and Firefox 1.0.2). Server-side transformations let you display XML data dynamically from your own server or from anywhere else on the web, while client-side transformations must use XML data that is locally hosted on your own web server. Finally, server-side transformations require that you deploy your pages to a configured application server, while client-side transformations only require access to a web server.

For a tutorial about understanding XML, see www.adobe.com/go/vid0165.

**Server-side XSL transformations**

Dreamweaver provides methods for creating XSLT pages that let you perform server-side XSL transformations. When an application server performs the XSL transformation, the file containing the XML data can reside on your own server, or anywhere else on the web. Additionally, any browser can display the transformed data. Deploying pages for server-side transformations, however, is somewhat complex, and requires that you have access to an application server.
When working with server-side XSL transformations, you can use Dreamweaver to create XSLT pages that generate full HTML documents (entire XSLT pages), or XSLT fragments that generate a portion of an HTML document. An entire XSLT page is similar to a regular HTML page. It contains a `<body>` tag and a `<head>` tag, and lets you display a combination of HTML and XML data on the page. An XSLT fragment is a piece of code, used by a separate document, that displays formatted XML data. Unlike an entire XSLT page, it is an independent file that contains no `<body>` or `<head>` tag. If you want to display XML data on a page of its own, you would create an entire XSLT page, and bind your XML data to it. If, on the other hand, you wanted to display XML data in a particular section of an existing dynamic page—for example, a dynamic home page for a sporting goods store, with sports scores from an RSS feed displayed on one side of the page—you would create an XSLT fragment and insert a reference to it in the dynamic page. Creating XSLT fragments, and using them in conjunction with other dynamic pages to display XML data, is the more common scenario.

The first step in creating these types of pages is to create the XSLT fragment. It is a separate file that contains the layout, formatting, and so on of the XML data that you eventually want to display in the dynamic page. Once you create the XSLT fragment, you insert a reference to it in your dynamic page (for example, a PHP or ColdFusion page). The inserted reference to the fragment works much like an Server Side Include (SSI) — the formatted XML data (the fragment) resides in a separate file, while in Design view, a placeholder for the fragment appears on the dynamic page itself. When a browser requests the dynamic page containing the reference to the fragment, the server processes the included instruction and creates a new document in which the formatted contents of the fragment appear instead of the placeholder.

You use the XSL Transformation server behavior to insert the reference to an XSLT fragment in a dynamic page. When you insert the reference, Dreamweaver generates an includes/MM_XSLTransform/ folder in the site's root folder that contains a runtime library file. The application server uses the functions defined in this file when transforming the specified XML data. The file is responsible for fetching the XML data and XSLT fragments, performing the XSL transformation, and outputting the results on the web page.

The file containing the XSLT fragment, the XML file containing your data, and the generated run-time library file must all be on the server for your page to display correctly. (If you select a remote XML file as your data source—one from an RSS feed, for example—that file must of course reside somewhere else on the Internet.)
You can also use Dreamweaver to create entire XSLT pages for use with server-side transformations. An entire XSLT page works in exactly the same way as an XSLT fragment, only when you insert the reference to the entire XSLT page using the XSL Transformation server behavior, you are inserting the full contents of an HTML page. Thus, the dynamic page (the .cfm, .php, or .asp page that acts as the container page) must be cleared of all HTML before you insert the reference.

Dreamweaver supports XSL transformations for ColdFusion, ASP, and PHP pages.

**Note:**

Your server must be correctly configured to perform server-side transformations. For more information, contact your server administrator.

### Client-side XSL transformations

You can perform XSL transformations on the client without the use of an application server. You can use Dreamweaver to create an entire XSLT page that will do this; however, client-side transformations require manipulation of the XML file that contains the data you want to display. Additionally, client-side transformations will only work in modern browsers (Internet Explorer 6, Netscape 8, Mozilla 1.8, and Firefox 1.0.2).

First, create an entire XSLT page and attach an XML data source. (Dreamweaver prompts you to attach the data source when you create the new page.) You can create an XSLT page from scratch, or you can convert an existing HTML page to an XSLT page. When you convert an existing HTML page to an XSLT page you must attach an XML data source using the Bindings panel (Window > Bindings).

After you've created your XSLT page, you must link it to the XML file containing the XML data by inserting a reference to the XSLT page in the XML file itself (much like you would insert a reference to an external CSS style sheet in the `<head>` section of an HTML page). Your site visitors must view the XML file (not the XSLT page) in a browser. When your site visitors view the page, the browser performs the XSL transformation and displays the XML data, formatted by the linked XSLT page.

The relationship between the linked XSLT and XML pages is conceptually similar, yet different from the external CSS/HTML page model. When you have an HTML page that contains content (such as text), you use an external style sheet to format that content. The HTML page determines the content, and the external CSS code, which the user never sees, determines the presentation. With XSLT and XML, the situation is reversed. The XML file (which the user never sees in its raw form), determines the content while the XSLT page determines the presentation. The XSLT page contains the tables, layout, graphics, and so forth that the standard HTML usually contains. When a user views the XML file in a browser, the XSLT page formats the content.
When you use Dreamweaver to link an XSLT page to an XML page, Dreamweaver inserts the appropriate code for you at the top of the XML page. If you own the XML page to which you’re linking (that is, if the XML file exclusively lives on your web server), all you need to do is use Dreamweaver to insert the appropriate code that links the two pages. When you own the XML file, the XSL transformations performed by the client are fully dynamic. That is, whenever you update the data in the XML file, any HTML output using the linked XSLT page will be automatically updated with the new information.

**Note:**

The XML and XSL files you use for client-side transformations must reside in the same directory. If they don't, the browser will read the XML file and find the XSLT page for the transformation, but will fail to find assets (style sheets, images, and so on) defined by relative links in the XSLT page.

If you don’t own the XML page to which you’re linking (for example, if you want to use XML data from an RSS feed somewhere out on the web), the workflow is a bit more complicated. To perform client-side transformations using XML data from an external source, you must first download the XML source file to the same directory where your XSLT page resides. When the XML page is in your local site, you can use Dreamweaver to add the appropriate code that links it to the XSLT page, and post both pages (the downloaded XML file and the linked XSLT page) to your web server. When the user views the XML page in a browser, the XSLT page formats the content, just like in the previous example.

The disadvantage of performing client-side XSL transformations on XML data that comes from an external source is that the XML data is only partially “dynamic.” The XML file that you download and alter is merely a “snapshot” of the file that lives elsewhere on the web. If the original XML file out on the web changes, you must download the file again, link it to the XSLT page, and repost the XML file to your web server. The browser only renders the data that it receives from the XML file on your web server, not the data contained in the original XML source file.

**XML data and repeating elements**

The Repeating Region XSLT object lets you display repeating elements from an XML file within a page. Any region containing an XML data placeholder can be turned into a repeated region. However, the most common regions are a table, a table row, or a series of table rows.
The following example shows how the Repeating Region XSLT object is applied to a table row that displays menu information for a restaurant. The initial row displays three different elements from the XML schema: item, description, and price. When the Repeating Region XSLT object is applied to the table row, and the page is processed by an application server or a browser, the table is repeated with unique data inserted in each new table row.

When you apply a Repeating Region XSLT object to an element in the Document window, a thin, tabbed, gray outline appears around the repeated region. When you preview your work in a browser (File > Preview in Browser), the gray outline disappears and the selection expands to display the specified repeating elements in the XML file, as in the previous illustration.

When you add the Repeating Region XSLT object to the page, the length of the XML data placeholder in the Document window is truncated. This is because Dreamweaver updates the XPath (XML Path language) expression for the XML data placeholder so that it is relative to the path of the repeating element.

For example, the following code is for a table that contains two dynamic placeholders, without a Repeating Region XSLT object applied to the table:

```xml
<table width="500" border="1">
  <tr>
    <td><xsl:value-of select="rss/channel/item/title"/></td>
  </tr>
  <tr>
    <td><xsl:value-of select="rss/channel/item/description"/></td>
  </tr>
</table>
```
The following code is for the same table with the Repeating Region XSLT object applied to it:

```xml
<xsl:for-each select="rss/channel/item">
    <table width="500" border="1">
        <tr>
            <td><xsl:value-of select="title"/></td>
        </tr>
        <tr>
            <td><xsl:value-of select="description"/></td>
        </tr>
    </table>
</xsl:for-each>
```

In the previous example, Dreamweaver has updated the XPath for the items that fall within the Repeating Region (title & description) to be relative to the XPath in the enclosing `<xsl:for-each>` tags, rather than the full document.

Dreamweaver generates context-relative XPath expressions in other cases as well. For example, if you drag an XML data placeholder to a table that already has a Repeating Region XSLT object applied to it, Dreamweaver automatically displays the XPath relative to the existing XPath in the enclosing `<xsl:for-each>` tags.

**Preview XML data**

When you use Preview in Browser (File > Preview in Browser) to preview XML data that you've inserted in an XSLT fragment or an entire XSLT page, the engine that performs the XSL transformation differs from situation to situation. For dynamic pages containing XSLT fragments, the application server always performs the transformation. At other times, either Dreamweaver or the browser might be performing the transformation.

The following table summarizes the situations when using Preview in Browser, and the engines that perform the respective transformations:

<table>
<thead>
<tr>
<th>Type of page previewed in browser</th>
<th>Data transformation performed by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamic page containing XSLT fragment</td>
<td>Application server</td>
</tr>
<tr>
<td>XSLT fragment or entire XSLT page</td>
<td>Dreamweaver</td>
</tr>
<tr>
<td>XML file with link to entire XSLT page</td>
<td>Browser</td>
</tr>
</tbody>
</table>

The following topics provide guidelines for helping you determine the appropriate previewing methods, based on your needs.

**Previewing pages for server-side transformations**

In the case of server-side transformations, the content the site visitor ultimately sees is transformed by your application server. When building XSLT and dynamic pages for use with server-side transformations, it is always preferable to preview the dynamic page that contains the XSLT fragment instead of the XSLT fragment itself. In the former scenario, you make use of the application server, which ensures that your preview is consistent with what your site visitors will see when they visit your page. In the latter scenario, Dreamweaver performs the transformation, and could provide slightly inconsistent results. You can use Dreamweaver to preview your XSLT fragment while you are building it, but you’ll be able to see the most accurate results of the data rendering if you use the application server to preview your dynamic page after you’ve inserted the XSLT fragment.

**Previewing pages for client-side transformations**
In the case of client-side transformations, the content the site visitor ultimately sees is transformed by a browser. You accomplish this by adding a link from the XML file to the XSLT page. If you open the XML file in Dreamweaver and preview it in a browser, you force the browser to load the XML file and perform the transformation. This provides you with the same experience as that of your site visitor.

Using this approach, however, makes it more difficult to debug your page because the browser transforms the XML and generates the HTML internally. If you select the browser’s View Source option to debug the generated HTML, you will only see the original XML that the browser received, not the full HTML (tags, styles, and so forth) responsible for the rendering of the page. To see the full HTML when viewing source code, you must preview the XSLT page in a browser instead.

**Previewing entire XSLT pages and XSLT fragments**

When creating entire XSLT pages and XSLT fragments, you’ll want to preview your work to make sure that your data is being displayed correctly. If you use Preview in Browser to display an entire XSLT page or an XSLT fragment, Dreamweaver performs the transformation using a built-in transformation engine. This method gives you quick results, and makes it easier for you to incrementally build and debug your page. It also provides a way for you to view the full HTML (tags, styles, and so forth) by selecting the View Source option in the browser.

**Note:**

This previewing method is commonly used when you begin building XSLT pages, regardless of whether you use the client or the server to transform your data.

**Perform server-side XSL transformations in Dreamweaver**

**Note:**

The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

**Workflow for performing server-side XSL transformations**

You can perform server-side XSL transformations on the server. Read about server-side and client-side XSL transformations and about using XML and XSL with web pages before building pages that display XML data.

**Note:**

Your server must be correctly configured to perform server-side transformations. For more information, contact your server administrator.

The general workflow for performing server-side XSL transformations is as follows (each step is described in other topics):

1. **Set up a Dreamweaver site.**
2. **Choose a server technology and set up an application server.**
3. **Test the application server.**

For example, create a page that requires processing, and make sure that the application server processes the page.
4. Create an XSLT fragment or page, or convert an HTML page to an XSLT page.

- In your Dreamweaver site, create an XSLT fragment or an entire XSLT page.
- Convert an existing HTML page to an entire XSLT page.

5. Attach an XML data source to the page.

6. Display XML data by binding the data to the XSLT fragment or to the entire XSLT page.

7. If appropriate, add a Repeating Region XSLT object to the table or table row that contains the XML data placeholders.

8. Insert references.

- To insert a reference to the XSLT fragment in your dynamic page, use the XSL Transformation server behavior.
- To insert a reference to the entire XSLT page in the dynamic page, delete all of the HTML code from a dynamic page, and then use the XSL Transformation server behavior.

9. Post the page and the fragment.

Post both the dynamic page and the XSLT fragment (or entire XSLT page) to your application server. If you are using a local XML file, you will need to post that as well.

10. View the dynamic page in a browser.

When you do so, the application server transforms the XML data, inserts it in the dynamic page, and displays it in the browser.

Create an XSLT page

You can create XSLT pages that let you display XML data on web pages. You can create either an entire XSLT page—an XSLT page that contains a `<body>` tag and a `<head>` tag—or you can create an XSLT fragment. When you create an XSLT fragment, you create an independent file that contains no body or head tag—a simple piece of code that is later inserted in a dynamic page.

Note:

If you are starting with an existing XSLT page, you need to attach an XML data source to it.

1 Select File > New.
2 In the Blank Page category of the New Document dialog box, select one of the following from the Page Type column:
   - Select XSLT (Entire page) to create an entire XSLT page.
   - Select XSLT (Fragment) to create an XSLT fragment.
3 Click Create and do one of the following in the Locate XML Source dialog box:
   - Select Attach A Local File, click the Browse button, browse to a local XML file on your computer, and click OK.
   - Select Attach A Remote File, enter the URL of an XML file on the Internet (such as one coming from an RSS feed), and click OK.

Note:

Clicking the Cancel button generates a new XSLT page with no attached XML data source.

The Bindings panel is populated with the schema of your XML data source.

Last updated 11/7/2019
The following table provides an explanation of the various elements in the schema that might appear:

<table>
<thead>
<tr>
<th>Element</th>
<th>Represents</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;&gt;</td>
<td>Required non-repeating XML element</td>
<td>An element that appears exactly once within its parent node</td>
</tr>
<tr>
<td>&lt;&gt;++</td>
<td>Repeating XML element</td>
<td>An element that appears one or more times within its parent node</td>
</tr>
<tr>
<td>&lt;&gt;+</td>
<td>Optional XML element</td>
<td>An element that appears zero or more times within its parent node</td>
</tr>
<tr>
<td>Element node in boldface type</td>
<td>Current context element</td>
<td>Normally the repeating element when the insertion point is inside a repeating region</td>
</tr>
<tr>
<td>@</td>
<td>XML attribute</td>
<td></td>
</tr>
</tbody>
</table>

4. Save your new page (File > Save) with the .xsl or .xslt extension (.xsl is the default).

**Convert HTML pages to XSLT pages**

You can also convert existing HTML pages to XSLT pages. For example, if you have a predesigned static page to which you want to add XML data, you can convert the page to an XSLT page, instead of creating an XSLT page and redesigning the page from scratch.

1. Open the HTML page that you want to convert.
2. Select File > Convert > XSLT 1.0.

   A copy of the page opens in the Document window. The new page is an XSL style sheet, saved with the .xsl extension.

**Attach XML data sources**

If you are starting with an existing XSLT page, or if you don't attach an XML data source when creating a new XSLT page with Dreamweaver, you must attach an XML data source using the Bindings panel.

1. In the Bindings panel (Window > Bindings), click the XML link.
Click XML in the Bindings panel

Note:

You can also click the Source link at the upper-right corner of the Bindings panel to add an XML data source.

2 Do one of the following:

• Select Attach A Local File, click the Browse button, browse to a local XML file on your computer, and click OK.
• Select Attach A Remote File, and enter the URL of an XML file on the Internet (such as one coming from an RSS feed).

3 Click OK to close the Locate XML Source dialog box.

The Bindings panel is populated with the schema of your XML data source.

Display XML data in XSLT pages

After you’ve created an XSLT page and attached an XML data source, you can bind data to the page. To do this, you add an XML data placeholder to your page and then use the XPath Expression Builder or the Property inspector to format selected data that will be displayed on the page.

1 Open an XSLT page with an attached XML data source.

2 (Optional) Select Insert > Table to add a table to the page. A table helps you organize your XML data.

   Note:

   In most cases, you use the Repeating Region XSLT object to display repeating XML elements on a page. In this case, you might want to create a single-row table with one or more columns, or a two-row table if you want to include a table header.

3 In the Bindings panel, select an XML element and drag it to the place on the page where you want to insert data.
Select an XML element in the Bindings panel

An XML data placeholder appears on the page. The placeholder is highlighted and in curly brackets. It uses the XPath (XML Path language) syntax to describe the hierarchical structure of the XML schema. For example, if you drag the child element title to the page, and that element has the parent elements rss, channel, and item, then the syntax for the dynamic content placeholder will be {rss/channel/item/title}.

Double-click the XML data placeholder on the page to open the XPath Expression Builder. The XPath Expression Builder lets you format selected data, or select other items from the XML schema.

(Optional) Apply styles to your XML data by selecting an XML data placeholder and applying styles to it like any other piece of content using the Property inspector or the CSS Styles panel. Alternatively, you can use Design-time style sheets to apply styles to XSLT fragments. Each of these methods has its own set of benefits and limitations.

Preview your work in a browser (File > Preview in Browser).

Note:

When you preview your work using Preview in Browser, Dreamweaver performs an internal XSL transformation without the use of an application server.

Display repeating XML elements

The Repeating Region XSLT object lets you display repeating elements from an XML data source in a web page. For example, if you are displaying article titles and descriptions from a news feed, and that news feed contains between 10 and 20 articles, each title and description in the XML file would probably be a child element of a repeating element.

Any region in Design view containing an XML data placeholder can be changed to a repeated region. However, the most common regions are tables, table rows, or a series of table rows.

In Design view, select a region that contains an XML data placeholder or placeholders.

The selection can be anything, including a table, a table row, or even a paragraph of text.
To select a region on the page precisely, you can use the tag selector in the lower-left corner of the Document window. For example, if the region is a table, click inside the table on the page, and then click the tag in the tag selector.

2 Do one of the following
   • Select Insert > XSLT Objects > Repeating Region.
   • In the XSLT category of the Insert panel, click the Repeating Region button.

3 In the XPath Expression Builder, select the repeating element, indicated by a small plus sign.

4 Click OK.

In the Document window, a thin, tabbed, gray outline appears around the repeated region. When you preview your work in a browser (File > Preview in Browser), the gray outline disappears and the selection expands to display the specified repeating elements in the XML file.
When you add the Repeating Region XSLT object to the page, the XML data placeholder in the Document window is truncated. This is because Dreamweaver truncates the XPath for the XML data placeholder so that it is relative to the path of the repeating element.

**Set Repeating Region (XSL) properties**
In the Property inspector, you can select a different XML node to create the repeating region.

? In the Select box, enter a new node, and then press the lightning bolt icon and select the node from the XML schema tree that appears.

**Edit a Repeating Region XSLT object**
After you've added a Repeating Region XSLT object to a region, you can edit it using the Property inspector.

1 Select the object by clicking the gray tab that surrounds the repeated region.
2 In the Property inspector (Window > Properties), click the dynamic icon next to the Select text field.
3 In the XPath Expression Builder, make your changes and click OK.

**Insert XSLT fragments in dynamic pages**
After you have created an XSLT fragment, you can insert it in a dynamic web page using the XSL Transformation server behavior. When you add the server behavior to your page and view the page in a browser, an application server performs a transformation that displays the XML data from the selected XSLT fragment. Dreamweaver supports XSL transformations for ColdFusion, ASP, or PHP pages.

*Note:*
*If you want to insert the contents of an entire XSLT page in a dynamic page, the procedure is exactly the same. Before using the XSL Transformation server behavior to insert the entire XSLT page, delete all HTML code from the dynamic page.*

1 Open an existing ColdFusion, ASP, or PHP page.
2 In Design view, place the insertion point in the location where you want to insert the XSLT fragment.

*Note:*
*When inserting XSLT fragments, you should always click the Show Code And Design Views button after placing the insertion point on the page so that you can ensure that the insertion point is in the correct location. If it isn't, you might need to click somewhere else in Code view to place the insertion point where you want it.*

3 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select XSL Transformation.
4 In the XSL Transformation dialog box, click the Browse button and browse to an XSLT fragment or an entire XSLT page.

Dreamweaver populates the next text field with the file path or URL of the XML file that is attached to the specified fragment. To change it, click the Browse button and browse to another file.

5 (Optional) Click the Plus (+) button to add an XSLT parameter.

6 Click OK to insert a reference to the XSLT fragment in the page. The fragment is not editable. You can double-click the fragment to open the fragment's source file and edit it.

An includes/MM_XSLTransform/ folder is also created in the site's root folder that contains a runtime library file. The application server uses the functions defined in this file to perform the transformation.

7 Upload the dynamic page to your server (Site > Put) and click Yes to include dependent files. The file containing the XSLT fragment, the XML file containing your data, and the generated run-time library file must all be on the server for your page to display correctly. (If you selected a remote XML file as your data source, that file must reside somewhere else on the Internet.)

**Delete XSLT fragments from dynamic pages**

You can remove an XSLT fragment from a page by deleting the XSLT Transformation server behavior used to insert the fragment. Deleting the server behavior deletes the XSLT fragment only—it does not delete the associated XML, XSLT, or run-time library files.

1 In the Server Behaviors panel (Window > Server Behaviors), select the XSLT Transformation server behavior that you want to delete.

2 Click the minus (-) button.

*Note:*
You should always remove server behaviors in this fashion. Manually deleting the generated code only partially removes the server behavior, even though the server behavior may disappear from the Server Behaviors panel.

**Edit XSL Transformation server behaviors**

After you've added an XSLT fragment to a dynamic web page, you can edit the XSL Transformation server behavior at any time.

1. In the Server Behaviors panel (Window > Server Behaviors), double-click the XSL Transformation server behavior that you want to edit.
2. Make your changes and click OK.

**Create a dynamic link**

You can create a dynamic link on your XSLT page that links to a specific URL when the user clicks a specified word or group of words from your XML data. For full instructions, see the Dreamweaver errata at www.adobe.com/go/dw_documentation.

**Apply styles to XSLT fragments**

When you create an entire XSLT page (that is, an XSLT page that contains `<body>` and `<head>` tags), you can display XML data on the page and then format the data like any other piece of content using the Property inspector or the CSS Styles panel. When you create an XSLT fragment for insertion in a dynamic page, however (for example, a fragment for insertion in an ASP, PHP, or Cold Fusion page), the rendering of styles in the fragment and in the dynamic page becomes more complicated. Although you work on an XSLT fragment separately from the dynamic page, it is important to remember that the fragment is intended for use within the dynamic page, and that the output from the XSLT fragment ultimately resides somewhere within the `<body>` tags of the dynamic page. Given this workflow, it is important to make sure that you do not include `<head>` elements (such as style definitions or links to external style sheets) in XSLT fragments. Doing so will cause the application server to place these elements into the `<body>` of the dynamic page, thereby generating invalid markup.

For example, you might want to create an XSLT fragment for insertion in a dynamic page and format the fragment using the same external style sheet as the dynamic page. If you attach the same style sheet to the fragment, the resulting HTML page contains a duplicate link to the style sheet (one in the `<head>` section of the dynamic page, and another in the `<body>` section of the page, where the content of the XSLT fragment appears). Instead of this approach, you should use Design-time style sheets to reference the external style sheet.

When formatting the content of XSLT fragments, use the following workflow:

- First, attach an external style sheet to the dynamic page. (This is a best practice for applying styles to the content of any web page).
- Next, attach the same external style sheet to the XSLT fragment as a Design-time style sheet. As the name implies, Design-time style sheets only work in the Dreamweaver Design view.

After you have completed the two previous steps, you can create new styles in your XSLT fragment using the same style sheet that you've attached to your dynamic page. The HTML output will be cleaner (because the reference to the style sheet is only valid while working in Dreamweaver), and the fragment will still display the appropriate styles in Design view. Additionally, all of your styles will be applied to both the fragment and the dynamic page when you view the dynamic page in Design view, or preview the dynamic page in a browser.

**Note:**
If you preview the XSLT fragment in a browser, the browser does not display the styles. Instead you should preview the dynamic page in the browser to see the XSLT fragment within the context of the dynamic page.

Use parameters with XSL transformations
You can define parameters for your XSL transformation when adding the XSL Transformation server behavior to a web page. A parameter controls how XML data is processed and displayed. For example, you might use a parameter to identify and list a specific article from a news feed. When the page loads in a browser, only the article you specified with the parameter appears.

Add an XSLT parameter to an XSL transformation
1. Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation server behavior.
2. In the XSL Transformation dialog box, click the Plus (+) button next to XSLT Parameters.

![XSL Transformation dialog box](image)

3. In the Add Parameters dialog box, enter a name for the parameter in the Name box. The name can only contain alphanumeric characters. It cannot contain spaces.
4. Do one of the following:
   • If you want to use a static value, enter it in the Value box.
   • If you want to use a dynamic value, click the dynamic icon next to the Value box, complete the Dynamic Data dialog box, and click OK. For more information, click the Help button in the Dynamic Data dialog box.
5. In the Default Value box, enter the value you want the parameter to use if the page receives no run-time value, and click OK.

Edit an XSLT parameter
1. Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation server behavior.
2. Select a parameter from the XSLT parameters list.
3. Click the Edit button.
4. Make your changes and click OK.
480
Coding websites

Delete an XSLT parameter
1 Open the XSL Transformation dialog box. You can do this by double-clicking an XSL Transformation server

behavior in the Server Behaviors panel (Window > Server Behaviors), or by adding a new XSL Transformation
server behavior.
2 Select a parameter from the XSLT parameters list.
3 Click the minus (-) button.

Create and edit conditional XSLT regions
You can create simple conditional regions or multiple conditional regions on an XSLT page. You can either select an
element in Design view and apply a conditional region to the selection, or you can insert a conditional region wherever
the insertion point is in the document.
For example, if you wanted to display the word “Unavailable” next to the price of an item when the item is unavailable,
you type the text “Unavailable” on the page, select it, and then apply a conditional region to the selected text.
Dreamweaver surrounds the selection with <xsl:if> tags, and only displays the word “Unavailable” on the page when
the data match the conditions of the conditional expression.

Apply a conditional XSLT region
You can write a simple conditional expression to insert into your XSLT page. If content is selected when you open the
Conditional Region dialog box, the content will be wrapped in an <xsl:if> block. If you rcontent is not selected, the
<xsl:if> block is added at the insertion point on the page. It’s a good idea to use the dialog box to get started and then
customize the expression in Code view.
The <xsl:if> element is similar to the if statement in other languages. The element provides a way for you to test a
condition and take a course of action based on the result. The <xsl:if> element allows you to test an expression for a
single true or false value.
1 Select Insert > XSLT Objects > Conditional Region or click the Conditional Region icon in the XLST category of the

Insert panel.
2 In the Conditional Region dialog box, enter the conditional expression to use for the region.

In the following example, you want to test to see if the context node’s @available attribute value is true.

Conditional Region dialog box

3 Click OK.

The following code is inserted in your XSLT page:
<xsl:if test="@available=&apos;true&apos;">
Content goes here
</xsl:if>

Last updated 11/7/2019


Note:

You must surround string values such as true in quotes. Dreamweaver encodes the quotes for you (apostrophes) so that they are entered as valid XHTML.

In addition to testing nodes for values, you can use any of the supported XSLT functions in any conditional statement. The condition is tested for the current node within your XML file. In the following example, you want to test for the last node in the result set:

![Conditional Region dialog box](image)

Test for the last node in the result set

For more information and examples on writing conditional expressions, see the `<xsl:if>` section in the Reference panel (Help > Reference).

**Apply multiple conditional XSLT regions**

You can write a simple conditional expression to insert into your XSLT page. If content is selected when you open the Conditional Region dialog box, the content is wrapped in an `<xsl:choose>` block. If you do not select content, the `<xsl:choose>` block is added at the insertion point on the page. It's a good idea to use the dialog box to get started and then customize the expression in Code view.

The `<xsl:choose>` element is similar to the `case` statement in other languages. The element provides a way for you to test a condition and take a course of action based on the result. The `<xsl:choose>` element allows you to test for multiple conditions.

1. Select Insert > XSLT Objects > Multiple Conditional Region or click the Multiple Conditional Region icon in the XSLT category of the Insert panel.
2. In the Multiple Conditional Region dialog box, enter the first condition.
   
   In the following example, you want to test to see if the context node's `price` subelement is less than 5.

   ![Multiple Conditional Region dialog box](image)

   Multiple Conditional Region dialog box

3. Click OK.

   In the example, the following code is inserted in your XSLT page:
<xsl:choose>
  <xsl:when test="price&lt;5">
    Content goes here
  </xsl:when>
  <xsl:otherwise>
    Content goes here
  </xsl:otherwise>
</xsl:choose>

4 To insert another condition, place the insertion point in Code view between <xsl:when> tag pairs or just before the <xsl:otherwise> tag, and then insert a conditional region (Insert > XSLT Objects > Conditional Region).

After you specify the condition and click OK, another <xsl:when> tag is inserted in the <xsl:choose> block.

For more information and examples on writing conditional expressions, see the <xsl:choose> sections in the Reference panel (Help > Reference).

Set conditional region (If) properties
The purpose of the Set Conditional Region Property inspector is to change the condition used in a conditional region in your XSL page. The conditional region tests the condition and takes a course of action based on the result.

? In the Test box, enter a new condition, and then press Enter.

Set conditional (When) properties
The purpose of the Set Conditional Region Property inspector is to change the condition used in a multiple conditional region in your XSL page. The multiple conditional region tests the condition and takes a course of action based on the result.

? In the Test box, enter a new condition, and then press Enter.

Insert XSL comments
You can add XSL comment tags to a document, or you can wrap a selection in XSL comment tags.

Add XSL comment tags to a document
? Do one of the following:
  • In Design view, select Insert > XSLT Objects > XSL Comment, type the contents of the comment (or leave the box blank), and click OK.
  • In Code view, select Insert > XSLT Objects > XSL Comment.

💡 You can also click on the XSL Comment icon in the XSLT category of the Insert panel.

Wrap a selection in XSL comment tags
1 Switch to Code view (View > Code).
2 Select the code you want to comment.
3 In the Coding toolbar, click the Apply Comment button and select Apply <xsl:comment/> Comment.
Use the XPath Expression Builder to add expressions for XML data

XPath (XML Path Language) is a non-XML syntax for addressing portions of an XML document. It is used mostly as a query language for XML data, just as the SQL language is used to query databases. For more information on XPath, see the XPath language specification on the W3C website at www.w3.org/TR/xpath.

The XPath Expression Builder is a Dreamweaver feature that lets you build simple XPath expressions for identifying specific nodes of data and for repeating regions. The advantage of using this method instead of dragging values from the XML schema tree is that you can format the value that is displayed. The current context is identified based on the position of the insertion point in the XSL file when the XPath Expression Builder dialog box is opened. The current context is in boldface type in the XML schema tree. As you make selections within this dialog box, the correct XPath statements, relative to your current context, are generated. This simplifies the process of writing correct XPath expressions for beginners and advanced users.

*Note:*

This feature is designed to help you build simple XPath expressions to identify a specific node or for repeating regions. It does not allow you to edit the expressions by hand. If you need to create complex expressions, use the XPath Expression Builder to get started and then customize your expressions in Code view or with the Property inspector.

Create an XPath expression to identify a specific node

1. Double-click the XML data placeholder on the page to open the XPath Expression Builder.
2. In the XPath Expression Builder (Dynamic Text) dialog box, select any node in the XML schema tree.
   - The correct XPath expression is written in the Expression box to identify the node.

   *Note:*

   If you select a different node in the XML schema tree, the expression changes to reflect your choice.

In the following example, you want to display the `price` subelement of the `item` node:

This selection would insert the following code in your XSLT page:

```xml
<xsl:value-of select="price"/>
```
3  (Optional) Select a formatting option from the Format pop-up menu.

Formatting a selection is useful when the value of your node returns a number. Dreamweaver provides a predefined list of formatting functions. For a complete list of available formatting functions and examples, see the Reference panel.

In the following example, you want to format the price subelement as a currency with two decimal places:

These options would insert the following code in your XSLT page:

```xml
<xsl:value-of select="format-number(provider/store/items/item/price, '$#.00')"/>

<xsl:value-of select="format-number(provider/store/items/item/price, '$#.00')"/>
```

4  Click OK.

5  To display the value of each node in the XML file, apply a repeating region to the element containing the dynamic text (for example, an HTML table row or a paragraph).

For more information and examples on selecting nodes to return a value, see the `<xsl:value-of/>` section in the Reference panel.

**Select a node to repeat**

You can select a node to repeat over and, optionally, to filter the results. In the XPath Expression Builder dialog box, your selected content will be wrapped inside an `<xsl:for-each>` block. If you have not selected content, the `<xsl:for-each>` block will be entered at the insertion point of your cursor.

1  Double-click the XML data placeholder on the page to open the XPath Expression Builder.

2  In the XPath Expression Builder (Repeating Region) dialog box, select the item to repeat in the XML schema tree.

The correct XPath expression is written in the Expression box to identify the node.

**Note:**

*Repeating items are identified with a Plus (+) symbol in the XML schema tree.*

In the following example, you want to repeat each item node within the XML file.
XPath Expression Builder (Repeating Region) dialog box

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store/items/item">
  Content goes here
</xsl:for-each>
```

In some cases, you may want to work with a subset of the repeating nodes—for example, you may only want items where an attribute has a specific value. In this case, you need to create a filter.

**Filter the data to be repeated**

Use a filter to identify repeating nodes that have specific attribute values.

1. In the XML schema tree, select a node to repeat.
2. Click the Build Filter expander button.
3. Click the Plus (+) button to create an empty filter.
4. Enter the filter criteria in the following fields:
   - **Filter By** Specifies the repeating node that contains the data you want to filter by. The pop-up menu provides a list of ancestor nodes relative to the node you selected in the XML schema tree.
   - **Where** Specifies the attribute or subelement of the Filter By node that will be used to limit the results. You can select an attribute or subelement from the pop-up menu, or you can enter your own XPath expression in this field to identify children that exist deeper within the schema tree.
   - **Operator** Specifies the comparison operator to use in the filter expression.
   - **Value** Specifies the value to check for in the Filter By node. Enter the value. If dynamic parameters are defined for your XSLT page, you can select one from the pop-up menu.
5. To specify another filter, click the Plus (+) button again.

As you enter values or make selections in the pop-up menus, the XPath expression in the Expression box changes. In the following example, you want to restrict the result set to those `item` nodes where the value of the `@available` attribute is `true`. 
Restrict the result set to those item nodes where the value of the @available attribute is true

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store/items/item[@available = 'true']"> Content goes here </xsl:for-each>
```

```xml
<xsl:for-each select="provider/store/items/item[@available = 'true']">
  Content goes here
</xsl:for-each>
```

**Note:**

You need to surround string values such as true in quotes. Dreamweaver encodes the quotes for you ("apos;) so that they are entered as valid XHTML.

You can create more complex filters that allow you to specify parent nodes as part of your filter criteria. In the following example, you want to restrict the result set to those item nodes where the store’s @id attribute is equal to 1 and the item’s price node is greater than 5.
Restrict the result set to those item nodes where the store's @id attribute is equal to 1 and the item's price node is greater than 5

When you click OK, the following code is inserted in your XSLT page:

```xml
<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> Content goes here </xsl:for-each>
```

For more information and examples of repeating regions, see the `<xsl:for-each>` section in the Reference panel.

```xml
<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]">
  Content goes here
</xsl:for-each>
```

### Performing client-side XSL transformations in Dreamweaver

**Note:**

The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

### Workflow for performing client-side XSL transformations

You can perform client-side XSL transformations. Read about server-side and client-side XSL transformations and about using XML and XSL with web pages before building pages that display XML data.

The general workflow for performing client-side XSL transformations is as follows (each step is described in other topics):

Set up a Dreamweaver site.
Create an XSLT page or convert an HTML page to XSLT.

- In your Dreamweaver site, create an entire XSLT page.
- Convert an existing HTML page to an entire XSLT page.

Attach an XML data source to the page (if you haven't already done so).

The XML file that you attach must reside in the same directory as the XSLT page.

Bind your XML data to the XSLT page.

Display XML data by binding the data to the entire XSLT page.

If appropriate, add a Repeating Region XSLT object to the table or table row that contains the XML data placeholder(s).

Attach the XSLT page to the XML page.

Post both the XML page and the linked XSLT page to your web server.

View the XML page in a browser.

When you do so, the browser transforms the XML data, formats it with the XSLT page, and displays the styled page in the browser.

Create entire XSLT pages and display data

You must use an entire XSLT page for client-side transformations. (XSLT fragments don’t work for this type of transformation.) Follow these general steps for creating, binding XML data to, and formatting XSLT pages for client-side transformations:

Create the XSLT page.

Display data in the XSLT page.

Display repeating elements in the XSLT page.

Link an XSLT page to an XML page

After you have an entire XSLT page with dynamic content placeholders for your XML data, you must insert a reference to the XSLT page in the XML page.

Note:

The XML and XSL files you use for client-side transformations must reside in the same directory. If they don't, the browser will read the XML file and find the XSLT page for the transformation, but will fail to find assets (style sheets, images, and so on) defined by relative links in the XSLT page.

1 Open the XML file that you want to link to your XSLT page.
2 Select Commands > Attach an XSLT Stylesheet.
3 In the dialog box, click the Browse button, browse to the XSLT page you want to link to, select it, and click OK.
4 Click OK to close the dialog box and insert the reference to the XSLT page at the top of the XML document.
Add character entities for XSLT in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

Specify a missing character entity

In XSLT, some characters are not allowed in certain contexts. For example, you cannot use the less than sign (<) and the ampersand (&) in the text between tags or in an attribute value. The XSLT transformation engine will give you an error if those characters are used incorrectly. To solve the problem, you can specify character entities to replace the special characters.

A character entity is a string of characters that represents other characters. Character entities are either named or numbered. A named entity begins with an ampersand (&) followed by the name or characters, and ends with a semicolon (;). For example, &lt; represents the left angle bracket character (<). Numbered entities also start and end the same way, except that a hash sign (#) and a number specify the character.

XSLT has the following five predefined entities:

<table>
<thead>
<tr>
<th>Character</th>
<th>Entity Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt; (less-than)</td>
<td>&lt;</td>
</tr>
<tr>
<td>&amp; (ampersand)</td>
<td>&amp;</td>
</tr>
<tr>
<td>&gt; (greater-than)</td>
<td>&gt;</td>
</tr>
<tr>
<td>&quot; (quote)</td>
<td>&quot;</td>
</tr>
<tr>
<td>’ (apostrophe)</td>
<td>'</td>
</tr>
</tbody>
</table>

If you use other character entities in an XSL file, you need to define them in the DTD section of the XSL file. Dreamweaver provides several default entity definitions that you can see at the top of an XSL file created in Dreamweaver. These default entities cover a broad selection of the most commonly used characters.

When you preview your XSL file in a browser, Dreamweaver checks the XSL file for undefined entities and notifies you if an undefined entity is found.

If you preview an XML file attached to an XSLT file or if you preview a server-side page with an XSLT transformation, the server or browser (instead of Dreamweaver) notifies you of an undefined entity. The following is an example of a message you may get in Internet Explorer when you request an XML file transformed by an XSL file with a missing entity definition:Reference to undefined entity 'auml'. Error processing resource 'http://localhost/testthis/list.xsl'. Line 28, Position 20 <p class="test">&auml;</p> -------------------^  

To correct the error in your page, you must add the entity definition to your page manually.

Reference to undefined entity 'auml'. Error processing resource 'http://localhost/testthis/list.xsl'. Line 28, Position 20 <p class="test">&auml;</p> -------------------^
Specify a missing entity definition

1. Look up the missing character in the character entity reference page on the W3C website at [www.w3.org/TR/REC-html40/sgml/entities.html](http://www.w3.org/TR/REC-html40/sgml/entities.html).

   This web page contains the 252 allowed entities in HTML 4 and XHTML 1.0.

   For example, if the character entity Egrave is missing, search for "Egrave" on the W3C web page. You will find the following entry:

   ```xml
   <!ENTITY Egrave CDATA '&#200;' -- latin capital letter E with grave, U+00C8 ISOlat1 -->
   ```

2. Make a note of the entity name and entity code in the entry.

   In the example, `Egrave` is the entity name, and `&#200;` is the entity code.

3. With this information, switch to Code view and enter the following entity tag at the top of your XSL file (following the Doctype declaration and with the other entity tags):

   ```xml
   <!ENTITY entityname "entitycode;">  
   ```

   In the example, you would enter the following entity tag:

   ```xml
   <!ENTITY Egrave "&#200;">  
   ```

4. Save your file.

   If you repeatedly use the same character entities, you may want to permanently add their definitions in the XSL files Dreamweaver creates by default when you use File > New.

Add entity definitions to the XSL files Dreamweaver creates by default

1. Locate the following configuration file in the Dreamweaver application folder and open it in any text editor:

   Configuration/DocumentTypes/MMDocumentTypeDeclarations.xml

2. Locate the declaration called mm_xslt_1:

   ```xml
   <documenttypedeclaration id="mm_xslt_1">  
   ```

3. Enter the new entity tag or tags in the list of entity tags, as follows:

   ```xml
   <!ENTITY entityname "entitycode;">  
   ```

4. Save the file and restart Dreamweaver.
Chapter 12: Cross-product workflows

Installing and using extensions to Dreamweaver

Add-ons or extensions are new features that you can add easily to Dreamweaver. You can use many types of add-ons; for example, there are add-ons that let you reformat tables, connect to back-end databases, or help you write scripts for browsers.

Note:

To install add-ons that all users have access to in a multiuser operating system, you must be logged in as Administrator (Windows) or root (Mac OS X). For more information on using Dreamweaver on multiuser systems, click here.

The Adobe Add-ons page lists all the add-ons that you can install and use with Dreamweaver. You can also install the add-ons easily from the Add-ons page.

Install add-ons using the Add-ons page

Click Windows > Extensions > Browse Extensions to browse and install add-ons. When you click Browse Extensions, the Adobe Creative Cloud Add-Ons page appears.

On the Adobe Creative Cloud Add-Ons page, click Dreamweaver on the left to view Dreamweaver-specific add-ons. You can also use the search box on the right to search for a specific add-on.
Important: Before installing add-ons, ensure that you have enabled file sync for your Adobe Creative Cloud account. See Enable file sync on Adobe Creative Cloud for more details.

Follow the on-screen instructions to install the add-on.

To view the add-ons that you have installed or shared, click All Your Purchases And Shared Items under My Add-Ons.
Enable file sync on Adobe Creative Cloud

Before installing add-ons from Adobe Creative Cloud, ensure that you enable file sync through your Adobe Creative Cloud client.

1. Click  on your system tray to open the Adobe Creative Cloud client.
2. Click  , and then click Preferences.
In the Files tab, set Sync On/Off to On.
Use acquired add-ons in new versions of Dreamweaver

Most times, an add-on is built to work with a specific version of Dreamweaver, mostly the latest version. The add-on can be used with later versions of Dreamweaver too, if it is built or configured to be used across Dreamweaver versions. When you install a new version of Dreamweaver and the previous version is uninstalled, the add-ons too are uninstalled.

In such cases, the Adobe Creative Cloud desktop app automatically installs the add-ons that you have acquired (from the Add-ons page) while installing the new version of Dreamweaver. After the add-ons are installed, the Creative Cloud desktop displays a notification to indicate that the installation is successful. The only thing that you have to ensure is that the file sync option in the Creative Cloud desktop app is enabled for the automatic installation of add-ons.

**Note:** Only those add-ons that are compatible with the new version of Dreamweaver are installed by the Adobe Creative Cloud app.

Install third-party extensions

Third-party extensions can be installed through ZXP files using the Exman command line tool. If you do not have the ZXP file with you, contact the company selling the extension.

Ensure that the extension is supported on the version of the application on which it is being installed.

Install third-party extensions on Windows

2. Extract the files to a location on your computer. For this this tutorial, the files are extracted to C:\Exmancmd_Win.
3 Download the ZXP file, and copy it to the same location. In this example, the ServerBehaviorDatabase_1_0_0.zxp file is copied to this location.

4 Run the command line tool as an administrator. Right-click the command line application and select Run as Administrator.

   **Note:**
   
   Close the application related to the extension before you proceed with the installation.

5 In the command prompt, navigate to the folder containing your extracted files. In our example, the location is C:\Exmancmd_Win. To navigate to this location, run the command cd C:\Exmancmd_Win.

   **Note:**
   
   When using the command line tool, ensure that you maintain case for the letters that you type.

6 To install the extension, run the command `ExManCmd.exe /install .zxp`

   To troubleshoot errors during installation, see this article.

7 To verify the extension being installed, run the command `ExManCmd.exe /list all`.

8 Open the application related to the extension, and follow instructions in the user guide to locate the extension.

   Ensure that you open the correct version of the application.

### Install third-party extensions on Mac OS

Similar to Windows OS, you can install extensions using the Terminal application on Mac OS. Ensure that you maintain case for every command.

1 Download the ZXP file, and place a copy on the desktop.


3 Extract the contents of the downloaded ZIP file. Copy the Contents folder to the Desktop.

4 Open Finder. Select Application > Utilitiies, and double-click Terminal.

5 Enter `cd ~/Desktop` to navigate to the Desktop.

   **Note:**
   
   Close the application related to the extension before you proceed with the installation.

6 Run the command `. /Contents/Mac OS/ExManCmd --install .zxp` to install the extension.

   To troubleshoot errors during installation, see this article.

   **Note:**
   
   If you run into permission issues, you can run the command using elevated privileges. Prefix `sudo` to the command. For example, in this case, use `sudo . /Contents/Mac OS/ExManCmd --install .zxp`.

7 Enter password at the prompt and press Enter. It is possible that you do not see the cursor moving or the text being entered as you type.

8 Open the application related to the extension, and follow instructions in the user guide to locate the extension.

   Ensure that you open the correct version of the application.
In-App updates in Dreamweaver

Installing In-App updates
Adobe provides updates on an on-going basis to keep Dreamweaver up-to-date with the ever-evolving technology. For example, updates to Bootstrap libraries or starter templates.

You can download and install In-App updates automatically or manually. The Dreamweaver preferences dialog box lets you specify the mode of update, enable, or disable In-App updates.

In-App updates are installed in the following locations:

- Windows: C:\Users\<username>\AppData\Roaming\Adobe\Dreamweaver CC 2015\en_US\Configuration\Updates\n

Automatic update
When you choose automatic update, the download and install of In-App updates are transparent. When an In-App update becomes available, it is downloaded automatically. You will be notified about the status of the installation when you launch Dreamweaver next.

Note:
The image above is only indicative and illustrates an example of an In-App update installation when it becomes available.

The success or failure notifications are auto-dismissed after a few seconds. If you want to verify if the installation is successful, check the Current Version number in the In-App update preferences (Edit > Preferences (Win); Dreamweaver > Preferences (Mac)).

Manual update
When you choose manual update, Dreamweaver notifies you when an In-App update becomes available. You can choose to download and install the update immediately or at a later point in time.

Note:
The image above is only indicative and illustrates an example of an In-App update when it becomes available.

When you click Update, the in-app update is only downloaded. The update is installed and is available for use only after you relaunch Dreamweaver.

The success or failure notifications are auto-dismissed after a few seconds. If you want to verify if the installation is successful, check the Current Version number in the In-App update preferences (Edit > Preferences (Win); Dreamweaver > Preferences (Mac)).

Specify preferences
In Dreamweaver preferences, you can specify how you want to download and install In-App updates: manually or automatically. You can also choose to disable In-App updates.

1 Click Edit > Preferences (Windows), or go to Dreamweaver > Preferences (Mac).
2 Click In-App updates in the Category list.
3 Click an option that suits your requirement:
   • Manual
   • Automatic
   • Turn-off in-app updates

![In-App update preferences]

**Reverting In-App updates**

You cannot selectively revert In-App updates. This means that if four updates have been installed, all the four updates are uninstalled when you revert.

1 Click Edit > Preferences (Windows), or go to Dreamweaver > Preferences (Mac).
2 Click In-App updates in the Category list.
3 Click Revert.
4 Click OK when prompted to confirm, and then click Apply.
5 Restart Dreamweaver.

**List of In-App updates**

• **Bootstrap update - August 2016**
• **Bootstrap update - December 2015**

**Bootstrap update - August 2016**

This update upgrades the Bootstrap version in Dreamweaver to 3.3.7.
Cross-product workflows

Notification for Bootstrap v3.3.7 update (in manual mode)

After this update, you will see that the following files, components, and templates are updated to version 3.3.7:

- The CSS and JavaScript file versions when you create Bootstrap documents
- Bootstrap components that you insert
- Bootstrap starter templates

For more information on what's included in this Bootstrap update, see The Bootstrap blog.

Note: This Bootstrap update is for Dreamweaver 2015 users only (versions 16.1.0, 16.1.2, or 16.1.3).

Bootstrap update - December 2015

This update upgrades the Bootstrap version in Dreamweaver to 3.3.6.

Notification for Bootstrap v3.3.6 update (in manual mode)

After the update, you will see that:

- The CSS/JS file version is 3.3.6 when you create Bootstrap documents
- Bootstrap components that will be inserted are of v 3.3.6

Note: The starter templates are not updated and remain in version 3.3.5.
Insert Microsoft Office documents in Dreamweaver (Windows only)

You can insert the full contents of a Microsoft Word or Excel document in a new or existing web page. When you drag a Word or Excel document into your page, Dreamweaver receives the converted HTML and inserts it into your web page. The file's size, after Dreamweaver receives the converted HTML, must be less than 300K.

Instead of dragging the file, you can also paste portions of a Word document and preserve the formatting.

Note:

The content in this article is applicable only for Dreamweaver 2015 and earlier versions.

If you use Microsoft Office 97, you cannot import the contents of a Word or Excel document; you must insert a link to the document.

1 Open the web page into which you want to insert the Word or Excel document.

2 In Design view, drag the file from its current location to the page where you want the content to appear.

   Note:

   For Dreamweaver 2015.x releases and earlier, you can select File > Import > Word Document, or File > Import > Excel Document.

3 In the Insert Document dialog box, select one of the formatting options:

   Drag a Word or an Excel document into Dreamweaver

   - **Text Only**: Inserts unformatted text. If the original text is formatted, all the formatting is removed.
   - **Text With Structure**: Inserts text that retains structure, but does not retain basic formatting. For example, you can paste text and retain the structure of paragraphs, lists, and tables, without retaining bold, italics, and other formatting.
Cross-product workflows

- **Text With Structure Plus Basic Formatting**: Inserts both structured and simple HTML-formatted text. For example, paragraphs, tables, and text formatted with bold, italic, underlined.
- **Text With Structure Plus Full Formatting**: Inserts text that retains all structure, HTML formatting, and CSS styles.
- **Clean Up Word Paragraph Spacing**: Eliminates extra space between paragraphs when you paste your text if you selected Text With Structure or Basic Formatting.

The contents of the Word or Excel document appear in your page.

## Working with Fireworks and Dreamweaver

This feature is not supported in Adobe Dreamweaver versions.

### Insert a Fireworks image

Dreamweaver and Fireworks recognize and share many of the same file-editing procedures, including changes to links, image maps, table slices, and more. Together, the two applications provide a streamlined workflow for editing, optimizing, and placing web graphics files in HTML pages.

You can place a Fireworks exported graphic directly in a Dreamweaver document using the Insert Image command, or you can create a new Fireworks graphic from a Dreamweaver image placeholder.

1. In the Dreamweaver document, place the insertion point where you want the image to appear, then do one of the following:
   - Select **Insert > Image**.
   - In the Common category of the Insert panel, click the Image button or drag it to the document.

2. Navigate to the desired Fireworks exported file, and click **OK** (Windows) or **Open** (Macintosh).

   **Note:**
   
   If the Fireworks file is not in the current Dreamweaver site, a message appears asking whether you want to copy the file to the root folder. Click **Yes**.

### Edit a Fireworks image or table from Dreamweaver

When you open and edit an image or an image slice that is part of a Fireworks table, Dreamweaver starts Fireworks, which opens the PNG file from which the image or table was exported.

**Note:**

This assumes that Fireworks is set as the primary external image editor for PNG files. Fireworks is often also set as the default editor for JPEG and GIF files, although you may wish to set Photoshop as the default editor for these file types.

When the image is part of a Fireworks table, you can open the entire Fireworks table for edits, as long as the `<!-fw table->` comment exists in the HTML code. If the source PNG file was exported from Fireworks to a Dreamweaver site using the Dreamweaver Style HTML And Images setting, the Fireworks table comment is automatically inserted in the HTML code.

1. In Dreamweaver, open the Property inspector (**Window > Properties**) if it isn’t already open.

2. Click the image or image slice to select it.
When you select an image that was exported from Fireworks, the Property inspector identifies the selection as a Fireworks image or table and displays the name of the PNG source file.

3 To start Fireworks for editing, do one of the following:
   • In the Property inspector, click Edit.
   • Hold down Control (Windows) or Command (Macintosh) and double-click the selected image.
   • Right-click (Windows) or Control-click (Macintosh) the selected image and select Edit With Fireworks from the context menu.

   Note:
   If Fireworks cannot locate the source file, you are prompted to locate the PNG source file. When you work with the Fireworks source file, changes are saved to both the source file and the exported file; otherwise, only the exported file is updated.

4 In Fireworks, edit the source PNG file and click Done.

   Fireworks saves the changes in the PNG file, exports the updated image (or HTML and images), and returns focus to Dreamweaver. In Dreamweaver, the updated image or table appears.

   For a tutorial about Dreamweaver and Fireworks integration, see www.adobe.com/go/vid0188.

Optimize a Fireworks image from Dreamweaver

You can use Dreamweaver to make quick changes to Fireworks images and animations. From within Dreamweaver, you can change optimization settings, animation settings, and the size and area of the exported image.

1 In Dreamweaver, select the desired image and do one of the following:
   • Select Command > Optimize Image
   • Click the Edit Image Settings button in the Property inspector.

2 Make your edits in the Image Preview dialog box:
   • To edit optimization settings, click the Options tab.
   • To edit the size and area of the exported image, click the File tab.

3 When you finish, click OK.

Use Fireworks to modify Dreamweaver image placeholders

You can create a placeholder image in a Dreamweaver document and then start Fireworks to design a graphic image or Fireworks table to replace it.

To create a new image from an image placeholder, you must have both Dreamweaver and Fireworks installed on your system.

1 Make sure you’ve already set Fireworks as the image editor for PNG files.

2 In the Document window, click the image placeholder to select it.

3 Start Fireworks in Editing From Dreamweaver mode by doing one of the following:
   • In the Property inspector, click Create.
   • Press Control (Windows) or Command (Macintosh) then double-click the image placeholder.
   • Right-click (Windows) or Control-click (Macintosh) the image placeholder, then select Create Image In Fireworks.
4. Use Fireworks options to design the image.

Fireworks recognizes the following image placeholder settings you may have set while working with the image placeholder in Dreamweaver: image size (which correlates to Fireworks canvas size), image ID (which Fireworks uses as the default document name for the source file and export file you create), and text alignment. Fireworks also recognizes links and certain behaviors (such as swap image, pop-up menu, and set text) you attached to the image placeholder while working in Dreamweaver.

Note:

Although Fireworks doesn't show links you've added to an image placeholder, they are preserved. If you draw a hotspot and add a link in Fireworks, it will not delete the link you added to the image placeholder in Dreamweaver; however, if you cut out a slice in Fireworks in the new image, Fireworks will delete the link in the Dreamweaver document when you replace the image placeholder.

Fireworks doesn't recognize the following image placeholder settings: image alignment, color, Vspace and Hspace, and maps. They are disabled in the image placeholder Property inspector.

5. When you finish, click Done to display the save prompt.

6. In the Save In text box, select the folder you defined as your Dreamweaver local site folder.

   If you named the image placeholder when you inserted it in the Dreamweaver document, Fireworks populates the File Name box with that name. You can change the name.

7. Click Save to save the PNG file.

   The Export dialog box appears. Use this dialog box to export the image as a GIF or JPEG file, or, in the case of sliced images, as HTML and images.

8. For Save In, select the Dreamweaver local site folder.

   The Name box automatically displays the name you used for the PNG file. You can change the name.

9. For Save As Type, select the type of file or files you want to export; for example, Images Only or HTML And Images.

10. Click Save to save the exported file.

    The file is saved, and focus returns to Dreamweaver. In the Dreamweaver document, the exported file or Fireworks table replaces the image placeholder.

**About Fireworks pop-up menus**

Fireworks lets you quickly and easily create CSS-based pop-up menus.

In addition to being extensible and fast to download, the pop-up menus you create with Fireworks give you the following advantages:

- The menu items can be indexed by search engines.
- The menu items can be read by screen readers, making your pages more accessible.
- The code generated by Fireworks complies to standards and can be validated.

You can edit Fireworks pop-up menus with Dreamweaver or with Fireworks, but not both. Changes made in Dreamweaver are not preserved in Fireworks.
Edit Fireworks pop-up menus in Dreamweaver

You can create a pop-up menu in Fireworks 8 or later and then edit it with Dreamweaver or with Fireworks (using roundtrip editing), but not with both. If you edit your menus in Dreamweaver and then edit them in Fireworks, you will lose all your previous edits except for the text content.

If you prefer to edit your menus with Dreamweaver, you can use Fireworks to create the pop-up menu and then use Dreamweaver exclusively to edit and customize the menu.

If you prefer to edit the menus in Fireworks, you can use the roundtrip editing feature in Dreamweaver, but you should not edit the menus directly in Dreamweaver.

1 In Dreamweaver, select the Fireworks table that contains the pop-up menu, and then click Edit in the Property inspector.

   The source PNG file opens in Fireworks.

2 In Fireworks, edit the menu with the Pop-up Menu Editor, and then click Done on the Fireworks toolbar.

   Fireworks sends the edited pop-up menu back to Dreamweaver.

   If you created a pop-up menu in Fireworks MX 2004 or earlier, you can edit it in Dreamweaver using the Show Pop-Up Menu dialog box, available from the Behaviors panel.

Edit a pop-up menu created in Fireworks MX 2004 or earlier

1 In Dreamweaver, select the hotspot or image that triggers the pop-up menu.

2 In the Behaviors panel (Shift+F3), double-click Show Pop-Up Menu in the Actions list.

3 Make your changes in the Pop-Up Menu dialog box and click OK.

Specify launch-and-edit preferences for Fireworks source files

When you use Fireworks to edit images, the images in your web pages are normally exported by Fireworks from a source PNG file. When you open an image file in Dreamweaver to edit it, Fireworks automatically opens the source PNG file, prompting you to locate the PNG file if it cannot be found. If you prefer, you can set preferences in Fireworks to have Dreamweaver open the inserted image, or you can have Fireworks give you the option of using the inserted image file or the Fireworks source file every time you open an image in Dreamweaver.

Note:

Dreamweaver recognizes the Fireworks launch-and-edit preferences only in certain cases. Specifically, you must be opening and optimizing an image that is not part of a Fireworks table and contains a correct Design Notes path to a source PNG file.

1 In Fireworks, select Edit > Preferences (Windows) or Fireworks > Preferences (Macintosh) and then click the Launch And Edit tab (Windows) or select Launch And Edit from the pop-up menu (Macintosh).

2 Specify the preference options to use when editing or optimizing Fireworks images placed in an external application:

   Always Use Source PNG  Automatically opens the Fireworks PNG file that is defined in the Design Note as the source of the placed image. Updates are made to the source PNG file and its corresponding placed image.

   Never Use Source PNG  Automatically opens the placed Fireworks image, whether or not a source PNG file exists. Updates are made to the placed image only.

   Ask When Launching  Displays a message asking whether to open the source PNG file. You can also specify global launch-and-edit preferences from this message.
Insert Fireworks HTML code in a Dreamweaver document

From Fireworks, you can use the Export command to export and save optimized images and HTML files to a location inside a Dreamweaver site folder. You can then insert the file in Dreamweaver. Dreamweaver lets you insert Fireworks-generated HTML code, complete with associated images, slices, and JavaScript, into a document.

1. In Dreamweaver document, place the insertion point where you want to insert the Fireworks HTML code.

2. Do one of the following:
   • Select Insert > Image Objects > Fireworks HTML.
   • In the Common category of the Insert panel, click the Images button and choose Insert Fireworks HTML from the popup menu.

3. Click Browse to select a Fireworks HTML file.

4. If you will have no further use for the file, select Delete File After Insertion. Selecting this option has no effect on the source PNG file associated with the HTML file.

   Note:
   If the HTML file is on a network drive, it is permanently deleted—not moved to the Recycle Bin or Trash.

5. Click OK to insert the HTML code, along with its associated images, slices, and JavaScript, into the Dreamweaver document.

Paste Fireworks HTML code into Dreamweaver

A fast way to place Fireworks-generated images and tables in Dreamweaver is to copy and paste Fireworks HTML code directly into a Dreamweaver document.

Copy and paste Fireworks HTML code into Dreamweaver

1. In Fireworks, select Edit > Copy HTML Code.

2. Follow the wizard as it guides you through the settings for exporting your HTML and images. When prompted, specify your Dreamweaver site folder as the destination for the exported images.

   The wizard exports the images to the specified destination and copies the HTML code to the Clipboard.

3. In Dreamweaver document, place the insertion point where you want to paste the HTML code, and select Edit > Paste Fireworks HTML.

   All HTML and JavaScript code associated with the Fireworks files you exported is copied into the Dreamweaver document, and all links to images are updated.

Export and paste Fireworks HTML code into Dreamweaver

1. In Fireworks, select File > Export.

2. Specify your Dreamweaver site folder as the destination for the exported images.

3. In the Export pop-up menu, select HTML And Images.

4. In the HTML pop-up menu, select Copy To Clipboard, and then click Export.

5. In the Dreamweaver document, place the insertion point where you want to paste the exported HTML code, and select Edit > Paste Fireworks HTML.

   All HTML and JavaScript code associated with the Fireworks files you exported is copied into the Dreamweaver document, and all links to images are updated.
Update Fireworks HTML code placed in Dreamweaver

In Fireworks, the File > Update HTML command provides an alternative to the launch-and-edit technique for updating Fireworks files placed in Dreamweaver. With Update HTML, you can edit a source PNG image in Fireworks and then automatically update any exported HTML code and image files placed in a Dreamweaver document. This command lets you update Dreamweaver files even when Dreamweaver is not running.

1. In Fireworks, open the source PNG file and make your edits.
2. Select File > Save.
3. In Fireworks, select File > Update HTML.
4. Navigate to the Dreamweaver file containing the HTML you want to update, and click Open.
5. Navigate to the folder destination where you want to place the updated image files, and click Select (Windows) or Choose (Macintosh).

Fireworks updates the HTML and JavaScript code in the Dreamweaver document. Fireworks also exports updated images associated with the HTML and places the images in the specified destination folder.

If Fireworks cannot find matching HTML code to update, it gives you the option of inserting new HTML code into the Dreamweaver document. Fireworks places the JavaScript section of the new code at the beginning of the document and places the HTML table or link to the image at the end.

Create a web photo album

The Create Web Photo Album feature has been deprecated as of Dreamweaver CS5.

Edit content in Dreamweaver sites using Contribute

Manage Contribute sites

Adobe® Contribute® CS4 combines a web browser with a web-page editor. It enables your colleagues or clients to browse to a page in a site that you created, and to edit or update the page if they have permission to do so. Contribute users can add and update basic web content, including formatted text, images, tables, and links. Contribute site administrators can limit what ordinary (non-administrator) users can do in a site.

Note:
This topic assumes that you are a Contribute administrator.

As the site administrator, you give non-administrators the ability to edit pages by creating a connection key and sending it to them (for information on how to do this, see Contribute Help. You can also set up a connection to a Contribute site using Dreamweaver, which lets you or your site designer connect to the Contribute site and use all of the editing capabilities available in Dreamweaver.

Contribute adds functionality to your website with Contribute Publishing Server (CPS), a suite of publishing applications and user management tools that lets you integrate Contribute with your organization's user directory service—for example, Lightweight Directory Access Protocol (LDAP) or Active Directory. When you enable your Dreamweaver site as a Contribute site, Dreamweaver reads Contribute's administration settings whenever you connect to the remote site. If Dreamweaver detects that CPS is enabled, it inherits some of the functionality of CPS, such as file rollback and event logging.
You can use Dreamweaver to connect to and modify a file in a Contribute site. Most Dreamweaver capabilities work the same way with a Contribute site as they do with any other site. However, when you use Dreamweaver with a Contribute site, Dreamweaver automatically performs certain file-management operations, such as saving multiple revisions of a document, and logging certain events in the CPS Console.

For more information, see Contribute Help.

Site structure and page design for a Contribute site

To enable Contribute users to edit your website, keep the following points in mind when you structure it:

- Keep your site structure simple. Don't nest folders too deeply. Group related items together in a folder.
- Set up appropriate read and write permissions for folders on the server.
- Add index pages to folders as you create them, to encourage Contribute users to place new pages in the correct folders. For example, if Contribute users provide pages containing meeting minutes, create a folder in the site root folder named meeting_minutes, and create an index page in that folder. Then provide a link from your site's main page to the index page for meeting minutes. A Contribute user can then navigate to that index page and create a new page of minutes for a specific meeting, linked from that page.
- On each folder's index page, provide a list of links to the individual content pages and documents in that folder.
- Keep page designs as simple as possible, minimizing fancy formatting.
- Use CSS rather than HTML tags and name your CSS styles clearly. If the Contribute users use a standard set of styles in Microsoft Word, use the same names for the CSS styles, so that Contribute can map the styles when a user copies information from a Word document and pastes it into a Contribute page.
- To prevent a CSS style from being available to Contribute users, change the name of the style so that the name starts with mmhide_. For example, if you use a style named RightJustified in a page but you don't want Contribute users to be able to use that style, rename the style to mmhide_RightJustified.

Note:

You have to add mmhide_ to the style name in Code view; you cannot add it in the CSS panel.

- Use as few CSS styles as possible, to keep things simple and clean.
- If you use server-side includes for HTML page elements, such as headers or footers, create an unlinked HTML page that contains links to the include files. Contribute users can then bookmark that page and use it to navigate to the include files and edit them.

File transfer to and from a Contribute site

Contribute uses a system much like the Dreamweaver Check In/Check Out system to ensure that only one user at a time can edit a given web page. When you enable Contribute compatibility in Dreamweaver, the Dreamweaver Check In/Check Out system is automatically enabled.

To transfer files to and from a Contribute site using Dreamweaver, always use the Check In and Check Out commands. If you instead use the PUT and GET commands to transfer files, you might overwrite the modifications that a Contribute user has recently made to a file.

When you check a file in to a Contribute site, Dreamweaver makes a backup copy of the previous checked-in version of the file in the _baks folder and adds your user name and a date stamp to a Design Notes file.
Contribute file and folder permissions on the server

Contribute provides a way to manage file and folder permissions for each user role you define; however, Contribute doesn't provide a way to manage the underlying read and write permissions assigned to files and folders by the server. In Dreamweaver, you can manage those permissions directly on the server.

If a Contribute user doesn't have read access on the server to a dependent file, such as an image displayed in a page, the contents of the dependent file don't appear in the Contribute window. For example, if a user doesn't have read access to an images folder, the images in that folder appear as broken image icons in Contribute. Similarly, Dreamweaver templates are stored in a subfolder of the site's root folder, so if a Contribute user doesn't have read access to the root folder, they can't use templates in that site unless you copy the templates to an appropriate folder.

When you set up a Dreamweaver site, you must give users read access on the server to the /_mm folder (the _mm subfolder of the root folder), the /Templates folder, and all of the folders containing assets that they will need to use.

If, for security reasons, you can't give users read access to the /Templates folder, you can still enable Contribute users to access templates. See Enable Contribute users to access templates without root folder access.

For more information about Contribute permissions, see Administering Contribute in Contribute Help.

Contribute special files

Contribute uses a variety of special files that aren't intended to be viewed by visitors to your site:

- The shared settings file, which has an obfuscated filename with a CSI extension, appears in a folder named _mm in the root folder of the site, and contains information that Contribute uses to manage the site
- Older versions of files, in folders named _baks
- Temporary versions of pages, so that users can preview changes
- Temporary lock files, indicating that a given page is being edited or previewed
- Design Notes files containing metadata about the site's pages

In general, you shouldn't edit any of these Contribute special files using Dreamweaver; Dreamweaver manages them automatically.

If you don't want these Contribute special files to appear on your publicly accessible server, you can set up a staging server where Contribute users work on pages. Then periodically copy those web pages from the staging server to a production server that's on the web. If you take this staging-server approach, copy only web pages to the production server, not any of the above-listed Contribute special files. In particular, don't copy the _mm and _baks folders to the production server.

Note:

For information about setting up a server to prevent visitors from seeing files in folders that begin with an underscore, see “Website security” in Contribute Help.

Occasionally you might need to manually delete Contribute special files. For example, there might be circumstances in which Contribute fails to delete temporary preview pages when the user is finished previewing; in that case, you would have to manually delete those temporary pages. Temporary preview pages have filenames that begin with TMP.

Similarly, under some circumstances an outdated lock file may be accidentally left on the server. If that happens, you must manually delete the lock file to allow others to edit the page.
Prepare a site for use with Contribute

If you’re preparing an existing Dreamweaver site for Contribute users, you need to explicitly enable Contribute compatibility to use Contribute-related features; Dreamweaver does not prompt you to do this; however, when you connect to a site that’s been set up as a Contribute site (that has an administrator), Dreamweaver prompts you to enable Contribute compatibility.

Not all connection types support Contribute compatibility. The following restrictions apply to connection types:

• If your remote site connection uses WebDAV, you can't enable Contribute compatibility, because those source-control systems aren’t compatible with the Design Notes and Check In/Check Out systems that Dreamweaver uses for Contribute sites.

• If you use RDS to connect to your remote site, you can enable Contribute compatibility, but you must customize your connection before you can share it with Contribute users.

• If you’re using your local computer as a web server, you must set up the site using an FTP or network connection to your computer (rather than just a local folder path) to be able to share your connection with Contribute users.

When you enable Contribute compatibility, Dreamweaver automatically enables Design Notes (including the Upload Design Notes For Sharing option) and the Check In/Check Out system.

If Contribute Publishing Server (CPS) is enabled on the remote site you are connecting to, Dreamweaver notifies the CPS every time you trigger a network operation such as checking in, rolling back, or publishing a file. The CPS will log these events, and you can view the log in the CPS Administration Console. (If you disable CPS, these events are not logged.) You enable CPS using Contribute. For more information, see Adobe Contribute Help.

Note:

You can make a site Contribute compatible without having Contribute on your computer; but if you want to be able to start Contribute Administrator from Dreamweaver, you must have Contribute installed on the same computer as Dreamweaver and you must be connected to the remote site before you enable Contribute compatibility. Otherwise, Dreamweaver cannot read Contribute’s administrative settings to determine whether CPS and Rollback are enabled.

Note:

You must make sure that the shared settings file (CSI file) that Contribute uses to administer the site is on the remote server and uncorrupted. Contribute automatically creates this file (and overwrites old versions of it) whenever you administer in Contribute Administrator. If the shared settings file is not on the server or is corrupted, Dreamweaver returns the error, “The file required for Contribute compatibility does not exist on the server” whenever you attempt a network operation (such as put). To ensure that the correct file is on the server, disable the connection to the server in Dreamweaver, start Contribute Administrator, make an administration change, and then reconnect to the server in Dreamweaver. For more information, see Adobe Contribute Help.

1 Select Site > Manage Sites.

2 Select a site, then click Edit.

3 In the Site Setup dialog box, expand Advanced Settings, select the Contribute category, and then select Enable Contribute Compatibility.

4 If a dialog box appears saying that you must enable Design Notes and Check In/Check Out, click OK.

5 If you haven’t already provided your Check In/Check Out contact information, type your name and e-mail address in the dialog box, and then click OK. Rollback status, CPS status, the Site Root URL text box, and the Administer Site in Contribute button appear in the Site Definition dialog box.

If Rollback is enabled in Contribute, you’ll have the ability to roll back to previous versions of files that you’ve changed in Dreamweaver.
Check the URL in the Site Root URL text box and correct it if necessary. Dreamweaver constructs a site root URL based on other site-definition information you’ve provided, but sometimes the constructed URL isn’t quite right.

Click the Test button to verify that you’ve entered the correct URL.

Note:
If you are ready to send a connection key or perform Contribute site administration tasks now, skip the remaining steps.

Click Administer Site in Contribute if you want to make administration changes. Remember, you must have Contribute installed on the same machine if you want to open Contribute Administrator from Dreamweaver.

Click Save and then click Done.

**Administer a Contribute site using Dreamweaver**

After you enable Contribute compatibility, you can use Dreamweaver to start Contribute to perform site administration tasks.

Note:
Contribute must be installed on the same computer as Dreamweaver.

As an administrator of a Contribute site, you can:

- Change the administrative settings for the site.
  
  Contribute administrative settings are a collection of settings that apply to all users of your website. These settings enable you to fine-tune Contribute to provide a better user experience.

- Change the permissions granted to user roles in Contribute.

- Set up Contribute users.
  
  Contribute users need certain information about the site to be able to connect to it. You can package all of this information in a file called a connection key to send to Contribute users.

Note:
A connection key is not the same as a Dreamweaver exported site file.

Before you give Contribute users the connection information they need to edit pages, use Dreamweaver to create the basic folder hierarchy for your site, and to create any templates and CSS style sheets needed for the site.

1 Select Site > Manage Sites.

2 Select a site, and then click Edit.

3 In the Site Setup dialog box, expand Advanced Settings and select the Contribute category.

4 Click the Administer Site in Contribute button.

Note:
This button does not appear if you have not enabled Contribute compatibility.

5 If prompted, enter the administrator password, and then click OK.

The Administer Website dialog box appears.

- To change administrative settings, select a category from the list on the left, and then change settings as necessary.
To change role settings, in the Users and Roles category, click Edit Role Settings, and then make changes as necessary.

To send a connection key to set up users, in the Users and Roles category, click Send Connection Key, and then complete the Connection Wizard.

6 Click Close, click OK, and then click Done.

For more information about administrative settings, managing user roles, or creating a connection key, see Contribute Help.

**Delete, move, or rename a remote file in a Contribute site**

Deleting a file from the remote server that hosts a Contribute site works much like deleting a file from the server for any Dreamweaver site. However, when you delete a file from a Contribute site, Dreamweaver asks whether to delete all older versions of the file. If you choose to keep the older versions, Dreamweaver saves a copy of the current version in the _baks folder so you can restore it later.

Renaming a remote file or moving it from one folder to another in a Contribute site works the same way it works in any Dreamweaver site. In a Contribute site, Dreamweaver also renames or moves the associated previous versions of the file that are saved in the _baks folder.

1 Select the file in the Remote pane of the Files panel (Window > Files), and then press Backspace (Windows) or Delete (Macintosh).

   A dialog box appears asking you to confirm that you want to delete the file.

2 In the confirmation dialog box:
   - To delete all previous versions of the file as well as the current version, select the Delete Rollback Versions option.
   - To leave previous versions on the server, deselect the Delete Rollback Versions option.

3 Click Yes to delete the file.

**Enable Contribute users to access templates without root folder access**

In a Contribute site, you manage underlying file and folder permissions directly on the server. If, for security reasons, you can't give users read access to the /Templates folder, you can still make the templates available to users.

1 Set up the Contribute site so that its root folder is the folder you want users to see as the root.

2 Manually copy the template folder from the main site's root folder into the Contribute site's root folder, using the Files panel.

3 After you update templates for the main site, recopy the changed templates into appropriate subfolders as needed.

   If you take this approach, don't use site root-relative links in the subfolders. Site root-relative links are relative to the main root folder on the server, not to the root folder you define in Dreamweaver. Contribute users can't create site root-relative links.

   If links in a Contribute page appear to be broken, it's possible that there's a problem with folder permissions, particularly if the links link to pages outside of the Contribute user's root folder. Check read and write permissions for folders on the server.

**Troubleshoot a Contribute site**

If a remote file in a Contribute site appears to be checked out, but the file isn't actually locked on the user's computer, you can unlock the file to enable users to edit it.
When you click any button related to Contribute site administration, Dreamweaver verifies that it can connect to your remote site and that the Site Root URL you’ve given for the site is valid. If Dreamweaver can’t connect, or if the URL isn’t valid, an error message appears.

If the administration tools aren’t working properly, there might be something wrong with the _mm folder.

**Unlock a file in a Contribute site**

*Note:*

*Before following this procedure, make sure that the file really isn’t checked out. If you unlock a file while a Contribute user is editing it, multiple users might edit the file simultaneously.*

1. Do one of the following:
   - Open the file in the Document window, and then select Site > Undo Check Out.
   - In the Files panel (Window > Files), right-click (Windows) or Control-click (Macintosh), and then select Undo Check Out.
     A dialog box might appear, indicating who has the file checked out and asking you to confirm that you want to unlock the file.

2. If the dialog box appears, click Yes to confirm.

   The file is unlocked on the server.

**Troubleshoot connection problems for a Contribute site**

1. Check the Site Root URL in the Contribute category of the Site Definition dialog box by opening that URL in a browser, to make sure that the correct page opens.

2. Use the Test button in the Remote Info category of the Site Definition dialog box to make sure that you can connect to the site.

3. If the URL is correct but the Test button results in an error message, ask your system administrator for help.

**Troubleshoot Contribute administration tools**

1. On the server, make sure that you have read and write permissions, and executable permissions if necessary, for the _mm folder.

2. Make sure that the _mm folder contains a shared settings file with a CSI extension.

3. If it doesn’t, use the Connection Wizard (Windows) or Connection Assistant (Macintosh) to create a connection to the site and to become an administrator for the site. The shared settings file is created automatically when you become an administrator. For more information about becoming an administrator for an existing Contribute website, see *Administering Contribute* in Contribute Help.

**Dreamweaver-Business Catalyst integration**

This feature is not supported in Adobe Dreamweaver versions.

*Note:َ Business Catalyst extension for Dreamweaver is unavailable in Dreamweaver 2015 release and later. For information on using Business Catalyst with Dreamweaver, see the [Business Catalyst documentation](#).*

Business Catalyst is a hosted application for building and managing online businesses. Using this unified platform and without back-end coding, you can build everything from websites to powerful online stores.
Dreamweaver's integration with Business Catalyst allows you to create and update a Business Catalyst site in Dreamweaver. After you create a Business Catalyst site, you can connect to the Business Catalyst server. The server provides you with files and templates that you can use to build your site.

**Install the Business Catalyst add-on**

To install the add-on, go to Window > Browse Add-Ons. The Adobe Creative Cloud Add-Ons page appears. Search for the Business Catalyst add-on and follow the on-screen instructions to install the add-on.

**Important:** Before installing add-ons, ensure that you have enabled file sync for your Adobe Creative Cloud account. See [Enable file sync on Adobe Creative Cloud](#) for more details.

**Create a temporary Business Catalyst site**

1. Select Site > Manage Sites.
2. Click New Business Catalyst Site.
4. Enter your date of birth and click Update.
5. In the Create Temporary Site dialog, enter the details for your site, and click Create Free Temporary Site.
   
   **Note:**
   
   Emails related to your Business Catalyst account details are sent to you after you create your site. These emails contain information of your site such as getting started information, the URL of the site that you created and that of the administration site.

6. Choose a folder on your computer for the local site.
   
   **Note:**
   
   If you click Cancel, the site is created in Business Catalyst but is not displayed in Dreamweaver. The same scenario occurs if there is a network problem while creating a Business Catalyst site.

7. Enter the password associated with your Adobe ID.
8. When the file activity is complete, click Done.
9. Select Window > File. The local view of the site that you created is displayed.
10. Select Remote Server from the menu.
11. Enter the Adobe ID associated with your password.
    The file structure on the remote server is displayed.

**Import a Business Catalyst site**

For information on migrating sites that you previously created using the Business Catalyst extension, see [Migrating Business Catalyst sites to Dreamweaver CS6](#).

1. Select Site > Manage Sites.
2. Click Import Business Catalyst Site. The list of Business Catalyst sites you created with the Adobe ID is displayed.
3. Select the site, and click Import Site.
4. For the site that you are trying to import, specify a location on your computer.
5. Enter the password related to your Adobe ID.
Cross-product workflows

6 When the file activity is complete, click **Done**.

**Manage files**
Because Business Catalyst is also a web hosting service, you can use Dreamweaver to manage local and remote site files. For more information, see the following topics:

- Manage files and folders
- Getting and putting files to and from your server
- Check in and check out files

**Insert modules, data, or snippets**
1 Select **Window > Business Catalyst** to open the Business Catalyst panel.
2 Do one of the following:
   - To insert a Business Catalyst module, select the **Modules** tab.
   - To insert tags, select the **Data** tab. Tags are displayed if you are editing files that support tags such as the affiliate.html page in the Layouts/Affiliate/ folder.
3 Expand the module and click the module that you want to add to the file.
4 Provide the required information, and click **Insert**.
5 If your current site uses the new rendering engine, the Snippets tab is displayed. Using the options in the Snippet tab, you can add code snippets, such as repeating and conditional regions, comment sections, and include (works similar to server-side include).
6 Click **Live** to preview the page as it would appear in a web browser.

**Edit properties of Business Catalyst objects**
Similar to editing other objects on a web page, you can use the **Property inspector** to edit properties of objects in Business Catalyst modules.

If you don’t see the options to edit properties, check whether you have permissions to edit the file. Also, for some modules, you can edit the page only on the online Admin website.

**Create personalized email campaigns**
Adobe Campaign is generally used for automated email marketing. When you use Dreamweaver with Campaign, you can combine the email design capabilities of Dreamweaver with the cross-channel marketing capabilities of Adobe Campaign in the Adobe Marketing Cloud.

Designers can continue to work designing within Dreamweaver, but personalized data from Adobe Campaign can be pulled into the Dreamweaver user-interface for more contextual designs.

And because this integration is two-way, Adobe Campaign users can also access Dreamweaver’s editing capabilities from within the Campaign interface.
In summary:

- Use Adobe Dreamweaver with Adobe Campaign to create and design emails in Dreamweaver that automatically sync to Adobe Campaign.
- You can also choose to work within Adobe Campaign accessing Dreamweaver’s editing capabilities from within the Campaign interface.

**Campaign extension for Dreamweaver**

The Adobe Campaign extension in Dreamweaver allows you to personalize email content in Dreamweaver by adding personalization fields and content blocks to your content.

In a few quick steps, you can be up and running and creating personalized content:

1. Install the Campaign extension.
2. Understand your way around the Campaign extension panel.
3. Add personalization fields and content blocks in your template from the Campaign extension panel (**Window > Campaign**).
4. Content is automatically synchronized between Dreamweaver and Campaign.
5. Send the email to the recipients from Adobe Campaign.

**Install the Campaign extension**

1. Click **Windows > Extensions > Browse Extensions**.
   The Adobe Creative Cloud Add-Ons page appears.
2. On the Adobe Creative Cloud Add-Ons page, click Dreamweaver on the left to view Dreamweaver-specific add-ons, or search for the **Adobe Campaign integration** add-on.
3. Follow the on-screen instructions to download the add-on.

*Note:*

_If you face issues downloading and installing the extension using the above procedure, try Installing the extension using the instructions here: Install third-party extensions.**Install third-party extensions**_

**The Adobe Campaign panel in Dreamweaver**

There are multiple ways you can work with Dreamweaver and Adobe Campaign.

- You can use Adobe Campaign content and edit it in Dreamweaver.
- You can create content in Dreamweaver, and then send it to email recipients from Adobe Campaign.

In either scenario, you can use the Adobe Campaign panel to edit your templates within Dreamweaver. In addition, your content changes are automatically synchronized between Campaign and Dreamweaver.

Read on to know more about how to work with the Adobe Campaign panel in Dreamweaver.

After installing the Campaign extension, you can see the Adobe Campaign panel by selecting **Window > Campaign**.
Opening an Adobe Campaign template in Dreamweaver

The Adobe Campaign panel contains the following options:

- **Select a file:** Use this option if you want to open a template created in Dreamweaver.
- **Use Current tab:** Use this option if you have a template currently open in Dreamweaver.
- **Use ACS content:** Use this option if you want to open an email template from Adobe Campaign and edit it in Dreamweaver.

After you open a template in Dreamweaver, the Adobe Campaign panel is populated with the personalization fields and content blocks.
The blocks in the Adobe Campaign extension panel

The Adobe Campaign panel consists of the following blocks:

- **Personalization field**: Use the personalization fields to personalize the content of sent messages (such as the first name personalization field). The fields that you insert into the email content mark the place where the information from the Adobe Campaign database is to be inserted. For more information on personalization fields, see Adding a personalization field in the Adobe Campaign documentation.

- **Content block**: Use the fields in the Content block to add content that is personalized, and have a specific rendering (such as an unsubscribe link at the bottom of the email). For more information on content blocks, see Adding a content block in the Adobe Campaign documentation.

The label and ID in the Adobe Campaign extension panel in Dreamweaver reflect the label and ID of the template in Adobe Campaign.

**Note:**

*The blocks available in the Content block vary depending on the context (email or landing page).*
Working with Adobe Campaign and Dreamweaver

There are multiple ways you can work with Dreamweaver and Adobe Campaign.

- You can use Adobe Campaign content and edit it in Dreamweaver. For more information, see Edit Adobe Campaign content in Dreamweaver.
- You can create content in Dreamweaver. Add personalization fields, and content blocks using the Adobe Campaign panel. Your content is automatically synchronized with Adobe Campaign. For more information, see Create content in Dreamweaver and upload to Adobe Campaign

Edit Adobe Campaign content in Dreamweaver

1. In Adobe Campaign, create a new email template, or select and open an existing template that you want to edit.
2. To open the template in Dreamweaver, click Dreamweaver, and confirm that you want to open Dreamweaver.

The template opens up in Dreamweaver.

3. In Dreamweaver, select Window > Campaign to open the Adobe Campaign extension panel.
   Then click Use ACS content to open the Campaign template in Dreamweaver.
4. Add the personalization fields, and content blocks that you want to use.
   When you add a personalization field or a content block, they appear as yellow boxes in Design or Live View.
Add images and other media content like you would normally do in Dreamweaver.

After you are done with all your changes in Dreamweaver, go to Adobe Campaign, and you can see all the changes you made in Dreamweaver reflected in the campaign there.

In Adobe Campaign, you can continue to make further changes, and all these changes are synchronized with the campaign in Dreamweaver.

After you are done with your changes, click Confirm and then Save in Adobe Campaign. All your changes are saved, and the synchronization connection with Dreamweaver is broken.

You can then send the finished email campaign to your recipients from Adobe Campaign.

Create content in Dreamweaver and upload to Adobe Campaign

You can create email templates in Dreamweaver, use the Campaign extensions panel to add personalization, and content blocks, and then synchronize it with Adobe Campaign.

To start creating an email campaign in Dreamweaver, you can use one of the starter templates. Choose File > New > Starter Templates > Email Templates. Or you can create one from scratch.
Dreamweaver’s starter email templates

2 Edit the template to adapt it to your needs.

3 After you have made all your changes, close and exit Dreamweaver.

4 Open Adobe Campaign. Open any existing email template in Campaign and then click Dreamweaver.

5 In Dreamweaver, open the template you created. Select Window > Campaign to display the Adobe Campaign extension panel.

   Note:

   If you do not have a template open in Dreamweaver, click Select a File, and then browse to the saved template to open it.

6 In the Campaign panel, click Use Current tab.
The Adobe Campaign extension panel before the campaign is opened

The Adobe Campaign personalization fields and content blocks appear in the Adobe Campaign extension panel.
The blocks in the Adobe Campaign extension panel

7 Add the personalization fields, and content blocks that you want to use.

When you add a personalization field or a content block, they appear as yellow boxes in Design or Live View.
Cross-product workflows

After you are done with all your changes in Dreamweaver, go to Adobe Campaign, and you can see all the changes you made in Dreamweaver reflected in the campaign there.

8 In Adobe Campaign, you can continue to make further changes, and all these changes are synchronized with the campaign in Dreamweaver.

After you are done with your changes, click Confirm and then Save in Adobe Campaign. All your changes are saved, and the synchronization connection with Dreamweaver is broken.

9 You can then send the finished email campaign to your recipients from Adobe Campaign.
Chapter 13: Templates

About Dreamweaver templates

A template is a special type of document that you use to design a “fixed” page layout; you can then create documents based on the template that inherit its page layout. As you design a template, you specify as “editable” which content users can edit in a document based on that template. Templates enable template authors to control which page elements template users—such as writers, graphic artists, or other web developers—can edit. There are several types of template regions the template author can include in a document.

Note:

Templates enable you to control a large design area and reuse complete layouts. If you want to reuse individual design elements, such as a site’s copyright information or a logo, create library items.

Using templates enables you to update multiple pages at once. A document that is created from a template remains connected to that template (unless you detach the document later). You can modify a template and immediately update the design in all documents based on it.

Note:

Templates in Dreamweaver differ from templates in some other Adobe Creative Cloud software in that page sections of Dreamweaver templates are fixed (or uneditable) by default.

Types of template regions

When you save a document as a template, most regions of a document are locked. As a template author, you specify which regions of a template-based document will be editable by inserting editable regions or editable parameters in the template.

As you create the template, you can make changes to both editable and locked regions. In a document based on the template, however, a template user can make changes only in the editable regions; the locked regions can’t be modified.

There are four types of template regions:

An editable region: An unlocked region in a template-based document—a section a template user can edit. A template author can specify any area of a template as editable. For a template to be effective, it should contain at least one editable region; otherwise, pages based on the template can’t be edited. For detailed information in editable regions, see Create editable regions in templates.

A repeating region: A section of the document layout that is set so that the template user can add or delete copies of the repeating region in a document based on the template as necessary. For example, you can set a table row to repeat. Repeating sections are editable so that the template user can edit the content in the repeating element, while the design itself is under the control of the template author.

There are two types of repeating regions you can insert in a template: repeating region and repeating table. To know how to work with repeating regions, see Create repeating regions and tables in Dreamweaver.
An **optional region**: A section of a template that holds content—such as text or an image—that may or may not appear in a document. In the template-based page, the template user usually controls whether the content is displayed. See the [Use optional regions in templates](#) section for more information.

An **editable tag attribute**: Lets you unlock a tag attribute in a template, so the attribute can be edited in a template-based page. For example, you can "lock" which image appears in the document but let the template user set the alignment to left, right, or center. See [Define editable tag attributes in Dreamweaver](#) for more information.

**Links in templates**

When you create a template file by saving an existing page as a template, the new template in the Templates folder, and any links in the file are updated so that their document-relative paths are correct. Later, when you create a document based on that template and save it, all the document-relative links are updated again to continue to point to the correct files.

When you add a new document-relative link to a template file, it’s easy to enter the wrong path name if you type the path into the link text box in the Property inspector. The correct path in a template file is the path from the Templates folder to the linked document, not the path from the template-based document’s folder to the linked document. Ensure that the correct paths for links exist by using either the folder icon or the Point-to-file icon in the Property inspector when creating links in templates.

**Server scripts in templates and template-based documents**

Some server scripts are inserted at the very beginning or end of the document (before the `<html>` tag or after the `</html>` tag). Such scripts require special treatment in templates and template-based documents. Normally, if you make changes to script code before the `<html>` tag or after the `</html>` tag in a template, the changes are not copied to documents based on that template. This can cause server errors if other server scripts, within the main body of the template, depended on the scripts that are not copied. An alert warns you if you change scripts before the `<html>` tag or after the `</html>` tag in a template.

To avoid this problem, you can insert the following code in the *head* section of the template:

```xml
<!-- TemplateInfo codeOutsideHTMLIsLocked="true" -->
```

When this code is in a template, changes to scripts before the `<html>` tag or after the `</html>` tag are copied to documents based on that template. However, you will no longer be able to edit those scripts in documents based on the template. Thus, you can choose to either edit these scripts in the template, or in documents based on the template, but not both.

**Template parameters**

Template parameters indicate values for controlling content in documents based on a template. Use template parameters for optional regions or editable tag attributes, or to set values you want to pass to an attached document. For each parameter, you select a name, a data type, and a default value. Each parameter must have a unique name that is case sensitive. They must be one of five permitted data types: text, boolean, color, URL, or number.

Template parameters are passed to the document as instance parameters. In most cases, a template user can edit the parameter’s default value to customize what appears in a template-based document. In other cases, the template author might determine what appears in the document, based on the value of a template expression.

**Template expressions**

Template expressions are statements that compute or evaluate a value.
You can use an expression to store a value and display it in a document. For example, an expression can be as simple as the value of a parameter, such as @*(Param)@*, or complex enough to compute values which alternate the background color in a table row, such as @*((_index & 1) ? red : blue)@*.

You can also define expressions for if and multiple-if conditions. When an expression is used in a conditional statement, Dreamweaver evaluates it as true or false. If the condition is true, the optional region appears in the template-based document; if it is false, it doesn’t appear.

You can define expressions in Code view or in the Optional Region dialog box when you insert an optional region.

In Code view, there are two ways to define template expressions: use the <html:TemplateExpr expr="your expression" /> comment or @*(your expression)@*. When you insert the expression in the template code, an expression marker appears in Design view. When you apply the template, Dreamweaver evaluates the expression and displays the value in the template-based document.

### Template expression language

The template expression language is a small subset of JavaScript, and uses JavaScript syntax and precedence rules. Use JavaScript operators to write an expression like this:

`@*(firstName+lastName)@*`

The following features and operators are supported:

- numeric literals, string literals (double-quote syntax only), Boolean literals (true or false)
- variable reference (see the list of defined variables later in this section)
- field reference (the “dot” operator)
- unary operators: +, -, ~, !
- binary operators: +, -, *, /, %, &, |, ^, &&, ||, <, <=, >, >=, ==, !=, <<, >>
- conditional operator: ?:
- parentheses: ()

The following data types are used: Boolean, IEEE 64-bpc floating point, string, and object. Dreamweaver templates do not support the use of JavaScript “null” or “undefined” types. Nor do they allow scalar types to be implicitly converted into an object; thus, the expression "abc".length would trigger an error, instead of yielding the value 3.

The only objects available are those defined by the expression object model. The following variables are defined:

- **_document** Contains the document-level template data with a field for each parameter in the template.
- **_repeat** Only defined for expressions which appear inside a repeating region. Provides built-in information about the region
- **_index** The numerical index (from 0) of the current entry
- **_numRows** The total number of entries in this repeating region
- **_isFirst** True if the current entry is the first entry in its repeating region
- **_isLast** True if the current entry is the last entry in its repeating region
- **_prevRecord** The _repeat object for the previous entry. It is an error to access this property for the first entry in the region.
- **_nextRecord** The _repeat object for the next entry. It is an error to access this property for the last entry in the region.
In a nested repeated region, this gives the _repeat object for the enclosing (outer) repeated region. It is an error to access this property outside of a nested repeated region. During expression evaluation, all fields of the _document object and _repeat object are implicitly available. For example, you can enter title instead of _document.title to access the document's title parameter. In cases where there is a field conflict, fields of the _repeat object take precedence over fields of the _document object. Therefore, you shouldn't need to explicitly reference _document or _repeat except that _document might be needed inside a repeating region to reference document parameters that are hidden by repeated region parameters. When nested repeated regions are used, only fields of the innermost repeated regions are available implicitly. Outer regions must be explicitly referenced using _parent.

**Multiple If condition in template code**

You can define template expressions for if and multiple-if conditions. This example demonstrates defining a parameter named "Dept", setting an initial value, and defining a multiple-if condition which determines which logo to display.

The following is an example of the code you might enter in the head section of the template:

```html
<!-- TemplateParam name="Dept" type="number" value="1" -->

The following condition statement checks the value assigned to the Dept parameter. When the condition is true or matches, the appropriate image is displayed.

```html
<!-- TemplateBeginMultipleIf -->
<!-- checks value of Dept and shows appropriate image-->
<!-- TemplateBeginIfClause cond="Dept == 1" --> <img src=".../sales.gif"></img> <!-- TemplateEndIfClause -->
<!-- TemplateBeginIfClause cond="Dept == 2" --> <img src=".../support.gif"></img> <!-- TemplateEndIfClause -->
<!-- TemplateBeginIfClause cond="Dept == 3" --> <img src=".../hr.gif"></img> <!-- TemplateEndIfClause -->
<!-- TemplateBeginIfClause cond="Dept != 3" --> <img src=".../spacer.gif"></img> <!-- TemplateEndIfClause -->
<!-- TemplateEndMultipleIf -->
```

When you create a template-based document, the template parameters are automatically passed to it. The template user determines which image to display.

**Recognizing templates and template-based documents**

**Recognize templates in Design view**

In Design view, editable regions appear in the Document window surrounded by rectangular outlines. See the bottom pane in the Document window to view the name of the region.

You can identify a template file by looking at the title bar in the Document window. The filename extension for the file is .dwt.
Templates

Recognize templates in Code view

In Code view, editable content regions are marked in HTML with the following comments:

<!-- TemplateBeginEditable> and <!-- TemplateEndEditable -->

💡

You can use code color preferences to set your own color scheme so you can easily distinguish template regions when you view a document in Code view.

Everything between these comments will be editable in documents based on the template. The HTML source code for an editable region might look like this:

```html
<table width="75%" border="1" cellspacing="0" cellpadding="0">
  <tr bgcolor="#333366">
    <td>Name</td>
    <td><font color="#FFFFFF">Address</font></td>
    <td><font color="#FFFFFF">Telephone Number</font></td>
  </tr>
  <!-- TemplateBeginEditable name="LocationList" -->
  <tr>
    <td>Enter name</td>
    <td>Enter Address</td>
    <td>Enter Telephone</td>
  </tr>
  <!-- TemplateEndEditable -->
</table>

Note:
When you edit template code in Code view, be careful not to change any of the template-related comment tags that Dreamweaver relies on.

Recognize template-based documents in Design view

In a document based on a template (a template-based document), editable regions appear in the Design view of the Document window surrounded by rectangular outlines in dotted lines. The bottom of the window shows the name of the region.

In addition to the editable-region outlines, the entire page is surrounded by a different-colored outline, with a tab in the upper-right corner giving the name of the template that the document is based on. This highlighted rectangle reminds you that the document is based on a template and that you can't change content outside the editable regions.

Recognize template-based documents in Code view

In Code view, editable regions of a document derived from a template appear in a different color than code in the non-editable regions. You can make changes only to code in the editable regions or editable parameters but you cannot type in locked regions.

Editable content is marked in HTML with the following Dreamweaver comments:

```html
<!-- InstanceBeginEditable --> and <!-- InstanceEndEditable -->
```

Everything between these comments is editable in a template-based document. The HTML source code for an editable region might look like this:

```html
<body bgcolor="#FFFFFF" leftmargin="0">
<table width="75%" border="1" cellspacing="0" cellpadding="0">
<tr bgcolor="#333366">
 <td>Name</td>
 <td><font color="#FFFFFF">Address</font></td>
 <td><font color="#FFFFFF">Telephone Number</font></td>
</tr>
<!-- InstanceBeginEditable name="LocationList" -->
<tr>
 <td>Enter name</td>
 <td>Enter Address</td>
 <td>Enter Telephone</td>
</tr>
<!-- InstanceEndEditable -->
</table>
</body>
```

The default color for non-editable text is gray; you can select a different color for the editable and non-editable regions in the Preferences dialog box.

Create a Dreamweaver template

You can create a template from an existing document such as an HTML, or you can create a template from a new document.

After you create a template, you can insert template regions, and set template preferences for code color and template region highlight color.
You can store additional information about a template (such as who created it, when it was last changed, or why you made certain layout decisions) in a Design Notes file for the template. Documents based on a template do not inherit the template’s Design Notes.

**Note:**

Templates in Dreamweaver differ from templates in some other Adobe Creative Cloud products in that page sections of Dreamweaver templates are fixed (or uneditable) by default.

**Create a template from an existing document**

You can create a template from an existing document.

1. Open the document you want to save as a template.
2. Do one of the following:
   - Select Insert > Template > Make Template.
   - In the Common category of the Insert panel, select Templates from the drop-down menu, then select the Make Template option.

   **Note:**

   Unless you selected Don’t Show This Dialog Again in the past, you’ll receive a warning that says the document you’re saving has no editable regions. Click OK to save the document as a template, or click Cancel to exit this dialog box without creating a template.

3. Select a site to save the template in from the Site pop-up menu, and then enter a unique name for the template in the Save As field.

4. Click Save. Dreamweaver saves the template file in the site’s Templates folder in the local root folder of the site, with a .dwt filename extension. If the Templates folder does not already exist in the site, Dreamweaver automatically creates it when you save a new template.

   **Note:**
Do not move your templates out of the Templates folder, or put any non-template files in the Templates folder. Also, do not move the Templates folder out of your local root folder. Doing so causes errors in paths in the templates.

Use the Assets panel to create a new template

1. In the Assets panel (Window > Assets), select the Templates icon on the left side of the panel.
2. Click the New Template icon at the bottom of the Assets panel.
   A new, untitled template is added to the list of templates in the Assets panel.
3. While the template is still selected, enter a name for the template, then press Enter (Windows) or Return (Macintosh).
   Dreamweaver creates a blank template in the Assets panel and in the Templates folder.

About creating templates for Contribute sites

Using Dreamweaver, you can create templates to help Adobe® Contribute® users create new pages, to provide a consistent look and feel for your site, and to enable you to update the layout of many pages at once.

When you create a template and upload it to the server, it becomes available to all Contribute users who connect to your site, unless you’ve set restrictions on template use for certain Contribute roles. If you have set restrictions on template use, you might need to add each new template to the list of templates a Contribute user can use (see Administering Contribute).

Note:
Make sure that the site root folder defined in each Contribute user's site definition is the same as the site root folder defined in your site definition in Dreamweaver. If a user’s site root folder doesn’t match yours, that user won’t be able to use templates.

In addition to Dreamweaver templates, you can create non-Dreamweaver templates using the Contribute administration tools. A non-Dreamweaver template is an existing page that Contribute users can use to create new pages; it’s similar to a Dreamweaver template, except that pages that are based on it don’t update when you change the template. Also, non-Dreamweaver templates can’t contain Dreamweaver template elements such as editable, locked, repeating, and optional regions.

When a Contribute user creates a new document within a site containing Dreamweaver templates, Contribute lists the available templates (both Dreamweaver and non-Dreamweaver templates) in the New Page dialog box.

To include pages that use encodings other than Latin-1 in your site, you might need to create templates (either Dreamweaver templates or non-Dreamweaver templates). Contribute users can edit pages that use any encoding, but when a Contribute user creates a new blank page, it uses the Latin-1 encoding. To create a page that uses a different encoding, a Contribute user can create a copy of an existing page that uses a different encoding, or can use a template that uses a different encoding. However, if there are no pages or templates in the site that use other encodings, then you must first create a page or a template in Dreamweaver that uses that other encoding.

Create a template for a Contribute site

1. Select Site > Manage Sites.
2. Double click the site you want to edit.
3. In the Site Setup dialog box, select Advanced Settings > Contribute.
4. If you haven’t already done so, you need to enable Contribute compatibility.
   Select Enable Contribute Compatibility, and then enter a site root URL.
5 Click Administer Site In Contribute.

6 If prompted, enter the administrator password, and then click OK.

7 In the Users And Roles category, select a role, and then click the Edit Role Settings button.

8 Select the New Pages category, and then add existing pages to the list under Create A New Page By Copying A Page From This List.

For more information, see Administering Contribute.

9 Click OK twice to close the dialog boxes.

Create editable regions in templates

Editable template regions control which areas of a template-based page a user can edit. Before you insert an editable region, save the document you are working in as a template.

Note:

If you insert an editable region in a document rather than a template file, an alert warns you that the document will automatically be saved as a template.

You can place an editable region anywhere in your page, but consider the following points if you are making a table editable:

You can mark an entire table or an individual table cell as editable, but you can't mark multiple table cells as a single editable region. If a <td> tag is selected, the editable region includes the region around the cell; if not, the editable region affects only content inside the cell.

1 In the Document window, do one of the following to select the region:
   • Select the text or content that you want to set as an editable region.
   • Place the insertion point where you want to insert an editable region.

2 Do one of the following to insert an editable region:
   • Select Insert > Template > Editable Region.
   • In the Templates category of the Insert panel, select Editable Region.

3 In the Name box, enter a unique name for the region. (You cannot use the same name for more than one editable region in a particular template.)

   Note:

   Do not use special characters in the Name box.

4 Click OK. The editable region is enclosed in a highlighted rectangular outline in the template, using the highlighting color that is set in preferences. If you insert an empty editable region in the document, the name of the region also appears inside the region.

Select editable regions

You can easily identify and select template regions in both the template document and template-based documents.

Select an editable region in the Document window

? Click on the editable region in the Code View.
Find an editable region and select it in the document

? Select Tools > Templates, then select the name of the region from the list at the bottom of that submenu.

Find editable regions

Note:

Editable regions that are inside a repeated region do not appear in the menu. You must locate these regions by looking for tabbed borders in the Document window.

The editable region is selected in the document.

Remove an editable region

If you've marked a region of your template file as editable and you want to lock it (make it noneditable in template-based documents) again, use the Remove Template Markup command.

1 Click the tab in the editable region tag at the bottom of the page to select the editable region.

2 Do one of the following:
   • Select Tools > Template > Remove Template Markup.
     The region is no longer editable.

Change an editable region’s name

After you insert an editable region, you can later change its name.

1 From the Code View, select the editable region that you want to modify.
2 From the bottom pane, select the editable region tag. Right-click and select Quick Tag Editor. You can easily modify the name of the editable region from the pop-up dialog box.

![Select the Quick tag editor](Select%20the%20Quick%20tag%20editor.png)

3 Press Enter (Windows) or Return (Macintosh).

### Create repeating regions and tables in Dreamweaver

A repeating region is a section of a template that can be duplicated many times in a template-based page. Typically, repeating regions are used with tables but you can define a repeating region for other page elements. Repeating regions enable you to control your page layout by repeating certain items, such as a catalog item and description layout, or a row for data such as a list of items.

There are two repeating region template objects you can use: repeating region and repeating table.

#### Create a repeating region in a template

Repeating regions enable template users to duplicate a specified region in a template as often as desired. A repeating region is not necessarily an editable region. To make content in a repeating region editable (for example, to allow a user to enter text in a table cell in a template-based document), you must insert an editable region in the repeating region.

1 In the Document window, do one of the following:
   - Select the text or content you want to set as a repeating region.
   - Place the insertion point in the document where you want to insert the repeating region.

2 Do one of the following:
   - Select Insert > Template > Repeating Region.
   - In the Templates category of the Insert panel, select Repeating Region.

3 In the Name box, enter a unique name for the template region. (You cannot use the same name for more than one repeating region in a template.)
Note:

When you name a region, do not use special characters.

4 Click OK.

Insert a repeating table

You can use a repeating table to create an editable region (in table format) with repeating rows. You can define table attributes and set which table cells are editable.

1 In the Document window, place the insertion point in the document where you want to insert the repeating table.

2 Do one of the following:
   • Select Insert > Template > Repeating Table.
   • In the Templates category of the Insert panel, select Repeating Table.

3 Specify the following options and click OK.

   Rows Determines the number of rows the table has.

   Columns Determines the number of columns the table has.

   Cell Padding Determines the number of pixels between a cell's content and the cell boundaries.

   Cell Spacing Determines the number of pixels between adjacent table cells.

   If you don't explicitly assign values for cell padding and cell spacing, most browsers display the table as if cell padding were set to 1 and cell spacing were set to 2. To ensure that browsers display the table with no padding or spacing, set Cell Padding and Cell Spacing to 0.

   Width Specifies the width of the table in pixels, or as a percentage of the browser window's width.

   Border Specifies the width, in pixels, of the table's borders.

   If you don't explicitly assign a value for border, most browsers display the table as if the border were set to 1. To ensure that browsers display the table with no border, set Border to 0.

   To view cell and table boundaries when the border is set to 0, select View > Design View Options > Visual Aids. This option is available only in the Design view.

   Repeat Rows of the Table Specify which rows in the table are included in the repeating region.

   Starting Row Sets the row number entered as the first row to include in the repeating region.

   Ending Row Sets the row number entered as the last row to include in the repeating region.

   Region Name Lets you set a unique name for the repeating region.
Creating repeating tables

Set alternating background colors in a repeating table

After you insert a repeating table in a template, you can customize it by alternating the background color of the table rows.

1. In the Document window, select a row in the repeating table.
2. Click the Show Code View or Show Code And Design Views button in the Document toolbar so you can access the code for the selected table row.
3. In Code view, edit the `<tr>` tag to include the following code:

```
<tr bgcolor="@@(_index &amp; 1 ? '#FFFFFF' : '#CCCCCC')@@">
```

You can replace the `#FFFFFF` and `#CCCCCC` hexadecimal values with other color choices.

4. Save the template.

The following is a code example of a table that includes alternating background row colors:

```
<table width="75%" border="1" cellspacing="0" cellpadding="0">
<tr><th>Name</th><th>Phone Number</th><th>Email Address</th></tr>
<!-- TemplateBeginRepeat name="contacts" -->
<tr bgcolor="@@(_index &amp; 1 ? '#FFFFFF' : '#CCCCCC')@@">
<td> <!-- TemplateBeginEditable name="name" --> name <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="phone" --> phone <!-- TemplateEndEditable -->
</td>
<td> <!-- TemplateBeginEditable name="email" --> email <!-- TemplateEndEditable -->
</td>
<!-- TemplateEndRepeat -->
</table>
```

Use optional regions in templates

An optional region is a region in a template that users can set to show or to hide in a template-based document. Use an optional region when you want to set conditions for displaying content in a document.
When you insert an optional region, you can either set specific values for a template parameter or define conditional statements (If...else statements) for template regions. Use simple true/false operations, or define more complex conditional statements and expressions. You can later modify the optional region if necessary. Based on the conditions you define, template users can edit the parameters in template-based documents they create and control whether the optional region is displayed.

You can link multiple optional regions to a named parameter. In the template-based document, both regions will show or hide as a unit. For example, you can show a "closeout" image and sales price text area for a sale item.

**Insert an optional region**

Use an optional region to control content that may or may not be displayed in a template-based document. There are two types of optional regions:

- Non-editable optional regions, which enable template users to show and hide specially marked regions without enabling them to edit the content.
  
  The template tab of an optional region is preceded by the word *if*. Based on the condition set in the template, a template user can define whether the region is viewable in pages they create.

- Editable optional regions, which enable template users to set whether the region shows or hides, and enable users to edit content in the region.

  For example, if the optional region includes an image or text, the template user can set whether the content is displayed, as well as make edits to the content if desired. An editable region is controlled by a conditional statement.

**Insert a non-editable optional region**

1. In the Document window, select the element you want to set as an optional region.
2. Do one of the following:
   - Select Insert > Template > Optional Region.
   - In the Common category of the Insert panel, select Templates from the drop-down list, then select Optional Region.
3. Enter a name for the optional region, click the Advanced tab if you want to set values for the optional region, and then click OK.

**Insert an editable optional region**

1. In the Document window, place the insertion point where you want to insert the optional region.
2. Do one of the following:
   - Select Insert > Template > Editable Optional Region.
   - In the Templates category of the Insert panel, select Editable Optional Region.
3. Enter a name for the optional region, click the Advanced tab if you want to set values for the optional region, and then click OK.

*You cannot wrap a selection to create an editable optional region. Insert the region, then insert the content in the region.*

1. In the Document window, place the insertion point where you want to insert the optional region.
2. Do one of the following:
   - Select Insert > Template > Optional Region.
   - In the Common category of the Insert panel, select Templates from the drop-down list, then select Optional Region.
3. Enter a name for the optional region, click the Advanced tab if you want to set values for the optional region, and then click OK.
Set values for an optional region

You can edit optional region settings after you’ve inserted the region in a template. For example, you can change whether the default setting for the content is to be displayed or not, to link a parameter to an existing optional region, or to modify a template expression.

Create template parameters and define conditional statements (if... else statements) for template regions. You can use simple true/false operations, or define more complex conditional statements and expressions.

In the Advanced tab you can link multiple optional regions to a named parameter. In the template-based document, both regions will show or hide as a unit. For example, you can show a “closeout” image and sales price text area for a sale item.

You can also use the Advanced tab to write a template expression that evaluates a value for the optional region and shows it or hides it based on the value.

1 In the Document window, do one of the following:
   • In Design view, click the template tab of the optional region you want to modify.
   • In Design view, place the insertion point in the template region; then in the tag selector at the bottom of the Document window, select the template tag, <mmtemplate:if>.
   • In Code view, click the comment tag of the template region you want to modify.

2 In the Property inspector (Window > Properties), click Edit.

3 In the Basics tab, enter a name for the parameter in the Name box.

4 Select the Show By Default checkbox to set the selected region to show in the document. Deselect the checkbox to set the default value to false.

   Note:
   To set a different value for the parameter, in Code view locate the parameter in the section of the document and edit the value.

5 (Optional) Click the Advanced tab, then set the following options:
   • If you want to link optional region parameters, click the Advanced tab, select Use Parameter, then from the pop-up menu select the existing parameter you want to link the selected content to.
   • If you want to write a template expression to control the display of an optional region, click the Advanced tab, select Enter Expression, then enter the expression in the box.

   Note:
   Dreamweaver inserts double- quotation marks around the text you enter.

6 Click OK.

When you use the Optional Region template object, Dreamweaver inserts template comments in the code. A template parameter is defined in the head section, as in the following example:

   <!-- TemplateParam name="departmentImage" type="boolean" value="true" -->

At the location where the optional region is inserted, code similar to the code below appears:

   <!-- TemplateParam name="departmentImage" type="boolean" value="true" -->
   Do Not Use<!-- TemplateBeginIf cond="departmentImage" -->.
   <p><img src="/images/airfare_on.gif" width="85" height="22"></p><!-- TemplateEndIf -->

You can access and edit template parameters in the template-based document.
Define editable tag attributes in Dreamweaver

You can allow a template user to modify specified tag attributes in a document created from a template.

For example, you can set a background color in the template document, yet enable template users to set a different background color for pages they create. Users can update only the attributes you specify as editable.

You can also set multiple editable attributes in a page so that template users can modify the attributes in template-based documents. The following data types are supported: text, Boolean (true/false), color, and URL.

Creating an editable tag attribute inserts a template parameter in the code. An initial value for the attribute is set in the template document; when a template-based document is created, it inherits the parameter. A template user can then edit the parameter in the template-based document.

**Note:**

*If you make the link to a style sheet an editable attribute, then the attributes of the style sheet are no longer available for either viewing or editing in the template file.*

1. In the Document window, select an item you want to set an editable tag attribute for.
2. Select Tools > Templates > Make Attribute Editable.

3. In the Attribute box, enter a name or select an attribute in the Editable Tag Attributes dialog box by doing one of the following:
   - If the attribute you want to make editable is listed in the Attribute pop-up menu, select it.
   - If the attribute you want to make editable isn't listed in the Attribute pop-up menu, click Add, and in the dialog box that opens, enter the name of the attribute you want to add, then click OK.
4. Make sure the Make Attribute Editable option is selected.
5. In the Label box, enter a unique name for the attribute.

Last updated 11/7/2019
To make it easier to identify a specific editable tag attribute later, use a label that identifies the element and the attribute. For example, you might label an image whose source is editable logoSrc or label the editable background color of a body tag bodyBgcolor.

6 In the Type menu, select the type of value allowed for this attribute by choosing one of the following options:
   - Text: Select this option to enable a user to enter a text value for the attribute. For example, you can use text with the `align` attribute; the user can then set the attribute's value to left, right, or center.
   - URL: Select this option to insert a link to an element, such as the file path to an image. Using this option automatically updates the path used in a link. If the user moves the image to a new folder, the Update Links dialog box appears.
   - Color: Select this option to make the color picker available for selecting a value.
   - True/False: Select this option to enable a user to select a true or false value on the page.
   - Number: Select this option to enable a template user to type a numerical value to update an attribute (for example, to change the height or width values of an image).

7 The Default Value box displays the value of the selected tag attribute in the template. Enter a new value in this box to set a different initial value for the parameter in the template-based document.

8 (Optional) If you want to make changes to another attribute of the selected tag, select the attribute and set the options for that attribute.

9 Click OK.

Make an editable tag attribute uneditable
A tag previously marked as editable can be marked as uneditable.

1 In the template document, click the element associated with the editable attribute or use the tag selector to select the tag.

2 Select Tools > Templates > Make Attribute Editable.

3 In the Attributes pop-up menu, select the attribute you want to affect.

4 Deselect Make Attribute Editable and click OK.

5 Update documents based on the template.

How to create nested templates in Dreamweaver
A nested template is a template whose design and editable regions are based on another template. Nested templates are useful for controlling content in pages of a site that share many design elements, but have a few variations between pages. For example, a base template might contain broader design areas and be usable by many content contributors for a site, while a nested template might further define the editable regions in pages for a specific section in a site.

Editable regions in a base template are passed through to the nested template, and remain editable in pages created from a nested template unless new template regions are inserted in these regions.

Changes to a base template are automatically updated in templates based on the base template, and in all template-based documents that are based on the main and nested templates.

In the following example, the template `trioHome` contains three editable regions, named `Body`, `NavBar`, and `Footer:`
A template with three editable regions

To create a nested template, a new document based on the template was created and then saved as a template and named TrioNested. In the nested template, two editable regions have been added in the editable region named Body.
When you add a new editable region in an editable region passed through to the nested template, the highlighting color of the editable region changes to orange. Content you add outside the editable region, such as the graphic in the editableColumn, is no longer editable in documents based on the nested template. The blue highlighted editable areas, whether added in the nested template or passed through from the base template, remain editable in documents that are based on the nested template. Template regions that do not contain an editable region pass through to template-based documents as editable regions.

Create a nested template

Nested templates let you create variations of a base template. You can nest multiple templates to define increasingly specific layouts.

By default, all editable template regions from the base template pass through the nested template to the document based on the nested template. That means that if you create an editable region in a base template, then create a nested template, the editable region appears in documents based on the nested template (if you did not insert any new template regions in that region in the nested template).

Note:

You can insert template markup inside an editable region so that it won't pass through as an editable region in documents based on the nested template. Such regions have an orange border instead of a blue border.

1. Create a document from the template in which you want to base the nested template. Do one of the following:
   - From the Assets panel, click Templates from the left pane. Select New Template from the bottom pane. Select New Template from the bottom pane.
• Select File > New. In the New Document dialog box, select the Page from Template category, then select the site that contains the template you want to use. In the Template list, double-click the template to create a new document.

2 Select File > Save As. In the Save as dialog box, select Template Files in the Save as type drop-down list.

3 Enter a name in the Save As box and click OK to save the new document as a nested template.

Prevent an editable region from passing through to a nested template

In nested templates, pass-through editable regions have a blue border. You can insert template markup inside an editable region so that it won’t pass through as an editable region in documents based on the nested template. Such regions have an orange border instead of a blue border.

1 In Code view, locate the editable region you want to prevent from passing through.

   Editable regions are defined by template comment tags.

2 Add the following code to the editable region code:

   @@(" ")@@

   This template code can be placed anywhere within the <!-- InstanceBeginEditable --> <!-- InstanceEndEditable --> tags that surround the editable region. For example:

   <!-- InstanceBeginEditable name="EditRegion1" -->
   <p>@@(" ")@@ Editable 1 </p>
   <!-- InstanceEndEditable -->

Edit, update, and delete templates

When you make changes to and save a template, all the documents based on the template are updated. You can also manually update a template-based document or the entire site if necessary.

Note:

To edit a template for a Contribute site, you must use Dreamweaver; you cannot edit templates in Contribute.

Use the Templates category of the Assets panel to manage existing templates, including renaming template files and deleting template files.

You can perform the following template management tasks using the Assets panel:

• Create a template
• Edit and update templates
• Apply or remove a template from an existing document

Dreamweaver checks template syntax when you save a template but it’s a good idea to manually check the template syntax while you’re editing a template.

Open a template for editing

You can open a template file directly for editing, or you can open a template-based document, then open the attached template for editing.

When you make a change to a template, Dreamweaver prompts you to update the documents based on the template.
Templates

Note:

*You can also manually update the documents for template changes if necessary.*

Open and edit a template file
1 In the Assets panel (Window > Assets), select the Templates icon on the left side of the panel. The Assets panel lists all of the available templates for your site and displays a preview of the selected template.
2 In the list of available templates, do one of the following:
   • Right-click the template and click Edit.
   • Double-click the name of the template you want to edit.
   • Select a template to edit, then click the Edit button at the bottom of the Assets panel.
3 Save the template. Dreamweaver prompts you to update pages based on the template.
4 Click Update to update all documents based on the modified template; click Don't Update if you don't want to update documents based on the modified template.
   Dreamweaver displays a log indicating the files that were updated.

Open and modify the template attached to the current document
1 Open the template-based document in the Document window.
2 Select Tools > Templates > Open Attached Template.
3 Modify the contents of the template.

   *To modify the template's page properties, select File > Page Properties. (Documents based on a template inherit the template's page properties)*
4 Save the template. Dreamweaver prompts you to update pages based on the template.
5 Click Update to update all documents based on the modified template; click Don't Update if you don't want to update documents based on the modified template.
   Dreamweaver displays a log indicating the files that were updated.

Rename a template
1 In the Assets panel (Window > Assets), select the Templates icon on the left side of the panel.
2 Click the name of the template to select it.
3 Click the name again so that the text is selectable, then enter a new name.
   This method of renaming works in the same way as renaming a file in Windows Explorer (Windows) or the Finder (Macintosh). As with Windows Explorer and the Finder, be sure to pause briefly between clicks. Do not double-click the name, because that opens the template for editing.
4 Click in another area of the Asset panel, or press Enter (Windows) or Return (Macintosh) for the change to take effect.
   An alert asks if you want to update documents that are based on this template.
5 To update all documents in the site that are based on this template, click Update. Click Don't Update if you do not want to update any document based on this template.
**Change a template description**
The template description appears in the New Document dialog box when you're creating a page from an existing template.

1. Select Tools > Templates > Description.
2. In the Template Description dialog box, edit the description and click OK.

**Manually update documents based on templates**
When you make a change to a template, Dreamweaver prompts you to update the documents based on the template, but you can manually update the current document or the entire site if necessary. Manually updating template-based documents is the same as reapplying the template.

**Apply template changes to the current template-based document**
1. Open the document in the Document window.
   Dreamweaver updates the document with any template changes.

**Update the entire site or all documents that use a specified template**
You can update all the pages in the site, or only update pages for a specific template.

1. Select Tools > Templates > Update Pages...
2. In the Look In menu, do one of the following:
   • To update all the files in the selected site to their corresponding templates, select Entire Site, then select the site name from the adjacent pop-up menu.
   • To update files for a specific template, select Files That Use, then select the template name from the adjacent pop-up menu.

3. Make sure Templates is selected in the Update option.
4. If you don’t want to see a log of the files Dreamweaver updates, deselect the Show Log option; otherwise, leave that option selected.
5. Click Start to update the files as indicated. If you selected the Show Log option, Dreamweaver provides information about the files it attempts to update, including information on whether they were updated successfully.
6 Click Close.

**Update templates in a Contribute site**

Contribute users can't make changes to a Dreamweaver template. You can, however, use Dreamweaver to change a template for a Contribute site.

Keep these factors in mind when updating templates in a Contribute site:

- Contribute retrieves new and changed templates from the site only when Contribute starts up and when a Contribute user changes their connection information. If you make changes to a template while a Contribute user is editing a file based on that template, the user won't see the changes to the template until they restart Contribute.
- If you remove an editable region from a template, a Contribute user editing a page based on that template might be confused about what to do with the content that was in that editable region.

To update a template in a Contribute site, complete the following steps.

1 Open the Contribute template in Dreamweaver, edit it, and then save it. For instructions, see Open a template for editing.

2 Notify all of the Contribute users who are working on the site to restart Contribute.

**Delete a template file**

1 In the Assets panel (Window > Assets), select the Templates icon on the left side of the panel.

2 Click the name of the template to select it.

3 Click the Delete button at the bottom of the panel, then confirm that you want to delete the template.

   **Note:**

   *After you delete a template file, you can't retrieve it. The template file is deleted from your site.*

   Documents that are based on a deleted template are not detached from the template; they retain the structure and editable regions that the template file had before it was deleted. You can convert such a document into an HTML file without editable or locked regions.

**Export and import xml content in Dreamweaver**

You can think of a document based on a template as containing data represented by name-value pairs. Each pair consists of the name of an editable region, and the contents of that region.

You can export the name-value pairs into an XML file so that you can work with the data outside of Dreamweaver (for example, in an XML editor or a text editor, or a database application). Conversely, if you have an XML document that's structured appropriately, you can import the data from it into a document based on a Dreamweaver template.

**Export a document’s editable regions as XML**

1 Open a template-based document that contains editable regions.

2 Select File > Export > Template Data As XML.

3 Select one of the Notation options:

   - If the template contains repeating regions or template parameters, select Use Standard Dreamweaver XML Tag.
* If the template does not contain repeating regions or template parameters, select Use Editable Region Names as XML Tags.

4 Click OK.

5 In the dialog box that appears, select a folder location, enter a name for the XML file, and then click Save.

An XML file is generated that contains the material from the document’s parameters and editable regions, including editable regions inside repeating regions or optional regions. The XML file includes the name of the original template, as well as the name and contents of each template region.

Note:

Content in the non-editable regions is not exported to the XML file.

**Import XML content**

1 Select File > Import > Import XML into Template.

2 Select the XML file and click Open.

Dreamweaver creates a new document based on the template specified in the XML file. It fills in the contents of each editable region in that document using the data from the XML file. The resulting document appears in a new Document window.

*If your XML file isn't set up exactly the way Dreamweaver expects, you might not be able to import your data. One solution to this problem is to export a dummy XML file from Dreamweaver, so that you'll have an XML file with exactly the right structure. Then copy the data from your original XML file into the exported XML file. The result is an XML file with the correct structure that contains the appropriate data, ready to be imported.*

**Export a site without templatemarkup**

You can export template-based documents in a site to another site without including the template markup.

1 Select Tools > Templates > Export Without Markup.

2 In the Folder box, enter the file path to the folder you want to export the file to or click Browse and select the folder.

*Note:*

You must select a folder outside of the current site.

3 If you want to save an XML version of exported template-based documents, select Keep Template Data Files.

4 If you want to update changes to previously exported files, select Extract Only Changed Files and click OK.

**Apply or remove a template from an existing document**

When you apply a template to a document that contains existing content, Dreamweaver attempts to match the existing content to a region in the template. If you are applying a revised version of one of your existing templates, the names are likely to match.

If you apply a template to a document that hasn't had a template applied to it, there are no editable regions to compare and a mismatch occurs. Dreamweaver tracks these mismatches so you can select which region or regions to move the current page's content to, or you can delete the mismatched content.
You can apply a template to an existing document using the Assets panel or from the Document window. You can undo a template application if necessary.

Note:

When you apply a template to an existing document, the template replaces the document's contents with the template's boilerplate content. Always back up a page's contents before applying a template to it.

Apply a template to an existing document using the Assets panel

1. Open the document you want to apply the template to.
2. In the Assets panel (Window > Assets), select the Templates icon on the left side of the panel.
3. Do one of the following:
   • From the Design view, drag the template you want to apply from the Assets panel to the Document window.
   • Select the template you want to apply, then click the Apply button at the bottom of the Assets panel.
     If content exists in the document that can't be automatically assigned to a template region, the Inconsistent Region Names dialog box appears.
4. Select a destination for the content by using the Move Content to New Region menu to select one of the following:
   • Select a region in the new template to move the existing content to.
   • Select Nowhere to remove the content from the document.
5. To move all unresolved content to the selected region, click Use For All.
6. Click OK to apply the template or click Cancel to cancel the application of the template to the document.

Note:

When you apply a template to an existing document, the template replaces the document's contents with the template's boilerplate content. Always back up a page's contents before applying a template to it.

Apply a template to an existing document from the Document window

1. Open the document you want to apply the template to.
2. Select Tools > Templates > Apply Template to Page.
3. From the Select Template dialog box, choose a template from the list, then click Select.
   If content exists in the document that can't be automatically assigned to a template region, the Inconsistent Region Names dialog box appears.
4. Select a destination for the content by using the Move Content to New Region menu to select one of the following:
   • Select a region in the new template to move the existing content to.
   • Select Nowhere to remove the content from the document.
5. To move all unresolved content to the selected region, click Use For All.
6. Click OK to apply the template or click Cancel to cancel the application of the template to the document.

Note:

When you apply a template to an existing document, the template replaces the document's contents with the template's boilerplate content. Always back up a page's contents before applying a template to it.
**Detach a document from a template**

To make changes to the locked regions of a document based on a template, you must detach the document from the template. When the document is detached, the entire document becomes editable.

*Note:*

You cannot convert a template file (.dwt) to a normal file by simply resaving the template file as an HTML (.html) file. Doing so does not delete the template code that appears throughout the document. If you want to convert a template file to a normal file, you can save the document as a normal HTML file, but must then manually delete all of the template code in Code view.

1. Open the template-based document you want to detach.
2. Select Tools > Templates > Detach from Template.

   The document is detached from the template and all template code is removed.

**Edit content in Dreamweaver templates**

Dreamweaver templates specify regions that are locked (uneditable) and others that are editable for template-based documents.

In pages based on templates, template users can edit content in editable regions only. You can easily identify and select editable regions to edit content. Template users cannot edit content in locked regions.

*Note:*

If you try to edit a locked region in a document based on a template when highlighting is turned off, the mouse pointer changes to indicate that you can't click in a locked region.

Template users can also modify properties and edit entries for a repeating region in template-based documents.

**Modify template properties**

When template authors create parameters in a template, documents based on the template automatically inherit the parameters and their initial value settings. A template user can update editable tag attributes and other template parameters (such as optional region settings).

**Modify an editable tag attribute**

1. Open the template-based document.
2. Select Edit > Template Properties.

   The Template Properties dialog box opens, showing a list of available properties. The dialog box shows optional regions and editable tag attributes.
3. In the Name list, select the property.

   The bottom area of the dialog box updates to show the selected property's label and its assigned value.
4. In the field to the right of the property label, edit the value to modify the property in the document.

   *Note:*

   The field name and updateable values are defined in the template. Attributes that do not appear in the Name list are not editable in the template-based document.
5 Select Allow Nested Templates To Control This if you want to pass the editable property along to a documents based on the nested template.

**Modify optional region template parameters**

1 Open the template-based document.

2 Select Edit > Template Properties.

The Template Properties dialog box opens, showing a list of available properties. The dialog box shows optional regions and editable tag attributes.

3 In the Name list, select a property.

The dialog box updates to show the selected property’s label and its assigned value.

4 Select Show to display the optional region in the document, or deselect Show to hide the optional region.

*Note:*

*The field name and default setting are defined in the template.*

5 Select Allow Nested Templates To Control This if you want to pass the editable property along to a documents based on the nested template.

**Add, delete, and change the order of a repeating region entry**

Use repeating region controls to add, delete, or change the order of entries in template-based documents. When you add a repeating region entry, a copy of the entire repeating region is added. To update the content in the repeating regions, the original template must include an editable region in the repeating region.

<table>
<thead>
<tr>
<th>Product Name</th>
<th>SKU#</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macadamia nuts</td>
<td>Mac3423</td>
<td>12.00 lb.</td>
</tr>
<tr>
<td>Brazil nuts</td>
<td>Braz002</td>
<td>9.00 lb.</td>
</tr>
</tbody>
</table>

**Add, delete, or change the order of a repeating region**

1 Open the template-based document.

2 Place the insertion point in the repeating region to select it.

3 Do one of the following:

   • Click the Plus (+) button to add a repeating region entry below the currently selected entry.
   • Click the Minus (-) button to delete the selected repeating region entry.
   • Click the Down Arrow button to move the selected entry down one position.
   • Click the Up Arrow button to move the selected entry up one position.

*Note:*

*Alternatively, you can select Modify > Template, then select one of the repeating entry options near the bottom of the context menu. You can use this menu to insert a new repeating entry or move the selected entry’s position.*
Cut, copy, and delete entries

1. Open the template-based document.
2. Place the insertion point in the repeating region to select it.
3. Do one of the following:
   • To cut a repeating entry, select Edit > Repeating Entries > Cut Repeating Entries.
   • To copy a repeating entry, select Edit > Repeating Entries > Copy Repeating Entries.
   • To remove a repeating entry, select Edit > Repeating Entries > Delete Repeating Entries.
   • To paste a repeating entry, select Edit > Paste.

Note:
Pasting inserts a new entry; it does not replace an existing entry.

Syntax rules for template tags in Dreamweaver

Dreamweaver uses HTML comment tags to specify regions in templates and template-based documents, so template-based documents are still valid HTML files. When you insert a template object, template tags are inserted in the code.

General syntax rules are as follows:

• Wherever a space appears, you can substitute any amount of white space (spaces, tabs, line breaks). The white space is mandatory except at the very beginning or end of a comment.
• Attributes can be given in any order. For example, in a TemplateParam, you can specify the type before the name.
• Comment and attribute names are case sensitive.
• All attributes must be in quotation marks. Single or double quotes can be used.

Template tags

Dreamweaver uses the following template tags:

<!-- TemplateBeginEditable name="..." -->
<!-- TemplateEndEditable -->
<!-- TemplateParam name="..." type="..." value="..." -->
<!-- TemplateBeginRepeat name="..." -->
<!-- TemplateEndRepeat -->
<!-- TemplateBeginIf cond="..." -->
<!-- TemplateEndIf -->
<!-- TemplateBeginPassthroughIf cond="..." -->
<!-- TemplateEndPassthroughIf -->
<!-- TemplateBeginMultipleIf -->
<!-- TemplateEndMultipleIf -->
<!-- TemplateBeginIfClause cond="..." -->
<!-- TemplateEndIfClause -->
<!-- TemplateBeginPassthroughIfClause cond="..." -->
<!-- TemplateEndPassthroughIfClause -->
<!-- TemplateExpr expr="..." --> (equivalent to @@...@@)
<!-- TemplatePassthroughExpr expr="..." -->
<!-- TemplateInfo codeOutsideHTMLIsLocked="..." -->
Instance tags

Dreamweaver uses the following instance tags:

<!-- InstanceBegin template="..." codeOutsideHTMLIsLocked="..." -->
<!-- InstanceEnd -->
<!-- InstanceBeginEditable name="..." -->
<!-- InstanceEndEditable -->
<!-- InstanceParam name="..." type="..." value="..." passthrough="..." -->
<!-- InstanceBeginRepeat name="..." -->
<!-- InstanceEndRepeat -->
<!-- InstanceBeginRepeatEntry -->
<!-- InstanceEndRepeatEntry -->

Check template syntax

Dreamweaver checks the template syntax when you save a template, but you can manually check the template syntax prior to saving a template. For example, if you add a template parameter or expression in Code view, you can check that the code follows correct syntax.

1. Open the document you want to check in the Document window.
2. Select Tools > Templates > Check Template Syntax.

An error message appears if the syntax is badly formed. The error message describes the error and refers to the specific line in the code where the error exists.

Set highlighting preferences for template regions

You can use the Dreamweaver highlighting preferences to customize the highlight colors for the outlines around the editable and locked regions of a template in Design view. The editable region color appears in the template as well as in documents based on the template.

Change template highlight colors

1. Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh).
2. Select Highlighting from the category list on the left.
3 Click the Editable Regions, Nested Regions, or Locked Regions color box, then select a highlight color using the color picker (or enter the hexadecimal value for the highlight color in the box).

For information about using the color picker, see Use the color picker.

4 (Optional) Repeat the process for other template region types, as necessary.

5 Click the Show option to enable or disable displaying colors in the Document window.

   Note:

   Nested Region does not have a Show option; its display is controlled by the Editable Region option.

6 Click OK.

**View highlight colors in the Documentwindow**

7 From the Design View, select View > Design View Options > Visual Aids > Invisible Elements.

Highlight colors appear in the document window only when Invisible Elements is enabled and the appropriate options are enabled in Highlighting preferences.

   Note:
If invisible elements are showing but the highlight colors are not, select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), and then select the Highlighting category. Make sure that the Show option next to the appropriate highlight color is selected. Also make sure that the desired color is visible against the background color of your page.

## Benefits of using templates in Dreamweaver

Templates allow a Web designer to construct a site that can be flexible, easy to update, and consistent between HTML pages. Templates can enhance productivity, allowing some members of the team to focus on the format of the pages, while other members of the team create new pages and revise the content without changing the formatted layout.

Designers can make changes to the overall design of the site quickly by revising the DWT (Dreamweaver template) files directly. The pages that are linked to the template files are automatically updated allowing for site-wide modifications in minutes.

## Creating templates

Any HTML page may be saved as a template. Simply create a new page (File > New) or open an existing one (File > Open) and make changes to the page properties, insert images, type text, generate layer and table layouts, and so forth. Once the design of your HTML page is complete, choose File > Save as Template to generate the DWT file. Dreamweaver creates a Templates folder for the template (DWT file) at the root level of the local site folder.

**Note:** Make sure not to move the DWT file from the Templates folder. Do not rename or move the Templates folder. As long as the DWT file remains inside the Templates folder, the links from the HTML pages to the template will not be broken.
Chapter 14: Mobile and multiscreen

Create media queries

You can use media queries to specify CSS files based on the reported characteristics of a device (responsive design). The browser on a device checks the media query and uses the corresponding CSS file to display the web page.

For example, the following media query specifies the phone.css file for devices that are 300-320 pixels wide.

```
<link href="css/orig/phone.css" rel="stylesheet" type="text/css" media="all and (min-width: 300px) and (max-width: 320px)"/>
```

For an extensive introduction to media queries see Don Booth's article on the Adobe Developer Center www.adobe.com/go/learn_dw_medquery_don_en.

For more information on media queries from the W3C see www.w3.org/TR/css3-mediaqueries/.

Create a media query

In Dreamweaver, you can create a site-wide media query file, or a document-specific media query. Site-wide media query file specifies display settings for all pages in your site that include the file. The site-wide media query file acts as the central repository for all media queries in your site. After you create this file, link to it from pages in your site that must use the media queries in the file for their display. Document-specific media query The media query is inserted directly into the document, and the page is displayed based on the inserted media query.

1. Create a web page.
2. Select Modify > Media Queries.
3. Do one of the following:
   - To create a site-wide media query file, select Site Wide Media Queries File.
   - To create a document-specific media query, select This Document.
4. For site-wide media query, do the following:
   a. Click Specify.
   b. Select Create New File.
   c. Specify a name for the file, and click OK.
5. It is possible that some devices do not report their actual width. To force devices to report their actual width, ensure that the option Force Devices To Report Actual Width is enabled.
   The following code is inserted into your file when you choose this option.
   ```html
   <meta name="viewport" content="width=device-width">
   ```
6. Do one of the following:
   - Click "+" to define the properties for the media query file.
   - Click Default Presets if you want to begin with standard presets.
7 Select rows in the table, and edit their properties using the options under Properties.

**Description** The description of the device for which the CSS file must be used. For example, phone, TV, tablet, and so on.

**Min Width and Max width** The CSS file is used for devices whose reported width is within the specified values.

*Note:*

*Leave either Min Width or Max Width blank if you do not want to specify an explicit range for a device. For example, it is common to leave Min Width blank if you want to target phones, which are 320px wide, or less.*

**CSS file** Select Use Existing File, and browse to the CSS file for the device.

If you want to specify a CSS file that you are yet to create, select Create New File. Enter the name of the CSS file. The file is created when you press OK.

8 Click OK.

9 For site-wide media query, a new file is created. Save it.

Site-wide media query: For existing pages, ensure that you include the media query file in all the pages in the `<head>` tag.

Example of a media query link where mediaquery_adobedotcom.css is the site-wide media query file for the site www.adobe.com:

```html
<link href="mediaquery_adobedotcom.css" rel="stylesheet" type="text/css">
```

**Use an existing media queries file**

1 Create a web page, or open an existing page.

2 Select Modify > Media Queries.

3 Select Site-Wide Media Queries File.

4 Click Specify.

5 Select Use Existing File if you have already created a CSS file with the Media Query.

6 Click the browse icon to navigate to, and specify the file. Click OK.

7 Select Site-Wide Media Queries File.

8 To force devices to report their actual width, ensure that the option Force Devices To Report Actual Width is enabled. The following code is inserted into your file when you choose this option.

```html
<meta name="viewport" content="width=device-width">
```

9 Click OK.

**Choose a different site-wide media queries file**

Use this procedure to change the site-wide media queries file that you have set in the Media Queries dialog box.

1 Select Site > Manage Sites.

2 In the Manage Sites dialog, select your site.

3 Click Edit. The Site Setup dialog box is displayed.

4 Under Advanced Settings in the left panel, select Local Info.

5 In Site-Wide Media Query File on the right panel, click Browse to select the media query CSS file.
Note:

Changing the site-wide media queries file does not affect documents linked to a different or previous site-wide media query file.

6 Click Save.

View web pages based on media query

Dimensions specified in a media query appear in the options for Multiscreen button/window size. When you select a dimension from the menu, the following changes are seen:

• The view size changes to reflect the specified dimensions. The document frame size is unaltered.
• The CSS file specified in the media query is used to display the page.

Changing page orientation for mobile devices

In most advanced mobile devices, the orientation of a page changes based on how the device is held. When the user holds the phone vertically, the portrait view is displayed. When the user flips the device horizontally, the page readjusts itself to fit the landscape dimensions.

In Dreamweaver, the option to view a page in either Portrait or Landscape orientation is available in both Live View and Design View. Using these options you can test how your page adapts to these settings. You can then, if necessary, modify your CSS file such that the page is displayed as intended in both these orientations.

? Select View > Live View Options or Design View Options > Window Size > Orientation Landscape, or Orientation Portrait.

Create web apps for mobile devices using Dreamweaver

Dreamweaver's integration with jQuery Mobile helps you quickly design a web application that works on most mobile devices while adapting itself to the dimensions of the device.

Creating a web application using jQuery Mobile

Open a jQuery Mobile starter page, or create a HTML5 page

Use the jQuery Mobile starter pages in Dreamweaver to create your application. Alternatively, you can start creating your web application with a new HTML5 page.

The jQuery Mobile starter pages include the HTML, CSS, JavaScript, and image files that help you get started with designing your application. You can use the CSS and JavaScript files hosted on a CDN, your own server, or files installed along with Dreamweaver.

Note:

To identify the location of the linked files, see the <link> and <script src> tags in code view.

Insert jQuery Mobile components from the Insert panel

Insert jQuery Mobile components from the Insert panel into the HTML page. The jQuery Mobile CSS and JavaScript files define the style and behavior of the components.
About CDNs and local jQuery Mobile files

CDNs

A CDN (content delivery network) is a computer network containing copies of data placed at various points in the network. When you create a web application using the URL for a CDN, the CSS and JavaScript files specified in the URL are used for your application. By default, Dreamweaver uses the jQuery Mobile CDN.

Alternatively, you can use URLs of CDNs from other sites such as Microsoft and Google. In code view, edit the server location of the CSS and JavaScript files specified in the `<link>` and `<script src>` tags.

The files downloaded from a CDN are read-only.

Local jQuery Mobile files

When you install Dreamweaver, a copy of the jQuery Mobile files is copied to your computer. The HTML page that opens when you choose the jQuery Mobile (local) starter page is linked to local CSS, JavaScript, and image files.

Starter pages for jQuery Mobile

Dreamweaver provides you with the following starter pages to create your web application:

jQuery Mobile (CDN)

Use this starter page if you plan to host the jQuery Mobile library on a CDN.

jQuery Mobile (Local)

Use this starter page if you plan to host the assets yourself, or if your application doesn't rely on an Internet connection.

jQuery Mobile (PhoneGap)

Use this starter page if your web application, when deployed as a mobile application, accesses features native to mobile devices. For more information, see Packaging web applications.

Use starter pages to create an application for mobile devices

1. Select File > New.

2. Select one of the following based on your requirement:
   - Page From Sample > Mobile Starters > jQuery Mobile (CDN).
   - Page From Sample > Mobile Starters > jQuery Mobile (Local).

3. Click Create.
   - In the page that appears, enable Follow Links Continuously (View > Live View Options), and switch to Live View. Use the navigation components to test how the application works.
   - Use the options in the Multiscreen menu to see how the design is displayed in devices with various dimensions. Disable Live view, and switch back to the Design view.

4. In the Insert panel (Window > Insert), select jQuery Mobile. The components that you can add to the web application are displayed.
5 In Design view, place the cursor at the location where you want to insert the component, and click the component in the Insert Panel. In the dialog box that appears, customize the components using the options.

6 (jQuery Mobile - Local) After you save the HTML file, the jQuery Mobile files, including image files, are copied to a folder in the HTML file location.

Preview the page in Live view. Some of the CSS classes are applied only in the Live view.

Create a web application for mobile devices from a new page

The Page component acts as the container for all the other jQuery Mobile components. Add the Page component before you proceed to insert other components.

1 Select File > New.

2 Select Blank Page > HTML.

   Some of the jQuery Mobile components use HTML5-specific attributes. To ensure HTML5 compliance during validation, ensure that you select HTML5 as your DocType.

3 In the Insert panel (Window > Insert), select jQuery Mobile from the menu. The jQuery Mobile components appear in the panel.

4 From the Insert panel, drag the Page component to Design view.

5 In the jQuery Mobile Files dialog, select one of the following:

   Remote (CDN) If you want to connect to a remote CDN server hosting the jQuery Mobile files. Use the default option for the jQuery site if you have not configured a site containing jQuery Mobile files. You can also choose to use other CDN servers.

   Local The files that are available in Dreamweaver are displayed. To specify a different folder, click Browse, and navigate to the folder containing the jQuery Mobile files.

   The CSS and JavaScript files are copied to a local temp directory until you save the HTML file to your computer. After you save the HTML file, all associated jQuery Mobile and image files are copied to a folder in the site's root folder.

6 Enter the properties for the Page component.

7 In Design view, place the cursor at the location where you want to insert the component, and click the component in the Insert Panel. In the dialog box that appears, customize the components using the options.

Preview the page in Live view. Some of the CSS classes are applied only in the Live view.

Using custom files and folders

You can choose to create custom CSS and JS files for your application. Ensure that your files are named jquery.mobile.js, jquery.mobile.css, and jquery.js

If you are using custom folders, do the following:

1 Download the uncompressed version of the jQuery 1.5 core library from http://docs.jquery.com/Downloading_jQuery#Download_jQuery.

2 Save the file to the core folder containing the other resources.
Chapter 15: Dynamic sites, pages and web forms

Understand web applications

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About web applications
A web application is a website that contains pages with partly or entirely undetermined content. The final content of a page is determined only when the visitor requests a page from the web server. Because the final content of the page varies from request to request based on the visitor’s actions, this kind of page is called a dynamic page.

Web applications are built to address a variety of challenges and problems. This section describes common uses for web applications and gives a simple example.

Common uses for web applications
Web applications have many uses for both site visitors and developers, including the following:

• Let visitors find information quickly and easily on a content-rich website.
  This kind of web application gives visitors the ability to search, organize, and navigate content as they see fit. Examples include company intranets, Microsoft MSDN (www.msdn.microsoft.com), and Amazon.com (www.amazon.com).

• Collect, save, and analyze data provided by site visitors.
  In the past, data entered in HTML forms was sent as e-mail messages to employees or CGI applications for processing. A web application can save form data directly into a database and also extract the data and create web-based reports for analysis. Examples include online banking pages, store check-out pages, surveys, and user-feedback forms.

• Update websites that have constantly changing content.
  A web application frees the web designer from continually updating the site's HTML. Content providers such as news editors provide the web application with content, and the web application updates the site automatically. Examples include the Economist (www.economist.com) and CNN (www.cnn.com).
Web application example
Janet is a professional web designer and longtime Dreamweaver user responsible for maintaining the intranet and Internet sites of a medium-sized company of 1000 employees. One day, Chris from Human Resources comes to her with a problem. HR administers an employee fitness program that gives employees points for every mile walked, biked, or run. Each employee must report his or her monthly mile totals in an e-mail to Chris. At the end of the month, Chris gathers all the e-mail messages and awards employees small cash prizes according to their point totals.

Chris’s problem is that the fitness program has grown too successful. So many employees now participate that Chris is inundated with e-mails at the end of each month. Chris asks Janet if a web-based solution exists.

Janet proposes an intranet-based web application that performs the following tasks:
• Lets employees enter their mileage on a web page using a simple HTML form
• Stores the employees’ mileage in a database
• Calculates fitness points based on the mileage data
• Lets employees track their monthly progress
• Gives Chris one-click access to point totals at the end of each month

Janet gets the application up and running before lunchtime using Dreamweaver, which has the tools she needs to build this kind of application quickly and easily.

How a web application works
A web application is a collection of static and dynamic web pages. A static web page is one that does not change when a site visitor requests it: The web server sends the page to the requesting web browser without modifying it. In contrast, a dynamic web page is modified by the server before it is sent to the requesting browser. The changing nature of the page is why it’s called dynamic.

For example, you could design a page to display fitness results, while leaving certain information (such as employee name and results) to be determined when the page is requested by a particular employee.

The next sections describe how web applications work in greater detail.

Process static web pages
A static website comprises a set of related HTML pages and files hosted on a computer running a web server.

A web server is software that serves web pages in response to requests from web browsers. A page request is generated when a visitor clicks a link on a web page, selects a bookmark in a browser, or enters a URL in a browser’s address text box.

The final content of a static web page is determined by the page designer and doesn’t change when the page is requested. Here’s an example:

```html
<html>
  <head>
    <title>Trio Motors Information Page</title>
  </head>
  <body>
    <h1>About Trio Motors</h1>
    <p>Trio Motors is a leading automobile manufacturer.</p>
  </body>
</html>
```
Every line of the page's HTML code is written by the designer before the page is placed on the server. Because the HTML doesn't change once it's on the server, this kind of page is called a static page.

**Note:**

*Strictly speaking, a "static" page may not be static at all. For example, a rollover image or Flash content (a SWF file) can make a static page come alive. However, this documentation refers to a page as static if it is sent to the browser without modifications.*

When the web server receives a request for a static page, the server reads the request, finds the page, and sends it to the requesting browser, as the following example shows:

```
A  Web browser requests static page.
B  Web server finds page.
C  Web server sends page to requesting browser.
```

In the case of web applications, certain lines of code are undetermined when the visitor requests the page. These lines must be determined by some mechanism before the page can be sent to the browser. The mechanism is discussed in the following section.

**Process dynamic pages**

When a web server receives a request for a static web page, the server sends the page directly to the requesting browser. When the web server receives a request for a dynamic page, however, it reacts differently: It passes the page to a special piece of software responsible for finishing the page. This special software is called an application server.

The application server reads the code on the page, finishes the page according to the instructions in the code, and then removes the code from the page. The result is a static page that the application server passes back to the web server, which then sends the page to the requesting browser. All the browser gets when the page arrives is pure HTML. Here's a view of the process:
Access a database

An application server lets you work with server-side resources such as databases. For example, a dynamic page may instruct the application server to extract data from a database and insert it into the page's HTML. For more information, see www.adobe.com/go/learn_dw_dbguide.

Using a database to store content allows you to separate your website's design from the content you want to display to site users. Instead of writing individual HTML files for every page, you only need to write a page—or template—for the different kinds of information you want to present. You can then upload content into a database and then have the website retrieve that content in response to a user request. You can also update information in a single source, and then populate that change throughout the website without having to manually edit each page. You can use Adobe Dreamweaver to design web forms to insert, update, or delete data from the database.

The instruction to extract data from a database is called a database query. A query consists of search criteria expressed in a database language called SQL (Structured Query Language). The SQL query is written into the page's server-side scripts or tags.

An application server cannot communicate directly with a database because the database's proprietary format renders the data undecipherable in much the same way that a Microsoft Word document opened in Notepad or BBEdit may be undecipherable. The application server can communicate with the database only through the intermediary of a database driver: software that acts like an interpreter between the application server and the database.

After the driver establishes communication, the query is executed against the database and a recordset is created. A recordset is a set of data extracted from one or more tables in a database. The recordset is returned to the application server, which uses the data to complete the page.

Here's a simple database query written in SQL:

```sql
SELECT lastname, firstname, fitpoints
FROM employees
```
This statement creates a three-column recordset and fills it with rows containing the last name, first name, and fitness points of all employees in the database. For more information, see www.adobe.com/go/learn_dw_sqlprimer.

The following example shows the process of querying a database and returning data to the browser:

Access a database

A Web browser requests dynamic page.  B Web server finds page and passes it to application server.  C Application server scans page for instructions.  D Application server sends query to database driver.  E Driver executes the query against the database.  F Recordset is returned to driver.  G Driver passes recordset to application server  H Application server inserts data in page, and then passes the page to the web server  I Web server sends finished page to requesting browser.

You can use almost any database with your web application, as long as the appropriate database driver for it is installed on the server.

If you plan to build small low-cost applications, you can use a file-based database, such as one created in Microsoft Access. If you plan to build robust, business-critical applications, you can use a server-based database, such as one created in Microsoft SQL Server, Oracle 9i, or MySQL.

If your database is located on a system other than your web server, make sure you have a fast connection between the two systems so that your web application can operate quickly and efficiently.

Author dynamic pages

Authoring a dynamic page consists of writing the HTML first, and then adding the server-side scripts or tags to the HTML to make the page dynamic. When you view the resulting code, the language appears embedded in the page's HTML. Accordingly, these languages are known as HTML embedded programming languages. The following basic example uses ColdFusion Markup Language (CFML):

note: CFML support is removed from Dreamweaver and later.
The embedded instructions on this page perform the following actions:

1. Create a variable called `department` and assign the string "Sales" to it.
2. Insert the variable's value, "Sales", in the HTML code.

The application server returns the following page to the web server:

```html
<html>
<head>
  <title>Trio Motors Information Page</title>
</head>
<body>
  <h1>About Trio Motors</h1>
  <p>Trio Motors is a leading automobile manufacturer.</p>
  <!--- embedded instructions start here --->
  <cfset department="Sales">
  <cfoutput>
    <p>Be sure to visit our #department# page.</p>
  </cfoutput>
  <!--- embedded instructions end here --->
</body>
</html>
```

The web server sends the page to the requesting browser, which displays it as follows:

**About Trio Motors**

*Trio Motors is a leading automobile manufacturer.*

*Be sure to visit our Sales page.*

You choose a scripting or tag-based language to use depending on the server technology available on your server. Here are the most popular languages for the server technologies supported by Dreamweaver:

<table>
<thead>
<tr>
<th>Server technology</th>
<th>Language</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion</td>
<td>ColdFusion Markup Language (CFML)</td>
</tr>
<tr>
<td>Active Server Pages (ASP)</td>
<td>VBScript</td>
</tr>
<tr>
<td></td>
<td>JavaScript</td>
</tr>
<tr>
<td>PHP</td>
<td>PHP</td>
</tr>
</tbody>
</table>

Dreamweaver can create the server-side scripts or tags necessary to make your pages work, or you can write them by hand in the Dreamweaver coding environment.
Web application terminology

This section defines frequently used terms relating to web applications.

An application server  Software that helps a web server process web pages containing server-side scripts or tags. When such a page is requested from the server, the web server hands the page off to the application server for processing before sending the page to the browser. For more information, see How a web application works.

Common application servers include ColdFusion and PHP.

A database  A collection of data stored in tables. Each row of a table constitutes one record and each column constitutes a field in the record, as shown in the following example:

<table>
<thead>
<tr>
<th>Number</th>
<th>LastName</th>
<th>FirstName</th>
<th>Position</th>
<th>Goal</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A database

A database driver  Software that acts as an interpreter between a web application and a database. Data in a database is stored in a proprietary format. A database driver lets the web application read and manipulate data that would otherwise be undecipherable.

A database management system  (DBMS, or database system) Software used to create and manipulate databases. Common database systems include Microsoft Access, Oracle 9i, and MySQL.

A database query  The operation that extracts a recordset from a database. A query consists of search criteria expressed in a database language called SQL. For example, the query can specify that only certain columns or only certain records be included in the recordset.

A dynamic page  A web page customized by an application server before the page is sent to a browser.

A recordset  A set of data extracted from one or more tables in a database, as in the following example:

<table>
<thead>
<tr>
<th>Number</th>
<th>LastName</th>
<th>FirstName</th>
<th>Position</th>
<th>Goals</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A recordset

A relational database  A database containing more than one table, with the tables sharing data. The following database is relational because two tables share the DepartmentID column.
Dynamic sites, pages and web forms

A server technology The technology that an application server uses to modify dynamic pages at runtime.

The Dreamweaver development environment supports the following server technologies:

- Adobe® ColdFusion®
- Microsoft Active Server Pages (ASP)
- PHP: Hypertext Preprocessor (PHP)

You can also use the Dreamweaver coding environment to develop pages for any other server technology not listed.

A static page A web page that is not modified by an application server before the page is sent to a browser. For more information, see Process static web pages.

A web application A website that contains pages with partly or entirely undetermined content. The final content of these pages is determined only when a visitor requests a page from the web server. Because the final content of the page varies from request to request based on the visitor's actions, this kind of page is called a dynamic page.

A web server Software that sends out web pages in response to requests from web browsers. A page request is generated when a visitor clicks a link on a web page in the browser, selects a bookmark in the browser, or enters a URL in the browser's address text box.

Popular web servers include Microsoft Internet Information Server (IIS) and Apache HTTP Server.

Set up your computer for application development

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

What you need to build web applications
To build web applications in Adobe Dreamweaver, you need the following software:

- A web server
- An application server that works with your web server

Note:
In the context of web applications, the terms web server and application server refer to software, not hardware.

- If you want to use a database with your application, you require the following additional software:
  - A database system
• A database driver that supports your database

Several web hosting companies offer plans that let you use their software to test and deploy web applications. In some cases, you can install the required software on the same computer as Dreamweaver for development purposes. You can also install the software on a network computer (typically a Windows 2000 or XP computer) so that other developers on your team can work on a project.

If you want to use a database with your web application, you must first connect to it.

**Web server basics**

To develop and test dynamic web pages, you need a functioning web server. A web server is software that serves web pages in response to requests from web browsers. A web server is sometimes called an HTTP server. You can install and use a web server on your local computer.

If you're a Macintosh user, you can use the Apache web server already installed on your Macintosh.

*Note:*

*Adobe does not provide technical support for third-party software such as Microsoft Internet Information Server. If you need assistance with a Microsoft product, please contact Microsoft technical support.*

If you use Internet Information Server (IIS) to develop web applications, the default name of your web server is the name of your computer. You can change the server name by changing the name of your computer. If your computer has no name, the server uses the word localhost.

The server name corresponds to the server's root folder, which (on a Windows computer) is most likely C:\Inetpub\wwwroot. You can open any web page stored in the root folder by entering the following URL in a browser running on your computer:

http://your_server_name/your_file_name

For example, if the server name is mer_noire and a web page called soleil.html is stored in C:\Inetpub\wwwroot\, you can open the page by entering the following URL in a browser running on the local computer:

http://mer_noire/soleil.html

*Note:*

*Remember to use forward slashes, not backslashes, in URLs.*

You can also open any web page stored in any subfolder of the root folder by specifying the subfolder in the URL. For example, suppose the soleil.html file is stored in a subfolder called gamelan, as follows:

C:\Inetpub\wwwroot\gamelan\soleil.html

You can open this page by entering the following URL in a browser running on your computer:

http://mer_noire/gamelan/soleil.html

When the web server is running on your computer, you can replace the server name with localhost. For example, the following URLs open the same page in a browser:

http://mer_noire/gamelan/soleil.html
http://localhost/gamelan/soleil.html

*Note:*

*Another expression you can use instead of the server name or localhost is 127.0.0.1 (for example, http://127.0.0.1/gamelan/soleil.html).*
Choose a web server

To develop and test web applications, you can choose from a number of common web servers including Microsoft Internet Information Server (IIS) and Apache HTTP Server.

If you're not using a web hosting service, choose a web server and install it on your local computer for development purposes. Windows and Macintosh users who want to develop ColdFusion web applications can use the web server included in the developer edition of the ColdFusion 8 application server, which you can install and use for free.

Other Windows users can run a web server on their local computer by installing IIS. This web server may already be installed on your system. Check your folder structure to see if it contains a C:\IIS\Inetpub or D:\IIS\Inetpub folder. IIS creates this folder during installation.

Mac OS users can use the local Apache web server installed with the operating system.

For information on installing and configuring other web servers, see the server vendor's documentation or your system administrator.

Choose an application server

An application server is software that helps a web server process dynamic pages. When choosing an application server, you should consider several factors, including your budget, the server technology you want to use (ColdFusion, ASP, or PHP), and the type of web server.

**Budget** Some vendors sell high-end application servers that are expensive to buy and administer. Others vendors provide easier, more cost-effective solutions (an example is ColdFusion). Some application servers are built into web servers (such as Microsoft IIS) and others can be downloaded for free from the Internet (such as PHP).

**Server technology** Application servers use different technologies. Dreamweaver supports three server technologies: ColdFusion, ASP, and PHP. The following table shows common application servers available for the server technologies supported by Dreamweaver:

<table>
<thead>
<tr>
<th>Server technology</th>
<th>Application server</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion</td>
<td>Adobe ColdFusion 8</td>
</tr>
<tr>
<td>ASP</td>
<td>Microsoft IIS</td>
</tr>
<tr>
<td>PHP</td>
<td>PHP server</td>
</tr>
</tbody>
</table>

To learn more about ColdFusion, select ColdFusion Help from the Help menu.


To learn more about PHP, visit the PHP website at [www.php.net/](http://www.php.net/).

Choose a database

Databases come in many forms depending upon the amount and the complexity of the data they must store. When choosing a database, you should consider several factors, including your budget and the number of users you anticipate will access the database.

**Budget** Some vendors produce high-end application database servers that are expensive to buy and administer. Others vendors provide easier, more cost-effective solutions, such as Microsoft Access or the open-source database MySQL.

**Users** If you anticipate a large user community accessing the site, select a database designed to support your site's intended user base. For websites requiring greater flexibility in their data modeling, and the ability to support large,
concurrent user communities, consider server-based relational databases (typically referred to as RDBMS) like Microsoft SQL Server and Oracle.

**Set up a ColdFusion development environment**

For detailed instructions on setting up a ColdFusion development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_cf.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_cf.html).


*Note:*

_The Developer Edition is for non-commercial use for developing and testing web applications. It is not licensed for deployment. It supports requests from the local host and two remote IP addresses. You can use it to develop and test your web applications as long as you want; the software does not expire. For more information, see ColdFusion help (Help > ColdFusion Help)._

During installation, you can configure ColdFusion to use the web server built into ColdFusion or another web server installed on your system. Generally, it's best to match your development environment to your production environment. Therefore, if you have an existing web server such as Microsoft IIS on your development computer, you may want to use it instead of the built-in ColdFusion web server.

**Set up a PHP development environment**

For detailed instructions on setting up a PHP development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_php.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_php.html).

Editions of the PHP application server exist for Windows, Linux, UNIX, HP-UX, Solaris, and Mac OS X systems. For more information on the application server, see the PHP documentation, which you can also download from the PHP website at [www.php.net/download-docs.php](http://www.php.net/download-docs.php).

**Set up an ASP development environment**

For detailed instructions on setting up an ASP development environment for Dreamweaver on your Windows or Mac computer, see the Adobe website at [www.adobe.com/devnet/dreamweaver/articles/setup_asp.html](http://www.adobe.com/devnet/dreamweaver/articles/setup_asp.html).

To run ASP pages, you need an application server that supports Microsoft Active Server Pages 2.0., such as Microsoft IIS (Internet Information Services), which comes with Windows 2000 and Windows XP Professional. Windows XP Professional users can install and run IIS on their local computer. Macintosh users can use a web hosting service with an ASP plan or install IIS on a remote computer.

**Create a root folder for the application**

After signing up with a web hosting company or setting up the server software yourself, create a root folder for your web application on the computer running the web server. The root folder can be local or remote, depending on where your web server is running.

The web server can serve any file in this folder or in any of its subfolders in response to an HTTP request from a web browser. For example, on a computer running ColdFusion 8, any file in the \ColdFusion8\wwwroot folder or any of its subfolders can be served to a web browser.

The following are the default root folders of selected web servers:
To test the web server, place a test HTML page in the default root folder and attempt to open it by entering the page’s URL in a browser. The URL comprises the domain name and the filename of the HTML page, as follows: www.example.com/testpage.htm.

If the web server is running on your local computer, you can use localhost instead of a domain name. Enter one of the following localhost URLs to match your web server:

<table>
<thead>
<tr>
<th>Web server</th>
<th>Default root folder</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion 8</td>
<td>\ColdFusion8\wwwroot</td>
</tr>
<tr>
<td>IIS</td>
<td>\inetpub\wwwroot</td>
</tr>
<tr>
<td>Apache (Windows)</td>
<td>\apache\htdocs</td>
</tr>
<tr>
<td>Apache (Macintosh)</td>
<td>Users:MyUserName:Sites</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Web server</th>
<th>Localhost URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>ColdFusion 8</td>
<td><a href="http://localhost:8500/testpage.htm">http://localhost:8500/testpage.htm</a></td>
</tr>
<tr>
<td>IIS</td>
<td><a href="http://localhost/testpage.htm">http://localhost/testpage.htm</a></td>
</tr>
<tr>
<td>Apache (Windows)</td>
<td><a href="http://localhost:80/testpage.htm">http://localhost:80/testpage.htm</a></td>
</tr>
<tr>
<td>Apache (Macintosh)</td>
<td><a href="http://localhost/~MyUserName/testpage.htm">http://localhost/~MyUserName/testpage.htm</a> (where MyUserName is your Macintosh user name)</td>
</tr>
</tbody>
</table>

Note:

By default the ColdFusion web server runs on port 8500 and the Apache web server for Windows runs on port 80.

If the page doesn’t open as expected, check for the following errors:

- The web server is not started. Consult the web server’s documentation for starting instructions.
- The file does not have an .htm or .html extension.
- You entered the page’s file path (for example, c:\ColdFusion8\wwwroot\testpage.htm), not its URL (for example, http://localhost:8500/testpage.htm), in the browser’s address text box.
- The URL contains a typing mistake. Check for errors and make sure the filename is not followed by a slash, such as http://localhost:8080/testpage.htm/.

After creating a root folder for your application, define a Dreamweaver site to manage your files.

**About defining a Dreamweaver site**

After configuring your system to develop web applications, define a Dreamweaver site to manage your files.

Before you start, make sure you meet the following requirements:

- You have access to a web server. The web server can be running on your local computer, on a remote computer such as a development server, or on a server maintained by a web hosting company.
- An application server is installed and running on the system running your web server.
- You created a root folder for your web application on the system running your web server.

Defining a Dreamweaver site for your web application consists of three steps:

1. Define a local folder
The local folder is the folder you use to store working copies of site files on your hard disk. You can define a local folder for each new web application you create. Defining a local folder also gives you the ability to manage your files and to transfer files to and from your web server easily.

2. Define a remote folder

Define a folder located on the computer running your web server as a Dreamweaver remote folder. The remote folder is the folder you created for your web application on the web server.

3. Define a testing folder

Dreamweaver uses this folder to generate and display dynamic content and connect to databases while you work. The testing server can be your local computer, a development server, a staging server, or a production server. As long as it can process the kind of dynamic pages you plan to develop, the choice doesn’t matter.

After the Dreamweaver site is defined, you can start building your web application.

**Troubleshoot database connections**

*Note:*

The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

**Troubleshoot permissions problems**

One of the most common problems is insufficient folder or file permissions. If your database is located on a Windows 2000 or Windows XP computer and you receive an error message when you try to view a dynamic page in a web browser or in Live view, the error might be due to a permissions problem.

The Windows account attempting to access the database doesn’t have sufficient permissions. The account might be either the anonymous Windows account (by default, IUSR_computername) or a specific user account, if the page has been secured for authenticated access.

You must change the permissions to give the IUSR_computername account the correct permissions so the web server can access the database file. In addition, the folder containing the database file must also have certain permissions set to write to that database.

If the page is meant to be accessed anonymously, give the IUSR_computername account full control to the folder and database file, as described in the procedure below.

Additionally, if the path to the database is being referenced using UNC (\Server\Share), make sure the Share Permissions give the IUSR_computername account full access. This step applies even if the share is on the local web server.

If you copy the database from another location, it may not inherit the permissions from its destination folder and you may have to change the permissions for the database.

**Check or change the database file permissions (Windows XP)**

1. Make sure that you have administrator privileges on the computer.

2. In **Windows Explorer**, locate the database file or the folder containing the database, right-click the file or folder, and select Properties.

Dynamic sites, pages and web forms

Note:
This step applies only if you have an NTFS file system. If you have an FAT file system, the dialog box won’t have a Security tab.

4 If the IUSR_computername account is not listed in the Group or User Names list, click the Add button to add it.
5 In the Select Users or Groups dialog box, click Advanced.
   The dialog box changes to show more options.
6 Click Locations and select the computer’s name.
7 Click Find Now to display a list of account names associated with the computer.
8 Select the IUSR_computername account and click OK; then click OK again to clear the dialog box.
9 To assign the IUSR account full permissions, select Full Control and click OK.

Check or change the database file permissions (Windows 2000)
1 Make sure that you have administrator privileges on the computer.
2 In Windows Explorer, locate the database file or the folder containing the database, right-click the file or folder, and select Properties.
3 Select the Security tab.
   Note:
   This step applies only if you have an NTFS file system. If you have an FAT file system, the dialog box won’t have a Security tab.
4 If the IUSR_computername account is not listed among the Windows accounts in the File Permissions dialog box, click the Add button to add it.
5 In the Select Users, Computers, or Groups dialog box, select the computer name from the Look In menu to display a list of account names associated with the computer.
6 Select the IUSR_computername account and click Add.
7 To assign the IUSR account full permissions, select Full Control from the Type Of Access menu and click OK.
   For added security, permissions can be set so that Read permission is disabled for the web folder containing the database. Browsing the folder won’t be permitted, but web pages will still be able to access the database.
   For more information about the IUSR account and web server permissions, see the following TechNotes on the Adobe Support Center:
   • Understanding anonymous authentication and the IUSR account at www.adobe.com/go/authentication
   • Setting IIS web server permissions at www.adobe.com/go/server_permissions

Troubleshoot Microsoft error messages
These Microsoft error messages can occur when you request a dynamic page from the server if you use Internet Information Server (IIS) with a Microsoft database system such as Access or SQL Server.

Note:
Adobe does not provide technical support for third-party software such as Microsoft Windows, and IIS. If this information does not fix your problem, please contact Microsoft technical support or visit the Microsoft support website at http://support.microsoft.com/.
For more information on 80004005 errors, see "INFO: Troubleshooting Guide for 80004005 Errors in Active Server Pages and Microsoft Data Access Components (Q306518)," on the Microsoft website at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306518.

**[Reference]80004005—Data sourcename not found and no default driver specified**

This error occurs when you attempt to view a dynamic page in a web browser or in Live view. The error message may vary depending on your database and web server. Other variations of the error message include:

- 80004005—Driver's SQLSetConnectAttr failed
- 80004005—General error unable to open registry key 'DriverId'

Here are possible causes and solutions:

- The page can't find the DSN. Make sure a DSN has been created on both the web server and on the local machine.
- The DSN might have been set up as a user DSN, not as a system DSN. Delete the user DSN and create a system DSN to replace it.

*Note:*

*If you don't delete the user DSN, the duplicate DSN names produce a new ODBC error.*

If you use Microsoft Access, the database file (.mdb) might be locked. The lock might be due to a DSN with a different name accessing the database. In **Windows Explorer**, search for the lock file (.ldb) in the folder containing the database file (.mdb) and delete the .ldb file. If another DSN is pointing to the same database file, delete the DSN to prevent the error in the future. Reboot the computer after making any changes.

**[Reference]80004005—Couldn't use'(unknown)'; file already in use**

This error occurs when you use a Microsoft Access database and attempt to view a dynamic page in a web browser or in Live view. Another variation of this error message is "80004005—Microsoft Jet database engine cannot open the file (unknown)."

The probable cause is a permissions problem. Here are some specific causes and solutions:

- The account being used by Internet Information Server (usually IUSR) might not have the correct Windows permissions for a file-based database or for the folder containing the file. Check the permissions on the IIS account (IUSR) in the user manager.
- You might not have permission to create or destroy temporary files. Check the permissions on the file and the folder. Make sure that you have permission to create or destroy any temporary files. Temporary files are usually created in the same folder as the database, but the file may also be created in other folders such as /Winnt.
- In Windows 2000, the time-out value may need to be changed for the Access database DSN. To change the time-out value, select **Start > Settings > Control Panel > Administrative Tools > Data Sources (ODBC)**. Click the System tab, highlight the correct DSN, and click the Configure button. Click the Options button and change the Page Timeout value to 5000.

If you still have problems, see the following Microsoft Knowledge Base articles:

[[Reference]80004005—Logon Failed()]
This error occurs when you use Microsoft SQL Server and attempt to view a dynamic page in a web browser or in Live view.

This error is generated by SQL Server if it doesn't accept or recognize the logon account or password being submitted (if you're using standard security), or if a Windows account does not map to a SQL account (if you're using integrated security).

Here are possible solutions:

• If you use standard security, the account name and password might be incorrect. Try the system Admin account and password (UID= "sa" and no password), which must be defined in the connection string line. (DSNs do not store user names and passwords.)
• If you use integrated security, check the Windows account calling the page and find its mapped SQL account (if any).
• SQL Server does not allow an underscore in SQL account names. If someone manually maps the Windows IUSR_machinename account to a SQL account of the same name, it will fail. Map any account that uses an underscore to an account name on SQL that does not use an underscore.

[[Reference]8004005—Operation must use an updateable query]
This error occurs when an event is updating a recordset or inserting data in a recordset.

Here are possible causes and solutions:

• The permissions set on the folder containing the database are too restrictive. IUSR privileges must be set to read/write.
• The permissions on the database file itself does not have full read/write privileges in effect.
• The database might be located outside the Inetpub/wwwroot directory. Though you can view and search the data, you might not be able to update it unless the database is located in the wwwroot directory.
• The recordset is based on a non-updateable query. Joins are good examples of non-updateable queries within a database. Restructure your queries so they are updateable.

For more information on this error, see “PRB: ASP 'Error The Query Is Not Updateable' When You Update Table Record,” in the Microsoft Knowledge Base at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q174640.

[[Reference]80040e07—Data type mismatch in criteria expression]
This error occurs when the server tries to process a page containing an Insert Record or Update Record server behavior, and the server behavior attempts to set the value of a Date/Time column in a Microsoft Access database to an empty string ("").

Microsoft Access has strong data typing; it imposes a rigorous set of rules on given column values. The empty string value in the SQL query cannot be stored in an Access Date/Time column. Currently, the only known workaround is to avoid inserting or updating Date/Time columns in Access with empty strings ("") or with any other value that does not correspond to the range of values specified for the data type.

[[Reference]80040e10—Too few parameters]
This error occurs when a column specified in your SQL query does not exist in the database table. Check the column names in your database table against the SQL query. The cause of this error is often a typographical error.
Dynamic sites, pages and web forms

[[Reference]80040e10—COUNT fieldincorrect]
This error occurs when you preview a page containing an Insert Record server behavior in a web browser and try to use it to insert a record in a Microsoft Access database.

You might be trying to insert a record into a database field that has a question mark (?) in its field name. The question mark is a special character for some database engines, including Microsoft Access, and should not be used for database table names or field names.

Open your database system and delete the question mark (?) from the field names, and update the server behaviors on your page that refer to this field.

[[Reference]80040e14—Syntax errorin INSERT INTO statement]
This error occurs when the server tries to process a page containing an Insert Record server behavior.

This error typically results from one or more of the following problems with the name of a field, object, or variable in the database:

- Using a reserved word as a name. Most databases have a set of reserved words. For example, “date” is a reserved word and cannot be used for column names in a database.
- Using special characters in the name. Examples of special characters include: . / * : ! # & - ?
- Using a space in the name.

The error can also occur when an input mask is defined for an object in the database, and the inserted data does not conform to the mask.

To fix the problem, avoid using reserved words such as “date”, “name”, “select”, “where,” and “level” when specifying column names in your database. Also, eliminate spaces and special characters.

See the following web pages for lists of reserved words for common database systems:

- Microsoft Access at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q209187

[[Reference]80040e21—ODBC erroron Insert or Update]
This error occurs when the server tries to process a page containing an Update Record or Insert Record server behavior. The database cannot handle the update or insert operation the server behavior is trying to perform.

Here are possible causes and solutions:

- The server behavior is trying to update a database table’s auto-number field or to insert a record into an auto-number field. Because auto-number fields are populated automatically by the database system, any attempt to externally populate them with a value fails.
- The data the server behavior is updating or inserting is the wrong type for the database field, such as inserting a date into a Boolean (yes/no) field, inserting a string into a numeric field, or inserting an improperly formatted string into Date/Time field.

[[Reference]800a0bcd—Either BOFor EOF is true]
This error occurs when you attempt to view a dynamic page in a web browser or in Live view.
The problem occurs when the page tries to display data from an empty recordset. To solve the problem, apply the Show Region server behavior to the dynamic content to be displayed on the page, as follows:

1. Highlight the dynamic content on the page.
2. In the Server Behaviors panel, click the Plus (+) button and select Show Region > Show Region If Recordset Is Not Empty.
3. Select the recordset supplying the dynamic content and click OK.
4. Repeat steps 1 to 3 for each element of dynamic content on the page.

Troubleshoot MySQL error messages

One common error message that you might encounter when testing a PHP database connection to MySQL 4.1 is “Client does not support authentication protocol requested. Consider upgrading MySQL client.”

You may have to revert to an earlier version of MySQL, or install PHP 5 and copy some dynamic link libraries (DLLs). For detailed instructions, see Set up a PHP development environment.

Removing connection scripts in Dreamweaver

*Note:*

*The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.*

**Use the Remove Connection Scripts command**

You can use the Remove Connection Scripts command to remove scripts that Dreamweaver places in a remote folder to access databases. These scripts are only needed for design-time authoring in Dreamweaver.

When you select the Using Driver On Testing Server option or the Using DSN On Testing Server option in the Database Connections dialog box, Dreamweaver uploads an MMHTTPDB script file to the testing server. This allows Dreamweaver to manipulate the remote database driver with the HTTP protocol, which in turn allows Dreamweaver to get the database information it needs to help you create your site. However, this file does make it possible to see the data source names (DSNs) defined on the system. If the DSNs and databases are not password protected, the script also enables an attacker to issue SQL commands to the database.

The MMHTTPDB script files are located in the _mmServerScripts folder, which is located in the root of your website.

*Note:*

*The Dreamweaver file browser (the Files panel) hides the _mmServerScripts folder. You can see the _mmServerScripts folder if you use a third-party FTP client or the file browser.*

In some configurations these scripts are not necessary at all. The scripts are not involved when serving web pages to visitors to your website, so they should not be placed on a production server.

If you’ve uploaded the MMHTTPDB scripts file to a production server, you should delete the MMHTTPDB scripts file. The Remove Connection Scripts command automatically removes the script files for you.
Design dynamic pages

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

Prerequisites to building dynamic websites

Before you begin building dynamic web pages, there are a few preparations that must be done, including setting up a web application server and connecting to a database for Coldfusion, ASP, and PHP applications. Adobe Dreamweaver handles database connections differently depending on your server technology.

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

Dreamweaver and dynamic page design

Follow these general steps to successfully design and create a dynamic website.

1 Design the page.

A key step in designing any website—whether static or dynamic—is the visual design of the page. When adding dynamic elements to a web page, the design of the page becomes crucial to its usability. You should carefully consider how users will interact with both individual pages and the website as a whole.

A common method of incorporating dynamic content into a web page is to create a table to present content, and import dynamic content into one or more of the table's cells. Using this method you can present information of various types in a structured format.

2 Create a source of dynamic content.

Dynamic websites require a content source from which to extract data before they can display it on a web page. Before you can use content sources in a web page, you must do the following:

- Create a connection to the dynamic content source (such as a database) and the application server processing the page. Create the data source by using the Bindings panel; then you can select and insert the data source in the page.
- Specify what information in the database you want to display, or what variables to include in the page by creating a recordset. You can also test the query from within the Recordset dialog box, and make any needed adjustments before adding it to the Bindings panel.
- Select and insert dynamic content elements into the selected page.

3 Add dynamic content to a web page.

After you define a recordset or other data source, and add it to the Bindings panel, you can insert the dynamic content the recordset represents into the page. The Dreamweaver menu-driven interface makes adding dynamic content elements as easy as selecting a dynamic content source from the Bindings panel, and inserting it into an appropriate text, image, or form object within the current page.
When you insert a dynamic content element or other server behavior into a page, Dreamweaver inserts a server-side script into the page's source code. This script instructs the server to retrieve data from the defined data source and render it within the web page. To place dynamic content within a web page, you can do one of the following:

- Place it at the insertion point in either Code or Design view.
- Replace a text string or other placeholder.

Insert it into an HTML attribute. For example, dynamic content can define the `src` attribute of an image or the value attribute of a form field.

4 Add server behaviors to a page.

In addition to adding dynamic content, you can incorporate complex application logic into web pages by using server behaviors. *Server behaviors* are predefined pieces of server-side code that add application logic to web pages, providing greater interaction and functionality.

The Dreamweaver server behaviors let you add application logic to a website without having to write the code yourself. The server behaviors supplied with Dreamweaver support ColdFusion, ASP, and PHP document types. The server behaviors are written and tested to be fast, secure, and robust. The built-in server behaviors support cross-platform web pages for all browsers.

Dreamweaver provides a point-and-click interface that makes applying dynamic content and complex behaviors to a page as easy as inserting textual and design elements. The following server behaviors are available:

- Define a recordset from an existing database. The recordset you define is then stored in the Bindings panel.
- Display multiple records on a single page. You select either an entire table or individual cells or rows that contain dynamic content, and specify the number of records to display on each page view.
- Create and insert a dynamic table into a page, and associate the table with a recordset. You can later modify both the table’s appearance and the repeating region by using the Property inspector and Repeating Region Server Behavior, respectively.
- Insert a dynamic text object into a page. The text object you insert is an item from a predefined recordset, to which you can apply any of the data formats.
- Create record navigation and status controls, master/detail pages, and forms for updating information in a database.
- Display more than one record from a database record.
- Create recordset navigation links that allow users to view the previous or next records from a database record.
- Add a record counter to help users keep track of how many records were returned, and where they are in the returned result.

You can also extend Dreamweaver server behaviors by writing your own, or installing server behaviors written by third parties.

5 Test and debug the page.

Before making a dynamic page—or an entire website—available on the web, you should test its functionality. You should also consider how your application’s functionality might affect people with disabilities.

---

**Dynamic content sources overview**

*Note:*

Last updated 11/7/2019
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About dynamic content sources

A dynamic content source is a store of information from which you can retrieve and display dynamic content for use in a web page. Sources of dynamic content include not only information stored in a database, but values submitted by HTML forms, values contained in server objects, and other content sources.

Dreamweaver lets you easily connect to a database and create a recordset from which to extract dynamic content. A recordset is the result of a database query. It extracts the specific information you request and allows you to display that information within a specified page. You define the recordset based on the information contained in the database and the content you want to display.

Different technology vendors may use different terminology for a recordset. In ASP and ColdFusion, a recordset is defined as a query. If you are using other sources of data, such as user input or server variables, the name of the data source that is defined in Dreamweaver is the same as the data source name itself.

Dynamic websites require a data source from which to retrieve and display dynamic content. Dreamweaver lets you use databases, request variables, URL variables, server variables, form variables, stored procedures, and other sources of dynamic content. Depending on the data source, you can either retrieve new content to satisfy a request, or modify the page to meet the needs of users.

Any content source that you define in Dreamweaver is added to the list of content sources in the Bindings panel. Then you can insert the content source into the currently selected page.

About recordsets

Web pages can't directly access the data stored in a database. Instead, they interact with a recordset. A recordset is a subset of the information (records), extracted from the database using a database query. A query is a search statement designed to find and extract specific information from a database.

When using a database as a content source for a dynamic web page, you must first create a recordset in which to store the retrieved data. Recordsets serve as an intermediary between the database storing the content and the application server generating the page. Recordsets are temporarily stored in the application server's memory for faster data retrieval. The server discards the recordset when it is no longer needed.

A query can produce a recordset that includes only certain columns, only certain records, or a combination of both. A recordset can also include all the records and columns of a database table. However, because applications rarely need to use every piece of data in a database, you should strive to make your recordsets as small as possible. Because the web server temporarily holds the recordset in memory, using a smaller recordset uses less memory, and can potentially improve server performance.

Database queries are written in Structured Query Language (SQL, pronounced "sequel"), a simple language that allows you to retrieve, add, and delete data to and from a database. The SQL builder included with Dreamweaver lets you create simple queries without having to understand SQL. However, if you want to create complex SQL queries, a basic knowledge of this language lets you create more advanced queries, and provides you with greater flexibility in designing dynamic pages.

Before you define a recordset for use with Dreamweaver, you must create a connection to a database and—if no data exists yet—enter data into the database. If you have not yet defined a database connection for your site, refer to the database connection chapter for the server technology you are developing for, and follow the instructions on creating a database connection.
About URL and form parameters

URL parameters store retrieved information input by users. To define a URL parameter you create a form or hypertext link that uses the GET method to submit data. The information is appended to the URL of the requested page and communicated to the server. When using URL variables, the query string contains one or more name-value pairs that are associated with the form fields. These name-value pairs are appended to the URL.

Form parameters store retrieved information that is included in the HTTP request for a web page. If you create a form that uses the POST method, the data submitted by the form is passed to the server. Before you begin, make sure you pass a form parameter to the server.

About session variables

Session variables let you store and display information maintained for the duration of a user's visit (or session). The server creates a different session object for each user and maintains it for a set period of time or until the object is explicitly terminated.

Because session variables last throughout the user's session and persist when the user moves from page to page within the website, they're ideal for storing user preferences. Session variables can also be used for inserting a value in the page's HTML code, assigning a value to a local variable, or providing a value to evaluate a conditional expression.

Before defining session variables for a page, you must create them in the source code. After you create a session variable in the web application's source code, you can use Dreamweaver to retrieve its value and use it in a web page.

How session variables work

Session variables store information (usually form or URL parameters submitted by users) and make it available to all of a web application's pages for the duration of the user's visit. For example, when users log on to a web portal that provides access to e-mail, stock quotes, weather reports, and daily news, the web application stores the login information in a session variable that identifies the user throughout the site's pages. This allows the user to see only the types of content they have selected as they navigate through the site. Session variables can also provide a safety mechanism by terminating the user's session if the account remains inactive for a certain period of time. This also frees server memory and processing resources if the user forgets to log off a website.

Session variables store information for the life of the user session. The session begins when the user opens a page within the application and ends when the user does not open another page in the application for a certain period of time, or when the user explicitly terminates the session (typically by clicking a “log-off” link). While it exists, the session is specific to an individual user, and every user has a separate session.

Use session variables to store information that every page in a web application can access. The information can be as diverse as the user's name, preferred font size, or a flag indicating whether the user has successfully logged in. Another common use of session variables is to keep a running tally, such as the number of questions answered correctly so far in an online quiz, or the products the user selected so far from an online catalog.

Session variables can only function if the user's browser is configured to accept cookies. The server creates a session ID number that uniquely identifies the user when the session is first initiated, then sends a cookie containing the ID number to the user's browser. When the user requests another page on the server, the server reads the cookie in the browser to identify the user and to retrieve the user's session variables stored in the server's memory.

Collecting, storing, and retrieving information in session variables

Before creating a session variable, you must first obtain the information you want to store, and then send it to the server for storage. You can gather and send information to the server using HTML forms or hypertext links containing URL parameters. You can also obtain information from cookies stored on the user's computer, from the HTTP headers sent by the user's browser with a page request, or from a database.
A typical example of storing URL parameters in session variables is a product catalog that uses hard-coded URL parameters created using a link to send product information back to the server to be stored in a session variable. When a user clicks the “Add to shopping cart” link, the product ID is stored in a session variable while the user continues to shop. When the user proceeds to the check-out page, the product ID stored in the session variable is retrieved.

A form-based survey is a typical example of a page that stores form parameters in session variables. The form sends the selected information back to the server, where an application page scores the survey and stores the responses in a session variable to be passed to an application that might tally up the responses gathered from the survey population. Or the information might be stored in a database for later use.

After information is sent to the server, you store the information in session variables by adding the appropriate code for your server model to the page specified by the URL or form parameter. Referred to as the destination page, this page is specified in either the action attribute of the HTML form or the href attribute of the hypertext link on the starting page.

After you store a value in a session variable, you can use Dreamweaver to retrieve the value from session variables and use it in a web application. After you define the session variable in Dreamweaver, you can insert its value in a page.

The HTML syntax for each appears as follows:

```html
<form action="destination.html" method="get" name="myform"> </form>
<param name="href" value="destination.html">
```

Both the server technology used and the method you use to obtain the information determines the code used to store the information in a session variable. The basic syntax for each server technology is as follows:

**ColdFusion**

```coldfusion
<CFSET session.variable_name = value>
```

**ASP**

```asp
<% Session("variable_name") = value %>
```

The value expression is usually a server expression such as `Request.Form(“lastname”)`. For example, if you use a URL parameter called `product` (or an HTML form with the GET method and a text field called `product`) to gather information, the following statements store the information in a session variable called `prodID`:

**ColdFusion**

```coldfusion
<CFSET session.prodID = url.product>
```

**ASP**

```asp
<% Session("prodID") = Request.QueryString("product") %>
```

If you use an HTML form with the post method and a text field called `txtProduct` to gather the information, then the following statements store the information in the session variable:

**ColdFusion**

```coldfusion
<CFSET session.prodID = form.txtProduct>
```

**ASP**

```asp
<% Session("prodID") = Request.Form("txtProduct") %>
```

**Example of information stored in session variables**

You’re working on a site with a large audience of senior citizens. In Dreamweaver, add two links to the Welcome screen that let users customize the size of the site’s text. For larger, easy-to-read text, the user clicks one link, and for regular-size text, the user clicks another link.
Dynamic sites, pages and web forms

Information stored in session variables

Each link has a URL parameter called `fontsize` that submits the user’s text preference to the server, as the following Adobe ColdFusion® example shows:

```
<a href="resort.cfm?fontsize=large">Larger Text</a>
<a href="resort.cfm?fontsize=small">Normal Text</a>
```

Store the user’s text preference in a session variable and use it to set the font size on each page the user requests.

Near the top of the destination page, enter the following code to create a session called `font_pref` that stores the user’s font size preference.

**ColdFusion**

```
<CFSET session.font_pref = url.fontsize>
```

**ASP**

```
<% Session("font_pref") = Request.QueryString("fontsize") %>
```

When the user clicks the hypertext link, the page sends the user’s text preference in a URL parameter to the destination page. The code on the destination page stores the URL parameter in the `font_pref` session variable. For the duration of the user’s session, all the pages of the application retrieve this value and display the selected font size.

**ASP and ColdFusion application variables**

In ASP and ColdFusion, you can use application variables to store and display information that is maintained for the lifetime of the application and persists from user to user. The application’s lifetime lasts from the time the first user requests a page in the application to the time the web server is stopped. (An application is defined as all the files in a virtual directory and its subdirectories.)

Because application variables last for the lifetime of the application, and persist from user to user, they’re ideal for storing information that must exist for all users, such as the current time and date. The value of the application variable is defined in the application’s code.

**ASP server variables**

You can define the following ASP server variables as sources of dynamic content: `Request.Cookie`, `Request.QueryString`, `Request.Form`, `Request.ServerVariables`, and `Request.ClientCertificates`. 
ColdFusion server variables
You can define the following ColdFusion server variables:

**Client variables**  Associate data with a specific client. Client variables maintain the application's state as the user moves from page to page in the application, as well as from session to session. “Maintaining state” means to preserve information from one page (or session) to the next so that the application remembers the user, and the user's previous choices and preferences.

**Cookie variables**  Access cookies passed to the server by the browser.

**CGI variables**  Provide information about the server running ColdFusion, the browser requesting a page, and other information about the processing environment.

**Server variables**  Can be accessed by all clients and applications on the server. They persist until the server is stopped.

**Local variables**  Created with the **CFSET** tag or **CFPARAM** tag within a ColdFusion page.

Define sources of dynamic content

*Note:*

*The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.*

Define a recordset without writing SQL
You can create a recordset without manually entering SQL statements.

1. In the Document window, open the page that will use the recordset.
2. Select Windows > Bindings to display the Bindings panel.
3. In the Bindings panel, click the Plus (+) button and select Recordset (Query) from the pop-up menu.
   
   The simple Recordset dialog box appears. If you are developing a ColdFusion site, the Recordset dialog box is slightly different. (If the advanced Recordset dialog appears instead, click the Simple button to switch to the simple Recordset dialog box.)
4. Complete the Recordset dialog box for your document type.
   
   For instructions, see the topics below.
5. Click the Test button to execute the query and ensure that it retrieves the information you intended.
   
   If you defined a filter that uses parameters input by users, enter a value in the Test Value box, and click OK. If an instance of the recordset is successfully created, a table appears that displays data extracted from the recordset.
6. Click OK to add the recordset to the list of available content sources in the Bindings panel.

Options for the simple Recordset dialog box (PHP, ASP)

1. In the Name box, enter a name for the recordset.
   
   A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in the code, for example: `rsPressReleases`.

   Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.
2. Select a connection from the Connection pop-up menu.
   If no connection appears in the list, click Define to create one.

3. In the Table pop-up menu, select the database table that will provide data to the recordset.
   The pop-up menu displays all tables in the specified database.

4. To include a subset of the table’s columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

5. To further limit the records returned from the table, complete the Filter section:
   • From the first pop-up menu, select a column in the database table to compare against a test value you define.
   • From the second pop-up menu, select a conditional expression to compare the selected value in each record against the test value.
   • From the third pop-up menu, select Entered Value.
   • In the box, enter the test value.
     If the specified value in a record meets your filtering condition, the record is included the recordset.

6. (Optional) To sort the records, select a column to sort by, and then specify whether the records should be sorted in ascending order (1, 2, 3... or A, B, C...) or descending order.

7. Click Test to connect to the database and create an instance of the data source, and click OK to close the data source.
   A table appears displaying the returned data. Each row contains a record and each column represents a field in that record.

8. Click OK. The newly defined recordset appears in the Bindings panel.

Options for the simple Recordset dialog box (ColdFusion)
Define a recordset for ColdFusion document types as a source of dynamic content without you having to hand code SQL statements.

1. In the Name box, enter a name for the recordset.
   A common practice is to add the prefix rs to recordset names to distinguish them from other object names in your code. For example: rsPressReleases
   Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

2. If you’re defining a recordset for a ColdFusion component (that is, if a CFC file is currently open in Dreamweaver), select an existing CFC function from the Function pop-up menu, or click the New Function button to create a new function.
   Note:
   The Function pop-up menu is only available if a CFC file is the current document and you have access to a computer running ColdFusion MX 7 or better.
   The recordset is defined in the function.

3. Select a data source from the Data Source pop-up menu.
   If no data source appears in the pop-up menu, you must create a ColdFusion data source.

4. In the Username and Password boxes, enter the user name and password for the ColdFusion application server if required.
Data sources in ColdFusion may require a user name and password to access them. If you do not have the user name and password to access a data source in ColdFusion, contact your organization's ColdFusion administrator.

5 In the Table pop-up menu, select the database table that will provide data to the recordset.
   The Table pop-up menu displays all tables in the specified database.

6 To include a subset of the table's columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

7 To further limit the records returned from the table, complete the Filter section:
   - From the first pop-up menu, select a column in the database table to compare against a test value you define.
   - From the second pop-up menu, select a conditional expression to compare the selected value in each record against the test value.
   - From the third pop-up menu, select Entered Value.
   - In the box, enter the test value.
   If the specified value in a record meets your filtering condition, the record is included in the recordset.

8 (Optional) To sort the records, select a column to sort by, and then specify whether the records should be sorted in ascending (1, 2, 3... or A, B, C...) or descending order.

9 Click Test to connect to the database and create an instance of the data source.
   A table appears displaying the returned data. Each row contains a record and each column represents a field in that record. Click OK to close the test recordset.

10 Click OK. The newly defined ColdFusion recordset appears in the Bindings panel.

Define an advanced recordset by writing SQL

Write your own SQL statements by using the advanced Recordset dialog box, or create a SQL statement by using the graphical Database Items tree.

1 In the Document window, open the page that will use the recordset.

2 Select Windows > Bindings to display the Bindings panel.

3 In the Bindings panel, click the Plus (+) button and select Recordset (Query) from the pop-up menu.
   The advanced Recordset dialog box appears. If you are developing a ColdFusion site, the Recordset dialog box is slightly different. (If the simple Recordset dialog box appears instead, switch to the advanced Recordset dialog box by clicking the Advanced button.)

4 Complete the advanced Recordset dialog box.
   For instructions, see the topics below.

5 Click the Test button to execute the query and ensure that it retrieves the information you intended.
   If you defined a filter that uses parameters input by users, the Test button displays the Test Value dialog box. Enter a value in the Test Value box and click OK. If an instance of the recordset is successfully created, a table displaying the data from the recordset appears.

6 Click OK to add the recordset to the list of available content sources in the Bindings panel.
Options for the advanced Recordset dialog box (PHP, ASP)

Define a recordset as a source of dynamic content by writing a custom SQL statement, or by creating a SQL statement using the graphical Database Items tree.

1. In the Name box, enter a name for the recordset.

   A common practice is to add the prefix `rs` to recordset names to distinguish them from other object names in the code. For example: `rsPressRelease`

   Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

2. Select a connection from the Connection pop-up menu.

3. Enter a SQL statement in the SQL text area or use the graphical Database Items tree at the bottom of the dialog box to build a SQL statement from the chosen recordset.

   Do the following to use the Database Items tree to build the SQL statement:

   - Ensure the SQL text area is blank.
   - Expand the branches of the tree until you find the database object you need—a column in a table, for example, or a stored procedure in the database.
   - Select the database object and click one of the buttons on the right side of the tree.

     For example, if you select a table column, the available buttons are SELECT, WHERE, and ORDER BY. Click one of the buttons to add the associated clause to your SQL statement.

     You can also use a predefined SQL statement in a stored procedure by selecting the stored procedure from the Database Items tree and clicking the Procedure button. Dreamweaver automatically fills in the SQL and Variable areas.

4. If the SQL statement contains variables, define their values in the Variables area by clicking the Plus (+) button and entering the variable's name, type (integer, text, date, or floating point number), default value (the value the variable should take if no run-time value is returned), and run-time value.

   **Note:**

   When using variables in a SQL statement in PHP, Dreamweaver automatically adds a leading dollar sign to the variable name, so you should omit the dollar sign (e.g., `colname`, instead of `$colname`).

   If the SQL statement contains variables, make sure the Default Value column of the Variables box contains valid test values.

   The run-time value is usually a URL or form parameter entered by a user in an HTML form field.

   **URL parameters in the Run-time Value column:**

<table>
<thead>
<tr>
<th>Server Model</th>
<th>Run-Time value expression for URL parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request.QueryString(&quot;formFieldName&quot;)</td>
</tr>
<tr>
<td>PHP</td>
<td>$_GET[&quot;formFieldName&quot;]</td>
</tr>
</tbody>
</table>

   **Form parameters in the Run-time Value column:**
Dynamic sites, pages and web forms

5 Click Test to connect to the database and create an instance of the recordset.

If the SQL statement contains variables, make sure the Default Value column of the Variables box contains valid test values before clicking Test.

If successful, a table appears displaying the data in your recordset. Each row contains a record and each column represents a field in that record. Click OK to clear the recordset.

6 If satisfied with your work, click OK.

Options for the advanced Recordset dialog box (ColdFusion)

Use the advanced Recordset dialog box to write custom SQL queries, or use the Database Items tree to author SQL queries using a point-and-click interface.

1 In the Name box, enter a name for the recordset.

A common practice is to add the prefix rs to recordset names to distinguish them from other object names in your code. For example: rsPressReleases

Recordset names can only contain letters, numbers, and the underscore character (_). You cannot use special characters or spaces.

If you’re defining a recordset for a ColdFusion component (that is, if a CFC file is currently open in Dreamweaver), select an existing CFC function from the Function pop-up menu, or click the New Function button to create a new function.

Note:

The Function pop-up menu is only available if a CFC file is the current document and you have access to a computer running ColdFusion MX 7 or better.

The recordset is defined in the function.

2 Select a data source from the Data Source pop-up menu.

If no data source appears in the pop-up menu list, you will need to first create a ColdFusion data source.

3 In the Username and Password boxes, enter the user name and password for the ColdFusion application server if required.

Data sources in ColdFusion may require a user name and password to access them. If you do not have the user name and password to access a data source in ColdFusion, contact your organization’s ColdFusion administrator.

4 Enter a SQL statement in the SQL text area or use the graphical Database Items tree at the bottom of the dialog box to build a SQL statement from the chosen recordset.

5 (Optional) Do the following to use the Database Items tree to build the SQL statement:

- Ensure the SQL text area is blank.
- Expand the branches of the tree until you find the database object you need—for example, a column in a table.
- Select the database object and click one of the buttons on the right side of the tree.

For example, if you select a table column, the available buttons are Select, Where, and Order By. Click one of the buttons to add the associated clause to your SQL statement.
If your SQL statement contains parameters, define their values in the Parameters area by clicking the Plus (+) button and entering the parameter's name and default value (the value the parameter should take if no run-time value is returned).

If the SQL statement contains parameters, make sure the Default Value column of the Parameters box contains valid test values.

The Page Parameters allow you to provide default values for run-time value references in the SQL you write. For example, the following SQL statement selects an employee record based on the value of the employee's ID. You can assign a default value to this parameter, ensuring that a run-time value is always returned. In this example, `FormFieldName` refers to a form field in which the user enters an employee ID:

```
SELECT * FROM Employees WHERE EmpID = + (Request.Form(#FormFieldName#))
```

The Add Page Parameters dialog box would contain a name-value pairing similar to:

<table>
<thead>
<tr>
<th>Name</th>
<th>Default values</th>
</tr>
</thead>
<tbody>
<tr>
<td>FormFieldName</td>
<td>0001</td>
</tr>
</tbody>
</table>

The run-time value is usually a URL or form parameter entered by a user in an HTML form field.

6. Click Test to connect to the database and create an instance of the recordset.

   If the SQL statement contains run-time references, make sure the Default Value column of the Page Parameters field contains valid test values before clicking Test.

   If successful, a table appears displaying the data in your recordset. Each row contains a record and each column represents a field in that record. Click OK to clear the recordset.

7. If satisfied with your work, click OK.

**Define parameters in a SQL statement (ColdFusion)**

Define parameters in a SQL statement; the default value is the value that the parameter should use if no run-time value is returned.

1. Select a parameter name from the Name pop-up menu.

2. Enter a default value for the parameter in the Default Parameter box, and click OK.

**Define parameters in a SQL statement (PHP)**

Define parameters in a SQL statement; the default value is the value that the parameter should use if no run-time value is returned.

1. Enter a parameter name in the Name box.

2. Enter a default value for the parameter in the Default Parameter box.

3. Enter a run-time value for a parameter in the Run-time Value box, and click OK.

**Create SQL queries using the Database Items tree**

Instead of manually typing SQL statements into the SQL box, you can use the Database Item's point-and-click interface to create complex SQL queries. The Database Items tree lets you select database objects and link them using the SQL SELECT, WHERE, and ORDER BY clauses. After you create a SQL query, you can define any variables using the Variables area of the dialog box.
The next two examples describe two SQL statements and the steps for creating them using the advanced Recordset dialog box's Database Items tree.

**Example: Selecting a table**

This example selects the entire contents of the Employees table. The SQL statement defining the query appears as follows:

```
SELECT * FROM Employees
```

To create this query, follow these steps:

1. Expand the Tables branch to display all of the tables in the selected database.
2. Select the Employees table.
3. Click the Select button.
4. Click OK to add the recordset to the Bindings panel.

**Example: Selecting specific rows from a table and ordering the results**

The following example selects two rows from the Employees table, and selects the job type using a variable that you must define. The results are then ordered by employee name.

```
SELECT emplNo, emplName 
FROM Employees
WHERE emplJob = 'varJob'
ORDER BY emplName
```

1. Expand the Tables branch to display all of the tables in the selected database; then expand the Employees table to display the individual table rows.
2. Build the SQL statement as follows:
   - Select emplNo, and click the Select button.
   - Select emplName, and click the Select button.
   - Select emplJob, and click the Where button.
   - Select emplName, and click the Order By button.
3. Place the insertion point after WHERE emplJob in the SQL text area and type = 'varJob' (include the equal sign).
4. Define the variable 'varJob' by clicking the Plus (+) button in the Variables area and entering the following values in the Name, Default Value, and Run-Time Value columns: varJob, CLERK, Request("job").
5. Click OK to add the recordset to the Bindings panel.

**Define URL parameters**

URL parameters store retrieved information input by users. Before you begin, make sure you pass a form or URL parameter to the server. After you define the URL variable, you can use its value in the currently selected page.

1. In the Document window, open the page that will use the variable.
2. Select Windows > Bindings to display the Bindings panel.
3. In the Bindings panel, click the Plus (+) button and select one of the following from the pop-up menu:
In the URL Variable dialog box, enter the name of the URL variable in the box, and click OK. The URL variable name is normally the name of the HTML form field or object used to obtain its value.

The URL variable appears in the Bindings panel.

Define form parameters
Form parameters store retrieved information that is included in the HTTP request for a web page. If you create a form that uses the POST method, the data submitted by the form is passed to the server. Before you begin, make sure you pass a form parameter to the server. After you define the form parameter as a content source, you can use its value in your page.

1 In the Document window, open the page that will use the variable.
2 Select Windows > Bindings to display the Bindings panel.
3 In the Bindings panel, click the Plus (+) button and select one of the following from the pop-up menu:

<table>
<thead>
<tr>
<th>Document Types</th>
<th>Menu item in Bindings panel for form variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASP</td>
<td>Request Variable &gt; Request.Form</td>
</tr>
<tr>
<td>ColdFusion</td>
<td>Form Variable</td>
</tr>
<tr>
<td>PHP</td>
<td>Form Variable</td>
</tr>
</tbody>
</table>

4 In the Form Variable dialog box, enter the name of the form variable, and click OK. The form parameter name is normally the name of the HTML form field or object used to obtain its value.

The form parameter appears in the Bindings panel.

Define session variables
You can use session variables to store and display information maintained for the duration of a user's visit (or session). The server creates a different session object for each user and maintains it for a set period of time or until the object is explicitly terminated.
Before defining session variables for a page, you must create them in the source code. After you create a session variable in the web application's source code, you can use Dreamweaver to retrieve its value and use it in a web page.

1. Create a session variable in the source code, and assign a value to it.
   For example, this ColdFusion example instantiates a session called `username`, and assigns it the value `Cornelius`:
   ```cfset session.username = Cornelius```

2. Select Window > Bindings to display the Bindings panel.
3. Click the Plus (+) button, and select Session Variable from the pop-up menu.
4. Enter the name of the variable you defined in the application's source code, and click OK.

**Define application variables for ASP and ColdFusion**

In ASP and ColdFusion, you can use application variables to store and display information that is maintained for the lifetime of the application and persists from user to user. After you define the application variable, you can use its value in a page.

*Note:*

*There are no application variable objects in PHP.*

1. Open a dynamic document type in the Document window.
2. Select Window > Bindings to display the Bindings panel.
3. Click the Plus (+) button, and select Application Variable from the pop-up menu.
4. Enter the name of the variable as defined in the application's source code, and click OK.
   The application variable appears in the Bindings panel under the Application icon.

**Use a variable as a data source for a ColdFusion recordset**

When you define a recordset for a page in the Bindings panel, Dreamweaver enters the name of the ColdFusion data source in the `cfquery` tag on the page. For more flexibility, you can store a data source name in a variable and use the variable in the `cfquery` tag. Dreamweaver provides a visual method of specifying such a variable in your recordsets.

1. Make sure a ColdFusion page is active in the Document window.
2. In the Bindings panel, click the Plus (+) button and select Data Source Name Variable from the pop-up menu.
   The Data Source Name Variable dialog box appears.
3 Define a variable, and click OK.
4 When defining the recordset, select the variable as the data source for the recordset.
   In the Recordset dialog box, the variable appears in the Data Source pop-up menu along with the ColdFusion data sources on the server.
5 Complete the Recordset dialog box, and click OK.
6 Initialize the variable.
   Dreamweaver does not initialize the variable for you so that you can initialize it how and where you want. You can initialize the variable in the page code (before the `cfquery` tag), in an include file, or in some other file as a session or application variable.

**Define server variables**

You define server variables as sources of dynamic content for use within a web application. Server variables vary from document type to document type and include form variables, URL variables, session variables, and application variables.

Server variables can be accessed by all clients that access the server, and by any applications running on the server. The variables persist until the server is stopped.

**Define ColdFusion server variables**

1 Open the Bindings panel (Window > Bindings). In the Server Variable dialog box, enter the name of the server variable, and click OK.
2 Click the Plus (+) button and select the server variable from the pop-up menu.
3 Enter the name of the variable, and click OK. The ColdFusion server variable appears in the Bindings panel.

The following table lists the built-in ColdFusion server variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server.ColdFusion.ProductName</td>
<td>ColdFusion product name.</td>
</tr>
<tr>
<td>Server.ColdFusion.SerialNumber</td>
<td>Serial number of currently installed version of ColdFusion.</td>
</tr>
<tr>
<td>Server.OS.Name</td>
<td>Name of operating system running on the server (Windows XP, Windows 2000, Linux).</td>
</tr>
<tr>
<td>Server.OS.AdditionalInformation</td>
<td>Additional information about installed operating system (service packs, updates).</td>
</tr>
<tr>
<td>Server.OS.Version</td>
<td>Version of installed operating system.</td>
</tr>
<tr>
<td>Server.OS.BuildNumber</td>
<td>Build number of installed operating system.</td>
</tr>
</tbody>
</table>

**Define a ColdFusion local variable**

Local variables are variables created with the `CFSET` or `CFPARAM` tag within a ColdFusion page. The defined local variable appears in the Bindings panel.

7 In the Local Variable dialog box, enter the name of the local variable and click OK.
Define ASP server variables

You can define the following ASP server variables as sources of dynamic content: Request.Cookie, Request.QueryString, Request.Form, Request.ServerVariables, and Request.ClientCertificates.

1. Open the Bindings panel (Window > Bindings).
2. Click the Plus (+) button, and select Request Variable from the pop-up menu.
3. In the Request Variable dialog box, select one of the following request collections from the Type pop-up menu:
   - **The QueryString collection** Retrieves information appended to the sending page's URL, such as when the page has an HTML form using the GET method. The query string consists of one or more name-value pairs (for example, last=Smith, first=Winston) appended to the URL with a question mark (?). If the query string has more than one name-value pair, they are combined with ampersands (&).
   - **The Form collection** Retrieves form information included in the body of the HTTP request by an HTML form using the POST method.
   - **The ServerVariables collection** Retrieves the values of predefined environment variables. The collection has a long list of variables, including CONTENT_LENGTH (the length of content submitted in the HTTP request, which you can use to see if a form is empty), and HTTP_USER_AGENT (provides information about the user's browser).
     For example, Request.ServerVariables("HTTP_USER_AGENT") contains information about the submitting browser, such as Mozilla/4.07 [en] (WinNT; I), which denotes a Netscape Navigator 4.07 browser.
     For a complete list of ASP server environment variables, see the online documentation installed with Microsoft Personal Web Server (PWS) or Internet Information Server (IIS).
   - **The Cookies collection** Retrieves the values of the cookies sent in an HTTP request. For example, suppose the page reads a cookie called "readMe" on the user's system. On the server, the values of the cookie are stored in the variable Request.Cookies("readMe").
   - **The ClientCertificate collection** Retrieves the certification fields from the HTTP request sent by the browser. The certification fields are specified in the X.509 standard.

4. Specify the variable in the collection that you want to access, and click OK.
   For example, if you want to access the information in the Request.ServerVariables("HTTP_USER_AGENT") variable, enter the argument HTTP_USER_AGENT. If you want to access the information in the Request.Form("lastname") variable, enter the argument lastname.
   The request variable appears in the Bindings panel.

Define PHP server variables

Define server variables as a source of dynamic content for PHP pages. The PHP server variables appear in the Bindings panel.

1. Open the Bindings panel (Window > Bindings).
2. Click the Plus (+) button, and select the variable from the pop-up menu.
3. In the Request Variable dialog box, enter the name of the variable (for example, REQUEST_METHOD), and click OK.
   For more information, search for the keyword $_SERVER in the PHP documentation.
Define a ColdFusion client variable

Define a ColdFusion client variable as a source of dynamic content for the page. The newly defined ColdFusion client variables appear in the Bindings panel.

? In the Client Variable dialog box, enter the name of the variable, and click OK.

For example, to access the information in the Client.LastVisit ColdFusion variable, enter LastVisit.

Client variables are variables created in the code to associate data with a specific client. Client variables maintain the application’s state as the user moves from page to page within the application, as well as from session to session.

Client variables can be user-defined or built-in. The following table lists the built-in ColdFusion client variables:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client.CFID</td>
<td>An incremental ID for each client that connects to the server.</td>
</tr>
<tr>
<td>Client.CFTOKEN</td>
<td>A randomly generated number used to uniquely identify a particular client.</td>
</tr>
<tr>
<td>Client.URLToken</td>
<td>A combination of CFID and CFTOKEN to be passed between templates when cookies are not used.</td>
</tr>
<tr>
<td>Client.LastVisit</td>
<td>Records the timestamp of the last visit made by a client.</td>
</tr>
<tr>
<td>Client.HitCount</td>
<td>The number of page requests tied to a single client (tracked using CFID and CFTOKEN).</td>
</tr>
<tr>
<td>Client.TimeCreated</td>
<td>Records the timestamp when CFID and CFTOKEN were first created for a particular client.</td>
</tr>
</tbody>
</table>

Define a ColdFusion cookie variable

Cookie variables are created in the code, and access information contained in cookies passed to the server by a browser. The defined cookie variable appears in the Bindings panel.

? In the Cookie Variable dialog box, enter the name of the cookie variable, and click OK.

Define a ColdFusion CGI variable

The defined CGI variable appears in the Bindings panel.

? In the CGI Variable dialog box, enter the name of the variable, and click OK.

For example, if you want to access the information in the CGI.HTTP_REFERER variable, enter HTTP_REFERER.

The following table lists the most common ColdFusion CGI variables that are created on the server:
The following table lists the most common CGI variables created by the browser and passed to the server:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SERVER_SOFTWARE</td>
<td>The name and version of the information server software answering the request (and running the gateway). Format: name/version.</td>
</tr>
<tr>
<td>SERVER_NAME</td>
<td>The server’s hostname, DNS alias, or IP address as it appears in self-referencing URLs.</td>
</tr>
<tr>
<td>GATEWAY_INTERFACE</td>
<td>The revision of the CGI specification to which this server complies. Format: CGI/revision.</td>
</tr>
<tr>
<td>SERVER_PROTOCOL</td>
<td>The name and revision of the information protocol this request came in with. Format: protocol/revision.</td>
</tr>
<tr>
<td>SERVER_PORT</td>
<td>The port number to which the request was sent.</td>
</tr>
<tr>
<td>REQUEST_METHOD</td>
<td>The method with which the request was made. For HTTP, this is Get, Head, Post, and so on.</td>
</tr>
<tr>
<td>PATH_INFO</td>
<td>The extra path information, as given by the client. Scripts can be accessed by their virtual pathname, followed by extra information at the end of this path. The extra information is sent as PATH_INFO.</td>
</tr>
<tr>
<td>PATH_TRANSLATED</td>
<td>The server provides a translated version of PATH_INFO, which takes the path and does any virtual-to-physical mapping to it.</td>
</tr>
<tr>
<td>SCRIPT_NAME</td>
<td>A virtual path to the script being executed; used for self-referencing URLs.</td>
</tr>
<tr>
<td>QUERY_STRING</td>
<td>The query information that follows the question mark (?) in the URL that referenced this script.</td>
</tr>
<tr>
<td>REMOTE_HOST</td>
<td>The hostname making the request. If the server does not have this information, it sets REMOTE_ADDR and does not set REMOTE_HOST.</td>
</tr>
<tr>
<td>REMOTE_ADDR</td>
<td>The IP address of the remote host making the request.</td>
</tr>
<tr>
<td>AUTH_TYPE</td>
<td>If the server supports user authentication, and the script is protected, this is the protocol-specific authentication method used to validate the user.</td>
</tr>
<tr>
<td>REMOTE_USER AUTH_USER</td>
<td>If the server supports user authentication, and the script is protected, this is the user name they have authenticated as. (Also available as AUTH_USER.)</td>
</tr>
<tr>
<td>REMOTE_IDENT</td>
<td>If the HTTP server supports RFC 931 identification, this variable is set to the remote user name retrieved from the server. Use this variable for logging only.</td>
</tr>
<tr>
<td>CONTENT_TYPE</td>
<td>For queries that have attached information, such as HTTP POST and PUT, this is the content type of the data.</td>
</tr>
<tr>
<td>CONTENT_LENGTH</td>
<td>The length of the content as given by the client.</td>
</tr>
</tbody>
</table>
Cache content sources
You can cache—or store—sources of dynamic content in a Design Note. This lets you work on a site even if you don't have access to the database or application server storing the sources of dynamic content. Caching may also speed up development by eliminating repeated access across a network to the database and application server.

? Click the arrow button in the top right corner of the Bindings panel and toggle Cache in the pop-up menu.
If you make changes to one of the content sources, you can refresh the cache by clicking the Refresh button (the circle-arrow icon) in the upper-right corner of the Bindings panel. (Expand the panel if you don't see the button.)

Change or delete content sources
You can change or delete any existing source of dynamic content—that is, any content source listed in the Bindings panel.

Changing or deleting a content source in the Bindings panel does not change or delete any instance of that content on the page. It merely changes or deletes it as a possible source of content for the page.

Change a content source in the Bindings panel
1 In the Bindings panel (Window > Bindings), double-click the name of the content source you want to edit.
2 Make your changes in the dialog box that appears.
3 If satisfied with your work, click OK.

Delete a content source from the Bindings panel
1 In the Bindings panel (Window > Bindings), select the content source from the list.
2 Click the Minus (-) button.

Copy a recordset from one page to another page
You can copy a recordset from one page to another within a defined site.

1 Select the recordset in either the Bindings panel or the Server Behaviors panel.
2 Right-click the recordset, and select Copy from the pop-up menu.
3 Open the page you want to copy the recordset to.
4 Right-click the Bindings panel or the Server Behaviors toolbar, and select Paste from the pop-up menu.

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP_REFERER</td>
<td>The referring document. This is the document that linked to or submitted form data.</td>
</tr>
<tr>
<td>HTTP_USER_AGENT</td>
<td>The browser the client is currently using to send the request. Format: software/version library/version.</td>
</tr>
<tr>
<td>HTTP_IF_MODIFIED_SINCE</td>
<td>The last time the page was modified. This variable is sent at the discretion of the browser, usually in response to the server having sent the LAST_MODIFIED HTTP header. It can be used to take advantage of browser-side caching.</td>
</tr>
</tbody>
</table>
Add dynamic content to pages

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About adding dynamic content

After you define one or more sources of dynamic content, you can use the sources to add dynamic content on the page. Content sources can include a column in a recordset, a value submitted by an HTML form, the value contained in a server object, or other data.

In Dreamweaver, you can place dynamic content almost anywhere in a web page or its HTML source code. You can place dynamic content at the insertion point, replace a text string, or insert it as an HTML attribute. For example, dynamic content can define the src attribute of an image, or the value attribute of a form field.

You can add dynamic content to a page by selecting a content source in the Bindings panel. Dreamweaver inserts a server-side script in the page's code instructing the server to transfer the data from the content source to the page's HTML code when the page is requested by a browser.

There is often more than one way to make a given page element dynamic. For example, to make an image dynamic you can use the Bindings panel, the Property inspector, or the Image command in the Insert menu.

By default, an HTML page can display only one record at a time. To display the other records in the recordset, you can add a link to move through the records one at a time, or you can create a repeating region to display more than one record on a single page.

About dynamic text

Dynamic text adopts any text formatting applied to the existing text or to the insertion point. For example, if a Cascading Style Sheet (CSS) style affects the selected text, the dynamic content replacing it is also affected by the style.

You can add or change the text format of dynamic content by using any of the Dreamweaver text formatting tools.

You can also apply a data format to dynamic text. For example, if your data consists of dates, you can specify a particular date format such as 04/17/00 for U.S. visitors, or 17/04/00 for Canadian visitors.

Make text dynamic

You can replace existing text with dynamic text, or you can place dynamic text at a given insertion point on the page.

Add dynamic text

1 In Design view, select text on the page, or click where you want to add dynamic text.

2 In the Bindings panel (Window > Bindings), select a content source from the list. If you select a recordset, specify the column you want in the recordset.

   The content source should contain plain text (ASCII text). Plain text includes HTML. If no content sources appear in the list, or if the available content sources don't meet your needs, click the Plus (+) button to define a new content source.

3 (Optional) Select a data format for the text.

4 Click Insert, or drag the content source onto the page.
A dynamic content placeholder appears. (If you selected text on the page, the placeholder replaces the text selection.) The placeholder for recordset content uses the syntax `{RecordsetName.ColumnName}`, where `Recordset` is the name of the recordset and `ColumnName` is the name of the column you chose from the recordset.

Sometimes, the length of the placeholders for dynamic text distorts the page's layout in the Document window. You can solve the problem by using empty curly braces as placeholders, as described in the next topic.

### Display placeholders for dynamic text

1. Select Edit > Preferences > Invisible Elements (Windows) or Dreamweaver > Preferences > Invisible Elements (Macintosh).
2. In the Show Dynamic Text As pop-up menu, select `{}`, and click OK.

### Make images dynamic

You can make images on your page dynamic. For example, suppose you design a page to display items for sale at a charity auction. Each page would include descriptive text and a photo of one item. The page's general layout would remain the same for each item, but the photo (and descriptive text) could change.

1. With the page open in Design view (View > Design), place the insertion point where you want the image to appear on the page.
2. Select Insert > Image.

   The Select Image Source dialog box appears.
3. Click the Data Sources option (Windows) or the Data Source button (Macintosh).

   A list of content sources appears.
4. Select a content source from the list, and click OK.

   The content source should be a recordset that contains the paths to your image files. Depending on the file structure of your site, the paths can be absolute, document relative, or root relative.

   **Note:**

   *Dreamweaver does not currently support binary images stored in a database.*

   If no recordsets appear in the list, or if the available recordsets don't meet your needs, define a new recordset.

### Make HTML attributes dynamic

You can dynamically change the appearance of a page by binding HTML attributes to data. For example, you can change the background image of a table by binding the table's `background` attribute to a field in a recordset.

You can bind HTML attributes with the Bindings panel or with the Property inspector.

#### Make HTML attributes dynamic with the Bindings panel

1. Open the Bindings panel by choosing Window > Bindings.
2. Ensure that the Bindings panel lists the data source you want to use.

   The content source should contain data that's appropriate for the HTML attribute you want to bind. If no sources of content appear in the list, or if the available content sources don't meet your needs, click the Plus (+) button to define a new data source.
3. In Design view, select an HTML object.
For example, to select an HTML table, click inside the table and click the `<table>` tag in the tag selector on the bottom-left of the Document window.

4 In the Bindings panel, select a content source from your list.
5 In the Bind To box, select an HTML attribute from the pop-up menu.
6 Click Bind.

The next time the page runs on the application server, the value of the data source will be assigned to the HTML attribute.

**Make HTML attributes dynamic with the Property inspector**

1 In Design view, select an HTML object and open the Property inspector (Window > Properties).

For example, to select an HTML table, click inside the table and click the `<table>` tag in the tag selector on the bottom-left of the Document window.

2 How you bind a dynamic content source to the HTML attribute depends on where it is located.
   • If the attribute you want to bind has a folder icon next to it in the Property inspector, click the folder icon to open a file selection dialog box; then click the Data Sources option to display a list of data sources.
   • If the attribute you want to bind does not have a folder icon next to it, click the List tab (the lower of the two tabs) on the left side of the inspector.

   The Property inspector’s List view appears.
   • If the attribute you want to bind is not listed in the List view, click the Plus (+) button; then enter the attribute’s name or click the small arrow button and select the attribute from the pop-up menu.

3 To make the attribute’s value dynamic, click the attribute; then click the lightning-bolt icon or folder icon at the end of the attribute’s row.

   If you clicked the lightning bolt icon, a list of data sources appears.
   If you clicked the folder icon, a file selection dialog box appears. Select the Data Sources option to display a list of content sources.

4 Select a source of content from the list of content sources, and click OK.

   The content source should hold data that’s appropriate for the HTML attribute you want to bind. If no content sources appear in the list, or if the available content sources don’t meet your needs, define a new content source.

   The next time the page runs on the application server, the value of the data source will be assigned to the HTML attribute.

**Make ActiveX, Flash, and other object parameters dynamic**

You can make the parameters of Java applets and plug-ins dynamic, as well as the parameters of ActiveX, Flash, Shockwave, Director, and Generator objects.

Before starting, make sure the fields in your recordset hold data that’s appropriate for the object parameters you want to bind.

1 In Design view, select an object on the page and open the Property inspector (Window > Properties).

2 Click the Parameters button.

3 If your parameter does not appear in the list, click the Plus (+) button and enter a parameter name in the Parameter column.
Dynamic sites, pages and web forms

4 Click the parameter’s Value column, and then click the lightning-bolt icon to specify a dynamic value. A list of data sources appears.

5 Select a data source from the list, and click OK.

The data source should hold data that’s appropriate for the object parameter you want to bind. If no data sources appear in the list, or if the available data sources don’t meet your needs, define a new data source.

Changing dynamic content in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About dynamic content
You can change the dynamic content on your page by editing the server behavior that provides the content. For example, you can edit a recordset server behavior to provide more records to your page.

Dynamic content on a page is listed in the Server Behaviors panel. For example, if you add a recordset to your page, the Server Behaviors panel lists it as follows:

Recordset(myRecordset)

If you add another recordset to your page, the Server Behaviors panel lists both recordsets as follows:

Recordset(mySecondRecordset)Recordset(myRecordset)

Edit dynamic content
1 Open the Server Behaviors panel (Window > Server Behaviors).

2 Click the Plus (+) button to display the server behaviors, and double-click the server behavior in the panel.

The dialog box that you used to define the original data source appears.

3 Make your changes in the dialog box, and click OK.

Delete dynamic content

After adding dynamic content to a page, delete it in one the following ways:

• Select the dynamic content on the page, and press Delete.

• Select the dynamic content in the Server Behaviors panel, and click the Minus (-) button.

Note:
This operation removes the server-side script in the page that retrieves the dynamic content from the database. It does not delete the data in the database.

Test dynamic content
You can preview and edit dynamic content using Live view.

Last updated 11/7/2019
While dynamic content is displayed, you can perform the following tasks:

- Adjust the page's layout using the page-design tools
- Add, edit, or delete dynamic content
- Add, edit, or delete server behaviors

1. Click the Live view button to display dynamic content.
2. Make the necessary changes to the page. You'll need to toggle between Live view and Design or Code view to make changes and see how they take effect.

Let Adobe Contribute users edit dynamic content

When a Contribute user edits a page containing dynamic content or invisible elements (such as scripts and comments), Contribute displays the dynamic content and invisible elements as yellow markers. By default, Contribute users can't select or delete these markers.

If you want Contribute users to be able to select and delete dynamic content and other invisible elements from a page, you can change permission-group settings to allow them to do so; Contribute users normally can never edit dynamic content, even when you allow them to select it.

Note:

Using some server technologies, you can display static text using a server tag or function. To allow Contribute users to edit the static text in a dynamic page that uses such a server technology, place the static text outside of the server tags. For more information, see Administering Adobe Contribute.

1. Select Site > Administer Contribute Site.
2. If certain required options for Contribute compatibility aren't enabled, a dialog box appears, asking if you want to enable those options. Click OK to enable those options and Contribute compatibility.
3. If prompted, enter the administrator password, and then click OK.
   The Administer Website dialog box appears.
4. In the Users And Roles category, select a role, and then click the Edit Role Settings button.
5. Select the Editing category, and deselect the option to protect scripts and forms.
6. Click OK to close the Edit Settings dialog box.
7. Click Close to close the Administer Website dialog box.

Modify recordsets with the Property inspector

Use the Property inspector is to modify the selected recordset. The available options vary depending on the server model.

1. Open the Property inspector (Window > Properties) and then select the recordset in the Server Behaviors panel (Window > Server Behavior).
2. Edit any of the options. When you select a new option in the inspector, Dreamweaver updates the page.

Display database records

Note:
About database records
Displaying database records involves retrieving information stored in a database or other source of content, and rendering that information to a web page. Dreamweaver provides many methods of displaying dynamic content, and provides several built-in server behaviors that let you both enhance the presentation of dynamic content, and allow users to more easily search through and navigate information returned from a database.

Databases and other sources of dynamic content provide you with more power and flexibility in searching, sorting, and viewing large stores of information. Using a database to store content for websites makes sense when you need to store large amounts of information, and then retrieve and display that information in a meaningful way. Dreamweaver provides you with several tools and prebuilt behaviors to help you effectively retrieve and display information stored in a database.

Server behaviors and formatting elements
Dreamweaver provides the following server behaviors and formatting elements to let you enhance the display of dynamic data:

- **Formats** let you apply different types of numerical, monetary, date/time, and percentage values to dynamic text.

  For example, if the price of an item in a recordset reads 10.989, you can display the price on the page as $10.99 by selecting the Dreamweaver “Currency - 2 Decimal Places” format. This format displays a number using two decimal places. If the number has more than two decimal places, the data format rounds the number to the closest decimal. If the number has no decimal places, the data format adds a decimal point and two zeros.

- **Repeating Region** server behaviors let you display multiple items returned from a database query, and let you specify the number of records to display per page.

- **Recordset Navigation** server behaviors let you insert navigation elements that allow users to move to the next or previous set of records returned by the recordset. For example, if you choose to display 10 records per page using the Repeating Region server object, and the recordset returns 40 records, you can navigate through 10 records at a time.

- **Recordset Status Bar** server behaviors let you include a counter that shows users where they are within a set of records relative to the total number of records returned.

- **Show Region** server behaviors let you choose to show or hide items on the page based on the relevance of the currently displayed records. For example, if a user has navigated to the last record in a recordset, you can hide the Next link, and display only the Previous records link.

Apply typographic and page layout elements to dynamic data
A powerful feature of Dreamweaver is the ability to present dynamic data within a structured page, and to apply typographic formatting using HTML and CSS. To apply formats to dynamic data in Dreamweaver, format the tables and placeholders for the dynamic data using the Dreamweaver formatting tools. When the data is inserted from its data source, it automatically adopts the font, paragraph, and table formatting you specified.

Navigate database recordset results
Recordset navigation links let users move from one record to the next, or from one set of records to the next. For example, after designing a page to display five records at a time, you might want to add links such as Next or Previous that let users display the five next or previous records.
You can create four types of navigation links to move through a recordset: First, Previous, Next, and Last. A single page can contain any number of these links, provided they all work on a single recordset. You can’t add links to move through a second recordset on the same page.

Recordset navigation links require the following dynamic elements:

- A recordset to navigate
- Dynamic content on the page to display the record or records
- Text or images on the page to serve as a clickable navigation bar
- A Move To Record set of server behaviors to navigate the recordset

You can add the last two elements by using the Record Navigation Bar server object, or you can add them separately by using the design tools and the Server Behaviors panel.

Create a recordset navigation bar

You can create a recordset navigation bar in a single operation using the Recordset Navigation Bar server behavior. The server object adds the following building blocks to the page:

- An HTML table with either text or image links
- A set of Move To server behaviors
- A set of Show Region server behaviors

The text version of the Recordset Navigation Bar looks like this:

![Text version of the Recordset Navigation Bar]

Before placing the navigation bar on the page, make sure the page contains a recordset to navigate and a page layout in which to display the records. After placing the navigation bar on the page, you can use the design tools to customize the bar to your liking. You can also edit the Move To and Show Region server behaviors by double-clicking them in the Server Behaviors panel. Dreamweaver creates a table that contains text or image links that allow the user to navigate through the selected recordset when clicked. When the first record in the recordset is displayed, the First and Previous links or images are hidden. When the last record in the recordset is displayed, the Next and Last links or images are hidden. You can customize the layout of the navigation bar by using the design tools and the Server Behaviors panel.

1. In Design view, place the insertion point at the location on the page where you want the navigation bar to appear.
3. Select the recordset you want to navigate from the Recordset pop-up menu.
4. From the Display Using section, select the format to display the navigation links on the page, and click OK.

- **Text** Places text links on the page.
- **Images** Includes graphical images as links. Dreamweaver uses its own image files. You can replace these images with image files of your own after placing the bar on the page.
Custom recordset navigation bars
You can create your own recordset navigation bar that uses more complex layout and formatting styles than the simple table created by the Recordset Navigation Bar server object.

To create your own recordset navigation bar, you must:

• Create navigation links in text or images
• Place the links in the page in Design view
• Assign individual server behaviors to each navigation link

This section describes how to assign individual server behaviors to the navigation links.

Create and assign server behaviors to a navigation link

1 In Design view, select the text string or image on the page you want to use as a record navigation link.

2 Open the Server Behaviors panel (Window > Server Behaviors), and click the Plus (+) button.

3 Select Recordset Paging from the pop-up menu; then select a server behavior appropriate to that link from the listed server behaviors.

   If the recordset contains a large number of records, the Move To Last Record server behavior can take a long time to run when the user clicks the link.

4 In the Recordset pop-up menu, select the recordset that contains the records, and click OK.

   The server behavior is assigned to the navigation link.

Set the Move To (server behavior) dialog box options
Add links that let the user navigate through records in a recordset.

1 If you didn't select anything on the page, select a link from the pop-up menu.

2 Select the recordset that contains the records to page through, and click OK.

   Note:

   *If the recordset contains a large number of records, the Move To Last Record server behavior can take a long time to run when the user clicks the link.*

Navigation bar design tasks
When creating a custom navigation bar, begin by creating its visual representation using the Dreamweaver page-design tools. You don't have to create a link for the text string or image, Dreamweaver creates one for you.

The page you create the navigation bar for must contain a recordset to navigate. A simple recordset navigation bar might look like this, with link buttons created out of images, or other content elements:

![Simple recordset navigation bar](image)

After you have added a recordset to a page, and have created a navigation bar, you must apply individual server behaviors to each navigation element. For example, a typical recordset navigation bar contains representations of the following links matched to the appropriate behavior:
Display and hide regions based on recordset results

You can also specify that a region be displayed or hidden based on whether the recordset is empty. If a recordset is empty (for example, no records were found matching the query), you can display a message informing the user that no records were returned. This is especially useful when creating search pages that rely on user input search terms to run queries against. Similarly, you can display an error message if there is a problem connecting to a database, or if a user’s user name and password do not match those recognized by the server.

The Show Region server behaviors are:
- Show If Recordset Is Empty
- Show If Recordset Is Not Empty
- Show If First Page
- Show If Not First Page
- Show If Last Page
- Show If Not Last Page

1 In Design view, select the region on the page to show or hide.
2 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button.
3 Select Show Region from the pop-up menu, select one of the listed server behaviors, and click OK.

Display multiple recordset results

The Repeating Region server behavior lets you display multiple records from a recordset within a page. Any dynamic data selection can be turned into a repeating region. However, the most common regions are a table, a table row, or a series of table rows.

1 In Design view, select a region that contains dynamic content.
   The selection can be anything, including a table, a table row, or even a paragraph of text.
   To select a region on the page precisely, you can use the tag selector on the left corner of the document window. For example, if the region is a table row, click inside the row on the page, then click the rightmost <tr> tag in the tag selector to select the table row.
2 Select Window > Server Behaviors to display the Server Behaviors panel.
3 Click the Plus (+) button, and select Repeating Region.
4 Select the name of the recordset to use from the pop-up menu.
5 Select the number of records to display per page, and click OK.
   In the Document window, a thin, tabbed, gray outline appears around the repeating region.
Modify repeating regions in the Property inspector

Modify the selected repeating region by changing any of the following options:

• The name of the repeating region.
• The recordset providing the records for the repeating region.
• The number of records displayed

When you select a new option, Dreamweaver updates the page.

Reuse PHP recordsets

For a tutorial on reusing PHP recordsets, see David Powers's tutorial, How Do I Reuse a PHP Recordset in More Than One Repeat Region?

Create a dynamic table

The following example illustrates how the Repeating Region server behavior is applied to a table row, and specifies that nine records are displayed per page. The row itself displays four different records: city, state, street address, and ZIP code.

To create a table such as the one in the previous example, you must create a table that contains dynamic content, and apply the Repeating Region server behavior to the table row containing the dynamic content. When the page is processed by the application server, the row is repeated the number of times specified in the Repeating Region server object, with a different record inserted in each new row.

1 Do one of the following to insert a dynamic table:

• Select Insert > Data Objects > Dynamic Data > Dynamic Table to display the Dynamic Table dialog box.
From the Data category of the Insert panel, click the Dynamic Data button and select the Dynamic Table icon from the pop-up menu.

2 Select the recordset from the Recordset pop-up menu.

3 Select the number of records to display per page.

4 (Optional) Input values for the table border, cell padding, and cell spacing.

   The Dynamic Table dialog box retains the values you enter for table borders, cell padding, and cell spacing.

   Note:

   If you are working on a project that requires several dynamic tables with the same appearance, enter the table layout values, which further simplifies page development. You can adjust these values after inserting the table by using the table Property inspector.

5 Click OK.

A table and placeholders for the dynamic content defined in its associated recordset are inserted into the page.

In this example, the recordset contains four columns: AUTHORID, FIRSTNAME, LASTNAME, and BIO. The table's heading row is populated with the names of each column. You can edit the headings using any descriptive text, or replace them with representative images.

Create record counters

Record counters give users a reference point when they are navigating through a set of records. Typically, record counters display the total number of records returned, and the current records being viewed. For example, if a recordset returns 40 individual records, and 8 records are displayed per page, the record counter on the first page would indicate “Displaying records 1-8 of 40.”

Before you create a record counter for a page, you must create a recordset for the page, an appropriate page layout to contain the dynamic content, and then a recordset navigation bar.

Create simple record counters

Record counters let users know where they are within a given set of records relative to the total number of records returned. For this reason record counters are a useful behavior that can significantly add to the usability of a web page.

Create a simple record counter by using the Recordset Navigation Status server object. This server object creates a text entry on the page to display the current record status. You can customize the record counter by using Dreamweaver page-design tools.

1 Place the insertion point where you want to insert the record counter.
Select Insert > Data Objects > Display Record Count > Recordset Navigation Status, select the recordset from the Recordset pop-up menu, and click OK.

The Recordset Navigation Status server object inserts a text record counter that appears similar to the following example:

Records {Employees_first} to {Employees_last} of {Employees_total}

When viewed in Live view, the counter appears similar to the following example:

Records 1 to 1 of 22

**Build and add the record counter to the page**

In the Insert Recordset Navigation Status dialog box, select the recordset to track, and click OK.

**Create custom record counters**

You use individual record count behaviors to create custom record counters. Creating a custom record counter lets you create a record counter beyond the simple, single row table inserted by the Recordset Navigation Status server object. You can arrange design elements in a number of creative ways, and apply an appropriate server behavior to each element.

The Record Count server behaviors are:

- Display Starting Record Number
- Display Ending Record Number
- Display Total Records

Before you create a custom record counter for a page, you must first create a recordset for the page, an appropriate page layout to contain the dynamic content, and a recordset navigation bar.

This example creates a record counter that appears similar to the example in “Simple record counters.” In this example, the text in sans-serif font represents the record count placeholders that will be inserted in the page. The record counter in this example appears as follows:

Displaying records StartRow through EndRow of RecordSet.RecordCount.

1. In Design view, enter the counter’s text on the page. The text can be anything you want, for example:

   Displaying records thru of .

2. Place the insertion point at the end of the text string.

3. Open the Server Behaviors panel (Window > Server Behaviors).

4. Click the Plus (+) button in the upper-left corner, and click Display Record Count. Within this submenu, select Display Total Records. The Display Total Records behavior is inserted into the page, and a placeholder is inserted where the insertion point was. The text string now appears as follows:

   Displaying records thru of {Recordset1.RecordCount}.

5. Place the insertion point after the word records, and select the Display Starting Record Count Number from the Server Behaviors > Plus (+) button > Record Count panel. The text string now appear as follows:

   Displaying records {StartRow_Recordset1} thru of {Recordset1.RecordCount}. 
6. Now place the insertion point between the words thru and of, and select the Display Starting Record Count Number from the Server Behaviors > Plus (+) button > Record Count panel. The text string now appear as follows:

```
Displaying records {StartRow_Recordset1} thru {EndRow_Recordset1} of {Recordset1.RecordCount}.
```

7. Confirm that the counter functions correctly by viewing the page in Live view; the counter is similar to the following example:

```
Displaying records 1 thru 8 of 40.
```

If the results page has a navigation link to move to the next set of records, clicking the link updates the record counter to read as follows:

```
Showing records 9 thru 16 of 40.
```

### Use predefined data formats

Dreamweaver includes several predefined data formats that you can apply to dynamic data elements. The data format styles include date and time, currency, numerical, and percentage formats.

### Apply data formats to dynamic content

1. Select the dynamic content placeholder in the Document window.
2. Select Window > Bindings to display the Bindings panel.
3. Click the down arrow button in the Format column.
   
   If the down arrow is not visible, expand the panel.
4. From the Format pop-up menu, select the data format category you want.
   
   Ensure that the data format is appropriate for the type of data you are formatting. For example, the Currency formats work only if the dynamic data consists of numerical data. Note that you cannot apply more than one format to the same data.
5. Verify that the format was applied correctly by previewing the page in Live view.

### Customize a data format

1. Open a page that contains dynamic data in Design view.
2. Select the dynamic data you want to create a custom format for.

   The bound data item whose dynamic text you selected is highlighted in the Bindings panel (Window > Bindings). The panel displays two columns for the selected item—Binding and Format. If the Format column is not visible, widen the Bindings panel to reveal it.
3. In the Bindings panel, click the down arrow in the Format column to expand the pop-up menu of available data formats.
   
   If the down arrow is not visible, widen the Bindings panel more.
4. Select Edit Format List from the pop-up menu.
5. Complete the dialog box, and click OK.
   a. Select the format from the list, and click Edit.
   b. Change any of the following parameters in the Currency, Number, or Percent dialog boxes, and click OK.

   - The number of digits to display after the decimal point
• Whether to place a leading zero in front of fractions
• Whether to use parentheses or a minus sign for negative values
• Whether to group digits

c. To delete a data format, click the format in the list, and click the Minus (-) button.

Create a data format (ASP only)
1  Open a page containing dynamic data in Design view.
2  Select the dynamic data you want to create a custom format for.
3  Select Window > Bindings to display the Bindings panel, and click the down arrow in the Format column. If the
down arrow is not visible, expand the panel.
4  Select Edit Format List from the pop-up menu.
5  Click the Plus (+) button, and select a format type.
6  Define the format, and click OK.
7  Enter a name for the new format in the Name column, and click OK.

Note:
Though Dreamweaver only supports creating data formats for ASP pages, ColdFusion and PHP users can download
formats that other developers created, or create server formats and post them to the Dreamweaver Exchange. For more
information on the Server Format API, see Extending Dreamweaver (Help > Extending Dreamweaver > Server
Formats).

Provide and troubleshoot live data in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options
described in this article in Dreamweaver and later. For more information, see this article.

The View Live Data feature has been deprecated as of Dreamweaver CS5. It has been replaced by the more streamlined
Live view feature.

To view live data in Live view, make sure that you have done the following:
• Define a folder to process dynamic pages (for example, a root folder on a ColdFusion server, either on your
computer or on a remote machine).
  If the page displays an error message when you enter Live View, make sure the Web URL in the Site Definition dialog
box is correct.
• Copy related files (if any) to the folder.
• Provide the page with any parameters a user would normally provide.

Provide the page with live data in Live view
1  Open the Live View Settings dialog box (View > Live View Options > HTTP Request Settings).
2  In the URL Request area, click the Plus (+) button and enter a parameter your page expects.
3  Specify a name and a test value for each parameter.
In the Method pop-up menu, select the HTML form method your page expects: **POST** or **GET**.

To save your settings for the current page, select **Save Settings For This Document**, and click OK.

*Note:*

*To save the settings, you must enable Design Notes (File > Design Notes).*

**Troubleshoot live data in Live view**

Many problems viewing live data in Live view can be traced back to missing or incorrect values in the Site Definition dialog box (Site > Edit Sites).

Check the settings for the server that you’ve specified as your testing server. You need to specify a folder capable of processing dynamic pages where the Site Definition dialog asks for a server folder or root directory. Here’s an example of a suitable server folder if you’re running IIS or PWS on your hard disk:

\C:\Inetpub\wwwroot\myapp\*

Verify that the Web URL box specifies a URL that corresponds (maps) to the server folder. For example, if PWS or IIS is running on your local computer, then the following remote folders have the following Web URLs:

<table>
<thead>
<tr>
<th>Remote folder</th>
<th>Web URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>\C:\Inetpub\wwwroot\</td>
<td><a href="http://localhost/">http://localhost/</a></td>
</tr>
<tr>
<td>\C:\Inetpub\wwwroot\myapp\</td>
<td><a href="http://localhost/myapp/">http://localhost/myapp/</a></td>
</tr>
<tr>
<td>\C:\Inetpub\wwwroot\fs\planes</td>
<td><a href="http://localhost/fs/planes">http://localhost/fs/planes</a></td>
</tr>
</tbody>
</table>

**Add custom server behaviors in Dreamweaver**

*Note:*

*The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.*

**About custom server behaviors**

Dreamweaver comes with a set of built-in server behaviors that lets you easily add dynamic capabilities to a site. You can extend the Dreamweaver functionality by creating server behaviors to suit your development needs, or by obtaining server behaviors from the Dreamweaver Exchange website.

Before creating your own server behaviors, you should check the Dreamweaver Exchange website to see if another party has already created a server behavior that supplies the functionality you’d like to add to your website. Often, a third-party developer has created and tested a server behavior that will address your needs.

**Access Dreamweaver Exchange**

1. In Dreamweaver, access Dreamweaver Exchange in one of these ways:
   - Select Help > Dreamweaver Exchange.
   - Select Window > Server Behaviors, click the Plus (+) button, and select Get More Server Behaviors.

   The Dreamweaver Exchange web page opens in your browser.
Log on to the Exchange using your Adobe ID, or, if you have not yet created a Dreamweaver Exchange ID for yourself, follow the instructions to open an Adobe account.

**Install a server behavior or other extension in Dreamweaver**

1. Start the Extension Manager by selecting Commands > Manage Extensions.
2. Select File > Install Package in the Extension Manager.

For more information, see *Using the Extension Manager*.

**Custom server behaviors workflow**

If you are a web developer proficient in ColdFusion, JavaScript, VBScript, or PHP, you can write your own server behaviors. The steps to create a server behavior include the following tasks:

- Write one or more code blocks that perform the required action.
- Specify where the code block should be inserted within the page's HTML code.
- If the server behavior requires that a value be specified for a parameter, create a dialog box that prompts the web developer applying the behavior to supply an appropriate value.
- Test the server behavior before making it available to others.

**Use the Server Behavior Builder**

Use the Server Behavior Builder to add the code block or blocks that the behavior inserts into a page.

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select New Server Behavior.
2. From the Document Type pop-up menu, select the document type that you are developing the server behavior for.
3. In the Name box, enter a name for the server behavior.
4. (Optional) To copy an existing server behavior to add to the behavior you are creating, select the Copy Existing Server Behavior option, and then select the server behavior in the Behavior to Copy pop-up menu. Click OK. The Server Behavior Builder dialog box is displayed.
5. To add a new code block, click the Plus (+) button, enter a name for the code block, and click OK. The name you enter appears in the Server Behavior Builder, with the appropriate scripting tags visible in the Code block box.
6. In the Code Block box, enter the run-time code necessary to implement the server behavior.

   **Note:**

   *When entering code in the Code Block box, you can only insert a single tag or code block for each named code block (for example, myBehavior_block1, myBehavior_block2, myBehavior_blockn, etc.). If you have to enter multiple tags or code blocks, create an individual code block for each one. You can also copy and paste code from other pages.*

7. Place the insertion point in the code block where you'd like to insert the parameter, or select a string to replace with a parameter.
8. Click the Insert Parameters in Code Block button.
9. Enter a name for the parameter in the Parameter Name box (for example, Session), and click OK.
The parameter is inserted into the code block at the location where you placed the insertion point prior to defining
the parameter. If you selected a string, every instance of the selected string in the code block is replaced with a
parameter marker (for example, `@@Session@@`).

10 Select an option from the Insert Code pop-up menu specifying where to embed the code blocks.

11 (Optional) To specify additional information about the server behavior, click the Advanced button.

12 To create more code blocks, repeat steps 5 through 11.

13 If the server behavior requires that parameters be supplied to it, you must create a dialog box that accepts parameters
from the person applying the behavior. See the link below.

14 After you perform the required steps to create the server behavior, click OK.

The Server Behaviors panel lists the server behavior.

15 Test the server behavior and ensure that it functions properly.

**Advanced options**

After you specify the source code and insert location for each code block, the server behavior is completely defined. In
most cases, you don't need to specify any additional information.

If you are an advanced user, you can set any of the following options:

**Identifier** Specifies whether the code block should be treated as an identifier.

By default, every code block is an identifier. If Dreamweaver finds an identifier code block anywhere in a document, it
lists the behavior in the Server Behaviors panel. Use the Identifier option to specify whether the code block should be
treated as an identifier.

At least one of the server behavior's code blocks must be an identifier. A code block should not be an identifier if one
of the following conditions applies: the same code block is used by some other server behavior; or the code block is so
simple that it might occur naturally on the page.

**Server Behavior Title** Specifies the title of the behavior in the Server Behaviors panel.

When the page designer clicks the Plus (+) button on the Server Behaviors panel, the new server behavior's title will
appear in the pop-up menu. When a designer applies an instance of a server behavior to a document, the behavior
appears in the list of applied behaviors in the Server Behaviors panel. Use the Server Behavior Title box to specify the
contents of the Plus (+) pop-up menu and the list of applied behaviors.

The initial value in the box is the name you supplied in the New Server Behavior dialog box. As parameters are defined,
the name is automatically updated so that the parameters appear inside parentheses after the server behavior name.

**Set Session Variable (@@Name@@, @@Value@@)**

If the user accepts the default value, everything before the parentheses appears in the Plus (+) pop-up menu (for
example, `Set Session Variable`). The name plus the parameters will appear in the list of applied behaviors—for example,
`Set Session Variable ("abcd", "5")`.

**Code Block to Select** Specifies what code block is selected when the user selects the behavior in the Server Behaviors
panel.

When you apply a server behavior, one of the code blocks within the behavior is designated the “code block to select.”
If you apply the server behavior and then select the behavior in the Server Behaviors panel, the designated block is
selected in the Document window. By default, Dreamweaver selects the first code block that is not above the `html`
tag. If all the code blocks are above the `html` tag, then the first one is selected. Advanced users can specify which code block is
the selected one.
Create code blocks

The code blocks you create in the Server Behavior Builder are encapsulated in a server behavior that appears in the Server Behaviors panel. The code can be any valid run-time code for the specified server model. For example, if you choose ColdFusion as the document type for your custom server behavior, the code you write must be valid ColdFusion code that runs on a ColdFusion application server.

You can create the code blocks either directly in the Server Behavior Builder, or you can copy and paste the code from other sources. Each code block you create in the Server Behavior Builder must be a single tag or script block. If you must insert multiple tag blocks, split them into separate code blocks.

Conditions in code blocks

Dreamweaver lets you develop code blocks that incorporate control statements that execute conditionally. The Server Behavior Builder uses if, elseif, and else statements, and may also contain server behavior parameters. This enables you to insert alternate text blocks based on the values of OR relationships among server behavior parameters.

The following example shows the if, elseif, and else statements. The square brackets ([ ]) denote optional code and the asterisk (*) denotes zero or more instances. To execute a portion of a code block or the entire code block only if a certain condition or conditions apply, use the following syntax:

```<@ if (expression1) @>    conditional
text1[@ elseif (expression2) @>    conditional text2] [@ else @>
      conditional text3]@ endif @>```

Condition expressions can be any JavaScript expression that can be evaluated using the JavaScript eval() function, and may include a server behavior parameter marked by @@’s. (The @@’s distinguish the parameter from JavaScript variables and keywords.)

Effectively using conditional expressions

When using if, else, and elseif directives within the insertText XML tag, the participant text is preprocessed to resolve the if directives and to determine which text to include in the result. The if and elseif directives take the expression as an argument. The condition expression is the same as that for JavaScript condition expressions, and can also contain server behavior parameters. Directives such as this allow you to choose between alternative code blocks based on the values of, or relationships between, server behavior parameters.

For example, the following JSP code comes from a Dreamweaver server behavior that uses a conditional code block:

```@@rsName@@.close();
<@ if (@@callableName@@ != '') @>
@@callableName@@.execute();
@@rsName@@ = @@callableName@@.getResultSet();<@ else @>
@@rsName@@ = Statement@@rsName@@.executeQuery();
<@ endif @>
@@rsName@@_hasData = @@rsName@@.next();
```

The conditional code block starts with `<@ if (@@callableName@@ != '') @>` and ends with `<@ endif @>`. According to the code, if the user enters a value for the @@callableName@@ parameter in the server behavior’s Parameter dialog box—in other words, if the @@callableName@@ parameter value is not null, or (@@callableName@@ != '')—then the conditional code block is replaced with the following statements:

```@@callableName@@.execute();
@@rsName@@ = @@callableName@@.getResultSet();
```

Otherwise, the code block is replaced with the following statement:

```@@rsName@@ = Statement@@rsName@@.executeQuery();```
Position a code block

When you create code blocks using the Server Behavior Builder, you must specify where to insert them in the page's HTML code.

For example, if you insert a code block above the opening `<html>` tag, you must then specify the code block's position relative to other tags, scripts, and server behaviors in that section of the page's HTML code. Typical examples include positioning a behavior either before or after any recordset queries that might also exist in the page code above the opening `<html>` tag.

When you select a positioning option from the Insert Code pop-up menu, the options available in the Relative Position pop-up menu change to provide relevant options for that part of the page. For example, if you select Above The `<html>` Tag In The Insert Code pop-up menu, the positioning options available in the Relative Position pop-up menu reflect choices relevant for that part of the page.

The following table shows the code block insert options, and the relative positioning options available for each:

<table>
<thead>
<tr>
<th>Insert Code options</th>
<th>Relative position options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Above the <code>&lt;html&gt;</code> Tag</td>
<td>• At the beginning of the file</td>
</tr>
<tr>
<td></td>
<td>• Just before the recordsets</td>
</tr>
<tr>
<td></td>
<td>• Just after the recordsets</td>
</tr>
<tr>
<td></td>
<td>• Just above the <code>&lt;html&gt;</code> tag</td>
</tr>
<tr>
<td></td>
<td>• Custom position</td>
</tr>
<tr>
<td>Below the <code>&lt;/html&gt;</code> Tag</td>
<td>• Before the end of the file</td>
</tr>
<tr>
<td></td>
<td>• Before the recordset close</td>
</tr>
<tr>
<td></td>
<td>• After the recordset close</td>
</tr>
<tr>
<td></td>
<td>• After the <code>&lt;/html&gt;</code> tag</td>
</tr>
<tr>
<td></td>
<td>• Custom position</td>
</tr>
<tr>
<td>Relative to a Specific Tag</td>
<td>Select a tag from the Tag pop-up menu, and then choose from the tag positioning options.</td>
</tr>
<tr>
<td>Relative to the Selection</td>
<td>Before the selection</td>
</tr>
<tr>
<td></td>
<td>After the selection</td>
</tr>
<tr>
<td></td>
<td>Replace the selection</td>
</tr>
<tr>
<td></td>
<td>Wrap the selection</td>
</tr>
</tbody>
</table>

To specify a custom position, you must assign a weight to the code block. Use the Custom Position option when you need to insert more than one code block in a particular order. For example, to insert an ordered series of three code blocks after the code blocks that open recordsets, you would enter a weight of 60 for the first block, 65 for the second, and 70 for the third.

By default, Dreamweaver assigns a weight of 50 to all recordset-opening code blocks inserted above the `<html>` tag. If the weight of two or more blocks match, Dreamweaver randomly sets the order among the blocks.

**Position a code block (general instructions)**

1. Using the Server Behavior Builder, write a code block.
2 In the Server Behavior Builder dialog box, select a position in which to insert the code block from the Insert Code pop-up menu.

3 In the Server Behavior Builder dialog box, select a position relative to that which you selected in the Insert Code pop-up menu.

4 If you complete the authoring of the code block, click OK.

   The server behavior is listed in the Server Behaviors panel (Window > Server Behavior); click the Plus (+) button to view the server behavior.

5 Test the server behavior and ensure that it functions properly.

**Position a code block relative to another tag on the page**

1 In the Insert Code pop-up menu, select Relative To A Specific Tag.

2 In the Tag box, enter the tag or select one from the pop-up menu.

   If you enter a tag, don’t include the angled brackets (<>).

3 Specify a location relative to the tag by choosing an option in the Relative Position pop-up menu.

**Position a code block relative to a tag selected by the page designer**

1 In the Insert Code pop-up menu, select Relative To The Selection.

2 Specify a location relative to the selection by choosing an option in the Relative Position pop-up menu.

   You can insert your code block just before or just after the selection. You can also replace the selection with your code block, or you can wrap the code block around the selection.

   To wrap the code block around a selection, the selection must consist of an opening and closing tag with nothing in between, as follows:

   `<CFIF Day="Monday"/></CFIF>`

   Insert the opening tag piece of the code block before the selection’s opening tag and the closing tag piece of the code block after the selection’s closing tag.

**Repeat code blocks with the loop directive**

To repeat a portion of a code block or the entire code block a number of times, use the following syntax:

```html
<@ loop (@@param1@@,@@param2@@) @> code block<@ endloop @>
```

When creating server behaviors, you can use looping constructs to repeat a code block a specified number of times. `<@ loop (@@param1@@,@@param2@@,@@param3@@,@@param_n@@) @> code block <@ endloop @>`

The loop directive accepts a comma-separated list of parameter arrays as arguments. In this case, parameter array arguments allow a user to supply multiple values for a single parameter. The repeating text is duplicated n times, where n is the length of the parameter array arguments. If more than one parameter array argument is specified, all the arrays must have the same length. On the ith evaluation of the loop, the ith elements of the parameter arrays replace the associated parameter instances in the code block.

When you create a dialog box for the server behavior, you can add a control to the dialog box that lets the page designer create parameter arrays. Dreamweaver includes a simple array control that you can use to create dialog boxes. This control, called Text Field Comma Separated List, is available through the Server Behavior Builder. To create user interface elements of greater complexity, see the API documentation to create a dialog box with a control to create arrays (a grid control, for example).
You can nest any number of conditionals or a loop directive within a conditional directive. For example, you can specify that if an expression is true to execute a loop.

The following example shows how such repeating code blocks can be used to create server behaviors (the example is a ColdFusion behavior used to access a stored procedure):

```
<@ loop (@@param1@@,@@param2@@,@@param3@@,@@param_n@@) @>
  code block
<@ endloop @>
```

Do Not Use:
```
<CFSTOREDPROC procedure="AddNewBook"
  datasource=#MM_connection_DSN#
  username=#MM_connection_USERNAME#
  password=#MM_connection_PASSWORD#>
  <CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryID#"
    cfsqltype="CF_SQL_INTEGER">
  <CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
    cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>
```

In this example, the `CFSTOREDPROC` tag can include zero or more `CFPROCPARAM` tags. However, without support for the loop directive, there is no way to include the `CFPROCPARAM` tags within the inserted `CFSTOREDPROC` tag.

If this were to be created as a server behavior without the use of the loop directive, you would need to divide this example into two participants: a main `CFSTOREDPROC` tag, and a `CFPROCPARAM` tag whose participant type is multiple.

Using the loop directive, you can write the same procedure as follows:

```
<CFSTOREDPROC procedure="@@procedure@@"
  datasource=#MM_@@conn@@_DSN#
  username=#MM_@@conn@@_USERNAME#
  password=#MM_@@conn@@_PASSWORD#>
  <@ loop (@@paramName@@,@@value@@,@@type@@) @>
    <CFPROCPARAM type="IN"
      dbvarname="@@paramName@@"
      value="@@value@@"
      cfsqltype="@@type@@">
  <@ endloop @>
</CFSTOREDPROC>
```

Note:

New lines after each "@>" are ignored.

If the user entered the following parameter values in the Server Behavior Builder dialog box:

- procedure = "proc1"
- conn = "connection1"
- paramName = ["@CategoryId", "@Year", "@ISBN"]
- value = ["#Form.CategoryId#", "#Form.Year#", "#Form.ISBN#"]
- type = ["CF_SQL_INTEGER", "CF_SQL_INTEGER", "CF_SQL_VARCHAR"]

The server behavior would insert the following run-time code in the page:
<CFSTOREDPROC procedure="proc1"
datasource=#MM_connection1_DSN#
username=#MM_connection1_USERNAME#
password=#MM_connection1_PASSWORD#>
  <CFPROCPARAM type="IN" dbvarname="@CategoryId" value="#Form.CategoryId#"
cfsqltype="CF_SQL_INTEGER">
  <CFPROCPARAM type="IN" dbvarname="@Year" value="#Form.Year#"
cfsqltype="CF_SQL_INTEGER">
  <CFPROCPARAM type="IN" dbvarname="@ISBN" value="#Form.ISBN#"
cfsqltype="CF_SQL_VARCHAR">
</CFSTOREDPROC>

Note:

Parameter arrays cannot be used outside of a loop except as part of a conditional directive expression.

Using the loop directive's _length and _index variables

The loop directive includes two built-in variables that you can use for embedded if conditions. The variables are: _length and _index. The _length variable evaluates to the length of the arrays processed by the loop directive, while the _index variable evaluates to the current index of the loop directive. To ensure that the variables are only recognized as directives, and not as actual parameters to be passed into the loop, do not enclose either variable in @@s.

An example of using built-in variables is to apply them to the import attribute of the page directive. The import attribute requires comma separation of packages. If the loop directive extends around the entire import attribute, you would only output the attribute name import= on the first iteration of the loop—this includes the closing double quote (")—and not output a comma on the last iteration of the loop. Using the built-in variable, you can express this as follows:

```cfml
<@loop (@@Import@@)@>
  @@Import@@
  <@if(_index == 0)@>import=""<@endif@>@@Import@@<@if (_index == _length-1)@>"<@else@>,
  <@ endif @>
<@endloop@>
```

Request a parameter for the server behavior

Server behaviors often require that the page designer supply a parameter value. This value must be inserted before the server behavior's code is inserted into the page.

You create the dialog box by defining the designer-supplied parameters in the code. Then you generate a dialog box for the server behavior, which prompts the page designer for a parameter value.

Note:

A parameter is added to your code block without your intervention if you specify that your code should be inserted relative to a specific tag chosen by the page designer (that is, you chose Relative to a Specific Tag in the Insert Code pop-up menu). The parameter adds a tag menu to the behavior's dialog box to let the page designer select a tag.

Define the parameter in the server behavior code

1 Enter a parameter marker in the code where you want to insert the supplied parameter value. The parameter has the following syntax:

   @@parameterName@@

2 Enclose the formParam string in parameter markers (@@):

   `<% Session("lang_pref") = Request.Form("@@formParam@@"); %>

   For example, if the server behavior contains the following code block:
Dynamic sites, pages and web forms

```<% Session("lang_pref") = Request.Form("Form_Object_Name"); %>

To require the page designer to supply the value of Form_Object_Name, enclose the string in parameter markers (@@):<% Session("lang_pref") = Request.Form("@@Form_Object_Name@@"); %>

You can also highlight the string and click the Insert Parameter In Code Block button. Enter a parameter name and click OK. Dreamweaver replaces every instance of the highlighted string with the specified parameter name enclosed in parameter markers.

Dreamweaver uses the strings that you enclose in parameter markers to label the controls in the dialog box it generates (see the following procedure). In the previous example, Dreamweaver creates a dialog box with the following label:

**Note:**

Parameter names in the server behavior code cannot have any spaces. Therefore, the dialog box labels cannot have any spaces. If you want to include spaces in the label, you can edit the generated HTML file.

Create a dialog box for your server behavior to request the parameter value

1. In the Server Behavior Builder, click Next.
2. To change the display order of the dialog box controls, select a parameter and click the up and down arrows.
3. To change a parameter's control, select the parameter and select another control in the Display As column.
4. Click OK.

Dreamweaver generates a dialog box with a labeled control for each designer-supplied parameter that you defined.

View the dialog box

1. Click the Plus (+) button in the Server Behaviors panel (Window > Server Behaviors), and select your custom server behavior from the pop-up menu.

Edit the dialog box you created for the server behavior

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Edit Server Behaviors from the pop-up menu.
2. Select your server behavior from the list, and click Open.
3. Click Next.
   A dialog box appears listing all the designer-supplied parameters that you defined in your code.
4. To change the display order of the dialog box controls, select a parameter and click the up and down arrows.
5. To change a parameter's control, select the parameter and select another control in the Display As column.
6. Click OK.
Dynamic sites, pages and web forms

Edit and modify server behaviors
You can edit any server behavior created with the Server Behavior Builder, including server behaviors you download from the Dreamweaver Exchange website, and other third-party developers.

If you apply a server behavior to a page and then edit the behavior in Dreamweaver, instances of the old behavior no longer appear in the Server Behaviors panel. The Server Behaviors panel searches the page for code that matches the code of known server behaviors. If the code of a server behavior changes, the panel does not recognize earlier versions of the behavior on that page.

Retain the old and new versions of the behavior in the panel
? Click the Plus (+) button on the Server Behaviors panel (Window > Server Behaviors), select New Server Behavior, and create a copy of the old server behavior.

Edit the code of a server behavior created with the Server Behavior Builder
1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Edit Server Behaviors from the pop-up menu.

   The Edit Server Behaviors dialog box displays all the behaviors for the current server technology.

2 Select the server behavior and click Edit.

3 Select the appropriate code block and modify the code, the parameter marks, or the position of the code block to be inserted in pages.

4 If the modified code does not contain any designer-supplied parameters, click OK.

   Dreamweaver regenerates the server behavior without a dialog box. The new server behavior appears in the Plus (+) pop-up menu of the Server Behaviors panel.

5 If the modified code does contain designer-supplied parameters, click Next.

   Dreamweaver asks you whether you want to create a new dialog box, overwriting the old one. Make your changes and click OK.

   Dreamweaver saves all changes in the server behavior's EDML file.

Coding guidelines
In general, your server behavior's code should be compact and robust. Web application developers are very sensitive to the code added to their pages. Follow generally accepted coding practices for the document type's language (ColdFusion, JavaScript, VBScript, or PHP). When writing comments, consider the different technical audiences that might need to understand the code, such as web and interaction designers, or other web application developers. Include comments that accurately describe the purpose of the code, and any special instructions for including it within a page.

Keep in mind the following coding guidelines when you create server behaviors:

Error checking An important requirement. The server behavior's code should handle error cases gracefully. Try to foresee every possibility. For example, what if a parameter request fails? What if no records are returned from a query?

Unique names Help to ensure that your code is clearly identifiable and avoids name collisions with existing code. For example, if the page contains a function called hideLayer() and a global variable called ERROR_STRING, and your server behavior inserts code that uses those names too, the server behavior may conflict with the existing code.

Code prefixes Allow you to identify your own run-time functions and global variables in a page. One convention is to use your initials. Never use the MM_ prefix, as it is reserved for Dreamweaver use only. Dreamweaver precedes all functions and global variables with the prefix MM_ to prevent them from conflicting with any code that you write.
var MM_ERROR_STRING = "...";
function MM_hideLayer() {

Avoid similar code blocks so that the code you write doesn't resemble too closely the code in other blocks. If a code block looks too much like another code block on the page, the Server Behaviors panel might mistakenly identify the first code block as an instance of the second code block (or conversely). A simple solution is to add a comment to a code block to make it more unique.

Test server behaviors
The Dreamweaver Exchange recommends performing the following tests on each server behavior you create:

• Apply the behavior from the Server Behaviors panel. If it has a dialog box, enter valid data in each field and click OK. Verify that no error occurs when the behavior is applied. Verify that the run-time code for the server behavior appears in the Code inspector.

• Apply the server behavior again and enter invalid data in each field of the dialog box. Try leaving the field blank, using large or negative numbers, using invalid characters (such as /, ?, :, *, and so on), and using letters in numeric fields. You can write form validation routines to handle invalid data (validation routines involve hand-coding, which is beyond the scope of this book).

After successfully applying your server behavior to the page, verify the following:

• Check the Server Behaviors panel to make sure the name of the server behavior appears in the list of behaviors added to the page.

• If applicable, verify that server-side script icons show up on the page. The generic server-side script icons are gold shields. To see the icons, enable Invisible Elements (View > Visual Aids > Invisible Elements).

• In Code view (View > Code), verify that no invalid code is generated.

In addition, if your server behavior inserts code in the document establishing a connection to a database, create a test database to test the code inserted in the document. Verify the connection by defining queries that produce different sets of data, and different sizes of data sets.

Finally, upload the page to the server and open it in a browser. View the page's HTML source code and verify that no invalid HTML has been generated by the server-side scripts.

Building forms using Dreamweaver

Note:
The user interface in Dreamweaver and later has been simplified. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

When a visitor enters information into a web form displayed in a web browser and clicks the submit button, the information is sent to a server where a server-side script or application processes it. The server responds by sending the processed information back to the user (or client), or by performing some other action based on the form's contents.

You can use Dreamweaver to create forms that submit data to most application servers, including PHP, ASP, and ColdFusion. If you use ColdFusion, you can also add ColdFusion-specific form controls to your forms. Your forms can have text fields, password fields, radio buttons, check boxes, pop-up menus, clickable buttons, and other form objects. Dreamweaver can also write code that validates the information a visitor provides. For example, you can check that an e-mail address that a user enters contains an "@" symbol, or that a required text field contains a value.

Note:
Use forms to collect information from users

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About collecting information from users
You can use web forms or hypertext links to gather information from users, store that information in the server’s memory, and then use the information to create a dynamic response based on the user’s input. The most common tools for gathering user information are HTML forms and hypertext links.

**HTML forms** Let you gather information from users and store it in the server’s memory. An HTML form can send the information either as form parameters or as URL parameters.

**Hypertext links** Let you gather information from users and store it in the server’s memory. You specify a value (or values) to be submitted when a user clicks a link—a preference, for example—by appending the value to the URL specified in the anchor tag. When a user clicks the link, the browser sends the URL and the appended value to the server.

**HTML form parameters**
Form parameters are sent to the server by means of an HTML form using either the *POST* or *GET* method.

When using the *POST* method, parameters are sent to the web server as part of the document’s header, and are not visible or accessible to anyone who’s viewing the page using standard methods. The *POST* method should be used for values that affect database content (for example inserting, updating, or deleting records), or for values that are sent by email.

The *GET* method appends parameters to the requested URL. The parameters are in turn visible to anyone viewing the page. The *GET* method should be used for search forms.

You can use Dreamweaver to quickly design HTML forms that send form parameters to the server. Be aware of the method you use to transmit information from the browser to the server.

Form parameters take the names of their corresponding form objects. For example, if your form contains a text field named *txtLastName*, then the following form parameter is sent to the server when the user clicks the Submit button:

```
txtLastName=enteredvalue
```

In cases where a web application expects a precise parameter value (for example, when it performs an action based on one of several options), use a radio button, check box, or list/menu form object to control the values the user can submit. This prevents users from typing information incorrectly and causing an application error. The following example depicts a pop-up menu form offering three choices:
Dynamic sites, pages and web forms

Pop-up menu form

Each menu choice corresponds to a hard-coded value that is submitted as a form parameter to the server. The List Values dialog box in the following example matches each list item to a value (Add, Update, or Delete):

List Values dialog box

After a form parameter is created, Dreamweaver can retrieve the value and use it in a web application. After defining the form parameter in Dreamweaver, you can insert its value within a page.

URL parameters

URL parameters let you pass user-supplied information from the browser to the server. When a server receives a request and parameters are appended to the URL of the request, the server gives the requested page access to the parameters before serving that page to the browser.

A URL parameter is a name-value pair appended to a URL. The parameter begins with a question mark (?) and takes the form name=value. If more than one URL parameter exists, each parameter is separated by an ampersand (&). The following example shows a URL parameter with two name-value pairs:

http://server/path/document?name1=value1&name2=value2

In this example workflow, the application is a web-based storefront. Because the developers of the site want to reach the widest possible audience, the site is designed to support foreign currencies. When users log in to the site, they can select the currency in which to view the prices of the available items.

1 The browser requests the report.cfm page from the server. The request includes the URL parameter Currency="euro". The Currency="euro" variable specifies that all monetary amounts retrieved be displayed as the European Union euro.

2 The server temporarily stores the URL parameter in memory.

3 The report.cfm page uses the parameter to retrieve the cost of items in euros. These monetary amounts can either be stored in a database table of different currencies, or converted from a single currency associated with each item (any currency supported by the application).
4 The server sends the report.cfm page to the browser and displays the value of items in the requested currency. When this user ends the session, the server clears the value of the URL parameter, freeing server memory to hold new user requests.

URL parameters are also created when the HTTP GET method is used in conjunction with an HTML form. The GET method specifies that the parameter value be appended to the URL request when the form is submitted.

Typical uses of URL parameters include personalizing websites based on user preferences. For example, a URL parameter consisting of a user name and password can be used to authenticate a user, displaying only information that user has subscribed to. Common examples of this include financial websites that display individual stock prices based on stock market symbols the user has previously chosen. Web application developers commonly use URL parameters to pass values to variables within applications. For example, you could pass search terms to SQL variables in a web application to generate search results.

Create URL parameters using HTML links

You create URL parameters within an HTML link by using the href attribute of the HTML anchor tag. You can enter the URL parameters directly in the attribute in Code view (View > Code), or by appending the URL parameters at the end of the link URL in the Property inspector Link box.

In the following example, three links create a single URL parameter (action) with three possible values (Add, Update, and Delete). When the user clicks a link, a parameter value is sent to the server, and the requested action is performed.

```
<a href="http://www.mysite.com/index.cfm?action=Add">Add a record</a>
<a href="http://www.mysite.com/index.cfm?action=Update">Update a record</a>
<a href="http://www.mysite.com/index.cfm?action=Delete">Delete a record</a>
```

The Property inspector (Window > Properties) lets you create the same URL parameters by selecting the link and appending the URL parameter values at the end of the link URL in the Link box.
After a URL parameter is created, Dreamweaver can retrieve the value and use it in a web application. After defining the URL parameter in Dreamweaver, you can insert its value within a page.

Create and enable ColdFusion forms in Dreamweaver

*Note:*

*Support for ColdFusion is removed in Dreamweaver and later.*

**About ColdFusion forms**

ColdFusion forms provide you with several built-in mechanisms to validate form data. For example, you can check to make sure a user has entered a valid date. Some form controls have additional features. Several do not have HTML counterparts, and others directly support dynamically populating the control from data sources.

Dreamweaver provides a number of enhancements for ColdFusion developers who use ColdFusion MX 7 or later as their development server. These enhancements include more Insert panel buttons, menu items, and Property inspectors so that you can rapidly build and set the properties of ColdFusion forms. You can also generate code that validates the information provided by site visitors. For example, you can check that the e-mail address provided by a user contains the @ symbol, or that a required text field contains a certain type of value.

**Enable the ColdFusion enhancements**

Some of these enhancements require that you define a computer running ColdFusion MX 7 or later as a testing server for Dreamweaver. For example, the Property inspectors for form controls are available only if you specify the correct testing server.

You define a testing server only once. Dreamweaver then automatically detects the testing server version and makes the enhancements available if it detects ColdFusion.

1. If you haven’t already done so, define a Dreamweaver site for your ColdFusion project.
2. Select Site > Manage Sites, select your site from the list, and click Edit.
3. Select the Servers category and specify a computer running ColdFusion MX 7 or later as the testing server for your Dreamweaver site. Ensure that you specify a valid Web URL.
4. Open any ColdFusion document.

   You won’t see any visible changes to the Dreamweaver work space until you open a ColdFusion document.

**Create ColdFusion forms**

You can use a number of Insert panel buttons, menu items, and Property inspectors to rapidly create ColdFusion forms and set their properties in Dreamweaver.

*Note:*

*These enhancements are available only if you have access to a computer running ColdFusion MX 7 or later.*

1. Open a ColdFusion page and place the insertion point where you want the ColdFusion form to appear.
2. Select Insert > ColdFusion Objects > CFForm > CFForm, or select the CFForm category from the Insert panel and click the CF Form icon.
Dreamweaver inserts an empty ColdFusion form. In Design view, the form is indicated by a dotted red outline. If you don't see this outline, make sure that View > Visual Aids > Invisible Elements is selected.

3 Ensure that the form is still selected, and then use the Property inspector to set any of the following form properties.

- **CFForm** Sets the name of the form.
- **Action** Lets you specify the name of the ColdFusion page to be processed when the form is submitted.
- **Method** Lets you define the method that the browser uses to send the form data to the server:
  - **POST** Sends the data using the HTTP post method; this method sends the data in a separate message to the server.
  - **GET** Sends the data using the HTTP get method, placing the form field contents in the URL query string.
- **Target** Lets you to modify the value of the target attribute of the cfform tag.
- **Encoding Type** Specifies the encoding method used for transmitting the form data.

  **Note:**

  *Encoding type does not refer to character encoding. This attribute specifies the content type used to submit the form to the server (when the value of method is post). The default value for this attribute is application/x-www-form-urlencoded.*

- **Format** Determines what kind of form is created:
  - **HTML** Generates an HTML form and sends it to the client. The cfgrid and cftree child controls can be in Flash or applet format.
  - **Flash** Generates a Flash form and sends it to the client. All controls are in Flash format.
  - **XML** Generates XForms XML and puts the results in a variable with the ColdFusion form name. Does not send anything to the client. The cfgrid and cftree child controls can be in Flash or applet format.
- **Style** Lets you specify a style for the form. For more information, see the ColdFusion documentation.
- **Flash/XML Skin** Lets you specify a halo color to stylize the output. The theme determines the color used for highlighted and selected elements.
- **Preserve Data** Determines whether to override the initial control values with submitted values when the form posts to itself.
  - If False, values specified in the control tag attributes are used.
  - If True, submitted values are used.
- **Scripts src** Specifies the URL, relative to the web root, of the JavaScript file that contains client-side code used by the tag and its child tags. This attribute is useful if the file is not in the default location. This attribute may be required in some hosting environments and configurations that block access to the /CFIDE directory. The default location is set in the ColdFusion Administrator; by default, it is /CFIDE/scripts/cfform.js.
- **Archive** Specifies the URL of downloadable Java classes for cfgrid, cfslider, and cftree applet controls. The default location is /CFIDE/classes/cfapplets.jar.
- **Height** Specifies the height of the form.
- **Width** Specifies the width of the form.
- **Display Tag Editor for cfform** Lets you edit properties not listed in the Property inspector.

4 Insert ColdFusion form controls.
Place the insertion point where you want the ColdFusion form control to appear in the ColdFusion form, and then select the control from the Insert menu (Insert > ColdFusion Objects > CFForm), or from the CFForm category in the Insert panel.

5 If required, set the properties of the control with the Property inspector.

Make sure the control is selected in Design view and then set the properties in the Property inspector. For more information on the properties, click the Help icon in the Property inspector.

6 Adjust the layout of the ColdFusion form.

If you're creating an HTML-based form, you can use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a ColdFusion form in another ColdFusion form (that is, you cannot overlap tags), but you can include more than one ColdFusion form in a page.

If you're creating a Flash-based form, use Cascading Style Sheets (CSS) styles to lay out your form. ColdFusion ignores any HTML in the form.

Remember to label the ColdFusion form fields with descriptive text to let users know what they are responding to. For example, create a “Type your name label” to request name information.

Insert ColdFusion form controls

Use the Insert panel or Insert menu to quickly insert ColdFusion form controls into a ColdFusion form. You need to create a blank ColdFusion form before inserting controls in it.

*Note:*

*These enhancements are only available if you have access to a computer running ColdFusion MX 7 or later.*

1 In Design view, place the insertion point inside the form outline.

2 Select the control from the Insert menu (Insert > ColdFusion Objects > CFForm), or from the CFForm category in the Insert panel.

3 Click the control on the page to select it and then set its properties in the Property inspector.

For information on the properties of specific controls, see the topics about the controls.

Insert ColdFusion text fields

You can visually insert a ColdFusion text field or password field into your form, and then set its options.

*Note:*

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

Visually insert a ColdFusion text field

1 In Design view, place the insertion point inside the form outline.

2 In the CFForm category of the Insert panel, click the CF Text Field icon or select Insert > ColdFusion Objects > CFForm > CFtextfield.

A text field appears in the form.

3 Select the text field and set its properties in the Property inspector.

4 To label the text field on the page, click beside it and enter text for the label.
Visually insert a password field

1. Repeat steps 1 and 2 in the previous procedure for inserting a text field.
2. Select the inserted text field to display its Property inspector.
3. Select the Password value from the Text Mode pop-up menu in the Property inspector.

**CFTextField options (ColdFusion)**

To set the options of a ColdFusion text or password field, set any of the following options in the CFTextField Property inspector:

- **CFTextField** Sets the id attribute of the `<cfinput>` tag.
- **Value** Lets you specify text to be displayed in the field when the page first opens in a browser. The information can either be static or dynamic.
  
  To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the text field when you view the form in a browser.
- **Text Mode** Lets you switch between the standard text input field and the password input field. The attribute modified by this control is `type`.
- **Read Only** Lets you make the displayed text read-only.
- **Max Length** Sets the maximum number of characters accepted by the text field.
- **Mask** Lets you specify a mask for your requested text. You use this property to validate the user input. The mask format is composed of A, 9, X and ? characters.
  
  **Note:**

  *The mask attribute is ignored for the `<cfinput type="password"` tag.*
- **Validate** Specifies the type of validation for the current field.
- **Validate At** Specifies when the field is validated: onSubmit, onBlur or onServer.
- **Label** Lets you specify a label for the text field.
- **Pattern** Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
- **Height** Lets you specify the height of the control, in pixels.
- **Width** Lets you specify the width of the control, in pixels.
- **Size** Lets you specify the size of the control.
- **Required** Lets you specify whether the text field must contain data before the form is submitted to the server.
- **Display Tag Editor** Lets you edit properties not listed in the Property inspector.

**Insert ColdFusion hidden fields**

You can visually insert a ColdFusion hidden field into your form and set its properties. Use hidden fields to store and submit information that the user does not enter. The information is hidden from the user.

**Note:**

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, place the insertion point inside the form outline.
2 In the CFForm category of the Insert panel, click the CF Hidden Field icon.

A marker appears in the ColdFusion form. If you don't see the marker, select View > Visual Aids > Invisible Elements.

3 Select the hidden field on the page and set any of the following options in the Property inspector:

- **Cfhiddenfield** lets you specify the unique name for the hidden field.
- **Value** lets you specify a value for the hidden field. The data can either be static or dynamic.
  
  To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the text field when you view the form in a browser.

- **Validate** specifies the type of validation for the current field.
- **Validate At** specifies when the field is validated: onSubmit, onBlur or onServer.
- **Label** lets you specify a label for the control. This property is ignored by the ColdFusion server at run time.
- **Pattern** lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
- **Height** lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.
- **Width** lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
- **Size** lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.
- **Required** lets you specify whether the hidden field must contain data before the form is submitted to the server.
- **Display Tag Editor** lets you edit properties not listed in the Property inspector.

## Insert ColdFusion text areas

You can visually insert a ColdFusion text area into your form and set its properties. A text area is an input element that consists of multiple lines of text.

*Note:*

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1 Place the insertion point inside the form outline.

2 In the CFForm category of the Insert panel, click the CF Text Area icon.

A text area appears in the ColdFusion form.

3 Select the text area on the page and set any of the following options in the Property inspector:

- **Cftextarea** lets you specify a unique name for the control.
- **Char Width** lets you set the number of characters per line.
- **Num Lines** lets you set the number of rows to display in the text area.
- **Wrap** lets you specify how you want the text entered by users to wrap.
- **Required** lets you specify whether the user must enter data in the field (checked) or not (unchecked).
- **Initial Value** lets you specify text to display in the text area when the page is initially opened in a browser.
Validate  Specifies the type of validation for the field.

Validate At  Specifies when the field is validated: onSubmit, onBlur, or onServer.

Label  Lets you specify a label for the control.

Style  Lets you specify a style for the control. For more information, see the ColdFusion documentation.

Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

4  To label the text area, click beside it and enter text for the label.

Insert ColdFusion buttons

You can visually insert a ColdFusion button into your form and set its properties. ColdFusion buttons control ColdFusion form operations. Buttons can be used to submit ColdFusion form data to the server or to reset the ColdFusion form. Standard ColdFusion buttons are typically labeled Submit, Reset, or Send. You can also assign other processing tasks that you defined in a script. For example, the button might calculate the total cost of selected items based on assigned values.

Note:

This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1  Place the insertion point inside the ColdFusion form outline.

2  In the CFForm category of the Insert panel, click the CF Button icon.

A button appears in the ColdFusion form.

3  Select the button on the page and set any of the following options in the Property inspector:

Cfbutton  Lets you specify a unique name for the control.

Action  Lets you specify the type of button to create.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

The other properties are ignored by the ColdFusion server at run time.

Insert ColdFusion check boxes

You can visually insert a ColdFusion check box into your form and set its properties. Use check boxes to let users select more than one option from a set of options.

Note:

This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1  Place the insertion point inside the form outline.

2  In the CFForm category of the Insert panel, click the CF Checkbox icon.

A check box appears in the ColdFusion form.

3  Select the check box on the page and set any of the following options in the Property inspector:

Cfcheckbox  Lets you specify a unique name for the control.
Checked Value  Lets you specify a value to be returned by the check box if the user checks it.

Initial State  Lets you specify whether the check box is checked when the page first opens in a browser.

Validate  Specifies the type of validation for the check box.

Validate At  Specifies when the check box is validated: onSubmit, onBlur, or onServer.

Label  Lets you specify a label for the check box.

Pattern  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Size  Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

Required  Lets you specify whether the checkbox must be checked before the form is submitted to the server.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

4  To label the check box, click next to the check box on the page and enter text for the label.

Insert ColdFusion radio buttons

You can visually insert a ColdFusion radio button into your form and set its properties. Use radio buttons when you want users to select only one choice from a set of options. Radio buttons are typically used in groups. All radio buttons in a group must have the same name.

Note:

This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1  Place the insertion point inside the form outline.

2  Select Insert > ColdFusion Objects > CFForm > CFradiobutton.

A radio button appears in the ColdFusion form.

3  Select the radio button on the page and set any of the following options in the Property inspector:

Cfradiobutton  Lets you specify a unique name for the control.

Checked Value  Lets you specify a value to be returned by the radio button if the user checks it.

Initial State  Lets you specify whether the radio button is checked when the page first opens in a browser.

Validate  Specifies the type of validation for the radio button.

Validate At  Specifies when the radio button is validated: onSubmit, onBlur, or onServer.

Label  Lets you specify a label for the radio button.

Pattern  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
Size  Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

Required  Lets you specify whether the radio button must be checked before the form is submitted to the server.

Display Tag Editor  Lets you edit properties not listed in the Property inspector.

4  To label the radio button, click beside it on the page and enter text for the label.

Insert ColdFusion select boxes

You can visually insert a ColdFusion select box into your form and set its properties. A select box lets a visitor select one or more items from a list. Select boxes are useful when you have a limited amount of space, but need to display many items. They’re also useful when you want to control the values returned to the server. Unlike text fields, where users can type anything they want, including invalid data, with select boxes, you can set the exact values returned by a menu.

You can insert two types of select boxes into a form: a menu that “drops down” when the user clicks it, or a menu that displays a scrollable list of items that the user can select.

Note:

This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1  Place the insertion point inside the form outline.

2  In the CFForm category of the Insert panel, click the CF Select icon.

A select box appears in the ColdFusion form.

3  Select the select box on the page and set any of the following options in the Property inspector:

Cfselect  Lets you specify a unique name for the control.

Type  Lets you choose between a pop-up menu or a list. If you select the list type, the List Height and Allow Multiple List Selections options become available.

List Height  Lets you specify the number of lines to display in the list menu. Available only if you select the list type.

Allow Multiple List Selections  Lets you specify whether the user can select more than one option from the list at a time. Available only if you select the list type.

Edit Values  Opens a dialog box that lets you add, edit, or remove options from the select box.

Initially Selected  Lets you specify which option is selected by default. You can select more than one option if you selected the Allow Multiple List Selections option.

Recordset  Lets you specify the name of the ColdFusion query you want to use to populate the list or menu.

Display Column  Lets you specify the recordset column to supply the display label of each list element. Used with Recordset property.

Value Column  Lets you specify the recordset column to supply the value of each list element. Used with the Recordset property.

Flash Label  Lets you specify a label for the select box.

Flash Height  Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.

Flash Width  Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
**Dynamic sites, pages and web forms**

- **Message**  Specifies the message to be displayed if the Required property is set to Yes and the user failed to make a selection before submitting the form.

- **Required**  Lets you specify whether a menu item must be selected before the form is submitted to the server.

- **Display Tag Editor**  Lets you edit properties not listed in the Property inspector.

**Insert ColdFusion image fields**

You can visually insert a ColdFusion image field into your form and set its options. Use image fields to make custom buttons.

*Note:*

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, place the insertion point inside the form outline.

2. In the CFForm category of the Insert panel, click the CF Image Field icon. Browse to select the image to insert, and click OK. Alternatively, you can enter the path of the image file in the Src box.

   *Note:*

   *If the image is outside the site root folder, you should copy the image to the root folder. Images outside the root folder might not be accessible when you publish the site.*

3. Select the image field on the page and set any of the following options in the Property inspector:

   - **Cfimagefield**  Lets you specify a unique name for the control.

   - **Src**  Lets you specify the URL of the inserted image.

   - **Alt**  Lets you specify a message when the image cannot be displayed.

   - **Align**  Lets you specify the alignment of the picture.

   - **Border**  Lets you set the width of the image border.

   - **Edit Image**  Opens the image in your default image editor.

   To define a default image editor, select Edit > Preferences > File Types / Editors. Otherwise, the Edit Image button does not perform any action.

   - **Validate**  Specifies the type of validation for the image field.

   - **Validate At**  Specifies when the field is validated: onSubmit, onBlur, or onServer.

   - **Label**  Lets you specify a label for the radio button.

   - **Pattern**  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.

   - **Height**  Lets you specify the height of the control, in pixels.

   - **Width**  Lets you specify the width of the control, in pixels.

   - **Size**  Lets you specify the size of the control. This property is ignored by the ColdFusion server at run time.

   - **Required**  Lets you specify whether the control must contain data before the form is submitted to the server.

   - **Display Tag Editor**  Lets you edit properties not listed in the Property inspector.
**Insert ColdFusion file fields**

You can visually insert a ColdFusion file field into your form and set its properties. Use a file field to let users select a file from their computer, such as a word processing document or a graphics file, and upload it to the server. A ColdFusion file field looks like other text fields, except it also has a Browse button. Users can manually enter the path to the file they want to upload, or use the Browse button to locate and select the file.

File fields require that you use the POST method to transmit files from the browser to the server. The file is posted to the address that you specify in the form’s Action box. Contact your server administrator to confirm that anonymous file uploads are allowed before using a file field in your form.

File fields also require that the form encoding be set to multipart/form-data. Dreamweaver sets this automatically when you insert a file field control.

*Note:*

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, select the CFForm to display its Property inspector.
   
   To quickly select the form, click anywhere in the form outline and click the `<cfform>` tag in the tag selector at the bottom of the Document window.

2. In the Property inspector, set the form method to POST.

3. From the Enctype pop-up menu, select multipart/form-data.

4. Position the insertion point inside the form outline where you want to file field to appear.

5. Select Insert > ColdFusion Objects > CFForm > CFfilefield.
   
   A file field appears in the document.

6. Select the file field on the page and set any of the following properties in the Property inspector:

   - **Cffilefield** Lets you specify a unique name for the control.
   - **MaxLength** Lets you specify the maximum number of characters that the path to the file can have.
   - **Validate** Specifies the type of validation for the field.
   - **Validate At** Specifies when the field is validated: onSubmit, onBlur, or onServer.
   - **Label** Lets you specify a label for the field.
   - **Pattern** Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
   - **Height** Lets you specify the height of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   - **Width** Lets you specify the width of the control, in pixels. This property is ignored by the ColdFusion server at run time.
   - **Size** Lets you specify the size of the control.
   - **Required** Lets you specify whether the file field must contain data before the form is submitted to the server.
   - **Display Tag Editor** Lets you edit properties not listed in the Property inspector.
**Insert ColdFusion date fields**

Although you can’t visually insert a ColdFusion date field in Dreamweaver, you can visually set its properties. A ColdFusion date field is a special type of text field that lets users select a date from a pop-up calendar to insert it in the text field.

*Note:*

*This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.*

1. In Design view, select the CFForm to display its Property inspector.
   
   To quickly select the form, click anywhere in the form outline and click the `<cfform>` tag in the tag selector at the bottom of the Document window.

2. In the Property inspector, set the form’s Format property to Flash.
   
   The date field control can only be rendered in Flash-based ColdFusion forms.

3. Switch to Code view (View > Code) and enter the following tag anywhere between the opening and closing CFForm tags:

   ```
   <cfinput name=”datefield” type=”datefield”>
   ```

4. Switch to Design view, select the date field on the page, and then set any of the following options in the Property inspector:

   - **Cfdatefield**  Lets you specify a unique name for the control.
   - **Value**  Lets you specify a date to be displayed in the field when the page first opens in a browser. The date can either be static or dynamic.
     
     To specify a dynamic value, click the lightning bolt icon beside the Value box and select a recordset column in the Dynamic Data dialog box. The recordset column supplies a value to the date field when you view the form in a browser.
   - **Validate**  Specifies the type of validation for the field.
   - **Validate At**  Specifies when the field is validated: onSubmit, onBlur, or onServer.
   - **Label**  Lets you specify a label for the field.
   - **Pattern**  Lets you specify a JavaScript regular expression pattern to validate input. Omit leading and trailing slashes. For more information, see the ColdFusion documentation.
   - **Height**  Lets you specify the height of the control, in pixels.
   - **Width**  Lets you specify the width of the control, in pixels.
   - **Size**  Lets you specify the size of the control.
   - **Required**  Lets you specify whether the date field must contain a value before the form is submitted to the server.
   - **Display Tag Editor**  Lets you edit properties not listed in the Property inspector.

**Modify ColdFusion form controls**

You can visually change the properties of ColdFusion form controls whether you’re working in Design view or Code view.

*Note:*
This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. In Design view, select the form control on the page; in Code view, click anywhere inside the control's tag.
   The Property inspector displays properties of the form control.

2. Change the control's properties in the Property inspector.
   For more information, click the Help icon in the Property inspector.

3. To set more properties, click the Display Tag Editor button in the Property inspector and set the properties in the Tag editor that appears.

Validate ColdFusion form data

You can build ColdFusion forms in Dreamweaver that check the contents of specified fields to ensure the user entered the correct data type.

Note:

This enhancement is available only if you have access to a computer running ColdFusion MX 7 or later.

1. Create a ColdFusion form that includes at least one input field and one Submit button. Ensure that every ColdFusion field that you want to validate has a unique name.

2. Select a field in the form that you want to validate.

3. In the Property inspector, specify how you want to validate the field.
   The lower part of each input Property inspector contains controls to help you define the specific validation rule. For example, you might want to specify that a text field should contain a telephone number. To do this, select Telephone from the Value pop-up menu in the Property inspector. You can also specify when to validate from the Validate At pop-up menu.

Create web forms

Note:

Support for HTML form elements has been enhanced in Dreamweaver Creative Cloud updates. For information, see Enhanced HTML5 support for form elements.

About web forms

When a visitor enters information into a web form displayed in a web browser and clicks the submit button, the information is sent to a server where a server-side script or application processes it. The server responds by sending the processed information back to the user (or client), or by performing some other action based on the form’s contents.

You can create forms that submit data to most application servers, including PHP, ASP, and ColdFusion. If you use ColdFusion, you can also add ColdFusion-specific form controls to your forms.

Note:

You can also send form data directly to an e-mail recipient.
Form objects

In Dreamweaver, form input types are called *form objects*. Form objects are the mechanisms that allow users to input data. You can add the following form objects to a form:

**Text fields** Accept any type of alphanumeric text entry. The text can be displayed as a single line, multiple lines, and as a password field where entered text is replaced by asterisks or bullets to hide the text from onlookers.

![Form objects](image)

Note:

*Passwords and other information sent to a server using a password field are not encrypted. The transferred data can be intercepted and read as alphanumeric text. For this reason, you should always provide encryption for data you want to keep secure.*

**Hidden fields** Store information entered by a user, such as a name, e-mail address, or viewing preference, and then use that data when the user next visits the site.

**Buttons** Perform actions when clicked. You can add a custom name or label for a button, or use one of the predefined “Submit” or “Reset” labels. Use a button to submit form data to the server or to reset the form. You can also assign other processing tasks that you define in a script. For example, the button might calculate the total cost of items selected based on assigned values.

**Check boxes** Allow multiple responses within a single group of options. A user can select as many options as apply. The following example shows three check box items selected: Surfing, Mountain Biking, and Rafting.
Radio buttons  Represent exclusive choices. Selecting a button within a radio button group deselects all others in the group (a group consists of two or more buttons that share the same name). In the example below, Rafting is the currently selected option. If the user clicks Surfing, the Rafting button is automatically cleared.

List menus  Display option values within a scrolling list that allows users to select multiple options. The List option displays the option values in a menu that allows users to select only a single item. Use menus when you have a limited amount of space, but must display many items, or to control the values returned to the server. Unlike text fields where users can type anything they want, including invalid data, you set the exact values returned by a menu.

Note:
A pop-up menu on an HTML form is not the same as a graphical pop-up menu. For information on creating, editing, and showing and hiding a graphical pop-up menu, see the link at the end of this section.

Jump menus  Navigational lists or pop-up menus that let you insert a menu in which each option links to a document or file.

File fields  Let users browse to a file on their computer and upload the file as form data.

Image fields  Let you insert an image in a form. Use image fields to make graphical buttons such as Submit or Reset buttons. Using an image to perform tasks other than submitting data requires attaching a behavior to the form object.
Create an HTML form

(Creative Cloud users only): As part of HTML5 support, new attributes have been introduced in the Properties panel for form elements. In addition, four new form elements (E-mail, search, telephone, URL) have been introduced in the Forms section of the Insert panel. For more information, see Enhanced HTML5 support for form elements.

1. Open a page and place the insertion point where you want the form to appear.
2. Select Insert > Form, or select the Forms category in the Insert panel and click the Form icon.
   In Design view, forms are indicated by a dotted red outline. If you don’t see this outline, select View > Visual Aids > Invisible Elements.
3. Set the properties of the HTML form in the Property inspector (Window > Properties):
   a. In the Document window, click the form outline to select the form.
   b. In the Form Name box, type a unique name to identify the form.
      Naming a form makes it possible to reference or control the form with a scripting language, such as JavaScript or VBScript. If you do not name the form, Dreamweaver generates a name using the syntax formn, and increments the value of n for each form added to the page.
   c. In the Action box, specify the page or script that will process the form data by typing the path, or clicking the folder icon to navigate to the appropriate page or script. Example: processorder.php.
   d. In the Method pop-up menu, specify the method to transmit the form data to the server.
      Set any of the following options:
      Default Uses the browser’s default setting to send the form data to the server. Typically, the default value is the GET method.
      GET Appends the value to the URL requesting the page.
      POST Embeds the form data in the HTTP request.
      Do not use the GET method to send long forms. URLs are limited to 8192 characters. If the amount of data sent is too large, data will be truncated, leading to unexpected or failed processing results.
      Dynamic pages generated by parameters passed by the GET method can be bookmarked because all the values needed to regenerate the page are contained in the URL displayed in the browser's Address box. In contrast, dynamic pages generated by parameters passed by the POST method cannot be bookmarked.
      If you collect confidential user names and passwords, credit card numbers, or other confidential information, the POST method may appear more secure than the GET method. However, the information sent by the POST method is not encrypted and can easily be retrieved by a hacker. To ensure security, use a secure connection to a secure server.
   e. (Optional) In the Enctype pop-up menu, specify the MIME encoding type of the data submitted to the server for processing.
      The default setting of application/x-www-form-urlencoded is typically used in conjunction with the POST method. If you are creating a file-upload field, specify the multipart/form-data MIME type.
   f. (Optional) In the Target pop-up menu, specify the window in which to display the data returned by the invoked program.
If the named window is not already open, a new window with that name opens. Set any of the following target values:

- **_blank** Opens the destination document in a new unnamed window.
- **_parent** Opens the destination document in the parent window of the one displaying the current document.
- **_self** Opens the destination document in the same window as the one in which the form was submitted.
- **_top** Opens the destination document in the body of the current window. This value can be used to ensure that the destination document takes over the full window even if the original document was displayed in a frame.

4 Insert form objects in the page:

a. Place the insertion point where the form object should appear in the form.

b. Select the object in the Insert > Form menu, or in the Forms category of the Insert panel.

c. Complete the Input Tag Accessibility Attributes dialog box. For more information, click the Help button in the dialog box.

**Note:**

*If you don't see the Input Tag Accessibility Attributes dialog box, you might have had the Insertion point in Code view when you tried to insert the form object. Make sure the Insertion point is in Design view and try again. For more information on this topic, see David Powers's article* Creating HTML forms in Dreamweaver.

d. Set the properties of the objects.

e. Enter a name for the object in the Property inspector.

Every text field, hidden field, check box, and list/menu object must have a unique name that identifies the object in the form. Form object names cannot contain spaces or special characters. You can use any combination of alphanumeric characters and an underscore (_). The label you assign to the object is the variable name that stores the value (the entered data) of the field. This is the value sent to the server for processing.

**Note:**

*All radio buttons in a group must have the same name.*

f. To label the text field, check box, or radio button object on the page, click beside the object and type the label.

5 Adjust the layout of the form.

Use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a form in another form (that is, you cannot overlap tags), but you can include more than one form in a page.

When designing forms, remember to label the form fields with descriptive text to let users know what they're responding to—for example, “Type your name” to request name information.

Use tables to provide structure for form objects and field labels. When using tables in forms make sure all the table tags are included between the form tags.

For a tutorial on creating forms, see [www.adobe.com/go/vid0160](http://www.adobe.com/go/vid0160).

For a tutorial on styling forms with CSS, see [www.adobe.com/go/vid0161](http://www.adobe.com/go/vid0161).

**Text Field object properties**

Select the text field object, and set any of the following options in the Property inspector:

- **Char Width** Specifies the maximum number of characters that can be displayed in the field. This number can be less than Max Chars, which specifies the maximum number of characters that can be entered in the field. For example, if the Char Width is set to 20 (the default value) and a user enters 100 characters, only 20 of those characters will be
Dynamic sites, pages and web forms

viewable in the text field. Although you cannot view the characters in the field, they are recognized by the field object and are sent to the server for processing.

**Max Chars** Specifies the maximum number of characters that the user can enter in the field for single-line text fields. Use Max Chars to limit zip codes to 5 digits, limit passwords to 10 characters, and so on. If you leave the Max Chars box blank, users can enter any amount of text. If the text exceeds the character width of the field the text will scroll. If a user exceeds the maximum number of characters, the form produces an alert sound.

**Num Lines** (Available when the Multiline option is selected) Sets the height of the field for multiple-line text fields.

**Disabled** Disables the text area.

**Read-only** Makes the text area a read-only text area.

**Type** Designates the field as a single-line, multiple-line, or password field.

**Single-line** Results in an *input* tag with its *type* attribute set to *text*. The Char Width setting maps to the *size* attribute, and the Max Chars setting maps to the *maxlength* attribute.

**Multi-line** Results in a *textarea* tag. The Char Width setting maps to the *cols* attribute, and the Num Lines setting maps to the *rows* attribute.

**Password** Results in an *input* tag with its *type* attribute set to *password*. The Char Width and Max Chars settings map to the same attributes as in single-line text fields. When a user types in a password text field, the input appears as bullets or asterisks to protect it from observation by others.

**Initial** Assigns the value displayed in the field when the form first loads. For example, you might indicate that the user enters information in the field by including a note or example value.

**Class** Lets you apply CSS rules to the object.

**Button object options**

**Button Name** Assigns a name to the button. Two reserved names, Submit and Reset, tell the form to submit the form data to the processing application or script, or to reset all the form fields to their original values, respectively.

**Value** Determines the text that appears on the button.

**Action** Determines what happens when the button is clicked.

**Submit Form** Submits the form data for processing when the user clicks the button. The data is submitted to the page or script specified in the form’s Action property.

**Reset Form** Clears the contents of the form when the button is clicked.

**None** Specifies the action to be performed when the button is clicked. For example, you can add a JavaScript behavior that opens another page when the user clicks the button.

**Class** Applies CSS rules to the object.

**Check Box object options**

**Checked Value** Sets the value to be sent to the server when the check box is checked. For example, in a survey you might set a value of 4 for strongly agree and a value of 1 for strongly disagree.

**Initial State** Determines whether the check box is selected when the form loads in the browser.

**Dynamic** Lets the server dynamically determine the initial state of the check box. For example, you can use check boxes to visually present the Yes/No information stored in a database record. At design time, you don’t know that information. At run time the server reads the database record and selects the check box if the value is Yes.

**Class** Applies Cascading Style Sheets (CSS) rules to the object.
**Single radio button object options**

**Checked Value**  Sets the value to be sent to the server when the radio button is selected. For example, you might type `skiing` in the Checked Value box to indicate a user chose skiing.

**Initial State**  Determines whether the radio button is selected when the form loads in the browser.

**Dynamic**  Lets the server dynamically determine the initial state of the radio button. For example, you can use radio buttons to visually present information stored in a database record. At design time, you don't know that information. At run time the server reads the database record and checks the radio button if the value matches one you specified.

**Class**  Applies CSS rules to the object.

**Menu options**

**List/Menu**  Assigns a name to the menu. The name must be unique.

**Type**  Indicates whether the menu drops down when clicked (the Menu option) or displays a scrollable list of items (the List option). Select the Menu option if you want only one option to be visible when the form is displayed in a browser. To display the other choices, the user must click the down arrow.

Select the List option to list some or all the options when the form is displayed in a browser, to let users select multiple items.

**Height**  (List type only) Sets the number of items displayed in the menu.

**Selections**  (List type only) Indicates whether the user can select multiple items from the list.

**List Values**  Opens a dialog box that lets you add the items to a form menu:

1. Use the Plus (+) and Minus (–) buttons to add and remove items in the list.
2. Enter label text and an optional value for each menu item.
   
   Each item in the list has a label (the text that appears in the list) and a value (the value that is sent to the processing application if the item is selected). If no value is specified, the label is sent to the processing application instead.
3. Use the up and down arrow buttons to rearrange items in the list.
   
   Items appear in the menu in the same order as they appear in the List Values dialog box. The first item on the list is the selected item when the page is loaded in a browser.

**Dynamic**  Lets the server dynamically select an item in the menu when it is first displayed.

**Class**  Lets you apply CSS rules to the object.

**Initially Selected**  Sets the items selected in the list by default. Click the item or items in the list.

**Insert file-upload fields**

You can create a file-upload field that lets users select a file on their computer—such as a word processing document or graphics file—and upload the file to the server. A file field looks like other text fields except it also contains a Browse button. The user either manually enters the path to the file they want to upload, or uses the Browse button to locate and select the file.

Before you can use file-upload fields, you must have a server-side script or a page capable of handling file submissions. Consult the documentation of the server technology you use to process form data. For example, if you use PHP, see “Handling files uploads” in the online PHP Manual at [http://us2.php.net/features.file-upload.php](http://us2.php.net/features.file-upload.php).

File fields require that you use the `POST` method to transmit files from the browser to the server. The file is posted to the address you specify in the form's Action box.

**Note:**
Contact your server's administrator to confirm that anonymous file uploads are allowed before using the file field.

1. Insert a form in the page (Insert > Form).
2. Select the form to display its Property inspector.
3. Set the form Method to POST.
4. From the Enctype pop-up menu, select multipart/form-data.
5. In the Action box, specify the server-side script or page capable of handling the uploaded file.
6. Place the insertion point inside the form outline, and select Insert > Form > File Field.
7. Set any of the following options in the Property inspector:
   - **File Field Name** Specifies the name for the file field object.
   - **Char Width** Specifies the maximum number of characters that can be displayed in the field.
   - **Max Chars** Specifies the maximum number of characters the field will hold. If the user browses to locate the file, the filename and path can exceed the specified Max Chars value. However, if the user attempts to type in the filename and path, the file field will only allow the number of characters specified by the Max Chars value.

**Insert an image button**

You can use images as button icons. Using an image to perform tasks other than submitting data requires attaching a behavior to the form object.

1. In the document, place the insertion point inside the form outline.
2. Select Insert > Form > Image Field.
   - The Select Image Source dialog box appears.
3. Select the image for the button in the Select Image Source dialog box, and click OK.
4. Set any of the following options in the Property inspector:
   - **ImageField** Assigns a name to the button. Two reserved names, Submit and Reset, tell the form to submit the form data to the processing application or script, or to reset all the form fields to their original values, respectively.
   - **Src** Specifies the image you want to use for the button.
   - **Alt** Lets you enter descriptive text in case the image fails to load in the browser.
   - **Align** Sets the align attribute of the object.
   - **Edit Image** Starts your default image editor and opens the image file for editing.
   - **Class** Lets you apply CSS rules to the object.
5. To attach a JavaScript behavior to the button, select the image, and then select the behavior in the Behaviors panel (Window > Behaviors).

**Hidden field object options**

- **HiddenField** Specifies the name for the field.
- **Value** Assigns a value to the field. This value is passed to the server when the form is submitted.

**Insert a group of radio buttons**

1. Place the insertion point inside the form outline.
2. Select Insert > Form > Radio Group.
3 Complete the dialog box and click OK.
   a. In the Name box, enter a name for the radio button group.
      
      If you set the radio buttons to pass parameters back to the server, the parameters are associated with the name. For example, if you name the group myGroup and set the form method to GET (that is, you want the form to pass URL parameters instead of form parameters when the user clicks the submit button), the expression myGroup="CheckedValue" is passed in the URL to the server.
      
      b. Click the Plus (+) button to add a radio button to the group. Enter a label and checked value for the new button.
      
      c. Click the up or down arrows to reorder the buttons.
      
      d. To set a particular radio button to be selected when the page opens in a browser, enter a value equal to the radio button's value in the Select Value Equal To box.
         
         Enter a static value or specify a dynamic one by clicking the lightning bolt icon beside the box and selecting a recordset that contains possible checked values. In either case, the value you specify should match the checked value of one of the radio buttons in the group. To view the checked values of the radio buttons, select each radio button and open its Property inspector (Window > Properties).
      
      e. Select the format in which you want Dreamweaver to lay out the buttons. Lay out the buttons using line breaks or a table. If you select the table option, Dreamweaver creates a single-column table, and places the radio buttons on the left and the labels on the right.
         
         You can also set the properties in the Property inspector or directly in Code view.

Insert a group of check boxes

1 Place the insertion point inside the form outline.
2 Select Insert > Form > Checkbox Group.
3 Complete the dialog box and click OK.
   a. In the Name box, enter a name for the check box group.
      
      If you set the check boxes to pass parameters back to the server, the parameters are associated with the name. For example, if you name the group myGroup and set the form method to GET (that is, you want the form to pass URL parameters instead of form parameters when the user clicks the submit button), the expression myGroup="CheckedValue" is passed in the URL to the server.
      
      b. Click the Plus (+) button to add a check box to the group. Enter a label and checked value for the new check box.
      
      c. Click the up or down arrows to reorder the check boxes.
      
      d. To set a particular check box to be selected when the page opens in a browser, enter a value equal to the check box's value in the Select Value Equal To box.
         
         Enter a static value or specify a dynamic one by clicking the lightning bolt icon beside the box and selecting a recordset that contains possible checked values. In either case, the value you specify should match the checked value of one of the check boxes in the group. To view the checked values of the check boxes, select each check box and open its Property inspector (Window > Properties).
      
      e. Select the format in which you want Dreamweaver to lay out the check boxes.
         
         Lay out the check boxes using line breaks or a table. If you select the table option, Dreamweaver creates a single-column table, and places the check boxes on the left and the labels on the right.
      
         You can also set the properties in the Property inspector or directly in Code view.

Last updated 11/7/2019
About dynamic form objects

A dynamic form object is a form object whose initial state is determined by the server when the page is requested from the server, not by the form designer at design time. For example, when a user requests a PHP page that contains a form with a menu, a PHP script in the page automatically populates the menu with values stored in a database. The server then sends the completed page to the user's browser.

Making form objects dynamic can simplify site maintenance. For example, many sites use menus to present users with a set of options. If the menu is dynamic, you can add, remove, or change menu items in a single place—the database table in which the items are stored—to update all instances of the same menu on the site.

Insert or change a dynamic HTML form menu

You can dynamically populate an HTML form menu or list menu with entries from a database. For most pages, you can use an HTML menu object.

Before you begin, you must insert an HTML form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the menu.

1 Insert an HTML List/Menu form object in your page:

   a. Click inside the HTML form on the page (Insert > Form > Form).
   b. Select Insert > Form > List/Menu to insert the form object.

2 Do one of the following:

   • Select the new or an existing HTML List/Menu form object, and then click the Dynamic button in the Property inspector.
   • Select Insert > Data Objects > Dynamic Data > Dynamic Select List.

3 Complete the Dynamic List/Menu dialog box, and click OK.

   a. In the Options From Recordset pop-up menu, select the recordset to use as a content source. You also use this menu to edit both static and dynamic list/menu items later.
   b. In the Static Options area, enter a default item in the list or menu. Also, use this option to edit static entries in a list/menu form object after adding dynamic content.
   c. (Optional) Use the Plus (+) and Minus (–) buttons to add and remove items in the list. Items are in the same order as in the Initial List Values dialog box. The first item on the list is the selected item when the page is loaded in a browser. Use the up and down arrow buttons to rearrange items in the list.
   d. In the Values pop-up menu, select the field containing the values of the menu items.
   e. In the Labels pop-up menu, select the field containing the labels for the menu items.
   f. (Optional) To specify that a particular menu item is selected when the page opens in a browser or when a record is displayed in the form, enter a value equal to the menu item's value, in the Select Value Equal To box.

   You can enter a static value or you can specify a dynamic one by clicking the lightning bolt icon beside the box, and selecting a dynamic value from the list of data sources. In either case, the value you specify should match one of the menu item values.

Make existing HTML form menus dynamic

1 In Design view, select the list/menu form object.
Dynamic sites, pages and web forms

2 In Property inspector, click the Dynamic button.
3 Complete the dialog box, and click OK.

**Display dynamic content in HTML text fields**
You can display dynamic content in HTML text fields when the form is viewed in a browser.

Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the text field.

1 Select the text field in the HTML form on your page.
2 In the Property inspector, click the lightning bolt icon beside the Init Val box to display the Dynamic Data dialog box.
3 Select the recordset column that will supply a value to the text field, and then click OK.

**Set the Dynamic Text Field dialog box options**
1 Select the text field to make dynamic from the Text Field pop-up menu.
2 Click the lightning bolt icon beside the Set Value To box, select a data source from the list of data sources, and click OK.

The data source should contain textual information. If no data sources appear in the list, or if the available data sources don't meet your needs, click the Plus (+) button to define a new data source.

**Dynamically preselect an HTML check box**
You can let the server decide whether to select a check box when the form is displayed in a browser.

Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and you must define a recordset or other source of dynamic content for the check boxes. Ideally, the source of content should contain Boolean data, such as Yes/No or true/false.

1 Select a check box form object on your page.
2 In the Property inspector, click the Dynamic button.
3 Complete the Dynamic CheckBox dialog box, and click OK:
   - Click the lightning bolt icon beside the Check If box and select the field from the list of data sources.
   - The data source must contain Boolean data such as Yes and No, or true and false. If no data sources appear in the list, or if the available data sources don't meet your needs, click the Plus (+) button to define a new data source.
   - In the Equal To box, enter the value the field must have for the check box to appear selected.
   - For example, for the check box to appear selected when a specific field in a record has a value of Yes, enter Yes in the Equal To box.

_**Note:**_
*This value is also returned to the server if the user clicks the form's Submit button.*

**Dynamically preselect an HTML radio button**
Dynamically preselect an HTML radio button when a record is displayed in the HTML form in a browser.
Before you begin, you must create the form in a ColdFusion, PHP, or ASP page, and insert at least one group of HTML radio buttons (Insert > Form > Radio Group). You must also define a recordset or other source of dynamic content for the radio buttons. Ideally, the source of content should contain Boolean data, such as Yes/No or true/false.

1 In Design view, select a radio button in the radio group.
2 In the Property inspector, click the Dynamic button.
3 Complete the Dynamic Radio Group dialog box, and click OK.

**Set the Dynamic Radio Group dialog box options**

1 In the Radio Button Group pop-up menu, select a form and radio button group in the page.

   The Radio Button Value box displays the values of all radio buttons in the group.

2 Select a value to dynamically preselect from the list of values. This value is displayed in the Value box.
3 Click the lightning bolt icon beside the Select Value Equal To box and select a recordset that contains possible checked values for the radio buttons in the group.

   The recordset you select contains values that match the radio buttons' checked values. To view the checked values of the radio buttons, select each radio button and open its Property inspector (Window > Properties).
4 Click OK.

**Set the Dynamic Radio Group dialog box options (ColdFusion)**

1 Select a radio group and form from the Radio Group pop-up menu.
2 Click the lightning bolt icon next to Select Value Equal To box.
3 Complete the Dynamic Data dialog box, and click OK.
   a. Select a data source from the list of data sources.
   b. (Optional) Select a data format for the text.
   c. (Optional) Modify the code that Dreamweaver inserts in your page to display the dynamic text.
4 Click OK to close the Dynamic Radio Group dialog box, and insert the dynamic content placeholder in the Radio Group.

**Validate HTML form data**

Dreamweaver can add JavaScript code that checks the contents of specified text fields to ensure that the user has entered the correct type of data.

You can use Spry form widgets to build your forms and validate the contents of specified form elements. For more information, consult the Spry topics listed below.

You can also build ColdFusion forms in Dreamweaver that validate the contents of specified fields. For more information, consult the ColdFusion chapter listed below.

1 Create an HTML form that includes at least one text field and one Submit button.

   Make sure every text field that you want to validate has a unique name.
2 Select the Submit button.
3 In the Behaviors panel (Window > Behaviors), click the Plus (+) button and select the Validate Form behavior from the list.
Set the validation rules for each text field, and click OK. For example, you might specify that a text field for a person's age accepts only numbers.

Note:
The Validate Form behavior is available only if a text field has been inserted into the document.

**Attach JavaScript behaviors to HTML form objects**
You can attach JavaScript behaviors stored in Dreamweaver to HTML form objects such as buttons.

1. Select the HTML form object.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button, and select a behavior from the list.

**Attach custom scripts to HTML form buttons**
Some forms use JavaScript or VBScript to perform form processing or some other action on the client as opposed to sending the form data to the server for processing. You can use Dreamweaver to configure a form button to run a specific client-side script when the user clicks the button.

1. Select a Submit button in a form.
2. In the Behaviors panel (Window > Behaviors), click the Plus (+) button, and select Call JavaScript from the list.
3. In the Call JavaScript box, enter the name of the JavaScript function to run when the user clicks the button, and click OK.
   For example, you can enter the name of a function that doesn't exist yet, such as `processMyForm()`.
4. If your JavaScript function doesn't exist in the head section of the document yet, add it now.
   For example, you could define the following JavaScript function in the head section of the document to display a message when the user clicks the Submit button:

   ```javascript
   function processMyForm()
   {
       alert('Thanks for your order!');
   }
   ```

**Create accessible HTML forms**
When you insert an HTML form object, you can make the form object accessible, and change the accessibility attributes later.

**Add an accessible form object**
1. The first time you add accessible form objects, activate the Accessibility dialog box for form objects (see Optimizing the workspace for visual development).
   This is a one-time-only step.
2. In the document, place the insertion point where you want the form object to appear.
3. Select Insert > Form, and select a form object to insert.
   The Input Tag Accessibility Attributes dialog box appears.
4. Complete the dialog box, and click OK. Here is a partial list of options:
   Note:
The screen reader reads the name you enter as the Label attribute for the object.

**ID** Assigns an ID to the form field. This value can be used to refer to the field from JavaScript; it’s also used as the value of the `for` attribute if you choose the Attach Label Tag Using For option under the Style options.

**Wrap With Label Tag** Wraps a label tag around the form item, as follows:

```html
<label> <input type="radio" name="radiobutton" value="radiobutton"> RadioButton1</label>
```

**Attach Label Tag Using For** Uses the `for` attribute to wrap a label tag around the form item, as follows:

```html
<input type="radio" name="radiobutton" value="radiobutton" id="radiobutton"> <label for="radiobutton">RadioButton2</label>
```

This choice causes the browser to render text associated with a check box and radio button with a focus rectangle, and enables the user to select the check box and radio button by clicking anywhere in the associated text instead of just the check box or radio button control.

**Note:** This is the preferred option for accessibility; however, the functionality may vary depending on the browser.

**No Label Tag** Does not use a label tag, as follows:

```html
<input type="radio" name="radiobutton" value="radiobutton"> RadioButton3
```

**Access Key** Uses a keyboard equivalent (one letter) and the Alt key (Windows) or the Control key (Macintosh) to select the form object in the browser. For example, if you enter `B` as the Access Key, users with a Macintosh browser could type Control+B to select the form object.

**Tab Index** Specifies a tab order for the form objects. If you set tab order for one object, you must set the tab order for all objects.

Setting a tab order is useful when you have other links and form objects on the page and need the user to tab through them in a specific order.

5 Click Yes to insert a form tag.

The form object appears in the document.

**Note:**

*If you press Cancel, the form object appears in the document, but Dreamweaver does not associate accessibility tags or attributes with it.*

**Edit accessibility values for a form object**

1 In the Document window, select the object.

2 Do one of the following:
   - Edit the appropriate attributes in Code view.
   - Right-click (Windows) or Control-click (Macintosh), and then select Edit Tag.

**Enhanced HTML5 support for form elements**

In line with continued support for HTML5 in Dreamweaver, new attributes have been introduced for some form elements. In addition, four new HTML5 form elements have been introduced.

You can locate the form elements in the Insert panel. Select Window > Insert. In the Insert panel menu, select Forms.
New attributes common to form elements

The following new attributes are common to all form elements:

- **Disabled**: Select this option if you want the browser to disable the element.
- **Required**: Select this option if you want the browser to check if a value has been specified.
- **Auto complete**: Select this option to auto fill values when user enters information in a browser.
- **Auto focus**: Select this option if you want the focus to be on this element when browser loads the page.
- **Read only**: Select this option to set the value of the element to read-only.
- **Form**: Specifies one or more forms to which an `<input>` element belongs.
- **Name**: Unique name used to reference the element in the code.
- **Place holder**: Hint that describes the expected value of an input field.
- **Pattern**: Regular expression against which the element's value is validated.
- **Title**: Extra information about an element. Displayed as a tool tip.
- **Tab Index**: Specifies the position of the current element in the tab order for the current document.

Form elements with modified attributes

- **Form No Validate**: Select this option to disable form validation. This selection overrides the No Validate attribute at form level.
- **Form Enc Type**: A MIME type with which a user agent is meant to associate this element for form submission.
- **Form Target**: A browsing context name or keyword that represents the target of the control.
- **Accept charset**: Specifies the character encodings used for form submission.

**Note:**
The links for attributes contain information on all attributes listed in the HTML5 specifications. Not all these attributes are present in the Properties panel. You can use the code view to add attributes not present in the panel.

<table>
<thead>
<tr>
<th>Form Element</th>
<th>New attributes specific to the element</th>
<th>Description of attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Field</td>
<td>List</td>
<td><a href="http://www.w3.org/TR/html-markup/input.text.html">http://www.w3.org/TR/html-markup/input.text.html</a></td>
</tr>
<tr>
<td>Button</td>
<td>&lt;No specific new attribute&gt;</td>
<td><a href="http://www.w3.org/wiki/HTML/Elements/button">http://www.w3.org/wiki/HTML/Elements/button</a></td>
</tr>
<tr>
<td>Check Box</td>
<td>&lt;No specific new attribute&gt;</td>
<td><a href="http://www.w3.org/TR/html-markup/input.checkbox.html">http://www.w3.org/TR/html-markup/input.checkbox.html</a></td>
</tr>
<tr>
<td>File</td>
<td>Multiple</td>
<td><a href="http://www.w3.org/TR/html-markup/input.file.html">http://www.w3.org/TR/html-markup/input.file.html</a></td>
</tr>
<tr>
<td>Form</td>
<td>No validate, Accept charset</td>
<td><a href="http://www.w3.org/TR/2012/WD-html-markup-20120329/form.html">http://www.w3.org/TR/2012/WD-html-markup-20120329/form.html</a></td>
</tr>
<tr>
<td>Hidden</td>
<td>&lt;No specific new attribute&gt;</td>
<td><a href="http://www.w3.org/TR/2012/WD-html-markup-20120329/input.hidden.html">http://www.w3.org/TR/2012/WD-html-markup-20120329/input.hidden.html</a></td>
</tr>
<tr>
<td>Password</td>
<td>&lt;No specific new attribute&gt;</td>
<td><a href="http://www.w3.org/TR/html-markup/input.password.html">http://www.w3.org/TR/html-markup/input.password.html</a></td>
</tr>
<tr>
<td>Image</td>
<td>Width, Height, Action, Method, Form no Validate, Form Enc Type, Form target.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.image.html">http://www.w3.org/TR/html-markup/input.image.html</a></td>
</tr>
</tbody>
</table>
## HTML5 form elements

<table>
<thead>
<tr>
<th>Form element</th>
<th>Available in</th>
<th>Description</th>
<th>Description of attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>12.2</td>
<td>For input fields that should contain a color.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.color.html">http://www.w3.org/TR/html-markup/input.color.html</a></td>
</tr>
<tr>
<td>Date</td>
<td>12.2</td>
<td>Control that helps the user select a date.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.date.html">http://www.w3.org/TR/html-markup/input.date.html</a></td>
</tr>
<tr>
<td>Date Time</td>
<td>12.2</td>
<td>Allows the user to select a date and time (with the time zone).</td>
<td><a href="http://www.w3.org/TR/html-markup/input.datetime.html">http://www.w3.org/TR/html-markup/input.datetime.html</a></td>
</tr>
<tr>
<td>Date Time Local</td>
<td>12.2</td>
<td>Allows the user to select a date and time (no time zone)</td>
<td><a href="http://www.w3.org/TR/html-markup/input.datetime-local.html">http://www.w3.org/TR/html-markup/input.datetime-local.html</a></td>
</tr>
<tr>
<td>Month</td>
<td>12.2</td>
<td>Allows the user to select a month and year.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.month.html">http://www.w3.org/TR/html-markup/input.month.html</a></td>
</tr>
<tr>
<td>Number</td>
<td>12.2</td>
<td>For fields that should contain only numbers.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.number.html">http://www.w3.org/TR/html-markup/input.number.html</a></td>
</tr>
<tr>
<td>Range</td>
<td>12.2</td>
<td>For fields that should contain values from a range of numbers.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.range.html">http://www.w3.org/TR/html-markup/input.range.html</a></td>
</tr>
<tr>
<td>Time</td>
<td>12.2</td>
<td>Allows the user to select a time.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.time.html">http://www.w3.org/TR/html-markup/input.time.html</a></td>
</tr>
<tr>
<td>Week</td>
<td>12.2</td>
<td>Allows the user to select a week and year.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.week.html">http://www.w3.org/TR/html-markup/input.week.html</a></td>
</tr>
<tr>
<td>E-mail</td>
<td>12.1</td>
<td>A control for editing a list of email addresses given in the element’s value.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.email.html">http://www.w3.org/TR/html-markup/input.email.html</a></td>
</tr>
<tr>
<td>Search</td>
<td>12.1</td>
<td>A one-line plain-text edit control for entering one or more search terms.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.search.html">http://www.w3.org/TR/html-markup/input.search.html</a></td>
</tr>
<tr>
<td>Telephone (Tel)</td>
<td>12.1</td>
<td>A one-line plain-text edit control for entering a telephone number.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.tel.html">http://www.w3.org/TR/html-markup/input.tel.html</a></td>
</tr>
<tr>
<td>URL</td>
<td>12.1</td>
<td>A control for editing an absolute URL given in the element’s value.</td>
<td><a href="http://www.w3.org/TR/html-markup/input.url.html">http://www.w3.org/TR/html-markup/input.url.html</a></td>
</tr>
</tbody>
</table>
Develop a form using Dreamweaver

You can create a web form visually in Dreamweaver by inserting form elements into a page, but that’s only part of the job. The other, more complex part is developing a mechanism to handle the data your visitors submit with the form. The data is sometimes saved in a customer database, for example. Typically, web application technology such as PHP or Adobe ColdFusion handles the form data.

This article describes how to create a simple web form. Developing a mechanism to handle submitted form data is beyond the scope of the article. For detailed instructions on building forms and a mechanism to handle submitted data with PHP, see this tutorial series on Adobe Developer Center.

Create a web form

1. Open a page in Design view in Dreamweaver and place the insertion point where you want the form to appear.

2. Choose Insert > Form > Form. Or, select the Forms category in the Insert panel (the small triangle below the panel’s tab) and click the Form icon. Dreamweaver inserts an empty form. In Design view, a dotted red outline indicates forms. If you don’t see this outline, select View > Visual Aids > Invisible Elements.

3. Specify the page or script that processes the form data. In the Document window, click the form outline to select the form. In the Property inspector (Window > Properties), enter the filename (and path, if necessary) of the processing page in the Property inspector’s Action text box. Or, click the folder icon to navigate to the appropriate page or script. Example: process_order.php.

4. Specify the method to use to transmit the form data to the server. In the Property inspector, select one of the following options in the Method pop-up menu:
   - POST embeds the form data in the HTTP request. For more information, see HTML form parameters in Dreamweaver Help.
   - GET appends the value to the URL requesting the page. For more information, see URL parameters in Dreamweaver Help.
   - Default uses the browser’s default setting to send the form data to the server. The default is usually the GET method.

5. Insert form objects. Place the insertion point where you want the form object to appear in the form. Then select the object in the Insert > Form menu, or in the Forms category of the Insert bar. Place form objects within the form’s dotted red outline on the page. For more information on the form objects, see Form objects in Dreamweaver Help.

6. Adjust the layout of the form. Use line breaks, paragraph breaks, preformatted text, or tables to format your forms. You cannot insert a form in another form, but you can include more than one form in a page. When designing forms, remember to label the form objects with descriptive text to let users know what they’re responding to. For example, “Type your name” to request name information. Use tables to provide structure for form objects and labels. Make sure that all the table tags are included between the form tags.
Chapter 16: Building applications visually

Build master and detail pages in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About master and detail pages
Master and detail pages are sets of pages used to organize and display recordset data. These pages provide a visitor to your site with both an overview and a detailed view. The master page lists all of the records and contains links to detail pages that display additional information about each record.
You can build master and detail pages by inserting a data object to create a master page and detail page in one operation or by using server behaviors to build the master and detail pages in a more customized way. When using server behaviors to build master and detail pages, you first create a master page to list the records and then add links from the list to the detail pages.

**Build a master page**

Before you start, ensure that you define a database connection for your site.

1. To create a blank page, select File > New > Blank Page, select a page type, and click Create. This page becomes the master page.

2. Define a recordset.

   In the Bindings panel (Windows > Bindings), click the Plus (+) button, select Recordset, and choose options. If you want to write your own SQL statement, click Advanced.

   Ensure that the recordset contains all the table columns you need to create your master page. The recordset must also include the table column containing the unique key of each record—that is, the record ID column. In the following example, the Code column contains the unique key of each record.
Typically, the recordset on the master page extracts a few columns from a database table while the recordset on the detail page extracts more columns from the same table to provide the extra detail.

The recordset can be defined by the user at run time. For more information, see Building search and results pages.

3 Insert a dynamic table to display the records.

Place the insertion point where you want the dynamic table to appear on the page. Select Insert > Data Objects > Dynamic Data > Dynamic Table, set the options, and click OK.

If you don’t want to show record IDs to users, you can delete the column from the dynamic table. Click anywhere on the page to move the focus to the page. Move the cursor near the top of the column in the dynamic table until the column cells are outlined in red, and then click to select the column. Press Delete to delete the column from the table.

Create links to the detail page

After building the master page and adding the recordset, you create links that open the detail page. You then modify the links to pass the IDs of the records the user selects. The detail page uses this ID to find the requested record in the database and display it.

Note:

You create links to update pages using the same process. The results page is similar to a master page, and the update page is similar to a detail page.

Open the detail page and pass a record ID (ColdFusion, PHP)

1 In the dynamic table, select the content placeholder for text that will serve as a link.
Building applications visually

Rental Locations

<table>
<thead>
<tr>
<th>LOCATION NAME</th>
<th>CITY</th>
<th>TELEPHONE</th>
</tr>
</thead>
<tbody>
<tr>
<td>(rslocations.LOCATION_NAME)</td>
<td>(rslocations.CITY)</td>
<td>(rsLocations.TELEPHONE)</td>
</tr>
</tbody>
</table>

Links applied to placeholder selected.

2 In the Property inspector, click the folder icon beside the Link box.

3 Browse and select the detail page. The detail page appears in the Link box in the Property inspector.
   In the dynamic table, the selected text appears linked. When the page runs on the server, the link is applied to the text in every table row.

4 On the master page, select the link in the dynamic table.

5 (ColdFusion) In the Link box in the Property inspector, add the following string at the end of the URL:

   ?recordID=#recordsetName.fieldName#

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Make a note of the name of the URL parameter because you’ll use it in the detail page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a ColdFusion expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the ColdFusion expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes.

   locationDetail.cfm?recordID=#rsLocations.CODE#

   When the page runs, the values of the recordset’s CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

   locationDetail.cfm?recordID=CBR

6 (PHP) In the Link field in the Property inspector, add the following string at the end of the URL:

   ?recordID=?php echo $row_recordsetName['fieldName']; ?

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can use any name you like). Make a note of the name of the URL parameter because you’ll use it in the detail page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a PHP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the PHP expression, replace recordsetName with the name of your recordset, and replace fieldName with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes.

   locationDetail.php?recordID=?php echo $row_rsLocations['CODE']; ?

   When the page runs, the values of the recordset’s CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:
locationDetail.php?recordID=CBR

7 Save the page.

**Open the detail page and pass a record ID (ASP)**

1 Select the dynamic content to double as a link.

2 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Go to Detail Page from the pop-up menu.

3 In the Detail Page box, click Browse and locate the page.

4 Specify the value you want to pass to the detail page by selecting a recordset and a column from the Recordset and Column pop-up menus. Typically the value is unique to the record, such as the record's unique key ID.

5 If desired, pass existing page parameters to the detail page by selecting the URL Parameters or Form Parameters options.

6 Click OK.

   A special link surrounds the selected text. When the user clicks the link, the Go To Detail Page server behavior passes a URL parameter containing the record ID to the detail page. For example, if the URL parameter is called id and the detail page is called customerdetail.asp, the URL looks something like the following when the user clicks on the link:

   http://www.mysite.com/customerdetail.asp?id=43

   The first part of the URL, http://www.mysite.com/customerdetail.asp, opens the detail page. The second part, ?id=43, is the URL parameter. It tells the detail page what record to find and display. The term id is the name of the URL parameter and 43 is its value. In this example, the URL parameter contains the record's ID number, 43.

**Find and display the requested record on the detail page**

In order to display the record requested by the master page, you must define a recordset to hold a single record and bind the recordset columns to the detail page.

1 Switch to the detail page. If you don't have a detail page yet, create a blank page (File > New).

2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) or DataSet (Query) from the pop-up menu.
   
   The simple Recordset or DataSet dialog box appears. If the advanced dialog box appears instead, click Simple.

3 Name the recordset, and select a data source and the database table that will provide data to your recordset.

4 In the Columns area, select the table columns to include in the recordset.
   
   The recordset can be identical to or different from the recordset on the master page. Usually a detail page recordset has more columns to display more detail.

   If the recordsets are different, make sure the recordset on the detail page contains at least one column in common with the recordset on the master page. The common column is usually the record ID column, but it can also be the join field of related tables.

   To include only some of the table's columns in the recordset, click Selected and choose the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.
5 Complete the Filter section as to find and display the record specified in the URL parameter passed by the master page:

   • From the first pop-up menu in the Filter area, select the column in the recordset containing values that match the value of the URL parameter passed by the master page. For example, if the URL parameter contains a record ID number, select the column containing record ID numbers. In the example discussed in the previous section, the recordset column called CODE contains the values that match the value of the URL parameter passed by the master page.

   • From the pop-up menu beside the first menu, select the equal sign (it should already be selected).

   • From the third pop-up menu, select URL Parameter. The master page uses a URL parameter to pass information to the detail page.

   • In the fourth box, enter the name of the URL parameter passed by the master page.

6 Click OK. The recordset appears in the Bindings panel.

7 Bind the recordset columns to the detail page by selecting the columns in the Bindings panel (Window > Bindings) and dragging them onto the page.

After uploading both the master and detail pages to the server, you can open the master page in a browser. After clicking a detail link on the master page, the detail page opens with more information about the selected record.

Find a specific record and display it on a page (ASP)

You can add a server behavior that finds a specific record in a recordset so that you can display the record data on the page. The server behavior is only available when using the ASP server model.

1 Create a page that has the following prerequisites:

   • A record ID contained in a URL parameter passed by another page to the current page. You can create URL parameters on the other page with HTML hyperlinks or with an HTML form. For more information, see Using forms to collect information from users.

   • A recordset defined for the current page. The server behavior extracts the record details from this recordset. For instructions, see Define a recordset without writing SQL or Define an advanced recordset by writing SQL.

   • Recordset columns bound to the page. The specific record must be displayed on the page. For more information, see Make text dynamic.

2 Add the server behavior to find the record specified by the URL parameter by clicking the Plus (+) button on the Server Behaviors panel (Window > Server Behaviors) and selecting Recordset Paging > Move to Specific Record.

3 In the Move To Record In pop-up menu, select the recordset you defined for the page.

4 In the Where Column pop-up menu, select the column that contains the value passed by the other page.

   For example, if the other page passes a record ID number, select the column containing record ID numbers.

5 In the Matches URL Parameter box, enter the name of the URL parameter passed by the other page.

   For example, if the URL the other page used to open the detail page is id=43, enter id in the Matches URL Parameter box.

6 Click OK.

   The next time the page is requested by a browser, the server behavior will read the record ID in the URL parameter passed by the other page and move to the specified record in the recordset.
Build master and detail pages in one operation

When developing web applications, you can quickly build master and detail pages using the Master Detail Page Set data object.

1. To create a blank dynamic page, select File > New > Blank Page, select a dynamic page from the Page Type list, and click Create.
   This page becomes the master page.

2. Define a recordset for the page.
   Make sure the recordset contains not only all the columns you'll need for the master page, but also all the columns you'll need for the detail page. Typically, the recordset on the master page extracts a few columns from a database table while the recordset on the detail page extracts more columns from the same table to provide the extra detail.

3. Open the master page in Design view, and select Insert > Data Objects > Master Detail Page Set.

4. In the Recordset pop-up menu, make sure the recordset containing the records you want to display on the master page is chosen.

5. In the Master Page Fields area, select the recordset columns to display on the master page.
   By default, all the columns in the recordset are selected. If your recordset contains a unique key column such as recordID, select it and click the Minus (-) button so that it is not displayed on your page.

6. To change the order in which the columns appear on the master page, select a column in the list and click the up or down arrow.
   On the master page, the recordset columns will be arranged horizontally in a table. Clicking the up arrow moves the column to the left; clicking the down arrow moves the column to the right.

7. In the Link To Detail From pop-up menu, select the column in the recordset that will display a value that also serves as a link to the detail page.
   For example, if you want each product name on your master page to have a link to the detail page, select the recordset column containing product names.

8. In the Pass Unique Key pop-up menu, select the column in the recordset containing values identifying the records.
   Usually, the column chosen is the record ID number. This value is passed to the detail page so that it can identify the record chosen by the user.

9. Deselect the Numeric option if the unique key column is not numeric.
   
   Note:
   
   *This option is selected by default; it does not appear for all server models.*

10. Specify the number of records to display on the master page.

11. In the Detail Page Name box, click Browse and locate the detail page file you created, or enter a name and let the data object create one for you.

12. In the Detail Page Fields area, select the columns to be displayed on the detail page.
   By default, all the columns in the master page's recordset are selected. If the recordset contains a unique key column such as recordID, select it and click the Minus (-) button so that it is not displayed on the detail page.

13. To change the order in which the columns appear on the detail page, select a column in the list and click the up or down arrow.
   On the detail page, the recordset columns are arranged vertically in a table. Clicking the up arrow moves the column up; clicking the down arrow moves the column down.
14 Click OK.

The data object creates a detail page (if you didn't already create one) and adds dynamic content and server behaviors to both the master and detail pages.

15 Customize the layout of the master and detail pages to suit your needs.

You can fully customize the layout of each page by using the Dreamweaver page-design tools. You can also edit the server behaviors by double-clicking them in the Server Behaviors panel.

After creating master and detail pages with the data object, use the Server Behaviors panel (Window > Server Behaviors) to modify the various building blocks the data object inserts into the pages.

Build search and results pages

Note:

The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About search and results pages

You can use Dreamweaver to build a set of pages to let users search your database and view the search results.

In most cases, you need at least two pages to add this feature to your web application. The first page is a page that contains an HTML form in which users enter search parameters. Although this page doesn't do any actual searching, it is referred to as the search page.

The second page you need is the results page, which performs most of the work. The result's page does the following tasks:

- Reads the search parameters submitted by the search page
- Connects to the database and searches for records
- Builds a recordset with the records found
- Displays the contents of the recordset

Optionally, you can add a detail page. A detail page gives users more information about a particular record on the results page.

If you have only one search parameter, Dreamweaver lets you add search capabilities to your web application without using SQL queries and variables. Simply design your pages and complete a few dialog boxes. If you have more than one search parameter, you need to write a SQL statement and define multiple variables for it.

Dreamweaver inserts the SQL query in your page. When the page runs on the server, each record in the database table is checked. If the specified field in a record meets your SQL query conditions, the record is included in a recordset. The SQL query in effect builds a recordset containing only the search results.

For example, field sales staff might have information about customers in a certain area who have incomes above a certain level. In a form on a search page, the sales associate enters a geographical area and a minimum income level, and then clicks the Submit button to send the two values to a server. On the server, the values are passed to the results page's SQL statement, which then creates a recordset containing only customers in the specified area with incomes above the specified level.
Build the search page

A search page on the web typically contains form fields in which the user enters search parameters. At minimum, your search page must have an HTML form with a Submit button.

To add an HTML form to a search page, complete the following procedure.

1. Open the search page or a new page, and select Insert > Form > Form.
   
   An empty form is created on the page. You might need to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.

2. Add form objects for users to enter their search parameters by selecting Form from the Insert menu.

   Form objects include text fields, menus, options, and radio buttons. You can add as many form objects as you want to help users refine their searches. However, keep in mind that the greater the number of search parameters on the search page, the more complex your SQL statement will be.

3. Add a Submit button to the form (Insert > Form > Button).

4. (Optional) Change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Value box.

   Next, you'll tell the form where to send the search parameters when the user clicks the Submit button.

5. Select the form by selecting the `<form>` tag in the tag selector at the bottom of the Document window, as the following image shows:

   ![form tag]

6. In the Action box in the form's Property inspector, enter the filename of the results page that will conduct the database search.

7. In the Method pop-up menu, select one of the following methods to determine how the form sends data to the server:
   - **GET** sends the form data by appending it to the URL as a query string. Because URLs are limited to 8192 characters, don't use the GET method with long forms.
   - **POST** sends the form data in the body of a message.
   - **Default** uses the browser's default method (usually GET).

   The search page is done.

Build a basic results page

When the user clicks the form's Search button, the search parameters are sent to a results page on the server. The results page on the server, not the search page on the browser, is responsible for retrieving records from the database. If the search page submits a single search parameter to the server, you can build the results page without SQL queries and variables. You create a basic recordset with a filter that excludes records that don't meet the search parameter submitted by the search page.

**Note:**

*If you have more than one search condition, you must use the advanced Recordset dialog box to define your recordset (see Build an advanced results page).*
Create the recordset to hold the search results

1 Open your results page in the Document window.
   If you don't have a results page yet, create a blank dynamic page (File > New > Blank Page).

2 Create a recordset by opening the Bindings panel (Window > Bindings), clicking the Plus (+) button, and selecting Recordset from the pop-up menu.

3 Make sure the simple Recordset dialog box appears.

   ![Recordset dialog box]

   *If the advanced dialog box appears instead, switch to the simple dialog box by clicking the Simple button.*

4 Enter a name for the recordset, and select a connection.
   The connection should be to a database containing data you want the user to search.

5 In the Table pop-up menu, select the table to be searched in the database.
   
   *Note:*
   In a single-parameter search, you can search for records in only a single table. To search more than one table at a time, you must use the advanced Recordset dialog box and define a SQL query.

6 To include only some of the table's columns in the recordset, click Selected and select the desired columns by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.
   You should include only the columns containing information you want to display on the results page.

   Leave the Recordset dialog box open for now. You'll use it next to retrieve the parameters sent by the search page and create a recordset filter to exclude records that don't meet the parameters.

Create the recordset filter

1 From the first pop-up menu in the Filter area, select a column in the database table in which to search for a match.
   For example, if the value sent by the search page is a city name, select the column in your table that contains city names.

2 From the pop-up menu beside the first menu, select the equal sign (it should be the default).

3 From the third pop-up menu, select Form Variable if the form on your search page uses the POST method, or URL Parameter if it uses the GET method.
The search page uses either a form variable or a URL parameter to pass information to the results page.

4 In the fourth box, enter the name of the form object that accepts the search parameter on the search page.

The name of the object doubles as the name of the form variable or URL parameter. You can get the name by switching to the search page, clicking the form object on the form to select it, and checking the object's name in the Property inspector.

For example, suppose you want to create a recordset that includes only adventure trips to a specific country. Assume you have a column in the table called TRIPLOCATION. Also assume the HTML form on your search page uses the GET method and contains a menu object called Location that displays a list of countries. The following example shows how your Filter section should look:

5 (Optional) Click Test, enter a test value, and click OK to connect to the database and create an instance of the recordset.

The test value simulates the value that would otherwise have been returned from the search page. Click OK to close the test recordset.

6 If you're satisfied with the recordset, click OK.

A server-side script is inserted on your page that checks each record in the database table when it runs on the server. If the specified field in a record meets the filtering condition, the record is included in a recordset. The script builds a recordset that contains only the search results.

The next step is to display the recordset on the results page. For more information, see Display the search results.

Build an advanced results page

If the search page submits more than one search parameter to the server, you must write a SQL query for the results page and use the search parameters in SQL variables.

Note:

*If you have only one search condition, you can use the simple Recordset dialog box to define your recordset (see Build a basic results page).*

1 Open the results page in Dreamweaver, and then create a recordset by opening the Bindings panel (Window > Bindings), clicking the Plus (+) button, and selecting Recordset from the pop-up menu.

2 Make sure the advanced Recordset dialog box appears.

The advanced dialog box has a text area to enter SQL statements. If the simple dialog box appears instead, switch to the advanced dialog box by clicking the Advanced button.

3 Enter a name for the recordset, and select a connection.

The connection should be to a database containing data you want the user to search.

4 Enter a Select statement in the SQL text area.

Make sure the statement includes a WHERE clause with variables to hold the search parameters. In the following example, the variables are called varLastName and varDept:

```sql
SELECT EMPLOYEEID, FIRSTNAME, LASTNAME, DEPARTMENT, EXTENSION FROM EMPLOYEE ¬
WHERE LASTNAME LIKE 'varLastName' ¬
AND DEPARTMENT LIKE 'varDept'
```
To reduce the amount of typing, you can use the tree of database items at the bottom of the advanced Recordset dialog box. For instructions, see Define an advanced recordset by writing SQL.

For help on SQL syntax, see the SQL primer at www.adobe.com/go/learn_dw_sqlprimer.

5 Give the SQL variables the values of the search parameters by clicking the Plus (+) button in the Variables area and entering the variable’s name, default value (the value the variable should take if no run-time value is returned), and run-time value (usually a server object holding a value sent by a browser, such as a request variable).

In the following ASP example, the HTML form on the search page uses the GET method and contains one text field called LastName and another called Department:

In ColdFusion, the run-time values would be #LastName# and #Department#. In PHP, the run-time values would be $_REQUEST["LastName"] and $_REQUEST["Department"].

6 (Optional) Click Test to create an instance of the recordset using the default variable values.

The default values simulate the values that would otherwise have been returned from the search page. Click OK to close the test recordset.

7 If you’re satisfied with the recordset, click OK.

The SQL query is inserted in your page.

The next step is to display the recordset on the results page.

Display the search results

After creating a recordset to hold the search results, you must display the information on the results page. Displaying the records can be a simple matter of dragging individual columns from the Bindings panel to the results page. You can add navigation links to move forward and backward through the recordset, or you can create a repeating region to display more than one record on the page. You can also add links to a detail page.

For more information on methods of displaying dynamic content on a page other than displaying results in a dynamic table, see Display database records.

1 Place the insertion point where you want the dynamic table to appear on the results page, and select Insert > Data Objects > Dynamic Data > Dynamic Table.

2 Complete the Dynamic Table dialog box, selecting the recordset you defined to hold the search results.

3 Click OK. A dynamic table that displays search results is inserted on the results page.

Create a detail page for a results page

Your set of search and results pages can include a detail page to display more information about specific records on the results page. In this situation, your results page also doubles as the master page in a master-detail page set.

Create a link to open a related page (ASP)

You can create a link that opens a related page and that passes existing parameters to that page. The server behavior is only available when using the ASP server model.
Before adding a Go To Related Page server behavior to a page, make sure the page receives form or URL parameters from another page. The job of the server behavior is to pass these parameters to a third page. For example, you can pass search parameters received by a results page to another page and save the user from entering the search parameters again.

Also, you can select text or an image on the page to serve as the link to the related page, or you can position your pointer on the page without selecting anything, and the link text is inserted.

1. In the Go To Related Page box, click Browse and locate the related page file.
   - If the current page submits data to itself, enter the current page's file name.
2. If the parameters you want to pass were received directly from an HTML form using the GET method, or are listed in the page's URL, select the URL Parameters option.
3. If the parameters you want to pass were received directly from an HTML form using the POST method, select the Form Parameters option.
4. Click OK.
   - When the new link is clicked, the page passes the parameters to the related page using a query string.

### Build a record insert page

*Note:*

*The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.*

### About building record insert pages

Your application can contain a page that lets users insert new records in a database.

An insert page consists of two building blocks:

- An HTML form that lets users enter data
- An Insert Record server behavior that updates the database

  - When a user clicks Submit on a form, the server behavior inserts records in a database table.

  You can add these building blocks in a single operation using the Record Insertion Form data object or you can add them separately using the Dreamweaver form tools and the Server Behaviors panel.

*Note:*

*The insert page can contain only one record-editing server behavior at a time. For example, you cannot add an Update Record or a Delete Record server behavior to the insert page.*

### Build an insert page block by block

You can also build an insert page by using the forms tools and server behaviors.

### Add an HTML form to an insert page

1. Create a dynamic page (File > New > Blank Page), and lay out your page using the Dreamweaver design tools.
2 Add an HTML form by placing the insertion point where you want the form to appear and selecting Insert > Form. An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.

3 Name the HTML form by clicking the `<form>` tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box. You don't need to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Insert Record server behavior sets these attributes for you.

4 Add a form object such as a text field (Insert > Form > Text Field) for each column in the database table you want to insert records into. The form objects are for data entry. Text fields are common for this purpose, but you can also use menus, options, and radio buttons.

5 Add a Submit button to the form (Insert > Form > Button). You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

Add a server behavior to insert records in a database table (ColdFusion)

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

2 Select a form from the Submit Values From pop-up menu.

3 In the Data Source pop-up menu, select a connection to the database.

4 Enter your user name and password.

5 In the Insert Into Table pop-up menu, select the database table to insert the record in.

6 Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form object in your form.

7 In the After Inserting, Go To box, enter the page to open after the record is inserted in the table or click the Browse button to browse to the file.

8 Click OK. Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.

Add a server behavior to insert records in a database table (ASP)

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

2 In the Connection pop-up menu, select a connection to the database.

3 In the Insert Into Table pop-up menu, select the database table into which the record should be inserted.

Last updated 11/7/2019
4 In the After Inserting, Go To box, enter the page to open after the record is inserted into the table or click Browse to browse to the file.

5 In the Get Values From pop-up menu, select the HTML form used to enter the data.
   Dreamweaver automatically selects the first form on your page.

6 Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu.
   The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values).
   Repeat the procedure for each form object in your form.

7 Click OK.
   Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.
   To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Insert Record behavior.

**Add a server behavior to insert records in a database table (PHP)**

1 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.

2 Select a form from the Submit Values From pop-up menu.

3 In the Connection pop-up menu, select a connection to the database.

4 In the Insert Table pop-up menu, select the database table to insert the record in.

5 Specify a database column to insert the record in, select the form object that will insert the record from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu.
   The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values).
   Repeat the procedure for each form object in your form.

6 In the After Inserting, Go To box, enter the page to open after the record is inserted in the table or click the Browse button to browse to the file.

7 Click OK.
   Dreamweaver adds a server behavior to the page that lets users insert records in a database table by filling out the HTML form and clicking the Submit button.

**Build the insert page in one operation**

1 Open the page in Design view, and select Insert > Data Objects > Insert Record > Record Insertion Form Wizard.

2 In the Connection pop-up menu, select a connection to the database. Click Define if you need to define a connection.

3 In the Insert Into Table pop-up menu, select the database table into which the record should be inserted.

4 If you use ColdFusion, enter a user name and password.

5 In the After Inserting, Go To box, enter the page to open after the record is inserted into the table or click the Browse button to browse to the file.
6 In the Form Fields area, specify the form objects you want to include on the insert page's HTML form, and which columns in your database table each form object should update.

By default, Dreamweaver creates a form object for each column in the database table. If your database automatically generates unique key IDs for each new record created, remove the form object corresponding to the key column by selecting it in the list and clicking the Minus (-) button. This eliminates the risk that the user of the form will enter an ID value that already exists.

You can also change the order of the form objects on the HTML form by selecting a form object in the list and clicking the up or down arrow on the right side of the dialog box.

7 Specify how each data-entry field should be displayed on the HTML form by clicking a row in the Form Fields table and entering the following information in the boxes below the table:

• In the Label box, enter a descriptive label to display beside the data-entry field. By default, Dreamweaver displays the table column’s name in the label.

• In the Display As pop-up menu, select a form object to serve as the data-entry field. You can select Text Field, Text Area, Menu, Checkbox, Radio Group, and Text. For read-only entries, select Text. You can also select Password Field, File Field, and Hidden Field.

Note:
Hidden fields are inserted at the end of the form.

• In the Submit As pop-up menu, select the data format accepted by your database table. For example, if the table column only accepts numeric data, select Numeric.

• Set the form object's properties. You have different options depending on the form object you select as your data-entry field. For text fields, text areas, and text, you can enter an initial value. For menus and radio groups, you open another dialog box to set the properties. For options, select the Checked or Unchecked option.

8 Click OK.

Dreamweaver adds both an HTML form and an Insert Record server behavior to your page. The form objects are laid out in a basic table, which you can customize using the Dreamweaver page design tools. (Make sure all the form objects remain within the form's boundaries.)

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Insert Record behavior.

Build an update record page in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About record update pages

Your application can contain a set of pages that lets users update existing records in a database table. The pages normally consist of a search page, a results page, and an update page. The search and results page let users retrieve the record and the update page lets users modify the record.
Search for the record to update
When users want to update a record, they must first find that record in the database. Accordingly, you need a search and a results page to work with the update page. The user enters search criteria in the search page and selects the record on the results page. When the user clicks the record on the results page, the update page opens and displays the record in an HTML form.

Create links to the update page
After creating the search and results pages, you create links on the results page to open the update page. You then modify the links to pass the IDS of the records the user selects. The update page uses this ID to find the requested record in the database and display it.

You use the same process to open the update page and pass a record ID that you do to open a detail page and pass a record ID. For more information, see Create links to the detail page.

Retrieve the record to update
After the results page passes a record ID to the update page identifying the record to update, the update page must read the parameter, retrieve the record from the database table, and store it temporarily in a recordset.

1 Create a page in Dreamweaver and save it.
   The page will become your update page.
2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset.
   If the advanced dialog box appears, click Simple. The advanced dialog box has a text area to enter SQL statements; the simple one does not.
3 Name the recordset and specify where the data you want to update is located using the Connection and Table pop-up menus.
4 Click Selected, and select a key column (usually the record ID column) and the columns that contain the data to be updated.
5 Configure the Filter area so that the value of your key column equals the value of the corresponding URL parameter passed by the results page.
   This kind of filter creates a recordset that contains only the record specified by the results page. For example, if your key column contains record ID information and is called PRID, and if the results page passes the corresponding record ID information in the URL parameter called id, the Filter area should look like the following example:

   | Filter area |
   | PRID | | | |
   | URLParameter | id |

6 Click OK.
When the user selects a record on the results page, the update page generates a recordset containing only the selected record.
Complete the update page block by block

An update page has three building blocks:

• A filtered recordset to retrieve the record from a database table
• An HTML form to let users modify the record's data
• An Update Record server behavior to update the database table

You can add the final two basic building blocks of an update page separately using the form tools and the Server Behaviors panel.

Add an HTML form to an update page

1. Create a page (File > New > Blank Page). This becomes your update page.
2. Lay out your page using the Dreamweaver design tools.
3. Add an HTML form by placing the insertion point where you want the form to appear and selecting Insert > Form > Form.

An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.

4. Name the HTML form by clicking the <form> tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

You don't have to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Update Record server behavior sets these attributes for you.

5. Add a form object such as a text field (Insert > Form > Text Field) for each column you want to update in the database table.

The form objects are for data entry. Text fields are common for this purpose, but you can also use menus, options, and radio buttons.

Each form object should have a corresponding column in the recordset you defined earlier. The only exception is the unique key column, which should have no corresponding form object.

6. Add a Submit button to the form (Insert > Form > Button).

You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

Display the record in the form

1. Make sure you defined a recordset to hold the record the user wants to update.

See Retrieve the record to update.

2. Bind each form object to data in the recordset, as described in the following topics:

   • Display dynamic content in HTML text fields
   • Dynamically preselect an HTML check box
   • Dynamically preselect an HTML radio button
   • Insert or change a dynamic HTML form menu
   • Make existing HTML form menus dynamic
Add a server behavior to update the database table

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Update Record from the pop-up menu.

   The Update Record dialog box appears.

2. Select a form from the Submit Values From pop-up menu.

3. In the Data Source or Connection pop-up menu, select a connection to the database.

4. Enter your user name and password if applicable.

5. In the Update Table pop-up menu, select the database table that contains the record you are updating.

6. (ColdFusion, PHP) Specify a database column to update, select the form object that will update the column from the Value pop-up menu, select a data type for the form object from the Submit As pop-up menu, and select Primary Key if you want to identify this column as the primary key.

   The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values).

   Repeat the procedure for each form object in your form.

7. (ASP) In the Select Record From pop-up menu, specify the recordset that contains the record displayed in the HTML form. In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table. Select the Numeric option if the value is a number. A key column usually accepts only numeric values, but sometimes accepts text values.

8. In the After Updating or On Success, Go To box, enter the page to open after the record updates in the table or click the Browse button to browse to the file.

9. (ASP) Specify a database column to update, select the form object that will update the column from the Value pop-up menu, and then select a data type for the form object from the Submit As pop-up menu. The data type is the kind of data the column in your database table is expecting (text, numeric, Boolean option values). Repeat the procedure for each form in your form.

10. Click OK.

   Dreamweaver adds a server behavior to the page that lets users update records in a database table by modifying the information displayed in the HTML form and clicking the Submit button.

   To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Update Record behavior.

Complete the update page in one operation

An update page has three building blocks:

- A filtered recordset to retrieve the record from a database table
- An HTML form to let users modify the record's data
- An Update Record server behavior to update the database table

You can add the final two building blocks of an update page in a single operation using the Record Update Form data object. The data object adds both an HTML form and an Update Record server behavior to the page.

Before you can use the data object, your web application must be able to identify the record to update, and your update page must be able to retrieve it.

After the data object places the building blocks on the page, you can use the Dreamweaver design tools to customize the form to your liking, or the Server Behaviors panel to edit the Update Record server behavior.
Note:
The update page can contain only one record-editing server behavior at a time. For example, you cannot add an Insert Record or a Delete Record server behavior to the update page.

1. Open the page in Design view, and select Insert > Data Objects > Update Record > Record Update Form Wizard. The Record Update Form dialog box appears.

2. In the Connection pop-up menu, select a connection to the database. Click the Define button if you need to define a connection.

3. In the Table To Update pop-up menu, select the database table that contains the record to update.

4. In the Select Record From pop-up menu, specify the recordset that contains the record displayed in the HTML form.

5. In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table.

   If the value is a number, select the Numeric option. A key column usually accepts only numeric values, but sometimes it accepts text values.

6. In the After Updating, Go To box, enter the page to open after the record updates in the table.

7. In the Form Fields area, specify which columns in your database table each form object should update.

   By default, Dreamweaver creates a form object for each column in the database table. If your database automatically generates unique key IDs for each new record created, remove the form object corresponding to the key column by selecting it in the list and clicking the Minus (-) button. This eliminates the risk that the user of the form will enter an ID value that already exists.

   You can also change the order of the form objects on the HTML form by selecting a form object in the list and clicking the up or down arrow on the right side of the dialog box.

8. Specify how each data-entry field should appear on the HTML form by clicking a row in the Form Fields table and entering the following information in the boxes below the table:

   • In the Label box, enter a descriptive label to display beside the data-entry field. By default, Dreamweaver displays the table column's name in the label.
   • In the Display As pop-up menu, select a form object to serve as the data-entry field. You can select Text Field, Text Area, Menu, Checkbox, Radio Group, and Text. For read-only entries, select Text. You can also select Password Field, File Field, and Hidden Field.

   Note:
   Hidden fields are inserted at the end of the form.

   • In the Submit As pop-up menu, select the data format expected by your database table. For example, if the table column only accepts numeric data, select Numeric.
   • Set the form object's properties. You have different options depending on the form object you select as your data-entry field. For text fields, text areas, and text, you can enter an initial value. For menus and radio groups, you open another dialog box to set the properties. For options, select the Checked or Unchecked option.

9. Set the properties of other form objects by selecting another Form Fields row and entering a label, Display As value, and Submit As value.

   For menus and radio groups, open another dialog box to set the properties. For options, define a comparison between the current record's value for the option and a given value to determine whether the option is checked when the record is displayed.
Click OK.

Dreamweaver adds both an HTML form and an Update Record server behavior to your page.

The data object adds both an HTML form and an Update Record server behavior to your page. The form objects are laid out in a basic table, which you can customize using the Dreamweaver page design tools. (Make sure all the form objects remain within the form's boundaries.)

To edit the server behavior, open the Server Behaviors panel (Window > Server Behaviors) and double-click the Update Record behavior.

**Form Element Properties options**

The purpose of the Form Element Properties dialog box is to set the options for form elements on pages that let users update records in a database.

1. Select either Manually or From Database, depending on how you plan to create the form element.
2. Click the Plus (+) button to add an element.
3. Enter a label and value for the element.
4. In the Select Value Equal To box, if you want a particular element selected when the page opens in a browser or when a record displays in the form, enter a value equal to the element's value.

You can enter a static value or you can specify a dynamic value by clicking the lightning bolt icon, and selecting a dynamic value from the list of data sources. In either case, the value you specify should match one of the element's values.

**Building record delete pages in Dreamweaver**

*Note:*

The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see [this article.](#)

**About record delete pages**

Your application can contain a set of pages that lets users delete records in a database. The pages normally consist of a search page, a results page, and a delete page. A delete page is usually a detail page working in tandem with a results page. The search and results pages let the user retrieve the record and the delete page lets the user confirm and delete the record.

After creating the search and results pages, you add links on the results page to open the delete page and then build a delete page that displays the records and a Submit button.

**Search for the record to delete**

When users want to delete a record, they must first find that record in the database. Accordingly, you need a search and a results page to work with the delete page. The user enters search criteria in the search page and selects the record on the results page. When the user clicks the record, the delete page opens and displays the record in an HTML form.
Create links to a delete page

After creating the search and results pages, you must create links on the results page to open the delete page. You then modify the links to pass the IDs of the records the user wants to delete. The delete page uses this ID to find and display the record.

To create the links manually

1. On the results page, create a column in the table used to display records by clicking inside the last table column and selecting Modify > Table > Insert Rows or Columns.
2. Select the Columns option and the After Current Column option, and click OK.

   A column is added to the table.
3. In the newly created table column, enter the string Delete in the row containing the dynamic content placeholders. Make sure you enter the string inside the tabbed repeating region.

   You can also insert an image with a word or symbol for delete.
4. Select the Delete string to apply a link to it.
5. In the Property inspector, enter the delete page in the Link box. You can enter any filename.

   After clicking outside the Link box, the Delete string appears linked in the table. If you Live view, you can see that the link is applied to the same text in every table row.
6. Select the Delete link on the results page.
7. (ColdFusion) In the Link box in the Property inspector, add the following string at the end of the URL:

   `?recordID=#recordsetName.fieldName#`

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you’ll use it in the delete page later.

   The expression after the equal sign is the value of the parameter. In this case, the value is generated by a ColdFusion expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the ColdFusion expression, replace `recordsetName` with the name of your recordset, and replace `fieldName` with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:

   `confirmDelete.cfm?recordID=#rsLocations.CODE#`

   When the page runs, the values of the recordset’s CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

   `confirmDelete.cfm?recordID=CBR`

8. (PHP) In the Link field in the Property inspector, add the following string at the end of the URL:

   `?recordID=<?php echo $row_recordsetName['fieldName']; ?>`

   The question mark tells the server that what follows is one or more URL parameters. The word recordID is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you’ll use it in the delete page later.
The expression after the equal sign is the value of the parameter. In this case, the value is generated by a PHP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the PHP expression, replace `recordsetName` with the name of your recordset, and replace `fieldName` with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:

```
confirmDelete.php?recordID=<?php echo $row_rsLocations['CODE']; ?>
```

When the page runs, the values of the recordset's CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

```
confirmDelete.php?recordID=CBR
```

9 (ASP) In the Link field in the Property inspector, add the following string at the end of the URL:

```
?recordID=<%= (recordsetName.Fields.Item("fieldName").Value)%>
```

The question mark tells the server that what follows is one or more URL parameters. The word `recordID` is the name of the URL parameter (you can make up any name you like). Note the name of the URL parameter because you'll use it in the delete page later.

The expression after the equal sign is the value of the parameter. In this case, the value is generated by an ASP expression that returns a record ID from the recordset. A different ID is generated for each row in the dynamic table. In the ASP expression, replace `recordsetName` with the name of your recordset, and replace `fieldName` with the name of the field in your recordset that uniquely identifies each record. In most cases, the field will consist of a record ID number. In the following example, the field consists of unique location codes:

```
confirmDelete.asp?recordID=<%(rsLocations.Fields.Item("CODE").Value)%>
```

When the page runs, the values of the recordset's CODE field are inserted in the corresponding rows in the dynamic table. For example, if the Canberra, Australia, rental location has the code CBR, the following URL is used in the Canberra row in the dynamic table:

```
confirmDelete.asp?recordID=CBR
```

10 Save the page.

To create the links visually (ASP only)

1 On the results page, create a column in the table used to display records by clicking inside the last table column and selecting Modify > Table > Insert Rows or Columns.

2 Select the Columns option and the After Current Column option, and click OK.

   A column is added to the table.

3 In the newly created table column, enter the string `Delete` in the row containing the dynamic content placeholders. Make sure you enter the string inside the tabbed repeating region.

   You can also insert an image with a word or symbol for delete.

4 Select the `Delete` string to apply a link to it.

5 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Go to Detail Page from the pop-up menu.

6 In the Detail Page box, click Browse and locate the delete page.

7 In the Pass URL Parameter box, specify the name of your parameter, such as `recordID`.

   You can make up any name you like, but take note of the name because you'll use it in the delete page later.
8 Specify the value you want to pass to the delete page by selecting a recordset and a column from the Recordset and Column pop-up menus. Typically the value is unique to the record, such as the record’s unique key ID.

9 Select the URL Parameters option.

10 Click OK.

A special link surrounds the selected text. When the user clicks the link, the Go To Detail Page server behavior passes a URL parameter containing the record ID to the specified delete page. For example, if the URL parameter is called recordID and the delete page is called confirmdelete.asp, the URL looks something like the following when the user clicks on the link:

http://www.mysite.com/confirmdelete.asp?recordID=43

The first part of the URL, http://www.mysite.com/confirmdelete.asp, opens the delete page. The second part, ?recordID=43, is the URL parameter. It tells the delete page what record to find and display. The term recordID is the name of the URL parameter and 43 is its value. In this example, the URL parameter contains the record’s ID number, 43.

Build the delete page

After completing the page listing the records, switch to the delete page. The delete page shows the record and asks the user if they’re sure they want to delete it. When the user confirms the operation by clicking the form button, the web application deletes the record from the database.

Building this page consists of creating an HTML form, retrieving the record to display in the form, displaying the record in the form, and adding the logic to delete the record from the database. Retrieving and displaying the record consists of defining a recordset to hold a single record—the record the user wants to delete—and binding the recordset columns to the form.

Note:

The delete page can contain only one record-editing server behavior at a time. For example, you cannot add an Insert Record or an Update Record server behavior to the delete page.

Create an HTML form to display the record

1 Create a page and save it as the delete page you specified in the previous section.

You specified a delete page when you created the Delete link in the previous section. Use this name when saving the file for the first time (for example, deleteConfirm.cfm).

2 Insert an HTML form on the page (Insert > Form > Form).

3 Add a hidden form field to the form.

The hidden form field is required to store the record ID passed by the URL parameter. To add a hidden field, place the insertion point in the form and select Insert > Form > Hidden Field.

4 Add a button to the form.

The user will click the button to confirm and delete the displayed record. To add a button, place the insertion point in the form and select Insert > Form > Button.

5 Enhance the design of the page any way you want and save it.
Retrieve the record the user wants to delete

1. In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.

   The simple Recordset or DataSet dialog box appears. If the advanced Recordset dialog box appears instead, click Simple.

2. Name the recordset, and select a data source and the database table that contains the records that users can delete.

3. In the Columns area, select the table columns (record fields) you want to display on the page.

   To display only some of the record’s fields, click Selected and choose the desired fields by Control-clicking (Windows) or Command-clicking (Macintosh) them in the list.

   Make sure to include the record ID field even if you won’t be displaying it.

4. Complete the Filter section as follows to find and display the record specified in the URL parameter passed by the results page:

   - From the first pop-up menu in the Filter area, select the column in the recordset containing values that match the value of the URL parameter passed by the page with the Delete links. For example, if the URL parameter contains a record ID number, select the column containing record ID numbers. In the example discussed in the previous section, the recordset column called CODE contains the values that match the value of the URL parameter passed by the page with the Delete links.

   - From the pop-up menu beside the first menu, select the equal sign, if not already selected.

   - From the third pop-up menu, select URL Parameter. The page with the Delete links uses a URL parameter to pass information to the delete page.

   - In the fourth box, enter the name of the URL parameter passed by the page with the Delete links.

5. Click OK.

   The recordset appears in the Bindings panel.
Display the record the user wants to delete

1 Select the recordset columns (record fields) in the Bindings panel, and drag them to the delete page.

Make sure you insert this read-only dynamic content within the form boundaries. For more information on inserting dynamic content in a page, see Make text dynamic.

Next, you must bind the record ID column to the hidden form field.

2 Make sure Invisible Elements are enabled (View > Visual Aids > Invisible Elements), and then click the yellow shield icon that represents the hidden form field.

The hidden form field is selected.

3 In the Property inspector, click the lightning bolt icon beside the Value box.

4 In the Dynamic Data dialog box, select the record ID column in the recordset.

In the following example, the record ID column, CODE, contains unique store codes.

5 Click OK and save the page.
Add logic to delete the record

After displaying the selected record on the delete page, you must add logic to the page that deletes the record from the database when the user clicks the Confirm Deletion button. You can add this logic quickly and easily by using the Delete Record server behavior.

To add a server behavior to delete the record (ColdFusion, PHP)

1. Make sure the ColdFusion or PHP delete page is open in Dreamweaver.
2. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Delete Record.
3. In the First Check If Variable Is Defined box, make sure Primary Key Value is selected. You specify the primary key value later in the dialog box.
4. In the Connection or Data Source (ColdFusion) pop-up menu, select a connection to the database so that the server behavior can connect to the affected database.
5. In the Table pop-up menu, select the database table that contains the records that will be deleted.
6. In the Primary Key Column pop-up menu, select the table column that contains record IDs.
   The Delete Record server behavior searches this column for a match. The column should contain the same record ID data as the recordset column you bound to the hidden form field on the page.
   If the record ID is numeric, select the Numeric option.
7. (PHP) In the Primary Key Value pop-up menu, select the variable on your page that contains the record ID identifying the record to be deleted.
   The variable is created by your hidden form field. It has the same name as the name attribute of the hidden field and is either a form or URL parameter, depending on the form's method attribute.
8. In the After Deleting, Go To box, or the On Success, Go To box, specify a page to open after the record has been deleted from the database table.
You can specify a page that contains a brief success message to the user, or a page listing the remaining records so that the user can verify that the record has been deleted.

![Delete Record dialog box](image)

**Delete Record**

**Delete Record dialog box**

9 Click OK, and save your work.

**To add a server behavior to delete the record (ASP)**

1 Make sure the ASP delete page is open in Dreamweaver.

2 In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Delete Record.

3 In the Connection pop-up menu, select a connection to the database so that the server behavior can connect to the affected database.

   Click the Define button if you need to define a connection.

4 In the Delete from Table pop-up menu, select the database table that contains the records to be deleted.

5 In the Select Record From pop-up menu, specify the recordset that contains the records to be deleted.

6 In the Unique Key Column pop-up menu, select a key column (usually the record ID column) to identify the record in the database table.

   If the value is a number, select the Numeric option. A key column usually accepts only numeric values, but sometimes it accepts text values.

7 In the Delete By Submitting pop-up menu, specify the HTML form with the Submit button that sends the delete command to the server.

8 In the After Deleting, Go To box, specify a page to open after the record has been deleted from the database.

   You can specify a page that contains a brief success message to the user, or a page listing the remaining records so that the user can verify that the record has been deleted.

9 Click OK, and save your work.

**Test your delete pages**

1 Upload the search, results, and delete pages to your web server, open a browser and search for a disposable test record to delete.

   When you click a Delete link on the results page, the delete page should appear.

2 Click the Confirm button to delete the record from the database.
3 Verify that the record has been deleted by searching for the record again. The record should no longer appear in the results page.

Use ASP commands to modify database in Dreamweaver

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About ASP command objects
An ASP command object is a server object that performs some operation on a database. The object can contain any valid SQL statement, including one that returns a recordset, or one that inserts, updates, or deletes records in a database. A command object can alter the structure of a database if the SQL statement adds or deletes a column in a table. You can also use a command object to run a stored procedure in a database.

A command object can be reusable, in the sense that the application server can reuse a single compiled version of the object to execute the command a number of times. You make a command reusable by setting the Prepared property of the Command object to true, as in the following VBScript statement:

mycommand.Prepared = true

If you know the command will be executed more than a few times, having a single compiled version of the object can make database operations more efficient.

Note:
Not all database providers support prepared commands. If your database does not support it, it might return an error when you set this property to true. It might even ignore the request to prepare the command and set the Prepared property to false.

A command object is created by scripts on an ASP page, but Dreamweaver lets you create command objects without writing a line of ASP code.

Use ASP commands to modify a database
You can use Dreamweaver to create ASP command objects that insert, update, or delete records in a database. You supply the command object with the SQL statement or stored procedure that performs the operation on the database.

1 In Dreamweaver, open the ASP page that will run the command.

2 Open the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button, and select Command.

3 Enter a name for the command, select a connection to the database that contains the records you want to edit, and select the editing operation that you want the command to perform—Insert, Update, or Delete.

Dreamweaver starts the SQL statement, based on the type of operation you select. For example, if you select Insert, the dialog box looks like the following example:
Enter the ASP command

4. Complete the SQL statement.

For information on writing SQL statements that modify databases, consult a Transact-SQL manual.

5. Use the Variables area to define any SQL variables. Provide the name and run-time value. Specifying the type and size of each variable prevents injection attacks.

The following example shows an Insert statement that contains three SQL variables. The values of these variables are provided by URL parameters passed to the page, as defined in the Run-Time Value column of the Variables area.

An Insert statement that contains three SQL variables

To get the Size value, use the Databases panel in Dreamweaver. Find your database in the Databases panel and expand it. Next, find the table you’re working with and expand it. The table lists the sizes for your fields. For example, it might say ADDRESS (WChar 50). In this example, 50 is the size. You can also find the size in your database application.

**Note:**

*Numeric, Boolean and date/time data types always use -1 as the size.*

To determine the Type value, see the following table:

<table>
<thead>
<tr>
<th>Type in database</th>
<th>Type in Dreamweaver</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numeric (MS Access, MS SQL Server, MySQL)</td>
<td>Double</td>
<td>-1</td>
</tr>
<tr>
<td>Boolean, Yes/No (MS Access, MS SQL Server, MySQL)</td>
<td>Double</td>
<td>-1</td>
</tr>
<tr>
<td>Date/Time (MS Access, MS SQL Server, MySQL)</td>
<td>DBTimeStamp</td>
<td>-1</td>
</tr>
</tbody>
</table>
Dreamweaver inserts ASP code in your page that, when run on the server, creates a command that inserts, updates, or deletes records in the database.

By default, the code sets the Prepared property of the Command object to `true`, which makes the application server reuse a single compiled version of the object every time the command is run. To change this setting, switch to Code view and change the Prepared property to `false`.

Create a page with an HTML form so users can enter record data. In the HTML form, include three text fields (txtCity, txtAddress, and txtPhone) and a submit button. The form uses the `GET` method and submits the text field values to the page that contains your command.

### About stored procedures

Although you can use server behaviors to build pages that modify databases, you can also use database manipulation objects such as stored procedures or ASP command objects to build the pages.

A stored procedure is a reusable database item that performs some operation on the database. A stored procedure contains SQL code that can, among other things, insert, update, or delete records. Stored procedures can also alter the structure of the database itself. For example, you can use a stored procedure to add a table column or even delete a table.

A stored procedure can also call another stored procedure, as well as accept input parameters and return multiple values to the calling procedure in the form of output parameters.

A stored procedure is reusable in the sense that you can reuse a single compiled version of the procedure to execute a database operation a number of times. If you know a database task will be executed more than a few times—or the same task will be executed by different applications—using a stored procedure to execute that task can make database operations more efficient.

**Note:**

*MySQL and Microsoft Access databases do not support stored procedures.*

### Add a stored procedure (ColdFusion) (CS6)

You can use a stored procedure to modify a database. A stored procedure is a reusable database item that performs some operation on the database.

Before you use a stored procedure to modify a database, make sure the stored procedure contains SQL that modifies the database in some way. To create and store one in your database, consult your database documentation and a good Transact-SQL manual.

1. In Dreamweaver, open the page that will run the stored procedure.
2 In the Bindings panel (Window > Bindings), click the Plus (+) button, and then select Stored Procedure.
3 In the Data Source pop-up menu, select a connection to the database containing the stored procedure.
4 Enter the ColdFusion Data Source user name and password.
5 Select a stored procedure from the Procedures pop-up menu. Dreamweaver automatically fills in any parameters.
6 Select a parameter, and click Edit if you have to make changes.
   The Edit Stored Procedure Variable dialog box appears. The name of the variable you are editing appears in the Name box.
   
   Note:
   You must enter test values for any stored procedure input parameters.
7 Make changes as necessary:
   • Select a Direction from the pop-up menu. A stored procedure might have input values, output values, or both input and output values.
   • Select a SQL type from the pop-up menu. Enter a return variable, a run-time value, and a test value.
8 If the stored procedure takes a parameter, click the Plus (+) button to add a page parameter.
   
   Note:
   You must enter corresponding page parameters for each stored procedure parameter return value. Do not add page parameters unless there is a corresponding return value.
   Click the Plus (+) button again to add another page parameter, if necessary.
9 Select a page parameter, and click the Minus (-) button to delete the parameter if necessary or click Edit to make changes to the parameter.
10 Select the Returns Recordset Named option, and then enter a name for the recordset; if the stored procedure returns a recordset, click the Test button to see the recordset that the stored procedure returns. Dreamweaver runs the stored procedure and displays the recordset, if any.
   
   Note:
   If the stored procedure returns a recordset and takes parameters, you must enter a value in the Default Value column in the Variables box to test the stored procedure.
   
   You can use different test values to generate different recordsets. To change test values, click the Edit button for Parameter, and change the test value, or click the Edit button for Page Parameter and change the default value.
11 Select the Returns Status Code Named option, enter a name for the status code, if the stored procedure returns a status code return value. Click OK.

After you close the box, Dreamweaver inserts ColdFusion code in your page that calls a stored procedure in the database, when the code runs on the server. The stored procedure in turn performs a database operation, such as inserting a record.

If the stored procedure takes parameters, you can create a page that gathers the parameter values and submits them to the page with the stored procedure. For example, you may create a page that uses URL parameters or an HTML form to gather parameter values from users.
Run a stored procedure (ASP) (CS6)
With ASP pages, you must add a command object to a page to run a stored procedure. For more information on command objects, see About ASP command objects.

1. In Dreamweaver, open the page that will run the stored procedure.
2. In the Bindings panel (Window > Bindings), click the Plus (+) button, and then select Command (Stored Procedure).
   The Command dialog box appears.
3. Enter a name for the command, select a connection to the database containing the stored procedure, and then select Stored Procedure from the Type pop-up menu.
4. Select your stored procedure by expanding the Stored Procedures branch in the Database Items box, selecting the stored procedure from the list, and clicking the Procedure button.
5. Enter any required parameters in the Variables table.
   You don't need to enter any parameters for any RETURN_VALUE variable.
6. Click OK.
   After you close the dialog box, ASP code is inserted in your page. When the code runs on the server, the code creates a command object that runs a stored procedure in the database. The stored procedure in turn performs a database operation, such as inserting a record.

By default, the code sets the Prepared property of the Command object to true, which makes the application server reuse a single compiled version of the object every time the stored procedure is run. If you know the command will be executed more than a few times, having a single compiled version of the object can improve the efficiency of database operations. However, if the command will only be executed one or two times, using one might actually slow down your web application because the system has to pause to compile the command. To change the setting, switch to Code view and change the Prepared property to false.

Note:
Not all database providers support prepared commands. If your database does not support it, you might get an error message when you run the page. Switch to Code view and change the Prepared property to false.

If the stored procedure takes parameters, you might create a page that gathers the parameter values and submits them to the page with the stored procedure. For example, you may create a page that uses URL parameters or an HTML form to gather parameter values from users.

Build a registration page

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About registration pages
Your web application can contain a page that requires users to register the first time they visit your site.

A registration page is made up of the following building blocks:

• A database table to store login information about the users
Building applications visually

- An HTML form that lets users select a user name and password
  You can also use the form to obtain other personal information from users.
- An Insert Record server behavior to update the database table of site users
- A Check New Username server behavior to make sure the user name entered by the user is not taken by another user

Store login information about users
A registration page requires a database table to store the login information entered by users.
- Make sure your database table contains a user name and a password column. If you want logged-in users to have different access privileges, include an access privilege column.
- If you want to set a common password for all users of the site, configure your database application (Microsoft Access, Microsoft SQL Server, Oracle, and so on) to enter the password in each new user record by default. In most database applications, you can set a column to a default value each time a new record is created. Set the default value to the password.
- You can also use the database table to store other useful information about the user.
  The next step in creating a registration page is to add an HTML form to the registration page to let users choose a user name and password (if applicable).

Add an HTML form for selecting a user name and password
You add an HTML form to the registration page to let users select a user name and password (if applicable).

1 Create a page (File > New > Blank Page) and lay out your registration page using the Dreamweaver design tools.
2 Add an HTML form by placing the insertion point where you want the form to appear and selecting Form from the Insert menu.
   An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.
3 Name the HTML form by clicking the `<form>` tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.
   You don't have to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Insert Record server behavior sets these attributes for you.
4 Add text fields (Insert > Form > Text Field) to let the user enter a user name and password.
   The form can also have more form objects to record other personal data.
   You should add labels (either as text or images) beside each form object to tell users what they are. You should also line up the form objects by placing them inside an HTML table. For more information on form objects, see Create web forms.
5 Add a Submit button to the form (Insert > Form > Button).
   You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Value box.
   The next step in creating a registration page is to add the Insert Record server behavior to insert records in the table of users in the database.
Update the database table of users
You must add an Insert Record server behavior to the registration page to update the table of users in the database.

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select Insert Record from the pop-up menu.
   The Insert Record dialog box appears.

2. Complete the dialog box, making sure to specify the table of users in the database into which the user data will be inserted. Click OK.
   The final step in creating a registration page is to make sure the user name is not used by another registered user.

Add a server behavior to ensure a unique user name
You can add a server behavior to a user registration page that verifies that the user name is unique before adding that user to your database of registered users.

When the user clicks the Submit button on the registration page, the server behavior compares the user name entered by the user against the user names stored in a database table of registered users. If no matching user name is found in the database table, the server behavior carries out the insert record operation normally. If a matching user name is found, the server behavior cancels the insert record operation and opens a new page (usually a page alerting the user that the user name is already taken).

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Check New Username from the pop-up menu.

2. In the Username Field pop-up menu, select the form text field that your visitors use to enter a user name.

3. In the If Already Exists, Go To box, specify a page to open if a matching user name is found in the database table, and click OK.
   The opened page should alert the user that the user name is already taken and let the user try again.

Build a login page

Note:
The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.

About login pages
Your web application can contain a page that lets registered users log in to the site.
A login page is made up of the following building blocks:

- A database table of registered users
- An HTML form to let users enter a user name and password
- A Log In User server behavior to make sure the entered user name and password are valid
  A session variable consisting of the user name is created for the user when the user logs in successfully.
Create a database table of registered users

You need a database table of registered users to verify that the user name and password entered in the login page are valid.

Use your database application and a registration page to create the table. For instructions, see the related topic link below.

The next step in building a login page is to add an HTML form to the page to let users log in. See the next topic for instructions.

Add an HTML form to let users log in

You add an HTML form to the page to let users log in by entering a user name and password.

1. Create a page (File > New > Blank Page), and lay out your login page using the Dreamweaver design tools.

2. Add an HTML form by placing the insertion point where you want the form to appear and choosing Form from the Insert menu.

   An empty form is created on the page. You may have to enable Invisible Elements (View > Visual Aids > Invisible Elements) to see the form's boundaries, which are represented by thin red lines.

3. Name the HTML form by clicking the <form> tag at the bottom of the Document window to select the form, opening the Property inspector (Window > Properties), and entering a name in the Form Name box.

   You don't have to specify an action or method attribute for the form to tell it where and how to send the record data when the user clicks the Submit button. The Log In User server behavior sets these attributes for you.

4. Add a user name and a password text field (Insert > Form > Text Field) to the form.

   Add labels (either as text or images) beside each text field, and line up the text fields by placing them inside an HTML table and setting the table's border attribute to 0.

5. Add a Submit button to the form (Insert > Form > Button).

   You can change the label of the Submit button by selecting the button, opening the Property inspector (Window > Properties), and entering a new value in the Label box.

   The next step in building a login page is to add the Log In User server behavior to verify that the entered user name and password are valid.

Verify the user name and password

You must add a Log In User server behavior to the login page to ensure that the user name and password that a user enters are valid.

When a user clicks the Submit button on the login page, the Log In User server behavior compares the values entered by the user against the values for registered users. If the values match, the server behavior opens one page (usually the site's Welcome screen). If the values do not match, the server behavior opens another page (usually a page alerting the user that the login attempt failed).

1. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Log In User from the pop-up menu.

2. Specify the form and the form objects that visitors use to enter their user name and password.

3. (ColdFusion) Enter your user name and password if applicable.

4. Specify the database table and columns that contain the user names and passwords of all the registered users.
The server behavior compares the user name and password a visitor enters on the login page against the values in these columns.

5 Specify a page to open if the login process succeeds.
   The specified page is usually the site's Welcome screen.

6 Specify a page to open if the login process fails.
   The specified page usually alerts the user that the login process failed and lets the user try again.

7 If you want users forwarded to the login page after attempting to access a restricted page to return to that restricted page after logging in, select the Go To Previous URL option.

   If a user tries to access your site by opening a restricted page without first logging in, the restricted page can forward the user to the login page. After the user logs in successfully, the login page redirects the user to the restricted page that forwarded them to the login page in the first place.

💡 When you complete the dialog box for the Restrict Access To Page server behavior on these pages, ensure that you specify your login page in the If Access Denied, Go To box.

8 Specify whether to grant access to the page based on user name and password alone, or based on authorization level too, and click OK.

   A server behavior is added to the login page that ensures the user name and password entered by a visitor are valid.

### Build a page that only authorized users can access

**Note:**

*The user interface has been simplified in Dreamweaver and later. As a result, you may not find some of the options described in this article in Dreamweaver and later. For more information, see this article.*

### About protected pages

Your web application can contain a protected page that only authorized users can access.

For example, if a user attempts to bypass the login page by typing the protected page's URL in a browser, the user is redirected to another page. Similarly, if you set the authorization level for a page to Administrator only users with Administrator access privileges can view the page. If a logged-in user attempts to access the protected page without the proper access privileges, the user is redirected to another page.

You can also use authorization levels to review newly registered users before granting them full access to the site. For example, you may want to receive payment before allowing a user access to the member pages of the site. To do so, you can protect the member pages with a Member authorization level and only grant newly registered users Guest privileges. After receiving payment from the user, you can upgrade the user's access privileges to Member (in the database table of registered users).

If you do not plan to use authorization levels, you can protect any page on your site simply by adding a Restrict Access To Page server behavior to the page. The server behavior redirects to another page any user who has not successfully logged in.
If you do plan to use authorization levels, you can protect any page on your site with the following building blocks:

- A Restrict Access To Page server behavior to redirect unauthorized users to another page
- An extra column in your users database table to store each user’s access privileges

Regardless of whether you use authorization levels, you can add a link to the protected page that lets a user log out and clears any session variables.

Redirect unauthorized users

To prevent unauthorized users from accessing a page, add a Restrict Access To Page server behavior to it. The server behavior redirects the user to another page if the user attempts to bypass the login page by typing the protected page’s URL in a browser, or if the user is logged in but attempts to access the protected page without the proper access privileges.

Note:

The Restrict Access To Page server behavior can only protect HTML pages. It does not protect other site resources such as image files and audio files.

If you want to give many pages on your site the same access rights, you can copy and paste access rights from one page to another.

Redirect unauthorized users to another page

1. Open the page you want to protect.
2. In the Server Behaviors panel (Window > Server Behaviors), click the Plus (+) button and select User Authentication > Restrict Access To Page from the pop-up menu.
3. Select the level of access for the page. To allow only users with certain access privileges to view the page, select the Username, Password, and Access Level option and specify the authorization levels for the page.
   For example, you can specify that only users with Administrator privileges can view the page by selecting Administrator in the authorization levels list.
4. To add authorization levels to the list, click Define. In the Define Access Levels list that appears, enter a new authorization level, and click the Plus (+) button. The new authorization level is stored for use with other pages.
   Ensure that the string for the authorization level matches exactly the string stored in your user database. For example, if the authorization column in your database contains the value "Administrator", enter Administrator, not Admin, in the Name box.
5. To set more than one authorization level for a page, Control-click (Windows) or Command-click (Macintosh) the levels in the list.
   For example, you can specify that any user with Guest, Member, or Administrator privileges can view the page.
6. Specify the page to open if an unauthorized user attempts to open the protected page.
   Ensure that the page you choose is not protected.
7. Click OK.

Copy and paste a page’s access rights to other pages on the site

1. Open the protected page and select the Restrict Access To Page server behavior listed in the Server Behaviors panel (not the one in the Plus (+) pop-up menu).
2. Click the arrow button in the upper-right corner of the panel, and select Copy from the pop-up menu.
The Restrict Access To Page server behavior is copied to your system's Clipboard.

3. Open another page you want to protect in the same way.

4. In the Server Behaviors panel (Window > Server Behaviors), click the arrow button in the upper-right corner, and select Paste from the pop-up menu.

5. Repeat steps 3 and 4 for each page you want to protect.

**Store access privileges in the user database**

This building block is required only if you want certain logged-in users to have different access privileges. If you simply require users to log in, you don't have to store access privileges.

1. To provide certain logged-in users with different access privileges, make sure your database table of users contains a column specifying each user's access privileges (Guest, User, Administrator, and so on). The access privileges of each user should be entered in the database by the site administrator.

   In most database applications, you can set a column to a default value each time a new record is created. Set the default value to the most common access privilege on your site (for example, Guest); then manually change the exceptions (for example, changing Guest to Administrator). The user now has access to all administrator pages.

2. Make sure each user in the database has a single access privilege, such as Guest or Administrator, not multiple privileges like User, Administrator. To set multiple access privileges for your pages (for example, all guests and administrators can see this page), set those privileges at the page level, not the database level.

**Log out users**

When a user logs in successfully, a session variable is created that consists of the user name. When the user leaves your site, you can use the Log Out User server behavior to clear the session variable and redirect the user to another page (usually a goodbye or thank you page).

You can invoke the Log Out User server behavior when the user clicks a link or when a specific page loads.

**Add a link to let users log out**

1. Select text or an image on a page to serve as the link.

2. In the Server Behaviors panel (Window > Behaviors), click the Plus (+) button and select User Authentication > Log Out User.

3. Specify a page to open when the user clicks the link, and click OK.

   The page is usually a goodbye or thank you page.

**Log out users when a specific page loads**

1. Open the page that will load in Dreamweaver.

   The page is usually a goodbye or thank you page.

2. In the Server Behaviors panel, click the Plus (+) button and select User Authentication > Log Out User.

3. Select the Log Out When Page Loads option, and click OK.
Securing folders in Coldfusion using Dreamweaver

Note:
Support for ColdFusion is removed in Dreamweaver and later.

Secure a folder or site on the server (ColdFusion)
You can use Dreamweaver to password-protect a specific folder in your ColdFusion application, including the application's root folder. When a visitor to your site requests any page in the specified folder, ColdFusion prompts the visitor for a user name and password. ColdFusion stores the user name and password in session variables so the visitor doesn't need to enter them again during the session.

Note:
This feature is available only if you have access to a computer running ColdFusion MX 7 or later.

1 With a ColdFusion document open in Dreamweaver, select Commands > ColdFusion Login Wizard.
2 Complete the ColdFusion Login Wizard.
   a. Specify the full path to the folder you want to secure and click Next.
   b. In the next screen, select one of the following authentication types:
      - Simple Authentication Secures your application with a single user name and password for all users.
      - Windows NT Authentication Secures your application using NT user names and passwords.
      - LDAP Authentication Secures your application with user names and passwords stored on an LDAP server.
   c. Specify whether you want users to log in using a ColdFusion login page or a pop-up menu.
   d. In the next screen, specify the following settings:
      • If you selected simple authentication, specify the user name and password that each visitor must enter.
      • If you selected Windows NT authentication, specify the NT domain to validate against.
      • If you selected LDAP authentication, specify the LDAP server to validate against.
3 Upload the new files to your remote site. The files are located in your local site folder.

Using ColdFusion components in Dreamweaver

Note:
Support for ColdFusion is removed in Dreamweaver and later.

About ColdFusion components
ColdFusion component (CFC) files let you encapsulate application and business logic into self-contained, reusable units. CFCs also provide a fast, easy way to create web services.

A CFC is a reusable software unit written in ColdFusion markup language (CFML), which makes it easy to reuse and maintain your code.
You can use Dreamweaver to work with CFCs. For information on CFC tags and syntax, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).

Note:

You can use CFCs only with ColdFusion MX or later. CFCs are not supported in ColdFusion 5.

CFCs are meant to provide a simple yet powerful way for developers to encapsulate elements of their websites. Generally, you should use components for application or business logic. Use customs tags for presentation elements such as customized greetings, dynamic menus, and so on.

As with many other types of construction, dynamic sites can often benefit from interchangeable parts. For example, a dynamic site may run the same query repeatedly, or calculate the total price of shopping cart pages and recalculate it every time an item is added. These tasks can be handled by components. You can fix, improve, extend, and even replace a component with minimal impact to the rest of your application.

Suppose an online store calculates shipping charges based on the price of orders. For orders under $20, the shipping charge is $4; for orders between $20 and $40, the shipping charge is $6, and so on. You could insert the logic for calculating the shipping charge in both the shopping cart page and the checkout page, but that would mix HTML presentation code and CFML logic code and generally make the code difficult to maintain and reuse.

You decide to create a CFC called Pricing that has, among other things, a function called ShippingCharge. The function takes a price as an argument and returns a shipping charge. For example, if the value of the argument is 32.80, the function returns 6.

In both the shopping cart page and the checkout page, you insert a special tag to invoke the ShippingCharge function. When the page is requested, the function is invoked and a shipping charge is returned to the page.

Later, the store announces a special promotion: free shipping for all orders above $100. You make the change to the shipping rates in one place—the ShippingCharge function of the Pricing component—and all the pages using the function automatically get accurate shipping charges.

**Components panel overview (ColdFusion)**

Use the Components panel (Window > Components) to view and edit ColdFusion components, and add code in the page that invokes the function when the CFM page is requested.

Note:

The Components panel is available only when viewing a ColdFusion page in Dreamweaver.

**Create or delete a CFC in Dreamweaver**

You can use Dreamweaver to visually define a CFC and its functions. Dreamweaver creates a .cfc file and inserts the necessary CFML tags for you.

Note:

Depending on the component, you may have to complete some code by hand.

1 Open a ColdFusion page in Dreamweaver.
2 In the Components panel (Window > Components), select CF Components from the pop-up menu.
3 Click the Plus (+) button, and complete the Create Components dialog box, and click OK.
   a.In the Components section, enter the details about the component. Here is a partial list:
**Name** Specifies the filename of the component. The name must contain only alphanumeric characters and underscores (_). Do not specify the .cfc file extension when entering the name.

**Component Directory** Specifies where the component is saved. Select the web application's root folder (such as \Inetpub\wwwroot\myapp\) or any of its subfolders.

b. To define one or more functions for the component, select Functions from the Section list, click the Plus (+) button, and enter the details of the new function.

Ensure that you specify the type of the value returned by the function in the Return Type option.

*If you select remote from the Access menu, the function becomes available as a web service.*

c. To define one or more arguments for a function, select Arguments from the Section list, select the function from the pop-up menu, click the Plus (+) button, and enter the details of the new argument on the right.

4. If you use a remote development server, upload the CFC file and any dependent files (such as those used to implement a function or include files) to the remote server.

Uploading the files ensures that Dreamweaver features such as Live view and Preview In Browser work properly.

Dreamweaver writes a CFC file and saves it in the folder you specified. The new component also appears in the Components panel (after clicking Refresh).

5. If you use a remote development server, upload the CFC file and any dependent files (such as those used to implement a function or include files) to the remote server.

**View CFCs in Dreamweaver**

Dreamweaver provides a way to visually examine the ColdFusion components (CFCs) located in your site folder or on the server as a whole. Dreamweaver reads the CFC files and displays information about them in an easy-to-navigate tree view in the Components panel.

Dreamweaver looks for the components on your testing server (see Connecting to the database in Dreamweaver). If you create CFCs or make changes to existing CFCs, make sure to upload the CFC files to the testing server so they are accurately reflected in the Components panel.

To view components located on another server, change the testing server settings.

You can view any of the following information about your CF components:

- List all of the ColdFusion components defined on the server.
- If you're running ColdFusion MX 7 or later, filter the list to show only the CFCs located in your site folder.
- Explore the functions and arguments of each component.
- Inspect the properties of functions that serve as web services.

*To use Dreamweaver to inspect CFCs residing in the server root while also managing your site files in a different website root, you can define two Dreamweaver sites. Set the first site to point to the server root and the second to point to the website root. Use the site pop-up menu on the Files panel to switch quickly between the two sites.*
To view CFCs in Dreamweaver, follow these steps:

1. Open any ColdFusion page in Dreamweaver.
2. In the Components panel (Window > Components), select CF Components from the pop-up menu.
3. Click the Refresh button in the panel to retrieve the components.
   The components package is displayed on the server. A component package is a folder that contains CFC files.
   If existing component packages do not appear, click the Refresh button in the panel toolbar.
4. To display only the CFCs located in your site folder, click the Show Only Current Site's CFCs button in the Components panel toolbar.
   
   Note:
   
   This feature is available only if you've defined a computer running ColdFusion MX 6 or later as a testing server for Dreamweaver.
   
   Note:
   
   If the current site is listed in a virtual folder on the remote server, the filtering does not work.
5. Click the Plus (+) button beside the package name to view the components stored in the package.
   - To list the functions of a component, click the Plus (+) button beside the component name.
   - To see the arguments a function takes, as well as the arguments' type and whether they are required or optional, open the function's branch in the tree view.
     Functions that take no arguments have no Plus (+) button beside them.
   - To quickly view the details of an argument, a function, a component, or a package, select the item in the tree view, and click the Get Details button in the panel toolbar.
     You can also right-click (Windows) or Control-click (Macintosh) the item and select Get Details from the pop-up menu.
     Details about the item are displayed in a message box.

**Edit CFCs in Dreamweaver**

Dreamweaver provides a streamlined way of editing the code of the ColdFusion components defined for your site. For example, you can add, change, or delete any component function without leaving Dreamweaver.

To use this feature, your development environment must be set up as follows:

- ColdFusion must be running locally.
- In the advanced Site Definition dialog box in Dreamweaver, the Access type specified in the Testing Server category must be Local/Network.
- In the advanced Site Definition dialog box, the path of your local root folder must be the same as the path of the testing server folder (for example, c:\inetpub\wwwroot\cf_projects\myNewApp\). You can examine and change these paths by selecting Site > Edit Sites.
- The component must be stored in the local site folder or any of its subfolders on your hard disk.

Open any ColdFusion page in Dreamweaver and display the components in the Components panel. To display the components, open the Components panel (Window > Components), select CF Components from the panel's pop-up menu, and click the Refresh button on the panel.

Because ColdFusion is running locally, Dreamweaver displays component packages on your hard disk.
Use the following procedure to edit a component.

1. Open any ColdFusion page in Dreamweaver and display the components in the Components panel (Window > Components).
2. Select CF Components from the panel's pop-up menu, and click the Refresh button on the panel.
   
   Because ColdFusion is running locally, Dreamweaver displays component packages on your hard disk.

   Note:

   To edit the CFC recordset visually, double-click it in the Bindings panel.

3. To edit a component file generally, open the package and double-click the component name in the tree view.
   
   The component's file opens in Code view.

4. To edit a specific function, argument, or property, double-click the item in the tree view.

5. Make your changes by hand in Code view.

6. Save the file (File > Save).

7. To see any new function in the Components panel, refresh the view by clicking the Refresh button on the panel toolbar.

Build web pages that use CFCs

One way to use a component function in your web pages is to write code in the page that invokes the function when the page is requested. You can use Dreamweaver to help you write this code.

Note:

For other ways to use components, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).

1. In Dreamweaver, open the ColdFusion page that will use the component function.

2. Switch to Code view (View > Code).

3. Open the Components panel (Window > Components), and select CF Components from the panel's pop-up menu.

4. Find the component you want and insert it using one of the following techniques:
   
   • Drag a function from the tree view to the page. Code is inserted in the page to invoke the function.
   • Select the function in the panel and click the Insert button on the panel toolbar (the second button on the right). Dreamweaver inserts the code in the page at the insertion point.

5. If you insert a function that has arguments, complete the argument code by hand.
   
   For more information, see the ColdFusion documentation from within Dreamweaver (Help > Using ColdFusion).

6. Save the page (File > Save).

Define a recordset in a CFC

Dreamweaver can help you define a recordset (also known as a ColdFusion query) in a ColdFusion component (CFC). By defining a recordset in a CFC, you don't need to define the recordset on each page that uses it. You define the recordset once in the CFC and use the CFC on different pages.

Note:
Building applications visually

This feature is available only if you have access to a computer running ColdFusion MX 7 or later. For more information, see Enable the ColdFusion enhancements.

1 Create or open an existing CFC file in Dreamweaver.

2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.
   The Recordset dialog box appears. You can work in either the simple or the advanced Recordset dialog boxes.

3 To use an existing function in the CFC, select the function from the Function pop-up menu and skip to step 5.
   The recordset is defined in the function.

4 To define a new function in the CFC, click the New Function button, enter a name for the function in the dialog box that appears, and then click OK.
   The name must contain only alphanumeric characters and underscores (_).

5 To define a recordset for the function, complete the Recordset dialog box options.
   The new function is inserted into the CFC that defines the recordset.

Use a CFC recordset as a source of dynamic content

You can use a ColdFusion component (CFC) as a source of dynamic content for your pages if the component contains a function defining a recordset.

Note:

This feature is available only if you have access to a computer running ColdFusion MX 7 or later. For more information, see Enable the ColdFusion enhancements.

1 Open a ColdFusion page in Dreamweaver.

2 In the Bindings panel (Window > Bindings), click the Plus (+) button and select Recordset (Query) from the pop-up menu.
   The Recordset dialog box appears. You can work in either the simple or the advanced Recordset dialog box.

3 Click the CFC Query button.

4 Complete the CFC query dialog box, click OK, and then click OK again to add the CFC recordset to the list of available content sources in the Bindings panel.

5 Use the Bindings panel to bind the recordset to various page elements.
   For more information, see Adding dynamic content to pages.

Define dynamic content by using a CFC

You can define a recordset as a source of dynamic content in Dreamweaver by using a CFC that contains a recordset definition.

1. In the Name box, enter a name for the CFC recordset.
A common practice is to add the prefix rs to recordset names to distinguish them from other object names in the code, for example: rsPressRelease.

Recordset names must contain only alphanumeric characters and underscores (_). You cannot use special characters or spaces.
2. Select a package from the ones already defined on the server.

If the package does not appear in the pop-up menu, you can refresh the list of packages by clicking the Refresh button near the pop-up menu.

Make sure you upload your CFCs to the testing server first. Only CFCs on the testing server are displayed.

3. Select a component from the ones defined in the currently selected package.

If the Component pop-up menu does not contain any components, or if none of your previously created components appear in the menu, you should upload the CFC files to the testing server.

4. (Optional) To create a component, click the Create New Component button.
   
a. In the Name box, enter the name for the new CFC. The name must contain only alphanumeric characters and underscores (_).
   
b. In the Component Directory box, enter the location for your CFC, or browse to locate the folder.

   **Note:**
   
   *The folder must be the relative path to the site root folder.*

5. From the Function pop-up menu, select the function that contains the recordset definition.

   The Function pop-up menu contains only the functions defined in the currently selected component. If no function appears in this pop-up menu, or if your last changes are not reflected in the currently listed functions, check that your last changes were saved and uploaded to server.

   **Note:**
   
   *The Connection and SQL boxes are read-only.*

6. Edit each parameter (type, value, and default value) that must be passed as a function argument by clicking the Edit button.

   a. Enter a value for the current parameter by selecting the value type from the Value pop-up menu and entering the value in the box to the right. The value type can be a URL parameter, a form variable, a cookie, a session variable, an application variable, or an entered value.

   b. Enter a default value for the parameter in the Default Value box. If no run-time value is returned, the default parameter value is used.

   c. Click OK.

   You cannot modify the database connection and the SQL query for the recordset. These fields are always disabled—the connection and SQL query are displayed for your information.

7. Click Test to connect to the database and create an instance of the recordset.

   If the SQL statement contains page parameters, ensure that the Default Value column of the Parameters box contains valid test values before clicking Test.

   If the query was executed successfully, a table displays the recordset. Each row contains a record and each column represents a field in that record.

   Click OK to clear the CFC Query.

8. Click Ok.
Chapter 17: Test, preview, and publish websites

Preview pages

Real-time preview allows you to preview your pages in the browser or on mobile devices and view the changes in the browser or device in real time as you code.

Live view gives you an idea of how your page will look on the web and lets you edit items in Code view.

Design view also gives you an idea of how your page will look on the web but does not render the page exactly as browsers do.

The Open in Browser feature lets you see how your pages will look in browsers. This is best for working with pages that use dynamic data from databases as this is not real-time.

Read on to learn more about the different types of preview options in Dreamweaver.

Real-time Preview in browser

You can preview your web pages in real-time as you code or design them in Dreamweaver. This feature allows you to code and preview your web pages simultaneously on multiple browsers.

Note:
You can also preview your code in mobile devices in real-time as you code. For more information, see Preview Dreamweaver web pages on multiple devices.

1. Click Real-time Preview in the Dreamweaver status bar.

You have options to preview your web pages in real-time in a browser, or on a device.

If you want to preview your webpages on a device, see Preview Dreamweaver web pages on multiple devices.

2. To preview your web pages in the browser, click any of the available browser options.

   Note:

   You can edit the browsers that appear in this list. To add or remove a browser from this list, see Set browser preview preferences.

   If you have a testing server, make sure you enable Automatically push files to testing server, while setting up the testing server.

   The real-time preview works off the files in the testing server. Enabling automatic push to the testing server ensures you see the changes in real time.
3 If prompted, save the web page and its related documents.
   A browser opens displaying the webpage.

4 Continue to code your page and watch the changes in the browser as you code.

**Set browser preview preferences**

You can switch between real time preview and preview in browser. Set preferences for the browser to use when previewing a site and define default primary and secondary browsers.

These browser preferences are then used regardless of whether you are previewing your site live with real-time preview, or you are opening the page in the browser.

1 Select File > Real-time Preview > Edit Browser List.
Test, preview, and publish websites

Default to Static Browser Preview

If you deselect the Default to Static Browser Preview option, realtime preview is disabled. You can use keyboard shortcuts of primary and secondary browsers to open preview in browser. Alternatively, you can use File menu or click the device preview icon at the status bar.

To add a browser to the list, click the Plus (+) button, complete the Add Browser dialog box, and then click OK.

To delete a browser from the list, select the browser, and then click the Minus (-) button.

To change settings for a selected browser, click the Edit button, make changes in the Edit Browser dialog box, and then click OK.

Select the Primary Browser or the Secondary Browser option to specify whether the selected browser is the primary or secondary browser.

F12 (Windows) or Option+F12 (Macintosh) opens the primary browser; Control+F12 (Windows) or Command+F12 (Macintosh) opens the secondary browser.

Select Preview Using Temporary File to create a temporary copy for previewing and server debugging. (Deselect this option if you want to update the document directly.)

Default to static browser preview This will allow users to choose the mode of previewing their files in browser. On checking the checkbox users can preview files using “Open in browser” from menus and using shortcuts. When unchecked Real Time Preview will be used for previewing files in browsers. By default the checkbox is unchecked and Real time preview will be used for previewing the files in browser.

Preview pages in Live view

Live view differs from the traditional Dreamweaver design view in that it provides a more realistic rendering of what your page will look like in a browser, which is also editable.

You can switch to Live view any time you are in Design view. Switching to Live view, however, is not related to switching between any of the other traditional views in Dreamweaver (Code/Split/Design). When you switch to Live view from Design view, you are simply toggling the Design view between editable and “live”.
While Design view remains frozen once you enter Live view, Code view remains editable, so you can change your code, and then refresh Live view to see your changes take effect. When you’re in Live view, you have the additional option of viewing live code. Live Code view is like Live view in that it displays a version of the code that the browser is executing in order to render the page. Like Live view, Live Code view is a non-editable view.

An additional advantage of Live view is the ability to freeze JavaScript. For example, you can switch to Live view and hover over jQuery-based table rows that change color as the result of user interaction. When you freeze JavaScript, Live view freezes the page in its current state. You can then edit your CSS or JavaScript and refresh the page to see the changes take effect. Freezing JavaScript in Live view is useful if you want to see and change properties for the different states of pop-up menus or other interactive elements that you can’t see in traditional Design view.

To preview pages in Live view:

1. Make sure that you are in Design view (View > Design) or Code and Design views (View > Code and Design).
2. Click the Live view button.
3. (Optional) Make your changes in Code view, in the CSS Styles panel, in an external CSS style sheet, or in another related file.

Even though you can’t edit in Live view, your options for making edits in other areas (for example, in the CSS Styles panel or in Code view) change as you click in Live view.

💡 You can work with related files (such as CSS style sheets) while keeping Live view in focus by opening the related file from the Related Files toolbar at the top of the document.

4. If you’ve made changes in Code view or in a related file, refresh Live view by clicking the Refresh button in the Document toolbar, or by pressing F5.
5. To return to the editable Design view, click the Live view button again.

**Preview Live Code**

The code displayed in Live Code view is similar to what you would see if you viewed the page source from a browser. While such page sources are static, providing you with only the source of the page from the browser, Live Code view is dynamic, and updates as you interact with the page in Live view.

1. Make sure that you are in Live view.
2. Click the Live Code button.

   Dreamweaver displays the live code that the browser would use to execute the page. The code is highlighted in yellow and is uneditable.

   When you interact with interactive elements on the page, Live Code highlights the dynamic changes in the code.

3. To turn off highlighting for changes in Live Code view, choose View > Live View Options > Highlight Changes in Live Code.
4. To return to the editable Code view, click the Live Code button again.

To change Live Code preferences, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh OS), and select the Code Coloring category.
**Freeze JavaScript**

Do one of the following:
- Press F6
- Select Freeze JavaScript from the Live View button's pop-up menu.

An info bar at the top of the document tells you that JavaScript is frozen. To close the info bar, click the close link.

**Live view options**

Besides the Freeze JavaScript option, there are some other options available from the Live View button's pop-up menu, or from the View > Live View Options menu item.

- **Freeze JavaScript** Freezes elements affected by JavaScript in their current state.
- **Disable JavaScript** Disables JavaScript and re-renders the page as it would look if a browser did not have JavaScript enabled.
- **Disable Plug-ins** Disables plug-ins and re-renders the page as it would look if a browser did not have plug-ins enabled.
- **Highlight Changes in Live Code** Turns highlighting for changes in Live Code off or on.
- **Edit the Live View Page in a New Tab** Lets you open new tabs for site documents you browse to using the Browser Navigation toolbar or the Follow Link(s) feature. You must browse to the document first, then select Edit the Live View Page in a New Tab to create a new tab for it.
- **Follow Link** Makes the next link you click in Live View active. Alternatively you can Control-click a link in Live view to make it active.
- **Follow Links Continuously** Makes links in Live View continuously active until you disable them again, or close the page.
- **Automatically Sync Remote Files** Automatically syncs the local and remote file when you click the Refresh icon in the Browser Navigation toolbar. Dreamweaver puts your file to the server before refreshing so that both files are in sync.
- **Use Testing Server for Document Source** Used mainly by dynamic pages (such as ColdFusion pages), and selected by default for dynamic pages. When this option is selected, Dreamweaver uses the version of the file on the site's testing server as the source for the Live view display.
- **Use Local Files for Document Links** The default setting for non-dynamic sites. When this option is selected for dynamic sites that use a testing server, Dreamweaver uses the local versions of files that are linked to the document (for example, CSS and JavaScript files), instead of the files on the testing server. You can then make local changes to related files so that you can see how they look before putting them to the testing server. If this option is deselected, Dreamweaver uses the testing server versions of related files.
- **HTTP Request Settings** Takes you to an advanced settings dialog box where you can enter values for displaying live data. For more information, click the Help button in the dialog box.

**Open in browser**

You can open a page in a browser at any time; you don't have to upload it to a web server first. When you preview a page, all browser-related functions should work, including JavaScript behaviors, document-relative and absolute links, ActiveX® controls, and browser plug-ins provided that you installed the required plug-ins or ActiveX controls in your browsers.
Before opening a document in browser, save the document; otherwise, the browser does not display your most recent changes.

1 Right-click the filename in the Document toolbar, and click Open in Browser.

   **Note:**

   *If no browsers are listed, select Edit > Preferences or Dreamweaver > Preferences (Macintosh), and then select the Preview In Browser category on the left to select a browser. For more information, see Set browser preview preferences.*

2 Click links and test content in your page.

   **Note:**

   *Content linked with a site root-relative path does not appear when you preview documents in a local browser unless you specify a testing server, or select the Preview Using Temporary File option in Edit > Preferences > Preview In Browser. This is because browsers don't recognize site roots—servers do.*

   To preview content linked with root-relative paths, put the file on a remote server, and then select File > Preview In Browser to view it.

3 Close the page in the browser when you finish testing.

### Preview Dreamweaver web pages on multiple devices

[Image of multiple devices showing Dreamweaver interface]

Dreamweaver now lets you test your production-ready web pages simultaneously on multiple devices. You can see how your web page refloows in various form factors and also test interactive features on your pages. All these without having to install any mobile app or having to physically connect the devices to your desktop! Simply scan the auto generated QR code with your devices and preview your web pages on the devices.

Live inspect, when triggered on desktop, reflects on all connected devices and helps you inspect various elements and tweak the design as required.
Prerequisites

<table>
<thead>
<tr>
<th></th>
<th>Ensure that you have a QR code scanner installed on your devices.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Ensure that your desktop and mobile devices are connected to the Internet and are on the same network.</td>
</tr>
<tr>
<td></td>
<td>Ensure that you have your Adobe ID credentials handy. You need the Adobe ID that you use for Dreamweaver on your desktop to log in to the devices during the preview.</td>
</tr>
<tr>
<td></td>
<td>If you are an enterprise customer, check if you have the required permissions to access the Device Preview service.</td>
</tr>
<tr>
<td></td>
<td>On the devices, ensure that JavaScript and cookies are enabled in the browser settings.</td>
</tr>
</tbody>
</table>

Supported devices

All Android and iOS devices

Preview web pages on devices

1. On your desktop computer, launch Dreamweaver, and open the web page that you want to preview on devices.
2. Click the Real-time Preview icon in the document toolbar.

The Device Preview pop-up appears with a QR code and a short URL.
3 Scan the QR code with the mobile device on which you want to preview the web document. To connect multiple devices, scan the QR code with each of those devices.

4 On the devices, a login screen appears. Log in using your Adobe ID credentials. Ensure that you use the same Adobe ID that you use for Dreamweaver/Creative Cloud.

![Login screen on devices](image.png)

5 After a successful login, the names of the connected devices appear in the Device Preview pop-up. And, you will see a preview of your web page on the connected devices.
Note:

To map the device names in the pop-up with the actual device, hover your mouse on the device names. A feedback screen appears on the corresponding device.

**Inspect web pages on devices**

To inspect the web page on all the connected devices, click the Inspect icon in the Dreamweaver toolbar.
To inspect the web page on a specific device, click the inspect icon that corresponds to the device name in the Device Preview pop-up. The viewport in Dreamweaver is set to match the viewport on the corresponding device and inspect is triggered on that specific device and Dreamweaver.

Click the Inspect icon in Dreamweaver again to exit the Inspect mode.

All the edits that you do to your web page on the desktop are reflected immediately on the devices after they are committed.

**Troubleshoot issues with Device Preview**

If you run into issues while connecting your devices or previewing your web pages on devices, see the information in the article Device Preview - Troubleshooting.

**Test your Dreamweaver site**

**Site testing guidelines**

Before uploading your site to a server and declaring it ready for viewing, it's a good idea to test it locally. (In fact, it's a good idea to test and troubleshoot your site frequently throughout its construction—you can catch problems early and avoid repeating them.)

You should make sure that your pages look and work as expected in the browsers you're targeting, that there are no broken links, and that the pages don't take too long to download. You can also test and troubleshoot your entire site by running a site report.

The following guidelines will help you create a good experience for visitors to your site:

**Make sure your pages function in the browsers you're targeting.**

Your pages should be legible and functional in browsers that do not support styles, layers, plug-ins, or JavaScript. For pages that fail badly in older browsers, consider using the Check Browser behavior to automatically redirect visitors to another page.

**Preview your pages in different browsers and platforms.**

This gives you an opportunity to see differences in layout, color, font sizes, and default browser window size that cannot be predicted in a target browser check.

**Check your site for broken links and fix them.**

Other sites undergo redesign and reorganization too, and the page you're linking to may have been moved or deleted. You can run a link check report to test your links.

**Monitor the file size of your pages and the time they take to download.**

Keep in mind that if a page consists of one large table, in some browsers, visitors will see nothing until the entire table finishes loading. Consider breaking up large tables; if this is not possible, consider putting a small amount of content—such as a welcome message or an advertising banner—outside the table at the top of the page so users can view this material while the table downloads.

**Run a few site reports to test and troubleshoot the entire site.**

You can check your entire site for problems, such as untitled documents, empty tags, and redundant nested tags.
Validate your code to locate tag or syntax errors.

Update and maintain the site after its published.

Publishing your site—that is, making it live—can be accomplished in several ways and is an ongoing process. An important part of the process is defining and implementing a version-control system, either with the tools Dreamweaver includes or through an external version-control application.

Use the discussion forums.

The Dreamweaver discussion forums can be found on the Adobe website at www.adobe.com/go/dreamweaver_newsgroup.

The forums are a great resource for getting information on different browsers, platforms, and so on. You can also discuss technical issues and share helpful hints with other Dreamweaver users.

For a tutorial on troubleshooting publishing problems, see www.adobe.com/go/vid0164.

Use reports to test your site

You can run site reports on workflow or HTML attributes. You can also use the Reports command to check links in your site.

Workflow reports can improve collaboration among members of a web team. You can run workflow reports that display who has checked out a file, which files have Design Notes associated with them, and which files have been modified recently. You can further refine Design Note reports by specifying name/value parameters.

Note:

You must have a remote site connection defined to run the workflow reports.

HTML reports enable you to compile and generate reports for several HTML attributes. You can check combinable nested font tags, missing Alt text, redundant nested tags, removable empty tags, and untitled documents.

After you run a report, you can save it as an XML file, then import it into a template instance or a database or spreadsheet and print it, or display it on a website.

Note:

You can also add different report types to Dreamweaver through the Adobe Dreamweaver Exchange website.

Run reports to test a site

1. Select Site > Reports.

2. Select what to report on from the Report On pop-up menu and set any of the report types to run (workflow or HTML).

   You cannot run a Selected Files In Site report unless you have already selected files in the Files panel.

3. If you selected a workflow report, click Report Settings. Otherwise, skip this step.

   Note:
If you selected more than one workflow report, you need to click the Report Settings button for each report. Select a report, click Report Settings, and enter settings; then, repeat the process for any other workflow reports.

**Checked Out By** Creates a report listing all documents checked out by a specific team member. Enter the name of a team member, and then click OK to return to the Reports dialog box.

**Design Notes** Creates a report listing all Design Notes for selected documents or for the site. Enter one or more name and value pairs, then select comparison values from the corresponding pop-up menus. Click OK to return to the Reports dialog box.

**Recently Modified** Creates a report listing files that have changed during a specified time frame. Enter date ranges and location for the files you want to view.

4 If you selected an HTML report, select from the following reports:

**Combiable Nested Font Tags** Creates a report that lists all nested font tags that can be combined to clean up the code.

For example, `<font color="#FF0000"><font size="4">STOP!</font></font>` is reported.

**Missing Alt Text** Creates a report listing all the `<img>` tags that don’t have alternate text.

Alternate text appears in place of images for text-only browsers or for browsers that have been set to download images manually. Screen readers read alternate text, and some browsers display alternate text when the user mouses over the image.

**Redundant Nested Tags** Creates a report detailing nested tags that should be cleaned up.

For example, `<i> The rain <i> in</i> Spain stays mainly in the plain</i>` is reported.

**Removable Empty Tags** Creates a report detailing all empty tags that can be removed to clean up the HTML code.

For example, you may have deleted an item or image in Code view, but left behind the tags that applied to that item.

**Untitled Documents** Creates a report listing all the untitled documents found within the selected parameters. Dreamweaver reports all documents with default titles, multiple title tags, or missing title tags.

5 Click Run to create the report.

Depending on the type of report you run, you might be prompted to save your file, define your site, or select a folder (if you haven’t already done so).

A list of results appears in the Site Reports panel (in the Results panel group).

**Use and save a report**

1 Run a report (see the previous procedure).

2 In the Site Reports panel, do any of the following to view the report:

   • Click the column heading you want to sort results by.
     You can sort by filename, line number, or description. You can also run several different reports and keep the different reports open.

   • Select any line in the report, then click the More Info button on the left side of the Site Reports panel for a description of the problem.

   • Double-click any line in the report to view the corresponding code in the Document window.
Test, preview, and publish websites

Note:
If you are in Design view, Dreamweaver changes the display to split view to show the reported problem in code.

3 Click Save Report to save the report.

When you save a report, you can import it into an existing template file. You can then import the file into a database or spreadsheet and print it, or use the file to display the report on a website.

💡

After running HTML reports, use the Clean Up HTML command to correct any HTML errors the reports listed.