Legal notices

Contents

Chapter 1: Introduction
Design, prototype, and share with Adobe XD ......................................................... 1
What’s new in Adobe XD .......................................................................................... 3
Common questions ................................................................................................. 7
Adobe XD system requirements .............................................................................. 13
Keyboard shortcuts ................................................................................................ 15
Release notes | Adobe XD ....................................................................................... 21
Adobe XD manual (PDF) ........................................................................................ 22
Workspace basics .................................................................................................. 22
Fixed issues ............................................................................................................ 27
Access UI design kits ............................................................................................. 28
Tips and tricks ........................................................................................................ 29

Chapter 2: Design
Design systems in XD ............................................................................................ 32
Collaborate and coedit designs ............................................................................. 33
Work with components in XD ............................................................................... 37
Add multiple states to components ....................................................................... 48
Work with linked assets ......................................................................................... 57
Work with external assets ...................................................................................... 68
Edit objects using Boolean operations ................................................................... 76
Responsive resize and constraints ....................................................................... 78
Create repeating elements .................................................................................... 82
Work with artboards and grids ............................................................................... 88
Work with drawing and text tools .......................................................................... 101
Move, align, distribute, and arrange objects ......................................................... 119
Create a mask with shapes .................................................................................... 125
Group, lock, duplicate, copy, and flip objects ...................................................... 128
Select, resize, and rotate objects .......................................................................... 131
Set stroke, fill, and drop shadow for objects ........................................................ 133
Work with blur effects in XD ................................................................................ 138
Manage assets and components .......................................................................... 140
Create and modify gradients ................................................................................. 150
Work with layers .................................................................................................. 154
Export design assets ............................................................................................. 156
Create scrollable artboards .................................................................................. 166
Apply blend effects ............................................................................................... 171
Export and download assets from design specs ................................................... 178

Chapter 3: Prototype
Create interactive prototypes | Overview ................................................................. 181
Animate prototypes ............................................................................................... 187
Create prototypes using voice commands ............................................................ 191
Contents

Preview designs and prototypes in the preview window .......................................................... 195
Add overlays ............................................................................................................................ 196
Design voice prototypes .......................................................................................................... 199

Chapter 4: Share
Share designs and prototypes .......................................................... 204
Share design specs ............................................................................................................... 209
Inspect design specs ......................................................................................................... 211
Navigate design specs ........................................................................................................ 216
Review and comment design specs ..................................................................................... 220

Chapter 5: Work with plugins
Plugins for Adobe XD ........................................................................................................... 222
Create and manage plugins ................................................................................................. 225

Chapter 6: XD for iOS and Android
Preview on mobile devices ................................................................................................. 229
Adobe XD on mobile FAQ .................................................................................................... 233

Chapter 7: Adobe XD and Creative Cloud
Adobe XD and Creative Cloud - an overview ................................................................. 240
Creative Cloud Libraries for Adobe XD .............................................................................. 241

Chapter 8: Adobe XD and Cloud Documents
Cloud documents in Adobe XD ......................................................................................... 245
Troubleshooting issues with cloud documents ................................................................. 247
Error 49 when saving a cloud document ............................................................................. 250
Chapter 1: Introduction

Design, prototype, and share with Adobe XD

Adobe XD enables UX designers design interactive user experiences for web and mobile apps using a single app.

You can design quick and simple designs on artboards in XD. Then wire the artboards together to create an interactive prototype that you can share and iterate with stakeholders. You can also use plugins to automate repeat operations or parts of designer workflows that are tedious, complex, or repetitive.

Adobe XD integrates well with Photoshop, Illustrator, and After Effects.

You can continue designing in your preferred applications, bring the assets into XD, and then use XD to create and share prototypes. XD supports SVG and bitmap files without any loss of fidelity. You can then enhance the assets further in Adobe XD or use them to develop interactive prototypes.

General workflow

In a nutshell, the workflow can be described in the following high-level steps:

- **Design**: Create design layout elements, add artboards, and import resources from other applications such as Adobe Illustrator, Adobe Photoshop, and Adobe After Effects. You can also use plugins to automate repeat operations or parts of designer workflows that are tedious, complex or repetitive.

- **Prototype**: Select objects or artboards in your design and create interactions between artboards.

- **Share**: Once your project is ready to be reviewed, you can share prototypes or design specs, or export the project or assets with your stakeholders.

Read on for more details on designing, prototyping, and sharing in XD. You can also view the following video tutorials to get a quick glimpse of what you can do with Adobe XD.

- Lay out and design your app or website
• Create and preview interactive prototypes

Design

Select a preset size for the artboard. If you want to work with a custom size, type the width and height in pixels in the text fields under the custom option. If you want to specify a custom size, click the Custom Size icon.

Gather your assets in one of the following ways:

• Use Adobe XD’s design tools to design your assets from scratch. For more information, see Work with drawing and text tools and Text tools.
• Copy your designs from Photoshop, Sketch, After Effects or Illustrator, and paste them into your artboard in Adobe XD. You can also import, drag, or copy and paste a JPG, SVG, PNG, or GIF file from:
  • File Explorer (on Windows)
  • Finder (on Mac)
  • Web browser
  • OS clipboard

Enhance the objects in your design. For example, combine or mask objects, change stroke and fill properties, use overlay to stack content on top of a base artboard, and move or rotate objects or use responsive resize to design assets for multiple screen sizes and layouts. Use linked assets to create and maintain a single version for UI kits, sticker sheets or style guides, and share them across documents for a consistent design scalability and plugins to automate repeat operations or parts of designer workflows that are tedious, complex, or repetitive.

For more information, see:

• Select, resize, and rotate objects
• Edit objects using Boolean operations
• Group, lock, duplicate, copy, and flip objects
• Move, align, distribute, and arrange objects
• Set stroke, fill, and drop shadow for objects
• Responsive resize
• Create and manage plugins
• Work with components in XD

Lay out repeating elements effortlessly using the Repeat Grid feature to create a grid out of existing content without duplicating them manually. For more information, see Create repeating elements.

Use plugins to automate repeat operations or parts of designer workflows that are tedious, complex, or repetitive. For more information, see Create and manage plugins.
Add more artboards for each of the screens you need in your prototype. For more information, see Work with artboards and grids.

Prototype
You can create interactive prototypes by using voice capabilities, auto-animate, drag gestures, and timed transitions. For more information, see Voice design and prototyping in XD, Animate prototypes, and Use timed transitions.
You can preview the interactivity in prototypes and while previewing, record the interaction as an MP4 file.

To link artboards or set up interactivity, select the artboard or an object and click the arrow on the right. A wire appears. Simply drag and connect the wire to another object or artboard. In the pop-up window that appears, specify the transition options and the duration for the transition.
You can also use overlay to simulate the concept of transitions without duplicating content across multiple artboards. For detailed information, see Create interactive prototypes | Overview.

Click the Preview icon on the upper right of the application. XD displays a preview screen that allows you to view and navigate the different pages. The Preview screen has a Record icon that allows you to record the flow between pages and save it in MP4 format.
For more information, see Preview and record interactions.

Share
Share designs and prototypes. You can also publish prototypes and design specs for development, or customize the viewing experience as per your preference. For more information, see Publish prototypes.

What's new in Adobe XD
Top new features

Realtime collaboration with Coediting
Collaborate in realtime with other designers.

Add interactive elements with Component states
Design variations of a component for different states and use Hover trigger to specify different interactions.

Manage design revisions with Document history
Browse previously saved versions of a document, bookmark specific versions, and more.
Create high-fidelity prototypes using multiple interactions
Define multiple interactions (wires) on the same object.

Access plugins from the redesigned Plugin Manager
Search and browse plugins, explore curated collections, and more.

Link

Share and collaborate with the redesigned Share mode
Share your designs and prototypes for review and gather feedback.
Introduction

Shared assets with enhanced Creative Cloud Libraries integration
Access and use assets from your library or upload assets from XD to your Creative Cloud Libraries.

Convert Sketch libraries into linked assets
Convert your Sketch library files in XD without having to recreate assets.

See detailed new feature summary

**Previous releases of XD**
- Feature summary | Adobe XD | 2018 releases
- Feature summary | Adobe XD | 2019 releases
Common questions

Adobe XD is a platform for designing, prototyping, and sharing user experiences.
Switch easily from wireframing, visual design, interaction design, prototyping, preview, and sharing, all in one powerful tool.

General questions

• What is Adobe XD and who is it for?
  Adobe XD is the end-to-end solution for designing and prototyping user experiences for websites and mobile apps. Switch easily from wireframing, visual design, interaction design, prototyping, preview, and sharing, all in one powerful tool.

• How much does Adobe XD cost?
  Adobe XD is available for free as part of the Starter plan and there are also paid plans. Visit the Compare plans page to see the different plan options.

• What is the free Starter plan?
  This free plan is available to anyone and includes Adobe XD, 2 GB of Cloud Storage, Adobe Fonts (Basic Library), up to 1 shared cloud document with up to 2 editors, and up to 1 active shared prototype or design spec. Anyone with an Adobe ID, Enterprise ID, or Federated ID can also get the Starter plan. Get XD for free here.

• How do I download Adobe XD?
  The easiest way to download Adobe XD is through the Creative Cloud desktop app - simply choose Install from the Apps tab. You can also download XD from the product page.
  If you are a Creative Cloud for teams or Creative Cloud for enterprise member and you don’t have access to the Creative Cloud desktop app, contact your IT Administrator to obtain access to XD through the Creative Cloud Packager.

• I am in a trial of Adobe XD; how do I get Adobe XD for free?
  Update XD from the Creative Cloud desktop app or within XD, click Help > Updates. When you update, your trial will automatically convert to the free Starter plan for Adobe XD and you will continue to have access to Adobe XD past the duration of your trial.
  Did you publish a prototype or design spec during your trial? If yes, then after you update you will still have access to these links. You will need to manage your links or upgrade your plan to publish new links.
  Learn more about the different plans for Adobe XD here.

• Is Adobe XD available as part of my Creative Cloud Single App membership?
  Yes, you can get XD for free by downloading it from the Creative Cloud desktop app or Adobe XD product page.

• How do I get started with Adobe XD?
  Some great getting started content has been included right inside Adobe XD - from the product home screen, you can select from:
  • A step-by-step example file.
• Links to UI kits that accelerate design for Apple iOS, Google, and Microsoft Windows platforms.
• Tutorials that cover design and exporting, prototyping and sharing, and that show you hints and tips for using Adobe XD.

You can connect with other designers using Adobe XD on our forums to share your experience and get further hints and tips.

• How can I preview my designs and prototypes on iOS or Android devices?

With the help of the Adobe XD mobile app, you can preview your designs and prototypes on iOS and Android devices. You can connect multiple devices to USB ports on the computer running Adobe XD. You can make changes to your designs and prototypes, and preview the changes in real time on all the connected devices. For detailed steps, see Adobe XD on mobile FAQ.

• Where do I go to suggest features or report an issue with Adobe XD?

Our team is actively listening to and responding to your feedback - you can look at existing feature requests, vote on them, or add your own on our UserVoice site. For issues related to product, reach out to our experts in XD support community.

• Where do I get Help and support for Adobe XD?

You can connect with other designers using Adobe XD on our forums to share your experiences and get answers to questions. For more support options, go to our support page.

• On which operating systems is Adobe XD supported?

Adobe XD is supported on the following operating systems:

• macOS 10.12 and later
• Windows 10 Creators Update (64-bit) and later

• In which languages is XD available?

Adobe XD is available in English, French, German, Japanese, Chinese, Korean, Brazilian Portugese, and Spanish on Mac and Windows 10 Creators Update (64-bit).

• What other apps can I use with XD?

You can bring in existing design work from either Adobe Photoshop or Adobe Illustrator. Copy from Illustrator and paste into XD to continue working with vector-based content. Copy from Photoshop and paste into XD as a bitmap. You can also export XD files into After Effects through the File > Export > After Effects option.

You can also copy from any other tool that places SVG content on the clipboard and paste that content into XD, in addition to importing JPG, PNG, GIF, TIFF and SVG content through the File > Import option.

• Does Adobe XD and Publish Services work with all the Adobe identity types, including enterprise identity types?

All identity types (Adobe ID, Enterprise ID, and Federated ID) are supported with Adobe XD and Publish Services. It is possible that an enterprise user could have an Adobe ID and Enterprise ID or Adobe ID and Federated ID associated to the same email address.
Adobe XD plans

- What plans include Adobe XD?

Adobe XD is available within several different plans. The Starter plan is available to anyone with an Adobe ID at no cost. The plan includes Adobe XD and up to one shared prototype and one shared design spec at a time. Get XD for free [here](#).

Paid plans for Adobe XD include unlimited shared prototypes and design specs. Learn more about the different paid plan options [here](#).

Here are some of the differences between free and paid plan options.

<table>
<thead>
<tr>
<th>Free Starter plan</th>
<th>Paid plans</th>
</tr>
</thead>
<tbody>
<tr>
<td>One active shared prototype</td>
<td>Unlimited shared prototypes</td>
</tr>
<tr>
<td>One active shared design spec</td>
<td>Unlimited shared design specs</td>
</tr>
<tr>
<td>2 GB of Cloud Storage</td>
<td>100 GB of Cloud Storage</td>
</tr>
<tr>
<td>Adobe Fonts (Basic Library)</td>
<td>Adobe Fonts (Complete Library)</td>
</tr>
</tbody>
</table>

If you are a Creative Cloud for teams or Creative Cloud for enterprise end user and you don’t have access to the Creative Cloud desktop app, contact your IT Administrator to obtain access to XD.

- How can I check if I have the Starter plan for Adobe XD?

Within XD, on Mac, click **XD > About XD**. On Windows, click **Help > About XD**. You can see the word **Starter** next to the version.

![Adobe XD](#)

Version: 8.0.20.70 (Starter) Creative Cloud Sync 2.4.6.82

**Starter plan for Adobe XD**

- How do I upgrade from the Starter plan?

Visit [this page](#) to upgrade XD.

- I have a paid plan for Adobe XD and I want to switch to the Starter plan. How do I do this?

You will either need to:

  - cancel your plan which you can manage from [here](#).
  - or, contact support, if you are a team or enterprise member.

When you cancel, you automatically move to the Starter plan. You will still have access to Adobe XD and your shared links; however, you will lose the ability to create an unlimited number of prototype and design spec links.

- Is the Starter plan available to Creative Cloud for teams or Creative Cloud for enterprise end-users?

Yes.
If you are a Creative Cloud for teams or Creative Cloud for enterprise end-user and you don’t have access to the Creative Cloud desktop app, contact your IT Administrator to obtain access to XD through the Creative Cloud Packager.

If you, your team, or your enterprise does not have a paid plan that includes Adobe XD, then you can still get XD for free as part of the Starter plan via the Creative Cloud Packager.

- **Is the Starter plan available to enterprise customers in Commercial, Government, or Education?**
  Enterprise customers in Commercial, Government, and Education have access to the Starter plan. To download Adobe XD, customers must use named licensing deployment. Adobe XD supports all three identity types (Adobe ID, Enterprise ID, and Federated ID). You can download Adobe XD from the Creative Cloud desktop app. If you don’t have access to the Creative Cloud desktop app, contact your IT Administrator to obtain access to Adobe XD.

### Adobe XD on Windows

- **Why aren’t older versions of Windows supported?**
  Windows 10 Creators Update (64-bit) represents the future of the Windows platform, opening up opportunities for Adobe XD to use the latest touch-enabled hardware, deliver the highest performance possible, and be available to the next generation of Windows-based devices.

- **What are the minimum system requirements for XD on Windows?**
  See [System requirements](#) for detailed information.

- **Can I use the pen & touch features of Windows 10 in Adobe XD?**
  Pen and touch features are supported in the Property Inspector, the left-side toolbar menu and in the application’s frame at this point. The center canvas cannot be handled with touch yet; you will need a mouse and keyboard to create designs and wire prototypes on the canvas.

- **Can enterprise IT administrators deploy Adobe XD for Windows using the Creative Cloud Packager tool?**
  Currently, IT administrators cannot deploy Adobe XD for Windows and get regular updates using the Creative Cloud Packager tool.

- **Can XD documents be shared with both Mac and Windows users?**
  Yes, you can share documents across platforms.

- **Can I use XD on mobile to preview XD documents open in Windows?**
  Yes, you can save your documents to Creative Cloud Files and open these projects on devices using the mobile version of Adobe XD.

- **Why doesn’t XD prompt me to save my projects on Windows? Have I lost all my work?**
  Native Windows 10 applications such as XD save your files automatically in the background. In case you closed a document without saving it, you can always resume your work by going to **File > Open Recent**, and choose the file from the list.

- **How come my artboards look corrupted on Windows?**
  Adobe XD requires a modern GPU with the latest drivers installed. If you’re seeing large chunks of shifted pixels in your artboards, you should update your drivers to the latest versions to ensure the best experience with XD. Note that many hardware vendors do not update their drivers for older GPUs. For more information on whether your drivers are compatible, see the [System Requirements](#).

  There are specific rendering issues with two older drivers for which there are no available updates from the vendor - Intel 8.15.10.2697 and Intel 8.15.10.2702.
• Why is XD sometimes closing when left for a longer time in the background?
When using many resource-demanding apps simultaneously on your PC, Windows 10 might choose to close some of its native apps running in the background to optimize its performance. If this happens, Adobe XD saves your file automatically and you can resume your work by going to File > Open Recent, and choose the file from the list.

• Can I share XD prototypes on Windows?
Yes, you can share your prototypes.

• How do I stay informed about the updates to XD?
  - Follow us on Twitter: https://twitter.com/adobexd
  - Follow us on Facebook: https://www.facebook.com/adobexd
  - Visit the XD blog: https://www.adobe.com/go/xd_blog

Importing and exporting

• What is the file format in XD? Can I export files to Photoshop and Illustrator?
Files are saved with the file extension.xd in XD. You can export any object as PNG or SVG and import them into Photoshop and Illustrator. Illustrator brings in SVG as editable vectors. Photoshop brings in the content as a flat bitmap.

• Why am I unable to import files into XD?
Adobe XD currently supports the following formats for import: Text, JPG, GIF, PNG, TIFF, SVG, BMP. If you try to drag an unsupported format onto the canvas, the file is ignored.

• Why didn’t my SVG import into XD?
Adobe XD should be able to import SVG from any source. If you are unable to import an SVG file, the file may be too large or contains properties that are not supported by Adobe XD. For more information, see this article.

• Why am I unable to export my assets?
Your export may not have completed for several reasons.
  - Your asset was too large. Adobe XD has a limit of exporting an asset that is 16000 x 16000 pixels.
  - You may be exporting to a read-only or locked directory.
If you run into a different case where export failed, report the issue in our forums.

• How do I export my XD project as an HTML or a CSS or a JavaScript file?
You can install and use third-party plugins to export or extract your XD project as an HTML, CSS, or a JavaScript file. Check out this Adobe Community post for instructions on how to use the available third-party plugins.

Prototypes and sharing

• Can I share a private link with other people?
This is a secure feature that requires you to log in with the same Adobe ID that is used to send the private link. The link cannot be accessed unless the recipient has your Adobe ID and password.

• What is an active shared prototype or design spec?
In XD, you can publish a prototype or design spec to share with others for gathering feedback or handing off to developers. Publishing a prototype or design spec creates a link. If you are on the Starter plan, you can only have one active shared prototype and one active shared design spec at any time. You can always update a link. To publish more links, upgrade to a paid plan or manage your links.

• Why am I unable to use the Adobe XD Publish Services feature?

The Publish Services feature of XD requires a Creative Cloud login. This login ensures that your account allows the use of storage and services. If you have logged in successfully and are still seeing an error, you may have run into one of the scenarios described in this article.

• How can I delete a public link that I have shared using Adobe XD?

1. Go to Share mode > Share Links.
2. In the URL picker menu (🔗), click Manage Links. The Adobe Creative Cloud website opens in your browser, where you can manage your prototypes.
3. Select the prototype to delete and click Permanently delete.

• I deleted all of my existing links but I am still seeing a request to upgrade?

Reconfirm that the links are deleted. If the links are deleted, try closing and reopening Adobe XD.

• I upgraded my plan for unlimited sharing but I am still seeing a request to upgrade?

Try closing and reopening Adobe XD.

• How can I publish a new link?

After sharing your prototype the first time, any subsequent update will offer you two options: Update Link or New Link. Choose New Link to create a new link to your shared prototype. To update the prototype at the previous link, choose Update Link.

• Why did my prototype not update the existing link?

In some scenarios, the previous link is not updated and a new link is generated. These scenarios include:

• The previous link was deleted.
• You changed your login between sharing sessions.
• Adobe’s service experienced an error and we could not update the previous prototype.

Enterprise Support: Commercial, Government, and Education

• Is the free Starter plan for Adobe XD available for commercial, government, or education customers?

Enterprise customers in Commercial, Government, and Education have access to the Starter plan. To download Adobe XD, customers must use named licensing deployment. Adobe XD supports all three identity types (Adobe ID, Enterprise ID, and Federated ID). You can download Adobe XD from the Creative Cloud desktop app. If you don’t have access to the Creative Cloud desktop app, contact your IT Administrator to obtain access to Adobe XD.

• If I don’t have the ability to share prototypes or design specs from Adobe XD, is there something my IT administrators can do to enable me to use XD Publish Services?

Sharing prototypes and design specs in Adobe XD relies upon access to Creative Cloud services. To share prototypes and design specs, XD Publish Services within the Admin Console must be enabled by IT administrators. To learn more, see Enable/disable services for a product profile.

• Can customers use a serial number to deploy Adobe XD for offline use?
Adobe XD does not support offline deployment with a Creative Cloud for enterprise serial number. Customers must use named licensing deployment to access Adobe XD. All three identity types are supported (Adobe ID, Enterprise ID, and Federated ID).

- **As an IT administrator, is there anything I need to do to enable designers to be able to share a prototype or a design spec with users in our organization that do not currently have a Creative Cloud account?**

Adobe XD now allows designers to share prototypes and design specs via a private link only viewable by invite. In order for your users to share and view these assets, it is recommended to set up user’s identities through the Adobe User Management System, so reviewers don’t have to create a new Creative Cloud account when invited (if they don’t already have an account). Link your organization’s enterprise directory system using the Adobe User Sync Tool or another user management tool.

Learn more about the User Sync Tool.

Learn more about sharing and reviewing prototypes and design specs via a private link.

### Adobe XD system requirements

#### Minimum system requirements for Adobe XD on desktop

If your Creative Cloud account is managed under an enterprise account, please consult your Creative Cloud administrator or your organization’s procurement team about upgrading your device.

**macOS**

The latest version of Adobe XD is well tested with public releases of MAC and Windows OS. However, unexpected behaviors may occur on Beta versions of MAC and Windows OS.

<table>
<thead>
<tr>
<th>Minimum requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operating system</strong></td>
</tr>
<tr>
<td>macOS X v10.13 or later For information on upgrading your macOS version, see <a href="#">Upgrade to macOS High Sierra</a>.</td>
</tr>
<tr>
<td><strong>Processor</strong></td>
</tr>
<tr>
<td>Intel® or AMD processor with 64-bit support</td>
</tr>
<tr>
<td><strong>Display</strong></td>
</tr>
<tr>
<td>Non-retina display (Retina recommended)</td>
</tr>
<tr>
<td><strong>Internet</strong></td>
</tr>
<tr>
<td>Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services. Voice capabilities require users to be connected to the Internet to preview their prototypes.</td>
</tr>
<tr>
<td><strong>RAM</strong></td>
</tr>
<tr>
<td>4 GB of RAM</td>
</tr>
</tbody>
</table>
To install and use Adobe XD, you need Windows 10 Creators Update (64-bit) (v1703 (build 10.0.15063) or later), or macOS 10.12 or later. Adobe XD is not supported on Windows 10 (v14393) or macOS 10.11. To upgrade from macOS 10.11, see Upgrade to macOS Sierra.

### Minimum system requirements for Adobe XD on mobile devices

- **iOS** - only 64-bit devices are supported
- **Android** - devices with Open GL ES 2.0 are supported; x86 Android devices are not supported.

#### Adobe XD for iOS

<table>
<thead>
<tr>
<th>64-bit devices:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• iPhone: XR, XS, XS Max, X, 8, 8 Plus, 7, 7 Plus, 6, 6 Plus, 6S, 6S Plus, SE, iPhone 5S</td>
</tr>
<tr>
<td>• iPad: iPad (2018 and 2017), Air, Air2, mini 2, mini 3, mini 4, and iPad Pro (generations 1, 2, 3)</td>
</tr>
</tbody>
</table>

#### Adobe XD for Android

<table>
<thead>
<tr>
<th>Tested on:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Samsung Galaxy S6, S7, S9</td>
</tr>
<tr>
<td>• HTC One M9</td>
</tr>
<tr>
<td>• LG G4</td>
</tr>
<tr>
<td>• Nexus 5X</td>
</tr>
<tr>
<td>• Nexus 6P</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Apple iOS versions 11.0 or later</th>
</tr>
</thead>
<tbody>
<tr>
<td>Android 6.0 or later</td>
</tr>
</tbody>
</table>
**Supported browsers**

Prototypes and design specs created and shared through Adobe XD work best on the latest versions of modern browsers and operating systems. The following is a list of the minimum recommended versions of browsers used for viewing shared prototypes. Shared prototypes are not guaranteed to work on older browser versions.

<table>
<thead>
<tr>
<th>Desktop browsers</th>
<th>Mobile browsers</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Internet Explorer 11+ on Windows 7+. Voice capabilities are not supported on IE11.</td>
<td>• Default browser on Android 4.2.</td>
</tr>
<tr>
<td>• Edge on Windows 10+ (latest two releases of the browser)</td>
<td>• Chrome on iOS 9+. Voice capabilities are not supported in Chrome on iOS.</td>
</tr>
<tr>
<td>• Safari 9 on Mac OS 10.12+</td>
<td>• Safari for iOS 8+</td>
</tr>
<tr>
<td>• Chrome on Mac 10.12+ and Windows 7+ (latest two releases of the browser)</td>
<td>• Currently, XD does not support viewing of shared design specs on mobile browsers.</td>
</tr>
<tr>
<td>• Firefox on Mac 10.12+ and Windows 7+ (latest two releases of the browser)</td>
<td></td>
</tr>
</tbody>
</table>

**Unsupported browsers for Auto-animate**

Prototypes using Auto-Animate does not support animation playback and dissolves between the start and end of an artboard when viewed on the following browsers:

• IE 11  
• Edge 15  
• iOS10

As a workaround, you can open the prototype in any of the other supported browsers listed in the Supported browsers section.

**Language versions**

XD is currently available in the following languages:

• English  
• French  
• German  
• Japanese  
• Korean  
• Simplified Chinese  
• Brazilian Portuguese  
• Spanish

**Keyboard shortcuts**

XD provides shortcuts to help you quickly work on documents. Many keyboard shortcuts appear next to the command names in menus.
Downloadable version of keyboard shortcuts
Download and print a print-friendly version of these keyboard shortcuts.
Click to download.

General shortcuts

<table>
<thead>
<tr>
<th>Result</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quit</td>
<td>?Q</td>
<td>Alt + F4</td>
</tr>
</tbody>
</table>

Keys for Edit menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>?Z</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo</td>
<td>??Z</td>
<td>Ctrl + Shift + Z</td>
</tr>
<tr>
<td>Cut</td>
<td>?X</td>
<td>Ctrl + X</td>
</tr>
<tr>
<td>Copy</td>
<td>?C</td>
<td>Ctrl + C</td>
</tr>
<tr>
<td>Paste</td>
<td>?V</td>
<td>Ctrl + V</td>
</tr>
<tr>
<td>Paste Appearance (in Design mode), and Paste Interaction (in Prototype mode)</td>
<td>??V</td>
<td>Ctrl + Alt +V</td>
</tr>
<tr>
<td>Duplicate</td>
<td>?D</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Delete</td>
<td>?</td>
<td>Delete</td>
</tr>
<tr>
<td>Select All</td>
<td>?A</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Deselect All</td>
<td>??A</td>
<td>Ctrl + Shift + A</td>
</tr>
</tbody>
</table>

Keys for File menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>?N</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Open...</td>
<td>? + Shift + O</td>
<td>Ctrl + Shift + O</td>
</tr>
<tr>
<td>Close</td>
<td>?W</td>
<td>Alt + F4</td>
</tr>
<tr>
<td>Save...</td>
<td>?S</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Save As...</td>
<td>??S</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Export Batch</td>
<td>??E</td>
<td>Ctrl + Shift + E</td>
</tr>
<tr>
<td>Export Selected</td>
<td>?E</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Export to an integrated third-party application (if an application integrated with XD is installed on your computer)</td>
<td>??E</td>
<td>Not available</td>
</tr>
<tr>
<td>Import</td>
<td>??I</td>
<td>Ctrl + Shift + I</td>
</tr>
</tbody>
</table>
### Keys for Path/Pen

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to Pen tool</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Convert Point</td>
<td>Double-click</td>
<td>Double-click</td>
</tr>
<tr>
<td>Asymmetric Control Point</td>
<td>?</td>
<td>Alt</td>
</tr>
<tr>
<td>Snap Control Point Angle</td>
<td>?</td>
<td>Shift</td>
</tr>
<tr>
<td>Snap Anchor Point Angle</td>
<td>?</td>
<td>Shift</td>
</tr>
<tr>
<td>Add</td>
<td>??U</td>
<td>Ctrl + Alt + U</td>
</tr>
<tr>
<td>Subtract</td>
<td>??S</td>
<td>Ctrl + Alt + S</td>
</tr>
<tr>
<td>Intersect</td>
<td>??I</td>
<td>Ctrl + Alt + I</td>
</tr>
<tr>
<td>Exclude Overlap</td>
<td>??X</td>
<td>Ctrl + Alt + X</td>
</tr>
<tr>
<td>Convert to Path</td>
<td>??8</td>
<td>Ctrl + 8</td>
</tr>
</tbody>
</table>

### Keys for Layers (Objects), Groups, and Artboards

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group layers</td>
<td>?G</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>Ungroup layers</td>
<td>??G</td>
<td>Ctrl + Shift + G</td>
</tr>
<tr>
<td>Make component</td>
<td>??K</td>
<td>Ctrl + K</td>
</tr>
<tr>
<td>Lock/Unlock layer</td>
<td>??L</td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>Hide/Show layer</td>
<td>?</td>
<td>Ctrl + ,</td>
</tr>
<tr>
<td>Mask with shape</td>
<td>??M</td>
<td>Ctrl + Shift + M</td>
</tr>
<tr>
<td>Make repeat grid</td>
<td>??R</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Directly select a layer in a group/component</td>
<td>?Click layer in canvas</td>
<td>Ctrl + click layer in canvas</td>
</tr>
<tr>
<td>Change layer opacity</td>
<td>1 to 9 (0 for 100%)</td>
<td>1 to 9 (or 0 for 100%)</td>
</tr>
<tr>
<td>Select artboard</td>
<td>?Click on blank part of artboard</td>
<td>Ctrl + click on blank part of artboard</td>
</tr>
<tr>
<td>Draw shape from center</td>
<td>?Drag</td>
<td>Alt + Drag</td>
</tr>
<tr>
<td>Draw shape with 1:1 aspect ratio (perfects square/circle)</td>
<td>?Drag</td>
<td>Shift + Drag</td>
</tr>
<tr>
<td>Draw equilateral triangle</td>
<td>Shift + Drag</td>
<td>Shift + Drag</td>
</tr>
<tr>
<td>Show/Hide artboard guides</td>
<td>? + ;</td>
<td>Ctrl + ;</td>
</tr>
<tr>
<td>Lock artboard guides</td>
<td>Shift + ? + ;</td>
<td>Shift + Ctrl + ;</td>
</tr>
<tr>
<td>Move element by 10px</td>
<td>Shift + Arrows</td>
<td>Shift + Arrows</td>
</tr>
<tr>
<td>Resize element by 1px increment</td>
<td>? + Arrows</td>
<td>Alt + Arrows</td>
</tr>
<tr>
<td>Resize element by 10px increment</td>
<td>? + Shift + Arrows</td>
<td>Alt + Shift + Arrows</td>
</tr>
<tr>
<td>Select through overlapping layers</td>
<td>? + Click</td>
<td>Ctrl + Click</td>
</tr>
</tbody>
</table>
Keys for Align

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>??</td>
<td>Ctrl + Shift + ?</td>
</tr>
<tr>
<td>Center (horizontally)</td>
<td>??C</td>
<td>Shift + C</td>
</tr>
<tr>
<td>Right</td>
<td>??</td>
<td>Ctrl + Shift + ?</td>
</tr>
<tr>
<td>Top</td>
<td>??</td>
<td>Ctrl + Shift + ?</td>
</tr>
<tr>
<td>Middle (vertically)</td>
<td>??M</td>
<td>Shift + M</td>
</tr>
<tr>
<td>Bottom</td>
<td>??</td>
<td>Ctrl + Shift + ?</td>
</tr>
</tbody>
</table>

Keys for Arrange

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bring to Front</td>
<td>??</td>
<td>Shift + Ctrl + ]</td>
</tr>
<tr>
<td>Bring Forward</td>
<td>?</td>
<td>Ctrl + ]</td>
</tr>
<tr>
<td>Send Backward</td>
<td>??</td>
<td>Ctrl + [</td>
</tr>
<tr>
<td>Send to Back</td>
<td>??</td>
<td>Shift + Ctrl + [</td>
</tr>
</tbody>
</table>

Keys for Distribute

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal</td>
<td>??H</td>
<td>Ctrl + Shift + H</td>
</tr>
<tr>
<td>Vertical</td>
<td>??V</td>
<td>Ctrl + Shift + V</td>
</tr>
</tbody>
</table>

Keys for Text

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>??B</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Italic</td>
<td>??I</td>
<td>Ctrl + I</td>
</tr>
<tr>
<td>Increase font size</td>
<td>??&gt;</td>
<td>Ctrl + Shift + &gt;</td>
</tr>
<tr>
<td>Decrease font size</td>
<td>??&lt;</td>
<td>Ctrl + Shift + &lt;</td>
</tr>
</tbody>
</table>

Keys for Operations menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>From Center</td>
<td>?</td>
<td>Alt</td>
</tr>
<tr>
<td>Copy Paste Object</td>
<td>?? Drag</td>
<td>Alt + Drag</td>
</tr>
<tr>
<td>Constrain</td>
<td>?</td>
<td>Shift</td>
</tr>
<tr>
<td>Edit Text</td>
<td>Enter</td>
<td>Enter</td>
</tr>
<tr>
<td>Constrain Rotate</td>
<td>?? (15°)</td>
<td>Shift (15°)</td>
</tr>
<tr>
<td>Line Constrain Rotate</td>
<td>?? (45°)</td>
<td>Shift (45°)</td>
</tr>
</tbody>
</table>
### Keys for Tools menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>V</td>
<td>V</td>
</tr>
<tr>
<td>Rectangle</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Ellipse</td>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>Polygon</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Line</td>
<td>L</td>
<td>L</td>
</tr>
<tr>
<td>Pen</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Text</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Artboard</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Zoom</td>
<td>Enter zoom mode: Z</td>
<td>Enter zoom mode: Z</td>
</tr>
<tr>
<td>Zoom to Selection</td>
<td>?3</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Eyedropper</td>
<td>I</td>
<td>I</td>
</tr>
</tbody>
</table>

### Keys for Interface and Viewing Options

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom In</td>
<td>• ?+,</td>
<td>• Ctrl + +</td>
</tr>
<tr>
<td></td>
<td>• Option-Scrollwheel,</td>
<td>• Ctrl-Scrollwheel</td>
</tr>
<tr>
<td></td>
<td>• Option-swipe (Magic Mouse)</td>
<td>• Pinch out (trackpad)</td>
</tr>
<tr>
<td></td>
<td>• Pinch out (trackpad)</td>
<td></td>
</tr>
<tr>
<td>Zoom Out</td>
<td>• ?-,</td>
<td>• Ctrl + -</td>
</tr>
<tr>
<td></td>
<td>• Option-Scrollwheel,</td>
<td>• Ctrl-Scrollwheel</td>
</tr>
<tr>
<td></td>
<td>• Option-swipe (Magic Mouse)</td>
<td>• Pinch in (trackpad)</td>
</tr>
<tr>
<td></td>
<td>• Pinch in (trackpad)</td>
<td></td>
</tr>
<tr>
<td>Zoom to Fit</td>
<td>? 0</td>
<td>Ctrl + 0</td>
</tr>
<tr>
<td>100%</td>
<td>? 1</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>200%</td>
<td>? 2</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>Pan</td>
<td>Spacebar</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Assets</td>
<td>? ? Y</td>
<td>Ctrl + Shift + Y</td>
</tr>
<tr>
<td>Layers</td>
<td>? Y</td>
<td>Ctrl + Y</td>
</tr>
</tbody>
</table>
### Keys for Window menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximize</td>
<td>WIN ?</td>
<td></td>
</tr>
<tr>
<td>Minimize</td>
<td>?M</td>
<td>WIN ?</td>
</tr>
<tr>
<td>Preview</td>
<td>??</td>
<td>Ctrl + Enter</td>
</tr>
</tbody>
</table>

### Keys for operation modifiers

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal Pan</td>
<td>Shift + Scrollwheel</td>
<td>Shift + Scrollwheel</td>
</tr>
<tr>
<td>Vertical Pan</td>
<td>Scrollwheel</td>
<td>Scrollwheel</td>
</tr>
</tbody>
</table>

### Keys for Selection and measuring distances between elements

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable measurements</td>
<td>Option (with an object selected)</td>
<td>Alt (with an object selected)</td>
</tr>
<tr>
<td>Distance from Selected Layer</td>
<td>Hold ? and Hover over object/group/artboard</td>
<td>Hold Alt and Hover over object/group/artboard</td>
</tr>
<tr>
<td>Distance relative to Selected Group</td>
<td>Hold ?? and Hover over an object in the group</td>
<td>Hold Ctrl + Alt and Hover over an object in the group</td>
</tr>
</tbody>
</table>

### Keys for Design Specs

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcut on macOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td>? + Mousewheel</td>
<td>Ctrl + Mousewheel</td>
</tr>
<tr>
<td></td>
<td>?+, ?, ?-</td>
<td>Ctrl +, Ctrl -</td>
</tr>
<tr>
<td>Reset zoom</td>
<td>?0</td>
<td>Ctrl + 0</td>
</tr>
<tr>
<td>Pan</td>
<td>??, ?, ??, ??</td>
<td>??, ?, ??, ??</td>
</tr>
<tr>
<td></td>
<td>Spacebar + Click-drag</td>
<td>Spacebar + Click-and-drag</td>
</tr>
</tbody>
</table>
Introduction

Adobe XD is a vector-based tool for designing and prototyping user experiences for web and mobile apps. Switch easily from wireframing, visual design, interaction design, prototyping, preview and sharing, all in one powerful tool.

New Features
Learn more about the latest and greatest by visiting the list of new features and enhancements in this release.Link

Known issues
We maintain a list of known issues. Please note that this is a living document and may change between releases.

System requirements
For the latest system requirements, see the Adobe XD system requirements page.

Keys for Vector Editing

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcuts on MacOS</th>
<th>Keyboard Shortcuts on Win</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Editing Selected Vector Object</td>
<td>Return</td>
<td>Enter</td>
</tr>
<tr>
<td>Stop Editing Selected Vector Object</td>
<td>Esc</td>
<td>Esc</td>
</tr>
<tr>
<td>Switch Between Straight and Mirrored Control Points</td>
<td>Double-Click</td>
<td>Double-Click</td>
</tr>
<tr>
<td>Disconnect Control Point Handle</td>
<td>?Drag</td>
<td>Alt + drag</td>
</tr>
</tbody>
</table>

Keys for Prototyping

<table>
<thead>
<tr>
<th>Menu</th>
<th>Keyboard Shortcuts on MacOS</th>
<th>Keyboard Shortcuts on Win</th>
</tr>
</thead>
<tbody>
<tr>
<td>See all connections in prototype mode</td>
<td>?A</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Preview</td>
<td>?Return</td>
<td>Ctrl + Enter</td>
</tr>
<tr>
<td>Start or stop recording the preview</td>
<td>^?R</td>
<td>Not available</td>
</tr>
<tr>
<td>Stop recording</td>
<td>Esc</td>
<td>Not available</td>
</tr>
<tr>
<td>Share prototype online</td>
<td>??E</td>
<td>Ctrl + Shift + E</td>
</tr>
<tr>
<td>Navigate artboards in preview or shared prototype</td>
<td>Right or Left Arrow</td>
<td>? or ?</td>
</tr>
</tbody>
</table>
Online resources
Join the community and ask your questions in the Adobe XD Forum.
To find help on topics related to downloading, installing, and getting started with your software visit:
• Download and install Creative Cloud apps
• Use the Creative Cloud desktop app to manage your apps and services
For product help, inspiration, and support, visit the Adobe XD Help.Link

Customer support
For Adobe Customer Care visit http://www.adobe.com/go/customer_support, which provides assistance with product information, sales, registration, and other issues.
Outside of North America visit http://www.adobe.com/go/intlsupport/, click Choose Your Region at the bottom of the page, and click your country or region.

License agreement
You must accept the license agreement and warranty terms to use this product. Visit www.adobe.com/go/eulas for details.

Notice to users
Internet connection, Adobe ID and acceptance of license agreement may be required to activate and use this product. This product may integrate with or allow access to certain Adobe or third-party hosted online services. Adobe services are available only to users that are 13 years of age and older, and require agreement to additional terms of use and Adobe's online privacy policy (see http://www.adobe.com/aboutadobe/legal.html). Applications and Services may not be available in all countries or languages and may be subject to change or discontinuation without notice. Additional fees or membership charges may apply.

Copyright © 2016-2018 Adobe Incorporated and its licensors. All rights reserved.
Adobe, the Adobe logo and Experience Design are either registered or trademarks of Adobe Incorporated in the United States and/or other countries. All other trademarks are the property of their respective owners.

Adobe XD manual (PDF)
Find a PDF of articles to learn how to use Adobe XD.

Workspace basics
In Adobe XD, you create and manipulate your designs and prototypes using various elements, such as toolbars, and Property Inspector. These elements form the workspace of Adobe XD.
Home screen
The Home screen gives you quick access to artboard presets, add-ons, cloud documents, files shared with you, manage links, deleted files, and files stored in your computer. You can also access recently accessed XD files, what’s New in XD, learn & support articles, built-in tutorials, and an option to provide product feedback.

Add-ons
You can access plug-ins, UI Kits, and app integrations from the Add-ons tab on the left pane of the home screen.

Plug-ins extend the functionality of XD by automating complex and repetitive tasks, or integrating external services or applications within the native XD workflow. For more information, see Plugins for Adobe XD.

Graphic elements native to various platforms are available in the UI kits. For more information, see Access UI design kits.

App integrations such as JIRA provide a complete solution for designers and stakeholders.

Cloud documents
View the list of cloud documents that you have saved from within XD.

Shared with you
Lists the various cloud documents that other stakeholders have shared with you for review.

Manage links
Manage links directs you to assets.web.com. You can view and access the cloud documents from within the Cloud documents section in the Files menu. You can view the documents in a grid or list view and sort the documents by name or by date of modification or select the documents to delete them.
Deleted
Lists the cloud documents for delete. You can either restore the files tagged to be deleted or permanently delete them.

Your computer
You can use the computer file picker to access local XD files.

What's new
View a summary of all the latest features that XD offers.

Learn & support
Access the articles on getting started with XD, tutorials, and user guide.

Provide feedback
You can provide feedback regarding any existing bugs at XD support community or request any new features on the UserVoice portal.

Artboard presets
Get started with your design by directly clicking one of the preset artboard sizes on the home screen. You can also choose to create a custom artboard size. For more information on artboards, see Work with artboards and grids.

Recent
From the Recent section under the artboard presets, access your most recent XD files.

Begin tutorial
From the Begin Tutorial section next to the artboard presets, access built-in tutorials to learn what you can create with Adobe XD.

Workspace overview
Introduction

Adobe XD workspace on Mac
A Main menu  B Design mode  C Prototype mode  D Share mode  E Invite to document  F Preview on device  G Preview  H Property inspector  I Pasteboard  J Artboard  K Plugins  L Layers  M Assets  N Toolbar

**Main menu**  Includes File, Edit, Object, View, Window, and Help menus and the submenus within them.

**Design mode**  In Design mode, you can create and design the artboards that make up your project. You can choose to import assets created using other tools or from the web, or create graphics in XD.

**Prototype mode**  In Prototype mode, you can link artboards together, create video demos of the design (currently only on Mac), prototype your design in a browser or a device, and share the prototype with others and get feedback.

**Invite to document**  Using Invite to document, you can enable Coediting (BETA) and invite your fellow designers to simultaneously access and edit your XD document.

**Share mode**  In Share mode, you can create and share links for design reviews, development, presentations and user testing.

**Preview on device**  Connect multiple devices via USB to your desktop machine, set them up to transfer data, and view live device preview.

**Preview**  Test your prototype within Adobe XD using the desktop preview or the Adobe XD app on your iOS or Android device.

**Property Inspector**  Using the Property Inspector, you can define various properties of objects and manipulate them using different options. For example, you can specify backgrounds, fills, borders, shadows, alignments, and dimensions of objects. You can also combine objects together to make entirely new objects. To lay out repeating elements, use the Repeat Grid option in the Property Inspector. Use the Fixed Position option to fix the position of multiple elements on

Last updated 11/6/2019
scroll. You can also use the math calculation to create designs with greater precision or move objects to a new location or modify its width and height.

**Toolbar (Plugins, Layers, Assets, and tools)** Provides access to the selection tool, drawing tools, text tool, artboard tool, and to the Assets and Layers panel.

**Application toolbar** Provides access to Design mode, Prototype mode, zoom levels of the canvas, preview, and sharing options

**Work area** Contains the canvas or artboards with the assets that you create. The pasteboard (the gray space around the artboards) lets you place the work that is in progress and the work that you do not want to include within the existing artboards.

**Windows**
The XD interface on Windows 10 is similar to the Mac interface except for some minor differences:

- On Windows, there are no top-level and Object menus. Simply right-click an object and use the context menu instead.

- XD on Windows has a Hamburger menu on the upper-left corner that allows you to create or open files, save, and export assets.

![Adobe XD workspace on Windows](image)

A Design mode  B Prototype mode  C Zoom level  D Share online  E Property Inspector  F Pasteboard  G Artboards  H Toolbar  I Pop-up menu
Fixed issues

**XD 2019 (version 24.1.22)**
- [Mac and Windows] Autosave is unreliable when coediting.
- [Mac and Windows] During a coediting session, an object deselected by a collaborator appears as selected to the other collaborator.
- [Mac and Windows] Renaming a component in the Layers panel ends abruptly during live coediting.
- [Mac and Windows] Improved coediting handling and error messaging.
- [Mac and Windows] An error message saying 'Something Went Wrong' appears after initializing the machine from sleep mode and XD is minimized.
- [Mac and Windows] Interaction and text typed in a node are deleted in the prototype but the empty text node is still left on the canvas.
- [Windows only] XD crashes when you create a password for a design document in the Share mode.

**XD 2019 (version 22.7.12)**
- [Mac and Windows] Artboards are lost after an error on Save as.
- [Mac and Windows] Component shadows are not accurately rendering on preview mode and web playback. This is applicable on a scrollable artboard with the Fixed Position option set.
- [Mac and Windows] Import and Export windows does not open after an import error.
- [Mac only] The interaction wires on objects within a component are removed when the parent component is copy and pasted.

**XD 2019 (version 22.3.12)**
- [Windows only] Error when opening multiple cloud documents.
- [Windows only] Unable to create or save a new XD document.
- [Windows only] XD crashes after the welcome screen is blank for 30 seconds.

**Got an idea to make XD better?**
Tell us about it.
Access UI design kits

Adobe XD provides links to UI kits for Apple iOS, Google Material, Microsoft Windows, and wireframes. These UI kits contain graphic elements that are native to the operating system. For example, if you are designing an iOS app, you can directly get started with the readily available screens in the Apple iOS kit. XD also provides access to inspirational kits such as Designer Marketplace or Dashboard UI kits.

You can access the UI kits in any of the following ways:

- In the home screen, select Add-ons > Plugins.
- On Mac: Select File > Get UI Kits
- On Windows: Click the Hamburger menu, and click Get UI Kits.

Have feedback? We're all ears.
Report issues on the Adobe XD support community.

Curious about new features in XD?
Explore them from the New features summary.
Tips and tricks

Here are a few tricks to help you while using Adobe XD.

General tips and tricks

- Rather than copy and pasting groups of items in your design, consider using the Repeat Grid tool (available in the Property Inspector).
- You can duplicate a shape by selecting it, holding the Option key (on Mac), or Alt key (on Windows) and dragging a new copy of it.
- Elements can be locked with Object > Lock (or Cmd + L) on Mac. This actually toggles lock, so use the same command to unlock the elements. On Windows, right-click an object and select Lock from the context menu.
- Enable direct selection by holding the Cmd or Ctrl key. This allows you to select nested objects.
- Quickly mask by dropping an image onto a shape: the shape's fill becomes the image.
- Create an editable mask by importing an image, and then draw a shape over it. Select both and then choose Object > Mask with Shape (on Mac), or right-click the objects and choose Mask with Shape from the context menu. You can edit the mask or the image later by double-clicking on the masked group.

Drawing and Text

- You can turn the snap guides off by holding down the Cmd / Ctrl key.
- Double-click any anchor point to toggle between a curve and an angle.
- Press Opt/Alt while dragging a curve handle to make the curve handle independent. (To make them dependent again, double click to return to an angle, then double click again).
- You can select anchor points when you draw using the pen tool.
- Double click to enter a group's edit context (you can add elements in this context), or simply Cmd /Ctrl click an object inside a group to select it.
- Select a text item, then create a new one to apply all the styles from the first item to the second.
- Path combinations (Add/Subtract/Intersect/Exclude Overlap) are nondestructive. You can toggle them on and off.

Importing content

- To bring in content from Illustrator, select the vector shape in Illustrator, copy and then paste into Adobe XD.
- To bring in bitmap content from Photoshop, select all (Cmd+A or Ctrl + A) in a bitmap or text layer (or first convert a vector layer or group to a Smart Object), copy, and then paste it in Adobe XD. The pasted layer will be a bitmap. You can also copy content from Photoshop by making a selection using the marquee tool. Then, from the menus, choose Edit >Copy (to get the selection on the current layer), or Edit > Copy Merged (to get the selection on all the layers within your selection).
- To bring in content from Sketch, select one or more layers or groups, and click Make Exportable. Choose SVG as the format, and drag and drop the layer from Sketch into Adobe XD. This gives you editable vector content in Adobe XD.
- To import assets (PNG, JPG, TIFF, GIF, SVGs), on Mac, you can use File > Import, or drag and drop, or copy and paste images into Adobe XD from Finder. On Windows, click the Hamburger menu and click Import, or drag and drop, or copy and paste images from File Explorer. You can also copy and paste from the browser to Adobe XD.
Keyboard controls

- When adjusting corner radius you can hold down the OPTION key to restrict the adjustment to a single corner.
- To temporarily disable snapping when moving or resizing elements, hold down the Cmd or Ctrl key.
- Hold the SHIFT key while resizing an element to maintain the aspect ratio of the element.
- Hold ALT while drawing a shape to draw from center rather than the default (which is in the top left corner).
- To quickly change the opacity of a selected item, hit the following number keys. Here, 1 = 10%, 2 = 20%, and so on; 0 = 100%.
- When nudging a shape or control point using the arrow keys, hold down the SHIFT key to nudge by 10 px.
- Hold down the SPACEBAR to engage the hand mode. You can click and drag to span through the canvas.

Artboards

- To select a artboard, click the art board title, Cmd / Ctrl + Click on its background, or double click on its background.
- To select an empty artboard, click on the background of the artboard.
- To duplicate an artboard (and its contents), select the artboard, and press Cmd (on Mac) or Alt (on Windows) while dragging to make a copy.
- To rename an artboard, double click on its title.

Repeat Grid

- To adjust padding between repeating items in a Repeat Grid, select the repeat grid, then mouseover the space between elements, and drag. If you are editing an item within the repeat grid, you need to press ESCAPE to exit the editing mode.

Prototyping and Preview

- Select any object on an artboard (or the whole artboard) and drag a wire to trigger an interaction between artboards.
- Drag a wire off of a destination to unwire an interaction that you have set.
- Use the Dissolve transition when designing for web.
- You can see all the connections between your artboards (except those that are triggered directly from artboards) by pressing Cmd + A (on Mac) or Ctrl + A (on Windows) in the Prototype mode.
- The Preview window displays the artboard that has the current selection. If there is no selection, the Preview window opens with the Home artboard first.
- You can record a video from the Preview window of your interactive prototype. Click on the record icon on the title bar to begin a video.
- Clicking on the record button again OR press ESC to stop a video recording.
- You can use keyboard shortcuts or gamepad triggers on prototypes based on the type of experience you design.
Sharing

- In order to share, you must be logged in with an Adobe account to either the Adobe Creative Cloud desktop app or any other Adobe application (such as Photoshop, Illustrator, and so on). Adobe IDs, Enterprise IDs, and Federated IDs are all supported.
- If you share your design file without first adding interactions, all your artboards are uploaded and users will be able to navigate using the keyboard arrow keys. The order of your artboards will be from the top left and move to the right.
- If your design includes interactions, only those artboards connected to the Home artboard will be uploaded and shared.
- The artboard defined as your Home artboard is the first artboard users see when they view your shared design.
- You can change the Home artboard by selecting the Home artboard icon next to the artboard, in the prototype mode. This Home artboard icon shows up only for artboards which are selected (or the destination of a selected target).
- When viewing a prototype in a mobile web browser, you can save a shortcut to it on the device's home screen. This makes the prototype feel more like a native application when presenting it.
Chapter 2: Design

Design systems in XD

When designing digital products at scale, it becomes increasingly challenging and critical to remain consistent. Under the increased pressures of content velocity, organizations are searching for ways to move faster when designing and building customer experiences.

A design system provides consistent, robust, and reusable design patterns that unite multi-disciplinary product teams (designers, developers, and stakeholders) around a common visual language. It reduces design debt, accelerates the design process, and bridges teams bringing products to life.

With XD 19.0, creating and maintaining a design system is flexible, frictionless, and intuitive. You can use design systems to:

- Create cloud documents that contain Work with linked assets, and components (formerly known as symbols),
- Share them across teams for reuse in their own documents, and
- Manage updates from a central system so that everyone uses the latest assets.

Using design systems can be incredibly handy if you are sharing design system assets with your team, or reusing design elements from project to project.

To learn more about design systems, do check this video.
Collaborate and coedit designs

Adobe XD powers end-to-end collaboration at every step of the design process — from editing in real-time with other designers to working with developers and designers to gather feedback.

Combined with the power of Manage design revisions, you can coedit (Beta) your designs with your fellow designers to accelerate design cycles, eliminate duplicative work, and avoid conflicting versions.

Beta features are new features available for XD users to try and provide feedback on while we make these features ready for use. Beta features might have some quality and performance issues.

Invite to coedit

Collaborating with fellow designers has never been easier. You can enable Coediting (BETA) and invite your fellow designers to simultaneously access and edit your XD document.

Go ahead and save your design as a cloud document, click 👉 and select Enable coediting (Beta). Enter Adobe IDs (email addresses associated with Adobe account) of your fellow designers and click Invite.

Your fellow designers are then notified through their Creative Cloud desktop application or email.

Edit designs collaboratively

You can collaboratively edit a design document and view real-time changes that are saved as you work. When you coedit a document with your fellow designers, you can view these visual indicators.
Colored avatar

An avatar of fellow designers coediting your design.

Bounding box

A bounding box that matches the avatar color that appears on your design. Hover over the bounding box to view the names of your coeditors.

Real-time edits

Simultaneous edits in real-time as your coeditors navigate and modify your design.
Manage design revisions

Access your design revisions — Click 🔄 on the XD command bar.

Naming convention — By default, versions are named based on time and date stamps, and are autosaved at regular intervals. Since auto-saved versions expire after 30 days, use 📝 to name versions and permanently save them.

Benefits — View iterations of your collaborative designs and maintain a single source of truth.

Access previous versions — You can preview and access previous versions from Creative Cloud website. Read Browse, sync, and manage assets to learn more.

Limitations — You cannot rollback your previous versions; however, you can open a version of the document from document history, copy, and paste the content to your current version.

Few things to keep in mind

Remember these aspects when you coedit an XD document.
Minimize lag

Use a high-speed Internet connection to minimize lag in viewing and editing your documents. If you lose your connection, cloud documents sync your non-conflicting changes once you are online.

Revoke access

Remove the coeditor’s name from Invite to Document pop-up window.

Prevent overwriting

Avoid coediting the same object with a fellow designer to prevent overwriting. XD retains the edits that reach the server first and other changes are discarded.

Learn more

"Coediting lets you work right along side with your team and empowers you to work better. Together" — Dani Beaumont, Principal Product Manager, XD.

To learn more about coediting and document history, watch this video.

Viewing time: 1 minute.
Video

What's next?
We've got you started with coediting and managing your design revisions. Take a step forward and learn how to Share designs and prototypes with stakeholders such as users, developers, and fellow designers.

Have a question or an idea?
If you have a question to ask or an idea to share, come and participate in Adobe XD Community. We would love to hear from you and see your creations.

Work with components in XD
As a designer, you often create foundational elements, like navigation bars or buttons, that are repeated throughout your designs. However, these foundational elements have to be customized based on context or layout where they're placed. In such scenarios, you often end up creating multiple versions of the same foundational element, making it that much harder to maintain your design.

Components (previously known as symbols), are design elements with unmatched flexibility that help you create and maintain repeated elements while varying the instances for different contexts and layouts. For example, usage of buttons in varying contexts.

You can create a master component to define a reusable element, such as a button, and you can change any of its properties to customize instances of that element. Changes you make to an individual instance are specific to that element, but changes you make to the master propagates to all the instances where the property hasn't been customized.

Let's use these workflows to learn how to work with components.

Master components and instances
The first time you create a component in XD, it becomes a master component. You can manipulate a master component on canvas and edit it just as you would edit any other element. Master components are indicated by a green filled diamond in the upper left corner.
To create a master component, select an object or group of objects and use any of the following options:

- Right-click an object and select **Make Component** (CMD+K).
- Click the + button in the components section of the **Assets panel**.
- From the XD app, select **Object > Make Component**.
- Select an object and click the + icon in the **Component** section of the Property Inspector.

Components can have multiple states in Adobe XD, enabling you to develop dynamic, interactive content easily without having to use multiple objects in a design project.

After creating the component, you can go ahead and create multiple states for the component and wire them up to create interactions. For more information, see **Add multiple states to components**.

**Work with component instances**

Every copy of the master component you create is known as an instance. Component instances are indicated by a green hollow diamond in the upper left corner. When you create instances:

- They are an exact copy of the master component,
- Have the same properties as the original, and
- Are intrinsically linked to the master.

You can override properties of an instance without breaking its connection to the master component. Here’s how this works:

- When you make changes to the master component, same changes are applied to all instances.
- However, if you change a property in an instance, XD marks that property as an override. **Override properties** are unique changes that apply only to that instance and not the master component.

**Edit a master component**

You can use any of these options to edit a master component:

- Right-click an instance on canvas and select **Edit Master Component**.
- Click a component in the **Assets panel** and select **Edit Master Component**.
- Select an instance on canvas and select the edit pencil icon next to **Default State** in the Component section in the Property Inspector.

If you’ve deleted a master component from the canvas, XD generates a master component on the canvas next to the objects you’re currently editing.
Override properties
Master components provide the required consistency to maintain a design system. Any changes made to the master component automatically propagate to its instances.
Changes to the master component propagate to its instances

However, a design system is only as usable as the degree of flexibility it provides. You can start with the same original element, but you have to customize it depending on the context where it is used. That's where instances come in. When you edit any instance of a component, it does not affect the master component. Every property you change is considered an override.
Overridden properties are always preserved, even if you edit the same property from the master component.

Properties that have not been overridden in instances, like the corner radius in these buttons, always sync from the master.

If you’re not happy with the results of your overrides, you can always reset it back to the original master component by right-clicking an instance and selecting **Reset to Master Component**. This clears all overrides on an instance and resets it back to the master component.

**Style and appearance overrides**

Changing your original elements depending on context is extremely important when creating reusable elements. As a result, you can override every style and appearance property of an instance. The overrides allow for a range of variations while still keeping their ties to the foundational element.

**Note:**

Rotation and opacity properties currently do not propagate from the master component to instances.

**Resize and layout overrides**

XD 12.0 released a feature called **Responsive resize and constraints** that allowed you to resize groups of objects while keeping their placement and scalability. All you have to do is resize the group right there on the design canvas and XD retains the relative spacing in place. Inevitably, you end up having reusable elements that are similar, but variants of different sizes. Components are also resizeable, and come with the powerful capabilities of responsive resize baked right in.
Responsive resize of a master component

If you resize the master component, instances that are not resized are automatically resized. Therefore, instances that have already been resized, preserve their resized position as an override. You can also independently resize an instance without affecting the master component.

Not only can you resize an entire component, but you can also alter the layout of the items within. You can now change the component instances irrespective of the sizes you've adapted them to. Just like responsive resize, XD does its best to re-create the placement of your elements on a larger or smaller canvas as you resize them. You can also switch to manual mode to manually edit the constraints for more control.
Manually edit responsive constraints

Modified properties in an instance (for example, text size in Joshua Tree), preserve their overrides and not receive updates of that property from the master component.
Modified properties preserve their overrides

If you edit the layout of an instance, changes to properties that have not been overridden from the master component propagates to instances.

Changes from master component propagate to instances
**Wiring overrides**

When wiring components, it is helpful to understand the following principles:

- In Prototype mode, when you wire an interaction to a master component, the component instances are also automatically wired in the same way.
- If you edit the properties of an interaction on the Master component, all instances receive those updates as long as they are not overridden in an instance.
- You can delete or edit (override) interactions on an instance that were inherited from Master. For example, if the instance has a tap trigger that was inherited from the Master component, a user can modify the properties of that tap trigger like its action or destination etc. This means that the instance will no longer receive any future updates to that tap interaction from Master. This is called overriding an inherited interaction.
- Additionally, a user can also add more interactions to an instance. For more information, see [Wire up your screens](#).

**Add and remove elements as an override**

Not only can you override the size of a component or the layout of elements within, but you can also structurally override the components. This means you can add or subtract elements in the master component and its instances.

If you add an object to the master component, it is also added to its respective instances. When you add an object, XD applies the responsive resize algorithm and automatically places the constraints on the object. This depends on the position of the new object relative to its container. When an object is deleted from the master component, it is also removed in all instances.

Elements can also be added or removed from an instance and constraints are automatically placed on an object when it is added. When an element in an instance is deleted, only the element in that instance is removed. The same element continues to exist in the master component.

**Swap a nested component**

There are many cases where you have designed a larger component that has nested components within, like modals and nav bars that require customization based on the context. Swapping a component in XD is as simple as dragging a component from the **Assets panel** and placing it on top of the component on canvas you like to swap it with.
Swapping a master Component with an instance replaces the master in all instances.

Swapping a master component with an instance replaces the master in all instances.

Swapping an instance becomes a local override only to that instance. You can swap an entire component or a nested component at the global level for one another.

**Use components across documents**

Linked assets allow you to consume assets (components, colors, and character styles) from one or more design files available on XD cloud documents. Linked assets complement the workflow of linked components.

When a linked instance is used in a consuming document, you can use overrides (style and appearance, resize and layout, and structure) to customize the local instances in the consuming document.
If you modify and save the master component in the source document, a blue badge next to each linked component instance in the consuming document indicates that an update is available. You can hover over the blue badge to preview the updates within the Assets panel, and if visible, on the design canvas.

Click the blue badge to accept the updates to an individual component and click Update All at the bottom of the Assets panel to update all instances within the document. For more information on linked assets, see Work with linked assets.

**Feature limitations**

Get to know these feature limitations when working with components:

- You cannot move your master component from one document to another.
- Edit Master component and Reset to Master options are not available with multi-selection of components.
- Overrides are removed if you select Convert to Path option. If you continue to edit, overrides are removed on the object instances.
- Opacity and rotation are currently not supported as master properties if you edit from the master. Each instance has its own opacity and rotation.
Add multiple states to components

Components that change appearance based on user interactions are invaluable for creating high-fidelity prototypes. You can create a component, add multiple variations (states) to it, and wire it to mimic real-world user behavior (without having to copy your components multiple times).

Having components with states also makes it easier to manage your assets and to create interactive design systems.

Common examples of components with states are buttons, check boxes, and animated toggle buttons. These components need to change when users interact with them by tapping or hovering over them.

Add component states

Once you have Work with components in XD, the Property Inspector has a new section that lists the component with a Default State. You can now add two types of states for your components — New State and Hover State. Read on to know how to add a state.

New State

Use New State for scenarios where you want to show variations of a component such as a disabled or clicked version of a component.

Click the + button next to the master component’s Default State in the Property Inspector, and select New State. New State does not have any interactivity baked into the state. You have to wire the interaction in Prototype mode. For more information, see Add interactivity to components.

Hover State

Use Hover State if you want your component to change and display a different state when a user hovers over the component.

Click the + button next to the Master component’s Default State in the Property Inspector, and select Hover State.
When using **Hover State**, you don’t have to go to Prototype mode to wire the interaction. It’s automatically done for you.

![Adding states to a component](image)

You can add states only to a Master component. Component instances always inherit their states from the Master component.

**Visualize components in different states**

After you create the states for your component, you can edit the properties of your component and visualize how your component appears to the user who interacts with it.

1. Select the component.
2. Go to Property Inspector and toggle or switch between various states.
Switch states using the Property Inspector

Add interactivity to components

You can wire hover and tap interactions between component states in Prototype mode. Wiring component states interactions is similar to adding interactions between artboards. The main difference is when wiring component states interactions you choose a state as a destination instead of an artboard.

1. Select a component and switch to Prototype mode.

You can see all the states you created in the Component section in the Property Inspector.

2. Click the > icon on the component or the + in the Interaction section in the Property Inspector to add an interaction.

3. Select the state where you want to add the interaction.

4. Choose Tap (for click events) or Hover (for mouse over actions) as a trigger.

5. Pick an action type (such as Auto-Animate or Transition).

6. Pick a state as a destination.

7. Switch to the Preview window and test your component's interactivity.
Wiring up component states to create a tap interaction

States are listed above the artboards in the dropdown separated with a divider.

You can define multiple interactions for the same component state. For example, if you have a toggle switch that has both hover and tap states, you can define those interactions by repeating steps 4-7 twice to define the tap and hover states. After you create multiple interactions, you can see the Interaction section displaying the defined interactions. Toggle between those interactions and modify the interaction properties to fit your requirements.
Edit component states

When you define an interaction on a Master component state, all instances of that component automatically inherit those interactions. This means if you wire a component to a specific artboard or state, all instances of that component also contain those interactions.

When you have an instance selected on canvas and you want to edit existing states or add new states to the Master component, you can do so through one of the following options:

Option 1

Right-click the component instance and select Edit Master Component.
Option 2

Click Edit to switch the selection to the Master component to add or edit states.
Component instances are linked with the master component. Changes to a master component cascade to the instances. For more information, see Manage components with a single source.

**Rename and delete component states**

**Rename a component state:** Double-click the component state name in the Property Inspector and type in a new name.

**Delete a component state from a Master component:** Right-click the component state and select Delete. When you delete a component state from the Master component, component instances that have that state active on canvas switch back to the Default State.

- You can only rename and delete states in the Master component. You cannot rename the Default State.

**Manage components with a single source**

To simplify the management of component states, you can only add, rename and delete states from a Master component. Instances of that component automatically inherit any state changes made in the Master component. You can easily identify the Master component from the green filled diamond on canvas or from the Component section in the Property Inspector. Instances have a hollow green diamond.

**Inheritance of component states**

Follow these principles while editing states across Master components and instances:

- You can override properties (text, bitmap, size, appearance, or structure changes) for states just like you can override a component instance.
- When you edit the state in a Master component, that state updates across all instances.
When you edit the state in an instance, it is treated as a unique override and no longer syncs that property with changes from the master state.

If you are not happy with the results of your overrides, reset it back to the original Master component by right-clicking an instance and selecting **Reset to Master State**. This clears all overrides on an instance and resets it back to the Master component.

---

**Linked components states across documents**

You can create and maintain a single source for all your reusable components along with their states and defined interactions. For example, if you have a button component with 5 defined states: Primary, Secondary, Hover, Tap, and Disabled states, when you copy and paste that component across documents, XD creates a linked component that maintains all the defined component states along with the state interactions.

If you change your linked component properties (styling, interactions, and so on) in the source document, XD notifies documents with instances of that linked component with those updates. From there, you can preview the changes and choose to accept or ignore them.

Linked Components only support interactions defined between states and not artboards.

**Examples and sample files**

Want to create a toggle switch that turns on and off when a user taps on it?
Create an animated toggle button using our sample asset

1. Download the **toggle button** sample file and open it in XD.
2. Select the entire object (make sure the circle is selected) and press Cmd + K (macOS) or Ctrl + K (Win).
3. Add a new state and name it Disabled.
4. In the Disabled state, select the Rounded rectangle and change the fill to gray. Select the circle and move it to the left.
5. In Prototype mode, wire the following interactions:
   - **Default State**: Set the Trigger to Tap, Action to Auto-Animate, and Destination to Disabled.
   - **Disabled State**: Set the Trigger to Tap, Action to Auto-Animate, and Destination to Default State.
6. (Optional): If you want the toggle button to glow on hover, select the component, add a **Hover State**, and then edit the component to have a glow effect.

**Learn more**

Watch this video to learn more about how you can build interactivity using components with states.

**Viewing time**: 7 minutes.

[Video](#)

**Have a question or an idea?**

If you have a question to ask or an idea to share, come and participate in [Adobe XD Community](#). We would love to hear from you and see your creations.
Work with linked assets

With the ever-increasing design surfaces, designers need an easy way to create and maintain consistent designs at scale. With linked assets, you can easily share and consume not only components — or what was formerly known as symbols — but colors and character styles as well. This is incredibly handy if you are sharing sticker sheet with your team or reuse design elements across projects.

Linked Assets complement the workflow of linked components. When you modify a linked asset in the source document, all the consuming documents with those linked assets receive update notifications. From there, you can choose preview and accept the updates.

Here is a visual that depicts how to use linked assets in Adobe XD.

Use these workflows to learn how to work with linked assets:

- Create and share reusable assets
- Link assets from a source cloud document
- Filter and search linked assets within linked cloud documents
- Work with linked colors and linked character styles
- Work with linked components
- Remove a linked cloud document
- Relink missing cloud documents
Create and share reusable assets

The Assets panel provides a way for you to manage the colors, characters styles, and components used within your document. As part of a design system, you can now use the assets panel to curate the collection of reusable elements that you want to make available to other designers on your team.

To create one or multiple sources of truth for the reusable assets (colors, character styles, and components) across cloud documents, follow these steps:

1. In the source document, add the required colors, character styles, components to the Assets panel, and save as an XD cloud document.
2. Click Share > Invite to Edit. In the Invite tab, add email address of the invitees, optional message if any, and click Invite.

Link assets from a source cloud document

To use the colors, character styles and components that you have created in another source document or that has been shared with you, link your design project to those cloud documents. All colors, character styles, and components from the source document are added to your cloud document as linked assets.

As and when you update the source document, XD indicates that updates are available. You can then choose to accept the updates and thus ensure that everyone uses the latest assets.

To link assets from a source cloud document, follow these steps:

1. If you are creating a new project, click the Link Assets button in the Assets panel. If you are working off an existing document with populated assets, select + icon at the upper right of the Assets panel.
2. Browse for cloud documents that you have created or have been shared with you. When you select the required XD cloud document, all assets (colors, character styles, and components) from the source document are added as linked assets to the Assets panel. You can identify linked assets with ☰ icon.
Filter and search linked assets within linked cloud documents

Filter assets in the assets panel
When you link a cloud document to your design file, a filter for the linked source document is added in the Assets panel drop-down. Adobe XD has three filtering mechanisms to narrow down the assets that you would like to use in your project. You can filter assets in the Assets panel by asset type, locally created document assets, or linked assets from other source documents.

Filter by asset type
When you filter the Assets panel by asset type (colors, character styles, or components), you can see both the local and linked assets.

Filter by document assets
If you want to use only the local document assets, select the Document Assets filter in the Assets panel.

Filter by linked assets
If you have linked assets from multiple cloud documents and you want to use assets from a specific source, select the linked source document from the filter drop-down in the Assets panel.

Search assets in the assets panel
As your design system and brand kits grow in size with a large number of assets to manage, XD makes it easy for you to find your assets quickly using the search feature in the Assets panel. As you start typing the search term, XD will display the local and linked assets that match your search criteria.
You can search for colors by name or HEX code, while you could search for character styles and components by name.

**Work with linked colors and linked character styles**

Linked colors and linked character styles work similar to local colors and character styles with one exception, they could only be edited from the source linked document.

Use these workflows to work with linked colors or linked character styles in design files:

- **Edit linked components, colors and character styles in source document**
- **Apply linked color and linked character**
- **Highlight assets on canvas**
- **Edit linked components, colors and character styles in source document**
- **Preview linked component, color or linked character style updates**
- **Accept updates for a linked component, color or linked character style**
- **Delete linked assets in source document**

**Apply linked color and linked character**

You can apply linked colors to any object or component on canvas. To apply a linked color or character styles to selected objects or components on canvas, follow these steps:

- Click a linked color in the **Assets** panel or right-click the color and select **Apply as Fill**.
- To apply a linked color as stroke (border), right-click a color in the **Assets** panel, and select **Apply as Border**.

To apply a linked character style, select the text on the canvas and click the required linked character styles in the **Assets** panel.
Highlight assets on canvas
XD allows you to quickly find assets on the canvas. To find where all an asset has been placed on the canvas, select that asset in the Assets panel, right-click, and select Highlight on Canvas. Wherever the asset has been placed on the canvas, the asset is highlighted.

Edit linked components, colors and character styles in source document
You can edit linked components, colors and linked character styles in the source document and all the consuming documents with the linked assets are notified with the changes.

- Right-click the linked component, color or character style in the Assets panel and select Edit in Source Document. The asset is highlighted in the Assets panel (list view by default) of the source document.
- Edit the linked components, colors and character styles in the source document and all the consuming documents receive update notifications.
- Add or remove components, colors and character styles in the source document. This would in turn trigger an update notification to all documents linked to that source document.

Note:
To ensure that the naming convention of assets is consistent for all designers using linked assets, linked assets could only be renamed in the source cloud document. If you rename a linked asset in the source document, all consuming documents having that linked asset are notified with updates to reflect the new asset names.

To rename or edit the value of a linked component, color or linked character style in the source document in list view, do one of the following:

- Double-click the linked component, color or linked character style.
- Right-click the linked component, color or linked character style and select Rename.
**Preview linked component, color or linked character style updates**

When a linked component, color or linked character style is modified in the source document, the consuming document receives an update notification indicated by a blue badge icon in the **Assets** panel.

When you open the **Assets** panel, each updated linked asset has a blue update icon next to it to indicate an available update.

Hover over the blue update icon to preview the updated component, colors or character changes in the **Assets** panel and on canvas for any object or component that has those updated linked assets applied to:

- Preview the updates and view the last modified date and source document details before committing the changes.
- View the updated changes on both **Assets** panel thumbnails (list and grid views) and canvas in context of your designs.

**Accept updates for a linked component, color or linked character style**

Once you preview the linked assets changes, you can accept single or multiple updates for a linked component, color or linked character style.

To accept a single linked component, color or character style update, do the following:

- Click the blue update icon in the **Assets** panel.
- Right-click the asset and click **Update**.

To accept multiple updates, do one of the following:

- Click **Update All** to accept all linked component, color, character styles, and components updates. This includes addition of new colors, character styles, and components that are added to the source document.
- Multi-select linked components, colors, character styles, and right-click **Update**.
Delete linked assets in source document

When you delete linked assets (colors, character styles, or components) in the source document, the link badge turns red indicating that the linked assets have a broken link and are missing from the source document.

You can convert broken linked assets to local assets. Right-click the broken linked assets in the Assets panel and select Make Local Component, Make Local Color, or Make Local Character Style. All the objects that were previously linked to the broken linked component, color or character style are now linked to the updated local component, color or character style.
Design

Last updated 11/6/2019

Convert a broken linked color to a local color

Note:

You can delete linked assets only in the source document. This ensures that all the documents using linked assets from the source document are always synchronized with the changes.

Work with linked components

Components replace what has been symbols in the past and make the task of building out repeated design elements more streamlined and powerful.

Linked components allow you to create and maintain a single master kit for all their reusable components that you would like to use in your own projects or share with others. This ensures that your team is working from a single source of truth and their designs are always in sync. Similar to linked colors and character styles, when you modify a linked component in the source document, Adobe XD notifies documents with instances of that linked component with those updates. From there, you can preview the changes and choose to accept or ignore them.

For information on components, see Work with components in XD

Use these workflows to work with linked components in design files:

• Create linked components
• Override properties of linked components properties
• Edit linked component in source document
• Preview and accept linked component updates
• Convert a linked component to a local component
Create linked components
Use any of the following options to create linked components:

1. To use a set of components from your XD source document, copy the components from the saved source XD document and paste them in your own project. Hover the icon to view the pasted components on the canvas and icon in the Assets panel.

2. To access all the components in your source document along with the colors and character styles, use the linked assets workflow to bring in all the components from the source document as linked.

Override properties of linked components properties
When a linked component instance is used in a consuming document, you can override the style, appearance, and layout to customize the local instances in the consuming document. To learn more about components overrides, see Work with components in XD.

Edit linked component in source document
To edit the master component in the source document, right-click the component in the Assets panel or on the canvas and select Edit Master in Source Document. The source document opens and the master component is highlighted on the canvas.

If you change and save the master component in the source document, a blue update icon next to each component instance in document consuming documents appears in the Assets panel.

Note:
Use the shortcut CMD + 3 (Mac) and Ctrl + 3 (Win) to zoom into the master component.
Edit linked component in source document

**Preview and accept linked component updates**

Similar to linked colors and linked character styles, you can hover over the blue update icon for an updated linked component to preview the updates within the **Assets** panel, and if visible, on the design canvas.

Click the blue update icon to accept the update to an individual component and click **Update All** button at the bottom of the **Assets** panel to update all component instances within the document.

**Note:**

*If the component instances have overrides, the overridden properties are always preserved, even if you edit that same property from the master component. The properties that are not overridden are updated to reflect the changes in the master component.*
Convert a linked component to a local component
To experiment and change the properties for a linked component without impacting its instances in other documents, convert a linked component to a local component.

If you want to edit the appearance properties of linked component without impacting other documents with that same linked component, convert the linked component to a local symbol. You can edit or override the properties of a local component and updates made to a local component are confined to its own document.

To convert a linked component to a local component, right-click the linked component in the Assets panel and select Make Local Component.

Note:
If you convert a linked component to a local component, you no longer receive notifications to changes made to the component in the source document. Other XD documents with the linked component continue to receive updates.

Make Local Component only works if you copy/paste a linked component across documents or you have a broken linked component.

Remove a linked cloud document
To remove a linked cloud document from your XD document, hover on the linked cloud document in the Assets panel filter and click the button.

Once a linked cloud document is removed:
• Linked assets from the cloud document are removed from the Assets panel.
• Linked cloud document filter is removed from the Assets panel.
• All linked components on the canvas are converted to regular groups.

Relink missing cloud documents
When you delete an XD source cloud document, all consuming documents are notified of broken links. Click Relink from the context menu of the Assets panel.
If you select an XD cloud document that contains the same assets, XD relinks all the broken assets to the new document and the new relinked source document is added as a filter.

If the relinked XD Cloud Document does not have any or has some of the broken linked assets, only the available assets are linked, and the remaining assets continue to have a broken link.

![Relink missing cloud documents](image)

**Work with external assets**

You can bring assets into Adobe XD from other Adobe applications, such as, Photoshop, Illustrator, and from third-party applications such as Sketch. You can enhance these assets further in XD or use them to develop interactive prototypes.

You can bring in assets in multiple ways depending on the application you are using.

- **Work with Photoshop**
- **Bring in assets from Illustrator**
- **Bring in assets from Sketch**
- **Bring in assets from web browsers**
- **Export to After Effects**
- **Import other files**

If you want to convert Photoshop and Illustrator files into XD files, use the Open feature; if you want to add the content of those files into an existing XD file, use the Import feature.
Work with Photoshop

Multiple ways of bringing Photoshop assets into XD

Bring in assets from Photoshop
You can bring in Photoshop assets into XD in multiple ways:

- You can open a .psd file directly in XD. You can then edit the file in XD just like any other XD file, wire interactions, and share as prototypes or design specs. For more information, see Open Photoshop files in XD.
- You can import .psd file into XD.
- You can copy and paste bitmap and vector content from Photoshop and paste it in XD.
- You can drag Photoshop assets from the Libraries panel to the XD canvas. For more information, see Creative Cloud Libraries for Adobe XD.
- You can also copy a .psd file to the OS clipboard and use the Paste Appearance option to paste the image directly as an image fill.

Edit images in Photoshop
Follow these steps to edit JPG, PNG, GIF, or BMP images directly in Photoshop from XD and update them in real-time:

1. Double-click to select an image from a repeat grid or mask to access the layer where the image is placed.
2. Right-click the image and select Edit in Photoshop. If Photoshop is open in your system, the image opens as a new file with the same name as the image layer name in XD. If the application is not installed, this option is grayed out.
3  Edit and enhance your image in Photoshop and click File > Save. The image is automatically sent to XD as a flattened bitmap image.

You can revert or make further changes to the image in Photoshop as long as the application is open in the background.

Open Photoshop files in XD
You can directly open your Photoshop (.psd) files in XD, and convert them into XD files. After you open your files, you can edit them in XD, wire interactions, and share them as prototypes or design specs.

To open a Photoshop file in XD, do one of the following:

- Click File > Open. Navigate to the required folder, select a .psd file, and open it in XD.
- Drag the Photoshop file over the XD icon to open the file in XD (on Mac only).
- Right click the Photoshop file and select Open with > XD from the context menu.

You can also use the Cmd+O (Mac), or Ctrl+O (Windows) keyboard shortcuts. If you have opened a PSD file recently, you can also open it from the Recent Files list on the start screen.
Photoshop and XD have many different feature sets. XD brings in Photoshop elements and effects that can be mapped to XD's functionality. The rest of the elements are either rasterized or not transferrable yet to the XD file. To learn what elements are supported in this version, see Supported elements when you open Photoshop files in XD.

**Import Photoshop files to XD**

To import a Photoshop file to XD, on XD, select **File > Import**. If the imported Photoshop files have artboards, those artboards are placed below XD artboards. If there is a lack of space below the XD artboards, the imported artboards are placed in the available spaces. If the imported file does not have artboards, its assets are placed at the center of the canvas.

When a Photoshop file is imported to XD:

- Imported smart objects from Photoshop have high fidelity and are editable.
- Adjustment layers of a Photoshop image are not discarded.
- Files are placed within the open document rather than opening them as a separate document.
- Smart objects are imported as expanded layers instead of bitmaps, and adjustment layers are retained.
- Any links to Creative Cloud library assets from Photoshop are retained.

**Copy and paste bitmap content from Photoshop**

To bring in bitmap content from Photoshop, perform the following steps:

You can copy bitmap content from Photoshop by making a selection using the marquee tool. Then, select one of the following options:

- **Edit > Copy** to select the content on the current layer
- **Edit > Copy Merged** to select the content on all the layers within your selection.

Paste the copied content into XD.

1. Select all (**Cmd**+A or **Ctrl**+A) in a bitmap or a text layer (or, first convert a vector layer or group to a Smart Object).
2. Copy the content.
3. Paste the content in XD.
   
   The layer is pasted as a bitmap.

**Copy and paste SVG from Photoshop**

To copy and paste an SVG from Photoshop, right-click the shape or vector layer in Photoshop, click **Copy SVG**, and paste it in XD.

**Bring in assets from Illustrator**

You can open Illustrator files in XD, or import them.

You can also copy vector and bitmap images from Adobe Illustrator and paste them into XD retaining the same fidelity and editability when you open or import Illustrator files. Illustrator files are placed within the open document rather than opening them as a separate document. Smart objects are imported as expanded layers instead of bitmaps, and adjustment layers are retained. However, you cannot copy and paste an Illustrator artboard to XD.

You can also copy a vector file to the OS clipboard and use the **Paste Appearance** option to paste the image directly as an image fill.

Last updated 11/6/2019
You can also bring in Adobe Illustrator assets stored in Creative Cloud Libraries into XD by dragging them from the Libraries panel to the XD canvas. For more information, see Creative Cloud Libraries for Adobe XD.

**Copy and paste SVG into Illustrator from XD**

You can now copy XD vector content to the clipboard and then paste it as fully editable layers into Adobe Illustrator. To copy and paste any content from XD to Illustrator:

1. Right-click the shape or vector layer in XD and select Copy from the contextual menu.
2. From Adobe Illustrator, select Edit > Paste to paste the vector content.

**Open Illustrator files in XD**

You can directly open your Illustrator (.ai) files in XD and convert them to XD files. After you open your files, you can edit them in XD, wire interactions, and share them as prototypes or design specs.

To open an Illustrator file in XD, do the following:

- In XD, select File > Open. Navigate to the required folder, select an .ai file, and open in XD. You can also use the Cmd+O (Mac), or Ctrl+O (Windows) keyboard shortcuts.
- To open the file in XD (on Mac only), drag the Ai file over the XD icon.
- Right-click the Illustrator file and select Open with > XD from the submenu.

*When you open an Illustrator file in XD, not all elements are supported with complete fidelity. For a list of supported and unsupported elements, see Supported elements when you open Illustrator files in XD.

**Import Illustrator files**

To import an Illustrator file to XD, select File > Import. If the imported Illustrator file has artboards, those artboards are placed below XD artboards. If there is a lack of space below the XD artboards, the imported artboards are placed in the available spaces. If the imported file does not have artboards, its assets are placed at the center of the canvas. If the imported file does not have artboards, its assets are placed at the center of the canvas.
Bring in assets from Sketch

You can open a .sketch file directly in XD. You can then edit the file in XD just like any other XD file, wire interactions, and share as prototypes or design specs. For more information, see Open Sketch files in XD.

You can also copy assets from Sketch and paste it in XD. For more information, see Bring in selected assets from Sketch.

You can also copy and paste directly from Sketch into XD, maintaining its editability in XD.

You can also copy a Sketch file to the OS clipboard, and use the Paste Appearance option to paste the image directly as an image fill.

You can convert Sketch content to XD design systems. For more information, see Convert Sketch libraries to XD design systems.

Open Sketch files in XD

You can directly open your Sketch (.sketch) files in XD, and convert them to XD files. After you open your files, you can edit them in XD, wire interactions, and share them as prototypes or design specs.

You can only open Sketch files created using Sketch version 43 or newer versions. If you have an older file, save the file using the latest version of Sketch, and then open the file in XD.

To open a Sketch file in XD, do one of the following:

- Click File > Open. Navigate to the required folder, select a .sketch file, and open it in XD.
- Drag the Sketch file over the XD icon to open the file in XD (on Mac only).
- Right click the Sketch file and select Open with > XD from the context menu.

You can also use the **Cmd+O** (Mac), or **Ctrl+O** (Windows) keyboard shortcuts.
When you open a Sketch file in XD, not all the elements are supported with complete fidelity. For a list of supported and unsupported elements, see Supported elements when you open Sketch files in XD.

**Bring in selected assets from Sketch**

1. In Sketch, select one or more layers or groups, and click Make Exportable.
2. Choose SVG as the format, and drag the layer from Sketch into XD.
   
The content is inserted as an editable vector content in XD.

**Convert Sketch libraries to XD design systems**

You can now move your Sketch content into XD and continue working on your design systems. Not only are the Sketch symbols and elements converted to XD components, but you can also use them as linked assets.

1. Open the design system in XD.
2. From the Assets panel, click Link Assets. If there are existing assets in the Assets panel, click the plus icon (+).
3. In the Link Assets window, select Convert Sketch Library, and select a Sketch file from the file picker. XD converts the source Sketch document and automatically saves it as a cloud document and links the color, character styles and components to your XD document.
4. If you have multiple Sketch libraries that you have to work with, click the plus icon in the Assets panel and re-import another Sketch library.
5. Once the import and conversion is complete, click the All Assets menu and close the library.

**Sketch libraries and components**

Use these guidelines to work with components in XD:

1. Drag the converted components into the artboard.
2. To edit a source component, click a component instance, right-click and select Edit Master in Source Document.
3. To edit an asset, select the asset from the Assets panel.
4. Once the changes are applied, switch to your working document.
5. Click Update to accept the changes.

For more information, see Work with components in XD

**Learn more**

Watch this animated illustration to learn more about converting Sketch libraries to XD design systems.

Viewing time: 30 seconds.
Bring in assets from web browsers

You can drag images directly from all modern web browsers onto your artboards. You can also drag the images into an object on an artboard - when you do so, the image size is automatically adjusted to fit the object.

You can also copy an image to the OS clipboard, and use the Paste Appearance option to paste the image directly as an image fill.

Export to After Effects

Export to After Effects is supported only with After Effects 2018 and 2019 versions. If you have an older version installed, Export to After Effects option is disabled in XD. To enable this option, log into your Creative Cloud application and update After Effects to the latest version.

If you want to use After Effects to turn your XD designs into custom animations or micro-interactions, do the following:

- In XD, select the layer or artboard you want to animate in After Effects.
- Select File > Export > After Effects. If After Effects is not installed on your machine, this option is grayed out. You can also use the ??F (Mac), or Ctrl+Alt+F (Windows) keyboard shortcuts. After Effects launches (if closed) or moves to the foreground (if running in the background).
The selected layers or artboards are transferred as native shapes, texts that includes paragraph spacing, assets, inside and outside strokes and nested compositions in your After Effects project. You can perform multiple asset transfers to the same After Effects project and create animations in stages or from multiple XD files.

When you export XD content to After Effects, not all the elements are supported with complete fidelity. For a list of supported and unsupported elements, see Supported features when you export XD files to After Effects.

**Import other files**

To import assets saved as PNG, JPG, TIFF, GIF, or SVG files, perform one of the following actions:

- In XD, on Mac, click **File > Import**, and browse to select the file. On Windows, click the Hamburger menu, and select **Import**.
- Drag-and-drop, or copy and paste the image into XD from Finder or from Windows File Explorer.

**Edit objects using Boolean operations**

**Combine objects using Boolean operations**

You can combine simple shapes to create compound shapes and objects. Select the shapes that you want to combine and use one of the following options in the Property Inspector:

- **Add to Shape Area** Adds the area of the component to the underlying geometry.
- **Subtract from Shape Area** Cuts out the area of the component from the underlying geometry.
- **Intersect Shape Areas** Uses the area of the component to clip the underlying geometry as a mask would.
- **Exclude Overlapping Shape Areas** Uses the area of the component to invert the underlying geometry, turning filled regions into holes and vice versa.
Add, subtract, and intersect shape areas.
**Mask objects**

Masking helps in hiding or revealing parts of an image. Intelligent use of masks can help you draw focus on required parts of an image, or blur or sharpen an image or change opacity of layers. You can use masks to get circle icons from a square or rectangle image.

You can also use masks to hide portions of images, and vector objects. Consider a scenario where one vector object needs to be masked with another. In this case, the top object in the stack acts as a mask.

Want to learn how to use masks to hide portions of your object? For more information, see [Create a mask with shapes](#).

**Responsive resize and constraints**

**Responsive resize**

When designing for a multi-device landscape today, it's important to consider the wide variety of screen sizes available across mobile, tablet, and desktop resolutions. Since not all designers use similar devices, designers need to consider how content works across multiple screen sizes.

To solve this user problem, Adobe XD has developed a feature called responsive resize that allows you to resize objects while maintaining spatial relationships at different sizes to best adapt to multiple screen sizes.
**Work with responsive resize**

With Responsive Resize, XD automatically predicts which constraints you are likely to apply and automatically applies those constraints as objects are resized.

Traditionally, to achieve a responsive-like behavior, designers had to manually apply constraints to multiple objects to dictate the object behavior when resized. This monotonous and time-consuming method focused more on guesswork and repetitive motions overshadowing the creative spark of designing.

XD automatically applies constraints by analyzing the objects you have selected, their grouping structure and proximity to the edges of the parent group, and layout information.

![Responsive resize working with an asset being resized](image)

**Responsive resize crosshairs**

When resizing, pink crosshairs appear on the object being resized. These crosshairs indicate what constraint rules are applied to a group. XD provides a visual, in-context method of learning how responsive resize and manual constraints work in tandem.
Responsive resize and groups

Before resizing, you can group similar objects to establish relationships between them. XD retains the grouped objects together by default and allows you to establish a hierarchy in your projects through an organization mechanism you already use. When resized, grouped objects stay together.

Manually edit constraints

If you’re not happy with the results of responsive resize, you can edit the constraint rules manually. Placing manual constraints allows you to explicitly determine how objects behave when you resize a component, artboard, or group with layers within.

Select Manual to manually edit constraints that responsive resize has placed on objects. Manual constraints always override automatic constraints placed by XD. You can use the following constraints to specify the rules and control the behavior of the various components.

- Fixed/Variable width
- Fixed/Variable height
- Fixed/Variable left margin
• Fixed/Variable right margin
• Fixed/Variable top margin
• Fixed/Variable bottom margin

Setting up constraints on individual objects

Setting up constraints on a group of objects

**Responsively resizing artboards**

By default, responsive resize is turned off for artboards, but you can turn it on to initiate responsive resize on artboards.

To switch on responsive resize:

1. Select the artboard in design mode.

2. In the **Property Inspector**, select the toggle button to switch on responsive resize.

3. Select the following responsive resize options:
   • **Auto**: automatically uses constraints to resize the artboard.
   • **Manual**: lets you set manual constraints available in the **Property Inspector**.
Override responsive resize for groups

Though responsive resize is the default resize behavior for multi-selection and group resizing, you can:

- For a scaled resize, use the Shift key to temporarily override the responsive behavior. You can pull from one of the corner selection handles to lock the aspect ratio of your group as you resize.
- Switch off responsive resize option in the Property Inspector.

Create repeating elements

While designing for web or mobile apps, there is often a need to define repeating elements or content lists. However, it can be time consuming to create these elements or update when there are design changes.

The Repeat Grid feature changes a group of elements to a repeating element. You can simply pull the element in any direction and the grid repeats. When you modify any style of an element, the change is replicated in all the elements of the grid. For example, if you change the image size in one of the elements, all images in the grid are resized automatically.

If you have a text element in the grid, only the style of the text element is replicated and not the content. So, you can style text elements quickly while keeping the content different in the grid elements.

You can replace placeholder text in a repeat grid by dragging a text file onto the grid.

Create a repeat grid

At its core, a Repeat Grid is a special type of group. You can create a Repeat Grid by selecting an object or a group of objects and convert them to a Repeat Grid.

1. Design the base element that you want to repeat - for example, a combination of image thumbnails and text.
2. Select the elements you want to repeat.
3. Convert the selection to a Repeat Grid by clicking the button in the Property Inspector or by using the keyboard shortcut Cmd + R (Mac), or Ctrl + R (Windows).

Large handles appear on the boundary of the element.
Handles for repeating an element or a group of elements

4 To repeat the element in a vertical grid, drag the handle at the bottom of the element. To repeat the element in a horizontal grid, drag the handle at the right of the element.
To select elements in a grid to edit, double-click the grid.

To ungroup the grid elements and work on them separately, select the grid and click Ungroup Grid in the Property Inspector.

You can access the Repeat Grid’s component elements by double clicking inside the group.

After you make your changes, exit the edit context by pressing the Escape key.

**Note:**

You can also access the component elements by drilling down into the element in the Layer panel or by directly selecting it.

**Adjust the padding between two elements in a repeat grid**

To adjust the padding between two elements in the grid, hover over the gap between the elements. When the cursor changes to double arrows, drag to increase or decrease the padding.
Work with text in a repeat grid

You can use text in multiple ways in a Repeat Grid. You can either update each individual instance of a text object in a Repeat Grid, or you can choose to drag a pre-filled .txt document to a Repeat Grid and have the contents of the text file automatically populate the text objects in a Repeat Grid.

- Update individual text elements in a Repeat Grid
- Drag a return-separated text file to your text object in a Repeat Grid

Update individual text elements in a Repeat Grid

1. Cmd + Click (Mac) or Ctrl + Click (Windows) a text object in your Repeat Grid to select it.
2. To edit the text element, double-click it and change the text.

Note:
Changes to the content are not applied to other text objects in a Repeat Grid. However, any style applied to the text object applies to all text objects.

Drag a return-separated text file to your text object in a Repeat Grid

You can replace the placeholder text in a repeat grid by dragging a text file onto the grid.

1. Create a text file with the extension .txt. You can create this using Mac’s TextEdit or Windows’ Notepad (save as .txt), or any other text editor. Ensure the encoding is set to UTF-8. Separate each line of data with a return.
2. Drag the text file on to the repeat grid.
The repeat grid is populated in the same sequence of the text as in the text file. If there are more grids than the lines of text in the file, the sequence repeats.

**Work with images in a repeat grid**

With images, you can build repeated patterns of objects, where the image fill of an object is repeated in a pattern that you define.

You can choose to create an image fill pattern by dragging images one-by-one into an object, or select multiple images and then drag them to an object on the repeat grid.
Replace images in a repeat grid

To replace the images in the grid, open Finder or File Explorer, and navigate to the location where you have stored the images for your project. Select all the images that you want to appear in the grid, and drag-and-drop them onto the target object within the repeat grid.

The older images are replaced with the new images, which are resized automatically.

Create interactions from a repeat grid

You can wire a repeat grid to other artboards in Prototype mode in the following different ways:

- Wire the entire Repeat Grid for a single interaction
- Wire a single element of a Repeat Grid for an interaction
- Create a group of elements within the Repeat Grid and create an interaction from the group

Wire the entire Repeat Grid for a single interaction

1. In Design mode, create a second artboard in your file using the Artboard tool (A).
2. Switch to Prototype mode by clicking the Prototype tab or by using the Ctrl + Tab keyboard shortcut.
3. Select the Repeat Grid in your first artboard. A connector with an arrow appears on the right side of the object at its midpoint.
4. Drag the connector to the next artboard. Select your transition options in the pop-up, then press Escape or click outside the pop-up to dismiss it.
5 Preview by either pressing the Play button in the upper right corner of the application frame or by using the keyboard shortcut Cmd + Enter (Mac) or Ctrl + Enter (Windows). Click anywhere over the Repeat Grid to play the interaction.

**Wire a single element of a Repeat Grid for an interaction**

1 Select an object within the Repeat Grid.

2 Drag the connector on the right of the rectangle and drag it to the artboard you want to link. Select your transition options in the pop-up, then press Escape, or click outside the pop-up to dismiss it.

3 Preview by either pressing the Play button in the upper right corner of the application frame or by using the keyboard shortcut Cmd + Enter (on Mac) or Ctrl + Enter (on Windows). Click the object to verify the interaction.

**Create a group of elements within the Repeat Grid and create an interaction from the group**

You can also create a group of objects within your Repeat Grid, and then create interactions from that group.

1 Select an object in your Repeat Grid and then Shift-click other objects to add it to your selection.

2 After selecting the objects, right-click, and select Group from the context menu. You can also use the keyboard shortcut Cmd + G (Mac) or Ctrl + G (Windows) to group the objects.

3 Switch to Prototype mode. Drag the connector from the group to the artboard you want to link.

4 Preview by either pressing the Play button in the upper right corner of the application frame or by using the keyboard shortcut Cmd + Enter (on Mac) or Ctrl + Enter (on Windows). Click the group to verify the interaction.

**Work with artboards and grids**

Artboards typically represent each of the screens that you want to design as part of your mobile app or website.

You can have many artboards in a single Adobe XD file. For example, you can choose to define artboards for mobile, tablet and desktop-based web experiences within a single file. Alternatively, you can also choose to design multiple screens of a user flow for a single platform in a file.

You can choose a preset size for the artboard at the beginning of your project from the Start screen. If you do not want to use the available presets, you can create an artboard with a custom size. Once your new file with the chosen artboard size is created, you can add as many artboards as you like using the Artboard tool.
To view all the artboards in your project, open the Layers panel (click 🖼 in the toolbar).

Create artboards
While creating a project or a file for the first time, you can select the artboard size from one of the presets on the home screen. To specify a custom-size, select Custom and specify the size in pixels.

To add more artboards to an existing file, click the Artboard tool. Then, click one of the presets on the right panel and click the location where you want the artboard to be placed.

To define a custom sized artboard, select the artboard tool and draw the artboard you want directly on the pasteboard area.

Create scrollable artboards
When you create an XD design, sometimes an artboard is not long enough to fit your content. By making an artboard longer and choosing options based on your design needs, you can vertically scroll an artboard to accommodate different device sizes.

Vertical scrolling helps you simulate scroll effects when designing scrollable drop-down lists or websites, however, horizontal scrolling is not supported in XD. For more information, see Create scrollable artboards

Select artboards
To select an artboard, click the Selection tool and do one of the following actions:

- Click the artboard title, or
- Double-click the artboard’s background
Copy and resize artboards
On Mac, hold down the Option key and drag an artboard to copy. On Windows, hold down the Alt key and drag an artboard.

Alternatively, right-click the artboard name in the Layers panel, select Copy. Then, right-click again and select Paste. To resize an artboard, click the artboard and use the circular handles that appear on the edges.

Rearrange artboards
Click the artboard title and drag it to the new location.

Note:
You can drag the artboards in the Layers panel and change their order in the Artboards list. But, doing so only changes the stacking order of the artboards and does not change their position (X and Y coordinates).

Rename artboards
By default, the artboards are named based on the preset you select and are numbered sequentially. To specify a custom name for your artboards, double-click the artboard title and type the new name of the artboard.

You can also rename artboards in the Layers panel. Double-click or right-click the artboard title and select Rename.

Align and distribute artboards
Marquee-select multiple artboards and click the Align and Distribute options in the Property Inspector.

Copy and move elements between artboards
You can freely move any element on one artboard to another. Simply drag the element and drop it onto the desired artboard.

To copy an element, use Command + C (on Mac), or Ctrl + C (on Windows). Click the artboard in which you want to paste the element and click Command + V (on Mac), or Ctrl + V (on Windows).

You can also drag an element while holding the Option key (on Mac), or the Alt key (on Windows) to duplicate elements.

You can also use the Fixed Position to fix the position of elements such as headers and footers on a scrolling artboard, or floating fixed elements. The pin icon in the prototype mode indicates the fixed elements, and you can layer them above or below other design objects.
Note:

If you have a collection of objects that do not fit the artboard when you paste them, they all paste to the center of the target artboard.

You can use the gray area around the artboards as the pasteboard. You can place any element in the pasteboard and copy or move them to the artboards when required.

Note:

When you export all artboards, elements in the pasteboard that are not part of any artboard are not exported. If an element is placed partially on an artboard, then, only the portion of the element on the artboard is exported.

Cut, copy, move, resize, zoom, and delete multiple artboards simultaneously

Marquee-select multiple artboards to edit them simultaneously.

Use the Selection tool to drag a marquee around the artboards you want to select.

When selecting multiple artboards, make sure that you select the artboards completely. If an artboard is covered partially, the objects within the artboard are selected instead of the artboard itself.

A bounding box appears around the selected artboards.

**Resize**  Drag the handles on the bounding box to resize the selected artboards.

**Cut, copy, and paste**  Ctrl+Click (on Mac) or right-click (on Windows) to open the context menu that allows you to cut, copy, and paste all the selected artboards.

**Delete**  Press Delete on your keyboard, or use Ctrl + Click (on Mac) or right-click (on Windows) to open the menu to delete the selected artboards. Alternatively, you can select one or more artboards in the **Layers** panel, right-click, then choose **Delete**.

**Zoom**  Enter Zoom mode by clicking the Zoom icon in the toolbar or pressing Z on your keyboard. Once in Zoom mode, you can:

- **Zoom in**: Click anywhere in the XD canvas, or click the required artboard. Or, marquee-select an area to zoom in.
- **Zoom out**: Option + Click (on Mac), or Alt + Click (on Windows).
To quickly zoom in or out without actually entering Zoom mode, you can temporarily activate Zoom mode:

- **Zoom in:** Press Space + Cmd (on Mac), or Space + Ctrl (on Windows), then click or marquee select an area on the artboard.
- **Zoom out:** Press Space + Cmd + Opt

To zoom into specific objects on the artboard, select the objects, then select View > Zoom to Selection or ? 3 on Mac. On Windows, use the Ctrl + 3 keyboard shortcut.

**Work with Custom Artboard Guides**

**Custom artboard guides** help you position and layout objects on canvas with precision, by easily snapping them to guides across multiple artboards. You can create guides, tweak their position, copy-paste guides across multiple artboards, remove them, lock or hide their visibility.

![Custom artboard guides](image)

**Create Guide:** To create a vertical guide, hover over the left border of the artboard, where a double-sided arrow appears. Drag-and-drop the arrow icon toward the artboard to create a guide, and release it to place the guide on the artboard. To create a horizontal guide, drag-and-drop the arrow icon from the top border of the artboard. While creating the guide, the distance between the guides and artboard edges, or other guides as well as the absolute guide position on the canvas is displayed.

During creation, guides snap to selected objects or top-level objects drawn on the canvas. To temporarily disable the snapping behavior, press Cmd (on Mac) or Ctrl (on Win).

Press Shift key during guide creation to position the guide in 10px increments on the canvas.

**Copy-paste guides:** To copy guides from an artboard, select the artboard, click View option from the top menu bar. Click Guides option from the drop-down list and select Copy Guides. All the guides from the selected artboard are copied.
To paste the guides, select an artboard you want the guides to be pasted on. Click **Cmd+v** (on Mac) or **Ctrl+v** (on Win) to paste the guides. Alternatively, click **View** option from the top menu bar (on Mac), or right-click on the artboard (on Win), select **Guides** option from the drop-down list and click **Paste Guides**.

Duplicating an artboard also duplicates the guides created on that artboard.
Step - 1

Copy and paste guides

Step - 2

Copy and paste guides
Clear Guides: To delete a guide, click and drag the guide out of the artboard. To delete all the guides on an artboard, select the artboard and click View option from the top menu bar (on Mac), or right-click on the artboard (on Win). Click Guides option from the drop-down list and select Clear Guides.

Hide Guides: The Hide All Guides option turns off the visibility of the guides across all the artboards and disables guide creation. Select the artboard and click Cmd+; (on Mac), and Ctrl+; (on Win) to hide the guides. Alternatively, you can click View option from the top menu bar (on Mac), or right-click on the artboard (on Win), select Guides option from the drop-down list and click Hide All Guides.

Lock Guides: The Lock All Guides option lets you lock the guides across all the artboards. While the guides are locked, you can create guides and snap objects to guides, but you cannot change their position on the canvas. To lock the guides, press shift+Cmd+; (on Mac) and shift+Ctrl+; (on Win). Alternatively, you can click View option from the top menu bar (on Mac), or right-click on the artboard (on Win), select Guides option from the drop-down list and click Lock All Guides.

Position elements on artboards using grids
XD provides you two types of grid options: square grids and layout grids.

Square grids
Square grids provide guides to which you can align objects and text. When you draw, objects snap to the grid automatically when the object’s edges are within the grid’s snap-to-zone.

Square grids also help you get a quick idea of measurement while laying out objects or text on your artboards.

Layout grids
You can use layout grids to define columns in XD. A layout grid helps you to define the underlying structure of your design and how each component in it responds to different breakpoints (for responsive designs).

After the layout grid is applied to an artboard, you can snap elements to it. However, if the artboard is resized or grid is adjusted, the pinned items do not resize or reflow.
**Show or hide grids**
Select an artboard and do one of the following:

- On Mac: Choose View > Show Layout Grid or View > Show Square Grid.
- On Mac or Windows: On the Property Inspector, select a grid type from the Grid drop-down list, and select the check box next to it.
- Keyboard shortcuts:
  - Show Square Grid:
    - On Mac - ?'
    - On Windows - Ctrl + '
  - Show Layout Grid:
    - On Mac - ??'
    - On Windows - Ctrl + Tab

To hide the grid, deselect the Grid check box.

**Set square grid preferences**
The square grid options allow you to change the spacing of a grid and change its color. You can save a set of grid options as default to use them quickly in future. For more information, see Default square or layout grid preferences.

**Note:**
XD uses a virtual pixel for most of its measurements and font sizes, which is the same unit of measure as a CSS pixel, or measurements in iOS. The virtual pixel is roughly equal to one physical pixel on a 72-dpi monitor. You cannot change the unit of measurement in XD currently.

**Change grid size**
To change the size of the grid, edit the spacing value in the Property Inspector. The smaller the number, the denser the grid.

**Snap objects to a square grid**
To snap an object to a grid, drag an object towards a grid until one of the object’s edges is within the grid’s snap-to zone.

![Artboard 1](image)

*Snap to grid while drawing objects*

To avoid snapping to the grid, press the Cmd key (on Mac), or the Ctrl key (on Windows) while dragging the mouse and drawing an object.

**Set layout grid preferences**
When you enable a layout grid, XD intelligently displays columns that suit the nature of the artboard. So, for example, a phone artboard has fewer and narrower columns than the default layout grids for a tablet.

If you resize an artboard, the column widths in the layout grid change to fit the new artboard size. The objects on the artboard remain the same and do not maintain their relationship with the columns.
You can set your preferences for number of columns, width of columns, column color, gutter width, and margin sizes from the Property Inspector.

After you change the layout grid, you can make your changes the default, or you can revert to the default layout grid in XD. For more information, see Default square or layout grid preferences.

**Change column and gutter properties**

You can change the layout column properties according to your needs.

To set the number of columns in a layout grid, edit the Column value in the Property Inspector. When you change the number of columns, XD automatically recalculates the width of the columns.

The space between columns on an artboard is called the gutter width. Define the gutter width by editing the default Gutter Width value.

To change the width of the columns, edit the default Column Width value.
Design

Setting layout grids in XD

Change margins
You can change the size of the margins while setting your layout grid.

To adjust the left and right margins uniformly, click the Linked left/right margins icon and edit the value of the margin. To adjust the margins for all four sides individually, click the different margins for each side icon, and then edit the values for each margin.

Editing the size of the left and right margins uniformly

Editing the size of the margins individually

Change square or layout grid color
To change the color of a square or layout grid:

1. Click the box next to Square Size for square grids and Columns for layout grids. The color picker appears.
2 You can choose to:
   • Specify the HSBA or the hexadecimal values in the HSBA or hexadecimal fields if you know the exact values.
   • Adjust the color using the color field and color slider. When you do so, the numeric HSBA and hexadecimal values are adjusted accordingly.
   • Set the opacity of the fill by using the color slider or typing in a value in percentage. If you set the alpha to 0, the layout grid switches to outline view.
   • Use the eyedropper to select a color from an artboard.

Note:
Adobe XD also supports shorthand for hexadecimal codes. For example, if you type 0 and press Return, XD automatically displays the color with code #000000. Similarly, you can type 0A for #0A0A0A and 0AF for #00AAFF.

You can see that the grid color changes as you modify the options in the Colors dialog box.

3 Once you have decided on a color, save it for easier access by clicking the + icon at the bottom of the color picker.

Default square or layout grid preferences
Revert to the default square or layout grid appearance by clicking Use Default on the Grid section of the Property Inspector.

Set your customized grid preferences as default by clicking Make Default. This option sets the default grid option for your account. Any new files you open with XD has this new default.

Nudge and nudge resize
You can combine these keyboard shortcuts with the arrow keys to precisely control the position and size of the UI elements in grid size increments:
   • Shift + Arrows: moves the selection in 10px increments.
   • Cmd + Arrows: resizes selection in 1px increments (element is pinned in upper-left corner).
   • Cmd + Shift + Arrows (Mac) and Alt + Shift + Arrows (Win): resizes selection in 10px increments (element is pinned in upper-left corner).

When the square grid is enabled:
   • Shift + Arrows: moves the selection to snap to the grid first and then increases the grid size.
   • Cmd + Shift + Arrows (Mac) and Alt + Shift + Arrows (Win): resizes the selection to snap to the grid and then resizes the selection in grid size increments (element is pinned in upper-left corner).
Work with drawing and text tools

Drawing tools
You can quickly draw simple icons and graphics in Adobe XD using the drawing tools on the left toolbar - the rectangle, ellipse, line, and pen tools. The selection tool helps you select specific line, shapes, or objects to edit them.

You can then combine these shapes in different ways to create compound shapes and objects, or mask portions of the shape. For more information on combining and masking techniques, see Edit objects using Boolean operations.

Draw rectangles and squares
1 Select the Rectangle tool.
2 Perform one of the following actions:
   • To draw a rectangle, drag diagonally until the rectangle is the desired size.
   • To draw a square, hold down the Shift key while you drag diagonally until the square is the desired size.
3 To draw a rounded rectangle, draw a rectangle, and then click it to see the radius editing handles. Click any handle and drag toward the center of the rectangle. You can also use the Property Inspector to enter a specific value for the radius of one or more corners.
4 To further customize your square or rectangle, you can edit the corner radii.
   • To adjust the radius of a single corner only, do one of the following:
     • Hold the **Option** key (Mac) or the **Alt** key (Win), click the handle of the corner, and drag your mouse.
     • Edit each corner radius value individually after selecting ⌘ in the **Property Inspector**.
   • To adjust the radius of all the corners simultaneously, do one of the following:
     • Click a corner radius and drag your mouse.
     • Edit the value of the radius after selecting ⌘ in the **Property Inspector**.

**Adjusting all four corners simultaneously**

**Adjusting the corners one by one**

**Draw ellipses and circles**

1 Select the Ellipse tool ⌅.

2 Perform one of the following actions:
   • Drag diagonally until the ellipse is the desired size.
   • To create a circle, hold down the **Shift** key while dragging.
Hold Shift and drag to resize circle.

**Draw lines**

1. Select the Line tool.
2. Position the pointer where you want the line to begin, and drag to where you want the line to end.
**Draw with the Pen tool**

The simplest path you can draw with the Pen tool is a straight line, made by clicking the Pen tool to create two anchor points. By continuing to click, you create a path made of straight-line segments connected by corner points.

1. Select the Pen tool.
2. Position the Pen tool where you want the straight segment to begin, and click to define the first anchor point.
3. Click again where you want the segment to end (**Shift**-click to constrain the angle of the segment to a multiple of 45°).
4. Continue clicking to set anchor points for more straight segments.

**Note:**

To convert an anchor point from straight to curved and the opposite way, double-click the anchor point.
The last anchor point you add always appears as a solid circle, indicating that it is selected. Previously defined anchor points become hollow, and deselected, as you add more anchor points.

5 Complete the path by doing one of the following:
   • To leave the path open, click Esc.
   • To close the path, position the Pen tool over the first (hollow) anchor point. Click or drag to close the path.
   • To select and drag the start point without closing the path, hold down the Cmd/Ctrl key.

---

**Draw straight lines using the pen tool.**

**Draw curves**

You create a curve by adding an anchor point where a curve changes direction, and dragging the direction lines that shape the curve. The length and slope of the direction lines determine the shape of the curve.

Curves are easier to edit and your system can display and print them faster if you draw them using as few anchor points as possible. Using too many points can also introduce unwanted bumps in a curve. Instead, draw widely spaced anchor points, and practice shaping curves by adjusting the length and angles of the direction lines.

1 Select the Pen tool.

2 Position the Pen tool where you want the curve to begin, and hold down the mouse button.

3 Drag to set the slope of the curve segment you’re creating, and then release the mouse button.

   
   *Hold down the Shift key while dragging to constrain the tool to multiples of 15°.*

4 Position the Pen tool where you want the curve segment to end, and do one of the following:
   • To create a C-shaped curve, drag in a direction opposite to the previous direction line. Then release the mouse button.
   • To create an S-shaped curve, drag in the same direction as the previous direction line. Then release the mouse button.
**Draw curves using the Pen tool**

5 To create a series of smooth curves, continue dragging the Pen tool from different locations.

💡 You can also drag direction lines to break out the direction lines of an anchor point.

6 Complete the path by doing one of the following:
   - To close the path, position the Pen tool over the first (hollow) anchor point. Click or drag to close the path.
   - To leave the path open, press Esc.

**Draw straight lines followed by curves**

1 Using the Pen tool ( ), click corner points in two locations to create a straight segment.

2 Position the Pen tool over the selected endpoint. To set the slope of the curved segment you create next, click the anchor point, and drag the direction line that appears.

3 Position the pen where you want the next anchor point; then click (and drag, if desired) the new anchor point to complete the curve.

**Draw curves followed by straight lines**

1 Using the Pen tool ( ), drag to create the first smooth point of the curved segment, and release the mouse button.

2 Reposition the Pen tool where you want the curved segment to end, drag to complete the curve, and release the mouse button.

3 Position the Pen tool over the selected endpoint.

4 Reposition the Pen tool where you want the straight segment to end, and click to complete the straight segment.
Draw curves followed by straight lines

**Draw two curved segments connected by a corner**

1. Using the Pen tool ( ), drag to create the first smooth point of a curved segment.
2. To create a curve with a second smooth point, reposition the Pen tool and drag.
3. Reposition the Pen tool where you want the second curved segment to end, and drag a new smooth point to complete the second curved segment.

**Drawing versus editing mode**

To toggle between drawing mode and edit mode, press the Esc key.

You can also enter the 'path edit mode' by double-clicking the shape or path. In this mode, anchor points of the shape are visible, but moving the mouse does not draw anything. You can manipulate existing anchor/control points or insert new anchor points on existing segments on path.

When drawing with the pen tool, you can perform all the edits described above in addition to drawing new segments.
Extend existing paths
When you select the pen tool, all paths on the artboard under the mouse display handles over their start and end point. To continue drawing the path from that point, click one of the handles.

Extending a closed path reopens the path and then puts the pen tool in drawing mode for that path.

Select anchor points
Double-click the drawing to view the anchor points. You can then click an anchor point to select it. To select multiple anchor points, hold Shift and select the anchor points, or marquee select the anchor points using the Selection tool.

Nudge the selected anchor points using your keyboard, drag them using mouse, or edit their properties (x and y-coordinates) in the Property Inspector.

Disable anchor point snapping
While placing a new anchor point or dragging an existing anchor point, snap lines appear when an anchor is vertically or horizontally near another anchor point. Hold down the Cmd/Ctrl key to disable anchor point snapping.

Add and edit anchor points
Double-click the drawing to select it and view the existing anchor points. Click the path to add new anchor points at the cursor location.
Adding and editing anchor points

Delete anchor points
Select the anchor points and then press Delete.

Draw Polygons
The Polygon tool helps you create a range of new shapes, from triangles to rhombus, pentagons or any polygons with up to 100 sides.
To start drawing a polygon, click “Y” on the keyboard, or select the triangle icon from the Toolbar.

On the artboard or canvas, click and drag to draw the shape of the desired size. You’ll notice that the default shape is a triangle.

- Hold down Shift key while drawing to create an equilateral shape.
- Use the up and down keyboard arrows while drawing to increase or decrease the number of polygon sides.

After creating the shape, you can change the number of polygon sides from the Property Inspector. Select the shape, click the Side Count field in the Property Inspector and type in the desired number of sides.

To change the Corner Radius of the polygon, click and drag the radius decoration handle from the upper corner of the shape, or click the Corner Radius field in the Property Inspector, and enter the desired value.

Note:
Every shape has one radius decoration handle. You cannot change the corner radius of each side of the shape.

Set the shape properties (Fill Color, Border Thickness and Color, Shadow and Background Blur) for the polygon. These properties are preserved when you change the number of sides of the shape.
Double-click on a polygon to view all the anchor points of the shape. You can create new anchor points by clicking anywhere on the path of the shape.

*Note:*

*Creating or editing the anchor points of a shape will turn it into a path, and it loses its polygon abilities.*

### Drawing shortcuts

<table>
<thead>
<tr>
<th>Drawing tool</th>
<th>Keyboard shortcut on MacOS</th>
<th>Keyboard shortcut on Windows</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>V</td>
<td>V</td>
</tr>
<tr>
<td>Rectangle</td>
<td>R</td>
<td>R</td>
</tr>
<tr>
<td>Ellipse</td>
<td>E</td>
<td>E</td>
</tr>
<tr>
<td>Polygon</td>
<td>Y</td>
<td>Y</td>
</tr>
<tr>
<td>Line</td>
<td>L</td>
<td>L</td>
</tr>
<tr>
<td>Pen</td>
<td>P</td>
<td>P</td>
</tr>
<tr>
<td>Zoom</td>
<td>Enter zoom in mode: Z</td>
<td>Enter zoom in mode: Z</td>
</tr>
<tr>
<td></td>
<td>• Zoom in: Click anywhere in the Adobe XD canvas, or click the required artboard. Or, marquee-select an area to zoom in.</td>
<td>• Zoom in: Click anywhere in the Adobe XD canvas, or click the required artboard. Or, marquee-select an area to zoom in.</td>
</tr>
<tr>
<td></td>
<td>• Zoom out: Option+Click</td>
<td>• Zoom out: Alt+Click</td>
</tr>
<tr>
<td></td>
<td>To temporarily activate zoom in and zoom out:</td>
<td>To temporarily activate zoom in:</td>
</tr>
<tr>
<td></td>
<td>• Press Space+Cmd, then click or marquee select an area on the artboard to zoom in.</td>
<td>• Press Space+Ctrl, then click or marquee select an area on the artboard to zoom in.</td>
</tr>
<tr>
<td></td>
<td>• Space+Cmd+Opt to zoom out</td>
<td></td>
</tr>
<tr>
<td>Zoom to Selection</td>
<td>?3</td>
<td>Ctrl + 3</td>
</tr>
</tbody>
</table>

### Measure distances

Measure distances between an object and the artboard, or an object and other surrounding objects by clicking the object and pressing the **Option** key on Mac, or the **Alt** key on Windows.

*Note:*

*If the selected object is not a square or a rectangle, then XD draws a bounding box around the object. It then displays the measurements from the boundaries of the bounding box.*

**To measure an object’s distance from the edges of the artboard:**

Simply click the object and press the **Option** key (on Mac), or **Alt** key (on Windows).

Adobe XD measures the distances and displays the measurements for as long as you press the **Option** or **Alt** key.
To measure an object’s distance from other objects in the artboard:
Click the object, press the **Option** (on Mac) or **Alt** (on Windows) key, and hover the mouse over other objects.
Adobe XD measures the distances between the closest boundaries of both the objects and displays the measurements as long as you press the **Option** or **Alt** key.

**Text tools**

**Enter text at a point**
Click the text tool and click at the location where you want the text to begin. Type the text and press **Esc** to commit your text changes, or **Return** to go to the next line.
When you type text by selecting a point on your canvas, you get a horizontal line of text that begins where you click and expands as you enter characters. Each line of text is independent—the line expands or shrinks as you edit it, but doesn't wrap to the next line. Entering text this way is useful for adding a few words to your artwork.

You can type text over other objects and arrange the text to appear in the front using the Object > Arrange options.

**Enter text in an area**
Click the Text tool, click at the location you want the text on the canvas and drag to define the text area. Then, click inside the area to begin typing text.

When you define a text area, the boundaries of an object control the flow of characters, either horizontally or vertically. When the text reaches a boundary, it automatically wraps to fit inside the defined area. Entering text this way is useful when you want to create one or more paragraphs, such as for a brochure.
Click the Text tool and start typing text.

**Spell check**

From the **Edit** menu, select **Turn Spellcheck On**. The spell check feature works only on the incorrect text in the text container. Misspelled words are underlined in red and auto-corrected words are underlined in blue. Grammatical errors are highlighted with a green underline.
Turn on spelling and grammar option

Right-click the misspelled word and select the contextually accurate spelling from the suggested list.

Select correctly spelled word

To revert the auto-corrected spellings to the word you initially entered, press **Cmd + Z** on Mac OS and **Ctrl + Z** on Windows OS.

Undo auto-correct
Switch between point and area text
You can switch between point and area text with one click.
Select a text object and toggle between the Point text and Area text options in the Property Inspector.

Import text from text files
You can easily include pre-written text to your artboard using one of the following methods:

• Drag a text file on to the artboard.
You can easily include pre-written text in your design by simply dragging a plain text file to your artboard. This action creates an area text on the artboard with the contents of the text file.

• Drag a text file on to a repeating grid.
You can also drag a text file (with new lines) on to and drag that file over a text component on a repeating grid. All of the text elements are populated with the text from that file.
For more information, see Drag a return-separated text file to your text object in a Repeat Grid.

• Copy and paste text on to the artboard.
You can also copy and paste text on to the artboard, creating an area text element that you can easily move and edit in Adobe XD.

Resize the text area
Click the text and drag the handle to change the size of the typeface. This feature is available only for point text.
Format text
Click the text and then specify the type, font size, and text alignment for the text using the **Property Inspector**.
You can also select individual words or characters in a block of text and format those sections alone.

You can adjust the text properties of an entire text object.

You can adjust the text properties of a selection of text within a **text object**.

Format the entire text object or individual sections of text

**Change character, line, and para spacing**
To change character spacing, click the text object and specify the character spacing using the **Character Spacing** option in the **Property Inspector**.
To change the character spacing in a subset of text, select the text and modify the character spacing in milli-ems using the **Property Inspector**.

Drag the handle to resize text.
Design

Changing the character and line spacing for text in a text object

To change the line spacing, click the text area, and then specify the line spacing using the Line Spacing option in the Property Inspector.

To reset the line height to the default, enter 0 in the Line Spacing option in the Property Inspector.

Similar to Photoshop and InDesign, Adobe XD allows you to change the space before and after paragraphs within the same text element.

To change the paragraph spacing, select a paragraph and click the paragraph icon in the Formatting panel. Change the spacing value as per requirement.

Text transformations

To apply any of the text transformations, select the text that you want to change. From the Property Inspector, select any of the following options:

• Uppercase icon (TT) to set the text to uppercase.
• Lowercase icon (tt) to set the text to lowercase.
• Titlecase icon (Tt) to set the text to title case.
• Text superscript icon to set the text to superscript.
• Text subscript icon to set the text to subscript.

Underline text

To underline text, click the text area, and then click the Underline icon in the Property Inspector. XD draws a smooth underline that breaks around the descenders in text (creating a more aesthetic line).
**Text strikethrough**
To strikethrough text, select the text area, from the Property Inspector, click the Strikethrough icon. A smooth line is drawn right in the center of the text, making it appear like it has been struck over.

**Global style changes**
To make global style changes easily, apply text transformation or strikethrough to Character Styles.

In the Assets Panel, save a style that you use across the document as a character style. Then, right-click on the character style and select Edit option from the drop-down menu. Choose one of the uppercase, lowercase, title case or strikethrough options and the text using that character style will change across the document.

**Create precision designs with math calculations**
Use the math calculation to create designs with greater precision or move objects to a new location or modify the width and height.

Select one or more objects. In the Property Inspector, perform simple math in any box that accepts numeric values. Adobe XD supports +, -,-/, * math operations to calculate the changes.

For example, if you want to move selected object 3 units to the right using the current measurement units, enter +3 after the current value.

In the Property Inspector text box that accepts numerical values, do one of the following:

- To replace the entire current value with a mathematical expression, select the entire current value.
- To use the current value as part of a mathematical expression, click before or after the current value.

**Note:**
Adobe XD can only perform one operation at a time. That is, it can handle “4in+2p”, but it cannot handle “4in+2p-1p” because they are construed as two different operations.

**Move, align, distribute, and arrange objects**

**Move objects**
You can move objects in the following ways:

- Dragging objects with your mouse,
- Using the arrow keys on the keyboard, or
- Entering precise math operation values (+, -,-/, *) in the Property Inspector

Use the Shift key to constrain the movement of one or more objects, so that they move in a precise horizontal or vertical direction relative to the current orientation of the x and y-axes.

You can also use the Align panel to position objects in relation to each other.
**Move an object by dragging**
Select one or more objects, and drag to the new location.

**Move an object using the arrow keys**
1. Select one or more objects.
2. Press the arrow key for the direction in which you want to move the object.

**Move an object using X and Y coordinates**
Select one or more objects. In the Property Inspector, enter new values for the X and/or Y coordinates. You can also click in X and Y values and use the arrow keys to increase or decrease the value.

**Move an object using math calculations**
Select one or more objects. In the Property Inspector, perform simple math in any box that accepts numeric values. For example, if you want to move a selected object 3 units to the right using the current measurement units, enter +3 after the current value.

Supported math operations to calculate the changes include +, -, /, *.

In a text box that accepts numerical values, do one of the following:
- To replace the entire current value with a mathematical expression, select the entire current value.
- To use the current value as part of a mathematical expression, click before or after the current value.

💡

*Hold down the Shift key while using arrow keys to bump up the value by 10px.*

**Align and distribute objects**
You can use the Align panel to align or space selected objects horizontally or vertically to the selection, or the artboard.

**Align or distribute objects relative to each other**
Select the objects to be aligned, and click one of the following options in the Property Inspector:
- Align top
- Align middle
- Align bottom
- Align left
- Align center
- Align right
- Distribute objects horizontally or vertically
Align objects vertically

**Align an object or group relative to the artboard**
Select the object or group to be aligned, and click one of the following options in the Property Inspector:

- Align top
- Align middle
- Align bottom
- Align left
- Align center
- Align right

**Align objects to a pixel grid**
You can align the edge of an object with the pixel grid. In order to do so, XD rounds off the integer values for the X,Y,W,H properties of an element to ensure they look sharp and crisp.
To align an object to pixel grid, right-click the object and select **Align to Pixel Grid**.

Aligning to pixel grid does not always mean the X/Y/W/H properties will not have fractions. For lines and paths (center-stroked shapes), sometimes the X/Y need to end in 0.5 to keep the stroke crisply aligned on-pixel.

Adobe XD supports artboard grids which are different from pixel preview. Adobe XD does not support pixel preview. The default artboard grid in Adobe XD is an 8-pixel grid. You can change the grid settings to create a 1 pixel grid. For more information, see [Position elements on artboards using grids](#).

**Arrange objects**

Adobe XD stacks successively drawn objects, beginning with the first object drawn.

You can also select, order, and move objects in different layers using the Layer panel. For more information, see [Work with layers](#).

**On Mac:**

To move an object to the top or bottom position in its group, select the object you want to move and choose one of the options as appropriate:

- **Object > Arrange > Bring To Front** - To bring the object at the top of all objects
- **Object > Arrange > Bring Forward** - To move the object at the top of the immediate object above it
- **Object > Arrange > Send Backward** - To move the object below the immediate object behind it
- **Object > Arrange > Send To Back** - To move the object at the bottom of all objects

You can also Ctrl+Click an object, and select any of the Arrange options in the context menu.

**On Windows:**

Right-click an object, and select any of the Arrange options that appear in the context menu.
Bring selected image to the top of the stack

Bring selected image forward

Send selected image backward
Create a mask with shapes

Use masks to clip portions of images or objects and create outcomes that focus on specific elements in your designs.

Some of the scenarios where you can use masking is creating a profile avatar or simulating a dark mode experience as shown below.
Profile avatar in a mobile application

Animated masks to simulate a dark mode experience

Want to learn how to create, edit, or remove a mask effect? Follow these steps:

1. Draw a shape that you want to use as the mask and place it on the portion of the image you want to retain. Select the image and the shape.
2  Select **Object > Mask with Shape** (MacOS) or right-click the selected content and choose **Mask with Shape** (Windows). The portion of the image or drawing that is outside the shape is masked.

3  To edit the content within the mask shape, double-click the masked content. The masked area is not deleted from your project. You can readjust the mask to highlight another portion of the image.

4  To disable or remove a mask, select the object and right-click (Windows) or Ctrl + Click (Mac), and select **Ungroup Mask** from the context menu.

**Limitations**

- When you mask one vector object with another, the object on top of the stack acts as a mask.
- You cannot mask text on shapes, components, groups, or symbols.
- XD does not support alpha masks or masks with opacity. [Here is an interesting discussion](#) that you can be part of and [upvote](#) this feature in UserVoice.

**Examples and sample files**

- **Profile avatar within a custom shape**

  Did you know that when you are starting a design with placeholder graphics, like a circle in place of a profile picture, you can create masks by dropping assets into the shapes?

  To learn more about dragging an asset into a shape or using an existing shape as a mask, check the tutorial below or download the [sample files](#) to try them out yourself.

  Viewing time: 1 minute.

  [Video](#)

- **Animated number counter using masking**

  Number counter animations are used to display numbers in an interesting and eye-catching way. Want to learn how to use masking to create a running scoreboard? Check out this video and [download the sample files](#) to try them yourself.

  Viewing time: 1 minute 2 seconds.
Video
You can also check out XD support community for examples and tutorials.

Tutorials
Use masks to place an image into a custom shape and crop out parts of an image that you do not want to be visible. Check out this tutorial on how to work with images and masking in XD.
Viewing time: 1 minute.
Video

**Group, lock, duplicate, copy, and flip objects**

**Group objects**
You can combine several objects into a group so that the objects are treated as a single unit. You can then move or transform a group of objects without affecting their attributes or relative positions. For example, you can group the objects in a logo design so that you can move and scale the logo as one unit. You can ungroup the group to get back the editing control on individual components again.

You can also edit fill and stroke properties for all objects within a group at a group level.

Groups can also be nested. They can be grouped within other objects or groups to form larger groups.

1 Select the objects to be grouped or the group to be ungrouped.
2 On Mac, choose either **Object > Group** or **Object > Ungroup** from the main menu, or select **Group** or **Ungroup** from the context menu.
   
   On Windows, select the objects to be grouped or ungrouped, right-click, and select **Group** or **Ungroup** from the context menu.

You can also group objects using the Layers panel. For more information on layers, see [Work with layers](#).

**Select objects in a group or across multiple groups**
Normally, you can select an object by simply clicking it. When the object is part of a group, the whole group is selected when you click the object.

To select an object in a group, double-click or Cmd + click / Ctrl + Click the object in the group.

To select objects across multiple groups, use Cmd/Ctrl+Shift+Click to add objects to the selection independent of which groups they’re part of. Once selected, you can easily change common attributes in the Properties Inspector and group, lock, toggle visibility and so on.
Group objects

Lock and unlock objects

Locking objects prevents you from selecting and editing them.

- On Mac, select the object and click **Object > Lock**. Or, right-click the object and select **Lock** from the context menu.
- On Windows, right-click the object and select **Lock** from the context menu.

When you lock an object, a lock icon appears when you select it.

To unlock objects, select them and click the lock icon, or click **Object > Unlock**.

**Note:**

You can also use the lock/unlock options in the **Layers** panel.
Lock objects

**Duplicate objects**
Select one or more objects. Option-drag (Mac) or Alt-drag (Windows) the selection (but not a handle on the bounding box). On Mac, you can also click **Edit > Duplicate** to duplicate an object.

**Copy and paste objects**
You can select an object or group of objects, copy them (Ctrl + C or Cmd + C), and paste them (Ctrl + V or Cmd + V) onto multiple artboards. When you paste them, XD intelligently places them in the same X and Y location where the original object was located. This feature is especially useful while copying headers or footers across multiple artboards.

*Note:*
*If the artboard is selected but is not within the viewport, then XD does not paste on that artboard.*

You can also copy an object’s style, and paste that style onto other objects or text elements in your project. Copy the object, right-click (on Windows) or Ctrl-click (on Mac) another object, and select **Paste Appearance**. The object formatting alone is copied and pasted.

**Flip objects**
Use the flip option to flip objects or elements for faster and more precise designing on a canvas. You can also toggle between vertical and horizontal flip and view the flipped objects on all surfaces such as preview, mobile, and web.

Exceptions when working with flip:
- Flip is not supported on artboard, repeat grid, and components. However, you can select all the content within an artboard and flip them.
- When it comes to images, you can flip either the mask surrounding the image, or the fill image itself, or both depending on the selection state.
- Location of the flipped object does not change.
- Flip takes the center point of the object or group and flips across the axis.
- Flip does not impact shadows.
- If an object is rotated, the object flips across the visual axis, not the original object’s axis.
If multiple objects are selected, objects flip as a group.

**Apply artwork flip**

1. Select the element to be flipped in the artboard.
2. Select **Vertical** or **Horizontal** flip from the Property Inspector. Clicking the flip icon a second time reverts the elements to its original state. The icons are dimmed if the object you have selected cannot be flipped. Often this has to do with which element on the canvas you have selected.

---

**Flip objects**

---

**Select, resize, and rotate objects**

**Select objects**

- Before you modify an object, distinguish it from the objects around it. You do so by selecting the object. Once you’ve selected an object, or a part of an object, you can edit it as required.
- Click the **Selection** tool and when the cursor changes to a pointer, click the object or an object group. To select multiple objects, draw a marquee around the objects using the **Selection** tool, or **Shift-click** the objects.
- To select layers in a group, double-click or **Cmd+Click** (MAC) or **Ctrl+Click** (WIN) on the objects. Repeat the keyboard shortcuts to select the layer beneath the selected object in Z-order. When you reach the base object, use the shortcut to navigate to the top-most object and thus resetting the selection cycle.
- To select an object without a fill, click its border.

**Resize objects**

Select the object or the object group, and drag the circular handles. In object groups, you see the circular handles around the bounding box of the group. Drag these handles to resize the object or the object group.
Resize objects

To lock the aspect ratio of objects while resizing, click the lock icon in the Property Inspector. When you do so, the ratio between the width and height of the object is retained on resizing an object.

![Lock aspect ratio in the Property Inspector](image)

Rotate objects

Select the object or the object group.

Hover over the circular handles and move the cursor slightly to the outside of the handle to see the rotation cursor (icon).

When you see the rotation cursor, drag the handle in the desired direction to rotate.

**Note:**

In object groups, you see the circular handles around the bounding box of the group.
You can use the Shift key to rotate objects in multiples of 45°.

**Set stroke, fill, and drop shadow for objects**

**Apply a fill color to an object**
1. Select the object.
2. Click the rectangle next to **Fill**. The Color Picker appears.
The color picker

Note:

You can also use the Eyedropper tool to fill colors. The [i] key activates the Fill Eyedropper.

- Clicking the key once would open the Fill Eyedropper.
- Clicking the key again would close the Fill Eyedropper.

You can choose to:

- Specify the HSBA, RGB, or hexadecimal values if you know the exact color values. You can also switch between the different color modes.
- Adjust the color using the color field and color slider. When you do so, the numeric HSBA, RGB, and hexadecimal values are adjusted accordingly.
- You can set the fill and the opacity of the fill by using the color slider or specifying a value in percentage.
- Use the Eyedropper tool to select a color from an artboard.
- You can also apply gradient fills to objects. For more information on gradients, see Create and modify gradients.

As you modify the options in the color picker, you can preview the changes on the artboard.

Note:

Adobe XD also supports shorthand for hexadecimal codes. For example, if you type 0 and press Return, XD automatically displays the color with code #000000.

You can save a color as a swatch for future use. To save a color as a swatch, click the + icon at the bottom of the Color Picker.
You can rearrange swatches in the color picker by dragging a swatch to the new location. To delete a swatch, drag it outside the color picker.

**Apply image fill to objects**
First, turn on the fill if it’s not already on (as described in Apply a fill color to an object). Then, drag the image onto the object from the location where you have saved it (for example, Finder or Windows Explorer).

**Crop and place image fills**
You can now double-click images placed within containers (Object > mask with Shape) to crop and reposition the images (when dragged from the desktop) within the image fills. Use the Crop mode in an image fill to:

- Double click and enter a crop mode for an image fill
- Reposition the image within the crop mode, or
- Move the image anywhere in the crop mode

This enhancement is also applicable for files imported from Photoshop and Sketch. The imported files retain the image fills and the crop performed in the source application.

**Image paste from clipboard**
You can also copy an image outside of Adobe XD into your operating system clipboard, select a shape, and paste the image as an image fill from your operating system clipboard. Images will also fill a shape if a shape is selected and a user selects File > Import.

**Create strokes and specify stroke color**
1. Select the object.
2. The default stroke width is 1. To specify a different value, change the **Border** value.
3. Click the rectangular color chip next to **Border**. The Color picker appears.
4 You can choose to:
   • Specify the HSBA, RGB, or hexadecimal values if you know the exact values.
   • Adjust the color using the color field and color slider. When you do so, the numeric HSBA, RGB, and hexadecimal values are adjusted accordingly.
   • Use the Eyedropper tool to select a color from an artboard.
   • Set the opacity of the border using the color slider or typing in a value in percentage.
   • Edit the border size and create dotted lines
   • Specify end caps (Butt, Round, Projecting) and joins (Miter, Round, Bevel), and inner and outer strokes.
As you modify the options in the color picker, you can preview the stroke color on the object.

5 You can save a color as a swatch for future use. To save a color as a swatch, click the + icon at the bottom of the Color Picker.

Add swatches
You can rearrange swatches in the color picker by dragging a swatch to a new location. To delete a swatch, drag it off the color picker.

6 If the object is a closed path, you can specify the stroke width. To align the stroke along the path, choose one of the following options listed in the next illustration.
   By default, XD aligns the inner stroke in a closed path.
Stroke styles
A Inner stroke  B Outer stroke  C Center stroke  D Butt cap  E Round cap  F Projecting cap  G Miter join  H Round join  I Bevel join

Note:
Changing the stroke width or stroke alignment does not change the actual size of the object (in terms of the bounding box). However, when you export the object, chances are there for the dimensions of the object to change depending on the type of stroke used.

SVG only supports center strokes. If you export an object with inner or outer strokes as SVG, the size of the exported image appears as if it had a center stroke.

Create a drop shadow
1 Select the object.
2 To choose a color for the shadow, click Shadow in the Property Inspector. The Color Picker appears.
   You can choose to:
   • Specify the HSBA, RGB, or hexadecimal values if you know the exact values. You can also switch easily between the different color modes.
   • Adjust the color using the color field and color slider. When you do so, the numeric HSBA, RGB, and hexadecimal values are adjusted accordingly.
   • Use the Eyedropper tool to select a color from an artboard.
   • Set the opacity of the shadow using the color slider or typing in a value in percentage.
3 Specify the following options:
   X offset and Y offset  Specify the distance you want the drop shadow to be offset from the object.
   B (Blur) Specify the distance from the edge of the shadow where you want any blurring to occur.

Specifies the distance from the edge of the shadow where you want any blurring to occur. Illustrator creates a transparent raster object to simulate the blur.

To save a swatch, click the + icon at the bottom of the color picker. You can rearrange swatches in the color picker by dragging a swatch to a new location. To delete a swatch, drag it off the color picker.
**Apply blend effects**
Select an image or object (including shapes, text layers, groups, masks, or components) on the design canvas. From the Property Inspector, select and apply the blend mode of your choice. For more information, see Apply blend effects.

**Remove a fill, shadow, or stroke from an object**
Select the object. Then, click the check box next to Border, Fill, or Shadow in the Property Inspector. If you want the fill, stroke, or shadow back, click the check box again.

**Work with blur effects in XD**

**How do you add background blur?**
You can add background blur to objects, or images on an artboard to emphasize, or de-emphasize parts of the object in the following ways:

- Create a blur mask to blur anything visible underneath
- Add background blur effect to selected objects to blur the entire object

When you add background blur to objects, the changes are non-destructive, and you can recover the original object or image that was blurred.

**How do you blur specific areas of an artboard?**
1. Draw a shape over the portion of the image, object, or area that you want to blur.
2. Select Background Blur in the Property Inspector.
3. Adjust the following sliders to control the background blur:
   - **Amount**: Controls the extent of the blur
   - **Brightness**: Controls the brightness of the blur mask
   - **Opacity**: Controls the opacity of the blur mask
Adding background blur to a portion of an image

4 To show or hide the blur, select or deselect the check box next to **Background Blur**.

To remove the blur, simply select the object (blur mask) and delete it.

**How do you add background blur to a selected object?**

1 Select the object or image to which you want to add background blur.
2 Select **Object Blur** in the Property Inspector.
3 Adjust the slider to control the extent of the blur.

4 To show or hide the blur, select or deselect the check box next to **Object Blur**.
**Manage assets and components**

To centrally manage assets such as colors, gradients, and character styles of the objects that you use in your project, you can add them to the **Assets** panel.

The **Asset** panel also automatically displays any components that you create in XD. For more on components, see **Components**.

To open the **Assets** panel, click ☀️ in the toolbar, or press **Cmd + Shift + Y** (on Mac) or **Ctrl + Shift + Y** (on Windows).

**Add and remove assets**

**To add colors and gradients (linear or radial) to the Assets panel:** Select an object or a group of objects on the artboard, and click the + icon next to **Colors** in the **Assets** panel. For more, see **Add and use colors as assets**.

**To add character styles to the Assets panel:** Select a text or a text box on the artboard, and click the + icon next to **Character Styles** in the **Assets** panel. For more, see **Add and use character styles as assets**.

**To delete an asset from the Assets panel:** Select the asset in the **Assets** panel, right click (on Windows) or **Ctrl** click (on Mac) and select **Delete** from the context menu.

You can also select an artboard or a group of artboards and click the + icon to add all the colors and character styles from the artboards to the **Assets** panel.

**Note:**

Colors, gradients, character styles, and components added to the **Assets panel** remain there even if you delete the asset itself from the artboard, allowing you to reuse the asset whenever you need it next.
Add and use colors as assets

1. Select the relevant object on the canvas and apply the color you need from the Property Inspector.
2. To add the color as an asset, select the above object and click the + icon next to Colors in the Assets panel.
3. To apply the color to an object, select the object on the canvas and follow one of the steps below:
   • To apply a color fill, either click the color in the Assets panel, or right-click the color and select Apply as Fill.
   • To apply a color stroke (border), right-click a color in the Assets panel, and select Apply as Border.
4. Edit the colors centrally by right-clicking them in the Assets panel and see them being applied across the document.

Add and use character styles as assets

1. Select the text on the canvas and apply the styles from the Property Inspector.
2. To add styles as assets, select the styled text and click the + icon next to Character Styles in the Assets panel. If you select a text with multiple styles, click the + icon to create multiple character styles.
3. To apply character styles to a text, select the text on the canvas and click the character styles in the Assets panel.
4. Select and right-click the character styles to edit them and view them being applied across the document.

Label assets

You can add custom labels to the assets that you add to the Assets panel. In the Assets panel, switch to list view and click the label to rename it. For example, you can customize the name of a color from the HEX value to tile background color.
When you rename a component, the change applies to all instances of the component in the *Layers* panel for better identification.

XD also allows you to add emoticons to the labels.

![Label assets](image)

**Reorder assets in the Assets panel**

You can reorder the assets in the *Assets* panel. You can move frequently used assets to the top of the list or arrange them as groups.
Reorder assets in the Assets panel

1. In the Assets panel, drag the assets across the panel.

2. If you want to move multiple assets across the panel at the same time, press and hold Ctrl (Win) or Cmd (Mac) and select those assets.

Resolve missing fonts

When your XD document contains fonts that are missing from your machine, XD lists them within the Missing Fonts section of the Assets Panel, allows you to highlight them on canvas, and assess their use in the designs, and replace them throughout your design. For missing fonts that are available in the Adobe Fonts library, XD automatically activates them to deliver a seamless user experience.

Working with Adobe fonts

To make your Adobe fonts experience as simple as possible, XD automatically activates the missing fonts available in Adobe Fonts Library on your machine without intervention.

As long as you are online, opening a document that has missing fonts which are available in Adobe Fonts (to which you have access to via your Creative Cloud Subscription), XD automatically activates them on your machine.

Fonts that are activated from Adobe Fonts are highlighted with a blue activation icon and as soon they are ready to use they will be made available in your document, with no intervention from your end.

For more information on working with fonts, see Using fonts from Adobe Fonts in Creative Cloud apps.

Note:

If you load multiple documents with different fonts, ensure that you have deactivated fonts that you no longer use from the Creative Cloud Fonts library.
Auto-activate Adobe fonts
A Missing fonts  B Activating fonts

**Identify and replace missing fonts**

If you have any missing fonts in your document, an exclamation mark appears adjacent to the missing font in the Assets panel. To replace the missing font:

1. Right-click the missing font and select **Replace Font** to choose a replacement font. XD automatically previews the suggested replacement font on canvas. You can also alternatively use the **Highlight on Canvas** option to highlight the missing font in your designs before replacing them.

2. Select **Ok** to replace the font on canvas as well in the defined character styles.
Identify, highlight, and replace missing fonts

A Highlight on Canvas  B Missing font indicator  C pop-up when you right-click on missing font

Replace font dialog
Components

A component is an object or group of objects that can be reused multiple times across artboards in your project. All instances of a component used in your project are linked. That is, any update made to one instance is instantly reflected in all other instances. For more information, see Work with components.

To convert an object into a component, perform one of the following actions:

- Right-click the object and select Make Component.
- Select the object and press **Cmd** + **K** (on Mac), or **Ctrl** + **K** (on Windows).
- On a Mac, select the object and then select Object > Make Component.
- Select the object and click + in the Components library within the Assets panel.

All the components that you create in your project are automatically displayed in the Components library within the Assets panel.

Component library. Click ‘+’ to make a selected object a component and add to library.

Edit and delete components

To make changes to a component’s shadow and background blur, you need to double-click the component on the artboard, unlike for regular objects. When you double-click a component on the artboard, it is displayed with a thicker border. If your component is a group of objects, when you double-click it, you can edit every object in the group.

To delete a component from the Components library, right-click the component and select Remove Component.

Reuse components

To reuse a component, drag it from the Components library onto the artboard. Alternatively, copy and paste a component within an artboard, or from one artboard to another. All linked instances of a component are indicated with a green border. You can also copy and paste components from one XD document to another.

Replace components

You can replace all instances of a component with another component. Drag a component from the Assets panel on to another component. When you drag it on top, the icon changes into an arrow indicating that the component and all its instances are replaced.
Swapping a master component with an instance replaces the master in all instances.

**Link**

Swapping an instance becomes a local override only to that instance. You can swap an entire component or a nested component at the global level for one another.

**Linked assets**

With linked assets, you can consume assets (components, colors, and character styles) from one or multiple design files available on the XD cloud documents. Linked assets complement the workflow of linked components. When you modify a linked asset in the source document, XD notifies instances of that linked asset with all the updates. From there, you can preview and accept the updates.

**How to add linked assets to the Assets panel?**

To add linked assets to the **Assets** panel, do one of the following:

- click the + icon next to **Assets** panel in case of populated assets panel

Or

- click the **Link Assets** badge in case of empty assets panel.
Link Assets window opens with two tabs; Cloud Documents and Shared with You. You can sort documents in Cloud Documents, and Shared with You tabs by Name, Date Modified, Date Created, and Size. Select to add any XD cloud document into your design project.

If you have set a filter in the Asset panel, switch to All Assets view to view the newly added assets from the cloud document in the asset browser. Do note that colors, character styles, and components are automatically imported from the linked document.

For information on how to use linked assets, see Work with linked assets.

**Linked components**

With linked components, you can share components across documents and maintain a single source of truth for UI kits, style guides, and sticker sheets. When you update a linked component in the source document and save the changes, XD notifies you about this update in the destination document.

**Search and filter assets and components**

**Filter assets based on asset type**

By default, all the assets added to the Assets panel are displayed in it. You can filter assets by asset type by clicking the drop-down arrow against the Search field in the Assets panel. In the drop-down, you can choose the asset type as either Color, Character Style, or Components.
You can search for colors, character styles, and components in the Assets panel. To search for colors, type the hex code or custom label of the color that you want. Similarly, to search for character styles and components, type the string that matches with the asset name. Based on your search string, XD displays the relevant results in the Assets panel.

XD remembers the last five search queries for each session. These queries appear in the search history.

**Find assets and components on canvas**

XD allows you to quickly find assets on the canvas. To find where all an asset has been placed on the canvas, select that asset in the Assets panel, right-click, and select Highlight on Canvas. Wherever the asset has been placed on the canvas, the asset is highlighted.

When a component is not used anywhere in the project, XD displays the message: "0 copies of this component is used."

**Highlight assets in Asset panel for objects selected on canvas**

XD also allows you to highlight the assets in the Asset panel used for an object that you select on the canvas. When you select an object on the canvas, you can quickly find the color, character style, or the component that is used for that object.
To highlight the assets in the Assets panel used for an object, select the object on the artboard, right-click it, and select one of the following options:

- **Reveal Color**: Highlights the color that has been used, in the Assets panel.
- **Reveal Character Style**: Highlights the character style that has been used in the element.
- **Reveal Component**: Matches the component that is already added to the panel.

**XD** highlights the assets that are used for the selected object.

Create and modify gradients

A gradient is a graduated blend between two or more colors or tints of the same color or different colors. You can use gradients to create color blends, add volume to vector objects, and add a light and shadow effect to your designs.

**XD** supports linear and radial gradients.

**Linear gradient**  XD shades from the starting point to the ending point in a straight line.

**Radial gradient**  XD shades from the starting point to the ending point in a circular pattern.

**The Gradient color picker**

To access the Gradient color picker in XD, select an object, and click Fill in the Property Inspector. You can create linear or radial gradients in XD.

Choose **Linear Gradient** or **Radial Gradient** from the drop-down list at the top of the color picker.
You can use the Gradient color picker to choose the colors and set the opacity for gradients.

The Gradient color picker has a gradient editor that shows a quick preview of all the colors used in a gradient. Checkerboards indicate the transparent parts.

The gradient editor also displays the color stops in a gradient. Small circles indicate the color stops. The colors change and mix depending on how close the color stops are to each other. The color stops are also displayed in the on-canvas gradient editor that appears on the object to which the gradient is applied.

Two color stops are available by default. You can add more color stops by clicking the gradient editors. You can drag the color stops along the gradient editors to change the positions of the color stops and vary the spread of each color. To delete or remove a color stop, drag it away from the gradient editor in the Gradient color picker. Or, click the color stop on the on-canvas gradient editor and press Delete.

The on-canvas gradient editor helps you change the direction of the gradient.

The corner handle helps you change the origination point and angle of a radial gradient.

The slider on the right of the Gradient color picker allows you to control the opacity of the color stop.

**Apply a linear or radial gradient fill**

1. Select an object and click Fill in the Property Inspector.
2. From the color picker, select **Linear Gradient** or **Radial Gradient** from the drop-down list.
3 Click the color stops in the gradient editor and select the required colors using the color picker.

- To add more color stops, click the gradient editor.
- To modify the color assigned to a color stop, click the color stop.
- To move color stops, drag them along the gradient editor. **Note:** You cannot move the color stops on either end of the gradient editor.
- To delete a color stop, drag it away from the gradient editor. If you are using the on-canvas gradient editor, click the color stop and press Delete.
- To shift between color stops, use the Tab key.
- To change the orientation point and the angle of radial gradients, drag the corner handle.
4 To change the direction of the gradient, drag the on-canvas gradient editor segment (on the object) as required. You can also drag the end-points of the on-canvas gradient editor segment outside the bounds of the object. If a color stop is placed outside the bounds of an object, the color (associated with the color stop) is not shown on the object.

💡 You can move the end of the on-canvas gradient editor segment by using the arrow keys and shift-arrow keys. Once you select an inner color stop, you can move it along the segment by using the arrow keys and shift-arrow keys.

💡 You can also press Tab to change color stops along the on-canvas gradient editor.

5 After creating a gradient, you can save it for later reuse in the Assets panel. Click an object with the gradient and click the + icon next to Colors in the Assets panel to save it.
**Import objects with gradient fill**

1. Ensure that you save the file as a .svg file before importing into Adobe XD.
2. Click File > Import, select the SVG file, and click Import.

When you import a gradient as an SVG, the color picker displays the Gradient option by default. When you copy and paste an object in XD, the gradient fill is also copied. You can modify the color and the color stops of the gradient that you import.

*Note:*

Imported radial gradients with off-centered origin points are not editable in XD.

**Work with layers**

**Access layers**

Layers in Adobe XD is an adaptation of the layers in Adobe Illustrator and Adobe Photoshop that you know and depend on, but are reimagined for UX designers. Only the layers that are associated with the artboard you are working on are highlighted, so your panel stays clean and uncluttered. You can view all the artboards in your document and immediately pan and zoom to a specific artboard from the Layers panel. Double-clicking an artboard icon contextually displays only the layers for that artboard. Reorder, rename, show/hide, and lock/unlock layers quickly and easily.

Access layers using the shortcut **Cmd + Y** (on Mac), or **Ctrl + Y** (on Windows), or click the 🏛 icon in the toolbar.
Search within layers

You can search the Layers panel by layer names, or filter layers by text, shapes, and image categories. Search experience is optimized to show only relevant layers and artboards containing the keyword, without the layers structure (example-expanded groups) in the context of using Auto-Animate. Recent search keywords are temporarily saved in the filter dropdown for easy access, like in the Assets panel.
By default, each object in your project resides on its own layer. For example, when you draw a rectangle, a new layer for this rectangle is created. When you draw another rectangle, a separate layer, with the default name 'Rectangle 2' is created.

When you group objects on the artboard, the layers corresponding to the grouped objects are also grouped in the Layers panel. When you combine objects using Boolean operations, the layers of objects are replaced with a single layer, with the name of the Boolean operation.

You can manage layers, for example, group, rename, duplicate, or export layers, using the Layers panel:

- To group layers, multiselect layers, right-click, and pick Group from the context menu.
- To rename a layer, double-click the name of the layer and type a new name. To continue editing the next layer or artboard name, press Tab.
- To duplicate a layer, right-click the layer and select Duplicate.
- To hide a layer, hover your mouse over the layer, and click Hide button. To show the layer, click Show button. Hidden layers are not visible on the artboard.
- To lock a layer, hover your mouse over the layer, and click Lock button. To unlock the layer, click the Lock button. Locked layers are excluded from all the editing operations that you perform in the artboard.
- To export layers, select the layers, right-click, and select Export. Choose the export options in the dialog box that is displayed.
- To create a component using a layer or a group of layers, right-click the layer and select Make Component. For more information, see Work with components.
- To delete a layer, right-click the layer and select Delete.

Note:
You can manage artboards easily using the Layers panel. For example, if you are working with layers, press Esc, and the Layers panel switches to the artboard view. You can also right-click the artboard names in the Layers panel to copy, paste, duplicate, rename, delete, or export artboards.

Objects that are not on any artboard and are placed on pasteboard, are grouped under 'Pasteboard' in the Layers panel.

Export design assets
You can share production-ready assets with developers for use in websites or mobile applications. The design assets can be exported from XD to PNG, SVG, JPG, and PDF, optimized for deployment on iOS, Android, or the web.

You can export specific assets or text, specific artboards, or all artboards in the project. If you are using XD on Mac, you can also export assets to other applications. For more information, see Work with third-party integration.
Export design assets and artboards

1 To export design assets on Mac, select File > Export. On Windows, click the Hamburger menu, and click Export.

If you have artboards selected in the Layers panel, right-click, and select Export.

The following export options are available:

- **Batch**: Export assets that are marked using the Mark for Export option.
- **Selected**: Export selected assets.
- **All Artboards**: Export all the artboards in your design.

To learn how to include assets in design specs, see Mark layers for export.

![Export options](image)

**Note:**

To export multiple objects as a single asset, you must group the objects before you export them.

2 Select a target platform (web, iOS, or Android), and the file format (PNG, SVG, JPG, or PDF).

For more information on the export options, see:

- Export design assets to PNG
- Export design assets to SVG
- Export design assets to JPG
- Export design assets to PDF

3 To save the output files, specify the directory.

4 If prompted, specify the resolution at which the assets were designed. If you are not sure about the resolution, leave the setting to the default (1x).

5 Click Export.

Export design assets to PNG

1 To export design assets as PNG on Mac, select File > Export. On Windows, click the Hamburger menu, and click Export.

2 Click the drop-down list next to the format option, and select PNG. XD exports all associated resolutions for that object.

3 Select the platform you want them to be exported for - Design, Web, iOS, or Android, and click Export.
Design is the default option where your asset is exported to PNG at 1x resolution.

Web
Assets are exported at 1x and 2x resolutions.

iOS
iOS has three export sizes. Assets are exported at 1x, 2x, and 3x resolutions.

The default artboard sizes for various iOS devices assume that you are designing at 1x, so if you’ve used the defaults, leave your export at 1x. However, you can opt to design at 2x too by doubling the width and height of your artboard.

Use the following infographic to understand how your design assets are exported for iOS when you design at 1x and 2x.
Export assets as PNG for iOS

**Android**

Design assets are optimized and exported for the following Android screen densities:

- **ldpi** - Low density (75%)
- **mdpi** - Medium density (100%)
- **hdpi** - High density (150%)
- **xhdpi** - Extra high density (200%)
- **xxhdpi** - Extra extra high density (300%)
- **xxxhdpi** - Extra extra extra high density (400%)
Use the following infographic to understand how your design assets are exported for Android when you design at different resolutions.

When you export assets at varied resolutions or screen densities, existing files are overwritten if you select the same target file name or folder.
**ANDROID Export Assets**

**Designed at 75% (ldpi):**
- 10
- 10
  - xhdpi: 40 px
  - xxhdpi: 54 px

**Designed at 100% (mdpi):**
- 10
- 10
  - xhdpi: 30 px
  - xxhdpi: 40 px

**Designed at 150% (hdpi):**
- 10
  - ldpi: 5 px
  - mdpi: 7 px
  - hdpi: 10 px
  - xhdpi: 14 px
  - xxhdpi: 20 px

**Designed at 200% (xhdpi):**
- 10
  - ldpi: 4 px
  - mdpi: 5 px
  - hdpi: 8 px
  - xhdpi: 10 px
  - xxhdpi: 20 px

**Designed at 300% (xxhdpi):**
- 10
  - ldpi: 3 px
  - mdpi: 4 px
  - hdpi: 5 px
  - xhdpi: 7 px
  - xxhdpi: 10 px

**Designed at 400% (xxxhdpi):**
- 10
  - ldpi: 2 px
  - mdpi: 3 px
  - hdpi: 4 px
  - xhdpi: 5 px
  - xxhdpi: 6 px

Last updated 11/6/2019
Export options when you export as PNG for Android

Export design assets to SVG

1 To export design assets as PNG on Mac, select File > Export. On Windows, click the Hamburger menu, and click Export.

2 Click the drop-down list next to the format option, and select SVG.

3 Set styling options, and save them as embedded or linked images.
   - **Styling**: Choose how visual styling information is stored in the SVG markup as Presentation Attributes or Internal CSS. The default styling for SVG is set to Presentation Attributes as it improves compatibility with common developer tools, such as Android Studio.
     - **Presentation Attributes**: Uses separate XML attributes for each individual style property on each SVG tag. This format is required to use SVG assets with Android Studio.
     - **Internal CSS**: Uses a single style tag with CSS classes and shares the styling settings between objects with same styles leading to smaller file sizes.

4 Save images: You can save as embedded or linked images.
   - **Embed**: The bitmap image is encoded into the SVG file.
   - **Link**: The bitmap image is stored separately with a reference to the SVG file.

Export design assets to SVG

4 If you want to optimize your assets, select Optimize File Size (Minify) on Mac, or Optimized (Minified) against File size on Windows.

Export design assets to JPG

1 To export design assets as PNG on Mac, select File > Export. On Windows, click the Hamburger menu, and click Export.

2 Click the drop-down list next to the format option, and select JPG.
When you export assets (such as photos) as JPG, you can set the quality level of the exported JPG accordingly. Choose any of the percentage options in the Quality drop-down list, and against Export for, choose Design or Web.

**Export design assets to PDF**

1. To export design assets as PNG on Mac, select File > Export. On Windows, click the Hamburger menu, and click Export.
2. Click the drop-down list next to the format option, and select PDF. You can choose to export them as a single PDF file or individual PDF files.

![Export design assets to PDF](image)

3. **Single PDF file**: You can select multiple artboards or assets, and export them as a single PDF file. Multiple artboards or assets are placed in separate pages and a single PDF is created.

   **Individual PDF files**: You can select multiple artboards or assets, and export them as individual PDF files. Separate PDF files are created for each of the selected assets or artboards.

4. Then, click Export.

**Work with third-party integration**

You can bring your designs into other applications that integrate with XD: Zeplin, Avocode, Sympli (only on MAC), Kite Compositor, and ProtoPie.

The section below provides a high-level overview of the workflow using the example of XD running on Mac with Zeplin.

The procedure works the same way on XD running on Windows.

**Note:**

*This procedure varies slightly depending on the application you are using. For more information, refer to your application’s documentation:*

- Zeplin
- Avocode
- Sympli
- ProtoPie
- Kite Compositor

1. Select an artboard or layer in your XD file, and click File > Export > Zeplin.
Note:

If you have multiple applications integrated with XD, the Export to keyboard shortcut (⌘E) launches the last integration you used.

2 In the dialog box that opens, click Import.

To replace existing screens in Zeplin with the same name, select Replace screens with the same name. Zeplin adds it as a new version of that same screen, without losing your notes.
The artboards are imported into Zeplin.
Extract assets for design specs

You can mark layers as assets for export and send them to developers as a design specs link. Developers can download all the vector assets as SVG, PNG, PDF, and bitmap assets as PNG and PDF.

For more information, see Export and download assets from design specs

If you are unable to see third-party applications in the File > Export option, see Unable to see supported third-party app in Export options.

If you are unable to export your file, see Why can’t I import or export files in Adobe XD?

Create scrollable artboards

When you create an XD design, sometimes an artboard is not long enough to fit your content. By making an artboard longer and choosing options based on your design needs, you can vertically scroll an artboard to accommodate different device sizes.

Vertical scrolling helps you simulate scroll effects when designing scrollable drop-down lists or websites, however, horizontal scrolling is not supported in XD.
Create a vertical scroll

1. On preset artboards: Drag down the lowest point of the artboard to increase its length longer than the device screen. A dotted line indicates the start of the scrollable content.

2. On custom artboards: In design mode, select the artboard and set the following options in the Property Inspector:
   - Scrolling: Select Vertical or None.
   - Viewport Height: Specify the viewport height through which you view the artboard.
Vertical scroll on a custom size artboard

3 Wire the artboards in the prototype mode.

4 In the prototype Property Inspector, select the following options based on your design requirements:
   - **Preserve scroll position**: Transitions to the next artboard while maintaining the position from the previous artboard. Check out this Twitter post for more details.
   - **Fix position when scrolling**: Pins the design elements to a fixed position to avoid scrolling with the content. Read on to learn more about this option in UX designs.
Preserve scroll position
To preview the artboard, select Desktop Preview. Drag the preview window to view the vertical scroll.

**Examples and sample files**

- **Scrollable drop-down lists**
  
  Want to work with preset artboards to create a vertical scrollable drop-down list?

  1. Use the Select tool to click the artboard name or drag across artboards. You can also click an artboard name in the Layers panel to select it in the Document window.

  2. To make the selected artboard longer, drag the bottom point of the artboard down. A dotted line indicates the original height of the artboard.
3 To preview scrolling on an artboard, you can preview directly in XD using the Desktop Preview option. Do download the sample files and try them yourself or watch this video for more information. Viewing time: 1 minute.

Video

• Website designs

As you are building up your designs for desktop or mobile, do you want to see portions of your website only when scrolled and pin the design elements without floating? Watch this video to learn more on scrollable artboards and fixed elements. Viewing time: 1 minute.

Video

You can also check out the XD community for more such tutorials and sample files.

Tips and tricks

Want to mimic a horizontal scroll in your prototype?

XD does not support horizontal scrolling; as a workaround, you can use auto-animate with a drag trigger to simulate horizontal scrolling:

1 Group the elements you want to horizontally scroll in the artboard and duplicate the same artboard.
2 In the new artboard, copy and move the group of elements to its final position in the scroll.
3 Wire the prototypes and switch the trigger from Tap to Drag and action to Auto-Animate.
4 Drag the preview window to view the mimicked horizontal scroll effect.

Best practices

“Sticky headers and other fixed elements are like signs on a highway — way finders to ensure we’re continuing to provide relevant information to a corresponding section or aiding customers along their journey via calls to action.” Says Oliver Lindberg. Check out the blog on best practices for designing sticky headers and other fixed elements.

Apply blend effects

When working on images in your designs, you may want to go beyond a simple photo to create interesting and unique effects. For example, you may want to add your brand’s color as an effect on your images to create a visually appealing design.

Blend modes allow you to automatically create composite image assets by combining an image layer with another layer using a set of pre-defined modes.

Here are some sample effects created using Multiply, Screen, Hard Light, Exclusion, and Luminosity blend modes.
Use blend effects to create magic with colors!

Curious about blend color terminologies?

• The blend color is the original color of the selected object, group, or layer.
• The base color is the underlying color in the artwork.
• The resulting color is the color resulting from the blend.

The base and the blend color mix depend on the selected blending mode.

• Supported blend modes and their design outcomes
<table>
<thead>
<tr>
<th>Groups</th>
<th>Blend mode</th>
<th>Design outcomes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Normal</td>
<td>This is the default mode and no blending mode is applied.</td>
</tr>
<tr>
<td>Darken</td>
<td>Darken</td>
<td>Looks at the color information in each image and selects the base or blend color—whichever is darker—as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change.</td>
</tr>
<tr>
<td>Multiply</td>
<td>Darken</td>
<td>Looks at the color information in each image and multiplies the base color by the blend color. The result color is always a darker color.</td>
</tr>
<tr>
<td>Color Burn</td>
<td>Darken</td>
<td>Looks at the color information in each image and darkens the base color to reflect the blend color by increasing the contrast between the two.</td>
</tr>
<tr>
<td>Lighten</td>
<td>Lighten</td>
<td>Looks at the color information in each image and selects the base or blend color—whichever is lighter—as the result color.</td>
</tr>
<tr>
<td>Screen</td>
<td>Lighten</td>
<td>Looks at the color information of each image and multiplies the inverse of the blend and base colors. The result color is always a lighter color.</td>
</tr>
<tr>
<td>Color Dodge</td>
<td>Lighten</td>
<td>Looks at the color information in each image and brightens the base color to reflect the blend color by decreasing contrast between the two.</td>
</tr>
<tr>
<td>Contrast</td>
<td>Overlay</td>
<td>Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing pixels while preserving the highlights and shadows of the base color.</td>
</tr>
<tr>
<td>Soft Light</td>
<td>Overlay</td>
<td>Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the image.</td>
</tr>
<tr>
<td>Hard Light</td>
<td>Overlay</td>
<td>Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the image.</td>
</tr>
<tr>
<td>Inversion</td>
<td>Difference</td>
<td>Looks at the color information in each image and subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value.</td>
</tr>
<tr>
<td>Exclusion</td>
<td>Difference</td>
<td>Creates an effect similar to but lower in contrast than the Difference mode.</td>
</tr>
<tr>
<td>Component</td>
<td>Hue</td>
<td>Creates a result color with the luminance and saturation of the base color and the hue of the blend color.</td>
</tr>
</tbody>
</table>
Want to create a blend effect?

1 Before you begin, use these simple rules to understand how objects are handled when applying or modifying blend modes:
   • **Appearance**: applies and affects the whole object.
   • **Master component**: applies and affects all instances in your design project. For example, if you change the color of an object in the Master component, the change is cascaded across all instances in your design project.
   • **Component instance**: overrides the applied blend modes in component instances.
   • **Repeat grid**: applies on all the cells.
   • **Interoperability**: preserves the blend effect when working with Photoshop, Illustrator, Sketch, and After Effects.

2 Select an image or object (including shapes, text layers, groups, masks, or components) on the design canvas. From the **Property Inspector**, select and apply the blend mode of your choice.

   You can also use **Option Shift + / -** in MAC and **Alt Shift + / -** in WIN to toggle through the appearance levels of the applied blend modes.

3 To preview the applied blend mode effect, select 🎞.

**Limitations**

Blend modes are not supported in these object behaviours:

• Blend effects used in auto-animate change at the start of the transition without any animation.

• You cannot apply blend effects on fills, borders, or shadows.

**Examples and sample files**

• **Posters with varied hues and color blends**

   Want to create a poster with blend effects? Select an image on canvas, and from the **Property Inspector**, select and apply the following blend options to create these stunning outcomes:

   • **Hard Light**
   • **Difference**
   • **Screen**
   • **Color Burn**
Tutorials

Watch this video to learn how to blend the color of an object with the background color of an artboard or blend the colors of multiple objects layered on top of one another.

Viewing time: 1 minute.

Video

Have a question or an idea?

We’ve got you started with blend modes in Adobe XD. The interface of Adobe XD is intuitive; we think you will find it easy to unleash your creativity with Create and modify gradients Work with blur effects in XD, and more.

If you have a question to ask or an idea to share, come and participate in Adobe XD Community. We would love to hear from you and see your creations.
Export and download assets from design specs

Export assets from design specs
If you mark layers for export, and include assets when publishing design specs, you can download them from the published design specs link. Vector assets are available in SVG, PNG, and PDF and bitmap assets in PNG and PDF.

To learn more about exporting assets for design specs and downloading them, check out this video.

Video

Mark layers for export
Layers marked for export are included as assets in design specs. To mark assets for export, select any layer on canvas, and use any of the following options:

- Click on any artboard layer and click Mark for Export checkbox from the pop-up menu.
- Right-click the layer on the canvas and choose Mark for Export from the pop-up menu.
- Use the keyboard shortcut in macOS and keyboard shortcut in Windows OS.
- Open the layers panel and click the mark for export icon next to the layer name.

To export multiple assets, select multiple layers within an artboard and click Mark for Export.

When you import or open Illustrator or Photoshop document with images, XD automatically marks all bitmap images for export.

Mark the assets for export
**Publish design specs with assets**

When you include assets while publishing design specs and share the published link with developers, you provide them with a centralized location to download those assets.

1. Mark layers for export in XD.
2. Click Share to switch to the Share mode.
3. Select Development from View Setting. In design specs, it is assumed that designs are at 1x resolution.
4. In the Design mode, select the assets that you want to export. In the Property Inspector, select the Mark for Export checkbox. The assets for export appear in the Share mode screen.
5. Select the Downloadable Assets checkbox to mark your assets for export.

Based on the platform you create the design for, each platform has a separate set of resolution settings:

- **Web**: Assets are exported at 1x and 2x resolutions.
- **iOS**: Assets are exported at 1x, 2x, and 3x resolutions.
- **Android**: Assets are optimized and exported for the following Android screen densities:
  - ldpi - Low density (75%)
  - mdpi - Medium density (100%)
  - hdpi - High density (150%)
  - xhdpi - Extra high density (200%)
  - xxhdpi - Extra extra high density (300%)
  - xxxhdpi - Extra extra extra high density (400%)

6. To open the published design specs in the browser, click the Open in Browser icon, and select an artboard to view the assets. The browser displays the selected assets along with other artboard details.

When you hover the pointer over the assets, contextual selection highlights the selected asset in blue.
Download assets from design specs

When you share the published design specs with developers, developers can download assets from it. Developers can download assets individually or at the same time.

Use **Cmd+ A** or **Ctrl+ A** to select all the assets or use the **Shift** key to multi-select. Assets are downloaded as .zip files in the downloads folder on your machine. You can change the format of vector assets to **SVG**, **PDF**, and **PNG** and the format of bitmap assets to **PNG** and **PDF**.

*Download assets*
Chapter 3: Prototype

Create interactive prototypes | Overview

After you have completed designing your screens, you can visualize how users can experience your app or website by building an interactive prototype.

You can wire up your screens in desired navigation sequence and feel the experience like real users.

Set the Home screen

The Home screen is the first screen of your app or website. Your users begin to navigate the app or the website from the Home screen.

Also, when you preview your prototype and nothing is selected, the preview begins with the Home screen. That is, by default, your Home screen is set to the first artboard you add a wire to.

1 Switch to Prototype mode.
2 Click the artboard that you want to set as the Home screen. A gray home icon appears in the upper left corner.
3 Click the Home icon. It turns into blue indicating that the artboard is now successfully set as the Home screen.
To set a different artboard as the Home screen, simply click the Home icon associated with that artboard. To view all the artboards after publishing, ensure to link all the relevant artboards.

**Wire up your screens**

To link the artboards for an interactive prototype, you can wire up the artboards by connecting the interactive elements to a target object or artboards. Before you link artboards or screens, name the artboards appropriately. Doing so helps you identify the screen to which you want to link to.

1. Switch to **Prototype** mode.
2. Click the object that you want to link. A connecting handle with an arrow appears on the object. When you hover your mouse over the handle, the cursor changes to a connector.
3 Click and start dragging your mouse to see the connector. Release your mouse on the target artboard or screen. When you wire up the first element, the artboard of that element is set as the home artboard.

4 To make your prototypes more engaging, you may want to introduce triggers and actions. To do so, click the + button on the canvas or click + in the Property Inspector, and select the on-screen options.

**Prototyping options**
A Set to Tap, Drag, Hover, Time, Keys & Gamepad, or Voice. B Set time Delay in seconds. C Set to Transition, Auto-animate, Overlay, or Speech Playback. D Change the destination artboard if required. E Set to Dissolve or None. F Select the easing effect. G Enter the time duration in seconds.
You can also combine multiple triggers to create advanced interactions without distributing the triggers across different objects on an artboard. To do so, use the + button on the canvas or click + in the Property Inspector, and select Triggers, Action, and Destination as in Step 4.

Remember that you can apply Tap, Animate prototypes Hover, and triggers only once, and Add a voice command to a prototype, and many times.

To preview your prototype, click Desktop preview.

Tutorials
"As prototyping workflows continue to evolve, there are more and more ways to interact with your design. Everything from touch, drag and tap gestures, to keyboard shortcuts and voice recognition can not only be used, but combined to trigger a variety of interactions." - Dani Beaumont, Principal Product Manager, Adobe XD.

Watch this tutorial to learn how to combine multiple triggers for a variety of interactions.

Watching time: 1 minute.

Video

Tips
💡 To edit or delete a wire, select the wires to edit or delete them. You can also select a single interaction from the Property Inspector and edit its interactions.
💡 Hover over the wire to view a tool tip that tells you the number of interactions and their type.
💡 To apply the defined interaction to another object, select the object or the artboard, select copy, click on the destination object or artboard, and in the right-click context menu, select Paste Interaction.

Link to previous artboard
In the Prototype mode, select the element you want to link. When a small arrow appears, click and drag the arrow to the previous artboard, or select Action > Previous Artboard.
2 When the **Action** is set to **Previous Artboard**, a tail icon appears at the end of the wire.

3 Use the preview window to preview the linking.

**Unlink artboards**

1 In **Prototype** mode, select **Target > None**.

   You can also drag the wire from the artboard to the draft area (the gray space between the artboards).
Unlink artboards

- The None option is available only if the artboard is linked to a target.

2 Preview the linking in a browser. Any target link previously set from the element is removed. To view all the artboards after publishing, ensure to link or unlink the relevant artboards.

**Preview and record interactions**

- Recording prototypes is not supported in Adobe XD on Windows. However, there's a workaround. Press the Windows + G keys and use the native recorder to record the Preview window.

To test your prototype and the interactions, you can preview the prototype. You can also record the preview and save the recording as a .mp4 file. You can then choose to share the .mp4 file with your stakeholders, who can view (or review) the walkthrough of the prototype and provide feedback.

1 Click the Desktop Preview icon. The Preview window appears and displays the artboard in focus.

   To test the navigation between screens, click the interactive elements.

   You can edit the design and interactions in your prototype while previewing in the preview window. The changes are instantaneously available for preview.

2 To record the interaction, click **Record** icon in the preview window. To end the recording, press **Esc** or click the **Record** icon again.
Record prototype interactions

Specify a name and location where you want to save the recording. The recording is saved as a .mp4 file.

**Animate prototypes**

With auto-animate, you can create immersive transitions to visualize the movement of content across artboards. Combined with the power of Drag and Time triggers, it helps you create a wide range of effects such as a YouTube swipe and drag to tell a better prototype story.
Ripple effect in a website

Swipe and drag effect on a touch enabled device
To create an animated prototype, follow these steps:

1. Before you begin, use these simple rules to understand how objects are handled during animation:
   - If an object isn’t present on the destination artboard, it fades in.
   - If an object isn’t present on the source artboard, it fades out.
   - If an object has a match both in terms of its layer name and its group, attributes are animated. For a comprehensive list of supported properties and transitions, read Object properties.

2. Wire the artboards in the prototype mode.

3. Click the connector to view the interaction panel that appears in Property Inspector and set the following options:
   - **Trigger**: Select an option to trigger an animation. For example, to simulate a tapping card experience, select Tap.
   - **Action**: Select Auto-Animate.
   - **Destination**: Select the destination artboard to transition the animation.
   - **Easing**: Select an option to simulate easing effects. For example, select Ease Out if you want your animations to ease out from your prototype.

4. To define more interaction for an object, select the object with an interaction already defined, and click the + button on the artboard; alternatively, you can also click + on the Property Inspector.
   - Remember that you can apply Tap, Drag, Hover, and triggers once, and Voice, Keys & Gamepad many times.

5. Preview your animations in supported browsers.
   - Remember that XD does not support scrolling when previewing auto-animated artboards.
Examples and sample files

- Sample auto-animate UI kit
  Want to learn the nuts and bolts of auto-animate? Get started with this UI kit that has basic interactions, UI elements, drag examples, and much more.

  You can also use more such sample files to test auto-animate.

- YouTube swipe effect
  Want to achieve a YouTube swipe effect without the hassle of timelines and key frames?

  Wire up your artboards and select these options in the prototype Property Inspector:
  - Trigger: select Drag.
  - Action: select Auto-Animate.
  - Destination: select the destination artboard to transition the animation.
  - Easing: select an option to create easing effects. For example, select Ease In-Out to ease in-out your animations from your prototype.

  Do download the sample files and try them yourself or watch this video for more information.

  Viewing time: 1 minute.

  Video

- Animated mobile menu
  Want to learn how to create an animated mobile menu with an ease in effect?

  1 Download the sample files.
  2 In the prototype mode, wire the hamburger menu to the home_expanded artboard and select the following options in the prototype Property Inspector:

    - Trigger: select Tap.
    - Action: select Auto-Animate.
    - Destination: select the destination artboard to transition the animation.
    - Easing: select Ease In effect.
    - Duration: select the duration to 0.8 seconds.

- After-Effects to add advanced micro-interactions
  Want to add advanced animations to your designs? Watch this video for working with After-Effects.

  Export from Adobe XD to After-Effects (Viewing time: 1 minute)

  Video

  You can also check out the XD community for more such tutorials and sample files.

Best practices

Did you know that you can play around with the various easing options to change the user experience of your animated prototypes? Read on for best practices and watch Talin Wadsworth, Principal Designer of Adobe XD, share some nifty tricks on using auto-animate.

Viewing time: 1 minute.
Create prototypes using voice commands

Adobe XD provides an easy-to-use solution that lets you use voice commands to trigger an interaction between artboards. Like using a **Click** or a **Tap** as a **Trigger**, you can use **Voice Commands** to trigger a prototype interaction and **Speech Playback** as a triggered action. For example, if you are integrating voice search within a mobile application, you can use **Voice Commands** and **Speech Playback** to automatically transition between artboards.

**Add a voice command to a prototype**

1. In XD, switch to **Prototype** mode.
2. Select all the artboards on the canvas to view their wires.
3. Click and drag the wires from the source artboard to the destination artboard. When you wire up the first element, the artboard of that element is set as the home artboard.
4. Click the connector to view the **Interaction** panel that appears in **Property Inspector** and set the following options:
   - **Trigger**: set to **Voice**.
   - **Command**: enter the **Voice Command** as text.
   - **Action**: set to **Transition**.
   - **Destination**: set the destination artboard.
   - **Animation**: set animations based on the available options.
   - **Easing**: set easing based on the available options.
   - **Duration**: set duration in **Seconds**.
5 To define more than one interaction for an object, select the object with an interaction already defined, and click the + button on the artboard; alternatively, you can also click + on the Property Inspector.

Remember that you can apply Tap, Drag, Add interactivity to components and Time triggers once, and Voice, Keys & Gamepad many times.

Use multiple triggers to define more interactions

6 To preview the changes, select the Desktop Preview icon.

7 To preview the transition to the next artboard, hold down the spacebar and repeat the voice command.

Add a speech playback to a voice input

1 Click and drag the wire from the destination artboard to the source artboard.

2 In the Interaction panel that appears in Property Inspector, set the following options:
   - Trigger: set to Time.
   - Time delay: set the transition delay period in Seconds.
   - Action: set it to Speech Playback.
   - Voice: choose a voice for the speech playback.
   - Speech: add the corresponding speech response.
Add a voice narration to a prototype

1 In the Prototype mode, select the Home screen where the start of the flow is set and click on the Desktop Preview button.

Note:
MAC users have the option to enable the microphone before starting a preview recording; Windows users can enable this through an OS-level control in Gamecenter.

To preview the changes, select the Desktop Preview icon.

To preview the transition to the next artboard, hold down the spacebar and repeat the voice command.
2 Select the drop-down arrow adjacent to the record button and select Enable the microphone option. When recording, watch out for the red icon that flashes on the interface.

3 You can save the recording as an mp4 and share it with your stakeholders or post it in social media.

Share and review the prototype or design specs link on the web

1 In the desktop app, click the Share icon at the upper right and choose Share for Review (for prototypes) or Share for Development (for design specs).

2 When previewing a prototype on a:
   • Desktop or laptop: hold down the spacebar.
   • Adobe XD Mobile app (iOS/Android): use a long press gesture anywhere on the screen. Place your finger on the screen (without moving it) and use the voice command before lifting your finger back.
   • Mobile browser in a smartphone: hold down the microphone icon located in the lower right-corner of the screen.

3 When previewing design specs, developers can read or view the voice commands and speech playback as text.

Note:

Design specs do not support voice interactions.

Troubleshoot voice interactions using notifications

You can now troubleshoot voice triggered interactions during prototype previews on the desktop or web. Stakeholders, who review the design specs can also use this feature to better understand how to interact with your prototype in Adobe XD.

Before talking to your prototype during preview, ensure the Show Notifications menu item is checked. By default, this menu item is in checked state when you launch Adobe XD.
Show notifications for voice prototype

Each command you speak to Adobe XD is matched against all of the voice triggers present on that current artboard. If no match is found, you will receive a notification stating No match found for: [the command you spoke]. Seeing what Adobe XD heard helps you determine why a match is not being made each time you speak.

There can be different reasons a match can't be found. Perhaps the voice command spoken isn't being used in any interactions on that artboard. Or maybe the speech-to-text service is returning an unexpected result.

For example, you may decide to add the phrase two dollars as a voice command in an interaction. But when spoken, the speech-to-text service may return a result of $2.00. By seeing this in the notification, you will now know to change the interaction to use numerals instead of words.

Preview designs and prototypes in the preview window

After designing your assets or prototypes, you can accurately preview the workflow of your website or app, including screen transitions. During the preview, you can change your designs or prototypes in Adobe XD and preview them in real time.
You can also preview your designs and prototypes on iOS and Android devices using the Adobe XD mobile app. For more information, see Adobe XD on mobile FAQ.

1 In the Design or Prototype mode, click the Desktop Preview icon. The Preview window appears. The Preview window displays the artboard that contains the currently selected objects. If no object is selected, the Preview window opens with the Home artboard first.

You can Preview the design in full-screen view or regular view. On Mac, to view in full-screen mode, click the Play icon on the upper right of the design. The prototype then expands to fill the entire screen.

2 (Optional) Click an asset or prototype interaction in XD and make changes if necessary. Notice that the changes are instantly updated in the Preview window.

3 To close the Preview window, click the close button of the window.

Record interactions in prototypes

Recording prototypes is not supported in Adobe XD on Windows. However, there's a workaround. Press the Windows + G keys and use the native recorder to record the Preview window.

To preview your design or prototype, click the Preview icon. In the Preview window, click Record. If there's an interactive prototype, all interactions in the Preview window, are recorded as a .mp4 file.

To stop recording, click Record again or press Esc. Specify a location to save the .mp4 file.

The recording also stops if:
• You switch away from the application
• The preview window does not have focus anymore

Using the Adobe XD mobile app, you can preview your designs and prototypes on iOS and Android devices. Multiple devices can be connected using USB ports on the computer running XD. You can make changes to your designs and prototypes, and simultaneously preview them in real time on all the connected devices. For more information, see Adobe XD on mobile FAQ.

Add overlays

Adobe XD allows you to stack content on top of another artboard, rather than duplicate it on multiple artboards, to simulate effects such as drop-down lists, slide-up keyboards, and more.
1 In Design mode, select a source artboard and the other artboard to overlay it. You can reuse an overlay artboard multiple times.

2 In Prototype mode, drag-and-drop the connector from the source artboard to the artboard with the overlay content. Click the connector to view the Interaction panel that appears in Property Inspector and set the following options:
   - **Trigger**: Select an option.
   - **Action**: Select Overlay.
   - **Animation**: Select the animation type. If you select **Slide Up** or **Slide Down**, XD automatically positions the overlay to the edge of the source artboard.
   - **Easing**: Select an option to simulate easing effects.
   - **Duration**: Enter the time duration. The maximum duration you can set between two transitioning artboards is five seconds.
3 To adjust the position of an overlay on the source artboard, click, drag, and drop the green position knob (+).

4 To preview your overlays in supported browsers, click 📦.

### Nested overlays
Adobe XD does not support nested overlays where you apply an overlay over another overlay. In such scenarios, when you connect the first overlay artboard to another artboard, the first overlay is transitioned out before transitioning in the second overlay.

### Examples and sample files
- **Overlays with background blur effects**
  
  Want to create interactive overlays using background blur effects?

  1 Choose a source artboard and an overlay artboard with a background blur. For information on how to add background blur, see [Work with blur effects in XD](#).

  2 Switch to **Prototype** mode to wire the source artboard to the overlay artboard.

  3 Choose the following options from the **Property Inspector**:

    - **Trigger**: Select Tap.
    - **Action**: Select Overlay.
    - **Animation**: Select Dissolve.
    - **Easing**: Select Ease Out.
    - **Duration**: Enter 0.2s.

  4 Wire as many different source artboards to the overlay artboard.
5 Use Desktop Preview to preview the effect.
For a detailed tutorial and downloadable sample files, see Create an interactive overlay.

- **Slide-in drop-down list effect**
  Want to learn how to use overlays to create a slide-in drop-down list effect? Watch the tutorial at the end of this example and follow these steps:
  1. Choose a source artboard and an overlay artboard that has a drop-down list of items.
  2. Switch to Prototype mode to wire the source artboard to the overlay artboard.
  3. Choose the following options from the Property Inspector:
     - **Trigger**: Select Tap.
     - **Action**: Select Overlay.
     - **Animation**: Select Slide Right.
     - **Easing**: Select Ease Out effect.
     - **Duration**: Enter 0.3s.
  4. Wire as many different source artboards to the overlay artboard.
  5. Use Desktop Preview to preview the effect.

You can also check out the XD community for more such tutorials and sample files.

**Best practices**
"Overlay is a very powerful feature that has many uses. The tasks that users are trying to perform are becoming increasingly complex, and overlays can really help to take off the pressure". Says Oliver Lindberg. Check out his blog on best practices for designing overlays.

**Design voice prototypes**
**Voice prototype integration with XD**

Voice capabilities in Adobe XD allow designers to incorporate the medium of voice into their prototypes and design rich experiences such as integrating voice search within a mobile application, adding a speech output for turn-by-turn directions in a car navigation system, or including both into an interactive kiosk in retail environments.

Adobe XD uses voice commands to seamlessly integrate voice into prototyping workflows so that designers can be involved in the early creation stages of voice applications.

Voice commands allow you to trigger an interaction using a verbal command. Similar to using a **Click** or **Tap** as a **Trigger**, you can add a specific utterance as a trigger within XD’s prototyping mode. **Speech Playback** gives you access to a powerful text-to-speech engine that you can use to interact with your prototype.

**Benefits of voice capabilities in XD**

- Ability to design, prototype, and share experiences using the medium of voice.
- Create experiences for new platforms and devices, such as voice assistants and smart speakers.
- Ease of use in adding voice like any other prototyping interaction with no previous experience in voice technology or coding.

**Prerequisites to use voice within prototypes**

- XD version 13.0 or later to add and preview voice capabilities.
- A reliable Internet connection to interact with voice features.
- You cannot use voice commands with embedded or offline prototypes.
Hardware dependencies when getting started with voice
• Adobe XD requires access to the microphone of the device it is being used on.
• Ensure that the speakers are enabled and set to an appropriate volume level to hear any speech playback incorporated into your prototype.

Supported languages for voice capabilities
While voice command and speech playback features of Adobe XD are translated to all localized versions of XD, voice command and speech playback capabilities are available in English, German, Japanese, Korean, Chinese, Spanish, Brazilian Portuguese, and French. Do note that these capabilities are based on the Language and Region settings on your computer.

Speech detection has been optimized for accents and speech playback offers a wider variety of voices with accents based on your region.

Specific use cases associated with voice prototyping
Voice prototyping is a quickly evolving technology with new devices entering the market all the time. A few examples of voice prototyping with Adobe XD include:
• Voice search within a mobile application.
• Third-party applications for voice appliances such as Amazon Alexa, Google Assistant, or Microsoft Cortana.
• Speech output for turn-by-turn directions in a car navigation system.
• Interactive kiosk in retail environments.

Common workflows associated with voice prototyping
Some of the workflows are:
• Add voice control as an input to a prototype and preview the integration.
• Add a speech response to the voice input in the artboard.
• Share a voice-enabled published prototype with other designers or test usability with prospective users.

Create prototypes using voice commands
For information on how to create, publish, and preview a voice prototype and speech playback response, see Create prototypes using voice commands

Activate voice commands in the preview mode
When previewing a prototype on a:
• Desktop or laptop: hold down the spacebar.
• Adobe XD Mobile app (iOS/Android): use a long press gesture anywhere on the screen. Place your finger on the screen (without moving it) and use the voice command before lifting your finger back.
• Mobile browser in a smartphone: hold down the microphone icon located in the lower right-corner of the screen.
Best practices associated with using voice capabilities

- A common pattern when working with voice and speech is to not actually combine them in one interaction. To use them together, use a voice trigger to transition from the first artboard to the second artboard. Then on the second artboard, use a time trigger for speech playback. This combines a visual response and speech playback when using a voice trigger.

- If you want to add multiple voice triggers to the same artboard, use placeholder objects. For example, add multiple circles to an artboard in design mode and in prototype mode, add a different voice trigger to each circle. To hide the circles, click the eye icon in the layers panel. Though the objects are not visible on the artboard, the voice triggers associated with them continue to work during preview.

Troubleshooting voice-related errors and issues

- **Why does my voice trigger not work in preview mode?**
  
  Assuming that you have set up the voice command in a proper manner, check your mic settings to ensure that Adobe XD has permissions to access your microphone.

- **Does the voice trigger command exactly match your utterances?**
  
  Adobe XD does its best to match what is said to the available set of commands. Though it does not need an exact mapping, how close it should be varies for different phrases. A significant part of working with voice is testing how Adobe XD handles different phrases in your design.

- **Why am I unable to hear the speech playback in preview mode?**
  
  Ensure that your device is not muted, and the volume is turned up. A good way to validate speech playback is to enter the prototyping mode, add an interaction to an object that uses a tap trigger and speech playback. In the preview mode, click the object to hear the speech playback.

- **Why am I unable to use my headphones to preview my prototype?**
  
  Some wireless headphones may not work properly with voice triggers and speech playback. If you are having issues, try disconnecting your wireless headphones.
- How do I troubleshoot voice interactions using notifications?

  You can now troubleshoot voice triggered interactions during prototype previews on the desktop or web. For more information, see Troubleshoot voice interactions using notifications
Chapter 4: Share

Share designs and prototypes

The Share mode in XD consolidates different sharing capabilities into a centralized location and makes sharing your designs and collaborating with stakeholders and designers a breeze!

Built-in presets, such as Design Review, Development, and Presentation help you share your documents, manage your shared links, and use the same URL for multiple sharing scenarios and iterations.

Prepare to share your designs

Before you share a design, run these checks:
Set the Home artboard for your design:

- Create interactive prototypes | Overview to other artboards.

Arrange artboards in the correct sequence:

- Wire the artboards as you would like them to be published in the navigation sequence.
- Confirm if the wired artboards are visually highlighted on the design canvas. Artboards that are wired and not connected to the Home artboard will be grayed out in Share mode.
- For artboards that aren’t wired, the navigation sequence defaults from left to right or top to bottom. If you want to change the navigation sequence, go back to Prototype mode and Create interactive prototypes | Overview.

Work with presets

XD provides scenario-based presets to create sharable links for your designs with ease. For example, when creating a design link for review, all you have to do is select the available preset based on your requirement, How do I create links for sharing a design or prototype?, and share it with your stakeholders. You don’t need to worry about setting the commenting options or navigation controls.

Read on to learn how you can How do I create links for sharing a design or prototype?, I have modified my design project; should I create a new link?, or manage design or prototype review links using these built-in presets.
How do I create links for sharing a design or prototype?
You can choose any one of the five presets to create a public or private link for an XD document.

To create a new public link using the **Design Review** preset, watch this animated illustration.

Create and share a public link using a Design Review preset
Now that you have learned how to use a preset to create a new public link, go ahead and try creating a new private link that only invited people can access:

1. Select any one of the presets from **View Setting**. If you choose the **Development** preset, specify the target platforms, such as iOS, Web, or Android.

2. Choose **Only invited people** and click **Create Link**.

3. Add your reviewers in the **Invite** popup and click **Invite**.

**I have modified my design project; should I create a new link?**

No, you don’t have to create a new link for an XD document. As you change your design or your preset, you can update an existing link that you have shared for review.

**Example 1** — If you have created multiple prototypes and shared them for review, all the created links appear in the URL picker. You can now pick and choose any link to update by clicking **Update Link**.
Example 2 — If you have created a prototype link and shared it for feedback, and now want to share the same prototype with your developer, navigate to **View Setting**, switch to **Development**, and click **Update Link**.

The same URL is retained with the latest design changes, comments, and conversations from the previous design version is retained, and new preset information is added.

**How do I view previously generated links and delete them?**

You can manage published links of your XD document by navigating to **Creative Cloud** website from XD.

1. From the URL picker, select **Manage Links**.
2. From the **Creative Cloud** website, you can copy or delete a published link.
Learn more
"There are many ways to communicate your ideas with Adobe XD — everything from presenting a prototype flow, to organizing a stakeholder review, or finally delivering specifications as part of the developer handoff. To help you navigate all of these capabilities, we’ve moved to a new share experience and expanded on its functionality" — Dani Beaumont, Principal Product Manager XD

To learn more about the new share experience, watch this video.

Viewing time: 2 minutes.

Video

What's next?
We’ve got you started with sharing your designs and prototypes with your stakeholders. Take a step forward and learn how to comment on your prototypes and Review and comment design specs

Have a question or an idea?
If you have a question to ask or an idea to share, come and participate in Adobe XD Community. We would love to hear from you and see your creations.

Share design specs
Design specs empower you to share design properties of your files with the developers. By sharing the design specs, you provide key information like object height, width, size, alignment, relative spacing between two icons (objects), colors, and typography.

When you share the design specs as public links, you can also restrict access through password protection. To password-protect an already shared design spec, see Password protect existing prototype links.

When you share design specs as private links, you can invite internal and external reviewers.

To share design specs:
1. Open the Adobe XD file that you want to share with the developers.
2. Click Share to switch to Share mode.
3. In the Link Settings pane, set a design spec title.
4 From View Setting, select Development, and choose the output of your form factor (Web, iOS, or Android).

*Note:* XD sets the default units of measurement based on the option chosen in the share dialog box.

- iOS: Default unit is pt, assets are available in 1x, 2x, and 3x.
- Web: Default unit is px, assets are available in 1x and 2x.
- Android: Default unit is dp.

*These default units are not editable.*

5 Click Create Link to generate a sharable link. You can also access it from the URL picker list (🔗) in the Property Inspector in the Share mode.

If you want to create a public link:

- Click the link to open the design specs in the default browser.
- Click Copy Link to copy the public link and send it to developer for inspection.

6 If you want to create a secured private link to be shared, select Only invited people in the Who Has Access settings.

7 You can continue updating your design even after you have shared the design link. You can update the existing link with the changes you have made, and click Update Link.

To create a new link to the design specs, from Manage Links, click New Link.

*If you have any issues with sharing or viewing shared design specs, see Workarounds for common design spec errors.*
Inspect design specs

On receiving design specs, you can view and inspect attributes such as colors, text, measurements, and hotspots of different objects in an artboard.

View and inspect measurements

Select an object in the artboard to inspect its measurements and styles.

To find out the spacing between objects, select an object and hover the pointer over other objects in the artboard.

View colors, character styles, and assets

When you select an artboard in the design specs link, all the unique colors used in that artboard are shown in the Colors section. You can view the available color formats and use the drop-down list to select the format of your choice. For example, if you prefer to work in HSLA, use the drop-down list to convert the color format to HSLA. This change is persistent across the entire session and the same color formats are used when you view other artboards.

Similarly, you can view all the unique character styles of an artboard in the Character Styles section.

If you have marked any layers in the artboard for export, you can view the colors and character styles of those layers in the Assets section.

Note:

When you select an object in the artboard, colors used for that object are shown in the Appearance section.
**View and inspect hidden layers**

To view and inspect layers hidden below an overlapping layer, hover and right-click over the specific area on the artboard. This displays the list of layers and its contextual details at that pixel point.

You can also use cmd+click to sequentially drill down and view the layer properties.

---

**View, inspect, and copy text properties**

To inspect the text properties in an artboard, select a line of text. You can also copy text and its color from the Properties panel.

Adobe XD is unit-less and focuses on the relationships between objects. For example, if you design an iPhone 6/7 artboard at 375 x 667 units, and it uses text with a 10 unit font size, that relationship remains the same, no matter what physical size the design is scaled to.

However, design specs append the default units like px, pt, and dp to the base unitless measurements, according to the platform, so that you can understand the measurements with the platform you are developing for. You can also change the unit of measurements from one unit to another in design specs.
Changing the unit of measurements

**View and inspect sub-range text**

If you have a text element with multiple styles, you can hover over sub-ranges within a text element. Design specs then highlights similar sub-ranges inside the text element with the same styles and lets you access their individual properties from the Properties Inspector.

**View and copy CSS snippets**

You can view and copy the CSS code of your design from the CSS snippets section. The CSS code is automatically generated when you select Web as an output destination in the Share for Development window when publishing design specs.

To copy and paste the code snippet into your CSS files, press and drag the CSS snippets, switch to your code editor, and paste it.
CSS snippets

View and inspect layout grid properties

To view layout grids, toggle on Layout Grids in the Property Inspector. This option activates the layout grids for all artboards in the design specs.

Use the toggle button to remove layout grids from the artboard. Use the Opacity slider to control the transparency of the layout grid.

If you have set the parameters within Layout Grids, hover the pointer over those parameters to highlight them in the displayed artboard.

Note:

Design specs do not display square grids.

Before you publish a design specs link, ensure to enable layout grids in the relevant artboards. By default, if you have not used layout grids in your designs, they do not appear in the design specs link.
Layout grid properties

View and inspect overlays

In the design specs view, you can inspect the overlay connections in the UX flow screen.

To inspect the applied overlays, navigate to the **Interactions** section in the **Properties** Inspector and click the displayed artifact, or press **Shift** and click the hotspot in the design specs.

View and inspect overlays

You can inspect artboard details, styles, and target information for the applied overlay:

- **Viewport size**: Displays the dimensions of the visible area, which changes based on the size of the device used to access the page.
- **Design size**: Displays the design dimensions of the artboard.
• **Overlay position**: Displays the position of the overlay with reference to the source artboard in **px**, **pt**, and **dp** formats.

• **Colors**: Displays the colors in **RGBA**, **Hex**, and **HSLA** formats.

• **Character Styles**: Displays the character styles in **px**, **pt**, and **dp** sizes. The format of the overlay position changes based on the character style you set.

• **Interactions**: Displays information about the interactions and actions associated with the target artboard.

To revert to the source artboard, press **Esc** or click **Close Overlay** on the screen.

**View and inspect fixed objects**

In design specs, fixed objects show a pin icon in their upper-left corner when you click them in the artboard.

![Inspect fixed objects](image)

**View and inspect hotspots**

To view hotspots defined in the artboard, press and hold the **Shift** key. To inspect a hotspot, click the displayed artifact in the **Interactions** section, or **Shift**-click the hotspot.

**Navigate design specs**

The share for development link has been made richer by including interactive prototype information along with design specs. Click the **View specs** toggle icon in the shared link to toggle between a design specs and prototype view. The new experience provides the following advantages:

• Designers can now efficiently communicate their design intent and provide all the resources developers need with a single shared link.
• Developers can understand interactions and intended behaviors better and save time by avoiding constant switching between separate prototype and design spec links.
• Developers can easily switch between grid and flow view to view the design specs.

**Grid view and flow view**

To get a holistic view of your design flow with all the artboard layout information, you can choose to switch between Grid and Flow views.

Efficient to navigate, the Grid view is a simple grid format of the artboard layout information, whereas the Flow view preserves the artboard layout and its architecture.

To navigate to default Grid view, click the link name or the grid icon in the upper left corner. To toggle between Grid view and Flow view, click the Flow view icon in the upper-right corner of the screen.
In **Grid view**, you can:

- View the thumbnail representation of all the screens,
- Number of comments on a given artboard,
- Search for a particular artboard by its name, and
- View the linked screens for a given artboard.

In the **Flow view**, you can:

- Communicate the design and layout hierarchy, and
- Hover over an artboard to view its linked artboards.

Do feel free to share your feedback on the new experience using Adobe XD user voice.

**Specs view**

The specs view shows the artboard details, colors, character styles, and targets used. You can use the collapsible arrow to expand and collapse individual sections.
In the Properties panel, you can view:

- Artboard details, unique colors and character styles used in that artboard, and the target artboard it is linked to.
- CSS code snippets for your designs developers can copy-and-paste right into their code.
- Instances where the colors and character styles have been used when you hover the pointer over.
- Hexadecimal color codes and custom labels for the colors used in the artboard.
- Details of various interactions such as transitions, blend mode properties, overlays, voice, interactions, and auto-animate.
- Comments related to the artboard.

At the bottom of the screen, there are arrow keys, and a Home icon. The left arrow key takes you to previous artboard, the right arrow key takes you to the next artboard while the Home icon takes you to the Home artboard.

For keyboard shortcuts specific to design specs, see Keys for Design Specs.

Note:

You can view the custom labels only if the designer has given the color label names in the Assets panel.

Specs view
Review and comment design specs

Design specs have the same commenting features as prototypes. You can comment on design specs, use a commenting pin to pin the exact location of the comment, and move the pin if necessary. A commenting notification email sent to other collaborators provides a direct contextual link to the relevant artboard and not just the home artboard. Their responses are reflected when you refresh your browser.

Review workflow

1. To pin or move your comments to indicate specific areas in the artboard, click **Place a pin**, and then click the specific location in the artboard.
Commenting on design specs
A Pinned comment  B Mention a collaborator  C Place a pin

2 Type in your comment and click Submit to submit the comment. You can also switch from a regular comment to a pinned comment. XD assigns a number to every pinned comment. The comments in the comments panel also reflect these numbers, allowing designers to easily identify the context of the comment.

3 Use @mention while commenting to call out specific collaborators to your feedback and notify them via email or Creative Cloud application. @mention provides hints of their names based on the invite settings set in the Publish dialog box while designers share design specs.

4 Select Cancel to cancel an added comment in the comments panel.

5 To view the comments that have been marked as resolved, click the Filter icon, and select Resolved.

6 To keep your comments open if they are wrongly marked as resolved, click Move to Unresolved.
Chapter 5: Work with plugins

Plugins for Adobe XD

Adobe XD features plugins and app-integrations from Adobe and third-party developers that enhances your design workflow by automating complex and repeat tasks, and enabling deep integrations with external tools and services. For example, if you have a need to use Google Maps, you can install and use a third-party plugin to bring them into your XD project. Check out this Adobe Community post to know more about using Google Maps in XD projects.

XD also supports external integrations such as JIRA and in-app extensions to provide a complete solution for designers and stakeholders.

To view the list of plugins available for XD, Visit the Adobe XD resources page.

System requirements to get started with plugins

You need XD version 13.0 to view, manage, and build plugins. Plugin development and management are supported on both Windows and MacOS platforms.
View and install plugins

Use any of the following options to view and install plugins:

- In the home screen, select Add-ons > Plugins to launch the Plugin panel.
- Click the Plugins icon on the Toolbar, and select Discover Plugins, or click the + icon to launch the Plugin panel.

From the Plugin panel, you can view, launch, install, and update plugins.
Do more with XD.

Discover  You can find the featured collections, essential plugins, and categories of XD such as collaboration, tools. Collections are the curated plugins that are categorized based on certain themes such as connecting your tools, designing with real data.

Browse You can browse and filter plugins by Category, Most Recent, Top Rated, and Most Popular. You can rate a plugin only when you install one.

Manage You can view the list of all plugins that are installed in your system. Sort the plugins based on Name or Last Updated options. Click the ellipsis (...) icon on a plugin to disable or uninstall.
Create plugins

To get started with plugins, select Plugins > Development > Create a Plugin that leads you to the Adobe I/O developer console.

For information on how to get started with building, testing, and submitting plugins for an in-app listing, see Adobe XD developer documentation.

Troubleshooting plugin-related issues

To resolve troubleshooting issues, use the Get Support option within plugins to reach out to the plugin developer.

To verify if the troubleshooting issues are exclusively related to plugins:

- Use the Disable option in the Plugin panel to manually disable each installed plugin, or
- Hold down the Shift key when launching XD to temporarily disable all plugins.

Create and manage plugins

Last updated 11/6/2019
Create plugins

Select Plugins > Development > Create a Plugin that leads you to the Adobe I/O developer console.

For more information on how to build, test, and submit plugins, see Adobe XD developer documentation.

View and install plugins

1 To view the available plugins for installation, select Plugins > Discover Plugins or click the Plugins icon on the Toolbar. Further, click the Discover Plugins (+) icon to launch the Plugin panel.

2 In the Plugin panel, click the Browse tab and use the search field to search for the list of available plugins for installation.

3 To install plugins, use any of the following options:
   • In the Plugin panel, choose the Browse tab, select the plugin, and click Install.
   • If you received a plugin package with the .xdx file extension, you can double-click on it to install.
Do more with XD.

Discover  Browse  Manage

Search Plugins...

All Categories  Most Popular

Redesigned plugin manager

4 To view and modify the properties of an installed plugin from within XD, select the **Plugins** icon from the toolbar. Select an installed plugin to display a modal window with the plugin actions and properties.

View plugin actions and properties

**Update plugins**

In the **Plugin panel**, go to **Manage** tab, click the installed plugins to view the version number of the plugin. If the plugin requires an update, an **Update Plugin** button appears. Click the **Update Plugin**.
Uninstall plugins
In the Plugin panel, select the ellipsis (…) next to the installed plugins and click Uninstall.

Get support and report abuse
• Click Get Support to get in touch with the developer for plug-in related queries.
• To report abuse through an email client application, click Report Abuse.
Chapter 6: XD for iOS and Android

Preview on mobile devices

Using the Adobe XD mobile app, you can:

• Connect your mobile device using USB to your computer running XD, edit your designs and prototypes on the desktop, and preview them in real time on connected mobile devices. For more information, see Preview prototypes in real time on mobile devices.

• Invite people to review your prototypes using a shareable private link. For more information, see Use private invites for web and mobile.

• Preview XD documents that you saved in your Cloud Documents folder from XD on Mac or Windows. View XD documents on your mobile device, and share them with others.

Note:

If your device is running Adobe XD on Windows 10, real-time preview through USB is not supported on Android.

Using a mobile browser, you can preview any published prototypes in a user-friendly manner, on the go.

Requirements to preview on a mobile device

To preview real time or by opening XD files from Creative Cloud:

• Adobe XD mobile app
  • iOS: Download from the iTunes app store.
  • Android: Download from the Google Play Store.

For a list of supported iOS and Android versions, see Adobe XD on mobile FAQ.

To preview published prototypes:

• Mobile browser.

For a list of supported mobile browsers, see Supported browsers.

Preview prototypes in real time on mobile devices

Preview your designs in real time on a mobile device connected to your computer using a USB cable.
1 Connect your mobile device to the USB port of the computer running Adobe XD on desktop. Make sure that you have installed the latest version of XD on desktop available on Creative Cloud.

**Note:**

*Ensure that you use USB cables that transfer data. Some USB cables can be used to only charge your devices and cannot transfer data.*

2 Open Adobe XD on your device.

3 The artboard that is currently selected (or in focus) in Adobe XD on desktop is displayed on your device. All the changes you make to your designs are reflected in real time on your mobile device.

If you add wires creating interactions in Prototype mode, you can see the interactions work, just like in the Preview window on desktop.

**Note:**

*Fonts are sent to your device when you preview on mobile. However certain font vendors do not allow for the transfer, display, and distribution of their fonts. You are responsible for ensuring that you respect the font license agreement between you and the font vendor.*

While viewing a prototype on mobile, if the required font is not present on your device, you get an alert message. The fonts are substituted with available fonts.

4 Use the triple tap gesture on the mobile app screen for more options:

- **Browse artboards**: To scroll through all the artboards in your design.
- **Share this screen as image**: To share a particular artboard as a PNG file through email, Slack, or other channels.
- **Hotspot hints**: To enable hotspot hints while viewing the prototype.
- **Swipe navigation**: To prevent you from swiping when interacting with a prototype.

**Note:**

*If you have enabled Accessibility > Magnification, use the two fingers double-tap instead of the standard triple tap.*
Preview XD documents saved as cloud documents

You can preview your XD documents by saving them as cloud documents on your desktop.

1. Make sure that your XD document is saved as a cloud document on your desktop.
2. Open Adobe XD on your mobile device.
3. In XD Documents, you can see all the XD documents in your Cloud Documents folder. You can search for files by filename, then sort them in ascending or descending order (alphabetical or last modified). After you find the file you want, tap on it to view the file.
4. While previewing, use the triple tap gesture to access the prototype options:
   - Browse artboards: To search and jump to the desired artboards in your design.
   - Share this screen as image: To share a particular artboard as a PNG file through email, social media, or any other sharing option provided by your device.
   - Hotspot hints: To enable hotspot hints while viewing the prototype.
   - Swipe navigation: To enable swiping when interacting with a prototype.

   Note:
   If you have enabled Accessibility > Magnification, use the two fingers double-tap instead of the standard triple tap.

5. After you have reviewed the design in your mobile app, you can share the prototype with reviewers.
   Before sharing the prototype, make sure that you have the hotspot hints are turned on. Triple tap the mobile screen and enable Hotspot Hints.
6. Share the prototype link with others through email, social media, or any other sharing option provided by your device. Triple tap the mobile screen and press Share for Review.

   Note:
   You can share a prototype only if it has been shared at least once before using the XD desktop application.

Delete downloaded XD files from your device

To control the storage space on your mobile device, you can delete downloaded files, by tapping Settings > Preferences.

Here you can view the amount of local space used, and then tap Remove Offline Documents to delete XD documents downloaded to your device.

You can also remove individual files by selecting the file and disabling the Available offline Option.

Preview published prototypes in mobile browsers

When you open a published prototype link in a mobile browser, you can view the prototype with a zoomed-in artboard.
If the artboards of the prototype are unlinked, swipe left or right to navigate from one artboard to the other.

You can also pinch on the zoomed-in artboard for a pan view.

Use the following options in the pan view:

- icon to navigate to the home artboard.
- arrows to navigate through the artboards.
- icon to the left of the Home icon with prototype name and date of creation.
- icon to the right of the Home icon to report abuse.
Note:

When you first open an XD prototype in a browser and the screen is idle for three seconds, it shows a pinch icon used to pinch in on the artboard for the pan view. The pinch icon does not reappear even if you open another published prototype.
Adobe XD on mobile FAQ

The Adobe XD mobile app enables you to preview your designs on iOS and Android devices.

Edit your design using XD on the desktop and see them reflected in real time on mobile devices connected through USB.

You can save XD documents as cloud documents (a new native file type that is accessible online or offline directly from inside the XD app) from within XD and retrieve them from Cloud Documents section in assets.adobe.com.

General information

- What is Adobe XD on mobile?

Adobe XD on mobile is a companion app that lets you preview your designs and prototypes on iOS and Android devices using the following modes:

  - Real-time Preview via USB (available on macOS and Windows 10 on iOS and only on macOS on Android): You can connect multiple devices via USB to your computer running Adobe XD, edit your designs and prototypes on the desktop, and preview them in real time on all the connected mobile devices. For previewing using an USB on Win 10, ensure that you install the latest version of iTunes on Win 10.

  - Loading Adobe XD Cloud Documents (available for documents created in Adobe XD on macOS or Windows 10): If you have XD documents saved as cloud documents on your desktop, you can load them onto your devices using Adobe XD on mobile.
• How can I get Adobe XD on mobile?
You can download Adobe XD for free from iTunes App Store or Google Play Store.

• Should I use Adobe XD on mobile along with Adobe XD on desktop?
• Yes, for Real-time Preview via USB (available on Adobe XD Desktop for macOS and Windows 10): Adobe XD on desktop sends data from the computer to the mobile device. All changes you make to your designs or prototypes are reflected on all USB-connected mobile devices. When you disconnect the USB cable, the process stops. To see your work again on your mobile devices, you must connect the devices to the computer running the desktop app of Adobe XD.

• Can I download Adobe XD on mobile for free?
Yes. On your mobile device, you can download Adobe XD for free from iTunes App Store for iOS (iPhones and iPads) or Google Play Store (Android phones and tablets).

• Do I need Creative Cloud account to use Adobe XD on mobile?
You need a Creative Cloud account to download XD desktop but you need not be logged into Creative Cloud to use the mobile application.

• In which countries is Adobe XD on mobile available?
Adobe XD on mobile is available in all countries supported by the app stores.

Use Adobe XD on mobile browser
• How do I add comments to shared prototypes on a mobile browser?
As a reviewer, you can add comments to a shared prototype on Android or iOS mobile browsers by using the steps below:

1. When you open a shared prototype in Mobile, a pinch gesture appears on the screen. Use the gesture to comment or navigate the prototype. A commenting panel appears at the bottom of the prototype.

2. Type the comment and tap on the plane icon to enter.

3. Long press on the pin in commenting panel and drag to place it anywhere in the prototype screen and add comment for a specific position.

You can use the commenting panel to add comment, delete comment, or reply to an existing comment. You can use @mentions option for private invites. For more information on adding comments or navigating prototypes, see Working with prototypes.

When you rotate screen horizontally, the commenting feature is not supported in Mobile. A pop-up message appears on screen prompting you to rotate back to normal mode.

• Can I invite collaborators to review my prototype?
Yes, you can invite collaborators from your mobile browser. Copy the private link from the desktop and open it in a mobile browser. Use the Invite option to invite collaborators. For more information, see Use private invites for web and mobile.

Use Adobe XD on mobile
• How do I learn to use Adobe XD on mobile? Where do I go for help and support?
For more help, see Preview on mobile devices.

If you do not find what you need, email us at xdmobilefeedback@adobe.com.

Last updated 11/6/2019
• **What are the steps to follow for previewing my work using Adobe XD on mobile using USB?**

Preview using Adobe XD on mobile using USB is available for documents open in Adobe XD on macOS and Windows 10. For more information, see Preview prototypes in real time on mobile devices.

• **What changes were made in XD 14 that affect how I save and access my documents in XD mobile?**

  - On the XD mobile app, **XD Documents** screen is now renamed as **Cloud Documents**.
  - On the XD desktop app, all new XD documents you create are auto-saved to Creative Cloud as cloud documents to prevent loss of your work. However, you have the option to save the document to your desktop as a non-cloud document, but the document will not auto-save.
  - Older XD documents created prior to XD version 14 must be **Saved As** cloud documents to be visible on the XD mobile app. You cannot move the documents to the **Creative Cloud Sync** folder on your desktop and convert them to new cloud documents. Instead, you must open the document in XD and **Save As** a cloud document.

  For more information on working with cloud documents in XD, see Cloud documents in Adobe XD and Manage and work with cloud documents in XD.

To learn more about the mobile experience when working with cloud documents, check out this video.

  Video

• **Can I unplug my USB cable or go offline on Adobe XD mobile? Can I still see my work created with Adobe XD?**

  (USB connection is available on Adobe XD on macOS and Windows 10)

Yes. The latest previewed XD document is cached on your mobile device, so you can unplug the USB and continue working on the previewed prototype. When relaunching the XD app, switch to Live Preview and see the latest prototype.

Large documents take some time to cache after unplugging. If you are previewing a large document and unplug your phone, killing the XD app right away prevents it from properly caching the document. To preview this document later, do not kill the app immediately.

• **Can I access and use my prototypes with Adobe XD on mobile while being offline?**

Yes. If you save your XD documents to Creative Cloud, you can download them for viewing later when offline.

  1. Open Adobe XD on your mobile device.
  2. In the **XD Documents** section, find the document you want to use offline and tap the ellipses (...) icon.
  3. Enable the **Available Offline** option.

This option downloads the file locally and makes it accessible without an Internet connection.

• **How do I browse the artboards of the current document I’m seeing using Adobe XD on mobile?**

When viewing a document with many artboards, after a triple tap, choose **Browse Artboards** to see all artboards as thumbnails for quick access. You can also search by artboard name to filter the results. Search and tap on the artboard you want to view.

• **How do I share the current screen I’m viewing as an image using Adobe XD on mobile?**

From any screen, use triple tap and choose **Share this Screen as Image**. Adobe XD on mobile creates an image and calls the share sheet on your device, so that you can share the image using any sharing service.

• **How do I enable or disable hotspot hints using Adobe XD on mobile?**

Guiding the user with hotspot hints can be beneficial when testing a prototype. After using the triple tap, you can activate and deactivate hotspot hints. If hotspots are enabled, when the user taps on a non-interactive area, all the interactive areas (like buttons) are highlighted in blue, to show the areas that can be tapped.
• **Which versions of iOS does Adobe XD support?**

Adobe XD for iOS works with 64-bit devices, with iOS version 11.0 or later installed. Here is a list of supported 64-bit Apple devices:

- iPhone: XR, XS, XS Max, X, 8, 8 Plus, 7, 7 Plus, 6, 6 Plus, 6S, 6S Plus, SE, iPhone 5S
- iPad: iPad (2018 and 2017), Air, Air2, mini 2, mini 3, mini 4, and iPad Pro (generations 1, 2, 3)

• **Which versions of Android do Adobe XD support?**

Adobe XD for Android works with devices that support Open GL ES 2.0, with Android 6.0 or later installed. Adobe has tested the Adobe XD app on the following Android devices:

- Samsung Galaxy S6, S7, S9
- HTC One M9
- LG G4
- Nexus 5X
- Nexus 6P

• **How many devices can I connect to Adobe XD on the desktop simultaneously using USB?**

(USB connection is available only on Adobe XD on macOS and Windows 10)

There’s no specific limit on the number of devices you can connect. If you decide to use a USB hub, Adobe cannot guarantee it’s going to work, mainly because these hubs manage connections themselves.

• **How do I connect using a USB connection?**

(USB connection is available only on Adobe XD on macOS and Windows 10; do note that android and windows are not compatible)

Plug your mobile device using a USB cable that transfers data, launch Adobe XD on desktop and on your mobile device, and then open a project with at least one artboard.

*Note:*

Real-time preview via USB is available only for users using Adobe XD on macOS and Windows 10.

• **Can I connect wirelessly?**

Currently, you cannot connect to Adobe XD on mobile wirelessly.

• **Can I swipe to navigate the artboards on my device?**

Yes, you can swipe regardless of interactions.

*Tip*: On desktop, to see all the wires at once, go to **Prototype Mode** and press Cmd + A (on Mac) or Ctrl + A (on Windows).

*Tip*: On desktop, in order to see all the wires at once, go to Prototype Mode and press **Cmd A**.

• **What should I do if the triple tap does not display the menu options?**

On Android, if **Accessibility > Magnification** is enabled, you can use two-fingers to double-tap instead of triple tapping.

• **Does Adobe XD on mobile support portrait and landscape orientations?**

Yes, it does.
• **How can I set up Android devices to preview Adobe XD projects?**

Make sure that your Android device is set to transfer data through the USB port, not transfer power (charging mode). To do so, set "USB configuration" on your device to "MTP (Media Transfer Protocol)" using the following steps:

1. Open an Adobe XD project on your computer and launch Adobe XD on your Android phone (make sure that your device is supported).
2. Connect your phone to the computer using a USB cable that transfers data; some USB cables only charge your phone.
3. On your Android device, tap the topmost part of the screen and slide down to open the notification panel.
4. Tap Connected as a media device or Connected as a Camera.
5. Select Media device (MTP).

You can change the setting at a later point in time by opening Settings > Developer Options (see [how to enable Developer Options](#)) > Networking > Select USB Configuration > MTP (Media Transfer Protocol).

• **What is this window I see every time I connect my Android device to my desktop, saying "Open Adobe XD when this USB accessory is connected"?**

When you open Adobe XD on Android for the first time and connect your device through USB, you see a pop-up window with the message **Open Adobe XD when this USB accessory is connected**. Tap OK for the connection to work. If you tap CANCEL, the connection does not work and you have to reinstall the app on Android or change permissions.

• **Does Adobe XD on mobile support text transformations and text strikethrough?**

Yes, you can view the text transformations (uppercase, lowercase and title case), and the text strikethrough features when you preview a prototype on mobile.

• **How can I preview a prototype with keyboard shortcuts or gamepad keys in mobile?**

Keyboard and gamepad shortcuts are not supported on XD mobile. When you preview a prototype with keyboard or gamepad keys on mobile, XD shows a dialog box showing that the keys are not supported on mobile, and you can tap to navigate through the prototype.
Work with cloud documents

- Will cloud documents change how I access XD documents through the XD mobile app and the Creative Cloud mobile app?

  Yes. The XD mobile app retrieves cloud documents from a destination called Cloud Documents hosted on Creative Cloud. To access your XD documents, open your XD files from the XD desktop app and save them as cloud documents. Your files appear in the XD mobile app in the Cloud Documents section. The Creative Cloud mobile app currently does not support cloud documents.

  For more information, see Manage and work with cloud documents.

- Will XD display my documents saved in Creative Cloud file format?

  Adobe XD has changed the cloud sync workflow from CreativeCloud Files to Cloud Documents. The mobile app will no longer display documents saved as Creative Cloud Files.

  To view cloud based documents on mobile, open those documents on Mac or Win XD 14.0 and re-save them as Cloud Documents. You can use the Shared with You tab to view the documents that have been shared with you.

  For more information on Cloud Documents, see Cloud documents in XD.

- How do I save my existing XD documents as cloud documents?

  Designers need to open documents from XD desktop and save them as cloud documents. For more information, see Cloud documents in Adobe XD.
Windows 10

- Does Real-time Preview via USB work on Windows 10?
  Yes; but not with Android devices.

Troubleshooting

- Why some of my fonts are not being transferred to the mobile device?
  Fonts are not transferred to your device because of any of the following reasons:
  - The font is missing on desktop.
  - Certain font vendors do not allow for the transfer, display, and distribution of their fonts.
  - Adobe XD on mobile does not support the format (for example, PostScript type 1 fonts).
  You are responsible for ensuring that you respect the font license agreement between you and the font vendor.

- Why am I getting the message "The downloaded file has no artboards. Please add an artboard on desktop XD" when I attempt to open certain files on mobile (iOS)?
  Adobe has released an improved XD file format that is incompatible with older XD versions (1.2.2 and below).
  Update to the latest XD for iOS version (1.2.3 or above) to open all files.

- Why am I unable to open certain files on mobile (Android)?
  The latest XD file format is incompatible with older XD versions (1.2.2 and below). Update to the latest XD for Android version (1.2.3 or above) to open all files.

Feedback

- How do I provide feedback regarding Adobe XD on mobile?
  You can provide feedback to us in the following ways:
  - XD support community
  - Twitter, using the hashtag #AdobeXD.

- How do I suggest a feature request?
  You can influence the future of Adobe XD on desktop and on mobile! At anytime, you can suggest a feature request using the Adobe XD site on UserVoice, or upvote on existing ones. When Adobe updates the status of the feature (for example, "feature-completed"), you get an email with the update.

- How do I file a bug?
  You can file bugs on the Adobe XD site on UserVoice, or upvote on existing ones. When Adobe updates the status of the bug (for example, "bug-fixed"), you get an email with the update.
Chapter 7: Adobe XD and Creative Cloud

Adobe XD and Creative Cloud - an overview

XD works seamlessly with Creative Cloud to help you save time and get the job done.

You can bring in your work from Photoshop, Illustrator, and InDesign or Creative Cloud Libraries for Adobe XD

Assets added to Creative Cloud libraries from XD can be used across other Creative Cloud applications. Similarly, you can use assets from other Creative Cloud applications in XD. Assets include raster or vector graphics, colors, components, character styles, and so on.

Creative Cloud libraries help you achieve consistency across your projects by updating any changes to Work with linked assets across project files.

You can put your XD documents into Creative Cloud Files to access from other computers or from your mobile device. Or else, you can manage all of the shared prototypes that you’ve created from an XD document.

Reuse creative assets in XD

Creative Cloud Libraries provide a mechanism to share design assets between various apps - for example, Work with external assets.

Saving design assets created in Photoshop or Illustrator to Libraries allows you to access them in XD and add them to your artboards.

In XD, open the Creative Cloud Libraries window, and single click a character style, or a color to apply it to a selected object. To add a raster graphic to your artboard as a linked graphic, drag it from the Libraries window.

For more information on bringing in assets using Creative Cloud Libraries, see Creative Cloud Libraries for Adobe XD.

Note:

Currently, XD supports bringing in images (both raster and vector), colors, and character styles from Creative Cloud Libraries.

Using Creative Cloud Files with XD

You can also use the Creative Cloud ecosystem to store and manage your prototypes. For example, if you save a prototype in your Creative Cloud Files folder on your desktop, it is automatically available on the Cloud. The prototype can then be accessed from your mobile device (using the Adobe XD mobile app).

Share and collaborate

Prototypes that you share for review are also stored in the cloud. When you share a prototype with users for review, XD stores the prototype on the cloud, and sends you a link that you can share with stakeholders.

Stakeholders get to review your project and annotate it with their feedback - allowing for quick turnover in design, and transparent communication between designer and stakeholders.
Adobe XD and Creative Cloud

For more information on the sharing workflow, see Share designs and prototypes.

**Creative Cloud Libraries for Adobe XD**

XD makes it easy for you and your teams to use assets that are shared using Creative Cloud Libraries. You can add colors, character styles, and components from XD to Creative Cloud Libraries and readily use them within other apps such as Photoshop and Illustrator. Similarly, you can bring colors, character styles and graphics from these apps into XD using Creative Cloud Libraries.

To use Creative Cloud Libraries, make sure that you use the same Adobe account for all the CC apps.

**Add assets from XD to Creative Cloud Libraries**

You can add assets colors, character styles, components, and graphics from XD to Creative Cloud Libraries. Follow the steps below to add assets to CC Libraries:

1. In the **Design** mode, open the CC Libraries window using one of the following options:
   - Open the **Assets** panel and click the CC Libraries icon.
   - On macOS, select **File > Open CC Libraries**. On Windows, click the hamburger menu, and select **Open CC Libraries**.
2. In the **CC Libraries** window, click the ellipsis (···) and select **Create New Library**. If you want to access an existing library, select the library from the Libraries drop-down list.
3. To add assets from XD to your Creative Cloud Library:
   - Select the element on your artboard that has the color, the character style or the component.
   - Click the + icon in the **CC Libraries** window, and click the asset type you want to add. The selected asset type is added and is displayed as a thumbnail image in CC Libraries.

Your Creative Cloud Library assets are automatically synced to the cloud and will be available for use in other Adobe apps. For example, in Photoshop, you can go to Creative Cloud Libraries and access your XD assets.
To share your library with other users, click the ellipsis ( ... ) > Collaborate in the CC Libraries window. For more information on sharing libraries with others, see Collaborate on Creative Cloud Libraries and folders.

**Organize library assets in groups**

After you add your assets into the Creative Cloud Libraries, you can create groups to further organize and keep the related assets together. For example, you can group related components together such as buttons, toggles and modals that will make it easier to discover assets. You can also create groups for a mix of asset types to match your branding requirements. It is a good practice to use groups to more efficiently organize your creative assets.

**Use assets from Creative Cloud Libraries in XD**

You can use colors, gradients, character styles, graphics and components from Creative Cloud libraries in your XD projects.

- Apply colors and character styles
- Use graphics
- Use XD components

**Apply colors and character styles**

Click + to add colors, character styles, or components.

1. To apply a color or a color stroke (border) from a CC Library, select an element on your artboard, and do one of the following:
   - Click the thumbnail of the library color that you want to apply from the CC Libraries window.
   - Right-click and select **Apply Fill Color**. Select **Apply Stroke Color** for a color stroke.

Link
2. To apply a character style, select the text element on your artboard, and do one of the following:
   - Click the character style in your CC Library.
   - Right-click and select Apply Character Style.

**Use graphics**

You can bring graphics from Creative Cloud Libraries into your XD project by dragging them onto your artboard. You can edit both raster graphics (images) and vector graphics. The image is, by default, added to the artboard as a linked image. This means that any modification made to the asset affects all its linked copies.

You can resize this image and edit its properties in the Property Inspector without affecting the original image. To make further edits without affecting the original image, you need to unlink it.

To bring graphics from Creative Cloud Libraries as unlinked assets, press Alt (on Windows) or Option (on Mac) while dragging it from CC Libraries.

To change a graphic from a linked to an unlinked asset, click the green link icon at the upper left corner of the asset. You can also right-click the image and select Unlink Graphic from the Property Inspector.

**Edit graphics in Creative Cloud Libraries**

To edit a graphic in Creative Cloud Libraries, right-click the graphic in your Creative Cloud Libraries and select Edit. Raster graphics open in Photoshop, and vector graphics open in Illustrator. Make the changes to your graphics and save them.

The graphic is updated in the Creative Cloud Library, and the thumbnail in the Creative Cloud Libraries panel in XD is automatically refreshed. The image on the artboard is also refreshed with your changes.

**Use XD components**

You can bring components from Creative Cloud Libraries into your XD project by dragging them to your artboards. A new master component is added to the artboard every time you drag a component from CC Libraries to XD and will be displayed in the Assets panel.
1. Open the Creative Cloud Libraries window from the Assets panel (click icon).

2. Select the component that you want to use from the CC Libraries and drag it to an artboard. A new master component is added to the artboard and is displayed in the Assets panel. Note that the component instances are currently not linked to the source component, so any changes you make to the component in XD will not affect the source component in the Creative Cloud Libraries.

**Limitations**

- You cannot edit colors or character Styles in Creative Cloud Libraries in XD.
- You cannot edit graphics or components that are added from XD to Creative Cloud Libraries.
- When you add a component to a CC Library, only the active component state will be added.
- The component instances are not linked to the component in your Creative Cloud Library. So the changes you make to the master component in your XD document will not affect the component stored in your Creative Cloud Libraries.

For more information on how you can use Creative Cloud Libraries for greater efficiency and collaboration, see:

- Manage assets with Creative Cloud Libraries
- Share assets using Creative Cloud Libraries
Chapter 8: Adobe XD and Cloud Documents

Cloud documents in Adobe XD

Saving your work as cloud documents helps you share, collaborate, and access your work from multiple devices.

![Access cloud documents from the XD Home screen](image)

Cloud documents ensure that your work is always updated, across every device, wherever you are, with full fidelity.

You can access cloud documents from the XD Home screen or the Cloud Document Organizer or from the Creative Cloud website.

Why cloud documents?

- **Access files across devices**: Save your XD design as a cloud document and access it at your desk, laptop, or mobile devices. It’s in the cloud wherever you design.

- **Simple and efficient asset utilization**: Use Work with linked assets to share and reuse design elements across design systems, or ensure brand consistency across your designs. No boundaries for your documents or your creativity!
Work offline
Download your cloud documents to work offline. Your offline version automatically syncs when you reconnect. Remember that documents for coediting can't be offline.

Collaborate and share designs
Coedit and Share designs and prototypes for quick iterations. Share designs and prototypes on the go.

Locate past versions
Manage design revisions or view and open any version of your cloud document. Autosave keeps past versions ready at hand.

Organize, sync, & share work
Browse and organize your work in the My work tab. Then sync your files so that you can access them anywhere you are connected. See Sync Creative Cloud files.

Keep your files current
Keep your work up to date with the handy Autosave feature. You can pick up where you left off on any device. No more having to manually save your documents or losing unsaved worked.

Access cloud documents across mobile devices
Watch this tutorial to learn how cloud documents impact file management workflows in mobile devices.
Viewing time: 1 minute.
Video
Have a question or an idea?

We’ve got you started with cloud documents to help you collaborate, co-own, and co-design. You can take a step forward and learn how to Share designs and prototypes for review or how to bring in and edit assets before adding interactivity.

If you have a question to ask or an idea to share, come and participate in Adobe XD Community. We would love to hear from you and see your creations.

Troubleshooting issues with cloud documents

Experiencing issues with creating, saving, or opening a shared cloud document? Try out this resolution.

When you work on cloud documents, your work is kept in sync with the Creative Cloud sync process. Reboot the machine to check if Creative Cloud sync is running accurately or needs an update.

To update Creative Cloud Sync

1. Quit Adobe XD.
2. Open the Adobe Creative Cloud desktop app.
3. On Windows:
   - Open your Start menu.
   - Click Adobe Creative Cloud to launch.

   ![Launch Adobe Creative Cloud]

4. On macOS:
   - In Applications, go to Adobe Creative Cloud folder.
• Launch Adobe Creative Cloud.

Launch Adobe Creative Cloud in macOS

3. Click **Update** to execute any pending updates.

Click **Update** to execute pending updates

4. When the update is complete, navigate to **Help > About Creative Cloud** to verify that the Creative Cloud Sync version is 4.2.0.25 or later.
Follow these steps if the update was completed but version does not indicate the required version:

- Click the profile image and select Sign out.
- Quit the Creative Cloud desktop app.
- Relaunch Adobe Creative Cloud app.
- Sign back in using your Adobe ID.
- Verify Creative Core Sync version.

Follow these steps to verify that the following Creative Cloud preferences are enabled:

a. Click the gear icon in the upper-right corner to access Preferences.

b. Click General in the sidebar.

c. Ensure that Always keep Creative Cloud up to date (under Settings) is enabled.
Keep Creative Cloud app up to date

7 Relaunch XD or go to the next step to update the Creative Cloud desktop app.

8 Follow these steps to execute the Creative Cloud update:
   a Restart your machine and launch the Adobe Creative Cloud desktop app.
   b If the Update banner is still not available:
      1 Click Help > Check for updates.
      2 Wait for the update to complete.

For additional support and information, reach out to fellow designers at XD community.

Error 49 when saving a cloud document
Solution

1. Cancel the displayed Error 49 dialog box.

2. In XD, navigate to File > Save As and save the document as a new cloud document. Relink the cloud document if the cloud document was a source of another document component.

You can also reach out to fellow designers at XD community for additional support.