When you install Adobe Creative Suite 4, you receive the error message, "Setup has detected that you already have a more functional product installed. Setup will now terminate."


This message can occur when a more functional version of a product is already installed on the system on which Creative Suite 4 is being installed.


Restart the installation of Creative Suite 4, and choose to performa Custom Installation. When asked to select the products to install, de-select the product version for which a later or more functional version is already present on the system. For example, deselect Acrobat 9 Pro when Creative Suite 4 is being installed on a system where Acrobat 9 Pro Extended is installed.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy