Issue

When you try to install Adobe Creative Suite 4 or a Creative Suite 4 point product, you see the following error message:

"This application requires Adobe AIR to function. Please download the latest version of the runtime from http://www.adobe.com/go/getair, then launch the application again."

Details

The error can also appear in a language other than your system language or the application installer language.

This same error sometimes appears when running the AIR Installer downloaded from Adobe.com.

Running the Creative Suite 4 installer after a successful installation of the separate AIR 1.1 installer can result in the following error message:

"This application requires a version of Adobe AIR which is no longer supported. Please contact the application author for an updated version."

Solution

Try one or more of the following workarounds:

Solution 1: Change the Mac OS International Languages list.

  1. Choose System Preferences from the Apple menu.
  2. Select the International icon.
  3. Click Edit List.
  4. Change the languages list. For example, add or remove a language from the list.

  5. Rerun the installer.

Solution 2: Run the CS4 clean script, then reinstall.

For more information, see "CS Cleaner Tool for installation problems".

Solution 3: Install the Creative Suite 4 or CS4 application without AIR, and then download and install AIR separately.

  1. In the Creative Suite 4 installer, choose Custom Install.
  2. Deselect the following items:
    • Adobe AIR
    • Acrobat.com
    • Adobe Media Player
  3. Complete the installation.

Note: You can silently deploy AIR on its own at a later time. For more information, see the Adobe AIR Administrator's Guide (http://www.adobe.com/go/learn_air_admin_guide_en).

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy