Learn to identify and resolve common issues like missing fonts, modified images, text formatting, and more to ensure your documents display as intended.

What you'll need

This sample file contains assets provided by Adobe Stock for your tutorial practice purposes only. Check out the ReadMe file in the folder for the terms of use for this file. Adobe Stock has millions of royalty-free images and videos for your commercial use. You can get 10 images with a free month trial.

What you learned: Common factors that affect appearance and how to use the Preflight panel to identify potential issues

Top issues to check for

Before sharing or printing your document, take a moment to ensure it is error free. That means no missing fonts, missing or modified images, spelling errors, hidden text, and more. 

Checklist for avoiding common issues:

  • Check your spelling! To spellcheck your document, choose Edit > Spelling > Check Spelling.
  • Make sure your images aren’t missing or modified in the Links panel (Window > Links).
  • Check for missing fonts. When you first open a document you will be alerted to missing fonts. Get those fixed so the text looks the way you intended.
  • Make sure all of the text is visible. 

Use Preflight to automate error checking

You can also let InDesign automate the bulk of those checks for you using the Preflight panel. As you work, InDesign can check your document for issues in the background. Here’s how it works:

  • In the status bar, below the document, with Preflight on (by default), you’ll see a green or red circle. Green is good, red means issues. InDesign checks for basic issues defined in a preflight profile.
  • If you see red, to see the issues, click the arrow to the right of the error message (green or red circle and message) and choose Preflight Panel (or choose Window > Output > Preflight). 
  • In the Preflight panel, click page numbers to see where issues are and fix them in the document manually. 
  • You can choose what is checked in the document by choosing Define Profiles in the previous menu. Create a new profile and select errors to check for.

Tips for using Preflight

Change the preflight profile that InDesign uses to check for errors from the menu at the top of the Preflight panel or in the Status bar below the document.

Embed a preflight profile in the document so others can use it! In the Preflight panel, click Embed Selected Profile to embed it. You can’t embed the default profile since everyone already has it in their version of InDesign.

04/07/2021

Adobe Stock contributors: adogslifephoto, ink drop, Wavebreak Media

Presenter: Brian Wood

Was this page helpful?