Aplikace Acrobat při distribuci formuláře automaticky vytvoří portfolio PDF ke sběru dat zaslaných jednotlivými uživateli. Tento soubor je standardně ukládán do stejné složky jako původní formulář a je pojmenován název souboru _odpovědi. Tento soubor můžete použít ke zpracování vrácených formulářů.

Adobe recommends

Adobe recommends
<A href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">Výukový video program: Správa dat formuláře</a>
Timothy Plumer, Jr.

Sběr dat od uživatelů

  1. Po odeslání formuláře uživatelem otevřete vrácený formulář.
  2. V dialogovém okně Přidat vyplněný formulář do souboru odpovědí vyberte jednu z následujících voleb:

    Přidat do existujícího souboru odpovědí

    Zpracuje data v souboru odpovědí, který byl vytvořen, když jste při distribuci formuláře použili průvodce Rozeslat formulář. (Pokud je to nutné, klepněte na tlačítko Procházet a vyhledejte soubor odpovědí.)

    Vytvoření nového souboru odpovědí

    Vytvoří nový soubor odpovědí s použitím vámi zadaného názvu a umístění.

Soubor odpovědí se otevře po klepnutí na tlačítko OK. Všechny vrácené formuláře přidané do souboru odpovědí se zobrazují jako dílčí soubory portfolia PDF.

Sběr dat z formuláře

  1. V aplikaci Acrobat vyberte možnost Nástroje > Formuláře > Další volby pro formulář > Sestavit vrácené formuláře.
  2. V dialogovém okně Sestavit data vyberte jedním z následujících způsobů soubor odpovědí PDF:
    • Klikněte na tlačítko Procházet a vyberte soubor odpovědí.

    • Zadejte cestu k souboru odpovědí.

  3. Klikněte na tlačítko Přidat soubor a přejděte na vrácený formulář.
  4. Opakujte předchozí krok tolikrát, kolikrát je potřeba k přidání více vrácených formulářů.

Po klepnutí na tlačítko OK jsou do souboru odpovědí přidána data z vybraných formulářů. Každý vrácený formulář se zobrazuje jako dílčí soubor portfolia PDF.

Přidání dat od uživatelů do již existujícího souboru odpovědí

  1. V aplikaci Acrobat otevřete soubor odpovědí.
  2. V levém navigačním panelu klepněte na volbu Přidat.
  3. V dialogovém okně Přidat vrácené formuláře klikněte na tlačítko Přidat soubor. Poté vyhledejte a vyberte vrácené formuláře a klepněte na tlačítko Otevřít.
  4. Pokud chcete přidat další vrácené formuláře z jiných složek, opakujte předchozí kroky. Až budete hotovi, klepněte na tlačítko OK.

Po skončení se každý přidaný formulář PDF v portfoliu PDF zobrazí jako dílčí soubor.

Export dat od uživatelů ze souboru odpovědí

Tímto postupem uložíte všechny záznamy v souboru odpovědí portfolia PDF do tabulky nebo do souboru XML.

  1. V Acrobatu otevřete soubor odpovědí a vyberte data, která chcete exportovat.
  2. V levém navigačním panelu klepněte na volbu Exportovat.
  3. V dialogovém okně Vyberte složku pro uložení souboru zadejte název, umístění a formát souboru (CSV nebo XML) pro data formuláře a poté klepněte na tlačítko Uložit.

Správa souborů s daty formulářů

Odpovědi z formuláře PDF můžete přesouvat z nebo do jiných formátů souborů, které veškerá data dokáží uchovat s mnohem menšími nároky na prostor než plnohodnotný soubor PDF.

Import dat do formuláře

V některých pracovních postupech jednotliví uživatelé zasílají vyplněné formuláře namísto úplných souborů PDF jako soubory obsahující pouze data. Tyto soubory nejsou ve formátu PDF, ale využívají jiný formát, jako například FDF nebo XML. Data zaslaná jednotlivými příjemci můžete prohlížet v kontextu souboru PDF tak, že otevřete originální soubor a provedete import údajů v datovém souboru.

  1. V aplikaci Acrobat otevřete formulář PDF, do kterého chcete importovat data.
  2. Vyberte volbu Nástroje > Formuláře > Vymazat formulář.

    Poznámka:

    Když importujete data z jiného souboru do formuláře PDF, nahradí importovaná data veškeré údaje, které se dříve vyskytovaly v jednotlivých polích formuláře. Pokud však soubor s importovanými daty obsahuje jedno nebo více prázdných polí formuláře, import původní data nevymaže.

  3. Vyberte možnost Nástroje > Formuláře > Další volby pro formulář > Správa dat formuláře > Importovat data.
  4. V dialogovém okně Vyberte soubor obsahující data formuláře vyberte v nabídce Soubory typu formát souboru odpovídající datovému souboru, který chcete importovat. Poté tento soubor vyhledejte a vyberte a klepněte na tlačítko Otevřít.

    Poznámka:

    Některé formáty jsou dostupné pouze pro konkrétní typy formulářů PDF, v závislosti na aplikaci použité k vytvoření formuláře, jako je například aplikace Acrobat nebo Designer ES2. Data, která importujete z textového souboru (.txt) musí být ve formátu řádků s hodnotami oddělenými tabulátory tvořící sloupce.

Export dat souboru

Údaje ve vyplněném formuláři PDF můžete uložit jako datový soubor v jiném formátu souboru. Později tato data můžete znovu použít k opětovnému vyplnění jiného formuláře se stejnými poli a jejich názvy.

  1. V aplikaci Acrobat otevřete vyplněný soubor s formulářem.
  2. Vyberte možnost Nástroje > Formuláře > Další volby pro formulář > Správa dat formuláře > Exportovat data.
  3. V dialogovém okně Exportovat data formuláře jako vyberte formát, ve kterém chcete data formuláře uložit (FDF, XFDF, XML nebo TXT). Poté vyberte umístění, zadejte název souboru a klepněte na tlačítko Uložit.

    Poznámka:

    Některé formáty souborů jsou dostupné pouze pro konkrétní typy formulářů PDF, v závislosti na tom, jak byl formulář vytvořen.

Sloučení exportovaných souborů dat do tabulky

Pokud chcete zpracovat data z formulářů, která ještě nejsou uložena v sadě dat, použijte následující postup.

  1. Vyberte možnost Nástroje > Formuláře > Další volby pro formulář > Správa dat formuláře > Sloučit datové soubory do tabulky.
  2. V dialogovém okně Exportovat data z více formulářů klikněte na tlačítko Přidat soubory.
  3. V dialogovém okně Vyberte soubor obsahující data formuláře vyberte v nabídce Soubory typu formát souboru (Datové soubory formulářů Acrobatu nebo Všechny soubory. Poté vyhledejte soubory formulářů, které chcete sloučit do tabulky, vyberte je a klepněte na tlačítko Otevřít.
  4. Dle potřeby opakujte předchozí krok pro přidání souborů s daty formuláře, umístěných v jiných umístěních.
  5. Klikněte na Exportovat. Poté vyberte vyberte složku a název souboru s tabulkou a klepněte na tlačítko Uložit.
  6. V dialogovém okně Postup exportu klepněte na volbu Zobrazit soubor a otevřete soubor s tabulkou nebo klepněte na volbu Zavřít dialog a vraťte se do aplikace Acrobat.

Poznámka:

Když jsou vrácené formuláře uloženy v souboru odpovědí, nejúčinnějším způsobem exportu údajů do tabulky je použití tlačítka Exportovat data v levém navigačním panelu pro soubor odpovědí portfolia PDF.

O nástroji Sledování formulářů

Nástroj Sledování můžete použít ke správě rozeslaných nebo přijatých formulářů. Nástroj Sledování umožňuje prohlížení a úpravu umístění souboru odpovědí, sledování, kteří příjemci odpověděli, přidávání dalších příjemců, zaslání e-mailu všem příjemcům a zobrazování odpovědí pro formulář.

Sledování formulářů

  1. V aplikaci Acrobat vyberte možnost Upravit > Volby pro formulář > Sledovat nebo Zobrazit > Sledování.

  2. V levém navigačním panelu rozbalte položku Formuláře.

  3. Vyberte formulář a proveďte jeden z následujících úkonů:

    • Chcete-li zobrazit všechny odpovědi formuláře, klikněte na volbu Zobrazit odpovědi.

    • Chcete-li upravit umístění souboru odpovědí, klikněte v části Umístění souboru odpovědí na volbu Upravit umístění souboru.

    • Chcete-li zobrazit původní formulář, klikněte na volbu Otevřít původní formulář.

    • Chcete-li odeslat formulář více příjemcům, klikněte na volbu Přidat příjemce.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online