Poznámka:

Kompletní seznam článků o zabezpečení najdete na stránce Přehled zabezpečení v aplikaci Acrobat a v obsahu PDF.

Proč redigovat nebo odstraňovat citlivý obsah?

Před distribucí PDF můžete zkontrolovat, zda dokument neobsahuje důvěrný obsah nebo soukromé informace, které by vás mohly prozradit jako jeho autora. Pomocí nástrojů Začernit a odstranit obsah (nazývaných také nástroje pro redigování) můžete odebrat nebo redigovat citlivé obrazy nebo text viditelný v PDF.

K vyhledání a odstranění skrytého obsahu z dokumentu PDF použijte funkci Odstranit skryté informace. Například pokud jste vytvořili PDF, v metadatech dokumentu je obvykle uvedeno vaše jméno jako jméno jeho autora. Také možná budete chtít odstranit obsah, který může nežádoucím způsobem změnit vzhled dokumentu. Mezi takové typy obsahu patří například JavaScript, akce a pole formulářů.

Redigování (začernění a odstranění) citlivého obsahu (Acrobat Pro)

Redigování je proces trvalého odstranění viditelného textu a grafiky z dokumentu. K odstranění obsahu můžete použít nástroje Začernit a odstranit obsah (také nazývané nástroje pro redigování). Na místech odstraněných položek můžete mít značky redigování, které vypadají jako barevné rámečky, nebo můžete nechat tyto oblasti prázdné. Můžete určit, aby se nad značkami redigování objevil vlastní text nebo kódy redigování.

Poznámka:

Pokud chcete najít a odstranit určitá slova, znaky nebo slovní spojení, použijte raději nástroj Hledat a odstranit text .

Text označený pro redigování (vlevo) a redigovaný (vpravo)
Text označený pro redigování (vlevo) a redigovaný (vpravo)

  1. Zvolte příkaz Nástroje > Ochrana > Označit pro redigování . (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

  2. (Volitelně) Chcete-li nastavit vzhled značek redigování, klikněte na Vlastnosti redigování. (Viz Změna vzhledu značek redigování.)

  3. Označte položky, které chcete odstranit, libovolným z následujících způsobů:
    • Poklepáním vyberte slovo nebo obraz.
    • Přetažením vyberte čáru, blok textu, objekt nebo plochu.
    • Stiskněte Ctrl a přetažením vyberte plochy stránky v naskenovaném dokumentu.

    Poznámka:

    Chcete-li vidět, jak budou vaše značky redigování vypadat, podržte ukazatel nad označenou oblastí.

  4. Chcete-li použít více položek kódu na jedno redigování, klepněte pravým tlačítkem na značku redigování a vyberte některou z voleb. Další informace viz Použití položek kódu na redigování.
  5. (Volitelné) Chcete-li opakovat značku redigování, klikněte na ni pravým tlačítkem a vyberte možnost Opakovat značky napříč stránkami. Tato funkce je výhodná, pokud se na témže místě na řadě stránek zobrazuje konkrétní záhlaví, zápatí nebo vodoznak.

  6. Pokud jste již dokončili označování položek, které chcete redigovat, tak pomocí možnosti Nástroje > Ochrana > Aplikovat redigování odeberte tyto položky a klikněte na OK.

    Položky nejsou z dokumentu trvale odstraněny, dokud ho neuložíte.

  7. Chcete-li pomocí funkce Odstranit skryté informace vyhledat a odstranit skryté informace v dokumentu, klikněte v tomto dialogovém okně na možnost Ano. V opačném případě klikněte na Ne.

  8. Zvolte Soubor > Uložit a určete název a umístění souboru. K názvu souboru se připojí přípona „_Redacted“. Nechcete-li přepsat původní soubor, uložte soubor s jiným názvem anebo na jiné místo.

Vyhledání a odstranění textu (Acrobat Pro)

Pomocí nástroje Hledat a odstranit text můžete najít a odstranit slova nebo slovní spojení v jednom nebo více souborech PDF obsahujících prohledávatelný text.

Poznámka:

Nástrojem Hledat a odstranit text nelze prohledávat zabezpečené (zašifrované) soubory PDF.

  1. Vyberte možnost Nástroje > Ochrana a potom zvolte nástroj Hledat a odstranit text . (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

  2. Určete, zda se má prohledat aktuální PDF, nebo všechny soubory PDF v jiném místě.
  3. Proveďte jeden z následujících úkonů:
    • Chcete-li vyhledat jen jedno slovo nebo slovní spojení, zvolte položku Jedno slovo nebo slovní spojení a zadejte požadovaný text do pole.
    • Chcete-li vyhledat více slov, vyberte Více slov nebo slovní spojení a potom klikněte na Vybrat slova. Zadejte každé slovo do textového pole Nové slovo nebo slovní spojení a klikněte na tlačítko Přidat. Můžete rovněž importovat textový soubor se seznamem slov nebo slovních spojení, které chcete vyhledat.
    • Chcete-li vyhledat vzorek (například telefonní čísla, čísla kreditních karet, e-mailové adresy, čísla sociálního pojištění nebo kalendářní data), klikněte na Vzorky. Zvolte jeden z dostupných vzorků. Můžete změnit jazykovou verzi těchto vzorků. (Viz Výběr jiné jazykové verze pro vzorky.)
  4. Klikněte na Hledat a odstranit text.

  5. Ve výsledcích hledání klepněte na znaménko plus (+) vedle názvu dokumentu, čímž zobrazíte všechny výskyty slova nebo slovního spojení. Pak vyberte výskyty, které chcete označit k redigování:
    • Chcete-li v seznamu vybrat všechny výskyty, klikněte na Zaškrtnout vše.
    • Chcete-li vybrat jednotlivé výskyty, klepnutím zaškrtněte pole u každého výskytu, který chcete redigovat. Kliknutím na text vedle zaškrtávacího pole zobrazte výskyt slova nebo slovního spojení na stránce.
    • Nechcete-li označit žádný z výskytů, zavřete okno Prohledat nebo kliknutím na Nové hledání začněte znovu.
    • Chcete-li označit celá slova nebo části slov (znaky) k redigování, vyberte příslušnou volbu v nabídce Volby značek redigování. U částí slov klikněte na možnost Nastavení a zadejte počet a umístění znaků k redigování. Redigování znaků se používá například tehdy, když hledáte určitý vzor, například čísla kreditních karet, a chcete, aby byla část čísla viditelná pro účely identifikace.
  6. Pokud jste vybrali výskyty, které chcete označit k redigování, klikněte na Označit zaškrtnuté výsledky pro redigování.

    Položky v seznamu, které jste vybrali, se zobrazí jako označené pro redigování.

    Poznámka:

    Pokud jste soubor neuložili, můžete vybrat značku redigování v dokumentu a stisknutím klávesy Delete ji odstranit. Značky redigování se stanou trvalými po uložení souboru.

  7. Chcete-li odstranit označené položky, klikněte na příkaz Nástroje > Ochrana > Aplikovat redigování a klikněte na tlačítko OK.

    Položky nejsou z dokumentu trvale odstraněny, dokud ho neuložíte.

  8. Chcete-li pomocí funkce Odstranit skryté informace vyhledat a odstranit skryté informace v dokumentu, klikněte na možnost Ano. V opačném případě klikněte na Ne.

  9. Zvolte Soubor > Uložit a určete název a umístění souboru. Nechcete-li přepsat původní soubor, uložte soubor s jiným názvem anebo na jiné místo.

Hledání a odstranění skrytého obsahu

Pomocí funkce Odstranit skryté informace vyhledejte a odstraňte z dokumentu nežádoucí obsah, například skrytý text, metadata, poznámky a přílohy. Při odstranění položek se z dokumentu automaticky odstraní i další položky. Mezi odstraněné položky patří digitální podpisy, informace o dokumentu přidané zásuvnými moduly a aplikacemi od jiných výrobců, a také speciální funkce umožňující uživatelům aplikace Adobe Reader recenzovat, podepisovat a vyplňovat dokumenty PDF.

Poznámka:

Abyste mohli před zavřením nebo odesláním e-mailem zkontrolovat každý soubor PDF, zda neobsahuje skrytý obsah, vyberte příslušnou možnost v předvolbách dokumentů pomocí dialogového okna Předvolby.

  1. Vyberte možnost Nástroje > Ochrana > Odstranit skryté informace. (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

    Pokud jsou nějaké položky nalezeny, zobrazí se v panelu Odstranit skryté informace dokument se zaškrtnutým políčkem vedle každé položky.

  2. Zkontrolujte, že jsou rámečky zaškrtnuté jen u položek, které chcete z dokumentu odstranit. (Viz volby Odstranit skryté informace.)
  3. Kliknutím na Odstranit odstraňte ze souboru vybrané položky a klikněte na OK.

  4. Zvolte Soubor > Uložit a určete název a umístění souboru. Nechcete-li přepsat původní soubor, uložte soubor s jiným názvem anebo na jiné místo.

Vybraný obsah bude po uložení souboru trvale odstraněný. Pokud soubor zavřete bez uložení, zopakujte tento proces a nezapomeňte soubor uložit.

Volby Odstranit skryté informace

Metadata

Metadata zahrnují informace o dokumentu a jeho obsahu, jako je jméno autora, klíčová slova a informace o copyrightu. Chcete-li zobrazit metadata, zvolte Soubor > Vlastnosti.

Přiložené soubory

K PDF lze jako přílohu připojit soubory libovolného formátu. Chcete-li si zobrazit přílohy, zvolte příkaz Zobrazení > Zobrazit/Skrýt > Navigační panely > Přílohy.

Záložky

Záložky jsou odkazy s reprezentativním textem, které se používají k otevření určitých stránek v PDF. Chcete-li si zobrazit záložky, zvolte příkaz Zobrazení > Zobrazit/Skrýt > Navigační panely > Záložky.

Poznámky a označení

Tato položka zahrnuje všechny poznámky přidané do PDF pomocí nástrojů pro poznámky a označování, včetně souborů přiložených jako poznámky. Chcete-li si zobrazit poznámky, vyberte podokno Poznámky.

Pole formulářů

Tato položka zahrnuje pole formulářů (včetně polí podpisů) a všechny akce a výpočty související s poli formulářů. Pokud tuto položku odstraníte, všechna pole formulářů se sloučí s obsahem dokumentu a už je nebude možné vyplňovat, upravovat ani podepisovat.

Skrytý text na stránkách

Tato položka označuje text v PDF, který je průhledný, zakrytý jiným obsahem, nebo má stejnou barvu jako pozadí.

Skryté vrstvy

Soubory PDF mohou obsahovat více vrstev, které mohou být viditelné nebo skryté. Při odstranění skrytých vrstev se tyto vrstvy z PDF odstraní a zbývající vrstvy se sloučí do jedné vrstvy. Chcete-li si zobrazit vrstvy, zvolte příkaz Zobrazení > Zobrazit/Skrýt > Navigační panely > Vrstvy.

Vložený index prohledávání

Vložený index prohledávání urychluje hledání v souboru. Chcete-li zjistit, zda PDF obsahuje index pro vyhledávání, zvolte možnost Zobrazení > Nástroje > Zpracování dokumentu > Správa vloženého indexu. Odstraněním indexů se zmenší velikost souboru, ale prodlouží se doba prohledávání PDF.

Odstraněný nebo oříznutý obsah

Soubory PDF v sobě někdy zachovají obsah, který byl odstraněn a není již viditelný, například oříznuté nebo odstraněné stránky nebo odstraněné obrazy.

Odkazy, akce a JavaScript

Tato položka obsahuje webové odkazy, akce přidané průvodcem akcí a kód JavaScriptu v dokumentu.

Objekty s přesahem

Tato položka obsahuje objekty, které se vzájemně přesahují. Těmito objekty mohou být obrazy (složené z obrazových bodů), vektorové grafiky (složené z cest), přechody nebo vzorky.

Výběr jiné jazykové verze pro vzorky (Acrobat Pro)

Lokalizované vzorky se zobrazují na panelu Hledání (Ochrana > Hledání > Odstranit text).

  1. Zvolte možnost Úpravy > Předvolby (Windows) nebo Acrobat > Předvolby (Mac OS).

  2. V levé nabídce Kategorie vyberte Dokumenty.

  3. Na ploše Redigování vyberte v nabídce Vybrat lokalizaci pro vzorky hledání a odstranění textu nějaký jazyk. Pak klikněte na OK.

Změna vzhledu značek redigování (Acrobat Pro)

Ve výchozím nastavení se kolem obrazů a textů označených k redigování zobrazí tenká červená čára a místo redigovaných obrazů a textů se zobrazí černá pole. Ještě před označením položek k redigování můžete nastavit výchozí vzhled značek redigování. Vzhled značek redigování můžete také změnit před použitím redigování.

Nastavení výchozího vzhledu všech značek

  1. Vyberte možnost Nástroje > Ochrana > Vlastnosti redigování. (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

  2. V záložce Vzhled vyberte volby, které chcete změnit, a pak klikněte na OK:
    • Klikněte na ikonu Barva výplně redigované oblasti a z palety Barvy vyberte barvu pro vyplnění rámečků, které nahradí odstraněné položky. Chcete-li nechat redigovanou oblast prázdnou, zvolte možnost Žádná barva.
    • Vyberte Použít překrytí textem, chcete-li vybrat vlastní text nebo volby kódu redigování. Vyberte písmo, velikost a zarovnání textu.
    • Vyberte možnost Vlastní text a zadejte text, který se má objevit ve zredigované oblasti.
    • Vyberte Kód redigování a pak buď vyberte kód ze stávající sady, nebo klikněte na Upravit a definujte novou sadu kódů nebo nový kód. (Viz Vytváření kódů a sad kódů redigování.)
    • Na ploše Vzhled značky redigování klikněte na ikonu Barva obrysu nebo Barva výplně nebo na obě. Na barevné paletě vyberte barvu pro obrazy a text, které označíte k redigování. Přesunutím posuvníku můžete upravit krytí barvy. Chcete-li nechat vybranou oblast prázdnou, zvolte možnost Žádná barva.

Vlastnosti pro redigování textu (Acrobat Pro)

Vlastní text

Text zadaný ve volbě Vlastní text se zobrazí přes značku redigování.

Písmo

Vlastní text se zobrazí s vybraným písmem.

Velikost písma

Vlastní text se zobrazí s písmem vybrané velikosti.

Automaticky přizpůsobit velikost textu podle oblasti redigování

Velikost vlastního textu se změní tak, aby se vešel do zredigované oblasti. Když je vybraná tato volba, má přednost před nastavenou velikostí písma pro překrývající text.

Barva písma

Vlastní text se zobrazí ve vybrané barvě, kterou můžete změnit klepnutím na vzorek barvy.

Opakovat překryvný text

Vyplní zredigovanou oblast potřebným množstvím výskytů vlastního textu beze změny velikosti písma. Pokud například jako vlastní text určíte písmeno x nebo pomlčku (–), tyto znaky se budou opakovat přes celou zredigovanou oblast.

Zarovnání textu

Zarovná text vlevo, vpravo nebo na střed.

Kódy redigování (Acrobat Pro)

Aplikace Acrobat používá k přetisku oblastí vybraných k redigování překryvný text. Jednou ukázkou textu překrytí je kód redigování, který se skládá z jedné nebo více kódových položek ze sady kódů. Aplikace Acrobat obsahuje kódové sady U.S. FOIA a U.S. Privacy Act, které můžete používat. K vytvoření překryvného textu můžete použít buď kódy nebo vlastní text. Rozdíl je v tom, že kódy redigování jsou textové položky, které můžete uložit, exportovat a importovat. Jedna sada kódů může obsahovat více kódů.

Poznámka:

V kódech se neuloží aktuální atributy textu překrytí jako součást definice kódu, například barvy, vlastnosti písma a opakování nebo velikost textu. Kódy pouze umožní opakované použití samotného textu překrytí při příštím spuštění programu a ostatními uživateli, se kterými sady kódů sdílíte. Další atributy kódu nastavíte v dialogovém okně Vlastnosti nástroje redigování.

Vytváření kódů a sad kódů redigování

  1. Vyberte možnost Nástroje > Ochrana > Vlastnosti redigování . (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

  2. Vyberte Použít překrytí textem.
  3. Vyberte kód redigování.
    • Chcete-li přidat více položek kódu do kódu redigování, vyberte nějakou položku v seznamu Položky kódu a klikněte na příkaz Přidat vybranou položku. Opakujte podle potřeby. Chcete-li odstranit položku kódu, vyberte možnost Odstranit vybranou položku.
    • Kliknutím na možnost Úpravy kódů můžete provést další změny.
  4. V dialogovém okně Editor kódu redigování klikněte na možnost Přidat sadu.

  5. (Volitelně) Do textového pole pod seznamem sad kódů zadejte nový název pro sadu a pak klikněte na příkaz Přejmenovat sadu.
  6. Klikněte na možnost Přidat kód, do textového pole pod seznamem kódů zadejte text, který chcete zobrazit jako text překrytí, a pak klikněte na možnost Přejmenovat kód.

  7. Zopakováním předcházejícího kroku přidejte další položky kódů do této sady kódů, nebo opakováním předcházejících tří kroků vytvořte další sady kódů a kódy.

Úpravy kódů a sad kódů redigování (Acrobat Pro)

  1. Vyberte možnost Nástroje > Ochrana > Vlastnosti redigování . (Nevidíte-li panel Ochrana, vyberte možnost Zobrazit > Nástroje > Ochrana.)

  2. Zvolte Použít překrytí textem a pak vyberte Kód redigování.
  3. Ze seznamu vlevo vyberte sadu kódů a klikněte na Upravit kódy.

  4. V dialogovém okně Editor kódu redigování proveďte libovolné z následujících úkonů:

    • Chcete-li odstranit sadu kódů a všechny položky kódů v této sadě, vyberte sadu kódů a klikněte na Odstranit sadu.
    • Chcete-li sadu kódů exportovat do samostatného souboru XML, který můžete znovu použít v dalších PDF nebo sdílet s ostatními uživateli, vyberte příslušnou sadu kódů. Poté klikněte na možnost Exportovat sadu, určete název a umístění souboru a klikněte na tlačítko Uložit.
    • Chcete-li importovat dříve uloženou sadu kódů, klikněte na Importovat sadu, najděte a vyberte tento soubor a klikněte na Otevřít.
    • Chcete-li přejmenovat sadu kódů, zadejte nový název do pole pod seznamem a klikněte na Přejmenovat sadu.
  5. Po vybrání sady kódů vyberte položku kódu, kterou chcete upravit, a proveďte jeden z následujících úkonů:

    • Chcete-li odstranit položku kódu, klikněte na Odstranit kód.
    • Chcete-li přejmenovat položku kódu, zadejte nový název do pole pod seznamem a klikněte na Přejmenovat kód.

Použití více položek kódů k jednomu redigování

  1. Klikněte pravým tlačítkem na značku redigování. Vyberte sadu kódů nebo položku kódu v seznamu ve spodní části kontextové nabídky.

  2. Vyberte sadu kódů ze seznamu ve spodní části kontextové nabídky a poté vyberte položku kódu z rozevírací nabídky. Po použití kódu se vedle položky kódu zobrazí zaškrtnutí.

  3. Chcete-li do redigování přidat další položku kódu, opakujte předchozí krok.

Podržením ukazatele na značce redigování si zobrazíte položky kódů oddělené čárkami.

Poznámka:

Chcete-li použít stejný kód na více redigování, nastavte před označením obsahu volbu Vlastnosti redigování. Na panelu Ochrana klikněte na možnost Vlastnosti redigování. Zvolte Použít překrytí textem, pak vyberte Kód redigování. Vyberte sadu kódů a položku kódu a poté klikněte na Přidat vybranou položku.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online