O souborech Flash

V aplikaci Flash Professional můžete pracovat s celou řadou různých typů souborů, z nichž každý slouží k určitému účelu:

  • Soubory FLA, se kterými převážně pracujete v aplikaci Flash Professional, obsahují základní média, časovou osu a informace skriptů pro dokument aplikace Flash Professional. Objekty médií jsou grafiky, texty, zvuky a videa, která tvoří obsah vašeho dokumentu v aplikaci Flash Professional. Časová osa slouží aplikaci Flash Professional k určení, kdy se mají určité objekty médií zobrazit ve vymezené ploše. Do dokumentů aplikace Flash Professional můžete přidat kód v jazyce ActionScript®, což vám umožní jemněji řídit jejich chování a zajistit, aby reagovaly na akce uživatelů.

  • Nekomprimované soubory XFL se podobají souborům FLA. Soubor XFL a další přidružené soubory ve stejné složce jsou prostě nekomprimovaný ekvivalent souboru FLA. Tento formát usnadňuje skupinám uživatelů pracovat na různých prvcích projektu Flash současně. Další informace najdete v části Práce s nekomprimovanými soubory XFL.

  • Soubory SWF, což jsou zkompilované verze souborů FLA, jsou soubory, které se zobrazují na webové stránce. Když publikujete soubor FLA, aplikace Flash Professional vytvoří soubor SWF.

    Formát souboru SWF v aplikaci Flash Professional představuje otevřený standard podporovaný i jinými aplikacemi. Další informace o formátech souborů aplikace Flash Professional viz www.adobe.com/go/flashplayer_cz.

  • Soubory AS jsou soubory jazyka ActionScript – pomocí těchto souborů můžete zachovat určité části nebo celé kódy jazyka ActionScript mimo soubory FLA, což je užitečné pro uspořádání kódu a také u projektů, ve kterých různí lidé pracují na různých částech obsahu aplikace Flash Professional.

  • Soubory SWC obsahují opakovaně použitelné komponenty aplikace Flash Professional. Každý soubor SWC obsahuje zkompilovaný filmový klip, kód v jazyce ActionScript a případně další zdroje, které daná komponenta vyžaduje.

    Poznámka: (Pouze verze Flash Professional CC) Soubory SWC nelze do aplikace Flash Pro naimportovat.

  • Soubory ASC slouží k ukládání ActionScriptu, který se bude provádět na počítači, na kterém je spuštěný Flash Media Server. Tyto soubory umožňují implementovat logiku na straně serveru, která slouží spolu s ActionScriptem v souboru SWF.

    Poznámka:Soubory ASC nejsou v aplikaci Flash Professional CC podporovány.

  • Soubory JSFL jsou soubory v jazyce JavaScript, jejichž pomocí můžete do vývojového nástroje Flash Professional přidávat další funkce.

Společnost Adobe doporučuje

Společnost Adobe doporučuje
<a href="http://goo.gl/1iL8L">Introducing Flash Professional (Představujeme aplikaci Flash Professional)</a>
Todd Perkins

Následující doplňková videa a výukové lekce ukazují práci s aplikací Flash Professional. Přestože mohou být v některých videích zobrazené aplikace Flash Professional CS3 nebo CS4, videa se vztahují i k aplikaci Flash Professional CS5.

Práce s jinými aplikacemi Adobe

Aplikace Flash® je navržena tak, aby mohla spolupracovat i s jinými aplikacemi Adobe, takže umožňuje širokou škálu kreativních pracovních postupů. Do aplikace Flash můžete přímo importovat soubory aplikací Illustrator® a Photoshop®. Také můžete v aplikaci Flash vytvořit video a upravit ho v aplikaci Adobe® Premiere® Pro nebo After Effects®, nebo můžete naimportovat video do aplikace Flash z kterékoli z těchto dvou aplikací. Při publikování souborů SWF můžete použít aplikaci Dreamweaver® k vložení obsahu do vašich webových stránek; také můžete aplikaci Flash spustit přímo z aplikace Dreamweaver za účelem úprav tohoto obsahu.

Otvírání souborů XFL

Počínaje verzí Flash Professional CS5 mají vytvořené soubory FLA interní formát XFL. Když v aplikaci Flash ukládáte soubor, výchozí formát je FLA, ale interní formát souboru je XFL.

Soubory ve formátu XFL mohou exportovat i jiné aplikace Adobe®, například After Effects®. Tyto soubory mají příponu XFL, nikoli FLA. Aplikace InDesign® umožňuje export přímo do formátu FLA, jehož interní formát je XFL. Díky tomu můžete na projektu nejdříve pracovat v aplikaci After Effects nebo InDesign a poté v práci pokračovat v aplikaci Flash.

Soubory XFL můžete v programu Flash otevírat a s těmito soubory můžete pracovat stejně jako se soubory FLA. Pokud soubor XFL otevřete v aplikaci Flash Professional, můžete tento soubor uložit jako soubor FLA i jako nekomprimovaný soubor XFL.

Následující výuková videa ukazují export z aplikací InDesign a AfterEffects do aplikace Flash prostřednictvím formátu XFL a FLA:

Otevření souboru XFL v aplikaci Flash:

  1. Exportujte svou práci jako soubor XFL v jiné aplikaci Adobe®, například InDesign nebo After Effects.

    Aplikace uchová v souboru XFL všechny vrstvy a objekty původního souboru.

  2. Vyberte v aplikaci Flash Professional volbu Soubor > Otevřít a přejděte k souboru XFL. Klikněte na Otevřít.

    Soubor XFL se v programu Flash otevře stejným způsobem jako soubor FLA. V časové ose se objeví všechny vrstvy původního souboru a v panelu knihovny se objeví původní objekty.

    Nyní můžete se souborem normálně pracovat.

  3. Chcete-li soubor uložit, zvolte volbu Soubor > Uložit.

    Aplikace Flash Professional vás v dialogovém okně Uložit jako vyzve, abyste tento nový soubor pojmenovali.

  4. Zadejte název a soubor FLA uložte.

Práce s nekomprimovanými soubory XFL

Nově ve verzi aplikace Flash Professional CS5 můžete zvolit, zda chcete pracovat se soubory aplikace Flash v nekomprimovaném formátu XFL. Tento formát umožňuje zobrazení jednotlivých částí neboli podsouborů, z nichž se soubor aplikace Flash skládá. Tyto části zahrnují:

  • Soubor XML, popisující soubor aplikace Flash jako celek.

  • Oddělené soubory XML, které popisují jednotlivé symboly Knihovny.

  • Dodatečné soubory XML, obsahující nastavení publikování, nastavení mobility a další.

  • Složky obsahující externí datové zdroje, například soubory bitmap, používané souborem aplikace Flash.

Pokud pracujete v nekomprimovaném formátu XFL, můžete povolit zpracování každé části souboru aplikace Flash samostatně, jinými pracovníky. Rovněž můžete pomocí systému správy zdrojů provádět správu změn provedených v jednotlivých podsouborech v rámci nekomprimovaného souboru XFL. Dohromady umožňují tyto schopnosti mnohem snadnější spolupráci na velkých projektech s více projektanty a vývojáři.

Použití služby Live update u souborů XFL

Pomocí služby Live update pro upravitelné datové zdroje nekomprimovaných dokumentů XFL můžete upravovat jakékoliv položky knihovny z nekomprimovaného dokumentu XFL, zatímco je dokument otevřený v aplikaci Flash. Změny v položce se v aplikaci Flash projeví po dokončení úprav položky v jiné aplikaci.

Postup při úpravě položky z nekomprimovaného dokumentu formátu XFL v jiné aplikaci:

  1. Uložte dokument Flash v nekomprimovaném formátu XFL.

  2. Ve vhodném editoru, například v aplikaci Photoshop, otevřete ze složky KNIHOVNA nekomprimovaného dokumentu XFL položku, kterou chcete upravit.

  3. Upravte položku a uložte změny.

  4. Vraťte se zpět do aplikace Flash Pro.

    Aktualizace položky se v aplikaci Flash okamžitě projeví.

Upravení souboru SWF z aplikace Dreamweaver v aplikaci Flash

Pokud máte nainstalované programy Flash i Dreamweaver, můžete vybrat soubor SWF v dokumentu aplikace Dreamweaver a použít Flash k jeho úpravám. Flash neupravuje soubor SWF přímo; upravuje zdrojový dokument (soubor FLA) a pak ho znovu exportuje do souboru SWF.

  1. V aplikaci Dreamweaver otevřete inspektor Vlastnosti (Okna > Vlastnosti).
  2. V dokumentu aplikace Dreamweaver proveďte jeden z následujících úkonů:
    • Klikněte na vyhrazené místo pro soubor SWF a tím ho vyberte; pak v inspektoru Vlastnosti klikněte na Upravit.

    • Klikněte pravým tlačítkem (Windows) nebo se stisknutou klávesou Apple (Macintosh) na vyhrazené místo pro soubor SWF a v místní nabídce vyberte příkaz Upravit pomocí aplikace Flash.

      Dreamweaver přepne do programu Flash, který se pokusí najít původní soubor Flash (FLA) pro vybraný soubor SWF. Pokud Flash nemůže najít původní soubor Flash, budete vyzváni, abyste ho vyhledali sami.

      Poznámka: Pokud je soubor FLA nebo SWF zamknutý, zpřístupněte soubor v aplikaci Dreamweaver.

  3. V programu Flash upravte soubor FLA. Okno dokumentu Flash ukazuje, že soubor měníte z aplikace Dreamweaver.
  4. Po dokončení úprav klikněte na Hotovo.

    Flash aktualizuje soubor FLA, znovu ho exportuje jako soubor SWF, zavře se a pak přepne zpátky do dokumentu aplikace Dreamweaver.

    Poznámka:

    Chcete-li aktualizovat soubor SWF a nechat aplikaci Flash otevřenou, v aplikaci Flash vyberte položky Soubor > Aktualizovat pro Dreamweaver.

  5. Chcete-li zobrazit aktualizovaný soubor v dokumentu, v aplikaci Dreamweaver klikněte na Přehrát v inspektoru Vlastnosti nebo stisknutím F12 zobrazte náhled stránky v okně prohlížeče.
  1. Spusťte aplikaci Flash.
  2. Na hlavní obrazovce aplikace Flash zvolte možnost Vytvořit nový > Soubor Flash (mobilní).
  3. Vyberte v aplikaci Device Central verzi přehrávače a skript jazyka ActionScript.
  4. Vyberte typ obsahu.
  5. Vyberte v seznamu Dostupná zařízení jedno nebo více cílových zařízení (nebo vyberte sadu nebo jednotlivé zařízení v seznamu Device Sets).
  6. Klikněte na Vytvořit.
  7. Přidejte obsah do nového dokumentu Flash.
  8. Chcete-li dokument otestovat, vyberte možnosti Ovládání > Testovat.

Vytvoření nového dokumentu

Můžete vytvořit nový dokument nebo otevřít dokument, který jste dříve v aplikaci Flash Professional uložili, a také můžete během práce otevřít nové okno. Můžete nastavit vlastnosti pro nové nebo existující dokumenty.

Vytvoření nového dokumentu

  1. Zvolte Soubor > Nový.
  2. Na záložce Všeobecné vyberte typ dokumentu Flash, který chcete vytvořit.
  3. Proveďte jeden z následujících úkonů:

Vytvoření nového dokumentu z předlohy

  1. Zvolte Soubor > Nový.
  2. Klikněte na záložku Předlohy.
  3. Ze seznamu Kategorie vyberte kategorii, ze seznamu Položky kategorie vyberte požadovaný dokument a klikněte na OK. Můžete vybírat ze standardních šablon dodávaných s aplikací Flash Professional nebo můžete zvolit předlohu, kterou jste uložili.

Otevření existujícího souboru

  1. Vyberte Soubor > Otevřít.
  2. V dialogovém okně Otevřít vyhledejte požadovaný soubor nebo zadejte k němu cestu do pole Jít na.
  3. Klikněte na Otevřít.

Zobrazení dokumentu, když je otevřeno více dokumentů

Když otevřete více dokumentů, záložky na horním okraji okna Dokument označují otevřené dokumenty a umožňují snadno mezi nimi přecházet. Tyto záložky se zobrazují jen tehdy, když jsou dokumenty v okně Dokument maximalizované.

  1. Klepněte na záložku dokumentu, který chcete zobrazit.

    Standardně se záložky zobrazují v pořadí, ve kterém byly vytvořeny. Přetažením záložek dokumentů můžete jejich pořadí změnit.

Otevření nového okna v aktuálním dokumentu

  1. Zvolte Okna > Duplikovat okno.

Nastavení vlastností nového nebo existujícího dokumentu

  1. Když je dokument otevřený, zvolte Změnit > Dokument.

    Objeví se dialogové okno Vlastnosti dokumentu.

  2. Chcete-li nastavit rozměry vymezené plochy, proveďte jeden z následujících úkonů:
    • Chcete-li velikost vymezené plochy určit v obrazových bodech, zadejte hodnoty do polí Šířka a Výška. Minimální velikost je 1 x 1 obrazový bod; maximální je 2880 x 2880 obrazových bodů.

    • Chcete-li velikost vymezené plochy přesně přizpůsobit místu využívanému obsahem ve vymezené ploše, vyberte možnost Přizpůsobení: Obsah.

    • Chcete-li nastavit velikost vymezené plochy na maximální dostupnou tisknutelnou oblast, vyberte možnost Přizpůsobení: Tiskárna. Tato plocha je dána velikostí papíru zmenšené o velikost okraje vybraného pomocí volby Okraje v dialogovém okně Vzhled stránky (Windows) nebo v dialogovém okně Okraje tisku (Macintosh).

    • Chcete-li nastavit vymezenou plochu na výchozí velikost 550 x 400 obrazových bodů, vyberte možnost Přizpůsobení: Výchozí.

  3. Chcete-li upravit polohu a orientaci 3D objektů ve vymezené ploše a zachovat jejich vzhled ve vztahu k okrajům vymezené plochy, vyberte možnost Přizpůsobit úhel 3D perspektivy za účelem zachování aktuální projekce scény.

    Tato možnost je k dispozici pouze v případě, že změníte velikost vymezené plochy.

  4. (Pouze CS5.5) Chcete-li automaticky změnit velikost obsahu ve vymezené ploše podle změny velikosti vymezené plochy, vyberte možnost Změnit velikost obsahu podle vymezené plochy.

    Tato možnost je k dispozici pouze v případě, že změníte velikost vymezené plochy. V předvolbách můžete zvolit, zda chcete změnit velikost obsahu v zamknutých a skrytých vrstvách. Další informace viz Nastavení všeobecných předvoleb.

  5. Chcete-li určit měrnou jednotku pro pravítka, která jsou zobrazeny na pracovní ploše, vyberte volbu z nabídky Jednotky pravítka. (Toto nastavení také určuje jednotky pro panel Informace.)
  6. Chcete-li nastavit barvu pozadí dokumentu, klikněte na položku Barva pozadí a vyberte požadovanou barvu z palety.
  7. V poli Kmitočet snímků zadejte požadovaný počet snímků animace za sekundu.

    U většiny animací zobrazovaných v počítači, zejména pokud se přehrávají z webu, stačí 8 snímků za sekundu (fps) až 15 fps. Když změníte kmitočet snímků, stane se nový kmitočet snímků výchozím pro nové dokumenty.

  8. (Pouze CS5.5) Chcete-li automaticky ukládat dokument v určeném časovém intervalu, vyberte možnost Automaticky uložit a zadejte počet minut mezi uloženími.
  9. Proveďte jeden z následujících úkonů:
    • Chcete-li nové nastavení použít pouze pro aktuální dokument, klepněte na tlačítko OK.

    • Chcete-li nové nastavení určit jako výchozí vlastnosti pro všechny nové dokumenty, klepněte na volbu Nastavit jako výchozí.

Změny vlastností dokumentu s použitím inspektoru vlastností

  1. Kliknutím na pracovní plochu mimo vymezenou plochu odznačte všechny objekty ve vymezené ploše. V inspektoru vlastností se objeví vlastnosti dokumentu. Chcete-li otevřít inspektor vlastností, vyberte (Okno > Vlastnosti).
  2. (Pouze CS5.5) V oddílu Publikovat zvolte pro svůj dokument verzi přehrávače Flash Player a verzi jazyka ActionScript. Pro přístup k dalším nastavením publikování klepněte na tlačítko Nastavení publikování. Další informace naleznete v tématu Nastavení publikování.

  3. V oddílu Vlastnosti zadejte u položky FPS (snímky za sekundu) počet snímků animace, které se mají přehrát každou sekundu.
  4. Chcete-li změnit velikost vymezené plochy, zadejte hodnoty pro šířku a výšku vymezené plochy.
  5. Chcete-li vybrat barvu pozadí vymezené plochy, klikněte na políčko barvy vedle vlastnosti vymezené plochy a vyberte barvu z palety.
  6. Chcete-li upravit další vlastnosti dokumentu, klepněte na tlačítko Upravit vedle vlastnosti Velikost. Další informace o všech vlastnostech dokumentu viz Nastavení vlastností nového nebo existujícího dokumentu.

Přidání metadat XMP do dokumentu

Do souborů FLA můžete zahrnout data Extensible Metadata Platform (XMP), jako je například název, autor, popis, autorská práva a další. XMP představuje formát metadat, který je srozumitelný určitým aplikacím Adobe®. Tato metadata lze prohlížet v aplikaci Flash Professional a in Adobe® Bridge. Další informace o metadatech XMP najdete v části o metadatech a klíčových slovech v nápovědě aplikace Bridge.

Poznámka: 32bitová verze nástroje Bridge není v aplikaci Adobe Flash Professional CC podporována.

Vkládání metadat zlepšuje schopnost webových vyhledávačů vracet smysluplné výsledky vyhledávání pro obsah aplikace Flash Professional. Vyhledávací metadata jsou založena na specifikacích formátu XMP (Extensible Metadata Platform) a ukládají se do souboru FLA ve formátu vyhovujícím standardu W3C.

Metadata souboru obsahují informace o jeho obsahu, stavu copyrightu, původu a historii. Metadata aktuálního souboru můžete zobrazit a upravit v dialogovém okně Informace o souboru.

V závislosti na vybraném souboru se mohou objevit následující typy metadat:

Popis

Obsahuje informace o autorovi, titulu, copyrightu a další.

IPTC

Zobrazuje upravitelná metadata. Umožňují přidat k souborům popisky a informace o copyrightu. Základní IPTC je specifikace, která byla schválena radou IPTC (International Press Telecommunications Council) v říjnu 2004. Od starší specifikace IPTC (IIM, staré) se liší v tom, že byly přidány nové vlastnosti, názvy některých vlastností byly změněny a některé vlastnosti byly odstraněny.

Data z fotoaparátu (EXIF)

Zobrazuje informace přiřazené digitálním fotoaparátem, včetně informace o nastavení fotoaparátu použitém při pořízení obrazu.

Video Data

Zobrazuje metadata pro video soubory, včetně poměru stran obrazových bodů, scény a záběru.

Zvuková data

Zobrazuje informace pro zvukové soubory, včetně umělce, alba, čísla skladby a žánru.

Mobilní SWF

Vypisuje informace o souborech SWF, včetně titulu, autora, popisu a copyrightu.

Historie

Obsahuje záznam změn provedených v obrazech v aplikaci Photoshop.

Poznámka: Aby se záznam ukládal do metadat souboru, musí být v aplikaci Photoshop zapnuta předvolba Záznam historie.

Version Cue

Vypisuje jakoukoli verzi souborů aplikace Version Cue.

DICOM

Zobrazuje informace o obrazech uložených ve formátu DICOM (Digital Imaging and Communications in Medicine).

Přidání metadat:

  1. Zvolte příkaz Soubor > Informace o souboru.
  2. V zobrazeném dialogovém okně Informace o souboru zadejte metadata, která chcete zahrnout. Metadata můžete kdykoliv přidat nebo odebrat v souboru FLA.

Ukládání dokumentů Flash

Dokument FLA aplikace Flash Professional můžete uložit s aktuálním názvem a umístěním nebo s jiným názvem či umístěním.

Když dokument obsahuje neuložené změně, v titulním pruhu dokumentu, v titulním pruhu aplikace a v záložce dokumentu se za jeho názvem zobrazí hvězdička (*). Jakmile dokument uložíte, hvězdička zmizí.

Uložení dokumentu Flash ve výchozím formátu FLA

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li přepsat aktuální verzi na disku, zvolte Soubor > Uložit.

    • Pokud chcete dokument uložit na jiné místo a/nebo pod jiným názvem nebo pokud ho chcete komprimovat, zvolte Soubor > Uložit jako.

  2. Jestliže jste zvolili Uložit jako nebo pokud dokument ještě nebyl nikdy uložen, zadejte název souboru a umístění.
  3. Klikněte na tlačítko Uložit.

Uložení dokumentu v nekomprimovaném formátu XFL

  1. Zvolte Soubor > Uložit jako.
  2. V nabídce Uložit jako typ zvolte možnost Nekomprimovaný dokument aplikace Flash CS5 nebo CS5.5 (*.xfl).
  3. Zvolte název a umístění souboru a klikněte na Uložit.

Obnovení naposledy uložené verze dokumentu

  1. Zvolte Soubor > Obnovit.

Uložení dokumentu jako předlohy

  1. Zvolte Soubor > Uložit jako předlohu.
  2. V dialogovém okně Uložit jako předlohu zadejte název předlohy do pole Název.
  3. Z rozbalovací nabídky Kategorie zvolte požadovanou kategorii nebo zadejte název, aby se vytvořila nová kategorie.
  4. Do pole Popis zadejte popis předlohy (maximálně 255 znaků) a klikněte na OK.

    Popis se zobrazí při vybrání předlohy v dialogovém okně Nový dokument.

    Chcete-li odstranit uložené šablony, přejděte do jedné z následujících složek a odstraňte soubor předlohy FLA ze složky kategorie, která jej obsahuje.

    • Systém Windows XP: C:\Documents and Settings\<uživatelské jméno>\Local Settings\Application Data\Adobe\Flash CS5\cs_CZ\Configuration\Templates\

    • Systém Windows Vista a 7: C:\Users\<uživatelské jméno>\AppData\Local\Adobe\Flash CS5\<jazyk>\Configuration\Templates\

    • Systém Mac OS: <pevný disk>/Users/<uživatelské jméno>/Library/Application Support/Adobe/Flash CS5/<jazyk>/Configuration/Templates/

Uložení dokumentu ve formátu dokumentu aplikace Flash CS4

  1. Zvolte Soubor > Uložit jako.
  2. Zadejte název souboru a jeho umístění.
  3. Z rozbalovací nabídky Formát vyberte možnost Dokument aplikace Flash CS4 a klikněte na tlačítko Uložit.

    Poznámka:

    Jestliže se objeví upozornění, že obsah bude vymazán, pokud ho uložíte ve formátu aplikace Flash CS4, pokračujte kliknutím na tlačítko Uložit jako Flash CS4.K tomu může dojít v případě, že dokument obsahuje vlastnosti, které jsou dostupné pouze v aplikaci Flash CS5. Aplikace Flash Professional tyto vlastnosti při uložení dokumentu ve formátu aplikace Flash CS4 nezachová.

Ukládání dokumentů při ukončení programu Flash

  1. Zvolte Soubor > Konec (Windows) nebo Flash > Ukončit Flash (Macintosh).
  2. Pokud máte otevřené dokumenty, ve kterých jsou neuložené změny, aplikace Flash Professional vás vyzve, ať změny pro každý dokument uložíte nebo vypustíte.
    • Klepněte na Ano, chcete-li změny uložit a dokument zavřít.

    • Klepněte na Ne, chcete-li dokument zavřít bez uložení změn.

Tisk dokumentů Flash

Chcete-li zobrazit náhled a upravit dokumenty, vytiskněte snímky z dokumentů aplikace Flash Professional nebo určete snímky, které bude možné vytisknout z přehrávače Flash Player pomocí prohlížeče.

Při tisku snímků z dokumentu aplikace Flash Professional použijte dialogové okno Tisk a v něm určete rozsah scén nebo snímků k tisku a počet kopií. Ve Windows dialogové okno Vzhled stránky určuje velikost, orientaci papíru a různé volby tisku – včetně nastavení okrajů a toho, zda se mají pro každou stránku vytisknout všechny snímky. Na počítači Macintosh jsou tyto volby rozdělené mezi dialogová okna Vzhled stránky a Okraje tisku.

Dialogová okna Tisk a Vzhled stránky jsou standardní v obou operačních systémech a jejich vzhled závisí na vybraném ovladači tiskárny.

  1. Vyberte Soubor > Vzhled stránky (Windows) nebo Soubor > Okraje tisku (Macintosh).
  2. Nastavte okraje stránky. Vyberte obě volby Na střed, aby se snímek vytiskl uprostřed stránky.
  3. V nabídce Snímky vyberte, zda se mají tisknout všechny snímky v dokumentu, nebo pouze první snímek každé scény.
  4. V nabídce Rozvržení vyberte z následujících voleb:

    Skutečná velikost

    Tiskne snímek v plné velikosti. Zadejte hodnotu pro Změnit velikost, chcete-li tištěný snímek zmenšit nebo zvětšit.

    Přizpůsobit na jednu stránku

    Zmenší nebo zvětší každý snímek, aby vyplnil tisknutelnou oblast stránky.

    Storyboard

    Tiskne několik miniatur na jedné stránce. Vyberte z voleb Rámečky, Mřížka, nebo Prázdné. V poli Snímky zadejte počet miniatur na stránku. Nastavte mezeru mezi miniaturami v poli Okraj článku a vyberte Popsat snímky, chcete-li vytisknout popis snímku jako miniaturu.

  5. Snímky vytiskněte příkazem Soubor > Tisknout.

Použití popisů snímků k zakázání tisku

Chcete-li zvolit, aby se netiskl žádný ze snímků v hlavní časové ose, popište snímek jako !#p, čímž změníte celý soubor SWF na netisknutelný. Popsání snímku jako !#p ztlumí příkaz Tisknout v kontextové nabídce přehrávače Flash Player. Také můžete odstranit kontextovou nabídku přehrávače Flash Player.

Pokud zakážete tisk z přehrávače Flash Player, uživatel může stále použít k vytištění snímků příkaz Tisknout v prohlížeči. Protože je tento příkaz je funkcí prohlížeče, nelze k jeho ovládání nebo zakázání použít aplikaci Flash Professional.

Zakázání tisku v kontextové nabídce přehrávače Flash Player

  1. Otevřete nebo aktivujte dokument aplikace Flash Professional (soubor FLA), který chcete publikovat.
  2. V hlavní časové ose vyberte první klíčový snímek.
  3. Příkazem Okno > Vlastnosti zobrazte inspektor Vlastnosti.
  4. V inspektoru Vlastnosti zadejte pro Popis snímku hodnotu !#p, čímž snímek určíte jako netisknutelný.

    Určete pouze jeden popis !#p, kterým ztlumíte příkaz Tisknout v kontextové nabídce.

    Poznámka:

    Můžete také vybrat prázdný snímek (a ne klíčový snímek) a popsat ho #p.

Zakázání tisku odstraněním kontextové nabídky přehrávače Flash Player

  1. Otevřete nebo aktivujte dokument aplikace Flash Professional (soubor FLA), který chcete publikovat.
  2. Vyberte příkaz Soubor > Nastavení publikování.
  3. Vyberte záložku HTML, odznačte Zobrazit nabídku a klikněte na OK.

Určení oblasti tisku při tisku snímků

  1. Otevřete dokument aplikace Flash Professional (soubor FLA) obsahující snímky, které nastavíte k vytištění.
  2. Vyberte snímek, který jste neurčili, aby se vytiskl s popisem snímku #p, a který je ve stejné vrstvě jako snímek popsaný #p.

    Abyste si uspořádali práci, vyberte další snímek za snímkem popsaným #p.

  3. Ve vymezené ploše vytvořte tvar o velikosti požadované oblasti tisku. Chcete-li použít ohraničovací rámeček snímku, vyberte snímek s jakýmkoliv objektem požadované velikosti oblasti tisku.
  4. V časové ose vyberte snímek obsahující tvar, který se má použít pro ohraničovací rámeček.
  5. V inspektoru Vlastnosti (Okno > Vlastnosti) zadejte #b, čímž určíte vybraný tvar jako ohraničující rámeček pro oblast tisku.

    Pro každou časovou osu je povolen pouze jeden popis snímku #b. Tato volba je stejná jako vybrání volby ohraničovacího rámečku filmu s akcí Tisknout.

Změna tištěné barvy pozadí

Můžete vytisknout barvu pozadí nastavenou v dialogovém okně Vlastnosti dokumentu. Umístěním barevného objektu do nejnižší vrstvy časové osy, která se tiskne, změňte barvu pozadí pouze pro snímky, které se mají vytisknout.

  1. Umístěte vyplněný tvar, který zakryje plochu v nejnižší vrstvě časové osy, která se bude tisknout.
  2. Vyberte tvar a zvolte Změnit > Dokument. Vyberte barvu pro vytištění pozadí.

    Tato akce změní barvu pozadí celého dokumentu včetně barvy pozadí filmových klipů a načtených souborů SWF.

  3. Proveďte jeden z následujících úkonů:
    • Chcete-li tuto barvu vytisknout jako pozadí dokumentu, určete, aby se vytiskl snímek, do kterého jste umístili daný tvar.

    • Chcete-li zachovat odlišnou barvu pozadí pro netisknutelné snímky, opakujte kroky 2 a 3. Pak umístěte tvar do nejnižší vrstvy časové osy ve všech snímcích, které nejsou určené k tisku.

Pomocí příkazu Tisknout v místní nabídce přehrávače Flash Player můžete vytisknout snímky z jakéhokoliv souboru SWF aplikace Flash Professional.

Příkazem Tisknout z kontextové nabídky nelze tisknout průhlednost ani barevné efekty a také nelze tisknout snímky z jiných filmových klipů; chcete-li využívat možnosti dalších voleb tisku, použijte objekt PrintJob (Tisková úloha) nebo funkci print().

  1. Otevřete dokument.

    Příkaz vytiskne snímky popsané #p, přičemž k určení oblasti tisku použije vymezenou plochu nebo určený ohraničovací rámeček.

    Pokud jste neoznačili k tisku jen určité snímky, vytisknou se všechny snímky v hlavní časové ose dokumentu.

  2. Pokud chcete zobrazit obsah aplikace Flash Professional v prohlížeči, klikněte na položky Soubor > Náhled publikování > Výchozí nebo stiskněte klávesu F12.
  3. Místní nabídku přehrávače Flash Player zobrazíte tak, že kliknete pravým tlačítkem myši na obsah v okně prohlížeče (Windows) nebo na něm podržíte klávesu Ctrl (Macintosh).
  4. Z kontextové nabídky přehrávače Flash Player vyberte Tisknout, aby se zobrazilo tiskové dialogové okno.
  5. Ve Windows vyberte rozsah tisku a tím určete, které snímky se mají vytisknout.
  6. Na Macintoshi vyberte v tiskovém dialogovém okně stránky, které se mají vytisknout.
  7. Podle vlastností konkrétní tiskárny vyberte další volby tisku.
  8. Klikněte na tlačítko OK (Windows) nebo Tisknout (Macintosh).

Poznámka:

Tisk z kontextové nabídky nepracuje s voláními objektu PrintJob.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online