Uživatelé operačního systému Ubuntu 10.x a 11.x Linux OS mohou někdy u aplikace Flash Player 11 při přehrávání chráněného video obsahu zaznamenat prázdnou nebo černou obrazovku. (Stává se to například u služeb, jako je Amazon Instant Video.) Toto chování má na svědomí chybějící model Ubuntu HAL (hardwarová abstrakční vrstva), který není součástí výchozí instalace. Pokud program zobrazí chybovou zprávu, uživatelé uvidí DRM chybu 3323 či 3322.

Požadavky na přehrávání chráněného obsahu

U systému Ubuntu 10.04 nebo novějšího nejprve zajistěte instalaci modulu hardwarové abstrakční vrstvy pomocí příkazu apt-get.
(Při instalaci dbejte na chyby knihovny „hal“, protože instalace poškozeného balíčku může mít dál nepříznivý vliv na přehrávání videí.)

sudo apt-get install hal

Po dokončení instalace knihovny „libhal“ (HAL) zavřete prohlížeč a vyčistěte adresáře Adobe Access spuštěním následujících příkazů shellu:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Poznámka:

Pokud chybí modul hardwarové abstrakční vrstvy, aplikace Flash Player bude dále fungovat. Nedokáže však přehrát chráněný obsah, který vyžaduje modul Adobe Flash Access DRM (Digital Rights Management).

Podpora pro cílové 64bitové verze systému Linux

Společnost Adobe uvádí podporu platformy pro 32bitový a 64bitový Linux v sekci systémových požadavků na stránkách aplikace Flash Player 11. Mezi aktuálně podporované distribuce (32bitvá a 64bitová verze) patří Redhat Enterprise Linux 5.6 nebo novější a Ubuntu 10.04 nebo novější.

Je podporována i verze openSuse.

Nainstalujte správný 32bitový nebo 64bitový zásuvný modul Flash Player

Pro instalaci nejnovější aplikace Flash Player pro vaši platformu a architekturu přejděte na http://www.adobe.com/cz/products/flashplayer.html.

V případě nejistoty, který balíček pro Linux nainstalovat, klikněte na sekci Vlastníte jiný operační systém nebo prohlížeč?, která vám nabídne další varianty OS.

openSuse a další verze systému Linux

Některé distribuce systému Linux přistupují ke správě balíčků vlastním způsobem, zejména pak openSUSE. openSUSE využívá jako nativní formát balíčků RPM Pro správu instalací systémového softwaru má nicméně svůj vlastní špičkový nástroj. 
Instalace .rpm v systému openSuse (32bitová i 64bitová verze) nespolehlivé. Občas vrátí generickou chybu „Zpráva neobdržela odpověď (vypršel časový limit žádosti sběrnice zpráv)“.

V těchto případech si raději stáhněte archiv tar.gz a vložte Flash Player (libflashplayer.so) do následujícího umístění:

/usr/lib/adobe-flashplugin/libflashplayer.so

Otestujte přehrávání chráněného video obsahu pomocí demoverze přehrávače

  1. Spusťte konejner demoverze přehrávače videí společnosti Adobe: http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html
     
    Poznamenejte si verzi aplikace Adobe Flash Player v levé spodní části programu pro přehrávání videí. Přesvědčte se, zda je zde napsáno 11.2 nebo vyšší
  2. Přehrajte ukázku chráněného obsahu.
     
      Do pole „Input the video URL: (rozlišuje malá a velká písmena) zadejte následující URL
      http://drmtest2.adobe.com:8080/Content/anonymous.f4v
  3. Ve spodní části kontejneru videa klikněte na tlačítko [Play].

Dojde k přehrávání chráněného obsahu anonymous.f4v. (Toto video se nazývá Getty „train“.)

 

Související produkty

Adobe Flash Player 11, Flash Access (FAXS), Ubuntu 10.x & 11.x Linux

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online