Tento dokument popisuje instalaci a používání doplňkového zásuvného modulu OpenEXR Alpha.

Doplňkový zásuvný modul OpenEXR Alpha umožňuje alternativní zpracování dat kanálu A při otevírání souborů OpenEXR. Zásuvný modul OpenEXR Alpha místo přímého převodu dat kanálu A na průhlednost (k němuž dochází ve původním zásuvném modulu OpenEXR) otevře data kanálu A jako alfa kanál.

Základní informace

Aplikace Photoshop CS2 v 32bitovém režimu nepodporovala průhlednost. Díky alternativnímu řešení však bylo v této verzi možné načíst data průhlednosti do kanálu alpha. V aplikaci Photoshop CS3 byla zavedena podpora průhlednosti v 32bitovém režimu v souladu se specifikací OpenEXR. Při přímém skládání kanálů se tedy průhlednost již nenačítala do alfa kanálu.

Na úvod

K instalaci zásuvného modulu OpenEXR Alpha jsou potřeba oprávnění místního správce. Pokud používáte systém Mac OS, Windows Vista nebo Windows 7, vyzve vás systém k zadání uživatelského jména a hesla správce. V systému Windows XP se nejprve přihlaste pomocí místního účtu správce.

Uživatelé systému Windows: V některých krocích jsou uvedeny úplné názvy souborů včetně přípon (například OpenEXR Alpha.8bi). V systému Windows jsou přípony souborů známých typů ve výchozím nastavení skryty. Zobrazíte je následujícím způsobem:

  1. V Průzkumníkovi Windows zvolte možnost Nástroje > Možnosti složky (v systému Windows XP) nebo Uspořádat > Možnosti složky a hledání (v systému Windows 7 a Vista).
  2. V horní části okna Možnosti složky vyberte kartu Zobrazení.
  3. Na kartě Zobrazení v části Upřesnit nastavení zrušte zaškrtnutí políčka Skrýt příponu souborů známých typů.
  4. Klikněte na tlačítko OK.

Uživatelé systému Windows: V některých krocích je potřeba zjistit, zda používáte 32bitovou nebo 64bitovou verzi systému Windows. Pokyny ke zjištění používané verze systému naleznete v článku Ověření, zda je v počítači nainstalována 32- nebo 64bitová verze systému Windows.

Kompatibilita

V systému Windows není zásuvný modul OpenEXR Alpha kompatibilní s verzemi aplikace Photoshop, které jsou starší než verze Photoshop CS5. V aplikaci Photoshop CS3 a CS4 se tedy nenačte.

V systému Mac OS se zásuvný modul OpenEXR Alpha nenačte v počítačích PowerPPC.

Instalace zásuvného modulu OpenEXR Alpha pro aplikaci Photoshop CS5 v systému Mac OS nebo Windows (stažení aktualizace z webu společnosti Adobe)

Zásuvný modul OpenEXR Alpha můžete nainstalovat tak, že z webu společnosti Adobe stáhnete aktualizaci:

  1. Stáhněte komprimovaný soubor zásuvného modulu:

  2. Ukončete aplikaci Photoshop CS5.
  3. Rozbalte stažený soubor.
  4. Přetáhněte zásuvný modul do složky zásuvných modulů aplikace Photoshop.
    • Windows (32bitová verze): Přetáhněte soubor OpenEXR Alpha.8bi ze složky Win32 do složky /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows (64bitová verze) a Photoshop (64bitová verze): Přetáhněte soubor OpenEXR Alpha.8bi ze složky Win64 do složky /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Windows (64bitová verze) a Photoshop (32bitová verze): Přetáhněte soubor OpenEXR Alpha.8bi ze složky Win32 do složky /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: Přetáhněte soubor OpenEXR.plugin do složky /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Spusťte aplikaci Photoshop CS5.

Používání zásuvného modulu OpenEXR Alpha

Otevření souboru EXR:

  1. Spusťte aplikaci Photoshop CS5.
  2. Zvolte možnost Soubor > Otevřít.
  3. Vyhledejte soubor EXR, který chcete otevřít. V seznamu formátů souborů vyberte formát OpenEXR Alpha. V aplikaci Photoshop se data kanálu A zpracují jako alfa kanál, nikoli jako průhlednost.

Export souboru EXR:

  1. Zvolte možnost Soubor > Uložit jako.
  2. V seznamu formátů souborů vyberte formát OpenEXR Alpha.

  3. Vyberte možnost Uložit: Alfa kanály. Díky tomuto nastavení zůstanou zachována data alfa kanálů.

Poznámka: Dojde ke sloučení průhlednosti přidané po otevření souboru.

Poznámka: Po instalaci zásuvného modulu OpenEXR Alpha je v seznamu formátů souborů nadále k dispozici i původní formát OpenEXR. Tento zásuvný modul zpracovává data kanálu A jako průhlednost. Toto chování je v aplikaci Photoshop výchozí od verze Photoshop CS3 (10.0).

Další poznámky

Při používání doplňkového zásuvného modulu dochází k určitým změnám:

  • Není podporováno předem vynásobené skládání.
  • Když soubor otevřete dvojitým kliknutím, aplikace Photoshop CS5 vždy použije zásuvný modul OpenEXR Alpha, nikoli modul OpenEXR.
  • Pokud otevřete soubor se dvěma či více alfa anály, zásuvný modul OpenEXR Alpha všechny alfa kanály vypustí, takže nezůstane zachován žádný.
  • (Mac OS): V dialogu Uložit je formát OpenEXR Alpha uveden jako první. Nezobrazuje se v abecedním pořadí za formátem Open EXR.
  • (Windows): Pokud chcete použít původní zásuvný modul OpenEXR, zvolte možnost Soubor > Otevřít jako a vyberte formát OpenEXR.
     

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online