Příručka uživatele Zrušit

Optimalizace výkonu aplikace Photoshop

  1. Uživatelská příručka k aplikaci Photoshop
  2. Úvod do aplikace Photoshop
    1. Přetvořte své sny v realitu
    2. Co je nového v aplikaci Photoshop
    3. Úprava vaší první fotky
    4. Vytváření dokumentů
    5. Photoshop | Časté otázky
    6. Systémové požadavky aplikace Photoshop
    7. Seznamte se s aplikací Photoshop
  3. Photoshop a další produkty a služby Adobe
    1. Práce s kresbou aplikace Illustrator v aplikaci Photoshop
    2. Práce se soubory aplikace Photoshop v aplikaci InDesign
    3. Materiály aplikace Substance 3D pro Photoshop
    4. Použití rozšíření Capture v aplikaci Photoshop
  4. Photoshop na iPadu (není k dispozici v kontinentální Číně)
    1. Photoshop na iPadu | Časté otázky
    2. Seznámení s pracovní plochou
    3. Systémové požadavky | Photoshop na iPadu
    4. Vytváření, otevírání a export dokumentů
    5. Přidání fotografií
    6. Práce s vrstvami
    7. Kreslení a malování štětci
    8. Výběry a přidání masek
    9. Retušování kompozic
    10. Práce s vrstvami úprav
    11. Úprava tónů kompozice pomocí křivek
    12. Používání transformací
    13. Oříznutí a otočení kompozic
    14. Otáčení, posouvání, přiblížení a obnovení plátna
    15. Práce s textovými vrstvami
    16. Práce s aplikacemi Photoshop a Lightroom
    17. Získání chybějících písem v aplikaci Photoshop na iPadu
    18. Japonský text v aplikaci Photoshop na iPadu
    19. Správa nastavení aplikace
    20. Dotykové zkratky a gesta
    21. Klávesové zkratky
    22. Úprava velikosti obrázku
    23. Živý přenos během tvorby v aplikaci Photoshop na iPadu
    24. Opravy nedokonalostí pomocí retušovacího štětce
    25. Vytváření štětců v rozšíření Capture a jejich použití v aplikaci Photoshop na iPadu
    26. Práce se soubory Camera Raw
    27. Vytváření inteligentních objektů a práce s nimi
    28. Úprava expozice na snímcích pomocí možností Zesvětlení a Ztmavení
    29. Příkazy pro automatické úpravy v aplikaci Photoshop na iPadu
    30. Rozmazání oblastí obrazu pomocí aplikace Photoshop na iPadu
    31. Zvýšení nebo snížení sytosti obrazu pomocí nástroje Houba
    32. Výplň podle obsahu pro iPad
  5. Photoshop na webu (není k dispozici v kontinentální Číně)
    1. Časté otázky
    2. Systémové požadavky
    3. Klávesové zkratky
    4. Podporované typy souborů
    5. Úvod do pracovní plochy
    6. Otevření cloudových dokumentů a práce s nimi
    7. Funkce generativní umělé inteligence
    8. Základní koncepty úprav
    9. Rychlé akce
    10. Práce s vrstvami
    11. Retušování a odstraňování nedostatků
    12. Rychlé výběry
    13. Vylepšení obrazu pomocí vrstev úprav
    14. Přesouvání, transformace a oříznutí obrázků
    15. Kreslení a malování
    16. Práce s textovými vrstvami
    17. Spolupráce s uživateli na webu
    18. Správa nastavení aplikace
    19. Generování obrázků
    20. Generování pozadí
    21. Referenční obrázek
  6. Photoshop (beta) (není k dispozici v kontinentální Číně)
    1. Začínáme s betaverzemi aplikací Creative Cloud
    2. Photoshop (beta) na počítači
    3. Generování obrázku pomocí popisných textových pokynů
    4. Generování pozadí pomocí popisných textových pokynů
  7. Generativní umělá inteligence (není k dispozici v kontinentální Číně) 
    1. Časté týkající se generativní umělé inteligence v aplikaci Photoshop
    2. Generativní výplň v aplikaci Photoshop na počítači
    3. Generativní rozšíření v aplikaci Photoshop na počítači
    4. Generativní výplň v aplikaci Photoshop na iPadu
    5. Generativní rozšíření v aplikaci Photoshop na iPadu
    6. Funkce generativní umělé inteligence v aplikaci Photoshop na webu
  8. Autenticita obsahu (není k dispozici v kontinentální Číně)
    1. Pověření k obsahu v aplikaci Photoshop
    2. Identita a původ pro NFT
    3. Propojení účtů pro atribuci kreativního díla
  9. Dokumenty v cloudu (nejsou k dispozici v kontinentální Číně)
    1. Cloudové dokumenty aplikace Photoshop | Časté otázky
    2. Cloudové dokumenty aplikace Photoshop | Otázky k pracovním postupům
    3. Práce s cloudovými dokumenty a jejich správa v aplikaci Photoshop
    4. Upgrade cloudového úložiště pro aplikaci Photoshop
    5. Nelze vytvořit nebo uložit dokument v cloudu
    6. Řešení chyb dokumentů aplikace Photoshop v cloudu
    7. Shromažďování protokolů synchronizace cloudových dokumentů
    8. Pozvání uživatelů k úpravám cloudových dokumentů
    9. Sdílení souborů a komentářů v aplikaci
  10. Pracovní plocha
    1. Základy práce s pracovní plochou
    2. Předvolby
    3. Rychlejší učení s panelem Prohledávání aplikace Photoshop
    4. Vytváření dokumentů
    5. Vkládání souborů
    6. Výchozí klávesové zkratky
    7. Přizpůsobení klávesových zkratek
    8. Galerie nástrojů
    9. Předvolby výkonu
    10. Použití nástrojů
    11. Přednastavení
    12. Mřížka a vodítka
    13. Dotyková gesta
    14. Používání panelu Touch Bar s aplikací Photoshop
    15. Možnosti dotykového ovládání a přizpůsobitelné pracovní plochy
    16. Technologické náhledy
    17. Metadata a poznámky
    18. Možnosti dotykového ovládání a přizpůsobitelné pracovní plochy
    19. Umístění obrázků aplikace Photoshop do jiných aplikací
    20. Pravítka
    21. Zobrazení nebo skrytí netištěných doplňků
    22. Nastavení sloupců pro obraz
    23. Příkaz Zpět a historie
    24. Panely a nabídky
    25. Umísťování elementů pomocí přitahování
    26. Nastavení polohy nástrojem Pravítko
  11. Design webu, obrazovky a aplikací
    1. Photoshop pro vytváření návrhů
    2. Návrhové plochy
    3. Náhled v zařízení
    4. Kopírování CSS z vrstev
    5. Rozdělení webové stránky na řezy
    6. Volby HTML pro řezy
    7. Úprava rozvržení řezů
    8. Práce s webovou grafikou
    9. Vytváření webových fotogalerií
  12. Základy práce s obrázky a barvami
    1. Změna velikosti snímků
    2. Práce s rastrovými a vektorovými obrazy
    3. Velikost obrazu a rozlišení
    4. Načítání obrazů z fotoaparátů a skenerů
    5. Vytváření, otevírání a import obrazů
    6. Zobrazení obrázků
    7. Chyba neplatného markeru JPEG | Otevírání obrazů
    8. Zobrazování více obrazů
    9. Přizpůsobení dialogů pro výběr barvy a vzorků barev
    10. Obrázky s vysokým dynamickým rozsahem
    11. Srovnání barev v obraze
    12. Převádění mezi barevnými režimy
    13. Barevné režimy
    14. Vymazání částí obrazu
    15. Režimy prolnutí
    16. Výběr barev
    17. Úpravy tabulek indexovaných barev
    18. Informace o obrazu
    19. Nedostupné filtry deformace
    20. O barvách
    21. Úpravy barevných a monochromatických obrazů pomocí kanálů
    22. Výběr barev na panelech Barvy a Vzorník
    23. Vzorek
    24. Barevný režim (režim obrázku)
    25. Barevný nádech
    26. Přidání podmíněné změny režimu do akce
    27. Přidávání vzorků barev ze souborů HTML, CSS a SVG
    28. Bitová hloubka a předvolby
  13. Vrstvy
    1. Základy práce s vrstvami
    2. Nedestruktivní úpravy
    3. Vytváření a správa vrstev a skupin
    4. Výběr, seskupení a svázání vrstev
    5. Vložení obrázků do rámečku
    6. Krytí a prolnutí vrstev
    7. Maskování vrstev
    8. Aplikování inteligentních filtrů
    9. Kompozice vrstev
    10. Přesunutí, překrývání a zamykání vrstev
    11. Maskování vrstev pomocí vektorových masek
    12. Správa vrstev a skupin
    13. Efekty a styly vrstev
    14. Úpravy masek vrstev
    15. Extrahování datových zdrojů
    16. Odhalení vrstev s ořezovými maskami
    17. Generování obrazových datových zdrojů z vrstev
    18. Práce s inteligentními objekty
    19. Režimy prolnutí
    20. Zkombinování více obrazů do skupinového portrétu
    21. Spojování obrázků pomocí příkazu Automaticky prolnout vrstvy
    22. Zarovnání a rozmístění vrstev
    23. Kopírování CSS z vrstev
    24. Načítání výběrů z hranic vrstvy nebo z hranic masky vrstvy
    25. Odkrytí obsahu jiných vrstev vyseknutím
  14. Výběry
    1. Začínáme s výběry
    2. Provádění výběrů v kompozici
    3. Pracovní plocha Vybrat a maskovat
    4. Výběr pomocí nástrojů výběru
    5. Výběr pomocí nástrojů lasa
    6. Úpravy výběrů obrazových bodů
    7. Přesouvání, kopírování a odstraňování vybraných obrazových bodů
    8. Vytvoření dočasné rychlé masky
    9. Výběr rozsahu barev v obrázku
    10. Změna cest na hranice výběru a naopak
    11. Základní informace o kanálech
    12. Ukládání výběrů a masek alfa kanálů
    13. Výběr důležitých oblastí obrazu
    14. Duplikování, rozdělení a sloučení kanálů
    15. Výpočty s kanály
  15. Úpravy obrázků
    1. Nahrazení barev objektů
    2. Pokřivení perspektivy
    3. Redukce chvění fotoaparátu
    4. Příklady použití retušovacího štětce
    5. Export vyhledávacích tabulek barev
    6. Nastavení ostrosti a rozmazání obrazu
    7. Jak fungují úpravy barev
    8. Použití nastavení Jas a kontrast
    9. Úpravy detailů v oblastech stínů a světel
    10. Nastavení úrovní
    11. Nastavení odstínu a sytosti
    12. Úprava živosti
    13. Nastavení sytosti barev v oblastech obrazu
    14. Provádění rychlých úprav tónů
    15. Aplikování speciálních barevných efektů na obrazy
    16. Vylepšení obrázku pomocí úprav vyvážení barev
    17. Obrázky s vysokým dynamickým rozsahem
    18. Prohlížení histogramů a hodnot obrazových bodů
    19. Srovnání barev v obraze
    20. Oříznutí a narovnání fotografií
    21. Převedení barevného obrázku na černobílý
    22. Vrstvy úprav a vrstvy výplně
    23. Nastavení křivek
    24. Režimy prolnutí
    25. Příprava obrazů pro komerční tisk
    26. Nastavení barev a tónů pomocí kapátek Úrovně a Křivky
    27. Nastavení expozice a tónování HDR
    28. Zesvětlení nebo ztmavení určitých oblastí obrázku
    29. Nastavení selektivní barvy
  16. Adobe Camera Raw
    1. Systémové požadavky modulu Camera Raw
    2. Co je nového v modulu Camera Raw
    3. Úvod do aplikace Camera Raw
    4. Vytváření panoramat
    5. Podporované objektivy
    6. Efekty vinětování, zrnění a odstranění oparu v aplikaci Camera Raw
    7. Výchozí klávesové zkratky
    8. Automatická korekce perspektivy v Camera Raw
    9. Kruhový filtr v Camera Raw
    10. Správa nastavení nástroje Camera Raw
    11. Otevírání, zpracování a ukládání obrazů v aplikaci Camera Raw
    12. Oprava obrazů pomocí vylepšeného nástroje Odstranění bodů v aplikaci Camera Raw
    13. Otočení, oříznutí a úpravy obrazů
    14. Úprava vykreslení barev v aplikaci Camera Raw
    15. Verze zpracování v nástroji Camera Raw
    16. Vytváření místních úprav v modulu Camera Raw
  17. Oprava a obnovení obrázků
    1. Odebrání objektů z fotografií pomocí funkce Výplň podle obsahu
    2. Záplata a přesun podle obsahu
    3. Retušování a opravování fotografií
    4. Korekce deformace a šumu obrazu
    5. Základní postupy při řešení potíží, které pomohou vyřešit většinu problémů
  18. Vylepšení a transformace obrázku
    1. Nahrazení oblohy na snímcích
    2. Transformace objektů
    3. Nastavení oříznutí, otočení a velikosti plátna
    4. Oříznutí a narovnání fotografií
    5. Vytváření a úpravy panoramatických obrázků
    6. Pokřivení obrazů, tvarů a cest
    7. Úběžný bod
    8. Změna měřítka s ohledem na obsah
    9. Transformace obrázků, tvarů a cest
  19. Kreslení a malování
    1. Kreslení symetrických vzorů
    2. Kreslení obdélníků a úprava voleb tahu
    3. O kreslení
    4. Kreslení a úpravy tvarů
    5. Malovací nástroje
    6. Vytváření a úpravy štětců
    7. Režimy prolnutí
    8. Přidání barev k cestám
    9. Úpravy cest
    10. Malování míchacím štětcem
    11. Přednastavené stopy
    12. Přechody
    13. Interpolace přechodu
    14. Vyplnění a vytažení výběrů, vrstev a cest
    15. Kreslení pomocí nástrojů pera
    16. Vytváření vzorků
    17. Generování vzorku pomocí filtru Pattern Maker (Vytvořit vzorek)
    18. Správa cest
    19. Správa knihoven a přednastavení vzorků
    20. Kreslení nebo malování na grafickém tabletu
    21. Vytváření stop s texturami
    22. Přidávání dynamických prvků do stop štětců
    23. Přechod
    24. Malování stylizovaných tahů pomocí uměleckého štětce historie
    25. Malování vzorkem
    26. Synchronizace přednastavení na více zařízeních
    27. Migrace přednastavení, akcí a nastavení
  20. Text
    1. Přidání a úpravy textu
    2. Sjednocený textový modul
    3. Práce s písmy OpenType SVG
    4. Formátování znaků
    5. Formátování odstavců
    6. Vytváření textových efektů
    7. Úpravy textu
    8. Mezery mezi řádky a znaky
    9. Arabský a hebrejský text
    10. Písma
    11. Řešení potíží s písmy
    12. Asijský text
    13. Vytváření textu
  21. Filtry a efekty
    1. Použití galerie nástroje Rozostření
    2. Základy používání filtrů
    3. Přehled efektů filtrů
    4. Přidávání světelných efektů
    5. Použití filtru Adaptivní široký úhel
    6. Použití filtru Olejová malba
    7. Používání filtru Zkapalnění
    8. Efekty a styly vrstev
    9. Použití specifických filtrů
    10. Rozmazání oblastí obrazu
  22. Ukládání a export
    1. Ukládání souborů v aplikaci Photoshop
    2. Export souborů v aplikaci Photoshop
    3. Podporované formáty souborů
    4. Ukládání souborů v grafických formátech
    5. Přesouvání návrhů mezi aplikacemi Photoshop a Illustrator
    6. Ukládání a export videa a animací
    7. Ukládání souborů PDF
    8. Ochrana autorských práv systémem Digimarc
  23. Správa barev
    1. Principy správy barev
    2. Zachování shodných barev
    3. Nastavení barev
    4. Duplexy
    5. Práce s profily barev
    6. Správa barev v dokumentech pro zobrazování online
    7. Správa barev v dokumentech při tisku
    8. Správa barev pro importované obrazy
    9. Kontrolní náhled barev
  24. Design webu, obrazovky a aplikací
    1. Photoshop pro vytváření návrhů
    2. Návrhové plochy
    3. Náhled v zařízení
    4. Kopírování CSS z vrstev
    5. Rozdělení webové stránky na řezy
    6. Volby HTML pro řezy
    7. Úprava rozvržení řezů
    8. Práce s webovou grafikou
    9. Vytváření webových fotogalerií
  25. Video a animace
    1. Úpravy videa v aplikaci Photoshop
    2. Úpravy vrstev videa a animací
    3. Video a animace – přehled
    4. Zobrazení náhledu videa a animací
    5. Malování na snímky ve vrstvách videa
    6. Import videí a obrázkových sekvencí
    7. Vytváření animací snímků
    8. Creative Cloud 3D Animation (Náhled)
    9. Vytváření animací na časové ose
    10. Vytváření obrazů pro video
  26. Tisk
    1. Tisk 3D objektů
    2. Tisk z aplikace Photoshop
    3. Tisk se správou barev
    4. Stránky miniatur a prezentace PDF
    5. Tisk fotografií v rozvržení sady obrazů
    6. Tisk přímých barev
    7. Tisk obrazů na komerčních tiskových strojích
    8. Zvýšení kvality barevného tisku z aplikace Photoshop
    9. Řešení problémů s tiskem | Photoshop
  27. Automatizace
    1. Vytváření akcí
    2. Vytváření grafických souborů řízených daty
    3. Skriptování
    4. Zpracování dávky souborů
    5. Přehrávání a správa akcí
    6. Přidání podmíněných akcí
    7. O akcích a panelu Akce
    8. Záznam nástrojů v akcích
    9. Přidání podmíněné změny režimu do akce
    10. Sada nástrojů uživatelského rozhraní aplikace Photoshop pro moduly plug-in a skripty
  28. Řešení problémů
    1. Opravené problémy 
    2. Známé problémy
    3. Optimalizace výkonu aplikace Photoshop
    4. Základní postupy při řešení potíží
    5. Poradce při potížích s chybovým ukončením nebo zamrznutím aplikace
    6. Řešení chyb programu
    7. Řešení chyb zaplnění odkládacího disku
    8. Řešení problémů s grafickým procesorem a ovladačem grafické karty
    9. Vyhledání chybějících nástrojů
    10. Photoshop 3D | Časté otázky týkající se ukončených funkcí

Pokud běží aplikace Photoshop v počítači pomaleji, než jste očekávali, vyzkoušejte tipy a techniky popsané v tomto dokumentu.

  Ukončení 3D funkcí v aplikaci Photoshop

3D funkce aplikace Photoshop budou v budoucích aktualizacích odebrány. Uživatelům pracujícím s 3D obsahem se doporučuje vyzkoušet novou kolekci Adobe Substance 3D, která představuje novou generaci 3D nástrojů od společnosti Adobe. Další podrobnosti o ukončení 3D funkcí aplikace Photoshop najdete tady: Photoshop 3D | Časté otázky týkající se ukončených 3D funkcí.

Obecný postup pro zlepšení výkonu

Nastavení je u každého uživatele jedinečné a k dosažení co nejefektivnějšího výkonu aplikace Photoshop bude pravděpodobně třeba použít vždy jinou kombinaci metod. Zvažte, která z doporučení uvedených v tomto článku je s ohledem na nastavení počítače, typy používaných souborů a pracovních postupů vhodné realizovat. Existují čtyři hlavní způsoby, jak ovlivnit výkon v aplikaci Photoshop – Optimalizujte nastavení hardwaru, Optimalizujte operační systém pro aplikaci Photoshop, Nastavte předvolby související s výkonemDolaďte funkce aplikace Photoshop.

Nejjednodušším způsobem, jak bez finančních nákladů zlepšit výkon, je nastavit předvolby aplikace Photoshop a vyladit její funkce podle toho, jakým způsobem a s jakými typy souborů obvykle pracujete.

Největšího zvýšení výkonu dosáhnete investicí do rychlejšího a výkonnějšího hardwaru. Pokud má aplikace Photoshop fungovat optimálně, musí počítač splňovat určité minimální systémové požadavky. Při používání aplikace Photoshop v počítači s nedostatečným výkonem nebo nepodporovaným hardwarem, například v počítači s nekompatibilním grafickým procesorem, může docházet k problémům s jejím výkonem. 

Nastavení předvoleb týkajících se výkonu

V tomto krátkém videu se dozvíte, jak v aplikaci Photoshop rychle optimalizovat předvolby související s výkonem.

V aplikaci Photoshop je k dispozici sada předvoleb (Předvolby > Výkon), které pomáhají optimalizovat využívání prostředků počítače, například paměti, mezipaměti, grafického procesoru, monitoru atd. Podle toho, k čemu aplikaci Photoshop nejvíce používáte a s jakými typy dokumentů obecně pracujete, pro vás mohou být vhodné různé kombinace těchto nastavení.

Další nastavení, například možnost Odkládací disky, která jsou k dispozici na dalších kartách dialogového okna Předvolby, mohou mít na rychlost a stabilitu počítače také přímý vliv.

Předvolby výkonu v aplikaci Photoshop

Úprava velikosti paměti přidělené aplikaci Photoshop

Výkon můžete zlepšit tím, že aplikaci Photoshop přidělíte více paměti nebo paměti RAM. Informace o tom, kolik paměti RAM je k dispozici pro aplikaci Photoshop, jsou uvedeny v části Využití paměti v dialogovém okně předvoleb Výkon (Předvolby > Výkon). Je tam také uveden ideální rozsah přidělení paměti pro aplikaci Photoshop v daném systému.

Aplikace Photoshop standardně využívá 70 % dostupné paměti RAM.

  1. Chcete-li aplikaci Photoshop přidělit více paměti RAM, můžete změnit hodnotu v poli Dovolit pro Photoshop použít. Jinou možností je změnit nastavení pomocí posuvníku Využití paměti.
  2. Restartujte aplikaci Photoshop, aby se změny aktivovaly.

Jestliže chcete najít pro svůj systém ideální množství přidělené paměti RAM, měňte její přidělení s přírůstkem 5 % a sledujte výkon indikovaný ukazatelem Výkonnost. 

Doporučujeme nepřidělovat aplikaci Photoshop více než 85 % paměti počítače. Pokud byste to udělali, nezbyla by paměť pro další nepostradatelné systémové aplikace a došlo by ke snížení jejich výkonu.

Poznámka:

Jestliže v aplikaci Photoshop dochází k chybám způsobeným nedostatkem paměti nebo paměti RAM, zkuste zvýšit množství paměti RAM přidělené aplikaci Photoshop. Přidělením příliš velkého množství paměti (více než 85 %) aplikaci Photoshop však může být ovlivněn výkon jiných spuštěných aplikací, což může být příčinou nestability systému. 

Nejlepším řešením tohoto problému je zvýšení velikosti paměti RAM v počítači. Zkontrolujte u výrobce počítače specifikace a kompatibilitu paměti RAM.

Nastavení úrovní mezipaměti

Základní informace o mezipaměti

Aplikace Photoshop využívá v zájmu zrychlení překreslování dokumentů s vysokým rozlišením, se kterými pracujete, metodu ukládání obrazů do mezipaměti. Můžete nastavit až osm úrovní mezipaměti pro ukládání obrazových dat a vybrat si některou ze čtyř dostupných velikostí dlaždic.

Zvýšením počtu úrovní mezipaměti se zvýší rychlost odezvy aplikace Photoshop při práci, ale načítání obrazů bude trvat déle. Velikost dlaždice určuje množství dat, se kterými aplikace Photoshop pracuje současně. Při použití větších dlaždic probíhají rychleji složité operace (například zostření). Menší změny, například tahy štětcem, zase probíhají rychleji při použití menších dlaždic.

Předvolby týkající se mezipaměti

Předvolby týkající se mezipaměti jsou k dispozici na panelu předvoleb Výkon. Podle toho, k čemu aplikaci Photoshop nejvíce používáte, vyberte jednu z následujících možností:

  • Web / Návrh uživatelského rozhraní: Tuto možnost vyberte v případě, že aplikaci Photoshop používáte především k návrhu webů, aplikací a oken uživatelského rozhraní. Tato možnost je vhodná pro dokumenty s velkým počtem vrstev s položkami malých až středních rozměrů (v obrazových bodech).
  • Výchozí / Fotografie: Tuto možnost vyberte v případě, že aplikaci Photoshop používáte především k retušování nebo úpravě obrazů střední velikosti. Tuto možnost použijte například k běžné úpravě fotografií z mobilního zařízení nebo digitálního fotoaparátu v aplikaci Photoshop.
  • Velké rozměry v obr. bodech: Tuto možnost vyberte v případě, že v aplikaci Photoshop často pracujete s velkými dokumenty, například s panoramatickými obrazy, krajinomalbami apod.

Počet úrovní mezipaměti

Výchozí hodnota počtu úrovní mezipaměti je 4, ručně můžete nastavit jinou hodnotu.

  • Pokud používáte poměrně malé soubory – zhruba 1 megapixel neboli 1 280 ×1 024 pixelů – a mnoho vrstev (50 a více), nastavte počet úrovní mezipaměti na hodnotu 1 nebo 2. Nastavením počtu úrovní mezipaměti na hodnotu 1 zakážete ukládání obrazů do mezipaměti, takže v mezipaměti bude uložen pouze aktuální snímek obrazovky.
  • Pokud používáte soubory s většími rozměry – řekněme 50 megapixelů nebo větší – nastavte počet úrovní mezipaměti na hodnotu vyšší než 4. Při vyšším počtu úrovní mezipaměti je urychleno překreslování.
Poznámka:

Při nastavení počtu úrovní mezipaměti na hodnotu 1 nemusí výsledky některých funkcí aplikace Photoshop dosahovat vysoké kvality.

Omezení stavů historie

Omezením nebo snížením počtu stavů historie, které aplikace Photoshop ukládá na panelu Historie, můžete ušetřit místo na odkládacím disku a zlepšit celkový výkon. Velikost ušetřeného prostoru se liší v závislosti na tom, kolik obrazových bodů daná operace změní. Například stav historie založený na malém tahu štětcem nebo nedestruktivní operaci, jako je vytvoření nebo úprava vrstvy úprav, spotřebuje jen málo místa. Použití filtru na celý obraz naopak spotřebuje mnohem více prostoru.

Aplikace Photoshop může uložit až 1 000 stavů historie; výchozí počet je 50.

Chcete-li tento počet snížit, přejděte do dialogového okna předvoleb Výkon. V části Historie a vyrovnávací paměť
nastavte pro možnost Stavy historie nižší hodnotu.

Nastavení grafického procesoru (GPU)

Nejlepší způsob, jak optimalizovat akceleraci GPU, která urychluje překreslení obrazovky, je udržovat ovladač grafického adaptéru stále aktuální.  Pokyny k aktualizaci ovladačů grafické karty:

Viz Aktualizace ovladače grafické karty.

Další informace k tomu, jak aplikace Photoshop využívá grafický procesor, a také k testovaným kartám a k minimálním požadavkům na grafický procesor a zobrazovací zařízení: 

Viz Časté otázky týkající se GPU a grafického adaptéru v aplikaci Photoshop.

Předvolby týkající se grafického procesoru (GPU)

Nastavení týkající se grafického procesoru jsou v aplikaci Photoshop k dispozici v okně Předvolby v části Výkon a v části 3D.

Nastavení v části Předvolby > Výkon

Pokud je v systému detekována grafická karta, zobrazí se v oblasti Nastavení grafického procesoru v části Výkon pod Detekovaným grafickým procesorem její název.

  • Jestliže vaše grafická karta je podporována, je možnost Používat grafický procesor aktivní a políčko je ve výchozím nastavení zaškrtnuté.
  • Pokud vaše grafická karta není podporována, bude zaškrtávací políčko šedé a nebude ve výchozím nastavení zaškrtnuté.
  • Pokud vaše grafická karta podporována je, ale políčko Používat grafický procesor není zaškrtnuté, je to pravděpodobně proto, že aplikace Photoshop zjistila chybu způsobenou poškozeným ovladačem grafické karty nebo její konfigurací. Viz Odstraňování problémů s grafickým procesorem a ovladačem grafické karty v aplikaci Photoshop.

Další rozšířená nastavení:

  • Použít rozhraní OpenCL:Tuto volbu vypněte, pokud funkce Galerie nástroje Rozostření, Chytré zostření, Výběr oblasti zaměření nebo Velikost obrazu se zachováním detailů nefunguje podle očekávání.
  • Vyhlazovat vodítka a cesty: Tuto možnost deaktivujte, pokud se vodítka a cesty zdají být příliš těžké nebo široké.
  • 30bitové zobrazení: Tato možnost slouží ke zvýšení věrnosti barev na monitoru podporujícím 30bitové zobrazení.
Zakázat Open CL

Poznámka:

Zapnutím rozhraní OpenCL se pravděpodobně zlepší výkon, pokud používáte tyto funkce aplikace Photoshop:

  • Galerie nástroje Rozostření – Rozostření pole, Rozostření clony, Posun náklonu, Rozostření cesty, Rozostření otočením (s akcelerací přes rozhraní OpenCL)
  • Chytré zostření (Redukce šumu – s akcelerací přes rozhraní OpenCL)
  • Vybrat a maskovat (akcelerace pomocí knihoven OpenCL)

Nastavení v části Předvolby > 3D

Část 3D v dialogovém okně Předvolby obsahuje posuvník pro nastavení paměti RAM, který je podobný ovládacímu prvku pro nastavení paměti umístěnému v části Výkon. Pomocí tohoto posuvníku můžete určit horní limit velikosti grafické paměti RAM (VRAM) dostupné pro 3D modul aplikace Photoshop. Celková hodnota představuje procento celkové dostupné paměti VRAM. I při nastavení hodnoty 100 % zůstane část celkové paměti VRAM stále k dispozici pro použití operačním systémem. Vyšší hodnoty zaručují vyšší výkon při práci ve 3D, ale mohou snižovat výkon ostatních aplikací využívajících grafický procesor.

3D: Využití paměti

Správa odkládacích disků

Poznámka:

Pokud nelze aplikaci Photoshop spustit, protože odkládací disk je plný, podržte během spouštění aplikace stisknuté klávesy Cmd+Option (macOS) nebo Ctrl+Alt (Windows) a nastavte nový odkládací disk.

Při práci na v aplikaci Photoshop se může stát, že se zobrazí chyba odkládacího disku, kvůli které nemůžete dokončit požadovaný úkol. Ale co vlastně odkládací disk je?

Další informace o správě předvoleb odkládacích disků a doporučených nastaveních naleznete v tématu Nastavení odkládacích disků.

Další informace o řešení potíží s odkládacími disky naleznete v tématu Řešení chyb s odkládacím diskem v aplikaci Photoshop.

Indikátor výkonnosti

Během práce v aplikaci Photoshop sledujte výkon indikovaný ukazatelem Výkonnost. Klikněte na rozevírací nabídku v dolní části okna obrazu a vyberte příkaz Výkonnost.

Je-li hodnota v ukazateli nižší než 100 %, využila aplikace Photoshop veškerou dostupnou paměť RAM a používá odkládací disk, což zpomaluje výkon. Pokud je výkonnost nižší než 90 %, přidělte aplikaci Photoshop v předvolbách výkonu více paměti RAM. Případně můžete do systému přidat další paměť RAM.

Indikátor výkonnosti

Doladění funkcí aplikace Photoshop pro zlepšení výkonu

Vypnutí pravítek a překryvů

Viditelná pravítka a překryvy (jako jsou mřížky, řezy a automatická vodítka) mohou zpomalovat některé operace, například malování, transformaci a přetahování vrstev na plátně.

  • Pokud chcete vypnout pravítka, zrušte v nabídce Zobrazit zaškrtnutí položky Pravítka.
  • Chcete-li zakázat překryvy, přejděte do nabídky Zobrazení > Zobrazovat a vyberte možnost Žádné nebo zakažte jednotlivé položky.

Viz Zobrazení nebo skrytí netištěných prvků.

Práce v rámci omezení velikosti souboru

Velmi velké soubory jsou častou příčinou problémů s výkonem.

Aplikace Photoshop podporuje maximální velikost souboru 300 000 × 300 000 obrazových bodů, kromě souborů PDF, které jsou omezeny na 30 000 × 30 000 obrazových bodů a 200 × 200 palců, a zásuvného modulu Camera Raw, který podporuje obrázky dlouhé nebo široké maximálně 65 000 obrazových bodů a s maximálně 512 megapixely.

Povolená velikost souborů v aplikaci Photoshop:

  • Soubory PSD: 2 GB
  • Soubory TIFF: 4 GB
  • Soubory PSB: 4 exabajty (4 096 petabajtů nebo 4 miliony terabajtů)
  • Soubory PDF: 10 GB (stránky jsou omezeny na maximální velikost 200 palců – 508 cm)

Zavřete nepotřebná okna dokumentů

Pokud se zobrazí chybová zpráva „Nedostatek paměti RAM“ nebo pokud aplikace Photoshop běží pomalu, může to být způsobeno tím, že máte příliš mnoho otevřených obrazů. Máte-li otevřeno několik oken, zkuste některá z nich zavřít.

Snížení počtu přednastavení

Chcete-li zmenšit velikost prostoru využívaného aplikací Photoshop na odkládacím disku, minimalizujte počet přednastavení, jež načítáte. Mezi nejpočetnější přednastavení patří vzorky a hroty štětce. Přednastavení, která právě nepotřebujete, uložte do souboru přednastavení, poté je odeberte a načtěte je pouze v případě potřeby.

Další informace týkající se správy přednastavení najdete v článku Přednastavení.

Minimalizace nebo vypnutí zobrazení miniatur v okně náhledu

Při každé změně dokumentu aktualizuje aplikace Photoshop všechny miniatury, které se zobrazují na panelech VrstvyKanály. Tato aktualizace může ovlivnit její schopnost reagovat při rychlém malování, posunování nebo manipulaci s vrstvami. Čím více miniatur je zobrazeno, tím je tento efekt větší.

Pokud chcete tyto náhledy miniatur minimalizovat nebo zakázat, klikněte v nabídce Panel na položku Volby panelu. Vyberte menší velikost miniatury nebo zvolte možnost Žádné a potom klikněte na tlačítko OK.

Úprava možností kompatibility souborů

Pokud nepotřebujete pracovat se soubory ve formátu PSD a PSB ve starších verzích aplikace Photoshop nebo v aplikacích, které nepodporují vrstvy, můžete vypnout funkci kompatibility souborů a tím urychlit ukládání dokumentů:

  1. V okně Předvolby > Zpracování souborů vyberte pro 16bitové a 32bitové dokumenty PSD a PSB možnost Zakázat kompresi u souborů PSD a PSB.

  2. V nabídce Maximalizovat kompatibilitu souborů PSD a PSB zvolte možnost Vždy se zeptat nebo Nikdy.

Práce v 8bitovém obrazovém režimu

Aplikace Photoshop může provádět mnoho operací na 16bitových a 32bitových obrázcích. Nicméně tyto obrázky vyžadují více paměti, odkládacího prostoru a času na zpracování než 8bitové obrázky.

Chcete-li převést obrázek na 8 bitů na kanál, zvolte možnost Obraz > Režim > 8 bitů/kanál.

Viz Bitová hloubka a předvolby.

Poznámka:

Převodem na 8 bitů na kanál dojde k odstranění dat z obrázku. Než začnete obrázek převádět na 8 bitů na kanál, uložte si kopii původního 16bitového nebo 32bitového obrázku.

Vypnutí náhledu písma

Chcete-li urychlit zpracování písma v aplikaci Photoshop, vypněte seznam náhledů písem zvolením možnosti Text > Velikost náhledu písma > Žádný.

Snížení rozlišení obrazu

Čím větší je rozlišení obrazu, tím více paměti a místa na disku vyžaduje aplikace Photoshop k zobrazení, zpracování a vytištění obrázku. V závislosti na finálním výstupu nemusí vyšší rozlišení obrazu nutně poskytovat vyšší konečnou kvalitu obrazu, ale může snížit celkový výkon, spotřebovat další prostor na odkládacím disku a zpomalit tisk. Optimální rozlišení obrázků závisí na tom, jak je budete zobrazovat nebo tisknout. 

U obrázků prezentovaných na obrazovce uvažujte z hlediska celkových rozměrů v obrazových bodech. Chcete-li zmenšit rozměry obrázku, zvolte možnost Obraz > Velikost obrazu. V dialogovém okně Velikost obrazu zkontrolujte, zda je zaškrtnuta možnost Převzorkovat. Zadejte novou hodnotu rozměrů Šířka nebo Výška (zadáním hodnoty pro jeden se změní oba).

U tištěných obrazů přinese zvýšení rozlišení nad 360 DPI většinou jen nepatrné zlepšení, pokud vůbec nějaké. Pokud produkujete mnoho výtisků, experimentujte a zkuste najít rozlišení, které vám přinese příznivé výsledky. Chcete-li snížit rozlišení obrazu, zvolte možnost Obraz > Velikost obrazu. V dialogovém okně Velikost obrazu zaškrtněte možnost Převzorkovat. Změňte hodnoty šířky a výšky, aby odrážely fyzickou velikost tištěného dokumentu. Potom snižte hodnotu Rozlišení a klikněte na tlačítko OK.

Pokud se místo snížení chystáte rozlišení obrazu spíše zvýšit kvůli tisku, proveďte to jako jeden z posledních kroků před vytištěním snímku. Nebudete tak muset všechny dodatečné informace zpracovávat v předchozích krocích.

Vyčištění paměti

Výkon systému můžete zlepšit tím, že z aplikace Photoshop uvolníte nevyužitou paměť a místo na odkládacím disku, aby bylo k dispozici pro ostatní programy. Pokud tak chcete učinit, zvolte jednu z následujících možností:

  • Úpravy > Vyčistit > Vše
  • Úpravy > Vyčistit > Zpět
  • Podržte klávesu Option (macOS) nebo Alt (Windows) a vyberte možnost O aplikaci Photoshop.

Pokud se jiné programy aktivně snaží přidělit nebo využít paměť, uvolněním paměti v aplikaci Photoshop dojde ke zlepšení výkonu. Uvolnění prostoru na odkládacím disku bude přínosem, pokud vám dochází místo ve svazku disků. Jestliže uvolníte značnou část paměti nebo místa na disku, bude otevření dalšího velkého souboru v aplikaci Photoshop kvůli přidělovaní místa trvat déle.

Pokud chcete, aby aplikace Photoshop vždy využívala méně paměti, vyberte možnost Úpravy > Předvolby > Výkon (Windows) nebo Photoshop > Předvolby > Výkon (macOS) a posuňte posuvník Využití paměti doleva.

Viz Nastavení využití paměti.

Poznámka:

Nástroje pro sledování aktivity, správci úloh a diskové nástroje mohou změnu zaregistrovat až za několik sekund. U některých nástrojů budete dokonce muset explicitně požádat o aktualizaci.

Vyčištění schránky

Obsah schránky je často velký, pokud jste kopírovali a vkládali data v rámci velkých dokumentů. A po vložení už nemá tento obsah žádné využití. Chcete-li uvolnit paměť RAM používanou obrazovými daty ve schránce, zvolte možnost Úpravy > Vyčistit > Schránka.

Poznámka:

Příkaz Vyčistit nelze vrátit zpět.

Používání galerie filtrů

Pomocí Galerie filtrů lze na obrázku vyzkoušet jeden či více filtrů ještě před aplikováním efektů, což může ušetřit značné množství času a paměti.

Viz Přehled galerie filtrů.

Přetahování mezi soubory místo kopírování a vkládání

Přetahování vrstev nebo souborů je efektivnější než jejich kopírování a vkládání. Přetahování obchází Schránku a přenáší data přímo. Kopírování a vkládání může teoreticky vyžadovat přenos většího objemu dat a je mnohem méně efektivní.

Ukládání souborů TIFF bez komprese ZIP

Aby se zvýšila rychlost při exportu souborů TIFF, nevybírejte možnost komprese ZIP. (Komprese ZIP však vytváří nejmenší soubory TIFF.)

Zakázání exportu schránky

Možnost Exportovat schránku způsobí, že aplikace Photoshop poskytne obsah schránky k dispozici ostatním programům. Pokud v aplikaci Photoshop kopírujete velké množství dat, ale nebudete je vkládat do jiných aplikací, ušetřete čas vypnutím této možnosti:

  1. Vyberte položku Photoshop > Předvolby > Všeobecné (macOS) nebo Úpravy > Předvolby > Všeobecné (Windows).

  2. Zrušte zaškrtnutí volby Exportovat schránku.

  3. Klikněte na tlačítko OK.

Deaktivace panelu Knihovny

  1. V kontextové nabídce Knihovny vyberte příkaz Zavřít.

  2. Restartujte aplikaci Photoshop.

Zakázání generátoru

  1. Vyberte možnost Úpravy > Předvolby > Zásuvné moduly.

  2. Zrušte výběr možnosti Povolit generátor.

  3. Klikněte na tlačítko OK.

Tvorba kompozic v aplikaci Photoshop

Tvorba kompozice je proces skládání několika vizuálních prvků dohromady do jednoho snímku, který představuje váš dokument. Interní modul pro tvorbu kompozic v aplikaci Photoshop se během používání aplikace tisíckrát propočítává a neustále zobrazuje každou změnu provedenou v obrázku dohromady jako jedinou kompozici.

Vícevláknová kompozice

Ve verzi aplikace Photoshop 22.3 z dubna 2022 můžete nyní aktivovat vícevláknovou kompozici tak, že přejdete do nastavení Předvolby > Výkon a zaškrtnete políčko Vícevláknová kompozice. Aby se tato změna projevila, není nutné aplikaci Photoshop restartovat. 

Vícevláknová kompozice

Vrstvy úprav, masky vrstev, režimy prolnutí, filtry, styly a efekty zvyšují složitost zpracování dokumentu, která může snížit rychlost zpracování aplikace Photoshop. Můžete si všimnout, že různé úpravy prováděné pomocí posuvníků se na obrazovce neaktualizují tak rychle, jako tomu bylo před přidáním všech těchto vrstev a efektů. Vícevláknová kompozice urychluje kompoziční úlohy využívající CPU a GPU tím, že rozděluje výpočetní práci na menší části, které lze spustit paralelně, často rychleji, než by mohly být vypočteny v jediném „vlákně“.

I když existuje řada důvodů, proč mohou dokumenty při práci v aplikaci Photoshop reagovat pomaleji, zrychlení tvorby kompozice v rozsahu 100 % až 250 % pomocí vícevláknové kompozice výrazně přispívá k tomu, že Photoshop může reagovat tak rychle a plynule, jak potřebuje.

Jestliže si všimnete chyb při překreslování a máte podezření, že problém tkví ve vícevláknové kompozici, můžete tuto funkci vypnout v nastavení Předvolby > Výkon. Pokud máte dotaz nebo se chcete podělit o svůj problém s tímto nastavením, dejte nám vědět v komunitě aplikace Adobe Photoshop. Rádi s vámi vše probereme!

Poznámka:

Vícevláknová kompozice nahrazuje dřívější upozornění na odebrání staršího modulu kompozice, které již není potřeba a nyní bylo odstraněno.

Tvorba kompozic akcelerovaná GPU

Ve verzi aplikace Photoshop 22.3 z dubna 2022 byla přidána tvorba kompozic pomocí GPU, aby se zlepšila odezva určitých operací vrstvy v dokumentu. Tvorbu kompozic pomocí GPU je možné použít jenom v případě, že aplikace Photoshop správně detekuje GPU při spuštění. Pokud si to chcete potvrdit, přejděte na Předvolby > Výkon a ověřte, jestli je váš grafický procesor uvedený v oddílu Nastavení grafického procesoru a jestli je zaškrtnutá volba Používat grafický procesor.

Zaškrtávací políčko pro zapnutí nebo vypnutí tvorby kompozic pomocí GPU je dostupné po kliknutí na tlačítko Rozšířená nastavení

Tvorba kompozic s využitím GPU

U menších, méně složitých dokumentů obsahujících málo vrstev a úprav založených na vrstvách (např. režimy prolnutí, vrstvy úprav) nemusíte při zapnutí nebo vypnutí režimů prolnutí nebo viditelnosti vrstev zaznamenat žádné snížení výkonu. S rostoucí složitostí a velikostí dokumentů však může být od modulu pro tvorbu kompozici v aplikaci Photoshop požadováno, aby prováděl více zpracování v reálném čase a doba potřebná k zobrazení výsledků na obrazovce se může prodloužit. U velmi složitých dokumentů jste si možná všimli, že přesun obsahu vrstvy nebo změna krytí trvá o zlomek sekundy déle, než se obrazovka aktualizuje a zobrazí výsledky. S povolenou tvorbou kompozic s využitím GPU bude aplikace Photoshop využívat větší výpočetní výkon grafického procesoru k urychlení kompozice a plynulejším úpravám.

Pokud při provádění těchto úprav založených na vrstvách narazíte na neočekávané výsledky, můžete zkusit tuto možnost zakázat a zjistit, zda se tím výsledky změní. 

Máte nějaký dotaz nebo nápad?

Zeptejte se komunity

Pokud máte dotaz nebo se chcete podělit o svůj nápad, zapojte se do komunity aplikace Adobe Photoshop. Vašeho názoru si ceníme!


 Adobe

Získejte pomoc rychleji a snáze

Nový uživatel?

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX 2024

Adobe MAX
Konference věnovaná tvořivosti

14.–16. října Miami Beach a online

Adobe MAX

Konference věnovaná tvořivosti

14.–16. října Miami Beach a online