Hinweis:

Die OpenGL-Funktionalität in After Effects CS6 unterscheidet sich von der OpenGL-Funktionalität in früheren Versionen. Dieses Dokument bezieht sich nur auf After Effects CS4 bis CS5.5. Weitere Informationen zu GPU-Funktionen in After Effects CS6 finden Sie im entsprechenden Video.

Dieses Dokument bietet Hilfe bei der Lösung von Problemen mit OpenGL, die im Zusammenhang mit After Effects auftreten. OpenGL-Probleme können an verschiedenen Merkmalen erkannt werden. Dazu gehören beispielsweise:

  • Adobe After Effects stürzt ab oder wird beim Starten ohne Fehlermeldung beendet.
  • Absturz oder keine Reaktion bei Bewegungen in der Zeitleiste, bei der Anzeige einer Vorschau oder beim Rendern einer Komposition.
  • Absturz, wenn Sie die Einstellungen eines Effekts ändern, während OpenGL-Vorschaubilder aktiviert sind.
  • Absturz oder keine Reaktion, wenn Sie OpenGL-Vorschaubilder aktiveren oder deaktivieren.
  • Die Aktualisierung des Kompositionsfensters dauert lange.
  • Im Kompositionsfenster werden Artefakte oder Blöcke aus unbrauchbaren Pixeln gezeichnet.
  • Das Kompositionsfenster wird unterschiedlich gezeichnet, je nachdem, ob OpenGL-Vorschaubilder aktiviert oder deaktiviert sind.
  • Eine der folgenden Fehlermeldungen:

    „After Effects-Warnung: Bei der Verarbeitung der OpenGL-Befehle ist ein Fehler aufgetreten.“

    „Die Anweisung in '0x00fe1940' verweist auf Speicher in '0x000000000'. Der Speicher konnte nicht gelesen werden.“

    „AE_OpenGL: Schattenzuordnung konnte nicht generiert werden. (5065::0)“

    „Diese Komposition ist zu komplex für die OpenGL-Hardware.“

    „After Effects-Fehler: AE_OpenGL: Fehler beim Erstellen der Struktur. (5065 :: 0)“

Weitere Informationen zum Konfigurieren der Vorschau-Voreinstellungen in After Effects für OpenGL und eine Liste von Elementen in After Effects, die mit OpenGL gerendert werden können, finden Sie in der After Effects-Hilfe unter Rendern mit OpenGL.

Führen Sie die Aufgaben in der angegebenen Reihenfolge aus. Notieren Sie sich die durchgeführten Aufgben und deren Ergebnisse, einschließlich Fehler und anderer Probleme. Wenn Sie sich an den technischen Support von Adobe wenden, können Ihnen die Mitarbeiter durch diese Informationen bessere Unterstützung bieten.

Sie müssen als Administrator angemeldet sein, um einige der Schritte in diesem Dokument durchzuführen.

Unter Windows: Bei einigen Vorgehensweisen müssen Sie versteckte Dateien und Ordner suchen. Bei manchen Vorgehensweisen müssen Sie Dateien anhand der vollständigen Dateinamen einschließlich der Erweiterungen (wie „beispiel_dateiname.ini“) ausfindig machen. Standardmäßig werden in Windows Explorer keine versteckten Dateien, versteckten Ordner und bekannten Dateinamenerweiterungen angezeigt. Weitere Details finden Sie unter Ausgeblendete Dateien und Ordner in Windows anzeigen.

Bei Windows Vista beziehen sich die Schritte im Zusammenhang mit der Systemsteuerung in diesem Dokument auf die klassische Ansicht. Weitere Informationen zum Anzeigen der Systemsteuerung in der klassischen Ansicht und andere übliche Verfahren beim Betriebssystem finden Sie unter Übliche Verfahren im Zusammenhang mit dem Betriebssystem.

Diese Schritte können Ihnen helfen, die meisten Probleme mit OpenGL zu lösen. Bevor Sie die jeweiligen Schritte durchführen, sichern Sie alle persönlichen Dateien (beispielsweise von Ihnen erstellte After Effects-Dateien). Starten Sie den Computer nach einem Systemfehler immer neu, um den Speicher zu aktualisieren. Andernfalls kann der Fehler sich verschlimmern.

1. Installieren Sie die neueste Version von After Effects.

Um nach Updates zu suchen, wählen Sie „Hilfe“ > „Updates in After Effects“.

2. Vergewissern Sie sich, dass das Computersystem die Mindestanforderungen für After Effects erfüllt.

Eine Liste der Systemanforderungen finden Sie auf dieser Seite: Systemanforderungen für Adobe After Effects

3. Vergewissern Sie sich, dass die Grafikkarte und Treiber die Anforderungen für OpenGL erfüllen.

Verwenden von OpenGL in After Effects erfordert eine OpenGL-Karte, die OpenGL 2.0 unterstützt.

Um festzustellen, welche OpenGL-Version Ihre Karte unterstützt, klicken Sie in den Vorschau-Voreinstellungen auf die Schaltfläche „OpenGL-Info“. Wählen Sie in Mac OS „After Effects“ > „Voreinstellungen“ > „Vorschau“. Wählen Sie in Windows „Bearbeiten“ > „Voreinstellungen“ > „Vorschau“.

Weitere Informationen zu unterstützter OpenGL-Hardware finden Sie unter GPU-(CUDA, OpenGL) Funktionen.

Neuere Videokartentreiber können die OpenGL-Fähigkeiten Ihrer Karte verbessern. Siehe Aktualisieren des Grafikkartentreibers weiter unten.

4. Deaktiveren Sie OpenGL, um festzustellen, ob das Problem hierdurch verursacht wird.

Deaktiveren der Vorschau von OpenGL:

  1. Wählen Sie „After Effects“ > „Voreinstellungen“ > „Vorschau“ (Mac OS) oder „Bearbeiten“ > „Voreinstellungen“ > „Vorschau“ (Windows).
  2. Deaktivieren Sie die Option „OpenGL aktivieren“.

Hinweis: Einige Funktionen in After Effects werden von OpenGL nicht unterstützt, und Ihre Komposition kann in einer OpenGL-Vorschau anders aussehen als in einer softwaregerenderte Vorschau. Weitere Informationen zu Funktionen, die von OpenGL unterstützt werden, finden Sie in der After Effects-Hilfe im Abschnitt zum Rendern und Exportieren unter Rendern mit OpenGL.

5. Entfernen Sie das Zusatzmodul OpenGL aus dem After Effects-Ordner für Zusatzmodule.

Um festzustellen, ob OpenGL das Problem verursacht hat, entfernen Sie das OpenGL-Zusatzmodul und starten Sie After Effects neu.

Entfernen des Zusatzmoduls OpenGL:

  1. After Effects beenden.
  2. Mac OS: Ziehen Sie die Datei „AE_OpenGL.plugin“ aus dem Ordner „Programme/Adobe After Effects CS4/Plug-ins/Extensions“ auf den Desktop.

    Windows: Ziehen Sie die Datei „AE_OpenGL.AEX“ aus dem Ordner „C:\Programme\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions“ auf den Desktop.
  3. Starten Sie After Effects neu.

Wenn das Problem noch einmal auftritt, ist es nicht von OpenGL verursacht worden. Verschieben Sie das Zusatzmodul „OpenGL“ wieder an seinen ursprünglichen Speicherort. Wenn der Fehler nicht mehr auftritt, ist OpenGL die Ursache des Problems. Siehe Aktualisieren des Grafikkartentreibers weiter unten.

6. Aktualisieren Sie den Grafikkartentreiber.

Die meisten Probleme und Konflikte mit OpenGL werden durch Aktualisieren des Grafikkartentreibers gelöst. Viele Hersteller von Grafikkarten aktualisieren ihre Softwaretreiber regelmäßig. Wenn Sie den Grafikkartentreiber länger nicht mehr aktualisiert haben, erkundigen Sie sich beim Hersteller der Karte nach einem aktualisierten Treiber oder laden Sie ihn von der Website des Herstellers herunter.

7. Starten Sie After Effects erneut und wiederholen Sie den Vorgang, der zum Absturz geführt hat. (Nur Windows)

Nach einem Absturz, der durch ein OpenGL-Problem unter Windows verursacht wurde, kann After Effects CS4 automatisch die Voreinstellung „DLL-Adressraum nicht fragmentieren“ deaktivieren. Durch diese Voreinstellung kann After Effects auf mehr zusammenhängenden RAM-Speicher zugreifen, sie ist jedoch unter Umständen nicht mit allen OpenGL-Treibern kompatibel.

Sie können die Voreinstellung „DLL-Adressraum nicht fragmentieren“ aktivieren bzw. deaktivieren, indem Sie „Bearbeiten“ > „Voreinstellungen“ > „Speicher und Cache“ wählen.

Lassen Sie diese Voreinstellung aktiviert, es sei es das System stürzt aufgrund von OpenGL- oder Speicherproblemen ab. Wenn Sie die Voreinstellung wegen eines OpenGL-Problems deaktivieren und zu einem späteren Zeitpunkt die Grafikkartentreiber deaktivieren, aktivieren Sie die Voreinstellungen erneut. Testen Sie dann erneut, ob das Problem weiterhin auftritt.

8. Optimieren Sie die Voreinstellung für den Strukturspeicher.

Abstürze und OpenGL-Fehler können auftreten, wenn durch After Effects zu viel Grafikstrukturspeicher verwendet wird. Strukturspeicher ist die Größe des RAM-Speichers auf der Grafikkarte (VRAM).

Festlegen der Voreinstellung für den Strukturspeicher in After Effects:

  1. Die optimale Einstellung für den Strukturspeicher beträgt 80 % des insgesamt installierten VRAM.
  2. Wählen Sie in After Effects „After Effects“ > „Voreinstellungen“ > „Vorschau“ (Mac OS) oder „Bearbeiten“ > „Voreinstellungen“ > „Vorschau“ (Windows).
  3. Klicken Sie auf „OpenGL-Info“.
  4. Geben Sie den in Schritt 1 berechneten Wert ein und klicken Sie auf „OK“.

Der optimale Strukturspeicherwert entspricht 80 % des VRAM-Speichers auf der Grafikkarte. (Wenn Sie mehrere Grafikkarten verwenden, beträgt der optimale Wert 80 % des VRAM-Speichers auf der Grafikkarte, die im Dialogfeld „OpenGL-Informationen“ genannt wird.) Wenn die Voreinstellung für den Strukturspeicher in After Effects auf mehr als 80 % VRAM eingestellt ist, ist möglicherweise nicht mehr genügend VRAM verfügbar, damit die Grafikkarte die Benutzeroberfläche oder andere Aufgaben verarbeiten kann. (Beispielsweise kann der gesamte Bildschirm weiß werden.) Wenn ein Wert unter 80 % festgelegt wird, kann bei einer OpenGL-Vorschau in After Effects die Verarbeitung von Frames länger dauern.

Hinweise zur Menge des VRAM auf einer Grafikkarte finden Sie in der Mac OS-Hilfe oder der Windows-Hilfe.

9. Leeren Sie den Bildcache und Grafikspeicher.

Wenn After Effects im Kompositionsfenster Artefakte oder unbrauchbare Pixelblöcke anzeigt, ist der Grafikspeicher (VRAM) möglicherweise voll, fragmentiert oder beschädigt. Leeren Sie den Bildcache und Grafikspeicher, um freien VRAM-Speicher zu gewinnen, und lassen Sie After Effects die Vorschau des Kompositionsfensters erneut aufbauen.

Um den Bildcache zu leeren, wählen Sie „Bearbeiten“ > „Entleeren“ > „Bildcache“.

Um den Grafikspeicher zu leeren, wählen Sie „Bearbeiten“ > „Entleeren“ > „Grafikspeicher“.

Hinweis: Manche Bildschirmschoner, die OpenGL (oder Direct3D unter Windows) verwenden, können den Grafikspeicher beschädigen, wenn sie aktiviert werden, während After Effects ausgeführt wird. Wechseln oder deaktivieren Sie den Bildschirmschoner, wenn Sie nach Abschalten des Bildschirmschoners häufig Probleme mit beschädigten Bildern im Kompositionsfenster haben.

10. Setzen Sie die Farbeinstellung für die Grafikkarte auf „Höchste“ (32 Bit) (Windows) oder „Millionen“ (Mac OS).

Weitere Informationen zum Ändern der Grafikkarten- und Anzeigeeinstellungen finden Sie in der Hilfe zu Mac OS bzw. Windows.

11. Deaktiveren Sie erweiterte Funktionen der Grafikkarte (Nur Windows)

Die meisten Grafikkartentreiber enthalten Dienstprogramme für den Zugriff auf erweiterte Funktionen der Karte. Insbesondere können Antialiasing- und 16-Bit-Modus-Funktionen zu Konflikten mit OpenGL führen und After Effects zum Absturz bringen. Setzen Sie die erweiterten Funktionen der Karte auf ihre Standardeinstellungen und deaktivieren Sie anschließend die Antialiasing- und 16-Bit-Modus-Optionen.

Wenn Sie mehrere Monitore mit einer Nvidia-Karte verwenden, setzen Sie die Einstellung für mehrere Monitore auf „Kompatibel“.

Weitere Informationen zu erweiterten Funktionen finden Sie in der Dokumentation zur Grafikkarte oder auf der Website des Herstellers.

12. Verwenden Sie einen einzigen Monitor.

Wenn Sie mehrere Monitore verwenden und in After Effects Probleme mit OpenGL haben, versuchen Sie Folgendes:

  • Wenn das Hauptfenster von After Effects oder das Kompositionsfenster auf einem zweiten Monitor angezeigt wird, verschieben Sie es wieder zum ersten Monitor.
  • Trennen Sie alle bis auf einen Monitor vom System.
  • Wenn Sie mehrere Grafikkarten verwenden, entfernen Sie alle bis auf eine Grafikkarte. Beste Ergebnisse mit OpenGL lassen sich mit einer einzigen Dual-Head-Grafikkarte erzielen.

13. Platzieren Sie das Skript „Reduce OpenGL Texture Size“ in den Ordner für Startskripte.

Das Skript „Reduce OpenGL Texture Size“ reduziert die Größe des von After Effects verwendeten Strukturspeichers und kann für bessere Kompatibilität mit älteren Grafikkarten sorgen.

Platzieren des Skripts „Reduce OpenGL Texture Size“ in den Ordner für Startskripte:

  1. Navigieren Sie zum Skript-Ordner von After Effects.

    Unter Mac OS: Applications/Adobe After Effects CS4/Scripts.

    Windows: „C:\Programme\Adobe\Adobe After Effects CS4\Support Files\Scripts“
  2. Verschieben Sie die Datei „Reduce OpenGL Texture Size.jsx“ aus dem Support-Ordner in den Start-Ordner.

Eine neuere Grafikkarte kann die OpenGL-Fähigkeiten Ihres Computers verbessern und das Skript ist dann nicht mehr erforderlich. Wenn Sie eine neue Karte mit Treibern installiert haben, verschieben Sie das Skript „Reduce OpenGL Texture Size“ wieder in den Support-Ordner. Setzen Sie dann die After Effects-Voreinstellungen zurück.

14. Setzen Sie die After Effects-Voreinstellungen zurück.

Erstellen Sie die Datei „After Effects-Voreinstellungen“ erneut, um Probleme zu vermeiden, die von beschädigten OpenGL-Voreinstellungen verursacht werden können.

Um die Datei „After Effects-Voreinstellungen“ neu zu erstellen, starten Sie After Effects erneut. Halten Sie die Tasten Strg+Alt+Umschalt (Windows) oder Befehl+Option+Umschalt (Mac OS), während die Anwendung startet.

15. Nehmen Sie mit dem technischen Support von Adobe Kontakt auf.

Wenn durch die beschriebenen Schritte der Fehler oder das Nichtreagieren von After Effects nicht behoben werden konnte, wenden Sie sich an den technischen Support von Adobe. Die Supportoptionen finden Sie im Adobe-Support.

 

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie