Sie sehen sich Hilfeinhalte der folgenden Version an:

Vorsicht:

Informationen zur Verwendung der klassischen Benutzeroberfläche finden Sie in der Dokumentation zu AEM 6.3.

Sie erstellen ein Workflow-Modell, um die Schritte zu definieren, die ausgeführt werden, wenn ein Benutzer den Workflow startet. Sie können auch Modelleigenschaften definieren, um beispielsweise festzulegen, ob es sich um einen Übergangs-Workflow handelt oder der Workflow mehrere Ressourcen verwendet.

Wenn ein Benutzer einen Workflow startet, wird eine Instanz gestartet. Dabei handelt es sich um das entsprechende Laufzeitmodell, das erstellt wird, wenn Sie Ihre Änderungen durch Klicken auf Sync synchronisieren.

Erstellen neuer Workflows

Wenn Sie zum ersten Mal ein neues Workflow-Modell erstellen, umfasst es Folgendes:

  • Die Schritte Prozessstart und Prozessende.
    Diese stellen den Anfang und das Ende des Workflows dar. Diese Schritte sind erforderlich und können nicht bearbeitet bzw. entfernt werden. 
  • Ein Teilnehmer-Beispielschritt namens Schritt 1.
    Dieser Schritt ist so konfiguriert, dass er dem Workflow-Initiator ein Arbeitselement zuordnet. Sie können diesen Schritt nach Bedarf bearbeiten oder löschen und Schritte hinzufügen.

Gehen Sie folgendermaßen vor, um einen neuen Workflow mit dem Editor zu erstellen:

  1. Öffnen Sie die Workflow-Modelle-Konsole über Tools > Workflow > Modelle oder beispielsweise über:

    http://localhost:4502/aem/workflow

  2. Wählen Sie dann Erstellen und dann Modell erstellen aus.

  3. Daraufhin wird das Dialogfeld Workflow-Modell hinzufügen angezeigt. Geben Sie den Titel und den Namen (optional) ein. Wählen Sie anschließend Fertig aus.

  4. Das neue Modell wird nun in der Workflow-Modelle-Konsole aufgeführt.

  5. Wählen Sie Ihren neuen Workflow aus und öffnen Sie ihn dann, indem Sie auf Bearbeiten klicken, um ihn zu konfigurieren:

    wf-01

Hinweis:

Wenn Sie Modelle programmgesteuert (mithilfe eines CRX-Pakets) erstellen, können Sie auch einen Unterordner erstellen:

/var/workflow/models

Beispiel: /var/workflow/models/prototypes

Dieser Ordner kann anschließend zum Verwalten des Zugriffs auf die Modelle in diesem Ordner verwendet werden.

Bearbeiten von Workflows

Sie können jedes vorhandene Workflow-Modell zu folgenden Zwecken bearbeiten:

Das Bearbeiten eines (vordefinierten) Standard- bzw. Legacy-Workflows umfasst einen zusätzlichen Schritt, um sicherzustellen, dass eine sichere Kopie erstellt wird, bevor Sie Änderungen vornehmen.

Wenn Sie mit den Änderungen an Ihrem Workflow fertig sind, müssen Sie zum Generieren eines Laufzeitmodells auf Sync klicken. Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Synchronisieren von Workflows – Generieren von Laufzeitmodellen

Wenn Sie rechts in der Editor-Symbolleiste auf Sync klicken, wird ein Laufzeitmodell generiert. Das Laufzeitmodell ist das Modell, das tatsächlich verwendet wird, wenn ein Benutzer einen Workflow startet. Wenn Sie Ihre Änderungen nicht durch Klicken auf Sync synchronisieren, stehen diese nicht zur Laufzeit zur Verfügung.

Wenn Sie (oder andere Benutzer) Änderungen am Workflow vornehmen, müssen Sie auf Sync klicken, um ein Laufzeitmodell zu erstellen, auch wenn einzelne Dialogfelder (z. B. für Schritte) eigene Optionen zum Speichern aufweisen.

Nachdem die Änderungen mit dem (gespeicherten) Laufzeitmodell synchronisiert wurden, wird stattdessen Synchronisiert angezeigt.

Bei einigen Schritten gibt es Pflichtfelder und/oder eine integrierte Validierung. Wenn die entsprechenden Bedingungen nicht erfüllt sind, wird eine Fehlermeldung angezeigt, falls Sie versuchen, das Modell mithilfe der Option Sync zu synchronisieren. Etwa wenn für einen Teilnehmer-Schritt kein Teilnehmer definiert wurde:

WF-21

Erstmaliges Bearbeiten von Standard- oder Legacy-Workflows

Wenn Sie ein Standard- bzw. Legacy-Modell zur Bearbeitung öffnen, finden Sie die folgenden Bedingungen vor:

  • Der Schritte-Browser (auf der linken Seite) ist nicht verfügbar.
  • Die Symbolleiste weist eine Option zum Bearbeiten auf (auf der rechten Seite).
  • Zunächst werden das Modell und seine Eigenschaften im schreibgeschützten Modus wie folgt dargestellt:
    • Standard-Workflows befinden sich unter /libs.
    • Legacy-Workflows befinden sich unter /etc
      .

Durch Auswahl von Bearbeiten geschieht Folgendes:

  • Es wird eine Kopie des Workflows unter /conf gespeichert.
  • Der Schritte-Browser wird verfügbar gemacht.
  • Sie erhalten die Möglichkeit, Änderungen vorzunehmen.

Hinweis:

Unter Speicherorte von Workflow-Modellen finden Sie weitere Informationen.

WF-22

Hinzufügen von Schritten zu Modellen

Sie müssen zu Ihrem Modell Schritte hinzufügen, um die auszuführende Aktivität darzustellen. Mit jedem Schritt wird eine bestimmte Aktivität ausgeführt. In einer Standard-AEM-Instanz stehen unterschiedliche Schrittkomponenten zur Auswahl. 

Wenn Sie ein Modell bearbeiten, werden die verfügbaren Schritte in den verschiedenen Gruppen des Schritte-Browsers angezeigt. Beispiel:

wf-10

Hinweis:

Weitere Informationen zu den primären Schrittkomponenten, die mit AEM installiert werden, finden Sie in der Referenz für Workflow-Schritte.

Gehen Sie folgendermaßen vor, um Schritte zu Ihrem Workflow-Modell hinzuzufügen:

  1. Öffnen Sie ein vorhandenes Workflow-Modell zur Bearbeitung. Wählen Sie in der Workflow-Modelle-Konsole das gewünschte Modell aus und klicken Sie anschließend auf Bearbeiten.  

  2. Öffnen Sie über das Symbol Seitliches Bedienfeld ein/aus links in der oberen Symbolleiste den Schritte-Browser. Folgende Informationen/Optionen sind verfügbar:

    • Die Option Filter zum Filtern nach bestimmten Schritten.
    • Verwenden Sie das Dropdown-Menü, um die Auswahl auf eine bestimmte Gruppe von Schritten zu begrenzen.
    • Über das Symbol „Beschreibung anzeigen“  können Sie weitere Informationen zum jeweiligen Schritt anzeigen.
    wf-02
  3. Ziehen Sie die entsprechenden Schritte an die gewünschte Stelle im Modell,

    beispielsweise einen Teilnehmer-Schritt.

    Nachdem Sie ihn zum Workflow hinzugefügt haben, können Sie den Schritt konfigurieren.

    wf-03
  4. Fügen Sie nach Bedarf Schritte hinzu oder nehmen Sie andere Änderungen vor.

    Zur Laufzeit werden die Schritte in der Reihenfolge ausgeführt, in der sie im Modell erscheinen. Nachdem Sie Schrittkomponenten hinzugefügt haben, können Sie diese an eine andere Stelle im Modell ziehen.

    Sie können vorhandene Schritte wie beim Seiten-Editor darüber hinaus kopieren, ausschneiden, einfügen, gruppieren oder löschen.

    Unterteilte Schritte können auch mithilfe der Symbolleistenoption ein- oder ausgeblendet werden. 

  5. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Konfigurieren von Workflow-Schritten

Sie können das Verhalten von Workflow-Schritten über das Dialogfeld Schritt-Eigenschaften konfigurieren und anpassen.

  1. Führen Sie zum Öffnen des Dialogfelds Schritt-Eigenschaften einen der folgenden Schritte durch:

    • Klicken/tippen Sie auf den Schritt im Workflow-Modell und wählen Sie in der Komponenten-Symbolleiste die Option Konfigurieren aus.
    • Doppelklicken Sie auf den Schritt.

    Hinweis:

    Weitere Informationen zu den primären Schrittkomponenten, die mit AEM installiert werden, finden Sie in der Referenz für Workflow-Schritte.

  2. Konfigurieren Sie die Schritt-Eigenschaften nach Bedarf. Die jeweils verfügbaren Eigenschaften hängen vom Schritttyp ab, ggf. stehen auch mehrere Registerkarten zur Verfügung. Beispiel: der standardmäßige Teilnehmer-Schritt, der in einem neuen Workflow als Schritt 1 enthalten ist:

    WF-11
  3. Bestätigen Sie Ihre Änderungen durch Klicken auf das Häkchen-Symbol.

  4. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Erstellen von Übergangs-Workflows

Sie können ein Übergangs-Workflow-Modell erstellen, wenn Sie ein neues Modell erstellen oder ein vorhandenes Modell bearbeiten:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus.

  3. Aktivieren Sie im Dialogfeld das Kontrollkästchen Übergangs-Workflow (bzw. deaktivieren Sie es, falls erforderlich):

    wf-07
  4. Bestätigen Sie die Änderung mit Speichern und schließen und klicken Sie anschließend in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Hinweis:

Beim Ausführen eines Workflows im Übergangsmodus speichert AEM keinen Workflow-Verlauf. Aus diesem Grund werden in der Timeline keine Informationen zu diesem Workflow angezeigt.

Konfigurieren von Workflows für die Unterstützung für mehrere Ressourcen

Sie konfigurieren ein Workflow-Modell für die Unterstützung für mehrere Ressourcen, wenn Sie ein neues Modell erstellen oder ein vorhandenes Modell bearbeiten:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus.

  3. Aktivieren Sie im Dialogfeld das Kontrollkästchen Unterstützung für mehrere Ressourcen (bzw. deaktivieren Sie es, falls erforderlich):

    wf-08
  4. Bestätigen Sie die Änderung mit Speichern und schließen und klicken Sie anschließend in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Konfigurieren von Workflow-Phasen (die den Workflow-Fortschritt anzeigen)

Die Workflow-Phasen helfen Ihnen bei der Visualisierung des Fortschritts bei der Verarbeitung von Aufgaben.

Vorsicht:

Wenn Workflow-Phasen in Seiteneigenschaften definiert sind, aber für keinen der Workflow-Schritte verwendet werden, zeigt der Fortschrittsbalken keinen Fortschritt an (unabhängig vom aktuellen Workflow-Schritt).

Die jeweils verfügbaren Phasen werden in den Workflow-Modellen definiert. Die vorhandenen Workflow-Modelle können aktualisiert werden, um die Phasendefinitionen einzubinden. Sie können eine beliebige Anzahl von Phasen für das Workflow-Modell definieren. 

Gehen Sie folgendermaßen vor, um Phasen zu definieren:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus. Wechseln Sie dann zur Registerkarte Phasen.

  3. Fügen Sie Ihre gewünschten Phasen hinzu (und positionieren Sie sie). Sie können beliebig viele Phasen für das Workflow-Modell definieren.

    Beispiel:

    wf-08
  4. Klicken Sie zum Speichern der Eigenschaften auf Speichern und schließen.

  5. Ordnen Sie jedem der Schritte im Workflow-Modell eine Phase zu. Beispiel:

    wf-09

    Eine Phase kann mehreren Schritten zugeordnet werden. Beispiel:

    Schritt Phase
    Schritt 1 Erstellen
    Schritt 2 Erstellen
    Schritt 3 Überprüfen
    Schritt 4 Genehmigen
    Schritt 5 Genehmigen
    Schritt 6 Fertig stellen
  6. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Exportieren von Workflow-Modellen in Pakete

Gehen Sie folgendermaßen vor, um ein Workflow-Modell in ein Paket zu exportieren:

  1. Erstellen Sie mit Package Manager ein neues Paket:

    1. Navigieren Sie über Tools > Bereitstellung > Pakete zu Package Manager.
    2. Klicken Sie auf Paket erstellen.
    3. Geben Sie den Paketnamen sowie alle weiteren erforderlichen Informationen an.
    4. Klicken Sie auf OK.
  2. Klicken Sie in der Symbolleiste Ihres neuen Pakets auf Bearbeiten.

  3. Öffnen Sie die Registerkarte Filter.

  4. Wählen Sie Filter hinzufügen und geben Sie den Pfad zum Design Ihres Workflow-Modells ein:

    /conf/global/settings/workflow/models/<Name-Ihres-Modells>

    Klicken Sie auf Fertig.

  5. Wählen Sie Filter hinzufügen und geben Sie den Pfad zu Ihrem Laufzeit-Workflow-Modell ein:

    /var/workflow/models/<Name-Ihres-Modells>

    Klicken Sie auf Fertig.

  6. Fügen Sie weitere Filter für alle benutzerdefinierten Skripte hinzu, die von Ihrem Modell verwendet werden.

  7. Klicken Sie auf Speichern, um Ihre Filterdefinitionen zu bestätigen.

  8. Wählen Sie in der Symbolleiste Ihrer Paketdefinition die Option Build aus.

  9. Wählen Sie in der Symbolleiste Ihres Pakets die Option Herunterladen aus.

Verwenden von Workflows zum Verarbeiten von Formularübermittlungen

Sie können ein Formular so konfigurieren, dass es durch den ausgewählten Workflow verarbeitet wird. Wenn Benutzer das Formular übermitteln, wird eine neue Workflow-Instanz mit den Daten der Formularübermittlung als Nutzlast erstellt.

Gehen Sie folgendermaßen vor, um den Workflow zur Verwendung mit Ihrem Formular zu konfigurieren:

  1. Erstellen Sie eine neue Seite und öffnen Sie sie zur Bearbeitung.

  2. Fügen Sie der Seite die Komponente Formular hinzu.

  3. Konfigurieren Sie die Komponente Formular-Start, die auf der Seite angezeigt wird.

     

  4. Wählen Sie mithilfe von Workflow starten den gewünschten Workflow aus den verfügbaren Optionen aus:

    WF-12
  5. Bestätigen Sie die neue Formularkonfiguration durch Klicken auf das Häkchen-Symbol.

Testen von Workflows

Beim Testen eines Workflows ist es sinnvoll, verschiedene Nutzlasttypen zu verwenden, auch solche, die sich von denen unterscheiden, für die der Workflow entwickelt wurde. Wenn Sie beispielsweise möchten, dass Ihr Workflow für die Verwendung mit Assets ausgelegt ist, testen Sie ihn, indem Sie eine Seite als Nutzlast festlegen und sicherstellen, dass keine Fehler auftreten.

Testen Sie Ihren neuen Workflow beispielsweise wie folgt:

  1. Starten Sie Ihr Workflow-Modell über die Konsole.
  2. Definieren Sie die Nutzlast und bestätigen Ihre Eingaben.
  3. Ergreifen Sie die erforderlichen Maßnahmen, damit der Workflow fortgesetzt wird.
  4. Überwachen Sie während der Ausführung des Workflows die Protokolldateien.

Sie können AEM auch so konfigurieren, dass die DEBUG-Meldungen in den Protokolldateien angezeigt werden. Weitere Informationen finden Sie unter Protokollierung. Wenn die Entwicklung abgeschlossen ist, legen Sie die Einstellung für die Protokollebene wieder auf Informationen fest.

Beispiele

Beispiel: Erstellen eines (einfachen) Workflows zum Annehmen oder Ablehnen einer Anfrage zur Veröffentlichung

Um einige der Möglichkeiten zur Erstellung eines Workflows zu veranschaulichen, wird im folgenden Beispiel eine Variante des Workflows Publish Example erstellt.

  1. Erstellen Sie ein neues Workflow-Modell.

    Der neue Workflow umfasst Folgendes:

    • Prozessstart
    • Schritt 1
    • Prozessende
  2. Löschen Sie Schritt 1 (da es sich um den falschen Schritttyp für dieses Beispiel handelt):

    • Klicken Sie auf den Schritt und wählen Sie in der Komponenten-Symbolleiste die Option Löschen aus. Bestätigen Sie die Aktion.
  3. Ziehen Sie aus der Workflow-Auswahl des Schritte-Browsers einen Teilnehmer-Schritt auf den Workflow und positionieren Sie ihn zwischen Prozessstart und Prozessende.

  4. Führen Sie zum Öffnen des Dialogfelds „Eigenschaften“ einen der folgenden Schritte durch:

    • Klicken Sie auf den Teilnehmer-Schritt und wählen Sie in der Komponenten-Symbolleiste die Option Konfigurieren aus.
    • Doppelklicken Sie auf den Teilnehmer-Schritt.
  5. Geben Sie auf der Registerkarte Allgemein als Titel und Beschreibung den die Bezeichnung Inhalt überprüfen ein.

  6. Öffnen Sie die Registerkarte Benutzer/Gruppe:

    • Aktivieren Sie das Kontrollkästchen Benachrichtigen Sie den Benutzer per E-Mail.
    • Wählen Sie für das Feld Benutzer/Gruppe die Option Administrator (Admin) aus.

    Hinweis:

    Damit E-Mails versendet werden können, müssen der E-Mail-Dienst und die Benutzerkontoinformationen konfiguriert werden.

  7. Bestätigen Sie Ihre Änderungen durch Klicken auf das Häkchen-Symbol.

    Daraufhin wird wieder die Übersicht über das Workflow-Modell angezeigt. Der Teilnehmer-Schritt ist nun in Inhalt überprüfen umbenannt.

  8. Ziehen Sie eine ODER-Teilung auf den Workflow und positionieren Sie sie zwischen Inhalt überprüfen und Prozessende.

  9. Öffnen Sie die ODER-Teilung zur Konfiguration.

  10. Konfigurieren Sie Folgendes:

    • Allgemein: Wählen Sie 2 Verzweigungen aus.
    • Zweig 1: Wählen Sie Standardroute aus.
    • Zweig 2: Stellen Sie sicher, dass Standardroute nicht ausgewählt ist.
  11. Bestätigen Sie Ihre Änderungen an der ODER-Teilung.

  12. Ziehen Sie einen Teilnehmer-Schritt auf den linken Zweig, öffnen Sie die Eigenschaften, geben Sie die folgenden Werte an und bestätigen Sie die Änderungen:

    • Titel: Reject Publish Request
    • Benutzer/Gruppe: z. B. projects-administrators
    • Benachrichtigen Sie den Benutzer per E-Mail: Aktivieren Sie dieses Kontrollkästchen, damit die Benutzer per E-Mail benachrichtigt werden.
  13. Ziehen Sie einen Prozessschritt auf den rechten Zweig, öffnen Sie die Eigenschaften, geben Sie die folgenden Werte an und bestätigen Sie die Änderungen:

    • Titel: Seite wie angefordert veröffentlichen
    • Prozess: Wählen Sie Seite aktivieren aus. Mit diesem Prozess wird die ausgewählte Seite in den Publisher-Instanzen veröffentlicht.
  14. Klicken Sie in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

    Ihr neues Workflow-Modell sieht dann wie folgt aus:

    WF-13
  15. Wenden Sie diesen Workflow auf Ihre Seite an, sodass Benutzer, die zur Phase Fertig stellen übergehen, den Schritt Inhalt überprüfen auswählen können, egal ob sie die Seite wie angefordert veröffentlichen oder die Anfrage zur Veröffentlichung ablehnen möchten.

    chlimage_1

Beispiel: Definieren einer Regel oder ODER-Teilung

ODER-Teilung-Schritte ermöglichen es Ihnen, bedingte Verarbeitungspfade in Ihren Workflow einzubinden.

Gehen Sie folgendermaßen vor, um eine Regel für eine ODER-Teilung zu definieren:

  1. Erstellen Sie zwei Skripte und speichern Sie diese im Repository, beispielsweise unter:

    /apps/myapp/workflow/scripts

    Hinweis:

    Die Skripte müssen eine Funktion check() aufweisen, die einen booleschen Wert zurückgibt.

  2. Bearbeiten Sie den Workflow und fügen Sie die ODER-Teilung zum Modell hinzu.

  3. Bearbeiten Sie die Eigenschaften von Zweig 1 der ODER-Teilung:

    • Definieren Sie dies als Standardroute, indem Sie den Wert auf true festlegen.
    • Geben Sie für Regel den Pfad zum Skript an. Beispiel:
      /apps/myapp/workflow/scripts/myscript1.ecma

    Hinweis:

    Sie können die Reihenfolge der Zweige ändern, sofern dies erforderlich ist.

  4. Bearbeiten Sie die Eigenschaften von Zweig 2 der ODER-Teilung:

    • Geben Sie für Regel den Pfad zum anderen Skript an. Beispiel:
      /apps/myapp/workflow/scripts/myscript2.ecma
  5. Legen Sie die Eigenschaften der einzelnen Schritte in jedem Zweig fest. Stellen Sie sicher, dass die Einstellung für Benutzer/Gruppe festlegt ist.

  6. Klicken Sie in der Editor-Symbolleiste auf Sync, um Ihre Änderungen am Laufzeitmodell beizubehalten.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Funktion „Check()“

Hinweis:

Weitere Informationen finden Sie unter Verwenden von ECMAScript.

Das folgende Beispielskript gibt true zurück, wenn es sich bei dem Knoten um eine JCR_PATH-Konstante unter /content/we-retail/us/en handelt:

function check() {
    if (workflowData.getPayloadType() == "JCR_PATH") {
	     var path = workflowData.getPayload().toString();
	     var node = jcrSession.getItem(path);
	     
	     if (node.getPath().indexOf("/content/we-retail/us/en") >= 0) {
	     	return true;
	     } else {
	     	return false;
	     }	
     } else {
     	return false;
     }
}

Beispiel: Benutzerdefinierte Aktivierungsanfrage

Sie können jeden der vorkonfigurierten Workflows anpassen. Um das Verhalten anzupassen, überlagern Sie Details des entsprechenden Workflows.

Beispielsweise der Workflow Aktivierungsanfrage. Dieser wird für die Veröffentlichung von Seiten innerhalb von Sites verwendet und automatisch ausgelöst, wenn ein Inhaltsautor nicht über die entsprechenden Replikationsrechte verfügt. Weitere Informationen finden Sie unter Anpassen der Seitenbearbeitung – Anpassen des Workflows „Aktivierungsanfrage“.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie