Fehlende Systembenutzer-ACLs korrigieren

Sie haben versehentlich System-ACLs in AEM gelöscht und die AEM-Funktionalität wurde unterbrochen.

Ursache

Dafür kann es viele Ursachen geben, aber die häufigsten sind:

  • Versehentliches Entfernen von Berechtigungen durch Benutzer
  • Installation des ACL-Pakets mit eingestellten Wert „Overwrite“ in der AC-Handlungsoption des Pakets.

Lösung

Um dieses Problem zu beheben, können Sie folgende Schritte ausführen:

  1. Installieren Sie einen sauberen AEM-Autor oder eine lokale Veröffentlichungsinstanz und setzen Sie während der Installation die Option -r nosamplecontent (passen Sie den Instanztyp an die Instanz an, der die ACLs fehlen).  Zum Beispiel: java -Xmx2048m -jar cq-author-p4502.jar -r nosamplecontent
  2. Gehen Sie zu AEM-Paketmanager http://host:port/crx/packmgr/index.jsp und melden Sie sich als Administrator an.
  3. ACS-Commons herunterladen und installieren
  4. Verwenden Sie ACL-Packager, um alle Out-of-the-Box-ACLs zu verpacken.  Bei der Konfiguration des ACL-Pakets setzen Sie "/.*" als einzigen Wert in Einschlussmuster. Dann stellen Sie die Option AC-Handling auf Verknüpfen.
  5. Rufen Sie den Paketmanager auf und erstellen Sie das ACL-Paket.
  6. Paket herunterladen
  7. Sobald Sie diesen Hotfix erhalten haben, installieren Sie ihn in der fehlerhaften Umgebung, indem Sie ihn im Ordner crx-quickstart/install ablegen.
  8. Nach der vollständigen Installation des Hotfix (Validierung über error.log) starten Sie AEM neu.
  9. Dann legen Sie das ACL-Paket im Ordner crx-quickstart/install auf der fehlerhaften Instanz ab.
  10. Nachdem dieses Paket installiert ist, starten Sie AEM noch einmal neu.

Jetzt sind die Original-ACLs wiederhergestellt.

Adobe-Logo

Bei Ihrem Konto anmelden