Dieser Artikel enthält die Schritte, die notwendig sind, wenn ein Benutzer auf DRMError 3324 mit dem Subfehlercode „111 - Machine Token Invalid“ trifft.

Problem

Beim Versuch, den geschützten DRM-Stream von AAXS (Adobe Access) abzuspielen, tritt folgender Fehler auf:

DrmErrorCode 3324:111

Umgebung

  • Desktop
  • Android
  • iOS
  • Sonstige Plattformen

Ursache

Ein Fehler 3324 wird ausgelöst, wenn der Lizenzserver den „MachineToken“ des Clients nicht erkennt.  Dieses Token wird vom Individualisierungsservice bereitgestellt. Wenn der Individualisierungsservice ein Zertifikat verwendet, das vom Access DRM Lizenzserver nicht als vertrauenswürdig eingestuft ist, wird das Token offensichtlich „invalid“.  

Subfehleridentifikation 111 ist der serverseitige Fehlercode und verweist auf „REQ_MACHINE_TOKEN_INVALID_EXPIRED”, was passiert, wenn das Machine Token des Clients abgelaufen oder ungültig ist. 

Lösung

  1. Stellen Sie sicher, dass Sie alle Ihre Access DRM Lizenzserver aktualisiert haben, sodass der neue Individualisierungsservice-Endpunkt, den wir kürzlich aufgestellt haben, als vertrauenswürdig eingestuft ist.  Befolgen Sie die Anweisungen, die in diesem Beitrag beschrieben sind: https://forums.adobe.com/message/8548395#8548395
  2. Wenn Sie das oben Beschriebene durchgeführt haben, waren der DRM-Lizenzserver (1 oder mehr davon) möglicherweise nicht ordnungsgemäß aktualisiert und/oder wurden nach der oben beschrieben Aktualisierung nicht neu gestartet.
  3. Wenn die beiden oben genannten Schritte nicht funktionieren, liegt möglicherweise ein Problem mit der Firewall/dem Zugriff auf den Access DRM-Lizenzserver vor, der verhindert, dass die folgende URL gedrückt wird (der Lizenzserver muss die CRL-Datei (CRL = Zertifikatssperrliste) von dort bekommen).  Überprüfen Sie, ob Ihr Server den CRL-Endpunkt erreichen kann. Es war ein neuer CRL-Endpunkt vorhanden, der erstellt wurde, um den neuen Individualisierungsserver zu bedienen. Möglicherweise hat Ihr Lizenzserver Zugriffsprobleme beim Drücken dieses neuen Endpunkts: http://individualization-crl.primetime.adobe.com/FlashAccessIndividualizationCA.crl  

Wenn Sie tatsächlich Zugriffsprobleme beim Erreichen dieser Datei haben, können Sie, um die aktuelle Hürde zu überwinden, diese Datei manuell in Ihren Lizenzserver kopieren und (wenn Sie Tomcat verwenden) im tomcat/temp-Ordner einfügen, wo heruntergeladene .crl-Dateien gespeichert werden.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie