Issue

When end users attempt to download new folios in your branded viewer application, the following message appears:

"Please update your app. This issue is available for download, but requires a newer version of the app."

This document is written for all publishers using InDesign CS5.x. Publishers using InDesign CS6 can use the Folio Builder panel to set the folio format version when creating a folio. For assistance setting the folio format version using InDesign CS6, see the Create Folios page in the Digital Publishing Suite Help.

Solutions

Solution 1: Rebuild your app to be compatible with new folios.

  1. First, make the incompatible folios invisible to your end users:
    1. Select the existing folio in the Folio Producer: Organizer in the DPS dashboard.
    2. Click Update.
    3. Set the Status to Private.
    4. Deselect Update Content.
    5. Click Update.
  2. Ensure that your cetificates are still valid.
  3. Install the latest version of the Viewer Builder application from the Digital Publishing Suite (DPS) dashboard: http://digitalpublishing.acrobat.com
  4. Select your application and click Edit.
  5. Click Next to move through the setup options, reselecting resource files as needed.
  6. When you reach the build details panel, click Submit Build.
  7. Click Finish.
  8. Once your build is complete, test the Developer Viewer. Then submit the Distribution Viewer to the appropriate store for the platform you have developed it for.
  9. Once your update is available in the app marketplace, make the folios visible to your end users:

    1. Select the existing folio in the Folio Producer: Organizer in the DPS dashboard.
    2. Click Update.
    3. Set the Status to Public (and Free/Retail based on your business plans).
    4. Deselect Update Content.
    5. Click Update.

Solution 2: Re-create your folio to be compatible with your viewer.

Note:

This process requires that you have access to the source files (.indd, .html, and so on) for your articles to reimport into the affected folios.

  1. First, make the incompatible folios invisible to your end users:
    1. Select the existing folio in the Folio Producer: Organizer in the DPS dashboard.

    2. Click Update.
    3. Set the Status to Private.
    4. Deselect Update Content.
    5. Click Update.
  2. Quit InDesign and wait five minutes for the CS5[.5]ServiceManager background process to quit. Or, use the Activity Monitor (Mac OS) or TaskManager (Windows) to end the process.

  3. Uninstall the Folio Producer Tools:

    • Mac OS: Use the uninstaller located in Applications > Utilities > Adobe Installers > Uninstall Adobe Folio Producer Tools for InDesign CS5[.5].
    • Windows: use the Control Panel > Programs and Features > Uninstall Adobe Folio Producer Tools for InDesign CS5[5.5]
  4. Install the version of the Folio Producer Tools that matches the current version of your Viewer app from the chart below.
  5. In the Folio Producer or the Folio Builder panel, open the affected folio and delete ALL of its articles.
  6. In the Folio Producer Organizer, select the affected folio and click Update. Ensure that the Update Content checkbox is selected, and then click Update.

  7. In the Folio Builder panel, open the affected folio and reimport all of its articles, or use open the files and use the Add command to add them..

    Note:

    If you created your folio's InDesign documents using InDesign CS5.5 and require using InDesign CS5 with the prerelease Folio Producer tools (Content Bundler) first export your .indd files to .idml. Then, open them in InDesign CS5 and save them again as .indd files, to a matching name and folder structure, in another location than the originals.

  8. Review your documents and their overlays to ensure that all overlay resources can be located, or relocate them as necessary.

  9. In the Folio Producer Organizer, select the affected folio and click the Update button, ensure the Update Content checkbox is checked, set the status back to Public and click Update.
  10. Last, make the folios visible to your end users:

    1. Select the existing folio in the Folio Producer: Organizer in the DPS dashboard.
    2. Click the Update button.
    3. Set the Status to Public (and Free/Retail based on your business plans).
    4. Deselect the "Update Content" checkbox.
    5. Click the Update button.

 Folio Producer Tools and Viewer App version compatibility:

Component                  
Producer Tools Installer 1.0 or 1.0.1 1.1.1
1.5 or 1.6
1.7 1.8 1.9 1.10 1.11 1.12
ID Digital Publishing Plug-in 7.x.x.12 7.x.x.13 7.x.x.15 or *.16 7.x.x.17 7.x.x.18 7.x.x.19 7.x.x.20 7.x.x.21 7.x.x.22
Folio version 1.7 1.8 1.9 1.10 1.11 1.12 2.0.0 2.1.0 2.2.0
Viewer Builder "Viewer Version" v12 v13 v15 v17 v18 v19 v20 v21 V22
Viewer version 1.8.x 1.9.x 2.0.x or 2.1.x 2.2.x 2.3.x 2.4.x. 2.5.x 2.6.x 2.7.x

Legend:
Producer Tools = the version as advertised on the Previous DPS Downloads pages: Mac / Win.
ID Digital Publishing Plug-in = version shown when you choose the About command from the Folio Builder panel pop-up menu.
Folio version = the version as shown in as a property in the <folio> tag of the Folio.xml file. You can find this version by mounting your device via USB. Then, using a tool like Phone Disk, browse to the application that you downloaded the folio with, and look in the following path.
/Volumes/<device name or number> (<application name>)/Documents/issues/<application name or GUID>/<issue GUID>
Viewer Builder "Viewer Version" = the value selected in the Viewer Builder when creating your custom viewer app.
Viewer version = the version as shown when you launch your custom viewer app on a device, view a folio, tap once on the screen to bring up the navigation controls, then tap twice on the folio name to display the version of the viewer code base.

Additional information

When you update the Digital Publishing Suite authoring tools, folios you publish are no longer compatible with a custom viewer created with a previous set of tools. For example, suppose that you used Viewer Builder 1.2 to create a custom viewer that you submitted to the app store. To continue creating folios for that custom viewer, keep using the v12 authoring tools (installer 1.0). Do not update the installer until you are ready to create and submit a new version of the custom viewer to the app store. However, update the Folio Builder panel when the Folio Producer is updated on the web.

You sometimes must revert to a previous set of Folio Producer tools to be compatible with an older custom viewer. Uninstall the Folio Producer tools, and then download and install the appropriate version. For InDesign CS5, run the 1.0.x installer first, and then install the desired authoring tools update. If necessary, update the Folio Builder panel.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy