Problem

Fejlen "du skal installere den tidligere Java SE 6 runtime", vises når du starter et Adobe-program.

Legacy Java error

Løsning

Fra og med Mac OS 10.7 (Lion) og nyere installeres Java runtime ikke længere automatisk som en del af operativsystemet. Installer Java runtime på en af nedenstående måder.

Metode 1

Du kan downloade og installere den nyeste Java runtime fra Java-webstedet - Download gratis Java-software.

Bemærk:

Når du starter et Adobe-produkt på Mac OS 10.10 (Yosemite), vises eventuelt en advarsel: "Programmet er blevet fjernet og stien er blevet ændret...".

Klik på knappen Reparer nu eller Opdater for at opdatere placeringen og løse problemet. Når du bliver bedt om at angive dinadgangskodeskal du angive adgangskoden til computeren.

Meddelelse om, at programmet er flyttet

Metode 2

Hvis Java runtime ikke er installeret, bliver du bedt om at installere det, første gang du installerer et Adobe-produkt. Følg vejledningen på skærmen til, hvordan du installerer Java.

Metode 3 (Mac OS 10.7 og 10.8)

Brug følgende metode til at starte Java runtime-installationen, eller bekræft, hvis den allerede er installeret.

  1. Gå til Programmer > Hjælpeprogrammer > Java-indstillinger.
  2. Åbn Java-indstillinger.
  3. Hvis Java ikke er installeret, vises følgende meddelelse: "For at åbne "Java-indstillinger" kræves Java runtime. Vil du installere det nu?"

    Meddelelsen "Java er ikke installeret"
  4. Klik på Installer, og accepter Licensaftalen. Java runtime downloades og installeres.
    Status for download af Java
    I Java-indstillinger vises det som installeret

Yderligere oplysninger

Mange Adobe-programmer kræver JRE (Oracle Java Runtime Environment) for at nogle funktioner kan fungere. Apple ændrede for nylig måden hvorpå de inkluderer Java i Mac OS, og fra og med Lion vil Java ikke længere blive forudinstalleret. Det er nu en valgfri installation, som du selv skal vælge. 

Eftersom de nuværende Adobe-installationsprogrammer og programmer blev udviklet, før Apple lavede disse ændringer, forudsætter Adobe-software, at Java er installeret. Adobe og Apple har arbejdet sammen for at sikre, at du kan installere Java, når du installerer Mac OS. Eller det kan installeres senere, før du installerer Adobe-programmer. Når du starter et Adobe-program, bliver du bedt om at installere Java, hvis det ikke allerede er installeret. Hvis du ikke installerer Java, før du kører et Adobe-program, kan der være funktioner, som mangler eller ikke fungerer korrekt. Hvis du oplever problemer, skal du installere Java for at løse problemerne. Adobe anbefaler, at IT-firmaer forudinstallerer Java (eller sikrer, at Java kan installeres via deres firewalls og sikkerhedssystemer) for at undgå konflikter med Adobe-programmer.

Hvis Java runtime ikke er installeret, vil der opstå en række kendte fejl, herunder -  

  • Programmet kan ikke startes.
  • Påmindelser om at installere Java runtime, når du forsøger at bruge programmerne.
  • Programmer hænger eller lukkes.

Dette arbejde har licens under en Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Opslag på Twitter™ og Facebook er ikke omfattet af vilkårene for Creative Commons.

Juridiske meddelelser   |   Politik for beskyttelse af personlige oplysninger online