La herramienta de firma móvil de AEM muestra lo siguiente en su panel iOS y las aplicaciones iOS no pueden ser firmadas: "Las aplicaciones iOS no se pueden firmar debido a los siguientes problemas: Xcode 8 o superior no se encuentra en su sistema. Xcode 8 es necesario para firmar y enviar a la App Store."

Entorno

Mac OS

Causa

El sistema operativo Mac tiene el "directorio activo del desarrollador" configurado en "/Library/Developer/CommandLineTools". Está bien cuando se utilizan sólo las herramientas de línea de comandos de Xcode, pero la herramienta de firma móvil AEM necesita la aplicación Xcode. Por lo tanto, debe estar instalado y, si es necesario, tiene el "directorio activo del desarrollador" configurado en la aplicación.

Resolución

Si aún no lo has hecho, instala Xcode desde la aplicación Mac OS App Store. Intente utilizar la herramienta de firma móvil de AEM.

Si todavía muestra el error, haga lo siguiente:

  1. En el buscador vaya a /Applications/Utilities y ejecute la aplicación Terminal.
  2. Escriba lo siguiente y, a continuación, pulse Enter:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

Ahora ejecute la herramienta de firma móvil de AEM.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea