The Impact of AWS Signature Version 2 Deprecation for Amazon S3 on S3 Datastore Connector

Issue

AEM instances with old versions of S3 Datastore connector may become unavailable due to S3 access failures after the end of support for Signature Version 2 on June 24, 2019.

 

Amazon Web Service announced the end of support for AWS Signature Version 2 for Amazon S3. S3 will only accept API requests with AWS Signature Version 4 after that.

 

Affected versions of AEM and S3 connector:

  • AEM 6.3 - S3 connector 1.6.0
  • AEM 6.2 - S3 connector 1.4.8 or older
  • AEM 6.1 - S3 connector 1.2.4 or older

 

Note AEM 6.4 (or later) is not affected because the S3 connector for this version (1.8.x) uses AWS Signature Verions 4 by default.

 

Resolution

The following versions of S3 connector are AWS Signature Version 4 compatible. We recommend to update S3 connector to the most recent version by June 24, 2019.

 

  • AEM 6.3 - S3 connector 1.6.1 or later
  • AEM 6.2 - S3 connector 1.4.10 or later
  • AEM 6.1 - S3 connector 1.2.6 or later

 

S3 connector should be found under <aem-install>/crx-quickstart/install/15. For checking your current S3 connector and updating to a newer version, see Amazon S3 Data Store configuration document.

 

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea