Aviso transversal para consulta prism:expirationDate

Problema

Esta advertencia se repite en los archivos de registro de AEM:

23.03.2017 07:49:59.379 *WARN* [pool-8-thread-3] org.apache.jackrabbit.oak.spi.query.Cursors$TraversingCursor Traversed 2993000 nodes with filter Filter(query=select [jcr:path], [jcr:score], * from [dam:Asset] as a where [jcr
:content/metadata/prism:expirationDate] > cast('2017-03-22T07:00:00.000Z' as date) and [jcr:content/metadata/prism:expirationDate] < cast('2017-03-23T07:00:00.001Z' as date) and isdescendantnode(a, '/content/dam') /* xpath: /
jcr:root/content/dam//element(*, dam:Asset)[(jcr:content/metadata/@prism:expirationDate > xs:dateTime('2017-03-22T07:00:00.000Z') and jcr:content/metadata/@prism:expirationDate < xs:dateTime('2017-03-23T07:00:00.001Z'))] */,
path=/content/dam//*, property=[jcr:content/metadata/prism:expirationDate=[(2017-03-22T07:00:00.000Z.., ..2017-03-23T07:00:00.001Z)]]); consider creating an index or changing the query

Este mensaje de advertencia significa que algo está mal en la instancia de AEM donde el índice /oak:index/damAssetLucene no está funcionando.   Esto hace que la consulta anterior se desvíe, en lugar de utilizar el índice damAssetLucene.

Entorno

Causa

Se ha producido un error con el índice /oak:index/damAssetLucene.  Tendría que investigar los archivos de registro y buscar "damAssetLucene" para encontrar la causa exacta.

Resolución

A. Investigar la causa raíz

Busque "damAssetLucene" en error.log y en cualquier otro registro de indexación configurado.  Investigue sobre cualquier mensaje de ERROR o de ADVERTENCIA para ver si son la causa del problema.

Por ejemplo, en el caso de un cliente, esta fue la causa del problema:

22.03.2017 12:46:45.205 *ERROR* [Thread-44] org.apache.jackrabbit.oak.plugins.index.lucene.IndexTracker Could not access the Lucene index at /oak:index/damAssetLucene
java.io.FileNotFoundException: [/oak:index/damAssetLucene] segments_8o28

B. Intente reconstruir la copia de índice local

  1. Detener AEM

  2. Borrar crx-quickstart/repository/index

  3. Inicio de AEM

  4. Pruebe de nuevo

C. Decida si reindexar o no

Si la reconstrucción de la copia de índice local no solucionó el problema, póngase en contacto con Atención al cliente de AEM para depurar y decidir si necesita volver a indexar el índice /oak:index/damAssetLucene.

Logotipo de Adobe

Inicia sesión en tu cuenta