Asunto: ¿Cómo puedo actualizar el panel de lanzamiento?

Hay algunas correcciones en el último Apache Felix Framework, ¿cómo puedo actualizarlo en Adobe Experience Manager?

Solución

Siga estos pasos:

  1. Descargue la nueva base jar del repositorio oficial de Maven en http://search.maven.org/#search%7Cga%7C1%7Corg.apache.sling.launchpad.base. Puede elegir la versión. Cuando se escribió este artículo, se recomienda 5.0.1-2.6.2 (todavía usa javax.servlet.api 2.5). No obstante, puede usar 5.2.0-2.6.4 si no tiene dependencias con la versión anterior de la API de servlets.
  2. Apague la instancia.
  3. Reemplace la base .jar en la instalación (predeterminado en crx-quickstart/launchpad).
  4. Reinicie la instancia con -Dorg.apache.sling.launchpad.startupmode=RESTART.

Realice la validación por si le ayuda a resolver este problema y tenga en cuenta la exención de responsabilidad general de uso en producción

EXENCIÓN DE RESPONSABILIDAD: LA BIBLIOTECA DE TERCEROS SE PROPORCIONA "TAL CUAL" Y SIN GARANTÍA DE NINGÚN TIPO, INCLUIDAS LAS GARANTÍAS O CONDICIONES DE COMERCIABILIDAD, IDONEIDAD PARA UN FIN DETERMINADO, CALIDAD SATISFACTORIA, AUSENCIA DE VIRUS, TÍTULO, NO INFRACCIÓN, EXACTITUD O INTEGRIDAD DE LAS RESPUESTAS, RESULTADOS, FALTA DE NEGLIGENCIA Y/O FALTA DE ESFUERZO DE MANO DE OBRA. ADOBE NO GARANTIZA LA AUSENCIA DE ERRORES, OMISIONES, DEFECTOS, DEFICIENCIAS O FALTA DE CONFORMIDAD EN LAS BIBLIOTECAS DE TERCEROS. LAS BIBLIOTECAS DE TERCEROS NO LAS PRUEBA QA. ÚSELO BAJO SU PROPIA RESPONSABILIDAD. ADOBE RECOMIENDA QUE ESTA BIBLIOTECA DE TERCEROS SE UTILICE CON FINES DE DESARROLLO. SI DEBE APLICAR ESTA BIBLIOTECA DE TERCEROS A UN SISTEMA DE PRODUCCIÓN, DEBE PROBAR A FONDO SU APLICACIÓN. ADOBE NO SE HACE RESPONSABLE DE CUALQUIER DAÑO QUE PUDIERA SER CAUSADO POR ESTA BIBLIOTECA DE TERCEROS.

Se aplica a: CQ5.x/AEM 6.x, cualquier versión que esté usando este panel de lanzamiento de base .jar

Acerca de las dependencias de API de Servlet: La API de Servlet la proporciona el motor de servlets CQSE, Felix/Jetty HTTP u otro (Websphere, Weblogic, Tomcat, JBoss, etc.). Compruebe si funciona con la base del panel de lanzamiento disponible en el repositorio de Maven (puede comprobar el pom.xml para obtener información sobre la dependencia de la API de servlets).

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea