Problema

Cuando se intenta iniciar sesión en AEM, el error "Nombre de usuario y contraseña no coinciden" devuelve en un cuadro rojo en la pantalla de inicio de sesión.

Cuando se inspecciona el tráfico de red a través de un depurador de navegador, se devuelve una respuesta de error 403 desde una petición HTTP POST de Ajax a esta URL:
/libs/granite/core/content/login.html/j_security_check

Entorno

AEM 6.x

Causa

El nombre de usuario o la contraseña pueden ser incorrectos o puede haber un error del gestor de autenticación durante el inicio de sesión.

Resolución

Para depurar y corregir este problema, siga la siguiente guía:

Analysis

I. Valide el nombre de usuario, la contraseña y que el usuario existe:

Si el problema sólo ocurre con uno o unos pocos usuarios, puede ser que se estén utilizando nombres de usuario o contraseñas incorrectos o que los usuarios no existan en AEM.

Compruebe la contraseña:

  1. Use el navegador Chrome y abra la pestaña Herramientas de desarrollo => Red en el navegador y, a continuación, intente iniciar sesión de nuevo.

  2. Seleccione la petición POST que termina en j_security_check en la URL.

  3. En el panel inferior derecho de la pestaña Encabezados, desplácese hasta la parte inferior.

  4. Valide que en Datos del formulario, la contraseña que se envía en el parámetro j_password es correcta.

Validar que el usuario existe y restablecer la contraseña:

  1. Inicie sesión como usuario administrador.

  2. Verificar que los usuarios existen.

  3. Crear el usuario si no existe o restablecer la contraseña si existe.

II. Analizar el manejo de la autenticación rota

Si nada de lo anterior resuelve el problema, entonces:

  1. Inicie sesión en el sistema operativo del servidor AEM.

  2. Siga o vea el archivo error.log.

  3. Vea las actualizaciones del registro mientras intenta iniciar sesión en AEM.

  4. Si se registra algún error o advertencia, analice dichas advertencias.  Si no hay nada registrado, habilite un registro de depuración con esta configuración:

    Log Level: Debug
    Log File: auth-debug.log
    Loggers:
    org.apache.sling.auth
    com.adobe.granite.auth
    com.day.crx.security.token

  5. En este punto, si no puede analizar los mensajes de registro y encontrar la causa principal, póngase en contacto con Atención al cliente de AEM.

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