Find out what's new in Adobe Experience Design CC (Beta)

Adobe Experience Design CC (Beta) is a vector-based tool for designing and prototyping user experiences for web and mobile apps. Switch easily from wire framing, visual design, interaction design, prototyping, preview and sharing, all in one powerful tool.

What's new in Adobe Experience Design CC (Beta 15 | June 2017)

New features on Windows

In this beta update, the following new features have been added for Windows:

  • Symbols: You can now reuse objects across artboards in your document. Drag and drop symbols onto your artboards, or manage them from your Symbol library. When you edit a symbol, all instances of it automatically update across your design. For more information on symbols, see Work with symbols.
  • Gradients: You can now create and edit linear gradients in Adobe XD on Windows.
  • Layers: You can now move layers in the layers panel by dragging and dropping them to reorder the z-index.
  • Text: You can now style a sub-section of text within a text block - such as the font type, color, size, and character spacing. 
  • Images: You can now copy bitmaps from Adobe XD and paste them to the clipboard or in other applications such as Photoshop or Illustrator.

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Override text and bitmaps in symbols

You can now override text and bitmaps for individual symbol instances. This feature allows you to reuse the same symbol across the document and have unique text or bitmaps per symbol instance.

However, if you have multiple instances of a symbol with overrides and you want to replace and update the text or bitmap across all instances, right-click the symbol that you want to propagate across its instances, and select Update All Symbols from the contextual menu.

For more information, see Work with symbols.

What's new in Adobe Experience Design CC (Beta 14 | May 2017)

New features on Windows

In this beta update, the following new features have been added for Windows:

  • Layers: You can now organize all the items that make up your design in layers. 

    Access layers in an artboard by using the Ctrl + Y keyboard shortcut, or click the  icon in the toolbar. You can create new layers, rename layers, show/hide, and lock/unlock layers. However, you cannot reorder layers by dragging them in this beta version.

    For general information on layers in Adobe XD, see Work with layers.

  • Update shared prototypes: You can now make changes to an already shared prototype, and then refresh the URL by clicking Share Again, and then Update Again.
  • Export assets as PDF: You can now export assets as PDF - either as a single PDF file, or multiple PDF files.
    • Single PDF file: Select multiple artboards or assets, and export them as a single PDF file. Multiple artboards or assets are placed in separate pages and a single PDF is created. 
    • Multiple PDF files: Select multiple artboards or assets, and export them as individual PDF files. Multiple artboards or assets are placed in separate pages and separate PDF files for each of the selected assets or artboards are created.
  • Convert an object, text, or shape to a path: You can now convert an object, shape, or text to a path using the context menu (right-click an object, and then select Path > Convert to Path). You can then use the Pen tool to change and edit the anchor points along the path to refine your design.
  • Copy and paste images from File Explorer directly into Adobe XD: You can now copy an image from File Explorer and paste it as an image object into Adobe XD.

Additionally, Adobe XD for Windows is now available in French and German.

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Copy and paste objects with interactions

From this beta release onwards, when you copy an object in Prototype mode, the associated interaction too is copied. This feature helps you to quickly copy and paste repetitive design elements without having to reconnect or rewire the pasted object again.

This functionality is available on both Mac and Windows operating systems.

For more information on prototyping, see Create interactive prototypes.

Note:

You can reconnect or rewire the pasted object. When you do so, only the copied instance of the object is affected, and not the original object.

What's new in Adobe Experience Design CC (Beta 13 | April 2017)

New features on Windows

In this beta update, the following new features have been added for Windows:

  • Masking: You can now use objects or shapes as masks to hide portions of your assets, and bring users' focus on interesting elements in your design.
  • Boolean operations: You can combine objects in your artboard using boolean operations. You can add, subtract, intersect, or exclude objects to create complex artwork for your designs.
  • Import assets from browsers: You can drag images directly from all modern browsers onto your artboards. You can also drag the images in to an object on an artboard. When you do so, the image size is automatically adjusted to fit the object. You can also copy an image from a browser and paste it in Adobe XD.

Note:

You cannot import assets from Microsoft Edge by copying and pasting or by dragging assets into Adobe XD.

Apart from these features, Adobe XD for Windows is now available in Japanese and Korean. During installation, the installer detects the operating system and installs the corresponding language version of Adobe XD.

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Recording format changes for prototypes

In the previous Beta releases, you were able to record the preview and save them as .mov files. From this release onward, the recordings can be saved as .mp4 instead of .mov files. 

What's new in Adobe Experience Design CC (Beta 12 | March 2017)

New features on Windows

In this beta update for Windows, support for the following features have been added:

  • Bring in assets from Illustrator and Photoshop. For more information, see Bring in assets from Illustrator, and Bring in assets from Photoshop.
  • Align to pixel grid functionality to move any selected objects to the nearest whole pixel.
  • Zoom into selected objects or areas of your artboard by pressing Z and activating the zoom tool. To zoom into specific objects on your artboard, select the object, and press Ctrl + 3. To zoom into a specific area on your artborad, click and select a specific area on your artboard.
  • Maintain the aspect ratio of objects while resizing them. To maintain the aspect ratio of an object, select the object, click the new "Lock" icon in the Property inspector, and then resize the object.

In addition to the above mentioned features, enterprise users can now share a link to their prototypes by using the Share Online option.

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Resolve comments

You can now manage your design better by resolving comments received on shared prototypes. To resolve a comment, you can click Resolve Comment in the Comments panel of the shared prototype. Resolved comments disappear from from your comments list, but you can view them by clicking View Resolved Comments.

You can also unresolve a resolved comment using the Move to Unresolved option in the Comments panel. For more information, see Adding comments to shared prototypes.

What's new in Adobe Experience Design CC (Beta 11 | February 2017)

New features on Windows

In this Beta update for Windows, Adobe XD supports the following features:

  • New Start screen to easily navigate various artboard sizes, tutorials, UI kits, and other links
  • Create blur masks using background blur 
  • Blur your objects using object blur
  • Create, edit, remove, and preview scrollable artboards
  • In addition to importing SVG files, you can now export your design assets as SVG files with embedded or linked images
  • Share and manage prototypes online (updating prototypes coming soon)
  • Zoom in and out of the artboard by using the Ctrl+Mouse wheel or Alt+Mouse wheel keyboard shortcuts

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Add pinned comments during reviews

Reviewers can now pin comments to shared prototypes by connecting a comment to a specific location on the artboard.

Adobe XD adds numbered comments, and maps them to a corresponding number on the artboard, allowing designers to easily understand the context of the comment.

For more information, see Adding comments to shared prototypes.

Add pinned comments
Add pinned comments

What's new in Adobe Experience Design CC (Beta 10 | January 2017)

New features on Windows

In this Beta update for Windows, support for the following features has been added:

  • Snap to grid
  • Import SVG files
  • UI kits
  • Individual and Enterprise login

For more information on Adobe XD on Windows and supported features, see Adobe Experience Design on Windows.

Commenting on shared prototypes as 'Guest'

You can now accept comments and feedback from your stakeholders in a faster way. Prior to this Beta release, stakeholders who wanted to comment on a shared prototype had to sign in using their Adobe ID (if they did not have an ID, they had to sign up to comment). But now, stakeholders can comment as a 'Guest' without having to sign in using their Adobe ID. 

For more information, see Adding comments to shared prototypes.

What's new in Adobe Experience Design (Beta 9 | December 2016)

Support for Windows

The eagerly anticipated first release of XD for Windows is here. The first Beta release of Windows is available for Windows 10 Anniversary Update and is available only in English.

This release of Adobe XD for Windows includes core design and prototyping features, and will be updated every month with additional features. Eventually, the core feature set across both Windows and Mac versions of Adobe XD will be consistent, with each version being optimized for performance and stability.

A simple Adobe XD tutorial is included in the Windows build to help you get started quickly. You can access this tutorial from the hamburger menu on the left of the interface.

For more detailed information on the supported features and other frequently asked questions, see Adobe Experience Design CC (Beta) on Windows. For system requirements, see System requirements for Windows.

New features in Adobe XD on mobile

In the previous release of Adobe XD on mobile, you were able to preview your documents on devices by connecting the devices to Adobe XD on macOS using USB.

In this release, you can also upload your documents to Creative Cloud Files and open them directly on your devices using Adobe XD on mobile. 

Note: In Adobe XD on Windows, mobile preview through USB is not supported yet. To preview your documents on devices, you can upload your documents to Creative Cloud Files and view them on the devices.

This release of Adobe XD on mobile also provides the following features when you long press on a document open on your device:

  • Browse artboards: For documents with a large number of artboards, selecting a specific artboard can be a challenge. Now, when viewing a document, after a long press, you can choose "Browse Artboards" to see all artboards as thumbnails for quick access. You can also search by artboard name to filter the results. Just search and tap on the artboard you want to view.
  • Share screen as image: From any screen, you can long press and choose "Share this Screen as Image". Adobe XD on mobile will create an image and will call the share sheet on your device, so that you can easily share the image using the service you use the most (for example, Slack or Email).
  • Enable/disable hotspot hints: Guiding the user with hotspot hints can be beneficial when testing a prototype. After a long press, you can activate and deactivate hotspot hints. If they're on, all interactive areas (like buttons) will briefly highlight in blue when the user taps on a non-interactive area. This shows the user where the tappable areas are

The latest XD document you're viewing is always cached on your mobile device. If you unplug your USB cable or go offline after viewing a document from CC Files, your design and prototype will remain accessible on your device, even if you kill the app and open it again. The next time you open an XD document or use real-time preview via USB, the previous cached document is replaced. 

For more information, see Adobe XD on mobile FAQ.

Enhancements to UI kits in the Start screen

Adobe XD helps users like you to onboard easily by providing ready-to-use UI kits in the Start screen - Apple iOS, Google Material, and Microsoft Windows. In this release of Adobe XD, the default layers in these UI kits have been named to make it easier for you to associate them with the objects in the artboards.

What's new in Adobe Experience Design (Beta 8 | November 2016)

Layers

Work faster using a modern approach to layers that quickly helps you find what you need. Only the layers that are associated with the artboard you're working on are highlighted, so your panel stays clean and uncluttered.

View all the artboards in your document and immediately pan & zoom to a specific artboard from the Layers panel. Double-clicking an artboard icon contextually displays only the layers for that artboard. Reorder, rename, show/hide, and lock/unlock layers quickly and easily.

Layers in Adobe XD is an adaptation of the layers in Ai and Ps that you know and depend on, but are re-imagined for UX designers. Access layers using the shortcut Cmd + Y, or click the  icon in the toolbar.

For more information, see Work with layers.

Symbols

With new Symbols in Adobe XD, you can reuse objects across artboards in your document. Drag and drop symbols onto your artboards, or manage them from your Symbol library. Double-click to edit a Symbol. Symbols will automatically update across your design – no need for isolation mode. 

Create a Symbol with the shortcut Command + K, or by right-clicking an element and selecting “Make Symbol” from the contextual menu. Access the Symbol Library using Command + Shift + Y (or click  in the toolbar).

If you want to unlink a symbol instance, so that the changes made to the symbol are not propagated, right-click the instance and select Ungroup Symbol.

For more information, see Work with symbols.

Align to pixel grid

You can now use the Align to Pixel Grid command to adjust objects so they are aligned crisply with pixel boundaries. Objects may appear blurry if their edges are not exactly aligned with the pixel grid.
Right click an object and select Align to Pixel Grid from the context menu. The Align to Pixel Grid command in XD tweaks each object’s X/Y/W/H (and individual path points) by up to 0.5px to align it more crisply with the pixel boundaries.

Align to Pixel Grid option
Right-click context menu of a selected object showing the Align to Pixel Grid option

What's new in Adobe Experience Design (Preview 7 | September 2016)

Preview designs and prototypes on devices

With the help of the Adobe XD mobile app, you can preview your designs and prototypes on iOS and Android devices. Multiple devices can be connected using USB ports on the computer running Adobe XD. You can make changes to your designs and prototypes, and preview them in real time on all the connected devices. 

You can download the Adobe XD mobile app from iTunes App store and Google Play. Currently, only 64-bit iOS devices and devices running Android OS version 4.4 or later are supported. For a detailed list of supported device types, see System requirements for the Adobe XD mobile app.

Zoom to selection

In earlier preview releases, you were able to zoom in or zoom out of an artboard, or zoom to a specific level (100% or 200%). In this preview release, you can zoom in to a selected objects of your artboard using the new Zoom to Selection (Cmd + 3) option in the Zoom menu.

Use the selection tool () to select objects, or marquee select the required objects or areas of your artboard, and then select Zoom > Zoom to Selection.

Zoom to selection
A repeat grid selected for zooming in

Object selected in the previous image after using Zoom to Selection (Cmd+3)
Object selected in the previous image after using Zoom to Selection (Cmd+3)

Lock aspect ratio for objects

You can now maintain the aspect ratio of objects while resizing them. This means that if you are resizing a rectangle for example, you can always keep the ratio between the length and width constant.

The Property Inspector for objects now includes a new 'lock' icon that is displayed adjacent to width and height. To maintain the aspect ratio while editing an object, select the object, click the lock icon, and then resize the object.

Lock icon in the Property Inspector for locking aspect ratio of objects
Lock icon in the Property Inspector for locking aspect ratio of objects

Lock aspect ratio disabled
Lock aspect ratio disabled


Option to enable or disable scrolling in artboards

In the previous preview releases, the scrolling for long artboards was automatic and you did not have an option to disable scrolling. Also, you were not able to enable scrolling for custom artboards.

Now, you can choose to enable or disable vertical scrolling in both custom artboards and in artboards with preset sizes. The Property Inspector includes the new Scrolling section that lets you enable or disable vertical scrolling for a selected artboard.

For more information, see Create scrollable artboards.

New Scrolling option in Property Inspector. Vertical scrolling enabled for a long artboard.
New Scrolling option in Property Inspector. Vertical scrolling enabled for a long artboard.

New slide transitions

This preview release includes the new 'slide' transitions - Slide Left, Slide Right, Slide Up, and Slide Down. When you select a 'slide' transition, the artboard 'slides' over an existing artboard, which exits with a slight parallax effect. This transition is different from the 'push' transition in which an artboard moves off the screen at the same speed and in the same direction as the second artboard that enters the screen.

Slide transitions
Slide transitions

What's New in Adobe Experience Design (Preview 6 | August 2016)

The August release of Adobe Experience Design (Preview) includes support for linear gradients, shorthand code for hexadecimal codes in Color Picker, Korean language support, and a few other enhancements.

Read on to know more about these new features and enhancements:

Linear gradients

You can now use linear gradient fill for your objects in Adobe XD. Select an object, click Fill, and choose the Gradient option to get started. You can create single or multicolor gradients using the Gradient tool.

For detailed information on creating and using linear gradients, see Linear gradients.

Note: Currently, Radial gradients are not supported in Adobe XD. However, you can import objects with radial gradients and edit the gradients in Adobe XD.

The Gradient tool
The Gradient tool

Shorthand for hexadecimal codes

The color picker now lets you use shorthand for hexadecimal codes. For example, if you type 0 and press Return, the hexadecimal value, #000000, is automatically filled out. Similarly, you can type 0A for #0A0A0A, and 0AF for #00AAFF.

Creative Cloud login

Creative Cloud login capabilities are integrated with Adobe XD in this preview release. The login screen appears if you launch Adobe XD without being signed into the Creative Cloud desktop application.

Creative Cloud login
Creative Cloud login

You need to provide a valid Adobe ID (individual or enterprise) to log in successfully to Creative Cloud and Adobe XD. If you click Cancel in the login screen or provide invalid credentials, you will not be able to launch Adobe XD.

If you have signed out from the Creative CButloud desktop application and try to launch Adobe XD, you will be prompted to sign in using your Adobe ID credentials.

From within Adobe XD, you can access Help > Sign Out (your Adobe ID) to sign out, if necessary.

If you have signed out from the Creative CButloud desktop application and try to launch Adobe XD, you will be prompted to sign in using your Adobe ID credentials.

From within Adobe XD, you can access Help > Sign Out (your Adobe ID) to sign out, if necessary.

If you have signed out from the Creative CButloud desktop application and try to launch Adobe XD, you will be prompted to sign in using your Adobe ID credentials.

From within Adobe XD, you can access Help > Sign Out (your Adobe ID) to sign out, if necessary.

Note:

You can sign out of Creative Cloud from within Adobe XD using Help > Sign Out (your Adobe ID).

'None' option to unlink artboards

If you have linked artboards in your interactive prototypes, you can now unlink them with a single click using the new 'None' option (Target > None in Prototype mode).

Set artboard linking to None
Set artboard linking to None

For more information on unlinking artboards, see the section on Unlink artboards.

Changes to segue

Slide segues are now renamed to 'Push' and the default segue is changed to 'Dissolve'.

Instant transitions between artboards

You can now create instant transitions between artboards, without visible transitions or easing, by selecting 'None' in the Segue drop-down list in the transition pop-up.

Support for Korean language

Along with English, French, German, and Japanese, Adobe XD is now also available in Korean. During installation, the OS setting is detected and the corresponding language version of Adobe XD is installed.

What's new in Adobe Experience Design (Preview 5 | July 2016)

The July release of Adobe Experience Design (Preview) rolls out enhancements such as PDF export, paste from Sketch, and the ability to link to previous artboard. 

Read on for a quick introduction to these new features and links to resources offering more information.

PDF export

You can now export assets or artboards as a single PDF file or individual PDF files.

PDF export

For detailed information, see Export design assets.

Paste from Sketch

Copy and paste items from vector-based design applications like Adobe Illustrator and Bohemian Coding's Sketch. We now preserve vectors, text, and bitmaps on copy and paste.

For detailed information, see Bring in assets from Sketch.

Context menu to group and ungroup objects

The Context menu now allows you to group and ungroup objects in an artboard.

Group and ungroup objects from the context menu

For detailed information, see Group objects.

In earlier previews of Adobe XD, if you wanted the users or reviewers to see a previously visited artboard, you had to specifically choose the name of the artboard while linking. Now a new option, 'Previous Artboard', is introduced in the Prototype mode. This option creates a back button, and when it is clicked during the preview, the previously visited artboard is displayed.

For detailed information, see Link to previous artboard.

Link to previous artboard

Zoom tool

The zoom functionality has been enhanced allowing you to quickly and easily view sections of the artboard in greater or lesser detail.

Enter Zoom mode by clicking the Zoom icon on the toolbar or pressing Z on your keyboard. Once in Zoom mode, you can:

  • Zoom in: Click anywhere in the Adobe XD canvas, or click the required artboard. Or, marquee-select an area to zoom in.
  • Zoom out: Option+Click

If you want to quickly zoom in or out without actually entering the Zoom mode, you can temporarily activate Zoom mode:

  • Press Space+Cmd, then click or marquee select an area on the artboard to zoom in.
  • Space+Cmd+Opt to zoom out
Before zoom

After zoom

For detailed information, see Working with artboards.

What's new in Adobe Experience Design (Preview 4 | June 2016)

The June release of Adobe Experience Design (Preview) rolls out enhancements such as the ability to embed prototypes in websites, blur objects, and the ability to measure distances between objects.

Read on for a quick introduction to these new features and links to resources offering more information.

Embed prototypes

You can now embed your prototypes into any website that supports IFrames - such as Behance, a personal website, Wordpress blog, or any other website. You can also share your embed code so that others can embed your prototypes in their websites.

Embed prototypes in a web page
Embed prototypes in a web page

For detailed information, see Embed designs and prototypes.

Add blur to objects

Select an object and apply an even blur effect on the entire object.

Adding a blur effect to an object
Adding a blur effect to an object

For detailed information, see Add an object blur.

Measurements

You can now measure the distances between objects on an artboard, or between a selected object and the artboard.

For more information, see Drawing tools.

Context menu for common actions

Context menus display commands related to the active tool or selection. You can use context menus as a quick way to choose commonly used commands. 

For example, when you right-click or Ctrl+Click an object, a context menu appears displaying commands to:

  • Cut, copy, paste, or delete,  
  • Lock or unlock, 
  • Move objects forward or behind other objects in a stack,
  • Move objects to the top or bottom of a stack.

For more information, see Move, align, and stack objects and Group, lock, and duplicate objects.

Single-click option to export assets as PNG at 1x

If you want to export assets as PNG at 1x, you can use the default Design export option. This allows you to export assets as PNG at 1x with a single-click.

For more information, see Export design assets.

What's new in Adobe Experience Design (Preview 3 | May 2016)

Scrolling artboards in preview

You can now create long artboards that can scroll beyond the stipulated size that you select in the beginning. During preview, a scroll bar appears using which you can scroll the artboard.

Drag the bottom of the artboard to create a scrolling artboard
Creating a scrollable artboard by dragging the bottom of the artboard

For detailed information, see Working with artboards.

Note:

This version of Adobe Experience Design (Preview) does not support horizontal scrolling.

Align objects to artboard

You can now align objects with respect to the artboard (such as aligning an object to the center of an artboard). Simply select the object or group and click one of the Align buttons in the Property Inspector. 

For detailed information, see Move, align, and stack objects.

Align and distribute artboards

You can now align and distribute multiple artboards with respect to each other. 

For detailed information, see Working with artboards.

Add background blur to objects

You can now blur specific sections of an object or an image by drawing a blur mask and blurring it using the Background Blur option in the Property Inspector. 

For detailed information, see How to add a background blur.

Improved color picker

In the new, improved Color Picker, you can choose colors using the HSB color model. If you know the hexadecimal value of the color you want, you can enter it into the text field. You can also use the color slider to preview a color to choose. As you adjust the color using the color slider, the numeric values are adjusted accordingly. 

You can also save the color swatches you create in the color picker for easier reuse.

For detailed information, see Set stroke, fill, and drop shadow for objects.

The new and improved Color Picker
The new and improved Color Picker

Format and edit properties of a portion of text

Edit text properties such as size, font, spacing for individual blocks of text in a text area.

Select a word, character, or a phrase, and apply formatting using the Text panel in the Property Inspector.

Format the entire text object or individual sections of text
Format the entire text object or individual sections of text

For detailed information, see Text tools.

View prototypes in full-screen mode

Shared prototypes can now be viewed in full screen in the browser and in Preview mode. When reviewers click the Full Screen icon, the prototype expands to fill the entire screen, allowing them to see all the design details clearly. 

For detailed information, see Preview designs and prototypes and Share designs and prototypes.

What's new in Adobe Experience Design (Preview 2 | April 2016)

The April release of Adobe Experience Design (Preview) rolls out exciting new features such as grids in artboards, dragging images from browsers on to the Adobe XD canvas, dragging text into repeat grids, and more. 

Read on for a quick introduction to these features and links to resources offering more information.

Grids

Grids provide guides to which you can align objects and text. When you draw, objects snap to the grid automatically when the object's edges are within the grid's snap-to-zone. Grids also help you get a quick idea of measurement while laying out objects or text on your artboards.

In Adobe Experience Design CC (Preview), you can show or hide grids by selecting an artboard and then toggling the checkbox in the Property Inspector on or off. The grid options also allow you to change the spacing of a grid and change its color. You can save a set of grid options as default to use them quickly in future.

Snap to grid while drawing objects
Snap to grid while drawing objects

For detailed information, see Grids.

Export images as SVG files

While exporting assets as SVG files, you can now choose to export them with embedded or linked images. 

  • Embed: If an image is exported as an embedded image, the bitmap image is encoded into the SVG.
  • Link: If an image is exported as a linked image, a bitmap image is stored separately with a reference to it in the SVG file. 

For detailed information, see Export design assets.

Drag images from web browsers to artboard

You can now drag images directly from all modern web browsers onto your artboards. You can also drag an image into an object on an artboard - when you do so, the image size is automatically adjusted to fit the object.

Specify different corner radii for squares and rectangles

You can now choose to have a common value for the corner radius of squares and rectangles, or specify different corner radii.

Adjusting all four corners simultaneously with a common value
Adjusting all four corners simultaneously with a common value

Adjusting the corners one by one with different values
Adjusting the corners one by one with different values


For detailed information, see Edit the corners of squares and rectangles.

Marquee-select anchor points

Use the Selection tool to marquee select specific anchor points for a shape, and then move these anchor points around to fine-tune your drawing.

For detailed information, see Selecting anchor points.

Context menu to edit objects

Right-click or Ctrl + click an object to see a shortcut menu that allows you to cut, copy, paste, and delete the selected object.

Marquee-select multiple artboards

You can now marquee-select multiple artboards, to perform editing operations, such as, moving, deleting, and copying on all selected artboards simultaneously.

Note:

Make sure at least two artboards are selected during the marquee selection. If only one artboard is selected or the artboards are only partially selected, only the contents within the artboard is selected.

Marquee-select multiple artboards to edit them simultaneously
Marquee-select multiple artboards to edit them simultaneously

Text enhancements

Drag text and text files to your artboard

You can easily include pre-written text in your design by simply dragging a plain text file on to your artboard. This action creates an area text on the artboard with the contents of the text file.            

You can also copy and paste text on to the artboard, creating an area text element that you can easily move and edit in Adobe XD.

Drag a text file on to a repeat grid

If you have a text file with new lines and drag that file over a text component in a Repeat grid, all of the text elements are populated with the text from that file. 

For detailed information, see Drag a text file on to a repeat grid.

Modify the leading between lines of text

The vertical space between lines of type is called leading (or line spacing). Leading is measured from the baseline of one line of text to the baseline of the line above it. Baseline is the invisible line on which most letters—that is, those characters without descenders—sit.

Increase or decrease space between lines of text by entering a numeric value in the Line Spacing option in the Property Inspector.

Changing the leading or line spacing between lines of text
Changing the leading or line spacing between lines of text

For detailed information on all these text enhancements, see Text tools.

New keyboard shortcut to toggle between Design and Prototype modes

Use Ctrl + Tab to toggle between Design and Prototype modes.

Enhancements to sharing and viewing prototypes

While sharing prototypes, you can now:

  • Target multiple URLs: When you want to share different versions of a prototype or share prototypes for different devices, you can now target different URLs each time.
  • Include hints in shared prototypes: Hotspot hints are now available for anyone viewing a shared prototype. These hints appear when a reviewer clicks on a space in the artboard where there is no interactive element.

For detailed instructions, see Share designs and prototypes.

UI Kit enhancements

In addition to the Welcome screen, UI kits for Google, Apple, and Microsoft devices can now be accessed from the File menu as well (File > Open UI Kit).

Download

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy