You're viewing help content for version:

The following document describes troubleshooting for Dynamic Media running dynamicmedia_scene7 run mode.

Setup and Configuration

Ensure that Dynamic Media has been set up properly by doing the following:

  • Start up command contains  the -r dynamicmedia_scene7 runmode argument.

  • Any AEM 6.4 cumulative fix packs (CFPs) have been installed first before any available Dynamic Media Feature Packs.

  • Optional Feature Pack 18912 is installed.

    This optional feature pack is for FTP support or if you are migrating assets to Dynamic Media from Dynamic Media Classic (Scene7).

  • Navigate to the Cloud Services user interface and confirm that the provisioned account appears under Available Configurations.

  • Ensure that the Dynamic Media Asset Activation (scene7) replication agent is enabled.

    This replication agent is found under Agents on Author.

General (All Assets)

The following are some general tips and tricks for all assets.

Asset Synchronization Status Properties

The following asset properties can be reviewed in CRXDE Lite to confirm the successful synchronization of the asset from AEM to Dynamic Media:

Property Example Description
<object_node>/jcr:content/metadata/dam:scene7ID a|364266 General indicator that node is linked to Dynamic Media.
<object_node>/jcr:content/metadata/dam:scene7FileStatus PublishComplete or error text Status of upload of asset to Dynamic Media.
<object_node>/jcr:content/metadata/dam:scene7File  myCompany/myAssetID Must be populated in order to generate URLs to remote asset of Dynamic Media.
<object_node>/jcr:content/dam:lastSyncStatus success or failed: <error text> Synchronization status of sets (spin sets, image sets, and so on), image presets, viewer presets, image map updates for an asset, or images that were edited.

Synchronization Logging

Synchronization errors and issues are logged in error.log (AEM server directory /crx-quickstart/logs/). Sufficient logging is available to determine the root cause of most issues, however you can increase the logging to DEBUG on the com.adobe.cq.dam.ips package through the Sling Console (http://localhost:4502/system/console/slinglog) to gather more information.

Move, Copy, Delete

Before performing a Move, Copy, or Delete operation, do the following:

  • For images and videos, confirm that a <object_node>/jcr:content/metadata/dam:scene7ID value exists before performing move, copy, or delete operations. 
  • For image and viewer presets, confirm that an http://<server>/crx/de/index.jsp#/etc/dam/presets/viewer/testpreset/jcr%3Acontent/metadata value exists before performing move, copy, or delete operations.
  • If above metadata value is missing, you need to re-upload assets before move, copy, or delete operations.

Version Control

When replacing an existing Dynamic Media asset (same name and location), you have the option to keep both assets or replace/create a version:

  • Keeping both will create a new asset with a unique name for the published asset URL; for example, image.jpg is the original asset and image1.jpg is the newly uploaded asset.
  • Creating a version is not supported in Dynamic Media - Scene7 mode delivery. The new version will replace the existing asset in delivery.

Images and Sets

If you are having issues with images and sets, see the following troubleshooting guidance.

Issue How to debug Solution
Cannot access copy URL/Embed button in asset detail view
  1. Go to CRX/DE:

    • Check whether the preset in the JCR /etc/dam/presets/viewer/<preset> has lastReplicationAction defined. Note that this location applies if you upgraded from AEM 6.x to 6.4 and opted out of migration. Otherise, the location is /conf/global/settings/dam/dm/presets/viewer.
    • Check to make sure that the asset in the JCR has dam:scene7FileStatus under Metadata shows as PublishComplete.

Refresh page/navigate to another page and come back (side rail JSP needs to be recompiled)

If that does not work:

  • Publish asset.
  • Re-upload asset and publish it.
Asset selector in set editor stuck in perpetual loading

Known issue to be fixed in 6.4

Close the selector and reopen it.

Select button is not active after selecting an asset as part of editing a set

 

Known issue to be fixed in 6.4

 

Click on another folder in the Asset Selector first and go back to select the asset.

Carousel hotspot moves around after switching between slides

Check that all slides are the same size.

Use only images with the same size for the carousel.

Image does not preview with the Dynamic Media viewer

Check that the asset contains dam:scene7File in the Metadata properties (CRXDE Lite)

Check that all assets have finished processing.

Uploaded asset does not show in asset selector

Check asset has property jcr:content > dam:assetState = processed (CRXDE Lite)

Check that all assets have finished processing.

Banner on card view shows New when asset has not started processing Check asset jcr:content > dam:assetState = if unprocessed it was not picked up by the workflow. Wait until asset is picked up by workflow.
Images or sets do not display the viewer URL or embed code Check if the viewer preset has been published.

Go to Tools > Assets > Viewer Presets and publish the viewer preset.

Video

If you are having issues with video, see the following troubleshooting guidance.

Issue How to debug Solution
Video cannot be previewed
  • Check that the folder has a video profile assigned to it (if non-supported file format). If non-supported, only an image displays.
  • Video profile must contain more than one encoding preset to generate an AVS set (single encodings are treated as video content for MP4 files; for non-supported files, treated the same as non-processed).
  • Check that the video has finished processing by confirming dam:scene7FileAvs of dam:scene7File in metadata.
  1. Assign a video profile to the folder.
  2. Edit video profile to include more than one encoding preset.
  3. Wait for video to finish processing.
  4. Be you re-load the video, make sure that the Dynamic Media Encode Video workflow is not running.
  5. Re-upload the video.
Video is not encoded
  • Check that the runmode is dynamicmedia_scene7.
  • Check whether Dynamic Media cloud service is configured.
  • Check whether a video profile is associated with the upload folder.
  1. Check your AEM instance with -r dynamicmedia_scene7
  2. Check that the Dynamic Media Configuration under Cloud Services is properly setup.
  3. Check that the folder has a video profile. Also, check the video profile.
Video processing takes too long

To determine if video encoding is still in progress or if it has entered a failure state:

  • Check the video status https://localhost:4502/crx/de/index.jsp#/content/dam/folder/videomp4/jcr%3Acontent > dam:assetState
  • Monitor the video from the workflow console http://localhost:4502/libs/cq/workflow/content/console.html > Instances, Archive, Failures tabs.
 
Video rendition missing

When video is uploaded, but there are no encoded renditions:

  • Check that the folder has a video profile assigned to it.
  • Check that the video has finished processing by confirming dam:scene7FileAvs in metadata.
  1. Assign a video profile to the folder.
  2. Wait for video to finish processing.

Viewers

If you are having issues with viewers, see the following troubleshooting guidance.

Issue How to debug Solution
Viewer Presets are not published

Proceed to sample manager diagnostic page: http://localhost:4502/libs/dam/gui/content/s7dam/samplemanager/samplemanager.html

Observe computed values. When operating correctly you should see:

_DMSAMPLE status: 0 unsyced assets - activation not necessary
_OOTB status: 0 unsyced assets - 0 unactivated assets

Note: It can take about 10 minutes after configuration of Dynamic Media cloud settings for the viewer assets to sync.

If unactivated assets remain, click either of the List all Unactivated Assets buttons to see details.

  1. Navigate to viewer preset list in admin tools: http://localhost:4502/libs/dam/gui/content/s7dam/samplemanager/samplemanager.html
  2. Select all viewer presets, then click Publish.
  3. Navigate back to sample manager and observe that unactivated asset count is now zero.
Viewer Preset artwork returns 404 from preview in asset details or copy URL/embed code

In CRXDE Lite do the following:

  1. Navigate to <sync-folder>/_CSS/_OOTB folder within your Dynamic Media sync folder (for example, /content/dam/_CSS/_OOTB),
  2. Find the metadata node of the problematic asset (for example, <sync-folder>/_CSS/_OOTB/CarouselDotsLeftButton_dark_sprite.png/jcr:content/metadata/).
  3. Check for the presence of dam:scene7* properties. If the asset was successfully synced and published you see the dam:scene7FileStatus set is to PublishComplete.
  4. Attempt to request the artwork directly from Dynamic Media by concatenating the values of the following properties and string literals
    • dam:scene7Domain
    • "is/content"
    • dam:scene7Folder
    • <asset-name>
    • Example: http://<server>/is/content/myfolder/_CSS/_OOTB/CarouselDotsLeftButton_dark_sprite.png

If the sample assets or viewer preset artwork have not synced or published then restart the entire copy/sync process:

  1. Navigate to CRXDE Lite.
    • Delete <sync-folder>/_CSS/_OOTB.
  2. Navigate to the CRX package manager: http://localhost:4502/crx/packmgr/
    1. Search for viewer package in list (it starts with cq-dam-scene7-viewers-content)
    2. Click Reinstall.
  3. Under Cloud Services, navigate to the Dynamic Media Configuration page, then open the configuration dialog box for your Dynamic Media - S7 configuration.
    • Make no changes, click Save. This triggers the logic again to create and sync the sample assets, viewer preset CSS, and artwork.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy