Issue

After upgrading from AEM 6.2 to AEM 6.4, content fragments no longer work.

Environment

6.2 to AEM 6.4 upgrade.

Cause

The upgrade fails to upgrade the custom content fragments.

Resolution

  1. Go to http://aemhost:port/crx/packmgr/index.jsp and log in as admin.

  2. Upload and install the attached package.

  3. Go to http://aemhost:port/crx/de/index.jsp#/apps/tools/components/fixContentFragments

  4. Log in as admin.

  5. Open /apps/tools/components/fixContentFragments/POST.jsp and modify the sling:resourceType that is set by the script.

  6. Go to http://aemhost:port/apps/tools/components/fixContentFragments/run.html

  7. Enter the path you need to run the tool against (not /content/dam/..., the path of the pages referencing the content fragments).

  8. Click start.

  9. The tool outputs all output to the error.log file at INFO level. For example

    03.08.2018 22:38:50.000 *INFO* [Thread-1665] org.apache.jsp.apps.tools.components.fixContentFragments.POST_jsp$FixContentFragmentsThread Running content fragments fix.
    03.08.2018 22:38:50.547 *INFO* [Thread-1665] org.apache.jsp.apps.tools.components.fixContentFragments.POST_jsp$FixContentFragmentsThread Fixing: /content/aetnacom2/en/health-guide/jacksonville-gardener-ron-pauline/jcr:content/content_section/articleform/descriptionsections
    03.08.2018 22:38:52.297 *INFO* [Thread-1665] org.apache.jsp.apps.tools.components.fixContentFragments.POST_jsp$FixContentFragmentsThread fixContentFragments completed, total time: 2297ms
    

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy