Validate OSGi bundle versions after upgrades, service pack, feature pack or fix pack installations.
The tool below helps you to validate that the versions of the OSGi bundles installed in your AEM instance match the expected versions for your AEM version and patches.  This is helpful in validating successful AEM upgrades and service pack installations.
 
Instructions:
  1. Copy / Paste the JSON from http://aemhost1:port/system/console/bundles.json to the Actual JSON text field.
  2. Select Product Version and minor version from the two dropdown menus to autopopulate the Expected JSON field or copy / paste JSON from another AEM instance to the Expected JSON field (also from http://aemhost2:port/system/console/bundles.json).
  3. Click Compare to view the diff.
  4. Similar bundles are displayed in white, differing bundle versions are displayed in yellow, newly added bundles are displayed in aqua, and deleted bundles in light red.
  5. Filter the data using the Filter box.
Product Version:  Loading...
JSON from /system/console/bundles.json

Results of comparision
Filter:
Symbolic Name Bundle Name Expected Version Number Actual Version Number

 

 

* Thanks to Sham Sundar Hassan Chikkegowda for providing the original source code for this tool.  His personal site can be visited here.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy