Lomakkeen luominen aiemmin luodusta dokumentista

Voit muuntaa aiemmin luodun dokumentin (esimerkiksi Word-, Excel- tai PDF-dokumentin) tai skannata paperidokumentin PDF-muotoon. Acrobat lisää automaattisesti lomakkeisiin vuorovaikutteiset lomakekentät. Sitten voit muokata lomaketta lisäämällä siihen avattavan luettelon, luetteloruudun tai painikkeita.

Lomakekenttätyypit, joita PDF-tiedostoon voi lisätä
Lomakekenttätyypit, joita PDF-tiedostoon voi lisätä

A. Varmennepohjainen allekirjoituskenttä B. Avattava luetteloruutu C. Tekstikentät D. Automaattinen sanomarivi E. Valintaruudut F. Valintanapit G. Luetteloruutu H. Painikkeet 
  1. Valitse työkalurivin Luo -valikosta Luo lomake.

  2. Valitse Aiemmin luodusta dokumentista ja valitse sitten Seuraava.

  3. Valitse haluamasi seuraavista vaihtoehdoista:

    Käytä nykyistä dokumenttia

    Muuntaa avoimena olevan PDF-dokumentin vuorovaikutteiseksi lomakkeeksi.

    Valitse toinen tiedosto

    Muuntaa sähköisen dokumentin (esimerkiksi Word-, Excel- tai PDF-tiedoston) vuorovaikutteiseksi PDF-lomakkeeksi. Valitse Selaa ja etsi tiedosto.

    Skannaa paperilomake

    Skannaa paperilomakkeen ja muuntaa sen vuorovaikutteiseksi PDF-lomakkeeksi.

  4. Valitse Jatka ja noudata näyttöön tulevia ohjeita.

    Acrobat luo lomakkeen ja avaa sen lomakkeenmuokkaustilassa. Lomakkeet-tehtäväruudussa näkyvät lomakkeen muokkausvaihtoehdot. Kenttiä voi lisätä työkalurivin lomakekenttätyökaluilla.

  5. Tarkista Acrobatin luomat lomakekentät. Lisää kenttiä tehtäväpalkin lomakekenttätyökaluilla. Poista kenttiä, muuta niiden kokoa tai järjestä niitä uudelleen tarvittaessa. Voit lisätä mitä tahansa seuraavantyyppisiä lomakekenttiä:

    Viivakoodit

    Nämä koodaavat valittujen kenttien sisällön ja näyttävät sen kuviona, joka voidaan tulkita dekoodausohjelmalla tai -laitteella (saatavana erikseen).

    Painikkeet

    Nämä käynnistävät käyttäjän tietokoneessa toiminnon, esimerkiksi avaavat tiedoston, soittavat äänen tai lähettävät tiedot Web-palvelimeen. Painikkeita voidaan mukauttaa kuvilla, tekstillä ja visuaalisilla vaihdoksilla, jotka käynnistetään hiirellä.

    Valintaruudut

    Nämä esittävät kyllä tai ei -valintoja, jotka koskevat yksittäisiä asioita. Jos lomakkeessa on useita valintaruutuja, käyttäjä voi yleensä valita niistä niin monta kuin haluaa.

    Digitaalinen allekirjoituskenttä

    Nämä antavat käyttäjän allekirjoittaa PDF-tiedoston sähköisesti käyttämällä digitaalista allekirjoitusta.

    Avattava luettelo

    Nämä antavat käyttäjän joko valita vaihtoehdon ponnahdusvalikosta tai kirjoittaa arvon. Voit määrittää lomakekentän ominaisuuden, jonka avulla käyttäjä voi antaa mukautetun arvon.

    Luetteloruudut

    Nämä luettelevat vaihtoehdot, joista käyttäjä voi valita. Voit määrittää lomakekentän ominaisuuden, joka antaa käyttäjän valita luettelosta useita vaihtoehtoja vaihto-napsauttamalla.

    Valintanapit

    Nämä esittävät joukon vaihtoehtoja, joista käyttäjä voi valita vain yhden. Kaikki samannimiset valintanapit toimivat yhdessä ryhmänä.

    Tekstikentät

    Nämä antavat käyttäjän kirjoittaa tekstiä, kuten nimen, osoitteen tai puhelinnumeron.

    Lisätietoja on aiheessa Perustietoja lomakekentistä.

  6. Kun olet saanut lomakkeen valmiiksi, valitse Sulje lomakkeen muokkaaminen.

Lisätietoja on video-opastusohjelmassa, joka käsittelee PDF-lomakkeiden luontia aiemmin luoduista dokumenteista: http://tv.adobe.com/watch/acrobat-xi-tips-tricks/how-to-create-new-pdf-forms-from-existing-documents/

Lomakkeiden luominen Adobe Signia varten

Voit muuntaa aiemmin luodun lomakkeen Adobe Sign -lomakkeeksi tai vetää ja pudottaa Adobe Sign -kenttiä helposti PDF-dokumenttiin. Voit lähettää lomakkeen täytettäväksi ja allekirjoitettavaksi Adobe Sign -palvelun kautta. Kaikkia kenttiä ei voi muuntaa Adobe Sign -kentiksi. Tällaisia kenttiä ovat esimerkiksi Luetteloruutu-, Avattava luettelo- ja Painike-kentät. Voit lisätä muita Adobe Sign -kenttiä työkalurivistä.

  1. Avaa PDF-tiedosto, jonka haluat muuntaa Adobe Sign -lomakkeeksi.

  2. Valitse Työkalut > Lomakkeet > Muokkaa

  3. Jos ohjelma kysyy, haluatko Acrobatin tunnistavan lomakekentät puolestasi, valitse Kyllä.

  4. Kun ohjelma ilmoittaa siirtymisestä lomakkeen muokkaustilaan, valitse OK.

  5. Valitse esiin tulevasta Lomakkeet-ruudusta Tehtävät > Muunna Adobe Sign -lomakkeeksi.

  6. Kun ohjelma ilmoittaa, että Acrobat poistaa kentät, joita Adobe Sign ei tue, valitse Seuraava ja valitse seuraavassa ilmoituksessa OK.

  7. Jos haluat lisätä lomakkeeseen kentän, valitse sen kuvake tehtäväpalkista. Siirrä osoitin kohtaan, johon haluat sijoittaa kentän, ja lisää se napsauttamalla.

  8. Nimeä kenttä ja määritä, kenen pitää täyttää tai allekirjoittaa se. Jos haluat määrittää kentän ominaisuudet, esimerkiksi reunan värin, täytön, fontin ja kirjasinkoon, kaksoisnapsauta kenttää.

    Lomakekentän ominaisuudet
    Kun sijoitat Adobe Sign -kentän ensimmäisen kerran, voit nimetä sen ja määrittää, kenen pitää täyttää tai allekirjoittaa kenttä.

  9. Kun lomake on valmis, valitse tehtäväpalkista Sulje lomakkeen muokkaaminen.

  10. Kun haluat ladata lomakkeen Adobe Signiin, valitse Allekirjoita > Hanki allekirjoitus muilta > Lähetä allekirjoitettavaksi.

  11. Kun näyttöön tulee sanoma ”Dokumentti on ladattu Adobe Sign -palveluun”, valitse Jatka siirtymällä Adobe Sign -palveluun. Kun Adobe Sign -sivusto avautuu, noudata näyttöön tulevia ohjeita.

Adobe Sign -erikoiskenttien lisääminen

Voit luoda Adobe Sign -kenttiä erityistarkoituksiin, esimerkiksi avattavia luetteloita tai kenttiä, jotka tarkistavat arvot tai sallivat vain tietyt arvot. Kenttä nimetään erityisellä tekstikoodilla. Koodin syntaksi sisältää kaikki kentän luomiseen tarvittavat tiedot. Kentän ominaisuudet eivät näy Acrobatissa. Tämän tekstikoodin perusteella Adobe Sign muodostaa kentän, kun lataat lomakkeen Adobe Sign -sivustoon.

Kirjoita tekstikoodi Nimi-kenttään, kun lisäät kentän ensimmäisen kerran. Voit myös muokata kentän nimeä Ominaisuudet-valintaikkunan Yleiset-välilehdessä (avaa kentän ominaisuudet kaksoisnapsauttamalla kenttää). Adobe Sign -tekstitunnisteiden luettelon löydät aiheesta Adobe Sign -lomakkeiden luominen tekstitunnisteiden avulla. Kun lisäät tekstikoodin Acrobatissa, älä käytä koodin ympärillä aaltosulkeita: {{koodi}}.

Lomakkeen tietojen tallentamisen salliminen Readerin käyttäjille

Tavallisesti Reader X:n ja sitä aiempien versioiden käyttäjät eivät voi tallentaa täyttämiään lomakkeita. Voit kuitenkin laajentaa PDF:n käyttöoikeuksia siten, että nämä käyttäjät voivat tallentaa lomaketiedot. Jos käytössäsi on Acrobat Pro, voit antaa Reader-käyttäjille myös muita oikeuksia, kuten tekstin lisäämisen ei-vuorovaikutteisiin lomakkeisiin.

Huomautus:

Toisin kuin Readerin aiemmissa versiossa, Reader XI:ssä on sekä tekstin lisäystyökalu että lomaketietojen tallennusmahdollisuus. Acrobat-käyttäjät voivat kirjoittaa tekstiä ei-täytettäviin lomakkeisiin, lisätä kommentteja ja allekirjoittaa PDF-tiedostoja digitaalisesti ilman erityisoikeuksia.

  1. Avaa yksittäinen PDF-tiedosto tai esikatsele PDF-portfolioon kuuluvaa PDF-osatiedostoa.

  2. Jos muokkaat lomaketta, napsauta Lomakkeet-tehtäväruudussa Sulje lomakkeen muokkaaminen.

  3. Valitse Tiedosto > Tallenna muussa muodossa > Reader-laajennettu PDF ja valitse jokin seuraavista vaihtoehdoista:

    Ota käyttöön tekstin lisääminen PDF-tiedostoihin (jotka eivät ole PDF-lomakkeita)

    (Acrobat Pro) Käyttäjät voivat lisätä tekstiä PDF-tiedostoihin tai ei-täytettäviin lomakkeisiin (Readerin aiemmissa versioissa).

    Kommentointi ja mittaus

    (Acrobat Pro) Käyttäjät voivat lisätä kommentteja tai käsitellä objektitieto-, Mittaus- ja Geospatiaalinen-työkaluja.

    Ota käyttöön lisää työkaluja (kuten lomakkeiden täyttö ja tallennus)

    Käyttäjät voivat tallentaa vuorovaikutteisiin tai täytettäviin lomakkeisiin kirjoittamansa tiedot.

Täytettyjen lomakkeiden paikallista tallentamista koskevat rajoitukset

Acrobat Standard- ja Acrobat Pro -ohjelmissa Adobe Reader 8:n ja sitä uudempien versioiden käyttäjät voivat tallentaa PDF-lomakkeita paikallisesti. Reader Extensions -ominaisuuden käyttäjien mahdollisuutta tallentaa PDF-lomakkeita paikallisesti (jota kutsutaan nimellä laajennetut asiakirjat) on rajoitettu kahdella tavalla:

Käytössä olevien laajennettujen asiakirjojen määrä

Acrobat Standardin ja Acrobat Pron käyttäjät voivat lähettää laajennetun asiakirjan täytettäväksi rajoittamattomalle määrälle vastaanottajia. Esimerkiksi Acrobatin käyttäjä voi lähettää tyhjän lomakepohjan WWW-sivulle, jolla käyttäjät voivat täyttää ja tallentaa PDF-lomakkeita paikallisesti. Rajoittamaton määrä ihmisiä voi käyttää lomakepohjaa. Acrobatin käyttäjä voi kuitenkin kerätä vain 500 täytettyä vastauslomaketta. Tämä rajoitus koskee täytetyn lomakkeen sekä tulostettuja (käyttäjät lähettävät lomakkeen paperimuodossa) että sähköisiä muotoja.

Laajennetun asiakirjan vastaanottajien määrä

Acrobat Standardin tai Acrobat Pron käyttäjät voivat lähettää laajennetun asiakirjan täytettäväksi enintään 500 vastaanottajalle. Oletetaan, että Acrobatin käyttäjä kuuluu organisaatioon, jossa on enintään 500 jäsentä. Acrobatin käyttäjä voi lähettää rajoittamattoman määrän laajennettuja asiakirjoja noille 500 vastaanottajalle ja kerätä rajoittamattoman määrän vastauksia täytetyistä lomakkeista.

Molemmat rajoitukset koskevat tiettyä kokonaisuutta tai yritystä eivätkä kokonaisuuden eri käyttäjät voi kiertää tätä ominaisuutta. Lisäkäyttöoikeuksien hankkiminen Acrobatia varten ei aiheuta muutoksia yllä oleviin rajoituksiin. Esimerkiksi yrityksen viisi Acrobat Standard 9 -version käyttäjää eivät voi lähettää samaa laajennettua asiakirjaa ja vastaanottaa ja kerätä tietoja yhteensä enemmän kuin 500 kertaa.

Acrobat Standard ja Acrobat Pro sisältävät tekniikoita, joilla PDF-dokumentissa voi ottaa käyttöön tiettyjä ominaisuuksia käyttämällä digitaalista valtuutusta. Tämä valtuutus sijaitsee ohjelmistossa ("Avain"). Hyväksyt, ettet käytä, yritä käyttää, hallitse, poista käytöstä, poista, tai jakele Avainta missään tarkoituksessa.

JavaScriptin lisääminen lomakkeisiin

JavaScript-ohjelmointikielellä voidaan luoda vuorovaikutteisia Web-sivuja. Adobe on laajentanut JavaScript-kieltä niin, että voit helposti lisätä vuorovaikutteisuutta PDF-lomakkeisiin. JavaScript-komentosarjojen yleisimpiä käyttötapoja Acrobat -lomakkeissa ovat tietojen muotoilu, laskenta ja tarkistus sekä toimintojen luominen. Windowsissa Adobe PDF -lomakkeet voivat muodostaa suoraan yhteyden tietokantoihin ODBC:n (Open Database Connection) avulla.

Huomautus:

Jos luot dynaamisia lomakkeita, muista, että Reader ei tue kaikkia mukautettuja JavaScript-komentoja, joten lomake ei ehkä toimi oikein, kun sitä tarkastellaan Readerissa, ellei PDF-tiedostoon ole määritetty lisäkäyttöoikeuksia.

Lisäresurssit

Jos tarvitset lisätietoja Acrobat JavaScriptistä, katso seuraavia resursseja:

Lomakkeiden jakaminen (lähettäminen) vastaanottajille

PDF- tai verkkolomakkeiden jakaminen

Kun olet luonut lomakkeen, valitse menetelmä sen lähettämiseksi vastaanottajille.

  1. Valitse Työkalut > Lomakkeet > Jaa.

  2. Näyttöön voi tulla joukko ilmoituksia sen mukaan, millaisia ehtoja Acrobat löytää lomakkeesta. Noudata näyttöön tulevia ohjeita tarvittaessa ja tallenna lomake.
  3. Valitse jakelu- ja kokoamismenetelmä:

    Sähköposti

    Kerää vastauksia sähköpostiohjelmasi Saapuneet-kansioon.

    Sisäinen palvelin

    Jakele ja kerää vastauksia sisäiseen palvelimeen, kuten SharePointiin tai verkkokansioon. Lisätietoja on kohdassa Palvelimen määrittäminen.

  4. Valitse Jatka ja noudata näyttöön tulevia lomakkeen jakeluohjeita.

  5. Jos päätit kerätä vastaukset saapuvan sähköpostin laatikkoosi, tee yksi seuraavista:

Huomautus:

Jos et tiedä vastaanottajien sähköpostiosoitteita, kirjoita oma sähköpostiosoitteesi. Järjestelmä lähettää sinulle linkin lomakkeeseen, ja voit lähettää sen vastaanottajille sähköpostitse.

Adobe Sign -lomakkeiden jakeleminen

Kun olet luonut Adobe Sign -lomakkeen, voit lähettää sen Adobe Sign -palvelun kautta vastaanottajille täytettäväksi ja allekirjoitettavaksi.

  1. Jos lomake on lomakkeen muokkaamistilassa, valitse tehtäväpalkista Sulje lomakkeen muokkaaminen.

  2. Tallenna lomake, jos et ole jo tehnyt sitä.

  3. Kun haluat ladata lomakkeen Adobe Signiin, valitse Allekirjoita > Hanki allekirjoitus muilta > Lähetä allekirjoitettavaksi.

  4. Kun näyttöön tulee sanoma ”Dokumentti on ladattu Adobe Sign -palveluun”, valitse Jatka siirtymällä Adobe Sign -palveluun.

  5. Kun Adobe Sign -sivusto avautuu, noudata näyttöön tulevia ohjeita.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö