Huomautus:

Tässä dokumentissa on ohjeet Acrobat XI -ohjelmaa varten. Jos käytät Acrobat DC:tä, perehdy Acrobat DC:n ohjeeseen.

PDF-tiedoston indeksin luominen ja hallinta

Voit nopeuttaa tietojen etsimistä suuresta PDF-tiedostosta sisällyttämällä tiedostoon indeksin, jossa on lueteltu tiedostossa mainitut sanat. Acrobat pystyy etsimään indeksistä paljon nopeammin kuin itse tiedostosta. Sisällytetty indeksi on mukana PDF-tiedoston jaetuissa ja yhteisissä kopioissa. Käyttäjät etsivät indeksin sisältävistä PDF-tiedostoista tietoja aivan samoin kuin muistakin PDF-tiedostoista; ylimääräisiä vaiheita ei tarvita.

Indeksin lisääminen PDF-tiedostoon

  1. Kun dokumentti on avoinna Acrobatissa, valitse Työkalut > Dokumentin käsittely > Hallitse upotettua indeksiä.
  2. Napsauta Sisällytetyn indeksin hallinta -valintaikkunassa Sisällytä indeksi.
  3. Lue näyttöön tulevat tiedot ja napsauta OK.

    Huomautus:

    Outlookissa ja Lotus Notesissa on mahdollisuus sisällyttää indeksi silloin, kun sähköpostiviestejä tai -kansioita muunnetaan PDF-muotoon. Sisällyttäminen on erittäin suositeltavaa, jos kansioissa on paljon sähköpostiviestejä.

PDF-tiedostoon sisällytetyn indeksin päivittäminen tai poistaminen

  1. Valitse Työkalut > Dokumentin käsittely > Hallitse upotettua indeksiä.
  2. Napsauta joko Päivitä indeksi tai Poista indeksi.

Tietoja Catalog-ominaisuudesta  (Acrobat Pro)

Voit määrittää tietyn ryhmän PDF-tiedostoja luetteloksi ja luoda koko tiedostoryhmälle yhteisen hakemiston. Kun käyttäjät etsivät tiettyjä tietoja luetteloiduista PDF-tiedostoista, hakemisto nopeuttaa etsintää.

Kun kokoelma jaetaan CD-levyllä, voit sisällyttää hakemiston PDF-tiedostojen mukaan.

Voit luetteloida dokumentteja, joissa käytetään roomalaisia, kiinalaisia, japanilaisia tai korealaisia merkkejä. Luetteloon voidaan liittää dokumentin tekstiä, kommentteja, kirjanmerkkejä, lomakekenttiä, koodimerkintöjä, objektien ja dokumentin metatietoja, liitteitä, dokumentin tietoja, digitaalisia allekirjoituksia, kuvan XIF-metatietoja (eXtended Image File) ja dokumentin mukautettuja ominaisuuksia.

PDF-dokumenttien valmisteleminen hakemiston laatimista varten  (Acrobat Pro)

Luo ensin kansio niitä PDF-tiedostoja varten, joista hakemisto tehdään. Kaikkien PDF-tiedostojen pitää olla valmiita sisällön ja sähköisten ominaisuuksien, kuten linkkien, kirjanmerkkien ja lomakekenttien, osalta. Jos tiedostojen joukossa on skannattuja dokumentteja, varmista, että niistä voidaan etsiä tekstiä. Voit parantaa haun suorituskykyä jakamalla pitkät dokumentit pienemmiksi, kappalekokoisiksi tiedostoiksi. Voit myös parantaa tiedoston etsittävyyttä lisäämällä tietoja tiedoston dokumenttiominaisuuksiin.

Ennen kuin laadit dokumenttikokoelmasta hakemiston, on tärkeää muodostaa dokumenttirakenne kiintolevylle tai verkon palvelimeen ja tarkistaa erilaisissa laiteympäristöissä käytettävät tiedostonimet. Tiedostonimet voivat lyhentyä, mikä vaikeuttaa tiedostojen löytämistä haussa eri ympäristöissä. Voit ehkäistä tämän ongelman ottamalla huomioon seuraavat seikat:

  • Nimeä tiedostot, kansiot ja hakemistot MS-DOS-tiedostojen nimeämissääntöjen mukaan (enintään kahdeksan merkkiä ja kolmen merkin pituinen tiedostotunniste) etenkin silloin, kun aiot toimittaa tiedostokokoelman ja hakemiston ISO 9660 -standardin mukaisella CD-levyllä.

  • Poista tiedostojen ja kansioiden nimistä erikoismerkit, kuten aksentteja sisältävät kirjaimet ja muut kuin englannin kielen kirjaimet. (Luettelotoiminnon käyttämä kirjasin ei tue merkkikoodeja 133–159.)

  • Älä käytä pitkiä alikansiorakenteita tai yli 256 merkin pituisia polkunimiä hakemistoissa, joista on tarkoitus hakea Mac OS -järjestelmässä.

  • Jos käytät Mac OS -tietokonetta OS/2-verkkopalvelimen kanssa, määritä IBM® LAN Server Macintosh (LSM) käyttämään MS-DOS-tiedostonnimeämiskäytäntöjä tai laatimaan hakemisto vain FAT (File Allocation Table) -taltioista. (HPFS [High Performance File System] -taltiot voivat sisältää liian pitkiä tiedostonimiä.)

    Jos dokumenttirakenne sisältää alikansioita, joita et halua sisällyttää hakemistoon, voit jättää ne pois hakemiston luomisen aikana.

Metatietojen lisääminen dokumentin ominaisuuksiin  (Acrobat Pro)

Voit helpottaa haun suorittamista PDF-tiedostossa lisäämällä dokumentin ominaisuuksiin tietoja, joita kutsutaan metatiedoiksi. (Voit tarkastella avoimena olevan PDF-tiedoston ominaisuuksia valitsemalla Tiedosto > Ominaisuudet ja valitsemalla sitten Kuvaus-välilehden.)

Huomautus:

(Windows) Voit lisätä ja lukea ominaisuuksien tietoja myös työpöydältä. Napsauta dokumenttia Resurssienhallinnassa hiiren kakkospainikkeella, valitse Ominaisuudet ja valitse PDF-välilehti. Kaikki tässä valintaikkunassa lisäämäsi ja muokkaamasi tiedot näkyvät myös dokumentin ominaisuuksien kuvauksessa, kun tiedosto avataan.

Kun lisäät tietoja dokumentin ominaisuuksiin, muista seuraavat suositukset:

  • Kirjoita Otsikko-kenttään kuvaava otsikko. Dokumentin tiedostonimen pitäisi näkyä Hakutulokset-valintaikkunassa.

  • Kirjoita samankaltaiset tiedot aina samaan kenttään. Älä esimerkiksi lisää tärkeää termiä Aihe-kenttään joissakin dokumenteissa ja Avainsanat-kenttään muissa dokumenteissa.

  • Käytä samoille tiedoille johdonmukaisesti yhtä termiä. Älä esimerkiksi kirjoita toisiin dokumentteihin biologia ja toisiin luonnontiede.

  • Kirjoita Tekijä-kenttään dokumentista vastaavan ryhmän nimi. Esimerkiksi työntekijöiden palkkaamista käsittelevän dokumentin tekijä voisi olla Henkilöstöosasto.

  • Jos dokumenteille on annettu osanumerot, lisää ne avainsanoiksi. Lisää Avainsanat-kenttään esimerkiksi julknro=m234, jos dokumentti kuuluu suureen, tiettyä aihetta käsittelevien dokumenttien kokoelmaan.

  • Luokittele dokumentit tyypin mukaan käyttämällä Aihe- tai Avainsana-kenttää tai molempia. Voisit esimerkiksi kirjoittaa dokumentin Aihe-kenttään tilaraportti ja Avainsanat-kenttään kuukausittainen tai viikoittainen.

    Jos olet jo osallistunut Adobe PDF -koulutukseen, osaat määrittää hakemistoa luodessasi mukautettuja tietokenttiä, esimerkiksi Dokumentin tyyppi, Dokumentin numero ja Dokumentin tunniste. Tätä menettelytapaa suositellaan vain edistyneille käyttäjille, ja sitä ei kuvata Acrobatin ohjeissa.

Hakemiston luominen kokoelmalle (Acrobat Pro)

Kun muodostat uutta hakemistoa, Acrobat luo .pdx-tunnisteella varustetun tiedoston ja uuden tukikansion, joka sisältää vähintään yhden .idx-tunnisteella varustetun tiedoston. IDX-tiedostot sisältävät hakemistomerkinnät. Käyttäjä tarvitsee kaikki nämä tiedostot etsiessään tietoja hakemistosta.

Acrobat Pron hakemiston luontiprosessissa käytettävät valintaikkunat
Acrobat Pron hakemiston luontiprosessissa käytettävät valintaikkunat

  1. Valitse Työkalut > Dokumentin käsittely > Täysi tekstihakemisto ja luettelo ja valitse sitten Uusi indeksi.

    Huomautus:

    Jos Dokumentin käsittely -paneeli ei ole näkyvissä, katso ohjeet paneelien lisäämiseen tehtäväpaneeleja käsittelevästä kohdasta.

  2. Kirjoita Indeksin otsikko -ruutuun hakemistotiedoston nimi.
  3. Kirjoita Indeksin kuvaus -ruutuun muutama sana hakemiston tyypistä tai sen tarkoituksesta.
  4. Valitse Asetukset, valitse hakemistossa käytettävät lisäasetukset ja valitse sitten OK.
  5. Valitse Sisällytä nämä hakemistot -kohdasta Lisää, valitse osan hakemiston PDF-tiedostoista tai ne kaikki sisältävä kansio ja valitse sitten OK. Voit lisätä kansioita toistamalla tämän vaiheen.

    Huomautus:

    Kansion sisältämät alikansiot sisällytetään hakemiston muodostukseen. Voit lisätä eri palvelimissa tai levyasemissa sijaitsevia kansioita, jos olet varma, ettet aio siirtää hakemistoa tai kokoelmaan kuuluvia dokumentteja.

  6. Valitse Ohita nämä alihakemistot, valitse Lisää ja valitse alikansio, joka sisältää PDF-tiedostoja, joita et halua sisällyttää hakemistoon. Valitse OK ja toista toimenpide tarvittaessa.
  7. Tarkista valinnat. Voit muuttaa sisällytettävien tai ohitettavien kansioiden luetteloa valitsemalla muutettavan kansion ja valitsemalla sitten Poista.
  8. Napsauta Muodosta ja määritä hakemistotiedoston sijainti. Valitse Tallenna ja toimi sitten seuraavasti:
    • Valitse Sulje, kun hakemiston muodostaminen on valmis.

    • Peruuta hakemiston muodostaminen valitsemalla Pysäytä.

    Huomautus:

    Jos pysäytät hakemiston muodostamisen, et voi jatkaa samaa hakemiston muodostamisistuntoa, mutta työtä ei kuitenkaan tarvitse tehdä uudelleen. Asetukset ja kansiovalinnat eivät katoa. Voit valita keskeneräisen hakemiston ja käsitellä sitä valitsemalla Avaa indeksitiedosto.

    Huomautus:

    Jos pitkät tiedostonimet näkyvät katkaistuina Sisällytä nämä hakemistot- ja Ohita nämä alikansiot-luetteloissa, pidä osoitinta kolmen pisteen (...) päällä. Esiin tulee työkaluvihje, joka näyttää sisällytetyn tai ohitetun kansion täydellisen polkunimen.

Hakemistoasetukset-valintaikkuna

Älä sisällytä numeroita

Valitsemalla tämän vaihtoehdon voit jättää hakemistosta pois kaikki dokumentin tekstissä esiintyvät numerot. Numeroiden ohittaminen voi merkittävästi pienentää hakemistoa ja nopeuttaa etsintää.

Lisää tunnukset Adobe PDF v1.0 -tiedostoihin

Valitse tämä vaihtoehto, jos kokoelma sisältää PDF-tiedostoja, jotka on luotu vanhemmalla versiolla kuin Acrobat 2.0, jolloin niihin ei ole lisätty automaattisesti tunnusnumeroita. Kun pitkiä Mac OS -tiedostonimiä lyhennetään DOS-tiedostonimiksi, tarvitaan tunnusnumeroita. Acrobat 2.0 ja uudemmat lisäävät tunnukset automaattisesti.

Älä varoita muuttuneista asiakirjoista etsittäessä

Kun tätä asetusta ei ole valittu, näyttöön tulee varoitus etsittäessä dokumentteja, jotka ovat muuttuneet hakemiston viimeisen päivityksen jälkeen.

Mukautetut ominaisuudet

Tällä asetuksella sisällytetään hakemistoon dokumentin mukautettuja ominaisuuksia. Vain PDF-dokumenteissa ennestään olevat mukautetut ominaisuudet otetaan huomioon hakemistoa muodostettaessa. Kirjoita ominaisuus, valitse haluamasi vaihtoehto Tyyppi-valikosta ja valitse sitten Lisää. Nämä ominaisuudet näkyvät hakuvaihtoehtoina Etsi PDF -ikkunan lisäehtojen ponnahdusvalikoissa, kun hakemistosta etsitään tietoja. Voit esimerkiksi antaa mukautetun ominaisuuden Dokumentin nimi ja valita merkkijono-ominaisuuden Tyyppi-valikosta; tällöin hakemistossa haun suorittava käyttäjä voi etsiä mukautetusta ominaisuudesta valitsemalla Käytä näitä lisäehtoja -valikosta Dokumentin nimi -vaihtoehdon.

Huomautus:

Kun luot mukautettuja kenttiä Microsoft Office -sovelluksella ja PDFMakerissa on valittu Muunna dokumentin tiedot -asetus, kentät siirtyvät kaikkiin luomiisi PDF -tiedostoihin.  

XMP-kentät

Tällä asetuksella sisällytetään hakemistoon mukautettuja XMP-kenttiä. Mukautetut XMP-kentät otetaan huomioon hakemistoa muodostettaessa. Ne näkyvät lisäehtojen ponnahdusvalikoissa, jotta niitä voidaan käyttää etsittäessä tietoja hakemistosta.

Hukkasanat

Tällä asetuksella määritetään sanat (enintään 500), joita ei oteta huomioon etsittäessä tietoja hakemistosta. Kirjoita sanat, valitse Lisää ja toista toimenpide tarvittaessa. Sanojen jättäminen pois voi pienentää hakemistoa 10–15 prosentilla. Hukkasanassa voi olla jopa 128 merkkiä. Isot ja pienet kirjaimet erotellaan.

Huomautus:

Jotta käyttäjät eivät yrittäisi hakea näitä sanoja sisältäviä lauseita, voit luetella ne luettelon Readme-tiedostossa.

Rakennemerkinnät

Tällä asetuksella luodaan alempien tasojen merkintäsolmuja. Niitä voidaan käyttää etsittäessä tietoja dokumenteista, joiden looginen rakenne on osoitettu koodimerkinnöin.

Huomautus:

Mukautetut ominaisuudet-, Hukkasanat- ja Rakennemerkinnät-asetukset koskevat vain käsiteltävää hakemistoa. Jos niiden täytyy koskea kaikkia luomiasi hakemistoja, muuta mukautettujen kenttien, hukkasanojen ja koodimerkintöjen oletusasetuksia Oletusarvot-valintaikkunan Luettelo-paneelissa.  

Luettelon LueMinut-tiedostot (Acrobat Pro)

On usein järkevää luoda erillinen LueMinut-tiedosto ja asettaa se samaan kansioon hakemiston kanssa. LueMinut-tiedosto voi sisältää hakemistosta esimerkiksi seuraavat tiedot:

  • Hakemistoon kuuluvien dokumenttien tyyppi.

  • Käytettävissä olevat hakuvaihtoehdot.

  • Lisätietoja antavan henkilön nimi tai puhelinnumero.

  • Hakemistosta poistettujen numeroiden tai sanojen luettelo.

  • Niiden kansioiden luettelo, jotka sisältävät lähiverkkoperustaiseen hakemistoon sisältyviä dokumentteja, tai levyperustaiseen hakemistoon sisältyvien dokumenttien luettelo. Tiedostossa voi olla myös kunkin kansion tai dokumentin sisällön lyhyt kuvaus.

  • Kunkin dokumentin kenttäarvojen luettelo, jos dokumentin tietoihin kuuluvia kenttäarvoja on määritetty.

    Jos luettelossa on erittäin paljon dokumentteja, sinun kannattaa laatia taulukko, joka sisältää kuhunkin dokumenttiin liitetyt arvot. Taulukko voi olla osa LueMinut-tiedostoa tai erillinen dokumentti. Kun kehittelet hakemistoa, taulukko auttaa säilyttämään yhdenmukaisuuden.

Hakemiston muokkaaminen  (Acrobat Pro)

Voit päivittää, muodostaa uudelleen tai tyhjentää hakemiston.

  1. Valitse Työkalut > Dokumentin käsittely > Täysi tekstihakemisto ja luettelo ja valitse sitten Avaa indeksi.
  2. Etsi ja valitse hakemiston määritystiedosto (PDX) ja napsauta Avaa.
  3. Jos hakemisto on luotu Acrobat 5.0:lla tai vanhemmalla, luo uusi indeksi (korvaamatta vanhempaa versiota) valitsemalla Luo kopio tai korvaa edellinen hakemisto valitsemalla Korvaa vanha indeksi.
  4. Tee haluamasi muutokset Indeksin määritystiedostot -valintaikkunassa ja valitse sitten toiminto, jonka haluat Acrobatin tekevän:

    Muodosta

    Luo uuden IDX-tiedoston, joka sisältää nykyiset tiedot, ja päivittää sen lisäämällä uudet merkinnät ja merkitsemällä muutetut tai vanhentuneet merkinnät kelvottomiksi. Hakuajat voivat pidentyä, jos teet paljon muutoksia tai käytät tätä vaihtoehtoa toistuvasti uuden hakemiston muodostamisen sijaan.

    Muodosta uudelleen

    Luo uuden hakemiston korvaamalla nykyisen hakemistokansion ja sen sisällön (IDX-tiedostot).

    Tyhjennä

    Poistaa hakemiston sisällön (IDX-tiedostot), mutta ei poista indeksitiedostoa (PDX).

Luettelon oletusarvot (Acrobat Pro)

Voit määrittää oletusarvoja, jotka koskevat kaikkia seuraavaksi luotavia hakemistoja. Osa oletusarvoista voidaan syrjäyttää hakemistoa luotaessa valitsemalla uudet asetukset.

Valitse Luettelo Asetukset-valintaikkunan Luokat-kohdasta. Monet asetuksista ovat samoja kuin hakemiston muodostamisen yhteydessä.

Huomautus:

Pakota kansiot ISO 9660 -yhteensopiviksi -vaihtoehto on käyttökelpoinen silloin, kun et halua muuttaa PDF-tiedostojen pitkiä nimiä MS-DOS-tiedostonimiksi valmistellessasi dokumentteja hakemiston muodostamista varten. Tästä huolimatta MS-DOS-nimeämissääntöjä on noudatettava kansioiden nimissä (enintään 8 merkkiä), mutta ei välttämättä tiedostojen nimissä.

Hakemistojen ajastettu päivittäminen  (Acrobat Pro)

Käytä Luettelo-toimintoa ja PDX-luetteloeräajotiedostoa (.bpdx), kun haluat määrittää, milloin ja kuinka usein hakemisto muodostetaan, muodostetaan uudelleen, päivitetään ja tyhjennetään. BPDX-tiedosto on tekstitiedosto, joka sisältää laiteympäristökohtaisia hakemistotiedostojen polkuja ja asetuksia. Voit näyttää BPDX-tiedoston Acrobatissa käyttämällä ajoitussovellusta, esimerkiksi Windowsin Tehtävien ajoitusta. Acrobat luo hakemiston uudelleen BPDX-hakemistoon tallennettujen asetusten mukaisesti.

Jos tarvitset lisätietoja hakemiston päivityksen ajoittamisesta, etsi hakusanaa BPDX sivustosta www.adobe.com/fi/support.

 

Huomautus:

Jos aiot käyttää BPDX-tiedostoja, valitse Asetukset-valintaikkunasta Luettelo-kohdassa Salli luetteloeräajotiedostojen (.bpdx) suorittaminen.

Kokoelmien ja niiden hakemistojen siirtäminen (Acrobat Pro)

Voit muodostaa dokumenttikokoelman ja hakemiston paikalliselle kiintolevylle, testata sen ja sitten siirtää sen verkon palvelimeen tai levylle. Hakemiston määritys sisältää suhteelliset polut hakemiston määritystiedostosta (PDX) kansioihin, jotka sisältävät hakemistoon kuuluvat dokumentit. Jos näitä suhteellisia polkuja ei muuteta, hakemistoa ei tarvitse muodostaa uudelleen dokumenttikokoelman siirtämisen jälkeen. Jos PDX-tiedosto ja hakemistoon kuuluvat dokumentit sisältävät alikansiot ovat samassa kansiossa, voit säilyttää suhteelliset polut yksinkertaisesti siirtämällä koko kansion.

Jos suhteellinen polku muuttuu dokumenttikokoelmaa siirrettäessä, hakemisto on luotava uudelleen. Voit silti käyttää alkuperäistä PDX-tiedostoa. Jos haluat käyttää tätä tiedostoa, siirrä ensin dokumentit, joista hakemisto on tehty. Kopioi sitten PDX-tiedosto kansioon, johon haluat luoda uuden hakemiston, ja muokkaa sisällytettävien ja ohitettavien kansioiden ja alikansioiden luetteloa tarvittaessa.

Jos hakemisto sijaitsee levyasemassa tai palvelimen levyllä, joka on erillään vastaavan dokumenttikokoelman kaikista osista, kokoelman tai hakemiston siirtäminen muuttaa hakemiston käyttökelvottomaksi. Jos aiot siirtää dokumenttikokoelman toiseen paikkaan verkossa tai CD-levylle, luo ja muodosta hakemisto samaan paikkaan kuin kokoelma.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö