Make a printed-circuit pattern draw itself using the animated outlining look of the Vegas effect in Adobe After Effects.
Girl wearing headphones sits at her computer watching the start screen for Circuit Games

Tarvittavat

Any reference to “Circuit Games” is for demonstration purposes only and is not intended to refer to any actual organization, products, services, or creative work.

Starting in Adobe Illustrator, make sure that each layer contains a discrete portion of the overall circuit board pattern. Label the layers so they’re self-explanatory (for example, Top, Left, Right, Bottom). This will greatly help you identify them later in After Effects. Drag-select the entire design and copy (Edit > Copy) it to the clipboard.

Adobe Illustrator shows a design with three layers (Top, Left, Bottom) selected in the artboard

Switch to After Effects and create a composition to contain your design. Add a solid layer to the composition (same size). With the solid selected, paste (Edit > Paste) the vector design you copied from Illustrator. Press M to reveal the masks corresponding to the layers in the Illustrator file. (Toggle Mask Visibility on if you don’t see the mask paths.) Rename the masks (press Return/Enter) so they match the layer names in Illustrator. Doing this will help you later.

Adobe After Effects shows three layers from the Illustrator file pasted as masks on a solid layer in a composition

With the solid layer selected, choose Effect > Generate > Vegas. In the Effect Controls panel, set Stroke to Mask/Path and point Path to a specific mask — such as Top. Toggle Mask Visibility off to see the applied effect instead of the mask paths. In the Rendering section, increase Width and Hardness so the dashed outlining is more noticeable and has a flatter edge. Finally, choose the Transparent blend mode and pick a color.

In Effect Controls panel, Vegas effect is applied to the solid layer and hex value 8A82F2 is entered in the Color picker

Take time to play around with the Vegas effect. By default, there are 32 outline segments. Use a single-digit number instead. (A continuous line appears at 1.) Reduce the Length value slightly to shorten each segment. Since each line trails off, maximize End Opacity so every line is completely visible. Drag the Rotation dial around to adjust each segment’s start and end point.

In Effect Controls panel, changes are made to Segments, Rotation, and End Opacity settings

With the Vegas effect set the way you want the circuit board design to appear, it’s time to animate it into view. Move the playhead ahead and toggle keyframing on for Length. Move the playhead to the beginning and zero it out. Preview the composition and watch each segment draw its own path from a fixed point, eventually completing the design. Create parallel keyframes for Rotation, starting at zero and ending with your chosen final value. Now when you preview, each segment’s start point follows the end point along the path — slower or faster, depending on the final Rotation keyframe value.

In Effect Controls panel, keyframes are added to Length and Rotation settings

To complete the design, add round test points (dots) to the ends of the printed-circuit lines. These can simply be thicker lines that are extremely short. Collapse the Vegas effect in the Effect Controls panel and duplicate it (Command/Control+D). Right-click Vegas 2 and rename it Tails. In the Tails instance, delete the Length keyframes (click the stopwatch) and reduce Length to just over zero. Finally, change the blend mode to Over, increase Width to form a dot, and maximize End Opacity.

In Effect Controls panel, Vegas effect is duplicated is renamed as Tails, with various settings changed in it

Collapse the Tails instance, duplicate it, and rename it Heads. In the Heads instance, position the playhead at the final Rotation keyframe and scrub the value so each segment’s dot moves along the path from the tail to the head. Preview the composition; the animated lines now show dots at both ends.

In Effect Controls panel, Tails instance is duplicated is renamed as Heads, with Rotation setting changed in it

Finally, apply the Vegas effect to the remaining portions of the design. In the Timeline panel, rename the solid so its name describes the portion of the design it animated — such as Top. Duplicate this layer (Command/Control+D) and rename it so it describes another portion (Left). In the Effect Controls panel, open each instance of the Vegas effect and select the appropriate mask for that section to bring that portion of the design into view. Duplicate the layer again, rename it so it applies to the final portion (Bottom), and update the mask selections accordingly.

In Timeline panel, solid layer is duplicated twice and renamed; Vegas effects are adjusted in Effect Controls panel

As for final touches, consider easing the keyframes to smooth the animation. Fine-tune your design further by adding Glow effects, so the circuit looks charged. Examine some of the embellishments we added to the practice file.

09/02/2020

Adobe Stock contributor: ohishiftl

Oliko tästä sivusta hyötyä?