Content fails to download or update in AEM Mobile iOS app version 2017.9.4 or 2017.9.5

Issue

After updating an app to version 2017.9.4 or 2017.9.5, content fails to download, fails to display, or displays out-dated content.

Environment

AEM Mobile iOS apps version 2017.9.4 or 2017.9.5

Cause

The viewer expects the authtoken it receives from the server to time out after 24 hours. The token actually expires in one hour. After one hour, the viewer continues to send the expired token which the server rejects.

Resolution

A fix has been deployed as part of Hot Fix 2017.11.4 [1].
To get this fix into the AEM Mobile preflight in the iOS, App Store takes some time as Apple puts it through its review process. In the meantime, you can test by building your own app with preflight enabled for testing. See “Building an app with ‘Enable Preflight’ selected” [2].

[1] https://helpx.adobe.com/digital-publishing-solution/release-note/bug-fix-release-notes.html
[2] https://helpx.adobe.com/digital-publishing-solution/help/preview-content.html

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