Tässä asiakirjassa kerrotaan, miten asennat OpenEXR Alpha -lisälaajennuksen ja käytät sitä.

OpenEXR Alpha -lisälaajennus tarjoaa vaihtoehtoisen tavan käsitellä A-kanavan tietoja OpenEXR-tiedostoa avattaessa. OpenEXR Alpha avaa A-kanavan tiedot alfakanavana sen sijaan, että se muuntaisi ne suoraan läpinäkyvään tilaan (kuten vanha OpenEXR-laajennus tekee).

Tausta

Photoshop CS2 ei yleensä tukenut läpinäkyvyyttä 32-bittisessä tilassa. Tässä versiossa oli käytettävä tilapäisratkaisua, jolla läpinäkyvyystiedot luettiin alfakanavalle. Photoshop CS3:ssa läpinäkyvyyden tukeminen otettiin käyttöön 32-bittisessä tilassa, niin että se takasi yhteensopivuuden OpenEXR-määrityksen kanssa. Läpinäkyvyyttä ei sen vuoksi enää luettu alfakanavalle suoran kanavasommittelun aikana.

Ennen kuin aloitat

Tarvitset OpenEXR Alpha -laajennuksen asentamiseen paikallisen pääkäyttäjän käyttöoikeudet. Käyttöjärjestelmät Mac OS, Windows Vista ja Windows 7 pyytävät sinua antamaan pääkäyttäjän tilin käyttäjätunnuksen ja salasanan. Jos käytät Windows XP:tä, kirjaudu sisään paikallisen pääkäyttäjän tilille ennen kuin aloitat.

Windows-käyttäjät: Osa tämän TechNoten vaiheista luettelevat tiedostot täydellisellä tiedostotunnisteet sisältävällä tiedostonimellä (esim. OpenEXR Alpha.8bi). Windowsissa tunnettujen tiedostotyyppien tiedostotunnisteet eivät ole oletusarvoisesti näkyvissä. Saat tiedostotunnisteet näkyville seuraavalla tavalla:

  1. Valitse Windows Explorerissa Työkalut > Kansioasetukset (Windows XP) tai Järjestä > Kansio- ja hakuasetukset (Windows 7 ja Vista).
  2. Valitse Näkymä-välilehti Kansioasetukset-ikkunan yläosan läheltä.
  3. Näkymä-välilehden Lisäasetukset-osiossa poista valinta Piilota tunnettujen tiedostotyyppien tiedostotunnisteet.
  4. Valitse OK.

Windows-käyttäjät: Osa tämän asiakirjan vaiheista vaatii, että määrität käytätkö Windowsin 32- vai 64-bittistä versiota. Tarkista mitä järjestelmätyyppiä käytät kohdan Määritä, onko tietokoneessasi Windowsin 32- vai 64-bittinen versio ohjeiden avulla.

Yhteensopivuus

Windowsissa OpenEXR Alpha -laajennus ei ole yhteensopiva Photoshop CS5 -versiota vanhempien Photoshop-versioiden kanssa. Se ei lataudu Photoshopin versioissa CS3 tai CS4.

Mac OS -käyttöjärjestelmässä OpenEXR Alpha -laajennus ei lataudu PPC-koneissa.

Asenna Macissa tai Windowsissa Photoshop CS5 -sovelluksen OpenEXR Alpha -laajennus (lataa päivitys Adoben verkkosivustolta).

OpenEXR Alpha -laajennuksen asentaminen lataamalla päivitys Adoben verkkosivustolta:

  1. Lataa pakattu laajennus:

  2. Sulje Photoshop CS5.
  3. Pura ladattu tiedosto.
  4. Vedä laajennus Photoshopin Plug-ins-kansioon.
    • 32-bittinen Windows: Vedä OpenEXR Alpha.8bi Win32-kansiosta kansioon /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-bittinen Windows: Vedä OpenEXR Alpha.8bi Win64-kansiosta kansioon /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • 64-bittinen Windows / 32-bittinen Photoshop: Vedä OpenEXR Alpha.8bi Win32-kansiosta kansioon /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats.
    • Mac OS: Vedä OpenEXR.plugin kansioon /Applications/Adobe Photoshop CS5/Plug-ins/File Formats.
  5. Käynnistä Photoshop CS5.

OpenEXR Alpha -laajennuksen käyttö

EXR-tiedoston avaaminen:

  1. Käynnistä Photoshop CS5.
  2. Valitse Tiedosto > Avaa.
  3. Etsi selaamalla haluamasi EXR-tiedosto. Valitse tiedostomuotojen luettelosta OpenEXR Alpha. Photoshop kohtelee A-kanavan tietoja alfakanavana läpinäkyvyyden sijaan.

EXR-tiedoston vieminen:

  1. Valitse Tiedosto > Tallenna nimellä.
  2. Valitse tiedostomuotojen luettelosta OpenEXR Alpha.

  3. Valitse Tallenna: Alfakanavat -vaihtoehto. Tämä asetus säilyttää alfakanavatiedot.

Huomautus: Tiedoston avaamisen jälkeen lisätty läpinäkyvyys litistetään.

Huomautus: OpenEXR Alpha -laajennuksen asentamisen jälkeen voit yhä valita vanhan OpenEXR-muodon tiedostomuotojen luettelosta. Tämä laajennus käsittelee A-kanavan tietoja edelleen läpinäkyvyytenä. Tämä toimintatapa on ollut Photoshopissa oletuksena Photoshop CS3 (version 10.0) -sovelluksesta lähtien.

Lisätietoja

Muita huomionarvoisia lisälaajennuksen käytöstä seuraavia toimintatapoja:

  • Premultiplied compositing -toiminto ei ole tuettu.
  • Jos avaat tiedoston kaksoisnapsauttamalla, Photoshop CS5 käyttää aina OpenEXR Alpha -muotoa OpenEXR-muodon sijaan.
  • Jos avaat tiedoston, jossa on kaksi tai useampi alfakanava, OpenEXR Alpha ei säilytä ainuttakaan alfakanavaa. Ne ohitetaan kokonaan.
  • (Mac OS): OpenEXR Alpha on Tallenna-dialogin listalla ylimpänä. Sitä ei luetella aakkosjärjestyksessä Open EXR -muodon vieressä.
  • (Windows): Jos haluat käyttää vanhaa OpenEXR-muotoa, valitse Tiedosto > Tallenna nimellä, ja sieltä OpenEXR.

Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö