Adobe® Flash® Builder™ 4 Read Me

Welcome to Adobe® Flash® Builder™ 4. This document contains late-breaking product information, updates, and troubleshooting tips not covered in the Flash Builder 4 documentation. 

What's new in Flash Builder 4 (4.0.1)

Minimum system requirements

What's included

Install your software

Uninstall your software

Trial software

Electronic licensing

Registration information

Known issues

Fixed issues

Customer care

Other resources

What's new in Flash Builder 4 (4.0.1)

  • Support for Adobe AIR 2
  • Support for Flash Player 10.1
  • Support for Flex SDK 4.1
  • Bug Fixes

Minimum system requirements 



For the latest system requirements, please visit www.adobe.com/go/flashbuilder4_systemreqs 

What's included

 

DVD:

The Flash Builder 4 DVD includes the following:

  • Flash Builder 4 Standalone install folder
  • Flash Builder 4 Eclipse Plug-in install folder
  • Extras folder that includes: *
    • LiveCycle Data Services 3.1 installer
    • Adobe Application Modeling Plug-in for Eclipse 3.4
    • Adobe Application Modeling Plug-in for Eclipse 3.5
    • LiveCycle Service Discovery Plug-in for Flash Builder 4.0
    • Flex 4 Test Automation Plug-in **
  • Flash Builder 4 Readme

* The contents of the Extras folder is not included in the Electronic Software Distribution (ESD) download. 

** Not included in the Electronic Software Distribution (ESD) download, but available as a separate download at www.adobe.com/go/flex_plugin

Install your software 

 

1. Before you install, quit all browsers and close all applications currently running on your system—including other Adobe applications, chat applications and Microsoft Office applications.  It is also recommended to temporarily turn off virus protection during the installation process. Uninstall any prerelease versions of Flash Builder 4. 

2. You must have administrative privileges or be able to validate as an administrator. 

3. Do one of the following: 

Install Flash Builder 4 Standalone on Windows:

a.  Log in as the Windows Administrator or as a computer administrator (a user account with administrator privileges).

Note: If you attempt to install without administrator privileges, the installation will complete with flagged issues. However, you will have installed an incomplete version of Flash Builder that you will not be able to run.

b. Prior to installing, uninstall any prerelease versions of Flash Builder 4.

c. Insert the DVD in your drive, and follow the on-screen instructions.  If the installer does not launch automatically, navigate to the Adobe Flash Builder 4 Standalone folder found at the root level on the DVD and double-click Set-up.exe to start the installation process. 

If you downloaded the software from the web, the installer will self-extract after the folder to copy the installer is selected and launch automatically.  If the installer does not launch automatically, open the folder, navigate to the Adobe Flash Builder 4 Installer folder, double-click Set-up.exe, and then follow the on-screen instructions.

d. Accept the user license agreement.  When prompted, enter your serial number or choose the trial option.  Select a language if not selected.

e. If you are installing as an upgrade, the installer will check your system to find the valid upgrade product.  If it cannot find it, it will ask you to input the serial number of the product being upgraded.  You can also install the software in trial, then input your new and previous serial numbers in the serialization screen shown during launch.

Install Flash Builder 4 Plug-in on Windows:

NOTE: Flash Builder 4 is only supported on Eclipse 3.4 or 3.5.

CAUTION: Do not install the plug-in version of Flash Builder 4 into a copy of Eclipse that is already hosting Flex Builder 3 plug-in. If you want to continue running Flex Builder 3 plug-in, download a new copy of Eclipse and use that when installing Flash Builder 4 plug-in, or choose bundled Eclipse option in the installer.  In addition, be sure to use separate Eclipse workspaces for each installation.

a.  Log in as the Windows Administrator or as a computer administrator (a user account with administrator privileges).

Note: If you attempt to install without administrator privileges, the installation will complete with flagged issues. However, you will have installed an incomplete version of Flash Builder that you will not be able to run.

b. Prior to installing, uninstall any prerelease versions of Adobe Flash Builder 4 Eclipse Plug-in.

c. Insert the DVD in your drive, and follow the on-screen instructions. If the installer does not launch automatically, navigate to the Adobe Flash Builder 4 Eclipse Plug-in folder found at the root level on the DVD and double-click InstallFlashBuilder4Plugin.bat to start the installation process. 

If you downloaded the software from the web, the installer will self-extract after the folder to copy the installer is selected and launch automatically.  If the installer does not launch automatically, open the folder, navigate to the Adobe Flash Builder 4 Plugin Installer folder, double-click InstallFlashBuilder4Plugin.bat, and then follow the on-screen instructions.

d. Accept the license agreement and follow the prompts.

e. If you are installing as an upgrade, the installer will check your system to find the valid upgrade product.  If it cannot find it, it will ask you to input the serial number of the product being upgraded.  You can also install the software in trial, then input your new and previous serial numbers in the serialization screen shown during launch.

Install Flash Builder 4 Standalone on Mac:  

a. Log in as the Administrator or as a computer administrator (a user account with administrator privileges).

b. Prior to installing, uninstall any prerelease versions of Flash Builder 4.

c. Insert the DVD in your drive, and follow the on-screen instructions.  If the installer does not launch automatically, navigate to the Adobe Flash Builder 4 Standalone folder found at the root level on the DVD and double-click Install.app to start the installation process. 

If you downloaded the software from the web, open the folder, navigate to the application folder, double-click Install.app, and then follow the on-screen instructions.

d. Accept the license agreement and follow the prompts.

e. If you are installing as an upgrade, the installer will check your system to find the valid upgrade product.  If it cannot find it, it will ask you to input the serial number of the product being upgraded.  You can also install the software in trial, then input your new and previous serial numbers in the serialization screen shown during launch.

Install Flash Builder 4 Plug-in on Mac: 

NOTE: Flash Builder 4 is only supported on Eclipse 3.4 or 3.5.

CAUTION: Do not install the plug-in version of Flash Builder 4 into a copy of Eclipse that is already hosting Flex Builder 3 plug-in. If you want to continue running Flex Builder 3 plug-in, download a new copy of Eclipse and use that when installing Flash Builder 4 plug-in, or choose bundled Eclipse option in the installer.  In addition, be sure to use separate Eclipse workspaces for each installation.

a.  Log in as the Administrator or as a computer administrator (a user account with administrator privileges).

Note: If you attempt to install without administrator privileges, the installation will complete with flagged issues. However, you will have installed an incomplete version of Flash Builder that you will not be able to run.

b. Prior to installing, uninstall any prerelease versions of Adobe Flash Builder 4 Eclipse Plug-in. 

c. Insert the DVD in your drive, and follow the on-screen instructions. If the installer does not launch automatically, navigate to the Adobe Flash Builder 4 Eclipse Plug-in folder found at the root level on the DVD and double-click  FB4_Plugin_Mac_Installer app  to start the installation process. 

If you downloaded the software from the web,  open the folder, navigate to the Adobe Flash Builder 4 Plugin Installer folder, double-click FB4_Plugin_Mac_Installer app, and then follow the on-screen instructions.

d. Accept the license agreement and follow the prompts.

e. If you are installing as an upgrade, the installer will check your system to find the valid upgrade product.  If it cannot find it, it will ask you to input the serial number of the product being upgraded.  You can also install the software in trial, then input your new and previous serial numbers in the serialization screen shown during launch.

NOTE:  You must create a new workspace before beginning. Select File > Switch Workspace from the menu bar and enter a new folder name. If the folder doesn't exist, Eclipse creates it. 

4. For detailed installation instructions for Flex 4 Automation Plug-in, go to www.adobe.com/go/flex_plugin

Note: In order to install additional components or reinstall your software after your original installation, you will need access to the original installer (CD, DVD or the download from the web).  Repair is not an available option. 

Uninstall your software



Before you uninstall, quit all browsers and close all applications currently running on your system—including other Adobe applications, chat applications and Microsoft Office applications. 

  • In Windows XP, open the Windows Control Panel and double-click Add or Remove Programs. Select the product that you want to uninstall, click Change/Remove, and then follow the on-screen instructions. 
  • In Windows Vista and Windows 7, open the Windows Control Panel and double-click Programs and Features. Select the product that you want to uninstall, click Uninstall, and then follow the on-screen instructions. 
  • IMPORTANT: Mac OS has new uninstall functionality. DO NOT drag applications to the trash to uninstall them. To safely uninstall on Mac OS X, double-click on the Uninstall alias located in the Application folder. Select Remove Preferences, then Authenticate as an administrator and follow the on-screen instructions.

Note: If you want to install the product on a different computer, you must first deactivate the software on your computer. To deactivate, choose Help > Deactivate Flash Builder. 

Trial software 

Entering a serial number 

Enter the serial number for the software you purchased in the serialization screen.  The serialization screen will load the first time you launch the application (if using the Adobe Flash Builder 4 Eclipse Plugin, it may take more than one launch for the serialization screen to appear).  

Only applications running as a trial will recognize the new serial number.  If any of the applications have already been serialized with a different serial number, it will continue to use that serial number until you remove the older serial number using the Help > Deactivate Flash Builder.  Then on the next launch of the application, it will recognize the new serial number. 

Volume licensing 

Volume licensing customers cannot purchase from a trial directly. Please contact your reseller or authorized Adobe licensing center to place an order for a volume license.  To find a reseller in your area, go to http://partners.adobe.com/resellerfinder/na/reseller.jsp.  

Electronic licensing

You must accept the license agreement and warranty terms to use this product.  See www.adobe.com/go/eulas for details.  This product may automatically attempt to activate over the Internet. See www.adobe.com/go/activation for details. 

Registration information



Creating an Adobe ID registers your software.  Please register to get up-to-date product information, training, newsletters, and invitations to Adobe events and seminars.  

Known issues

For a list of known issues, go to http://kb2.adobe.com/cps/840/cpsid_84098.html

Fixed issues

For a list of issues fixed in this release, go to http://kb2.adobe.com/cps/841/cpsid_84151.html

Customer care

Customer Service

Adobe Customer Service provides assistance with product information, sales, registration, and other non-technical issues. To find out how to contact Adobe Customer Service, please visit Adobe.com for your region or country and click on Contact.

Support Plan Options and Technical Resources 

If you require technical assistance for your product, including information on complimentary and fee-based support plans and troubleshooting resources, more information is available at http://www.adobe.com/go/support/.  Outside of North America, go to http://www.adobe.com/go/intlsupport/ click on the drop down menu under the question “Need a different country or region?”, choose a different country or region, then click GO.  Alternatively, you can click on Change beside the country name at the top of the screen to select a different country or region.

Free troubleshooting resources include Adobe’s support knowledgebase, Adobe user-to-user forums, Adobe Support Advisor and more.  We are continually making additional tools and information available online in order to provide you with flexible options for resolving issues as fast as possible. 

Other resources

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy